%%ItemTitle%%

Solutions::Schedule for .NET Send comments on this topic.
Introduction

Glossary Item Box

Solutions Schedule for .NET is the leading component software for application developers creating multi-resource scheduling applications to address any business scenario. From logistics and resource scheduling in health care, to retail and government, broadcast program planning, to ERP / CRM software - Solutions Schedule for .NET offers an uncommon set of features and unparalleled value for Windows Forms and Smart Client solutions.

This edition of Solutions Schedule for .NET builds on industry proven successes and further extends developer capabilities to create outstanding software solutions with these new features:

NEW In Solutions Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 8.0)

  • GuideLine In DeadZone event

  • *User (owner) Drawn Custom Areas

  • ImageIntoView property

  • CustomAreasAt method

  • *Schedule Scroll Bars Offset Area properties and event

  • *User (owner) Drawn List Scroll Area

  • dbiScheduleObject Visible Property

  • dbiScheduleObject TimeDistance Property

  • TooTip Duration property

  • ListScrollViewType property

  • BeforeCellTextDisplay event

  • dbiTimeBarItem Visible property

NEW In Solutions Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 7.0)

  • dbiLinkItem LineStyle and DashPattern properties

  • *User (owner) Drawn Link Lines

  • Custom Areas Vertical Offset

  • SetView method

  • Text Watermark

  • *User (owner) Drawn Watermark

  • *User (owner) Drawn Ruler Segments

  • TimeBarDateText event

  • MoveTimeBarStart and MoveTimeBarEnd methods

NEW In Solutions Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 6.0)

  • Resource List inLine Editing and support of Third Party edit Controls

  • In Cell Editing with built-in Edit Box and Combo Box

  • Click and Drag Resource List Items within Parent Nodes

  • User (owner) Drawn Resource List Items

  • *User (owner) Drawn Time Line Ruler and Ruler Title

  • *Drag and drop timebars between side by side Schedule Objects

NEW In Solutions::Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 5.0)

  • ListGuide display

  • Ruler Selection

  • GuideLine Positions

  • EditMode ToolBar

NEW In Solutions::Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 4.0)

  • LineArrow Timebar indicators

  • HitTest methods

  • Advanced Timebar restrictions

  • TimebarMouseEnter and TimebarMouseLeave events

  • Extended ValuePoint event

  • Extended ItemMouseOver event

  • Guide Line widths (both global and unique)

  • *Schedule Notes

  • Guide Line dash pattern

  • *TimeBarsBeforeSchedule and TimeBarsAfterSchedule methods

NEW In Solutions::Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 3.1)

  • Default property settings for dbiScheduleObjects

  • DeadZoneDrop event

  • ControlStyle property

  • Timebar Shadows

  • Write XML overloads; Data, properties or both

  • Snap to divisions

  • Custom Cursors for EditModes

  • *UserDrawnBarAfter event

  • LineHeight method

NEW In Solutions::Schedule for .NET

(dbiSchedule/dbiScheduleE.dll 3.0)

  • Guide Lines

  • New edit mode for Guide Lines

NEW In Solutions::Schedule 2.0 for .NET

  • Copy TimeBar

  • Object Data Tag

  • TimeBar Activity Display

  • TimeBar Linking Styles

  • TimeBar Split Edit

  • *Fixed (non-scrolling) UserDrawn Header and Footer

  • *History Collection

  • *Multi-level undo and redo history collection

  • *Scroll to Date

  • *Selected TimeBar Collection

  • *Undo/Redo Event

  • *UserDrawn Time Bars

  • *UserDrawn Time Lines

Solutions::Schedule 1.0 for .NET

  • TimeBar multi-select

  • Resizable Line Item Heights

  • List with hierarchical tree

  • *Map View

  • TimeBar linking (one to one in Standard version, one to many in Enterprise version)

  • *Multi Schedule view

  • Multi column sorting

  • Line item page break

  • TimeBar locking

  • TimeBar Alarms

  • Dead zones

  • Cell-level formatting

  • Undo/Redo (unlimited in Enterprise Edition)

* Available in Enterprise Version Only

© dbi Technologies Inc. All Rights Reserved.


%%ItemTitle%%

Quick Member Locator

Glossary Item Box

dbiSchedule Members

dbiSchedule Item Members

dbiSchedule Timebar Members

dbiSchedule Schedule Object Members


%%PageItemTitle%% $$Members$$

dbiSchedule Class Members
See Also Properties Methods Events
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule Class

"

The following tables list the members exposed by dbiSchedule.

"

Public Constructors

 | Name | Description
public Constructor | dbiSchedule Constructor | Initializes a new instance of the dbiSchedule class.
Top

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveSchedule | Gets or sets the active schedule in the control.
public Property | AlignmentLineColor | Determines the color used to paint the AlignmentLines when they are shown.
public Property | AlignmentLines | Determines if alignment lines will be drawn as the user interacts with dbiTimeBarItems in the control.
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowHorzMoves | Determines whether time bars can be moved horizontally with the mouse.
public Property | AllowItemDrag | Determines if users will be allowed to re-order items in the list by dragging and dropping them within their current level. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AllowNewBars | Determines whether new time bars can be created in a schedule with the mouse.
public Property | AllowResizeBars | Determines whether new time bars can be resized with the mouse.
public Property | AllowVertMoves | Determines if Timebars can be moved vertically.
public Property | AltColorEven | Determines the background color of an even numbered list item in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AltColorOdd | Determines the background color of an odd numbered list item in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AlternateColor | Determines whether or not the list items will be drawn with alternating background colors. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AlternateItems | Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | ArrowAlign | Determines on what side of a column header the sort arrows will be placed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ArrowOffset | Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AutoDuplicate | Determines whether a duplicate time bar will be created when the <Shift> key is pressed, and a time bar is clicked and dragged.
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Determines the background color of the list items section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BackgroundImage | Determines the background image for the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BarSelectBackColor | Gets or sets the background color of the selected Timebar.
public Property | BarSelectBackColorTo | Gets or sets the background color to of the selected Timebar.
public Property | BarSelectBorderColor | Gets or sets the border color of the selected Timebar.
public Property | BarSelectFillType | Gets or sets the background fill pattern of the selected Timebar based on the enumFillType.
public Property | BarSelectForeColor | Gets or sets the forecolor of the selected Timebar.
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BodyColumnEnd | Determines the final column for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyColumnStart | Determines the starting column for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyFont | Determines the font used to draw the body text of a item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyForeColor | Determines the color used to paint the body text of an item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyIndent | Determines the indent of the left margin spacing for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BorderColor | Gets or sets the border color around the control.
public Property | BorderType | Gets or sets the type of border to place around the control.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | BreakChar | Gets or sets the character used to seperate the item text into columns. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClosedSchedules | Determines if dbiTimeBarItems will be restricted to a single dbiScheduleObject inside the control's display.
public Property | Columns | Gets or sets the columns assigned to dbiSchedule. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ComboBox | Returns the dbiComboBox that will be used for editing cells in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | ControlStyle | Set the appearance of the control to a particular style. By setting this property, the control will set font and color properties consistent with the enumControlStyle Enumeration. Once these properties are set they can be modified to further refine the style or you can skip setting this property and manually set colors and fonts to achieve the style you are looking for. Once this property has been set, it will then revert to default. Setting this property to default has no effect on the control.
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Culture | Gets or sets the culture information specifically for dbiSchedule. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CurrentTimeColor | Gets or sets the primary color for the current time line.
public Property | CurrentTimeColorTo | Gets or sets the secondary color for the current time line.
public Property | CurrentTimeLine | Determines if a time line will be drawn for the current date and time.
public Property | CurrentTimeOffset | Determines the offset used for displaying the CurrentTimeLine.
public Property | CurrentTimePosition | Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | CustomAreas | Gets the custom areas assigned to dbiSchedule.
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Defines how DateTime values are formatted and displayed, depending on the culture. (Inherited from Dbi.WinControl.DbiListControl)
public Property | DayMonthOffset | Determines the offset used to calculate the starting day of the week in a monthly ruler.
public Property | DayNames | Gets or sets the day names in dbiSchedule.
public Property | DefaultStyle | Gets or sets the default Timebar style.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayGuideLines | Determines if the GuideLines are shown in the dbiSchedule.
public Property | DisplayHeader | Determines whether or not the column headers will be displayed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | DisplayListGuide | Determines whether a list guide will appear in the schedule.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTitle | Determines whether or not the title will be displayed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | DivisionDistance | Determines how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | DragLineColor | Gets or sets the border color of the splitter bar when the mouse clicks it.
public Property | DragTimerInterval | Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.
public Property | EditAutoNavigate | Determines if the control will automatically navigate to the next/previous cell when editing. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditAutoSize | Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditColumn | Returns the dbiColumnItem that contains the cell being edited. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditMode | Gets or sets the type of action which can be performed on a Timebar.
public Property | EditNode | Returns the dbiNodeItem that contains the cell to be edited (Inherited from Dbi.WinControl.DbiListControl)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | ErasorCursor | Allows a custom image to be used in place of the default erase cursor.
public Property | ErasorHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | FillList | Determines whether the last column in a list will always extend to the edge of the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | FocusBorder | Determines if a focus line will be drawn around the selected item in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | FocusColor | Determines the color used to paint the FocusBorder (Inherited from Dbi.WinControl.DbiListControl)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | FooterLine | Determines if the user drawn footer line is displayed on the bottom of the List in the dbiSchedule.
public Property | FooterLineHeight | Gets or sets the height of a user drawn footer line in the List of dbiSchedule.
public Property | ForeColor | Determines the foreground color of the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | GridFrequency | Gets or sets the distance (in pixels) where a Timebar can be moved or sized to with SnapToGrid enabled.
public Property | GuideDashPattern | An array of real numbers that specifies the lengths of alternating dashes and spaces representing the lines of each GuideLine.
public Property | GuideImageIndex | Determines the default images used when adding GuideLines to the dbiScheduleObject.GuideLines collection.
public Property | GuideImagePosition | Determines whether GuideLine images will be in the front or back of the ruler numbers and markers.
public Property | GuideImages | Attaches an ImageList control to the dbiSchedule for use with the GuideLines.
public Property | GuideImageXOffset | Determines the horizontal offset used to calculate the position of the guide line image. This property only applies to the GuideImgeIndex property.
public Property | GuideImageYOffset | Determines the vertical offset used to calculate the position of the guide line image. This property only applies to the GuideImageIndex property.
public Property | GuideLineColor | Determines the default color of the GuideLines.
public Property | GuideLineDistance | Determines how close the edge of a time bar must be to a GuideLine before the time bar is snapped to the GuideLine location (in pixels). The maximum value is 10 pixels.
public Property | GuideLinePosition | Determines the ZOrder for Guide Lines, relative to the Timebars in the control.
public Property | GuideLineWidth | Determines the default width of all guide lines.
public Property | GuideSelectColor | Determines the default color of a selected guide line.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderAlign | Determines how the text in the column headers will be aligned. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColor | Determines the background color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColorMiddle | Determines the middle back color of the column header allowing for greater readability with certain fill types. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColorTo | Determines the secondary background color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBorder | Determines the border type for the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderColor | Determines the default line color for a header defined schedule line.
public Property | HeaderDownColor | Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderFillType | Determines the pattern used to paint the background of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderFont | Determines the font used for the text in the column headers of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderForeColor | Determines the foreground color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderHeight | Determines the height of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderImageOffset | Determines the value used to calculate the horizontal and vertical position of the images within the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderLine | Determines if the user drawn header line is displayed on the top of the List in the dbiSchedule.
public Property | HeaderLineHeight | Gets or sets the height of a user drawn header line in the List of dbiSchedule.
public Property | HeaderOverColor | Determines the color used to paint background when the mouse pointer is over the column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderStyle | Determines the style of the column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderTextImageRelation | Determines how the column header position of text and image relate to each other. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HistorySize | Gets or sets the maximum number of items stored in the Undo/Redo history collection.
public Property | HorzGridColor | Determines the color of the horizontal grid lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzGridLines | Determines whether or not horizontal grid lines will be drawn between the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzGridWidth | Determines the width of the horizontal grid lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzListLargeChange | Determines the large change when scrolling the list area's Horizontal scroll bar.
public Property | HorzListSmallChange | Determines the small change when scrolling the list area's Horizontal scroll bar.
public Property | HorzScheduleLargeChange | Determines the large change when scrolling the schedule area's Horizontal scroll bar.
public Property | HorzScheduleScrollOffset | Determines the offset used to calculate the width of the horizontal scroll bar in the schedule area.
public Property | HorzScheduleSmallChange | Determines the small change when scrolling the schedule area's Horizontal scroll bar.
public Property | HorzScrollType | Determines the horizontal scrolling action for the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckDisabled | Determines the image used to replace the stock check disabled state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckDown | Determines the image used to replace the stock check down state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckUp | Determines the image used to replace the stock check up state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageIntoView | Determines if images applied to timebars as Start and End images will be forced into the display when the respective edge of the timebar is partially outside the view.
public Property | ImageList | The image list for the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageMinus | Determines the image used to replace the stock collapse parent item image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImagePlus | Determines the image used to replace the stock expand parent item image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageType | Gets or sets the type of image to create with the CreateImage method.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InactiveBackColor | Determines the color used to paint the background of a selected item when the control no longer has focus. (Inherited from Dbi.WinControl.DbiListControl)
public Property | InactiveForeColor | Determines the color used to paint the text of a selected item when the control no longer has focus. (Inherited from Dbi.WinControl.DbiListControl)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemBorder | Determines the border type for the items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemDragColor | Determines the color of the drag bar when an item is dragged inside the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemDragHeight | Determines the height of the drag bar when an item is dragged inside the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeaderBackColor | Determines the default background color for all Header items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeaderForeColor | Determines the default foreground color for all Header items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeightOffset | Overridden. Gets or sets the vertical offset value used to calculate the height of the items in the list.
public Property | Items | Gets the list items in dbiSchedule.
public Property | LabelEdit | Determines if a cell will be put in to edit mode automatically, if the user double clicks it. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineArrowAfter | Determines the image used to indicate more timebars are after the visible area of the schedule.
public Property | LineArrowBefore | Determines the image used to indicate more timebars are before the visible area of the schedule.
public Property | LineArrowColor | Determines the color used to paint the arrows used to indicate additional timebars before or after the visible area of a schedule.
public Property | LineArrowDisplay | Determines the condition of how a line arrow will be displayed.
public Property | LineArrowPosition | Determines where the line arrows will be drawn in the schedules, in relation to other objects.
public Property | LineColor | Determines the color of list/tree connector lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LineType | Determines the list/tree connector line type. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LinkCursor | Allows a custom image to be used in place of the default link cursor.
public Property | LinkHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | LinkLineColor | Gets or sets the default color of the link lines in dbiSchedule.
public Property | Links | Gets the links in dbiSchedule.
public Property | ListBackColor | Gets or sets the background color of the list area in the schedule.
public Property | ListFont | Gets or sets the default font for the list area in the schedule.
public Property | ListForeColor | Gets or sets the
public Property | ListGuideColumn | Determines the zero-based index of the column that will be used as part of the ListGuide display.
public Property | ListGuideDistance | Determines how far, in pixels, the cusro needs to be from the ListArea before the ListGuide will display.
public Property | ListGuideInterval | Determines the interval (milliseconds) used to cause a fade in effect for the ListGuide.
public Property | ListGuideOpacity | Determines the opacity of the ListGuide.
public Property | ListGuideWidth | Determines the width of the ListGuide.
public Property | ListGuideXPosn | Determines the horizontal coordinate where the ListGuide will be painted.
public Property | ListScrollBackColor | Determines the color used to paint the background of the horizontal scroll bar area.
public Property | ListScrollMaximum | Returns the current maximum value of the horizontal scroll bar in the ListArea
public Property | ListScrollValue | Gets or sets the horizontal scroll value of the List in dbiSchedule.
public Property | ListScrollViewType | Determines the display behavior of the horizontal scroll bar in the ListArea.
public Property | ListType | Determines how the list items will be drawn in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ListWidth | Gets or sets the width of the list area.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LockLineHeight | Overridden. Determines if the height of the items can be resized.
public Property | LockSplitterBar | Determines if the splitter bar can be moved.
public Property | MapBorder | Gets or sets the type of border to place around the map area.
public Property | MapHeight | Gets or sets the height of the map area in the schedule.
public Property | MapLineColor | Gets or sets the color to place around the current view in the map area of the schedule.
public Property | MapVisible | Determines if the map area will be visible in the schedule.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaskColor | Gets or sets the mask color for the images in the schedule.
public Property | MaxImageHeight | Gets or sets the maximum height of a user created image of dbiSchedule.
public Property | MaxImageWidth | Gets or sets the maximum width of a user created image of dbiSchedule.
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinBarTime | Gets or sets the minimum time for a Timebar when it is resized.
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MonthNames | Gets or sets the names of the months in dbiSchedule.
public Property | MultiSelect | Determines if the list area will allow a multi-select mode (using ctrl/click and shift/click). (Inherited from Dbi.WinControl.DbiListControl)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | NoteImages | The image list for the schedule notes.
public Property | NotesDistance | Determines the distance separating locked notes on a line.
public Property | NotesPosition | Determines where the schedule notes will be drawn in the schedules, in relation to the other objects.
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PencilCursor | Allows a custom image to be used in place of the default pencil (create timebar) cursor.
public Property | PencilHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | PercentColor | Determines the default color of all Percent complete bars rendered inside dbiTimeBarItems
public Property | PlusMinusStyle | Determines the style used when rendering the Plus/Minus boxes on parent nodes. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBackColor | Determines the background color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBackColorTo | Determines the secondary background color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBorder | Determines the type of border to place around the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnFillType | Determines the pattern used to paint the background of the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnFont | Determines the font used for the text in the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnForeColor | Determines the foreground color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnPicture | Determines the picture clip within the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnType | Determines the pre-column to be used on the list part of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnWidth | Determines the width of the pre-column in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | PreSelectBackColor | Determines the background color of the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreSelectBorder | Determines the type of border to place around the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreSelectForeColor | Determines the type of border to place around the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintBackImage | Determines if the back image will be visible in a printed report.
public Property | PrintFitToPage | Determines if the PrintTimeDistance property will be adjusted so the entire control can be printed on a single page.
public Property | PrintFont | Gets or sets the font of a printed report.
public Property | PrintFooterAlign | Gets or sets the vertical and horizontal position of the footer in a printed report.
public Property | PrintHeaderBackColor | Determines the background color of the column headers in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintHeaderForeColor | Determines the foreground color of the column headers in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintItemBackColor | Determines the background color of the items in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintItemForeColor | Determines the foreground color of the items in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintListAlways | Determines whether the list will be printed on every page of a report.
public Property | PrintListFormat | Gets or sets the type of list to display in a printed report.
public Property | PrintPageControl | Determines if the control should print using the current colors rendered in the control (True) or if the specified "Print" related colors should be used (False). (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintPageText | Gets or sets the text descibing the page number on the report footer.
public Property | PrintReportType | Determines how dbiSchedule is printed.
public Property | PrintSubTitle | Gets or sets the sub-title of a printed report.
public Property | PrintTimeDistance | Gets or sets the distance between the major time segments in a printed report.
public Property | PrintTitle | Gets or sets the title of a printed report.
public Property | PrintTitleAlign | Gets or sets the vertical and horizontal alignment of the title in a printed report.
public Property | PrintTitleBackColor | Determines the background color of the list area title in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintTitleForeColor | Determines the foreground color of the list area title in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | RedoHistory | Gets the redo actions which can be performed on the Timebars in the schedule.
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RulerAlign | Determines the default alignment for the text within the ruler.
public Property | RulerBackColor | Determines the default background color of the ruler.
public Property | RulerBackColorTo | Determines the default secondary background color of the ruler.
public Property | RulerBorder | Determines the default border type for the ruler area.
public Property | RulerFillType | Determines the default fill effect used to paint the background of the ruler.
public Property | RulerFont | Determines the default font used for rendering the time units in the ruler of the schedule.
public Property | RulerForeColor | Determines the default foreground color of the ruler.
public Property | RulerLineColor | Determines the default line color of the ruler.
public Property | RulerSelectColor | Determines the background color used to highlight the current start/end, of the selected TimeBar, in the ruler.
public Property | RulerSelectOffset | Determines the vertical offset for displaying the selected TimeBar in the ruler.
public Property | RulerTitleBackColor | Determines the default primary background color of the title area of the ruler in a schedule.
public Property | RulerTitleBackColorTo | Determines the default secondary background color of the title area of the ruler in a schedule.
public Property | RulerTitleFillType | Determines the default background fill pattern of the title area of the ruler in a schedule.
public Property | RulerTitleFont | Determines the default font used for the title area of the ruler in a schedule.
public Property | RulerTitleForeColor | Determines the default foreground color of the title area of the ruler in a schedule.
public Property | SchedAltColorEven | Determines one of the default alternating line colors for a schedule line.
public Property | SchedAltColorOdd | Determines one of the default alternating line colors for a schedule line.
public Property | SchedScrollValue | Gets or sets the horizontal scroll value of the Schedule(s) area in dbiSchedule.
public Property | ScheduleBackColor | Determines the default background color of a schedule.
public Property | ScheduleLineColor | Determines the default line color of the schedules.
public Property | Schedules | Gets the Schedules in dbiSchedule.
public Property | ScrollHorzBuffer | Gets or sets the size of a buffer area in the dbiSchedule horizontal schedule scroll bar where another control can be placed.
public Property | SelectedBackColor | Determines the background color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBackColorTo | Determines the second background color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBorder | Determines the type of border to place around the selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBorderColor | Determines the border color of a selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedFillType | Determines the pattern used to paint the background of the selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedFont | Determines the font used to draw the text of a selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedForeColor | Determines the foreground color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedStyle | Determines how the selection will be applied to the selected node(s). (Inherited from Dbi.WinControl.DbiListControl)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SnapToDivisions | Determines if a time bar will snap to the Minor Time divisions (created with RulerDivisions Property)when they are moved/added/resized using the mouse. Snap to Divisions will not affect programmatically added time bars.
public Property | SnapToGrid | Determines if the Timebars will automatically align to the control.
public Property | SnapToGuideLines | Determines if a time bar will snap to the GuideLines when they are moved/added/resized using the mouse. Snap to GuideLine will not affect programmatically added time bars.
public Property | SortArrows | Determines whether arrows indicating the direction of the sort order will be displayed in the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SortColumn | Determines the zero-based index of the column whose data a sort will be performed on. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SortDirection | Determines the direction a sort operation will perform. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Sorted | Determines whether the list is currently considered sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SplitCursor | Allows a custom image to be used in place of the default split timebar cursor.
public Property | SplitHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | SplitterBarBorder | Gets or sets the dbi.enumBorderType for the splitter bar in the dbiSchedule.
public Property | SplitterBarColor | Gets or sets the color of the splitter bar.
public Property | SplitterBarWidth | Gets or sets the width of the splitter bar.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TextAntiAlias | Determines if the text within the control will be rendered using the Anti Alias option. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TextBox | Returns the dbiTextBox that will be used for editing cells in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TextIntoView | Determines if the text of a Timebar will always be in view.
public Property | TimeBarBackColor | Gets or sets the default background color of a Timebar.
public Property | TimeBarBackColorTo | Gets or sets the default background color to of a Timebar.
public Property | TimeBarBorderColor | Gets or sets the default border color of a Timebar
public Property | TimeBarBorderType | Gets or sets the default border type of a Timebar.
public Property | TimeBarDialog | Determines if the Timebar dialog will appear when a Timebar is double clicked on.
public Property | TimeBarExtension | Gets or sets the distance from the Timebar border at which the resizing handle (mouse cursor) appears.
public Property | TimeBarFillType | Gets or sets the default background fill pattern of a Timebar based on the enumFillType.
public Property | TimeBarFont | Gets or sets the default font of the Timebars.
public Property | TimeBarForeColor | Gets or sets the default forecolor of a Timebar.
public Property | TimeBarMargin | Gets or sets the margin size on each side of a Timebar when being resized with the mouse.
public Property | TimeBarMinWidth | Gets or sets the minimum width of a Timebar.
public Property | TimeBarShadows | Determines wether the timebars should be drawn with an opaque shadow. This will give the schedule some depth.
public Property | TimeBarStyles | Gets the Timebar styles assigned to dbiSchedule.
public Property | TimeBarWordWrap | Determines if the Timebar text will automatically wrap.
public Property | TimeDistance | Gets or sets the distance between major time units.
public Property | TimeLineColor | Determines the default line color of the schedule time lines.
public Property | TimerInterval | Determines how often to check for Timebar alarms.
public Property | TipsBackColor | Gets or sets the background color of the tool tip.
public Property | TipsBackColorTo | Gets or sets the background color to of the tool tip.
public Property | TipsBorderColor | Gets or sets the border color to of the tool tip.
public Property | TipsBorderType | Gets or sets the type of border for the tool tip.
public Property | TipsDuration | Gets or sets how long (in milliseconds) the tool tip remains visible when the mouse is static.
public Property | TipsFillType | Gets or sets fill type for the background colors of a tool tip.
public Property | TipsFont | Gets or sets the font of the tool tips.
public Property | TipsForeColor | Gets or sets the forecolor of the tool tips.
public Property | TipsOnChangeBar | Determines if the tool tips will be displayed when a Timebar is being moved or sized.
public Property | TipsOnCreateBar | Determines if the tool tips will be displayed when a bar is being created.
public Property | TipsOnNotes | Determines whether a tool tip will be displayed when the mouse is over a note.
public Property | TipsOnOverBar | Determines if the tool tips will be displayed when the mouse moves over a Timebar.
public Property | TipsOnVScroll | Determines if the tool tips will be displayed when the vertical scroll is being clicked on.
public Property | TitleAlign | Determines the alignment for the text within the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColor | Determines the background color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColorMiddle | Determines the middle back color of the list area title section allowing for greater readability with certain fill types. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColorTo | Determines the secondary background color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBorder | Determines the border type for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleFillType | Determines the pattern used to paint the background of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleFont | Determines the font used for the text in the list area title of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleForeColor | Determines the foreground color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleHeight | Determines the height of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleImage | Determines the image for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleImageAlign | Determines the image alignment for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleText | Determines the text of the list area title. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleTextOffset | Determines the values used to calculate the horizontal and vertical position of the text within the list area title. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ToolbarBackColor | Determines the backcolor used when displaying the built in EditMode ToolBar.
public Property | ToolbarOnRightClick | Determines if the built in EditMode ToolBar will display when the user right-clicks the control.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TreeLevelIndent | Determines the indent used to offset the text of each level of child items in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | UndoHistory | Gets the undo actions which can be performed on the Timebars in the schedule.
public Property | UnlinkCursor | Allows a custom image to be used in place of the default unlink cursor.
public Property | UnlinkHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VertGridColor | Determines the color of the vertical grid lines in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | VertGridLines | Determines whether or not to draw vertical grid lines between the columns in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | VertScrollLargeChange | Determines the large change when scrolling the Vertical scroll bar.
public Property | VertScrollOffset | Determines the offset used to calculate the height of the vertical scroll bar.
public Property | VertScrollSmallChange | Determines the small change when scrolling the Vertical scroll bar.
public Property | VertScrollValue | Gets or sets the vertical scroll value of the List/Schedule(s) areas in dbiSchedule.
public Property | VertThumbTrack | Determines whether the list will scroll as the vertical mouse thumb is tracked.
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | WatermarkAlign | Determines the vertical and horizontal alignment of the WaterMarkText in the schedule area.
public Property | WatermarkFont | Determines the Font used when drawing the WaterMarkText in the schedule area.
public Property | WatermarkForeColor | Determines the color used to paint the WaterMarkText in the schedule area.
public Property | WatermarkOffset | Determines the vertical and horizontal offset used when painting the WaterMarkText in the schedule area.
public Property | WatermarkText | Determines the text displayed as a WaterMark in the the schedule area.
public Property | WeekendDays | Gets or sets the days of the week considered to be the weekend.
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | XMLRead | Gets or sets an XML file to read the data to dbiSchedule.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to dbiSchedule.
public Property | XMLWrite | Gets or sets an XML file to write the data from dbiSchedule.
Top

Public Methods

 | Name | Description
public Method | AddHistoryItem | Overloaded. Adds a dbiHistoryItem to the history collection.
public Method | AutoSetNodeHeight | Automatically sets the HeightOffset for the dbiScheduleItem passed as a parameter.
public Method | BarToBack | Moves a specified Timebar behind any conflicting Timebars.
public Method | BarToFront | Moves a specified Timebar in front of any conflicting Timebars.
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ColumnAt | Overloaded. Gets the dbiColumnItem at a specified location (Inherited from Dbi.WinControl.DbiListControl)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateImage | Creates an image of dbiSchedule.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CustomAreasAt | Overloaded. This function will receive a cursor location, and return a dbiCustomAreaCollection Class
public Method | DateTimeAt | Overloaded. Gets the DateTime value at a specific location.
public Method | DisplayToolbar | Overloaded. Displays a Toolbar with the available EditModes for the control, at a specified location.
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EditCell | Overloaded. Places the desired cell into edit mode.
public Method | EditNextCell | Places the next logical cell in to edit
public Method | EditPrevCell | Places the previous logical cell in to edit
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EnsureVisible | Method to move the visible portion of the control to ensure that the item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate. (Inherited from Dbi.WinControl.DbiListControl)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetExpandedItemCount | Gets or sets the number of visible child nodes of a given dbiNodeItem.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetNodeLevel | Returns the zero-based level within the nested structure of a specified node. (Inherited from Dbi.WinControl.DbiListControl)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InDeadZone | Overloaded. Determines if a dbiTimeBarItem, dbiAppointmentItem, dbiGuideLine or a TimeSpan is in a dead zone.
public Method | IndexesFromTimeBar | Gets the dbiScheduleItem index value and the dbiTimebarItem index value of a given Timebar.
public Method | IndexFromNode | Gets the index value of a node.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | InvalidateControl | Overloaded. The dbiSchedule control will redraw itself.
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | IsMilestone | Determines if a Timebar item is a milestone.
public Method | ItemAt | Overloaded. This function will receive a cursor location, and return the dbiScheduleItem located at that position.
public Method | LineHeight | Overloaded. Gets the physical height of a dbiScheduleItem in pixels.
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | MoveTimeBarEnd | Move the end of a time bar while keeping the original time span of the time bar.
public Method | MoveTimeBarStart | Move the start of a time bar while keeping the original time span of the time bar.
public Method | NodeFromIndex | Returns a dbiScheduleItem given the index value.
public Method | NodeFromTimeBar | Gets the dbiScheduleItem associated with a specified dbiTimebarItem.
public Method | NodeToScheduleItem | Converts a dbiNodeItem to a dbiScheduleItem.
public Method | PaintBackground | Overloaded. Paints individual backgrounds on a specific graphics handle.
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | Print | Overloaded. Prints the dbiSchedule.
public Method | PrintPreview | Overloaded. Creates a preview of a printed report.
public Method | ReadXMLFile | Reads the data from an XML file into dbiSchedule.
public Method | Redo | Performs a redo operation on dbiSchedule.
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RestoreCell | Reset internal items required for the edit mode. (Inherited from Dbi.WinControl.DbiListControl)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | RulerHeight | Returns the internally calculated height of the ruler area based on the current control setup.
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScheduleAt | Overloaded. This function will receive a cursor location, and return the dbiScheduleObject located at that position.
public Method | ScheduleDocument | Returns a dbiPrintSchedule document object.
public Method | ScheduleItemAt | Overloaded. Returns the area of the dbiSchedule Control at the mouse point provided.
public Method | ScrollToCell | Overloaded. Attempt to scroll a desired cell in to the visible portion of the list area.
public Method | ScrollToColumn | Overloaded. Attempt to scroll a desired column in to the visible portion of the list area
public Method | ScrollToDateTime | Overloaded. Scrolls the dbiSchedule control to the specified date/time value.
public Method | ScrollToNode | Attempts to make a specified dbiScheduleItem visible in the list display. (Inherited from Dbi.WinControl.DbiListControl)
public Method | SelectedTimeBars | Gets a collection representing the currently selected Timebars in dbiSchedule.
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetView | Overloaded. Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | Sort | Overloaded. Sort the data of the list portion of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | TimeBarConflicts | Overloaded. Gets a collection of time bars that conflict with a specified time bar.
public Method | TimeBarsAfterSchedule | This function returns a collection of timebars that exist after the visible area of a schedule.
public Method | TimeBarsAt | Overloaded. This function will receive a cursor location, and return a TimeBarItemCollection.
public Method | TimeBarsBeforeSchedule | This function returns a collection of timebars that exist before the visible area of a schedule.
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Undo | Performs an undo operation on dbiSchedule.
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | WriteXMLData | Writes only the data elements of the dbiSchedule.
public Method | WriteXMLFile | Overloaded. Writes the data in dbiSchedule to an XML file.
Top

Public Events

 | Name | Description
public Event | AfterCellEdit | Event fired after the editing of a cell has completed. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterColumnSort | Occurs after a column has been sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterGuideLineInserted | Event fired after a new GuideLine is inserted with the mouse.
public Event | AfterGuideLineMoved | Event fired after a GuideLine is moved with the mouse.
public Event | AfterGuideLineRemoved | Event fired after a GuideLine is removed with the mouse.
public Event | AfterNodeCollapse | Event fired after a parent node has collapsed (hiding its child nodes). (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeExchange | Event fired after a node has been internally dragged/dropped was moved. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeExpand | Event fired after a parent node has expanded (showing its child nodes). (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeSelect | Event fired after a node has been selected. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterTimeBarDrop | Occurs after a Timebar has been dropped onto the schedule.
public Event | AfterTimeBarInserted | Occurs after a Timebar is inserted.
public Event | AfterTimeBarLinked | Occurs after 2 Timebars have been linked together.
public Event | AfterTimeBarMoved | Occurs after a Timebar has been moved.
public Event | AfterTimeBarRemoved | Occurs after a Timebar is removed.
public Event | AfterTimeBarSelect | Occurs after a TimeBar is selected.
public Event | AfterTimeBarSized | Occurs after a Timebar has been sized.
public Event | AfterTimeBarSplit | Occurs after a Timebar has been split while the edit mode is in split mode.
public Event | AfterTimeBarUnlinked | Occurs after the link between two Timebars has been removed.
public Event | AfterTimeBarUnSelect | Occurs after a TimeBar has been unselected.
public Event | AlarmTimeBarEnd | Occurs when an alarm has fired at the end of a Timebar.
public Event | AlarmTimeBarStart | Occurs when an alarm is fired at the beginning of a Timebar.
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BeforeCellEdit | Event fired before a cell is placed in to an editable state. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeCellTextDisplay | Event fires before the text is drawn in each cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeColumnSort | Occurs before a column is sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeGuideLineInsert | Event fired before a new GuideLine is inserted with the mouse.
public Event | BeforeGuideLineMove | Event fired before a GuideLine is moved with the mouse.
public Event | BeforeGuideLineRemove | Event fired before a GuideLine is removed with the mouse.
public Event | BeforeNodeCollapse | Event fired before a parent node is collapsed (child nodes will be hidden). (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeExchange | Event fired before a node that has been internally dragged/dropped is moved. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeExpand | Event fired before a parent node is expanded (child nodes will be made visible). (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeSelect | Event fired before a node is selected in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforePaint | Event fired before the control has painted the list. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforePrintPageNumber | Occurs before each page number is prepared for the printed report.
public Event | BeforeTimeBarDrop | Occurs before a Timebar is dropped onto the schedule.
public Event | BeforeTimeBarInsert | Occurs before a Timebar is inserted.
public Event | BeforeTimeBarLink | Occurs before 2 times bars are linked together.
public Event | BeforeTimeBarMove | Occurs before a Timebar is moved.
public Event | BeforeTimeBarRemove | Occurs before a Timebar is removed.
public Event | BeforeTimeBarSelect | Occurs before a Timebar is selected.
public Event | BeforeTimeBarSize | Occurs before a Timebar is sized.
public Event | BeforeTimeBarSplit | Occurs before a Timebar has been split while the edit mode is in split mode.
public Event | BeforeTimeBarUnlink | Occurs before the link between two Timebars has been removed.
public Event | BeforeTimeBarUnSelect | Occurs before a TimeBar is unselected.
public Event | BeforeToolTips | Occurs before a tool tip is displayed.
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | Change | Event fired when a list item is selected. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | CheckClick | Event fired when a check box in the list is clicked. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlError | Occurs when an error takes place in the control.
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DeadZoneDrop | Event fired when a time bar is moved onto a dead zone area with the mouse.
public Event | DisplayUserControl | Event fired before a cell is placed in to edit mode, allowing the developer to prepare and display their own control for the editing process. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DropList | Occurs when an item is dropped into the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditInputKey | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyDown | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyPress | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyUp | Event fired when a key is released inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditModeChanged | Event fired when the EditMode is changed on the control.
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FirstDraw | Occurs after dbiSchedule has been drawn for the first time.
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | GuideLineClick | Event fired when a GuideLine is clicked.
public Event | GuideLineInDeadZone | Fires when a dbiGuideLine is detected to intersect with a custom area marked as a dead zone.
public Event | GuideLineMove | Event fired when a GuideLine is moved.
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HeaderClick | Event fired when the left mouse button clicks on a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Event | HeaderDoubleClick | Event fired when the left mouse button double clicks on a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | HistoryChange | Occurs when an item in the RedoHistory or UndoHistory collections change.
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InitializeCellEdit | Event fired before the cell edit operation is started (Inherited from Dbi.WinControl.DbiListControl)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | ItemLineHeightChanged | Event fired when the item height is changed. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ItemMouseOver | Occurs when the mouse moves over a new schedule item.
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LineArrowClick | Event fired when a line arrow is clicked.
public Event | LineArrowDoubleClick | Event fired when a line arrow is double clicked.
public Event | LineArrowMouseOver | Event fired when the mouse moves over a line arrow.
public Event | ListClick | Occurs when a schedule item is clicked.
public Event | ListDoubleClick | Occurs when a schedule item is double clicked.
public Event | ListDrop | Occurs when an item is dropped into the list area.
public Event | ListMouseOver | Event fired when the mouse moves over a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ListWidthChanged | Occurs when the list width has changed.
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheelCheck | Occurs when the wheel on the users mouse is scrolled.
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | NodeClick | Occurs when a schedule item is clicked on. (Inherited from Dbi.WinControl.DbiListControl)
public Event | NodeDoubleClick | Occurs when a schedule item is double clicked. (Inherited from Dbi.WinControl.DbiListControl)
public Event | NoteClick | Event fired when a schedule note is clicked.
public Event | NoteDoubleClick | Event fired when a schedule note is double clicked.
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RedoAction | Occurs after a redo action has taken place.
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | RemoveUserControls | Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RulerDrag | Occurs when the user mouses down in the ruler area, and drags.
public Event | ScheduleClick | Occurs when the user clicks in the schedule area
public Event | ScheduleScrollBarsOffsetArea | Occurs before the control renders either the horizontal or vertical scroll bar in the display.
public Event | ScrollBufferResize | Event fired when the Scroll Buffer is resized to allow for the repositioning of any controls in the buffer zone.
public Event | ScrollTrack | Occurs when a scroll bar within the control is moved either manually or programmatically.
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TimeBarClick | Occurs when a Timebar is clicked on.
public Event | TimeBarDateText | Occurs just before the text is written at each end of a timebar in the display, when a dbiScheduleObject's DisplayTimeBarDates property is true.
public Event | TimeBarDoubleClick | Occurs when a Timebar is double clicked on.
public Event | TimeBarMouseEnter | Occurs when the mouse moves into a time bar.
public Event | TimeBarMouseLeave | Occurs when the mouse moves out of a time bar.
public Event | TimeBarMoving | Occurs while a TimeBar is moving in the schedule area.
public Event | TimeBarSizing | Occurs as the size of the Timebar is being changed by the mouse.
public Event | UndoAction | Occurs after an undo action has taken place.
public Event | UserDrawnBar | Occurs at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.
public Event | UserDrawnBarAfter | This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.
public Event | UserDrawnCell | Event fired before a cell is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnColumnHeader | Event fired before a column header is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnCustomArea | Occurs at the point a custom area is drawn to provide custom painting of the display of the custom area.
public Event | UserDrawnFooter | A static item painted through the list and schedule area at the bottom of the control above the horizontal scroll bars.
public Event | UserDrawnHeader | A static item painted through the list and schedule area at the top of the control below the list title and ruler (time line).
public Event | UserDrawnLine | Rendered in the dbiSchedule Items collection(s) to provide custom painting of the rectangle inside the schedule area of the control.
public Event | UserDrawnLinkLine | Occurs before a Link is drawn in the control.
public Event | UserDrawnListScrollArea | Allows for custom painting of the background of the area containing the horizontal scroll bar of the list.
public Event | UserDrawnNode | Event fired before a node is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnRuler | Occurs before the ruler is painted in each schedule; once when the background is painted and then a second time after the rest of the ruler is painted.
public Event | UserDrawnRulerSegment | Occurs just before a segment is drawn in the middle row of the ruler in a dbiScheduleObject. The DisplayUserDrawnRulerSegments property of the dbiScheduleObject must be set to True.
public Event | UserDrawnRulerTitle | Occurs before the title text is written in the ruler of each schedule.
public Event | UserDrawnTimeBars | Occurs after all other drawing has completed for each dbiScheduleObject in the visible schedule area.
public Event | UserDrawnTitle | Event fired before the title area is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnWaterMark | Occurs after the control has finished painting all the objects in the schedule area.
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | ValuePoint | Occurs before each time value is drawn in the ruler.
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiSchedule Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleItem Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleItem Class

"

The following tables list the members exposed by dbiScheduleItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleItem Constructor | Overloaded. Initializes a new instance of the dbiScheduleItem class.
Top

Public Properties

 | Name | Description
public Property | Appointments | Gets the Timebars assigned to a schedule item.
public Property | BackColor | Gets or sets the background color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | BackColorTo | Gets or sets the secondary background color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Body | Gets or sets the body text for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | BodyVisible | Determines if the body text is visible for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Cargo | Gets or sets a non-visible text value for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | CellFormat | Gets the cell formats assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Control | Gets or sets the name of the object containing the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | CustomAreas | Gets the custom areas assigned to the schedule item.
public Property | Data | Gets or sets a non-visible integer value for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | FillType | Gets or sets the background fill pattern of the item based on the enumFillType Enumeration. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Font | Gets or sets the font of the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ForeColor | Gets or sets the foreground color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | FullPath | Gets the full text path of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Header | Determines if the schedule item will act as a header. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderBackColor | Determines the background color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderBackColorTo | Determines the secondary background color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderFillType | Determines the background pattern of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderForeColor | Determines the foreground color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeightOffset | Gets or sets the vertical offset value used to calculate the height of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HorzGridColor | Gets or sets the color of horizontal grid line below the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HorzGridWidth | Gets or sets the width of the horizontal grid line below the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageAlign | Determines the vertical and horizontal alignment of the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageIndex | Determines the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageOffset | Determines the vertical and horizontal offset values used to calculate the position of the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | IsExpanded | Determines if the node item is expanded, displaying child items. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Item | Gets or sets the schedule item at a specific location in the collection. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Items | Gets the child nodes assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Level | Gets the current tree level of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | LockHeight | Determines if the item height can be adjusted through user interaction. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | MaxTimeBars | Gets or sets the maximum number of Timebars an item can contain.
public Property | Nodes | Gets the child nodes assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Notes | The collection of ScheduleNotes assigned to this dbiScheduleItem.
public Property | PageBreak | Determines if a page break will occur after a given item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Parent | Gets the parent item of the current item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ReadOnly | Determines if the item is ReadOnly. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Selected | Determines if the item is selected (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | SelectedImageIndex | Determines the index of the image to use when the item is selected. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Subject | Determines the subject of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Tag | Determines an object value that contains additional data about the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Text | Determines the items text. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | TimeBars | The collection of TimeBars assigned to this dbiScheduleItem.
public Property | UserDrawn | Determines if the line item can be drawn by the user.
public Property | XMLString | Overridden. Gets or sets an XML string to read the data from or write the data to dbiSchedule.
Top

Public Methods

 | Name | Description
public Method | Collapse | Closes a parent item so that the children are not visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | EnsureVisible | Attempts to adjust the Vertical scroll bar to ensure the item is visible in the list. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | Expand | Expands the item so that its child items are visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | ExpandAll | Expands the item, and all items below the calling item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellChecked | Gets the boolean value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellFormat | Gets the dbiCellFormat assigned to a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellInteger | Gets the integer value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellText | Gets the text at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetNodeCount | Gets the number of child nodes in an item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | IsVisible | Determines if a given node is visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | NextListNode | Gets the next node in the list.
public Method | NextVisibleNode | Gets the next visible item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | NodeFullPath | Gets the full text path of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | PrevVisibleNode | Gets the previous visible item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellChecked | Sets the boolean value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellInteger | Sets the integer value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellText | Sets the text for a specific column in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | Toggle | Expands/Collapes a parent node. (Inherited from Dbi.WinControl.dbiNodeItem)
Top

See Also

Reference

dbiScheduleItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiTimeBarItem Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarItem Class

"

The following tables list the members exposed by dbiTimeBarItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiTimeBarItem Constructor | Overloaded. Initializes a new instance of the dbiAppointmentItem class.
Top

Public Properties

 | Name | Description
public Property | AlarmEnd | Determines if an alarm will fire when the Timebar ends. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | AlarmStart | Determines if an alarm will fire when the Timebar begins. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BackColor | Gets or sets the primary background color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BackColorTo | Gets or sets the secondary background color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Body | Gets or sets the subtext of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BodyForeColor | Determines the foreground color used for body text on a dbiTimeBarItem.
public Property | BorderColor | Gets or sets the border color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BorderType | Overridden. Gets or sets the type of border to place around the Timebar.
public Property | Cargo | Gets or sets a non-visible text value for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ContactID | Assigns a contact to the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Data | Gets or sets a non-visible numeric value for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | DateColor | Determines the foreground color used when displaying dates inside a dbiTimeBarItem.
public Property | End | Gets or sets the ending date and time for a Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | EndImage | Gets or sets the image to place after the Timebar.
public Property | EntryID | Gets or sets a non-visible text value for the Timebar.. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | FillType | Gets or sets the background fill pattern of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Font | Gets or sets the font for the main text in the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Font2 | Gets or sets the font of the Timebar body text. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ForeColor | Gets or sets the fore color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | HatchStyle | Gets or sets the background pattern of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Image1 | Gets or sets the primary image associated with the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ImageAlign | Gets or sets the alignment of Image1.
public Property | IsSelected | Determines if a Timebar is selected.
public Property | Location | Gets or sets the appointment location. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | LocationID | Assigns a location to the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Locked | Determines if the appointment can be moves or sized by user-interaction. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | MaxTime | Gets or sets the maximum end time of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | MinTime | Gets or sets the minimum start time of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | PercentBorderColor | Determines the color used for the border of the percent bar in the dbiTimeBarItem.
public Property | PercentColor | Gets or sets the color of the percent complete bar inside the regular time bar.
public Property | PercentColorTo | Determines the secondary background color of the percent bar in the dbiTimeBarItem
public Property | PercentFillType | Determines the background pattern to paint the percent bar in the dbiTimeBarItem.
public Property | PercentHeight | Gets or sets the height of the percent complete bar inside the regular time bar.
public Property | PercentValue | Gets or sets the value of the percent complete bar inside the regular time bar.
public Property | PercentVOffset | Determines the vertical offset for displaying the percent bar inside a dbiTimeBarItem.
public Property | ReadOnly | Determines if the appointment info can be edited. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | RecordID | Gets or sets a hidden numeric value for the appoinment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderMinutesBeforeStart | Determines how many minutes before the Timebar starts an alarm is fired. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderPlaySound | Determines if a reminder sound will be played when the Timebar alarm is triggered. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSet | Determines if a reminder has been set for the start of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSetEnd | Determines if a reminder has been set for the end of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSoundFile | Gets or sets the reminder sound to be played when the appointment alarm is triggered. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Start | Gets or sets the starting date and time of an appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | StartImage | Gets or sets the image to place before the Timebar.
public Property | Style | Overridden. Gets or sets a pre-defined style assigned to the Timebar.
public Property | SubTextFont | Gets or sets the sub text font of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Tag | Determines an object that contains data about the dbiTimeBarItem. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | TaskID | Assigns a task to the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Text | Gets or sets the Timebar text. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | TextAlign | Gets or sets the horizontal and vertical alignment of the primary text in the Timebar.
public Property | VCalendar | Gets or sets the VCalendar specification for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Visible | Gets or sets a value indicating whether the time bar will be visible.
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current instance. (Inherited from Dbi.PIM.dbiAppointmentItem)
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleObject Class Members
See Also Properties Methods Events
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject Class

"

The following tables list the members exposed by dbiScheduleObject.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleObject Constructor | Overloaded. Initializes a new instance of the dbiScheduleObject class.
Top

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AltColorEven | Gets or sets the background color of the even numbers list items in the schedule area.
public Property | AltColorOdd | Gets or sets the background color of the odd numbers list items in the schedule area.
public Property | AlternateColor | Determines if the item background colors in the schedule area will be painted with alternating colors.
public Property | AlternateItems | Gets or sets the frequency of the alternating background colors.
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color of the schedule.
public Property | BackgroundImage | Gets or sets the background image for the schedule.
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ContactID | Assigns a contact to the schedule.
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Gets or sets the date format of the schedule.
public Property | DayLength | Gets or sets the number of characters used to represent the days of the week.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayBody | Determines if the body text will be displayed in the Timebars.
public Property | DisplayDays | Determines if the days of the week will be displayed with the major time segments.
public Property | DisplayOverlap | Determines if overlap lines will be displayed.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTimeBarDates | Determines if the start and end date will be displayed in the Timebar.
public Property | DisplayTimeLines | Determines if lines will be displayed for major time segments through the schedule.
public Property | DisplayUserDrawnRulerSegments | Determines if an additional row will be displayed inside the ruler, between the title and timeline areas.
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | End | Gets or sets the end date and time of a schedule.
public Property | FirstDayOfWeek | Gets or sets the starting day of the week in the schedule.
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
public Property | GuideLines | A collection of GuideLines to display in the Schedule.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderColor | Gets or sets the background color of a header item in the schedule.
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HorzGridLines | Determines if horizontal grid lines will be displayed in the schedule.
public Property | ImageAlignment | Gets or sets the vertical and horizontal alignment of the background image in the schedule.
public Property | ImageEffect | Determines how the background image in the schedule will be displayed.
public Property | ImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the background image.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineMaxSize | Gets or sets the height of the lines marking the major time segments in the ruler of the schedule.
public Property | LineMinSize | Gets or sets the height of the lines marking the minor time segments in the ruler of the schedule.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LocationID | Assigns a location to the schedule.
public Property | MajorTimeLine | Determines whether a full vertical line will be drawn at major time segments in the ruler.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MonthFormat | Determines how the monthly ruler is displayed in the schedule.
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | OverlapColor | Gets or sets the color of the overlap lines in the schedule.
public Property | OverlapSpan | Determines when the overlap lines will appear between 2 Timebars.
public Property | OverlapWidth | Gets or sets the width of the overlap lines in the schedule.
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RulerAlign | Gets or sets the position of the ruler text in the schedule
public Property | RulerBackColor | Gets or sets the primary background color of the ruler area in the schedule.
public Property | RulerBackColorTo | Gets or sets the secondary background color of the ruler area in the schedule.
public Property | RulerBorder | Gets or sets the type of border to place around the ruler area in the schedule.
public Property | RulerDivisions | Gets or sets the number of divisions to place in the ruler area between major time units
public Property | RulerFillType | Gets or sets the fill style for the ruler area in the schedule.
public Property | RulerFont | Gets or sets the ruler font in the schedule.
public Property | RulerForeColor | Gets or sets the text color of the ruler area in the schedule.
public Property | RulerLineColor | Gets or sets the color of the lines in the ruler area.
public Property | RulerOffset | Gets or sets the vertical and horizontal offset values of the ruler text in a schedule.
public Property | RulerThreeD | Determines if the ruler area will appear with some three dimensional features.
public Property | RulerTitle | Gets or sets the ruler title in the schedule.
public Property | RulerTitleBackColor | Determines the background color of the title area of the ruler.
public Property | RulerTitleBackColorTo | Determines the secondary background color of the title area of the ruler.
public Property | RulerTitleFillType | Determines the background pattern for the title area of the ruler.
public Property | RulerTitleFont | Determines the font used for the text in the title area of the ruler.
public Property | RulerTitleForeColor | Determines the foreground color used for the title area of the ruler.
public Property | ScheduleLineColor | Gets or sets the color of the horizontal lines seperating the list items in the schedule.
public Property | SelectedBackColor | Gets or sets the background color of selected list items in the schedule area.
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SplitRuler | Determines if the ruler will be split along the vertical axis.
public Property | Start | Gets or sets the start date and time of a schedule.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | TaskID | Assign a task to the schedule.
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TimeBarDateColor | Gets or sets the color of the Timebar dates.
public Property | TimeDistance | Gets or sets the distance between major time units for this dbiScheduleObject
public Property | TimeFormat | Determines how the hours in the ruler are displayed.
public Property | TimeLineBreak | Gets or sets the frequency of the time lines along the major time units in a schedule.
public Property | TimeLineColor | Gets or sets the color of the time lines in a schedule.
public Property | TimeLineStart | Gets or sets the major division where the first time line will be drawn.
public Property | TimeLineWidth | Gets or sets the width of the time lines in the schedule.
public Property | TimeType | Gets or sets the type of unit to display in the ruler of the schedule.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | Visible | Gets or sets a value indicating whether the dbiScheduleObject will be visible.
public Property | WeekendColor | Gets or sets the background color for weekend columns.
public Property | WeekFormat | Determines how the monthly ruler is displayed in the schedule.
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
public Property | YearFormat | Determines how the yearly ruler is displayed in the schedule.
Top

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WinControl.Schedule Namespace


%%ItemTitle%%

Dbi Namespace
See Also Inheritance Hierarchy
Dbi4 Assembly : Dbi Namespace

Enumerations

Enumeration | Description
enumBorderType | The type of border to display.
enumCheckBox | The type of checkbox to display.
enumFillType | The type of background pattern to display.
enumImageStyle | How the image is displayed.
enumSelectedMode | How the dates can be selected.
enumSelectedStyle | Determines how the select color applies to an item.
enumSelectType | The border around the selected object.
enumTodayFormat | The format for the "today" label visible in date picker controls.
enumVisualStyle | The visual style of the control.

See Also

Reference

Dbi4 Assembly


%%PageItemTitle%%

enumBorderType Enumeration
See Also
[image]
Dbi4 Assembly > Dbi Namespace : enumBorderType Enumeration

The type of border to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumBorderType
C#
public enum enumBorderType : System.Enum

Members

Member | Description
Default | Default border type
Lowered | A shadow will appear in the top / left corner. This value is similar to the LoweredThin border, but border width is larger.
LoweredThin | A shadow will appear in the top / left corner. This value is similar to the Lowered border, but this border width is small.
None | No border
Raised | The control will appear raised on the form, by having a shadow in the bottom / right corner. This value is similar to the RaisedThin border, but this border width is larger.
RaisedThin | A shadow will appear in the bottom / right corner. This value is similar to the Raised border, but this border width is smaller.
Regular | All four sides of the border will be equal width.
RoundedEdge | All four sides of the border will be equal width, and the corners will be rounded.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumBorderType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumCheckBox Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumCheckBox Enumeration

The type of checkbox to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumCheckBox
C#
public enum enumCheckBox : System.Enum

Members

Member | Description
Custom | A custom checkbox using images defined in the parent control: ImageCheckDisabled, ImageCheckDown, and ImageCheckUp.
Flat | A flat webstyle checkbox.
None | No checkbox shown.
Standard | A 3d style checkbox.
System | An XP system style checkbox.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumCheckBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumFillType Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumFillType Enumeration

The type of background pattern to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumFillType
C#
public enum enumFillType : System.Enum

Members

Member | Description
Circle | The *BackColor (BackColorFrom) property will appear on all four sides of the control, and gradually turn into the *BackColorTo property towards the center of the control, displaying a circle
Default | The default fill type.
Diagonal | The *BackColor (BackColorFrom) property will appear in the bottom/right corner of the control, and gradually turn into the *BackColorTo property in the top/left corner of the control.
Diamond | The *BackColor (BackColorFrom) property will appear on all four corners of the control, and gradually turn into the *BackColorTo property towards the center of the control. A vertical and horizontal line will be displayed in the *BackColorTo value.
Ellipse | The *BackColor (BackColorFrom) property will appear on all four sides of the control, and gradually turn into the *BackColorTo property towards the center of the control, displaying a circle. The circle in this pattern is more defined that in the Circle fill type.
Horizontal | The *BackColor (BackColorFrom) property will appear on the left side of the control, and gradually turn into the *BackColorTo property on the right of the control.
HorizontalBump | The *BackColor (BackColorFrom) property will appear on the left and right sides of the control, and gradually turn into the *BackColorTo property towards the center of the control.
HorizontalEdge | A new style derived from the Microsoft™ VISTA™ and Office 2007™ gradient fills where the Backcolor (BackColorFrom) meets the BackColorTo at a sharp horizontal point.
Pyramid | The *BackColor (BackColorFrom) property will appear on all four corners of the control, and gradually turn into the *BackColorTo property towards the center of the control. A diagonal line from each corner will be displayed in the *BackColorTo value.
ReverseDiagonal | The *BackColor (BackColorFrom) property will appear in the bottom/left corner of the control, and gradually turn into the *BackColorTo property in the top/right corner of the control.
Solid | Only the *BackColor (BackColorFrom) property will be displayed
Starburst | A unique fill style with a bezier curve used in the fill style.
Vertical | The *BackColor (BackColorFrom) property will appear on the top of the control, and gradually turn into the *BackColorTo property on the bottom of the control.
VerticalBump | The *BackColor (BackColorFrom) property will appear on the top and bottom sides of the control, and gradually turn into the *BackColorTo property towards the center of the control.
VerticalEdge | A new style derived from the Microsoft™ VISTA™ and Office 2007™ gradient fills where the Backcolor (BackColorFrom) meets the BackColorTo at a sharp vertical point.
VerticalEdge2 | A modified version of the VerticalEdge fill type that slightly adjusts the positioning of the colors to better fill larger areas.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumImageStyle Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumImageStyle Enumeration

How the image is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumImageStyle
C#
public enum enumImageStyle : System.Enum

Members

Member | Description
BottomLeft | The image will maintain its original size and it will be place in the bottom left corner.
BottomRight | The image will maintain its original size and it will be place in the bottom right corner.
Centered | The image will maintain its original size and it will be centered.
Scaled | The image will stretch to fill the area.
ScaledKeepRatio | The image will stretch to fill the area and remain proportional.
Tiled | The image will maintain its original size and it will be repeated to fill the area.
TopLeft | The image will maintain its original size and it will be place in the top left corner.
TopRight | The image will maintain its original size and it will be place in the top right corner.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumImageStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumSelectedMode Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumSelectedMode Enumeration

How the dates can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSelectedMode
C#
public enum enumSelectedMode : System.Enum

Members

Member | Description
Multiple | Multiple dates can be selected at a time.
None | Dates cannot be selected.
Single | A single date can be selected at a time.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumSelectedMode

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumSelectedStyle Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumSelectedStyle Enumeration

Determines how the select color applies to an item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSelectedStyle
C#
public enum enumSelectedStyle : System.Enum

Members

Member | Description
All | Highlight the whole node as selected.
TextOnly | Highlight the text only as selected.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumSelectedStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumSelectType Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumSelectType Enumeration

The border around the selected object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSelectType
C#
public enum enumSelectType : System.Enum

Members

Member | Description
Full | A square/rectangular border.
Round | A round border.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumSelectType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumTodayFormat Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumTodayFormat Enumeration

The format for the "today" label visible in date picker controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumTodayFormat
C#
public enum enumTodayFormat : System.Enum

Members

Member | Description
Date | Highlight the date.
None | Do not display a label.
Text | Highlight the date and display the text in the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumTodayFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%PageItemTitle%%

enumVisualStyle Enumeration
[image]
Dbi4 Assembly > Dbi Namespace : enumVisualStyle Enumeration

The visual style of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumVisualStyle
C#
public enum enumVisualStyle : System.Enum

Members

Member | Description
Clear | The control will be transparent.
Standard | The control will appear with default values.
XP | The control properties will be preset to XP styles.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.enumVisualStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi Namespace


%%ItemTitle%%

Dbi.PIM Namespace
See Also Inheritance Hierarchy
dbiPim4 Assembly : Dbi.PIM Namespace

Classes

Class | Description
AlarmEventArgs | Provides data to the Alarm event.
AlarmItemCollection | The collection of Alarms.
DaysWeekendCollection | Collection containing the days that are to be considered weekends.
dbiAppointmentCollection | The collection of Appointments.
dbiAppointmentItem | Provides appointment properties.
dbiContactCollection | The collection of Contacts.
dbiContactItem | Provides properties for defining contacts.
dbiCustomArea | Provides properties for defining custom areas.
dbiCustomAreaCollection | The collection of custom areas.
dbiDayFormat | Provides properties for defining day formats.
dbiDayFormatCollection | The collection of DayFormats.
dbiLocationCollection | The collection of Locations.
dbiLocationItem | Provides properties for defining locations.
dbiPIM | A repository class for the base classes used in the collaboration architecture with some dbi Calendar based controls.
dbiReminderDialog | The default reminder dialog.
dbiTaskCollection | The collection of Tasks.
dbiTaskItem | Provides properties for defining Tasks.
dbiTimeBarDialog | The default time bar dialog.

Delegates

Delegate | Description
dbiPIM.EventAlarmHandler | Represents the method that will handle the Alarm event in dbiPim4

Enumerations

Enumeration | Description
dbiReminderDialog.enumReminderState | The last button clicked before the dialog was closed.
dbiTaskItem.enumStatus | The status of the task.

See Also

Reference

dbiPim4 Assembly


%%PageItemTitle%%

AlarmEventArgs Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmEventArgs Class

Provides data to the Alarm event.

Object Model

AlarmEventArgs ClassdbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmEventArgs
C#
public class AlarmEventArgs

Inheritance Hierarchy

System.Object
Dbi.PIM.AlarmEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmEventArgs Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

AlarmEventArgs Class Members
See Also Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmEventArgs Class

"

The following tables list the members exposed by AlarmEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AlarmEventArgs Constructor | Initializes a new instance of the AlarmEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Appointment | The dbiAppointmentItem triggering the alarm.
public Property | Index | The index value of the alarm.
Top

See Also

Reference

AlarmEventArgs Class
Dbi.PIM Namespace


%%PageItemTitle%%

AlarmEventArgs Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmEventArgs Class : AlarmEventArgs Constructor

Initializes a new instance of the AlarmEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AlarmEventArgs()
C#
public AlarmEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmEventArgs Class
AlarmEventArgs Members


%%PageItemTitle%%

Appointment Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmEventArgs Class : Appointment Property

The dbiAppointmentItem triggering the alarm.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmEventArgs
Dim value As dbiAppointmentItem

instance.Appointment = value

value = instance.Appointment
C#
public dbiAppointmentItem Appointment {get; set;}

Remarks

This property value is of type dbiAppointmentItem, indicating the appointment which has triggered the alarm.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmEventArgs Class
AlarmEventArgs Members


%%PageItemTitle%%

Index Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmEventArgs Class : Index Property

The index value of the alarm.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmEventArgs
Dim value As System.Integer

instance.Index = value

value = instance.Index
C#
public System.int Index {get; set;}

Remarks

This property value is of type Integer, indicating the index value of the triggered alarm.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmEventArgs Class
AlarmEventArgs Members


%%PageItemTitle%%

AlarmItemCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmItemCollection Class

The collection of Alarms.

Object Model

AlarmItemCollection ClassdbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
C#
public class AlarmItemCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.AlarmItemCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

AlarmItemCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmItemCollection Class

"

The following tables list the members exposed by AlarmItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | AlarmItemCollection Constructor | Initializes a new instance of the AlarmItemCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new contact to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AlarmItemCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

AlarmItemCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : AlarmItemCollection Constructor

owner
The owner of the alarm item.
Initializes a new instance of the AlarmItemCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim owner As dbiPIM

Dim instance As New AlarmItemCollection(owner)
C#
public AlarmItemCollection(
   dbiPIM owner
)

Parameters

owner
The owner of the alarm item.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Add Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Add Method

objAlarm
The dbiAppointmentItem to add to the alarm collection.
Adds a new contact to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim objAlarm As dbiAppointmentItem
Dim value As System.Integer

value = instance.Add(objAlarm)
C#
public System.int Add(
   dbiAppointmentItem objAlarm
)

Parameters

objAlarm
The dbiAppointmentItem to add to the alarm collection.

Return Value

The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
Me.dbiPim.Alarms.Add(objAppointment)
C# Copy Code
this.dbiPim.Alarms.Add(objAppointment);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members
Setting Alarms


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection

instance.Clear()
C#
public void Clear()

Remarks

This method will delete all the items from the collection. To remove a single item, use the Remove or RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

IndexOf(dbiAppointmentItem) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : IndexOf(dbiAppointmentItem) Method

obj
The dbiAppointmentItem to locate in the collection.
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim obj As dbiAppointmentItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiAppointmentItem obj
)

Parameters

obj
The dbiAppointmentItem to locate in the collection.

Return Value

This method returns a value of type Integer, indicating the index value of the specified item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Insert Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
objAlarm
The dbiAppointmentItem to insert into the alarm collection.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim nIndex As System.Integer
Dim objAlarm As dbiAppointmentItem

instance.Insert(nIndex, objAlarm)
C#
public void Insert(
   System.int nIndex,
   dbiAppointmentItem objAlarm
)

Parameters

nIndex
The zero-based index location where the item is inserted.
objAlarm
The dbiAppointmentItem to insert into the alarm collection.

Example

Visual Basic Copy Code
Me.dbiPim.Alarms.Insert(0,objAppointment)
C# Copy Code
this.dbiPim.Alarms.Insert(0,objAppointment);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Remove Method

objAlarm
The dbiAppointmentItem to remove from the alarm collection.
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim objAlarm As dbiAppointmentItem

instance.Remove(objAlarm)
C#
public void Remove(
   dbiAppointmentItem objAlarm
)

Parameters

objAlarm
The dbiAppointmentItem to remove from the alarm collection.

Example

Visual Basic Copy Code
Me.dbiPim.Alarms.Remove(objAppointment)
C# Copy Code
this.dbiPim.Alarms.Remove(objAppointment);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Remarks

If the index value provided in less that zero, or greater than the value in Count property of the dbiContactCollection an ArgumentExceptionOutOfRange will occur.

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the number of items in the collections.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : Item Property

nIndex
The index of the item to get or set in the collection.
Gets or sets the item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmItemCollection
Dim nIndex As System.Integer
Dim value As dbiAppointmentItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiAppointmentItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The index of the item to get or set in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

DaysWeekendCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : DaysWeekendCollection Class

Collection containing the days that are to be considered weekends.

Object Model

DaysWeekendCollection Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
C#
public class DaysWeekendCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.DaysWeekendCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

DaysWeekendCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : DaysWeekendCollection Class

"

The following tables list the members exposed by DaysWeekendCollection.

"

Public Constructors

 | Name | Description
public Constructor | DaysWeekendCollection Constructor | Initializes a new instance of the DaysWeekendCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new day to the DayWeekendCollection object.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if a specific day of the week has been added to the DaysWeekendCollection.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

DaysWeekendCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

DaysWeekendCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : DaysWeekendCollection Constructor

Initializes a new instance of the DaysWeekendCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DaysWeekendCollection()
C#
public DaysWeekendCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Add Method

item
The System.DateTime.DayOfWeek to add to the collection.
Adds a new day to the DayWeekendCollection object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim item As System.DayOfWeek
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   System.DayOfWeek item
)

Parameters

item
The System.DateTime.DayOfWeek to add to the collection.

Return Value

The zero-based index of the item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Contains Method

item
The day of the week to evaluate.
Determines if a specific day of the week has been added to the DaysWeekendCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim item As System.DayOfWeek
Dim value As System.Boolean

value = instance.Contains(item)
C#
public System.bool Contains(
   System.DayOfWeek item
)

Parameters

item
The day of the week to evaluate.

Return Value

A Boolean value indicating if the day of the week has been added to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : IndexOf Method

item
A System.DateTime.DayOfWeek member to locate in the collection.
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim item As System.DayOfWeek
Dim value As System.Integer

value = instance.IndexOf(item)
C#
public System.int IndexOf(
   System.DayOfWeek item
)

Parameters

item
A System.DateTime.DayOfWeek member to locate in the collection.

Return Value

An Integer value representing the index of a specific item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
item
The System.DateTime.DayOfWeek to insert into the collection.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim nIndex As System.Integer
Dim item As System.DayOfWeek

instance.Insert(nIndex, item)
C#
public void Insert(
   System.int nIndex,
   System.DayOfWeek item
)

Parameters

nIndex
The zero-based index location where the item is inserted.
item
The System.DateTime.DayOfWeek to insert into the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Remove Method

item
The System.DateTime.DayOfWeek to remove from the collection.
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim item As System.DayOfWeek

instance.Remove(item)
C#
public void Remove(
   System.DayOfWeek item
)

Parameters

item
The System.DateTime.DayOfWeek to remove from the collection.

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the number of items in the collection.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : Item Property

nIndex
The index of the item to get or set in the collection.
Gets or sets the item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim nIndex As System.Integer
Dim value As System.DayOfWeek

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public System.DayOfWeek this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The index of the item to get or set in the collection.

Property Value

The System.DateTime.DayOfWeek member.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%%

dbiAppointmentCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentCollection Class

The collection of Appointments.

Object Model

dbiAppointmentCollection ClassdbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
C#
public class dbiAppointmentCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiAppointmentCollection

Requirements

Must use PIM as the data source for the DBI controls.

See Also

Reference

dbiAppointmentCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiAppointmentCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentCollection Class

"

The following tables list the members exposed by dbiAppointmentCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiAppointmentCollection Constructor | Initializes a new instance of the dbiAppointmentCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiAppointmentItem at a specific index value.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiAppointmentItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetAppointment | ** Method has been deprecated, it will no longer return values. Please use a for..each loop to select appointments from a date. See examples below**
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | Sort | Sorts the elements of the collection.
public Method | WriteXMLFile | Creates an XML File containing the Appointments collection.
public Method | XMLString | Creates a string that contains the XML information for the Appointments collection.
Top

See Also

Reference

dbiAppointmentCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiAppointmentCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : dbiAppointmentCollection Constructor

Initializes a new instance of the dbiAppointmentCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiAppointmentCollection()
C#
public dbiAppointmentCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Add Method

obj
The dbiAppointmentItem to add to the collection.
Add a dbiAppointmentItem to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim obj As dbiAppointmentItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiAppointmentItem obj
)

Parameters

obj
The dbiAppointmentItem to add to the collection.

Return Value

An integer indicating the index of the dbiAppointmentItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

GetAppointment Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : GetAppointment Method

dtDate
The date to check for appointments.
** Method has been deprecated, it will no longer return values. Please use a for..each loop to select appointments from a date. See examples below**

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim dtDate As System.Date
Dim value As dbiAppointmentItem

value = instance.GetAppointment(dtDate)
C#
public dbiAppointmentItem GetAppointment(
   System.DateTime dtDate
)

Parameters

dtDate
The date to check for appointments.

Example

Visual Basic Copy Code
Private Function AppointmentsOnDate(ByVal dtDate As Date) As Collections.Generic.List(Of Dbi.PIM.dbiAppointmentItem)
        Dim apptInDate As New Collections.Generic.List(Of Dbi.PIM.dbiAppointmentItem)
        Dim apptCurrent As Dbi.PIM.dbiAppointmentItem
        For Each apptCurrent In Me.DbiPIM1.Appointments
            If dtDate.Date >= apptCurrent.Start.Date And dtDate.Date <= apptCurrent.End Then
                apptInDate.Add(apptCurrent)
            End If
        Next
        Return apptInDate
 End Function
C# Copy Code
Private List<Dbi.PIM.dbiAppointmentItem> AppointmentsOnDate(DateTime dtDate)
 {
    List<Dbi.PIM.dbiAppointmentItem> apptInDate = New List<Dbi.PIM.dbiAppointmentItem>();
    foreach (Dbi.PIM.dbiAppointmentItem apptCurrent In this.dbiPIM1.Appointments)
      {
         If (dtDate.Date >= apptCurrent.Start.Date && dtDate.Date <= apptCurrent.End.Date)
           {
              apptInDate.Add(apptCurrent);
           }
      }
     Return apptInDate;
 }

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

IndexOf(dbiAppointmentItem) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : IndexOf(dbiAppointmentItem) Method

obj
dbiAppointmentItem
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim obj As dbiAppointmentItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiAppointmentItem obj
)

Parameters

obj
dbiAppointmentItem

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiAppointmentItem to insert.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim nIndex As System.Integer
Dim obj As dbiAppointmentItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiAppointmentItem obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiAppointmentItem to insert.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Remove Method

obj
dbiAppointmentItem
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim obj As dbiAppointmentItem

instance.Remove(obj)
C#
public void Remove(
   dbiAppointmentItem obj
)

Parameters

obj
dbiAppointmentItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Sort Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Sort Method

comparer
The Comparer to use when comparing the elements in the collection.
Sorts the elements of the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim comparer As System.Collections.IComparer

instance.Sort(comparer)
C#
public virtual void Sort(
   System.Collections.IComparer comparer
)

Parameters

comparer
The Comparer to use when comparing the elements in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : WriteXMLFile Method

strFileName
The fully qualified file name used to write the data.
Creates an XML File containing the Appointments collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified file name used to write the data.

Return Value

Boolean value indicating if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : XMLString Method

Creates a string that contains the XML information for the Appointments collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value containing an XML formatted version of the Appointments collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : Item Property

nIndex
Integer
Gets or sets the dbiAppointmentItem at a specific index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentCollection
Dim nIndex As System.Integer
Dim value As dbiAppointmentItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiAppointmentItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
Integer

Property Value

dbiAppointmentItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%%

dbiAppointmentItem Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentItem Class

Provides appointment properties.

Object Model

dbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
C#
public class dbiAppointmentItem

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiAppointmentItem
Dbi.WinControl.Schedule.dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiAppointmentItem Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentItem Class

"

The following tables list the members exposed by dbiAppointmentItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiAppointmentItem Constructor | Overloaded. Initializes a new instance of the dbiAppointmentItem class.
Top

Public Properties

 | Name | Description
public Property | AlarmEnd | Determines if an alarm will fire when the appointment ends.
public Property | AlarmStart | Determines if an alarm will fire when the appointment starts.
public Property | AllDayEvent | Determines if the appointment will be an all day appointment.
public Property | BackColor | Gets or sets the primary background color of the appointment.
public Property | BackColorTo | Gets or sets the secondary background color of the appointment.
public Property | Body | Gets or sets any additional details of the appointment.
public Property | BorderColor | Gets or sets the border color of the appointment.
public Property | BorderType | Gets or sets the type of border to place around the appointment.
public Property | Cargo | Gets or sets a non-visible text value for the appointment.
public Property | ContactID | Assigns a contact to the appointment.
public Property | Data | Gets or sets a non-visible numeric value for the appointment.
public Property | End | Gets or sets the ending date and time for an appointment.
public Property | EntryID | Gets or sets a non-visible text value for the appointment.
public Property | FillType | Gets or sets the type of pattern to paint the background of the appointment.
public Property | Font | Gets or sets the font for the main text in the appointment.
public Property | Font2 | Gets or sets the font of the information line in the appointment.
public Property | ForeColor | Gets or sets the fore color of the appointment.
public Property | HatchStyle | Gets or sets the background pattern of the appointment.
public Property | Image1 | Gets or sets the primary image associated with the appointment.
public Property | Image2 | Gets or sets the secondary image associated with the appointment.
public Property | Image3 | Gets or sets the tertiary image associated with the appointment.
public Property | InfoFont | Gets or sets the font of the information line in the appointment.
public Property | IsRecurring | Determines if the appointment will be recurring.
public Property | Location | Gets or sets the appointment location.
public Property | LocationID | Assigns a location to the appointment.
public Property | Locked | Determines if the appointment can be moves or sized by user-interaction.
public Property | MaxTime | Gets or sets the maximum end time of the appointment.
public Property | MinTime | Gets or sets the minimum start time of the appointment.
public Property | ReadOnly | Determines if the appointment can be modified by user interaction.
public Property | RecordID | Gets or sets a hidden numeric value for the appoinment.
public Property | ReminderMinutesBeforeStart | Determines how many minutes before the appointment an alarm is fired.
public Property | ReminderPlaySound | Determines if a reminder sound will be played when the appointment alarm is triggered.
public Property | ReminderSet | Determines if a reminder has been set for the appointment.
public Property | ReminderSetEnd | Determines if a reminder has been set for the end of the appointment.
public Property | ReminderSoundFile | Gets or sets the reminder sound to be played when the appointment alarm is triggered.
public Property | Start | Gets or sets the starting date and time of an appointment.
public Property | Style | Gets or sets a pre-defined style assigned to the appointment.
public Property | SubTextFont | Gets or sets the sub text font of the appointment.
public Property | Tag | A property where you can store an object relative to the dbiAppointmentItem. Good property for storing datarow or record information.
public Property | TaskBarColor | Gets or sets the color of the taskbar of the appointment.
public Property | TaskID | Assigns a task to the appointment.
public Property | Text | Gets or sets the appointment text.
public Property | VCalendar | Gets or sets the VCalendar specification for the appointment.
public Property | XMLString | Gets or sets an xml string to read or write the appointment data.
Top

Public Methods

 | Name | Description
public Method | Clone | reates a new object that is a copy of the current instance.
public Method | ResetFonts | Clears all the fonts for the appointment.
public Method | XMLProperties | Return an XML string of the properties from dbiAppointmentItem
Top

See Also

Reference

dbiAppointmentItem Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiAppointmentItem Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : dbiAppointmentItem Constructor

Initializes a new instance of the dbiAppointmentItem class.

Overload List

Overload | Description
dbiAppointmentItem Constructor() | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(DateTime,DateTime) | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(DateTime,DateTime,String) | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(DateTime,DateTime,String,String) | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(dbiAppointmentItem) | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(String) | Initializes a new instance of the dbiAppointmentItem class.
dbiAppointmentItem Constructor(XmlNodeList) | Initializes a new instance of the dbiAppointmentItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

dbiAppointmentItem Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor()

Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiAppointmentItem()
C#
public dbiAppointmentItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(DateTime,DateTime)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(DateTime,DateTime)

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date

Dim instance As New dbiAppointmentItem(dtStart, dtEnd)
C#
public dbiAppointmentItem(
   System.DateTime dtStart,
   System.DateTime dtEnd
)

Parameters

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(DateTime,DateTime,String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(DateTime,DateTime,String)

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.
strText
The appointment text.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim strText As System.String

Dim instance As New dbiAppointmentItem(dtStart, dtEnd, strText)
C#
public dbiAppointmentItem(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.string strText
)

Parameters

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.
strText
The appointment text.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(DateTime,DateTime,String,String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(DateTime,DateTime,String,String)

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.
strText
The appointment text.
strEntryID
The appointment Entry ID.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim strText As System.String
Dim strEntryID As System.String

Dim instance As New dbiAppointmentItem(dtStart, dtEnd, strText, strEntryID)
C#
public dbiAppointmentItem(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.string strText,
   System.string strEntryID
)

Parameters

dtStart
The start date and time of the appointment.
dtEnd
The end date and time of the appointment.
strText
The appointment text.
strEntryID
The appointment Entry ID.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(dbiAppointmentItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(dbiAppointmentItem)

objAppoint
The dbiAppointmentItem object.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objAppoint As dbiAppointmentItem

Dim instance As New dbiAppointmentItem(objAppoint)
C#
public dbiAppointmentItem(
   dbiAppointmentItem objAppoint
)

Parameters

objAppoint
The dbiAppointmentItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(String)

strVCalendar
The VCalendar specifications for the appointment.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strVCalendar As System.String

Dim instance As New dbiAppointmentItem(strVCalendar)
C#
public dbiAppointmentItem(
   System.string strVCalendar
)

Parameters

strVCalendar
The VCalendar specifications for the appointment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

dbiAppointmentItem Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class > dbiAppointmentItem Constructor : dbiAppointmentItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing appointment information.
Initializes a new instance of the dbiAppointmentItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiAppointmentItem(xmlNodes)
C#
public dbiAppointmentItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing appointment information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Overload List


%%PageItemTitle%%

Clone Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Clone Method

reates a new object that is a copy of the current instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Object

value = instance.Clone()
C#
public System.object Clone()

Return Value

A new object that is a copy of this instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ResetFonts Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ResetFonts Method

Clears all the fonts for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem

instance.ResetFonts()
C#
public void ResetFonts()

Return Value

This method does not return a value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ResetFonts()
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ResetFonts();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

XMLProperties Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : XMLProperties Method

Return an XML string of the properties from dbiAppointmentItem

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

value = instance.XMLProperties()
C#
public System.string XMLProperties()

Return Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

AlarmEnd Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : AlarmEnd Property

Determines if an alarm will fire when the appointment ends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.AlarmEnd = value

value = instance.AlarmEnd
C#
public virtual System.bool AlarmEnd {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.AlarmEnd = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.AlarmEnd = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

AlarmStart Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : AlarmStart Property

Determines if an alarm will fire when the appointment starts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.AlarmStart = value

value = instance.AlarmStart
C#
public virtual System.bool AlarmStart {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.AlarmStart = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.AlarmStart = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

AllDayEvent Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : AllDayEvent Property

Determines if the appointment will be an all day appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.AllDayEvent = value

value = instance.AllDayEvent
C#
public virtual System.bool AllDayEvent {get; set;}

Property Value

A Boolean value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.AllDayEvent = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.AllDayEvent = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : BackColor Property

Gets or sets the primary background color of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A Color value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.BackColor = System.Drawing.Color.Silver
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.BackColor = System.Drawing.Color.Silver;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : BackColorTo Property

Gets or sets the secondary background color of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public virtual System.Drawing.Color BackColorTo {get; set;}

Property Value

A Color value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.BackColorTo = System.Drawing.Color.Silver;
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.BackColorTo = System.Drawing.Color.Silver;

Remarks

This property is only visible when the FillType property is not equal to Solid. The primary background color is defined in the BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Body Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Body Property

Gets or sets any additional details of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public virtual System.string Body {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Body = "Additional Text"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Body = "Additional Text";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

BorderColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : BorderColor Property

Gets or sets the border color of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.BorderColor = System.Drawing.Color.Black
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.BorderColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

BorderType Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : BorderType Property

Gets or sets the type of border to place around the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As enumBorderType

instance.BorderType = value

value = instance.BorderType
C#
public virtual enumBorderType BorderType {get; set;}

Property Value

This property value is of type Dbi.enumBorderType

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.BorderType = Dbi.enumBorderType.Regular
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.BorderType = Dbi.enumBorderType.Regular;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Cargo Property

Gets or sets a non-visible text value for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public virtual System.string Cargo {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Cargo = "Appointment detail"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Cargo = "Appointment Detail";

Remarks

This property is not visible to the end user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ContactID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ContactID Property

Assigns a contact to the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.ContactID = value

value = instance.ContactID
C#
public virtual System.string ContactID {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ContactID = "CT12345"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ContactID = "CT1234";

Remarks

This property defines which contact to assign to the appointment. The contact identication must be a valid contact Entry ID.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Working with Entry ID's


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Data Property

Gets or sets a non-visible numeric value for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public virtual System.int Data {get; set;}

Property Value

An Integer value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Data = 12345
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Data = 12345;

Remarks

This property defines a non-visible numeric value for the appointment. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

End Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : End Property

Gets or sets the ending date and time for an appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Date

instance.End = value

value = instance.End
C#
public virtual System.DateTime End {get; set;}

Property Value

A DateTime value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.End = dtEndDateTime
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.End = dtEndDatTime;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

EntryID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : EntryID Property

Gets or sets a non-visible text value for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.EntryID = value

value = instance.EntryID
C#
public virtual System.string EntryID {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.EntryID = "App46704"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.EntryID = "App46704";

Remarks

This property indicates a non-visible text value for the appointment. It is recommended that the Record ID is stored as a string in this property. If this property is not manually defined, a value will be generated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Working with Entry ID's


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : FillType Property

Gets or sets the type of pattern to paint the background of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Property Value

A Dbi.enumFillType value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.FillType = Dbi.enumFillType.Vertical
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.FillType = Dbi.enumFillType.Vertical;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Font Property

Gets or sets the font for the main text in the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

A Font value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Font = New Font("Verdana",10)
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Font = new Font("Verdana", 10);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Font2 Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Font2 Property

Gets or sets the font of the information line in the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Font

instance.Font2 = value

value = instance.Font2
C#
public virtual System.Drawing.Font Font2 {get; set;}

Property Value

A Font value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Font = new Font("Verdana", 10)
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Font2 = new Font("Verdana", 10);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ForeColor Property

Gets or sets the fore color of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

A Color value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ForeColor = System.Drawing.Color.Black
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

HatchStyle Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : HatchStyle Property

Gets or sets the background pattern of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Drawing2D.HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public virtual System.Drawing.Drawing2D.HatchStyle HatchStyle {get; set;}

Property Value

A Drawing2.HatchStyle value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Image1 Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Image1 Property

Gets or sets the primary image associated with the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.Image1 = value

value = instance.Image1
C#
public virtual System.int Image1 {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Image1 = -3
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Image1 = -3;

Remarks

This property indicates the primary image associated with the appointment. A positive value will use the image list associated with the control, while a negative value will reference a stock image available within dbiPIM.

For additional information on using images in dbiDayView, please see Custom Images.

If using the property with a dbiTimeBarItem, please see the dbiTimeBarItem.Image1 Property

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Image2 Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Image2 Property

Gets or sets the secondary image associated with the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.Image2 = value

value = instance.Image2
C#
public virtual System.int Image2 {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Image2 = -4
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Image2 = -4;

Remarks

This property indicates the secondary image associated with the appointment. A positive value will use the image list associated with the control, while a negative value will reference a stock image available within dbiPIM.

For additional information on using images in dbiDayView, please see Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Image3 Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Image3 Property

Gets or sets the tertiary image associated with the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.Image3 = value

value = instance.Image3
C#
public virtual System.int Image3 {get; set;}

Property Value

An integer value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Image3 = -5
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Image3 = -5;

Remarks

This property indicates the tertiary image associated with the appointment. A positive value will use the image list associated with the control, while a negative value will reference a stock image available within dbiPIM.

For additional information on using images in dbiDayView, please see Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

InfoFont Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : InfoFont Property

Gets or sets the font of the information line in the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Font

instance.InfoFont = value

value = instance.InfoFont
C#
public virtual System.Drawing.Font InfoFont {get; set;}

Property Value

A Font value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.InfoFont = New Font("Tahoma", 8)
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.InfoFont = new Font("Tahoma", 8);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

IsRecurring Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : IsRecurring Property

Determines if the appointment will be recurring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.IsRecurring = value

value = instance.IsRecurring
C#
public virtual System.bool IsRecurring {get; set;}

Property Value

A Boolean value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.IsRecurring = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.IsRecurring = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Location Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Location Property

Gets or sets the appointment location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.Location = value

value = instance.Location
C#
public virtual System.string Location {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Location = "Boardroom"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Location = "Boardroom";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

LocationID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : LocationID Property

Assigns a location to the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.LocationID = value

value = instance.LocationID
C#
public virtual System.string LocationID {get; set;}

Property Value

A String value, indicating the location to assign to the appointment.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.LocationID = "LOC123"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.LocationID = "LOC123";

Remarks

The location identication must be a valid location Entry ID.

For additional information on Entry ID's, please see Working with Entry ID's.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Locked Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Locked Property

Determines if the appointment can be moves or sized by user-interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.Locked = value

value = instance.Locked
C#
public virtual System.bool Locked {get; set;}

Property Value

A Boolean value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Locked = False
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Locked = false;

Remarks

If this property value is set to true, the appointment can be moved and resized programmatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

MaxTime Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : MaxTime Property

Gets or sets the maximum end time of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.TimeSpan

instance.MaxTime = value

value = instance.MaxTime
C#
public virtual System.TimeSpan MaxTime {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.MaxTime = 960
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.MaxTime = 960;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

MinTime Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : MinTime Property

Gets or sets the minimum start time of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.TimeSpan

instance.MinTime = value

value = instance.MinTime
C#
public virtual System.TimeSpan MinTime {get; set;}

Property Value

An Integer value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.MinTime = 480
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.MinTime = 480;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReadOnly Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReadOnly Property

Determines if the appointment can be modified by user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public virtual System.bool ReadOnly {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReadOnly = False
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReadOnly = false;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

RecordID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : RecordID Property

Gets or sets a hidden numeric value for the appoinment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.RecordID = value

value = instance.RecordID
C#
public virtual System.int RecordID {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.RecordID = 35
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.RecordID = 35;

Remarks

This property is not visible to the end user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReminderMinutesBeforeStart Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReminderMinutesBeforeStart Property

Determines how many minutes before the appointment an alarm is fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.ReminderMinutesBeforeStart = value

value = instance.ReminderMinutesBeforeStart
C#
public virtual System.int ReminderMinutesBeforeStart {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReminderMinutesBeforeStart = 5
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReminderMinutesBeforeStart = 5;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReminderPlaySound Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReminderPlaySound Property

Determines if a reminder sound will be played when the appointment alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.ReminderPlaySound = value

value = instance.ReminderPlaySound
C#
public virtual System.bool ReminderPlaySound {get; set;}

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReminderPlaySound = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReminderPlaySound = true;

Remarks

This property value is of type Boolean, indicating is a reminder sound will be played when the alarm is triggered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReminderSet Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReminderSet Property

Determines if a reminder has been set for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.ReminderSet = value

value = instance.ReminderSet
C#
public virtual System.bool ReminderSet {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReminderSet = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReminderSet = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReminderSetEnd Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReminderSetEnd Property

Determines if a reminder has been set for the end of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Boolean

instance.ReminderSetEnd = value

value = instance.ReminderSetEnd
C#
public virtual System.bool ReminderSetEnd {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReminderSetEnd = True
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReminderSet = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

ReminderSoundFile Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : ReminderSoundFile Property

Gets or sets the reminder sound to be played when the appointment alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.ReminderSoundFile = value

value = instance.ReminderSoundFile
C#
public virtual System.string ReminderSoundFile {get; set;}

Property Value

A String value, indicating the sound file used when the appointment alarm is triggered.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.ReminderSoundFile = "Sound.wav"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.ReminderSoundFile = "Sound.wav";

Remarks

This sound will only be played when the ReminderPlaySound property is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Start Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Start Property

Gets or sets the starting date and time of an appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public virtual System.DateTime Start {get; set;}

Property Value

A DateTime value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Start = dtStartDateTime
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Start = dtStartDateTime;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Style Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Style Property

Gets or sets a pre-defined style assigned to the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Integer

instance.Style = value

value = instance.Style
C#
public virtual System.int Style {get; set;}

Property Value

An Integer value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Style = 1
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Style = 1;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

SubTextFont Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : SubTextFont Property

Gets or sets the sub text font of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Font

instance.SubTextFont = value

value = instance.SubTextFont
C#
public virtual System.Drawing.Font SubTextFont {get; set;}

Property Value

A Font value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.SubTextFont = New Font("Verdana", 8)
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.SubTextFont = new Font("Tahoma", 8);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Tag Property

A property where you can store an object relative to the dbiAppointmentItem. Good property for storing datarow or record information.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

TaskBarColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : TaskBarColor Property

Gets or sets the color of the taskbar of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.Drawing.Color

instance.TaskBarColor = value

value = instance.TaskBarColor
C#
public virtual System.Drawing.Color TaskBarColor {get; set;}

Property Value

A Color value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.TaskBarColor = System.Drawing.Color.Blue
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.TaskBarColor = System.Drawing.Color.Blue;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

TaskID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : TaskID Property

Assigns a task to the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.TaskID = value

value = instance.TaskID
C#
public virtual System.string TaskID {get; set;}

Property Value

A String value, indicating the task to assign to the appointment.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.TaskID = "TASK7"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.TaskID = "TASK7";

Remarks

The task identication must be a valid task Entry ID.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members
Working with Entry ID's


%%PageItemTitle%%

Text Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : Text Property

Gets or sets the appointment text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

A String value

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem

newAppointment.Text = "Appointment Text"
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.Text = "Appointment Text";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

VCalendar Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : VCalendar Property

Gets or sets the VCalendar specification for the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.VCalendar = value

value = instance.VCalendar
C#
public virtual System.string VCalendar {get; set;}

Property Value

A String value, indicating the VCalendar specification of the appointment.

Remarks

For additional information on using VCalendar, please see VCalendar Support.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentItem Class : XMLString Property

Gets or sets an xml string to read or write the appointment data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiAppointmentItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Example

Visual Basic Copy Code
Dim newAppointment As New Dbi.Pim4.dbiAppointmentItem
Dim strXML As String

newAppointment.XMLString = strXML
C# Copy Code
Dbi.Pim4.dbiAppointmentItem newAppointment;
string strXML;

newAppointment = new Dbi.Pim4.dbiAppointmentItem();

newAppointment.XMLString = strXML;

Remarks

This property indicates an xml string to read or write to the appointment.

For additional information, please see Reading and Writing XML Data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentItem Class
dbiAppointmentItem Members


%%PageItemTitle%%

dbiContactCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactCollection Class

The collection of Contacts.

Object Model

dbiContactCollection ClassdbiContactItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
C#
public class dbiContactCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiContactCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiContactCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactCollection Class

"

The following tables list the members exposed by dbiContactCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiContactCollection Constructor | Initializes a new instance of the dbiContactCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiContactItem at a specific index value.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiContactItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiContactItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the Contacts collection.
public Method | XMLString | Creates a string that contains the XML information for the Contacts collection.
Top

See Also

Reference

dbiContactCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiContactCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : dbiContactCollection Constructor

Initializes a new instance of the dbiContactCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiContactCollection()
C#
public dbiContactCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Add Method

item
The dbiContactItem to add to the collection.
Add a dbiContactItem to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim item As dbiContactItem
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   dbiContactItem item
)

Parameters

item
The dbiContactItem to add to the collection.

Return Value

An integer indicating the index of the dbiContactItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Contains Method

item
dbiContactItem
Determines if the Contact collection contains a specific dbiContactItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim item As dbiContactItem
Dim value As System.Boolean

value = instance.Contains(item)
C#
public System.bool Contains(
   dbiContactItem item
)

Parameters

item
dbiContactItem

Return Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

IndexOf(dbiContactItem) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : IndexOf(dbiContactItem) Method

item
dbiContactItem
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim item As dbiContactItem
Dim value As System.Integer

value = instance.IndexOf(item)
C#
public System.int IndexOf(
   dbiContactItem item
)

Parameters

item
dbiContactItem

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Remove Method

item
dbiContactItem
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim item As dbiContactItem

instance.Remove(item)
C#
public void Remove(
   dbiContactItem item
)

Parameters

item
dbiContactItem

Return Value

None

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : WriteXMLFile Method

strFileName
The fully qualified file name used to write the data.
Creates an XML File containing the Contacts collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified file name used to write the data.

Return Value

Boolean value indicating if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : XMLString Method

Creates a string that contains the XML information for the Contacts collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value containing an XML formatted version of the Contacts collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : Item Property

nIndex
Integer
Gets or sets the dbiContactItem at a specific index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactCollection
Dim nIndex As System.Integer
Dim value As dbiContactItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiContactItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
Integer

Property Value

dbiContactItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%%

dbiContactItem Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactItem Class

Provides properties for defining contacts.

Object Model

dbiContactItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
C#
public class dbiContactItem

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiContactItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiContactItem Class Members
See Also Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactItem Class

"

The following tables list the members exposed by dbiContactItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiContactItem Constructor | Overloaded. Initializes a new instance of the dbiContactItem class.
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the contact.
public Property | BackColor | Gets or sets the primary background color of the contact.
public Property | BackColorTo | Gets or sets the secondary background color of the contact.
public Property | Body | Gets or sets additional information for the contact.
public Property | Cargo | Gets or sets a non-visible text value for the contact.
public Property | City | Gets or sets the city of the contact.
public Property | CompanyName | Gets or sets the company name of the contact.
public Property | Country | Gets or sets the country of the contact.
public Property | Data | Gets or sets a non-visible numeric value for the contact.
public Property | Email | Gets or sets the email address of the contact.
public Property | EntryID | Gets or sets a non-visible text value for the contact.
public Property | FaxNumber | Gets or sets the fax number of the contact.
public Property | FirstName | Gets or sets the first name of the contact.
public Property | ForeColor | Gets or sets the fore color of the contact.
public Property | Image | Gets or sets the image to display with the contact.
public Property | LastName | Gets or sets the last name of the contact.
public Property | PostalCode | Gets or sets the postal code (or zip code) for the contact.
public Property | RecordID | Gets or sets a non-visible numeric value for the contact.
public Property | State | Gets or sets the state of the contact.
public Property | Subject | Gets or sets a short description of the contact.
public Property | Tag | A property where you can store an object relative to the dbiContactItem. Good property for storing datarow or record information.
public Property | TelephoneNumber | Gets or sets a phone number for the contact.
public Property | Title | Gets or sets the title or job position of the contact.
public Property | XMLString | Gets or sets an xml string to read or write the contact data.
Top

See Also

Reference

dbiContactItem Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiContactItem Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : dbiContactItem Constructor

Initializes a new instance of the dbiContactItem class.

Overload List

Overload | Description
dbiContactItem Constructor() | Initializes a new instance of the dbiContactItem class.
dbiContactItem Constructor(String) | Initializes a new instance of the dbiContactItem class.
dbiContactItem Constructor(String,String) | Initializes a new instance of the dbiContactItem class.
dbiContactItem Constructor(dbiContactItem) | Initializes a new instance of the dbiContactItem class.
dbiContactItem Constructor(XmlNodeList) | Initializes a new instance of the dbiContactItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

dbiContactItem Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class > dbiContactItem Constructor : dbiContactItem Constructor()

Initializes a new instance of the dbiContactItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiContactItem()
C#
public dbiContactItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Overload List


%%PageItemTitle%%

dbiContactItem Constructor(String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class > dbiContactItem Constructor : dbiContactItem Constructor(String)

strTitle
The title of the contact.
Initializes a new instance of the dbiContactItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strTitle As System.String

Dim instance As New dbiContactItem(strTitle)
C#
public dbiContactItem(
   System.string strTitle
)

Parameters

strTitle
The title of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Overload List


%%PageItemTitle%%

dbiContactItem Constructor(String,String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class > dbiContactItem Constructor : dbiContactItem Constructor(String,String)

strTitle
The title of the contact.
strEntryID
The EntryID of the contact.
Initializes a new instance of the dbiContactItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strTitle As System.String
Dim strEntryID As System.String

Dim instance As New dbiContactItem(strTitle, strEntryID)
C#
public dbiContactItem(
   System.string strTitle,
   System.string strEntryID
)

Parameters

strTitle
The title of the contact.
strEntryID
The EntryID of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Overload List


%%PageItemTitle%%

dbiContactItem Constructor(dbiContactItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class > dbiContactItem Constructor : dbiContactItem Constructor(dbiContactItem)

objContact
The dbiContactItem containing contact information.
Initializes a new instance of the dbiContactItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objContact As dbiContactItem

Dim instance As New dbiContactItem(objContact)
C#
public dbiContactItem(
   dbiContactItem objContact
)

Parameters

objContact
The dbiContactItem containing contact information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Overload List


%%PageItemTitle%%

dbiContactItem Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class > dbiContactItem Constructor : dbiContactItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing contact information.
Initializes a new instance of the dbiContactItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiContactItem(xmlNodes)
C#
public dbiContactItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing contact information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Overload List


%%PageItemTitle%%

Address Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Address Property

Gets or sets the address of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Address = value

value = instance.Address
C#
public System.string Address {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Address = "123 Main St."
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Address = "123 Main St.";

Remarks

This property value is of type String, indicating the address of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : BackColor Property

Gets or sets the primary background color of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.BackColor = System.Drawing.Color.White
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.BackColor = System.Drawing.Color.White;

Remarks

This property value is of type Color, indicating the color used to paint the background of the contact when you are displaying by contact in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : BackColorTo Property

Gets or sets the secondary background color of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.BackColorTo = System.Drawing.Color.Silver
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.BackColorTo = System.Drawing.Color.Silver;

Remarks

This property value is of type Color, indicating the secondary color used to paint the background of the contact when you are displaying by contact in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Body Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Body Property

Gets or sets additional information for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public System.string Body {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Body = "Additional Details"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Body = "Additional Details";

Remarks

This property value is of type String, indicating any additional details of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Cargo Property

Gets or sets a non-visible text value for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Cargo = "Key Data"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Cargo = "Key Data";

Remarks

This property value is of type String, indicating a non-visible text value for the contact. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

City Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : City Property

Gets or sets the city of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.City = value

value = instance.City
C#
public System.string City {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.City = "Toronto"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.City = "Toronto";

Remarks

This property value is of type String, indicating the city of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

CompanyName Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : CompanyName Property

Gets or sets the company name of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.CompanyName = value

value = instance.CompanyName
C#
public System.string CompanyName {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.CompanyName = "DBI Technologies"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.CompanyName = "DBI Technologies";

Remarks

This property value is of type String, indicating the company name of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Country Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Country Property

Gets or sets the country of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Country = value

value = instance.Country
C#
public System.string Country {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Country = "Canada"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Country = "Canada";

Remarks

This property value is of type String, indicating the country of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Data Property

Gets or sets a non-visible numeric value for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Data = 44
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Data = 44;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the contact. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Email Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Email Property

Gets or sets the email address of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Email = value

value = instance.Email
C#
public System.string Email {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Email = "info@dbi-tech.com"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Email = "info@dbi-tech.com";

Remarks

This property value is of type String, indicating the email address of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

EntryID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : EntryID Property

Gets or sets a non-visible text value for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.EntryID = value

value = instance.EntryID
C#
public System.string EntryID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.EntryID = "DBIID44"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.EntryID = "DBIID44";

Remarks

This property value is of type String, indicating a non-visible text value for the contact. This property is used to relate the contacts to the appointments. It is also used to filtering the displayed appointments within the controls. It is recommended that the Record ID is stored as a string in this property. If this property is not manually defined, a value will be generated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members
Working with Entry ID's


%%PageItemTitle%%

FaxNumber Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : FaxNumber Property

Gets or sets the fax number of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.FaxNumber = value

value = instance.FaxNumber
C#
public System.string FaxNumber {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.FaxNumber = "(204)985-5771"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.FaxNumber = "(204)985-5771";

Remarks

This property value is of type String, indicating the fax number of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

FirstName Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : FirstName Property

Gets or sets the first name of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.FirstName = value

value = instance.FirstName
C#
public System.string FirstName {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.FirstName = "John"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.FirstName = "John";

Remarks

This property value is of type String, indicating the first name of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : ForeColor Property

Gets or sets the fore color of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.ForeColor = System.Drawing.Color.Black
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.ForeColor = System.Drawing.Color.Black;

Remarks

This property value is of type Color, indicating the fore color of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Image Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Image Property

Gets or sets the image to display with the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Integer

instance.Image = value

value = instance.Image
C#
public System.int Image {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Image = -4
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Image = -4;

Remarks

This property value is of type Integer, indicating the index of the image to display with the contact.

For additional information on using images, please refer to Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

LastName Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : LastName Property

Gets or sets the last name of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.LastName = value

value = instance.LastName
C#
public System.string LastName {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.LastName = "Smith"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.LastName = "Smith";

Remarks

This property value is of type String, indicating the last name of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

PostalCode Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : PostalCode Property

Gets or sets the postal code (or zip code) for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.PostalCode = value

value = instance.PostalCode
C#
public System.string PostalCode {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.PostalCode = "F3R 9I9"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.PostalCode = "F3R 9I9";

Remarks

This property value is of type String, indicating the postal code or zip code of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

RecordID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : RecordID Property

Gets or sets a non-visible numeric value for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Integer

instance.RecordID = value

value = instance.RecordID
C#
public System.int RecordID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.RecordID = 302
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.RecordID = 302;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the contact. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

State Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : State Property

Gets or sets the state of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.State = value

value = instance.State
C#
public System.string State {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.State = "California"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.State = "California";

Remarks

This property value is of type String, indicating the state of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Subject Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Subject Property

Gets or sets a short description of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
public System.string Subject {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Subject = "Manager"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Subject = "Manager";

Remarks

This property value is of type String, indicating a short description for the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Tag Property

A property where you can store an object relative to the dbiContactItem. Good property for storing datarow or record information.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

TelephoneNumber Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : TelephoneNumber Property

Gets or sets a phone number for the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.TelephoneNumber = value

value = instance.TelephoneNumber
C#
public System.string TelephoneNumber {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.TelephoneNumber = "(204)985-5770"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.TelephoneNumber = "(204)985-5770";

Remarks

This property value is of type String, indicating the phone number of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

Title Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : Title Property

Gets or sets the title or job position of the contact.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.Title = value

value = instance.Title
C#
public System.string Title {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem

newContact.Title = "President"
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
newContact = new Dbi.Pim4.dbiContactItem();

newContact.Title = "President";

Remarks

This property value is of type String, indicating the title of the job or position of the contact.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactItem Class : XMLString Property

Gets or sets an xml string to read or write the contact data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiContactItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Example

Visual Basic Copy Code
Dim newContact As New Dbi.Pim4.dbiContactItem
Dim strXML As String

newContact.XMLString = strXML
C# Copy Code
Dbi.Pim4.dbiContactItem newContact;
string strXML;

newContact = new Dbi.Pim4.dbiContactItem();

newContact.XMLString = strXML;

Remarks

This property value is of type String, indicating an xml string to read or write to the contact.

For additional information, please see Reading and Writing XML Data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactItem Class
dbiContactItem Members


%%PageItemTitle%%

dbiCustomArea Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomArea Class

Provides properties for defining custom areas.

Object Model

dbiCustomArea Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
C#
public class dbiCustomArea

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiCustomArea

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiCustomArea Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomArea Class

"

The following tables list the members exposed by dbiCustomArea.

"

Public Constructors

 | Name | Description
public Constructor | dbiCustomArea Constructor | Overloaded. Initializes a new instance of the CustomArea class.
Top

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the custom area.
public Property | BackColorTo | Gets or sets the secondary background color of the custom area.
public Property | Cargo | Gets or sets a non-visible text value for the custom area.
public Property | ContactID | Gets or sets the ContactID used to filter the custom areas.
public Property | Daily | Determines if the custom area will appear daily.
public Property | Data | Gets or sets a non-visible numeric value for the custom area.
public Property | DeadZone | Determines if the custom area will be a dead zone.
public Property | End | Gets or sets the ending time of the custom area.
public Property | FillType | Gets or sets the background fill pattern of the custom area.
public Property | LocationID | Gets or sets the LocationID used to filter the custom areas.
public Property | Start | Gets or sets the starting time of the custom area.
public Property | Tag | Determines an object that contains data about the dbiCustomArea
public Property | TaskID | Gets or sets the TaskID used to filter the custom areas.
public Property | VertOffset | Determines the vertical offset used when drawing a custom area.
public Property | XMLString | Gets or sets an xml string to read the data from or write the data to the collection.
Top

Public Methods

 | Name | Description
public Method | SetXMLValues | Sets the CustomArea to the XmlNodeList passed into the method.
Top

See Also

Reference

dbiCustomArea Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiCustomArea Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : dbiCustomArea Constructor

Initializes a new instance of the CustomArea class.

Overload List

Overload | Description
dbiCustomArea Constructor() | Initializes a new instance of the CustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Color) | Initializes a new instance of the CustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Color,Boolean) | Initializes a new instance of the CustomArea class.
dbiCustomArea Constructor(DateTime,DateTime,Boolean) | Initializes a new instance of the CustomArea class.
dbiCustomArea Constructor(XmlNodeList) | Initializes a new instance of the CustomArea class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

dbiCustomArea Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor()

Initializes a new instance of the CustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiCustomArea()
C#
public dbiCustomArea()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Color)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Color)

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
clrColor
The background color of the custom area.
Initializes a new instance of the CustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim clrColor As System.Drawing.Color

Dim instance As New dbiCustomArea(dtStart, dtEnd, clrColor)
C#
public dbiCustomArea(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.Drawing.Color clrColor
)

Parameters

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
clrColor
The background color of the custom area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Color,Boolean)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Color,Boolean)

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
clrColor
The background color of the custom area.
bDeadZone
Indicates if the custom area is a dead zone.
Initializes a new instance of the CustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim clrColor As System.Drawing.Color
Dim bDeadZone As System.Boolean

Dim instance As New dbiCustomArea(dtStart, dtEnd, clrColor, bDeadZone)
C#
public dbiCustomArea(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.Drawing.Color clrColor,
   System.bool bDeadZone
)

Parameters

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
clrColor
The background color of the custom area.
bDeadZone
Indicates if the custom area is a dead zone.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(DateTime,DateTime,Boolean)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(DateTime,DateTime,Boolean)

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
bDeadZone
Indicates if the custom area is a dead zone.
Initializes a new instance of the CustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim bDeadZone As System.Boolean

Dim instance As New dbiCustomArea(dtStart, dtEnd, bDeadZone)
C#
public dbiCustomArea(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.bool bDeadZone
)

Parameters

dtStart
The start time of the new custom area.
dtEnd
The end time of the new custom area.
bDeadZone
Indicates if the custom area is a dead zone.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

dbiCustomArea Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class > dbiCustomArea Constructor : dbiCustomArea Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing custom area information.
Initializes a new instance of the CustomArea class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiCustomArea(xmlNodes)
C#
public dbiCustomArea(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing custom area information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Overload List


%%PageItemTitle%%

SetXMLValues Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : SetXMLValues Method

xmlNodes
XmlNodeList
Sets the CustomArea to the XmlNodeList passed into the method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim xmlNodes As System.Xml.XmlNodeList

instance.SetXMLValues(xmlNodes)
C#
public void SetXMLValues(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
XmlNodeList

Return Value

None

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : BackColor Property

Gets or sets the primary background color of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim dtDateTime As DateTime
Dim objCustom As New Dbi.Pim4.CustomArea

dtDateTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 0, 0, 0)
'Set the background color of the custom area
objCustom.BackColor = Color.Red
'This custom area will not occur daily
objCustom.Daily = False
'This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = True
'Set the start time of the custom area
objCustom.Start = dtDateTime
'Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1)
C# Copy Code
System.DateTime dtDateTime;
Dbi.Pim4.CustomArea objCustom;

objCustom = new Dbi.Pim4.CustomArea();

dtDateTime = new System.DateTime(System.DateTime.Today.Year, System.DateTime.Today.Month, System.DateTime.Today.Day, 0, 0, 0);
//Set the background color of the custom area
objCustom.BackColor = System.Drawing.Color.Red;
//This custom area will not occur daily
objCustom.Daily = false;
//This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = true;
//Set the start time of the custom area
objCustom.Start = dtDateTime;
//Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1);

Remarks

The secondary background color is defined by the BackColorTo property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : BackColorTo Property

Gets or sets the secondary background color of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objCustom As New Dbi.Pim4.CustomArea

objCustom.BackColor = System.Drawing.Color.Silver
objCustom.BackColorTo = System.Drawing.Color.WhiteSmoke
objCustom.FillType = Dbi3.enumFillType.Diamond
C# Copy Code
Dbi.Pim4.CustomArea objCustom;
objCustom = new Dbi.Pim4.CustomArea();

objCustom.BackColor = System.Drawing.Color.Silver;
objCustom.BackColorTo = System.Drawing.Color.WhiteSmoke;
objCustom.FillType = Dbi3.enumFillType.Diamond;

Remarks

This property is only applicable when FillType is not equal to Solid. The primary background color is defined by the BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : Cargo Property

Gets or sets a non-visible text value for the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Property Value

String

Example

VB.NET Copy Code
Dim newCustomArea As New Dbi.Pim4.dbiCustomArea

newCustomArea.Cargo = "CustomArea detail"
C# Copy Code
Dbi.Pim4.dbiCustomArea newCustomArea;
newCustomArea = new Dbi.Pim4.dbiCustomArea();

newCustomArea.Cargo = "CustomArea Detail";

Remarks

This property is not visible to the end user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

ContactID Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : ContactID Property

Gets or sets the ContactID used to filter the custom areas.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.String

instance.ContactID = value

value = instance.ContactID
C#
public System.string ContactID {get; set;}

Property Value

A String value, indicating the Contact ID used filter the custom areas.

Remarks

This property must equal a valid contact Entry ID.

NOTE: this property is not applicable to dbiSchedule. At the time of documentation, it is only applicable to the dbiDayView control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas
Working with Entry ID's


%%PageItemTitle%%

Daily Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : Daily Property

Determines if the custom area will appear daily.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Boolean

instance.Daily = value

value = instance.Daily
C#
public System.bool Daily {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim dtDateTime As DateTime
Dim objCustom As New Dbi.Pim4.CustomArea

dtDateTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 0, 0, 0)
'Set the background color of the custom area
objCustom.BackColor = Color.Red
'This custom area will not occur daily
objCustom.Daily = False
'This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = True
'Set the start time of the custom area
objCustom.Start = dtDateTime
'Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1)
C# Copy Code
System.DateTime dtDateTime;
Dbi.Pim4.CustomArea objCustom;

objCustom = new Dbi.Pim4.CustomArea();

dtDateTime = new System.DateTime(System.DateTime.Today.Year, System.DateTime.Today.Month, System.DateTime.Today.Day, 0, 0, 0);
//Set the background color of the custom area
objCustom.BackColor = System.Drawing.Color.Red;
//This custom area will not occur daily
objCustom.Daily = false;
//This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = true;
//Set the start time of the custom area
objCustom.Start = dtDateTime;
//Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1);

Remarks

This property value is of type Boolean, indicating is the custom area will appear daily.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : Data Property

Gets or sets a non-visible numeric value for the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Property Value

Integer

Example

VB.NET Copy Code
Dim newCustomArea As New Dbi.Pim4.dbiCustomArea

newCustomArea.Data = 12345
C# Copy Code
Dbi.Pim4.dbiCustomArea newCustomArea;
newCustomArea = new Dbi.Pim4.dbiCustomArea();

newCustomArea.Data = 12345;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

DeadZone Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : DeadZone Property

Determines if the custom area will be a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Boolean

instance.DeadZone = value

value = instance.DeadZone
C#
public System.bool DeadZone {get; set;}

Property Value

A Boolean value, indicating if the custom area will be considered a "dead zone".

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim dtDateTime As DateTime
Dim objCustom As New Dbi.Pim4.dbiCustomArea

dtDateTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 0, 0, 0)
'Set the background color of the custom area
objCustom.BackColor = Color.Red
'This custom area will not occur daily
objCustom.Daily = False
'This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = True
'Set the start time of the custom area
objCustom.Start = dtDateTime
'Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1)
C# Copy Code
System.DateTime dtDateTime;
Dbi.Pim4.CustomArea objCustom;

objCustom = new Dbi.Pim4.dbiCustomArea();

dtDateTime = new System.DateTime(System.DateTime.Today.Year, System.DateTime.Today.Month, System.DateTime.Today.Day, 0, 0, 0);
//Set the background color of the custom area
objCustom.BackColor = System.Drawing.Color.Red;
//This custom area will not occur daily
objCustom.Daily = false;
//This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = true;
//Set the start time of the custom area
objCustom.Start = dtDateTime;
//Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1);

Remarks

A dead zone is a defined area where appointments and timebars cannot be added or dropped.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas


%%PageItemTitle%%

End Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : End Property

Gets or sets the ending time of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

A DateTime value, indicating the ending time for the custom area.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim dtDateTime As DateTime
Dim objCustom As New Dbi.Pim4.CustomArea

dtDateTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 0, 0, 0)
'Set the background color of the custom area
objCustom.BackColor = Color.Red
'This custom area will not occur daily
objCustom.Daily = False
'This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = True
'Set the start time of the custom area
objCustom.Start = dtDateTime
'Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1)
C# Copy Code
System.DateTime dtDateTime;
Dbi.Pim4.CustomArea objCustom;

objCustom = new Dbi.Pim4.CustomArea();

dtDateTime = new System.DateTime(System.DateTime.Today.Year, System.DateTime.Today.Month, System.DateTime.Today.Day, 0, 0, 0);
//Set the background color of the custom area
objCustom.BackColor = System.Drawing.Color.Red;
//This custom area will not occur daily
objCustom.Daily = false;
//This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = true;
//Set the start time of the custom area
objCustom.Start = dtDateTime;
//Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : FillType Property

Gets or sets the background fill pattern of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public enumFillType FillType {get; set;}

Property Value

A Dbi3.enumFillType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objCustom As New Dbi.Pim4.CustomArea

objCustom.BackColor = System.Drawing.Color.Silver
objCustom.BackColorTo = System.Drawing.Color.WhiteSmoke
objCustom.FillType = Dbi3.enumFillType.Diamond
C# Copy Code
Dbi.Pim4.CustomArea objCustom;
objCustom = new Dbi.Pim4.CustomArea();

objCustom.BackColor = System.Drawing.Color.Silver;
objCustom.BackColorTo = System.Drawing.Color.WhiteSmoke;
objCustom.FillType = Dbi3.enumFillType.Diamond;

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

LocationID Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : LocationID Property

Gets or sets the LocationID used to filter the custom areas.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.String

instance.LocationID = value

value = instance.LocationID
C#
public System.string LocationID {get; set;}

Property Value

A String value, indicating the Location ID used filter the custom areas.

Remarks

This property must equal a valid location Entry ID.

NOTE: this property is not applicable to dbiSchedule. At the time of documentation, it is only applicable to the dbiDayView control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas
Working with Entry ID's


%%PageItemTitle%%

Start Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : Start Property

Gets or sets the starting time of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

A DateTime value indicating the ending time for the custom area.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim dtDateTime As DateTime
Dim objCustom As New Dbi.Pim4.CustomArea

dtDateTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 0, 0, 0)
'Set the background color of the custom area
objCustom.BackColor = Color.Red
'This custom area will not occur daily
objCustom.Daily = False
'This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = True
'Set the start time of the custom area
objCustom.Start = dtDateTime
'Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1)
C# Copy Code
System.DateTime dtDateTime;
Dbi.Pim4.CustomArea objCustom;

objCustom = new Dbi.Pim4.CustomArea();

dtDateTime = new System.DateTime(System.DateTime.Today.Year, System.DateTime.Today.Month, System.DateTime.Today.Day, 0, 0, 0);
//Set the background color of the custom area
objCustom.BackColor = System.Drawing.Color.Red;
//This custom area will not occur daily
objCustom.Daily = false;
//This custom area is a dead zone, therefore no appointments can be dropped into it.
objCustom.DeadZone = true;
//Set the start time of the custom area
objCustom.Start = dtDateTime;
//Set the end time of the custom area
objCustom.End = objCustom.Start.AddHours(1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : Tag Property

Determines an object that contains data about the dbiCustomArea

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

TaskID Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : TaskID Property

Gets or sets the TaskID used to filter the custom areas.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.String

instance.TaskID = value

value = instance.TaskID
C#
public System.string TaskID {get; set;}

Property Value

A String value indicating the Task ID used filter the custom areas.

Remarks

This property must equal a valid task Entry ID.

NOTE: this property is not applicable to dbiSchedule. At the time of documentation, it is only applicable to the dbiDayView control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas
Working with Entry ID's


%%PageItemTitle%%

VertOffset Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : VertOffset Property

Determines the vertical offset used when drawing a custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.Integer

instance.VertOffset = value

value = instance.VertOffset
C#
public System.int VertOffset {get; set;}

Property Value

Integer

Remarks

Positive values will shift the top edge of the CustomArea towards the bottom, and negative values will shift the bottom edge towards the top.

Requirements

This property is currently only used when the dbiCustomArea object is rendered inside the latest version of the dbiSchedule or dbiScheduleE control.

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members


%%PageItemTitle%%

XMLString Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomArea Class : XMLString Property

Gets or sets an xml string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomArea
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value indicating an xml string to read or write to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomArea Class
dbiCustomArea Members
Creating Custom Areas
Reading and Writing XML Data


%%PageItemTitle%%

dbiCustomAreaCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomAreaCollection Class

The collection of custom areas.

Object Model

dbiCustomAreaCollection ClassdbiCustomArea Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
C#
public class dbiCustomAreaCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiCustomAreaCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiCustomAreaCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomAreaCollection Class

"

The following tables list the members exposed by dbiCustomAreaCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiCustomAreaCollection Constructor | Initializes a new instance of the CustomAreaCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new item to the CustomAreaCollection object.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified time bar style within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an xml file.
public Method | XMLString | Gets or sets an xml string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiCustomAreaCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : dbiCustomAreaCollection Constructor

Initializes a new instance of the CustomAreaCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiCustomAreaCollection()
C#
public dbiCustomAreaCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Add Method

obj
The dbiCustomArea object to add to the collection.
Adds a new item to the CustomAreaCollection object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiCustomArea obj
)

Parameters

obj
The dbiCustomArea object to add to the collection.

Return Value

The zero-based index of the item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

IndexOf(dbiCustomArea) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : IndexOf(dbiCustomArea) Method

obj
A dbiCustomArea object to locate in the collection.
Returns the index of a specified time bar style within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiCustomArea obj
)

Parameters

obj
A dbiCustomArea object to locate in the collection.

Return Value

An Integer value representing the index of a specific item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiCustomArea object to insert into the collection.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As System.Integer
Dim obj As dbiCustomArea

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiCustomArea obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiCustomArea object to insert into the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Remove Method

obj
The dbiCustomArea to remove from the collection.
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim obj As dbiCustomArea

instance.Remove(obj)
C#
public void Remove(
   dbiCustomArea obj
)

Parameters

obj
The dbiCustomArea to remove from the collection.

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the xml file.
Writes the data in the collection to an xml file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the xml file.

Return Value

A Boolean value, indicating if the file was written successfully.

Remarks

If no extension is provided in the strFileName parameter, the default extension is .xml

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : XMLString Method

Gets or sets an xml string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

This property value is of type String, indicating an xml string to read or write to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : Item Property

nIndex
The index of the item to get or set in the collection.
Gets or sets the item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCustomAreaCollection
Dim nIndex As System.Integer
Dim value As dbiCustomArea

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiCustomArea this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The index of the item to get or set in the collection.

Property Value

The dbiCustomArea object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%%

dbiDayFormat Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormat Class

Provides properties for defining day formats.

Object Model

dbiDayFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
C#
public class dbiDayFormat

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiDayFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiDayFormat Class Members
See Also Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormat Class

"

The following tables list the members exposed by dbiDayFormat.

"

Public Constructors

 | Name | Description
public Constructor | dbiDayFormat Constructor | Overloaded. Initializes a new instance of the dbiDayFormat class
Top

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the background color of the day format.
public Property | BackColorTo | Gets or sets the secondary background color of the day format.
public Property | ContactID | Gets or sets the unique identification to a contact item.
public Property | Enabled | Determines if a specific date can be selected.
public Property | End | Gets or sets the ending date of the day format.
public Property | FillType | Gets or sets the background pattern of the day format.
public Property | Font | Gets or sets the font for the day format.
public Property | ForeColor | Gets or sets the foreground color of the day format.
public Property | Image | Gets or sets the image to display with the day format.
public Property | LocationID | Gets or sets the unique identification to a location item.
public Property | Start | Gets or sets the starting date of the formatted area.
public Property | TaskID | Gets or sets the unique identification to a task item.
public Property | Text | Gets or sets the general text for a date.
public Property | XMLString | Gets or sets an xml string to read or write the day format data.
Top

See Also

Reference

dbiDayFormat Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiDayFormat Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : dbiDayFormat Constructor

Initializes a new instance of the dbiDayFormat class

Overload List

Overload | Description
dbiDayFormat Constructor() | Initializes a new instance of the dbiDayFormat class
dbiDayFormat Constructor(DateTime,DateTime) | Initializes a new instance of the dbiDayFormat class
dbiDayFormat Constructor(XmlNodeList) | Initializes a new instance of the dbiDayFormat class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

dbiDayFormat Constructor()
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class > dbiDayFormat Constructor : dbiDayFormat Constructor()

Initializes a new instance of the dbiDayFormat class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiDayFormat()
C#
public dbiDayFormat()

Example

Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat()
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members
Overload List


%%PageItemTitle%%

dbiDayFormat Constructor(DateTime,DateTime)
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class > dbiDayFormat Constructor : dbiDayFormat Constructor(DateTime,DateTime)

dtStart
The starting date of the formatted area.
dtEnd
The ending date of the formatted area.
Initializes a new instance of the dbiDayFormat class

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date

Dim instance As New dbiDayFormat(dtStart, dtEnd)
C#
public dbiDayFormat(
   System.DateTime dtStart,
   System.DateTime dtEnd
)

Parameters

dtStart
The starting date of the formatted area.
dtEnd
The ending date of the formatted area.

Example

Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat(today,today.AddDays(2))
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat(DateTime.Today, DateTime.Today.AddDays(2));

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members
Overload List


%%PageItemTitle%%

dbiDayFormat Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class > dbiDayFormat Constructor : dbiDayFormat Constructor(XmlNodeList)

xmlNodes
The XMLNodeList used to populate the day formats.
Initializes a new instance of the dbiDayFormat class

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiDayFormat(xmlNodes)
C#
public dbiDayFormat(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList used to populate the day formats.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members
Overload List


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : BackColor Property

Gets or sets the background color of the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type Color, indicating the primary background color of the day format. The secondary background color is defined in the BackColorTo property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : BackColorTo Property

Gets or sets the secondary background color of the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type Color, indicating the secondary background color of the day format. This property will only be visible if FillType is not equal to Solid. The primary background color is defined in the BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

ContactID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : ContactID Property

Gets or sets the unique identification to a contact item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.String

instance.ContactID = value

value = instance.ContactID
C#
public System.string ContactID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat
newDayFormat.ContactID = "ID12345"
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.ContactID = "ID12345";

Remarks

This property value is of type String, indicating a unique identification to a contact item. This property will be used for filtering the day formats in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

Enabled Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : Enabled Property

Determines if a specific date can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat newDayFormat()
newDayFormat.Enabled = False
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.Enabled = false;

Remarks

This property value is of type Boolean, indicating if the specified date can be selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

End Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : End Property

Gets or sets the ending date of the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type DateTime, indicating the ending date for the day format. The starting date is defined in the Start property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : FillType Property

Gets or sets the background pattern of the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type Dbi.enumFillType, indicating the background pattern of a specified date. The primary and secondary background color are defined by the BackColor and BackColorTo properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : Font Property

Gets or sets the font for the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat newDayFormat()
newDayFormat.Font = New Font("Verdana",8)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.Font = new Font("Verdana",8);

Remarks

This property value is of type Font, indicating the font of the day format.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : ForeColor Property

Gets or sets the foreground color of the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type Color, indicating the foreground color of the day format.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

Image Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : Image Property

Gets or sets the image to display with the day format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Integer

instance.Image = value

value = instance.Image
C#
public System.int Image {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat
newDayFormat.Image = -3
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.Image = -3;

Remarks

This property value is of type Integer, indicating the image to display with the day format.

For additional information on using images, please refer to Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

LocationID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : LocationID Property

Gets or sets the unique identification to a location item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.String

instance.LocationID = value

value = instance.LocationID
C#
public System.string LocationID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat
newDayFormat.LocationID = "Location203"
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.LocationID = "Location203";

Remarks

This property value is of type String, indicating a unique identification to a location item. This property will be used for filtering the day formats in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

Start Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : Start Property

Gets or sets the starting date of the formatted area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

'Set the background color for the day
newDayFormat.BackColor = Color.Aqua
'Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White
'Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal
'Set the fore color
newDayFormat.ForeColor = Color.Navy

'Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1)
newDayFormat.End = DateTime.Today.AddDays(3)
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

//Set the background color for the day
newDayFormat.BackColor = Color.Aqua;
//Set the secondary background color of the day
newDayFormat.BackColorTo = Color.White;
//Set the background fills style
newDayFormat.FillType = Dbi.enumFillType.Diagonal;
//Set the fore color
newDayFormat.ForeColor = Color.Navy;

//Set the date range for the day format
newDayFormat.Start = DateTime.Today.AddDays(1);
newDayFormat.End = DateTime.Today.AddDays(3);

Remarks

This property value is of type DateTime, indicating the starting date for the formatted area. The ending date is defined in the End property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

TaskID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : TaskID Property

Gets or sets the unique identification to a task item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.String

instance.TaskID = value

value = instance.TaskID
C#
public System.string TaskID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat
newDayFormat.TaskID = "TaskID5"
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.TaskID = "TaskID5";

Remarks

This property value is of type String, indicating a unique identification to a task item. This property will be used for filtering the day formats in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

Text Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : Text Property

Gets or sets the general text for a date.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat

newDayFormat.Text = "Staff Meeting"
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.Text = "Staff Meeting";

Remarks

This property value is of type String, indicating the general text for the date.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormat Class : XMLString Property

Gets or sets an xml string to read or write the day format data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormat
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Example

Visual Basic Copy Code
Dim newDayFormat As New Dbi.Pim4.dbiDayFormat
Dim strXML As String

newDayFormat.XMLString = strXML
C# Copy Code
Dbi.Pim4.dbiDayFormat newDayFormat;
string strXML;

newDayFormat = new Dbi.Pim4.dbiDayFormat();

newDayFormat.XMLString = strXML;

Remarks

This property value is of type String, indicating an xml string to read or write to the day format.

For additional information, please see Reading and Writing XML Data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormat Class
dbiDayFormat Members


%%PageItemTitle%%

dbiDayFormatCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormatCollection Class

The collection of DayFormats.

Object Model

dbiDayFormatCollection ClassdbiDayFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
C#
public class dbiDayFormatCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiDayFormatCollection

Requirements

Must use PIM as the data source for the DBI controls.

See Also

Reference

dbiDayFormatCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiDayFormatCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormatCollection Class

"

The following tables list the members exposed by dbiDayFormatCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiDayFormatCollection Constructor | Initializes a new instance of the dbiDayFormatCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiContactItem at a specific index value.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiDayFormat to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiDayFormat.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiDayFormatCollection collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiDayFormatCollection collection.
Top

See Also

Reference

dbiDayFormatCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiDayFormatCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : dbiDayFormatCollection Constructor

Initializes a new instance of the dbiDayFormatCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiDayFormatCollection()
C#
public dbiDayFormatCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Add Method

item
The dbiDayFormat to add to the collection.
Add a dbiDayFormat to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim item As dbiDayFormat
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   dbiDayFormat item
)

Parameters

item
The dbiDayFormat to add to the collection.

Return Value

An integer indicating the index of the dbiContactItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Contains Method

item
dbiDayFormat
Determines if the Contact collection contains a specific dbiDayFormat.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim item As dbiDayFormat
Dim value As System.Boolean

value = instance.Contains(item)
C#
public System.bool Contains(
   dbiDayFormat item
)

Parameters

item
dbiDayFormat

Return Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

IndexOf(dbiDayFormat) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : IndexOf(dbiDayFormat) Method

item
dbiDayFormat
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim item As dbiDayFormat
Dim value As System.Integer

value = instance.IndexOf(item)
C#
public System.int IndexOf(
   dbiDayFormat item
)

Parameters

item
dbiDayFormat

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
item
The dbiDayFormat to insert.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim nIndex As System.Integer
Dim item As dbiDayFormat

instance.Insert(nIndex, item)
C#
public void Insert(
   System.int nIndex,
   dbiDayFormat item
)

Parameters

nIndex
The zero-based index location where the item is inserted.
item
The dbiDayFormat to insert.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Remove Method

item
dbiDayFormat
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim item As dbiDayFormat

instance.Remove(item)
C#
public void Remove(
   dbiDayFormat item
)

Parameters

item
dbiDayFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : WriteXMLFile Method

strFileName
The fully qualified file name used to write the data.
Creates an XML File containing the dbiDayFormatCollection collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified file name used to write the data.

Return Value

Boolean value indicating if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : XMLString Method

Creates a string that contains the XML information for the dbiDayFormatCollection collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value containing an XML formatted version of the dbiDayFormatCollection collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : Item Property

nIndex
Integer
Gets or sets the dbiContactItem at a specific index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiDayFormatCollection
Dim nIndex As System.Integer
Dim value As dbiDayFormat

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiDayFormat this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
Integer

Property Value

dbiContactItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%%

dbiLocationCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationCollection Class

The collection of Locations.

Object Model

dbiLocationCollection ClassdbiLocationItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
C#
public class dbiLocationCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiLocationCollection

Requirements

Must use PIM as the data source for the DBI controls.

See Also

Reference

dbiLocationCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiLocationCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationCollection Class

"

The following tables list the members exposed by dbiLocationCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiLocationCollection Constructor | Initializes a new instance of the dbiLocationCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiLocationItem at a specific index value.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiLocationItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiLocationItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiLocationCollection collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiLocationCollection collection.
Top

See Also

Reference

dbiLocationCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiLocationCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : dbiLocationCollection Constructor

Initializes a new instance of the dbiLocationCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiLocationCollection()
C#
public dbiLocationCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Add Method

item
The dbiLocationItem to add to the collection.
Add a dbiLocationItem to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim item As dbiLocationItem
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   dbiLocationItem item
)

Parameters

item
The dbiLocationItem to add to the collection.

Return Value

An integer indicating the index of the dbiContactItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Contains Method

item
dbiLocationItem
Determines if the Contact collection contains a specific dbiLocationItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim item As dbiLocationItem
Dim value As System.Boolean

value = instance.Contains(item)
C#
public System.bool Contains(
   dbiLocationItem item
)

Parameters

item
dbiLocationItem

Return Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

IndexOf(dbiLocationItem) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : IndexOf(dbiLocationItem) Method

item
dbiLocationItem
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim item As dbiLocationItem
Dim value As System.Integer

value = instance.IndexOf(item)
C#
public System.int IndexOf(
   dbiLocationItem item
)

Parameters

item
dbiLocationItem

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Remove Method

item
dbiLocationItem
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim item As dbiLocationItem

instance.Remove(item)
C#
public void Remove(
   dbiLocationItem item
)

Parameters

item
dbiLocationItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : WriteXMLFile Method

strFileName
The fully qualified file name used to write the data.
Creates an XML File containing the dbiLocationCollection collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified file name used to write the data.

Return Value

Boolean value indicating if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : XMLString Method

Creates a string that contains the XML information for the dbiLocationCollection collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value containing an XML formatted version of the dbiDayFormatCollection collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : Item Property

nIndex
Integer
Gets or sets the dbiLocationItem at a specific index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationCollection
Dim nIndex As System.Integer
Dim value As dbiLocationItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiLocationItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
Integer

Property Value

dbiLocationItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%%

dbiLocationItem Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationItem Class

Provides properties for defining locations.

Object Model

dbiLocationItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
C#
public class dbiLocationItem

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiLocationItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiLocationItem Class Members
See Also Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationItem Class

"

The following tables list the members exposed by dbiLocationItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiLocationItem Constructor | Overloaded. Initializes a new instance of the dbiLocationItem class
Top

Public Properties

 | Name | Description
public Property | Address | Gets or sets the primary address of the location.
public Property | Address2 | Gets or sets the seconary address of the location.
public Property | BackColor | Gets or sets the background color of the location.
public Property | BackColorTo | Gets or sets the secondary background color of the location.
public Property | Cargo | Gets or sets a non-visible text value for the location.
public Property | City | Gets or sets the city of the location.
public Property | Country | Gets or sets the country of the location
public Property | Data | Gets or sets a non-visible numeric value for the location.
public Property | EntryID | Gets or sets a non-visible text value for the location.
public Property | ForeColor | Gets or sets the fore color of the location.
public Property | Image | Gets or sets the image to display with the location.
public Property | RecordID | Gets or sets a hidden numeric value for the location.
public Property | State | Gets or sets the state of the location.
public Property | Tag | Determines an object that contains data about the dbiLocationItem
public Property | Title | Gets or sets the name of the location.
public Property | XMLString | Gets or sets an xml string to read the location data or write the location data.
public Property | ZipCode | Gets or sets the zip code of the location.
Top

See Also

Reference

dbiLocationItem Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiLocationItem Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : dbiLocationItem Constructor

Initializes a new instance of the dbiLocationItem class

Overload List

Overload | Description
dbiLocationItem Constructor() | Initializes a new instance of the dbiLocationItem class
dbiLocationItem Constructor(String) | Initializes a new instance of the dbiLocationItem class
dbiLocationItem Constructor(String,String) | Initializes a new instance of the dbiLocationItem class
dbiLocationItem Constructor(dbiLocationItem) | Initializes a new instance of the dbiLocationItem class
dbiLocationItem Constructor(XmlNodeList) | Initializes a new instance of the dbiLocationItem class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

dbiLocationItem Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class > dbiLocationItem Constructor : dbiLocationItem Constructor()

Initializes a new instance of the dbiLocationItem class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiLocationItem()
C#
public dbiLocationItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Overload List


%%PageItemTitle%%

dbiLocationItem Constructor(String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class > dbiLocationItem Constructor : dbiLocationItem Constructor(String)

strTitle
The name of the location.
Initializes a new instance of the dbiLocationItem class

Syntax

Visual Basic (Usage) Copy Code
Dim strTitle As System.String

Dim instance As New dbiLocationItem(strTitle)
C#
public dbiLocationItem(
   System.string strTitle
)

Parameters

strTitle
The name of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Overload List


%%PageItemTitle%%

dbiLocationItem Constructor(String,String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class > dbiLocationItem Constructor : dbiLocationItem Constructor(String,String)

strTitle
The name of the location.
strEntryID
The EntryID of the location.
Initializes a new instance of the dbiLocationItem class

Syntax

Visual Basic (Usage) Copy Code
Dim strTitle As System.String
Dim strEntryID As System.String

Dim instance As New dbiLocationItem(strTitle, strEntryID)
C#
public dbiLocationItem(
   System.string strTitle,
   System.string strEntryID
)

Parameters

strTitle
The name of the location.
strEntryID
The EntryID of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Overload List


%%PageItemTitle%%

dbiLocationItem Constructor(dbiLocationItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class > dbiLocationItem Constructor : dbiLocationItem Constructor(dbiLocationItem)

objLocation
The dbiLocationItem containing location information.
Initializes a new instance of the dbiLocationItem class

Syntax

Visual Basic (Usage) Copy Code
Dim objLocation As dbiLocationItem

Dim instance As New dbiLocationItem(objLocation)
C#
public dbiLocationItem(
   dbiLocationItem objLocation
)

Parameters

objLocation
The dbiLocationItem containing location information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Overload List


%%PageItemTitle%%

dbiLocationItem Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class > dbiLocationItem Constructor : dbiLocationItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing location information.
Initializes a new instance of the dbiLocationItem class

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiLocationItem(xmlNodes)
C#
public dbiLocationItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing location information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Overload List


%%PageItemTitle%%

Address Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Address Property

Gets or sets the primary address of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.Address = value

value = instance.Address
C#
public System.string Address {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Address = "123 Main St."
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Address = "123 Main St.";

Remarks

This property value is of type String, indicating the primary address of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Address2 Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Address2 Property

Gets or sets the seconary address of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.Address2 = value

value = instance.Address2
C#
public System.string Address2 {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Address2 = "Suite 100"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Address2 = "Suite 100";

Remarks

This property value is of type String, indicating the secondary address of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : BackColor Property

Gets or sets the background color of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.BackColor = System.Drawing.Color.White
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.BackColor = System.Drawing.Color.White;

Remarks

This property value is of type Color, indicating the color used to paint the background of the location when you are displaying by location in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : BackColorTo Property

Gets or sets the secondary background color of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.BackColorTo = System.Drawing.Color.Silver
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.BackColorTo = System.Drawing.Color.Silver;

Remarks

This property value is of type Color, indicating the secondary color used to paint the background of the location when you are displaying by location in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Cargo Property

Gets or sets a non-visible text value for the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Cargo = "Key Data"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Cargo = "Key Data";

Remarks

This property value is of type String, indicating a non-visible text value for the location. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

City Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : City Property

Gets or sets the city of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.City = value

value = instance.City
C#
public System.string City {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.City = "Toronto"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.City = "Toronto";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Country Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Country Property

Gets or sets the country of the location

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.Country = value

value = instance.Country
C#
public System.string Country {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Country = "Canada"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Country = "Canada";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Data Property

Gets or sets a non-visible numeric value for the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Data = 12345
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Data = 12345;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the location. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

EntryID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : EntryID Property

Gets or sets a non-visible text value for the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.EntryID = value

value = instance.EntryID
C#
public System.string EntryID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.EntryID = "DBIID987"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.EntryID = "DBIID987";

Remarks

This property value is of type String, indicating a non-visible text value for the location. This property is used to relate the locations to the appointments. It is also used to filtering the displayed appointments within the controls. It is recommended that the Record ID is stored as a string in this property. If this property is not manually defined, a value will be generated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members
Working with Entry ID's


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : ForeColor Property

Gets or sets the fore color of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.ForeColor = System.Drawing.Color.Black
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.ForeColor = System.Drawing.Color.Black;

Remarks

This property value is of type Color, indicating the fore color of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Image Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Image Property

Gets or sets the image to display with the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Integer

instance.Image = value

value = instance.Image
C#
public System.int Image {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Image = -5
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Image = -5;

Remarks

This property value is of type Integer, indicating the index of the image to display with the location.

For additional information on using images, please refer to Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

RecordID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : RecordID Property

Gets or sets a hidden numeric value for the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Integer

instance.RecordID = value

value = instance.RecordID
C#
public System.int RecordID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.RecordID = 354
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.RecordID = 345;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the location. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

State Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : State Property

Gets or sets the state of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.State = value

value = instance.State
C#
public System.string State {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.State = "California"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.State = "California";

Remarks

This property value is of type String, indicating the state of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Tag Property

Determines an object that contains data about the dbiLocationItem

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

Title Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : Title Property

Gets or sets the name of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.Title = value

value = instance.Title
C#
public System.string Title {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.Title = "Boardroom"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.Tite = "Boardroom";

Remarks

This property value is of type String, indicating the name of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : XMLString Property

Gets or sets an xml string to read the location data or write the location data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Example

Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
Dim strXML As String

newLocation.XMLString = strXML
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
string strXML;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.XMLString = strXML;

Remarks

This property value is of type String, indicating an xml string to read or write to the location.

For additional information, please see Reading and Writing XML Data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

ZipCode Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationItem Class : ZipCode Property

Gets or sets the zip code of the location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLocationItem
Dim value As System.String

instance.ZipCode = value

value = instance.ZipCode
C#
public System.string ZipCode {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newLocation As New Dbi.Pim4.dbiLocationItem
newLocation.ZipCode = "12345"
C# Copy Code
Dbi.Pim4.dbiLocationItem newLocation;
newLocation = new Dbi.Pim4.dbiLocationItem();

newLocation.ZipCode = "12345";

Remarks

This property value is of type String, indicating the zip code of the location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationItem Class
dbiLocationItem Members


%%PageItemTitle%%

dbiPIM Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM Class

A repository class for the base classes used in the collaboration architecture with some dbi Calendar based controls.

Object Model

dbiPIM ClassAlarmItemCollection ClassdbiAppointmentItem ClassdbiAppointmentCollection ClassdbiAppointmentItem ClassdbiContactCollection ClassdbiContactItem ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiLocationCollection ClassdbiLocationItem ClassdbiTaskCollection ClassdbiTaskItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
C#
public class dbiPIM : System.ComponentModel.Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Dbi.PIM.dbiPIM

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiPIM Class Members
See Also Properties Methods Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM Class

"

The following tables list the members exposed by dbiPIM.

"

Public Constructors

 | Name | Description
public Constructor | dbiPIM Constructor | Initializes a new instance of the dbiPIM class.
Top

Public Properties

 | Name | Description
public Property | AlarmAutoClear | Determines if the appointments will automatically be cleared from the collection after their alarm has been triggered.
public Property | AlarmInterval | Determines how often to review the alarms collection.
public Property | Alarms | Gets the alarms in dbiPIM.
public Property | Appointments | Collection of Appointments in dbiPIM
public Property | Contacts | Collection of Contacts in dbiPIM
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | CustomAreas | Collection of CustomAreas in dbiPIM
public Property | Locations | Collection of Locations in dbiPIM
public Property | ReminderDialog | Determines if the ReminderDialog will be displayed when an alarm is triggered.
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Tasks | Collection of Tasks in dbiPIM
Top

Public Methods

 | Name | Description
public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

Public Events

 | Name | Description
public Event | Alarm | Occurs when an alarm is triggered.
Top

See Also

Reference

dbiPIM Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiPIM Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : dbiPIM Constructor

Initializes a new instance of the dbiPIM class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiPIM()
C#
public dbiPIM()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

AlarmAutoClear Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : AlarmAutoClear Property

Determines if the appointments will automatically be cleared from the collection after their alarm has been triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.Boolean

instance.AlarmAutoClear = value

value = instance.AlarmAutoClear
C#
public virtual System.bool AlarmAutoClear {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Me.dbiPIM.AlarmAutoClear = True
C# Copy Code
this.dbiPim.AlarmAutoClear = true;

Remarks

This property value is of type Boolean, indicating if the appointment will be removed from the alarm collection once they have been triggered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

AlarmInterval Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : AlarmInterval Property

Determines how often to review the alarms collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.Integer

instance.AlarmInterval = value

value = instance.AlarmInterval
C#
public virtual System.int AlarmInterval {get; set;}

Remarks

This property value is of type Integer, indicating, in milliseconds how ofter to review the alarms collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Alarms Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Alarms Property

Gets the alarms in dbiPIM.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As AlarmItemCollection

value = instance.Alarms
C#
public AlarmItemCollection Alarms {get;}

Remarks

This property value is of type AlarmItemCollection, representing the appointment in dbiMonth.

This property enables you to obtain a reference to the alarm items that are stored in dbiPIM. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the item collection, see the AlarmItemCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Appointments Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Appointments Property

Collection of Appointments in dbiPIM

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As dbiAppointmentCollection

value = instance.Appointments
C#
public dbiAppointmentCollection Appointments {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Contacts Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Contacts Property

Collection of Contacts in dbiPIM

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As dbiContactCollection

value = instance.Contacts
C#
public dbiContactCollection Contacts {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

CustomAreas Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : CustomAreas Property

Collection of CustomAreas in dbiPIM

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As dbiCustomAreaCollection

value = instance.CustomAreas
C#
public dbiCustomAreaCollection CustomAreas {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Locations Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Locations Property

Collection of Locations in dbiPIM

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As dbiLocationCollection

value = instance.Locations
C#
public dbiLocationCollection Locations {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

ReminderDialog Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : ReminderDialog Property

Determines if the ReminderDialog will be displayed when an alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.Boolean

instance.ReminderDialog = value

value = instance.ReminderDialog
C#
public virtual System.bool ReminderDialog {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Me.dbiPim.ReminderDialog = True
C# Copy Code
this.dbiPim.ReminderDialog = true;

Remarks

This property value is of type Boolean, indicating if the ReminderDialog will be displayed when an alarm is triggered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Tasks Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Tasks Property

Collection of Tasks in dbiPIM

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As dbiTaskCollection

value = instance.Tasks
C#
public dbiTaskCollection Tasks {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Alarm Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Alarm Event

Occurs when an alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim handler As dbiPIM.EventAlarmHandler

AddHandler instance.Alarm, handler
C#
public event dbiPIM.EventAlarmHandler Alarm

Event Data

The event handler receives an argument of type AlarmEventArgs containing data related to this event. The following AlarmEventArgs properties provide information specific to this event.

Property | Description
Appointment | The dbiAppointmentItem triggering the alarm.
Index | The index value of the alarm.

Remarks

The event handler receives an argument of type AlarmEventArgs containing data related to this event. The following AlarmEventArgs properties provide specific information to this event.

Properties | Description
Appointment | The dbiAppointmentItem triggering the alarm.
Index | The index value of the alarm

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

dbiReminderDialog Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog Class

The default reminder dialog.

Object Model

dbiReminderDialog ClassdbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
C#
public class dbiReminderDialog : System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Dbi.PIM.dbiReminderDialog

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiReminderDialog Class Members
See Also Properties Methods Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog Class

"

The following tables list the members exposed by dbiReminderDialog.

"

Public Constructors

 | Name | Description
public Constructor | dbiReminderDialog Constructor | Overloaded. Initializes a new instance of the dbiReminderDialog class.
Top

Public Properties

 | Name | Description
public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from System.Windows.Forms.Form)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from System.Windows.Forms.Form)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from System.Windows.Forms.Form)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Appointment | Gets or sets the appointment to display in the reminder dialog.
public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from System.Windows.Forms.Form)
public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoSize | Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode. (Inherited from System.Windows.Forms.Form)
public Property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from System.Windows.Forms.Form)
public Property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from System.Windows.Forms.Form)
public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Form)
public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from System.Windows.Forms.Form)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from System.Windows.Forms.Form)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DialogResult | Gets or sets the dialog result for the form. (Inherited from System.Windows.Forms.Form)
public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
public Property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from System.Windows.Forms.Form)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from System.Windows.Forms.Form)
public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Icon | Gets or sets the icon for the form. (Inherited from System.Windows.Forms.Form)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from System.Windows.Forms.Form)
public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from System.Windows.Forms.Form)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from System.Windows.Forms.Form)
public Property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from System.Windows.Forms.Form)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates. (Inherited from System.Windows.Forms.Form)
public Property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from System.Windows.Forms.Form)
public Property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from System.Windows.Forms.Form)
public Property | Menu | Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form. (Inherited from System.Windows.Forms.Form)
public Property | MergedMenu | Gets the merged menu for the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from System.Windows.Forms.Form)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Opacity | Gets or sets the opacity level of the form. (Inherited from System.Windows.Forms.Form)
public Property | OwnedForms | Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form. (Inherited from System.Windows.Forms.Form)
public Property | Owner | Gets or sets the form that owns this form. (Inherited from System.Windows.Forms.Form)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ReminderState | Gets the state of the reminder dialog.
public Property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from System.Windows.Forms.Form)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from System.Windows.Forms.Form)
public Property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from System.Windows.Forms.Form)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the size of the form. (Inherited from System.Windows.Forms.Form)
public Property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from System.Windows.Forms.Form)
public Property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from System.Windows.Forms.Form)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Form)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from System.Windows.Forms.Form)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from System.Windows.Forms.Form)
public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from System.Windows.Forms.Form)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
public Method | Activate | Activates the form and gives it focus. (Inherited from System.Windows.Forms.Form)
public Method | AddOwnedForm | Adds an owned form to this form. (Inherited from System.Windows.Forms.Form)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ClearState | Clears the ReminderState property.
public Method | Close | Closes the form. (Inherited from System.Windows.Forms.Form)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from System.Windows.Forms.Form)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from System.Windows.Forms.Form)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | Show | Overloaded. Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
public Method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Gets a string representing the current instance of the form. (Inherited from System.Windows.Forms.Form)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from System.Windows.Forms.Form)
public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.Form.AutoSize property changes. (Inherited from System.Windows.Forms.Form)
public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.Form.AutoValidate property changes. (Inherited from System.Windows.Forms.Form)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from System.Windows.Forms.Form)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | FormClosed | Occurs after the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | FormClosing | Occurs before the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from System.Windows.Forms.Form)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from System.Windows.Forms.Form)
public Event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from System.Windows.Forms.Form)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | Load | Occurs before a form is displayed for the first time. (Inherited from System.Windows.Forms.Form)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MaximizedBoundsChanged | Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MaximumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from System.Windows.Forms.Form)
public Event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from System.Windows.Forms.Form)
public Event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from System.Windows.Forms.Form)
public Event | MinimumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftLayoutChanged | Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.Form)
public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
public Event | Shown | Occurs whenever the form is first displayed. (Inherited from System.Windows.Forms.Form)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiReminderDialog Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiReminderDialog Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : dbiReminderDialog Constructor

Initializes a new instance of the dbiReminderDialog class.

Overload List

Overload | Description
dbiReminderDialog Constructor() | Initializes a new instance of the dbiReminderDialog class.
dbiReminderDialog Constructor(dbiAppointmentItem) | Initializes a new instance of the dbiReminderDialog class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

dbiReminderDialog Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > dbiReminderDialog Constructor : dbiReminderDialog Constructor()

Initializes a new instance of the dbiReminderDialog class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiReminderDialog()
C#
public dbiReminderDialog()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

dbiReminderDialog Constructor(dbiAppointmentItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > dbiReminderDialog Constructor : dbiReminderDialog Constructor(dbiAppointmentItem)

objAppoint
The dbiAppointmentItem used to populate the dialog.
Initializes a new instance of the dbiReminderDialog class.

Syntax

Visual Basic (Usage) Copy Code
Dim objAppoint As dbiAppointmentItem

Dim instance As New dbiReminderDialog(objAppoint)
C#
public dbiReminderDialog(
   dbiAppointmentItem objAppoint
)

Parameters

objAppoint
The dbiAppointmentItem used to populate the dialog.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ClearState Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ClearState Method

Clears the ReminderState property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.ClearState()
C#
public void ClearState()

Remarks

This method will clear the ReminderState property. There is no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CreateControl() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PerformAutoScale Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PerformAutoScale Method

Performs scaling of the container control and its children.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ValidateChildren Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ValidateChildren Method

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Appointment Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Appointment Property

Gets or sets the appointment to display in the reminder dialog.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As dbiAppointmentItem

instance.Appointment = value

value = instance.Appointment
C#
public dbiAppointmentItem Appointment {get; set;}

Remarks

This property value is of type dbiAppointmentItem, indicating the appointment to display in the dialog.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScaleDimensions Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScaleDimensions Property

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.SizeF

instance.AutoScaleDimensions = value

value = instance.AutoScaleDimensions
C#
public System.Drawing.SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScaleMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScaleMode Property

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AutoScaleMode

instance.AutoScaleMode = value

value = instance.AutoScaleMode
C#
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoSize Property

Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
public virtual System.bool AutoSize {get; set;}

Property Value

true if the form will automatically resize; false if it must be manually resized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoSizeMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoSizeMode Property

Gets or sets the mode by which the form automatically resizes itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}

Property Value

An System.Windows.Forms.AutoSizeMode enumerated value. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value is not a valid System.Windows.Forms.AutoSizeMode value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoValidate Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoValidate Property

Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}

Property Value

An System.Windows.Forms.AutoValidate enumerated value that indicates whether contained controls are implicitly validated on focus change. The default is Inherit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackgroundImageLayout Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CurrentAutoScaleDimensions Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CurrentAutoScaleDimensions Property

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.SizeF

value = instance.CurrentAutoScaleDimensions
C#
public System.Drawing.SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DeviceDpi Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HorizontalScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HorizontalScroll Property

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.HScrollProperties

value = instance.HorizontalScroll
C#
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsMirrored Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

LayoutEngine Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MainMenuStrip Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MainMenuStrip Property

Gets or sets the primary menu container for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}

Property Value

A System.Windows.Forms.MenuStrip that represents the container for the menu structure of the form. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Padding Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Padding Property

Gets or sets padding within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
public System.Windows.Forms.Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PreferredSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ReminderState Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ReminderState Property

Gets the state of the reminder dialog.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As dbiReminderDialog.enumReminderState

instance.ReminderState = value

value = instance.ReminderState
C#
public dbiReminderDialog.enumReminderState ReminderState {get; set;}

Remarks

This property value is of type dbiReminderDialog.enumReminderState, indicating the last button pressed in the reminder dialog before it was closed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RestoreBounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RestoreBounds Property

Gets the location and size of the form in its normal window state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Rectangle

value = instance.RestoreBounds
C#
public System.Drawing.Rectangle RestoreBounds {get;}

Property Value

A System.Drawing.Rectangle that contains the location and size of the form in the normal window state.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RightToLeftLayout Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RightToLeftLayout Property

Gets or sets a value indicating whether right-to-left mirror placement is turned on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
public virtual System.bool RightToLeftLayout {get; set;}

Property Value

true if right-to-left mirror placement is turned on; otherwise, false for standard child control placement. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ShowIcon Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ShowIcon Property

Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
public System.bool ShowIcon {get; set;}

Property Value

true if the form displays an icon in the caption bar; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

VerticalScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : VerticalScroll Property

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.VScrollProperties

value = instance.VerticalScroll
C#
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoSizeChanged Event

Occurs when the System.Windows.Forms.Form.AutoSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
public event System.EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoValidateChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoValidateChanged Event

Occurs when the System.Windows.Forms.Form.AutoValidate property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
public event System.EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackgroundImageLayoutChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackgroundImageLayoutChanged Event

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event System.EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DpiChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DpiChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.DpiChangedEventHandler

AddHandler instance.DpiChanged, handler
C#
public event System.Windows.Forms.DpiChangedEventHandler DpiChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.DpiChangedEventArgs containing data related to this event. The following DpiChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
DeviceDpiNew |
DeviceDpiOld |
SuggestedRectangle |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

FormClosed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : FormClosed Event

Occurs after the form is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
public event System.Windows.Forms.FormClosedEventHandler FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

FormClosing Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : FormClosing Event

Occurs before the form is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
public event System.Windows.Forms.FormClosingEventHandler FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HelpButtonClicked Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HelpButtonClicked Event

Occurs when the Help button is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
public event System.ComponentModel.CancelEventHandler HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PaddingChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PaddingChanged Event

Occurs when the control's padding changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event System.EventHandler PaddingChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RegionChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ResizeBegin Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ResizeBegin Event

Occurs when a form enters resizing mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
public event System.EventHandler ResizeBegin

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ResizeEnd Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ResizeEnd Event

Occurs when a form exits resizing mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
public event System.EventHandler ResizeEnd

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RightToLeftLayoutChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RightToLeftLayoutChanged Event

Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
public event System.EventHandler RightToLeftLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Scroll Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Scroll Event

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
public event System.Windows.Forms.ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Shown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Shown Event

Occurs whenever the form is first displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
public event System.EventHandler Shown

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

dbiTaskCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskCollection Class

The collection of Tasks.

Object Model

dbiTaskCollection ClassdbiTaskItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
C#
public class dbiTaskCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.dbiTaskCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiTaskCollection Class Members
See Also Properties Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskCollection Class

"

The following tables list the members exposed by dbiTaskCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiTaskCollection Constructor | Initializes a new instance of the dbiTaskCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiTaskItem at a specific index value.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiTaskItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiTaskItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiTaskItem collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiTaskCollection collection.
Top

See Also

Reference

dbiTaskCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiTaskCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : dbiTaskCollection Constructor

Initializes a new instance of the dbiTaskCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTaskCollection()
C#
public dbiTaskCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Add Method

item
The dbiTaskItem to add to the collection.
Add a dbiTaskItem to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim item As dbiTaskItem
Dim value As System.Integer

value = instance.Add(item)
C#
public System.int Add(
   dbiTaskItem item
)

Parameters

item
The dbiTaskItem to add to the collection.

Return Value

An integer indicating the index of the dbiContactItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Contains Method

item
dbiTaskItem
Determines if the Contact collection contains a specific dbiTaskItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim item As dbiTaskItem
Dim value As System.Boolean

value = instance.Contains(item)
C#
public System.bool Contains(
   dbiTaskItem item
)

Parameters

item
dbiTaskItem

Return Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

IndexOf(dbiTaskItem) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : IndexOf(dbiTaskItem) Method

item
dbiTaskItem
Returns the index of a specified item within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim item As dbiTaskItem
Dim value As System.Integer

value = instance.IndexOf(item)
C#
public System.int IndexOf(
   dbiTaskItem item
)

Parameters

item
dbiTaskItem

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Remove Method

item
dbiTaskItem
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim item As dbiTaskItem

instance.Remove(item)
C#
public void Remove(
   dbiTaskItem item
)

Parameters

item
dbiTaskItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : WriteXMLFile Method

strFileName
The fully qualified file name used to write the data.
Creates an XML File containing the dbiTaskItem collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified file name used to write the data.

Return Value

Boolean value indicating if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : XMLString Method

Creates a string that contains the XML information for the dbiTaskCollection collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value containing an XML formatted version of the dbiDayFormatCollection collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : Item Property

nIndex
Integer
Gets or sets the dbiTaskItem at a specific index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskCollection
Dim nIndex As System.Integer
Dim value As dbiTaskItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiTaskItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
Integer

Property Value

dbiTaskItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%%

dbiTaskItem Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskItem Class

Provides properties for defining Tasks.

Object Model

dbiTaskItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
C#
public class dbiTaskItem

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiTaskItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiTaskItem Class Members
See Also Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskItem Class

"

The following tables list the members exposed by dbiTaskItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiTaskItem Constructor | Overloaded. Initializes a new instance of the dbiTaskItem class.
Top

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the task.
public Property | BackColorTo | Gets or sets the secondary background color of the task.
public Property | Body | Gets or sets additional information for the task.
public Property | Cargo | Gets or sets a non-visible text value for the task.
public Property | Categories | Gets or sets the category of the task.
public Property | Complete | Determines if the task has been completed.
public Property | Data | Gets or sets a non-visible numeric value for the task.
public Property | DueDate | Gets or sets the due date for the task.
public Property | EntryID | Gets or sets a non-visible text value for the task.
public Property | ForeColor | Gets or sets the fore color of the task.
public Property | Image | Gets or sets the image to display with the task.
public Property | PercentComplete | Determines how much of the task has been completed.
public Property | RecordID | Gets or sets a non-visible numeric value for the task.
public Property | StartDate | Gets or sets the start date of the task.
public Property | Status | Gets or sets the status of the task.
public Property | Subject | Gets or sets the name of the task.
public Property | Tag | Determines an object that contains data about the dbiTaskItem
public Property | XMLString | Gets or sets an xml string to read or write the task data.
Top

See Also

Reference

dbiTaskItem Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiTaskItem Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : dbiTaskItem Constructor

Initializes a new instance of the dbiTaskItem class.

Overload List

Overload | Description
dbiTaskItem Constructor() | Initializes a new instance of the dbiTaskItem class.
dbiTaskItem Constructor(String) | Initializes a new instance of the dbiTaskItem class.
dbiTaskItem Constructor(String,String) | Initializes a new instance of the dbiTaskItem class.
dbiTaskItem Constructor(dbiTaskItem) | Initializes a new instance of the dbiTaskItem class.
dbiTaskItem Constructor(XmlNodeList) | Initializes a new instance of the dbiTaskItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

dbiTaskItem Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class > dbiTaskItem Constructor : dbiTaskItem Constructor()

Initializes a new instance of the dbiTaskItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTaskItem()
C#
public dbiTaskItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Overload List


%%PageItemTitle%%

dbiTaskItem Constructor(String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class > dbiTaskItem Constructor : dbiTaskItem Constructor(String)

strSubject
The name of the task.
Initializes a new instance of the dbiTaskItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strSubject As System.String

Dim instance As New dbiTaskItem(strSubject)
C#
public dbiTaskItem(
   System.string strSubject
)

Parameters

strSubject
The name of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Overload List


%%PageItemTitle%%

dbiTaskItem Constructor(String,String)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class > dbiTaskItem Constructor : dbiTaskItem Constructor(String,String)

strSubject
The name of the task.
strEntryID
The EntryID of the task.
Initializes a new instance of the dbiTaskItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strSubject As System.String
Dim strEntryID As System.String

Dim instance As New dbiTaskItem(strSubject, strEntryID)
C#
public dbiTaskItem(
   System.string strSubject,
   System.string strEntryID
)

Parameters

strSubject
The name of the task.
strEntryID
The EntryID of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Overload List


%%PageItemTitle%%

dbiTaskItem Constructor(dbiTaskItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class > dbiTaskItem Constructor : dbiTaskItem Constructor(dbiTaskItem)

objTask
The dbiTaskItem containing task information.
Initializes a new instance of the dbiTaskItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objTask As dbiTaskItem

Dim instance As New dbiTaskItem(objTask)
C#
public dbiTaskItem(
   dbiTaskItem objTask
)

Parameters

objTask
The dbiTaskItem containing task information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Overload List


%%PageItemTitle%%

dbiTaskItem Constructor(XmlNodeList)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class > dbiTaskItem Constructor : dbiTaskItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing task information.
Initializes a new instance of the dbiTaskItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiTaskItem(xmlNodes)
C#
public dbiTaskItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing task information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Overload List


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : BackColor Property

Gets or sets the primary background color of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.BackColor = System.Drawing.Color.White
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.BackColor = System.Drawing.Color.White;

Remarks

This property value is of type Color, indicating the color used to paint the background of the task when you are displaying by Task in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : BackColorTo Property

Gets or sets the secondary background color of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.BackColorTo = System.Drawing.Color.Silver
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.BackColorTo = System.Drawing.Color.Silver;

Remarks

This property value is of type Color, indicating the secondary color used to paint the background of the task when you are displaying by Task in a control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Body Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Body Property

Gets or sets additional information for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public System.string Body {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Body = "Additional details"
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Body = "Additional Details";

Remarks

This property value is of type String, indicating any additional details of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Cargo Property

Gets or sets a non-visible text value for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Cargo = "Key Data"
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Cargo = "Key Data";

Remarks

This property value is of type String, indicating a non-visible text value for the task. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Categories Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Categories Property

Gets or sets the category of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.Categories = value

value = instance.Categories
C#
public System.string Categories {get; set;}

Example

Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Categories = "Business"
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Categories = "Business";

Remarks

This property value is of type String, indicating the category of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Complete Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Complete Property

Determines if the task has been completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Boolean

instance.Complete = value

value = instance.Complete
C#
public System.bool Complete {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Complete = False
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Complete = false;

Remarks

This property value is of type Boolean, indicating if the task has been completed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Data Property

Gets or sets a non-visible numeric value for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Data = 44
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Data = 44;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the task. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

DueDate Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : DueDate Property

Gets or sets the due date for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Date

instance.DueDate = value

value = instance.DueDate
C#
public System.DateTime DueDate {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.DueDate =  DateTime.Today.AddDays(7)
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.DueDate =  DateTime.Today.AddDays(7);

Remarks

This property value is of type DateTime, indicating the due date for the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

EntryID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : EntryID Property

Gets or sets a non-visible text value for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.EntryID = value

value = instance.EntryID
C#
public System.string EntryID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.EntryID = "DBIID44"
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.EntryID = "DBIID44";

Remarks

This property value is of type String, indicating a non-visible text value for the task. This property is used to relate the tasks to the appointments. It is also used to filtering the displayed appointments within the controls. It is recommended that the Record ID is stored as a string in this property. If this property is not manually defined, a value will be generated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members
Working with Entry ID's


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : ForeColor Property

Gets or sets the fore color of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.ForeColor = System.Drawing.Color.Black
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.ForeColor = System.Drawing.Color.Black;

Remarks

This property value is of type Color, indicating the fore color of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Image Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Image Property

Gets or sets the image to display with the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Integer

instance.Image = value

value = instance.Image
C#
public System.int Image {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Image = -4
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Image = -4;

Remarks

This property value is of type Integer, indicating the index of the image to display with the task.

For additional information on using images, please refer to Custom Images.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

PercentComplete Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : PercentComplete Property

Determines how much of the task has been completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Integer

instance.PercentComplete = value

value = instance.PercentComplete
C#
public System.int PercentComplete {get; set;}

Property Value

This property value is of type Integer, indicating how much of the task is complete.

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.PercentComplete = 50
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.PercentComplete = 50;

Remarks

This property value is of type Integer, indicating how much of the task has been completed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

RecordID Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : RecordID Property

Gets or sets a non-visible numeric value for the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Integer

instance.RecordID = value

value = instance.RecordID
C#
public System.int RecordID {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.RecordID = 302
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.RecordID = 302;

Remarks

This property value is of type Integer, indicating a non-visible numeric value for the task. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

StartDate Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : StartDate Property

Gets or sets the start date of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Date

instance.StartDate = value

value = instance.StartDate
C#
public System.DateTime StartDate {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.StartDate = Today
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.StartDate = DateTime.Today;

Remarks

This property value is of type DateTime, indicating the start date of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Status Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Status Property

Gets or sets the status of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As dbiTaskItem.enumStatus

instance.Status = value

value = instance.Status
C#
public dbiTaskItem.enumStatus Status {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Status = Dbi.Pim4.dbiTaskItem.enumStatus.Complete
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Status = Dbi.Pim4..dbiTaskItem.enumStatus.Complete;

Remarks

This property value is of type dbiTaskItem.enumStatus, indicating the status of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Subject Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Subject Property

Gets or sets the name of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
public System.string Subject {get; set;}

Example

The following illustrates how to set this property programmatically. NOTE: This property can also be set at design time in the property window.
Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem

newTask.Subject = "Review Report"
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
newTask = new Dbi.Pim4.dbiTaskItem();

newTask.Subject = "Review Report";

Remarks

This property value is of type String, indicating the name of the task.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : Tag Property

Determines an object that contains data about the dbiTaskItem

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskItem Class : XMLString Property

Gets or sets an xml string to read or write the task data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Example

Visual Basic Copy Code
Dim newTask As New Dbi.Pim4.dbiTaskItem
Dim strXML As String

newTask.XMLString = strXML
C# Copy Code
Dbi.Pim4.dbiTaskItem newTask;
string strXML;

newTask = new Dbi.Pim4.dbiTaskItem();

newTask.XMLString = strXML;

Remarks

This property value is of type String, indicating an xml string to read or write to the task.

For additional information, please see Reading and Writing XML Data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskItem Class
dbiTaskItem Members


%%PageItemTitle%%

dbiTimeBarDialog Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTimeBarDialog Class

The default time bar dialog.

Object Model

dbiTimeBarDialog ClassdbiAppointmentItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
C#
public class dbiTimeBarDialog : System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Dbi.PIM.dbiTimeBarDialog

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

dbiTimeBarDialog Class Members
See Also Properties Methods Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTimeBarDialog Class

"

The following tables list the members exposed by dbiTimeBarDialog.

"

Public Constructors

 | Name | Description
public Constructor | dbiTimeBarDialog Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from System.Windows.Forms.Form)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from System.Windows.Forms.Form)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from System.Windows.Forms.Form)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Appointment | Gets or sets the appointment/time bar in the dbiTimeBarDialog object.
public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from System.Windows.Forms.Form)
public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoSize | Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode. (Inherited from System.Windows.Forms.Form)
public Property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from System.Windows.Forms.Form)
public Property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from System.Windows.Forms.Form)
public Property | BackColor | Gets or sets the backcolor of the time bar.
public Property | BackColorTo | Gets or sets the secondary backcolor of the time bar.
public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | BorderColor | Gets or sets the border color of the time bar.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from System.Windows.Forms.Form)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from System.Windows.Forms.Form)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | Delete | Determines if the Delete button was click in the dbiTimeBarDialog object.
public Property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DialogResult | Gets or sets the dialog result for the form. (Inherited from System.Windows.Forms.Form)
public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the forecolor of the time bar.
public Property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from System.Windows.Forms.Form)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from System.Windows.Forms.Form)
public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Icon | Gets or sets the icon for the form. (Inherited from System.Windows.Forms.Form)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from System.Windows.Forms.Form)
public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from System.Windows.Forms.Form)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from System.Windows.Forms.Form)
public Property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from System.Windows.Forms.Form)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates. (Inherited from System.Windows.Forms.Form)
public Property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from System.Windows.Forms.Form)
public Property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from System.Windows.Forms.Form)
public Property | Menu | Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form. (Inherited from System.Windows.Forms.Form)
public Property | MergedMenu | Gets the merged menu for the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from System.Windows.Forms.Form)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Opacity | Gets or sets the opacity level of the form. (Inherited from System.Windows.Forms.Form)
public Property | OwnedForms | Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form. (Inherited from System.Windows.Forms.Form)
public Property | Owner | Gets or sets the form that owns this form. (Inherited from System.Windows.Forms.Form)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from System.Windows.Forms.Form)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from System.Windows.Forms.Form)
public Property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from System.Windows.Forms.Form)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the size of the form. (Inherited from System.Windows.Forms.Form)
public Property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from System.Windows.Forms.Form)
public Property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from System.Windows.Forms.Form)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Form)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from System.Windows.Forms.Form)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from System.Windows.Forms.Form)
public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from System.Windows.Forms.Form)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from System.Windows.Forms.Form)
Top

Public Methods

 | Name | Description
public Method | Activate | Activates the form and gives it focus. (Inherited from System.Windows.Forms.Form)
public Method | AddOwnedForm | Adds an owned form to this form. (Inherited from System.Windows.Forms.Form)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Close | Closes the form. (Inherited from System.Windows.Forms.Form)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from System.Windows.Forms.Form)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from System.Windows.Forms.Form)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | Show | Overloaded. Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
public Method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Gets a string representing the current instance of the form. (Inherited from System.Windows.Forms.Form)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from System.Windows.Forms.Form)
public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.Form.AutoSize property changes. (Inherited from System.Windows.Forms.Form)
public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.Form.AutoValidate property changes. (Inherited from System.Windows.Forms.Form)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from System.Windows.Forms.Form)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | FormClosed | Occurs after the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | FormClosing | Occurs before the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from System.Windows.Forms.Form)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from System.Windows.Forms.Form)
public Event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from System.Windows.Forms.Form)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | Load | Occurs before a form is displayed for the first time. (Inherited from System.Windows.Forms.Form)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MaximizedBoundsChanged | Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MaximumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from System.Windows.Forms.Form)
public Event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from System.Windows.Forms.Form)
public Event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from System.Windows.Forms.Form)
public Event | MinimumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftLayoutChanged | Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.Form)
public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
public Event | Shown | Occurs whenever the form is first displayed. (Inherited from System.Windows.Forms.Form)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiTimeBarDialog Class
Dbi.PIM Namespace


%%PageItemTitle%%

dbiTimeBarDialog Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : dbiTimeBarDialog Constructor

Initializes a new instance of the dbiTimeBarDialog class.

Overload List

Overload | Description
dbiTimeBarDialog Constructor() | Initializes a new instance of the dbiTimeBarDialog class.
dbiTimeBarDialog Constructor(dbiAppointmentItem) | Initializes a new instance of the dbiTimeBarDialog class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

dbiTimeBarDialog Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > dbiTimeBarDialog Constructor : dbiTimeBarDialog Constructor()

Initializes a new instance of the dbiTimeBarDialog class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTimeBarDialog()
C#
public dbiTimeBarDialog()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

dbiTimeBarDialog Constructor(dbiAppointmentItem)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > dbiTimeBarDialog Constructor : dbiTimeBarDialog Constructor(dbiAppointmentItem)

objAppoint
The dbiAppointmentItem/dbiTimeBarItem to load into dialog.
Initializes a new instance of the dbiTimeBarDialog class.

Syntax

Visual Basic (Usage) Copy Code
Dim objAppoint As dbiAppointmentItem

Dim instance As New dbiTimeBarDialog(objAppoint)
C#
public dbiTimeBarDialog(
   dbiAppointmentItem objAppoint
)

Parameters

objAppoint
The dbiAppointmentItem/dbiTimeBarItem to load into dialog.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

CreateControl() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PerformAutoScale Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PerformAutoScale Method

Performs scaling of the container control and its children.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.PerformAutoScale()
C#
public void PerformAutoScale()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ValidateChildren Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ValidateChildren Method

Causes all of the child controls within a control that support validation to validate their data.

Overload List

Overload | Description
ValidateChildren() | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Appointment Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Appointment Property

Gets or sets the appointment/time bar in the dbiTimeBarDialog object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As dbiAppointmentItem

instance.Appointment = value

value = instance.Appointment
C#
public dbiAppointmentItem Appointment {get; set;}

Property Value

A dbiAppointmentItem object.

Example

The following example illustrates how to define a new dbiTimeBarDialog, set and read the properties. It is also assumed that the dialog box will not automatically appear when an appointment/time bar is double clicked.
Visual Basic Copy Code
'Initialize a new instance of the dialog
Dim newTimeBarDialog As New Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem)
'The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver 'primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke 'secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black 'border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan 'foreground color

'The dialog box is displayed.  If the OK button is clicked, the properties will
'be assigned to the appointment/time bar
If newTimeBarDialog.ShowDialog() = DialogResult.OK Then
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor
End If
C# Copy Code
//Initialize a new instance of the dialog
Dbi.PIM.dbiTimeBarDialog newTimeBarDialog;
newTimeBarDialog = new Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem);
//The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver; //primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke; //secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black; //border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan; //foreground color

//The dialog box is displayed.  If the OK button is clicked, the properties will
//be assigned to the appointment/time bar
if (newTimeBarDialog.ShowDialog() == DialogResult.OK);
{
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor;
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo;
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text;
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor;
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor;
}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScaleDimensions Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScaleDimensions Property

Gets or sets the dimensions that the control was designed to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.SizeF

instance.AutoScaleDimensions = value

value = instance.AutoScaleDimensions
C#
public System.Drawing.SizeF AutoScaleDimensions {get; set;}

Property Value

A System.Drawing.SizeF containing the dots per inch (DPI) or System.Drawing.Font size that the control was designed to.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The width or height of the System.Drawing.SizeF value is less than 0 when setting this value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScaleMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScaleMode Property

Gets or sets the automatic scaling mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AutoScaleMode

instance.AutoScaleMode = value

value = instance.AutoScaleMode
C#
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}

Property Value

An System.Windows.Forms.AutoScaleMode that represents the current scaling mode. The default is System.Windows.Forms.AutoScaleMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | An System.Windows.Forms.AutoScaleMode value that is not valid was used to set this property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoSize Property

Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
public virtual System.bool AutoSize {get; set;}

Property Value

true if the form will automatically resize; false if it must be manually resized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoSizeMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoSizeMode Property

Gets or sets the mode by which the form automatically resizes itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}

Property Value

An System.Windows.Forms.AutoSizeMode enumerated value. The default is System.Windows.Forms.AutoSizeMode.GrowOnly.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value is not a valid System.Windows.Forms.AutoSizeMode value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoValidate Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoValidate Property

Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}

Property Value

An System.Windows.Forms.AutoValidate enumerated value that indicates whether contained controls are implicitly validated on focus change. The default is Inherit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackColor Property

Gets or sets the backcolor of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public new System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following example illustrates how to define a new dbiTimeBarDialog, set and read the properties. It is also assumed that the dialog box will not automatically appear when an appointment/time bar is double clicked.
Visual Basic Copy Code
'Initialize a new instance of the dialog
Dim newTimeBarDialog As New Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem)
'The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver 'primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke 'secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black 'border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan 'foreground color

'The dialog box is displayed.  If the OK button is clicked, the properties will
'be assigned to the appointment/time bar
If newTimeBarDialog.ShowDialog() = DialogResult.OK Then
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor
End If
C# Copy Code
//Initialize a new instance of the dialog
Dbi.PIM.dbiTimeBarDialog newTimeBarDialog;
newTimeBarDialog = new Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem);
//The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver; //primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke; //secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black; //border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan; //foreground color

//The dialog box is displayed.  If the OK button is clicked, the properties will
//be assigned to the appointment/time bar
if (newTimeBarDialog.ShowDialog() == DialogResult.OK);
{
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor;
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo;
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text;
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor;
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor;
}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackColorTo Property

Gets or sets the secondary backcolor of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following example illustrates how to define a new dbiTimeBarDialog, set and read the properties. It is also assumed that the dialog box will not automatically appear when an appointment/time bar is double clicked.
Visual Basic Copy Code
'Initialize a new instance of the dialog
Dim newTimeBarDialog As New Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem)
'The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver 'primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke 'secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black 'border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan 'foreground color

'The dialog box is displayed.  If the OK button is clicked, the properties will
'be assigned to the appointment/time bar
If newTimeBarDialog.ShowDialog() = DialogResult.OK Then
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor
End If
C# Copy Code
//Initialize a new instance of the dialog
Dbi.PIM.dbiTimeBarDialog newTimeBarDialog;
newTimeBarDialog = new Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem);
//The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver; //primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke; //secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black; //border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan; //foreground color

//The dialog box is displayed.  If the OK button is clicked, the properties will
//be assigned to the appointment/time bar
if (newTimeBarDialog.ShowDialog() == DialogResult.OK);
{
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor;
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo;
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text;
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor;
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor;
}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackgroundImageLayout Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BorderColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BorderColor Property

Gets or sets the border color of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public System.Drawing.Color BorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following example illustrates how to define a new dbiTimeBarDialog, set and read the properties. It is also assumed that the dialog box will not automatically appear when an appointment/time bar is double clicked.
Visual Basic Copy Code
'Initialize a new instance of the dialog
Dim newTimeBarDialog As New Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem)
'The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver 'primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke 'secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black 'border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan 'foreground color

'The dialog box is displayed.  If the OK button is clicked, the properties will
'be assigned to the appointment/time bar
If newTimeBarDialog.ShowDialog() = DialogResult.OK Then
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor
End If
C# Copy Code
//Initialize a new instance of the dialog
Dbi.PIM.dbiTimeBarDialog newTimeBarDialog;
newTimeBarDialog = new Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem);
//The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver; //primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke; //secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black; //border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan; //foreground color

//The dialog box is displayed.  If the OK button is clicked, the properties will
//be assigned to the appointment/time bar
if (newTimeBarDialog.ShowDialog() == DialogResult.OK);
{
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor;
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo;
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text;
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor;
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor;
}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CurrentAutoScaleDimensions Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CurrentAutoScaleDimensions Property

Gets the current run-time dimensions of the screen.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.SizeF

value = instance.CurrentAutoScaleDimensions
C#
public System.Drawing.SizeF CurrentAutoScaleDimensions {get;}

Property Value

A System.Drawing.SizeF containing the current dots per inch (DPI) or System.Drawing.Font size of the screen.

Exceptions

Exception | Description
System.ComponentModel.Win32Exception | A Win32 device context could not be created for the current screen.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Delete Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Delete Property

Determines if the Delete button was click in the dbiTimeBarDialog object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.Delete = value

value = instance.Delete
C#
public System.bool Delete {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DeviceDpi Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ForeColor Property

Gets or sets the forecolor of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public new System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following example illustrates how to define a new dbiTimeBarDialog, set and read the properties. It is also assumed that the dialog box will not automatically appear when an appointment/time bar is double clicked.
Visual Basic Copy Code
'Initialize a new instance of the dialog
Dim newTimeBarDialog As New Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem)
'The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver 'primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke 'secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black 'border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan 'foreground color

'The dialog box is displayed.  If the OK button is clicked, the properties will
'be assigned to the appointment/time bar
If newTimeBarDialog.ShowDialog() = DialogResult.OK Then
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor
End If
C# Copy Code
//Initialize a new instance of the dialog
Dbi.PIM.dbiTimeBarDialog newTimeBarDialog;
newTimeBarDialog = new Dbi.PIM.dbiTimeBarDialog(e.TimeBarItem);
//The following will set the appointment colors in the dialog box.
newTimeBarDialog.BackColor = System.Drawing.Color.Silver; //primary background color
newTimeBarDialog.BackColorTo = System.Drawing.Color.WhiteSmoke; //secondary background color
newTimeBarDialog.BorderColor = System.Drawing.Color.Black; //border color
newTimeBarDialog.ForeColor = System.Drawing.Color.DarkCyan; //foreground color

//The dialog box is displayed.  If the OK button is clicked, the properties will
//be assigned to the appointment/time bar
if (newTimeBarDialog.ShowDialog() == DialogResult.OK);
{
    e.TimeBarItem.BackColor = newTimeBarDialog.Appointment.BackColor;
    e.TimeBarItem.BackColorTo = newTimeBarDialog.Appointment.BackColorTo;
    e.TimeBarItem.Text = newTimeBarDialog.Appointment.Text;
    e.TimeBarItem.BorderColor = newTimeBarDialog.Appointment.BorderColor;
    e.TimeBarItem.ForeColor = newTimeBarDialog.Appointment.ForeColor;
}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HorizontalScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HorizontalScroll Property

Gets the characteristics associated with the horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.HScrollProperties

value = instance.HorizontalScroll
C#
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}

Property Value

A System.Windows.Forms.HScrollProperties that contains information about the horizontal scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsMirrored Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

LayoutEngine Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MainMenuStrip Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MainMenuStrip Property

Gets or sets the primary menu container for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}

Property Value

A System.Windows.Forms.MenuStrip that represents the container for the menu structure of the form. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Padding Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Padding Property

Gets or sets padding within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
public System.Windows.Forms.Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PreferredSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RestoreBounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RestoreBounds Property

Gets the location and size of the form in its normal window state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Rectangle

value = instance.RestoreBounds
C#
public System.Drawing.Rectangle RestoreBounds {get;}

Property Value

A System.Drawing.Rectangle that contains the location and size of the form in the normal window state.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RightToLeftLayout Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RightToLeftLayout Property

Gets or sets a value indicating whether right-to-left mirror placement is turned on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
public virtual System.bool RightToLeftLayout {get; set;}

Property Value

true if right-to-left mirror placement is turned on; otherwise, false for standard child control placement. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ShowIcon Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ShowIcon Property

Gets or sets a value indicating whether an icon is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
public System.bool ShowIcon {get; set;}

Property Value

true if the form displays an icon in the caption bar; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

VerticalScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : VerticalScroll Property

Gets the characteristics associated with the vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.VScrollProperties

value = instance.VerticalScroll
C#
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}

Property Value

A System.Windows.Forms.VScrollProperties that contains information about the vertical scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoSizeChanged Event

Occurs when the System.Windows.Forms.Form.AutoSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
public event System.EventHandler AutoSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoValidateChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoValidateChanged Event

Occurs when the System.Windows.Forms.Form.AutoValidate property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
public event System.EventHandler AutoValidateChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackgroundImageLayoutChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackgroundImageLayoutChanged Event

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event System.EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DpiChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DpiChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.DpiChangedEventHandler

AddHandler instance.DpiChanged, handler
C#
public event System.Windows.Forms.DpiChangedEventHandler DpiChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.DpiChangedEventArgs containing data related to this event. The following DpiChangedEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
DeviceDpiNew |
DeviceDpiOld |
SuggestedRectangle |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

FormClosed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : FormClosed Event

Occurs after the form is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
public event System.Windows.Forms.FormClosedEventHandler FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

FormClosing Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : FormClosing Event

Occurs before the form is closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
public event System.Windows.Forms.FormClosingEventHandler FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HelpButtonClicked Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HelpButtonClicked Event

Occurs when the Help button is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
public event System.ComponentModel.CancelEventHandler HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PaddingChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PaddingChanged Event

Occurs when the control's padding changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event System.EventHandler PaddingChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RegionChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ResizeBegin Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ResizeBegin Event

Occurs when a form enters resizing mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
public event System.EventHandler ResizeBegin

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ResizeEnd Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ResizeEnd Event

Occurs when a form exits resizing mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
public event System.EventHandler ResizeEnd

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RightToLeftLayoutChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RightToLeftLayoutChanged Event

Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
public event System.EventHandler RightToLeftLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Scroll Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Scroll Event

Occurs when the user or code scrolls through the client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
public event System.Windows.Forms.ScrollEventHandler Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Shown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Shown Event

Occurs whenever the form is first displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
public event System.EventHandler Shown

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

dbiReminderDialog.enumReminderState Enumeration
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog.enumReminderState Enumeration

The last button clicked before the dialog was closed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog.enumReminderState
C#
public enum dbiReminderDialog.enumReminderState : System.Enum

Members

Member | Description
Dismiss | The Dismiss button was the last button clicked before the dialog was closed.
DismissAll | The Dismiss All button was the last button clicked before the dialog was closed.
None | No button was clicked before the dialog was closed.
Snooze | The Snooze button was the last button clicked before the dialog was closed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.PIM.dbiReminderDialog.enumReminderState

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.PIM Namespace


%%PageItemTitle%%

dbiTaskItem.enumStatus Enumeration
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskItem.enumStatus Enumeration

The status of the task.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTaskItem.enumStatus
C#
public enum dbiTaskItem.enumStatus : System.Enum

Members

Member | Description
Complete | The task is completed.
Deferred | The task has been defferred.
InProgress | The task is in process.
NotStarted | The task has not been started.
Waiting | The task is on hold.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.PIM.dbiTaskItem.enumStatus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.PIM Namespace


%%PageItemTitle%%

dbiPIM.EventAlarmHandler Delegate
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM.EventAlarmHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that will handle the Alarm event in dbiPim4

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiPIM.EventAlarmHandler(AddressOf HandlerMethod)
C#
public delegate void dbiPIM.EventAlarmHandler(
   System.object sender,
   AlarmEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM.EventAlarmHandler Members
Dbi.PIM Namespace


%%ItemTitle%%

Dbi.WinControl Namespace
See Also Inheritance Hierarchy
Dbi4 Assembly : Dbi.WinControl Namespace

Classes

Class | Description
AfterCellEditEventArgs | Arguments for the AfterCellEdit Event.
AfterColumnSortEventArgs | Arguments for the AfterColumnSort Event.
AfterNodeCollapseEventArgs | Arguments for the AfterNodeCollapse Event.
AfterNodeExchangeEventArgs | Arguments for the AfterNodeExchange Event.
AfterNodeExpandEventArgs | Arguments for the AfterNodeExpand Event.
AfterNodeSelectEventArgs | Arguments for the AfterNodeSelect Event.
BeforeCellEditEventArgs | Arguments for the BeforeCellEdit Event.
BeforeCellTextDisplayEventArgs | Arguments for the BeforeCellTextDisplay Event.
BeforeColumnSortEventArgs | Arguments for the BeforeColumnSort Event.
BeforeNodeCollapseEventArgs | Arguments for the BeforeNodeCollapse Event.
BeforeNodeExchangeEventArgs | Arguments for the BeforeNodeExchange Event.
BeforeNodeExpandEventArgs | Arguments for the BeforeNodeExpand Event.
BeforeNodeSelectEventArgs | Arguments for the BeforeNodeSelect Event.
BeforePaintEventArgs | Arguments for the BeforePaint Event.
CellFormatCollection | A collection to store dbiCellFormat Items
ChangeEventArgs | Arguments for the Change event.
CheckEventArgs | Arguments for the CheckBox Click Event.
ColumnEventArgs | Arguments used by column based events.
ColumnItemCollection | A collection used to store the column items.
dbiCellFormat | Provides the properties for defining cell formats.
dbiColumnFormat | Provides the properties for defining columns.
dbiColumnItem | Provides the properties for defining columns.
dbiComboBox | A custom ComboBox class.
DbiListControl | The base dbiList control.
dbiNodeItem | Provides the NodeItems for use in dbiList components.
dbiTextBox | A custom TextBox class
DisplayUserControlEventArgs | Arguments for the DisplayUserControlEvent.
DropListEventArgs | Represents the method that will handle an item being dropped on the list.
EditInputKeyEventArgs | Arguments for the EditInputKey Event.
EditKeyDownEventArgs | Arguments for the EditKeyDown Event.
EditKeyPressEventArgs | Arguments for the EditKeyPress Event.
EditKeyUpEventArgs | Arguments for the EditKeyUp Event.
InitializeCellEditEventArgs | Arguments for the InitializeCellEdit Event.
ItemEventArgs | Represents the method that will handle the AfterLabelEdit, BeforeLabelEdit, ItemClick and ItemDoubleClick events.
ListMouseOverEventArgs | Represents the method that will handle the ListMouseOver event.
NodeClickEventArgs | Represents the method that will handle the NodeClick event.
NodeDoubleClickEventArgs | Represents the method that will handle the NodeDoubleClick Event
NodeItemCollection | Represents a collection of node items.
RemoveUserControlsEventArgs | Arguments for the RemoveUserControls Event.
UserDrawnCellEventArgs | Arguments for the UserDrawnCell Event.
UserDrawnColumnHeaderEventArgs | Arguments for the UserDrawnColumnHeaders Event.
UserDrawnNodeEventArgs | Arguments for the UserDrawnNode Event.
UserDrawnTitleEventArgs | Arguments for the UserDrawnTitle Event.

Delegates

Delegate | Description
DbiListControl.AfterColumnSortEventHandler | Represents the method that handles the AfterColumnSort Event
DbiListControl.BeforeColumnSortEventHandler | Represents the method that handles the BeforeColumnSort Event
DbiListControl.EventAfterCellEditHandler | Represents the method that handles the AfterCellEdit Event
DbiListControl.EventAfterNodeCollapseHandler | Represents the method that handles the AfterNodeCollapse Event
DbiListControl.EventAfterNodeExchangeHandler | Represents the method that handles the AfterNodeExchange Event
DbiListControl.EventAfterNodeExpandHandler | Represents the method that handles the AfterNodeExpand Event
DbiListControl.EventAfterNodeSelectHandler | Represents the method that handles the AfterNodeSelect Event
DbiListControl.EventBeforeCellEditHandler | Represents the method that handles the BeforeCellEdit Event
DbiListControl.EventBeforeCellTextDisplayHandler | Represents the method that handles the BeforeCellTextDisplay Event
DbiListControl.EventBeforeNodeCollapseHandler | Represents the method that handles the BeforeNodeCollapse Event
DbiListControl.EventBeforeNodeExchangeHandler | Represents the method that handles the BeforeNodeExchange Event
DbiListControl.EventBeforeNodeExpandHandler | Represents the method that handles the BeforeNodeExpand Event
DbiListControl.EventBeforeNodeSelectHandler | Represents the method that handles the BeforeNodeSelect Event
DbiListControl.EventBeforePaintHandler | Represents the method that handles the BeforePaint Event
DbiListControl.EventChangeEventHandler | Represents the method that handles the Change Event
DbiListControl.EventCheckClickEventHandler | Represents the method that handles the CheckClick Event
DbiListControl.EventDisplayUserControlHandler | Represents the method that handles the DisplayUserControl Event
DbiListControl.EventDropListEventHandler | Represents the method that handles the DropList Event
DbiListControl.EventEditInputKeyHandler | Represents the method that handles the EditInputKey Event
DbiListControl.EventEditKeyDownHandler | Represents the method that handles the EditKeyDown Event
DbiListControl.EventEditKeyPressHandler | Represents the method that handles the EditKeyPress Event
DbiListControl.EventEditKeyUpHandler | Represents the method that handles the EditKeyUp Event
DbiListControl.EventHeaderClickEventHandler | Represents the method that handles the HeaderClick Event
DbiListControl.EventHeaderDoubleClickEventHandler | Represents the method that handles the HeaderDoubleClick Event
DbiListControl.EventInitializeCellEditHandler | Represents the method that handles the InitializeCellEdit Event
DbiListControl.EventListMouseOverEventHandler | Represents the method that handles the ListMouseOver Event
DbiListControl.EventNodeClickEventHandler | Represents the method that handles the NodeClick Event
DbiListControl.EventNodeDoubleClickEventHandler | Represents the method that handles the NodeDoubleClick Event
DbiListControl.EventRemoveUserControlsHandler | Represents the method that handles the RemoveUserControls Event
DbiListControl.EventUserDrawnCellHandler | Represents the method that handles the UserDrawnCell Event
DbiListControl.EventUserDrawnColumnHeaderHandler | Represents the method that handles the UserDrawnColumnHeader Event
DbiListControl.EventUserDrawnNodeHandler | Represents the method that handles the UserDrawnNode Event
DbiListControl.EventUserDrawnTitleHandler | Represents the method that handles the UserDrawnTitle Event

Enumerations

Enumeration | Description
enumAlignment | Specifies horizontal and vertical alignment within the container object.
enumArrowAlign | Specifies alignment of sort arrows on a column.
enumControlAction | Specifies the source of an action on the control
enumDataType | Data types associated with various controls.
enumEditType | Specifies the type of edit control
enumHorzScrollType | Determines how the list area will be scrolled.
enumItemHeightType | Determines if the item height can be resized.
enumLineType | Determines the list/tree line connector line types.
enumListType | Determines how the nodes will be drawn.
enumPlusMinusStyle | Determines the style used to paint the plus/minus boxes
enumPreColumnType | Determines the pre-column to be used on the list part of the control.
enumPrintListFormat | Specifies the type of list to print.
enumPrintReportType | Determines the type of report to print.
enumSortDirection | Determines the directions of the sort.
enumStyle | Specifies the style of the control to display.

Remarks

See Also

Reference

Dbi4 Assembly


%%PageItemTitle%%

AfterCellEditEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterCellEditEventArgs Class

Arguments for the AfterCellEdit Event.

Object Model

AfterCellEditEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
C#
public class AfterCellEditEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterCellEditEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterCellEditEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterCellEditEventArgs Class

"

The following tables list the members exposed by AfterCellEditEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterCellEditEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The index of the column where the edit occurred.
public Property | ColumnItem | The dbiColumnItem where the cell is located
public Property | Key | The Key code and modifiers that were pressed to end the edit session
public Property | NodeItem | The dbiNodeItem that contains the cell that was edited.
public Property | Text | The text that was assigned back to the cell.
Top

See Also

Reference

AfterCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterCellEditEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : AfterCellEditEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterCellEditEventArgs()
C#
public AfterCellEditEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : ColumnIndex Property

The index of the column where the edit occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : ColumnItem Property

The dbiColumnItem where the cell is located

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

Key Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : Key Property

The Key code and modifiers that were pressed to end the edit session

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
Dim value As System.Windows.Forms.Keys

instance.Key = value

value = instance.Key
C#
public System.Windows.Forms.Keys Key {get; set;}

Property Value

System.Windows.Forms.Keys (enum)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell that was edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterCellEditEventArgs Class : Text Property

The text that was assigned back to the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterCellEditEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterCellEditEventArgs Class
AfterCellEditEventArgs Members


%%PageItemTitle%%

AfterColumnSortEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterColumnSortEventArgs Class

Arguments for the AfterColumnSort Event.

Object Model

AfterColumnSortEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterColumnSortEventArgs
C#
public class AfterColumnSortEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterColumnSortEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterColumnSortEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterColumnSortEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterColumnSortEventArgs Class

"

The following tables list the members exposed by AfterColumnSortEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterColumnSortEventArgs Constructor | The constructor for the AfterColumnSortEventArgs.
Top

Public Properties

 | Name | Description
public Property | Columns | An array of columns in the order in which the sort is to occur. See Sort Method
Top

See Also

Reference

AfterColumnSortEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterColumnSortEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterColumnSortEventArgs Class : AfterColumnSortEventArgs Constructor

The constructor for the AfterColumnSortEventArgs.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterColumnSortEventArgs()
C#
public AfterColumnSortEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterColumnSortEventArgs Class
AfterColumnSortEventArgs Members


%%PageItemTitle%%

Columns Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterColumnSortEventArgs Class : Columns Property

An array of columns in the order in which the sort is to occur. See Sort Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterColumnSortEventArgs
Dim value() As System.Integer

instance.Columns = value

value = instance.Columns
C#
public System.int[] Columns {get; set;}

Property Value

An array of type integer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterColumnSortEventArgs Class
AfterColumnSortEventArgs Members


%%PageItemTitle%%

AfterNodeCollapseEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeCollapseEventArgs Class

Arguments for the AfterNodeCollapse Event.

Object Model

AfterNodeCollapseEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeCollapseEventArgs
C#
public class AfterNodeCollapseEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterNodeCollapseEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeCollapseEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterNodeCollapseEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeCollapseEventArgs Class

"

The following tables list the members exposed by AfterNodeCollapseEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterNodeCollapseEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | NodeItem | The dbiNodeItem that was collapsed.
Top

See Also

Reference

AfterNodeCollapseEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterNodeCollapseEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeCollapseEventArgs Class : AfterNodeCollapseEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterNodeCollapseEventArgs()
C#
public AfterNodeCollapseEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeCollapseEventArgs Class
AfterNodeCollapseEventArgs Members


%%PageItemTitle%%

Action Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeCollapseEventArgs Class : Action Property

An enumerated value indicating the action against the control that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeCollapseEventArgs
Dim value As enumControlAction

instance.Action = value

value = instance.Action
C#
public enumControlAction Action {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeCollapseEventArgs Class
AfterNodeCollapseEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeCollapseEventArgs Class : NodeItem Property

The dbiNodeItem that was collapsed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeCollapseEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeCollapseEventArgs Class
AfterNodeCollapseEventArgs Members


%%PageItemTitle%%

AfterNodeExchangeEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExchangeEventArgs Class

Arguments for the AfterNodeExchange Event.

Object Model

AfterNodeExchangeEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExchangeEventArgs
C#
public class AfterNodeExchangeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterNodeExchangeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExchangeEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterNodeExchangeEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExchangeEventArgs Class

"

The following tables list the members exposed by AfterNodeExchangeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterNodeExchangeEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | NodeItemSource | The node item that was dragged.
public Property | NodeItemTarget | The node item that received the drop.
Top

See Also

Reference

AfterNodeExchangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterNodeExchangeEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExchangeEventArgs Class : AfterNodeExchangeEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterNodeExchangeEventArgs()
C#
public AfterNodeExchangeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExchangeEventArgs Class
AfterNodeExchangeEventArgs Members


%%PageItemTitle%%

NodeItemSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExchangeEventArgs Class : NodeItemSource Property

The node item that was dragged.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExchangeEventArgs
Dim value As dbiNodeItem

instance.NodeItemSource = value

value = instance.NodeItemSource
C#
public dbiNodeItem NodeItemSource {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExchangeEventArgs Class
AfterNodeExchangeEventArgs Members


%%PageItemTitle%%

NodeItemTarget Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExchangeEventArgs Class : NodeItemTarget Property

The node item that received the drop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExchangeEventArgs
Dim value As dbiNodeItem

instance.NodeItemTarget = value

value = instance.NodeItemTarget
C#
public dbiNodeItem NodeItemTarget {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExchangeEventArgs Class
AfterNodeExchangeEventArgs Members


%%PageItemTitle%%

AfterNodeExpandEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExpandEventArgs Class

Arguments for the AfterNodeExpand Event.

Object Model

AfterNodeExpandEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExpandEventArgs
C#
public class AfterNodeExpandEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterNodeExpandEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExpandEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterNodeExpandEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExpandEventArgs Class

"

The following tables list the members exposed by AfterNodeExpandEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterNodeExpandEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | NodeItem | The dbiNodeItem that was expanded.
Top

See Also

Reference

AfterNodeExpandEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterNodeExpandEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExpandEventArgs Class : AfterNodeExpandEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterNodeExpandEventArgs()
C#
public AfterNodeExpandEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExpandEventArgs Class
AfterNodeExpandEventArgs Members


%%PageItemTitle%%

Action Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExpandEventArgs Class : Action Property

An enumerated value indicating the action against the control that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExpandEventArgs
Dim value As enumControlAction

instance.Action = value

value = instance.Action
C#
public enumControlAction Action {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExpandEventArgs Class
AfterNodeExpandEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeExpandEventArgs Class : NodeItem Property

The dbiNodeItem that was expanded.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeExpandEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeExpandEventArgs Class
AfterNodeExpandEventArgs Members


%%PageItemTitle%%

AfterNodeSelectEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeSelectEventArgs Class

Arguments for the AfterNodeSelect Event.

Object Model

AfterNodeSelectEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeSelectEventArgs
C#
public class AfterNodeSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.AfterNodeSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeSelectEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

AfterNodeSelectEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeSelectEventArgs Class

"

The following tables list the members exposed by AfterNodeSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterNodeSelectEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that was selected.
Top

See Also

Reference

AfterNodeSelectEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

AfterNodeSelectEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeSelectEventArgs Class : AfterNodeSelectEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterNodeSelectEventArgs()
C#
public AfterNodeSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeSelectEventArgs Class
AfterNodeSelectEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > AfterNodeSelectEventArgs Class : NodeItem Property

The dbiNodeItem that was selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterNodeSelectEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterNodeSelectEventArgs Class
AfterNodeSelectEventArgs Members


%%PageItemTitle%%

BeforeCellEditEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellEditEventArgs Class

Arguments for the BeforeCellEdit Event.

Object Model

BeforeCellEditEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiComboBox ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiTextBox Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
C#
public class BeforeCellEditEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeCellEditEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeCellEditEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellEditEventArgs Class

"

The following tables list the members exposed by BeforeCellEditEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeCellEditEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | AllowEdit | Determines if the edit is allowed
public Property | ColumnIndex | The zero-based index of the column where the cell exists.
public Property | ColumnItem | The dbiColumnItem where the cell exists.
public Property | ComboBox | The ComboBox that will be used to edit values in the cell.
public Property | Height | The height of the cell to edit.
public Property | NodeItem | The dbiNodeItem that contains the cell to edit.
public Property | Text | The current text of the cell.
public Property | TextBox | The TextBox that will be used to edit values in the cell.
public Property | Width | The width of the cell to edit.
public Property | X | The X coordinate of the cell to edit.
public Property | Y | The Y coordinate of the cell to edit.
Top

See Also

Reference

BeforeCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeCellEditEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : BeforeCellEditEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeCellEditEventArgs()
C#
public BeforeCellEditEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

AllowEdit Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : AllowEdit Property

Determines if the edit is allowed

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Boolean

instance.AllowEdit = value

value = instance.AllowEdit
C#
public System.bool AllowEdit {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : ColumnIndex Property

The zero-based index of the column where the cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : ColumnItem Property

The dbiColumnItem where the cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

ComboBox Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : ComboBox Property

The ComboBox that will be used to edit values in the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As dbiComboBox

instance.ComboBox = value

value = instance.ComboBox
C#
public dbiComboBox ComboBox {get; set;}

Property Value

dbiComboBox

Remarks

The ComboBox control wll only be used in the editing, if the EditType property of the ColumnItem is set to ComboBox.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

Height Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : Height Property

The height of the cell to edit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell to edit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : Text Property

The current text of the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

String

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

TextBox Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : TextBox Property

The TextBox that will be used to edit values in the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As dbiTextBox

instance.TextBox = value

value = instance.TextBox
C#
public dbiTextBox TextBox {get; set;}

Property Value

dbiTextBox

Remarks

The TextBox control wll only be used in the editing, if the EditType property of the ColumnItem is set to TextBox.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : Width Property

The width of the cell to edit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

X Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : X Property

The X coordinate of the cell to edit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

Y Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellEditEventArgs Class : Y Property

The Y coordinate of the cell to edit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellEditEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellEditEventArgs Class
BeforeCellEditEventArgs Members


%%PageItemTitle%%

BeforeCellTextDisplayEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellTextDisplayEventArgs Class

Arguments for the BeforeCellTextDisplay Event.

Object Model

BeforeCellTextDisplayEventArgs ClassdbiCellFormat ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
C#
public class BeforeCellTextDisplayEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeCellTextDisplayEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeCellTextDisplayEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellTextDisplayEventArgs Class

"

The following tables list the members exposed by BeforeCellTextDisplayEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeCellTextDisplayEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | CellFormat | The dbiCellFormat that was applied to the cell that contains the text.
public Property | CellText | The text that will be displayed in the cell
public Property | ColumnIndex | The zero-based index of the column where the cell exists.
public Property | ColumnItem | The dbiColumnItem where the cell exists.
public Property | Font | The font that will be used to drawn the cell's text.
public Property | NodeItem | The dbiNodeItem that contains the cell.
public Property | NodeLevel | Returns the zero-based level within the nested structure that the node containing the cell exists.
public Property | TextAlignment | Determines the horizontal/vertical alignment of the text within the cell.
public Property | TextColor | Determines the color of the text in the cell.
Top

See Also

Reference

BeforeCellTextDisplayEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeCellTextDisplayEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : BeforeCellTextDisplayEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeCellTextDisplayEventArgs()
C#
public BeforeCellTextDisplayEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

CellFormat Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : CellFormat Property

The dbiCellFormat that was applied to the cell that contains the text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As dbiCellFormat

instance.CellFormat = value

value = instance.CellFormat
C#
public dbiCellFormat CellFormat {get; set;}

Property Value

dbiCellFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

CellText Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : CellText Property

The text that will be displayed in the cell

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.String

instance.CellText = value

value = instance.CellText
C#
public System.string CellText {get; set;}

Property Value

String

Remarks

Assigning a new value to this property will change the displayed text in the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : ColumnIndex Property

The zero-based index of the column where the cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : ColumnItem Property

The dbiColumnItem where the cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : Font Property

The font that will be used to drawn the cell's text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

Font

Remarks

Assigning a new value to this property will change the font being used to draw the text.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

NodeLevel Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : NodeLevel Property

Returns the zero-based level within the nested structure that the node containing the cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.Integer

instance.NodeLevel = value

value = instance.NodeLevel
C#
public System.int NodeLevel {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

TextAlignment Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : TextAlignment Property

Determines the horizontal/vertical alignment of the text within the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.Drawing.ContentAlignment

instance.TextAlignment = value

value = instance.TextAlignment
C#
public System.Drawing.ContentAlignment TextAlignment {get; set;}

Property Value

enumerated value

Remarks

Adjusting this value will modify the alignment of the displayed text in the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

TextColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeCellTextDisplayEventArgs Class : TextColor Property

Determines the color of the text in the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeCellTextDisplayEventArgs
Dim value As System.Drawing.Color

instance.TextColor = value

value = instance.TextColor
C#
public System.Drawing.Color TextColor {get; set;}

Property Value

Color

Remarks

Adjusting this value will change the color of the displayed text,

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeCellTextDisplayEventArgs Class
BeforeCellTextDisplayEventArgs Members


%%PageItemTitle%%

BeforeColumnSortEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeColumnSortEventArgs Class

Arguments for the BeforeColumnSort Event.

Object Model

BeforeColumnSortEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeColumnSortEventArgs
C#
public class BeforeColumnSortEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeColumnSortEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeColumnSortEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeColumnSortEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeColumnSortEventArgs Class

"

The following tables list the members exposed by BeforeColumnSortEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeColumnSortEventArgs Constructor | The constructor for the BeforeColumnSortEventArgs.
Top

Public Properties

 | Name | Description
public Property | AllowSort | Indicate wether or not to proceed with the Sort. To cancel the sort set e.AllowSort = False in the BeforeColumnSort Event.
public Property | Columns | An array of columns in the order in which the sort is to occur. See Sort Method
Top

See Also

Reference

BeforeColumnSortEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeColumnSortEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeColumnSortEventArgs Class : BeforeColumnSortEventArgs Constructor

The constructor for the BeforeColumnSortEventArgs.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeColumnSortEventArgs()
C#
public BeforeColumnSortEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeColumnSortEventArgs Class
BeforeColumnSortEventArgs Members


%%PageItemTitle%%

AllowSort Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeColumnSortEventArgs Class : AllowSort Property

Indicate wether or not to proceed with the Sort. To cancel the sort set e.AllowSort = False in the BeforeColumnSort Event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeColumnSortEventArgs
Dim value As System.Boolean

instance.AllowSort = value

value = instance.AllowSort
C#
public System.bool AllowSort {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeColumnSortEventArgs Class
BeforeColumnSortEventArgs Members


%%PageItemTitle%%

Columns Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeColumnSortEventArgs Class : Columns Property

An array of columns in the order in which the sort is to occur. See Sort Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeColumnSortEventArgs
Dim value() As System.Integer

instance.Columns = value

value = instance.Columns
C#
public System.int[] Columns {get; set;}

Property Value

An array of type integer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeColumnSortEventArgs Class
BeforeColumnSortEventArgs Members


%%PageItemTitle%%

BeforeNodeCollapseEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeCollapseEventArgs Class

Arguments for the BeforeNodeCollapse Event.

Object Model

BeforeNodeCollapseEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeCollapseEventArgs
C#
public class BeforeNodeCollapseEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeNodeCollapseEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeCollapseEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeNodeCollapseEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeCollapseEventArgs Class

"

The following tables list the members exposed by BeforeNodeCollapseEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeNodeCollapseEventArgs Constructor | The default constructor
Top

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | AllowCollapse | Determines if the node will be collapsed.
public Property | NodeItem | The dbiNodeItem being collapsed.
Top

See Also

Reference

BeforeNodeCollapseEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeNodeCollapseEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeCollapseEventArgs Class : BeforeNodeCollapseEventArgs Constructor

The default constructor

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeNodeCollapseEventArgs()
C#
public BeforeNodeCollapseEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeCollapseEventArgs Class
BeforeNodeCollapseEventArgs Members


%%PageItemTitle%%

Action Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeCollapseEventArgs Class : Action Property

An enumerated value indicating the action against the control that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeCollapseEventArgs
Dim value As enumControlAction

instance.Action = value

value = instance.Action
C#
public enumControlAction Action {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeCollapseEventArgs Class
BeforeNodeCollapseEventArgs Members


%%PageItemTitle%%

AllowCollapse Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeCollapseEventArgs Class : AllowCollapse Property

Determines if the node will be collapsed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeCollapseEventArgs
Dim value As System.Boolean

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
public System.bool AllowCollapse {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeCollapseEventArgs Class
BeforeNodeCollapseEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeCollapseEventArgs Class : NodeItem Property

The dbiNodeItem being collapsed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeCollapseEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeCollapseEventArgs Class
BeforeNodeCollapseEventArgs Members


%%PageItemTitle%%

BeforeNodeExchangeEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExchangeEventArgs Class

Arguments for the BeforeNodeExchange Event.

Object Model

BeforeNodeExchangeEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExchangeEventArgs
C#
public class BeforeNodeExchangeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeNodeExchangeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExchangeEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeNodeExchangeEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExchangeEventArgs Class

"

The following tables list the members exposed by BeforeNodeExchangeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeNodeExchangeEventArgs Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | AllowNodeExchange | Determines if the exchange will be allowed
public Property | NodeItemSource | The node item being dragged.
public Property | NodeItemTarget | The node item receiving the drop
Top

See Also

Reference

BeforeNodeExchangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeNodeExchangeEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExchangeEventArgs Class : BeforeNodeExchangeEventArgs Constructor

The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeNodeExchangeEventArgs()
C#
public BeforeNodeExchangeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExchangeEventArgs Class
BeforeNodeExchangeEventArgs Members


%%PageItemTitle%%

AllowNodeExchange Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExchangeEventArgs Class : AllowNodeExchange Property

Determines if the exchange will be allowed

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExchangeEventArgs
Dim value As System.Boolean

instance.AllowNodeExchange = value

value = instance.AllowNodeExchange
C#
public System.bool AllowNodeExchange {get; set;}

Property Value

Boolean

Remarks

Setting this property to alse within the BeforeNodeExchange event will cancel the operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExchangeEventArgs Class
BeforeNodeExchangeEventArgs Members


%%PageItemTitle%%

NodeItemSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExchangeEventArgs Class : NodeItemSource Property

The node item being dragged.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExchangeEventArgs
Dim value As dbiNodeItem

instance.NodeItemSource = value

value = instance.NodeItemSource
C#
public dbiNodeItem NodeItemSource {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExchangeEventArgs Class
BeforeNodeExchangeEventArgs Members


%%PageItemTitle%%

NodeItemTarget Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExchangeEventArgs Class : NodeItemTarget Property

The node item receiving the drop

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExchangeEventArgs
Dim value As dbiNodeItem

instance.NodeItemTarget = value

value = instance.NodeItemTarget
C#
public dbiNodeItem NodeItemTarget {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExchangeEventArgs Class
BeforeNodeExchangeEventArgs Members


%%PageItemTitle%%

BeforeNodeExpandEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExpandEventArgs Class

Arguments for the BeforeNodeExpand Event.

Object Model

BeforeNodeExpandEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExpandEventArgs
C#
public class BeforeNodeExpandEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeNodeExpandEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExpandEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeNodeExpandEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExpandEventArgs Class

"

The following tables list the members exposed by BeforeNodeExpandEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeNodeExpandEventArgs Constructor | The default constructor
Top

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | AllowExpand | Determines if the node will be expanded.
public Property | NodeItem | The dbiNodeItem being expanded.
Top

See Also

Reference

BeforeNodeExpandEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeNodeExpandEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExpandEventArgs Class : BeforeNodeExpandEventArgs Constructor

The default constructor

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeNodeExpandEventArgs()
C#
public BeforeNodeExpandEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExpandEventArgs Class
BeforeNodeExpandEventArgs Members


%%PageItemTitle%%

Action Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExpandEventArgs Class : Action Property

An enumerated value indicating the action against the control that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExpandEventArgs
Dim value As enumControlAction

instance.Action = value

value = instance.Action
C#
public enumControlAction Action {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExpandEventArgs Class
BeforeNodeExpandEventArgs Members


%%PageItemTitle%%

AllowExpand Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExpandEventArgs Class : AllowExpand Property

Determines if the node will be expanded.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExpandEventArgs
Dim value As System.Boolean

instance.AllowExpand = value

value = instance.AllowExpand
C#
public System.bool AllowExpand {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExpandEventArgs Class
BeforeNodeExpandEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeExpandEventArgs Class : NodeItem Property

The dbiNodeItem being expanded.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeExpandEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeExpandEventArgs Class
BeforeNodeExpandEventArgs Members


%%PageItemTitle%%

BeforeNodeSelectEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeSelectEventArgs Class

Arguments for the BeforeNodeSelect Event.

Object Model

BeforeNodeSelectEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeSelectEventArgs
C#
public class BeforeNodeSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforeNodeSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforeNodeSelectEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeSelectEventArgs Class

"

The following tables list the members exposed by BeforeNodeSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeNodeSelectEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the node will be selected.
public Property | NodeItem | The dbiNodeItem that will be selected.
public Property | X | The X coordinate where the selection is occurring
public Property | Y | The Y coordinate where the selection is occurring.
Top

See Also

Reference

BeforeNodeSelectEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforeNodeSelectEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeSelectEventArgs Class : BeforeNodeSelectEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeNodeSelectEventArgs()
C#
public BeforeNodeSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Class
BeforeNodeSelectEventArgs Members


%%PageItemTitle%%

AllowSelect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeSelectEventArgs Class : AllowSelect Property

Determines if the node will be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeSelectEventArgs
Dim value As System.Boolean

instance.AllowSelect = value

value = instance.AllowSelect
C#
public System.bool AllowSelect {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Class
BeforeNodeSelectEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeSelectEventArgs Class : NodeItem Property

The dbiNodeItem that will be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeSelectEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Class
BeforeNodeSelectEventArgs Members


%%PageItemTitle%%

X Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeSelectEventArgs Class : X Property

The X coordinate where the selection is occurring

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeSelectEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Class
BeforeNodeSelectEventArgs Members


%%PageItemTitle%%

Y Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforeNodeSelectEventArgs Class : Y Property

The Y coordinate where the selection is occurring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeNodeSelectEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeNodeSelectEventArgs Class
BeforeNodeSelectEventArgs Members


%%PageItemTitle%%

BeforePaintEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforePaintEventArgs Class

Arguments for the BeforePaint Event.

Object Model

BeforePaintEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePaintEventArgs
C#
public class BeforePaintEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.BeforePaintEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePaintEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

BeforePaintEventArgs Class Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforePaintEventArgs Class

"

The following tables list the members exposed by BeforePaintEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforePaintEventArgs Constructor | Initializes a new instance of the class.
Top

See Also

Reference

BeforePaintEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeforePaintEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > BeforePaintEventArgs Class : BeforePaintEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforePaintEventArgs()
C#
public BeforePaintEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePaintEventArgs Class
BeforePaintEventArgs Members


%%PageItemTitle%%

CellFormatCollection Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CellFormatCollection Class

A collection to store dbiCellFormat Items

Object Model

CellFormatCollection ClassdbiCellFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
C#
public class CellFormatCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.CellFormatCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

CellFormatCollection Class Members
See Also Properties Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CellFormatCollection Class

"

The following tables list the members exposed by CellFormatCollection.

"

Public Constructors

 | Name | Description
public Constructor | CellFormatCollection Constructor | Constructor for new CellFormatCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | The object which contains the dbiCellFormat Item.
Top

Public Methods

 | Name | Description
public Method | Add | Add a dbiCellFormat object to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index value (integer) for the supplied dbiCellFormat.
public Method | Insert | Insert a dbiCellFormat Item into the collection in a specified nIndex location.
public Method | Remove | Remove the specified dbiCellFormat Item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Export the CellFormats to an XML file specified by strFileName
public Method | XMLString | Converts the CellFormat Collection to an XML string.
Top

See Also

Reference

CellFormatCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

CellFormatCollection Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : CellFormatCollection Constructor

Constructor for new CellFormatCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New CellFormatCollection()
C#
public CellFormatCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Add Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Add Method

obj

The dbiCellFormat to add to the collection.

Add a dbiCellFormat object to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim obj As dbiCellFormat
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiCellFormat obj
)

Parameters

obj

The dbiCellFormat to add to the collection.

Return Value

Integer value representing the index where the item was added to.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Clear Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

IndexOf(dbiCellFormat) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : IndexOf(dbiCellFormat) Method

obj

Integer value representing the index where the item was found.

Returns the index value (integer) for the supplied dbiCellFormat.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim obj As dbiCellFormat
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiCellFormat obj
)

Parameters

obj

Integer value representing the index where the item was found.

Return Value

Integer value representing the index where the item was found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Insert Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Insert Method

nIndex
Integer value representing the index of the item where the insertion is to occur.
obj
The dbiCellFormat to insert in the collection.
Insert a dbiCellFormat Item into the collection in a specified nIndex location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim nIndex As System.Integer
Dim obj As dbiCellFormat

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiCellFormat obj
)

Parameters

nIndex
Integer value representing the index of the item where the insertion is to occur.
obj
The dbiCellFormat to insert in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Remove Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Remove Method

obj
The dbiCellFormat object to remove from the collection.
Remove the specified dbiCellFormat Item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim obj As dbiCellFormat

instance.Remove(obj)
C#
public void Remove(
   dbiCellFormat obj
)

Parameters

obj
The dbiCellFormat object to remove from the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : WriteXMLFile Method

strFileName
The fully qualified filename, of the XML file to write.
Export the CellFormats to an XML file specified by strFileName

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified filename, of the XML file to write.

Return Value

Boolean value indicating the file was successfully saved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

XMLString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : XMLString Method

Converts the CellFormat Collection to an XML string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String value representing the collection of CellFormats.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Capacity Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Count Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

Item Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : Item Property

nIndex
An integer value representing the index value of a dbiCellFormat item in the collection.
The object which contains the dbiCellFormat Item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CellFormatCollection
Dim nIndex As System.Integer
Dim value As dbiCellFormat

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiCellFormat this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
An integer value representing the index value of a dbiCellFormat item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%%

ChangeEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ChangeEventArgs Class

Arguments for the Change event.

Object Model

ChangeEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ChangeEventArgs
C#
public class ChangeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.ChangeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ChangeEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

ChangeEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ChangeEventArgs Class

"

The following tables list the members exposed by ChangeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ChangeEventArgs Constructor | The constructor for the ChangeEventArgs.
Top

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that has been selected.
Top

See Also

Reference

ChangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

ChangeEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ChangeEventArgs Class : ChangeEventArgs Constructor

The constructor for the ChangeEventArgs.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ChangeEventArgs()
C#
public ChangeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ChangeEventArgs Class
ChangeEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ChangeEventArgs Class : NodeItem Property

The dbiNodeItem that has been selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ChangeEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ChangeEventArgs Class
ChangeEventArgs Members


%%PageItemTitle%%

CheckEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CheckEventArgs Class

Arguments for the CheckBox Click Event.

Object Model

CheckEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CheckEventArgs
C#
public class CheckEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.CheckEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CheckEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

CheckEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CheckEventArgs Class

"

The following tables list the members exposed by CheckEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | CheckEventArgs Constructor | The constructor for the CheckEventArgs.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The index value of the dbiColumnItem where the check occurred.
public Property | NodeItem | The dbiNodeItem where the check occurred.
Top

See Also

Reference

CheckEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

CheckEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CheckEventArgs Class : CheckEventArgs Constructor

The constructor for the CheckEventArgs.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New CheckEventArgs()
C#
public CheckEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CheckEventArgs Class
CheckEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CheckEventArgs Class : ColumnIndex Property

The index value of the dbiColumnItem where the check occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CheckEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CheckEventArgs Class
CheckEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CheckEventArgs Class : NodeItem Property

The dbiNodeItem where the check occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CheckEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CheckEventArgs Class
CheckEventArgs Members


%%PageItemTitle%%

ColumnEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnEventArgs Class

Arguments used by column based events.

Object Model

ColumnEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnEventArgs
C#
public class ColumnEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.ColumnEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

ColumnEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnEventArgs Class

"

The following tables list the members exposed by ColumnEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ColumnEventArgs Constructor | The constructor for the ColumnEvent Arguments.
Top

Public Properties

 | Name | Description
public Property | Button | The mousebutton that was used in the event.
public Property | ColumnIndex | The index of the column where the event occurred.
Top

See Also

Reference

ColumnEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

ColumnEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnEventArgs Class : ColumnEventArgs Constructor

The constructor for the ColumnEvent Arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ColumnEventArgs()
C#
public ColumnEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnEventArgs Class
ColumnEventArgs Members


%%PageItemTitle%%

Button Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnEventArgs Class : Button Property

The mousebutton that was used in the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnEventArgs Class
ColumnEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnEventArgs Class : ColumnIndex Property

The index of the column where the event occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnEventArgs Class
ColumnEventArgs Members


%%PageItemTitle%%

ColumnItemCollection Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnItemCollection Class

A collection used to store the column items.

Object Model

ColumnItemCollection ClassdbiColumnItem ClassdbiColumnFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
C#
public class ColumnItemCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.ColumnItemCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

ColumnItemCollection Class Members
See Also Properties Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnItemCollection Class

"

The following tables list the members exposed by ColumnItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | ColumnItemCollection Constructor | The constructor for the ColumnItemCollection.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | The object which contains the dbiColumnItem Class.
Top

Public Methods

 | Name | Description
public Method | Add | Add a column item to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the integer index value of the dbiColumnItem Class from the collection.
public Method | Insert | Insert a dbiColumnItem Class into the collection in a specified nIndex location.
public Method | Remove | Remove the specified dbiColumnItem Class from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Export the Columns to an XML file specified by strFileName.
public Method | XMLString | Converts the Column Collection to an XML string.
Top

See Also

Reference

ColumnItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

ColumnItemCollection Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : ColumnItemCollection Constructor

owner
The dbiListControl object that will own the collection.
The constructor for the ColumnItemCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim owner As DbiListControl

Dim instance As New ColumnItemCollection(owner)
C#
public ColumnItemCollection(
   DbiListControl owner
)

Parameters

owner
The dbiListControl object that will own the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Add Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Add Method

obj
The dbiColumnItem to add to the collection.
Add a column item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim obj As dbiColumnItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiColumnItem obj
)

Parameters

obj
The dbiColumnItem to add to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Clear Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

IndexOf(dbiColumnItem) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : IndexOf(dbiColumnItem) Method

obj
The dbiColumnItem to find the index value of.
Returns the integer index value of the dbiColumnItem Class from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim obj As dbiColumnItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiColumnItem obj
)

Parameters

obj
The dbiColumnItem to find the index value of.

Return Value

Integer value representing the current index of the column item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Insert Method

nIndex
obj
The dbiColumnItem to insert into the collection.
Insert a dbiColumnItem Class into the collection in a specified nIndex location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim nIndex As System.Integer
Dim obj As dbiColumnItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiColumnItem obj
)

Parameters

nIndex
obj
The dbiColumnItem to insert into the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Remove Method

obj
The dbiColumnItem to remove from the collection.
Remove the specified dbiColumnItem Class from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim obj As dbiColumnItem

instance.Remove(obj)
C#
public void Remove(
   dbiColumnItem obj
)

Parameters

obj
The dbiColumnItem to remove from the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : WriteXMLFile Method

strFileName
The fully qualified filename, of the XML file to write.
Export the Columns to an XML file specified by strFileName.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified filename, of the XML file to write.

Return Value

Boolean value indicating the file was successfully saved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

XMLString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : XMLString Method

Converts the Column Collection to an XML string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

System.String value representing the column information in XML format.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Capacity Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Count Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

Item Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : Item Property

nIndex
The index value of a dbiColumnItem contained in the collection.
The object which contains the dbiColumnItem Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ColumnItemCollection
Dim nIndex As System.Integer
Dim value As dbiColumnItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiColumnItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The index value of a dbiColumnItem contained in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%%

dbiCellFormat Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiCellFormat Class

Provides the properties for defining cell formats.

Object Model

dbiCellFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
C#
public class dbiCellFormat

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiCellFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiCellFormat Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiCellFormat Class

"

The following tables list the members exposed by dbiCellFormat.

"

Public Constructors

 | Name | Description
public Constructor | dbiCellFormat Constructor | Overloaded. Initializes a new instance of the dbiCellFormat class.
Top

Public Properties

 | Name | Description
public Property | AlignmentOffset | Determines the vertical and horizontal offset values used to calculate the position of the text/image.
public Property | BackColor | Determines the background color of a cell.
public Property | BackColorTo | Determines the secondary background color of a cell.
public Property | Column | Determines the column to apply the format.
public Property | DateFormat | Defines how DateTime values are formatted and displayed in the cell, depending on the culture.
public Property | FillType | Determines the fill pattern of a cell.
public Property | Font | Determines the font of a cell.
public Property | ForeColor | Determines the forecolor of a cell.
public Property | ImageAlign | Determines the vertical and horizontal alignment of an image in a cell.
public Property | ImageIndex | Determines the image to place in a cell.
public Property | TextAlign | Determines the vertical and horizontal alignment of the text in a cell.
public Property | XMLString | Determines an Xml string to read the data or write the data to the cell.
Top

See Also

Reference

dbiCellFormat Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiCellFormat Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : dbiCellFormat Constructor

Initializes a new instance of the dbiCellFormat class. Initializes a new instance of the dbiCellFormat class.

Overload List

Overload | Description
dbiCellFormat Constructor() | Initializes a new instance of the dbiCellFormat class.
dbiCellFormat Constructor(XmlNodeList) | Initializes a new instance of the dbiCellFormat class based on an XmlNodeList.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

dbiCellFormat Constructor()
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class > dbiCellFormat Constructor : dbiCellFormat Constructor()

Initializes a new instance of the dbiCellFormat class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiCellFormat()
C#
public dbiCellFormat()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members
Overload List


%%PageItemTitle%%

dbiCellFormat Constructor(XmlNodeList)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class > dbiCellFormat Constructor : dbiCellFormat Constructor(XmlNodeList)

xmlNodes
A collection of XMLNodes.
Initializes a new instance of the dbiCellFormat class based on an XmlNodeList.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiCellFormat(xmlNodes)
C#
public dbiCellFormat(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
A collection of XMLNodes.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members
Overload List


%%PageItemTitle%%

AlignmentOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : AlignmentOffset Property

Determines the vertical and horizontal offset values used to calculate the position of the text/image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Drawing.Point

instance.AlignmentOffset = value

value = instance.AlignmentOffset
C#
public System.Drawing.Point AlignmentOffset {get; set;}

Property Value

A System.Drawing.Point value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : BackColor Property

Determines the background color of a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

BackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : BackColorTo Property

Determines the secondary background color of a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

Column Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : Column Property

Determines the column to apply the format.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Integer

instance.Column = value

value = instance.Column
C#
public System.int Column {get; set;}

Property Value

The zero-based index value of the column.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

DateFormat Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : DateFormat Property

Defines how DateTime values are formatted and displayed in the cell, depending on the culture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
public System.string DateFormat {get; set;}

Property Value

String

Remarks

Only applicable if the cell is within a column that has its DataType Property set to DateTime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

FillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : FillType Property

Determines the fill pattern of a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Property Value

enumFillType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : Font Property

Determines the font of a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : ForeColor Property

Determines the forecolor of a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

ImageAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : ImageAlign Property

Determines the vertical and horizontal alignment of an image in a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As enumAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public enumAlignment ImageAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

ImageIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : ImageIndex Property

Determines the image to place in a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

TextAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : TextAlign Property

Determines the vertical and horizontal alignment of the text in a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As enumAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public enumAlignment TextAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

XMLString Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiCellFormat Class : XMLString Property

Determines an Xml string to read the data or write the data to the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiCellFormat
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCellFormat Class
dbiCellFormat Members


%%PageItemTitle%%

dbiColumnFormat Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnFormat Class

Provides the properties for defining columns.

Object Model

dbiColumnFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
C#
public class dbiColumnFormat

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiColumnFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiColumnFormat Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnFormat Class

"

The following tables list the members exposed by dbiColumnFormat.

"

Public Constructors

 | Name | Description
public Constructor | dbiColumnFormat Constructor | Overloaded. Initializes a new instance of the dbiColumnFormat class.
Top

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the column.
public Property | BackColorTo | Determines the secondary background color of the column.
public Property | CheckAlign | Determines the alignment of the check box in the column.
public Property | CheckBox | Determines the style of the checkbox to use in the column.
public Property | DateFormat | Defines how DateTime values are formatted and displayed in each cell of the column, depending on the culture.
public Property | FillType | Determines the fill pattern of the column.
public Property | Font | Determines the font of the column.
public Property | ForeColor | Determines the forecolor of the column.
public Property | ImageAlign | Determines the vertical and horizontal alignment of the image in the column.
public Property | TextAlign | Determines the vertical and horizontal alignment of the text in the column.
public Property | WordWrap | Determines if the text in the column will wrap.
public Property | XMLString | Determines an Xml string to read the data or write the data.
Top

See Also

Reference

dbiColumnFormat Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiColumnFormat Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : dbiColumnFormat Constructor

Initializes a new instance of the dbiColumnFormat class. Initializes a new instance of the dbiColumnFormat class.

Overload List

Overload | Description
dbiColumnFormat Constructor() | Initializes a new instance of the dbiColumnFormat class.
dbiColumnFormat Constructor(XmlNodeList) | Initializes a new instance of the dbiColumnFormat class based on the supplied XmlNodeList.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

dbiColumnFormat Constructor()
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class > dbiColumnFormat Constructor : dbiColumnFormat Constructor()

Initializes a new instance of the dbiColumnFormat class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiColumnFormat()
C#
public dbiColumnFormat()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members
Overload List


%%PageItemTitle%%

dbiColumnFormat Constructor(XmlNodeList)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class > dbiColumnFormat Constructor : dbiColumnFormat Constructor(XmlNodeList)

xmlNodes
A collection of XMLNodes.
Initializes a new instance of the dbiColumnFormat class based on the supplied XmlNodeList.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiColumnFormat(xmlNodes)
C#
public dbiColumnFormat(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
A collection of XMLNodes.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members
Overload List


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : BackColor Property

Determines the background color of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

BackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : BackColorTo Property

Determines the secondary background color of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

CheckAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : CheckAlign Property

Determines the alignment of the check box in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As enumAlignment

instance.CheckAlign = value

value = instance.CheckAlign
C#
public enumAlignment CheckAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

CheckBox Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : CheckBox Property

Determines the style of the checkbox to use in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As enumCheckBox

instance.CheckBox = value

value = instance.CheckBox
C#
public enumCheckBox CheckBox {get; set;}

Property Value

enumCheckBox Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members
enumCheckBox Enumeration


%%PageItemTitle%%

DateFormat Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : DateFormat Property

Defines how DateTime values are formatted and displayed in each cell of the column, depending on the culture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
public System.string DateFormat {get; set;}

Property Value

String

Remarks

Only applicable on a column that has the DataType Property set to DateTime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

FillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : FillType Property

Determines the fill pattern of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Property Value

enumFillType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : Font Property

Determines the font of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : ForeColor Property

Determines the forecolor of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

ImageAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : ImageAlign Property

Determines the vertical and horizontal alignment of the image in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As enumAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public enumAlignment ImageAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

TextAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : TextAlign Property

Determines the vertical and horizontal alignment of the text in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As enumAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public enumAlignment TextAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

WordWrap Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : WordWrap Property

Determines if the text in the column will wrap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.Boolean

instance.WordWrap = value

value = instance.WordWrap
C#
public System.bool WordWrap {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

XMLString Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnFormat Class : XMLString Property

Determines an Xml string to read the data or write the data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnFormat
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnFormat Class
dbiColumnFormat Members


%%PageItemTitle%%

dbiColumnItem Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnItem Class

Provides the properties for defining columns.

Object Model

dbiColumnItem ClassdbiColumnFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
C#
public class dbiColumnItem

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiColumnItem Class Members
See Also Properties Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnItem Class

"

The following tables list the members exposed by dbiColumnItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiColumnItem Constructor | Overloaded. Initializes a new instance of the dbiColumnFormat class.
Top

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the column header.
public Property | BackColorTo | Determines the secondary background color of the column header.
public Property | DataType | Determines the data type to assign to the column.
public Property | EditType | Determines the type of edit control to be used when editing cells in the column.
public Property | FillType | Determines the fill pattern of the column header.
public Property | ForeColor | Determines the forecolor of the column header.
public Property | Format | Determines a format for the column in the list.
public Property | ImageAlign | Determines the alignment of the image in the column.
public Property | ImageIndex | Determines the column header image.
public Property | Items | Determines the list of items used to populate a combo box that belongs to this column
public Property | LockWidth | Determines if the column can be resized.
public Property | ReadOnly | Determines if the column is readonly.
public Property | Sortable | Determines if the column is sortable.
public Property | Text | The column header text.
public Property | TextAlign | Determines the alignment of the column header
public Property | Visible | Determines if the column is visible.
public Property | Width | Determines the width of the column.
public Property | XMLString | Determines an Xml string to read the data or write the data.
Top

Public Methods

 | Name | Description
public Method | SetXMLValues | Sets the properties of the dbiColumnItem, based on the supplied XmlNodeList.
Top

See Also

Reference

dbiColumnItem Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiColumnItem Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : dbiColumnItem Constructor

Initializes a new instance of the dbiColumnFormat class. Initializes a new instance of the dbiColumnItem class

Overload List

Overload | Description
dbiColumnItem Constructor() | Initializes a new instance of the dbiColumnItem class
dbiColumnItem Constructor(String) | Initializes a new instance of the dbiColumnItem class setting the Text Property to the string parameter.
dbiColumnItem Constructor(String,Int32) | Initializes a new instance of the dbiColumnItem class with the Text Property set to the value of the string parameter and the Width Property set to the int32 parameter.
dbiColumnItem Constructor(XmlNodeList) | Initializes a new instance of the dbiColumnItem class based on the XML nodes parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

dbiColumnItem Constructor()
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor()

Initializes a new instance of the dbiColumnItem class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiColumnItem()
C#
public dbiColumnItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

dbiColumnItem Constructor(String)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor(String)

strText
The text to display in the column's header.
Initializes a new instance of the dbiColumnItem class setting the Text Property to the string parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String

Dim instance As New dbiColumnItem(strText)
C#
public dbiColumnItem(
   System.string strText
)

Parameters

strText
The text to display in the column's header.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

dbiColumnItem Constructor(String,Int32)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor(String,Int32)

strText
The text to display in the column's header.
nWidth
The width to assign the column.
Initializes a new instance of the dbiColumnItem class with the Text Property set to the value of the string parameter and the Width Property set to the int32 parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String
Dim nWidth As System.Integer

Dim instance As New dbiColumnItem(strText, nWidth)
C#
public dbiColumnItem(
   System.string strText,
   System.int nWidth
)

Parameters

strText
The text to display in the column's header.
nWidth
The width to assign the column.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

dbiColumnItem Constructor(XmlNodeList)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class > dbiColumnItem Constructor : dbiColumnItem Constructor(XmlNodeList)

xmlNodes
A collection of XMLNodes.
Initializes a new instance of the dbiColumnItem class based on the XML nodes parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiColumnItem(xmlNodes)
C#
public dbiColumnItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
A collection of XMLNodes.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members
Overload List


%%PageItemTitle%%

SetXMLValues Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : SetXMLValues Method

xmlNodes
The XmlNodeList to assign values from.
Sets the properties of the dbiColumnItem, based on the supplied XmlNodeList.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim xmlNodes As System.Xml.XmlNodeList

instance.SetXMLValues(xmlNodes)
C#
public void SetXMLValues(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XmlNodeList to assign values from.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : BackColor Property

Determines the background color of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

BackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : BackColorTo Property

Determines the secondary background color of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

DataType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : DataType Property

Determines the data type to assign to the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumDataType

instance.DataType = value

value = instance.DataType
C#
public enumDataType DataType {get; set;}

Property Value

enumDataType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

EditType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : EditType Property

Determines the type of edit control to be used when editing cells in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumEditType

instance.EditType = value

value = instance.EditType
C#
public enumEditType EditType {get; set;}

Property Value

enumerated value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

FillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : FillType Property

Determines the fill pattern of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Property Value

enumFillType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : ForeColor Property

Determines the forecolor of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Format Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Format Property

Determines a format for the column in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As dbiColumnFormat

instance.Format = value

value = instance.Format
C#
public dbiColumnFormat Format {get; set;}

Property Value

dbiColumnFormat Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : ImageAlign Property

Determines the alignment of the image in the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public enumAlignment ImageAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ImageIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : ImageIndex Property

Determines the column header image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Items Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Items Property

Determines the list of items used to populate a combo box that belongs to this column

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Collections.ArrayList

value = instance.Items
C#
public System.Collections.ArrayList Items {get;}

Property Value

ArrayList

Remarks

Will only be used if the EditType property of the column is equal to "ComboBox".

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

LockWidth Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : LockWidth Property

Determines if the column can be resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Boolean

instance.LockWidth = value

value = instance.LockWidth
C#
public System.bool LockWidth {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

ReadOnly Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : ReadOnly Property

Determines if the column is readonly.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public System.bool ReadOnly {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Sortable Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Sortable Property

Determines if the column is sortable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Boolean

instance.Sortable = value

value = instance.Sortable
C#
public System.bool Sortable {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Text Property

The column header text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

TextAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : TextAlign Property

Determines the alignment of the column header

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As enumAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public enumAlignment TextAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Visible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Visible Property

Determines if the column is visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : Width Property

Determines the width of the column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

XMLString Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiColumnItem Class : XMLString Property

Determines an Xml string to read the data or write the data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiColumnItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiColumnItem Class
dbiColumnItem Members


%%PageItemTitle%%

dbiComboBox Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiComboBox Class

A custom ComboBox class.

Object Model

dbiComboBox Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
C#
public class dbiComboBox : System.Windows.Forms.ComboBox

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Dbi.WinControl.dbiComboBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiComboBox Class Members
See Also Properties Methods Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiComboBox Class

"

The following tables list the members exposed by dbiComboBox.

"

Public Constructors

 | Name | Description
public Constructor | dbiComboBox Constructor | The default constructor.
Top

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoCompleteCustomSource | Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.ComboBox.AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.ComboBox)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DataSource | Gets or sets the data source for this System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayMember | Gets or sets the property to display for this System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownStyle | Gets or sets a value specifying the style of the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | DroppedDown | Gets or sets a value indicating whether the combo box is displaying its drop-down portion. (Inherited from System.Windows.Forms.ComboBox)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | FlatStyle | Gets or sets the appearance of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | Focused | Gets a value indicating whether the System.Windows.Forms.ComboBox has focus. (Inherited from System.Windows.Forms.ComboBox)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.ComboBox)
public Property | FormatInfo | Gets or sets the System.IFormatProvider that provides custom formatting behavior. (Inherited from System.Windows.Forms.ListControl)
public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from System.Windows.Forms.ListControl)
public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the System.Windows.Forms.ListControl.DisplayMember property of the System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from System.Windows.Forms.ComboBox)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemHeight | Gets or sets the height of an item in the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | Items | Gets an object representing the collection of the items contained in this System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | MaximumSize | Gets or sets the size that is the upper limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify. (Inherited from System.Windows.Forms.ComboBox)
public Property | MaxLength | Gets or sets the number of characters a user can type into the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | MinimumSize | Gets or sets the size that is the lower limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify. (Inherited from System.Windows.Forms.ComboBox)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PreferredHeight | Gets the preferred height of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedItem | Gets or sets currently selected item in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedText | Gets or sets the text that is selected in the editable portion of a System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedValue | Gets or sets the value of the member property specified by the System.Windows.Forms.ListControl.ValueMember property. (Inherited from System.Windows.Forms.ListControl)
public Property | SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectionStart | Gets or sets the starting index of text selected in the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from System.Windows.Forms.ComboBox)
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.ComboBox)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BeginUpdate | Maintains performance when items are added to the System.Windows.Forms.ComboBox one at a time. (Inherited from System.Windows.Forms.ComboBox)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EndUpdate | Resumes painting the System.Windows.Forms.ComboBox control after painting is suspended by the System.Windows.Forms.ComboBox.BeginUpdate method. (Inherited from System.Windows.Forms.ComboBox)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | FindString | Overloaded. Returns the index of the first item in the System.Windows.Forms.ComboBox that starts with the specified string. (Inherited from System.Windows.Forms.ComboBox)
public Method | FindStringExact | Overloaded. Finds the first item in the combo box that matches the specified string. (Inherited from System.Windows.Forms.ComboBox)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetItemHeight | Returns the height of an item in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | GetItemText | Returns the text representation of the specified item. (Inherited from System.Windows.Forms.ListControl)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.ComboBox)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | Select | Overloaded. Selects a range of text in the editable portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | SelectAll | Selects all the text in the editable portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Returns a string that represents the System.Windows.Forms.ComboBox control. (Inherited from System.Windows.Forms.ComboBox)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DataSourceChanged | Occurs when the System.Windows.Forms.ListControl.DataSource changes. (Inherited from System.Windows.Forms.ListControl)
public Event | DisplayMemberChanged | Occurs when the System.Windows.Forms.ListControl.DisplayMember property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DrawItem | Occurs when a visual aspect of an owner-drawn System.Windows.Forms.ComboBox changes. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDown | Occurs when the drop-down portion of a System.Windows.Forms.ComboBox is shown. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDownClosed | Occurs when the drop-down portion of the System.Windows.Forms.ComboBox is no longer visible. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDownStyleChanged | Occurs when the System.Windows.Forms.ComboBox.DropDownStyle property has changed. (Inherited from System.Windows.Forms.ComboBox)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Format | Occurs when the control is bound to a data value. (Inherited from System.Windows.Forms.ListControl)
public Event | FormatInfoChanged | Occurs when the value of the System.Windows.Forms.ListControl.FormatInfo property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | FormatStringChanged | Occurs when value of the System.Windows.Forms.ListControl.FormatString property changes (Inherited from System.Windows.Forms.ListControl)
public Event | FormattingEnabledChanged | Occurs when the value of the System.Windows.Forms.ListControl.FormattingEnabled property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MeasureItem | Occurs each time an owner-drawn System.Windows.Forms.ComboBox item needs to be drawn and when the sizes of the list items are determined. (Inherited from System.Windows.Forms.ComboBox)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SelectedIndexChanged | Occurs when the System.Windows.Forms.ComboBox.SelectedIndex property has changed. (Inherited from System.Windows.Forms.ComboBox)
public Event | SelectedValueChanged | Occurs when the System.Windows.Forms.ListControl.SelectedValue property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | SelectionChangeCommitted | Occurs when the user changes the selected item and that change is displayed in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextUpdate | Occurs when the control has formatted the text, but before the text is displayed. (Inherited from System.Windows.Forms.ComboBox)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | ValueMemberChanged | Occurs when the System.Windows.Forms.ListControl.ValueMember property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiComboBox Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiComboBox Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : dbiComboBox Constructor

objParent
The dbiListControl parent for the combobox.
The default constructor.

Syntax

Visual Basic (Usage) Copy Code
Dim objParent As DbiListControl

Dim instance As New dbiComboBox(objParent)
C#
public dbiComboBox(
   DbiListControl objParent
)

Parameters

objParent
The dbiListControl parent for the combobox.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BeginInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BeginUpdate Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BeginUpdate Method

Maintains performance when items are added to the System.Windows.Forms.ComboBox one at a time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.BeginUpdate()
C#
public void BeginUpdate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BringToFront Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Contains Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CreateControl() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CreateGraphics Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CreateObjRef Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Dispose() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Dispose() Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DoDragDrop Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

EndInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

EndUpdate Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : EndUpdate Method

Resumes painting the System.Windows.Forms.ComboBox control after painting is suspended by the System.Windows.Forms.ComboBox.BeginUpdate method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.EndUpdate()
C#
public void EndUpdate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FindForm Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FindString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FindString Method

Returns the index of the first item in the System.Windows.Forms.ComboBox that starts with the specified string.

Overload List

Overload | Description
FindString(String) | Returns the index of the first item in the System.Windows.Forms.ComboBox that starts with the specified string. (Inherited from System.Windows.Forms.ComboBox)
FindString(String,Int32) | Returns the index of the first item in the System.Windows.Forms.ComboBox beyond the specified index that contains the specified string. The search is not case sensitive. (Inherited from System.Windows.Forms.ComboBox)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FindStringExact Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FindStringExact Method

Finds the first item in the combo box that matches the specified string.

Overload List

Overload | Description
FindStringExact(String) | Finds the first item in the combo box that matches the specified string. (Inherited from System.Windows.Forms.ComboBox)
FindStringExact(String,Int32) | Finds the first item after the specified index that matches the specified string. (Inherited from System.Windows.Forms.ComboBox)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Focus Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetContainerControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetItemHeight Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetItemHeight Method

index
The index of the item to return the height of.
Returns the height of an item in the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim index As System.Integer
Dim value As System.Integer

value = instance.GetItemHeight(index)
C#
public System.int GetItemHeight(
   System.int index
)

Parameters

index
The index of the item to return the height of.

Return Value

The height, in pixels, of the item at the specified index.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The index is less than zero.-or- The index is greater than count of items in the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetItemText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetItemText Method

item
The object from which to get the contents to display.
Returns the text representation of the specified item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim item As System.Object
Dim value As System.String

value = instance.GetItemText(item)
C#
public System.string GetItemText(
   System.object item
)

Parameters

item
The object from which to get the contents to display.

Return Value

If the System.Windows.Forms.ListControl.DisplayMember property is not specified, the value returned by System.Windows.Forms.ListControl.GetItemText(System.Object) is the value of the item's ToString method. Otherwise, the method returns the string value of the member specified in the System.Windows.Forms.ListControl.DisplayMember property for the object specified in the item parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Hide Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Invalidate Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Invoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PerformLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PointToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PointToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RectangleToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Refresh Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ResetText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ResetText Method

Resets the System.Windows.Forms.Control.Text property to its default value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ResumeLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Select Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Select Method

Selects a range of text in the editable portion of the System.Windows.Forms.ComboBox.

Overload List

Overload | Description
Select(Int32,Int32) | Selects a range of text in the editable portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
Select() | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectAll Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectAll Method

Selects all the text in the editable portion of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.SelectAll()
C#
public void SelectAll()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SendToBack Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SetBounds Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Show Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SuspendLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ToString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ToString Method

Returns a string that represents the System.Windows.Forms.ComboBox control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Return Value

A System.String that represents the current System.Windows.Forms.ComboBox. The string includes the type and the number of items in the System.Windows.Forms.ComboBox control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Update Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AccessibleName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AccessibleRole Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AllowDrop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Anchor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AutoCompleteCustomSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AutoCompleteCustomSource Property

Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.ComboBox.AutoCompleteSource property is set to CustomSource.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AutoCompleteStringCollection

instance.AutoCompleteCustomSource = value

value = instance.AutoCompleteCustomSource
C#
public System.Windows.Forms.AutoCompleteStringCollection AutoCompleteCustomSource {get; set;}

Property Value

A System.Collections.Specialized.StringCollection to use with System.Windows.Forms.ComboBox.AutoCompleteSource.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AutoCompleteMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AutoCompleteMode Property

Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AutoCompleteMode

instance.AutoCompleteMode = value

value = instance.AutoCompleteMode
C#
public System.Windows.Forms.AutoCompleteMode AutoCompleteMode {get; set;}

Property Value

One of the values of System.Windows.Forms.AutoCompleteMode. The values are System.Windows.Forms.AutoCompleteMode.Append, System.Windows.Forms.AutoCompleteMode.None, System.Windows.Forms.AutoCompleteMode.Suggest, and System.Windows.Forms.AutoCompleteMode.SuggestAppend. The default is System.Windows.Forms.AutoCompleteMode.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value is not one of the values of System.Windows.Forms.AutoCompleteMode.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AutoCompleteSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AutoCompleteSource Property

Gets or sets a value specifying the source of complete strings used for automatic completion.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.AutoCompleteSource

instance.AutoCompleteSource = value

value = instance.AutoCompleteSource
C#
public System.Windows.Forms.AutoCompleteSource AutoCompleteSource {get; set;}

Property Value

One of the values of System.Windows.Forms.AutoCompleteSource. The options are AllSystemSources, AllUrl, FileSystem, HistoryList, RecentlyUsedList, CustomSource, and None. The default is None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value is not one of the values of System.Windows.Forms.AutoCompleteSource.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BackColor Property

Gets or sets the background color for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A color object that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BindingContext Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Bottom Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Bounds Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CanFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CanSelect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Capture Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CausesValidation Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ClientRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ClientSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ClientSize Property

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CompanyName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Container Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ContainsFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ContextMenu Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Controls Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Created Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Cursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DataBindings Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DataSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DataSource Property

Gets or sets the data source for this System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

instance.DataSource = value

value = instance.DataSource
C#
public System.object DataSource {get; set;}

Property Value

An object that implements the System.Collections.IList interface or an System.Array. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DeviceDpi Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DisplayMember Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DisplayMember Property

Gets or sets the property to display for this System.Windows.Forms.ListControl.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.DisplayMember = value

value = instance.DisplayMember
C#
public System.string DisplayMember {get; set;}

Property Value

A System.String specifying the name of an object property that is contained in the collection specified by the System.Windows.Forms.ListControl.DataSource property. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DisplayRectangle Property

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Disposing Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Dock Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DrawMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DrawMode Property

Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.DrawMode

instance.DrawMode = value

value = instance.DrawMode
C#
public System.Windows.Forms.DrawMode DrawMode {get; set;}

Property Value

One of the System.Windows.Forms.DrawMode enumeration values. The default is System.Windows.Forms.DrawMode.Normal.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value is not a valid System.Windows.Forms.DrawMode enumeration value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDownHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDownHeight Property

Gets or sets the height in pixels of the drop-down portion of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.DropDownHeight = value

value = instance.DropDownHeight
C#
public System.int DropDownHeight {get; set;}

Property Value

The height, in pixels, of the drop-down box.

Exceptions

Exception | Description
System.ArgumentException | The specified value is less than one.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDownStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDownStyle Property

Gets or sets a value specifying the style of the combo box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ComboBoxStyle

instance.DropDownStyle = value

value = instance.DropDownStyle
C#
public System.Windows.Forms.ComboBoxStyle DropDownStyle {get; set;}

Property Value

One of the System.Windows.Forms.ComboBoxStyle values. The default is DropDown.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ComboBoxStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDownWidth Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDownWidth Property

Gets or sets the width of the of the drop-down portion of a combo box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.DropDownWidth = value

value = instance.DropDownWidth
C#
public System.int DropDownWidth {get; set;}

Property Value

The width, in pixels, of the drop-down box.

Exceptions

Exception | Description
System.ArgumentException | The specified value is less than one.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DroppedDown Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DroppedDown Property

Gets or sets a value indicating whether the combo box is displaying its drop-down portion.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.DroppedDown = value

value = instance.DroppedDown
C#
public System.bool DroppedDown {get; set;}

Property Value

true if the drop-down portion is displayed; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Enabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FlatStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FlatStyle Property

Gets or sets the appearance of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.FlatStyle

instance.FlatStyle = value

value = instance.FlatStyle
C#
public System.Windows.Forms.FlatStyle FlatStyle {get; set;}

Property Value

One of the enumeration values that specifies the appearance of the control. The options are Flat, Popup, Standard, and System. The default is Standard.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value is not one of the values of System.Windows.Forms.FlatStyle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Focused Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Focused Property

Gets a value indicating whether the System.Windows.Forms.ComboBox has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if this control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ForeColor Property

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

The foreground color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormatInfo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormatInfo Property

Gets or sets the System.IFormatProvider that provides custom formatting behavior.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.IFormatProvider

instance.FormatInfo = value

value = instance.FormatInfo
C#
public System.IFormatProvider FormatInfo {get; set;}

Property Value

The System.IFormatProvider implementation that provides custom formatting behavior.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormatString Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormatString Property

Gets or sets the format-specifier characters that indicate how a value is to be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.FormatString = value

value = instance.FormatString
C#
public System.string FormatString {get; set;}

Property Value

The string of format-specifier characters that indicates how a value is to be displayed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormattingEnabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormattingEnabled Property

Gets or sets a value indicating whether formatting is applied to the System.Windows.Forms.ListControl.DisplayMember property of the System.Windows.Forms.ListControl.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.FormattingEnabled = value

value = instance.FormattingEnabled
C#
public System.bool FormattingEnabled {get; set;}

Property Value

true if formatting of the System.Windows.Forms.ListControl.DisplayMember property is enabled; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Handle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

HasChildren Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Height Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ImeMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

IntegralHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : IntegralHeight Property

Gets or sets a value indicating whether the control should resize to avoid showing partial items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.IntegralHeight = value

value = instance.IntegralHeight
C#
public System.bool IntegralHeight {get; set;}

Property Value

true if the list portion can contain only complete items; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

InvokeRequired Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

IsAccessible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

IsDisposed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

IsMirrored Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ItemHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ItemHeight Property

Gets or sets the height of an item in the combo box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.ItemHeight = value

value = instance.ItemHeight
C#
public System.int ItemHeight {get; set;}

Property Value

The height, in pixels, of an item in the combo box.

Exceptions

Exception | Description
System.ArgumentException | The item height value is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Items Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Items Property

Gets an object representing the collection of the items contained in this System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.ComboBox.ObjectCollection

value = instance.Items
C#
public System.Windows.Forms.ComboBox.ObjectCollection Items {get;}

Property Value

A System.Windows.Forms.ComboBox.ObjectCollection representing the items in the System.Windows.Forms.ComboBox.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

LayoutEngine Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Left Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Location Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Margin Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
C#
public System.Windows.Forms.Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MaxDropDownItems Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MaxDropDownItems Property

Gets or sets the maximum number of items to be shown in the drop-down portion of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.MaxDropDownItems = value

value = instance.MaxDropDownItems
C#
public System.int MaxDropDownItems {get; set;}

Property Value

The maximum number of items of in the drop-down portion. The minimum for this property is 1 and the maximum is 100.

Exceptions

Exception | Description
System.ArgumentException | The maximum number is set less than one or greater than 100.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MaximumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MaximumSize Property

Gets or sets the size that is the upper limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MaxLength Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MaxLength Property

Gets or sets the number of characters a user can type into the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.MaxLength = value

value = instance.MaxLength
C#
public System.int MaxLength {get; set;}

Property Value

The maximum number of characters a user can enter. Values of less than zero are reset to zero, which is the default value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MinimumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MinimumSize Property

Gets or sets the size that is the lower limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Name Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Parent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PreferredHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PreferredHeight Property

Gets the preferred height of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

value = instance.PreferredHeight
C#
public System.int PreferredHeight {get;}

Property Value

The preferred height, in pixels, of the item area of the combo box.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PreferredSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ProductName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ProductVersion Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Region Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Right Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RightToLeft Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedIndex Property

Gets or sets the index specifying the currently selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.SelectedIndex = value

value = instance.SelectedIndex
C#
public virtual System.int SelectedIndex {get; set;}

Property Value

A zero-based index of the currently selected item. A value of negative one (-1) is returned if no item is selected.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The specified index is less than or equal to -2.-or- The specified index is greater than or equal to the number of items in the combo box.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedItem Property

Gets or sets currently selected item in the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

instance.SelectedItem = value

value = instance.SelectedItem
C#
public System.object SelectedItem {get; set;}

Property Value

The object that is the currently selected item or null if there is no currently selected item.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedText Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedText Property

Gets or sets the text that is selected in the editable portion of a System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.SelectedText = value

value = instance.SelectedText
C#
public System.string SelectedText {get; set;}

Property Value

A string that represents the currently selected text in the combo box. If System.Windows.Forms.ComboBox.DropDownStyle is set to System.Windows.Forms.ComboBoxStyle.DropDownList, the return value is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedValue Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedValue Property

Gets or sets the value of the member property specified by the System.Windows.Forms.ListControl.ValueMember property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

instance.SelectedValue = value

value = instance.SelectedValue
C#
public System.object SelectedValue {get; set;}

Property Value

An object containing the value of the member of the data source specified by the System.Windows.Forms.ListControl.ValueMember property.

Exceptions

Exception | Description
System.InvalidOperationException | The assigned value is null or the empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectionLength Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectionLength Property

Gets or sets the number of characters selected in the editable portion of the combo box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.SelectionLength = value

value = instance.SelectionLength
C#
public System.int SelectionLength {get; set;}

Property Value

The number of characters selected in the combo box.

Exceptions

Exception | Description
System.ArgumentException | The value was less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectionStart Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectionStart Property

Gets or sets the starting index of text selected in the combo box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.SelectionStart = value

value = instance.SelectionStart
C#
public System.int SelectionStart {get; set;}

Property Value

The zero-based index of the first character in the string of the current text selection.

Exceptions

Exception | Description
System.ArgumentException | The value is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Site Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Size Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Size Property

Gets or sets the height and width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Sorted Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Sorted Property

Gets or sets a value indicating whether the items in the combo box are sorted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.Sorted = value

value = instance.Sorted
C#
public System.bool Sorted {get; set;}

Property Value

true if the combo box is sorted; otherwise, false. The default is false.

Exceptions

Exception | Description
System.ArgumentException | An attempt was made to sort a System.Windows.Forms.ComboBox that is attached to a data source.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TabIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TabIndex Property

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public System.int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TabStop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
C#
public System.bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true.This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Tag Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Top Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TopLevelControl Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ValueMember Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ValueMember Property

Gets or sets the path of the property to use as the actual value for the items in the System.Windows.Forms.ListControl.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.String

instance.ValueMember = value

value = instance.ValueMember
C#
public System.string ValueMember {get; set;}

Property Value

A System.String representing a single property name of the System.Windows.Forms.ListControl.DataSource property value, or a hierarchy of period-delimited property names that resolves to a property name of the final data-bound object. The default is an empty string ("").

Exceptions

Exception | Description
System.ArgumentException | The specified property path cannot be resolved through the object specified by the System.Windows.Forms.ListControl.DataSource property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Visible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BackColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ChangeUICues Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Click Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ControlAdded Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ControlRemoved Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

CursorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DataSourceChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DataSourceChanged Event

Occurs when the System.Windows.Forms.ListControl.DataSource changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DataSourceChanged, handler
C#
public event System.EventHandler DataSourceChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DisplayMemberChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DisplayMemberChanged Event

Occurs when the System.Windows.Forms.ListControl.DisplayMember property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DisplayMemberChanged, handler
C#
public event System.EventHandler DisplayMemberChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Disposed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DockChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DragDrop Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DragEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DragLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DragOver Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DrawItem Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DrawItem Event

Occurs when a visual aspect of an owner-drawn System.Windows.Forms.ComboBox changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.DrawItemEventHandler

AddHandler instance.DrawItem, handler
C#
public event System.Windows.Forms.DrawItemEventHandler DrawItem

Event Data

The event handler receives an argument of type System.Windows.Forms.DrawItemEventArgs containing data related to this event. The following DrawItemEventArgs properties provide information specific to this event.

Property | Description
BackColor | Gets the background color of the item that is being drawn.
Bounds | Gets the rectangle that represents the bounds of the item that is being drawn.
Font | Gets the font that is assigned to the item being drawn.
ForeColor | Gets the foreground color of the of the item being drawn.
Graphics | Gets the graphics surface to draw the item on.
Index | Gets the index value of the item that is being drawn.
State | Gets the state of the item being drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDown Event

Occurs when the drop-down portion of a System.Windows.Forms.ComboBox is shown.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DropDown, handler
C#
public event System.EventHandler DropDown

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDownClosed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDownClosed Event

Occurs when the drop-down portion of the System.Windows.Forms.ComboBox is no longer visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DropDownClosed, handler
C#
public event System.EventHandler DropDownClosed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DropDownStyleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : DropDownStyleChanged Event

Occurs when the System.Windows.Forms.ComboBox.DropDownStyle property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.DropDownStyleChanged, handler
C#
public event System.EventHandler DropDownStyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

EnabledChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Enter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FontChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Format Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Format Event

Occurs when the control is bound to a data value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.ListControlConvertEventHandler

AddHandler instance.Format, handler
C#
public event System.Windows.Forms.ListControlConvertEventHandler Format

Event Data

The event handler receives an argument of type System.Windows.Forms.ListControlConvertEventArgs containing data related to this event. The following ListControlConvertEventArgs properties provide information specific to this event.

Property | Description
DesiredType (Inherited from System.Windows.Forms.ConvertEventArgs) | Gets the data type of the desired value.
ListItem | Gets a data source item.
Value (Inherited from System.Windows.Forms.ConvertEventArgs) | Gets or sets the value of the System.Windows.Forms.ConvertEventArgs.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormatInfoChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormatInfoChanged Event

Occurs when the value of the System.Windows.Forms.ListControl.FormatInfo property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.FormatInfoChanged, handler
C#
public event System.EventHandler FormatInfoChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormatStringChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormatStringChanged Event

Occurs when value of the System.Windows.Forms.ListControl.FormatString property changes

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.FormatStringChanged, handler
C#
public event System.EventHandler FormatStringChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FormattingEnabledChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : FormattingEnabledChanged Event

Occurs when the value of the System.Windows.Forms.ListControl.FormattingEnabled property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.FormattingEnabledChanged, handler
C#
public event System.EventHandler FormattingEnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GiveFeedback Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

GotFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

HandleCreated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

HelpRequested Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Invalidated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

KeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

KeyPress Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

KeyUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Layout Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Leave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

LocationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

LostFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MarginChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MarginChanged Event

Occurs when the control's margin changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
C#
public event System.EventHandler MarginChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MeasureItem Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MeasureItem Event

Occurs each time an owner-drawn System.Windows.Forms.ComboBox item needs to be drawn and when the sizes of the list items are determined.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MeasureItemEventHandler

AddHandler instance.MeasureItem, handler
C#
public event System.Windows.Forms.MeasureItemEventHandler MeasureItem

Event Data

The event handler receives an argument of type System.Windows.Forms.MeasureItemEventArgs containing data related to this event. The following MeasureItemEventArgs properties provide information specific to this event.

Property | Description
Graphics | Gets the System.Drawing.Graphics object to measure against.
Index | Gets the index of the item for which the height and width is needed.
ItemHeight | Gets or sets the height of the item specified by the System.Windows.Forms.MeasureItemEventArgs.Index.
ItemWidth | Gets or sets the width of the item specified by the System.Windows.Forms.MeasureItemEventArgs.Index.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseHover Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseMove Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

MouseWheel Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Move Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ParentChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RegionChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Resize Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedIndexChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedIndexChanged Event

Occurs when the System.Windows.Forms.ComboBox.SelectedIndex property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.SelectedIndexChanged, handler
C#
public event System.EventHandler SelectedIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectedValueChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectedValueChanged Event

Occurs when the System.Windows.Forms.ListControl.SelectedValue property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.SelectedValueChanged, handler
C#
public event System.EventHandler SelectedValueChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SelectionChangeCommitted Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SelectionChangeCommitted Event

Occurs when the user changes the selected item and that change is displayed in the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.SelectionChangeCommitted, handler
C#
public event System.EventHandler SelectionChangeCommitted

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

StyleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TabIndexChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TabIndexChanged Event

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
C#
public event System.EventHandler TabIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TabStopChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TabStopChanged Event

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
C#
public event System.EventHandler TabStopChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

TextUpdate Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : TextUpdate Event

Occurs when the control has formatted the text, but before the text is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.TextUpdate, handler
C#
public event System.EventHandler TextUpdate

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Validated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Validating Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

ValueMemberChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : ValueMemberChanged Event

Occurs when the System.Windows.Forms.ListControl.ValueMember property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.ValueMemberChanged, handler
C#
public event System.EventHandler ValueMemberChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

VisibleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

DbiListControl Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl Class

The base dbiList control.

Object Model

DbiListControl ClassdbiColumnItem ClassdbiColumnFormat ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiTextBox Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
C#
public class DbiListControl : Dbi.dbiControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Dbi.WinControl.DbiListControl
Dbi.WinControl.Schedule.dbiSchedule

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

DbiListControl Class Members
See Also Properties Methods Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl Class

"

The following tables list the members exposed by DbiListControl.

"

Public Constructors

 | Name | Description
public Constructor | DbiListControl Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowItemDrag | Determines if dbiNodeItems can be dragged and dropped within the list area.
public Property | AltColorEven | Determines the background color of an even numbered list item in the control.
public Property | AltColorOdd | Determines the background color of an odd numbered list item in the control.
public Property | AlternateColor | Determines whether or not the list items will be drawn with alternating background colors.
public Property | AlternateItems | Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd.
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | ArrowAlign | Determines on what side of a column header the sort arrows will be placed.
public Property | ArrowOffset | Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header.
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Determines the background color of the list items section.
public Property | BackgroundImage | Determines the background image for the control.
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BodyColumnEnd | Determines the final column for the body text in the items.
public Property | BodyColumnStart | Determines the starting column for the body text in the items.
public Property | BodyFont | Determines the font used to draw the body text of a item.
public Property | BodyForeColor | Determines the color used to paint the body text of an item.
public Property | BodyIndent | Determines the indent of the left margin spacing for the body text in the items.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | BreakChar | Determines the character used to delimit the text within the different columns.
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Columns | Gets the collection of columns.
public Property | ComboBox | Gets the current dbiComboBox control used for editing cells in the list.
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Culture | Determines information about a specific culture including the names of the culture, the writing system, and the calendar used, as well as access to culture-specific objects that provide information for common operations, such as formatting dates and sorting strings.
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Defines how DateTime values are formatted and displayed, depending on the culture.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayHeader | Determines whether or not the column headers will be displayed.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTitle | Determines whether or not the title will be displayed.
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | EditAutoNavigate | Determines if the control will automatically navigate to the next/previous cell when editing.
public Property | EditAutoSize | Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length.
public Property | EditColumn | Gets the dbiColumnItem relative to the current cell edit operation.
public Property | EditNode | Gets the dbiNodeItem that contains the cell being edited.
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | FillList | Determines whether the last column in a list will always extend the the edge of the list.
public Property | FocusBorder | Determines if a focus line will be drawn around the selected dbiNodeItem when the control has focus.
public Property | FocusColor | Determines the color used to paint the focus border.
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Overridden. Determines the foreground color of the items.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderAlign | Determines how the text in the column headers will be aligned.
public Property | HeaderBackColor | Determines the background color of the column headers.
public Property | HeaderBackColorMiddle | Determines the middle back color of the column header allowing for greater readability with certain fill types.
public Property | HeaderBackColorTo | Determines the secondary background color of the column headers.
public Property | HeaderBorder | Determines the border type for the column headers.
public Property | HeaderDownColor | Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed.
public Property | HeaderFillType | Determines the pattern used to paint the background of the column headers.
public Property | HeaderFont | Determines the font used for the text in the column headers of the control.
public Property | HeaderForeColor | Determines the foreground color of the column headers.
public Property | HeaderHeight | Determines the height of the column headers.
public Property | HeaderImageOffset | Determines the value used to calculate the horizontal and vertical position of the images within the column headers.
public Property | HeaderOverColor | Determines the color used to paint background when the mouse pointer is over the column header.
public Property | HeaderStyle | Determines the style of the column header.
public Property | HeaderTextImageRelation | Determines how the column header position of text and image relate to each other.
public Property | HeaderTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the column headers.
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HorzGridColor | Determines the color of the horizontal grid lines.
public Property | HorzGridLines | Determines whether or not horizontal grid lines will be drawn between the items.
public Property | HorzGridWidth | Determines the width of the horizontal grid lines.
public Property | HorzScrollType | Determines the horizontal scrolling action for the list.
public Property | ImageCheckDisabled | Determines the image used to replace the stock check disabled state item image.
public Property | ImageCheckDown | Determines the image used to replace the stock check down state item image.
public Property | ImageCheckUp | Determines the image used to replace the stock check up state item image.
public Property | ImageList | The image list for the control.
public Property | ImageMinus | Determines the image used to replace the stock close node image.
public Property | ImagePlus | Determines the image used to replace the stock open node image.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InactiveBackColor | Determines the color used to paint the background of a selected item when the control no longer has focus.
public Property | InactiveForeColor | Determines the color used to paint the text of a selected item when the control no longer has focus.
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemBorder | Determines the border type for the node items.
public Property | ItemDragColor | Determines the color of the drag bar when an item is dragged inside the list area.
public Property | ItemDragHeight | Determines the height of the drag bar when an item is dragged inside the list area.
public Property | ItemHeaderBackColor | Determines the default background color of all Header Items in the list.
public Property | ItemHeaderForeColor | Determines the default foreground color of all Header Items in the list.
public Property | ItemHeightOffset | Determines the offset value used to calculate the height of the line items.
public Property | ItemHeightType | Determines how the line item heights are calculated.
public Property | LabelEdit | Determines if a cell will be put into edit mode automatically, if the user double clicks it.
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineColor | Determines the color of list/tree connector lines.
public Property | LineType | Determines the list/tree connector line type.
public Property | ListType | Determines how the node items will be drawn in the control.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LockLineHeight | Determines whether the line items can be resized with the mouse.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MultiSelect | Allow the list to utilize multi-select mode (using ctrl/click and shift/click).
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PlusMinusStyle | Determines the style used when rendering the Plus/Minus boxes on parent nodes.
public Property | PreColumnBackColor | Determines the background color of the pre-column section of a non-selected item.
public Property | PreColumnBackColorTo | Determines the secondary background color of the pre-column section of a non-selected item.
public Property | PreColumnBorder | Determines the type of border to place around the pre-column section of a non-selected item.
public Property | PreColumnFillType | Determines the pattern used to paint the background of the pre-column section.
public Property | PreColumnFont | Determines the font used for the text in the pre-column section.
public Property | PreColumnForeColor | Determines the text color of the pre-column section of a non-selected item.
public Property | PreColumnPicture | Determines the picture clip within the pre-column section.
public Property | PreColumnType | Determines the pre-column to be used on the list part of the control.
public Property | PreColumnWidth | Determines the width of the pre-column in the list.
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | PreSelectBackColor | Determines the background color of the pre-column section of a selected list item.
public Property | PreSelectBorder | Determines the type of border to place around the pre-column section of a selected list item.
public Property | PreSelectForeColor | Determines the type of border to place around the pre-column section of a selected list item.
public Property | PrintHeaderBackColor | Determines the background color of the header in a printed report.
public Property | PrintHeaderForeColor | Determines the text color of the header in a printed report.
public Property | PrintItemBackColor | Determines the background color of the item in a printed report.
public Property | PrintItemForeColor | Determines the text color of the item in a printed report.
public Property | PrintPageControl | Used to determine if the control should print using the colors as rendered in the form (true) or as described in the PrintItemBackColor Property and PrintItemForeColor Property (false). Default is true.
public Property | PrintTitleBackColor | Determines the background color of the title in a printed report.
public Property | PrintTitleForeColor | Determines the text color of the title in a printed report.
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | SelectedBackColor | Determines the background color of a selected list item.
public Property | SelectedBackColorTo | Determines the second background color of a selected list item.
public Property | SelectedBorder | Determines the type of border to place around the selected item.
public Property | SelectedBorderColor | Determines the border color of a selected item.
public Property | SelectedFillType | Determines the pattern used to paint the background of the selected item.
public Property | SelectedFont | Determines the font used to draw the text of a selected item.
public Property | SelectedForeColor | Determines the text color of a selected list item.
public Property | SelectedStyle | Determines how the selection will be applied to the selected node(s). See enumSelectedStyle Enumeration for values.
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SortArrows | Determines whether or not arrows indicating the direction of the sort order will be displayed in the column headers.
public Property | SortColumn | Determines the column whose data a sort will be performed on. See Sort Method for more information on sorting in the list.
public Property | SortDirection | Determines the direction a sort operation will perform.
public Property | Sorted | Determines whether or not the list is currently sorted.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TextAntiAlias | Determines if the text within the control will be rendered using the Anti Alias option.
public Property | TextBox | Gets the current dbiTextBox control used for editing cells in the list.
public Property | TitleAlign | Determines the alignment for the text within the title section.
public Property | TitleBackColor | Determines the background color of the title section.
public Property | TitleBackColorMiddle | Determines the middle back color of the title section allowing for greater readability with certain fill types.
public Property | TitleBackColorTo | Determines the secondary background color of the title setction.
public Property | TitleBorder | Determines the border type for the title section.
public Property | TitleFillType | Determines the pattern used to paint the background of the title section.
public Property | TitleFont | Determines the font used for the text in the title of the control.
public Property | TitleForeColor | Determines the text color of the title section.
public Property | TitleHeight | Determines the height of the title setction.
public Property | TitleImage | Determines the image for the title section.
public Property | TitleImageAlign | Determines the image alignment for the title section.
public Property | TitleText | Determines the text of the title area.
public Property | TitleTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the title.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TreeLevelIndent | Determines the indent used to offset the text of each level of child nodes.
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VertGridColor | Determines the color of the vertical grid lines.
public Property | VertGridLines | Determines whether or not to draw vertical grid lines between the columns.
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ColumnAt | Overloaded. Gets the dbiColumnItem at a specified location
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EnsureVisible | Method to move the visible portion of the control to ensure that the node item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate.
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetNodeLevel | Returns the zero-based level within the nested structure of a specified node.
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RestoreCell | Reset internal items required for the edit mode.
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollToNode | Attempts to make a specified dbiNodeItem visible in the list display.
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | Sort | Overloaded. Will sort the list based on the dbiListControl.SortColumn property.
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
public Event | AfterCellEdit | Event fired after the editing of a cell has completed.
public Event | AfterColumnSort | Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired after the actual sort is performed.
public Event | AfterNodeCollapse | Event fired after a parent node has collapsed (hiding its child nodes).
public Event | AfterNodeExchange | Event fired after a node has been internally dragged/dropped was moved.
public Event | AfterNodeExpand | Event fired after a parent node has expanded (showing its child nodes).
public Event | AfterNodeSelect | Event fired after a node has been selected.
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BeforeCellEdit | Event fired before a cell is placed into an editable state.
public Event | BeforeCellTextDisplay | Event fires before the text is drawn in each cell.
public Event | BeforeColumnSort | Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired BEFORE the actual sort is performed.
public Event | BeforeNodeCollapse | Event fired before a parent node is collapsed (child nodes will be hidden).
public Event | BeforeNodeExchange | Event fired before a node that has been internally dragged/dropped is moved.
public Event | BeforeNodeExpand | Event fired before a parent node is expanded (child nodes will be made visible).
public Event | BeforeNodeSelect | Event fired before a node is selected in the control.
public Event | BeforePaint | Event fired before the control has painted the list.
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | Change | Event fired when a list item is selected.
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | CheckClick | Event fired when a check box in the list is clicked.
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DisplayUserControl | Event fired before a cell is placed into edit mode, allowing the developer to prepare and display their own control for the editing process.
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DropList | Event fired when an item is dropped into the list.
public Event | EditInputKey | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyDown | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyPress | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyUp | Event fired when a key is released inside the TextBox or ComboBox when editing a cell.
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HeaderClick | Event fired when the left mouse button clicks on a column header.
public Event | HeaderDoubleClick | Event fired when the left mouse button double clicks on a column header.
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InitializeCellEdit | Event fired before the cell edit operation is started
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | ItemLineHeightChanged | Event fired when the item height is changed.
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | ListMouseOver | Event fired when the mouse moves over a cell.
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | NodeClick | Event fired when the mouse clicks on a list item.
public Event | NodeDoubleClick | Event fired when the item is double-clicked.
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | RemoveUserControls | Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control.
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | UserDrawnCell | Event fired before a cell is drawn, allowing the developer to customize the display.
public Event | UserDrawnColumnHeader | Event fired before a column header is drawn, allowing the developer to customize the display.
public Event | UserDrawnNode | Event fired before a node is drawn, allowing the developer to customize the display.
public Event | UserDrawnTitle | Event fired before the title area is drawn, allowing the developer to customize the display.
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DbiListControl Class
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl Constructor()
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > DbiListControl Constructor : DbiListControl Constructor()

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl()
C#
public DbiListControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

BeginInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BringToFront Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ColumnAt Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ColumnAt Method

Gets the dbiColumnItem at a specified location

Overload List

Overload | Description
ColumnAt(Int32,Int32) | Gets the dbiColumnItem at a specified location
ColumnAt(Point) | Gets the dbiColumnItem at a specified location

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ColumnAt(Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > ColumnAt Method : ColumnAt(Int32,Int32) Method

nX
The X coordinate to test for a dbiColumnItem
nY
The Y coordinate to test for a dbiColumnItem
Gets the dbiColumnItem at a specified location

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As dbiColumnItem

value = instance.ColumnAt(nX, nY)
C#
public dbiColumnItem ColumnAt(
   System.int nX,
   System.int nY
)

Parameters

nX
The X coordinate to test for a dbiColumnItem
nY
The Y coordinate to test for a dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

ColumnAt(Point) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > ColumnAt Method : ColumnAt(Point) Method

ptPoint
The Point (X and Y coordinate) to test for a dbiColumnItem
Gets the dbiColumnItem at a specified location

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim ptPoint As System.Drawing.Point
Dim value As dbiColumnItem

value = instance.ColumnAt(ptPoint)
C#
public dbiColumnItem ColumnAt(
   System.Drawing.Point ptPoint
)

Parameters

ptPoint
The Point (X and Y coordinate) to test for a dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Contains Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CreateControl() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CreateGraphics Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CreateObjRef Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Dispose() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Dispose() Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DoDragDrop Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EndInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EnsureVisible Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EnsureVisible Method

objItem
dbiNodeItem Class
Method to move the visible portion of the control to ensure that the node item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim objItem As dbiNodeItem

instance.EnsureVisible(objItem)
C#
public void EnsureVisible(
   dbiNodeItem objItem
)

Parameters

objItem
dbiNodeItem Class

Remarks

The control calling this method will need to be fully instanced and drawn before this method can work. Calling this method before the control has fully rendered will result in the method failing. NOTE: If using an older version of the dbi4.dll base assembly, calling this method before the control has been fully instanced may result in an exception.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

FindForm Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Focus Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetContainerControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetNodeLevel Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetNodeLevel Method

objItem
The dbiNodeItem to find the level of.
Returns the zero-based level within the nested structure of a specified node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.GetNodeLevel(objItem)
C#
public System.int GetNodeLevel(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to find the level of.

Return Value

Integer

Remarks

A value of 0 indicates the node item exists directly in the control's primary collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Hide Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Invalidate Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Invoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PerformLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PointToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PointToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RectangleToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Refresh Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RestoreCell Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RestoreCell Method

Reset internal items required for the edit mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.RestoreCell()
C#
public void RestoreCell()

Remarks

This method should be called by the developer after the user has cancelled an edit operation, when using a custom edit control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ResumeLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ScrollToNode Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ScrollToNode Method

objNodeItem
The dbiNodeItem to scroll the view to
Attempts to make a specified dbiNodeItem visible in the list display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim objNodeItem As dbiNodeItem
Dim value As System.Boolean

value = instance.ScrollToNode(objNodeItem)
C#
public System.bool ScrollToNode(
   dbiNodeItem objNodeItem
)

Parameters

objNodeItem
The dbiNodeItem to scroll the view to

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Select() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SendToBack Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SetBounds Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Show Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Sort Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Sort Method

Will sort the list based on the dbiListControl.SortColumn property. Method to sort the dbiListControl

Overload List

Overload | Description
Sort() | Will sort the list based on the dbiListControl.SortColumn property.
Sort(Int32) | Will sort the list based on the 0-based column parameter. The SortColumn Property will change to reflect the value entered here.
Sort(Int32,Int32) | Method to sort the list based on a specified column index, and starting at the desired level
Sort(Int32[]) | Will sort the list based on the column(s) passed in the array parameter. The SortColumn Property will change to reflect the first column value entered here.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Sort() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Sort Method : Sort() Method

Will sort the list based on the dbiListControl.SortColumn property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.Sort()
C#
public System.bool Sort()

Return Value

Boolean value - True if sort completed, False if there is an error.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Sort(Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Sort Method : Sort(Int32) Method

nColumn
The zero-based index of the column to sort the items based on.
Will sort the list based on the 0-based column parameter. The SortColumn Property will change to reflect the value entered here.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.Sort(nColumn)
C#
public System.bool Sort(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the column to sort the items based on.

Return Value

Boolean value - True if sort completed, False if there is an error.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Sort(Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Sort Method : Sort(Int32,Int32) Method

nColumn
The zero-based index of the column to sort the items on
nLevels
The highest level to start the sort on (0 is the top most level)
Method to sort the list based on a specified column index, and starting at the desired level

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim nColumn As System.Integer
Dim nLevels As System.Integer
Dim value As System.Boolean

value = instance.Sort(nColumn, nLevels)
C#
public System.bool Sort(
   System.int nColumn,
   System.int nLevels
)

Parameters

nColumn
The zero-based index of the column to sort the items on
nLevels
The highest level to start the sort on (0 is the top most level)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Sort(Int32[]) Method
See Also Example
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Sort Method : Sort(Int32[]) Method

arrayColumns
An array of zero-based integers, representing the columns to sort the items on.
Will sort the list based on the column(s) passed in the array parameter. The SortColumn Property will change to reflect the first column value entered here.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim arrayColumns() As System.Integer
Dim value As System.Boolean

value = instance.Sort(arrayColumns)
C#
public System.bool Sort(
   System.int[] arrayColumns
)

Parameters

arrayColumns
An array of zero-based integers, representing the columns to sort the items on.

Return Value

Boolean value - True if sort completed, False if there is an error.

Example

Passing array of columns to the sort, specifically if we want to sort a multi-column list first on column 2 then on column 0.
Visual Basic Copy Code
Dim arrSort(1) As Integer
arrSort(0) = 2
arrSort(1) = 0

Me.dbiList1.Sort(arrSort)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

SuspendLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ToString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ToString Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Update Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AccessibleName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AccessibleRole Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AllowDrop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AllowItemDrag Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AllowItemDrag Property

Determines if dbiNodeItems can be dragged and dropped within the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.AllowItemDrag = value

value = instance.AllowItemDrag
C#
public System.bool AllowItemDrag {get; set;}

Property Value

Boolean

Remarks

This property will allow for built-in dragging and dropping of dbiNodeItems within their current parent.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AltColorEven Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AltColorEven Property

Determines the background color of an even numbered list item in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.AltColorEven = value

value = instance.AltColorEven
C#
public System.Drawing.Color AltColorEven {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AltColorOdd Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AltColorOdd Property

Determines the background color of an odd numbered list item in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.AltColorOdd = value

value = instance.AltColorOdd
C#
public System.Drawing.Color AltColorOdd {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AlternateColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AlternateColor Property

Determines whether or not the list items will be drawn with alternating background colors.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.AlternateColor = value

value = instance.AlternateColor
C#
public System.bool AlternateColor {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AlternateItems Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AlternateItems Property

Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.AlternateItems = value

value = instance.AlternateItems
C#
public System.int AlternateItems {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
AltColorEven Property
AltColorOdd Property
AlternateColor Property


%%PageItemTitle%%

Anchor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ArrowAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ArrowAlign Property

Determines on what side of a column header the sort arrows will be placed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumArrowAlign

instance.ArrowAlign = value

value = instance.ArrowAlign
C#
public enumArrowAlign ArrowAlign {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ArrowOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ArrowOffset Property

Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.ArrowOffset = value

value = instance.ArrowOffset
C#
public System.Drawing.Point ArrowOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackColor Property

Determines the background color of the list items section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual new System.Drawing.Color BackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackgroundImage Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackgroundImage Property

Determines the background image for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public virtual new System.Drawing.Image BackgroundImage {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackgroundImageLayout Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BindingContext Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BodyColumnEnd Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BodyColumnEnd Property

Determines the final column for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.BodyColumnEnd = value

value = instance.BodyColumnEnd
C#
public System.int BodyColumnEnd {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BodyColumnStart Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BodyColumnStart Property

Determines the starting column for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.BodyColumnStart = value

value = instance.BodyColumnStart
C#
public System.int BodyColumnStart {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BodyFont Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BodyFont Property

Determines the font used to draw the body text of a item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.BodyFont = value

value = instance.BodyFont
C#
public System.Drawing.Font BodyFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BodyForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BodyForeColor Property

Determines the color used to paint the body text of an item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.BodyForeColor = value

value = instance.BodyForeColor
C#
public System.Drawing.Color BodyForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BodyIndent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BodyIndent Property

Determines the indent of the left margin spacing for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.BodyIndent = value

value = instance.BodyIndent
C#
public System.int BodyIndent {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Bottom Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Bounds Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BreakChar Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BreakChar Property

Determines the character used to delimit the text within the different columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Char

instance.BreakChar = value

value = instance.BreakChar
C#
public System.char BreakChar {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CanFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CanSelect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Capture Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CausesValidation Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ClientRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ClientSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ClientSize Property

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Columns Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Columns Property

Gets the collection of columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As ColumnItemCollection

value = instance.Columns
C#
public ColumnItemCollection Columns {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ComboBox Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ComboBox Property

Gets the current dbiComboBox control used for editing cells in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As dbiComboBox

value = instance.ComboBox
C#
public dbiComboBox ComboBox {get;}

Property Value

dbiComboBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CompanyName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Container Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ContainsFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ContextMenu Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Controls Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Created Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Culture Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Culture Property

Determines information about a specific culture including the names of the culture, the writing system, and the calendar used, as well as access to culture-specific objects that provide information for common operations, such as formatting dates and sorting strings.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
C#
public System.Globalization.CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Cursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DataBindings Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DateFormat Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DateFormat Property

Defines how DateTime values are formatted and displayed, depending on the culture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
public System.string DateFormat {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DeviceDpi Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DisplayHeader Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DisplayHeader Property

Determines whether or not the column headers will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.DisplayHeader = value

value = instance.DisplayHeader
C#
public System.bool DisplayHeader {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DisplayRectangle Property

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DisplayTitle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DisplayTitle Property

Determines whether or not the title will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.DisplayTitle = value

value = instance.DisplayTitle
C#
public System.bool DisplayTitle {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Disposing Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Dock Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditAutoNavigate Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditAutoNavigate Property

Determines if the control will automatically navigate to the next/previous cell when editing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.EditAutoNavigate = value

value = instance.EditAutoNavigate
C#
public System.bool EditAutoNavigate {get; set;}

Property Value

boolean

Remarks

The <return>, <tab> and <shift><tab> keys can be used to navigate the editable cells of the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditAutoSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditAutoSize Property

Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.EditAutoSize = value

value = instance.EditAutoSize
C#
public System.bool EditAutoSize {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditColumn Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditColumn Property

Gets the dbiColumnItem relative to the current cell edit operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As dbiColumnItem

value = instance.EditColumn
C#
public dbiColumnItem EditColumn {get;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditNode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditNode Property

Gets the dbiNodeItem that contains the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As dbiNodeItem

value = instance.EditNode
C#
public dbiNodeItem EditNode {get;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Enabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

FillList Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : FillList Property

Determines whether the last column in a list will always extend the the edge of the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.FillList = value

value = instance.FillList
C#
public System.bool FillList {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

FocusBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : FocusBorder Property

Determines if a focus line will be drawn around the selected dbiNodeItem when the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.FocusBorder = value

value = instance.FocusBorder
C#
public System.bool FocusBorder {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

FocusColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : FocusColor Property

Determines the color used to paint the focus border.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.FocusColor = value

value = instance.FocusColor
C#
public System.Drawing.Color FocusColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Focused Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ForeColor Property

Determines the foreground color of the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public override System.Drawing.Color ForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Base Implementation in ForeColor


%%PageItemTitle%%

Handle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HasChildren Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderAlign Property

Determines how the text in the column headers will be aligned.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.ContentAlignment

instance.HeaderAlign = value

value = instance.HeaderAlign
C#
public System.Drawing.ContentAlignment HeaderAlign {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderBackColor Property

Determines the background color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderBackColor = value

value = instance.HeaderBackColor
C#
public virtual System.Drawing.Color HeaderBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderBackColorMiddle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderBackColorMiddle Property

Determines the middle back color of the column header allowing for greater readability with certain fill types.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderBackColorMiddle = value

value = instance.HeaderBackColorMiddle
C#
public virtual System.Drawing.Color HeaderBackColorMiddle {get; set;}

Property Value

System.Drawing.Color

Remarks

Set to Color.Empty to remove this altogether.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderBackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderBackColorTo Property

Determines the secondary background color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderBackColorTo = value

value = instance.HeaderBackColorTo
C#
public virtual System.Drawing.Color HeaderBackColorTo {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderBorder Property

Determines the border type for the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.HeaderBorder = value

value = instance.HeaderBorder
C#
public enumBorderType HeaderBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderDownColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderDownColor Property

Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderDownColor = value

value = instance.HeaderDownColor
C#
public System.Drawing.Color HeaderDownColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderFillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderFillType Property

Determines the pattern used to paint the background of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumFillType

instance.HeaderFillType = value

value = instance.HeaderFillType
C#
public enumFillType HeaderFillType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderFont Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderFont Property

Determines the font used for the text in the column headers of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.HeaderFont = value

value = instance.HeaderFont
C#
public System.Drawing.Font HeaderFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderForeColor Property

Determines the foreground color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderForeColor = value

value = instance.HeaderForeColor
C#
public virtual System.Drawing.Color HeaderForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderHeight Property

Determines the height of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public System.int HeaderHeight {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderImageOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderImageOffset Property

Determines the value used to calculate the horizontal and vertical position of the images within the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.HeaderImageOffset = value

value = instance.HeaderImageOffset
C#
public System.Drawing.Point HeaderImageOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderOverColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderOverColor Property

Determines the color used to paint background when the mouse pointer is over the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HeaderOverColor = value

value = instance.HeaderOverColor
C#
public System.Drawing.Color HeaderOverColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderStyle Property

Determines the style of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
public enumStyle HeaderStyle {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderTextImageRelation Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderTextImageRelation Property

Determines how the column header position of text and image relate to each other.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.TextImageRelation

instance.HeaderTextImageRelation = value

value = instance.HeaderTextImageRelation
C#
public System.Windows.Forms.TextImageRelation HeaderTextImageRelation {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderTextOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderTextOffset Property

Determines the value used to calculate the horizontal and vertical position of the text within the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.HeaderTextOffset = value

value = instance.HeaderTextOffset
C#
public System.Drawing.Point HeaderTextOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Height Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HorzGridColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HorzGridColor Property

Determines the color of the horizontal grid lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.HorzGridColor = value

value = instance.HorzGridColor
C#
public System.Drawing.Color HorzGridColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HorzGridLines Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HorzGridLines Property

Determines whether or not horizontal grid lines will be drawn between the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.HorzGridLines = value

value = instance.HorzGridLines
C#
public System.bool HorzGridLines {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HorzGridWidth Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HorzGridWidth Property

Determines the width of the horizontal grid lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.HorzGridWidth = value

value = instance.HorzGridWidth
C#
public System.int HorzGridWidth {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HorzScrollType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HorzScrollType Property

Determines the horizontal scrolling action for the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumHorzScrollType

instance.HorzScrollType = value

value = instance.HorzScrollType
C#
public enumHorzScrollType HorzScrollType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImageCheckDisabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImageCheckDisabled Property

Determines the image used to replace the stock check disabled state item image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.ImageCheckDisabled = value

value = instance.ImageCheckDisabled
C#
public System.Drawing.Image ImageCheckDisabled {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImageCheckDown Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImageCheckDown Property

Determines the image used to replace the stock check down state item image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.ImageCheckDown = value

value = instance.ImageCheckDown
C#
public System.Drawing.Image ImageCheckDown {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImageCheckUp Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImageCheckUp Property

Determines the image used to replace the stock check up state item image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.ImageCheckUp = value

value = instance.ImageCheckUp
C#
public System.Drawing.Image ImageCheckUp {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImageList Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImageList Property

The image list for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ImageList

instance.ImageList = value

value = instance.ImageList
C#
public virtual System.Windows.Forms.ImageList ImageList {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImageMinus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImageMinus Property

Determines the image used to replace the stock close node image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.ImageMinus = value

value = instance.ImageMinus
C#
public System.Drawing.Image ImageMinus {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImagePlus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImagePlus Property

Determines the image used to replace the stock open node image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.ImagePlus = value

value = instance.ImagePlus
C#
public System.Drawing.Image ImagePlus {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImeMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

InactiveBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : InactiveBackColor Property

Determines the color used to paint the background of a selected item when the control no longer has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.InactiveBackColor = value

value = instance.InactiveBackColor
C#
public System.Drawing.Color InactiveBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

InactiveForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : InactiveForeColor Property

Determines the color used to paint the text of a selected item when the control no longer has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.InactiveForeColor = value

value = instance.InactiveForeColor
C#
public System.Drawing.Color InactiveForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

InvokeRequired Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

IsAccessible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

IsDisposed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

IsMirrored Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemBorder Property

Determines the border type for the node items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.ItemBorder = value

value = instance.ItemBorder
C#
public enumBorderType ItemBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemDragColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemDragColor Property

Determines the color of the drag bar when an item is dragged inside the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.ItemDragColor = value

value = instance.ItemDragColor
C#
public System.Drawing.Color ItemDragColor {get; set;}

Property Value

Color

Remarks

This property is only used when dragging list items using the internal drag drop functionality, AllowItemDrag.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemDragHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemDragHeight Property

Determines the height of the drag bar when an item is dragged inside the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.ItemDragHeight = value

value = instance.ItemDragHeight
C#
public System.int ItemDragHeight {get; set;}

Property Value

integer

Remarks

This property is only used when dragging list items using the internal drag drop functionality, AllowItemDrag.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemHeaderBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemHeaderBackColor Property

Determines the default background color of all Header Items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.ItemHeaderBackColor = value

value = instance.ItemHeaderBackColor
C#
public System.Drawing.Color ItemHeaderBackColor {get; set;}

Property Value

Color

Remarks

Replaces the older ItemHeaderColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemHeaderForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemHeaderForeColor Property

Determines the default foreground color of all Header Items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.ItemHeaderForeColor = value

value = instance.ItemHeaderForeColor
C#
public System.Drawing.Color ItemHeaderForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemHeightOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemHeightOffset Property

Determines the offset value used to calculate the height of the line items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.ItemHeightOffset = value

value = instance.ItemHeightOffset
C#
public virtual System.int ItemHeightOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemHeightType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemHeightType Property

Determines how the line item heights are calculated.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumItemHeightType

instance.ItemHeightType = value

value = instance.ItemHeightType
C#
public virtual enumItemHeightType ItemHeightType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LabelEdit Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LabelEdit Property

Determines if a cell will be put into edit mode automatically, if the user double clicks it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.LabelEdit = value

value = instance.LabelEdit
C#
public System.bool LabelEdit {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LayoutEngine Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Left Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LineColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LineColor Property

Determines the color of list/tree connector lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.LineColor = value

value = instance.LineColor
C#
public System.Drawing.Color LineColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
LineType Property


%%PageItemTitle%%

LineType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LineType Property

Determines the list/tree connector line type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumLineType

instance.LineType = value

value = instance.LineType
C#
public enumLineType LineType {get; set;}

Property Value

enumLineType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
enumLineType Enumeration
LineColor Property


%%PageItemTitle%%

ListType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ListType Property

Determines how the node items will be drawn in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumListType

instance.ListType = value

value = instance.ListType
C#
public enumListType ListType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Location Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LockLineHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LockLineHeight Property

Determines whether the line items can be resized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.LockLineHeight = value

value = instance.LockLineHeight
C#
public virtual System.bool LockLineHeight {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Margin Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
C#
public System.Windows.Forms.Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MaximumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MaximumSize Property

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MinimumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MinimumSize Property

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MultiSelect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MultiSelect Property

Allow the list to utilize multi-select mode (using ctrl/click and shift/click).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.MultiSelect = value

value = instance.MultiSelect
C#
public System.bool MultiSelect {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Name Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Padding Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Padding Property

Gets or sets padding within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
public System.Windows.Forms.Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Parent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PlusMinusStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PlusMinusStyle Property

Determines the style used when rendering the Plus/Minus boxes on parent nodes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumPlusMinusStyle

instance.PlusMinusStyle = value

value = instance.PlusMinusStyle
C#
public enumPlusMinusStyle PlusMinusStyle {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnBackColor Property

Determines the background color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PreColumnBackColor = value

value = instance.PreColumnBackColor
C#
public virtual System.Drawing.Color PreColumnBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnBackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnBackColorTo Property

Determines the secondary background color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PreColumnBackColorTo = value

value = instance.PreColumnBackColorTo
C#
public virtual System.Drawing.Color PreColumnBackColorTo {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnBorder Property

Determines the type of border to place around the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.PreColumnBorder = value

value = instance.PreColumnBorder
C#
public enumBorderType PreColumnBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnFillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnFillType Property

Determines the pattern used to paint the background of the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumFillType

instance.PreColumnFillType = value

value = instance.PreColumnFillType
C#
public enumFillType PreColumnFillType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnFont Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnFont Property

Determines the font used for the text in the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.PreColumnFont = value

value = instance.PreColumnFont
C#
public System.Drawing.Font PreColumnFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnForeColor Property

Determines the text color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PreColumnForeColor = value

value = instance.PreColumnForeColor
C#
public virtual System.Drawing.Color PreColumnForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnPicture Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnPicture Property

Determines the picture clip within the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.PreColumnPicture = value

value = instance.PreColumnPicture
C#
public System.Drawing.Image PreColumnPicture {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnType Property

Determines the pre-column to be used on the list part of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumPreColumnType

instance.PreColumnType = value

value = instance.PreColumnType
C#
public enumPreColumnType PreColumnType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreColumnWidth Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreColumnWidth Property

Determines the width of the pre-column in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.PreColumnWidth = value

value = instance.PreColumnWidth
C#
public System.int PreColumnWidth {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreferredSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreSelectBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreSelectBackColor Property

Determines the background color of the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PreSelectBackColor = value

value = instance.PreSelectBackColor
C#
public virtual System.Drawing.Color PreSelectBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreSelectBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreSelectBorder Property

Determines the type of border to place around the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.PreSelectBorder = value

value = instance.PreSelectBorder
C#
public enumBorderType PreSelectBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreSelectForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreSelectForeColor Property

Determines the type of border to place around the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PreSelectForeColor = value

value = instance.PreSelectForeColor
C#
public virtual System.Drawing.Color PreSelectForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintHeaderBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintHeaderBackColor Property

Determines the background color of the header in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintHeaderBackColor = value

value = instance.PrintHeaderBackColor
C#
public virtual System.Drawing.Color PrintHeaderBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintHeaderForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintHeaderForeColor Property

Determines the text color of the header in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintHeaderForeColor = value

value = instance.PrintHeaderForeColor
C#
public virtual System.Drawing.Color PrintHeaderForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintItemBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintItemBackColor Property

Determines the background color of the item in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintItemBackColor = value

value = instance.PrintItemBackColor
C#
public virtual System.Drawing.Color PrintItemBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintItemForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintItemForeColor Property

Determines the text color of the item in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintItemForeColor = value

value = instance.PrintItemForeColor
C#
public virtual System.Drawing.Color PrintItemForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintPageControl Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintPageControl Property

Used to determine if the control should print using the colors as rendered in the form (true) or as described in the PrintItemBackColor Property and PrintItemForeColor Property (false). Default is true.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.PrintPageControl = value

value = instance.PrintPageControl
C#
public virtual System.bool PrintPageControl {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintTitleBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintTitleBackColor Property

Determines the background color of the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintTitleBackColor = value

value = instance.PrintTitleBackColor
C#
public virtual System.Drawing.Color PrintTitleBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PrintTitleForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PrintTitleForeColor Property

Determines the text color of the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.PrintTitleForeColor = value

value = instance.PrintTitleForeColor
C#
public virtual System.Drawing.Color PrintTitleForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ProductName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ProductVersion Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Region Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Right Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RightToLeft Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedBackColor Property

Determines the background color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.SelectedBackColor = value

value = instance.SelectedBackColor
C#
public virtual System.Drawing.Color SelectedBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedBackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedBackColorTo Property

Determines the second background color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.SelectedBackColorTo = value

value = instance.SelectedBackColorTo
C#
public virtual System.Drawing.Color SelectedBackColorTo {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedBorder Property

Determines the type of border to place around the selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.SelectedBorder = value

value = instance.SelectedBorder
C#
public enumBorderType SelectedBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedBorderColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedBorderColor Property

Determines the border color of a selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.SelectedBorderColor = value

value = instance.SelectedBorderColor
C#
public virtual System.Drawing.Color SelectedBorderColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedFillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedFillType Property

Determines the pattern used to paint the background of the selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumFillType

instance.SelectedFillType = value

value = instance.SelectedFillType
C#
public enumFillType SelectedFillType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedFont Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedFont Property

Determines the font used to draw the text of a selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.SelectedFont = value

value = instance.SelectedFont
C#
public System.Drawing.Font SelectedFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedForeColor Property

Determines the text color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.SelectedForeColor = value

value = instance.SelectedForeColor
C#
public virtual System.Drawing.Color SelectedForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SelectedStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SelectedStyle Property

Determines how the selection will be applied to the selected node(s). See enumSelectedStyle Enumeration for values.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumSelectedStyle

instance.SelectedStyle = value

value = instance.SelectedStyle
C#
public enumSelectedStyle SelectedStyle {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Site Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Size Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Size Property

Gets or sets the height and width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SortArrows Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SortArrows Property

Determines whether or not arrows indicating the direction of the sort order will be displayed in the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.SortArrows = value

value = instance.SortArrows
C#
public System.bool SortArrows {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SortColumn Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SortColumn Property

Determines the column whose data a sort will be performed on. See Sort Method for more information on sorting in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.SortColumn = value

value = instance.SortColumn
C#
public System.int SortColumn {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Sort Method


%%PageItemTitle%%

SortDirection Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SortDirection Property

Determines the direction a sort operation will perform.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumSortDirection

instance.SortDirection = value

value = instance.SortDirection
C#
public enumSortDirection SortDirection {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Sorted Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Sorted Property

Determines whether or not the list is currently sorted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.Sorted = value

value = instance.Sorted
C#
public System.bool Sorted {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TabIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TabIndex Property

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public System.int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TabStop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
C#
public System.bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true.This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Tag Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TextAntiAlias Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TextAntiAlias Property

Determines if the text within the control will be rendered using the Anti Alias option.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.TextAntiAlias = value

value = instance.TextAntiAlias
C#
public System.bool TextAntiAlias {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TextBox Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TextBox Property

Gets the current dbiTextBox control used for editing cells in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As dbiTextBox

value = instance.TextBox
C#
public dbiTextBox TextBox {get;}

Property Value

dbiTextBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleAlign Property

Determines the alignment for the text within the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.ContentAlignment

instance.TitleAlign = value

value = instance.TitleAlign
C#
public System.Drawing.ContentAlignment TitleAlign {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleBackColor Property

Determines the background color of the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.TitleBackColor = value

value = instance.TitleBackColor
C#
public virtual System.Drawing.Color TitleBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleBackColorMiddle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleBackColorMiddle Property

Determines the middle back color of the title section allowing for greater readability with certain fill types.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.TitleBackColorMiddle = value

value = instance.TitleBackColorMiddle
C#
public virtual System.Drawing.Color TitleBackColorMiddle {get; set;}

Property Value

System.Drawing.Color

Remarks

Set to Color.Empty to remove this altogether.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleBackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleBackColorTo Property

Determines the secondary background color of the title setction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.TitleBackColorTo = value

value = instance.TitleBackColorTo
C#
public virtual System.Drawing.Color TitleBackColorTo {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleBorder Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleBorder Property

Determines the border type for the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumBorderType

instance.TitleBorder = value

value = instance.TitleBorder
C#
public enumBorderType TitleBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleFillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleFillType Property

Determines the pattern used to paint the background of the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As enumFillType

instance.TitleFillType = value

value = instance.TitleFillType
C#
public enumFillType TitleFillType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleFont Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleFont Property

Determines the font used for the text in the title of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Font

instance.TitleFont = value

value = instance.TitleFont
C#
public System.Drawing.Font TitleFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleForeColor Property

Determines the text color of the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.TitleForeColor = value

value = instance.TitleForeColor
C#
public virtual System.Drawing.Color TitleForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleHeight Property

Determines the height of the title setction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.TitleHeight = value

value = instance.TitleHeight
C#
public System.int TitleHeight {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleImage Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleImage Property

Determines the image for the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Image

instance.TitleImage = value

value = instance.TitleImage
C#
public System.Drawing.Image TitleImage {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleImageAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleImageAlign Property

Determines the image alignment for the title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.ContentAlignment

instance.TitleImageAlign = value

value = instance.TitleImageAlign
C#
public System.Drawing.ContentAlignment TitleImageAlign {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleText Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleText Property

Determines the text of the title area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.String

instance.TitleText = value

value = instance.TitleText
C#
public virtual System.string TitleText {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TitleTextOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TitleTextOffset Property

Determines the value used to calculate the horizontal and vertical position of the text within the title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Point

instance.TitleTextOffset = value

value = instance.TitleTextOffset
C#
public System.Drawing.Point TitleTextOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Top Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TopLevelControl Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TreeLevelIndent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TreeLevelIndent Property

Determines the indent used to offset the text of each level of child nodes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.TreeLevelIndent = value

value = instance.TreeLevelIndent
C#
public System.int TreeLevelIndent {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

VertGridColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : VertGridColor Property

Determines the color of the vertical grid lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Drawing.Color

instance.VertGridColor = value

value = instance.VertGridColor
C#
public System.Drawing.Color VertGridColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

VertGridLines Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : VertGridLines Property

Determines whether or not to draw vertical grid lines between the columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.VertGridLines = value

value = instance.VertGridLines
C#
public System.bool VertGridLines {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Visible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterCellEdit Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterCellEdit Event

Event fired after the editing of a cell has completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventAfterCellEditHandler

AddHandler instance.AfterCellEdit, handler
C#
public event DbiListControl.EventAfterCellEditHandler AfterCellEdit

Event Data

The event handler receives an argument of type AfterCellEditEventArgs containing data related to this event. The following AfterCellEditEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The index of the column where the edit occurred.
ColumnItem | The dbiColumnItem where the cell is located
Key | The Key code and modifiers that were pressed to end the edit session
NodeItem | The dbiNodeItem that contains the cell that was edited.
Text | The text that was assigned back to the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterColumnSort Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterColumnSort Event

Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired after the actual sort is performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.AfterColumnSortEventHandler

AddHandler instance.AfterColumnSort, handler
C#
public event DbiListControl.AfterColumnSortEventHandler AfterColumnSort

Event Data

The event handler receives an argument of type AfterColumnSortEventArgs containing data related to this event. The following AfterColumnSortEventArgs properties provide information specific to this event.

Property | Description
Columns | An array of columns in the order in which the sort is to occur. See Sort Method

Remarks

Event is fired after the actual sort is performed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterNodeCollapse Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterNodeCollapse Event

Event fired after a parent node has collapsed (hiding its child nodes).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventAfterNodeCollapseHandler

AddHandler instance.AfterNodeCollapse, handler
C#
public event DbiListControl.EventAfterNodeCollapseHandler AfterNodeCollapse

Event Data

The event handler receives an argument of type AfterNodeCollapseEventArgs containing data related to this event. The following AfterNodeCollapseEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
NodeItem | The dbiNodeItem that was collapsed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterNodeExchange Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterNodeExchange Event

Event fired after a node has been internally dragged/dropped was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventAfterNodeExchangeHandler

AddHandler instance.AfterNodeExchange, handler
C#
public event DbiListControl.EventAfterNodeExchangeHandler AfterNodeExchange

Event Data

The event handler receives an argument of type AfterNodeExchangeEventArgs containing data related to this event. The following AfterNodeExchangeEventArgs properties provide information specific to this event.

Property | Description
NodeItemSource | The node item that was dragged.
NodeItemTarget | The node item that received the drop.

Remarks

This event is triggered when a node is dragged/dropped through internal functionality enabled by the AllowItemDrag Property

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterNodeExpand Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterNodeExpand Event

Event fired after a parent node has expanded (showing its child nodes).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventAfterNodeExpandHandler

AddHandler instance.AfterNodeExpand, handler
C#
public event DbiListControl.EventAfterNodeExpandHandler AfterNodeExpand

Event Data

The event handler receives an argument of type AfterNodeExpandEventArgs containing data related to this event. The following AfterNodeExpandEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
NodeItem | The dbiNodeItem that was expanded.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

AfterNodeSelect Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : AfterNodeSelect Event

Event fired after a node has been selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventAfterNodeSelectHandler

AddHandler instance.AfterNodeSelect, handler
C#
public event DbiListControl.EventAfterNodeSelectHandler AfterNodeSelect

Event Data

The event handler receives an argument of type AfterNodeSelectEventArgs containing data related to this event. The following AfterNodeSelectEventArgs properties provide information specific to this event.

Property | Description
NodeItem | The dbiNodeItem that was selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackgroundImageChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackgroundImageChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event System.EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BackgroundImageLayoutChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BackgroundImageLayoutChanged Event

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event System.EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeCellEdit Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeCellEdit Event

Event fired before a cell is placed into an editable state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeCellEditHandler

AddHandler instance.BeforeCellEdit, handler
C#
public event DbiListControl.EventBeforeCellEditHandler BeforeCellEdit

Event Data

The event handler receives an argument of type BeforeCellEditEventArgs containing data related to this event. The following BeforeCellEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Determines if the edit is allowed
ColumnIndex | The zero-based index of the column where the cell exists.
ColumnItem | The dbiColumnItem where the cell exists.
ComboBox | The ComboBox that will be used to edit values in the cell.
Height | The height of the cell to edit.
NodeItem | The dbiNodeItem that contains the cell to edit.
Text | The current text of the cell.
TextBox | The TextBox that will be used to edit values in the cell.
Width | The width of the cell to edit.
X | The X coordinate of the cell to edit.
Y | The Y coordinate of the cell to edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeCellTextDisplay Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeCellTextDisplay Event

Event fires before the text is drawn in each cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeCellTextDisplayHandler

AddHandler instance.BeforeCellTextDisplay, handler
C#
public event DbiListControl.EventBeforeCellTextDisplayHandler BeforeCellTextDisplay

Event Data

The event handler receives an argument of type BeforeCellTextDisplayEventArgs containing data related to this event. The following BeforeCellTextDisplayEventArgs properties provide information specific to this event.

Property | Description
CellFormat | The dbiCellFormat that was applied to the cell that contains the text.
CellText | The text that will be displayed in the cell
ColumnIndex | The zero-based index of the column where the cell exists.
ColumnItem | The dbiColumnItem where the cell exists.
Font | The font that will be used to drawn the cell's text.
NodeItem | The dbiNodeItem that contains the cell.
NodeLevel | Returns the zero-based level within the nested structure that the node containing the cell exists.
TextAlignment | Determines the horizontal/vertical alignment of the text within the cell.
TextColor | Determines the color of the text in the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeColumnSort Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeColumnSort Event

Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired BEFORE the actual sort is performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.BeforeColumnSortEventHandler

AddHandler instance.BeforeColumnSort, handler
C#
public event DbiListControl.BeforeColumnSortEventHandler BeforeColumnSort

Event Data

The event handler receives an argument of type BeforeColumnSortEventArgs containing data related to this event. The following BeforeColumnSortEventArgs properties provide information specific to this event.

Property | Description
AllowSort | Indicate wether or not to proceed with the Sort. To cancel the sort set e.AllowSort = False in the BeforeColumnSort Event.
Columns | An array of columns in the order in which the sort is to occur. See Sort Method

Remarks

Event is fired BEFORE the actual sort is performed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeNodeCollapse Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeNodeCollapse Event

Event fired before a parent node is collapsed (child nodes will be hidden).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeNodeCollapseHandler

AddHandler instance.BeforeNodeCollapse, handler
C#
public event DbiListControl.EventBeforeNodeCollapseHandler BeforeNodeCollapse

Event Data

The event handler receives an argument of type BeforeNodeCollapseEventArgs containing data related to this event. The following BeforeNodeCollapseEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
AllowCollapse | Determines if the node will be collapsed.
NodeItem | The dbiNodeItem being collapsed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeNodeExchange Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeNodeExchange Event

Event fired before a node that has been internally dragged/dropped is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeNodeExchangeHandler

AddHandler instance.BeforeNodeExchange, handler
C#
public event DbiListControl.EventBeforeNodeExchangeHandler BeforeNodeExchange

Event Data

The event handler receives an argument of type BeforeNodeExchangeEventArgs containing data related to this event. The following BeforeNodeExchangeEventArgs properties provide information specific to this event.

Property | Description
AllowNodeExchange | Determines if the exchange will be allowed
NodeItemSource | The node item being dragged.
NodeItemTarget | The node item receiving the drop

Remarks

This event is triggered when a node is dragged/dropped through internal functionality enabled by the AllowItemDrag Property

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeNodeExpand Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeNodeExpand Event

Event fired before a parent node is expanded (child nodes will be made visible).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeNodeExpandHandler

AddHandler instance.BeforeNodeExpand, handler
C#
public event DbiListControl.EventBeforeNodeExpandHandler BeforeNodeExpand

Event Data

The event handler receives an argument of type BeforeNodeExpandEventArgs containing data related to this event. The following BeforeNodeExpandEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
AllowExpand | Determines if the node will be expanded.
NodeItem | The dbiNodeItem being expanded.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforeNodeSelect Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforeNodeSelect Event

Event fired before a node is selected in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforeNodeSelectHandler

AddHandler instance.BeforeNodeSelect, handler
C#
public event DbiListControl.EventBeforeNodeSelectHandler BeforeNodeSelect

Event Data

The event handler receives an argument of type BeforeNodeSelectEventArgs containing data related to this event. The following BeforeNodeSelectEventArgs properties provide information specific to this event.

Property | Description
AllowSelect | Determines if the node will be selected.
NodeItem | The dbiNodeItem that will be selected.
X | The X coordinate where the selection is occurring
Y | The Y coordinate where the selection is occurring.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeforePaint Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BeforePaint Event

Event fired before the control has painted the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventBeforePaintHandler

AddHandler instance.BeforePaint, handler
C#
public event DbiListControl.EventBeforePaintHandler BeforePaint

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Change Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Change Event

Event fired when a list item is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventChangeEventHandler

AddHandler instance.Change, handler
C#
public event DbiListControl.EventChangeEventHandler Change

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs properties provide information specific to this event.

Property | Description
NodeItem | The dbiNodeItem that has been selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ChangeUICues Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CheckClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CheckClick Event

Event fired when a check box in the list is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventCheckClickEventHandler

AddHandler instance.CheckClick, handler
C#
public event DbiListControl.EventCheckClickEventHandler CheckClick

Event Data

The event handler receives an argument of type CheckEventArgs containing data related to this event. The following CheckEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The index value of the dbiColumnItem where the check occurred.
NodeItem | The dbiNodeItem where the check occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Click Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ControlAdded Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ControlRemoved Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

CursorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DisplayUserControl Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DisplayUserControl Event

Event fired before a cell is placed into edit mode, allowing the developer to prepare and display their own control for the editing process.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventDisplayUserControlHandler

AddHandler instance.DisplayUserControl, handler
C#
public event DbiListControl.EventDisplayUserControlHandler DisplayUserControl

Event Data

The event handler receives an argument of type DisplayUserControlEventArgs containing data related to this event. The following DisplayUserControlEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the editable cell exists.
ColumnItem | The dbiColumnItem where the editable cell exists.
Height | The height of the cell to be edited.
NodeItem | The dbiNodeItem that contains the cell to be edited.
Text | The current text of the cell to be edited.
Width | The width of the cell to be edited.
X | The X coordinate of the cell being edited.
Y | The Y coordinate of the cell to be edited.

Remarks

Event is only fired, if the EditType property of the respective column is set to UserControl

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Disposed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DockChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DragDrop Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DragEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DragLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DragOver Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

DropList Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DropList Event

Event fired when an item is dropped into the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventDropListEventHandler

AddHandler instance.DropList, handler
C#
public event DbiListControl.EventDropListEventHandler DropList

Event Data

The event handler receives an argument of type DropListEventArgs containing data related to this event. The following DropListEventArgs properties provide information specific to this event.

Property | Description
DragEvent | The DragEventArgs related to the Drag/Drop operation.
NodeItem | The dbiNodeItem where the drop operation occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditInputKey Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditInputKey Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventEditInputKeyHandler

AddHandler instance.EditInputKey, handler
C#
public event DbiListControl.EventEditInputKeyHandler EditInputKey

Event Data

The event handler receives an argument of type EditInputKeyEventArgs containing data related to this event. The following EditInputKeyEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
Handled | A flag the developer can set to inform the control that the operation has been handled.
KeyData | The KeyData that triggered the event.
NodeItem | The dbiNodeItem that contains the cell being edited.

Remarks

This event can be used to test and override the behavior of keys as they are pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditKeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditKeyDown Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventEditKeyDownHandler

AddHandler instance.EditKeyDown, handler
C#
public event DbiListControl.EventEditKeyDownHandler EditKeyDown

Event Data

The event handler receives an argument of type EditKeyDownEventArgs containing data related to this event. The following EditKeyDownEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyDownEvents | The EventArguments for the KeyDown event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyDown event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyDown event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditKeyPress Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditKeyPress Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventEditKeyPressHandler

AddHandler instance.EditKeyPress, handler
C#
public event DbiListControl.EventEditKeyPressHandler EditKeyPress

Event Data

The event handler receives an argument of type EditKeyPressEventArgs containing data related to this event. The following EditKeyPressEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyPressEvents | The EventArguments for the KeyPress event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyPress event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyPressed event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EditKeyUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EditKeyUp Event

Event fired when a key is released inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventEditKeyUpHandler

AddHandler instance.EditKeyUp, handler
C#
public event DbiListControl.EventEditKeyUpHandler EditKeyUp

Event Data

The event handler receives an argument of type EditKeyUpEventArgs containing data related to this event. The following EditKeyUpEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyUpEvents | The EventArguments for the KeyUp event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyUp event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyDown event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

EnabledChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Enter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

FontChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GiveFeedback Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

GotFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HandleCreated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderClick Event

Event fired when the left mouse button clicks on a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventHeaderClickEventHandler

AddHandler instance.HeaderClick, handler
C#
public event DbiListControl.EventHeaderClickEventHandler HeaderClick

Event Data

The event handler receives an argument of type ColumnEventArgs containing data related to this event. The following ColumnEventArgs properties provide information specific to this event.

Property | Description
Button | The mousebutton that was used in the event.
ColumnIndex | The index of the column where the event occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HeaderDoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HeaderDoubleClick Event

Event fired when the left mouse button double clicks on a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventHeaderDoubleClickEventHandler

AddHandler instance.HeaderDoubleClick, handler
C#
public event DbiListControl.EventHeaderDoubleClickEventHandler HeaderDoubleClick

Event Data

The event handler receives an argument of type ColumnEventArgs containing data related to this event. The following ColumnEventArgs properties provide information specific to this event.

Property | Description
Button | The mousebutton that was used in the event.
ColumnIndex | The index of the column where the event occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

HelpRequested Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

InitializeCellEdit Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : InitializeCellEdit Event

Event fired before the cell edit operation is started

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventInitializeCellEditHandler

AddHandler instance.InitializeCellEdit, handler
C#
public event DbiListControl.EventInitializeCellEditHandler InitializeCellEdit

Event Data

The event handler receives an argument of type InitializeCellEditEventArgs containing data related to this event. The following InitializeCellEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Determines if the edit process will be allowed.
ColumnIndex | The zero-based index of the dbiColumnItem where the edit will take place.
ColumnItem | The dbiColumnItem where the edit will take place.
NodeItem | The dbiNodeItem where the edit will take place.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Invalidated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ItemLineHeightChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ItemLineHeightChanged Event

Event fired when the item height is changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ItemLineHeightChanged, handler
C#
public event System.EventHandler ItemLineHeightChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

KeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

KeyPress Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

KeyUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Layout Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Leave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ListMouseOver Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ListMouseOver Event

Event fired when the mouse moves over a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventListMouseOverEventHandler

AddHandler instance.ListMouseOver, handler
C#
public event DbiListControl.EventListMouseOverEventHandler ListMouseOver

Event Data

The event handler receives an argument of type ListMouseOverEventArgs containing data related to this event. The following ListMouseOverEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem being moused over.
NodeItem | The dbiNodeItem which the mouse is over

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LocationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

LostFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MarginChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MarginChanged Event

Occurs when the control's margin changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
C#
public event System.EventHandler MarginChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseHover Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseMove Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

MouseWheel Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Move Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

NodeClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : NodeClick Event

Event fired when the mouse clicks on a list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventNodeClickEventHandler

AddHandler instance.NodeClick, handler
C#
public event DbiListControl.EventNodeClickEventHandler NodeClick

Event Data

The event handler receives an argument of type NodeClickEventArgs containing data related to this event. The following NodeClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button used to click the node.
ColumnIndex | The zero-based index of the dbiColumnItem at the point where the node was clicked.
ColumnItem | The dbiColumnItem at the point where the node was clicked.
Handled | Determines if the developer has handled the click operation themselves.
NodeItem | The dbiNodeItem that was clicked.
X | The X coordinate where the click occurred.
Y | The Y coordinate where the click occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

NodeDoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : NodeDoubleClick Event

Event fired when the item is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventNodeDoubleClickEventHandler

AddHandler instance.NodeDoubleClick, handler
C#
public event DbiListControl.EventNodeDoubleClickEventHandler NodeDoubleClick

Event Data

The event handler receives an argument of type NodeDoubleClickEventArgs containing data related to this event. The following NodeDoubleClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button used to double click the node.
ColumnIndex | The zero-based index of the dbiColumnItem where the double click occurred.
ColumnItem | The dbiColumnItem where the double click occurred
NodeItem | The dbiNodeItem that was double clicked
X | The X coordinate where the double click occurred
Y | The Y coordinate where the double click occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PaddingChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PaddingChanged Event

Occurs when the control's padding changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event System.EventHandler PaddingChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Paint Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Paint Event

Occurs when the control is redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
public event System.Windows.Forms.PaintEventHandler Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

ParentChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RegionChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RemoveUserControls Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RemoveUserControls Event

Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventRemoveUserControlsHandler

AddHandler instance.RemoveUserControls, handler
C#
public event DbiListControl.EventRemoveUserControlsHandler RemoveUserControls

Event Data

The event handler receives an argument of type RemoveUserControlsEventArgs containing data related to this event. The following RemoveUserControlsEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem the UserControl is being displayed over.
ColumnItem | The dbiColumnItem the UserControl is being displayed over.
NodeItem | The dbiNodeItem that contains the cell the UserControl is displayed over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Resize Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

StyleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TabIndexChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TabIndexChanged Event

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
C#
public event System.EventHandler TabIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TabStopChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TabStopChanged Event

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
C#
public event System.EventHandler TabStopChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

TextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

UserDrawnCell Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : UserDrawnCell Event

Event fired before a cell is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventUserDrawnCellHandler

AddHandler instance.UserDrawnCell, handler
C#
public event DbiListControl.EventUserDrawnCellHandler UserDrawnCell

Event Data

The event handler receives an argument of type UserDrawnCellEventArgs containing data related to this event. The following UserDrawnCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the cell is being drawn.
ColumnItem | The dbiColumnItem where the cell is being drawn.
Graphics | A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
NodeItem | The dbiNodeItem that contains the cell being drawn.
PaintCell | Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

UserDrawnColumnHeader Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : UserDrawnColumnHeader Event

Event fired before a column header is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventUserDrawnColumnHeaderHandler

AddHandler instance.UserDrawnColumnHeader, handler
C#
public event DbiListControl.EventUserDrawnColumnHeaderHandler UserDrawnColumnHeader

Event Data

The event handler receives an argument of type UserDrawnColumnHeaderEventArgs containing data related to this event. The following UserDrawnColumnHeaderEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the header is being drawn.
ColumnItem | The dbiColumnItem where the header is being drawn.
Graphics | A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
PaintHeader | Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.
Rect | A rectangle representing the area being painted in the control.
Status | Determines the current status of the header column in the display.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

UserDrawnNode Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : UserDrawnNode Event

Event fired before a node is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventUserDrawnNodeHandler

AddHandler instance.UserDrawnNode, handler
C#
public event DbiListControl.EventUserDrawnNodeHandler UserDrawnNode

Event Data

The event handler receives an argument of type UserDrawnNodeEventArgs containing data related to this event. The following UserDrawnNodeEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
NodeItem | The dbiNodeItem that will be drawn
PaintNode | Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

UserDrawnTitle Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : UserDrawnTitle Event

Event fired before the title area is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As DbiListControl.EventUserDrawnTitleHandler

AddHandler instance.UserDrawnTitle, handler
C#
public event DbiListControl.EventUserDrawnTitleHandler UserDrawnTitle

Event Data

The event handler receives an argument of type UserDrawnTitleEventArgs containing data related to this event. The following UserDrawnTitleEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
PaintTitle | Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Validated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Validating Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

VisibleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

dbiNodeItem Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiNodeItem Class

Provides the NodeItems for use in dbiList components.

Object Model

dbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
C#
public class dbiNodeItem

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiNodeItem
Dbi.WinControl.Schedule.dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiNodeItem Class Members
See Also Properties Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiNodeItem Class

"

The following tables list the members exposed by dbiNodeItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiNodeItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the node item.
public Property | BackColorTo | Determines the secondary background color of the node item.
public Property | Body | Determines the body text for the node item.
public Property | BodyVisible | Determines if the body text is visible for the node item.
public Property | Cargo | Determines a non-visible text value for the node item.
public Property | CellFormat | Gets or sets the cell format assigned to the node item.
public Property | Checked | Determines whether the node item is in a checked state.
public Property | Control | Gets or sets the name of the object containing the node.
public Property | Data | Gets or sets a non-visible integer value for the node item.
public Property | FillType | Gets or sets the background fill pattern of the node item based on the enumFillType Enumeration.
public Property | Font | Gets or sets the font of the node item.
public Property | ForeColor | Gets or sets the forecolor of the node.
public Property | FullPath | Gets the full path of the node in the list.
public Property | Header | Determines if the node item will act as a header.
public Property | HeaderBackColor | Determines the background color for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderBackColorTo | Determines the secondary background color for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderFillType | Determines the background fill pattern for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderForeColor | Determines the foreground color for the dbiNodeItem when it is marked as a Header item.
public Property | HeightOffset | Gets or sets the vertical offset value used to calculate the height of the node.
public Property | HorzGridColor | Gets or sets the color of the horizontal grid line below the node item.
public Property | HorzGridWidth | Gets or sets the width of the horizontal grid line below the node item.
public Property | ImageAlign | Gets or sets the vertical and horizontal alignment of the image associated with the node.
public Property | ImageIndex | Gets or sets the image associated with the node. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.
public Property | ImageOffset | Determines the vertical and horizontal offset values used to calculate the position of the image associated with the node.
public Property | IsExpanded | Determines if the node item is expanded, displaying child nodes.
public Property | Item | Determines the node item at a specific location in the collection.
public Property | Items | This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections. Same as the nodes collection but included here for compatibility.
public Property | Level | Gets the current tree level of the dbiNodeItem.
public Property | LockHeight | Determines if the node height can be adjusted through user interaction.
public Property | Nodes | This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections.
public Property | PageBreak | Sets the item as a pagebreak item causing the printer functions to start a new page after that item.
public Property | Parent | Determines the parent node of a given node item.
public Property | ReadOnly | Determines if the node is readonly.
public Property | Selected | Determines if a node item is selected.
public Property | SelectedImageIndex | Determines the image associated with the node when it is selected. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.
public Property | Subject | Determines the subject of the list item.
public Property | Tag | Determines the object that contains data about the control. This property can be used to attach a data row to the node for reference elsewhere or a custom class can be created and attached.
public Property | Text | Determines the node text.
public Property | XMLString | Sets or gets the XML based description of the node item.
Top

Public Methods

 | Name | Description
public Method | Collapse | Closes a parent node so that the children are not visible.
public Method | EnsureVisible | Adjusts the vertical scroll bar to ensure the dbiNodeItem is visible in the list.
public Method | Expand | Expands a node so that the child nodes are visible.
public Method | ExpandAll | Expands all nodes of a given node including all layers of nodes under that node.
public Method | GetCellChecked | Gets the boolean value at a specific cell in the item.
public Method | GetCellFormat | Gets the dbiCellFormat assigned to a specific cell in the item.
public Method | GetCellInteger | Gets the integer value at a specific cell in the item.
public Method | GetCellText | Gets the text at a specific cell in the item.
public Method | GetNodeCount | Gets the number of children nodes of a item in the list.
public Method | IsVisible | Determines if a node is visible.
public Method | NextVisibleNode | Gets the next visible node.
public Method | NodeFullPath | Gets the node full path as a string.
public Method | PrevVisibleNode | Gets the previous visible node item.
public Method | SetCellChecked | Sets the boolean value at a specific cell in the item.
public Method | SetCellInteger | Sets the integer value at a specific cell in the item.
public Method | SetCellText | Sets the text of a specific cell.
public Method | Toggle | Toggle the node to either expand or collapse it.
Top

See Also

Reference

dbiNodeItem Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiNodeItem Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : dbiNodeItem Constructor

Initializes a new instance of the dbiNodeItem class.

Overload List

Overload | Description
dbiNodeItem Constructor() | Initializes a new instance of the dbiNodeItem class.
dbiNodeItem Constructor(dbiNodeItem[]) | Initializes a new node with the array of child nodes passed into the node.items collection.
dbiNodeItem Constructor(String) | Initializes a new node setting the Text Property to the value of the string parameter.
dbiNodeItem Constructor(String,Int32,Int32) | Initializes a new node setting the node properties for the Text Property, the ImageIndex Property and the SelectedImageIndex Property properties.
dbiNodeItem Constructor(TreeNode) | Initializes a new node based on an existing System.Windows.Forms.TreeNode item.
dbiNodeItem Constructor(XmlNodeList) | Create a new node item based on the XmlNodeList structure.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

dbiNodeItem Constructor()
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor()

Initializes a new instance of the dbiNodeItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiNodeItem()
C#
public dbiNodeItem()

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

dbiNodeItem Constructor(dbiNodeItem[])
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor(dbiNodeItem[])

objChildren
A one-dimensional array of dbiNodeItem.
Initializes a new node with the array of child nodes passed into the node.items collection.

Syntax

Visual Basic (Usage) Copy Code
Dim objChildren() As dbiNodeItem

Dim instance As New dbiNodeItem(objChildren)
C#
public dbiNodeItem(
   dbiNodeItem[] objChildren
)

Parameters

objChildren
A one-dimensional array of dbiNodeItem.

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

dbiNodeItem Constructor(String)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor(String)

strText
The value to assign as the text for the new dbiNodeItem.
Initializes a new node setting the Text Property to the value of the string parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String

Dim instance As New dbiNodeItem(strText)
C#
public dbiNodeItem(
   System.string strText
)

Parameters

strText
The value to assign as the text for the new dbiNodeItem.

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

dbiNodeItem Constructor(String,Int32,Int32)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor(String,Int32,Int32)

strText
The value to assign as the text for the new dbiNodeItem.
nImageIndex
Integer value for the ImageIndex property of the new dbiNodeItem.
nSelectedImageIndex
Integer value for the SelectedImageIndex property of the new dbiNodeItem.
Initializes a new node setting the node properties for the Text Property, the ImageIndex Property and the SelectedImageIndex Property properties.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String
Dim nImageIndex As System.Integer
Dim nSelectedImageIndex As System.Integer

Dim instance As New dbiNodeItem(strText, nImageIndex, nSelectedImageIndex)
C#
public dbiNodeItem(
   System.string strText,
   System.int nImageIndex,
   System.int nSelectedImageIndex
)

Parameters

strText
The value to assign as the text for the new dbiNodeItem.
nImageIndex
Integer value for the ImageIndex property of the new dbiNodeItem.
nSelectedImageIndex
Integer value for the SelectedImageIndex property of the new dbiNodeItem.

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

dbiNodeItem Constructor(TreeNode)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor(TreeNode)

objNode
The TreeNode to base the new dbiNodeItem off of.
Initializes a new node based on an existing System.Windows.Forms.TreeNode item.

Syntax

Visual Basic (Usage) Copy Code
Dim objNode As System.Windows.Forms.TreeNode

Dim instance As New dbiNodeItem(objNode)
C#
public dbiNodeItem(
   System.Windows.Forms.TreeNode objNode
)

Parameters

objNode
The TreeNode to base the new dbiNodeItem off of.

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

dbiNodeItem Constructor(XmlNodeList)
See Also
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class > dbiNodeItem Constructor : dbiNodeItem Constructor(XmlNodeList)

xmlNodes
The XmlNodeList to base the new dbiNodeItem from.
Create a new node item based on the XmlNodeList structure.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiNodeItem(xmlNodes)
C#
public dbiNodeItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XmlNodeList to base the new dbiNodeItem from.

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members
Overload List


%%PageItemTitle%%

Collapse Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Collapse Method

Closes a parent node so that the children are not visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem

instance.Collapse()
C#
public void Collapse()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

EnsureVisible Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : EnsureVisible Method

Adjusts the vertical scroll bar to ensure the dbiNodeItem is visible in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem

instance.EnsureVisible()
C#
public void EnsureVisible()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Expand Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Expand Method

Expands a node so that the child nodes are visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem

instance.Expand()
C#
public void Expand()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ExpandAll Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ExpandAll Method

Expands all nodes of a given node including all layers of nodes under that node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem

instance.ExpandAll()
C#
public void ExpandAll()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

GetCellChecked Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : GetCellChecked Method

nColumn
The zero-based index of the column.
Gets the boolean value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.GetCellChecked(nColumn)
C#
public System.bool GetCellChecked(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the column.

Return Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

GetCellFormat Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : GetCellFormat Method

nColumn
The zero-based index of the cell.
Gets the dbiCellFormat assigned to a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim value As dbiCellFormat

value = instance.GetCellFormat(nColumn)
C#
public dbiCellFormat GetCellFormat(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the cell.

Return Value

dbiCellFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

GetCellInteger Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : GetCellInteger Method

nColumn
The zero-based index of the column
Gets the integer value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim value As System.Integer

value = instance.GetCellInteger(nColumn)
C#
public System.int GetCellInteger(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the column

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

GetCellText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : GetCellText Method

nColumn
The zero-based index of the cell.
Gets the text at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim value As System.String

value = instance.GetCellText(nColumn)
C#
public System.string GetCellText(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the cell.

Return Value

String value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

GetNodeCount Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : GetNodeCount Method

bIncludeSubItems
A boolean indicating if sub items should be included in the calculation.
Gets the number of children nodes of a item in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim bIncludeSubItems As System.Boolean
Dim value As System.Integer

value = instance.GetNodeCount(bIncludeSubItems)
C#
public System.int GetNodeCount(
   System.bool bIncludeSubItems
)

Parameters

bIncludeSubItems
A boolean indicating if sub items should be included in the calculation.

Return Value

An Integer value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

IsVisible Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : IsVisible Method

Determines if a node is visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

value = instance.IsVisible()
C#
public System.bool IsVisible()

Return Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

NextVisibleNode Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : NextVisibleNode Method

Gets the next visible node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As dbiNodeItem

value = instance.NextVisibleNode()
C#
public dbiNodeItem NextVisibleNode()

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

NodeFullPath Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : NodeFullPath Method

Gets the node full path as a string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

value = instance.NodeFullPath()
C#
public System.string NodeFullPath()

Return Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

PrevVisibleNode Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : PrevVisibleNode Method

Gets the previous visible node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As dbiNodeItem

value = instance.PrevVisibleNode()
C#
public dbiNodeItem PrevVisibleNode()

Return Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

SetCellChecked Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : SetCellChecked Method

nColumn
The zero-based index of the column
bValue
The boolean value to assign
Sets the boolean value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim bValue As System.Boolean

instance.SetCellChecked(nColumn, bValue)
C#
public void SetCellChecked(
   System.int nColumn,
   System.bool bValue
)

Parameters

nColumn
The zero-based index of the column
bValue
The boolean value to assign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

SetCellInteger Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : SetCellInteger Method

nColumn
The zero-based index of the column
nValue
The integer value to assign
Sets the integer value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim nValue As System.Integer

instance.SetCellInteger(nColumn, nValue)
C#
public void SetCellInteger(
   System.int nColumn,
   System.int nValue
)

Parameters

nColumn
The zero-based index of the column
nValue
The integer value to assign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

SetCellText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : SetCellText Method

nColumn
The zero-based index of the cell.
strCell
The text to assign to the cell.
Sets the text of a specific cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nColumn As System.Integer
Dim strCell As System.String

instance.SetCellText(nColumn, strCell)
C#
public void SetCellText(
   System.int nColumn,
   System.string strCell
)

Parameters

nColumn
The zero-based index of the cell.
strCell
The text to assign to the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Toggle Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Toggle Method

Toggle the node to either expand or collapse it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem

instance.Toggle()
C#
public void Toggle()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : BackColor Property

Determines the background color of the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

BackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : BackColorTo Property

Determines the secondary background color of the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Body Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Body Property

Determines the body text for the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public System.string Body {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

BodyVisible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : BodyVisible Property

Determines if the body text is visible for the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.BodyVisible = value

value = instance.BodyVisible
C#
public System.bool BodyVisible {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Cargo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Cargo Property

Determines a non-visible text value for the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Property Value

A String value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

CellFormat Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : CellFormat Property

Gets or sets the cell format assigned to the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As CellFormatCollection

value = instance.CellFormat
C#
public CellFormatCollection CellFormat {get;}

Property Value

dbiCellFormat Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Checked Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Checked Property

Determines whether the node item is in a checked state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.Checked = value

value = instance.Checked
C#
public System.bool Checked {get; set;}

Property Value

Boolean

Remarks

Only applicable to nodes that are set as checkboxes.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Control Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Control Property

Gets or sets the name of the object containing the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As DbiListControl

instance.Control = value

value = instance.Control
C#
public DbiListControl Control {get; set;}

Property Value

A DbiListControl/dbiSchedule object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Data Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Data Property

Gets or sets a non-visible integer value for the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

FillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : FillType Property

Gets or sets the background fill pattern of the node item based on the enumFillType Enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public enumFillType FillType {get; set;}

Property Value

enumFillType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Font Property

Gets or sets the font of the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ForeColor Property

Gets or sets the forecolor of the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

FullPath Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : FullPath Property

Gets the full path of the node in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

value = instance.FullPath
C#
public System.string FullPath {get;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Header Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Header Property

Determines if the node item will act as a header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.Header = value

value = instance.Header
C#
public System.bool Header {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HeaderBackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HeaderBackColor Property

Determines the background color for the dbiNodeItem when it is marked as a Header item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.HeaderBackColor = value

value = instance.HeaderBackColor
C#
public System.Drawing.Color HeaderBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HeaderBackColorTo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HeaderBackColorTo Property

Determines the secondary background color for the dbiNodeItem when it is marked as a Header item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.HeaderBackColorTo = value

value = instance.HeaderBackColorTo
C#
public System.Drawing.Color HeaderBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Remarks

This property is only used when the HeaderFillType is equal to something other than Solid.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HeaderFillType Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HeaderFillType Property

Determines the background fill pattern for the dbiNodeItem when it is marked as a Header item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As enumFillType

instance.HeaderFillType = value

value = instance.HeaderFillType
C#
public enumFillType HeaderFillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HeaderForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HeaderForeColor Property

Determines the foreground color for the dbiNodeItem when it is marked as a Header item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.HeaderForeColor = value

value = instance.HeaderForeColor
C#
public System.Drawing.Color HeaderForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HeightOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HeightOffset Property

Gets or sets the vertical offset value used to calculate the height of the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

instance.HeightOffset = value

value = instance.HeightOffset
C#
public System.int HeightOffset {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HorzGridColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HorzGridColor Property

Gets or sets the color of the horizontal grid line below the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Color

instance.HorzGridColor = value

value = instance.HorzGridColor
C#
public System.Drawing.Color HorzGridColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

HorzGridWidth Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : HorzGridWidth Property

Gets or sets the width of the horizontal grid line below the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

instance.HorzGridWidth = value

value = instance.HorzGridWidth
C#
public System.int HorzGridWidth {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ImageAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ImageAlign Property

Gets or sets the vertical and horizontal alignment of the image associated with the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.ContentAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public System.Drawing.ContentAlignment ImageAlign {get; set;}

Property Value

enumAlignment Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ImageIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ImageIndex Property

Gets or sets the image associated with the node. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ImageOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ImageOffset Property

Determines the vertical and horizontal offset values used to calculate the position of the image associated with the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Drawing.Point

instance.ImageOffset = value

value = instance.ImageOffset
C#
public System.Drawing.Point ImageOffset {get; set;}

Property Value

A Point value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

IsExpanded Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : IsExpanded Property

Determines if the node item is expanded, displaying child nodes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

value = instance.IsExpanded
C#
public System.bool IsExpanded {get;}

Remarks

This property is only available at run-time.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Item Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Item Property

nIndex
The zero-based index of the dbiNodeItem desired.
Determines the node item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim nIndex As System.Integer
Dim value As System.String

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public System.string this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the dbiNodeItem desired.

Property Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Items Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Items Property

This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections. Same as the nodes collection but included here for compatibility.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As NodeItemCollection

instance.Items = value

value = instance.Items
C#
public NodeItemCollection Items {get; set;}

Property Value

Collection of dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Level Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Level Property

Gets the current tree level of the dbiNodeItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

value = instance.Level
C#
public System.int Level {get;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

LockHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : LockHeight Property

Determines if the node height can be adjusted through user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.LockHeight = value

value = instance.LockHeight
C#
public System.bool LockHeight {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Nodes Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Nodes Property

This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As NodeItemCollection

value = instance.Nodes
C#
public NodeItemCollection Nodes {get;}

Property Value

Collection of dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

PageBreak Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : PageBreak Property

Sets the item as a pagebreak item causing the printer functions to start a new page after that item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.PageBreak = value

value = instance.PageBreak
C#
public System.bool PageBreak {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Parent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Parent Property

Determines the parent node of a given node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As dbiNodeItem

instance.Parent = value

value = instance.Parent
C#
public dbiNodeItem Parent {get; set;}

Property Value

dbiNodeItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

ReadOnly Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : ReadOnly Property

Determines if the node is readonly.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public System.bool ReadOnly {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Selected Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Selected Property

Determines if a node item is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Boolean

instance.Selected = value

value = instance.Selected
C#
public System.bool Selected {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

SelectedImageIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : SelectedImageIndex Property

Determines the image associated with the node when it is selected. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Integer

instance.SelectedImageIndex = value

value = instance.SelectedImageIndex
C#
public System.int SelectedImageIndex {get; set;}

Property Value

An Integer value.

Remarks

This Integer value represent the index value of the image in the assigned ImageList object. This property will replace the ImageIndex when the node is selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Subject Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Subject Property

Determines the subject of the list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
public System.string Subject {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Tag Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Tag Property

Determines the object that contains data about the control. This property can be used to attach a data row to the node for reference elsewhere or a custom class can be created and attached.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An Object that contains data about the control. The default is a null reference (Nothing in Visual Basic).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : Text Property

Determines the node text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

XMLString Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiNodeItem Class : XMLString Property

Sets or gets the XML based description of the node item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiNodeItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public virtual System.string XMLString {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiNodeItem Class
dbiNodeItem Members


%%PageItemTitle%%

dbiTextBox Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiTextBox Class

A custom TextBox class

Object Model

dbiTextBox Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
C#
public class dbiTextBox : System.Windows.Forms.TextBox

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.TextBoxBase
System.Windows.Forms.TextBox
Dbi.WinControl.dbiTextBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

dbiTextBox Class Members
See Also Properties Methods Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiTextBox Class

"

The following tables list the members exposed by dbiTextBox.

"

Public Constructors

 | Name | Description
public Constructor | dbiTextBox Constructor | Initialize a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline System.Windows.Forms.TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from System.Windows.Forms.TextBox)
public Property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoCompleteCustomSource | Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.TextBox.AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.TextBox. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | CharacterCasing | Gets or sets whether the System.Windows.Forms.TextBox control modifies the case of characters as they are typed. (Inherited from System.Windows.Forms.TextBox)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Lines | Gets or sets the lines of text in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Multiline | Gets or sets a value indicating whether this is a multiline System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | PreferredHeight | Gets the preferred height for a text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.TextBox)
public Property | TextAlign | Gets or sets how text is aligned in a System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | TextLength | Gets the length of text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the System.Windows.Forms.TextBox control should appear as the default password character. (Inherited from System.Windows.Forms.TextBox)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from System.Windows.Forms.TextBoxBase)
Top

Public Methods

 | Name | Description
public Method | AppendText | Appends text to the current text of a text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Clear | Clears all text from the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | DeselectAll | Specifies that the value of the System.Windows.Forms.TextBoxBase.SelectionLength property is zero so that no characters are selected in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | Paste | Overloaded. Sets the selected text to the specified text without clearing the undo buffer. (Inherited from System.Windows.Forms.TextBox)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | SelectAll | Selects all text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Returns a string that represents the System.Windows.Forms.TextBoxBase control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Undo | Undoes the last edit operation in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
public Event | AcceptsTabChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.AcceptsTab property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | BorderStyleChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.BorderStyle property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the text box is clicked. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | HideSelectionChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.HideSelection property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | ModifiedChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.Modified property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | MultilineChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.Multiline property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | ReadOnlyChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.ReadOnly property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextAlignChanged | Occurs when the value of the System.Windows.Forms.TextBox.TextAlign property has changed. (Inherited from System.Windows.Forms.TextBox)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiTextBox Class
Dbi.WinControl Namespace


%%PageItemTitle%%

dbiTextBox Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : dbiTextBox Constructor

objParent
The dbiListControl parent of the new dbiTextBox.
Initialize a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim objParent As DbiListControl

Dim instance As New dbiTextBox(objParent)
C#
public dbiTextBox(
   DbiListControl objParent
)

Parameters

objParent
The dbiListControl parent of the new dbiTextBox.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AppendText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AppendText Method

text
The text to append to the current contents of the text box.
Appends text to the current text of a text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim text As System.String

instance.AppendText(text)
C#
public void AppendText(
   System.string text
)

Parameters

text
The text to append to the current contents of the text box.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BeginInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BringToFront Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Clear Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Clear Method

Clears all text from the text box control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ClearUndo Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ClearUndo Method

Clears information about the most recent operation from the undo buffer of the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.ClearUndo()
C#
public void ClearUndo()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Contains Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Copy Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Copy Method

Copies the current selection in the text box to the Clipboard.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Copy()
C#
public void Copy()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CreateControl() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CreateGraphics Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CreateObjRef Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Cut Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Cut Method

Moves the current selection in the text box to the Clipboard.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Cut()
C#
public void Cut()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DeselectAll Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DeselectAll Method

Specifies that the value of the System.Windows.Forms.TextBoxBase.SelectionLength property is zero so that no characters are selected in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.DeselectAll()
C#
public void DeselectAll()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Dispose() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Dispose() Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DoDragDrop Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

EndInvoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

FindForm Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Focus Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetCharFromPosition Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetCharFromPosition Method

pt
The location from which to seek the nearest character.
Retrieves the character that is closest to the specified location within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim pt As System.Drawing.Point
Dim value As System.Char

value = instance.GetCharFromPosition(pt)
C#
public virtual System.char GetCharFromPosition(
   System.Drawing.Point pt
)

Parameters

pt
The location from which to seek the nearest character.

Return Value

The character at the specified location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetCharIndexFromPosition Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetCharIndexFromPosition Method

pt
The location to search.
Retrieves the index of the character nearest to the specified location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim pt As System.Drawing.Point
Dim value As System.Integer

value = instance.GetCharIndexFromPosition(pt)
C#
public virtual System.int GetCharIndexFromPosition(
   System.Drawing.Point pt
)

Parameters

pt
The location to search.

Return Value

The zero-based character index at the specified location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetContainerControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetFirstCharIndexFromLine Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetFirstCharIndexFromLine Method

lineNumber
The line for which to get the index of its first character.
Retrieves the index of the first character of a given line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim lineNumber As System.Integer
Dim value As System.Integer

value = instance.GetFirstCharIndexFromLine(lineNumber)
C#
public System.int GetFirstCharIndexFromLine(
   System.int lineNumber
)

Parameters

lineNumber
The line for which to get the index of its first character.

Return Value

The zero-based index of the first character in the specified line.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The value of the lineNumber parameter is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetFirstCharIndexOfCurrentLine Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetFirstCharIndexOfCurrentLine Method

Retrieves the index of the first character of the current line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.GetFirstCharIndexOfCurrentLine()
C#
public System.int GetFirstCharIndexOfCurrentLine()

Return Value

The zero-based character index in the current line.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetLineFromCharIndex Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetLineFromCharIndex Method

index
The character index position to search.
Retrieves the line number from the specified character position within the text of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim index As System.Integer
Dim value As System.Integer

value = instance.GetLineFromCharIndex(index)
C#
public virtual System.int GetLineFromCharIndex(
   System.int index
)

Parameters

index
The character index position to search.

Return Value

The zero-based line number in which the character index is located.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetPositionFromCharIndex Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetPositionFromCharIndex Method

index
The index of the character for which to retrieve the location.
Retrieves the location within the control at the specified character index.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim index As System.Integer
Dim value As System.Drawing.Point

value = instance.GetPositionFromCharIndex(index)
C#
public virtual System.Drawing.Point GetPositionFromCharIndex(
   System.int index
)

Parameters

index
The index of the character for which to retrieve the location.

Return Value

The location of the specified character within the client rectangle of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Hide Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Invalidate Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Invoke Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Paste Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Paste Method

Sets the selected text to the specified text without clearing the undo buffer.

Overload List

Overload | Description
Paste(String) | Sets the selected text to the specified text without clearing the undo buffer. (Inherited from System.Windows.Forms.TextBox)
Paste() | Replaces the current selection in the text box with the contents of the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PerformLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PointToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PointToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RectangleToClient Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Refresh Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ResetText Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ResetText Method

Resets the System.Windows.Forms.Control.Text property to its default value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ResumeLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ScrollToCaret Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ScrollToCaret Method

Scrolls the contents of the control to the current caret position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.ScrollToCaret()
C#
public void ScrollToCaret()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Select Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Select Method

Selects a range of text in the text box.

Overload List

Overload | Description
Select(Int32,Int32) | Selects a range of text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
Select() | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SelectAll Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SelectAll Method

Selects all text in the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.SelectAll()
C#
public void SelectAll()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SelectNextControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SendToBack Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SetBounds Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Show Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SuspendLayout Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ToString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ToString Method

Returns a string that represents the System.Windows.Forms.TextBoxBase control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Return Value

A string that represents the current System.Windows.Forms.TextBoxBase. The string includes the type and the System.Windows.Forms.TextBoxBase property of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Undo Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Undo Method

Undoes the last edit operation in the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Undo()
C#
public void Undo()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Update Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AcceptsReturn Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AcceptsReturn Property

Gets or sets a value indicating whether pressing ENTER in a multiline System.Windows.Forms.TextBox control creates a new line of text in the control or activates the default button for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.AcceptsReturn = value

value = instance.AcceptsReturn
C#
public System.bool AcceptsReturn {get; set;}

Property Value

true if the ENTER key creates a new line of text in a multiline version of the control; false if the ENTER key activates the default button for the form. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AcceptsTab Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AcceptsTab Property

Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.AcceptsTab = value

value = instance.AcceptsTab
C#
public System.bool AcceptsTab {get; set;}

Property Value

true if users can enter tabs in a multiline text box using the TAB key; false if pressing the TAB key moves the focus. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AccessibleName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AccessibleRole Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AllowDrop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Anchor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AutoCompleteCustomSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AutoCompleteCustomSource Property

Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.TextBox.AutoCompleteSource property is set to CustomSource.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AutoCompleteStringCollection

instance.AutoCompleteCustomSource = value

value = instance.AutoCompleteCustomSource
C#
public System.Windows.Forms.AutoCompleteStringCollection AutoCompleteCustomSource {get; set;}

Property Value

A System.Collections.Specialized.StringCollection to use with System.Windows.Forms.TextBox.AutoCompleteSource.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AutoCompleteMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AutoCompleteMode Property

Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.TextBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AutoCompleteMode

instance.AutoCompleteMode = value

value = instance.AutoCompleteMode
C#
public System.Windows.Forms.AutoCompleteMode AutoCompleteMode {get; set;}

Property Value

One of the values of System.Windows.Forms.AutoCompleteMode. The following are the values.System.Windows.Forms.AutoCompleteMode.AppendAppends the remainder of the most likely candidate string to the existing characters, highlighting the appended characters.System.Windows.Forms.AutoCompleteMode.SuggestDisplays the auxiliary drop-down list associated with the edit control. This drop-down is populated with one or more suggested completion strings.System.Windows.Forms.AutoCompleteMode.SuggestAppendAppends both Suggest and Append options.System.Windows.Forms.AutoCompleteMode.NoneDisables automatic completion. This is the default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value is not one of the values of System.Windows.Forms.AutoCompleteMode.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AutoCompleteSource Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AutoCompleteSource Property

Gets or sets a value specifying the source of complete strings used for automatic completion.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.AutoCompleteSource

instance.AutoCompleteSource = value

value = instance.AutoCompleteSource
C#
public System.Windows.Forms.AutoCompleteSource AutoCompleteSource {get; set;}

Property Value

One of the values of System.Windows.Forms.AutoCompleteSource. The options are AllSystemSources, AllUrl, FileSystem, HistoryList, RecentlyUsedList, CustomSource, and None. The default is None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified value is not one of the values of System.Windows.Forms.AutoCompleteSource.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BackColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BackColor Property

Gets or sets the background color of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BindingContext Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BorderStyle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BorderStyle Property

Gets or sets the border type of the text box control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
public System.Windows.Forms.BorderStyle BorderStyle {get; set;}

Property Value

A System.Windows.Forms.BorderStyle that represents the border type of the text box control. The default is Fixed3D.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | A value that is not within the range of valid values for the enumeration was assigned to the property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Bottom Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Bounds Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CanFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CanSelect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CanUndo Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CanUndo Property

Gets a value indicating whether the user can undo the previous operation in a text box control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.CanUndo
C#
public System.bool CanUndo {get;}

Property Value

true if the user can undo the previous operation performed in a text box control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Capture Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CausesValidation Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CharacterCasing Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CharacterCasing Property

Gets or sets whether the System.Windows.Forms.TextBox control modifies the case of characters as they are typed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.CharacterCasing

instance.CharacterCasing = value

value = instance.CharacterCasing
C#
public System.Windows.Forms.CharacterCasing CharacterCasing {get; set;}

Property Value

One of the System.Windows.Forms.CharacterCasing enumeration values that specifies whether the System.Windows.Forms.TextBox control modifies the case of characters. The default is CharacterCasing.Normal.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | A value that is not within the range of valid values for the enumeration was assigned to the property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ClientRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ClientSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ClientSize Property

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CompanyName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Container Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ContainsFocus Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ContextMenu Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Controls Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Created Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Cursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DataBindings Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DeviceDpi Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DisplayRectangle Property

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Disposing Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Dock Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Enabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Focused Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Font Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ForeColor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ForeColor Property

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color that represents the control's foreground color.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Handle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HasChildren Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Height Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HideSelection Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HideSelection Property

Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.HideSelection = value

value = instance.HideSelection
C#
public System.bool HideSelection {get; set;}

Property Value

true if the selected text does not appear highlighted when the text box control loses focus; false, if the selected text remains highlighted when the text box control loses focus. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ImeMode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

InvokeRequired Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

IsAccessible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

IsDisposed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

IsMirrored Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

LayoutEngine Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Left Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Lines Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Lines Property

Gets or sets the lines of text in a text box control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value() As System.String

instance.Lines = value

value = instance.Lines
C#
public System.string[] Lines {get; set;}

Property Value

An array of strings that contains the text in a text box control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Location Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Margin Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
C#
public System.Windows.Forms.Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MaximumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MaximumSize Property

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MaxLength Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MaxLength Property

Gets or sets the maximum number of characters the user can type or paste into the text box control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.MaxLength = value

value = instance.MaxLength
C#
public virtual System.int MaxLength {get; set;}

Property Value

The number of characters that can be entered into the control. The default is 32767.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The value assigned to the property is less than 0.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MinimumSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MinimumSize Property

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Modified Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Modified Property

Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.Modified = value

value = instance.Modified
C#
public System.bool Modified {get; set;}

Property Value

true if the control's contents have been modified; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Multiline Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Multiline Property

Gets or sets a value indicating whether this is a multiline System.Windows.Forms.TextBox control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.Multiline = value

value = instance.Multiline
C#
public virtual System.bool Multiline {get; set;}

Property Value

true if the control is a multiline System.Windows.Forms.TextBox control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Name Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Parent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PasswordChar Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PasswordChar Property

Gets or sets the character used to mask characters of a password in a single-line System.Windows.Forms.TextBox control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Char

instance.PasswordChar = value

value = instance.PasswordChar
C#
public System.char PasswordChar {get; set;}

Property Value

The character used to mask characters entered in a single-line System.Windows.Forms.TextBox control. Set the value of this property to 0 (character value) if you do not want the control to mask characters as they are typed. Equals 0 (character value) by default.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PreferredHeight Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PreferredHeight Property

Gets the preferred height for a text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.PreferredHeight
C#
public System.int PreferredHeight {get;}

Property Value

The preferred height of a text box.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PreferredSize Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ProductName Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ProductVersion Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ReadOnly Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ReadOnly Property

Gets or sets a value indicating whether text in the text box is read-only.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public System.bool ReadOnly {get; set;}

Property Value

true if the text box is read-only; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Region Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Right Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RightToLeft Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ScrollBars Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ScrollBars Property

Gets or sets which scroll bars should appear in a multiline System.Windows.Forms.TextBox control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.ScrollBars

instance.ScrollBars = value

value = instance.ScrollBars
C#
public System.Windows.Forms.ScrollBars ScrollBars {get; set;}

Property Value

One of the System.Windows.Forms.ScrollBars enumeration values that indicates whether a multiline System.Windows.Forms.TextBox control appears with no scroll bars, a horizontal scroll bar, a vertical scroll bar, or both. The default is ScrollBars.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | A value that is not within the range of valid values for the enumeration was assigned to the property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SelectedText Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SelectedText Property

Gets or sets a value indicating the currently selected text in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.SelectedText = value

value = instance.SelectedText
C#
public virtual System.string SelectedText {get; set;}

Property Value

A string that represents the currently selected text in the text box.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SelectionLength Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SelectionLength Property

Gets or sets the number of characters selected in the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.SelectionLength = value

value = instance.SelectionLength
C#
public virtual System.int SelectionLength {get; set;}

Property Value

The number of characters selected in the text box.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The assigned value is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SelectionStart Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SelectionStart Property

Gets or sets the starting point of text selected in the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.SelectionStart = value

value = instance.SelectionStart
C#
public System.int SelectionStart {get; set;}

Property Value

The starting position of text selected in the text box.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The assigned value is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ShortcutsEnabled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ShortcutsEnabled Property

Gets or sets a value indicating whether the defined shortcuts are enabled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.ShortcutsEnabled = value

value = instance.ShortcutsEnabled
C#
public virtual System.bool ShortcutsEnabled {get; set;}

Property Value

true to enable the shortcuts; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Site Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Size Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Size Property

Gets or sets the height and width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TabIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TabIndex Property

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public System.int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TabStop Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
C#
public System.bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true.This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Tag Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TextAlign Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TextAlign Property

Gets or sets how text is aligned in a System.Windows.Forms.TextBox control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.HorizontalAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public System.Windows.Forms.HorizontalAlignment TextAlign {get; set;}

Property Value

One of the System.Windows.Forms.HorizontalAlignment enumeration values that specifies how text is aligned in the control. The default is HorizontalAlignment.Left.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | A value that is not within the range of valid values for the enumeration was assigned to the property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TextLength Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TextLength Property

Gets the length of text in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

value = instance.TextLength
C#
public virtual System.int TextLength {get;}

Property Value

The number of characters contained in the text of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Top Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TopLevelControl Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

UseSystemPasswordChar Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : UseSystemPasswordChar Property

Gets or sets a value indicating whether the text in the System.Windows.Forms.TextBox control should appear as the default password character.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.UseSystemPasswordChar = value

value = instance.UseSystemPasswordChar
C#
public System.bool UseSystemPasswordChar {get; set;}

Property Value

true if the text in the System.Windows.Forms.TextBox control should appear as the default password character; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Visible Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

WordWrap Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : WordWrap Property

Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim value As System.Boolean

instance.WordWrap = value

value = instance.WordWrap
C#
public System.bool WordWrap {get; set;}

Property Value

true if the multiline text box control wraps words; false if the text box control automatically scrolls horizontally when the user types past the right edge of the control. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

AcceptsTabChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : AcceptsTabChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.AcceptsTab property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.AcceptsTabChanged, handler
C#
public event System.EventHandler AcceptsTabChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BackColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

BorderStyleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : BorderStyleChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.BorderStyle property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.BorderStyleChanged, handler
C#
public event System.EventHandler BorderStyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ChangeUICues Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Click Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Click Event

Occurs when the text box is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ControlAdded Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ControlRemoved Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

CursorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Disposed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DockChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DragDrop Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DragEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DragLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DragOver Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

EnabledChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Enter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

FontChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GiveFeedback Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GotFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HandleCreated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HelpRequested Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

HideSelectionChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : HideSelectionChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.HideSelection property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.HideSelectionChanged, handler
C#
public event System.EventHandler HideSelectionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Invalidated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

KeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

KeyPress Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

KeyUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Layout Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Leave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

LocationChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

LostFocus Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MarginChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MarginChanged Event

Occurs when the control's margin changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
C#
public event System.EventHandler MarginChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ModifiedChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ModifiedChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.Modified property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ModifiedChanged, handler
C#
public event System.EventHandler ModifiedChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseEnter Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseHover Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseLeave Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseMove Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseUp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MouseWheel Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Move Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

MultilineChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : MultilineChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.Multiline property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.MultilineChanged, handler
C#
public event System.EventHandler MultilineChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ParentChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

ReadOnlyChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : ReadOnlyChanged Event

Occurs when the value of the System.Windows.Forms.TextBoxBase.ReadOnly property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.ReadOnlyChanged, handler
C#
public event System.EventHandler ReadOnlyChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RegionChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Resize Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SizeChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

StyleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TabIndexChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TabIndexChanged Event

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
C#
public event System.EventHandler TabIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TabStopChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TabStopChanged Event

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
C#
public event System.EventHandler TabStopChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TextAlignChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TextAlignChanged Event

Occurs when the value of the System.Windows.Forms.TextBox.TextAlign property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.TextAlignChanged, handler
C#
public event System.EventHandler TextAlignChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

TextChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Validated Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Validating Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

VisibleChanged Event
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

DisplayUserControlEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DisplayUserControlEventArgs Class

Arguments for the DisplayUserControlEvent.

Object Model

DisplayUserControlEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
C#
public class DisplayUserControlEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.DisplayUserControlEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

DisplayUserControlEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DisplayUserControlEventArgs Class

"

The following tables list the members exposed by DisplayUserControlEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | DisplayUserControlEventArgs Constructor | Initialize a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the editable cell exists.
public Property | ColumnItem | The dbiColumnItem where the editable cell exists.
public Property | Height | The height of the cell to be edited.
public Property | NodeItem | The dbiNodeItem that contains the cell to be edited.
public Property | Text | The current text of the cell to be edited.
public Property | Width | The width of the cell to be edited.
public Property | X | The X coordinate of the cell being edited.
public Property | Y | The Y coordinate of the cell to be edited.
Top

See Also

Reference

DisplayUserControlEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

DisplayUserControlEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : DisplayUserControlEventArgs Constructor

Initialize a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DisplayUserControlEventArgs()
C#
public DisplayUserControlEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the editable cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : ColumnItem Property

The dbiColumnItem where the editable cell exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

Height Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : Height Property

The height of the cell to be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell to be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

Text Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : Text Property

The current text of the cell to be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

string

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

Width Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : Width Property

The width of the cell to be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

X Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : X Property

The X coordinate of the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

Y Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DisplayUserControlEventArgs Class : Y Property

The Y coordinate of the cell to be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DisplayUserControlEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DisplayUserControlEventArgs Class
DisplayUserControlEventArgs Members


%%PageItemTitle%%

DropListEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DropListEventArgs Class

Represents the method that will handle an item being dropped on the list.

Object Model

DropListEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DropListEventArgs
C#
public class DropListEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.DropListEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DropListEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

DropListEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DropListEventArgs Class

"

The following tables list the members exposed by DropListEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | DropListEventArgs Constructor | Initializes a new instance of the DropListEventArgs class.
Top

Public Properties

 | Name | Description
public Property | DragEvent | The DragEventArgs related to the Drag/Drop operation.
public Property | NodeItem | The dbiNodeItem where the drop operation occurred.
Top

See Also

Reference

DropListEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

DropListEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DropListEventArgs Class : DropListEventArgs Constructor

Initializes a new instance of the DropListEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DropListEventArgs()
C#
public DropListEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DropListEventArgs Class
DropListEventArgs Members


%%PageItemTitle%%

DragEvent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DropListEventArgs Class : DragEvent Property

The DragEventArgs related to the Drag/Drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DropListEventArgs
Dim value As System.Windows.Forms.DragEventArgs

instance.DragEvent = value

value = instance.DragEvent
C#
public System.Windows.Forms.DragEventArgs DragEvent {get; set;}

Property Value

DragEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DropListEventArgs Class
DropListEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DropListEventArgs Class : NodeItem Property

The dbiNodeItem where the drop operation occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DropListEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DropListEventArgs Class
DropListEventArgs Members


%%PageItemTitle%%

EditInputKeyEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditInputKeyEventArgs Class

Arguments for the EditInputKey Event.

Object Model

EditInputKeyEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
C#
public class EditInputKeyEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.EditInputKeyEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

EditInputKeyEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditInputKeyEventArgs Class

"

The following tables list the members exposed by EditInputKeyEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditInputKeyEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | Handled | A flag the developer can set to inform the control that the operation has been handled.
public Property | KeyData | The KeyData that triggered the event.
public Property | NodeItem | The dbiNodeItem that contains the cell being edited.
Top

See Also

Reference

EditInputKeyEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

EditInputKeyEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : EditInputKeyEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditInputKeyEventArgs()
C#
public EditInputKeyEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : ColumnItem Property

The dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

Handled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : Handled Property

A flag the developer can set to inform the control that the operation has been handled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
Dim value As System.Boolean

instance.Handled = value

value = instance.Handled
C#
public System.bool Handled {get; set;}

Property Value

boolean

Remarks

When overriding default behavior in the EditInputKey event, set this flag to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

KeyData Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : KeyData Property

The KeyData that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
Dim value As System.Windows.Forms.Keys

instance.KeyData = value

value = instance.KeyData
C#
public System.Windows.Forms.Keys KeyData {get; set;}

Property Value

System.Windows.Forms.Keys

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditInputKeyEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditInputKeyEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditInputKeyEventArgs Class
EditInputKeyEventArgs Members


%%PageItemTitle%%

EditKeyDownEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyDownEventArgs Class

Arguments for the EditKeyDown Event.

Object Model

EditKeyDownEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
C#
public class EditKeyDownEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.EditKeyDownEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

EditKeyDownEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyDownEventArgs Class

"

The following tables list the members exposed by EditKeyDownEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditKeyDownEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyDownEvents | The EventArguments for the KeyDown event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyDown event has been processed yet.
Top

See Also

Reference

EditKeyDownEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

EditKeyDownEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : EditKeyDownEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditKeyDownEventArgs()
C#
public EditKeyDownEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : ColumnItem Property

The dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

KeyDownEvents Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : KeyDownEvents Property

The EventArguments for the KeyDown event triggered by the edit control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
Dim value As System.Windows.Forms.KeyEventArgs

instance.KeyDownEvents = value

value = instance.KeyDownEvents
C#
public System.Windows.Forms.KeyEventArgs KeyDownEvents {get; set;}

Property Value

KeyEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : NodeItem Property

The dbiNodeItem containing the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

Processed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyDownEventArgs Class : Processed Property

Determines if the edit control's KeyDown event has been processed yet.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyDownEventArgs
Dim value As System.Boolean

instance.Processed = value

value = instance.Processed
C#
public System.bool Processed {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyDownEventArgs Class
EditKeyDownEventArgs Members


%%PageItemTitle%%

EditKeyPressEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyPressEventArgs Class

Arguments for the EditKeyPress Event.

Object Model

EditKeyPressEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
C#
public class EditKeyPressEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.EditKeyPressEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

EditKeyPressEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyPressEventArgs Class

"

The following tables list the members exposed by EditKeyPressEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditKeyPressEventArgs Constructor | Initializes a new instance of the class
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyPressEvents | The EventArguments for the KeyPress event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyPress event has been processed yet.
Top

See Also

Reference

EditKeyPressEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

EditKeyPressEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : EditKeyPressEventArgs Constructor

Initializes a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditKeyPressEventArgs()
C#
public EditKeyPressEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : ColumnItem Property

The dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

KeyPressEvents Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : KeyPressEvents Property

The EventArguments for the KeyPress event triggered by the edit control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
Dim value As System.Windows.Forms.KeyPressEventArgs

instance.KeyPressEvents = value

value = instance.KeyPressEvents
C#
public System.Windows.Forms.KeyPressEventArgs KeyPressEvents {get; set;}

Property Value

KeyPressEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : NodeItem Property

The dbiNodeItem containing the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

Processed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyPressEventArgs Class : Processed Property

Determines if the edit control's KeyPress event has been processed yet.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyPressEventArgs
Dim value As System.Boolean

instance.Processed = value

value = instance.Processed
C#
public System.bool Processed {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyPressEventArgs Class
EditKeyPressEventArgs Members


%%PageItemTitle%%

EditKeyUpEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyUpEventArgs Class

Arguments for the EditKeyUp Event.

Object Model

EditKeyUpEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
C#
public class EditKeyUpEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.EditKeyUpEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

EditKeyUpEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyUpEventArgs Class

"

The following tables list the members exposed by EditKeyUpEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditKeyUpEventArgs Constructor | Initialize a new instance of the class
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyUpEvents | The EventArguments for the KeyUp event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyUp event has been processed yet.
Top

See Also

Reference

EditKeyUpEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

EditKeyUpEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : EditKeyUpEventArgs Constructor

Initialize a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditKeyUpEventArgs()
C#
public EditKeyUpEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : ColumnItem Property

The dbiColumnItem where the edit control resides.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

KeyUpEvents Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : KeyUpEvents Property

The EventArguments for the KeyUp event triggered by the edit control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
Dim value As System.Windows.Forms.KeyEventArgs

instance.KeyUpEvents = value

value = instance.KeyUpEvents
C#
public System.Windows.Forms.KeyEventArgs KeyUpEvents {get; set;}

Property Value

KeyEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : NodeItem Property

The dbiNodeItem containing the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

Processed Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > EditKeyUpEventArgs Class : Processed Property

Determines if the edit control's KeyUp event has been processed yet.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditKeyUpEventArgs
Dim value As System.Boolean

instance.Processed = value

value = instance.Processed
C#
public System.bool Processed {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditKeyUpEventArgs Class
EditKeyUpEventArgs Members


%%PageItemTitle%%

InitializeCellEditEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : InitializeCellEditEventArgs Class

Arguments for the InitializeCellEdit Event.

Object Model

InitializeCellEditEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As InitializeCellEditEventArgs
C#
public class InitializeCellEditEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.InitializeCellEditEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

InitializeCellEditEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : InitializeCellEditEventArgs Class

"

The following tables list the members exposed by InitializeCellEditEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | InitializeCellEditEventArgs Constructor | Initializes a new instance of the control.
Top

Public Properties

 | Name | Description
public Property | AllowEdit | Determines if the edit process will be allowed.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit will take place.
public Property | ColumnItem | The dbiColumnItem where the edit will take place.
public Property | NodeItem | The dbiNodeItem where the edit will take place.
Top

See Also

Reference

InitializeCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

InitializeCellEditEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > InitializeCellEditEventArgs Class : InitializeCellEditEventArgs Constructor

Initializes a new instance of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New InitializeCellEditEventArgs()
C#
public InitializeCellEditEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Class
InitializeCellEditEventArgs Members


%%PageItemTitle%%

AllowEdit Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > InitializeCellEditEventArgs Class : AllowEdit Property

Determines if the edit process will be allowed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As InitializeCellEditEventArgs
Dim value As System.Boolean

instance.AllowEdit = value

value = instance.AllowEdit
C#
public System.bool AllowEdit {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Class
InitializeCellEditEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > InitializeCellEditEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the edit will take place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As InitializeCellEditEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Class
InitializeCellEditEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > InitializeCellEditEventArgs Class : ColumnItem Property

The dbiColumnItem where the edit will take place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As InitializeCellEditEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Class
InitializeCellEditEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > InitializeCellEditEventArgs Class : NodeItem Property

The dbiNodeItem where the edit will take place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As InitializeCellEditEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

InitializeCellEditEventArgs Class
InitializeCellEditEventArgs Members


%%PageItemTitle%%

ItemEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ItemEventArgs Class

Represents the method that will handle the AfterLabelEdit, BeforeLabelEdit, ItemClick and ItemDoubleClick events.

Object Model

ItemEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemEventArgs
C#
public class ItemEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.ItemEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

ItemEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ItemEventArgs Class

"

The following tables list the members exposed by ItemEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ItemEventArgs Constructor | Initializes a new instance of the DropListEventArgs class.
Top

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that triggered the event
Top

See Also

Reference

ItemEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

ItemEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ItemEventArgs Class : ItemEventArgs Constructor

Initializes a new instance of the DropListEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ItemEventArgs()
C#
public ItemEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemEventArgs Class
ItemEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ItemEventArgs Class : NodeItem Property

The dbiNodeItem that triggered the event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemEventArgs Class
ItemEventArgs Members


%%PageItemTitle%%

ListMouseOverEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ListMouseOverEventArgs Class

Represents the method that will handle the ListMouseOver event.

Object Model

ListMouseOverEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListMouseOverEventArgs
C#
public class ListMouseOverEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.ListMouseOverEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListMouseOverEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

ListMouseOverEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ListMouseOverEventArgs Class

"

The following tables list the members exposed by ListMouseOverEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ListMouseOverEventArgs Constructor | Initializes a new instance of the CellOverEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem being moused over.
public Property | NodeItem | The dbiNodeItem which the mouse is over
Top

See Also

Reference

ListMouseOverEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

ListMouseOverEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ListMouseOverEventArgs Class : ListMouseOverEventArgs Constructor

Initializes a new instance of the CellOverEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ListMouseOverEventArgs()
C#
public ListMouseOverEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListMouseOverEventArgs Class
ListMouseOverEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ListMouseOverEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem being moused over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListMouseOverEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListMouseOverEventArgs Class
ListMouseOverEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ListMouseOverEventArgs Class : NodeItem Property

The dbiNodeItem which the mouse is over

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListMouseOverEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListMouseOverEventArgs Class
ListMouseOverEventArgs Members


%%PageItemTitle%%

NodeClickEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeClickEventArgs Class

Represents the method that will handle the NodeClick event.

Object Model

NodeClickEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
C#
public class NodeClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.NodeClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

NodeClickEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeClickEventArgs Class

"

The following tables list the members exposed by NodeClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | NodeClickEventArgs Constructor | The constructor for the NodeClick event.
Top

Public Properties

 | Name | Description
public Property | Button | The mouse button used to click the node.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem at the point where the node was clicked.
public Property | ColumnItem | The dbiColumnItem at the point where the node was clicked.
public Property | Handled | Determines if the developer has handled the click operation themselves.
public Property | NodeItem | The dbiNodeItem that was clicked.
public Property | X | The X coordinate where the click occurred.
public Property | Y | The Y coordinate where the click occurred.
Top

See Also

Reference

NodeClickEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

NodeClickEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : NodeClickEventArgs Constructor

The constructor for the NodeClick event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NodeClickEventArgs()
C#
public NodeClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : Button Property

The mouse button used to click the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

The mouse button used to click the node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem at the point where the node was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : ColumnItem Property

The dbiColumnItem at the point where the node was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

Handled Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : Handled Property

Determines if the developer has handled the click operation themselves.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As System.Boolean

instance.Handled = value

value = instance.Handled
C#
public System.bool Handled {get; set;}

Property Value

Boolean

Remarks

Setting this property to True will prevent any further click related operations (such as selecting the item) from occurring, as the developer has indicated they have handled such operations.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : NodeItem Property

The dbiNodeItem that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : X Property

The X coordinate where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeClickEventArgs Class : Y Property

The Y coordinate where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeClickEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeClickEventArgs Class
NodeClickEventArgs Members


%%PageItemTitle%%

NodeDoubleClickEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeDoubleClickEventArgs Class

Represents the method that will handle the NodeDoubleClick Event

Object Model

NodeDoubleClickEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
C#
public class NodeDoubleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.NodeDoubleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

NodeDoubleClickEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeDoubleClickEventArgs Class

"

The following tables list the members exposed by NodeDoubleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | NodeDoubleClickEventArgs Constructor | The constructor for the NodeDoubleClick Event
Top

Public Properties

 | Name | Description
public Property | Button | The mouse button used to double click the node.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the double click occurred.
public Property | ColumnItem | The dbiColumnItem where the double click occurred
public Property | NodeItem | The dbiNodeItem that was double clicked
public Property | X | The X coordinate where the double click occurred
public Property | Y | The Y coordinate where the double click occurred.
Top

See Also

Reference

NodeDoubleClickEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

NodeDoubleClickEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : NodeDoubleClickEventArgs Constructor

The constructor for the NodeDoubleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NodeDoubleClickEventArgs()
C#
public NodeDoubleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : Button Property

The mouse button used to double click the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

MouseButtons

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the double click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : ColumnItem Property

The dbiColumnItem where the double click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : NodeItem Property

The dbiNodeItem that was double clicked

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Remarks

Replaces the deprecated "Item" proeprty

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : X Property

The X coordinate where the double click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeDoubleClickEventArgs Class : Y Property

The Y coordinate where the double click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeDoubleClickEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeDoubleClickEventArgs Class
NodeDoubleClickEventArgs Members


%%PageItemTitle%%

NodeItemCollection Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeItemCollection Class

Represents a collection of node items.

Object Model

NodeItemCollection ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
C#
public class NodeItemCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.NodeItemCollection
Dbi.WinControl.Schedule.ScheduleItemCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

NodeItemCollection Class Members
See Also Properties Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeItemCollection Class

"

The following tables list the members exposed by NodeItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | NodeItemCollection Constructor | Initializes a new instance of the NodeItemCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Control | Gets the control this NodeItem is attached to.
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Determines the node item at a specific location in the collection.
public Property | Parent | Gets the parent node for this node item. Will return nothing if this node is the parent node.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a new node to the collection
public Method | AddRange | Adds multiple node items to the list.
public Method | Clear | This method will remove all the items from the collection. To remove a single item, use Remove Method.
public Method | CopyTo | Copies the NodeItem elements to a one-dimensional Array instance at the specified index.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item in the collection based on the dbiNodeItem parameter.
public Method | Insert | Inserts a new dbiNodeItem object into the collection.
public Method | Remove | Removes an item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | Sort | Overloaded. Sorts the items within the collection.
public Method | WriteXMLFile | Writes the data in the collection to an xml file.
public Method | XMLString | Converts the Item Collection to an XML string.
Top

See Also

Reference

NodeItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

NodeItemCollection Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : NodeItemCollection Constructor

Initializes a new instance of the NodeItemCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NodeItemCollection()
C#
public NodeItemCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Add Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Add Method

Adds a new node to the collection Adds a new node item to the control.

Overload List

Overload | Description
Add(String) | Adds a new node item to the collection.
Add(String,Color) | Adds a new node item to the collection.
Add(String,Color,Color) | Adds a new node item to the collection.
Add(dbiNodeItem) | Adds a new node item to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Add(String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Add Method : Add(String) Method

strText
The text of the new node.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim strText As System.String
Dim value As System.Integer

value = instance.Add(strText)
C#
public System.int Add(
   System.string strText
)

Parameters

strText
The text of the new node.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Color) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Add Method : Add(String,Color) Method

strText
The text of the new node.
colorFore
The fore color of the new node.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim strText As System.String
Dim colorFore As System.Drawing.Color
Dim value As System.Integer

value = instance.Add(strText, colorFore)
C#
public System.int Add(
   System.string strText,
   System.Drawing.Color colorFore
)

Parameters

strText
The text of the new node.
colorFore
The fore color of the new node.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Color,Color) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Add Method : Add(String,Color,Color) Method

strText
The text of the new node.
colorFore
The fore color of the new node.
colorBack
The back color of the new node.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim strText As System.String
Dim colorFore As System.Drawing.Color
Dim colorBack As System.Drawing.Color
Dim value As System.Integer

value = instance.Add(strText, colorFore, colorBack)
C#
public System.int Add(
   System.string strText,
   System.Drawing.Color colorFore,
   System.Drawing.Color colorBack
)

Parameters

strText
The text of the new node.
colorFore
The fore color of the new node.
colorBack
The back color of the new node.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiNodeItem) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Add Method : Add(dbiNodeItem) Method

objItem
The dbiNodeItem to add to the collection.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.Add(objItem)
C#
public System.int Add(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to add to the collection.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : AddRange Method

arrayItems
The one-dimensional array of dbiNodeItems to add to the collection
Adds multiple node items to the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim arrayItems() As dbiNodeItem

instance.AddRange(arrayItems)
C#
public void AddRange(
   dbiNodeItem[] arrayItems
)

Parameters

arrayItems
The one-dimensional array of dbiNodeItems to add to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Clear Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Clear Method

This method will remove all the items from the collection. To remove a single item, use Remove Method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection

instance.Clear()
C#
public new void Clear()

Remarks

This method will remove all the items from the collection. To remove a single item, use Remove Method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : CopyTo Method

arrayDestination
The one-dimensional Array that is the destination of the NodeItem objects copied from dbiNodeItem. The Array must have zero-based indexing.
nIndex

The zero-based index in array at which copying begins.

Copies the NodeItem elements to a one-dimensional Array instance at the specified index.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim arrayDestination As System.Array
Dim nIndex As System.Integer

instance.CopyTo(arrayDestination, nIndex)
C#
public void CopyTo(
   System.Array arrayDestination,
   System.int nIndex
)

Parameters

arrayDestination
The one-dimensional Array that is the destination of the NodeItem objects copied from dbiNodeItem. The Array must have zero-based indexing.
nIndex

The zero-based index in array at which copying begins.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

IndexOf(dbiNodeItem) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : IndexOf(dbiNodeItem) Method

obj
A dbiNodeItem in the collection.
Returns the index of a specified item in the collection based on the dbiNodeItem parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim obj As dbiNodeItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiNodeItem obj
)

Parameters

obj
A dbiNodeItem in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Insert Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
objItem
The dbiNodeItem object to insert.
Inserts a new dbiNodeItem object into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim nIndex As System.Integer
Dim objItem As dbiNodeItem

instance.Insert(nIndex, objItem)
C#
public void Insert(
   System.int nIndex,
   dbiNodeItem objItem
)

Parameters

nIndex
The zero-based index location where the item is inserted.
objItem
The dbiNodeItem object to insert.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Remove Method

objItem
The dbiNodeItem to remove.
Removes an item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim objItem As dbiNodeItem

instance.Remove(objItem)
C#
public void Remove(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to remove.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Sort Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Sort Method

Sorts the items within the collection.

Overload List

Overload | Description
Sort(Int32[],Boolean,Boolean) | Sorts the items in the collection.
Sort(Int32[],Boolean,Boolean,Int32) | Sorts the items in the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Sort(Int32[],Boolean,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Sort Method : Sort(Int32[],Boolean,Boolean) Method

arrSortColumns
An array of columns to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
Sorts the items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim arrSortColumns() As System.Integer
Dim bSortAsc As System.Boolean
Dim bIgnoreCase As System.Boolean

instance.Sort(arrSortColumns, bSortAsc, bIgnoreCase)
C#
public void Sort(
   System.int[] arrSortColumns,
   System.bool bSortAsc,
   System.bool bIgnoreCase
)

Parameters

arrSortColumns
An array of columns to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

Sort(Int32[],Boolean,Boolean,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class > Sort Method : Sort(Int32[],Boolean,Boolean,Int32) Method

arrSortColumns
An array of columns to perform the sort.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
nLevels
Determines the highest level (parent/child) where the sort will occur.
Sorts the items in the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim arrSortColumns() As System.Integer
Dim bSortAsc As System.Boolean
Dim bIgnoreCase As System.Boolean
Dim nLevels As System.Integer

instance.Sort(arrSortColumns, bSortAsc, bIgnoreCase, nLevels)
C#
public void Sort(
   System.int[] arrSortColumns,
   System.bool bSortAsc,
   System.bool bIgnoreCase,
   System.int nLevels
)

Parameters

arrSortColumns
An array of columns to perform the sort.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
nLevels
Determines the highest level (parent/child) where the sort will occur.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members
Overload List


%%PageItemTitle%%

WriteXMLFile Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the xml file.
Writes the data in the collection to an xml file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the xml file.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

XMLString Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : XMLString Method

Converts the Item Collection to an XML string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

A System.String value representing the data for the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Capacity Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Control Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Control Property

Gets the control this NodeItem is attached to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As DbiListControl

instance.Control = value

value = instance.Control
C#
public DbiListControl Control {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Count Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Item Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Item Property

nIndex
The zero-based index of the dbiNodeItem to get or set in the collection.
Determines the node item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim nIndex As System.Integer
Dim value As dbiNodeItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiNodeItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the dbiNodeItem to get or set in the collection.

Property Value

A dbiNodeItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

Parent Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : Parent Property

Gets the parent node for this node item. Will return nothing if this node is the parent node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NodeItemCollection
Dim value As dbiNodeItem

instance.Parent = value

value = instance.Parent
C#
public dbiNodeItem Parent {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

RemoveUserControlsEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : RemoveUserControlsEventArgs Class

Arguments for the RemoveUserControls Event.

Object Model

RemoveUserControlsEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RemoveUserControlsEventArgs
C#
public class RemoveUserControlsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.RemoveUserControlsEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RemoveUserControlsEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

RemoveUserControlsEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : RemoveUserControlsEventArgs Class

"

The following tables list the members exposed by RemoveUserControlsEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | RemoveUserControlsEventArgs Constructor | Initialize a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem the UserControl is being displayed over.
public Property | ColumnItem | The dbiColumnItem the UserControl is being displayed over.
public Property | NodeItem | The dbiNodeItem that contains the cell the UserControl is displayed over.
Top

See Also

Reference

RemoveUserControlsEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

RemoveUserControlsEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > RemoveUserControlsEventArgs Class : RemoveUserControlsEventArgs Constructor

Initialize a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New RemoveUserControlsEventArgs()
C#
public RemoveUserControlsEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RemoveUserControlsEventArgs Class
RemoveUserControlsEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > RemoveUserControlsEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem the UserControl is being displayed over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RemoveUserControlsEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RemoveUserControlsEventArgs Class
RemoveUserControlsEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > RemoveUserControlsEventArgs Class : ColumnItem Property

The dbiColumnItem the UserControl is being displayed over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RemoveUserControlsEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RemoveUserControlsEventArgs Class
RemoveUserControlsEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > RemoveUserControlsEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell the UserControl is displayed over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RemoveUserControlsEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RemoveUserControlsEventArgs Class
RemoveUserControlsEventArgs Members


%%PageItemTitle%%

UserDrawnCellEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnCellEventArgs Class

Arguments for the UserDrawnCell Event.

Object Model

UserDrawnCellEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
C#
public class UserDrawnCellEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.UserDrawnCellEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

UserDrawnCellEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnCellEventArgs Class

"

The following tables list the members exposed by UserDrawnCellEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnCellEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the cell is being drawn.
public Property | ColumnItem | The dbiColumnItem where the cell is being drawn.
public Property | Graphics | A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | NodeItem | The dbiNodeItem that contains the cell being drawn.
public Property | PaintCell | Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnCellEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

UserDrawnCellEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : UserDrawnCellEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnCellEventArgs()
C#
public UserDrawnCellEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the cell is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : ColumnItem Property

The dbiColumnItem where the cell is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : Graphics Property

A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : NodeItem Property

The dbiNodeItem that contains the cell being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

PaintCell Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : PaintCell Property

Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As System.Boolean

instance.PaintCell = value

value = instance.PaintCell
C#
public System.bool PaintCell {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnCellEventArgs Class : Rect Property

A rectangle representing the area being painted in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCellEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Remarks

The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnCell event the e.Rect object represents the cell area to be painted in the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCellEventArgs Class
UserDrawnCellEventArgs Members


%%PageItemTitle%%

UserDrawnColumnHeaderEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnColumnHeaderEventArgs Class

Arguments for the UserDrawnColumnHeaders Event.

Object Model

UserDrawnColumnHeaderEventArgs ClassdbiColumnItem ClassdbiColumnFormat Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
C#
public class UserDrawnColumnHeaderEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.UserDrawnColumnHeaderEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

UserDrawnColumnHeaderEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnColumnHeaderEventArgs Class

"

The following tables list the members exposed by UserDrawnColumnHeaderEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnColumnHeaderEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the header is being drawn.
public Property | ColumnItem | The dbiColumnItem where the header is being drawn.
public Property | Graphics | A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | PaintHeader | Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.
public Property | Rect | A rectangle representing the area being painted in the control.
public Property | Status | Determines the current status of the header column in the display.
Top

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

UserDrawnColumnHeaderEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : UserDrawnColumnHeaderEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnColumnHeaderEventArgs()
C#
public UserDrawnColumnHeaderEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the header is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : ColumnItem Property

The dbiColumnItem where the header is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : Graphics Property

A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

PaintHeader Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : PaintHeader Property

Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As System.Boolean

instance.PaintHeader = value

value = instance.PaintHeader
C#
public System.bool PaintHeader {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : Rect Property

A rectangle representing the area being painted in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Remarks

The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnColumnHeader event the e.Rect object represents the column header area to be painted in the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

Status Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnColumnHeaderEventArgs Class : Status Property

Determines the current status of the header column in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnColumnHeaderEventArgs
Dim value As enumColHeaderStatus

instance.Status = value

value = instance.Status
C#
public enumColHeaderStatus Status {get; set;}

Property Value

enumerated value

Remarks

This property can be used to determine if the user is currently interacting with the column header (clicking or mousing over it).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
UserDrawnColumnHeaderEventArgs Members


%%PageItemTitle%%

UserDrawnNodeEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnNodeEventArgs Class

Arguments for the UserDrawnNode Event.

Object Model

UserDrawnNodeEventArgs ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnNodeEventArgs
C#
public class UserDrawnNodeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.UserDrawnNodeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

UserDrawnNodeEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnNodeEventArgs Class

"

The following tables list the members exposed by UserDrawnNodeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnNodeEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | NodeItem | The dbiNodeItem that will be drawn
public Property | PaintNode | Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnNodeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

UserDrawnNodeEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnNodeEventArgs Class : UserDrawnNodeEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnNodeEventArgs()
C#
public UserDrawnNodeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Class
UserDrawnNodeEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnNodeEventArgs Class : Graphics Property

A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnNodeEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Class
UserDrawnNodeEventArgs Members


%%PageItemTitle%%

NodeItem Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnNodeEventArgs Class : NodeItem Property

The dbiNodeItem that will be drawn

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnNodeEventArgs
Dim value As dbiNodeItem

instance.NodeItem = value

value = instance.NodeItem
C#
public dbiNodeItem NodeItem {get; set;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Class
UserDrawnNodeEventArgs Members


%%PageItemTitle%%

PaintNode Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnNodeEventArgs Class : PaintNode Property

Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnNodeEventArgs
Dim value As System.Boolean

instance.PaintNode = value

value = instance.PaintNode
C#
public System.bool PaintNode {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Class
UserDrawnNodeEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnNodeEventArgs Class : Rect Property

A rectangle representing the area being painted in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnNodeEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Remarks

The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnNode event the e.Rect object represents the node area to be painted in the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnNodeEventArgs Class
UserDrawnNodeEventArgs Members


%%PageItemTitle%%

UserDrawnTitleEventArgs Class
See Also Members
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnTitleEventArgs Class

Arguments for the UserDrawnTitle Event.

Object Model

UserDrawnTitleEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTitleEventArgs
C#
public class UserDrawnTitleEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.UserDrawnTitleEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTitleEventArgs Members
Dbi.WinControl Namespace


%%PageItemTitle%% $$Members$$

UserDrawnTitleEventArgs Class Members
See Also Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnTitleEventArgs Class

"

The following tables list the members exposed by UserDrawnTitleEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnTitleEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | PaintTitle | Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnTitleEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%%

UserDrawnTitleEventArgs Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnTitleEventArgs Class : UserDrawnTitleEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnTitleEventArgs()
C#
public UserDrawnTitleEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTitleEventArgs Class
UserDrawnTitleEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnTitleEventArgs Class : Graphics Property

A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTitleEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTitleEventArgs Class
UserDrawnTitleEventArgs Members


%%PageItemTitle%%

PaintTitle Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnTitleEventArgs Class : PaintTitle Property

Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTitleEventArgs
Dim value As System.Boolean

instance.PaintTitle = value

value = instance.PaintTitle
C#
public System.bool PaintTitle {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTitleEventArgs Class
UserDrawnTitleEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > UserDrawnTitleEventArgs Class : Rect Property

A rectangle representing the area being painted in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTitleEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Remarks

The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnTitle event the e.Rect object represents the title area to be painted in the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTitleEventArgs Class
UserDrawnTitleEventArgs Members


%%PageItemTitle%%

enumAlignment Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumAlignment Enumeration

Specifies horizontal and vertical alignment within the container object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumAlignment
C#
public enum enumAlignment : System.Enum

Members

Member | Description
BottomCenter | Content is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Content is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Content is vertically aligned at the bottom, and horizontally aligned on the right.
Default | Default alignment
MiddleCenter | Content is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Content is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Content is vertically aligned in the middle, and horizontally aligned on the right.
TopCenter | Content is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Content is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Content is vertically aligned at the top, and horizontally aligned on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumAlignment

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumArrowAlign Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumArrowAlign Enumeration

Specifies alignment of sort arrows on a column.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumArrowAlign
C#
public enum enumArrowAlign : System.Enum

Members

Member | Description
Left | To the left of the column header text.
Right | To the right of the column header text.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumArrowAlign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumControlAction Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumControlAction Enumeration

Specifies the source of an action on the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumControlAction
C#
public enum enumControlAction : System.Enum

Members

Member | Description
ByKeyboard | Action was triggered by Keyboard
ByMouse | Action was triggered by mouse
Unknown | Action was triggered by unknown source

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumControlAction

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumDataType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumDataType Enumeration

Data types associated with various controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumDataType
C#
public enum enumDataType : System.Enum

Members

Member | Description
Boolean | True/False boolean value
DateTime | DateTime value
Image | Image type
Integer | Integer value
Real | Decimal number
Text | Text data

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumDataType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumEditType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumEditType Enumeration

Specifies the type of edit control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumEditType
C#
public enum enumEditType : System.Enum

Members

Member | Description
ComboBox | The built in ComboBox
TextBox | The built in TextBox
UserControl | A developer defined UserControl

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumEditType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumHorzScrollType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumHorzScrollType Enumeration

Determines how the list area will be scrolled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumHorzScrollType
C#
public enum enumHorzScrollType : System.Enum

Members

Member | Description
Columns | The horizontal scroll bar will receive a value based on the number of columns in the list not including the pre-column.
Width | The horizontal scroll bar will receive a value based upon the total width of all columns and the pre-column.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumHorzScrollType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumItemHeightType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumItemHeightType Enumeration

Determines if the item height can be resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumItemHeightType
C#
public enum enumItemHeightType : System.Enum

Members

Member | Description
Fixed | The item height is a fixed size and cannot be resized with the mouse.
Variable | The item height is a variable size and can be resized with the mouse.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumItemHeightType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumLineType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumLineType Enumeration

Determines the list/tree line connector line types.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineType
C#
public enum enumLineType : System.Enum

Members

Member | Description
Dotted | Dotted lines are displayed.
None | No lines are displayed.
Solid | Solid lines are displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumLineType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumListType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumListType Enumeration

Determines how the nodes will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumListType
C#
public enum enumListType : System.Enum

Members

Member | Description
ListView | The nodes will be drawn in a list format.
TreeView | The nodes will be drawn in a tree format which can contain child nodes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumListType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumPlusMinusStyle Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumPlusMinusStyle Enumeration

Determines the style used to paint the plus/minus boxes

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPlusMinusStyle
C#
public enum enumPlusMinusStyle : System.Enum

Members

Member | Description
Flat | A flat webstyle plus/minus box.
None | No plus/minus boxes
Triangle | A Triangle style plus/minus box.
Vista | A Vista system style plus/minus box.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumPlusMinusStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumPreColumnType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumPreColumnType Enumeration

Determines the pre-column to be used on the list part of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPreColumnType
C#
public enum enumPreColumnType : System.Enum

Members

Member | Description
Arrow | Arrow indicator for selected item.
None | No pre-column.
Number0 | Item numbers (0-based).
Number1 | Item numbers (1-based).
Picture | Uses pre-column image property to show an image for the selected item.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumPreColumnType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumPrintListFormat Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumPrintListFormat Enumeration

Specifies the type of list to print.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPrintListFormat
C#
public enum enumPrintListFormat : System.Enum

Members

Member | Description
All | Print all the nodes in the control.
Current | Print only the currently displayed nodes.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumPrintListFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumPrintReportType Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumPrintReportType Enumeration

Determines the type of report to print.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPrintReportType
C#
public enum enumPrintReportType : System.Enum

Members

Member | Description
Current | Print only those items which are currently visible in the control.
Full | Print all the items in the control.
Page | Print only the current page in the control.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumPrintReportType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumSortDirection Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumSortDirection Enumeration

Determines the directions of the sort.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSortDirection
C#
public enum enumSortDirection : System.Enum

Members

Member | Description
Ascend | Ascending order.
Descend | Descending order.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumSortDirection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

enumStyle Enumeration
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : enumStyle Enumeration

Specifies the style of the control to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumStyle
C#
public enum enumStyle : System.Enum

Members

Member | Description
Standard | Standard format.
XP | Windows XP™ styling.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.enumStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.AfterColumnSortEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.AfterColumnSortEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterColumnSort Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.AfterColumnSortEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.AfterColumnSortEventHandler(
   System.object sender,
   AfterColumnSortEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.AfterColumnSortEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.BeforeColumnSortEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.BeforeColumnSortEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeColumnSort Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.BeforeColumnSortEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.BeforeColumnSortEventHandler(
   System.object sender,
   BeforeColumnSortEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.BeforeColumnSortEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventAfterCellEditHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventAfterCellEditHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterCellEdit Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventAfterCellEditHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventAfterCellEditHandler(
   System.object sender,
   AfterCellEditEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventAfterCellEditHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventAfterNodeCollapseHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventAfterNodeCollapseHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterNodeCollapse Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventAfterNodeCollapseHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventAfterNodeCollapseHandler(
   System.object sender,
   AfterNodeCollapseEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventAfterNodeCollapseHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventAfterNodeExchangeHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventAfterNodeExchangeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterNodeExchange Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventAfterNodeExchangeHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventAfterNodeExchangeHandler(
   System.object sender,
   AfterNodeExchangeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventAfterNodeExchangeHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventAfterNodeExpandHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventAfterNodeExpandHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterNodeExpand Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventAfterNodeExpandHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventAfterNodeExpandHandler(
   System.object sender,
   AfterNodeExpandEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventAfterNodeExpandHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventAfterNodeSelectHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventAfterNodeSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterNodeSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventAfterNodeSelectHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventAfterNodeSelectHandler(
   System.object sender,
   AfterNodeSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventAfterNodeSelectHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeCellEditHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeCellEditHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeCellEdit Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeCellEditHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeCellEditHandler(
   System.object sender,
   BeforeCellEditEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeCellEditHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeCellTextDisplayHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeCellTextDisplayHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeCellTextDisplay Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeCellTextDisplayHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeCellTextDisplayHandler(
   System.object sender,
   BeforeCellTextDisplayEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeCellTextDisplayHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeNodeCollapseHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeNodeCollapseHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeNodeCollapse Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeNodeCollapseHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeNodeCollapseHandler(
   System.object sender,
   BeforeNodeCollapseEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeNodeCollapseHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeNodeExchangeHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeNodeExchangeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeNodeExchange Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeNodeExchangeHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeNodeExchangeHandler(
   System.object sender,
   BeforeNodeExchangeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeNodeExchangeHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeNodeExpandHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeNodeExpandHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeNodeExpand Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeNodeExpandHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeNodeExpandHandler(
   System.object sender,
   BeforeNodeExpandEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeNodeExpandHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforeNodeSelectHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforeNodeSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeNodeSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforeNodeSelectHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforeNodeSelectHandler(
   System.object sender,
   BeforeNodeSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforeNodeSelectHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventBeforePaintHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventBeforePaintHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforePaint Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventBeforePaintHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventBeforePaintHandler(
   System.object sender,
   BeforePaintEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventBeforePaintHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventChangeEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventChangeEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the Change Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventChangeEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventChangeEventHandler(
   System.object sender,
   ChangeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventChangeEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventCheckClickEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventCheckClickEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the CheckClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventCheckClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventCheckClickEventHandler(
   System.object sender,
   CheckEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventCheckClickEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventDisplayUserControlHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventDisplayUserControlHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the DisplayUserControl Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventDisplayUserControlHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventDisplayUserControlHandler(
   System.object sender,
   DisplayUserControlEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventDisplayUserControlHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventDropListEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventDropListEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the DropList Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventDropListEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventDropListEventHandler(
   System.object sender,
   DropListEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventDropListEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventEditInputKeyHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventEditInputKeyHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the EditInputKey Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventEditInputKeyHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventEditInputKeyHandler(
   System.object sender,
   EditInputKeyEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventEditInputKeyHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventEditKeyDownHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventEditKeyDownHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the EditKeyDown Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventEditKeyDownHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventEditKeyDownHandler(
   System.object sender,
   EditKeyDownEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventEditKeyDownHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventEditKeyPressHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventEditKeyPressHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the EditKeyPress Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventEditKeyPressHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventEditKeyPressHandler(
   System.object sender,
   EditKeyPressEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventEditKeyPressHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventEditKeyUpHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventEditKeyUpHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the EditKeyUp Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventEditKeyUpHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventEditKeyUpHandler(
   System.object sender,
   EditKeyUpEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventEditKeyUpHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventHeaderClickEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventHeaderClickEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the HeaderClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventHeaderClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventHeaderClickEventHandler(
   System.object sender,
   ColumnEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventHeaderClickEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventHeaderDoubleClickEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventHeaderDoubleClickEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the HeaderDoubleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventHeaderDoubleClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventHeaderDoubleClickEventHandler(
   System.object sender,
   ColumnEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventHeaderDoubleClickEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventInitializeCellEditHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventInitializeCellEditHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the InitializeCellEdit Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventInitializeCellEditHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventInitializeCellEditHandler(
   System.object sender,
   InitializeCellEditEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventInitializeCellEditHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventListMouseOverEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventListMouseOverEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ListMouseOver Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventListMouseOverEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventListMouseOverEventHandler(
   System.object sender,
   ListMouseOverEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventListMouseOverEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventNodeClickEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventNodeClickEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the NodeClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventNodeClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventNodeClickEventHandler(
   System.object sender,
   NodeClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventNodeClickEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventNodeDoubleClickEventHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventNodeDoubleClickEventHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the NodeDoubleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventNodeDoubleClickEventHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventNodeDoubleClickEventHandler(
   System.object sender,
   NodeDoubleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventNodeDoubleClickEventHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventRemoveUserControlsHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventRemoveUserControlsHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the RemoveUserControls Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventRemoveUserControlsHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventRemoveUserControlsHandler(
   System.object sender,
   RemoveUserControlsEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventRemoveUserControlsHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventUserDrawnCellHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventUserDrawnCellHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnCell Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventUserDrawnCellHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventUserDrawnCellHandler(
   System.object sender,
   UserDrawnCellEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventUserDrawnCellHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventUserDrawnColumnHeaderHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventUserDrawnColumnHeaderHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnColumnHeader Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventUserDrawnColumnHeaderHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventUserDrawnColumnHeaderHandler(
   System.object sender,
   UserDrawnColumnHeaderEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventUserDrawnColumnHeaderHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventUserDrawnNodeHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventUserDrawnNodeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnNode Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventUserDrawnNodeHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventUserDrawnNodeHandler(
   System.object sender,
   UserDrawnNodeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventUserDrawnNodeHandler Members
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl.EventUserDrawnTitleHandler Delegate
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl.EventUserDrawnTitleHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnTitle Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DbiListControl.EventUserDrawnTitleHandler(AddressOf HandlerMethod)
C#
public delegate void DbiListControl.EventUserDrawnTitleHandler(
   System.object sender,
   UserDrawnTitleEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl.EventUserDrawnTitleHandler Members
Dbi.WinControl Namespace


%%ItemTitle%%

Dbi.WinControl.Schedule Namespace
See Also Inheritance Hierarchy
dbiScheduleE Assembly : Dbi.WinControl.Schedule Namespace

Classes

Class | Description
AfterGuideLineInsertedEventArgs | Provides data for the AfterGuideLineInserted Event.
AfterGuideLineMovedEventArgs | Provides data for the AfterGuideLineMoved Event.
AfterGuideLineRemovedEventArgs | Provides data for the AfterGuideLineRemoved Event.
AfterTimeBarDropEventArgs | Provides data for the AfterTimebarDrop event.
AfterTimeBarInsertedEventArgs | Provides data for the AfterTimebarInserted event.
AfterTimeBarLinkedEventArgs | Provides data for the AfterTimebarLinked event.
AfterTimeBarMovedEventArgs | Provides data for the AfterTimebarMoved event.
AfterTimeBarRemovedEventArgs | Provides data for the AfterTimebarRemoved event.
AfterTimeBarSelectEventArgs | Provides data for the AfterTimeBarSelect Event
AfterTimeBarSizedEventArgs | Provides data for the AfterTimebarSized event.
AfterTimeBarSplitEventArgs | Provides data for the AfterTimebarSplit event.
AfterTimeBarUnlinkedEventArgs | Provides data for the AfterTimebarUnlinked event.
AfterTimeBarUnSelectEventArgs | Provides data for the AfterTimeBarUnSelect Event
AlarmTimeBarEndEventArgs | Provides data for the AlarmTimebarEnd event.
AlarmTimeBarStartEventArgs | Provides data for the AlarmTimebarStart event.
BeforeGuideLineInsertEventArgs | Provides data for the BeforeGuideLineInsert Event.
BeforeGuideLineMoveEventArgs | Provides data for the BeforeGuideLineMove Event.
BeforeGuideLineRemoveEventArgs | Provides data for the BeforeGuideLineRemove Event .
BeforePrintPageNumberEventArgs | Provides data for the BeforePrintPageNumber Event
BeforeTimeBarDropEventArgs | Provides data for the BeforeTimebarDrop event.
BeforeTimeBarInsertEventArgs | Provides data for the BeforeTimebarInsert event.
BeforeTimeBarLinkEventArgs | Provides data for the BeforeTimebarLink event.
BeforeTimeBarMoveEventArgs | Provides data for the BeforeTimebarMove event.
BeforeTimeBarRemoveEventArgs | Provides data for the BeforeTimebarRemove event.
BeforeTimeBarSelectEventArgs | Provides data for the BeforeTimebarSelect event.
BeforeTimeBarSizeEventArgs | Provides data for the BeforeTimebarSize event.
BeforeTimeBarSplitEventArgs | Provides data for the BeforeTimebarSplit event.
BeforeTimeBarUnlinkEventArgs | Provides data for the BeforeTimebarUnlink event.
BeforeTimeBarUnSelectEventArgs | Provides data for the BeforeTimeBarUnSelect Event
BeforeToolTipsEventArgs | Provides data for the BeforeToolTips event.
ControlErrorEventArgs | Provides data for the ControlError event.
dbiGuideLine | Provides the properties for defining a GuideLine for use in the GuideLines collection.
dbiGuideLineCollection | Provides a collection of GuideLine objects to the dbiScheduleObject.
dbiHistoryItem | Gets the properties of a history item.
dbiLinkItem | Provides properties for defining Timebar links.
dbiSchedule | Provides the properties for defining the list area and general properties of dbiSchedule.
dbiScheduleItem | Provides properties for defining items in the list area of dbiSchedule.
dbiScheduleNote | Provides the properties for defining a ScheduleNote for use in the dbiScheduleNote Collection.
dbiScheduleNoteCollection | Provides a collection of dbiScheduleNote objects to the dbiScheduleItem.
dbiScheduleObject | Provides properties for defining schedules.
dbiTimeBarItem | Provides properties for defining a Timebar.
dbiTimeBarStyle | Provides properties for defining Timebar styles.
dbiUserDrawnBar | Provides properties for custom drawing TimeBars in the UserDrawnTimeBars Event
dbiUserDrawnBarCollection | A collection of dbiUserDrawnBar Class
DeadZoneDropEventArgs | Provides data for the DeadZoneDrop Event.
EditModeChangedEventArgs | Provides data for the EditModeChanged event of the dbiSchedule control.
FirstDrawEventArgs | Provides data for the FirstDraw event.
GuideLineClickEventArgs | Provides data for the GuideLineClick Event.
GuideLineInDeadZoneEventArgs | Provides data for the GuideLineInDeadZone Event
GuideLineMoveEventArgs | Provides data for the GuideLineMove Event.
HistoryChangeEventArgs | Provides data for the HistoryChange event.
HistoryCollection | Represents a collection of history items.
ItemMouseOverEventArgs | Provides data for the ItemMouseOver event.
LineArrowClickEventArgs | Provides data for the LineArrowClick Event.
LineArrowDoubleClickEventArgs | Provides data for the LineArrowDoubleClick Event
LineArrowMouseOverEventArgs | Provides data for the LineArrowMouseOver Event
LinkCollection | Represents a collection of link items.
ListClickEventArgs | Provides data to the ListClick event in dbiSchedule.
ListDoubleClickEventArgs | Provides data to the ListDoubleClick event in dbiSchedule.
ListDropEventArgs | Provides data to the ListDrop event in dbiSchedule.
MouseWheelCheckEventArgs | Provides data for the MouseWheelCheck Event
NoteClickEventArgs | Provides data for the NoteClick Event
NoteDoubleClickEventArgs | Provides data for the NoteDoubleClick Event
RedoActionEventArgs | Provides data to the RedoAction event in dbiSchedule.
RulerDragEventArgs | Provides data to the RulerDrag Event
ScheduleClickEventArgs | Provides data to the ScheduleClick Event
ScheduleCollection | Represents a collection of schedules.
ScheduleItemCollection | Represents a collection of schedules items.
ScheduleScrollBarsOffsetAreaEventArgs | Provides data to the ScheduleScrollBarsOffsetArea Event
ScrollBufferResizeArgs | Provides data to the ScrollBufferResize Event in dbiSchedule.
ScrollTrackEventArgs | Provides the scroll bar used in the ScrollTrackEvent as well as the current value of the scroll bar.
TimeBarClickEventArgs | Provides data to the TimebarClick event in dbiSchedule.
TimeBarDateTextEventArgs | Provides data to the TimeBarDateText Event in dbiSchedule.
TimeBarDoubleClickEventArgs | Provides data to the TimebarDoubleClick event in dbiSchedule.
TimeBarItemCollection | Represents a collection of Timebars.
TimeBarMouseEnterEventArgs | Provides data for the TimeBarMouseEnter event.
TimeBarMouseLeaveEventArgs | Provides data for the TimeBarMouseLeave event.
TimeBarMovingEventArgs | Provides data to the TimeBarMoving Event
TimeBarSizingEventArgs | Provides data to the TimebarSizing event in dbiSchedule.
TimeBarStyleCollection | Represents a collections of Timebar styles.
UndoActionEventArgs | Provides data to the UndoAction event in dbiSchedule.
UserDrawnBarAfterEventArgs | Provides data to the UserDrawnBarAfter Event in dbiSchedule.
UserDrawnBarEventArgs | Provides data to the UserDrawnBar Event in dbiSchedule.
UserDrawnCustomAreaEventArgs | Provides data to the UserDrawnCustomArea Event
UserDrawnFooterEventArgs | Provides data to the UserDrawnFooter Event in dbiSchedule.
UserDrawnHeaderEventArgs | Provides data to the UserDrawnHeader Event in dbiSchedule.
UserDrawnLineEventArgs | Provides data to the UserDrawnLine Event in dbiSchedule.
UserDrawnLinkLineEventArgs | Provides data to the UserDrawnLinkLine Event in dbiSchedule.
UserDrawnListScrollAreaEventArgs | Provides data to the UserDrawnListScrollArea Event
UserDrawnRulerEventArgs | Provides data to the UserDrawnRuler Event
UserDrawnRulerSegmentEventArgs | Provides data to the UserDrawnRulerSegment Event in dbiSchedule.
UserDrawnRulerTitleEventArgs | Provides data to the UserDrawnRulerTitle Event
UserDrawnTimeBarsEventArgs | Provides data to the UserDrawnTimeBars Event
UserDrawnWaterMarkEventArgs | Provides data to the UserDrawnWaterMark Event
ValuePointEventArgs | Provides data to the ValuePoint event in dbiSchedule.

Delegates

Delegate | Description
dbiSchedule.EventAfterGuideLineInsertedHandler | Represents the method that handles the AfterGuideLineInserted Event
dbiSchedule.EventAfterGuideLineMovedHandler | Represents the method that handles the AfterGuideLineMoved Event
dbiSchedule.EventAfterGuideLineRemovedHandler | Represents the method that handles the AfterGuideLineRemoved Event
dbiSchedule.EventAfterTimeBarDropHandler | Represents the method that handles the AfterTimebarDrop event in dbiSchedule.
dbiSchedule.EventAfterTimeBarInsertedHandler | Represents the method that handles the AfterTimebarInserted event in dbiSchedule.
dbiSchedule.EventAfterTimeBarLinkedHandler | Represents the method that handles the AfterTimebarLinked event in dbiSchedule.
dbiSchedule.EventAfterTimeBarMovedHandler | Represents the method that handles the AfterTimebarMoved event in dbiSchedule.
dbiSchedule.EventAfterTimeBarRemovedHandler | Represents the method that handles the AfterTimebarRemoved event in dbiSchedule.
dbiSchedule.EventAfterTimeBarSelectHandler | Represents the method that handles the AfterTimeBarSelect Event
dbiSchedule.EventAfterTimeBarSizedHandler | Represents the method that handles the AfterTimebarSized event in dbiSchedule.
dbiSchedule.EventAfterTimeBarSplitHandler | Represents the method that handles the AfterTimebarSplit event in dbiSchedule.
dbiSchedule.EventAfterTimeBarUnlinkedHandler | Represents the method that handles the AfterTimebarUnlinked event in dbiSchedule.
dbiSchedule.EventAfterTimeBarUnSelectHandler | Represents the method that handles the AfterTimeBarUnSelect Event
dbiSchedule.EventAlarmTimeBarEndHandler | Represents the method that handles the AlarmTimebarEnd event in dbiSchedule.
dbiSchedule.EventAlarmTimeBarStartHandler | Represents the method that handles the AlarmTimebarStart event in dbiSchedule.
dbiSchedule.EventBeforeGuideLineInsertHandler | Represents the method that handles the BeforeGuideLineInsert Event
dbiSchedule.EventBeforeGuideLineMoveHandler | Represents the method that handles the BeforeGuideLineMove Event
dbiSchedule.EventBeforeGuideLineRemoveHandler | Represents the method that handles the BeforeGuideLineRemove Event
dbiSchedule.EventBeforePrintPageNumberHandler | Represents the method that handles the BeforePrintPageNumber Event
dbiSchedule.EventBeforeTimeBarDropHandler | Represents the method that handles the BeforeTimebarDrop event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarInsertHandler | Represents the method that handles the BeforeTimebarInsert event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarLinkHandler | Represents the method that handles the BeforeTimebarLink event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarMoveHandler | Represents the method that handles the BeforeTimebarMove event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarRemoveHandler | Represents the method that handles the BeforeTimebarRemove event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarSelectHandler | Represents the method that handles the BeforeTimebarSelect event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarSizeHandler | Represents the method that handles the BeforeTimebarSize event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarSplitHandler | Represents the method that handles the BeforeTimeBarSplit event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarUnlinkHandler | Represents the method that handles the BeforeTimebarUnlink event in dbiSchedule.
dbiSchedule.EventBeforeTimeBarUnSelectHandler | Represents the method that handles the BeforeTimeBarUnSelect Event
dbiSchedule.EventBeforeToolTipsHandler | Represents the method that handles the BeforeToolTips event in dbiSchedule.
dbiSchedule.EventControlErrorHandler | Represents the method that handles the ControError event in dbiSchedule.
dbiSchedule.EventDeadZoneDropHandler | Represents the method that handles the DeadZoneDrop Event.
dbiSchedule.EventEditModeChangedHandler | Represents the method that handles the EditModeChanged Event.
dbiSchedule.EventFirstDrawHandler | Represents the method that handles the FirstDraw event in dbiSchedule.
dbiSchedule.EventGuideLineClickHandler | Represents the method that handles the GuideLineClick Event
dbiSchedule.EventGuideLineInDeadZoneHandler | Represents the method that handles the GuideLineInDeadZone Event
dbiSchedule.EventGuideLineMoveHandler | Represents the method that handles the GuideLineMove Event
dbiSchedule.EventHistoryChangeHandler | Represents the method that handles the HistoryChange event in dbiSchedule.
dbiSchedule.EventItemMouseOverHandler | Represents the method that handles the ItemMouseOver event in dbiSchedule.
dbiSchedule.EventLineArrowClickHandler | Represents the method that handles the LineArrowClick Event in dbiSchedule.
dbiSchedule.EventLineArrowDoubleClickHandler | Represents the method that handles the LineArrowDoubleClick Event in dbiSchedule.
dbiSchedule.EventLineArrowMouseOverHandler | Represents the method that handles the LineArrowMouseOver Event in dbiSchedule.
dbiSchedule.EventListClickHandler | Represents the method that handles the ListClick event in dbiSchedule.
dbiSchedule.EventListDoubleClickHandler | Represents the method that handles the ListDoubleClick event in dbiSchedule.
dbiSchedule.EventListDropHandler | Represents the method that handles the ListDrop event in dbiSchedule.
dbiSchedule.EventMouseWheelCheckHandler | Represents the method that handles the MouseWheelCheck Event
dbiSchedule.EventNoteClickHandler | Represents the method that handles the NoteClick Event in dbiSchedule.
dbiSchedule.EventNoteDoubleClickHandler | Represents the method that handles the NoteDoubleClick Event in dbiSchedule.
dbiSchedule.EventRedoActionHandler | Represents the method that handles the RedoAction event in dbiSchedule.
dbiSchedule.EventRulerDragHandler | Represents the method that handles the RulerDrag Event
dbiSchedule.EventScheduleClickHandler | Represents the method that handles the ScheduleClick Event
dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler | Represents the method that handles the ScheduleScrollBarsOffsetArea Event
dbiSchedule.EventScrollBufferResizeHandler | Represents the method that handles the ScrollBufferResize event in dbiSchedule.
dbiSchedule.EventScrollTrackHandler | Represents the method that handles the ScrollTrack event in dbiSchedule.
dbiSchedule.EventTimeBarClickHandler | Represents the method that handles the TimebarClick event in dbiSchedule.
dbiSchedule.EventTimeBarDateTextHandler | Represents the method that handles the TimeBarDateText Event
dbiSchedule.EventTimeBarDoubleClickHandler | Represents the method that handles the TimebarDoubleClick event in dbiSchedule.
dbiSchedule.EventTimeBarMouseEnterHandler | Represents the method that handles the TimeBarMouseEnter event in dbiSchedule.
dbiSchedule.EventTimeBarMouseLeaveHandler | Represents the method that handles the TimeBarMouseLeave event in dbiSchedule.
dbiSchedule.EventTimeBarMovingHandler | Represents the method that handles the TimeBarMoving Event
dbiSchedule.EventTimeBarSizingHandler | Represents the method that handles the TimebarSizing event in dbiSchedule.
dbiSchedule.EventUndoActionHandler | Represents the method that handles the UndoAction event in dbiSchedule.
dbiSchedule.EventUserDrawnBarAfterHandler | Represents the method that handles the UserDrawnBarAfter Event.
dbiSchedule.EventUserDrawnBarHandler | Represents the method that handles the UserDrawnBar event in dbiSchedule.
dbiSchedule.EventUserDrawnCustomAreaHandler | Represents the method that handles the UserDrawnCustomArea Event
dbiSchedule.EventUserDrawnFooterHandler | Represents the method that handles the UserDrawnFooter event in dbiSchedule.
dbiSchedule.EventUserDrawnHeaderHandler | Represents the method that handles the UserDrawnHeader event in dbiSchedule.
dbiSchedule.EventUserDrawnLineHandler | Represents the method that handles the UserDrawnLine event in dbiSchedule.
dbiSchedule.EventUserDrawnLinkLineHandler | Represents the method that handles the UserDrawnLinkLine Event
dbiSchedule.EventUserDrawnListScrollAreaHandler | Represents the method that handles the UserDrawnListScrollArea Event
dbiSchedule.EventUserDrawnRulerHandler | Represents the method that handles the UserDrawnRuler Event
dbiSchedule.EventUserDrawnRulerSegmentHandler | Represents the method that handles the UserDrawnRulerSegment Event
dbiSchedule.EventUserDrawnRulerTitleHandler | Represents the method that handles the UserDrawnRulerTitle Event
dbiSchedule.EventUserDrawnTimeBarsHandler | Represents the method that handles the UserDrawnTimeBars Event
dbiSchedule.EventUserDrawnWaterMarkHandler | Represents the method that handles the UserDrawnWaterMark Event
dbiSchedule.EventValuePointHandler | Represents the method that handles the ValuePoint event in dbiSchedule.

Enumerations

Enumeration | Description
dbiHistoryItem.enumActionType | Specifies the type of Undo/Redo action added to the HistoryCollection.
dbiLinkItem.enumLinkDirection | Specifies the direction of a link.
dbiLinkItem.enumLinkType | Specifies the type of link to display.
dbiScheduleObject.enumFirstDayOfWeek | Specifies the first day of the week in the ruler.
dbiScheduleObject.enumImageEffect | Specifies how the background image in the schedule is displayed.
dbiScheduleObject.enumMonthFormat | Specifies how the monthly ruler is displayed.
dbiScheduleObject.enumRulerAlign | Specifies the alignment of the ruler text in a schedule.
dbiScheduleObject.enumTimeLineWidth | Specifies how the time lines will be drawn.
dbiScheduleObject.enumWeekFormat | Determines how the first week of the year is identified.
dbiScheduleObject.enumYearFormat | Specifies how the yearly ruler is displayed.
dbiTimeBarItem.enumTextAlign | Specifies the position of the primary text of a Timebar.
dbiTimeBarStyle.enumImageOrder | Specifies where the start and end images will be placed.
enumAlignment | Specifies the vertical and horizontal alignments.
enumControlStyle | The style of dbiSchedule.
enumCurrentTimePosition | The position of the CurrentTimeLine relative to the timebars.
enumEditMode | Specifies the type of action to perform on a Timebar.
enumGuideImagePosition | Specifies the ZOrder of the Guide Image in relation to the ruler text.
enumGuideLinePosition | Specifies the ZOrder of the GuideLine in relation to the TimeBars in the Schedule.
enumImageIntoView | Specifies which image on a timebar will be kept in view..
enumImageType | Specifies what type of image to create with the CreateImage method.
enumLineArrowDirection | Specifies which direction on the schedule, the LineArrow is pointing.
enumLineArrowDisplay | Specifies if a TimeBar must exist inside the Schedule's start and end values or not, when determining to show the LineArrows.
enumLineArrowPosition | Specifies how the LineArrow is shown inside the Schedule, in relation to the other objects.
enumListScrollViewType | Specifies the display behavior of the scroll bar in the list area.
enumNotesPosition | Specifies how the Notes are shown inside the Schedule, in relation to the other objects.
enumPrintListFormat | Determines how the list items are printed.
enumPrintReportType | Specifies how dbiSchedule will be printed.
enumScheduleItem | Specifies where the current point is in the dbiSchedule.
enumScrollBarType | Specifies the type of scroll bar
enumSetViewReturnCodes | Specifies the available return codes of the SetView Method
enumSnapToDivisions | Specifies how the mouse will snap to the divisions in the schedule.
enumTimeType | Specifies the type of unit to display in the rules.
enumTipsType | Specifies the type of tool tip to display.
enumXMLExportType | Specifies how the XML export will perform.

See Also

Reference

dbiScheduleE Assembly


%%PageItemTitle%%

AfterGuideLineInsertedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineInsertedEventArgs Class

Provides data for the AfterGuideLineInserted Event.

Object Model

AfterGuideLineInsertedEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
C#
public class AfterGuideLineInsertedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterGuideLineInsertedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineInsertedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineInsertedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineInsertedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineInsertedEventArgs Constructor | Initializes a new instance of the AfterGuideLineInsertedEventArgs Class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was inserted.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was inserted into.
Top

See Also

Reference

AfterGuideLineInsertedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterGuideLineInsertedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineInsertedEventArgs Class : AfterGuideLineInsertedEventArgs Constructor

Initializes a new instance of the AfterGuideLineInsertedEventArgs Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineInsertedEventArgs()
C#
public AfterGuideLineInsertedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineInsertedEventArgs Class : GuideLine Property

The dbiGuideLine that was inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineInsertedEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineInsertedEventArgs Class : LineTime Property

The date/time value for the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Property Value

Date

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineInsertedEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine was inserted into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineInsertedEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineInsertedEventArgs Class
AfterGuideLineInsertedEventArgs Members


%%PageItemTitle%%

AfterGuideLineMovedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineMovedEventArgs Class

Provides data for the AfterGuideLineMoved Event.

Object Model

AfterGuideLineMovedEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
C#
public class AfterGuideLineMovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterGuideLineMovedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineMovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineMovedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineMovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineMovedEventArgs Constructor | Initializes a new instance of the AfterGuideLineMovedEventArgs Class
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was moved.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was moved into.
Top

See Also

Reference

AfterGuideLineMovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterGuideLineMovedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineMovedEventArgs Class : AfterGuideLineMovedEventArgs Constructor

Initializes a new instance of the AfterGuideLineMovedEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineMovedEventArgs()
C#
public AfterGuideLineMovedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineMovedEventArgs Class : GuideLine Property

The dbiGuideLine that was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineMovedEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineMovedEventArgs Class : LineTime Property

The date/time value for the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Property Value

Date

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineMovedEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine was moved into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineMovedEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineMovedEventArgs Class
AfterGuideLineMovedEventArgs Members


%%PageItemTitle%%

AfterGuideLineRemovedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineRemovedEventArgs Class

Provides data for the AfterGuideLineRemoved Event.

Object Model

AfterGuideLineRemovedEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
C#
public class AfterGuideLineRemovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterGuideLineRemovedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineRemovedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterGuideLineRemovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineRemovedEventArgs Class

"

The following tables list the members exposed by AfterGuideLineRemovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterGuideLineRemovedEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was removed.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was removed from.
Top

See Also

Reference

AfterGuideLineRemovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterGuideLineRemovedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineRemovedEventArgs Class : AfterGuideLineRemovedEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterGuideLineRemovedEventArgs()
C#
public AfterGuideLineRemovedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineRemovedEventArgs Class : GuideLine Property

The dbiGuideLine that was removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineRemovedEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterGuideLineRemovedEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine was removed from.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterGuideLineRemovedEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterGuideLineRemovedEventArgs Class
AfterGuideLineRemovedEventArgs Members


%%PageItemTitle%%

AfterTimeBarDropEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarDropEventArgs Class

Provides data for the AfterTimebarDrop event.

Object Model

AfterTimeBarDropEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarDropEventArgs
C#
public class AfterTimeBarDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarDropEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarDropEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarDropEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarDropEventArgs Class

"

The following tables list the members exposed by AfterTimeBarDropEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarDropEventArgs Constructor | Initializes a new instance of the AfterTimebarDropEventArgs class.
Top

Public Properties

 | Name | Description
public Property | drgevent | Gets or sets the drag and drop information after a Timebar has been dropped.
public Property | ScheduleItem | The dbiScheduleItem the timebar has been added to.
public Property | TimeBarItem | The dbiTimeBar that was modified in the BeforeTimeBarDrop event.
Top

See Also

Reference

AfterTimeBarDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarDropEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarDropEventArgs Class : AfterTimeBarDropEventArgs Constructor

Initializes a new instance of the AfterTimebarDropEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarDropEventArgs()
C#
public AfterTimeBarDropEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarDropEventArgs Class
AfterTimeBarDropEventArgs Members


%%PageItemTitle%%

drgevent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarDropEventArgs Class : drgevent Property

Gets or sets the drag and drop information after a Timebar has been dropped.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarDropEventArgs
Dim value As System.Windows.Forms.DragEventArgs

instance.drgevent = value

value = instance.drgevent
C#
public System.Windows.Forms.DragEventArgs drgevent {get; set;}

Remarks

The drgevent property specifies any data associated with this event; the current state of the SHIFT, CTRL, and ALT keys; the location of the mouse pointer; and the drag-and-drop effects allowed by the source and target of the drag event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarDropEventArgs Class
AfterTimeBarDropEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarDropEventArgs Class : ScheduleItem Property

The dbiScheduleItem the timebar has been added to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarDropEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarDropEventArgs Class
AfterTimeBarDropEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarDropEventArgs Class : TimeBarItem Property

The dbiTimeBar that was modified in the BeforeTimeBarDrop event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarDropEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarDropEventArgs Class
AfterTimeBarDropEventArgs Members


%%PageItemTitle%%

AfterTimeBarInsertedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarInsertedEventArgs Class

Provides data for the AfterTimebarInserted event.

Object Model

AfterTimeBarInsertedEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
C#
public class AfterTimeBarInsertedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarInsertedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarInsertedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarInsertedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarInsertedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarInsertedEventArgs Constructor | Initializes a new instance of the AfterTimebarInsertedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the inserted Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar after it was inserted.
public Property | TimeBarItem | The dbiTimebarItem after it has been inserted.
public Property | WasDropped | Indicates if the inserted TimeBar came from a Drag and Drop operation.
Top

See Also

Reference

AfterTimeBarInsertedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarInsertedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarInsertedEventArgs Class : AfterTimeBarInsertedEventArgs Constructor

Initializes a new instance of the AfterTimebarInsertedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarInsertedEventArgs()
C#
public AfterTimeBarInsertedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarInsertedEventArgs Class : BarIndex Property

The zero-based index value of the inserted Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the inserted Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarInsertedEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar after it was inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar after it was inserted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarInsertedEventArgs Class : TimeBarItem Property

The dbiTimebarItem after it has been inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem after it has been inserted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

WasDropped Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarInsertedEventArgs Class : WasDropped Property

Indicates if the inserted TimeBar came from a Drag and Drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarInsertedEventArgs
Dim value As System.Boolean

instance.WasDropped = value

value = instance.WasDropped
C#
public System.bool WasDropped {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarInsertedEventArgs Class
AfterTimeBarInsertedEventArgs Members


%%PageItemTitle%%

AfterTimeBarLinkedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarLinkedEventArgs Class

Provides data for the AfterTimebarLinked event.

Object Model

AfterTimeBarLinkedEventArgs ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarLinkedEventArgs
C#
public class AfterTimeBarLinkedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarLinkedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarLinkedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarLinkedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarLinkedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarLinkedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarLinkedEventArgs Constructor | Initializes a new instance of the AfterTimebarLinkedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem after it is applied between two Timebars.
Top

See Also

Reference

AfterTimeBarLinkedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarLinkedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarLinkedEventArgs Class : AfterTimeBarLinkedEventArgs Constructor

Initializes a new instance of the AfterTimebarLinkedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarLinkedEventArgs()
C#
public AfterTimeBarLinkedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarLinkedEventArgs Class
AfterTimeBarLinkedEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarLinkedEventArgs Class : Link Property

The dbiLinkItem after it is applied between two Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarLinkedEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Property Value

The dbiLinkItem after it is applied between two Timebars.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarLinkedEventArgs Class
AfterTimeBarLinkedEventArgs Members


%%PageItemTitle%%

AfterTimeBarMovedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarMovedEventArgs Class

Provides data for the AfterTimebarMoved event.

Object Model

AfterTimeBarMovedEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
C#
public class AfterTimeBarMovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarMovedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarMovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarMovedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarMovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarMovedEventArgs Constructor | Initializes a new instance of the AfterTimebarMovedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it was moved.
public Property | ScheduleItemTo | The dbiScheduleItem containing the Timebar after it has been moved.
public Property | TimeBarItem | The dbiTimebarItem after it has been moved.
public Property | Vertical | Determines if the Timebar was moved vertically.
Top

See Also

Reference

AfterTimeBarMovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarMovedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarMovedEventArgs Class : AfterTimeBarMovedEventArgs Constructor

Initializes a new instance of the AfterTimebarMovedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarMovedEventArgs()
C#
public AfterTimeBarMovedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

ScheduleItemFrom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarMovedEventArgs Class : ScheduleItemFrom Property

The dbiScheduleItem containing the Timebar before it was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemFrom = value

value = instance.ScheduleItemFrom
C#
public dbiScheduleItem ScheduleItemFrom {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it was moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

ScheduleItemTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarMovedEventArgs Class : ScheduleItemTo Property

The dbiScheduleItem containing the Timebar after it has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemTo = value

value = instance.ScheduleItemTo
C#
public dbiScheduleItem ScheduleItemTo {get; set;}

Property Value

The dbiScheduleItem containing the Timebar after it has been moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarMovedEventArgs Class : TimeBarItem Property

The dbiTimebarItem after it has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem after it has been moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

Vertical Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarMovedEventArgs Class : Vertical Property

Determines if the Timebar was moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarMovedEventArgs
Dim value As System.Boolean

instance.Vertical = value

value = instance.Vertical
C#
public System.bool Vertical {get; set;}

Property Value

A Boolean value indicating if the Timebar was moved vertically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarMovedEventArgs Class
AfterTimeBarMovedEventArgs Members


%%PageItemTitle%%

AfterTimeBarRemovedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarRemovedEventArgs Class

Provides data for the AfterTimebarRemoved event.

Object Model

AfterTimeBarRemovedEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
C#
public class AfterTimeBarRemovedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarRemovedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarRemovedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarRemovedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarRemovedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarRemovedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarRemovedEventArgs Constructor | Initializes a new instance of the AfterTimebarRemovedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it was removed.
Top

See Also

Reference

AfterTimeBarRemovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarRemovedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarRemovedEventArgs Class : AfterTimeBarRemovedEventArgs Constructor

Initializes a new instance of the AfterTimebarRemovedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarRemovedEventArgs()
C#
public AfterTimeBarRemovedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarRemovedEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarRemovedEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar before it was removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarRemovedEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it was removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarRemovedEventArgs Class
AfterTimeBarRemovedEventArgs Members


%%PageItemTitle%%

AfterTimeBarSelectEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSelectEventArgs Class

Provides data for the AfterTimeBarSelect Event

Object Model

AfterTimeBarSelectEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSelectEventArgs
C#
public class AfterTimeBarSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSelectEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarSelectEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSelectEventArgs Class

"

The following tables list the members exposed by AfterTimeBarSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarSelectEventArgs Constructor | Initializes a new instance of the class
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem that was selected.
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was selected.
public Property | TimeBarItem | The dbiTimeBarItem that was selected.
Top

See Also

Reference

AfterTimeBarSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarSelectEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSelectEventArgs Class : AfterTimeBarSelectEventArgs Constructor

Initializes a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarSelectEventArgs()
C#
public AfterTimeBarSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSelectEventArgs Class
AfterTimeBarSelectEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSelectEventArgs Class : BarIndex Property

The zero-based index value of the dbiTimeBarItem that was selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSelectEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSelectEventArgs Class
AfterTimeBarSelectEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSelectEventArgs Class : ScheduleItem Property

The dbiScheduleItem that contains the dbiTimeBarItem that was selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSelectEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSelectEventArgs Class
AfterTimeBarSelectEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSelectEventArgs Class : TimeBarItem Property

The dbiTimeBarItem that was selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSelectEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSelectEventArgs Class
AfterTimeBarSelectEventArgs Members


%%PageItemTitle%%

AfterTimeBarSizedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSizedEventArgs Class

Provides data for the AfterTimebarSized event.

Object Model

AfterTimeBarSizedEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
C#
public class AfterTimeBarSizedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarSizedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSizedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarSizedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSizedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarSizedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarSizedEventArgs Constructor | Initializes a new instance of the AfterTimebarSizedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar after it has been sized.
public Property | TimeBarItem | The dbiTimebarItem after it has been sized.
Top

See Also

Reference

AfterTimeBarSizedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarSizedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSizedEventArgs Class : AfterTimeBarSizedEventArgs Constructor

Initializes a new instance of the AfterTimebarSizedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarSizedEventArgs()
C#
public AfterTimeBarSizedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSizedEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSizedEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar after it has been sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar after it has been sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSizedEventArgs Class : TimeBarItem Property

The dbiTimebarItem after it has been sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSizedEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem after it has been sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSizedEventArgs Class
AfterTimeBarSizedEventArgs Members


%%PageItemTitle%%

AfterTimeBarSplitEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSplitEventArgs Class

Provides data for the AfterTimebarSplit event.

Object Model

AfterTimeBarSplitEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
C#
public class AfterTimeBarSplitEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarSplitEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSplitEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarSplitEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSplitEventArgs Class

"

The following tables list the members exposed by AfterTimeBarSplitEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarSplitEventArgs Constructor | Initializes a new instance of the AfterTimebarSplitEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ScheduleItem | The dbiScheduleItem containing the Timebars after they have been split.
public Property | TimeBarNew | The newly created dbiTimebarItem.
public Property | TimeBarOld | The original dbiTimebarItem.
Top

See Also

Reference

AfterTimeBarSplitEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarSplitEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSplitEventArgs Class : AfterTimeBarSplitEventArgs Constructor

Initializes a new instance of the AfterTimebarSplitEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarSplitEventArgs()
C#
public AfterTimeBarSplitEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSplitEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebars after they have been split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarNew Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSplitEventArgs Class : TimeBarNew Property

The newly created dbiTimebarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarNew = value

value = instance.TimeBarNew
C#
public dbiTimeBarItem TimeBarNew {get; set;}

Property Value

dbiTimebarItem

Remarks

This Timebar is created as a new Timebar

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarOld Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarSplitEventArgs Class : TimeBarOld Property

The original dbiTimebarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarOld = value

value = instance.TimeBarOld
C#
public dbiTimeBarItem TimeBarOld {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarSplitEventArgs Class
AfterTimeBarSplitEventArgs Members


%%PageItemTitle%%

AfterTimeBarUnlinkedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnlinkedEventArgs Class

Provides data for the AfterTimebarUnlinked event.

Object Model

AfterTimeBarUnlinkedEventArgs ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnlinkedEventArgs
C#
public class AfterTimeBarUnlinkedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarUnlinkedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnlinkedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarUnlinkedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnlinkedEventArgs Class

"

The following tables list the members exposed by AfterTimeBarUnlinkedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarUnlinkedEventArgs Constructor | Initializes a new instance of the AfterTimebarUnlinkedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem which was removed between two Timebars.
Top

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarUnlinkedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnlinkedEventArgs Class : AfterTimeBarUnlinkedEventArgs Constructor

Initializes a new instance of the AfterTimebarUnlinkedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarUnlinkedEventArgs()
C#
public AfterTimeBarUnlinkedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
AfterTimeBarUnlinkedEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnlinkedEventArgs Class : Link Property

The dbiLinkItem which was removed between two Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnlinkedEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Property Value

The dbiLinkItem which was removed between two Timebars.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
AfterTimeBarUnlinkedEventArgs Members


%%PageItemTitle%%

AfterTimeBarUnSelectEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnSelectEventArgs Class

Provides data for the AfterTimeBarUnSelect Event

Object Model

AfterTimeBarUnSelectEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnSelectEventArgs
C#
public class AfterTimeBarUnSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AfterTimeBarUnSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnSelectEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AfterTimeBarUnSelectEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnSelectEventArgs Class

"

The following tables list the members exposed by AfterTimeBarUnSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AfterTimeBarUnSelectEventArgs Constructor | Initializes a new instance of the class
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem that was unselected.
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was unselected.
public Property | TimeBarItem | The dbiTimeBarItem that was unselected
Top

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AfterTimeBarUnSelectEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnSelectEventArgs Class : AfterTimeBarUnSelectEventArgs Constructor

Initializes a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AfterTimeBarUnSelectEventArgs()
C#
public AfterTimeBarUnSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
AfterTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnSelectEventArgs Class : BarIndex Property

The zero-based index value of the dbiTimeBarItem that was unselected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnSelectEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
AfterTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnSelectEventArgs Class : ScheduleItem Property

The dbiScheduleItem that contains the dbiTimeBarItem that was unselected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnSelectEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
AfterTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AfterTimeBarUnSelectEventArgs Class : TimeBarItem Property

The dbiTimeBarItem that was unselected

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AfterTimeBarUnSelectEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
AfterTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

AlarmTimeBarEndEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarEndEventArgs Class

Provides data for the AlarmTimebarEnd event.

Object Model

AlarmTimeBarEndEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarEndEventArgs
C#
public class AlarmTimeBarEndEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AlarmTimeBarEndEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarEndEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AlarmTimeBarEndEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarEndEventArgs Class

"

The following tables list the members exposed by AlarmTimeBarEndEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AlarmTimeBarEndEventArgs Constructor | Initializes a new instance of the AlarmTimebarEndEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
public Property | TimeBarItem | The dbiTimebarItem whose alarm has fired.
Top

See Also

Reference

AlarmTimeBarEndEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AlarmTimeBarEndEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarEndEventArgs Class : AlarmTimeBarEndEventArgs Constructor

Initializes a new instance of the AlarmTimebarEndEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AlarmTimeBarEndEventArgs()
C#
public AlarmTimeBarEndEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarEndEventArgs Class
AlarmTimeBarEndEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarEndEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarEndEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarEndEventArgs Class
AlarmTimeBarEndEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarEndEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar whose alarm fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarEndEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar whose alarm fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarEndEventArgs Class
AlarmTimeBarEndEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarEndEventArgs Class : TimeBarItem Property

The dbiTimebarItem whose alarm has fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarEndEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem whose alarm has fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarEndEventArgs Class
AlarmTimeBarEndEventArgs Members


%%PageItemTitle%%

AlarmTimeBarStartEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarStartEventArgs Class

Provides data for the AlarmTimebarStart event.

Object Model

AlarmTimeBarStartEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarStartEventArgs
C#
public class AlarmTimeBarStartEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.AlarmTimeBarStartEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarStartEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

AlarmTimeBarStartEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarStartEventArgs Class

"

The following tables list the members exposed by AlarmTimeBarStartEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | AlarmTimeBarStartEventArgs Constructor | Initializes a new instance of the AlarmTimebarStartEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
public Property | TimeBarItem | The dbiTimebarItem whose alarm has fired.
Top

See Also

Reference

AlarmTimeBarStartEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

AlarmTimeBarStartEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarStartEventArgs Class : AlarmTimeBarStartEventArgs Constructor

Initializes a new instance of the AlarmTimebarStartEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New AlarmTimeBarStartEventArgs()
C#
public AlarmTimeBarStartEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarStartEventArgs Class
AlarmTimeBarStartEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarStartEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarStartEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarStartEventArgs Class
AlarmTimeBarStartEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarStartEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar whose alarm fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarStartEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar whose alarm fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarStartEventArgs Class
AlarmTimeBarStartEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > AlarmTimeBarStartEventArgs Class : TimeBarItem Property

The dbiTimebarItem whose alarm has fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As AlarmTimeBarStartEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem whose alarm has fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmTimeBarStartEventArgs Class
AlarmTimeBarStartEventArgs Members


%%PageItemTitle%%

BeforeGuideLineInsertEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineInsertEventArgs Class

Provides data for the BeforeGuideLineInsert Event.

Object Model

BeforeGuideLineInsertEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
C#
public class BeforeGuideLineInsertEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeGuideLineInsertEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineInsertEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineInsertEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineInsertEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineInsertEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the GuideLine can be added.
public Property | GuideLine | The dbiGuideLine that is being inserted.
public Property | InDeadZone | Determines if the new GuideLine intersects with a dbiCustomArea flagged as a DeadZone.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being inserted into.
Top

See Also

Reference

BeforeGuideLineInsertEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeGuideLineInsertEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : BeforeGuideLineInsertEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineInsertEventArgs()
C#
public BeforeGuideLineInsertEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

AllowInsert Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : AllowInsert Property

Determines if the GuideLine can be added.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As System.Boolean

instance.AllowInsert = value

value = instance.AllowInsert
C#
public System.bool AllowInsert {get; set;}

Property Value

Boolean

Example

Visual Basic Copy Code
Private Sub DbiSchedule1_BeforeGuideLineInsert(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.BeforeGuideLineInsertEventArgs) Handles DbiSchedule1.BeforeGuideLineInsert
        'Block GuideLines outside of 9am to 5pm
        If e.LineTime.Hour < 9 Or e.LineTime.Hour > 17 Then
            e.AllowInsert = False
        End If
    End Sub
C# Copy Code
private void dbiSchedule1_BeforeGuideLineInsert(object sender, Dbi.WinControl.Schedule.BeforeGuideLineInsertEventArgs e)
        {
            if (e.LineTime.Hour < 9 || e.LineTime.Hour > 17)
            {
                e.AllowInsert = false;
            }
        }

Remarks

Setting this value to False will effectively cancel the inserting of the guideline. This is particularly useful for applying business rules to the insertion.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : GuideLine Property

The dbiGuideLine that is being inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

InDeadZone Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : InDeadZone Property

Determines if the new GuideLine intersects with a dbiCustomArea flagged as a DeadZone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As System.Boolean

instance.InDeadZone = value

value = instance.InDeadZone
C#
public System.bool InDeadZone {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : LineTime Property

The date/time value for the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Property Value

Date

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineInsertEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine is being inserted into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineInsertEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineInsertEventArgs Class
BeforeGuideLineInsertEventArgs Members


%%PageItemTitle%%

BeforeGuideLineMoveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineMoveEventArgs Class

Provides data for the BeforeGuideLineMove Event.

Object Model

BeforeGuideLineMoveEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
C#
public class BeforeGuideLineMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeGuideLineMoveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineMoveEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineMoveEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the GuideLine can be moved.
public Property | GuideLine | The dbiGuideLine that is being moved.
public Property | InDeadZone | Indicates if the dbiGuideLine is moving into a dead zone. You can then set the AllowMove accordingly.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | OldLineTime | The old date/time value for the GuideLine
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being moved into.
Top

See Also

Reference

BeforeGuideLineMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeGuideLineMoveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : BeforeGuideLineMoveEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineMoveEventArgs()
C#
public BeforeGuideLineMoveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

AllowMove Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : AllowMove Property

Determines if the GuideLine can be moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As System.Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public System.bool AllowMove {get; set;}

Property Value

Boolean

Example

Visual Basic Copy Code
Private Sub DbiSchedule1_BeforeGuideLineMove(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.BeforeGuideLineMoveEventArgs) Handles DbiSchedule1.BeforeGuideLineMove
        'Block GuideLines moving outside of 9am to 5pm
        If e.LineTime.Hour < 9 Or e.LineTime.Hour > 17 Then
            e.AllowMove = False
        End If
    End Sub
C# Copy Code
private void dbiSchedule1_BeforeGuideLineMove(object sender, Dbi.WinControl.Schedule.BeforeGuideLineMoveEventArgs e)
        {
            if (e.LineTime.Hour < 9 || e.LineTime.Hour > 17)
            {
                e.AllowMove = false;
            }
        }

Remarks

Setting this value to False will effectively cancel the moving of the guideline. This is particularly useful for applying business rules to the move.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : GuideLine Property

The dbiGuideLine that is being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

InDeadZone Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : InDeadZone Property

Indicates if the dbiGuideLine is moving into a dead zone. You can then set the AllowMove accordingly.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As System.Boolean

instance.InDeadZone = value

value = instance.InDeadZone
C#
public System.bool InDeadZone {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : LineTime Property

The date/time value for the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Property Value

Date

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

OldLineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : OldLineTime Property

The old date/time value for the GuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As System.Date

instance.OldLineTime = value

value = instance.OldLineTime
C#
public System.DateTime OldLineTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineMoveEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine is being moved into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineMoveEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

When using *Enterprise* the GuideLine cannot be moved between Schedule Objects, it can only be moved inside the originating dbiScheduleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineMoveEventArgs Class
BeforeGuideLineMoveEventArgs Members


%%PageItemTitle%%

BeforeGuideLineRemoveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineRemoveEventArgs Class

Provides data for the BeforeGuideLineRemove Event .

Object Model

BeforeGuideLineRemoveEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
C#
public class BeforeGuideLineRemoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeGuideLineRemoveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeGuideLineRemoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineRemoveEventArgs Class

"

The following tables list the members exposed by BeforeGuideLineRemoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeGuideLineRemoveEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the GuideLine can be removed.
public Property | GuideLine | The dbiGuideLine that is being removed.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The original time of the guideline. Setting AllowRemoval Property = False and modifying this property will place the guideline at this value.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being removed from.
Top

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeGuideLineRemoveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : BeforeGuideLineRemoveEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeGuideLineRemoveEventArgs()
C#
public BeforeGuideLineRemoveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

AllowRemoval Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : AllowRemoval Property

Determines if the GuideLine can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As System.Boolean

instance.AllowRemoval = value

value = instance.AllowRemoval
C#
public System.bool AllowRemoval {get; set;}

Property Value

Boolean

Example

Visual Basic Copy Code
Private Sub DbiSchedule1_BeforeGuideLineRemove(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.BeforeGuideLineRemoveEventArgs) Handles DbiSchedule1.BeforeGuideLineRemove
        If UserLevel < 5 Then
            e.AllowRemoval = False
        End If
    End Sub
C# Copy Code
private void dbiSchedule1_BeforeGuideLineRemove(object sender, Dbi.WinControl.Schedule.BeforeGuideLineRemoveEventArgs e)
        {
            if (UserLevel < 5)
            {
                e.AllowRemoval = false;
            }
        }

Remarks

Setting this value to False will effectively cancel the removal of the guideline. This is particularly useful for applying business rules to the removal.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : GuideLine Property

The dbiGuideLine that is being removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : LineTime Property

The original time of the guideline. Setting AllowRemoval Property = False and modifying this property will place the guideline at this value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Property Value

Date

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeGuideLineRemoveEventArgs Class : ScheduleObject Property

The dbiScheduleObject the GuideLine is being removed from.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeGuideLineRemoveEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
BeforeGuideLineRemoveEventArgs Members


%%PageItemTitle%%

BeforePrintPageNumberEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforePrintPageNumberEventArgs Class

Provides data for the BeforePrintPageNumber Event

Object Model

BeforePrintPageNumberEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintPageNumberEventArgs
C#
public class BeforePrintPageNumberEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforePrintPageNumberEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePrintPageNumberEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforePrintPageNumberEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforePrintPageNumberEventArgs Class

"

The following tables list the members exposed by BeforePrintPageNumberEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforePrintPageNumberEventArgs Constructor | Initializes a new instance of the class
Top

Public Properties

 | Name | Description
public Property | CurrentPage | The number of the page to be printed.
public Property | Text | Gets/sets the text printed on the page to display the current/max page number.
public Property | TotalPages | The total number of pages to be printed.
Top

See Also

Reference

BeforePrintPageNumberEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforePrintPageNumberEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforePrintPageNumberEventArgs Class : BeforePrintPageNumberEventArgs Constructor

Initializes a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforePrintPageNumberEventArgs()
C#
public BeforePrintPageNumberEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePrintPageNumberEventArgs Class
BeforePrintPageNumberEventArgs Members


%%PageItemTitle%%

CurrentPage Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforePrintPageNumberEventArgs Class : CurrentPage Property

The number of the page to be printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintPageNumberEventArgs
Dim value As System.Integer

instance.CurrentPage = value

value = instance.CurrentPage
C#
public System.int CurrentPage {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePrintPageNumberEventArgs Class
BeforePrintPageNumberEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforePrintPageNumberEventArgs Class : Text Property

Gets/sets the text printed on the page to display the current/max page number.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintPageNumberEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

string

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePrintPageNumberEventArgs Class
BeforePrintPageNumberEventArgs Members


%%PageItemTitle%%

TotalPages Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforePrintPageNumberEventArgs Class : TotalPages Property

The total number of pages to be printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforePrintPageNumberEventArgs
Dim value As System.Integer

instance.TotalPages = value

value = instance.TotalPages
C#
public System.int TotalPages {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforePrintPageNumberEventArgs Class
BeforePrintPageNumberEventArgs Members


%%PageItemTitle%%

BeforeTimeBarDropEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarDropEventArgs Class

Provides data for the BeforeTimebarDrop event.

Object Model

BeforeTimeBarDropEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarDropEventArgs
C#
public class BeforeTimeBarDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarDropEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarDropEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarDropEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarDropEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarDropEventArgs Constructor | Initializes a new instance of the BeforeTimebarDropEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowDrop | Determines if the Timebar can be dropped.
public Property | drgevent | Gets or sets the drag and drop information before a Timebar has been dropped.
public Property | ScheduleItem | The dbiScheduleItem the drop occurred on.
public Property | TimeBarItem | The dbiTimebarItem before it is dropped.
Top

See Also

Reference

BeforeTimeBarDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarDropEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarDropEventArgs Class : BeforeTimeBarDropEventArgs Constructor

Initializes a new instance of the BeforeTimebarDropEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarDropEventArgs()
C#
public BeforeTimeBarDropEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Class
BeforeTimeBarDropEventArgs Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarDropEventArgs Class : AllowDrop Property

Determines if the Timebar can be dropped.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarDropEventArgs
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public System.bool AllowDrop {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Class
BeforeTimeBarDropEventArgs Members


%%PageItemTitle%%

drgevent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarDropEventArgs Class : drgevent Property

Gets or sets the drag and drop information before a Timebar has been dropped.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarDropEventArgs
Dim value As System.Windows.Forms.DragEventArgs

instance.drgevent = value

value = instance.drgevent
C#
public System.Windows.Forms.DragEventArgs drgevent {get; set;}

Remarks

The drgevent property specifies any data associated with this event; the current state of the SHIFT, CTRL, and ALT keys; the location of the mouse pointer; and the drag-and-drop effects allowed by the source and target of the drag event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Class
BeforeTimeBarDropEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarDropEventArgs Class : ScheduleItem Property

The dbiScheduleItem the drop occurred on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarDropEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Class
BeforeTimeBarDropEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarDropEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is dropped.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarDropEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem which is to be dropped.

Remarks

The timebar information can be set here programmatically then ensure you set the e.AllowDrop=true

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarDropEventArgs Class
BeforeTimeBarDropEventArgs Members


%%PageItemTitle%%

BeforeTimeBarInsertEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarInsertEventArgs Class

Provides data for the BeforeTimebarInsert event.

Object Model

BeforeTimeBarInsertEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
C#
public class BeforeTimeBarInsertEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarInsertEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarInsertEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarInsertEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarInsertEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarInsertEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarInsertEventArgs Constructor | Initializes a new instance of the BeforeTimebarInsertEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the Timebar can be inserted.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is inserted.
public Property | TimeBarItem | The dbiTimebarItem before it is inserted.
Top

See Also

Reference

BeforeTimeBarInsertEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarInsertEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarInsertEventArgs Class : BeforeTimeBarInsertEventArgs Constructor

Initializes a new instance of the BeforeTimebarInsertEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarInsertEventArgs()
C#
public BeforeTimeBarInsertEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

AllowInsert Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarInsertEventArgs Class : AllowInsert Property

Determines if the Timebar can be inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As System.Boolean

instance.AllowInsert = value

value = instance.AllowInsert
C#
public System.bool AllowInsert {get; set;}

Property Value

A Boolean value indicating if the Timebar can be inserted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarInsertEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar before it is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it is inserted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarInsertEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarInsertEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem before it is inserted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarInsertEventArgs Class
BeforeTimeBarInsertEventArgs Members


%%PageItemTitle%%

BeforeTimeBarLinkEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarLinkEventArgs Class

Provides data for the BeforeTimebarLink event.

Object Model

BeforeTimeBarLinkEventArgs ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
C#
public class BeforeTimeBarLinkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarLinkEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarLinkEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarLinkEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarLinkEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarLinkEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarLinkEventArgs Constructor | Initializes a new instance of the BeforeTimebarLinkEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowLink | Determines if the Timebars can be linked together.
public Property | Link | The dbiLinkItem before it is applied between two Timebars.
Top

See Also

Reference

BeforeTimeBarLinkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarLinkEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarLinkEventArgs Class : BeforeTimeBarLinkEventArgs Constructor

Initializes a new instance of the BeforeTimebarLinkEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarLinkEventArgs()
C#
public BeforeTimeBarLinkEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%%

AllowLink Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarLinkEventArgs Class : AllowLink Property

Determines if the Timebars can be linked together.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
Dim value As System.Boolean

instance.AllowLink = value

value = instance.AllowLink
C#
public System.bool AllowLink {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarLinkEventArgs Class : Link Property

The dbiLinkItem before it is applied between two Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarLinkEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Property Value

The dbiLinkItem before it is applied between two Timebars.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarLinkEventArgs Class
BeforeTimeBarLinkEventArgs Members


%%PageItemTitle%%

BeforeTimeBarMoveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarMoveEventArgs Class

Provides data for the BeforeTimebarMove event.

Object Model

BeforeTimeBarMoveEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
C#
public class BeforeTimeBarMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarMoveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarMoveEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarMoveEventArgs Constructor | Initializes a new instance of the BeforeTimebarMoveEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the Timebar can be moved.
public Property | End | The new ending DateTime for the Timebar.
public Property | ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it is moved.
public Property | ScheduleItemTo | The dbiScheduleItem containing the Timebar after it is moved.
public Property | Start | The new starting DateTime for the Timebar.
public Property | TimeBarItem | The dbiTimebarItem before it is moved.
public Property | Vertical | Determines if the Timebar is being moved vertically.
Top

See Also

Reference

BeforeTimeBarMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarMoveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : BeforeTimeBarMoveEventArgs Constructor

Initializes a new instance of the BeforeTimebarMoveEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarMoveEventArgs()
C#
public BeforeTimeBarMoveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

AllowMove Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : AllowMove Property

Determines if the Timebar can be moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As System.Boolean

instance.AllowMove = value

value = instance.AllowMove
C#
public System.bool AllowMove {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : End Property

The new ending DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

The new ending DateTime for the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

ScheduleItemFrom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : ScheduleItemFrom Property

The dbiScheduleItem containing the Timebar before it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemFrom = value

value = instance.ScheduleItemFrom
C#
public dbiScheduleItem ScheduleItemFrom {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it is moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

ScheduleItemTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : ScheduleItemTo Property

The dbiScheduleItem containing the Timebar after it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemTo = value

value = instance.ScheduleItemTo
C#
public dbiScheduleItem ScheduleItemTo {get; set;}

Property Value

The dbiScheduleItem containing the Timebar after it is moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : Start Property

The new starting DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

The new starting DateTime for the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem before it is moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

Vertical Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarMoveEventArgs Class : Vertical Property

Determines if the Timebar is being moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarMoveEventArgs
Dim value As System.Boolean

instance.Vertical = value

value = instance.Vertical
C#
public System.bool Vertical {get; set;}

Property Value

A Boolean value indicating if the Timebar is being moved vertically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarMoveEventArgs Class
BeforeTimeBarMoveEventArgs Members


%%PageItemTitle%%

BeforeTimeBarRemoveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarRemoveEventArgs Class

Provides data for the BeforeTimebarRemove event.

Object Model

BeforeTimeBarRemoveEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
C#
public class BeforeTimeBarRemoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarRemoveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarRemoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarRemoveEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarRemoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarRemoveEventArgs Constructor | Initializes a new instance of the BeforeTimebarRemoveEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the Timebar can be removed.
public Property | BarIndex | The zero-based index value of the Timebar to be removed.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is removed.
public Property | TimeBarItem | The dbiTimebarItem before it is removed.
Top

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarRemoveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarRemoveEventArgs Class : BeforeTimeBarRemoveEventArgs Constructor

Initializes a new instance of the BeforeTimebarRemoveEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarRemoveEventArgs()
C#
public BeforeTimeBarRemoveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

AllowRemoval Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarRemoveEventArgs Class : AllowRemoval Property

Determines if the Timebar can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As System.Boolean

instance.AllowRemoval = value

value = instance.AllowRemoval
C#
public System.bool AllowRemoval {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarRemoveEventArgs Class : BarIndex Property

The zero-based index value of the Timebar to be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar to be removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarRemoveEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar before it is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it is removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarRemoveEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarRemoveEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem before it is removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
BeforeTimeBarRemoveEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSelectEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSelectEventArgs Class

Provides data for the BeforeTimebarSelect event.

Object Model

BeforeTimeBarSelectEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
C#
public class BeforeTimeBarSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSelectEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSelectEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSelectEventArgs Constructor | Initializes a new instance of the BeforeTimebarSelectEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the Timebar can be selected.
public Property | BarIndex | The zero-based index value of the Timebar being selected.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is selected.
public Property | TimeBarItem | The dbiTimebarItem before it is selected.
Top

See Also

Reference

BeforeTimeBarSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarSelectEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSelectEventArgs Class : BeforeTimeBarSelectEventArgs Constructor

Initializes a new instance of the BeforeTimebarSelectEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSelectEventArgs()
C#
public BeforeTimeBarSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

AllowSelect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSelectEventArgs Class : AllowSelect Property

Determines if the Timebar can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As System.Boolean

instance.AllowSelect = value

value = instance.AllowSelect
C#
public System.bool AllowSelect {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSelectEventArgs Class : BarIndex Property

The zero-based index value of the Timebar being selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar being selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSelectEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar before it is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it is selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSelectEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSelectEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem before it is selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSelectEventArgs Class
BeforeTimeBarSelectEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSizeEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSizeEventArgs Class

Provides data for the BeforeTimebarSize event.

Object Model

BeforeTimeBarSizeEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
C#
public class BeforeTimeBarSizeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSizeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSizeEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSizeEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSizeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSizeEventArgs Constructor | Initializes a new instance of the BeforeTimebarSizeEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowSize | Determines if the Timebar can be sized.
public Property | BarIndex | The zero-based index value of the Timebar to be sized.
public Property | End | The new starting DateTime for the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is sized.
public Property | Start | The new starting DateTime for the Timebar.
public Property | TimeBarItem | The dbiTimebarItem before it is sized.
Top

See Also

Reference

BeforeTimeBarSizeEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarSizeEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : BeforeTimeBarSizeEventArgs Constructor

Initializes a new instance of the BeforeTimebarSizeEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSizeEventArgs()
C#
public BeforeTimeBarSizeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

AllowSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : AllowSize Property

Determines if the Timebar can be sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As System.Boolean

instance.AllowSize = value

value = instance.AllowSize
C#
public System.bool AllowSize {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : BarIndex Property

The zero-based index value of the Timebar to be sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar to be sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : End Property

The new starting DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

The new starting DateTime for the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar before it is sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar before it is sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : Start Property

The new starting DateTime for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

The new starting DateTime for the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSizeEventArgs Class : TimeBarItem Property

The dbiTimebarItem before it is sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSizeEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem before it is sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSizeEventArgs Class
BeforeTimeBarSizeEventArgs Members


%%PageItemTitle%%

BeforeTimeBarSplitEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSplitEventArgs Class

Provides data for the BeforeTimebarSplit event.

Object Model

BeforeTimeBarSplitEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
C#
public class BeforeTimeBarSplitEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSplitEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarSplitEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSplitEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarSplitEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarSplitEventArgs Constructor | Initializes a new instance of the BeforeTimebarSplitEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowSplit | Determines if the split will be allowed to process. This can be set to False to cancel the split.
public Property | BarIndex | Gets the bar index value that is being split.
public Property | ScheduleItem | Get the schedule item of the Timebar that is being split.
public Property | SplitAt | Gets the Date/Time value where the split is occuring.
public Property | TimeBarItem | Gets the Timebar where the split is occurring.
Top

See Also

Reference

BeforeTimeBarSplitEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarSplitEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : BeforeTimeBarSplitEventArgs Constructor

Initializes a new instance of the BeforeTimebarSplitEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarSplitEventArgs()
C#
public BeforeTimeBarSplitEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

AllowSplit Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : AllowSplit Property

Determines if the split will be allowed to process. This can be set to False to cancel the split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As System.Boolean

instance.AllowSplit = value

value = instance.AllowSplit
C#
public System.bool AllowSplit {get; set;}

Property Value

System.Boolean

Remarks

You can perform tests to determine if the Timebar can be split at this location and if not, issue the e.AllowSplit = False to cancel it.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : BarIndex Property

Gets the bar index value that is being split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

System.Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : ScheduleItem Property

Get the schedule item of the Timebar that is being split.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

SplitAt Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : SplitAt Property

Gets the Date/Time value where the split is occuring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As System.Date

instance.SplitAt = value

value = instance.SplitAt
C#
public System.DateTime SplitAt {get; set;}

Property Value

System.DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarSplitEventArgs Class : TimeBarItem Property

Gets the Timebar where the split is occurring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarSplitEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimebarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarSplitEventArgs Class
BeforeTimeBarSplitEventArgs Members


%%PageItemTitle%%

BeforeTimeBarUnlinkEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnlinkEventArgs Class

Provides data for the BeforeTimebarUnlink event.

Object Model

BeforeTimeBarUnlinkEventArgs ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
C#
public class BeforeTimeBarUnlinkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarUnlinkEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnlinkEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarUnlinkEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnlinkEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarUnlinkEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarUnlinkEventArgs Constructor | Initializes a new instance of the BeforeTimebarUnlinkedEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowUnlink | Determines if the dbiLinkItem can be removed.
public Property | Link | The dbiLinkItem to remove.
Top

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarUnlinkEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnlinkEventArgs Class : BeforeTimeBarUnlinkEventArgs Constructor

Initializes a new instance of the BeforeTimebarUnlinkedEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarUnlinkEventArgs()
C#
public BeforeTimeBarUnlinkEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%%

AllowUnlink Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnlinkEventArgs Class : AllowUnlink Property

Determines if the dbiLinkItem can be removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
Dim value As System.Boolean

instance.AllowUnlink = value

value = instance.AllowUnlink
C#
public System.bool AllowUnlink {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnlinkEventArgs Class : Link Property

The dbiLinkItem to remove.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnlinkEventArgs
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Property Value

The dbiLinkItem to remove.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
BeforeTimeBarUnlinkEventArgs Members


%%PageItemTitle%%

BeforeTimeBarUnSelectEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnSelectEventArgs Class

Provides data for the BeforeTimeBarUnSelect Event

Object Model

BeforeTimeBarUnSelectEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnSelectEventArgs
C#
public class BeforeTimeBarUnSelectEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeTimeBarUnSelectEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeTimeBarUnSelectEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnSelectEventArgs Class

"

The following tables list the members exposed by BeforeTimeBarUnSelectEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeTimeBarUnSelectEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | AllowUnSelect | Determines if the unselect will be allowed.
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem to unselect
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem being unselected.
public Property | TimeBarItem | The dbiTimeBarItem being unselected
Top

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeTimeBarUnSelectEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnSelectEventArgs Class : BeforeTimeBarUnSelectEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeTimeBarUnSelectEventArgs()
C#
public BeforeTimeBarUnSelectEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
BeforeTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

AllowUnSelect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnSelectEventArgs Class : AllowUnSelect Property

Determines if the unselect will be allowed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnSelectEventArgs
Dim value As System.Boolean

instance.AllowUnSelect = value

value = instance.AllowUnSelect
C#
public System.bool AllowUnSelect {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
BeforeTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnSelectEventArgs Class : BarIndex Property

The zero-based index value of the dbiTimeBarItem to unselect

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnSelectEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
BeforeTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnSelectEventArgs Class : ScheduleItem Property

The dbiScheduleItem that contains the dbiTimeBarItem being unselected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnSelectEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
BeforeTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeTimeBarUnSelectEventArgs Class : TimeBarItem Property

The dbiTimeBarItem being unselected

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeTimeBarUnSelectEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
BeforeTimeBarUnSelectEventArgs Members


%%PageItemTitle%%

BeforeToolTipsEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeToolTipsEventArgs Class

Provides data for the BeforeToolTips event.

Object Model

BeforeToolTipsEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleNote ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
C#
public class BeforeToolTipsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.BeforeToolTipsEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

BeforeToolTipsEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeToolTipsEventArgs Class

"

The following tables list the members exposed by BeforeToolTipsEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | BeforeToolTipsEventArgs Constructor | Initializes a new instance of the BeforeToolTipsEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Align | Determines the alignment of the text displayed within the tool tip.
public Property | BackColor | Determines the primary color that will be used to paint the background of the tool tip.
public Property | BackColorTo | Determines the secondary color that will be used to paint the background of the tool tip.
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | BorderColor | Determines the color that will be used to paint the border of the tool tip.
public Property | BorderType | Determines the type of border to apply to the tool tip.
public Property | Display | Determines if the tool tip will be displayed.
public Property | Duration | Determines how long (in milliseconds) the tool tip remains visible when the mouse is static.
public Property | FillType | Determines the pattern used to paint the background of the tool tip.
public Property | Font | Determines the font used to draw the text in the tool tip.
public Property | ForeColor | Determines the color that will be used to draw the textof the tool tip.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar where the tool tip will be displayed.
public Property | ScheduleNote | The dbiScheduleNote to display a Tool Tip for.
public Property | ScrollValue | The position of the vertical scroll bar.
public Property | Text | The text to display in the tool tip.
public Property | TipsType | The type of tool tip to display.
Top

See Also

Reference

BeforeToolTipsEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeforeToolTipsEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BeforeToolTipsEventArgs Constructor

Initializes a new instance of the BeforeToolTipsEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New BeforeToolTipsEventArgs()
C#
public BeforeToolTipsEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Align Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : Align Property

Determines the alignment of the text displayed within the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.ContentAlignment

instance.Align = value

value = instance.Align
C#
public System.Drawing.ContentAlignment Align {get; set;}

Property Value

ContentAlignment

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

BackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BackColor Property

Determines the primary color that will be used to paint the background of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

BackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BackColorTo Property

Determines the secondary color that will be used to paint the background of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BarIndex Property

The zero-based index value of the Timebar the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

BorderColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BorderColor Property

Determines the color that will be used to paint the border of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public System.Drawing.Color BorderColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

BorderType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : BorderType Property

Determines the type of border to apply to the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As enumBorderType

instance.BorderType = value

value = instance.BorderType
C#
public enumBorderType BorderType {get; set;}

Property Value

enumBorderType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Display Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : Display Property

Determines if the tool tip will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Boolean

instance.Display = value

value = instance.Display
C#
public System.bool Display {get; set;}

Property Value

A Boolean value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Duration Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : Duration Property

Determines how long (in milliseconds) the tool tip remains visible when the mouse is static.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Integer

instance.Duration = value

value = instance.Duration
C#
public System.int Duration {get; set;}

Property Value

Integer

Remarks

This value must be greater than 0, and can be set up to a maximum of 3600000 (1 hour).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

FillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : FillType Property

Determines the pattern used to paint the background of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public enumFillType FillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Font Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : Font Property

Determines the font used to draw the text in the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : ForeColor Property

Determines the color that will be used to draw the textof the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar where the tool tip will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar where the tool tip will be displayed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ScheduleNote Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : ScheduleNote Property

The dbiScheduleNote to display a Tool Tip for.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As dbiScheduleNote

instance.ScheduleNote = value

value = instance.ScheduleNote
C#
public dbiScheduleNote ScheduleNote {get; set;}

Property Value

dbiScheduleNote Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ScrollValue Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : ScrollValue Property

The position of the vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.Integer

instance.ScrollValue = value

value = instance.ScrollValue
C#
public System.int ScrollValue {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : Text Property

The text to display in the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

TipsType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > BeforeToolTipsEventArgs Class : TipsType Property

The type of tool tip to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As BeforeToolTipsEventArgs
Dim value As enumTipsType

instance.TipsType = value

value = instance.TipsType
C#
public enumTipsType TipsType {get; set;}

Property Value

An enumTipsType member.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

BeforeToolTipsEventArgs Class
BeforeToolTipsEventArgs Members


%%PageItemTitle%%

ControlErrorEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ControlErrorEventArgs Class

Provides data for the ControlError event.

Object Model

ControlErrorEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
C#
public class ControlErrorEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ControlErrorEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ControlErrorEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ControlErrorEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ControlErrorEventArgs Class

"

The following tables list the members exposed by ControlErrorEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ControlErrorEventArgs Constructor | Initializes a new instance of the ControlErrorEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Error | The ID number of the error which has occurred.
public Property | Message | The description of the error which has occurred.
Top

See Also

Reference

ControlErrorEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ControlErrorEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ControlErrorEventArgs Class : ControlErrorEventArgs Constructor

Initializes a new instance of the ControlErrorEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ControlErrorEventArgs()
C#
public ControlErrorEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%%

Error Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ControlErrorEventArgs Class : Error Property

The ID number of the error which has occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
Dim value As System.Integer

instance.Error = value

value = instance.Error
C#
public System.int Error {get; set;}

Property Value

An Integer value indicating the ID number of the error which has occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%%

Message Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ControlErrorEventArgs Class : Message Property

The description of the error which has occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ControlErrorEventArgs
Dim value As System.String

instance.Message = value

value = instance.Message
C#
public System.string Message {get; set;}

Property Value

A String value indicating the description of the error which has occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ControlErrorEventArgs Class
ControlErrorEventArgs Members


%%PageItemTitle%%

dbiGuideLine Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLine Class

Provides the properties for defining a GuideLine for use in the GuideLines collection.

Object Model

dbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
C#
public class dbiGuideLine

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiGuideLine Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLine Class

"

The following tables list the members exposed by dbiGuideLine.

"

Public Constructors

 | Name | Description
public Constructor | dbiGuideLine Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | ImageIndex | The image index of the desired icon attached to the GuideImages Property.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a guide line image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a GuideLine.
public Property | LineColor | Determines the color of a GuideLine.
public Property | LineTime | Determines the date and time value of the GuideLine.
public Property | Locked | Determines if a GuideLine can be moved/removed with the mouse.
public Property | Tag | Allows an object to be stored on the dbiGuideLine.
public Property | Width | Gets and sets the width of the GuideLine
public Property | XMLString | Gets or sets the properties based on an XML String.
Top

See Also

Reference

dbiGuideLine Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiGuideLine Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : dbiGuideLine Constructor

Overload List

Overload | Description
dbiGuideLine Constructor() | Creates a new instance of the class.
dbiGuideLine Constructor(DateTime) | Creates a new instance of the class setting the LineTime property.
dbiGuideLine Constructor(dbiGuideLine) | Creates a new instance of the class based on an existing dbiGuideLine object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

dbiGuideLine Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor()

Creates a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiGuideLine()
C#
public dbiGuideLine()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

dbiGuideLine Constructor(DateTime)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor(DateTime)

dtTime

The date/time where the GuideLine will appear.

Creates a new instance of the class setting the LineTime property.

Syntax

Visual Basic (Usage) Copy Code
Dim dtTime As System.Date

Dim instance As New dbiGuideLine(dtTime)
C#
public dbiGuideLine(
   System.DateTime dtTime
)

Parameters

dtTime

The date/time where the GuideLine will appear.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

dbiGuideLine Constructor(dbiGuideLine)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class > dbiGuideLine Constructor : dbiGuideLine Constructor(dbiGuideLine)

objLine
An existing dbiGuideLine.
Creates a new instance of the class based on an existing dbiGuideLine object.

Syntax

Visual Basic (Usage) Copy Code
Dim objLine As dbiGuideLine

Dim instance As New dbiGuideLine(objLine)
C#
public dbiGuideLine(
   dbiGuideLine objLine
)

Parameters

objLine
An existing dbiGuideLine.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members
Overload List


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : ImageIndex Property

The image index of the desired icon attached to the GuideImages Property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

Integer

Remarks

This value will override the default image index set in the GuideImageIndex Property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageXOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : ImageXOffset Property

Determines the horizontal offset used to calculate the position of a guide line image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Integer

instance.ImageXOffset = value

value = instance.ImageXOffset
C#
public System.int ImageXOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

ImageYOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : ImageYOffset Property

Determines the vertical offset used to calculate the position of a GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Integer

instance.ImageYOffset = value

value = instance.ImageYOffset
C#
public System.int ImageYOffset {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

LineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : LineColor Property

Determines the color of a GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Drawing.Color

instance.LineColor = value

value = instance.LineColor
C#
public System.Drawing.Color LineColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : LineTime Property

Determines the date and time value of the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public virtual System.DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Locked Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : Locked Property

Determines if a GuideLine can be moved/removed with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Boolean

instance.Locked = value

value = instance.Locked
C#
public System.bool Locked {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : Tag Property

Allows an object to be stored on the dbiGuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Remarks

Useful for adding data rows or other items specific to the dbiGuideLine.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

Width Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : Width Property

Gets and sets the width of the GuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

Integer

Remarks

If this property is set, it will override the GuideLineWidth property, and draw the GuideLine as a solid line.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

XMLString Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLine Class : XMLString Property

Gets or sets the properties based on an XML String.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLine
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

String

Remarks

This is a proprietary format and should only be used by copying the contents. Any direct modifications to the string may cause unstable results.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLine Class
dbiGuideLine Members


%%PageItemTitle%%

dbiGuideLineCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLineCollection Class

Provides a collection of GuideLine objects to the dbiScheduleObject.

Object Model

dbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
C#
public class dbiGuideLineCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.dbiGuideLineCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiGuideLineCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLineCollection Class

"

The following tables list the members exposed by dbiGuideLineCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiGuideLineCollection Constructor | Represents a collection of GuideLines.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiGuideLine added to the dbiScheduleObject.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a dbiGuideLine to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiGuideLine
public Method | Insert | Inserts a dbiGuideLine into the collection at the specified index.
public Method | Remove | Removes a dbiGuideLine from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the collection to an XML file specified in strFileName
public Method | XMLString | Returns the GuideLine collection as an XML String.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiGuideLineCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : dbiGuideLineCollection Constructor

objOwner
The dbiScheduleObject that will contain the collection.
Represents a collection of GuideLines.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiScheduleObject

Dim instance As New dbiGuideLineCollection(objOwner)
C#
public dbiGuideLineCollection(
   dbiScheduleObject objOwner
)

Parameters

objOwner
The dbiScheduleObject that will contain the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Add Method

obj
dbiGuideLine
Adds a dbiGuideLine to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiGuideLine obj
)

Parameters

obj
dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

IndexOf(dbiGuideLine) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : IndexOf(dbiGuideLine) Method

obj
dbiGuideLine
Returns the internal index of the dbiGuideLine

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiGuideLine obj
)

Parameters

obj
dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Insert Method

nIndex
Integer
obj
dbiGuideLine
Inserts a dbiGuideLine into the collection at the specified index.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As System.Integer
Dim obj As dbiGuideLine

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiGuideLine obj
)

Parameters

nIndex
Integer
obj
dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Remove Method

obj
dbiGuideLine
Removes a dbiGuideLine from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim obj As dbiGuideLine

instance.Remove(obj)
C#
public void Remove(
   dbiGuideLine obj
)

Parameters

obj
dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : WriteXMLFile Method

strFileName
String - fully qualified file name to write to
Writes the collection to an XML file specified in strFileName

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
String - fully qualified file name to write to

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : XMLString Method

Returns the GuideLine collection as an XML String.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

String

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : Item Property

nIndex
The internal index of the dbiGuideLine in the collection
A dbiGuideLine added to the dbiScheduleObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiGuideLineCollection
Dim nIndex As System.Integer
Dim value As dbiGuideLine

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiGuideLine this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The internal index of the dbiGuideLine in the collection

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%%

dbiHistoryItem Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiHistoryItem Class

Gets the properties of a history item.

Object Model

dbiHistoryItem ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
C#
public class dbiHistoryItem

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiHistoryItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Members
Dbi.WinControl.Schedule Namespace

Developing with dbiSchedule

History


%%PageItemTitle%% $$Members$$

dbiHistoryItem Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiHistoryItem Class

"

The following tables list the members exposed by dbiHistoryItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiHistoryItem Constructor | Overloaded. Initializes a new instance of the dbiHistoryItem Class.
Top

Public Properties

 | Name | Description
public Property | ActionType | Determines the type of action that is taking place.
public Property | BarIndex | Gets or sets the index of the Timebar where the action is occuring.
public Property | End | The end date and time of the Timebar before the action has been performed.
public Property | Group | Gets or sets an internal number to identify the sequence where the action takes place.
public Property | Link | Gets the dbiLinkItem which was added to or removed from the schedule.
public Property | ScheduleItem | The original dbiScheduleItem the action was performed on.
public Property | ScheduleItemTo | The dbiScheduleItem a Timebar has been vertically moved to.
public Property | Start | The start date and time of the Timebar before the action has been performed.
public Property | TimeBar | The original dbiTimebarItem the action was performed on.
public Property | TimeBarTo | The dbiTimebarItem after it has been moved vertically.
Top

See Also

Reference

dbiHistoryItem Class
Dbi.WinControl.Schedule Namespace

Developing with dbiSchedule

History


%%PageItemTitle%%

dbiHistoryItem Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : dbiHistoryItem Constructor

Initializes a new instance of the dbiHistoryItem Class.

Overload List

Overload | Description
dbiHistoryItem Constructor() | Initializes a new instance of the dbiHistoryItem Class.
dbiHistoryItem Constructor(Int32,enumActionType) | Initializes a new instance of the dbiHistoryItem Class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

dbiHistoryItem Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class > dbiHistoryItem Constructor : dbiHistoryItem Constructor()

Initializes a new instance of the dbiHistoryItem Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiHistoryItem()
C#
public dbiHistoryItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members
Overload List


%%PageItemTitle%%

dbiHistoryItem Constructor(Int32,enumActionType)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class > dbiHistoryItem Constructor : dbiHistoryItem Constructor(Int32,enumActionType)

nGroup
The group ID of the history item.
nAction
The dbiHistoryItem.enumActionType member
Initializes a new instance of the dbiHistoryItem Class.

Syntax

Visual Basic (Usage) Copy Code
Dim nGroup As System.Integer
Dim nAction As dbiHistoryItem.enumActionType

Dim instance As New dbiHistoryItem(nGroup, nAction)
C#
public dbiHistoryItem(
   System.int nGroup,
   dbiHistoryItem.enumActionType nAction
)

Parameters

nGroup
The group ID of the history item.
nAction
The dbiHistoryItem.enumActionType member

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members
Overload List


%%PageItemTitle%%

ActionType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : ActionType Property

Determines the type of action that is taking place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiHistoryItem.enumActionType

instance.ActionType = value

value = instance.ActionType
C#
public dbiHistoryItem.enumActionType ActionType {get; set;}

Property Value

A dbiHistoryItem.enumActionType member.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : BarIndex Property

Gets or sets the index of the Timebar where the action is occuring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

System.Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : End Property

The end date and time of the Timebar before the action has been performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

System.DateTime

Remarks

When the Undo method is called, the Timebar will reset back to the end date and time specified in this property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Group Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : Group Property

Gets or sets an internal number to identify the sequence where the action takes place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As System.Integer

instance.Group = value

value = instance.Group
C#
public System.int Group {get; set;}

Property Value

System.Integer

Remarks

If an action occurs on multiple bars, each item will recieve it's own history item, however they will all have the same group value.

This number should not be directly manipulated. The methods used to add a history object to the control will do that automatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Link Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : Link Property

Gets the dbiLinkItem which was added to or removed from the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiLinkItem

instance.Link = value

value = instance.Link
C#
public dbiLinkItem Link {get; set;}

Property Value

The dbiLinkItem which was added or removed from the schedule.

Remarks

This property is only defined when the ActionType is equal to Link or UnLink.

ActionType/Method | Description
Link/Undo | The dbiLinkItem will be removed.
Link/Redo | The dbiLinkItem will be re-added
UnLink/Undo | The dbiLinkItem will be re-added
Unlink/Redo | The dbiLinkItem will be removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : ScheduleItem Property

The original dbiScheduleItem the action was performed on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

A dbiScheduleItem object.

Remarks

This property is only defined when the ActionType property is equal to Create, Remove, Size or Move, else a value of Null (Nothing in Visual Basic) is returned.

ActionType/Method | Description
Create/Undo | The dbiTimebarItem will be removed from the dbiScheduleItem object.
Create/Redo | The dbiTimebarItem will be re-added to the dbiScheduleItem object.
Remove/Undo | The dbiTimebarItem will be re-added to the dbiScheduleItem object.
Remove/Redo | The dbiTimebarItem will be removed from the dbiScheduleItem object.
Size/Undo | The dbiTimebarItem will be re-sized to the last size
Size/Redo | The resized Timebar will be resized to the newer size.
Move/Undo | The dbiTimebarItem will be moved back to this object.
Move/Redo | The dbiTimebarItem will be moved to the ScheduleItemTo object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

ScheduleItemTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : ScheduleItemTo Property

The dbiScheduleItem a Timebar has been vertically moved to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiScheduleItem

instance.ScheduleItemTo = value

value = instance.ScheduleItemTo
C#
public dbiScheduleItem ScheduleItemTo {get; set;}

Property Value

A dbiScheduleItem object.

Remarks

This property will return a Null value (Nothing in Visual Basic) unless a Timebar has been moved vertically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : Start Property

The start date and time of the Timebar before the action has been performed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

System.DateTime

Remarks

When the Undo method is called, the Timebar will reset back to the start date and time specified in this property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

TimeBar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : TimeBar Property

The original dbiTimebarItem the action was performed on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiTimeBarItem

instance.TimeBar = value

value = instance.TimeBar
C#
public dbiTimeBarItem TimeBar {get; set;}

Property Value

A dbiTimebarItem object.

Remarks

This property is only defined when the ActionType property is equal to Create, Remove, Size or Move, else a value of Null (Nothing in Visual Basic) is returned.

ActionType/Method | Description
Create/Undo | The dbiTimebarItem will be removed from the dbiScheduleItem object.
Create/Redo | The dbiTimebarItem will be re-added to the dbiScheduleItem object.
Remove/Undo | The dbiTimebarItem will be re-added to the dbiScheduleItem object.
Remove/Redo | The dbiTimebarItem will be removed from the dbiScheduleItem object.
Size/Undo | The dbiTimebarItem will be re-sized to the last size
Size/Redo | The resized Timebar will be resized to the newer size.
Move/Undo | The dbiTimebarItem will be moved back to this object.
Move/Redo | The dbiTimebarItem will be moved to the ScheduleItemTo object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

TimeBarTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiHistoryItem Class : TimeBarTo Property

The dbiTimebarItem after it has been moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem
Dim value As dbiTimeBarItem

instance.TimeBarTo = value

value = instance.TimeBarTo
C#
public dbiTimeBarItem TimeBarTo {get; set;}

Property Value

A dbiTimebarItem object.

Remarks

This property will return a Null value (Nothing in Visual Basic) unless a Timebar has been moved vertically.

ActionType/Method | Description
Move/Undo | The dbiTimebarItem will be moved to the Timebar object.
Move/Redo | The dbiTimebarItem will be re-added to the dbiScheduleItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiHistoryItem Class
dbiHistoryItem Members


%%PageItemTitle%%

dbiLinkItem Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiLinkItem Class

Provides properties for defining Timebar links.

Object Model

dbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
C#
public class dbiLinkItem

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiLinkItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiLinkItem Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiLinkItem Class

"

The following tables list the members exposed by dbiLinkItem.

"

Public Constructors

 | Name | Description
public Constructor | dbiLinkItem Constructor | Overloaded. Initializes a new instance of the dbiLinkItem class.
Top

Public Properties

 | Name | Description
public Property | DashPattern | An array of real numbers that specifies the lengths of alternating dashes and spaces representing the line.
public Property | LineColor | Gets or sets the color of the link line.
public Property | LineStyle | Determines the line style of the time bar link.
public Property | LinkDirection | Gets or sets the link direction between two Timebars.
public Property | LinkType | Gets or sets the type of link to create.
public Property | TimeBarFrom | Gets or sets the dbiTimebarItem receiving the link.
public Property | TimeBarTo | Gets or sets the dbiTimebarItem initiating the link.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to link.
Top

See Also

Reference

dbiLinkItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiLinkItem Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : dbiLinkItem Constructor

Initializes a new instance of the dbiLinkItem class.

Overload List

Overload | Description
dbiLinkItem Constructor() | Initializes a new instance of the dbiLinkItem class.
dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem) | Initializes a new instance of the dbiLinkItem class.
dbiLinkItem Constructor(XmlNodeList) | Initializes a new instance of the dbiLinkItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

dbiLinkItem Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class > dbiLinkItem Constructor : dbiLinkItem Constructor()

Initializes a new instance of the dbiLinkItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiLinkItem()
C#
public dbiLinkItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class > dbiLinkItem Constructor : dbiLinkItem Constructor(dbiTimeBarItem,dbiTimeBarItem)

objFrom
The dbiTimebarItem being linked.
objTo
The dbiTimebarItem being linked to.
Initializes a new instance of the dbiLinkItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objFrom As dbiTimeBarItem
Dim objTo As dbiTimeBarItem

Dim instance As New dbiLinkItem(objFrom, objTo)
C#
public dbiLinkItem(
   dbiTimeBarItem objFrom,
   dbiTimeBarItem objTo
)

Parameters

objFrom
The dbiTimebarItem being linked.
objTo
The dbiTimebarItem being linked to.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

dbiLinkItem Constructor(XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class > dbiLinkItem Constructor : dbiLinkItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing the linking information.
Initializes a new instance of the dbiLinkItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiLinkItem(xmlNodes)
C#
public dbiLinkItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing the linking information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members
Overload List


%%PageItemTitle%%

DashPattern Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : DashPattern Property

An array of real numbers that specifies the lengths of alternating dashes and spaces representing the line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value() As System.Single

instance.DashPattern = value

value = instance.DashPattern
C#
public System.float[] DashPattern {get; set;}

Property Value

A Float() value

Remarks

The elements in the DashPattern array set the length of each dash and space in the dash pattern. The first element sets the length of a dash, the second element sets the length of a space, the third element sets the length of a dash, and so on. Consequently, each element should be a non-zero positive number. Once all the values of the array have been used, the pattern will start from the first value and repeat until the end of the line.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

LineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : LineColor Property

Gets or sets the color of the link line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As System.Drawing.Color

instance.LineColor = value

value = instance.LineColor
C#
public System.Drawing.Color LineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Links(1).LineColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.Links[1].LineColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

LineStyle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : LineStyle Property

Determines the line style of the time bar link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As System.Drawing.Drawing2D.DashStyle

instance.LineStyle = value

value = instance.LineStyle
C#
public System.Drawing.Drawing2D.DashStyle LineStyle {get; set;}

Property Value

DashStyle enumerated value

Remarks

When set to Custom, the DashPattern property will be used to determine the appearance of the line drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

LinkDirection Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : LinkDirection Property

Gets or sets the link direction between two Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiLinkItem.enumLinkDirection

instance.LinkDirection = value

value = instance.LinkDirection
C#
public dbiLinkItem.enumLinkDirection LinkDirection {get; set;}

Property Value

dbiLinkItem.enumLinkDirection Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

LinkType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : LinkType Property

Gets or sets the type of link to create.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiLinkItem.enumLinkType

instance.LinkType = value

value = instance.LinkType
C#
public dbiLinkItem.enumLinkType LinkType {get; set;}

Property Value

A dbiLinkItem.enumLinkType value.

Example

The following illustrates how to set this property programmatically. This property cannot be set at design time using the property inspector window.
Visual Basic Copy Code
objLink = New Dbi.WinControl.Schedule.dbiLinkItem
'Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23
'Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39
'Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct

'Adds the new link
Me.dbiSchedule1.Links.Add(objLink)
C# Copy Code
Dbi.WinControl.Schedule.dbiLinkItem objLink;
objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

//Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23;
//Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39;

//Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct;

//Adds the new link
this.dbiSchedule1.Links.Add(objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

TimeBarFrom Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : TimeBarFrom Property

Gets or sets the dbiTimebarItem receiving the link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiTimeBarItem

instance.TimeBarFrom = value

value = instance.TimeBarFrom
C#
public dbiTimeBarItem TimeBarFrom {get; set;}

Property Value

A dbiTimebarItem object.

Example

This property is only available at run-time.
Visual Basic Copy Code
objLink = New Dbi.WinControl.Schedule.dbiLinkItem
'Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23
'Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39
'Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct

'Adds the new link
Me.dbiSchedule1.Links.Add(objLink)
C# Copy Code
Dbi.WinControl.Schedule.dbiLinkItem objLink;
objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

//Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23;
//Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39;

//Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct;

//Adds the new link
this.dbiSchedule1.Links.Add(objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

TimeBarTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : TimeBarTo Property

Gets or sets the dbiTimebarItem initiating the link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As dbiTimeBarItem

instance.TimeBarTo = value

value = instance.TimeBarTo
C#
public dbiTimeBarItem TimeBarTo {get; set;}

Property Value

A dbiTimebarItem object.

Example

This property is only available at run-time.
Visual Basic Copy Code
objLink = New Dbi.WinControl.Schedule.dbiLinkItem
'Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23
'Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39
'Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct

'Adds the new link
Me.dbiSchedule1.Links.Add(objLink)
C# Copy Code
Dbi.WinControl.Schedule.dbiLinkItem objLink;
objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

//Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23;
//Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39;

//Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct;

//Adds the new link
this.dbiSchedule1.Links.Add(objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiLinkItem Class : XMLString Property

Gets or sets an XML string to read the data from or write the data to link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value indicating an XML string to read or write to link.

Example

This property is only available at run-time.
Visual Basic Copy Code
Me.dbiSchedule.Links(0).XMLString = strXML
C# Copy Code
this.dbiSchedule.Links[0].XMLString = strXML;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLinkItem Class
dbiLinkItem Members


%%PageItemTitle%%

dbiSchedule Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule Class

Provides the properties for defining the list area and general properties of dbiSchedule.

Object Model

dbiSchedule ClassdbiColumnItem ClassdbiColumnFormat ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassScheduleItemCollection ClassdbiScheduleItem ClassLinkCollection ClassdbiLinkItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassHistoryCollection ClassdbiHistoryItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassScheduleCollection ClassdbiScheduleObject ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTextBox ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarStyleCollection ClassdbiTimeBarStyle ClassHistoryCollection ClassdbiHistoryItem ClassDaysWeekendCollection Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
C#
public class dbiSchedule : Dbi.WinControl.DbiListControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Dbi.WinControl.DbiListControl
Dbi.WinControl.Schedule.dbiSchedule

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : dbiSchedule Constructor

Initializes a new instance of the dbiSchedule class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule()
C#
public dbiSchedule()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AddHistoryItem Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AddHistoryItem Method

Adds a dbiHistoryItem to the history collection.

Overload List

Overload | Description
AddHistoryItem(dbiHistoryItem) | Adds a dbiHistoryItem to the history collection.
AddHistoryItem(dbiHistoryItem,Boolean) | Use this overload with bHistoryIncrement set to False if you want to add history objects to the collection with the same groupID as the last added history item.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

History


%%PageItemTitle%%

AddHistoryItem(dbiHistoryItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > AddHistoryItem Method : AddHistoryItem(dbiHistoryItem) Method

objHistory
dbiHistoryItem
Adds a dbiHistoryItem to the history collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objHistory As dbiHistoryItem

instance.AddHistoryItem(objHistory)
C#
public void AddHistoryItem(
   dbiHistoryItem objHistory
)

Parameters

objHistory
dbiHistoryItem

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List

Developing with dbiSchedule

History


%%PageItemTitle%%

AddHistoryItem(dbiHistoryItem,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > AddHistoryItem Method : AddHistoryItem(dbiHistoryItem,Boolean) Method

objHistory
dbiHistoryItem
bHistoryIncrement
System.Boolean
Use this overload with bHistoryIncrement set to False if you want to add history objects to the collection with the same groupID as the last added history item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objHistory As dbiHistoryItem
Dim bHistoryIncrement As System.Boolean

instance.AddHistoryItem(objHistory, bHistoryIncrement)
C#
public void AddHistoryItem(
   dbiHistoryItem objHistory,
   System.bool bHistoryIncrement
)

Parameters

objHistory
dbiHistoryItem
bHistoryIncrement
System.Boolean

Remarks

This overload is used for un-doing multiple history items with a single undo command... for instance, if there are multiple Timebar moves created programmatically by the developer during a single event. This will allow a single undo command to remove all the Timebar moves without iteration. For more information, see the SeeAlso - Developing with dbiSchedule - History topic below.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List

Developing with dbiSchedule

History


%%PageItemTitle%%

AutoSetNodeHeight(dbiScheduleItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > AutoSetNodeHeight Method : AutoSetNodeHeight(dbiScheduleItem) Method

objItem
dbiScheduleItem
Automatically sets the HeightOffset for the dbiScheduleItem passed as a parameter.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiScheduleItem

instance.AutoSetNodeHeight(objItem)
C#
public void AutoSetNodeHeight(
   dbiScheduleItem objItem
)

Parameters

objItem
dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

BarToBack Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarToBack Method

objTimeBar
The dbiTimebarItem object to move.
Moves a specified Timebar behind any conflicting Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As System.Boolean

value = instance.BarToBack(objTimeBar)
C#
public System.bool BarToBack(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem object to move.

Return Value

A Boolean value, indicating if the method was successful.

Example

Visual Basic Copy Code
Dim booReturn As Boolean
booReturn = Me.dbiSchedule.BarToBack(objTimebar)
C# Copy Code
bool booReturn;
booReturn = this.dbiSchedule.BarToBack(objTimebar);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Miscellaneous Features


%%PageItemTitle%%

BarToFront Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarToFront Method

objTimeBar
The dbiTimebarItem object to move.
Moves a specified Timebar in front of any conflicting Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As System.Boolean

value = instance.BarToFront(objTimeBar)
C#
public System.bool BarToFront(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem object to move.

Return Value

A Boolean value, indicating if the method was successful.

Example

Visual Basic Copy Code
Dim booReturn As Boolean
booReturn = Me.dbiSchedule.BarToFront(objTimebar)
C# Copy Code
bool booReturn;
booReturn = this.dbiSchedule.BarToFront(objTimebar);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Miscellaneous Features


%%PageItemTitle%%

ColumnAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ColumnAt Method

Gets the dbiColumnItem at a specified location

Overload List

Overload | Description
ColumnAt(Int32,Int32) | Gets the dbiColumnItem at a specified location (Inherited from Dbi.WinControl.DbiListControl)
ColumnAt(Point) | Gets the dbiColumnItem at a specified location (Inherited from Dbi.WinControl.DbiListControl)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CreateControl() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CreateImage Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CreateImage Method

strFileName
The name and path of the image to create.
nWidth
The width of the image.
nHeight
The height of the image.
Creates an image of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim strFileName As System.String
Dim nWidth As System.Integer
Dim nHeight As System.Integer
Dim value As System.Boolean

value = instance.CreateImage(strFileName, nWidth, nHeight)
C#
public System.bool CreateImage(
   System.string strFileName,
   System.int nWidth,
   System.int nHeight
)

Parameters

strFileName
The name and path of the image to create.
nWidth
The width of the image.
nHeight
The height of the image.

Return Value

A Boolean value, indicating if the method was successful.

Example

Visual Basic Copy Code
'Create a fixed size image
Me.dbiSchedule.CreateImage("C:\Image",15,15)

'Create an image of the actual size
Me.dbiSchedule.CreateImage("C:\Image",0,0)

'Create a full size image
Me.dbiSchedule.CreateImage("C:\Image",-1,-1)
C# Copy Code
//Create a fixed size image
this.dbiSchedule.CreateImage("C:\\Image",15,15);

//Create an image of the actual size
this.dbiSchedule.CreateImage("C:\\Image",0,0);

//Create a full size image
this.dbiSchedule.CreateImage("C:\\Image",-1,-1);

Remarks

The type of image is determined by the ImageType property. The image can be a fixed size, actual size, or full size.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating an Image of the Control


%%PageItemTitle%%

CustomAreasAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CustomAreasAt Method

This function will receive a cursor location, and return a dbiCustomAreaCollection Class

Overload List

Overload | Description
CustomAreasAt(Int32,Int32) | This function will receive a cursor location, and return a dbiCustomAreaCollection Class
CustomAreasAt(Point) | This function will receive a cursor location, and return a dbiCustomAreaCollection Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CustomAreasAt(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > CustomAreasAt Method : CustomAreasAt(Int32,Int32) Method

nX
The x-coordinate to use.
nY
the y-coordinate to use.
This function will receive a cursor location, and return a dbiCustomAreaCollection Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As dbiCustomAreaCollection

value = instance.CustomAreasAt(nX, nY)
C#
public dbiCustomAreaCollection CustomAreasAt(
   System.int nX,
   System.int nY
)

Parameters

nX
The x-coordinate to use.
nY
the y-coordinate to use.

Remarks

The top most custom area will be the first item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

CustomAreasAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > CustomAreasAt Method : CustomAreasAt(Point) Method

ptMouse
Cursor position to test for Custom Areas.
This function will receive a cursor location, and return a dbiCustomAreaCollection Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As dbiCustomAreaCollection

value = instance.CustomAreasAt(ptMouse)
C#
public dbiCustomAreaCollection CustomAreasAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
Cursor position to test for Custom Areas.

Remarks

The top most custom area will be the first item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

DateTimeAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DateTimeAt Method

Gets the DateTime value at a specific location.

Overload List

Overload | Description
DateTimeAt(Int32) | Gets the DateTime value at a specific location.
DateTimeAt(Point) | Gets the DateTime value at a specific location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DateTimeAt(Int32) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > DateTimeAt Method : DateTimeAt(Int32) Method

nX
An Integer value representing a specific x coordinate.
Gets the DateTime value at a specific location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim value As System.Date

value = instance.DateTimeAt(nX)
C#
public System.DateTime DateTimeAt(
   System.int nX
)

Parameters

nX
An Integer value representing a specific x coordinate.

Return Value

A DateTime value.

Example

The following syntax was placed in the MouseDown event.
Visual Basic Copy Code
Dim dtDate As DateTime
dtDate = Me.DbiSchedule1.DateTimeAt(e.X)
C# Copy Code
DateTime dtDate ;
dtDate = this.DbiSchedule1.DateTimeAt(e.X);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

DateTimeAt(Point) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > DateTimeAt Method : DateTimeAt(Point) Method

ptMouse
A System.Drawing.Point value representing a specific x y coordinate.
Gets the DateTime value at a specific location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As System.Date

value = instance.DateTimeAt(ptMouse)
C#
public System.DateTime DateTimeAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
A System.Drawing.Point value representing a specific x y coordinate.

Return Value

A DateTime value.

Example

The following syntax was placed in the MouseDown event.
Visual Basic Copy Code
Dim dtDate As DateTime
dtDate = Me.DbiSchedule1.DateTimeAt(New Point(e.X, e.Y))
C# Copy Code
DateTime dtDate;
dtDate = this.dbiSchedule1.DateTimeAt(new System.Drawing.Point(e.X, e.Y));

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

DisplayToolbar Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayToolbar Method

Displays a Toolbar with the available EditModes for the control, at a specified location.

Overload List

Overload | Description
DisplayToolbar(Point) | Displays a Toolbar with the available EditModes for the control, at a specified location.
DisplayToolbar(Int32,Int32) | Displays a Toolbar with the available EditModes for the control, at a specified location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayToolbar(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > DisplayToolbar Method : DisplayToolbar(Point) Method

ptPoint
The Point (X and Y coorindates) to display the toolbar at.
Displays a Toolbar with the available EditModes for the control, at a specified location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptPoint As System.Drawing.Point

instance.DisplayToolbar(ptPoint)
C#
public void DisplayToolbar(
   System.Drawing.Point ptPoint
)

Parameters

ptPoint
The Point (X and Y coorindates) to display the toolbar at.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

DisplayToolbar(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > DisplayToolbar Method : DisplayToolbar(Int32,Int32) Method

nX
The X coordinate to display the toolbar at.
nY
The Y coordinate to display the toolbar at.
Displays a Toolbar with the available EditModes for the control, at a specified location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer

instance.DisplayToolbar(nX, nY)
C#
public void DisplayToolbar(
   System.int nX,
   System.int nY
)

Parameters

nX
The X coordinate to display the toolbar at.
nY
The Y coordinate to display the toolbar at.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

DrawToBitmap Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditCell Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditCell Method

Places the desired cell into edit mode.

Overload List

Overload | Description
EditCell(dbiNodeItem) | Places the desired cell into edit mode
EditCell(dbiNodeItem,Int32) | Places the desired cell into edit mode
EditCell(dbiNodeItem,dbiColumnItem) | Places the desired cell into edit mode
EditCell(dbiNodeItem,dbiColumnItem,Boolean) | Places the desired cell into edit mode

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditCell(dbiNodeItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > EditCell Method : EditCell(dbiNodeItem) Method

objItem
The dbiScheduleItem to edit
Places the desired cell into edit mode

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim value As System.Boolean

value = instance.EditCell(objItem)
C#
public new System.bool EditCell(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiScheduleItem to edit

Return Value

Boolean value indicating the success of the attempt to start the edit.

Remarks

As no column is defined in this method call, the entire text of the item will be placed in the edit, and the default dbiTextBox will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

EditCell(dbiNodeItem,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > EditCell Method : EditCell(dbiNodeItem,Int32) Method

objItem
The dbiScheduleItem to edit
nIndex
The zero-based index of the dbiColumnItem that contains the cell to edit.
Places the desired cell into edit mode

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim nIndex As System.Integer
Dim value As System.Boolean

value = instance.EditCell(objItem, nIndex)
C#
public new System.bool EditCell(
   dbiNodeItem objItem,
   System.int nIndex
)

Parameters

objItem
The dbiScheduleItem to edit
nIndex
The zero-based index of the dbiColumnItem that contains the cell to edit.

Return Value

Boolean value indicating the success of the attempt to start the edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

EditCell(dbiNodeItem,dbiColumnItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > EditCell Method : EditCell(dbiNodeItem,dbiColumnItem) Method

objNodeItem
The dbiScheduleItem that contains the cell to edit
objColumnItem
The dbiColumnItem that contains the cell to edit.
Places the desired cell into edit mode

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objNodeItem As dbiNodeItem
Dim objColumnItem As dbiColumnItem
Dim value As System.Boolean

value = instance.EditCell(objNodeItem, objColumnItem)
C#
public new System.bool EditCell(
   dbiNodeItem objNodeItem,
   dbiColumnItem objColumnItem
)

Parameters

objNodeItem
The dbiScheduleItem that contains the cell to edit
objColumnItem
The dbiColumnItem that contains the cell to edit.

Return Value

Boolean value indicating the success of the attempt to start the edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

EditCell(dbiNodeItem,dbiColumnItem,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > EditCell Method : EditCell(dbiNodeItem,dbiColumnItem,Boolean) Method

objNodeItem
The dbiScheduleItem that contains the cell to edit.
objColumnItem
The dbiColumnItem that contains the cell to edit.
bAdjust
Determines if the control should scroll the view, to ensure the cell is visible.
Places the desired cell into edit mode

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objNodeItem As dbiNodeItem
Dim objColumnItem As dbiColumnItem
Dim bAdjust As System.Boolean
Dim value As System.Boolean

value = instance.EditCell(objNodeItem, objColumnItem, bAdjust)
C#
public System.bool EditCell(
   dbiNodeItem objNodeItem,
   dbiColumnItem objColumnItem,
   System.bool bAdjust
)

Parameters

objNodeItem
The dbiScheduleItem that contains the cell to edit.
objColumnItem
The dbiColumnItem that contains the cell to edit.
bAdjust
Determines if the control should scroll the view, to ensure the cell is visible.

Return Value

Boolean value indicating the success of the attempt to start the edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

EditNextCell Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditNextCell Method

Places the next logical cell in to edit

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.EditNextCell()
C#
public System.bool EditNextCell()

Return Value

Returns True if an editable cell is found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditPrevCell Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditPrevCell Method

Places the previous logical cell in to edit

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.EditPrevCell()
C#
public System.bool EditPrevCell()

Return Value

Returns True if an editable cell is found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EnsureVisible Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EnsureVisible Method

objItem
The dbiScheduleItem to attempt to scroll in to the view.
Method to move the visible portion of the control to ensure that the item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem

instance.EnsureVisible(objItem)
C#
public void EnsureVisible(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiScheduleItem to attempt to scroll in to the view.

Remarks

The control calling this method will need to be fully instanced and drawn before this method can work. Calling this method before the control has fully rendered will result in the method failing. NOTE: If using an older version of the dbi4.dll base assembly, calling this method before the control has been fully instanced may result in an exception.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetExpandedItemCount Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetExpandedItemCount Method

objItem
The dbiNodeItem to evaluate.
Gets or sets the number of visible child nodes of a given dbiNodeItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.GetExpandedItemCount(objItem)
C#
public System.int GetExpandedItemCount(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to evaluate.

Return Value

An Integer value

Example

Visual Basic Copy Code
Dim intExpanded As Integer
intExpanded = Me.DbiSchedule1.GetExpandedItemCount(objNodeItem)
C# Copy Code
int intExpanded;
intExpanded = this.DbiSchedule1.GetExpandedItemCount(objNodeItem);

Remarks

The return value includes the dbiNodeItem itself and all visible children.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetNodeLevel Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetNodeLevel Method

objItem
The dbiNodeItem to find the level of.
Returns the zero-based level within the nested structure of a specified node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.GetNodeLevel(objItem)
C#
public System.int GetNodeLevel(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to find the level of.

Return Value

Integer

Remarks

A value of 0 indicates the node item exists directly in the control's primary collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InDeadZone Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InDeadZone Method

Determines if a dbiTimeBarItem, dbiAppointmentItem, dbiGuideLine or a TimeSpan is in a dead zone.

Overload List

Overload | Description
InDeadZone(dbiTimeBarItem,dbiScheduleItem) | Determines if a dbiTimebarItem is in a dead zone.
InDeadZone(dbiAppointmentItem,dbiScheduleItem) | Determines if a dbiAppointmentItem is in a dead zone.
InDeadZone(DateTime,DateTime,dbiScheduleItem,Boolean) | Determines if a timespan (start date to end date) is in a dead zone for a specific dbiScheduleItem.
InDeadZone(dbiGuideLine) | Determines if a dbiGuideLine is in a dead zone.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Miscellaneous Features


%%PageItemTitle%%

InDeadZone(dbiTimeBarItem,dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InDeadZone Method : InDeadZone(dbiTimeBarItem,dbiScheduleItem) Method

objTimeBar
The dbiTimebarItem to evaluate.
objItem
The dbiScheduleItem containing the Timebar being evaluated.
Determines if a dbiTimebarItem is in a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim objItem As dbiScheduleItem
Dim value As System.Boolean

value = instance.InDeadZone(objTimeBar, objItem)
C#
public System.bool InDeadZone(
   dbiTimeBarItem objTimeBar,
   dbiScheduleItem objItem
)

Parameters

objTimeBar
The dbiTimebarItem to evaluate.
objItem
The dbiScheduleItem containing the Timebar being evaluated.

Return Value

A Boolean value indicating if the dbiTimebarItem is in a dead zone.

Example

Visual Basic Copy Code
Dim booDeadZone As Boolean
booDeadZone = Me.dbiSchedule1.InDeadZone(objTimebarItem, objScheduleItem)
C# Copy Code
bool booDeadZone;
booDeadZone = this.dbiSchedule1.InDeadZone(objTimebarItem, objScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List
Miscellaneous Features


%%PageItemTitle%%

InDeadZone(dbiAppointmentItem,dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InDeadZone Method : InDeadZone(dbiAppointmentItem,dbiScheduleItem) Method

objTimeBar
The dbiAppointmentItem to evaluate.
objItem
The dbiScheduleItem containing the appointment being evaluated.
Determines if a dbiAppointmentItem is in a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiAppointmentItem
Dim objItem As dbiScheduleItem
Dim value As System.Boolean

value = instance.InDeadZone(objTimeBar, objItem)
C#
public System.bool InDeadZone(
   dbiAppointmentItem objTimeBar,
   dbiScheduleItem objItem
)

Parameters

objTimeBar
The dbiAppointmentItem to evaluate.
objItem
The dbiScheduleItem containing the appointment being evaluated.

Return Value

A Boolean value indicating if the dbiAppointmentItem is in a dead zone.

Example

Visual Basic Copy Code
Dim booDeadZone as Boolean
booDeadZone = Me.dbiSchedule1.InDeadZone(objAppointmentItem, objScheduleItem)
C# Copy Code
bool booDeadZone;
booDeadZone = this.dbiSchedule1.InDeadZone(objAppointmentItem, objScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List
Miscellaneous Features


%%PageItemTitle%%

InDeadZone(DateTime,DateTime,dbiScheduleItem,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InDeadZone Method : InDeadZone(DateTime,DateTime,dbiScheduleItem,Boolean) Method

dtBarStart
The start date time to test against.
dtBarEnd
The end date time to test against.
objItem
The dbiScheduleItem to test on.
bGuideLine
Is this instance a guideline. This is for internal code or if the start date and end date share the same value.
Determines if a timespan (start date to end date) is in a dead zone for a specific dbiScheduleItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim dtBarStart As System.Date
Dim dtBarEnd As System.Date
Dim objItem As dbiScheduleItem
Dim bGuideLine As System.Boolean
Dim value As System.Boolean

value = instance.InDeadZone(dtBarStart, dtBarEnd, objItem, bGuideLine)
C#
public System.bool InDeadZone(
   System.DateTime dtBarStart,
   System.DateTime dtBarEnd,
   dbiScheduleItem objItem,
   System.bool bGuideLine
)

Parameters

dtBarStart
The start date time to test against.
dtBarEnd
The end date time to test against.
objItem
The dbiScheduleItem to test on.
bGuideLine
Is this instance a guideline. This is for internal code or if the start date and end date share the same value.

Return Value

Boolean - True if that timespan will conflict with a dbiCustomArea that is flagged as a deadzone.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

InDeadZone(dbiGuideLine) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InDeadZone Method : InDeadZone(dbiGuideLine) Method

objGuideLine
The dbiGuideLine to test against dead zones.
Determines if a dbiGuideLine is in a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objGuideLine As dbiGuideLine
Dim value As System.Boolean

value = instance.InDeadZone(objGuideLine)
C#
public System.bool InDeadZone(
   dbiGuideLine objGuideLine
)

Parameters

objGuideLine
The dbiGuideLine to test against dead zones.

Return Value

A Boolean value, indicating if the object is in a dead zone.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

IndexesFromTimeBar Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IndexesFromTimeBar Method

objTimeBar
The dbiTimebarItem to inspect.
Gets the dbiScheduleItem index value and the dbiTimebarItem index value of a given Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As System.Drawing.Point

value = instance.IndexesFromTimeBar(objTimeBar)
C#
public System.Drawing.Point IndexesFromTimeBar(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem to inspect.

Return Value

A System.Drawing.Point value representing the index of the dbiScheduleItem containing the Timebar, and the index value of the Timebar.

Example

The ptIndexValues.X contains the index value of the ScheduleItem containing the Timebar.

The ptIndexValues.Y contains the index value of the Timebar.

Visual Basic Copy Code
Dim ptIndexValues As System.Drawing.Point
ptIndexValues = Me.dbiSchedule1.IndexesFromTimebar(objTimebarItem)
C# Copy Code
System.Drawing.Point ptIndexValues;
ptIndexValues = this.dbiSchedule1.IndexesFromTimebar(objTimebarItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

IndexFromNode Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IndexFromNode Method

nodeFrom
the dbiNodeItem to inspect.
Gets the index value of a node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nodeFrom As dbiNodeItem
Dim value As System.Integer

value = instance.IndexFromNode(nodeFrom)
C#
public System.int IndexFromNode(
   dbiNodeItem nodeFrom
)

Parameters

nodeFrom
the dbiNodeItem to inspect.

Return Value

An Integer value representing the zero-based index value of the dbiNodeItem.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InvalidateControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InvalidateControl Method

The dbiSchedule control will redraw itself.

Overload List

Overload | Description
InvalidateControl() | Using this overload, the dbiSchedule will redraw itself while leaving the schedule scroll bar (the date/time scroll bar) in it's current position.
InvalidateControl(Boolean) | Using this overload and setting bScrollBars to False, the dbiSchedule will redraw itself resetting the schedule scroll bar (the date/time scroll bar) to the beginning of the schedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InvalidateControl() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InvalidateControl Method : InvalidateControl() Method

Using this overload, the dbiSchedule will redraw itself while leaving the schedule scroll bar (the date/time scroll bar) in it's current position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.InvalidateControl()
C#
public void InvalidateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

InvalidateControl(Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > InvalidateControl Method : InvalidateControl(Boolean) Method

bScrollBars
This value determines how the dbiSchedule will redraw itself. Setting this to True will leave the Schedule Scroll Bar where it is, while setting this to False will force the dbiSchedule to redraw with the Schdule Scroll Bar reset to the start date/time of the Schedule.
Using this overload and setting bScrollBars to False, the dbiSchedule will redraw itself resetting the schedule scroll bar (the date/time scroll bar) to the beginning of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim bScrollBars As System.Boolean

instance.InvalidateControl(bScrollBars)
C#
public void InvalidateControl(
   System.bool bScrollBars
)

Parameters

bScrollBars
This value determines how the dbiSchedule will redraw itself. Setting this to True will leave the Schedule Scroll Bar where it is, while setting this to False will force the dbiSchedule to redraw with the Schdule Scroll Bar reset to the start date/time of the Schedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

IsMilestone Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IsMilestone Method

objTimeBar
The dbiTimebarItem to inspect.
Determines if a Timebar item is a milestone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As System.Boolean

value = instance.IsMilestone(objTimeBar)
C#
public System.bool IsMilestone(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem to inspect.

Return Value

A Boolean value, indicating if the Timebar item is a milestone.

Example

Visual Basic Copy Code
Dim booMilestone As Boolean
booMilestone = Me.dbiSchedule.IsMilestone(objTimebarItem)
C# Copy Code
bool booMilestone;
booMilestone = this.dbiSchedule.IsMilestone(objTimebarItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemAt Method

This function will receive a cursor location, and return the dbiScheduleItem located at that position.

Overload List

Overload | Description
ItemAt(Int32,Int32) | This function will receive a cursor location, and return the dbiScheduleItem located at that position.
ItemAt(Point) | This function will receive a cursor location, and return the dbiScheduleItem located at that position.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemAt(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ItemAt Method : ItemAt(Int32,Int32) Method

nX
The x-coordinate to use.
nY
the y-coordinate to use.
This function will receive a cursor location, and return the dbiScheduleItem located at that position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As dbiScheduleItem

value = instance.ItemAt(nX, nY)
C#
public dbiScheduleItem ItemAt(
   System.int nX,
   System.int nY
)

Parameters

nX
The x-coordinate to use.
nY
the y-coordinate to use.

Return Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ItemAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ItemAt Method : ItemAt(Point) Method

ptMouse
Cursor position to test for a dbiScheduleItem
This function will receive a cursor location, and return the dbiScheduleItem located at that position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As dbiScheduleItem

value = instance.ItemAt(ptMouse)
C#
public dbiScheduleItem ItemAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
Cursor position to test for a dbiScheduleItem

Return Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

LineHeight Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineHeight Method

Gets the physical height of a dbiScheduleItem in pixels.

Overload List

Overload | Description
LineHeight(dbiNodeItem) | Gets the physical height of a dbiScheduleItem in pixels.
LineHeight(dbiScheduleItem) | Gets the physical height of a dbiScheduleItem in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineHeight(dbiNodeItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > LineHeight Method : LineHeight(dbiNodeItem) Method

objItem
A dbiNodeItem
Gets the physical height of a dbiScheduleItem in pixels.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.LineHeight(objItem)
C#
public System.int LineHeight(
   dbiNodeItem objItem
)

Parameters

objItem
A dbiNodeItem

Return Value

Integer value representing the height of the NodeItem in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

LineHeight(dbiScheduleItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > LineHeight Method : LineHeight(dbiScheduleItem) Method

objItem
A dbiScheduleItem
Gets the physical height of a dbiScheduleItem in pixels.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiScheduleItem
Dim value As System.Integer

value = instance.LineHeight(objItem)
C#
public System.int LineHeight(
   dbiScheduleItem objItem
)

Parameters

objItem
A dbiScheduleItem

Return Value

Integer value representing the height of the ScheduleItem in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MoveTimeBarEnd Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MoveTimeBarEnd Method

objTimeBar
The dbiTimeBarItem to adjust the values of.
dtDateTime
The DateTime value to assign to the dbiTimeBarItem's End property.
Move the end of a time bar while keeping the original time span of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim dtDateTime As System.Date

instance.MoveTimeBarEnd(objTimeBar, dtDateTime)
C#
public void MoveTimeBarEnd(
   dbiTimeBarItem objTimeBar,
   System.DateTime dtDateTime
)

Parameters

objTimeBar
The dbiTimeBarItem to adjust the values of.
dtDateTime
The DateTime value to assign to the dbiTimeBarItem's End property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MoveTimeBarStart Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MoveTimeBarStart Method

objTimeBar
The dbiTimeBarItem to adjust the values of.
dtDateTime
The DateTime value to assign to the dbiTimeBarItem's Start property.
Move the start of a time bar while keeping the original time span of the time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim dtDateTime As System.Date

instance.MoveTimeBarStart(objTimeBar, dtDateTime)
C#
public void MoveTimeBarStart(
   dbiTimeBarItem objTimeBar,
   System.DateTime dtDateTime
)

Parameters

objTimeBar
The dbiTimeBarItem to adjust the values of.
dtDateTime
The DateTime value to assign to the dbiTimeBarItem's Start property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NodeFromIndex Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NodeFromIndex Method

nIndex
A System.Integer representing the index of the dbiScheduleItem.
Returns a dbiScheduleItem given the index value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nIndex As System.Integer
Dim value As dbiScheduleItem

value = instance.NodeFromIndex(nIndex)
C#
public dbiScheduleItem NodeFromIndex(
   System.int nIndex
)

Parameters

nIndex
A System.Integer representing the index of the dbiScheduleItem.

Return Value

The dbiScheduleItem that contains the specified Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NodeFromTimeBar Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NodeFromTimeBar Method

objTimeBar
The dbiTimebarItem to inspect.
Gets the dbiScheduleItem associated with a specified dbiTimebarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As dbiScheduleItem

value = instance.NodeFromTimeBar(objTimeBar)
C#
public dbiScheduleItem NodeFromTimeBar(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem to inspect.

Return Value

The dbiScheduleItem that contains the specified Timebar.

Example

Visual Basic Copy Code
Dim newScheduleItem As Dbi.WinControl.Schedule.dbiScheduleItem
newScheduleItem = Me.DbiSchedule1.NodeFromTimebar(objTimebarItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;
newScheduleItem = this.dbiSchedule1.NodeFromTimebar(e.TimebarItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NodeToScheduleItem Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NodeToScheduleItem Method

objSource
The dbiNodeItem to convert.
Converts a dbiNodeItem to a dbiScheduleItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objSource As dbiNodeItem
Dim value As dbiScheduleItem

value = instance.NodeToScheduleItem(objSource)
C#
public dbiScheduleItem NodeToScheduleItem(
   dbiNodeItem objSource
)

Parameters

objSource
The dbiNodeItem to convert.

Return Value

A dbiScheduleItem object.

Remarks

The dbiNodeItem is part of the dbi.dll. dbiScheduleItem is inherited from the dbiNodeItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using the Schedule Items List Area


%%PageItemTitle%%

PaintBackground Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PaintBackground Method

Paints individual backgrounds on a specific graphics handle.

Overload List

Overload | Description
PaintBackground(Graphics,Rectangle,Color,Color,enumFillType) | Paints individual backgrounds on a specific graphics handle.
PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType) | Paints individual backgrounds on a specific graphics handle.
PaintBackground(Graphics,Rectangle,Color,Color,enumFillType,enumBorderType,Color) | Paints individual backgrounds and border on a specific graphics handle.
PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType,enumBorderType,Color) | Paints individual backgrounds and border on a specific graphics handle.

Remarks

We provide this method so our users can fill their own areas with our custom fill types as not all versions of the .NET graphics support all the fills.

Requirements

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PaintBackground(Graphics,Rectangle,Color,Color,enumFillType) Method
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PaintBackground Method : PaintBackground(Graphics,Rectangle,Color,Color,enumFillType) Method

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
Paints individual backgrounds on a specific graphics handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim graphics As System.Drawing.Graphics
Dim rcRect As System.Drawing.Rectangle
Dim clrFrom As System.Drawing.Color
Dim clrTo As System.Drawing.Color
Dim enumFill As enumFillType

instance.PaintBackground(graphics, rcRect, clrFrom, clrTo, enumFill)
C#
public new void PaintBackground(
   System.Drawing.Graphics graphics,
   System.Drawing.Rectangle rcRect,
   System.Drawing.Color clrFrom,
   System.Drawing.Color clrTo,
   enumFillType enumFill
)

Parameters

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType) Method
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PaintBackground Method : PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType) Method

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrMiddle
The System.Drawing.Color that is the tertiary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
Paints individual backgrounds on a specific graphics handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim graphics As System.Drawing.Graphics
Dim rcRect As System.Drawing.Rectangle
Dim clrFrom As System.Drawing.Color
Dim clrMiddle As System.Drawing.Color
Dim clrTo As System.Drawing.Color
Dim enumFill As enumFillType

instance.PaintBackground(graphics, rcRect, clrFrom, clrMiddle, clrTo, enumFill)
C#
public new void PaintBackground(
   System.Drawing.Graphics graphics,
   System.Drawing.Rectangle rcRect,
   System.Drawing.Color clrFrom,
   System.Drawing.Color clrMiddle,
   System.Drawing.Color clrTo,
   enumFillType enumFill
)

Parameters

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrMiddle
The System.Drawing.Color that is the tertiary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PaintBackground(Graphics,Rectangle,Color,Color,enumFillType,enumBorderType,Color) Method
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PaintBackground Method : PaintBackground(Graphics,Rectangle,Color,Color,enumFillType,enumBorderType,Color) Method

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
enumBorder
The dbi.enumBorderType fill type to paint.
clrBorderColor
The System.Drawing.Color for the border.
Paints individual backgrounds and border on a specific graphics handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim graphics As System.Drawing.Graphics
Dim rcRect As System.Drawing.Rectangle
Dim clrFrom As System.Drawing.Color
Dim clrTo As System.Drawing.Color
Dim enumFill As enumFillType
Dim enumBorder As enumBorderType
Dim clrBorderColor As System.Drawing.Color

instance.PaintBackground(graphics, rcRect, clrFrom, clrTo, enumFill, enumBorder, clrBorderColor)
C#
public new void PaintBackground(
   System.Drawing.Graphics graphics,
   System.Drawing.Rectangle rcRect,
   System.Drawing.Color clrFrom,
   System.Drawing.Color clrTo,
   enumFillType enumFill,
   enumBorderType enumBorder,
   System.Drawing.Color clrBorderColor
)

Parameters

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
enumBorder
The dbi.enumBorderType fill type to paint.
clrBorderColor
The System.Drawing.Color for the border.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType,enumBorderType,Color) Method
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PaintBackground Method : PaintBackground(Graphics,Rectangle,Color,Color,Color,enumFillType,enumBorderType,Color) Method

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrMiddle
The System.Drawing.Color that is the tertiary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
enumBorder
The dbi.enumBorderType fill type to paint.
clrBorderColor
The System.Drawing.Color for the border.
Paints individual backgrounds and border on a specific graphics handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim graphics As System.Drawing.Graphics
Dim rcRect As System.Drawing.Rectangle
Dim clrFrom As System.Drawing.Color
Dim clrMiddle As System.Drawing.Color
Dim clrTo As System.Drawing.Color
Dim enumFill As enumFillType
Dim enumBorder As enumBorderType
Dim clrBorderColor As System.Drawing.Color

instance.PaintBackground(graphics, rcRect, clrFrom, clrMiddle, clrTo, enumFill, enumBorder, clrBorderColor)
C#
public new void PaintBackground(
   System.Drawing.Graphics graphics,
   System.Drawing.Rectangle rcRect,
   System.Drawing.Color clrFrom,
   System.Drawing.Color clrMiddle,
   System.Drawing.Color clrTo,
   enumFillType enumFill,
   enumBorderType enumBorder,
   System.Drawing.Color clrBorderColor
)

Parameters

graphics
The System.Drawing.Graphics object to render the background image to.
rcRect
The System.Drawing.Rectangle object containing the actual sizes to draw to.
clrFrom
The System.Drawing.Color that is the primary fill color.
clrMiddle
The System.Drawing.Color that is the tertiary fill color.
clrTo
The System.Drawing.Color that is the secondary (fill to) color.
enumFill
The dbi.enumFillType fill type to paint.
enumBorder
The dbi.enumBorderType fill type to paint.
clrBorderColor
The System.Drawing.Color for the border.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Print Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Print Method

Prints the dbiSchedule.

Overload List

Overload | Description
Print() | Prints the dbiSchedule.
Print(PrintDialog) | Prints the dbiSchedule to the specified System.Windows.Forms.PrintDialog.
Print(PrinterSettings) | Prints the dbiSchedule to the specified System.Drawing.Printing.PrinterSettings.

Example

Visual Basic Copy Code
Dim booPrint As Boolean
booPrint = Me.dbiSchedule.Print()
C# Copy Code
bool booPrint;
booPrint = this.dbiSchedule.Print();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

Print() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Print Method : Print() Method

Prints the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Print()
C#
public System.bool Print()

Return Value

A Boolean value, indicating the print was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Print(PrintDialog) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Print Method : Print(PrintDialog) Method

printDialog
System.Windows.Forms.PrintDialog
Prints the dbiSchedule to the specified System.Windows.Forms.PrintDialog.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim printDialog As System.Windows.Forms.PrintDialog

instance.Print(printDialog)
C#
public void Print(
   System.Windows.Forms.PrintDialog printDialog
)

Parameters

printDialog
System.Windows.Forms.PrintDialog

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Print(PrinterSettings) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Print Method : Print(PrinterSettings) Method

printSettings
System.Drawing.Printing.PrinterSettings
Prints the dbiSchedule to the specified System.Drawing.Printing.PrinterSettings.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim printSettings As System.Drawing.Printing.PrinterSettings

instance.Print(printSettings)
C#
public void Print(
   System.Drawing.Printing.PrinterSettings printSettings
)

Parameters

printSettings
System.Drawing.Printing.PrinterSettings

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PrintPreview Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintPreview Method

Creates a preview of a printed report.

Overload List

Overload | Description
PrintPreview() | Previews the dbiSchedule.
PrintPreview(PrintDialog) | Previews the dbiSchedule using the settings from System.Windows.Forms.PrintDialog.
PrintPreview(PrinterSettings) | Previews the dbiSchedule using the settings from System.Drawing.Printing.PrinterSettings.

Example

Visual Basic Copy Code
Dim booPreview As Boolean
booPreview = Me.dbiSchedule.PrintPreview()
C# Copy Code
bool booPreview;
booPreview = this.dbiSchedule.PrintPreview();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintPreview() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PrintPreview Method : PrintPreview() Method

Previews the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.PrintPreview()
C#
public System.bool PrintPreview()

Return Value

A Boolean value, indicating if the method was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PrintPreview(PrintDialog) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PrintPreview Method : PrintPreview(PrintDialog) Method

printDialog
System.Windows.Forms.PrintDialog
Previews the dbiSchedule using the settings from System.Windows.Forms.PrintDialog.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim printDialog As System.Windows.Forms.PrintDialog

instance.PrintPreview(printDialog)
C#
public void PrintPreview(
   System.Windows.Forms.PrintDialog printDialog
)

Parameters

printDialog
System.Windows.Forms.PrintDialog

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PrintPreview(PrinterSettings) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PrintPreview Method : PrintPreview(PrinterSettings) Method

printSettings
System.Drawing.Printing.PrinterSettings
Previews the dbiSchedule using the settings from System.Drawing.Printing.PrinterSettings.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim printSettings As System.Drawing.Printing.PrinterSettings

instance.PrintPreview(printSettings)
C#
public void PrintPreview(
   System.Drawing.Printing.PrinterSettings printSettings
)

Parameters

printSettings
System.Drawing.Printing.PrinterSettings

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ReadXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ReadXMLFile Method

strFileName
The full path and file name of the XML file.
Reads the data from an XML file into dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.ReadXMLFile(strFileName)
C#
public System.bool ReadXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the XML file.

Return Value

A Boolean value, indicating if the read was successful.

Example

Visual Basic Copy Code
Me.dbiSchedule.ReadXMLFile("C:\XMLFile.XML")
C# Copy Code
this.dbiSchedule.ReadXMLFile("C:\XMLFile.XML");

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Redo Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Redo Method

Performs a redo operation on dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Redo()
C#
public System.bool Redo()

Return Value

A Boolean value, indicating if the operation was successful.

Example

Visual Basic Copy Code
Dim booReturn As Boolean
booReturn = Me.dbiSchedule.Redo()
C# Copy Code
bool booReturn;
booReturn = this.dbiSchedule.Redo();

Remarks

When invoked, the last item in the RedoHistory collection will be redone, and then removed from the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Undo/Redo Features


%%PageItemTitle%%

RestoreCell Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RestoreCell Method

Reset internal items required for the edit mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.RestoreCell()
C#
public void RestoreCell()

Remarks

This method should be called by the developer after the user has cancelled an edit operation, when using a custom edit control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerHeight Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerHeight Method

Returns the internally calculated height of the ruler area based on the current control setup.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

value = instance.RulerHeight()
C#
public System.int RulerHeight()

Return Value

Interger

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleAt Method

This function will receive a cursor location, and return the dbiScheduleObject located at that position.

Overload List

Overload | Description
ScheduleAt(Int32) | Uses the X coordinate to get the dbiScheduleObject.
ScheduleAt(Point) | Uses a drawing point to get the dbiSchedule Object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleAt(Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScheduleAt Method : ScheduleAt(Int32) Method

nX
Integer
Uses the X coordinate to get the dbiScheduleObject.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim value As dbiScheduleObject

value = instance.ScheduleAt(nX)
C#
public dbiScheduleObject ScheduleAt(
   System.int nX
)

Parameters

nX
Integer

Return Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScheduleAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScheduleAt Method : ScheduleAt(Point) Method

ptMouse
Current mouse Point
Uses a drawing point to get the dbiSchedule Object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As dbiScheduleObject

value = instance.ScheduleAt(ptMouse)
C#
public dbiScheduleObject ScheduleAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
Current mouse Point

Return Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScheduleDocument Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleDocument Method

Returns a dbiPrintSchedule document object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiPrintSchedule

value = instance.ScheduleDocument()
C#
public dbiPrintSchedule ScheduleDocument()

Remarks

The object returned is inherited from the standard PrintDocument class.

This object can be assigned to the .Document property of a PrintDIalog or PrintPreviewDialog object for custom printing options.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleItemAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleItemAt Method

Returns the area of the dbiSchedule Control at the mouse point provided.

Overload List

Overload | Description
ScheduleItemAt(Int32,Int32) | Returns the area of the dbiSchedule Control at the supplied coordinates
ScheduleItemAt(Point) | Returns the area of the dbiSchedule Control at the mouse point provided.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleItemAt(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScheduleItemAt Method : ScheduleItemAt(Int32,Int32) Method

nX
x-Corodinate to test
nY
y-Coordinate to test
Returns the area of the dbiSchedule Control at the supplied coordinates

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As enumScheduleItem

value = instance.ScheduleItemAt(nX, nY)
C#
public enumScheduleItem ScheduleItemAt(
   System.int nX,
   System.int nY
)

Parameters

nX
x-Corodinate to test
nY
y-Coordinate to test

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScheduleItemAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScheduleItemAt Method : ScheduleItemAt(Point) Method

ptMouse
Point
Returns the area of the dbiSchedule Control at the mouse point provided.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As enumScheduleItem

value = instance.ScheduleItemAt(ptMouse)
C#
public enumScheduleItem ScheduleItemAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
Point

Return Value

enumScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToCell Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollToCell Method

Attempt to scroll a desired cell in to the visible portion of the list area.

Overload List

Overload | Description
ScrollToCell(dbiNodeItem,Int32) | Attempt to scroll a desired cell in to the visible portion of the list area.
ScrollToCell(dbiNodeItem,dbiColumnItem) | Attempt to scroll a desired cell in to the visible portion of the list area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScrollToCell(dbiNodeItem,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToCell Method : ScrollToCell(dbiNodeItem,Int32) Method

objItem
The dbiScheduleItem containing the cell to scroll to.
nColumn
The zero-based index of the dbiColumnItem containing the cell to scroll to
Attempt to scroll a desired cell in to the visible portion of the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.ScrollToCell(objItem, nColumn)
C#
public System.bool ScrollToCell(
   dbiNodeItem objItem,
   System.int nColumn
)

Parameters

objItem
The dbiScheduleItem containing the cell to scroll to.
nColumn
The zero-based index of the dbiColumnItem containing the cell to scroll to

Return Value

Boolean value determining if the scroll was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToCell(dbiNodeItem,dbiColumnItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToCell Method : ScrollToCell(dbiNodeItem,dbiColumnItem) Method

objItem
The dbiScheduleItem containing the cell to scroll to
objColumn
The dbiColumnItem containing the cell to scroll to
Attempt to scroll a desired cell in to the visible portion of the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objItem As dbiNodeItem
Dim objColumn As dbiColumnItem
Dim value As System.Boolean

value = instance.ScrollToCell(objItem, objColumn)
C#
public System.bool ScrollToCell(
   dbiNodeItem objItem,
   dbiColumnItem objColumn
)

Parameters

objItem
The dbiScheduleItem containing the cell to scroll to
objColumn
The dbiColumnItem containing the cell to scroll to

Return Value

Boolean value indicating if the scroll was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToColumn Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollToColumn Method

Attempt to scroll a desired column in to the visible portion of the list area

Overload List

Overload | Description
ScrollToColumn(dbiColumnItem) | Attempt to scroll a desired column in to the visible portion of the list area
ScrollToColumn(Int32) | Attempt to scroll a desired column in to the visible portion of the list area

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScrollToColumn(dbiColumnItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToColumn Method : ScrollToColumn(dbiColumnItem) Method

objColumn
The dbiColumnItem to scroll to
Attempt to scroll a desired column in to the visible portion of the list area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objColumn As dbiColumnItem
Dim value As System.Boolean

value = instance.ScrollToColumn(objColumn)
C#
public System.bool ScrollToColumn(
   dbiColumnItem objColumn
)

Parameters

objColumn
The dbiColumnItem to scroll to

Return Value

Boolean value indicating if the scroll was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToColumn(Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToColumn Method : ScrollToColumn(Int32) Method

nColumn
The zero-based index of the dbiColumnItem to scroll to.
Attempt to scroll a desired column in to the visible portion of the list area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.ScrollToColumn(nColumn)
C#
public System.bool ScrollToColumn(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the dbiColumnItem to scroll to.

Return Value

Boolean value indicating if the scroll was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToDateTime Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollToDateTime Method

Scrolls the dbiSchedule control to the specified date/time value.

Overload List

Overload | Description
ScrollToDateTime(DateTime,Int16) | Scrolls the dbiSchedule control to the specified date/time value.
ScrollToDateTime(DateTime,Int16,dbiScheduleObject) | Scrolls a specific dbiScheduleObject to the supplied DateTime value.

Remarks

This method is only available in the Enterprise Edition.

This dtValue must be between the visible starting and ending time of a schedule. For instance, if a schedule is setup to be from 8:00 am and 4:30 pm with a time type of “Hours”, the schedule will display a time span from 8:00 am to 5:00pm. If the dtValue is a DateTime value of 4:45 pm, the method will return a value of true and adjust the view, even though the requested time is outside the range of the actual schedule.

Moves the position of the horizontal scroll bar in the schedule so that a given DateTime value is visible. If more than one schedule is present, it will start with the first schedule, and cycle through them all to find the appropriate date. If the DateTime value is not found, the method will return a value of False.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using Scroll Bars


%%PageItemTitle%%

ScrollToDateTime(DateTime,Int16) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToDateTime Method : ScrollToDateTime(DateTime,Int16) Method

dtValue
The date/time to move the dbiSchedule to.
nOffset

The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.

Scrolls the dbiSchedule control to the specified date/time value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim dtValue As System.Date
Dim nOffset As System.Short
Dim value As System.Boolean

value = instance.ScrollToDateTime(dtValue, nOffset)
C#
public System.bool ScrollToDateTime(
   System.DateTime dtValue,
   System.short nOffset
)

Parameters

dtValue
The date/time to move the dbiSchedule to.
nOffset

The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.

Return Value

System.Boolean value indicating if the dbiSchedule move was successful.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToDateTime(DateTime,Int16,dbiScheduleObject) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ScrollToDateTime Method : ScrollToDateTime(DateTime,Int16,dbiScheduleObject) Method

dtValue
The date/time to move the dbiSchedule to.
nOffset

The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.

objSched
The dbiScheduleObject to scroll in.
Scrolls a specific dbiScheduleObject to the supplied DateTime value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim dtValue As System.Date
Dim nOffset As System.Short
Dim objSched As dbiScheduleObject
Dim value As System.Boolean

value = instance.ScrollToDateTime(dtValue, nOffset, objSched)
C#
public System.bool ScrollToDateTime(
   System.DateTime dtValue,
   System.short nOffset,
   dbiScheduleObject objSched
)

Parameters

dtValue
The date/time to move the dbiSchedule to.
nOffset

The amount of time segments to use as a buffer from the left side of the schedule when displaying the requested DayeTime value. By default, the requested DateTime value will be displayed as the first time segment in the control. We can move this to the left or right by entering a value to this parameter other than 0.

objSched
The dbiScheduleObject to scroll in.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ScrollToNode Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollToNode Method

objNodeItem
The dbiScheduleItem to scroll to
Attempts to make a specified dbiScheduleItem visible in the list display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objNodeItem As dbiNodeItem
Dim value As System.Boolean

value = instance.ScrollToNode(objNodeItem)
C#
public System.bool ScrollToNode(
   dbiNodeItem objNodeItem
)

Parameters

objNodeItem
The dbiScheduleItem to scroll to

Return Value

boolean value determining the success of the scroll attempt.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedTimeBars Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedTimeBars Method

Gets a collection representing the currently selected Timebars in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As TimeBarItemCollection

value = instance.SelectedTimeBars()
C#
public TimeBarItemCollection SelectedTimeBars()

Return Value

TimebarItemCollection

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SetView Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SetView Method

Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.

Overload List

Overload | Description
SetView(DateTime,DateTime,Int32) | Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.
SetView(DateTime,DateTime,Int32,dbiScheduleObject) | Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SetView(DateTime,DateTime,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > SetView Method : SetView(DateTime,DateTime,Int32) Method

dtStart
The start DateTime to display.
dtEnd
The end DateTime to display.
nMinSize
The desired minimum size of the major time units in the display.
Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim nMinSize As System.Integer
Dim value As enumSetViewReturnCodes

value = instance.SetView(dtStart, dtEnd, nMinSize)
C#
public enumSetViewReturnCodes SetView(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.int nMinSize
)

Parameters

dtStart
The start DateTime to display.
dtEnd
The end DateTime to display.
nMinSize
The desired minimum size of the major time units in the display.

Return Value

an enumerated value indicating the success or failure.

Remarks

In the Standard edition of the control, this method will work against the current ActiveSchedule.

In the Enterprise edition of the control, this method will work against the first schedule in the control's collection. To use the SetView against a different dbiScheduleObject loaded in the control, use the overloaded version here.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

SetView(DateTime,DateTime,Int32,dbiScheduleObject) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > SetView Method : SetView(DateTime,DateTime,Int32,dbiScheduleObject) Method

dtStart
The start DateTime to display.
dtEnd
The end DateTime to display.
nMinSize
The desired minimum size of the major time units in the display.
objSchedule
The dbiScheduleObject to use in the display.
Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim dtStart As System.Date
Dim dtEnd As System.Date
Dim nMinSize As System.Integer
Dim objSchedule As dbiScheduleObject
Dim value As enumSetViewReturnCodes

value = instance.SetView(dtStart, dtEnd, nMinSize, objSchedule)
C#
public enumSetViewReturnCodes SetView(
   System.DateTime dtStart,
   System.DateTime dtEnd,
   System.int nMinSize,
   dbiScheduleObject objSchedule
)

Parameters

dtStart
The start DateTime to display.
dtEnd
The end DateTime to display.
nMinSize
The desired minimum size of the major time units in the display.
objSchedule
The dbiScheduleObject to use in the display.

Return Value

an enumerated value indicating the success or failure.

Example

** ENTERPRISE ONLY **

This overload of the SetView method is only available in the Enterprise edition of the control. It can be used against any of the dbiScheduleObjects currently loaded in the control's Schedules property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Sort Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Sort Method

Sort the data of the list portion of the control. Method to sort the dbiListControl

Overload List

Overload | Description
Sort() | Sort the data of the list portion of the control. (Inherited from Dbi.WinControl.DbiListControl)
Sort(Int32) | Will sort the list based on the 0-based column parameter. The SortColumn Property will change to reflect the value entered here. (Inherited from Dbi.WinControl.DbiListControl)
Sort(Int32,Int32) | Sort the data of the list portion of the control. (Inherited from Dbi.WinControl.DbiListControl)
Sort(Int32[]) | Will sort the list based on the column(s) passed in the array parameter. The SortColumn Property will change to reflect the first column value entered here. (Inherited from Dbi.WinControl.DbiListControl)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Sorting Schedule Items


%%PageItemTitle%%

TimeBarConflicts Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarConflicts Method

Gets a collection of time bars that conflict with a specified time bar.

Overload List

Overload | Description
TimeBarConflicts(dbiTimeBarItem,dbiScheduleItem) | Gets a collection of Timebars which conflicts with a specified Timebar within a given item.
TimeBarConflicts(dbiTimeBarItem) | Gets a collection of Timebars which conflicts with a specified Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Displaying and Determining Timebar Conflicts


%%PageItemTitle%%

TimeBarConflicts(dbiTimeBarItem,dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > TimeBarConflicts Method : TimeBarConflicts(dbiTimeBarItem,dbiScheduleItem) Method

objTimeBar
The dbiTimebarItem to evaluate.
objItem
The dbiScheduleItem to evaluate.
Gets a collection of Timebars which conflicts with a specified Timebar within a given item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim objItem As dbiScheduleItem
Dim value As TimeBarItemCollection

value = instance.TimeBarConflicts(objTimeBar, objItem)
C#
public TimeBarItemCollection TimeBarConflicts(
   dbiTimeBarItem objTimeBar,
   dbiScheduleItem objItem
)

Parameters

objTimeBar
The dbiTimebarItem to evaluate.
objItem
The dbiScheduleItem to evaluate.

Return Value

A TimebarItemCollection object containing all of the conflicting Timebars.

Example

The following code can be placed in the BeforeTimebarSize event.
Visual Basic Copy Code
Dim tbcTimebars As Dbi.WinControl.Schedule.TimebarItemCollection
tbcTimebars = Me.DbiSchedule1.TimebarConflicts(e.TimebarItem, e.ScheduleItem)

If tbcTimebars.Count &gt; 0 Then  'Timebar overlaps another time bar
    e.AllowSize = False
End If
C# Copy Code
Dbi.WinControl.Schedule.TimebarItemCollection tbcTimebars;
tbcTimebars = this.dbiSchedule1.TimebarConflicts(e.TimebarItem, e.ScheduleItem);

If (tbcTimebars.Count &gt; 0); //Timebar overlaps another time bar
    e.AllowSize = false;

Remarks

This method will check a single schedule item for any conflicts to the given Timebar. A conflict will be determined by the start date/time and end date/time.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

TimeBarConflicts(dbiTimeBarItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > TimeBarConflicts Method : TimeBarConflicts(dbiTimeBarItem) Method

objTimeBar
The dbiTimebarItem to evaluate.
Gets a collection of Timebars which conflicts with a specified Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objTimeBar As dbiTimeBarItem
Dim value As TimeBarItemCollection

value = instance.TimeBarConflicts(objTimeBar)
C#
public TimeBarItemCollection TimeBarConflicts(
   dbiTimeBarItem objTimeBar
)

Parameters

objTimeBar
The dbiTimebarItem to evaluate.

Return Value

A TimebarItemCollection object containing all of the conflicting Timebars.

Example

The following code can be placed in the BeforeTimebarMove event.
Visual Basic Copy Code
Dim tbcTimebars As Dbi.WinControl.Schedule.TimebarItemCollection
tbcTimebars = Me.DbiSchedule1.TimebarConflicts(e.TimebarItem)

If tbcTimebars.Count &gt; 0 Then  'Timebar overlaps another time bar
    e.AllowMove = False
End If
C# Copy Code
Dbi.WinControl.Schedule.TimebarItemCollection tbcTimebars;
tbcTimebars = this.dbiSchedule1.TimebarConflicts(e.TimebarItem);

If (tbcTimebars.Count &gt; 0); //Timebar overlaps another time bar
    e.AllowMove = false;

Remarks

This method will check the entire schedule object any conflicts to the given Timebar. A conflict will be determined by the start date/time and end date/time.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

TimeBarsAfterSchedule Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarsAfterSchedule Method

objSched
The dbiScheduleObject to test.
objItem
The dbiScheduleItem to test
bInSchedule
A boolean to specify if the TimeBars must exist within the end boundary of the dbiScheduleObject or not.
This function returns a collection of timebars that exist after the visible area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objSched As dbiScheduleObject
Dim objItem As dbiScheduleItem
Dim bInSchedule As System.Boolean
Dim value As TimeBarItemCollection

value = instance.TimeBarsAfterSchedule(objSched, objItem, bInSchedule)
C#
public TimeBarItemCollection TimeBarsAfterSchedule(
   dbiScheduleObject objSched,
   dbiScheduleItem objItem,
   System.bool bInSchedule
)

Parameters

objSched
The dbiScheduleObject to test.
objItem
The dbiScheduleItem to test
bInSchedule
A boolean to specify if the TimeBars must exist within the end boundary of the dbiScheduleObject or not.

Return Value

TimeBarItemCollection

Remarks

The TimeBars returned will be in the same order as how they were added to the dbiScheduleItem.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarsAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarsAt Method

This function will receive a cursor location, and return a TimeBarItemCollection.

Overload List

Overload | Description
TimeBarsAt(Int32,Int32) | This function will receive a cursor location, and return a TimeBarItemCollection.
TimeBarsAt(Point) | This function will receive a cursor location, and return a TimeBarItemCollection.

Remarks

The top most time bar will be the first item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarsAt(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > TimeBarsAt Method : TimeBarsAt(Int32,Int32) Method

nX
The x-coordinate to use.
nY
the y-coordinate to use.
This function will receive a cursor location, and return a TimeBarItemCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As TimeBarItemCollection

value = instance.TimeBarsAt(nX, nY)
C#
public TimeBarItemCollection TimeBarsAt(
   System.int nX,
   System.int nY
)

Parameters

nX
The x-coordinate to use.
nY
the y-coordinate to use.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

TimeBarsAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > TimeBarsAt Method : TimeBarsAt(Point) Method

ptMouse
Cursor position to test for TimeBars
This function will receive a cursor location, and return a TimeBarItemCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptMouse As System.Drawing.Point
Dim value As TimeBarItemCollection

value = instance.TimeBarsAt(ptMouse)
C#
public TimeBarItemCollection TimeBarsAt(
   System.Drawing.Point ptMouse
)

Parameters

ptMouse
Cursor position to test for TimeBars

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

TimeBarsBeforeSchedule Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarsBeforeSchedule Method

objSched
The dbiScheduleObject to test.
objItem
The dbiScheduleItem to test
bInSchedule
A boolean to specify if the TimeBars must exist within the start boundary of the dbiScheduleObject or not.
This function returns a collection of timebars that exist before the visible area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim objSched As dbiScheduleObject
Dim objItem As dbiScheduleItem
Dim bInSchedule As System.Boolean
Dim value As TimeBarItemCollection

value = instance.TimeBarsBeforeSchedule(objSched, objItem, bInSchedule)
C#
public TimeBarItemCollection TimeBarsBeforeSchedule(
   dbiScheduleObject objSched,
   dbiScheduleItem objItem,
   System.bool bInSchedule
)

Parameters

objSched
The dbiScheduleObject to test.
objItem
The dbiScheduleItem to test
bInSchedule
A boolean to specify if the TimeBars must exist within the start boundary of the dbiScheduleObject or not.

Remarks

The TimeBars returned will be in the same order as how they were added to the dbiScheduleItem.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Undo Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Undo Method

Performs an undo operation on dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Undo()
C#
public System.bool Undo()

Return Value

A boolean value.

Example

Visual Basic Copy Code
Dim booReturn As Boolean
booReturn = Me.dbiSchedule.Undo()
C# Copy Code
bool booReturn;
booReturn = this.dbiSchedule.Undo();

Remarks

When invoked, the last item in the UndoHistory collection will be undone, and placed into the RedoHistory item collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Undo/Redo Features


%%PageItemTitle%%

WriteXMLData Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WriteXMLData Method

strFileName

String - fully qualified filename used to write the data.

Writes only the data elements of the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLData(strFileName)
C#
public System.bool WriteXMLData(
   System.string strFileName
)

Parameters

strFileName

String - fully qualified filename used to write the data.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WriteXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WriteXMLFile Method

Writes the data in dbiSchedule to an XML file.

Overload List

Overload | Description
WriteXMLFile(String) | Writes the dbiSchedule Control to an XML file.
WriteXMLFile(String,enumXMLExportType) | Writes parts of the dbiSchedule Control to an XML file.

Example

Visual Basic Copy Code
Me.dbiSchedule.WriteXMLFile("C:\XMLFile.XML")
C# Copy Code
this.dbiSchedule.WriteXMLFile("C:\\XMLFile.XML");

Remarks

If no extension is provided in the strFileName parameter, the default extension is .XML

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WriteXMLFile(String) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > WriteXMLFile Method : WriteXMLFile(String) Method

strFileName
The fully qualified name of the file to write.
Writes the dbiSchedule Control to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The fully qualified name of the file to write.

Return Value

Boolean - True if the write was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

WriteXMLFile(String,enumXMLExportType) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > WriteXMLFile Method : WriteXMLFile(String,enumXMLExportType) Method

strFileName
The fully qualified name of the file to write.
enumType
enumXMLExportType - determines the content of the XML file.
Writes parts of the dbiSchedule Control to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim strFileName As System.String
Dim enumType As enumXMLExportType
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName, enumType)
C#
public System.bool WriteXMLFile(
   System.string strFileName,
   enumXMLExportType enumType
)

Parameters

strFileName
The fully qualified name of the file to write.
enumType
enumXMLExportType - determines the content of the XML file.

Return Value

Boolean - True if the write was successful.

Remarks

The XML structure is proprietary to the control, modifying the contents may cause undesirable results. The ReadXMLFile doesn't need an overload it can read and parse any of the enums automatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ActiveSchedule Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ActiveSchedule Property

Gets or sets the active schedule in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ActiveSchedule = value

value = instance.ActiveSchedule
C#
public System.int ActiveSchedule {get; set;}

Property Value

An Integer value.

Example

This property can only be set programmatically.
Visual Basic Copy Code
Me.dbiSchedule.ActiveSchedule = 0
C# Copy Code
this.dbiSchedule.ActiveSchedule = 0;

Remarks

When this property is defined, the active schedule is moved to be visible in the schedule area.

This property must be set in the Standard Edition. By default, all schedules are active in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Setting Up Different Views
Schedules


%%PageItemTitle%%

AlignmentLineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlignmentLineColor Property

Determines the color used to paint the AlignmentLines when they are shown.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.AlignmentLineColor = value

value = instance.AlignmentLineColor
C#
public virtual System.Drawing.Color AlignmentLineColor {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AlignmentLines Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlignmentLines Property

Determines if alignment lines will be drawn as the user interacts with dbiTimeBarItems in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AlignmentLines = value

value = instance.AlignmentLines
C#
public virtual System.bool AlignmentLines {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowHorzMoves Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowHorzMoves Property

Determines whether time bars can be moved horizontally with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowHorzMoves = value

value = instance.AllowHorzMoves
C#
public virtual System.bool AllowHorzMoves {get; set;}

Property Value

Boolean

Remarks

When this property is set to false, users can still resize the Time Bars horizontally, or move them vertically, if the AllowResizeBars and AllowVertMoves properties are set accordingly.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowItemDrag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowItemDrag Property

Determines if users will be allowed to re-order items in the list by dragging and dropping them within their current level.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowItemDrag = value

value = instance.AllowItemDrag
C#
public System.bool AllowItemDrag {get; set;}

Property Value

Boolean

Remarks

This property will allow for built-in dragging and dropping of dbiNodeItems within their current parent.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowNewBars Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowNewBars Property

Determines whether new time bars can be created in a schedule with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowNewBars = value

value = instance.AllowNewBars
C#
public virtual System.bool AllowNewBars {get; set;}

Property Value

Boolean

Remarks

Setting this property to false, will also prevent users from creating new time bars using AutoDuplicate or by splitting time bars (EditMode = Split).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowResizeBars Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowResizeBars Property

Determines whether new time bars can be resized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowResizeBars = value

value = instance.AllowResizeBars
C#
public virtual System.bool AllowResizeBars {get; set;}

Property Value

Boolean

Remarks

When this property is set to false, users can still move TimeBars horizontally and vertically, depending on the AllowHorzMoves and AllowVertMoves properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowVertMoves Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowVertMoves Property

Determines if Timebars can be moved vertically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowVertMoves = value

value = instance.AllowVertMoves
C#
public virtual System.bool AllowVertMoves {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.AllowVertMoves = True
C# Copy Code
this.dbiSchedule.AllowVertMoves = true;

Remarks

When this property is set to false, users can still move and resize TimeBars horizontally, based on the AllowHorzMoves and AllowResizeBars properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Moving Timebars Vertically
Schedule Edit Modes


%%PageItemTitle%%

AltColorEven Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AltColorEven Property

Determines the background color of an even numbered list item in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.AltColorEven = value

value = instance.AltColorEven
C#
public System.Drawing.Color AltColorEven {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.AltColorEven = System.Drawing.Color.Blue
C# Copy Code
this.dbiSchedule.AltColorEven = System.Drawing.Color.Blue;

Remarks

This property is only applicable when AlternateColor is equal to True. AltColorOdd determines the background color for the odd numbered list items.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AltColorOdd Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AltColorOdd Property

Determines the background color of an odd numbered list item in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.AltColorOdd = value

value = instance.AltColorOdd
C#
public System.Drawing.Color AltColorOdd {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.AltColorOdd = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.AltColorOdd = System.Drawing.Color.White;

Remarks

This property is only applicable when AlternateColor is equal to True. AltColorEven determines the background color for the even numbered list items.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AlternateColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlternateColor Property

Determines whether or not the list items will be drawn with alternating background colors.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AlternateColor = value

value = instance.AlternateColor
C#
public System.bool AlternateColor {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.AlternateColor = True
C# Copy Code
this.dbiSchedule.AlternateColor = true;

Remarks

When true, the even numbered items will be painted with the AltColorEven property and the odd numbered items will be painted with the AltColorOdd property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AlternateItems Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlternateItems Property

Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.AlternateItems = value

value = instance.AlternateItems
C#
public System.int AlternateItems {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.AlternateItems = 2
C# Copy Code
this.dbiSchedule.AlternateItems = 2;

Remarks

This property is only applicable when AlternateColor is equal to true. The background color for the even and odd numbered items are defined by the AltColorEven and AltColorOdd properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ArrowAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ArrowAlign Property

Determines on what side of a column header the sort arrows will be placed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumArrowAlign

instance.ArrowAlign = value

value = instance.ArrowAlign
C#
public enumArrowAlign ArrowAlign {get; set;}

Property Value

A Dbi.WinControl.enumArrowAlign value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ArrowAlign = Dbi.WinControl.enumArrowAlign.Right
C# Copy Code
Me.dbiSchedule.ArrowAlign = Dbi.WinControl.enumArrowAlign.Right;

Remarks

This property is only applicable when the columns are defined as sortable.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ArrowOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ArrowOffset Property

Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.ArrowOffset = value

value = instance.ArrowOffset
C#
public System.Drawing.Point ArrowOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ArrowOffset = New System.Drawing.Point(3,-2)
C# Copy Code
this.dbiSchedule.ArrowOffset = new System.Drawing.Point(3,-2);

Remarks

This property is only applicable when the columns are defined as sortable.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AutoDuplicate Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AutoDuplicate Property

Determines whether a duplicate time bar will be created when the <Shift> key is pressed, and a time bar is clicked and dragged.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AutoDuplicate = value

value = instance.AutoDuplicate
C#
public System.bool AutoDuplicate {get; set;}

Property Value

Boolean

Remarks

This functionality will not work, unless AllowNewBars is set to True.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackColor Property

Determines the background color of the list items section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BackColor = System.Drawing.Color.Grey
C# Copy Code
this.dbiSchedule.BackColor = System.Drawing.Color.Grey

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BackgroundImageLayout Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BarSelectBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarSelectBackColor Property

Gets or sets the background color of the selected Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BarSelectBackColor = value

value = instance.BarSelectBackColor
C#
public virtual System.Drawing.Color BarSelectBackColor {get; set;}

Property Value

System.Drawing.Color

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BarSelectBackColor = System.Drawing.Color.Red
C# Copy Code
this.dbiSchedule.BarSelectBackColor = System.Drawing.Color.Red;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BarSelectBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarSelectBackColorTo Property

Gets or sets the background color to of the selected Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BarSelectBackColorTo = value

value = instance.BarSelectBackColorTo
C#
public virtual System.Drawing.Color BarSelectBackColorTo {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BarSelectBorderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarSelectBorderColor Property

Gets or sets the border color of the selected Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BarSelectBorderColor = value

value = instance.BarSelectBorderColor
C#
public virtual System.Drawing.Color BarSelectBorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BarSelectBorderColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.BarSelectBorderColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BarSelectFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarSelectFillType Property

Gets or sets the background fill pattern of the selected Timebar based on the enumFillType.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.BarSelectFillType = value

value = instance.BarSelectFillType
C#
public virtual enumFillType BarSelectFillType {get; set;}

Property Value

dbi.enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BarSelectForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BarSelectForeColor Property

Gets or sets the forecolor of the selected Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BarSelectForeColor = value

value = instance.BarSelectForeColor
C#
public virtual System.Drawing.Color BarSelectForeColor {get; set;}

Property Value

System.Drawing.Color

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BarSelectForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.BarSelectForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BodyColumnEnd Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BodyColumnEnd Property

Determines the final column for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.BodyColumnEnd = value

value = instance.BodyColumnEnd
C#
public System.int BodyColumnEnd {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BodyColumnEnd = 3
C# Copy Code
this.dbiSchedule.BodyColumnEnd = 3;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BodyColumnStart Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BodyColumnStart Property

Determines the starting column for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.BodyColumnStart = value

value = instance.BodyColumnStart
C#
public System.int BodyColumnStart {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BodyColumnStart = 1
C# Copy Code
this.dbiSchedule.BodyColumnStart = 1;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BodyFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BodyFont Property

Determines the font used to draw the body text of a item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.BodyFont = value

value = instance.BodyFont
C#
public System.Drawing.Font BodyFont {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BodyFont = New System.Drawing.Font("Verdana", 8, FontStyle.Italic)
C# Copy Code
this.dbiSchedule.BodyFont = new System.Drawing.Font("Verdana", 8, FontStyle.Italic);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BodyForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BodyForeColor Property

Determines the color used to paint the body text of an item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BodyForeColor = value

value = instance.BodyForeColor
C#
public System.Drawing.Color BodyForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BodyForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.BodyForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BodyIndent Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BodyIndent Property

Determines the indent of the left margin spacing for the body text in the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.BodyIndent = value

value = instance.BodyIndent
C#
public System.int BodyIndent {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BodyIndent = 5
C# Copy Code
this.dbiSchedule.BodyIndent = 5;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BorderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BorderColor Property

Gets or sets the border color around the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BorderColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.BorderColor = System.Drawing.Color.Black;

Remarks

This property is only applied when BorderType is equal to Regular or RoundedEdge.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BorderType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BorderType Property

Gets or sets the type of border to place around the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.BorderType = value

value = instance.BorderType
C#
public enumBorderType BorderType {get; set;}

Property Value

A dbi.enumBorderType member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BorderType = dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule.BorderType = dbi.enumBorderType.Raised;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BreakChar Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BreakChar Property

Gets or sets the character used to seperate the item text into columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Char

instance.BreakChar = value

value = instance.BreakChar
C#
public System.char BreakChar {get; set;}

Property Value

A Char value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.BreakChar = ";"
C# Copy Code
this.dbiSchedule.BreakChar = ";";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Using the Schedule Items List Area


%%PageItemTitle%%

ClosedSchedules Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ClosedSchedules Property

Determines if dbiTimeBarItems will be restricted to a single dbiScheduleObject inside the control's display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.ClosedSchedules = value

value = instance.ClosedSchedules
C#
public virtual System.bool ClosedSchedules {get; set;}

Property Value

boolean

Remarks

**Available in Enterprise Version Only**

Setting this property to False will "open" the schedules, allowing dbiTimeBarItems to be moved between dbiScheduleObjects.

WARNING: Because dbiTimeBarItems are no longer restricted to the boundries of a dbiScheduleObject, they may become orphaned and lost if a user drags them outside of all current dbiScheduleObjects. It is up to the developer to deal with such occurrances in a manner of their choosing.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Columns Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Columns Property

Gets or sets the columns assigned to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As ColumnItemCollection

value = instance.Columns
C#
public ColumnItemCollection Columns {get;}

Property Value

A ColumnItemCollection representing the links in dbiSchedule.

Remarks

This property enables you to obtain a reference to the columns that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the column collection, see the ColumnItemCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Using the Schedule Items List Area


%%PageItemTitle%%

ComboBox Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ComboBox Property

Returns the dbiComboBox that will be used for editing cells in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiComboBox

value = instance.ComboBox
C#
public dbiComboBox ComboBox {get;}

Property Value

dbiComboBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ControlStyle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ControlStyle Property

Set the appearance of the control to a particular style. By setting this property, the control will set font and color properties consistent with the enumControlStyle Enumeration. Once these properties are set they can be modified to further refine the style or you can skip setting this property and manually set colors and fonts to achieve the style you are looking for. Once this property has been set, it will then revert to default. Setting this property to default has no effect on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumControlStyle

instance.ControlStyle = value

value = instance.ControlStyle
C#
public virtual enumControlStyle ControlStyle {get; set;}

Property Value

enumControlStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Culture Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Culture Property

Gets or sets the culture information specifically for dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Globalization.CultureInfo

instance.Culture = value

value = instance.Culture
C#
public System.Globalization.CultureInfo Culture {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CurrentTimeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CurrentTimeColor Property

Gets or sets the primary color for the current time line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.CurrentTimeColor = value

value = instance.CurrentTimeColor
C#
public virtual System.Drawing.Color CurrentTimeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.CurrentTimeColor = System.Drawing.Color.Khaki
C# Copy Code
this.dbiSchedule.CurrentTimeColor = System.Drawing.Color.Khaki;

Remarks

This property is only applicable when CurrentTimeLine is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CurrentTimeColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CurrentTimeColorTo Property

Gets or sets the secondary color for the current time line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.CurrentTimeColorTo = value

value = instance.CurrentTimeColorTo
C#
public virtual System.Drawing.Color CurrentTimeColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.CurrentTimeColorTo = System.Drawing.Color.WhiteSmoke
C# Copy Code
this.dbiSchedule.CurrentTimeColorTo = System.Drawing.Color.WhiteSmoke;

Remarks

This property is only applicable when CurrentTimeLine is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CurrentTimeLine Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CurrentTimeLine Property

Determines if a time line will be drawn for the current date and time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.CurrentTimeLine = value

value = instance.CurrentTimeLine
C#
public virtual System.bool CurrentTimeLine {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.CurrentTimeLine = True
C# Copy Code
this.dbiSchedule.CurrentTimeLine = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Coloring the Background of a Schedule


%%PageItemTitle%%

CurrentTimeOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CurrentTimeOffset Property

Determines the offset used for displaying the CurrentTimeLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.TimeSpan

instance.CurrentTimeOffset = value

value = instance.CurrentTimeOffset
C#
public virtual System.TimeSpan CurrentTimeOffset {get; set;}

Remarks

This property can be used for synching the CurrentTimeLine with a Date/Time other than the users current system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CurrentTimePosition Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CurrentTimePosition Property

Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumCurrentTimePosition

instance.CurrentTimePosition = value

value = instance.CurrentTimePosition
C#
public virtual enumCurrentTimePosition CurrentTimePosition {get; set;}

Property Value

enumCurrentTimePosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CustomAreas Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CustomAreas Property

Gets the custom areas assigned to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiCustomAreaCollection

value = instance.CustomAreas
C#
public dbiCustomAreaCollection CustomAreas {get;}

Property Value

A dbiPim2.CustomAreaCollection object.

Remarks

This property enables you to obtain a reference to the custom area items that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the custom area collection, see the dbiPim2.CustomAreaCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Coloring the Background of a Schedule
Creating Custom Areas


%%PageItemTitle%%

DateFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DateFormat Property

Defines how DateTime values are formatted and displayed, depending on the culture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
public System.string DateFormat {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.DateFormat = "M/d/yyyy h:mm tt"
C# Copy Code
this.dbiSchedule.DateFormat = "M/d/yyyy h:mm tt"

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Using the Schedule Items List Area


%%PageItemTitle%%

DayMonthOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DayMonthOffset Property

Determines the offset used to calculate the starting day of the week in a monthly ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.DayMonthOffset = value

value = instance.DayMonthOffset
C#
public System.int DayMonthOffset {get; set;}

Property Value

accepts values of 0-6 to determine the offset.

Remarks

This property is only valid when the ScheduleObject's TimeType proeprty is set to months. By default the first day of every week will correspond to the Start Property's day of the week.

Requirements

TimeType = Months

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DayNames Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DayNames Property

Gets or sets the day names in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value() As System.String

instance.DayNames = value

value = instance.DayNames
C#
public virtual System.string[] DayNames {get; set;}

Property Value

A String() value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DayNamesArray As String()
DayNamesArray = New String() {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"}
Me.DbiSchedule.DayNames = DayNamesArray
C# Copy Code
string[] DayNamesArray;
DayNamesArray = new string[] {"Sun", "Mon", "Tue", "Wed", "Thu", "Fri"};
this.dbiSchedule.DayNames = DayNamesArray;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DefaultStyle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DefaultStyle Property

Gets or sets the default Timebar style.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.DefaultStyle = value

value = instance.DefaultStyle
C#
public virtual System.int DefaultStyle {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.DefaultStyle = -1
C# Copy Code
this.dbiSchedule.DefaultStyle = -1;

Remarks

When set to -1, no Timebar style is applied. The properties of the Timebar styles are defined in the dbiTimebarStyle object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DeviceDpi Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayGuideLines Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayGuideLines Property

Determines if the GuideLines are shown in the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.DisplayGuideLines = value

value = instance.DisplayGuideLines
C#
public System.bool DisplayGuideLines {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayHeader Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayHeader Property

Determines whether or not the column headers will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.DisplayHeader = value

value = instance.DisplayHeader
C#
public System.bool DisplayHeader {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.DisplayHeader = True
C# Copy Code
this.dbiSchedule.DisplayHeader = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayListGuide Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayListGuide Property

Determines whether a list guide will appear in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.DisplayListGuide = value

value = instance.DisplayListGuide
C#
public virtual System.bool DisplayListGuide {get; set;}

Remarks

The ListGuide will appear inside the ScheduleArea of the control, when creating or moving TimeBars with the cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayTitle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayTitle Property

Determines whether or not the title will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.DisplayTitle = value

value = instance.DisplayTitle
C#
public System.bool DisplayTitle {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.DisplayTitle = True
C# Copy Code
this.dbiSchedule.DisplayTitle = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DivisionDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DivisionDistance Property

Determines how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.DivisionDistance = value

value = instance.DivisionDistance
C#
public System.int DivisionDistance {get; set;}

Property Value

Integer

Requirements

SnapToDivisions Property must be set to true.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragLineColor Property

Gets or sets the border color of the splitter bar when the mouse clicks it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.DragLineColor = value

value = instance.DragLineColor
C#
public virtual System.Drawing.Color DragLineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.DragLineColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.DragLineColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragTimerInterval Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragTimerInterval Property

Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.DragTimerInterval = value

value = instance.DragTimerInterval
C#
public System.int DragTimerInterval {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditAutoNavigate Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditAutoNavigate Property

Determines if the control will automatically navigate to the next/previous cell when editing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.EditAutoNavigate = value

value = instance.EditAutoNavigate
C#
public System.bool EditAutoNavigate {get; set;}

Property Value

boolean

Remarks

The <return>, <tab> and <shift><tab> keys can be used to navigate the editable cells of the list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditAutoSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditAutoSize Property

Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.EditAutoSize = value

value = instance.EditAutoSize
C#
public System.bool EditAutoSize {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditColumn Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditColumn Property

Returns the dbiColumnItem that contains the cell being edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiColumnItem

value = instance.EditColumn
C#
public dbiColumnItem EditColumn {get;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditMode Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditMode Property

Gets or sets the type of action which can be performed on a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumEditMode

instance.EditMode = value

value = instance.EditMode
C#
public enumEditMode EditMode {get; set;}

Property Value

An enumEditMode member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.EditMode = Dbi.WinControl.Schedule.enumEditMode.Edit
C# Copy Code
this.dbiSchedule.EditMode = Dbi.WinControl.Schedule.enumEditMode.Edit;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating Timebars
Timebar Linking
Schedule Edit Modes


%%PageItemTitle%%

EditNode Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditNode Property

Returns the dbiNodeItem that contains the cell to be edited

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiNodeItem

value = instance.EditNode
C#
public dbiNodeItem EditNode {get;}

Property Value

dbiNodeItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ErasorCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ErasorCursor Property

Allows a custom image to be used in place of the default erase cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ErasorCursor = value

value = instance.ErasorCursor
C#
public virtual System.Drawing.Image ErasorCursor {get; set;}

Property Value

Image

Remarks

You can set the hotspot to a unique point in the image so you can offset the location it uses in the schedule.

Set this to nothing to use the default cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ErasorHotSpot Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ErasorHotSpot Property

Determines the hotspot (point) in the image to use for the cursor pointer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.ErasorHotSpot = value

value = instance.ErasorHotSpot
C#
public virtual System.Drawing.Point ErasorHotSpot {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FillList Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FillList Property

Determines whether the last column in a list will always extend to the edge of the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.FillList = value

value = instance.FillList
C#
public System.bool FillList {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.FillList = True
C# Copy Code
this.dbiSchedule.FillList = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FocusBorder Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FocusBorder Property

Determines if a focus line will be drawn around the selected item in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.FocusBorder = value

value = instance.FocusBorder
C#
public System.bool FocusBorder {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FocusColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FocusColor Property

Determines the color used to paint the FocusBorder

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.FocusColor = value

value = instance.FocusColor
C#
public System.Drawing.Color FocusColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Font = New System.Drawing.Font("Verdana", 10)
C# Copy Code
this.dbiSchedule.Font = new System.Drawing.Font("Verdana", 10);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Resizing a List Item's Height


%%PageItemTitle%%

FooterLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FooterLine Property

Determines if the user drawn footer line is displayed on the bottom of the List in the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.FooterLine = value

value = instance.FooterLine
C#
public System.bool FooterLine {get; set;}

Property Value

System.Boolean

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

FooterLineHeight Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FooterLineHeight Property

Gets or sets the height of a user drawn footer line in the List of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.FooterLineHeight = value

value = instance.FooterLineHeight
C#
public System.int FooterLineHeight {get; set;}

Property Value

System.Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ForeColor Property

Determines the foreground color of the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.ForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GridFrequency Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GridFrequency Property

Gets or sets the distance (in pixels) where a Timebar can be moved or sized to with SnapToGrid enabled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GridFrequency = value

value = instance.GridFrequency
C#
public System.int GridFrequency {get; set;}

Property Value

An Integer value, representing pixels.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.GridFrequency = 15
C# Copy Code
this.dbiSchedule.GridFrequency = 15;

Remarks

This property is only applied when SnapToGrid is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Setting Up Different Views


%%PageItemTitle%%

GuideDashPattern Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideDashPattern Property

An array of real numbers that specifies the lengths of alternating dashes and spaces representing the lines of each GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value() As System.Single

instance.GuideDashPattern = value

value = instance.GuideDashPattern
C#
public System.float[] GuideDashPattern {get; set;}

Property Value

A Float() value.

Example

VB.NET Copy Code
Me.DbiSchedule1.GuideDashPattern = New Single() {3.0F, 3.0F}
C# Copy Code
this.dbiSchedule1.GuideDashPattern = new float[] { 3.0F, 3.0F };

Remarks

The elements in the GuideDashPattern array set the length of each dash and space in the dash pattern. The first element sets the length of a dash, the second element sets the length of a space, the third element sets the length of a dash, and so on. Consequently, each element should be a non-zero positive number.

The length of each dash and space in the dash pattern is the product of the element value in the array and the Width of the GuideLine (or the GuideLineWidth property of the dbiSchedule).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideImageIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideImageIndex Property

Determines the default images used when adding GuideLines to the dbiScheduleObject.GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GuideImageIndex = value

value = instance.GuideImageIndex
C#
public System.int GuideImageIndex {get; set;}

Property Value

Integer

Remarks

Individual images can be set on the dbiGuideLine object.

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideImagePosition Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideImagePosition Property

Determines whether GuideLine images will be in the front or back of the ruler numbers and markers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumGuideImagePosition

instance.GuideImagePosition = value

value = instance.GuideImagePosition
C#
public enumGuideImagePosition GuideImagePosition {get; set;}

Property Value

enumGuideImagePosition

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideImages Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideImages Property

Attaches an ImageList control to the dbiSchedule for use with the GuideLines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ImageList

instance.GuideImages = value

value = instance.GuideImages
C#
public virtual System.Windows.Forms.ImageList GuideImages {get; set;}

Property Value

ImageList

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideImageXOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideImageXOffset Property

Determines the horizontal offset used to calculate the position of the guide line image. This property only applies to the GuideImgeIndex property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GuideImageXOffset = value

value = instance.GuideImageXOffset
C#
public System.int GuideImageXOffset {get; set;}

Property Value

Integer

Remarks

Individual offsets can be set on the dbiGuideLine object.

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideImageYOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideImageYOffset Property

Determines the vertical offset used to calculate the position of the guide line image. This property only applies to the GuideImageIndex property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GuideImageYOffset = value

value = instance.GuideImageYOffset
C#
public System.int GuideImageYOffset {get; set;}

Property Value

Integer

Remarks

Individual offsets can be set on the dbiGuideLine object.

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineColor Property

Determines the default color of the GuideLines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.GuideLineColor = value

value = instance.GuideLineColor
C#
public virtual System.Drawing.Color GuideLineColor {get; set;}

Property Value

Color

Remarks

Individual colors can be set on the dbiGuideLine object.

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineDistance Property

Determines how close the edge of a time bar must be to a GuideLine before the time bar is snapped to the GuideLine location (in pixels). The maximum value is 10 pixels.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GuideLineDistance = value

value = instance.GuideLineDistance
C#
public System.int GuideLineDistance {get; set;}

Property Value

Integer representing the number of pixels away a time bar has to be before it is snapped to a line. The maximum value is 10 pixels.

Requirements

DisplayGuideLines Property must be set to True.

SnapToGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLinePosition Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLinePosition Property

Determines the ZOrder for Guide Lines, relative to the Timebars in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumGuideLinePosition

instance.GuideLinePosition = value

value = instance.GuideLinePosition
C#
public enumGuideLinePosition GuideLinePosition {get; set;}

Property Value

enumGuideLinePosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineWidth Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineWidth Property

Determines the default width of all guide lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.GuideLineWidth = value

value = instance.GuideLineWidth
C#
public System.int GuideLineWidth {get; set;}

Property Value

Integer

Remarks

This property can be overridden for individual GuideLine's, by setting their Width Property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideSelectColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideSelectColor Property

Determines the default color of a selected guide line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.GuideSelectColor = value

value = instance.GuideSelectColor
C#
public virtual System.Drawing.Color GuideSelectColor {get; set;}

Property Value

Color

Requirements

DisplayGuideLines Property must be set to True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderAlign Property

Determines how the text in the column headers will be aligned.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.HeaderAlign = value

value = instance.HeaderAlign
C#
public System.Drawing.ContentAlignment HeaderAlign {get; set;}

Property Value

A ContentAlignment value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderAlign = ContentAlignment.MiddleLeft
C# Copy Code
this.dbiSchedule.HeaderAlign = ContentAlignment.MiddleLeft;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderBackColor Property

Determines the background color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderBackColor = value

value = instance.HeaderBackColor
C#
public virtual System.Drawing.Color HeaderBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderBackColor = System.Drawing.Color.Green
C# Copy Code
this.dbiSchedule.HeaderBackColor = System.Drawing.Color.Green;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderBackColorMiddle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderBackColorMiddle Property

Determines the middle back color of the column header allowing for greater readability with certain fill types.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderBackColorMiddle = value

value = instance.HeaderBackColorMiddle
C#
public virtual System.Drawing.Color HeaderBackColorMiddle {get; set;}

Property Value

System.Drawing.Color

Remarks

Set to Color.Empty to remove this altogether.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderBackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderBackColorTo Property

Determines the secondary background color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderBackColorTo = value

value = instance.HeaderBackColorTo
C#
public virtual System.Drawing.Color HeaderBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderBackColorTo = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.HeaderBackColorTo = System.Drawing.Color.White;

Remarks

This property is only applicable when HeaderFillType is not equal to Solid. The primary background color is defined by the HeaderBackColor property.

This property is applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderBorder Property

Determines the border type for the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.HeaderBorder = value

value = instance.HeaderBorder
C#
public enumBorderType HeaderBorder {get; set;}

Property Value

A dbi.enumBorderType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderBorder = dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule.HeaderBorder = dbi.enumBorderType.Raised;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderColor Property

Determines the default line color for a header defined schedule line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderColor = value

value = instance.HeaderColor
C#
public virtual System.Drawing.Color HeaderColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderDownColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderDownColor Property

Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderDownColor = value

value = instance.HeaderDownColor
C#
public System.Drawing.Color HeaderDownColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderDownColor = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.HeaderDownColor = System.Drawing.Color.White;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderFillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderFillType Property

Determines the pattern used to paint the background of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.HeaderFillType = value

value = instance.HeaderFillType
C#
public enumFillType HeaderFillType {get; set;}

Property Value

A dbi.enumFillType value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderFillType = dbi.enumFillType.Solid
C# Copy Code
this.dbiSchedule.HeaderFillType = dbi.enumFillType.Solid;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderFont Property

Determines the font used for the text in the column headers of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.HeaderFont = value

value = instance.HeaderFont
C#
public System.Drawing.Font HeaderFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
this.dbiSchedule.HeaderFont = New System.Drawing.Font("Verdana", 10)
C# Copy Code
this.dbiSchedule.HeaderFont = new Font("Verdana", 10);

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderForeColor Property

Determines the foreground color of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderForeColor = value

value = instance.HeaderForeColor
C#
public virtual System.Drawing.Color HeaderForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.HeaderForeColor = System.Drawing.Color.Black;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderHeight Property

Determines the height of the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HeaderHeight = value

value = instance.HeaderHeight
C#
public System.int HeaderHeight {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderHeight = 40
C# Copy Code
this.dbiSchedule.HeaderHeight = 40;

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderImageOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderImageOffset Property

Determines the value used to calculate the horizontal and vertical position of the images within the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.HeaderImageOffset = value

value = instance.HeaderImageOffset
C#
public System.Drawing.Point HeaderImageOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderImageOffset = New System.Drawing.Point(2,5)
C# Copy Code
this.dbiSchedule.HeaderImageOffset = new System.Drawing.Point(2,5);

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderLine Property

Determines if the user drawn header line is displayed on the top of the List in the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.HeaderLine = value

value = instance.HeaderLine
C#
public System.bool HeaderLine {get; set;}

Property Value

System.Boolean

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

HeaderLineHeight Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderLineHeight Property

Gets or sets the height of a user drawn header line in the List of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HeaderLineHeight = value

value = instance.HeaderLineHeight
C#
public System.int HeaderLineHeight {get; set;}

Property Value

System.Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

HeaderOverColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderOverColor Property

Determines the color used to paint background when the mouse pointer is over the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HeaderOverColor = value

value = instance.HeaderOverColor
C#
public System.Drawing.Color HeaderOverColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderOverColor = System.Drawing.Color.LightSteel
C# Copy Code
this.dbiSchedule.HeaderOverColor = System.Drawing.Color.LightSteel;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderStyle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderStyle Property

Determines the style of the column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumStyle

instance.HeaderStyle = value

value = instance.HeaderStyle
C#
public enumStyle HeaderStyle {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderStyle = dbi.WinControl.enumStyle.XP
C# Copy Code
this.dbiSchedule.HeaderStyle = dbi.WinControl.enumStyle.XP;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderTextImageRelation Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderTextImageRelation Property

Determines how the column header position of text and image relate to each other.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.TextImageRelation

instance.HeaderTextImageRelation = value

value = instance.HeaderTextImageRelation
C#
public System.Windows.Forms.TextImageRelation HeaderTextImageRelation {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderTextOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderTextOffset Property

Determines the value used to calculate the horizontal and vertical position of the text within the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.HeaderTextOffset = value

value = instance.HeaderTextOffset
C#
public System.Drawing.Point HeaderTextOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HeaderTextOffset = New System.Drawing.Point(3,2)
C# Copy Code
this.dbiSchedule.HeaderTextOffset = new System.Drawing.Point(3,2);

Remarks

This property is only applied when DisplayHeader is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HistorySize Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HistorySize Property

Gets or sets the maximum number of items stored in the Undo/Redo history collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HistorySize = value

value = instance.HistorySize
C#
public System.int HistorySize {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HistorySize = 5
C# Copy Code
this.dbiSchedule.HistorySize = 5;

Remarks

This property is limited to 1 in the Standard Edition. The Enterprise Edition can accept a value greater than 1.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Undo/Redo Features


%%PageItemTitle%%

HorzGridColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzGridColor Property

Determines the color of the horizontal grid lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.HorzGridColor = value

value = instance.HorzGridColor
C#
public System.Drawing.Color HorzGridColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HorzGridColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.HorzGridColor = System.Drawing.Color.Black;

Remarks

This property is only applicable when HorzGridLines is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzGridLines Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzGridLines Property

Determines whether or not horizontal grid lines will be drawn between the items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.HorzGridLines = value

value = instance.HorzGridLines
C#
public System.bool HorzGridLines {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HorzGridLines = True
C# Copy Code
this.dbiSchedule.HorzGridLines = true;

Remarks

When set to true, the color and width of the grid lines are defined by the HorzGridColor and HorzGridWidth properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzGridWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzGridWidth Property

Determines the width of the horizontal grid lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzGridWidth = value

value = instance.HorzGridWidth
C#
public System.int HorzGridWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HorzGridWidth = 2
C# Copy Code
this.dbiSchedule.HorzGridWidth = 2;

Remarks

This property is only applicable when HorzGridLines is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzListLargeChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzListLargeChange Property

Determines the large change when scrolling the list area's Horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzListLargeChange = value

value = instance.HorzListLargeChange
C#
public virtual System.int HorzListLargeChange {get; set;}

Property Value

Integer

Remarks

A large change occurs when clicking in an empty portion of the scroll bar (between the thumb and arrow buttons)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzListSmallChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzListSmallChange Property

Determines the small change when scrolling the list area's Horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzListSmallChange = value

value = instance.HorzListSmallChange
C#
public virtual System.int HorzListSmallChange {get; set;}

Property Value

integer

Remarks

The small change occurs when clicking the arrow buttons on either end of the scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzScheduleLargeChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzScheduleLargeChange Property

Determines the large change when scrolling the schedule area's Horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzScheduleLargeChange = value

value = instance.HorzScheduleLargeChange
C#
public virtual System.int HorzScheduleLargeChange {get; set;}

Property Value

integer

Remarks

A large change occurs when clicking in an empty portion of the scroll bar (between the thumb and arrow buttons)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzScheduleScrollOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzScheduleScrollOffset Property

Determines the offset used to calculate the width of the horizontal scroll bar in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzScheduleScrollOffset = value

value = instance.HorzScheduleScrollOffset
C#
public System.int HorzScheduleScrollOffset {get; set;}

Property Value

Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzScheduleSmallChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzScheduleSmallChange Property

Determines the small change when scrolling the schedule area's Horizontal scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.HorzScheduleSmallChange = value

value = instance.HorzScheduleSmallChange
C#
public virtual System.int HorzScheduleSmallChange {get; set;}

Property Value

integer

Remarks

The small change occurs when clicking the arrow buttons on either end of the scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HorzScrollType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HorzScrollType Property

Determines the horizontal scrolling action for the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumHorzScrollType

instance.HorzScrollType = value

value = instance.HorzScrollType
C#
public enumHorzScrollType HorzScrollType {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.HorzScrollType = dbi.WinControl.enumHorzScrollType.Columns
C# Copy Code
this.dbiSchedule.HorzScrollType = dbi.WinControl.enumHorzScrollType.Columns;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageCheckDisabled Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageCheckDisabled Property

Determines the image used to replace the stock check disabled state checkbox image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ImageCheckDisabled = value

value = instance.ImageCheckDisabled
C#
public System.Drawing.Image ImageCheckDisabled {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageCheckDown Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageCheckDown Property

Determines the image used to replace the stock check down state checkbox image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ImageCheckDown = value

value = instance.ImageCheckDown
C#
public System.Drawing.Image ImageCheckDown {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageCheckUp Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageCheckUp Property

Determines the image used to replace the stock check up state checkbox image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ImageCheckUp = value

value = instance.ImageCheckUp
C#
public System.Drawing.Image ImageCheckUp {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageIntoView Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageIntoView Property

Determines if images applied to timebars as Start and End images will be forced into the display when the respective edge of the timebar is partially outside the view.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumImageIntoView

instance.ImageIntoView = value

value = instance.ImageIntoView
C#
public virtual enumImageIntoView ImageIntoView {get; set;}

Property Value

enumImageIntoView

Remarks

This property affects all time bars in the control, and has the same behavior if the images are assigned to the time bar directly or through a dbitimebarstyle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageList Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageList Property

The image list for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ImageList

instance.ImageList = value

value = instance.ImageList
C#
public virtual System.Windows.Forms.ImageList ImageList {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ImageList = Me.ImageList1
C# Copy Code
this.dbiSchedule.ImageList = Me.ImageList1

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Using the Schedule Items List Area


%%PageItemTitle%%

ImageMinus Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageMinus Property

Determines the image used to replace the stock collapse parent item image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ImageMinus = value

value = instance.ImageMinus
C#
public System.Drawing.Image ImageMinus {get; set;}

Property Value

A System.Drawing.Image value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ImageMinus = System.Drawing.Image.FromFile("C:\MinusNode.bmp")
C# Copy Code
this.dbiSchedule.ImageOpen = System.Drawing.Image.FromFile("C:\\OpenNode.bmp");

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImagePlus Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImagePlus Property

Determines the image used to replace the stock expand parent item image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.ImagePlus = value

value = instance.ImagePlus
C#
public System.Drawing.Image ImagePlus {get; set;}

Property Value

A System.Drawing.Image value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ImagePlus = System.Drawing.Image.FromFile("C:\ImagePlus.bmp")
C# Copy Code
this.dbiSchedule.ImagePlus = System.Drawing.Image.FromFile("C:\\ImagePlus.bmp");

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImageType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImageType Property

Gets or sets the type of image to create with the CreateImage method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumImageType

instance.ImageType = value

value = instance.ImageType
C#
public enumImageType ImageType {get; set;}

Property Value

An enumImageType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ImageType = Dbi.WinControl.Schedule.enumImageType.Bmp
C# Copy Code
this.dbiSchedule.ImageType = Dbi.WinControl.Schedule.enumImageType.Bmp;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating an Image of the Control


%%PageItemTitle%%

InactiveBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InactiveBackColor Property

Determines the color used to paint the background of a selected item when the control no longer has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.InactiveBackColor = value

value = instance.InactiveBackColor
C#
public System.Drawing.Color InactiveBackColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.InactiveBackColor = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.InactiveBackColor = System.Drawing.Color.White;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InactiveForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InactiveForeColor Property

Determines the color used to paint the text of a selected item when the control no longer has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.InactiveForeColor = value

value = instance.InactiveForeColor
C#
public System.Drawing.Color InactiveForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.InactiveForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.InactiveForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

IsMirrored Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemBorder Property

Determines the border type for the items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.ItemBorder = value

value = instance.ItemBorder
C#
public enumBorderType ItemBorder {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ItemBorder = dbi.enumBorderType.Regular
C# Copy Code
this.dbiSchedule.ItemBorder = dbi.enumBorderType.Regular;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemDragColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemDragColor Property

Determines the color of the drag bar when an item is dragged inside the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ItemDragColor = value

value = instance.ItemDragColor
C#
public System.Drawing.Color ItemDragColor {get; set;}

Property Value

Color

Remarks

This property is only used when dragging list items using the internal drag drop functionality, AllowItemDrag.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemDragHeight Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemDragHeight Property

Determines the height of the drag bar when an item is dragged inside the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ItemDragHeight = value

value = instance.ItemDragHeight
C#
public System.int ItemDragHeight {get; set;}

Property Value

integer

Remarks

This property is only used when dragging list items using the internal drag drop functionality, AllowItemDrag.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemHeaderBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemHeaderBackColor Property

Determines the default background color for all Header items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ItemHeaderBackColor = value

value = instance.ItemHeaderBackColor
C#
public System.Drawing.Color ItemHeaderBackColor {get; set;}

Property Value

Color

Remarks

Replaces the older ItemHeaderColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemHeaderForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemHeaderForeColor Property

Determines the default foreground color for all Header items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ItemHeaderForeColor = value

value = instance.ItemHeaderForeColor
C#
public System.Drawing.Color ItemHeaderForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemHeightOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemHeightOffset Property

Gets or sets the vertical offset value used to calculate the height of the items in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ItemHeightOffset = value

value = instance.ItemHeightOffset
C#
public override System.int ItemHeightOffset {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ItemHeightOffset = 10
C# Copy Code
this.dbiSchedule.ItemHeightOffset = 10;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Base Implementation in ItemHeightOffset

Developing with dbiSchedule

Resizing a List Item's Height


%%PageItemTitle%%

Items Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Items Property

Gets the list items in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As ScheduleItemCollection

value = instance.Items
C#
public ScheduleItemCollection Items {get;}

Property Value

A ScheduleItemCollection representing the items in dbiSchedule

Remarks

This property enables you to obtain a reference to the list items that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the item collection, see the ScheduleItemCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using the Schedule Items List Area


%%PageItemTitle%%

LabelEdit Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LabelEdit Property

Determines if a cell will be put in to edit mode automatically, if the user double clicks it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.LabelEdit = value

value = instance.LabelEdit
C#
public System.bool LabelEdit {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LayoutEngine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowAfter Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowAfter Property

Determines the image used to indicate more timebars are after the visible area of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.LineArrowAfter = value

value = instance.LineArrowAfter
C#
public virtual System.Drawing.Image LineArrowAfter {get; set;}

Property Value

Image

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowBefore Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowBefore Property

Determines the image used to indicate more timebars are before the visible area of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.LineArrowBefore = value

value = instance.LineArrowBefore
C#
public virtual System.Drawing.Image LineArrowBefore {get; set;}

Property Value

Image

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowColor Property

Determines the color used to paint the arrows used to indicate additional timebars before or after the visible area of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.LineArrowColor = value

value = instance.LineArrowColor
C#
public virtual System.Drawing.Color LineArrowColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowDisplay Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowDisplay Property

Determines the condition of how a line arrow will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumLineArrowDisplay

instance.LineArrowDisplay = value

value = instance.LineArrowDisplay
C#
public enumLineArrowDisplay LineArrowDisplay {get; set;}

Property Value

enumLineArrowDisplay Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowPosition Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowPosition Property

Determines where the line arrows will be drawn in the schedules, in relation to other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumLineArrowPosition

instance.LineArrowPosition = value

value = instance.LineArrowPosition
C#
public enumLineArrowPosition LineArrowPosition {get; set;}

Property Value

enumLineArrowPosition Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineColor Property

Determines the color of list/tree connector lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.LineColor = value

value = instance.LineColor
C#
public System.Drawing.Color LineColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineType Property

Determines the list/tree connector line type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumLineType

instance.LineType = value

value = instance.LineType
C#
public enumLineType LineType {get; set;}

Property Value

enumLineType Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LinkCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LinkCursor Property

Allows a custom image to be used in place of the default link cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.LinkCursor = value

value = instance.LinkCursor
C#
public virtual System.Drawing.Image LinkCursor {get; set;}

Property Value

Image

Remarks

You can set the hotspot to a unique point in the image so you can offset the location it uses in the schedule.

Set this to nothing to use the default cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LinkHotSpot Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LinkHotSpot Property

Determines the hotspot (point) in the image to use for the cursor pointer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.LinkHotSpot = value

value = instance.LinkHotSpot
C#
public virtual System.Drawing.Point LinkHotSpot {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LinkLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LinkLineColor Property

Gets or sets the default color of the link lines in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.LinkLineColor = value

value = instance.LinkLineColor
C#
public virtual System.Drawing.Color LinkLineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.LinkLineColor = System.Drawing.Black
C# Copy Code
this.dbiSchedule.LinkLineColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Links Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Links Property

Gets the links in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As LinkCollection

value = instance.Links
C#
public LinkCollection Links {get;}

Property Value

A LinkCollection representing the links in dbiSchedule.

Remarks

This property enables you to obtain a reference to the link items that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the item collection, see the LinkCollection for additional information.

The Standard Edition of dbiSchedule supports one-to-one linking. The Enterprise Edition supports one-to-many linking.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListBackColor Property

Gets or sets the background color of the list area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ListBackColor = value

value = instance.ListBackColor
C#
public virtual System.Drawing.Color ListBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ListBackColor = System.Drawing.Color.Silver
C# Copy Code
this.dbiSchedule.ListBarColor = System.Drawing.Color.Silver;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListFont Property

Gets or sets the default font for the list area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.ListFont = value

value = instance.ListFont
C#
public System.Drawing.Font ListFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ListFont = New System.Drawing.Font("Verdana", 10)
C# Copy Code
this.dbiSchedule.ListFont = new System.Drawing.Font("Verdana", 10);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListForeColor Property

Gets or sets the

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ListForeColor = value

value = instance.ListForeColor
C#
public virtual System.Drawing.Color ListForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideColumn Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideColumn Property

Determines the zero-based index of the column that will be used as part of the ListGuide display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideColumn = value

value = instance.ListGuideColumn
C#
public virtual System.int ListGuideColumn {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideDistance Property

Determines how far, in pixels, the cusro needs to be from the ListArea before the ListGuide will display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideDistance = value

value = instance.ListGuideDistance
C#
public virtual System.int ListGuideDistance {get; set;}

Requirements

DisplayListGuide needs to be True.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideInterval Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideInterval Property

Determines the interval (milliseconds) used to cause a fade in effect for the ListGuide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideInterval = value

value = instance.ListGuideInterval
C#
public virtual System.int ListGuideInterval {get; set;}

Property Value

integer

Remarks

A value of 0 is instant.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideOpacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideOpacity Property

Determines the opacity of the ListGuide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideOpacity = value

value = instance.ListGuideOpacity
C#
public virtual System.int ListGuideOpacity {get; set;}

Remarks

Valid values are from 0 - 100, representing the percentage of opacity desired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideWidth Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideWidth Property

Determines the width of the ListGuide.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideWidth = value

value = instance.ListGuideWidth
C#
public virtual System.int ListGuideWidth {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListGuideXPosn Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListGuideXPosn Property

Determines the horizontal coordinate where the ListGuide will be painted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListGuideXPosn = value

value = instance.ListGuideXPosn
C#
public virtual System.int ListGuideXPosn {get; set;}

Property Value

integer

Remarks

A value greater then -1 causes the list guide's position to be static instead of floating.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListScrollBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListScrollBackColor Property

Determines the color used to paint the background of the horizontal scroll bar area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ListScrollBackColor = value

value = instance.ListScrollBackColor
C#
public virtual System.Drawing.Color ListScrollBackColor {get; set;}

Property Value

Color

Remarks

This property is only applicable if the ListScrollViewType Property is set to Block

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListScrollMaximum Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListScrollMaximum Property

Returns the current maximum value of the horizontal scroll bar in the ListArea

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

value = instance.ListScrollMaximum
C#
public virtual System.int ListScrollMaximum {get;}

Property Value

IntegerInteger

Remarks

This property can be combined with the ListScrollViewType property to toggle the current display of the horizontal scroll bar in the list area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListScrollValue Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListScrollValue Property

Gets or sets the horizontal scroll value of the List in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListScrollValue = value

value = instance.ListScrollValue
C#
public System.int ListScrollValue {get; set;}

Property Value

System.Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using Scroll Bars


%%PageItemTitle%%

ListScrollViewType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListScrollViewType Property

Determines the display behavior of the horizontal scroll bar in the ListArea.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumListScrollViewType

instance.ListScrollViewType = value

value = instance.ListScrollViewType
C#
public virtual enumListScrollViewType ListScrollViewType {get; set;}

Property Value

enumListScrollViewType

Remarks

This property can be combined with the ListScrollMaximum property to toggle the current display of the horizontal scroll bar in the list area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListType Property

Determines how the list items will be drawn in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumListType

instance.ListType = value

value = instance.ListType
C#
public enumListType ListType {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ListType = dbi.WinControl.enumListType.ListView
C# Copy Code
this.dbiSchedule.ListType = dbi.WinControl.enumListType.ListView;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListWidth Property

Gets or sets the width of the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ListWidth = value

value = instance.ListWidth
C#
public System.int ListWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.ListWidth = 100
C# Copy Code
this.dbiSchedule.ListWidth = 100;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LockLineHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LockLineHeight Property

Determines if the height of the items can be resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.LockLineHeight = value

value = instance.LockLineHeight
C#
public override System.bool LockLineHeight {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.LockLineHeight = True
C# Copy Code
this.dbiSchedule.LockLineHeight = true;

Remarks

When set to false, the height of the items cannot be adjusted by user interaction.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Base Implementation in LockLineHeight

Developing with dbiSchedule

Resizing a List Item's Height


%%PageItemTitle%%

LockSplitterBar Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LockSplitterBar Property

Determines if the splitter bar can be moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.LockSplitterBar = value

value = instance.LockSplitterBar
C#
public virtual System.bool LockSplitterBar {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.LockSplitterBar = False
C# Copy Code
this.dbiSchedule.LockSplitterBar = false;

Remarks

When set to false, the splitter bar cannot be moved by user interaction.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MapBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MapBorder Property

Gets or sets the type of border to place around the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.MapBorder = value

value = instance.MapBorder
C#
public enumBorderType MapBorder {get; set;}

Property Value

A dbi.enumBorderType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MapBorder = dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule.MapBorder = dbi.enumBorderType.Raised;
Visual Basic Copy Code
Me.dbiSchedule.MapVisible = True
C# Copy Code
this.dbiSchedule.MapVisible = true;

Remarks

This property is only available in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Map Area


%%PageItemTitle%%

MapHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MapHeight Property

Gets or sets the height of the map area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.MapHeight = value

value = instance.MapHeight
C#
public System.int MapHeight {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MapHeight = 50
C# Copy Code
this.dbiSchedule.MapHeight = 50;

Remarks

This property is only available in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Map Area


%%PageItemTitle%%

MapLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MapLineColor Property

Gets or sets the color to place around the current view in the map area of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.MapLineColor = value

value = instance.MapLineColor
C#
public virtual System.Drawing.Color MapLineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MapLineColor = System.Drawing.Color.Red
C# Copy Code
this.dbiSchedule.MapLineColor = System.Drawing.Color.Red;
Visual Basic Copy Code
Me.dbiSchedule.MapVisible = True
C# Copy Code
this.dbiSchedule.MapVisible = true;

Remarks

This property is only available in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Map Area


%%PageItemTitle%%

MapVisible Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MapVisible Property

Determines if the map area will be visible in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.MapVisible = value

value = instance.MapVisible
C#
public virtual System.bool MapVisible {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MapVisible = True
C# Copy Code
this.dbiSchedule.MapVisible = true;

Remarks

This property is only available in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Map Area


%%PageItemTitle%%

Margin Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
C#
public System.Windows.Forms.Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MaskColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MaskColor Property

Gets or sets the mask color for the images in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.MaskColor = value

value = instance.MaskColor
C#
public virtual System.Drawing.Color MaskColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MaskColor = System.Drawing.Color.Red
C# Copy Code
this.dbiSchedule.MaskColor = System.Drawing.Color.Red;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MaxImageHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MaxImageHeight Property

Gets or sets the maximum height of a user created image of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.MaxImageHeight = value

value = instance.MaxImageHeight
C#
public virtual System.int MaxImageHeight {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MaxImageHeight = 300
C# Copy Code
this.dbiSchedule.MaxImageHeight = 300;

Remarks

This property is only applied when it is greater than 0, and the first parameter in the CreateImage method is -1.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating an Image of the Control


%%PageItemTitle%%

MaxImageWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MaxImageWidth Property

Gets or sets the maximum width of a user created image of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.MaxImageWidth = value

value = instance.MaxImageWidth
C#
public virtual System.int MaxImageWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.MaxImageWidth = 350
C# Copy Code
this.dbiSchedule.MaxImageWidth = 350;

Remarks

Remarks
This property is only applied when it is greater than 0, and the first parameter in the CreateImage method is -1.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating an Image of the Control


%%PageItemTitle%%

MaximumSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MaximumSize Property

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MinBarTime Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MinBarTime Property

Gets or sets the minimum time for a Timebar when it is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.TimeSpan

instance.MinBarTime = value

value = instance.MinBarTime
C#
public System.TimeSpan MinBarTime {get; set;}

Property Value

A System.TimeSpan value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The minimum time span for a resized Timebar will be 2 hours.

Visual Basic Copy Code
Me.dbiSchedule.MinBarTime = System.TimeSpan.AddHours(2)
C# Copy Code
this.dbiSchedule.MinBarTime = System.TimeSpan.AddHours(2);

Remarks

This property is only applied to Timebars when they are resized. It will have no effect when Timebars are added to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Schedule Edit Modes


%%PageItemTitle%%

MinimumSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MinimumSize Property

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MonthNames Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MonthNames Property

Gets or sets the names of the months in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value() As System.String

instance.MonthNames = value

value = instance.MonthNames
C#
public virtual System.string[] MonthNames {get; set;}

Property Value

A String() value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim MonthNamesArray As String()
MonthNamesArray = New String() {"Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec" }
Me.DbiSchedule.MonthNames = MonthNamesArray
C# Copy Code
Dim MonthNamesArray As String()
MonthNamesArray = New String() {"Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sept", "Oct", "Nov", "Dec" }
Me.DbiSchedule.MonthNames = MonthNamesArray

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MultiSelect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MultiSelect Property

Determines if the list area will allow a multi-select mode (using ctrl/click and shift/click).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.MultiSelect = value

value = instance.MultiSelect
C#
public System.bool MultiSelect {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NoteImages Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NoteImages Property

The image list for the schedule notes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ImageList

instance.NoteImages = value

value = instance.NoteImages
C#
public virtual System.Windows.Forms.ImageList NoteImages {get; set;}

Property Value

ImageList

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NotesDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NotesDistance Property

Determines the distance separating locked notes on a line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.NotesDistance = value

value = instance.NotesDistance
C#
public System.int NotesDistance {get; set;}

Property Value

integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NotesPosition Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NotesPosition Property

Determines where the schedule notes will be drawn in the schedules, in relation to the other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumNotesPosition

instance.NotesPosition = value

value = instance.NotesPosition
C#
public enumNotesPosition NotesPosition {get; set;}

Property Value

enumNotesPosition Enumeration

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Padding Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Padding Property

Gets or sets padding within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
public System.Windows.Forms.Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PencilCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PencilCursor Property

Allows a custom image to be used in place of the default pencil (create timebar) cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.PencilCursor = value

value = instance.PencilCursor
C#
public virtual System.Drawing.Image PencilCursor {get; set;}

Property Value

Image

Remarks

You can set the hotspot to a unique point in the image so you can offset the location it uses in the schedule.

Set this to nothing to use the default cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PencilHotSpot Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PencilHotSpot Property

Determines the hotspot (point) in the image to use for the cursor pointer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.PencilHotSpot = value

value = instance.PencilHotSpot
C#
public virtual System.Drawing.Point PencilHotSpot {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PercentColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PercentColor Property

Determines the default color of all Percent complete bars rendered inside dbiTimeBarItems

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PercentColor = value

value = instance.PercentColor
C#
public virtual System.Drawing.Color PercentColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PlusMinusStyle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PlusMinusStyle Property

Determines the style used when rendering the Plus/Minus boxes on parent nodes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumPlusMinusStyle

instance.PlusMinusStyle = value

value = instance.PlusMinusStyle
C#
public enumPlusMinusStyle PlusMinusStyle {get; set;}

Property Value

enumerated value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnBackColor Property

Determines the background color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PreColumnBackColor = value

value = instance.PreColumnBackColor
C#
public virtual System.Drawing.Color PreColumnBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnBackColor = System.Drawing.Color.Silver
C# Copy Code
this.dbiSchedule.PreColumnBackColor = System.Drawing.Color.Silver;

Remarks

The background color in a pre-column cell of a selected item is painted with PreSelectBackColor. The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnBackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnBackColorTo Property

Determines the secondary background color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PreColumnBackColorTo = value

value = instance.PreColumnBackColorTo
C#
public virtual System.Drawing.Color PreColumnBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnBackColorTo = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.PreColumnBackColorTo = System.Drawing.Color.White;

Remarks

This property is only applicable when PreColumnFillType is not equal to Solid. The primary background color is defined by the PreColumnBackColor property.

The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnBorder Property

Determines the type of border to place around the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.PreColumnBorder = value

value = instance.PreColumnBorder
C#
public enumBorderType PreColumnBorder {get; set;}

Property Value

A dbi.enumBorderType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnBorder = dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule.PreColumnBorder = dbi.enumBorderType.Raised;

Remarks

The border in a pre-column cell of a selected item is defined by the PreSelectBorder. The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnFillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnFillType Property

Determines the pattern used to paint the background of the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.PreColumnFillType = value

value = instance.PreColumnFillType
C#
public enumFillType PreColumnFillType {get; set;}

Property Value

A dbi.enumFillType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnFillType = dbi.enumFillType.Solid
C# Copy Code
this.dbiSchedule.PreColumnFillType = dbi.enumFillType.Solid;

Remarks

The pre-column area is only visible when PreColumnType is not equal to None. The primary and secondary background colors are defined in the PreColumnBackColor and PreColumnBackColorTo properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnFont Property

Determines the font used for the text in the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.PreColumnFont = value

value = instance.PreColumnFont
C#
public System.Drawing.Font PreColumnFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnFont = New System.Drawing.Font("Verdana", 8)
C# Copy Code
this.dbiSchedule.PreColumnFont = new System.Drawing.Font("Verdana", 8)

Remarks

The pre-column area is only visible when PreColumnType is equal to Number0 or Number1.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnForeColor Property

Determines the foreground color of the pre-column section of a non-selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PreColumnForeColor = value

value = instance.PreColumnForeColor
C#
public virtual System.Drawing.Color PreColumnForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.PreColumnForeColor = System.Drawing.Color.Black;

Remarks

The fore color in a pre-column cell of a selected item is painted with PreSelectForeColor. The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnPicture Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnPicture Property

Determines the picture clip within the pre-column section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.PreColumnPicture = value

value = instance.PreColumnPicture
C#
public System.Drawing.Image PreColumnPicture {get; set;}

Property Value

A System.Drawing.Image value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnPicture = System.Drawing.Image.FromFile("C:\Picture.bmp")
C# Copy Code
this.dbiSchedule.PreColumnPicture = System.Drawing.Image.FromFile("C:\\Picture.bmp");

Remarks

The pre-column area is only visible when PreColumnType is equal to Picture.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnType Property

Determines the pre-column to be used on the list part of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumPreColumnType

instance.PreColumnType = value

value = instance.PreColumnType
C#
public enumPreColumnType PreColumnType {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnType = dbi.WinControl.enumPreColumnType.Arrow
C# Copy Code
this.dbiSchedule.PreColumnType = dbi.WinControl.enumPreColumnType.Arrow;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreColumnWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreColumnWidth Property

Determines the width of the pre-column in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.PreColumnWidth = value

value = instance.PreColumnWidth
C#
public System.int PreColumnWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PreColumnWidth = 10
C# Copy Code
this.dbiSchedule.PreColumnWidth = 10;

Remarks

The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreferredSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreSelectBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreSelectBackColor Property

Determines the background color of the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PreSelectBackColor = value

value = instance.PreSelectBackColor
C#
public virtual System.Drawing.Color PreSelectBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Remarks

The background color of a pre-column cell of a non-selected item is painted with PreColumnBackColor.The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreSelectBorder Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreSelectBorder Property

Determines the type of border to place around the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.PreSelectBorder = value

value = instance.PreSelectBorder
C#
public enumBorderType PreSelectBorder {get; set;}

Remarks

The border of a pre-column cell of a non-selected item is defined by the PreColumnBorder. The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreSelectForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreSelectForeColor Property

Determines the type of border to place around the pre-column section of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PreSelectForeColor = value

value = instance.PreSelectForeColor
C#
public virtual System.Drawing.Color PreSelectForeColor {get; set;}

Remarks

The fore color of a pre-column cell of a non-selected item is painted with PreColumnForeColor. The pre-column area is only visible when PreColumnType is not equal to None.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintBackImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintBackImage Property

Determines if the back image will be visible in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.PrintBackImage = value

value = instance.PrintBackImage
C#
public virtual System.bool PrintBackImage {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintBackImage = False
C# Copy Code
this.dbiSchedule.PrintBackImage = false;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintFitToPage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintFitToPage Property

Determines if the PrintTimeDistance property will be adjusted so the entire control can be printed on a single page.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.PrintFitToPage = value

value = instance.PrintFitToPage
C#
public virtual System.bool PrintFitToPage {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintFitToPage = False
C# Copy Code
this.dbiSchedule.PrintFitToPage = false;

Remarks

When set to true, the PrintTimeDistance property will not be applied.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintFont Property

Gets or sets the font of a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.PrintFont = value

value = instance.PrintFont
C#
public System.Drawing.Font PrintFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintFont = New Font("Verdana",8)
C# Copy Code
this.dbiSchedule.PrintFont = new System.Drawing.Font("Verdana", 8);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintFooterAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintFooterAlign Property

Gets or sets the vertical and horizontal position of the footer in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.PrintFooterAlign = value

value = instance.PrintFooterAlign
C#
public System.Drawing.ContentAlignment PrintFooterAlign {get; set;}

Property Value

A ContentAlignment value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintFooterAlign = System.Drawing.ContentAlignment.MiddleCenter
C# Copy Code
this.dbiSchedule.PrintFooterAlign = System.Drawing.ContentAlignment.MiddleCenter;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintHeaderBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintHeaderBackColor Property

Determines the background color of the column headers in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintHeaderBackColor = value

value = instance.PrintHeaderBackColor
C#
public virtual System.Drawing.Color PrintHeaderBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintHeaderForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintHeaderForeColor Property

Determines the foreground color of the column headers in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintHeaderForeColor = value

value = instance.PrintHeaderForeColor
C#
public virtual System.Drawing.Color PrintHeaderForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintItemBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintItemBackColor Property

Determines the background color of the items in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintItemBackColor = value

value = instance.PrintItemBackColor
C#
public virtual System.Drawing.Color PrintItemBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintItemForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintItemForeColor Property

Determines the foreground color of the items in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintItemForeColor = value

value = instance.PrintItemForeColor
C#
public virtual System.Drawing.Color PrintItemForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintListAlways Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintListAlways Property

Determines whether the list will be printed on every page of a report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.PrintListAlways = value

value = instance.PrintListAlways
C#
public virtual System.bool PrintListAlways {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintListFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintListFormat Property

Gets or sets the type of list to display in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumPrintListFormat

instance.PrintListFormat = value

value = instance.PrintListFormat
C#
public enumPrintListFormat PrintListFormat {get; set;}

Property Value

An enumPrintListFormat member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintListFormat = Dbi.WinControl.Schedule.enumPrintListFormat.Current
C# Copy Code
this.dbiSchedule.PrintListFormat = Dbi.WinControl.Schedule.enumPrintFormat.Current;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintPageControl Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintPageControl Property

Determines if the control should print using the current colors rendered in the control (True) or if the specified "Print" related colors should be used (False).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.PrintPageControl = value

value = instance.PrintPageControl
C#
public virtual System.bool PrintPageControl {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintPageText Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintPageText Property

Gets or sets the text descibing the page number on the report footer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.PrintPageText = value

value = instance.PrintPageText
C#
public virtual System.string PrintPageText {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintPageText = "Page:"
C# Copy Code
this.dbiSchedule.PrintPageText = "Page:";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintReportType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintReportType Property

Determines how dbiSchedule is printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumPrintReportType

instance.PrintReportType = value

value = instance.PrintReportType
C#
public enumPrintReportType PrintReportType {get; set;}

Property Value

An enumPrintReportType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintReportType = Dbi.WinControl.Schedule.enumPrintReportType.Full
C# Copy Code
this.dbiSchedule.PrintReportType = Dbi.WinControl.Schedule.enumPrintReportType.Full;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintSubTitle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintSubTitle Property

Gets or sets the sub-title of a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.PrintSubTitle = value

value = instance.PrintSubTitle
C#
public virtual System.string PrintSubTitle {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintSubTitle = "Sub-Title Schedule Report"
C# Copy Code
this.dbiSchedule.PrintSubTitle = "Sub-Title dbiSchedule Report";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintTimeDistance Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintTimeDistance Property

Gets or sets the distance between the major time segments in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.PrintTimeDistance = value

value = instance.PrintTimeDistance
C#
public virtual System.int PrintTimeDistance {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintTimeDistance = 10
C# Copy Code
this.dbiSchedule.PrintTimeDistance = 10;

Remarks

This property is not applied when PrintFitToPage is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report
Setting Up Different Views


%%PageItemTitle%%

PrintTitle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintTitle Property

Gets or sets the title of a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.PrintTitle = value

value = instance.PrintTitle
C#
public virtual System.string PrintTitle {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintTitle = "Schedule Report"
C# Copy Code
this.dbiSchedule.PrintTitle = "Schedule Report";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintTitleAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintTitleAlign Property

Gets or sets the vertical and horizontal alignment of the title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.PrintTitleAlign = value

value = instance.PrintTitleAlign
C#
public System.Drawing.ContentAlignment PrintTitleAlign {get; set;}

Property Value

A ContentAlignment value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.PrintTitleAlign = System.Drawing.ContentAlignment.MiddleCenter
C# Copy Code
this.dbiSchedule.PrintTitleAlign = System.Drawing.ContentAlignment.MiddleCenter;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Creating a Printed Report


%%PageItemTitle%%

PrintTitleBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintTitleBackColor Property

Determines the background color of the list area title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintTitleBackColor = value

value = instance.PrintTitleBackColor
C#
public virtual System.Drawing.Color PrintTitleBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PrintTitleForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PrintTitleForeColor Property

Determines the foreground color of the list area title in a printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.PrintTitleForeColor = value

value = instance.PrintTitleForeColor
C#
public virtual System.Drawing.Color PrintTitleForeColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RedoHistory Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RedoHistory Property

Gets the redo actions which can be performed on the Timebars in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As HistoryCollection

value = instance.RedoHistory
C#
public HistoryCollection RedoHistory {get;}

Property Value

A HistoryCollection representing the redo actions in dbiSchedule.

Remarks

This property enables you to obtain a reference to the redo actions that are currently stored in redo history collection in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the history collection, see the HistoryCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Undo/Redo Features


%%PageItemTitle%%

RulerAlign Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerAlign Property

Determines the default alignment for the text within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiScheduleObject.enumRulerAlign

instance.RulerAlign = value

value = instance.RulerAlign
C#
public virtual dbiScheduleObject.enumRulerAlign RulerAlign {get; set;}

Property Value

dbiScheduleObject.enumRulerAlign

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerBackColor Property

Determines the default background color of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerBackColor = value

value = instance.RulerBackColor
C#
public virtual System.Drawing.Color RulerBackColor {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerBackColorTo Property

Determines the default secondary background color of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerBackColorTo = value

value = instance.RulerBackColorTo
C#
public virtual System.Drawing.Color RulerBackColorTo {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerBorder Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerBorder Property

Determines the default border type for the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.RulerBorder = value

value = instance.RulerBorder
C#
public enumBorderType RulerBorder {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerFillType Property

Determines the default fill effect used to paint the background of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.RulerFillType = value

value = instance.RulerFillType
C#
public enumFillType RulerFillType {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerFont Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerFont Property

Determines the default font used for rendering the time units in the ruler of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.RulerFont = value

value = instance.RulerFont
C#
public System.Drawing.Font RulerFont {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerForeColor Property

Determines the default foreground color of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerForeColor = value

value = instance.RulerForeColor
C#
public virtual System.Drawing.Color RulerForeColor {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerLineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerLineColor Property

Determines the default line color of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerLineColor = value

value = instance.RulerLineColor
C#
public virtual System.Drawing.Color RulerLineColor {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerSelectColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerSelectColor Property

Determines the background color used to highlight the current start/end, of the selected TimeBar, in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerSelectColor = value

value = instance.RulerSelectColor
C#
public virtual System.Drawing.Color RulerSelectColor {get; set;}

Remarks

Setting this property to a value of Empty, will hide the selected TimeBar from the ruler.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerSelectOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerSelectOffset Property

Determines the vertical offset for displaying the selected TimeBar in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.RulerSelectOffset = value

value = instance.RulerSelectOffset
C#
public virtual System.int RulerSelectOffset {get; set;}

Remarks

By default the selected area will span from the top to the bottom of the ruler. Assigning a positive value (>0) will result in the selected area shifting down, leaving a gap above it. Assigning a negative value (<0) will result in the selected area shifting up, leaving a gap below it.

The display of the selected area is bound to the ruler. Changing the offset will not result in the selected area overlapping any other portion of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerTitleBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerTitleBackColor Property

Determines the default primary background color of the title area of the ruler in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerTitleBackColor = value

value = instance.RulerTitleBackColor
C#
public virtual System.Drawing.Color RulerTitleBackColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerTitleBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerTitleBackColorTo Property

Determines the default secondary background color of the title area of the ruler in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerTitleBackColorTo = value

value = instance.RulerTitleBackColorTo
C#
public virtual System.Drawing.Color RulerTitleBackColorTo {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerTitleFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerTitleFillType Property

Determines the default background fill pattern of the title area of the ruler in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.RulerTitleFillType = value

value = instance.RulerTitleFillType
C#
public enumFillType RulerTitleFillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerTitleFont Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerTitleFont Property

Determines the default font used for the title area of the ruler in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.RulerTitleFont = value

value = instance.RulerTitleFont
C#
public System.Drawing.Font RulerTitleFont {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerTitleForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerTitleForeColor Property

Determines the default foreground color of the title area of the ruler in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.RulerTitleForeColor = value

value = instance.RulerTitleForeColor
C#
public virtual System.Drawing.Color RulerTitleForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SchedAltColorEven Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SchedAltColorEven Property

Determines one of the default alternating line colors for a schedule line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SchedAltColorEven = value

value = instance.SchedAltColorEven
C#
public virtual System.Drawing.Color SchedAltColorEven {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SchedAltColorOdd Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SchedAltColorOdd Property

Determines one of the default alternating line colors for a schedule line.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SchedAltColorOdd = value

value = instance.SchedAltColorOdd
C#
public virtual System.Drawing.Color SchedAltColorOdd {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SchedScrollValue Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SchedScrollValue Property

Gets or sets the horizontal scroll value of the Schedule(s) area in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.SchedScrollValue = value

value = instance.SchedScrollValue
C#
public System.int SchedScrollValue {get; set;}

Property Value

System.Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using Scroll Bars


%%PageItemTitle%%

ScheduleBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleBackColor Property

Determines the default background color of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ScheduleBackColor = value

value = instance.ScheduleBackColor
C#
public virtual System.Drawing.Color ScheduleBackColor {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleLineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleLineColor Property

Determines the default line color of the schedules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ScheduleLineColor = value

value = instance.ScheduleLineColor
C#
public virtual System.Drawing.Color ScheduleLineColor {get; set;}

Remarks

This property is applied to newly created dbiScheduleObjects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Schedules Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Schedules Property

Gets the Schedules in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As ScheduleCollection

value = instance.Schedules
C#
public ScheduleCollection Schedules {get;}

Property Value

A ScheduleCollection representing the schedules in dbiSchedule.

Remarks

This property enables you to obtain a reference to the schedules that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the schedule collection, see the ScheduleCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Schedules


%%PageItemTitle%%

ScrollHorzBuffer Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollHorzBuffer Property

Gets or sets the size of a buffer area in the dbiSchedule horizontal schedule scroll bar where another control can be placed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.ScrollHorzBuffer = value

value = instance.ScrollHorzBuffer
C#
public virtual System.int ScrollHorzBuffer {get; set;}

Property Value

System.Integer

Remarks

This functionality allows for a more integrated feel to the control allowing for different objects such as a slider for zooming or magnifying glass button and textbox combo for searching for Timebars. The size of the buffer will be reflected in the ScrollBufferResize Event so that if the dbiSchedule size changes the controls within can be sized accordingly. This buffer is merely a space reserved by the scroll bar, it is not a container for other controls, as such the controls that are used in that space may need to be moved/sized accordingly during said event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedBackColor Property

Determines the background color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SelectedBackColor = value

value = instance.SelectedBackColor
C#
public virtual System.Drawing.Color SelectedBackColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SelectedBackColor = System.Drawing.Color.Silver
C# Copy Code
this.dbiSchedule.SelectedBackColor = System.Drawing.Color.Silver;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedBackColorTo Property

Determines the second background color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SelectedBackColorTo = value

value = instance.SelectedBackColorTo
C#
public virtual System.Drawing.Color SelectedBackColorTo {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedBorder Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedBorder Property

Determines the type of border to place around the selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.SelectedBorder = value

value = instance.SelectedBorder
C#
public enumBorderType SelectedBorder {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedBorderColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedBorderColor Property

Determines the border color of a selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SelectedBorderColor = value

value = instance.SelectedBorderColor
C#
public virtual System.Drawing.Color SelectedBorderColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedFillType Property

Determines the pattern used to paint the background of the selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.SelectedFillType = value

value = instance.SelectedFillType
C#
public enumFillType SelectedFillType {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedFont Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedFont Property

Determines the font used to draw the text of a selected item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.SelectedFont = value

value = instance.SelectedFont
C#
public System.Drawing.Font SelectedFont {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedForeColor Property

Determines the foreground color of a selected list item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SelectedForeColor = value

value = instance.SelectedForeColor
C#
public virtual System.Drawing.Color SelectedForeColor {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SelectedForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.SelectedForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SelectedStyle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SelectedStyle Property

Determines how the selection will be applied to the selected node(s).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumSelectedStyle

instance.SelectedStyle = value

value = instance.SelectedStyle
C#
public enumSelectedStyle SelectedStyle {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SnapToDivisions Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SnapToDivisions Property

Determines if a time bar will snap to the Minor Time divisions (created with RulerDivisions Property)when they are moved/added/resized using the mouse. Snap to Divisions will not affect programmatically added time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumSnapToDivisions

instance.SnapToDivisions = value

value = instance.SnapToDivisions
C#
public virtual enumSnapToDivisions SnapToDivisions {get; set;}

Property Value

enumSnapToDivisions

Remarks

Note that you should only use one method of snapping either SnapToDivisions Property, SnapToGrid Property or SnapToGuideLines Property. Any combination may cause undesirable results.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SnapToGrid Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SnapToGrid Property

Determines if the Timebars will automatically align to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.SnapToGrid = value

value = instance.SnapToGrid
C#
public virtual System.bool SnapToGrid {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SnapToGrid = True
C# Copy Code
this.dbiSchedule.SnapToGrid = true;

Remarks

When set to true, GridFrequency is used to determine where the Timebars will snap to.

Note that you should only use one method of snapping either SnapToDivisions Property, SnapToGrid Property or SnapToGuideLines Property. Any combination may cause undesirable results.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SnapToGuideLines Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SnapToGuideLines Property

Determines if a time bar will snap to the GuideLines when they are moved/added/resized using the mouse. Snap to GuideLine will not affect programmatically added time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.SnapToGuideLines = value

value = instance.SnapToGuideLines
C#
public virtual System.bool SnapToGuideLines {get; set;}

Property Value

Boolean

Remarks

Note that you should only use one method of snapping either SnapToDivisions Property, SnapToGrid Property or SnapToGuideLines Property. Any combination may cause undesirable results.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SortArrows Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SortArrows Property

Determines whether arrows indicating the direction of the sort order will be displayed in the column headers.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.SortArrows = value

value = instance.SortArrows
C#
public System.bool SortArrows {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SortArrows = True
C# Copy Code
this.dbiSchedule.SortArrows = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SortColumn Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SortColumn Property

Determines the zero-based index of the column whose data a sort will be performed on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.SortColumn = value

value = instance.SortColumn
C#
public System.int SortColumn {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SortDirection Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SortDirection Property

Determines the direction a sort operation will perform.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumSortDirection

instance.SortDirection = value

value = instance.SortDirection
C#
public enumSortDirection SortDirection {get; set;}

Property Value

A dbi.WinControl.enumSortDirection value.

Example

Visual Basic Copy Code
Me.dbiSchedule.SortArrows = True
Me.dbiSchedule.SortDirection = dbi.WinControl.enumSortDirection.Ascending

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Sorted Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Sorted Property

Determines whether the list is currently considered sorted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.Sorted = value

value = instance.Sorted
C#
public System.bool Sorted {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SplitCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SplitCursor Property

Allows a custom image to be used in place of the default split timebar cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.SplitCursor = value

value = instance.SplitCursor
C#
public virtual System.Drawing.Image SplitCursor {get; set;}

Property Value

Image

Remarks

You can set the hotspot to a unique point in the image so you can offset the location it uses in the schedule.

Set this to nothing to use the default cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SplitHotSpot Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SplitHotSpot Property

Determines the hotspot (point) in the image to use for the cursor pointer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.SplitHotSpot = value

value = instance.SplitHotSpot
C#
public virtual System.Drawing.Point SplitHotSpot {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SplitterBarBorder Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SplitterBarBorder Property

Gets or sets the dbi.enumBorderType for the splitter bar in the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.SplitterBarBorder = value

value = instance.SplitterBarBorder
C#
public virtual enumBorderType SplitterBarBorder {get; set;}

Property Value

dbi.enumBorderType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SplitterBarColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SplitterBarColor Property

Gets or sets the color of the splitter bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.SplitterBarColor = value

value = instance.SplitterBarColor
C#
public virtual System.Drawing.Color SplitterBarColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SplitterBarColor = System.Drawing.Color.DimGray
C# Copy Code
this.dbiSchedule.SplitterBarColor = System.Drawing.Color.DimGray;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SplitterBarWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SplitterBarWidth Property

Gets or sets the width of the splitter bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.SplitterBarWidth = value

value = instance.SplitterBarWidth
C#
public virtual System.int SplitterBarWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.SplitterBarWidth = 3
C# Copy Code
this.dbiSchedule.SplitterBarWidth = 3;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TextAntiAlias Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TextAntiAlias Property

Determines if the text within the control will be rendered using the Anti Alias option.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TextAntiAlias = value

value = instance.TextAntiAlias
C#
public System.bool TextAntiAlias {get; set;}

Property Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TextBox Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TextBox Property

Returns the dbiTextBox that will be used for editing cells in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As dbiTextBox

value = instance.TextBox
C#
public dbiTextBox TextBox {get;}

Property Value

dbiTextBox

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TextIntoView Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TextIntoView Property

Determines if the text of a Timebar will always be in view.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TextIntoView = value

value = instance.TextIntoView
C#
public virtual System.bool TextIntoView {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TextIntoView = True
C# Copy Code
this.dbiSchedule.TextIntoView = true;

Remarks

For example, if a portion of the Timebar is in the visible area of the schedule, the text will shift over so that it can be displayed fully.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

An Overview of the Timebar Object


%%PageItemTitle%%

TimeBarBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarBackColor Property

Gets or sets the default background color of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TimeBarBackColor = value

value = instance.TimeBarBackColor
C#
public virtual System.Drawing.Color TimeBarBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarBackColor = System.Drawing.Color.Red
C# Copy Code
this.dbiSchedule.TimebarBackColor = System.Drawing.Color.Red;

Remarks

This property can be overridden with the dbiTimebarItem.BackColor property or the dbiTimebarStyle.BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarBackColorTo Property

Gets or sets the default background color to of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TimeBarBackColorTo = value

value = instance.TimeBarBackColorTo
C#
public virtual System.Drawing.Color TimeBarBackColorTo {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarBorderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarBorderColor Property

Gets or sets the default border color of a Timebar

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TimeBarBorderColor = value

value = instance.TimeBarBorderColor
C#
public virtual System.Drawing.Color TimeBarBorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarBorderColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.TimebarBorderColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarBorderType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarBorderType Property

Gets or sets the default border type of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.TimeBarBorderType = value

value = instance.TimeBarBorderType
C#
public virtual enumBorderType TimeBarBorderType {get; set;}

Property Value

dbi.enumBorderType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarDialog Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarDialog Property

Determines if the Timebar dialog will appear when a Timebar is double clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TimeBarDialog = value

value = instance.TimeBarDialog
C#
public System.bool TimeBarDialog {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarDialog = True
C# Copy Code
this.dbiSchedule.TimebarDialog = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Common Dialog Window


%%PageItemTitle%%

TimeBarExtension Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarExtension Property

Gets or sets the distance from the Timebar border at which the resizing handle (mouse cursor) appears.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TimeBarExtension = value

value = instance.TimeBarExtension
C#
public virtual System.int TimeBarExtension {get; set;}

Property Value

An integer value.

Example

Visual Basic Copy Code
'This will extend the border 10 points off the border to either side.
Me.dbiSchedule1.TimebarExtension = 10
C# Copy Code
// This will extend the border 10 points off the border to either side
DbiSchedule1.TimebarExtension = 10;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarFillType Property

Gets or sets the default background fill pattern of a Timebar based on the enumFillType.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.TimeBarFillType = value

value = instance.TimeBarFillType
C#
public virtual enumFillType TimeBarFillType {get; set;}

Property Value

dbi.enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarFont Property

Gets or sets the default font of the Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.TimeBarFont = value

value = instance.TimeBarFont
C#
public System.Drawing.Font TimeBarFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarFont = New System.Drawing.Font("Verdana", 10)
C# Copy Code
this.dbiSchedule.TimebarFont = new System.Drawing.Font("Verdana", 10);

Remarks

This property can be overridden with the dbiTimebarItem.Font property or the dbiTimebarStyle.Font property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarForeColor Property

Gets or sets the default forecolor of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TimeBarForeColor = value

value = instance.TimeBarForeColor
C#
public virtual System.Drawing.Color TimeBarForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.TimebarForeColor = System.Drawing.Color.Black;

Remarks

This property can be overridden with the dbiTimebarItem.ForeColor property or the dbiTimebarStyle.ForeColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarMargin Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarMargin Property

Gets or sets the margin size on each side of a Timebar when being resized with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TimeBarMargin = value

value = instance.TimeBarMargin
C#
public virtual System.int TimeBarMargin {get; set;}

Property Value

An Integer value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarMargin = 10
C# Copy Code
Me.dbiSchedule.TimebarMargin = 10;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarMinWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarMinWidth Property

Gets or sets the minimum width of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TimeBarMinWidth = value

value = instance.TimeBarMinWidth
C#
public virtual System.int TimeBarMinWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarMinWidth = 0
C# Copy Code
this.dbiSchedule.TimebarMinWidth = 0;

Remarks

This property is measured in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarShadows Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarShadows Property

Determines wether the timebars should be drawn with an opaque shadow. This will give the schedule some depth.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TimeBarShadows = value

value = instance.TimeBarShadows
C#
public virtual System.bool TimeBarShadows {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarStyles Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarStyles Property

Gets the Timebar styles assigned to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As TimeBarStyleCollection

value = instance.TimeBarStyles
C#
public TimeBarStyleCollection TimeBarStyles {get;}

Property Value

A TimebarStyleCollection object representing the styles assigned to the control.

Remarks

This property enables you to obtain a reference to the styles that are currently stored in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the styles collection, see the TimebarStyleCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarWordWrap Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarWordWrap Property

Determines if the Timebar text will automatically wrap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TimeBarWordWrap = value

value = instance.TimeBarWordWrap
C#
public virtual System.bool TimeBarWordWrap {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimebarWordWrap = True
C# Copy Code
this.dbiSchedule.TimebarWordWrap = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
An Overview of the Timebar Object


%%PageItemTitle%%

TimeDistance Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeDistance Property

Gets or sets the distance between major time units.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TimeDistance = value

value = instance.TimeDistance
C#
public virtual System.int TimeDistance {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TimeDistance = 60
C# Copy Code
this.dbiSchedule.TimeDistance = 60;

Remarks

When the TimeType is equal to Hours, Days or Weeks the TimeDistance represents the distance between major time units. When TimeType is equal to Months or Years, the TimeDistance represents the distance between days.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Schedules

Developing with dbiSchedule

Setting Up Different Views


%%PageItemTitle%%

TimeLineColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeLineColor Property

Determines the default line color of the schedule time lines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TimeLineColor = value

value = instance.TimeLineColor
C#
public virtual System.Drawing.Color TimeLineColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimerInterval Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimerInterval Property

Determines how often to check for Timebar alarms.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TimerInterval = value

value = instance.TimerInterval
C#
public System.int TimerInterval {get; set;}

Property Value

An Integer value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Alarms


%%PageItemTitle%%

TipsBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsBackColor Property

Gets or sets the background color of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TipsBackColor = value

value = instance.TipsBackColor
C#
public virtual System.Drawing.Color TipsBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsBackColor = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.TipsBackColor = System.Drawing.Color.White;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsBackColorTo Property

Gets or sets the background color to of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TipsBackColorTo = value

value = instance.TipsBackColorTo
C#
public virtual System.Drawing.Color TipsBackColorTo {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsBorderColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsBorderColor Property

Gets or sets the border color to of the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TipsBorderColor = value

value = instance.TipsBorderColor
C#
public virtual System.Drawing.Color TipsBorderColor {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsBorderType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsBorderType Property

Gets or sets the type of border for the tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.TipsBorderType = value

value = instance.TipsBorderType
C#
public virtual enumBorderType TipsBorderType {get; set;}

Property Value

enumBorderType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsDuration Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsDuration Property

Gets or sets how long (in milliseconds) the tool tip remains visible when the mouse is static.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TipsDuration = value

value = instance.TipsDuration
C#
public virtual System.int TipsDuration {get; set;}

Property Value

Integer

Remarks

This value must be greater than 0, and can be set up to a maximum of 3600000 (1 hour).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsFillType Property

Gets or sets fill type for the background colors of a tool tip.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.TipsFillType = value

value = instance.TipsFillType
C#
public virtual enumFillType TipsFillType {get; set;}

Property Value

dbi.enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsFont Property

Gets or sets the font of the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.TipsFont = value

value = instance.TipsFont
C#
public virtual System.Drawing.Font TipsFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsFont = New System.Drawing.Font("Verdana", 8)
C# Copy Code
this.dbiSchedule.TipsFont = new System.Drawing.Font("Verdana", 8);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsForeColor Property

Gets or sets the forecolor of the tool tips.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TipsForeColor = value

value = instance.TipsForeColor
C#
public virtual System.Drawing.Color TipsForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.TipsForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsOnChangeBar Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsOnChangeBar Property

Determines if the tool tips will be displayed when a Timebar is being moved or sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TipsOnChangeBar = value

value = instance.TipsOnChangeBar
C#
public System.bool TipsOnChangeBar {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsOnChangeBar = True
C# Copy Code
this.dbiSchedule.TipsOnChangeBar = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsOnCreateBar Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsOnCreateBar Property

Determines if the tool tips will be displayed when a bar is being created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TipsOnCreateBar = value

value = instance.TipsOnCreateBar
C#
public System.bool TipsOnCreateBar {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsOnCreateBar = False
C# Copy Code
this.dbiSchedule.TipsOnCreateBar = false;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsOnNotes Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsOnNotes Property

Determines whether a tool tip will be displayed when the mouse is over a note.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TipsOnNotes = value

value = instance.TipsOnNotes
C#
public System.bool TipsOnNotes {get; set;}

Property Value

Boolean

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsOnOverBar Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsOnOverBar Property

Determines if the tool tips will be displayed when the mouse moves over a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TipsOnOverBar = value

value = instance.TipsOnOverBar
C#
public System.bool TipsOnOverBar {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsOnOverBar = True
C# Copy Code
this.dbiSchedule.TipsOnOverBar = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TipsOnVScroll Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TipsOnVScroll Property

Determines if the tool tips will be displayed when the vertical scroll is being clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TipsOnVScroll = value

value = instance.TipsOnVScroll
C#
public System.bool TipsOnVScroll {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TipsOnVerticalScroll = True
C# Copy Code
this.dbiSchedule.TipsOnVerticalScroll = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Displaying Tool Tips


%%PageItemTitle%%

TitleAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleAlign Property

Determines the alignment for the text within the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.TitleAlign = value

value = instance.TitleAlign
C#
public System.Drawing.ContentAlignment TitleAlign {get; set;}

Property Value

A ContentAlignment value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleAlign = ContentAlignment.MiddleLeft
C# Copy Code
this.dbiSchedule.TitleAlign = ContentAlignment.MiddleLeft;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleBackColor Property

Determines the background color of the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TitleBackColor = value

value = instance.TitleBackColor
C#
public virtual System.Drawing.Color TitleBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleBackColor = System.Drawing.Color.Silver
C# Copy Code
this.dbiSchedule.TitleBackColor = System.Drawing.Color.Silver;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleBackColorMiddle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleBackColorMiddle Property

Determines the middle back color of the list area title section allowing for greater readability with certain fill types.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TitleBackColorMiddle = value

value = instance.TitleBackColorMiddle
C#
public virtual System.Drawing.Color TitleBackColorMiddle {get; set;}

Property Value

System.Drawing.Color

Remarks

Set to Color.Empty to remove this altogether.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleBackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleBackColorTo Property

Determines the secondary background color of the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TitleBackColorTo = value

value = instance.TitleBackColorTo
C#
public virtual System.Drawing.Color TitleBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleBackColorTo = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.TitleBackColorTo = System.Drawing.Color.White;

Remarks

This property is only applicable when TitleFillType is not equal to Solid. The primary background color is defined by the TitleBackColor property.

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleBorder Property

Determines the border type for the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumBorderType

instance.TitleBorder = value

value = instance.TitleBorder
C#
public enumBorderType TitleBorder {get; set;}

Property Value

A dbi.enumBorderType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleBorderType = dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule.TitleBorderType = dbi.enumBorderType.Raised;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleFillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleFillType Property

Determines the pattern used to paint the background of the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As enumFillType

instance.TitleFillType = value

value = instance.TitleFillType
C#
public enumFillType TitleFillType {get; set;}

Property Value

A dbi.enumFillType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleFillType = dbi.enumFillType.Vertical
C# Copy Code
this.dbiSchedule.TitleFillType = dbi.enumFillType.Vertical;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleFont Property

Determines the font used for the text in the list area title of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.TitleFont = value

value = instance.TitleFont
C#
public System.Drawing.Font TitleFont {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleFont = New System.Drawing.Font("Verdana", 10, FontStyle.Bold)
C# Copy Code
this.dbiSchedule.TitleFont = new System.Drawing.Font("Verdana", 10, FontStyle.Bold)

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleForeColor Property

Determines the foreground color of the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.TitleForeColor = value

value = instance.TitleForeColor
C#
public virtual System.Drawing.Color TitleForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.TitleForeColor = System.Drawing.Color.Black;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleHeight Property

Determines the height of the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TitleHeight = value

value = instance.TitleHeight
C#
public System.int TitleHeight {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleHeight = 40
C# Copy Code
this.dbiSchedule.TitleHeight = 40;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleImage Property

Determines the image for the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.TitleImage = value

value = instance.TitleImage
C#
public System.Drawing.Image TitleImage {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleImage = System.Drawing.Image.FromFile("C:\TitleImage.bmp")
C# Copy Code
this.dbiSchedule.TitleImage = System.Drawing.Image.FromFile("C:\\TitleImage.bmp");

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleImageAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleImageAlign Property

Determines the image alignment for the list area title section.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.TitleImageAlign = value

value = instance.TitleImageAlign
C#
public System.Drawing.ContentAlignment TitleImageAlign {get; set;}

Property Value

A ContentAlignment value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleImageAlign = ContentAlignment.TopLeft
C# Copy Code
this.dbiSchedule.TitleImageAlign = ContentAlignment.TopLeft;

Remarks

This property is only applicable when DisplayTitle is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleText Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleText Property

Determines the text of the list area title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.TitleText = value

value = instance.TitleText
C#
public virtual System.string TitleText {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleText = "Schedule Title"
C# Copy Code
this.dbiSchedule.TitleText = "Schedule Title";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TitleTextOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TitleTextOffset Property

Determines the values used to calculate the horizontal and vertical position of the text within the list area title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.TitleTextOffset = value

value = instance.TitleTextOffset
C#
public System.Drawing.Point TitleTextOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.TitleTextOffset = New System.Drawing.Point(0,5)
C# Copy Code
this.dbiSchedule.TitleTextOffset = new System.Drawing.Point(0,5);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ToolbarBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ToolbarBackColor Property

Determines the backcolor used when displaying the built in EditMode ToolBar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.ToolbarBackColor = value

value = instance.ToolbarBackColor
C#
public virtual System.Drawing.Color ToolbarBackColor {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ToolbarOnRightClick Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ToolbarOnRightClick Property

Determines if the built in EditMode ToolBar will display when the user right-clicks the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.ToolbarOnRightClick = value

value = instance.ToolbarOnRightClick
C#
public virtual System.bool ToolbarOnRightClick {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TreeLevelIndent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TreeLevelIndent Property

Determines the indent used to offset the text of each level of child items in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TreeLevelIndent = value

value = instance.TreeLevelIndent
C#
public System.int TreeLevelIndent {get; set;}

Property Value

integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UndoHistory Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UndoHistory Property

Gets the undo actions which can be performed on the Timebars in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As HistoryCollection

value = instance.UndoHistory
C#
public HistoryCollection UndoHistory {get;}

Property Value

A HistoryCollection representing the undo actions in dbiSchedule.

Remarks

This property enables you to obtain a reference to the undo actions that are currently stored in undo history collection in dbiSchedule. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the history collection, see the HistoryCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Undo/Redo Features


%%PageItemTitle%%

UnlinkCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UnlinkCursor Property

Allows a custom image to be used in place of the default unlink cursor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.UnlinkCursor = value

value = instance.UnlinkCursor
C#
public virtual System.Drawing.Image UnlinkCursor {get; set;}

Property Value

Image

Remarks

You can set the hotspot to a unique point in the image so you can offset the location it uses in the schedule.

Set this to nothing to use the default cursor.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UnlinkHotSpot Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UnlinkHotSpot Property

Determines the hotspot (point) in the image to use for the cursor pointer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.UnlinkHotSpot = value

value = instance.UnlinkHotSpot
C#
public virtual System.Drawing.Point UnlinkHotSpot {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertGridColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertGridColor Property

Determines the color of the vertical grid lines in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.VertGridColor = value

value = instance.VertGridColor
C#
public System.Drawing.Color VertGridColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.VertGridColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.VertGridColor = System.Drawing.Color.Black;

Remarks

This property is only applicable when VertGridLines is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertGridLines Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertGridLines Property

Determines whether or not to draw vertical grid lines between the columns in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.VertGridLines = value

value = instance.VertGridLines
C#
public System.bool VertGridLines {get; set;}

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.VertGridLines = True
C# Copy Code
this.dbiSchedule.VertGridLines = true;

Remarks

When set to true, the color of the grid lines are defined by the VertGridColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertScrollLargeChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertScrollLargeChange Property

Determines the large change when scrolling the Vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.VertScrollLargeChange = value

value = instance.VertScrollLargeChange
C#
public virtual System.int VertScrollLargeChange {get; set;}

Property Value

Integer

Remarks

A large change occurs when clicking in an empty portion of the scroll bar (between the thumb and arrow buttons)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertScrollOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertScrollOffset Property

Determines the offset used to calculate the height of the vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.VertScrollOffset = value

value = instance.VertScrollOffset
C#
public System.int VertScrollOffset {get; set;}

Property Value

Integer

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertScrollSmallChange Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertScrollSmallChange Property

Determines the small change when scrolling the Vertical scroll bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.VertScrollSmallChange = value

value = instance.VertScrollSmallChange
C#
public virtual System.int VertScrollSmallChange {get; set;}

Property Value

integer

Remarks

The small change occurs when clicking the arrow buttons on either end of the scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

VertScrollValue Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertScrollValue Property

Gets or sets the vertical scroll value of the List/Schedule(s) areas in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.VertScrollValue = value

value = instance.VertScrollValue
C#
public System.int VertScrollValue {get; set;}

Property Value

System.Integer

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Using Scroll Bars


%%PageItemTitle%%

VertThumbTrack Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VertThumbTrack Property

Determines whether the list will scroll as the vertical mouse thumb is tracked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.VertThumbTrack = value

value = instance.VertThumbTrack
C#
public System.bool VertThumbTrack {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WatermarkAlign Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WatermarkAlign Property

Determines the vertical and horizontal alignment of the WaterMarkText in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.ContentAlignment

instance.WatermarkAlign = value

value = instance.WatermarkAlign
C#
public System.Drawing.ContentAlignment WatermarkAlign {get; set;}

Property Value

ContentAlignment

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WatermarkFont Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WatermarkFont Property

Determines the Font used when drawing the WaterMarkText in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Font

instance.WatermarkFont = value

value = instance.WatermarkFont
C#
public System.Drawing.Font WatermarkFont {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WatermarkForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WatermarkForeColor Property

Determines the color used to paint the WaterMarkText in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Color

instance.WatermarkForeColor = value

value = instance.WatermarkForeColor
C#
public virtual System.Drawing.Color WatermarkForeColor {get; set;}

Property Value

System.Drawing.Color

Remarks

Adjusting the Alpha Channel on the color applied to this property is recommended, to allow items behind the text of the watermark to still be seen in the control's display.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WatermarkOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WatermarkOffset Property

Determines the vertical and horizontal offset used when painting the WaterMarkText in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.WatermarkOffset = value

value = instance.WatermarkOffset
C#
public virtual System.Drawing.Point WatermarkOffset {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WatermarkText Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WatermarkText Property

Determines the text displayed as a WaterMark in the the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.WatermarkText = value

value = instance.WatermarkText
C#
public virtual System.string WatermarkText {get; set;}

Property Value

Text

Remarks

When printing, the WaterMark will be drawn on schedule area on each printed page.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

WeekendDays Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : WeekendDays Property

Gets or sets the days of the week considered to be the weekend.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As DaysWeekendCollection

instance.WeekendDays = value

value = instance.WeekendDays
C#
public DaysWeekendCollection WeekendDays {get; set;}

Property Value

A dbiPim2.DayWeekendCollection value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set Saturday and Sunday as the weekend days.

Visual Basic Copy Code
Me.DbiSchedule1.WeekendDays.Add(DayOfWeek.Saturday)
Me.DbiSchedule1.WeekendDays.Add(DayOfWeek.Sunday)
C# Copy Code
this.DbiSchedule1.WeekendDays.Add(DayOfWeek.Saturday);
this.DbiSchedule1.WeekendDays.Add(DayOfWeek.Sunday);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

XMLRead Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : XMLRead Property

Gets or sets an XML file to read the data to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.XMLRead = value

value = instance.XMLRead
C#
public virtual System.string XMLRead {get; set;}

Property Value

A String value indicating the file name and path of the XML file

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.XMLRead = "C:\dbiScheduleData.XML"
C# Copy Code
this.dbiSchedule.XMLRead = "C:\\dbiScheduleData.XML";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : XMLString Property

Gets or sets an XML string to read the data from or write the data to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value indicating an XML string to read or write to dbiSchedule.

Example

This property is only available at run-time.
Visual Basic Copy Code
Me.dbiSchedule.XMLString = strXML
C# Copy Code
this.dbiSchedule.XMLString = strXML;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

XMLWrite Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : XMLWrite Property

Gets or sets an XML file to write the data from dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.XMLWrite = value

value = instance.XMLWrite
C#
public virtual System.string XMLWrite {get; set;}

Property Value

A String value indicating the file name and path of the XML file.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.XMLWrite = "C:\dbiScheduleData.XML"
C# Copy Code
this.dbiSchedule.XMLWrite = "C:\dbiScheduleData.XML";

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterCellEdit Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterCellEdit Event

Event fired after the editing of a cell has completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventAfterCellEditHandler

AddHandler instance.AfterCellEdit, handler
C#
public event DbiListControl.EventAfterCellEditHandler AfterCellEdit

Event Data

The event handler receives an argument of type AfterCellEditEventArgs containing data related to this event. The following AfterCellEditEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The index of the column where the edit occurred.
ColumnItem | The dbiColumnItem where the cell is located
Key | The Key code and modifiers that were pressed to end the edit session
NodeItem | The dbiNodeItem that contains the cell that was edited.
Text | The text that was assigned back to the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterColumnSort Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterColumnSort Event

Occurs after a column has been sorted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.AfterColumnSortEventHandler

AddHandler instance.AfterColumnSort, handler
C#
public event DbiListControl.AfterColumnSortEventHandler AfterColumnSort

Event Data

The event handler receives an argument of type AfterColumnSortEventArgs containing data related to this event. The following AfterColumnSortEventArgs properties provide information specific to this event.

Property | Description
Columns | An array of columns in the order in which the sort is to occur. See Sort Method

Remarks

The event handler receives an argument of type AfterColumnSortEventArgs containing data related to this event. The following AfterColumnSortEventArgs properties provide information specific to this event.

Property | Description
Columns | The zero-based index value of the column.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterGuideLineInserted Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterGuideLineInserted Event

Event fired after a new GuideLine is inserted with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterGuideLineInsertedHandler

AddHandler instance.AfterGuideLineInserted, handler
C#
public event dbiSchedule.EventAfterGuideLineInsertedHandler AfterGuideLineInserted

Event Data

The event handler receives an argument of type AfterGuideLineInsertedEventArgs containing data related to this event. The following AfterGuideLineInsertedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was inserted.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
LineTime | The date/time value for the GuideLine.
ScheduleObject | The dbiScheduleObject the GuideLine was inserted into.

Requirements

EditMode Property must be set to GuideLines

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterGuideLineMoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterGuideLineMoved Event

Event fired after a GuideLine is moved with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterGuideLineMovedHandler

AddHandler instance.AfterGuideLineMoved, handler
C#
public event dbiSchedule.EventAfterGuideLineMovedHandler AfterGuideLineMoved

Event Data

The event handler receives an argument of type AfterGuideLineMovedEventArgs containing data related to this event. The following AfterGuideLineMovedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was moved.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
LineTime | The date/time value for the GuideLine.
ScheduleObject | The dbiScheduleObject the GuideLine was moved into.

Remarks

EditMode Property must be set to GuideLines **OR** the GuideLine image must be moved using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterGuideLineRemoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterGuideLineRemoved Event

Event fired after a GuideLine is removed with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterGuideLineRemovedHandler

AddHandler instance.AfterGuideLineRemoved, handler
C#
public event dbiSchedule.EventAfterGuideLineRemovedHandler AfterGuideLineRemoved

Event Data

The event handler receives an argument of type AfterGuideLineRemovedEventArgs containing data related to this event. The following AfterGuideLineRemovedEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that was removed.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
ScheduleObject | The dbiScheduleObject the GuideLine was removed from.

Remarks

The GuideLine can only be removed with the mouse by dragging the GuideLine off of the Schedule Area.

Requirements

EditMode Property must be set to GuideLines **OR** the GuideLine image must be removed using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterNodeCollapse Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterNodeCollapse Event

Event fired after a parent node has collapsed (hiding its child nodes).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventAfterNodeCollapseHandler

AddHandler instance.AfterNodeCollapse, handler
C#
public event DbiListControl.EventAfterNodeCollapseHandler AfterNodeCollapse

Event Data

The event handler receives an argument of type AfterNodeCollapseEventArgs containing data related to this event. The following AfterNodeCollapseEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
NodeItem | The dbiNodeItem that was collapsed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterNodeExchange Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterNodeExchange Event

Event fired after a node has been internally dragged/dropped was moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventAfterNodeExchangeHandler

AddHandler instance.AfterNodeExchange, handler
C#
public event DbiListControl.EventAfterNodeExchangeHandler AfterNodeExchange

Event Data

The event handler receives an argument of type AfterNodeExchangeEventArgs containing data related to this event. The following AfterNodeExchangeEventArgs properties provide information specific to this event.

Property | Description
NodeItemSource | The node item that was dragged.
NodeItemTarget | The node item that received the drop.

Remarks

This event is triggered when a node is dragged/dropped through internal functionality enabled by the AllowItemDrag Property

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterNodeExpand Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterNodeExpand Event

Event fired after a parent node has expanded (showing its child nodes).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventAfterNodeExpandHandler

AddHandler instance.AfterNodeExpand, handler
C#
public event DbiListControl.EventAfterNodeExpandHandler AfterNodeExpand

Event Data

The event handler receives an argument of type AfterNodeExpandEventArgs containing data related to this event. The following AfterNodeExpandEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
NodeItem | The dbiNodeItem that was expanded.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterNodeSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterNodeSelect Event

Event fired after a node has been selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventAfterNodeSelectHandler

AddHandler instance.AfterNodeSelect, handler
C#
public event DbiListControl.EventAfterNodeSelectHandler AfterNodeSelect

Event Data

The event handler receives an argument of type AfterNodeSelectEventArgs containing data related to this event. The following AfterNodeSelectEventArgs properties provide information specific to this event.

Property | Description
NodeItem | The dbiNodeItem that was selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarDrop Event

Occurs after a Timebar has been dropped onto the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarDropHandler

AddHandler instance.AfterTimeBarDrop, handler
C#
public event dbiSchedule.EventAfterTimeBarDropHandler AfterTimeBarDrop

Event Data

The event handler receives an argument of type AfterTimeBarDropEventArgs containing data related to this event. The following AfterTimeBarDropEventArgs properties provide information specific to this event.

Property | Description
drgevent | Gets or sets the drag and drop information after a Timebar has been dropped.
ScheduleItem | The dbiScheduleItem the timebar has been added to.
TimeBarItem | The dbiTimeBar that was modified in the BeforeTimeBarDrop event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Implementing Drag and Drop


%%PageItemTitle%%

AfterTimeBarInserted Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarInserted Event

Occurs after a Timebar is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarInsertedHandler

AddHandler instance.AfterTimeBarInserted, handler
C#
public event dbiSchedule.EventAfterTimeBarInsertedHandler AfterTimeBarInserted

Event Data

The event handler receives an argument of type AfterTimeBarInsertedEventArgs containing data related to this event. The following AfterTimeBarInsertedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the inserted Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar after it was inserted.
TimeBarItem | The dbiTimebarItem after it has been inserted.
WasDropped | Indicates if the inserted TimeBar came from a Drag and Drop operation.

Remarks

This event only fires when the EditMode is equal to Edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarLinked Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarLinked Event

Occurs after 2 Timebars have been linked together.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarLinkedHandler

AddHandler instance.AfterTimeBarLinked, handler
C#
public event dbiSchedule.EventAfterTimeBarLinkedHandler AfterTimeBarLinked

Event Data

The event handler receives an argument of type AfterTimeBarLinkedEventArgs containing data related to this event. The following AfterTimeBarLinkedEventArgs properties provide information specific to this event.

Property | Description
Link | The dbiLinkItem after it is applied between two Timebars.

Remarks

This event will only fire when EditMode is equal to Link.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Linking


%%PageItemTitle%%

AfterTimeBarMoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarMoved Event

Occurs after a Timebar has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarMovedHandler

AddHandler instance.AfterTimeBarMoved, handler
C#
public event dbiSchedule.EventAfterTimeBarMovedHandler AfterTimeBarMoved

Event Data

The event handler receives an argument of type AfterTimeBarMovedEventArgs containing data related to this event. The following AfterTimeBarMovedEventArgs properties provide information specific to this event.

Property | Description
ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it was moved.
ScheduleItemTo | The dbiScheduleItem containing the Timebar after it has been moved.
TimeBarItem | The dbiTimebarItem after it has been moved.
Vertical | Determines if the Timebar was moved vertically.

Remarks

This event only fires when the EditMode is equal to Edit or Select.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Moving Timebars Vertically


%%PageItemTitle%%

AfterTimeBarRemoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarRemoved Event

Occurs after a Timebar is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarRemovedHandler

AddHandler instance.AfterTimeBarRemoved, handler
C#
public event dbiSchedule.EventAfterTimeBarRemovedHandler AfterTimeBarRemoved

Event Data

The event handler receives an argument of type AfterTimeBarRemovedEventArgs containing data related to this event. The following AfterTimeBarRemovedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar before it was removed.

Remarks

This event will only fire when EditMode is equal to Erase.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarSelect Event

Occurs after a TimeBar is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarSelectHandler

AddHandler instance.AfterTimeBarSelect, handler
C#
public event dbiSchedule.EventAfterTimeBarSelectHandler AfterTimeBarSelect

Event Data

The event handler receives an argument of type AfterTimeBarSelectEventArgs containing data related to this event. The following AfterTimeBarSelectEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the dbiTimeBarItem that was selected.
ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was selected.
TimeBarItem | The dbiTimeBarItem that was selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarSized Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarSized Event

Occurs after a Timebar has been sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarSizedHandler

AddHandler instance.AfterTimeBarSized, handler
C#
public event dbiSchedule.EventAfterTimeBarSizedHandler AfterTimeBarSized

Event Data

The event handler receives an argument of type AfterTimeBarSizedEventArgs containing data related to this event. The following AfterTimeBarSizedEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar after it has been sized.
TimeBarItem | The dbiTimebarItem after it has been sized.

Remarks

This event only fires when the EditMode is equal to Edit or Select.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarSplit Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarSplit Event

Occurs after a Timebar has been split while the edit mode is in split mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarSplitHandler

AddHandler instance.AfterTimeBarSplit, handler
C#
public event dbiSchedule.EventAfterTimeBarSplitHandler AfterTimeBarSplit

Event Data

The event handler receives an argument of type AfterTimeBarSplitEventArgs containing data related to this event. The following AfterTimeBarSplitEventArgs properties provide information specific to this event.

Property | Description
ScheduleItem | The dbiScheduleItem containing the Timebars after they have been split.
TimeBarNew | The newly created dbiTimebarItem.
TimeBarOld | The original dbiTimebarItem.

Requirements

The dbiSchedule edit mode is in split mode.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarUnlinked Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarUnlinked Event

Occurs after the link between two Timebars has been removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarUnlinkedHandler

AddHandler instance.AfterTimeBarUnlinked, handler
C#
public event dbiSchedule.EventAfterTimeBarUnlinkedHandler AfterTimeBarUnlinked

Event Data

The event handler receives an argument of type AfterTimeBarUnlinkedEventArgs containing data related to this event. The following AfterTimeBarUnlinkedEventArgs properties provide information specific to this event.

Property | Description
Link | The dbiLinkItem which was removed between two Timebars.

Remarks

This event only fires when the EditMode is equal to Unlink.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AfterTimeBarUnSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AfterTimeBarUnSelect Event

Occurs after a TimeBar has been unselected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAfterTimeBarUnSelectHandler

AddHandler instance.AfterTimeBarUnSelect, handler
C#
public event dbiSchedule.EventAfterTimeBarUnSelectHandler AfterTimeBarUnSelect

Event Data

The event handler receives an argument of type AfterTimeBarUnSelectEventArgs containing data related to this event. The following AfterTimeBarUnSelectEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the dbiTimeBarItem that was unselected.
ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was unselected.
TimeBarItem | The dbiTimeBarItem that was unselected

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AlarmTimeBarEnd Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlarmTimeBarEnd Event

Occurs when an alarm has fired at the end of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAlarmTimeBarEndHandler

AddHandler instance.AlarmTimeBarEnd, handler
C#
public event dbiSchedule.EventAlarmTimeBarEndHandler AlarmTimeBarEnd

Event Data

The event handler receives an argument of type AlarmTimeBarEndEventArgs containing data related to this event. The following AlarmTimeBarEndEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
TimeBarItem | The dbiTimebarItem whose alarm has fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Alarms


%%PageItemTitle%%

AlarmTimeBarStart Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AlarmTimeBarStart Event

Occurs when an alarm is fired at the beginning of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventAlarmTimeBarStartHandler

AddHandler instance.AlarmTimeBarStart, handler
C#
public event dbiSchedule.EventAlarmTimeBarStartHandler AlarmTimeBarStart

Event Data

The event handler receives an argument of type AlarmTimeBarStartEventArgs containing data related to this event. The following AlarmTimeBarStartEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
TimeBarItem | The dbiTimebarItem whose alarm has fired.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Alarms


%%PageItemTitle%%

BackColorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BackgroundImageChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackgroundImageChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event System.EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BackgroundImageLayoutChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackgroundImageLayoutChanged Event

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event System.EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeCellEdit Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeCellEdit Event

Event fired before a cell is placed in to an editable state.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeCellEditHandler

AddHandler instance.BeforeCellEdit, handler
C#
public event DbiListControl.EventBeforeCellEditHandler BeforeCellEdit

Event Data

The event handler receives an argument of type BeforeCellEditEventArgs containing data related to this event. The following BeforeCellEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Determines if the edit is allowed
ColumnIndex | The zero-based index of the column where the cell exists.
ColumnItem | The dbiColumnItem where the cell exists.
ComboBox | The ComboBox that will be used to edit values in the cell.
Height | The height of the cell to edit.
NodeItem | The dbiNodeItem that contains the cell to edit.
Text | The current text of the cell.
TextBox | The TextBox that will be used to edit values in the cell.
Width | The width of the cell to edit.
X | The X coordinate of the cell to edit.
Y | The Y coordinate of the cell to edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeCellTextDisplay Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeCellTextDisplay Event

Event fires before the text is drawn in each cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeCellTextDisplayHandler

AddHandler instance.BeforeCellTextDisplay, handler
C#
public event DbiListControl.EventBeforeCellTextDisplayHandler BeforeCellTextDisplay

Event Data

The event handler receives an argument of type BeforeCellTextDisplayEventArgs containing data related to this event. The following BeforeCellTextDisplayEventArgs properties provide information specific to this event.

Property | Description
CellFormat | The dbiCellFormat that was applied to the cell that contains the text.
CellText | The text that will be displayed in the cell
ColumnIndex | The zero-based index of the column where the cell exists.
ColumnItem | The dbiColumnItem where the cell exists.
Font | The font that will be used to drawn the cell's text.
NodeItem | The dbiNodeItem that contains the cell.
NodeLevel | Returns the zero-based level within the nested structure that the node containing the cell exists.
TextAlignment | Determines the horizontal/vertical alignment of the text within the cell.
TextColor | Determines the color of the text in the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeColumnSort Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeColumnSort Event

Occurs before a column is sorted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.BeforeColumnSortEventHandler

AddHandler instance.BeforeColumnSort, handler
C#
public event DbiListControl.BeforeColumnSortEventHandler BeforeColumnSort

Event Data

The event handler receives an argument of type BeforeColumnSortEventArgs containing data related to this event. The following BeforeColumnSortEventArgs properties provide information specific to this event.

Property | Description
AllowSort | Indicate wether or not to proceed with the Sort. To cancel the sort set e.AllowSort = False in the BeforeColumnSort Event.
Columns | An array of columns in the order in which the sort is to occur. See Sort Method

Remarks

The event handler receives an argument of type BeforeColumnSortEventArgs containing data related to this event. The following BeforeColumnSortEventArgs properties provide information specific to this event.

Property | Description
AllowSort | Determines if the columns can be sorted.
Columns | The zero-based index value of the column.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Sorting Schedule Items


%%PageItemTitle%%

BeforeGuideLineInsert Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeGuideLineInsert Event

Event fired before a new GuideLine is inserted with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeGuideLineInsertHandler

AddHandler instance.BeforeGuideLineInsert, handler
C#
public event dbiSchedule.EventBeforeGuideLineInsertHandler BeforeGuideLineInsert

Event Data

The event handler receives an argument of type BeforeGuideLineInsertEventArgs containing data related to this event. The following BeforeGuideLineInsertEventArgs properties provide information specific to this event.

Property | Description
AllowInsert | Determines if the GuideLine can be added.
GuideLine | The dbiGuideLine that is being inserted.
InDeadZone | Determines if the new GuideLine intersects with a dbiCustomArea flagged as a DeadZone.
LineTime | The date/time value for the GuideLine.
ScheduleObject | The dbiScheduleObject the GuideLine is being inserted into.

Remarks

You can only add a GuideLine to the ScheduleArea when the EditMode is set to GuideLines. Otherwise you will need to handle the add programmatically.

Requirements

EditMode Property must be set to GuideLines

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeGuideLineMove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeGuideLineMove Event

Event fired before a GuideLine is moved with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeGuideLineMoveHandler

AddHandler instance.BeforeGuideLineMove, handler
C#
public event dbiSchedule.EventBeforeGuideLineMoveHandler BeforeGuideLineMove

Event Data

The event handler receives an argument of type BeforeGuideLineMoveEventArgs containing data related to this event. The following BeforeGuideLineMoveEventArgs properties provide information specific to this event.

Property | Description
AllowMove | Determines if the GuideLine can be moved.
GuideLine | The dbiGuideLine that is being moved.
InDeadZone | Indicates if the dbiGuideLine is moving into a dead zone. You can then set the AllowMove accordingly.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
LineTime | The date/time value for the GuideLine.
OldLineTime | The old date/time value for the GuideLine
ScheduleObject | The dbiScheduleObject the GuideLine is being moved into.

Remarks

This event will fire just before the GuideLine is modified with it's new settings after it is dropped, it will only fire once. If you need a dynamic event (for setting tooltips or tracking) use the GuideLineMove Event.

Requirements

EditMode Property must be set to GuideLines **OR** the GuideLine image must be moved using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeGuideLineRemove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeGuideLineRemove Event

Event fired before a GuideLine is removed with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeGuideLineRemoveHandler

AddHandler instance.BeforeGuideLineRemove, handler
C#
public event dbiSchedule.EventBeforeGuideLineRemoveHandler BeforeGuideLineRemove

Event Data

The event handler receives an argument of type BeforeGuideLineRemoveEventArgs containing data related to this event. The following BeforeGuideLineRemoveEventArgs properties provide information specific to this event.

Property | Description
AllowRemoval | Determines if the GuideLine can be removed.
GuideLine | The dbiGuideLine that is being removed.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
LineTime | The original time of the guideline. Setting AllowRemoval Property = False and modifying this property will place the guideline at this value.
ScheduleObject | The dbiScheduleObject the GuideLine is being removed from.

Remarks

The GuideLine can only be removed with the mouse by dragging the GuideLine off of the Schedule Area.

Requirements

EditMode Property must be set to GuideLines **OR** the GuideLine image must be removed using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeNodeCollapse Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeNodeCollapse Event

Event fired before a parent node is collapsed (child nodes will be hidden).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeNodeCollapseHandler

AddHandler instance.BeforeNodeCollapse, handler
C#
public event DbiListControl.EventBeforeNodeCollapseHandler BeforeNodeCollapse

Event Data

The event handler receives an argument of type BeforeNodeCollapseEventArgs containing data related to this event. The following BeforeNodeCollapseEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
AllowCollapse | Determines if the node will be collapsed.
NodeItem | The dbiNodeItem being collapsed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeNodeExchange Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeNodeExchange Event

Event fired before a node that has been internally dragged/dropped is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeNodeExchangeHandler

AddHandler instance.BeforeNodeExchange, handler
C#
public event DbiListControl.EventBeforeNodeExchangeHandler BeforeNodeExchange

Event Data

The event handler receives an argument of type BeforeNodeExchangeEventArgs containing data related to this event. The following BeforeNodeExchangeEventArgs properties provide information specific to this event.

Property | Description
AllowNodeExchange | Determines if the exchange will be allowed
NodeItemSource | The node item being dragged.
NodeItemTarget | The node item receiving the drop

Remarks

This event is triggered when a node is dragged/dropped through internal functionality enabled by the AllowItemDrag Property

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeNodeExpand Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeNodeExpand Event

Event fired before a parent node is expanded (child nodes will be made visible).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeNodeExpandHandler

AddHandler instance.BeforeNodeExpand, handler
C#
public event DbiListControl.EventBeforeNodeExpandHandler BeforeNodeExpand

Event Data

The event handler receives an argument of type BeforeNodeExpandEventArgs containing data related to this event. The following BeforeNodeExpandEventArgs properties provide information specific to this event.

Property | Description
Action | An enumerated value indicating the action against the control that triggered the event.
AllowExpand | Determines if the node will be expanded.
NodeItem | The dbiNodeItem being expanded.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeNodeSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeNodeSelect Event

Event fired before a node is selected in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforeNodeSelectHandler

AddHandler instance.BeforeNodeSelect, handler
C#
public event DbiListControl.EventBeforeNodeSelectHandler BeforeNodeSelect

Event Data

The event handler receives an argument of type BeforeNodeSelectEventArgs containing data related to this event. The following BeforeNodeSelectEventArgs properties provide information specific to this event.

Property | Description
AllowSelect | Determines if the node will be selected.
NodeItem | The dbiNodeItem that will be selected.
X | The X coordinate where the selection is occurring
Y | The Y coordinate where the selection is occurring.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforePaint Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforePaint Event

Event fired before the control has painted the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventBeforePaintHandler

AddHandler instance.BeforePaint, handler
C#
public event DbiListControl.EventBeforePaintHandler BeforePaint

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforePrintPageNumber Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforePrintPageNumber Event

Occurs before each page number is prepared for the printed report.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforePrintPageNumberHandler

AddHandler instance.BeforePrintPageNumber, handler
C#
public event dbiSchedule.EventBeforePrintPageNumberHandler BeforePrintPageNumber

Event Data

The event handler receives an argument of type BeforePrintPageNumberEventArgs containing data related to this event. The following BeforePrintPageNumberEventArgs properties provide information specific to this event.

Property | Description
CurrentPage | The number of the page to be printed.
Text | Gets/sets the text printed on the page to display the current/max page number.
TotalPages | The total number of pages to be printed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeTimeBarDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarDrop Event

Occurs before a Timebar is dropped onto the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarDropHandler

AddHandler instance.BeforeTimeBarDrop, handler
C#
public event dbiSchedule.EventBeforeTimeBarDropHandler BeforeTimeBarDrop

Event Data

The event handler receives an argument of type BeforeTimeBarDropEventArgs containing data related to this event. The following BeforeTimeBarDropEventArgs properties provide information specific to this event.

Property | Description
AllowDrop | Determines if the Timebar can be dropped.
drgevent | Gets or sets the drag and drop information before a Timebar has been dropped.
ScheduleItem | The dbiScheduleItem the drop occurred on.
TimeBarItem | The dbiTimebarItem before it is dropped.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Implementing Drag and Drop


%%PageItemTitle%%

BeforeTimeBarInsert Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarInsert Event

Occurs before a Timebar is inserted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarInsertHandler

AddHandler instance.BeforeTimeBarInsert, handler
C#
public event dbiSchedule.EventBeforeTimeBarInsertHandler BeforeTimeBarInsert

Event Data

The event handler receives an argument of type BeforeTimeBarInsertEventArgs containing data related to this event. The following BeforeTimeBarInsertEventArgs properties provide information specific to this event.

Property | Description
AllowInsert | Determines if the Timebar can be inserted.
ScheduleItem | The dbiScheduleItem containing the Timebar before it is inserted.
TimeBarItem | The dbiTimebarItem before it is inserted.

Remarks

This event only fires when the EditMode is equal to Edit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Schedule Edit Modes


%%PageItemTitle%%

BeforeTimeBarLink Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarLink Event

Occurs before 2 times bars are linked together.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarLinkHandler

AddHandler instance.BeforeTimeBarLink, handler
C#
public event dbiSchedule.EventBeforeTimeBarLinkHandler BeforeTimeBarLink

Event Data

The event handler receives an argument of type BeforeTimeBarLinkEventArgs containing data related to this event. The following BeforeTimeBarLinkEventArgs properties provide information specific to this event.

Property | Description
AllowLink | Determines if the Timebars can be linked together.
Link | The dbiLinkItem before it is applied between two Timebars.

Remarks

This event will only fire when EditMode is equal to Link.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Time Bar Linking


%%PageItemTitle%%

BeforeTimeBarMove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarMove Event

Occurs before a Timebar is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarMoveHandler

AddHandler instance.BeforeTimeBarMove, handler
C#
public event dbiSchedule.EventBeforeTimeBarMoveHandler BeforeTimeBarMove

Event Data

The event handler receives an argument of type BeforeTimeBarMoveEventArgs containing data related to this event. The following BeforeTimeBarMoveEventArgs properties provide information specific to this event.

Property | Description
AllowMove | Determines if the Timebar can be moved.
End | The new ending DateTime for the Timebar.
ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it is moved.
ScheduleItemTo | The dbiScheduleItem containing the Timebar after it is moved.
Start | The new starting DateTime for the Timebar.
TimeBarItem | The dbiTimebarItem before it is moved.
Vertical | Determines if the Timebar is being moved vertically.

Remarks

This event only fires when the EditMode is equal to Edit or Select.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Moving Timebars Vertically
Schedule Edit Modes
Displaying and Determining Timebar Conflicts


%%PageItemTitle%%

BeforeTimeBarRemove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarRemove Event

Occurs before a Timebar is removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarRemoveHandler

AddHandler instance.BeforeTimeBarRemove, handler
C#
public event dbiSchedule.EventBeforeTimeBarRemoveHandler BeforeTimeBarRemove

Event Data

The event handler receives an argument of type BeforeTimeBarRemoveEventArgs containing data related to this event. The following BeforeTimeBarRemoveEventArgs properties provide information specific to this event.

Property | Description
AllowRemoval | Determines if the Timebar can be removed.
BarIndex | The zero-based index value of the Timebar to be removed.
ScheduleItem | The dbiScheduleItem containing the Timebar before it is removed.
TimeBarItem | The dbiTimebarItem before it is removed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeTimeBarSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarSelect Event

Occurs before a Timebar is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarSelectHandler

AddHandler instance.BeforeTimeBarSelect, handler
C#
public event dbiSchedule.EventBeforeTimeBarSelectHandler BeforeTimeBarSelect

Event Data

The event handler receives an argument of type BeforeTimeBarSelectEventArgs containing data related to this event. The following BeforeTimeBarSelectEventArgs properties provide information specific to this event.

Property | Description
AllowSelect | Determines if the Timebar can be selected.
BarIndex | The zero-based index value of the Timebar being selected.
ScheduleItem | The dbiScheduleItem containing the Timebar before it is selected.
TimeBarItem | The dbiTimebarItem before it is selected.

Remarks

This event only fires when the EditMode is equal to Edit or Select.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeTimeBarSize Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarSize Event

Occurs before a Timebar is sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarSizeHandler

AddHandler instance.BeforeTimeBarSize, handler
C#
public event dbiSchedule.EventBeforeTimeBarSizeHandler BeforeTimeBarSize

Event Data

The event handler receives an argument of type BeforeTimeBarSizeEventArgs containing data related to this event. The following BeforeTimeBarSizeEventArgs properties provide information specific to this event.

Property | Description
AllowSize | Determines if the Timebar can be sized.
BarIndex | The zero-based index value of the Timebar to be sized.
End | The new starting DateTime for the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar before it is sized.
Start | The new starting DateTime for the Timebar.
TimeBarItem | The dbiTimebarItem before it is sized.

Remarks

This event only fires when the EditMode is equal to Edit or Select.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Schedule Edit Modes
Displaying and Determining Timebar Conflicts


%%PageItemTitle%%

BeforeTimeBarSplit Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarSplit Event

Occurs before a Timebar has been split while the edit mode is in split mode.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarSplitHandler

AddHandler instance.BeforeTimeBarSplit, handler
C#
public event dbiSchedule.EventBeforeTimeBarSplitHandler BeforeTimeBarSplit

Event Data

The event handler receives an argument of type BeforeTimeBarSplitEventArgs containing data related to this event. The following BeforeTimeBarSplitEventArgs properties provide information specific to this event.

Property | Description
AllowSplit | Determines if the split will be allowed to process. This can be set to False to cancel the split.
BarIndex | Gets the bar index value that is being split.
ScheduleItem | Get the schedule item of the Timebar that is being split.
SplitAt | Gets the Date/Time value where the split is occuring.
TimeBarItem | Gets the Timebar where the split is occurring.

Requirements

The dbiSchedule edit mode is in split mode.

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeTimeBarUnlink Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarUnlink Event

Occurs before the link between two Timebars has been removed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarUnlinkHandler

AddHandler instance.BeforeTimeBarUnlink, handler
C#
public event dbiSchedule.EventBeforeTimeBarUnlinkHandler BeforeTimeBarUnlink

Event Data

The event handler receives an argument of type BeforeTimeBarUnlinkEventArgs containing data related to this event. The following BeforeTimeBarUnlinkEventArgs properties provide information specific to this event.

Property | Description
AllowUnlink | Determines if the dbiLinkItem can be removed.
Link | The dbiLinkItem to remove.

Remarks

This event only fires when the EditMode is equal to Unlink.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeTimeBarUnSelect Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeTimeBarUnSelect Event

Occurs before a TimeBar is unselected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeTimeBarUnSelectHandler

AddHandler instance.BeforeTimeBarUnSelect, handler
C#
public event dbiSchedule.EventBeforeTimeBarUnSelectHandler BeforeTimeBarUnSelect

Event Data

The event handler receives an argument of type BeforeTimeBarUnSelectEventArgs containing data related to this event. The following BeforeTimeBarUnSelectEventArgs properties provide information specific to this event.

Property | Description
AllowUnSelect | Determines if the unselect will be allowed.
BarIndex | The zero-based index value of the dbiTimeBarItem to unselect
ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem being unselected.
TimeBarItem | The dbiTimeBarItem being unselected

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BeforeToolTips Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BeforeToolTips Event

Occurs before a tool tip is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventBeforeToolTipsHandler

AddHandler instance.BeforeToolTips, handler
C#
public event dbiSchedule.EventBeforeToolTipsHandler BeforeToolTips

Event Data

The event handler receives an argument of type BeforeToolTipsEventArgs containing data related to this event. The following BeforeToolTipsEventArgs properties provide information specific to this event.

Property | Description
Align | Determines the alignment of the text displayed within the tool tip.
BackColor | Determines the primary color that will be used to paint the background of the tool tip.
BackColorTo | Determines the secondary color that will be used to paint the background of the tool tip.
BarIndex | The zero-based index value of the Timebar the mouse is over.
BorderColor | Determines the color that will be used to paint the border of the tool tip.
BorderType | Determines the type of border to apply to the tool tip.
Display | Determines if the tool tip will be displayed.
Duration | Determines how long (in milliseconds) the tool tip remains visible when the mouse is static.
FillType | Determines the pattern used to paint the background of the tool tip.
Font | Determines the font used to draw the text in the tool tip.
ForeColor | Determines the color that will be used to draw the textof the tool tip.
ScheduleItem | The dbiScheduleItem containing the Timebar where the tool tip will be displayed.
ScheduleNote | The dbiScheduleNote to display a Tool Tip for.
ScrollValue | The position of the vertical scroll bar.
Text | The text to display in the tool tip.
TipsType | The type of tool tip to display.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Displaying Tool Tips


%%PageItemTitle%%

BindingContextChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Change Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Change Event

Event fired when a list item is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventChangeEventHandler

AddHandler instance.Change, handler
C#
public event DbiListControl.EventChangeEventHandler Change

Event Data

The event handler receives an argument of type ChangeEventArgs containing data related to this event. The following ChangeEventArgs properties provide information specific to this event.

Property | Description
NodeItem | The dbiNodeItem that has been selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ChangeUICues Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CheckClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CheckClick Event

Event fired when a check box in the list is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventCheckClickEventHandler

AddHandler instance.CheckClick, handler
C#
public event DbiListControl.EventCheckClickEventHandler CheckClick

Event Data

The event handler receives an argument of type CheckEventArgs containing data related to this event. The following CheckEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The index value of the dbiColumnItem where the check occurred.
NodeItem | The dbiNodeItem where the check occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Click Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ControlAdded Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ControlError Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ControlError Event

Occurs when an error takes place in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventControlErrorHandler

AddHandler instance.ControlError, handler
C#
public event dbiSchedule.EventControlErrorHandler ControlError

Event Data

The event handler receives an argument of type ControlErrorEventArgs containing data related to this event. The following ControlErrorEventArgs properties provide information specific to this event.

Property | Description
Error | The ID number of the error which has occurred.
Message | The description of the error which has occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Error Messages


%%PageItemTitle%%

ControlRemoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CursorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DeadZoneDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DeadZoneDrop Event

Event fired when a time bar is moved onto a dead zone area with the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventDeadZoneDropHandler

AddHandler instance.DeadZoneDrop, handler
C#
public event dbiSchedule.EventDeadZoneDropHandler DeadZoneDrop

Event Data

The event handler receives an argument of type DeadZoneDropEventArgs containing data related to this event. The following DeadZoneDropEventArgs properties provide information specific to this event.

Property | Description
AllowDrop | Determines if the time bar will be allowed to intersect the dead zone.
CustomArea | The dbiCustomArea that is designated as a deadzone.
End | Determines the ending datetime value of the time bar when it intersects the dead zone.
ScheduleItem | Determines the dbiScheduleItem where the time bar encounters the dead zone
Start | Determines the starting datetime value of the time bar when it intersects the dead zone.
TimeBar | The timebar source of the deadzonedrop.

Remarks

Please note that this event will fire if a dragdrop from outside the control moves across a deadzone. As such any code in this event should check the timebar start and timebar end. If they are equal then it's not a true timebar and can be ignored. See the sample application dbiScheduleDragDrop for more information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayUserControl Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayUserControl Event

Event fired before a cell is placed in to edit mode, allowing the developer to prepare and display their own control for the editing process.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventDisplayUserControlHandler

AddHandler instance.DisplayUserControl, handler
C#
public event DbiListControl.EventDisplayUserControlHandler DisplayUserControl

Event Data

The event handler receives an argument of type DisplayUserControlEventArgs containing data related to this event. The following DisplayUserControlEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the editable cell exists.
ColumnItem | The dbiColumnItem where the editable cell exists.
Height | The height of the cell to be edited.
NodeItem | The dbiNodeItem that contains the cell to be edited.
Text | The current text of the cell to be edited.
Width | The width of the cell to be edited.
X | The X coordinate of the cell being edited.
Y | The Y coordinate of the cell to be edited.

Remarks

Event is only fired, if the EditType property of the respective column is set to UserControl

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Disposed Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DockChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragLeave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragOver Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DropList Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DropList Event

Occurs when an item is dropped into the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventDropListEventHandler

AddHandler instance.DropList, handler
C#
public event DbiListControl.EventDropListEventHandler DropList

Event Data

The event handler receives an argument of type DropListEventArgs containing data related to this event. The following DropListEventArgs properties provide information specific to this event.

Property | Description
DragEvent | The DragEventArgs related to the Drag/Drop operation.
NodeItem | The dbiNodeItem where the drop operation occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Implementing Drag and Drop


%%PageItemTitle%%

EditInputKey Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditInputKey Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventEditInputKeyHandler

AddHandler instance.EditInputKey, handler
C#
public event DbiListControl.EventEditInputKeyHandler EditInputKey

Event Data

The event handler receives an argument of type EditInputKeyEventArgs containing data related to this event. The following EditInputKeyEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
Handled | A flag the developer can set to inform the control that the operation has been handled.
KeyData | The KeyData that triggered the event.
NodeItem | The dbiNodeItem that contains the cell being edited.

Remarks

This event can be used to test and override the behavior of keys as they are pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditKeyDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditKeyDown Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventEditKeyDownHandler

AddHandler instance.EditKeyDown, handler
C#
public event DbiListControl.EventEditKeyDownHandler EditKeyDown

Event Data

The event handler receives an argument of type EditKeyDownEventArgs containing data related to this event. The following EditKeyDownEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyDownEvents | The EventArguments for the KeyDown event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyDown event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyDown event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditKeyPress Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditKeyPress Event

Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventEditKeyPressHandler

AddHandler instance.EditKeyPress, handler
C#
public event DbiListControl.EventEditKeyPressHandler EditKeyPress

Event Data

The event handler receives an argument of type EditKeyPressEventArgs containing data related to this event. The following EditKeyPressEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyPressEvents | The EventArguments for the KeyPress event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyPress event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyPressed event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditKeyUp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditKeyUp Event

Event fired when a key is released inside the TextBox or ComboBox when editing a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventEditKeyUpHandler

AddHandler instance.EditKeyUp, handler
C#
public event DbiListControl.EventEditKeyUpHandler EditKeyUp

Event Data

The event handler receives an argument of type EditKeyUpEventArgs containing data related to this event. The following EditKeyUpEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
ColumnItem | The dbiColumnItem where the edit control resides.
KeyUpEvents | The EventArguments for the KeyUp event triggered by the edit control.
NodeItem | The dbiNodeItem containing the cell being edited.
Processed | Determines if the edit control's KeyUp event has been processed yet.

Remarks

This event will fire twice, once before the edit control's KeyDown event (Processed = false) and then again after (Processed = true).

This event will only fire if either the TextBox or ComboBox is being used to edit the cell.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EditModeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EditModeChanged Event

Event fired when the EditMode is changed on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventEditModeChangedHandler

AddHandler instance.EditModeChanged, handler
C#
public event dbiSchedule.EventEditModeChangedHandler EditModeChanged

Event Data

The event handler receives an argument of type EditModeChangedEventArgs containing data related to this event. The following EditModeChangedEventArgs properties provide information specific to this event.

Property | Description
EditMode | The new EditMode for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EnabledChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Enter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FirstDraw Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FirstDraw Event

Occurs after dbiSchedule has been drawn for the first time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventFirstDrawHandler

AddHandler instance.FirstDraw, handler
C#
public event dbiSchedule.EventFirstDrawHandler FirstDraw

Remarks

This event provides an additional layer when setting default properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FontChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GiveFeedback Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GotFocus Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineClick Event

Event fired when a GuideLine is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventGuideLineClickHandler

AddHandler instance.GuideLineClick, handler
C#
public event dbiSchedule.EventGuideLineClickHandler GuideLineClick

Event Data

The event handler receives an argument of type GuideLineClickEventArgs containing data related to this event. The following GuideLineClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button that was used to click the GuideLine.
GuideLine | The dbiGuideLine that was clicked.
LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
OnImage | Determines if the GuideLine image was clicked or the GuideLine itself.
ScheduleObject | The dbiScheduleObject where the GuideLine was clicked.
X | The X position of the mouse where the click occurred.
Y | The Y position of the mouse where the click occurred.

Requirements

EditMode Property must be set to GuideLines **OR** the GuideLine image must be moved using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineInDeadZone Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineInDeadZone Event

Fires when a dbiGuideLine is detected to intersect with a custom area marked as a dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventGuideLineInDeadZoneHandler

AddHandler instance.GuideLineInDeadZone, handler
C#
public event dbiSchedule.EventGuideLineInDeadZoneHandler GuideLineInDeadZone

Event Data

The event handler receives an argument of type GuideLineInDeadZoneEventArgs containing data related to this event. The following GuideLineInDeadZoneEventArgs properties provide information specific to this event.

Property | Description
CustomArea | The dbiCustomArea that is designated as a deadzone.
GuideLine | The dbiGuideLine that is in the dead zone.
IgnoreDeadZone | Determines if the dead zone should be treated as a standard custom area instead of a dead zone
ScheduleItem | The dbiScheduleItem containing the dead zone

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GuideLineMove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GuideLineMove Event

Event fired when a GuideLine is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventGuideLineMoveHandler

AddHandler instance.GuideLineMove, handler
C#
public event dbiSchedule.EventGuideLineMoveHandler GuideLineMove

Event Data

The event handler receives an argument of type GuideLineMoveEventArgs containing data related to this event. The following GuideLineMoveEventArgs properties provide information specific to this event.

Property | Description
GuideLine | The dbiGuideLine that is moving.
LineTime | The current date/time value of the GuideLine that is being moved.
NewLine | Indicates if the GuideLine being moved is a newly added GuideLine or an existing GuideLine.
ScheduleObject | The dbiScheduleObject where the GuideLine is moving.

Requirements

EditMode Property must be set to GuideLines **OR** the GuideLine image must be moved using the mouse (if not in EditMode=GuideLine, the dbiSchedule will only respond to GuideLine events if the GuideLine image is being manipulated.)

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HandleCreated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderClick Event

Event fired when the left mouse button clicks on a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventHeaderClickEventHandler

AddHandler instance.HeaderClick, handler
C#
public event DbiListControl.EventHeaderClickEventHandler HeaderClick

Event Data

The event handler receives an argument of type ColumnEventArgs containing data related to this event. The following ColumnEventArgs properties provide information specific to this event.

Property | Description
Button | The mousebutton that was used in the event.
ColumnIndex | The index of the column where the event occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HeaderDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HeaderDoubleClick Event

Event fired when the left mouse button double clicks on a column header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventHeaderDoubleClickEventHandler

AddHandler instance.HeaderDoubleClick, handler
C#
public event DbiListControl.EventHeaderDoubleClickEventHandler HeaderDoubleClick

Event Data

The event handler receives an argument of type ColumnEventArgs containing data related to this event. The following ColumnEventArgs properties provide information specific to this event.

Property | Description
Button | The mousebutton that was used in the event.
ColumnIndex | The index of the column where the event occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HelpRequested Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HistoryChange Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HistoryChange Event

Occurs when an item in the RedoHistory or UndoHistory collections change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventHistoryChangeHandler

AddHandler instance.HistoryChange, handler
C#
public event dbiSchedule.EventHistoryChangeHandler HistoryChange

Event Data

The event handler receives an argument of type HistoryChangeEventArgs containing data related to this event. The following HistoryChangeEventArgs properties provide information specific to this event.

Property | Description
Redo | Determines if an item in the RedoHistory collection has changed.
Undo | Determines if an item in the UndoHistory collection has changed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Undo/Redo Features


%%PageItemTitle%%

ImeModeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InitializeCellEdit Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InitializeCellEdit Event

Event fired before the cell edit operation is started

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventInitializeCellEditHandler

AddHandler instance.InitializeCellEdit, handler
C#
public event DbiListControl.EventInitializeCellEditHandler InitializeCellEdit

Event Data

The event handler receives an argument of type InitializeCellEditEventArgs containing data related to this event. The following InitializeCellEditEventArgs properties provide information specific to this event.

Property | Description
AllowEdit | Determines if the edit process will be allowed.
ColumnIndex | The zero-based index of the dbiColumnItem where the edit will take place.
ColumnItem | The dbiColumnItem where the edit will take place.
NodeItem | The dbiNodeItem where the edit will take place.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Invalidated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemLineHeightChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemLineHeightChanged Event

Event fired when the item height is changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ItemLineHeightChanged, handler
C#
public event System.EventHandler ItemLineHeightChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ItemMouseOver Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ItemMouseOver Event

Occurs when the mouse moves over a new schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventItemMouseOverHandler

AddHandler instance.ItemMouseOver, handler
C#
public event dbiSchedule.EventItemMouseOverHandler ItemMouseOver

Event Data

The event handler receives an argument of type ItemMouseOverEventArgs containing data related to this event. The following ItemMouseOverEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar the mouse is over.
GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
GuideLineItem | The dbiGuideLine the mouse is over.
NoteIndex | The zero-based index value of the note the mouse is over.
NoteItem | The dbiScheduleNote the mouse is over.
ScheduleIndex | The zero-based index value of the schedule the mouse is over.
ScheduleItem | The dbiScheduleItem the mouse is over.
ScheduleObject | The dbiScheduleObject the mouse is over.
TimeBarItem | The dbiTimeBarItem the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

KeyDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

KeyPress Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

KeyUp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Layout Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Leave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowClick Event

Event fired when a line arrow is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventLineArrowClickHandler

AddHandler instance.LineArrowClick, handler
C#
public event dbiSchedule.EventLineArrowClickHandler LineArrowClick

Event Data

The event handler receives an argument of type LineArrowClickEventArgs containing data related to this event. The following LineArrowClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that performed the click.
Direction | The direction of the clicked Line Arrow.
ScheduleItem | The ScheduleItem where the Line Arrow exists.
ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowDoubleClick Event

Event fired when a line arrow is double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventLineArrowDoubleClickHandler

AddHandler instance.LineArrowDoubleClick, handler
C#
public event dbiSchedule.EventLineArrowDoubleClickHandler LineArrowDoubleClick

Event Data

The event handler receives an argument of type LineArrowDoubleClickEventArgs containing data related to this event. The following LineArrowDoubleClickEventArgs properties provide information specific to this event.

Property | Description
Direction | The direction of the clicked Line Arrow.
ScheduleItem | The ScheduleItem where the Line Arrow exists.
ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LineArrowMouseOver Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LineArrowMouseOver Event

Event fired when the mouse moves over a line arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventLineArrowMouseOverHandler

AddHandler instance.LineArrowMouseOver, handler
C#
public event dbiSchedule.EventLineArrowMouseOverHandler LineArrowMouseOver

Event Data

The event handler receives an argument of type LineArrowMouseOverEventArgs containing data related to this event. The following LineArrowMouseOverEventArgs properties provide information specific to this event.

Property | Description
Direction | The direction of the Line Arrow the mouse is over.
ScheduleIndex | The zero-based index value of the dbiScheduleObject where the mouse is over the Line Arrow.
ScheduleItem | The ScheduleItem where the Line Arrow the mouse is over exists.
ScheduleObject | The dbiScheduleObject where the mouse is over the Line Arrow

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListClick Event

Occurs when a schedule item is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventListClickHandler

AddHandler instance.ListClick, handler
C#
public event dbiSchedule.EventListClickHandler ListClick

Event Data

The event handler receives an argument of type ListClickEventArgs containing data related to this event. The following ListClickEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
ColumnIndex | The zero-based index of the dbiColumnItem where the click occurred.
ColumnItem | The dbiColumnItem where the click occurred.
ScheduleItem | The dbiScheduleItem which has been clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListDoubleClick Event

Occurs when a schedule item is double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventListDoubleClickHandler

AddHandler instance.ListDoubleClick, handler
C#
public event dbiSchedule.EventListDoubleClickHandler ListDoubleClick

Event Data

The event handler receives an argument of type ListDoubleClickEventArgs containing data related to this event. The following ListDoubleClickEventArgs properties provide information specific to this event.

Property | Description
Column | The column which has been double clicked on.
ScheduleItem | The dbiScheduleItem which has been double clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListDrop Event

Occurs when an item is dropped into the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventListDropHandler

AddHandler instance.ListDrop, handler
C#
public event dbiSchedule.EventListDropHandler ListDrop

Event Data

The event handler receives an argument of type ListDropEventArgs containing data related to this event. The following ListDropEventArgs properties provide information specific to this event.

Property | Description
drgevent | Gets or sets the drag and drop information of the ScheduleItem where the drop occurred.
ScheduleItem | Gets or sets the dbiScheduleItem where a drop has occurred.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListMouseOver Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListMouseOver Event

Event fired when the mouse moves over a cell.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventListMouseOverEventHandler

AddHandler instance.ListMouseOver, handler
C#
public event DbiListControl.EventListMouseOverEventHandler ListMouseOver

Event Data

The event handler receives an argument of type ListMouseOverEventArgs containing data related to this event. The following ListMouseOverEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem being moused over.
NodeItem | The dbiNodeItem which the mouse is over

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ListWidthChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ListWidthChanged Event

Occurs when the list width has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ListWidthChanged, handler
C#
public event System.EventHandler ListWidthChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LocationChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

LostFocus Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MarginChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MarginChanged Event

Occurs when the control's margin changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
C#
public event System.EventHandler MarginChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseEnter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseHover Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseLeave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseMove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseUp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseWheel Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

MouseWheelCheck Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : MouseWheelCheck Event

Occurs when the wheel on the users mouse is scrolled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventMouseWheelCheckHandler

AddHandler instance.MouseWheelCheck, handler
C#
public event dbiSchedule.EventMouseWheelCheckHandler MouseWheelCheck

Event Data

The event handler receives an argument of type MouseWheelCheckEventArgs containing data related to this event. The following MouseWheelCheckEventArgs properties provide information specific to this event.

Property | Description
Allow | Determines if the default MouseWheel behavior will occur (scrolling the vertical scrollbar)
MouseEvents | The MouseEventArgs related to the MouseWheel scroll that triggered the event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Move Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NodeClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NodeClick Event

Occurs when a schedule item is clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventNodeClickEventHandler

AddHandler instance.NodeClick, handler
C#
public event DbiListControl.EventNodeClickEventHandler NodeClick

Event Data

The event handler receives an argument of type NodeClickEventArgs containing data related to this event. The following NodeClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button used to click the node.
ColumnIndex | The zero-based index of the dbiColumnItem at the point where the node was clicked.
ColumnItem | The dbiColumnItem at the point where the node was clicked.
Handled | Determines if the developer has handled the click operation themselves.
NodeItem | The dbiNodeItem that was clicked.
X | The X coordinate where the click occurred.
Y | The Y coordinate where the click occurred.

Remarks

This event is inherited from the dbi.dll base assembly. The ListClick event should be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NodeDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NodeDoubleClick Event

Occurs when a schedule item is double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventNodeDoubleClickEventHandler

AddHandler instance.NodeDoubleClick, handler
C#
public event DbiListControl.EventNodeDoubleClickEventHandler NodeDoubleClick

Event Data

The event handler receives an argument of type NodeDoubleClickEventArgs containing data related to this event. The following NodeDoubleClickEventArgs properties provide information specific to this event.

Property | Description
Button | The mouse button used to double click the node.
ColumnIndex | The zero-based index of the dbiColumnItem where the double click occurred.
ColumnItem | The dbiColumnItem where the double click occurred
NodeItem | The dbiNodeItem that was double clicked
X | The X coordinate where the double click occurred
Y | The Y coordinate where the double click occurred.

Remarks

This event is inherited from the dbi.dll base assembly. The ListDoubleClick event should be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NoteClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NoteClick Event

Event fired when a schedule note is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventNoteClickHandler

AddHandler instance.NoteClick, handler
C#
public event dbiSchedule.EventNoteClickHandler NoteClick

Event Data

The event handler receives an argument of type NoteClickEventArgs containing data related to this event. The following NoteClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that performed the click.
ScheduleItem | The ScheduleItem where the clicked note exists.
ScheduleNote | the dbiScheduleNote that was clicked.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

NoteDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : NoteDoubleClick Event

Event fired when a schedule note is double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventNoteDoubleClickHandler

AddHandler instance.NoteDoubleClick, handler
C#
public event dbiSchedule.EventNoteDoubleClickHandler NoteDoubleClick

Event Data

The event handler receives an argument of type NoteDoubleClickEventArgs containing data related to this event. The following NoteDoubleClickEventArgs properties provide information specific to this event.

Property | Description
ScheduleItem | The ScheduleItem where the clicked note exists.
ScheduleNote | the dbiScheduleNote that was clicked.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PaddingChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PaddingChanged Event

Occurs when the control's padding changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event System.EventHandler PaddingChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Paint Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Paint Event

Occurs when the control is redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
public event System.Windows.Forms.PaintEventHandler Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ParentChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RedoAction Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RedoAction Event

Occurs after a redo action has taken place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventRedoActionHandler

AddHandler instance.RedoAction, handler
C#
public event dbiSchedule.EventRedoActionHandler RedoAction

Event Data

The event handler receives an argument of type RedoActionEventArgs containing data related to this event. The following RedoActionEventArgs properties provide information specific to this event.

Property | Description
HistoryItem | Gets the history item for the RedoActionEvent.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Extending Undo/Redo Functionality


%%PageItemTitle%%

RegionChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RemoveUserControls Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RemoveUserControls Event

Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventRemoveUserControlsHandler

AddHandler instance.RemoveUserControls, handler
C#
public event DbiListControl.EventRemoveUserControlsHandler RemoveUserControls

Event Data

The event handler receives an argument of type RemoveUserControlsEventArgs containing data related to this event. The following RemoveUserControlsEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem the UserControl is being displayed over.
ColumnItem | The dbiColumnItem the UserControl is being displayed over.
NodeItem | The dbiNodeItem that contains the cell the UserControl is displayed over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Resize Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RulerDrag Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RulerDrag Event

Occurs when the user mouses down in the ruler area, and drags.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventRulerDragHandler

AddHandler instance.RulerDrag, handler
C#
public event dbiSchedule.EventRulerDragHandler RulerDrag

Event Data

The event handler receives an argument of type RulerDragEventArgs containing data related to this event. The following RulerDragEventArgs properties provide information specific to this event.

Property | Description
ScheduleObject | The dbiScheduleObject that contains the ruler that triggered the event.
Source | The location where the drag started.
Target | The location where the cursor currently is.
TimeDistance | The current TimeDistance (pixels between major time units) for the dbiScheduleObject which contains the ruler where the drag is occurring.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleClick Event

Occurs when the user clicks in the schedule area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventScheduleClickHandler

AddHandler instance.ScheduleClick, handler
C#
public event dbiSchedule.EventScheduleClickHandler ScheduleClick

Event Data

The event handler receives an argument of type ScheduleClickEventArgs containing data related to this event. The following ScheduleClickEventArgs properties provide information specific to this event.

Property | Description
Button | The MouseButton that was used to click the schedule.
RulerClick | Indicates if the click occurred in the ruler area.
ScheduleObject | The dbiScheduleObject where the click occurred.
ScheduleX | The X-coordinate (relative to the dbiScheduleObject) where the click occurred
ScheduleY | The Y-coordinate (relative to the dbiScheduleObject) where the click occurred
X | The X-coordinate where the click occurred
Y | The Y-coordinate where the click occurred

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScheduleScrollBarsOffsetArea Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScheduleScrollBarsOffsetArea Event

Occurs before the control renders either the horizontal or vertical scroll bar in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler

AddHandler instance.ScheduleScrollBarsOffsetArea, handler
C#
public event dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler ScheduleScrollBarsOffsetArea

Event Data

The event handler receives an argument of type ScheduleScrollBarsOffsetAreaEventArgs containing data related to this event. The following ScheduleScrollBarsOffsetAreaEventArgs properties provide information specific to this event.

Property | Description
Area | Determines the available area based on the current scroll bar offset.
Length | Determines the total width/height of the scroll bar area
ScrollBar | Determines which scroll bar area is raising the event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScrollBufferResize Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollBufferResize Event

Event fired when the Scroll Buffer is resized to allow for the repositioning of any controls in the buffer zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventScrollBufferResizeHandler

AddHandler instance.ScrollBufferResize, handler
C#
public event dbiSchedule.EventScrollBufferResizeHandler ScrollBufferResize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ScrollTrack Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ScrollTrack Event

Occurs when a scroll bar within the control is moved either manually or programmatically.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventScrollTrackHandler

AddHandler instance.ScrollTrack, handler
C#
public event dbiSchedule.EventScrollTrackHandler ScrollTrack

Event Data

The event handler receives an argument of type ScrollTrackEventArgs containing data related to this event. The following ScrollTrackEventArgs properties provide information specific to this event.

Property | Description
ScrollBar | An integer value representing the scrollbar that has been moved.
Value | An integer value used to calculate the scroll bar position.

Example

This event can be used to synchronize two schedule controls or to manipulate the scroll bars in a multi-schedule control.
Used to synchronize multiple schedule controls on the same form.
Visual Basic Copy Code
'With two schedules on your form with identical time intervals and time type settings.
    'This will synchronize the movement between the two controls.
    Private Sub DbiSchedule1_ScrollTrack(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.ScrollTrackEventArgs) Handles DbiSchedule1.ScrollTrack
        If e.ScrollBar = 2 Then
            Me.DbiSchedule2.SchedScrollValue = e.Value
        End If
    End Sub
Used to synchronize multiple schedule controls on the same form.
C# Copy Code
//With two schedules on your form with identical time intervals and time type settings.
        //This will synchronize the movement between the two controls.
        private void dbiSchedule1_ScrollTrack(object sender, Dbi.WinControl.Schedule.ScrollTrackEventArgs e)
        {
            if (e.ScrollBar == 2)
                this.dbiSchedule2.SchedScrollValue = e.Value.ToString();
        }

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SizeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

StyleChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TabIndexChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TabIndexChanged Event

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
C#
public event System.EventHandler TabIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TabStopChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TabStopChanged Event

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
C#
public event System.EventHandler TabStopChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TextChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarClick Event

Occurs when a Timebar is clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarClickHandler

AddHandler instance.TimeBarClick, handler
C#
public event dbiSchedule.EventTimeBarClickHandler TimeBarClick

Event Data

The event handler receives an argument of type TimeBarClickEventArgs containing data related to this event. The following TimeBarClickEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
Button | The MouseButton being clicked.
ScheduleItem | The dbiScheduleItem containing the Timebar being clicked.
TimeBarItem | The dbiTimebarItem being clicked.
X | The x-Coordinate when the TimeBar was clicked
Y | The y-Coordinate when the TimeBar was clicked

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarDateText Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarDateText Event

Occurs just before the text is written at each end of a timebar in the display, when a dbiScheduleObject's DisplayTimeBarDates property is true.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarDateTextHandler

AddHandler instance.TimeBarDateText, handler
C#
public event dbiSchedule.EventTimeBarDateTextHandler TimeBarDateText

Event Data

The event handler receives an argument of type TimeBarDateTextEventArgs containing data related to this event. The following TimeBarDateTextEventArgs properties provide information specific to this event.

Property | Description
DateTime | The DateTime value of the edge of the TimeBar being drawn.
ForeColor | The color used to paint the text at the edge of the TimeBar.
IsStart | Determines if the current DateTime is for the start or end of the timebar.
ScheduleObject | The dbiScheduleOject where the TimeBar is being drawn.
Text | The text string to be drawn at the edge of the timebar.
TimeBarItem | The dbiTimeBarITem being drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarDoubleClick Event

Occurs when a Timebar is double clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarDoubleClickHandler

AddHandler instance.TimeBarDoubleClick, handler
C#
public event dbiSchedule.EventTimeBarDoubleClickHandler TimeBarDoubleClick

Event Data

The event handler receives an argument of type TimeBarDoubleClickEventArgs containing data related to this event. The following TimeBarDoubleClickEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar being double clicked.
TimeBarItem | The dbiTimebarItem being double clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Timebar Common Dialog Window


%%PageItemTitle%%

TimeBarMouseEnter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarMouseEnter Event

Occurs when the mouse moves into a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarMouseEnterHandler

AddHandler instance.TimeBarMouseEnter, handler
C#
public event dbiSchedule.EventTimeBarMouseEnterHandler TimeBarMouseEnter

Event Data

The event handler receives an argument of type TimeBarMouseEnterEventArgs containing data related to this event. The following TimeBarMouseEnterEventArgs properties provide information specific to this event.

Property | Description
TimeBarItem | The dbiTimeBarItem the mouse has moved into.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarMouseLeave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarMouseLeave Event

Occurs when the mouse moves out of a time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarMouseLeaveHandler

AddHandler instance.TimeBarMouseLeave, handler
C#
public event dbiSchedule.EventTimeBarMouseLeaveHandler TimeBarMouseLeave

Event Data

The event handler receives an argument of type TimeBarMouseLeaveEventArgs containing data related to this event. The following TimeBarMouseLeaveEventArgs properties provide information specific to this event.

Property | Description
TimeBarItem | The dbiTimeBarItem the mouse has moved from.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarMoving Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarMoving Event

Occurs while a TimeBar is moving in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarMovingHandler

AddHandler instance.TimeBarMoving, handler
C#
public event dbiSchedule.EventTimeBarMovingHandler TimeBarMoving

Event Data

The event handler receives an argument of type TimeBarMovingEventArgs containing data related to this event. The following TimeBarMovingEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index of the dbiTimeBarItem being moved.
End | The new End DateTime value for the dbiTimeBarItem
ScheduleItem | The dbiScheduleItem where the dbiTimeBarItem is currently being moved.
Start | The new Start DateTime value for the dbiTimeBarItem.
TimeBarItem | The dbiTimeBarItem being moved.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TimeBarSizing Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TimeBarSizing Event

Occurs as the size of the Timebar is being changed by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventTimeBarSizingHandler

AddHandler instance.TimeBarSizing, handler
C#
public event dbiSchedule.EventTimeBarSizingHandler TimeBarSizing

Event Data

The event handler receives an argument of type TimeBarSizingEventArgs containing data related to this event. The following TimeBarSizingEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The zero-based index value of the Timebar.
End | The ending date time value of the Timebar.
ScheduleItem | The dbiScheduleItem containing the Timebar being sized.
Start | The starting date time value of the Timebar.
TimeBarItem | The dbiTimebarItem being sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UndoAction Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UndoAction Event

Occurs after an undo action has taken place.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUndoActionHandler

AddHandler instance.UndoAction, handler
C#
public event dbiSchedule.EventUndoActionHandler UndoAction

Event Data

The event handler receives an argument of type UndoActionEventArgs containing data related to this event. The following UndoActionEventArgs properties provide information specific to this event.

Property | Description
HistoryItem | Gets the history item for the UndoActionEvent.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Extending Undo/Redo Functionality


%%PageItemTitle%%

UserDrawnBar Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnBar Event

Occurs at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnBarHandler

AddHandler instance.UserDrawnBar, handler
C#
public event dbiSchedule.EventUserDrawnBarHandler UserDrawnBar

Event Data

The event handler receives an argument of type UserDrawnBarEventArgs containing data related to this event. The following UserDrawnBarEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
PaintBar | Indicates to the control if the internal PaintBar routine is to be used to paint the Time Bar. When the e.PaintBar property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar.
PaintText | Indicates to the control if the internal PaintText routine is to be used to paint the Time Bar Text. When the e.PaintText property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar Text.
Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.

Remarks

A User Drawn Time Bar provides the developer an opportunity to take over the painting of any or all time bars in the dbiSchedule control. User Drawn Time Bars behave the same as standard time bars and scroll with the movement of the vertical and horizontal scroll bars.

The drawing of any time bar causes the dbiSchedule control to fire the UserDrawnBar Event before they are painted. If no code is placed in the event, all time bars will be drawn in accordance with their associated style, or in the absence of a style, in accordance with dbiSchedule TimeBar properties (i.e. .TimeBarBackColor, .TimeBarBackColorTo, .TimeBarFillType, etc.).

To override the control’s drawing of a time bar the developer is provided with two properties in the e argument of the UserDrawnLine Event;e.PaintBar ande.PaintText. Setting these properties to False cancels the control’s painting of the time bar’s rectangle and text properties and allows the developer to implement their own custom drawing code.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

UserDrawnBarAfter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnBarAfter Event

This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnBarAfterHandler

AddHandler instance.UserDrawnBarAfter, handler
C#
public event dbiSchedule.EventUserDrawnBarAfterHandler UserDrawnBarAfter

Event Data

The event handler receives an argument of type UserDrawnBarAfterEventArgs containing data related to this event. The following UserDrawnBarAfterEventArgs properties provide information specific to this event.

Property | Description
BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.

Remarks

This event can be used in conjunction with the UserDrawnBar Event to customize a timebar. For example setting the UserDrawnBar e.PaintText to false will give you the timebar without text, you can then add your own with multiple icons and text. For more information see the dbiScheduleUserDrawn Demo.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnCell Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnCell Event

Event fired before a cell is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventUserDrawnCellHandler

AddHandler instance.UserDrawnCell, handler
C#
public event DbiListControl.EventUserDrawnCellHandler UserDrawnCell

Event Data

The event handler receives an argument of type UserDrawnCellEventArgs containing data related to this event. The following UserDrawnCellEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the cell is being drawn.
ColumnItem | The dbiColumnItem where the cell is being drawn.
Graphics | A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
NodeItem | The dbiNodeItem that contains the cell being drawn.
PaintCell | Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnColumnHeader Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnColumnHeader Event

Event fired before a column header is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventUserDrawnColumnHeaderHandler

AddHandler instance.UserDrawnColumnHeader, handler
C#
public event DbiListControl.EventUserDrawnColumnHeaderHandler UserDrawnColumnHeader

Event Data

The event handler receives an argument of type UserDrawnColumnHeaderEventArgs containing data related to this event. The following UserDrawnColumnHeaderEventArgs properties provide information specific to this event.

Property | Description
ColumnIndex | The zero-based index of the dbiColumnItem where the header is being drawn.
ColumnItem | The dbiColumnItem where the header is being drawn.
Graphics | A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
PaintHeader | Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.
Rect | A rectangle representing the area being painted in the control.
Status | Determines the current status of the header column in the display.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnCustomArea Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnCustomArea Event

Occurs at the point a custom area is drawn to provide custom painting of the display of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnCustomAreaHandler

AddHandler instance.UserDrawnCustomArea, handler
C#
public event dbiSchedule.EventUserDrawnCustomAreaHandler UserDrawnCustomArea

Event Data

The event handler receives an argument of type UserDrawnCustomAreaEventArgs containing data related to this event. The following UserDrawnCustomAreaEventArgs properties provide information specific to this event.

Property | Description
CustomArea | The dbiCustomArea being drawn.
Graphics | A handle to the Graphics object responsible for the drawing.
MapArea | Determines if the custom area is currently being drawn in the map area.
PaintArea | Indicates to the control if the custom area should be drawn with the standard routines.
Rect | The rectangle representing the size and location of the custom area.
ScheduleItem | The dbiScheduleItem where the dbiCustomArea is being drawn.
ScheduleObject | The dbiScheduleObject where the dbiCustomArea is being drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnFooter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnFooter Event

A static item painted through the list and schedule area at the bottom of the control above the horizontal scroll bars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnFooterHandler

AddHandler instance.UserDrawnFooter, handler
C#
public event dbiSchedule.EventUserDrawnFooterHandler UserDrawnFooter

Event Data

The event handler receives an argument of type UserDrawnFooterEventArgs containing data related to this event. The following UserDrawnFooterEventArgs properties provide information specific to this event.

Property | Description
Graphics | A graphics handle to the custom area provided to the developer within the footer area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
ListArea | Reports True if the UserDrawnFooter event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnFooter event is being fired when the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnFooter event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnFooter Event fires once for each area in the footer to be painted; the list, and each ScheduleObject visible in the schedule area of the control.
ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.

Remarks

NOTE: The User Drawn Footer does not scroll when the vertical scroll bar is moved. NOTE: The User Drawn Footer is not reflected in the Map Area of the control.

The UserDrawnFooter is ideal for summarizing the activity of all the schedule items as whole, independent of list item headers, items, and time bar detail and / or providing intstruction to user regarding the contents of the schedule control. For example in a staff scheduling implementation the UserDrawnFooter could be used to illustrate the “coverage” or number of persons scheduled per hour for each hour in the schedule.

To implement a UserDrawnFooter set the dbiSchedule.FooterLine property to “True”. NOTE: This can be set in design time using the property inspector or at runtime in code.

When the FooterLine property is set to true the control fires a UserDrawnFooter event when the control is painted or repainted to allow the developer to custom code the contents of the UserDrawn area. The event is fired once for the list area, and once for each ScheduleObject visible in the schedule area. The UserDrawnFooter event is used by the developer to code the drawing routines specific to each area within the UserDrawnFooter.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

UserDrawnHeader Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnHeader Event

A static item painted through the list and schedule area at the top of the control below the list title and ruler (time line).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnHeaderHandler

AddHandler instance.UserDrawnHeader, handler
C#
public event dbiSchedule.EventUserDrawnHeaderHandler UserDrawnHeader

Event Data

The event handler receives an argument of type UserDrawnHeaderEventArgs containing data related to this event. The following UserDrawnHeaderEventArgs properties provide information specific to this event.

Property | Description
Graphics | A graphics handle to the custom area provided to the developer within the header area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
ListArea | Reports True if UserDrawnHeader event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnHeader event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnHeader event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnHeader Event fires once for each area in the header to be painted; the List, and each ScheduleObject visible in the schedule area of the control
ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.

Remarks

NOTE: The User Drawn Header does not scroll when the vertical scroll bar is moved. NOTE: The User Drawn Header is not reflected in the Map Area of the control.

The UserDrawnHeader is ideal for summarizing the activity of all the schedule items as whole, independent of list item headers, items, and time bar detail. A User Drawn Header might also be used to “brand” the contents of the schedule control with corporate logos, schedule information, etc. For example, in a schedule that represented a series of projects running concurrently, a UserDrawnHeader might be used to illustrate the status of all the projects contained in the schedule detail.

To implement a user drawn header set the dbiSchedule.HeaderLine property to “True”. NOTE: The HeaderLine property can be set in design time using the property inspector or at runtime in code.

When the HeaderLine property is set to true the control fires a UserDrawnHeader event when the control is painted or repainted to allow the developer to custom code the contents of the UserDrawn area. The event is fired once for the list area, and once for each ScheduleObject visible in the schedule area. The UserDrawnHeader event is used by the developer to code the drawing routines specific to each area within the UserDrawnHeader area.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

UserDrawnLine Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnLine Event

Rendered in the dbiSchedule Items collection(s) to provide custom painting of the rectangle inside the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnLineHandler

AddHandler instance.UserDrawnLine, handler
C#
public event dbiSchedule.EventUserDrawnLineHandler UserDrawnLine

Event Data

The event handler receives an argument of type UserDrawnLineEventArgs containing data related to this event. The following UserDrawnLineEventArgs properties provide information specific to this event.

Property | Description
Graphics | A graphics handle to the custom area provided to the developer within the schedule area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area or map area of the control.
MapArea | Reports True if UserDrawnLine event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnLine event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
Rect | rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnLine event the e.Rect object represents the item area to be drawn in schedule area specific to the ScheduleObject being drawn when the e.MapArea property is False (i.e. the control is painting the schedule area of the control), or the item area within the map area to be painted specific to the ScheduleOjbect being painted.
ScheduleItem | This property provides a handle back to the dbiScheduleItem being painted. The developer can read or interract with the properties of the item such as its text, backcolor, etc. within the UserDrawnLine event.
ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control.

Remarks

NOTE: A UserDrawnItem does not allow for custom painting in the List area of the control.

A User Drawn Item provides the developer a custom painting area within the body of the schedule items inside the schedule area of the control and within the map area of the control. User Drawn items behave the same as standard items and scroll with the movement of the vertical scroll bar, as opposed to the UserDrawnHeader or UserDrawnFooter objects which are static within the control viewing area.

A User Drawn Item is a standard dbiScheduleItem with its UserDrawn property set to True. This indicates to the control that region being painted in the visible schedule area is under the control of the developer and causes the control to raise a UserDrawnLine Event in which the developer can take control of the custom painting of the item in the schedule area. NOTE: If the developer does not wish to allow the user to interact with the item’s Time Bar collection then the user drawn items’s ReadOnly property should be set to True. For each dbiScheduleItem with its UserDrawn property set to true the control fires a UserDrawnLine Event for each ScheduleObject visible in the schedule area of the control. Additionally, if the MapArea of the control is visible, the UserDrawnLine Event is fired once for each ScheduleObject in the Schedules collection of the control while painting the map area.

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

User Drawn Functionality


%%PageItemTitle%%

UserDrawnLinkLine Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnLinkLine Event

Occurs before a Link is drawn in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnLinkLineHandler

AddHandler instance.UserDrawnLinkLine, handler
C#
public event dbiSchedule.EventUserDrawnLinkLineHandler UserDrawnLinkLine

Event Data

The event handler receives an argument of type UserDrawnLinkLineEventArgs containing data related to this event. The following UserDrawnLinkLineEventArgs properties provide information specific to this event.

Property | Description
Graphics | The Graphics object where the dbiLinkItem will be drawn.
LinkItem | The dbiLinkItem being drawn.
PaintLinkLine | Determines if the control should draw the dbiLinkItem with the default appearance.
PointFrom | The starting coordinate of the dbiLinkItem in the display.
PointTo | The ending coordinate of the dbiLinkItem in the display.
Printing | Determines if the event is being raised by the printing routines.
ScheduleItemFrom | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem begins.
ScheduleItemTo | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem ends.
ScheduleObject | The dbiScheduleObject where the dbiLinkItem is being rendered.
TimeBarFrom | The dbiTimeBarItem where the dbiLinkItem begins.
TimeBarTo | The dbiTimeBarItem where the dbiLinkItem ends.

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnListScrollArea Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnListScrollArea Event

Allows for custom painting of the background of the area containing the horizontal scroll bar of the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnListScrollAreaHandler

AddHandler instance.UserDrawnListScrollArea, handler
C#
public event dbiSchedule.EventUserDrawnListScrollAreaHandler UserDrawnListScrollArea

Event Data

The event handler receives an argument of type UserDrawnListScrollAreaEventArgs containing data related to this event. The following UserDrawnListScrollAreaEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the Graphics object responsible for the drawing.
Rect | The rectangle representing the size and location of the scroll bar area.

Remarks

This event will only fire if the ListScrollViewType Property is set to Block

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnNode Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnNode Event

Event fired before a node is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventUserDrawnNodeHandler

AddHandler instance.UserDrawnNode, handler
C#
public event DbiListControl.EventUserDrawnNodeHandler UserDrawnNode

Event Data

The event handler receives an argument of type UserDrawnNodeEventArgs containing data related to this event. The following UserDrawnNodeEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
NodeItem | The dbiNodeItem that will be drawn
PaintNode | Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnRuler Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnRuler Event

Occurs before the ruler is painted in each schedule; once when the background is painted and then a second time after the rest of the ruler is painted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnRulerHandler

AddHandler instance.UserDrawnRuler, handler
C#
public event dbiSchedule.EventUserDrawnRulerHandler UserDrawnRuler

Event Data

The event handler receives an argument of type UserDrawnRulerEventArgs containing data related to this event. The following UserDrawnRulerEventArgs properties provide information specific to this event.

Property | Description
End | The End value of the visible portion of the ruler.
FirstDraw | Determines if the event is firing before painting the background of the ruler.
Graphics | A handle to the Graphics object responsible for the drawing.
Rect | The rectangle representing the size and location of the ruler.
ScheduleObject | The dbiScheduleObject whose ruler is being drawn.
Start | The End value of the visible portion of the ruler.

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnRulerSegment Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnRulerSegment Event

Occurs just before a segment is drawn in the middle row of the ruler in a dbiScheduleObject. The DisplayUserDrawnRulerSegments property of the dbiScheduleObject must be set to True.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnRulerSegmentHandler

AddHandler instance.UserDrawnRulerSegment, handler
C#
public event dbiSchedule.EventUserDrawnRulerSegmentHandler UserDrawnRulerSegment

Event Data

The event handler receives an argument of type UserDrawnRulerSegmentEventArgs containing data related to this event. The following UserDrawnRulerSegmentEventArgs properties provide information specific to this event.

Property | Description
DateTime | The DateTime value of the segment.
Font | The Font the control will use to draw text in the segment.
ForeColor | The color the control will use to draw text in the segment.
Graphics | A handle to the Graphics object where the ruler segment will be rendered.
Rect | The rectangle representing the size and location of the ruler segment within the ruler.
Schedule | The dbiScheduleObject that the ruler and ruler segment belong to.
Segment | The index of the current segment being drawn
SegmentWidth | The current width of the segment to be drawn.
Text | The text string the control should draw within the segment in the ruler.
TextAlign | The alignment of the text when rendered by the control within the ruler segment.

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnRulerTitle Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnRulerTitle Event

Occurs before the title text is written in the ruler of each schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnRulerTitleHandler

AddHandler instance.UserDrawnRulerTitle, handler
C#
public event dbiSchedule.EventUserDrawnRulerTitleHandler UserDrawnRulerTitle

Event Data

The event handler receives an argument of type UserDrawnRulerTitleEventArgs containing data related to this event. The following UserDrawnRulerTitleEventArgs properties provide information specific to this event.

Property | Description
DateTime | The Date value to be written in the title area.
ScheduleObject | The dbiScheduleObject whose ruler title is being drawn.
Text | The text that will be displayed in the ruler title.

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnTimeBars Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnTimeBars Event

Occurs after all other drawing has completed for each dbiScheduleObject in the visible schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnTimeBarsHandler

AddHandler instance.UserDrawnTimeBars, handler
C#
public event dbiSchedule.EventUserDrawnTimeBarsHandler UserDrawnTimeBars

Event Data

The event handler receives an argument of type UserDrawnTimeBarsEventArgs containing data related to this event. The following UserDrawnTimeBarsEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the Graphics object responsible for the drawing.
TimeBars | The collection of dbiUserDrawnBars that can be drawn.

Remarks

**Available in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnTitle Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnTitle Event

Event fired before the title area is drawn, allowing the developer to customize the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As DbiListControl.EventUserDrawnTitleHandler

AddHandler instance.UserDrawnTitle, handler
C#
public event DbiListControl.EventUserDrawnTitleHandler UserDrawnTitle

Event Data

The event handler receives an argument of type UserDrawnTitleEventArgs containing data related to this event. The following UserDrawnTitleEventArgs properties provide information specific to this event.

Property | Description
Graphics | A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
PaintTitle | Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.
Rect | A rectangle representing the area being painted in the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

UserDrawnWaterMark Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : UserDrawnWaterMark Event

Occurs after the control has finished painting all the objects in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventUserDrawnWaterMarkHandler

AddHandler instance.UserDrawnWaterMark, handler
C#
public event dbiSchedule.EventUserDrawnWaterMarkHandler UserDrawnWaterMark

Event Data

The event handler receives an argument of type UserDrawnWaterMarkEventArgs containing data related to this event. The following UserDrawnWaterMarkEventArgs properties provide information specific to this event.

Property | Description
Graphics | The Graphics object for the display of the schedule.
PaintWaterMark | Determines if the control should still generate the WaterMark based on the associated properties.
Printing | Determines if the event is being raised during the printing process.
ScheduleAreaRect | Represents the size and location of the schedulea area relative to the Graphics.

Remarks

***Enterprise Only***

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Validated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Validating Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ValuePoint Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ValuePoint Event

Occurs before each time value is drawn in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As dbiSchedule.EventValuePointHandler

AddHandler instance.ValuePoint, handler
C#
public event dbiSchedule.EventValuePointHandler ValuePoint

Event Data

The event handler receives an argument of type ValuePointEventArgs containing data related to this event. The following ValuePointEventArgs properties provide information specific to this event.

Property | Description
CurrentTime | The DateTime value of the major unit being drawn.
Font | The font value of the major unit being drawn.
ForeColor | The fore color used to paint the major time unit.
Graphics | A handle to the Graphics object where the value point section will be drawn.
Rect | A rectangle representing the size and location of the Value Point within the Graphics object.
ScheduleIndex | The zero-based index value of the schedule.
Text | The text to display in the ruler.
Value | The value of major time unit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members

Developing with dbiSchedule

Schedules


%%PageItemTitle%%

VisibleChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

dbiScheduleItem Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleItem Class

Provides properties for defining items in the list area of dbiSchedule.

Object Model

dbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
C#
public class dbiScheduleItem : Dbi.WinControl.dbiNodeItem

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiNodeItem
Dbi.WinControl.Schedule.dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleItem Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : dbiScheduleItem Constructor

Initializes a new instance of the dbiScheduleItem class.

Overload List

Overload | Description
dbiScheduleItem Constructor() | Initializes a new instance of the dbiScheduleItem class.
dbiScheduleItem Constructor(String) | Initializes a new instance of the dbiScheduleItem class.
dbiScheduleItem Constructor(dbiNodeItem) | Initializes a new instance of the dbiScheduleItem class.
dbiScheduleItem Constructor(dbiScheduleItem) | Initializes a new instance of the dbiScheduleItem class.
dbiScheduleItem Constructor(XmlNodeList) | Initializes a new instance of the dbiScheduleItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

dbiScheduleItem Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class > dbiScheduleItem Constructor : dbiScheduleItem Constructor()

Initializes a new instance of the dbiScheduleItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleItem()
C#
public dbiScheduleItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Overload List


%%PageItemTitle%%

dbiScheduleItem Constructor(String)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class > dbiScheduleItem Constructor : dbiScheduleItem Constructor(String)

strText
The item text.
Initializes a new instance of the dbiScheduleItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String

Dim instance As New dbiScheduleItem(strText)
C#
public dbiScheduleItem(
   System.string strText
)

Parameters

strText
The item text.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Overload List


%%PageItemTitle%%

dbiScheduleItem Constructor(dbiNodeItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class > dbiScheduleItem Constructor : dbiScheduleItem Constructor(dbiNodeItem)

objItem
The dbiNodeItem to model it after.
Initializes a new instance of the dbiScheduleItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objItem As dbiNodeItem

Dim instance As New dbiScheduleItem(objItem)
C#
public dbiScheduleItem(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to model it after.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Overload List


%%PageItemTitle%%

dbiScheduleItem Constructor(dbiScheduleItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class > dbiScheduleItem Constructor : dbiScheduleItem Constructor(dbiScheduleItem)

objItem
The dbiScheduleItem to model it after.
Initializes a new instance of the dbiScheduleItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objItem As dbiScheduleItem

Dim instance As New dbiScheduleItem(objItem)
C#
public dbiScheduleItem(
   dbiScheduleItem objItem
)

Parameters

objItem
The dbiScheduleItem to model it after.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Overload List


%%PageItemTitle%%

dbiScheduleItem Constructor(XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class > dbiScheduleItem Constructor : dbiScheduleItem Constructor(XmlNodeList)

xmlNodes
The XmlNodeList containing the values to base the new dbiScheduleItem on.
Initializes a new instance of the dbiScheduleItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiScheduleItem(xmlNodes)
C#
public dbiScheduleItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XmlNodeList containing the values to base the new dbiScheduleItem on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Overload List


%%PageItemTitle%%

Collapse Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Collapse Method

Closes a parent item so that the children are not visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem

instance.Collapse()
C#
public void Collapse()

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Collapse
C# Copy Code
this.dbiSchedule.Items[0].Collapse();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

EnsureVisible Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : EnsureVisible Method

Attempts to adjust the Vertical scroll bar to ensure the item is visible in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem

instance.EnsureVisible()
C#
public void EnsureVisible()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Expand Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Expand Method

Expands the item so that its child items are visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem

instance.Expand()
C#
public void Expand()

Example

Visual Basic Copy Code
Me.dbiSchedule.Item(0).Expand
C# Copy Code
this.dbiSchedule.Items[0].Expand();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ExpandAll Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ExpandAll Method

Expands the item, and all items below the calling item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem

instance.ExpandAll()
C#
public void ExpandAll()

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(0).ExpandAll()
C# Copy Code
this.dbiSchedule.Items[0].ExpandAll();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

GetCellChecked Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : GetCellChecked Method

nColumn
The zero-based index of the column
Gets the boolean value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.GetCellChecked(nColumn)
C#
public System.bool GetCellChecked(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the column

Return Value

boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

GetCellFormat Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : GetCellFormat Method

nColumn
The zero-based index value of the column to evaluate.
Gets the dbiCellFormat assigned to a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim value As dbiCellFormat

value = instance.GetCellFormat(nColumn)
C#
public dbiCellFormat GetCellFormat(
   System.int nColumn
)

Parameters

nColumn
The zero-based index value of the column to evaluate.

Return Value

A dbi.WinControl.dbiCellFormat object

Example

The following will get the cell format object assigned to the first column of the first item in the list.
Visual Basic Copy Code
Dim objCellFormat As dbi.WinControl.dbiCellFormat
objCellFormat = Me.dbiSchedule.Items(0).GetCellFormat(0)
C# Copy Code
dbi.WinControl.dbiCellFormat objCellFormat;
objCellFormat = this.dbiSchedule.Items[0].GetCellFormat(0);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

GetCellInteger Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : GetCellInteger Method

nColumn
The zero-based index of the column
Gets the integer value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim value As System.Integer

value = instance.GetCellInteger(nColumn)
C#
public System.int GetCellInteger(
   System.int nColumn
)

Parameters

nColumn
The zero-based index of the column

Return Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

GetCellText Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : GetCellText Method

nColumn
The zero-based index value of the column to evaluate.
Gets the text at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim value As System.String

value = instance.GetCellText(nColumn)
C#
public System.string GetCellText(
   System.int nColumn
)

Parameters

nColumn
The zero-based index value of the column to evaluate.

Return Value

A String value.

Example

The following will get the cell text assigned to the first column of the first item in the list.
Visual Basic Copy Code
Dim strCellText As String
strCellText = Me.dbiSchedule.Items(0).GetCellText(0);
C# Copy Code
string strCellText;
strCellText = this.dbiSchedule.Items[0].GetCellText(0);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

GetNodeCount Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : GetNodeCount Method

bIncludeSubItems
A Boolean value, indicating if grand child nodes are included.
Gets the number of child nodes in an item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim bIncludeSubItems As System.Boolean
Dim value As System.Integer

value = instance.GetNodeCount(bIncludeSubItems)
C#
public System.int GetNodeCount(
   System.bool bIncludeSubItems
)

Parameters

bIncludeSubItems
A Boolean value, indicating if grand child nodes are included.

Return Value

An Integer value.

Example

Visual Basic Copy Code
Dim intCount As Integer
intCount = objItem.GetNodeCount(True)
C# Copy Code
int intCount;
intCount = objItem.GetNodeCount(true);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

IsVisible Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : IsVisible Method

Determines if a given node is visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

value = instance.IsVisible()
C#
public System.bool IsVisible()

Return Value

A Boolean value.

Example

Visual Basic Copy Code
Dim booVisible As Boolean
booVisible = objItem.IsVisible()
C# Copy Code
bool booVisible;
booVisible = objItem.IsVisible();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

NextListNode Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : NextListNode Method

Gets the next node in the list.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiNodeItem

value = instance.NextListNode()
C#
public dbiNodeItem NextListNode()

Return Value

A dbi.WinControl.dbiNodeItem object.

Example

The following will get the second visible node.
Visual Basic Copy Code
Dim nextNode As dbi.WinControl.dbiNodeItem
nextNode = Me.dbiSchedule.Items(0).NextListNode
C# Copy Code
dbi.WinControl.dbiNodeItem nextNode;
nextNode = this.dbiSchedule.Items[0].NextListNode();

Remarks

If the given node does not have a node which appears after it, a Null (Nothing in Visual Basic) will be returned. This method can return a node from any level which is the next node, including the parent node, sibling node, child node, etc. The returned node does not need to be in the visible area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

NextVisibleNode Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : NextVisibleNode Method

Gets the next visible item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiNodeItem

value = instance.NextVisibleNode()
C#
public dbiNodeItem NextVisibleNode()

Return Value

A dbiNodeItem object.

Example

The following will get the second visible node.
Visual Basic Copy Code
Dim nextNode As dbi.WinControl.dbiNodeItem
nextNode = Me.dbiSchedule.Items(0).NextVisibleNode
C# Copy Code
dbi.WinControl.dbiNodeItem nextNode;
nextNode = this.dbiSchedule.Items[0].NextVisibleNode();

Remarks

If the given node does not have a node which appears after it, a Null (Nothing in Visual Basic) will be returned. This method can return a node from any level which is the next node, including the parent node, sibling node, child node, etc. The returned node does not need to be in the visible area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

NodeFullPath Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : NodeFullPath Method

Gets the full text path of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

value = instance.NodeFullPath()
C#
public System.string NodeFullPath()

Return Value

A String value.

Example

Visual Basic Copy Code
Dim strPath As String
strPath = objItem.NodeFullPath()
C# Copy Code
string strPath;
strPath = objItem.NodeFullPath();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

PrevVisibleNode Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : PrevVisibleNode Method

Gets the previous visible item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiNodeItem

value = instance.PrevVisibleNode()
C#
public dbiNodeItem PrevVisibleNode()

Return Value

A dbiNodeItem object.

Example

The following will get the second last visible node.
Visual Basic Copy Code
Dim PrevNode As dbi.WinControl.dbiNodeItem
PrevNode = Me.DbiSchedule1.Items(Me.DbiSchedule1.Items.Count - 1).PrevVisibleNode
C# Copy Code
dbi.WinControl.dbiNodeItem PrevNode;
PrevNode = this.DbiSchedule1.Items[Me.DbiSchedule1.Items.Count - 1].PrevVisibleNode

Remarks

If the given node does not have a previous node, a Null (Nothing in Visual Basic) will be returned. This method can return a node from any level which is the previous, including the parent node, sibling node, child of a sibling, etc. The returned node does not need to be in the visible area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

SetCellChecked Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : SetCellChecked Method

nColumn
The zero-based index of the column
bValue
The boolean value to assign
Sets the boolean value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim bValue As System.Boolean

instance.SetCellChecked(nColumn, bValue)
C#
public void SetCellChecked(
   System.int nColumn,
   System.bool bValue
)

Parameters

nColumn
The zero-based index of the column
bValue
The boolean value to assign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

SetCellInteger Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : SetCellInteger Method

nColumn
The zero-based index of the column
nValue
The integer value to assign
Sets the integer value at a specific cell in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim nValue As System.Integer

instance.SetCellInteger(nColumn, nValue)
C#
public void SetCellInteger(
   System.int nColumn,
   System.int nValue
)

Parameters

nColumn
The zero-based index of the column
nValue
The integer value to assign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

SetCellText Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : SetCellText Method

nColumn
The colulmn to assign the text.
strCell
The text to assign to the cell.
Sets the text for a specific column in the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nColumn As System.Integer
Dim strCell As System.String

instance.SetCellText(nColumn, strCell)
C#
public void SetCellText(
   System.int nColumn,
   System.string strCell
)

Parameters

nColumn
The colulmn to assign the text.
strCell
The text to assign to the cell.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(0).SetCellText(1,"Column 2 Text")
C# Copy Code
this.dbiSchedule.Items[0].SetCellText(1,"Column 2 Text");

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

Toggle Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Toggle Method

Expands/Collapes a parent node.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem

instance.Toggle()
C#
public void Toggle()

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Toggle()
C# Copy Code
this.dbiSchedule.Items[0].Toggle();

Remarks

A Refresh method may be required after the Toggle method is invoked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Appointments Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Appointments Property

Gets the Timebars assigned to a schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As TimeBarItemCollection

value = instance.Appointments
C#
public TimeBarItemCollection Appointments {get;}

Property Value

A TimebarItemCollection representing the Timebar in a list item in dbiSchedule.

Remarks

This property enables you to obtain a reference to the Timebars that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the Timebar collection, see the TimebarItemCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : BackColor Property

Gets or sets the background color of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : BackColorTo Property

Gets or sets the secondary background color of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Remarks

This property is only applicable when FillType is not equal to Solid. The primary background color is defined by the BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Body Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Body Property

Gets or sets the body text for the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public System.string Body {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newNode As New Dbi.WinControl.Schedule.dbiScheduleItem("Node Text")
newNode.Body = "Body Text" 'Set the body text
newNode.BodyVisible = True 'Set the body text to visible
newNode.HeightOffset = 20 'Set the height offset so the body text can be displayed

Me.DbiSchedule1.Items.Add(newNode) 'Add the node to the list
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newNode;

newNode = new Dbi.WinControl.Schedule.dbiScheduleItem("Node Text");
newNode.Body = "Body Text"; //Set the body text
newNode.BodyVisible = True; //Set the body text to visible
newNode.HeightOffset = 20; //Set the height offset so the body text can be displayed

this.DbiSchedule1.Items.Add(newNode); //Add the node to the list

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

BodyVisible Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : BodyVisible Property

Determines if the body text is visible for the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.BodyVisible = value

value = instance.BodyVisible
C#
public System.bool BodyVisible {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newNode As New Dbi.WinControl.Schedule.dbiScheduleItem("Node Text")
newNode.Body = "Body Text" 'Set the body text
newNode.BodyVisible = True 'Set the body text to visible
newNode.HeightOffset = 20 'Set the height offset so the body text can be displayed

Me.DbiSchedule1.Items.Add(newNode) 'Add the node to the list
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newNode;

newNode = new Dbi.WinControl.Schedule.dbiScheduleItem("Node Text");
newNode.Body = "Body Text"; //Set the body text
newNode.BodyVisible = True; //Set the body text to visible
newNode.HeightOffset = 20; //Set the height offset so the body text can be displayed

this.DbiSchedule1.Items.Add(newNode); //Add the node to the list

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Cargo Property

Gets or sets a non-visible text value for the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public System.string Cargo {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Cargo = "UniqueID"
C# Copy Code
this.dbiSchedule.Items[0].Cargo = "UniqueID";

Remarks

This property is not visible to the user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

CellFormat Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : CellFormat Property

Gets the cell formats assigned to a schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As CellFormatCollection

value = instance.CellFormat
C#
public CellFormatCollection CellFormat {get;}

Property Value

A dbi.WinControl.CustomAreaCollection representing the cell formats a list item in dbiSchedule.

Remarks

This property enables you to obtain a reference to the cell formats that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the cell format collection, see the dbi.WinControl.CellFormatCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

Control Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Control Property

Gets or sets the name of the object containing the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As DbiListControl

instance.Control = value

value = instance.Control
C#
public DbiListControl Control {get; set;}

Property Value

A DbiListControl/dbiSchedule object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

CustomAreas Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : CustomAreas Property

Gets the custom areas assigned to the schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiCustomAreaCollection

value = instance.CustomAreas
C#
public dbiCustomAreaCollection CustomAreas {get;}

Property Value

A dbi.PIM.CustomAreaCollection representing the custom areas a list item in dbiSchedule.

Remarks

This property enables you to obtain a reference to the custom areas that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the custom areas collection, see the dbi.PIM.CustomAreaCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Coloring the Background of a Schedule
Creating Custom Areas


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Data Property

Gets or sets a non-visible integer value for the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public System.int Data {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Data = 111
C# Copy Code
this.dbiSchedule.Items[0].Data = 111;

Remarks

This property is not visible to the user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : FillType Property

Gets or sets the background fill pattern of the item based on the enumFillType Enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public enumFillType FillType {get; set;}

Property Value

A dbi.enumFillType member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Font Property

Gets or sets the font of the schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Font = New Font("Verdana", 12, FontStyle.Bold)
C# Copy Code
this.dbiSchedule.Items[0].Font = new Font("Verdana", 12, FontStyle.Bold);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ForeColor Property

Gets or sets the foreground color of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

FullPath Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : FullPath Property

Gets the full text path of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

value = instance.FullPath
C#
public System.string FullPath {get;}

Property Value

A String value.

Example

This property is only available at run-time.
Visual Basic Copy Code
Dim strPath As String
strPath = objItem.FullPath
C# Copy Code
string strPath;
strPath = objItem.FullPath;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Header Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Header Property

Determines if the schedule item will act as a header.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.Header = value

value = instance.Header
C#
public System.bool Header {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Header = True
C# Copy Code
this.dbiSchedule.Items(0).Header = true;

Remarks

When set the true, only the text from the first column is displayed and the column width will be ignored.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

HeaderBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HeaderBackColor Property

Determines the background color of the item when marked as a Header

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.HeaderBackColor = value

value = instance.HeaderBackColor
C#
public System.Drawing.Color HeaderBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

HeaderBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HeaderBackColorTo Property

Determines the secondary background color of the item when marked as a Header

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.HeaderBackColorTo = value

value = instance.HeaderBackColorTo
C#
public System.Drawing.Color HeaderBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Remarks

This property is only used when the HeaderFillType is equal to something other than Solid.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

HeaderFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HeaderFillType Property

Determines the background pattern of the item when marked as a Header

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As enumFillType

instance.HeaderFillType = value

value = instance.HeaderFillType
C#
public enumFillType HeaderFillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

HeaderForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HeaderForeColor Property

Determines the foreground color of the item when marked as a Header

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.HeaderForeColor = value

value = instance.HeaderForeColor
C#
public System.Drawing.Color HeaderForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

HeightOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HeightOffset Property

Gets or sets the vertical offset value used to calculate the height of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.HeightOffset = value

value = instance.HeightOffset
C#
public System.int HeightOffset {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newNode As New Dbi.WinControl.Schedule.dbiScheduleItem("Node Text")
newNode.Body = "Body Text" 'Set the body text
newNode.BodyVisible = True 'Set the body text to visible
newNode.HeightOffset = 20 'Set the height offset so the body text can be displayed

Me.DbiSchedule1.Items.Add(newNode) 'Add the node to the list
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newNode;

newNode = new Dbi.WinControl.Schedule.dbiScheduleItem("Node Text");
newNode.Body = "Body Text"; //Set the body text
newNode.BodyVisible = True; //Set the body text to visible
newNode.HeightOffset = 20; //Set the height offset so the body text can be displayed

this.DbiSchedule1.Items.Add(newNode); //Add the node to the list

Remarks

A positive value will increase the height of the item, a negative value will decrease the height.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Resizing a List Item's Height


%%PageItemTitle%%

HorzGridColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HorzGridColor Property

Gets or sets the color of horizontal grid line below the schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Color

instance.HorzGridColor = value

value = instance.HorzGridColor
C#
public System.Drawing.Color HorzGridColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).HorzGridColor = System.Drawing.Color.Blue
C# Copy Code
this.dbiSchedule.Items[0].HorzGridLines = System.Drawing.Color.Blue;

Remarks

This property is only applicable when dbiSchedule.HorzGridLines is equal to True.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

HorzGridWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : HorzGridWidth Property

Gets or sets the width of the horizontal grid line below the schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.HorzGridWidth = value

value = instance.HorzGridWidth
C#
public System.int HorzGridWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).HorzGridWidth = 2
C# Copy Code
this.dbiSchedule.Items[0].HorzGridWidth = 2;

Remarks

This property is only applicable when dbiSchedule.HorzGridLines is equal to True.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ImageAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ImageAlign Property

Determines the vertical and horizontal alignment of the image associated with the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.ContentAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public System.Drawing.ContentAlignment ImageAlign {get; set;}

Property Value

A System.Drawing.ContentAlignment member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).ImageAlign = System.Drawing.ContentAlignment.MiddleCenter
C# Copy Code
this.dbiSchedule.Items[0].ImageAlign = System.Drawing.ContentAlignment.MiddleLeft;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ImageIndex Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ImageIndex Property

Determines the image associated with the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).ImageIndex = 1
C# Copy Code
this.dbiSchedule.Items[0].ImageIndex = 1

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ImageOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ImageOffset Property

Determines the vertical and horizontal offset values used to calculate the position of the image associated with the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Drawing.Point

instance.ImageOffset = value

value = instance.ImageOffset
C#
public System.Drawing.Point ImageOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).ImageOffset = New System.Drawing.Point(0,5)
C# Copy Code
this.dbiSchedule.Items[0].ImageOffset = new System.Drawing.Point(0,5);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

IsExpanded Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : IsExpanded Property

Determines if the node item is expanded, displaying child items.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

value = instance.IsExpanded
C#
public System.bool IsExpanded {get;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Dim booExpanded As Boolean
booExpanded = Me.dbiSchedule.Items(0).IsExpanded
C# Copy Code
bool booExpanded;
booExpanded = this.dbiSchedule.Items[0].IsExpanded;

Remarks

This property is only available at run-time.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Item Property

nIndex
The zero-based index of the schedule item to get or set in the collection.
Gets or sets the schedule item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim nIndex As System.Integer
Dim value As System.String

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public System.string this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the schedule item to get or set in the collection.

Property Value

A dbiNodeItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Items Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Items Property

Gets the child nodes assigned to a schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As NodeItemCollection

instance.Items = value

value = instance.Items
C#
public NodeItemCollection Items {get; set;}

Property Value

A NodeItemCollection representing the Timebar in a list item in dbiSchedule.

Remarks

This property enables you to obtain a reference to the child nodes that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the node item collection, see the NodeItemCollection for additional information.

NOTE: Child nodes cannot be defined through the property window. If they are set in the property window, an InvalidCastException error will occur. They must be defined in code.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

Level Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Level Property

Gets the current tree level of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

value = instance.Level
C#
public System.int Level {get;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

LockHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : LockHeight Property

Determines if the item height can be adjusted through user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.LockHeight = value

value = instance.LockHeight
C#
public System.bool LockHeight {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).LockHeight = False
C# Copy Code
this.dbiSchedule.Items[0].LockHeight = false;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Resizing a List Item's Height


%%PageItemTitle%%

MaxTimeBars Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : MaxTimeBars Property

Gets or sets the maximum number of Timebars an item can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.MaxTimeBars = value

value = instance.MaxTimeBars
C#
public System.int MaxTimeBars {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).MaxTimebars = 10
C# Copy Code
this.dbiSchedule.Items(0).MaxTimebars = 10;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Schedule Edit Modes


%%PageItemTitle%%

Nodes Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Nodes Property

Gets the child nodes assigned to a schedule item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As NodeItemCollection

value = instance.Nodes
C#
public NodeItemCollection Nodes {get;}

Property Value

A NodeItemCollection representing the Timebar in a list item in dbiSchedule.

Remarks

This property enables you to obtain a reference to the child nodes that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the node item collection, see the NodeItemCollection for additional information.

NOTE: Child nodes cannot be defined through the property window. If they are set in the property window, an InvalidCastException error will occur. They must be defined in code.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Using the Schedule Items List Area


%%PageItemTitle%%

Notes Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Notes Property

The collection of ScheduleNotes assigned to this dbiScheduleItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiScheduleNoteCollection

value = instance.Notes
C#
public dbiScheduleNoteCollection Notes {get;}

Property Value

dbiScheduleNoteCollection Class

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

PageBreak Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : PageBreak Property

Determines if a page break will occur after a given item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.PageBreak = value

value = instance.PageBreak
C#
public System.bool PageBreak {get; set;}

Property Value

A Boolean value.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(0).PageBreak = True
C# Copy Code
this.dbiSchedule.Items[0].PageBreak = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Parent Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Parent Property

Gets the parent item of the current item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As dbiNodeItem

instance.Parent = value

value = instance.Parent
C#
public dbiNodeItem Parent {get; set;}

Property Value

A dbi.WinControl.dbiNodeItem object.

Example

This property is only available at run time. The following syntax is placed in the ListDblClick event.
Visual Basic Copy Code
Dim ParentNode As dbi.WinControl.dbiNodeItem
ParentNode = e.Item.Parent
C# Copy Code
dbi.WinControl.dbiNodeItem ParentNode;
ParentNode = e.Item.Parent;

Remarks

If the given node item does not have a parent node, a Null (Nothing in Visual Basic) value is returned.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

ReadOnly Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : ReadOnly Property

Determines if the item is ReadOnly.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public System.bool ReadOnly {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(1).ReadOnly = true

Remarks

When set the true, Timebar cannot be added.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Schedule Edit Modes


%%PageItemTitle%%

Selected Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Selected Property

Determines if the item is selected

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.Selected = value

value = instance.Selected
C#
public System.bool Selected {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Selected = True
C# Copy Code
this.dbiSchedule.Items[0].Selected = true;

Remarks

Multiple items can be selected at a time. If an item is selected through this property, the item which was previously selected will remain selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

SelectedImageIndex Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : SelectedImageIndex Property

Determines the index of the image to use when the item is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Integer

instance.SelectedImageIndex = value

value = instance.SelectedImageIndex
C#
public System.int SelectedImageIndex {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Item(0).SelectedImageIndex = 2
C# Copy Code
this.dbiSchedule.Items[0].SelectedImageIndex = 2;

Remarks

This Integer value represent the index value of the image in the assigned ImageList object. This property will replace the ImageIndex when the node is selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Subject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Subject Property

Determines the subject of the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
public System.string Subject {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Tag Property

Determines an object value that contains additional data about the item.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An Object that contains data about the item.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

Text Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : Text Property

Determines the items text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

TimeBars Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : TimeBars Property

The collection of TimeBars assigned to this dbiScheduleItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As TimeBarItemCollection

value = instance.TimeBars
C#
public TimeBarItemCollection TimeBars {get;}

Property Value

TimeBarItemCollection Class

Remarks

This property enables you to obtain a reference to the Timebars that are currently stored in a list item. With this reference, you can add items, remove items, and obtain a count of the items in the collection. For more information on the tasks that can be performed with the Timebar collection, see the TimebarItemCollection for additional information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

UserDrawn Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : UserDrawn Property

Determines if the line item can be drawn by the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.Boolean

instance.UserDrawn = value

value = instance.UserDrawn
C#
public System.bool UserDrawn {get; set;}

Requirements

**Available in Enterprise Version Only**

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleItem Class : XMLString Property

Gets or sets an XML string to read the data from or write the data to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public override System.string XMLString {get; set;}

Property Value

A String value indicating an XML string to read or write to dbiSchedule.

Example

This property is only available at run-time
Visual Basic Copy Code
Dim strXML As String
Me.dbiSchedule.Items(0).XMLString = strXML
C# Copy Code
string strXML;
this.dbiSchedule.Items(0).XMLString = strXML;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleItem Class
dbiScheduleItem Members
Base Implementation in XMLString


%%PageItemTitle%%

dbiScheduleNote Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNote Class

Provides the properties for defining a ScheduleNote for use in the dbiScheduleNote Collection.

Object Model

dbiScheduleNote ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
C#
public class dbiScheduleNote

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleNote Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNote Class

"

The following tables list the members exposed by dbiScheduleNote.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleNote Constructor | Overloaded. Initializes a new instance of the dbiScheduleNote class.
Top

Public Properties

 | Name | Description
public Property | ImageAlignment | Determines the alignment of the dbiScheduleNote's image inside of the dbiSchedule.
public Property | ImageIndex | Defines the index of the image in the NoteImages Image list to use for the dbiScheduleNote.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a schedule note image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a schedule note image.
public Property | Locked | Determines if the dbiScheduleNote is always rendered inside the visible area of the dbiSchedule.
public Property | NoteTime | Determines the date and time for a dbiScheduleNote.
public Property | Schedule | Determines the schedule object that the note is assigned to.
public Property | Tag | Allows an object to be stored on the dbiScheduleNote.
public Property | Text | Determines the text for the dbiScheduleNote.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to dbiSchedule.
Top

See Also

Reference

dbiScheduleNote Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleNote Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : dbiScheduleNote Constructor

Initializes a new instance of the dbiScheduleNote class.

Overload List

Overload | Description
dbiScheduleNote Constructor() | Initializes a new instance of the dbiScheduleNote class.
dbiScheduleNote Constructor(String,DateTime) | Initializes a new instance of the dbiScheduleNote class.
dbiScheduleNote Constructor(dbiScheduleNote) | Initializes a new instance of the dbiScheduleNote class.
dbiScheduleNote Constructor(XmlNodeList) | Initializes a new instance of the dbiScheduleNote class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

dbiScheduleNote Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor()

Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleNote()
C#
public dbiScheduleNote()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

dbiScheduleNote Constructor(String,DateTime)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor(String,DateTime)

strText

The Note text

dtTime
The Note Date and Time
Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim strText As System.String
Dim dtTime As System.Date

Dim instance As New dbiScheduleNote(strText, dtTime)
C#
public dbiScheduleNote(
   System.string strText,
   System.DateTime dtTime
)

Parameters

strText

The Note text

dtTime
The Note Date and Time

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

dbiScheduleNote Constructor(dbiScheduleNote)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor(dbiScheduleNote)

objLine
The dbiScheduleNote to model it after.
Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim objLine As dbiScheduleNote

Dim instance As New dbiScheduleNote(objLine)
C#
public dbiScheduleNote(
   dbiScheduleNote objLine
)

Parameters

objLine
The dbiScheduleNote to model it after.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

dbiScheduleNote Constructor(XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class > dbiScheduleNote Constructor : dbiScheduleNote Constructor(XmlNodeList)

xmlNodes
The XmlNodeList containing the values to base the new dbiScheduleNote on.
Initializes a new instance of the dbiScheduleNote class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiScheduleNote(xmlNodes)
C#
public dbiScheduleNote(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XmlNodeList containing the values to base the new dbiScheduleNote on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members
Overload List


%%PageItemTitle%%

ImageAlignment Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : ImageAlignment Property

Determines the alignment of the dbiScheduleNote's image inside of the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Drawing.ContentAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public System.Drawing.ContentAlignment ImageAlignment {get; set;}

Property Value

ContentAlignment

Remarks

This property is affected by the Locked property. If Locked, the displayed image will be shown relative to the visible area of the dbiScheduleItem inside the dbiScheduleObject. If Locked is false, then the alignment is relative to the NoteTime value assigned to the dbiScheduleNote.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : ImageIndex Property

Defines the index of the image in the NoteImages Image list to use for the dbiScheduleNote.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Integer

instance.ImageIndex = value

value = instance.ImageIndex
C#
public System.int ImageIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageXOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : ImageXOffset Property

Determines the horizontal offset used to calculate the position of a schedule note image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Integer

instance.ImageXOffset = value

value = instance.ImageXOffset
C#
public System.int ImageXOffset {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

ImageYOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : ImageYOffset Property

Determines the vertical offset used to calculate the position of a schedule note image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Integer

instance.ImageYOffset = value

value = instance.ImageYOffset
C#
public System.int ImageYOffset {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Locked Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : Locked Property

Determines if the dbiScheduleNote is always rendered inside the visible area of the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Boolean

instance.Locked = value

value = instance.Locked
C#
public System.bool Locked {get; set;}

Property Value

Boolean

Remarks

If True, a dbiScheduleNote will always remain visible inside the control, and will be displayed based relative to its ImageAlignment property. If set to False, the dbiScheduleNote will scroll in and out of the visible area based on its NoteTime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

NoteTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : NoteTime Property

Determines the date and time for a dbiScheduleNote.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Date

instance.NoteTime = value

value = instance.NoteTime
C#
public virtual System.DateTime NoteTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : Schedule Property

Determines the schedule object that the note is assigned to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Property Value

dbiScheduleObject

Remarks

When set, a dbiScheduleNote can only appear inside of the specified dbiScheduleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : Tag Property

Allows an object to be stored on the dbiScheduleNote.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : Text Property

Determines the text for the dbiScheduleNote.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

String

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

XMLString Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNote Class : XMLString Property

Gets or sets an XML string to read the data from or write the data to dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNote
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value indicating an XML string to read or write to dbiSchedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNote Class
dbiScheduleNote Members


%%PageItemTitle%%

dbiScheduleNoteCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNoteCollection Class

Provides a collection of dbiScheduleNote objects to the dbiScheduleItem.

Object Model

dbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
C#
public class dbiScheduleNoteCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.dbiScheduleNoteCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiScheduleNoteCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNoteCollection Class

"

The following tables list the members exposed by dbiScheduleNoteCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiScheduleNoteCollection Constructor | Represents a collection of dbiScheduleNotes.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiScheduleNote added to the dbiScheduleItem.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a dbiScheduleNote to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiScheduleNote
public Method | Insert | Inserts a dbiScheduleNote into the collection at the specified index.
public Method | Remove | Removes a dbiScheduleNote from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the collection to an XML file specified in strFileName
public Method | XMLString | Returns the dbiScheduleNote collection as an XML String.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleNoteCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : dbiScheduleNoteCollection Constructor

objOwner
The dbiScheduleItem that will contain the collection.
Represents a collection of dbiScheduleNotes.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiScheduleItem

Dim instance As New dbiScheduleNoteCollection(objOwner)
C#
public dbiScheduleNoteCollection(
   dbiScheduleItem objOwner
)

Parameters

objOwner
The dbiScheduleItem that will contain the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Add Method

obj
dbiScheduleNote
Adds a dbiScheduleNote to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiScheduleNote obj
)

Parameters

obj
dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

IndexOf(dbiScheduleNote) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : IndexOf(dbiScheduleNote) Method

obj

dbiScheduleNote

Returns the internal index of the dbiScheduleNote

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiScheduleNote obj
)

Parameters

obj

dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Insert Method

nIndex
Integer
obj
dbiScheduleNote
Inserts a dbiScheduleNote into the collection at the specified index.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As System.Integer
Dim obj As dbiScheduleNote

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiScheduleNote obj
)

Parameters

nIndex
Integer
obj
dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Remove Method

obj
dbiScheduleNote
Removes a dbiScheduleNote from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim obj As dbiScheduleNote

instance.Remove(obj)
C#
public void Remove(
   dbiScheduleNote obj
)

Parameters

obj
dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : WriteXMLFile Method

strFileName
String - fully qualified file name to write to
Writes the collection to an XML file specified in strFileName

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
String - fully qualified file name to write to

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

XMLString Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : XMLString Method

Returns the dbiScheduleNote collection as an XML String.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : Item Property

nIndex
The internal index of the dbiScheduleNote in the collection
A dbiScheduleNote added to the dbiScheduleItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleNoteCollection
Dim nIndex As System.Integer
Dim value As dbiScheduleNote

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiScheduleNote this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The internal index of the dbiScheduleNote in the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%%

dbiScheduleObject Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject Class

Provides properties for defining schedules.

Object Model

dbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
C#
public class dbiScheduleObject : Dbi.dbiControl

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Dbi.WinControl.Schedule.dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : dbiScheduleObject Constructor

Initializes a new instance of the dbiScheduleObject class.

Overload List

Overload | Description
dbiScheduleObject Constructor() | Initializes a new instance of the dbiScheduleObject class.
dbiScheduleObject Constructor(DateTime,DateTime) | Initializes a new instance of the dbiScheduleObject class.
dbiScheduleObject Constructor(dbiSchedule) | Initializes a new instance of the dbiScheduleObject class.
dbiScheduleObject Constructor(dbiSchedule,XmlNodeList) | Initializes a new instance of the dbiScheduleObject class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

dbiScheduleObject Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor()

Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiScheduleObject()
C#
public dbiScheduleObject()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

dbiScheduleObject Constructor(DateTime,DateTime)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor(DateTime,DateTime)

dtStart
The Start DateTime for the new dbiScheduleObject
dtEnd
The End DateTime for the new dbiScheduleObject
Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date

Dim instance As New dbiScheduleObject(dtStart, dtEnd)
C#
public dbiScheduleObject(
   System.DateTime dtStart,
   System.DateTime dtEnd
)

Parameters

dtStart
The Start DateTime for the new dbiScheduleObject
dtEnd
The End DateTime for the new dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

dbiScheduleObject Constructor(dbiSchedule)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor(dbiSchedule)

objCtrl
The dbiSchedule object.
Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim objCtrl As dbiSchedule

Dim instance As New dbiScheduleObject(objCtrl)
C#
public dbiScheduleObject(
   dbiSchedule objCtrl
)

Parameters

objCtrl
The dbiSchedule object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

dbiScheduleObject Constructor(dbiSchedule,XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > dbiScheduleObject Constructor : dbiScheduleObject Constructor(dbiSchedule,XmlNodeList)

objCtrl
The dbiSchedule object.
xmlNodes
An XMLNodeList object.
Initializes a new instance of the dbiScheduleObject class.

Syntax

Visual Basic (Usage) Copy Code
Dim objCtrl As dbiSchedule
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiScheduleObject(objCtrl, xmlNodes)
C#
public dbiScheduleObject(
   dbiSchedule objCtrl,
   System.Xml.XmlNodeList xmlNodes
)

Parameters

objCtrl
The dbiSchedule object.
xmlNodes
An XMLNodeList object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

BeginInvoke Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BringToFront Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CreateControl() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CreateControl() Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.CreateControl()
C#
public void CreateControl()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CreateGraphics Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CreateObjRef Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Dispose() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Dispose() Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DoDragDrop Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DrawToBitmap Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DrawToBitmap Method

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.
Supports rendering to the specified bitmap.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
The bitmap to be drawn to.
targetBounds
The bounds within which the control is rendered.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

EndInvoke Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

FindForm Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Focus Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetContainerControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetNextControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GetPreferredSize Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GetPreferredSize Method

proposedSize
The custom-sized area for a control.
Retrieves the size of a rectangular area into which a control can be fitted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize
The custom-sized area for a control.

Return Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Hide Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Invalidate Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Invoke Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LogicalToDeviceUnits Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LogicalToDeviceUnits Method

value

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer
Dim value As System.Integer

value = instance.LogicalToDeviceUnits(value)
C#
public System.int LogicalToDeviceUnits(
   System.int value
)

Parameters

value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PerformLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PointToClient Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PointToScreen Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PreProcessControlMessage Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PreProcessControlMessage Method

msg
A System.Windows.Forms.Message that represents the message to process.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message that represents the message to process.

Return Value

One of the System.Windows.Forms.PreProcessControlState values, depending on whether System.Windows.Forms.Control.PreProcessMessage(System.Windows.Forms.Message@) is true or false and whether System.Windows.Forms.Control.IsInputKey(System.Windows.Forms.Keys) or System.Windows.Forms.Control.IsInputChar(System.Char) are true or false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RectangleToClient Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Refresh Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ResetText Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ResetText Method

Resets the System.Windows.Forms.Control.Text property to its default value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ResumeLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Scale(SizeF) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Scale Method : Scale(SizeF) Method

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.
Scales the control and all child controls by the specified scaling factor.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
public void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor
A System.Drawing.SizeF containing the horizontal and vertical scaling factors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

ScaleBitmapLogicalToDevice Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ScaleBitmapLogicalToDevice Method

logicalBitmap

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim logicalBitmap As System.Drawing.Bitmap

instance.ScaleBitmapLogicalToDevice(logicalBitmap)
C#
public void ScaleBitmapLogicalToDevice(
   ref System.Drawing.Bitmap logicalBitmap
)

Parameters

logicalBitmap

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Select() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SelectNextControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SendToBack Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetBounds Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Show Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SuspendLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ToString Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ToString Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Update Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AccessibleName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AccessibleRole Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AltColorEven Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AltColorEven Property

Gets or sets the background color of the even numbers list items in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.AltColorEven = value

value = instance.AltColorEven
C#
public virtual System.Drawing.Color AltColorEven {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

This property is only applied when AlternateColor is equal to True. The frequency of the AltColorEven and AltColorOdd are defined by the AlternateItems property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

AltColorOdd Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AltColorOdd Property

Gets or sets the background color of the odd numbers list items in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.AltColorOdd = value

value = instance.AltColorOdd
C#
public virtual System.Drawing.Color AltColorOdd {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

This property is only applied when AlternateColor is equal to True. The frequency of the AltColorEven and AltColorOdd are defined by the AlternateItems property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

AlternateColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AlternateColor Property

Determines if the item background colors in the schedule area will be painted with alternating colors.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.AlternateColor = value

value = instance.AlternateColor
C#
public virtual System.bool AlternateColor {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

When this property is set to True, the background colors are painted with the AltColorEven and AltColorOdd properties. The AlternateItems property will be determine the frequency of the background colors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

AlternateItems Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AlternateItems Property

Gets or sets the frequency of the alternating background colors.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.AlternateItems = value

value = instance.AlternateItems
C#
public virtual System.int AlternateItems {get; set;}

Property Value

An Integer value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

This property is only applied when the AlternateColor property is equal to True. The item background colors are defined by the AltColorEven and AltColorOdd properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

Anchor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

AutoScrollOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : AutoScrollOffset Property

Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control).

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
public virtual System.Drawing.Point AutoScrollOffset {get; set;}

Property Value

A System.Drawing.Point specifying the scroll location. The default is the upper-left corner of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackColor Property

Gets or sets the background color of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public new System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

When displaying alternate line colors (AlternateColor equal True), the background color will appear behind the alternating colors.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

BackgroundImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackgroundImage Property

Gets or sets the background image for the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public new System.Drawing.Image BackgroundImage {get; set;}

Property Value

A System.Drawing.Image value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).BackgroundImage = System.Drawing.Image.FromFile("C:\BackImage.bmp")
C# Copy Code
this.dbiSchedule.Schedule[0].BackgroundImage = System.Drawing.Image.FromFile("C:\\Backimage.bmp");

Remarks

The ImageEffect property will deterimine if the image will be tiled or use a type of alignment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

BackgroundImageLayout Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackgroundImageLayout Property

Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}

Property Value

One of the values of System.Windows.Forms.ImageLayout (System.Windows.Forms.ImageLayout.Center , System.Windows.Forms.ImageLayout.None, System.Windows.Forms.ImageLayout.Stretch, System.Windows.Forms.ImageLayout.Tile, or System.Windows.Forms.ImageLayout.Zoom). System.Windows.Forms.ImageLayout.Tile is the default value.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The specified enumeration value does not exist.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BindingContext Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Bottom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Bounds Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CanFocus Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CanSelect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Capture Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CausesValidation Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ClientRectangle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ClientSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ClientSize Property

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CompanyName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContactID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContactID Property

Assigns a contact to the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.ContactID = value

value = instance.ContactID
C#
public virtual System.string ContactID {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).ContactID = "Contact1"
C# Copy Code
this.dbiSchedule.Schedules[0].ContactID = "Contact1";

Remarks

This property must equal a valid contact Entry ID. Contacts are defined by the dbi.PIM.dbiContactItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Container Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContainsFocus Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContextMenu Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContextMenuStrip Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContextMenuStrip Property

Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}

Property Value

The System.Windows.Forms.ContextMenuStrip for this control, or null if there is no System.Windows.Forms.ContextMenuStrip. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Controls Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Created Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Cursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DataBindings Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DateFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DateFormat Property

Gets or sets the date format of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.DateFormat = value

value = instance.DateFormat
C#
public System.string DateFormat {get; set;}

Property Value

A String value.

The following characters can be used in the date format:

D - the day of the week defined in the DayNames property

n - the month date

N - 2 digit

m - the numeric value of the month

M - the month name defined in the MonthNames property

y - 2 digit year

Y - 4 digit year

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).DateFormat = "D n/y"
C# Copy Code
this.dbiSchedule.Schedules[0].DateFormat = "D n/y";

Remarks

The date is only displayed when SplitRuler is equal to true and the RulerTitle property is equal to "".

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Miscellaneous Features
Schedules


%%PageItemTitle%%

DayLength Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DayLength Property

Gets or sets the number of characters used to represent the days of the week.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.DayLength = value

value = instance.DayLength
C#
public virtual System.int DayLength {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).DayLength = 3
C# Copy Code
this.dbiSchedule.Schedules[0].DayLength = 3;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DeviceDpi Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DeviceDpi Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

value = instance.DeviceDpi
C#
public System.int DeviceDpi {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayBody Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayBody Property

Determines if the body text will be displayed in the Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayBody = value

value = instance.DisplayBody
C#
public virtual System.bool DisplayBody {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).DisplayBody = True
C# Copy Code
this.dbiSchedule.Schedules[0].DisplayBody = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
An Overview of the Timebar Object


%%PageItemTitle%%

DisplayDays Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayDays Property

Determines if the days of the week will be displayed with the major time segments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayDays = value

value = instance.DisplayDays
C#
public virtual System.bool DisplayDays {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).DisplayDays = True
C# Copy Code
this.dbiSchedule.Schedules[0].DisplayDays = true;

Remarks

The days of the week will only be displayed when TimeType is equal to Days. The days of the week are defined by the DayNames property. The length of the day names can be adjusted using the DayLength property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayOverlap Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayOverlap Property

Determines if overlap lines will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayOverlap = value

value = instance.DisplayOverlap
C#
public virtual System.bool DisplayOverlap {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).DisplayOverlap = True
C# Copy Code
this.dbiSchedule1.Schedules[0].DisplayOverlap = true;

Remarks

When set to True, overlap lines can be customized using the OverlapColor, OverlapSpan and OverlapWidth properties. The overlap lines will appear above and below where the Timebars overlap.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Displaying and Determining Timebar Conflicts


%%PageItemTitle%%

DisplayRectangle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayRectangle Property

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DisplayTimeBarDates Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayTimeBarDates Property

Determines if the start and end date will be displayed in the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayTimeBarDates = value

value = instance.DisplayTimeBarDates
C#
public virtual System.bool DisplayTimeBarDates {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).DisplayTimebarDates = True
C# Copy Code
this.dbiSchedule.Schedules[0].DisplayTimebarDates = true;

Remarks

The color of the dates are defined in the TimebarDateColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
An Overview of the Timebar Object


%%PageItemTitle%%

DisplayTimeLines Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayTimeLines Property

Determines if lines will be displayed for major time segments through the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayTimeLines = value

value = instance.DisplayTimeLines
C#
public virtual System.bool DisplayTimeLines {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).DisplayTimeLines = True
C# Copy Code
this.dbiSchedule1.Schedules[0].DisplayTimeLines = true;

Remarks

When set to true, the time lines can be customized using the TimeLineBreak, TimeLineColor, TimeLineStart and TimeLineWidth properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

DisplayUserDrawnRulerSegments Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DisplayUserDrawnRulerSegments Property

Determines if an additional row will be displayed inside the ruler, between the title and timeline areas.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.DisplayUserDrawnRulerSegments = value

value = instance.DisplayUserDrawnRulerSegments
C#
public virtual System.bool DisplayUserDrawnRulerSegments {get; set;}

Property Value

Boolean

Remarks

*** Enterprise Only***

The additional row is a blank area for the developer to customize the appearance of in a manner of their choosing.

The UserDrawnRulerSegment Event is used to customize the appearance of each segment of the displayed row.

The segments align with the major time units of the timeline portion of the ruler.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Disposing Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Dock Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Enabled Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

End Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : End Property

Gets or sets the end date and time of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Date

instance.End = value

value = instance.End
C#
public virtual System.DateTime End {get; set;}

Property Value

A System.DateTime value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

The start date and time of a schedule is defined by the Start property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Schedules


%%PageItemTitle%%

FirstDayOfWeek Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : FirstDayOfWeek Property

Gets or sets the starting day of the week in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumFirstDayOfWeek

instance.FirstDayOfWeek = value

value = instance.FirstDayOfWeek
C#
public dbiScheduleObject.enumFirstDayOfWeek FirstDayOfWeek {get; set;}

Property Value

A dbiScheduleObject.enumFirstDayOfWeek member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).FirstDayOfWeek = Dbi.WinControl.Schedule.dbiScheduleObject.enumFirstDayOfWeek.Monday
C# Copy Code
this.dbiSchedule.Schedules[0].FirstDayOfWeek = Dbi.WinControl.Schedule.dbiScheduleObject.enumFirstDayOfWeek.Monday;

Remarks

This property will determine how the weeks are displayed in the ruler portion of the control. It is only applied when the TimeType property is equal to Weeks.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Focused Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Font Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ForeColor Property

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GuideLines Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GuideLines Property

A collection of GuideLines to display in the Schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiGuideLineCollection

value = instance.GuideLines
C#
public dbiGuideLineCollection GuideLines {get;}

Remarks

For more information see the Developing With - GuideLines

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Handle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HasChildren Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HeaderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HeaderColor Property

Gets or sets the background color of a header item in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.HeaderColor = value

value = instance.HeaderColor
C#
public virtual System.Drawing.Color HeaderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).HeaderColor = System.Drawing.Color.LightSteelBlue
C# Copy Code
this.dbiSchedule.Schedules[0].HeaderColor = System.Drawing.Color.LightSteelBlue;

Remarks

This property is applied to item whose Header property is set to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

Height Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HorzGridLines Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HorzGridLines Property

Determines if horizontal grid lines will be displayed in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.HorzGridLines = value

value = instance.HorzGridLines
C#
public virtual System.bool HorzGridLines {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).HorzGridLines = True
C# Copy Code
this.dbiSchedule.Schedules[0].HorzGridLines = true;

Remarks

When set to false, no lines will be displayed between items in the schedule area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ImageAlignment Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ImageAlignment Property

Gets or sets the vertical and horizontal alignment of the background image in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.ContentAlignment

instance.ImageAlignment = value

value = instance.ImageAlignment
C#
public System.Drawing.ContentAlignment ImageAlignment {get; set;}

Property Value

A ContentAlignment member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).ImageAlignment = ContentAlignment.MiddleCenter
C# Copy Code
this.dbiSchedule.Schedules[0].ImageAlignment = ContentAlignment.MiddleCenter;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ImageEffect Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ImageEffect Property

Determines how the background image in the schedule will be displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumImageEffect

instance.ImageEffect = value

value = instance.ImageEffect
C#
public dbiScheduleObject.enumImageEffect ImageEffect {get; set;}

Property Value

A dbiScheduleObject.enumImageEffect member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).ImageEffect = Dbi.WinControl.Schedule.dbiScheduleObject.enumImageEffect.Align
C# Copy Code
this.dbiSchedule.Schedules[0].ImageEffect = Dbi.WinControl.Schedule.dbiScheduleObject.enumImageEffect.Align;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

ImageOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ImageOffset Property

Gets or sets the vertical and horizontal offset values used to calculate the position of the background image.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Point

instance.ImageOffset = value

value = instance.ImageOffset
C#
public System.Drawing.Point ImageOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).ImageOffset = New Point(2,4)
C# Copy Code
this.dbiSchedule.Schedules[0].ImageOffset = new System.Drawing.Point(2,4);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ImeMode Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

InvokeRequired Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

IsAccessible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

IsDisposed Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

IsMirrored Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : IsMirrored Property

Gets a value indicating whether the control is mirrored.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.IsMirrored
C#
public System.bool IsMirrored {get;}

Property Value

true if the control is mirrored; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LayoutEngine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LayoutEngine Property

Gets a cached instance of the control's layout engine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}

Property Value

The System.Windows.Forms.Layout.LayoutEngine for the control's contents.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Left Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMaxSize Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LineMaxSize Property

Gets or sets the height of the lines marking the major time segments in the ruler of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.LineMaxSize = value

value = instance.LineMaxSize
C#
public virtual System.int LineMaxSize {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).LineMaxSize = 5
C# Copy Code
this.dbiSchedule.Schedules[0].LineMaxSize = 5;

Remarks

The height of the minor time segments are defined by the LineMinSize.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LineMinSize Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LineMinSize Property

Gets or sets the height of the lines marking the minor time segments in the ruler of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.LineMinSize = value

value = instance.LineMinSize
C#
public virtual System.int LineMinSize {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).LineMinSize = 3
C# Copy Code
this.dbiSchedule.Schedules[0].LineMinSize = 3;

Remarks

The height of the major time segments are defined by the LineMaxSize.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Location Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LocationID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LocationID Property

Assigns a location to the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.LocationID = value

value = instance.LocationID
C#
public virtual System.string LocationID {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).LocationID = "LOCATION1"
C# Copy Code
this.dbiSchedule.Schedules[0].LocationID = "LOCATION1";

Remarks

This property must equal a valid location Entry ID. Locations are defined by the dbi.PIM.dbiLocationItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MajorTimeLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MajorTimeLine Property

Determines whether a full vertical line will be drawn at major time segments in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.MajorTimeLine = value

value = instance.MajorTimeLine
C#
public virtual System.bool MajorTimeLine {get; set;}

Property Value

Boolean

Remarks

When set to true, a vertical line is drawn at set intervals of the ruler in a ScheduleObject (example: when TimeType = Hours, the line is drawn at the start of each day). When set to false, this line will not be drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Margin Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Margin Property

Gets or sets the space between controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Padding

instance.Margin = value

value = instance.Margin
C#
public System.Windows.Forms.Padding Margin {get; set;}

Property Value

A System.Windows.Forms.Padding representing the space between controls.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MaximumSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MaximumSize Property

Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MinimumSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MinimumSize Property

Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

An ordered pair of type System.Drawing.Size representing the width and height of a rectangle.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MonthFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MonthFormat Property

Determines how the monthly ruler is displayed in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumMonthFormat

instance.MonthFormat = value

value = instance.MonthFormat
C#
public dbiScheduleObject.enumMonthFormat MonthFormat {get; set;}

Property Value

A dbiScheduleObject.enumMonthFormat value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).MonthFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumMonthFormat.Dates
C# Copy Code
this.dbiSchedule.Schedules[0].MonthFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumMonthFormat.Dates;

Remarks

This property is only applicable when TimeType is equal to Months. The TimeDistance property is used to adjust the amount of space between each major time segment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Name Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

OverlapColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : OverlapColor Property

Gets or sets the color of the overlap lines in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.OverlapColor = value

value = instance.OverlapColor
C#
public virtual System.Drawing.Color OverlapColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).OverlapColor = System.Drawing.Color.Blue
C# Copy Code
this.dbiSchedule.Schedules[0].OverlapColor = System.Drawing.Color.Blue;

Remarks

This property is only applicable when DisplayOverlap is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Displaying and Determining Time Bar Conflicts


%%PageItemTitle%%

OverlapSpan Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : OverlapSpan Property

Determines when the overlap lines will appear between 2 Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.TimeSpan

instance.OverlapSpan = value

value = instance.OverlapSpan
C#
public virtual System.TimeSpan OverlapSpan {get; set;}

Property Value

A TimeSpan value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
'The overlap lines will appear when a time bar's start time is within 1
'hour of anothers end time.
Me.DbiSchedule1.Schedules(0).OverlapSpan = System.TimeSpan.FromHours(1)
C# Copy Code
//The overlap lines will appear when a time bar's start time is within 1
//hour of anothers end time.
this.DbiSchedule1.Schedules[0].OverlapSpan = System.TimeSpan.FromHours(1);

Remarks

This property is only applicable when DisplayOverlap is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Displaying and Determining Timebar Conflicts


%%PageItemTitle%%

OverlapWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : OverlapWidth Property

Gets or sets the width of the overlap lines in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.OverlapWidth = value

value = instance.OverlapWidth
C#
public virtual System.int OverlapWidth {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).OverlapWidth = 3
C# Copy Code
this.dbiSchedule.Schedules[0].OverlapWidth = 3;

Remarks

This property is only applicable when DisplayOverlap is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Displaying and Determining Time Bar Conflicts


%%PageItemTitle%%

Padding Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Padding Property

Gets or sets padding within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
public System.Windows.Forms.Padding Padding {get; set;}

Property Value

A System.Windows.Forms.Padding representing the control's internal spacing characteristics.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Parent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PreferredSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PreferredSize Property

Gets the size of a rectangular area into which the control can fit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
public System.Drawing.Size PreferredSize {get;}

Property Value

A System.Drawing.Size containing the height and width, in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ProductName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ProductVersion Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Region Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Right Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RightToLeft Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerAlign Property

Gets or sets the position of the ruler text in the schedule

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumRulerAlign

instance.RulerAlign = value

value = instance.RulerAlign
C#
public dbiScheduleObject.enumRulerAlign RulerAlign {get; set;}

Property Value

A dbiScheduleObject.enumRulerAlign member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

This property only effects the bottom portion on the ruler when SplitRuler is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerBackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerBackColor Property

Gets or sets the primary background color of the ruler area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerBackColor = value

value = instance.RulerBackColor
C#
public virtual System.Drawing.Color RulerBackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

The secondary background color is defined by the RulerBackColorTo property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerBackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerBackColorTo Property

Gets or sets the secondary background color of the ruler area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerBackColorTo = value

value = instance.RulerBackColorTo
C#
public virtual System.Drawing.Color RulerBackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

This property is only visible when RulerFillType is not equal to solid. The primary background color is defined by the RulerBackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerBorder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerBorder Property

Gets or sets the type of border to place around the ruler area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumBorderType

instance.RulerBorder = value

value = instance.RulerBorder
C#
public enumBorderType RulerBorder {get; set;}

Property Value

A Dbi.enumBorderType member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.DbiSchedule1.Schedules(0).RulerBorder = Dbi.enumBorderType.Raised
C# Copy Code
this.dbiSchedule1.Schedules[0].RulerBorder = Dbi.enumBorderType.Raised;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerDivisions Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerDivisions Property

Gets or sets the number of divisions to place in the ruler area between major time units

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.RulerDivisions = value

value = instance.RulerDivisions
C#
public virtual System.int RulerDivisions {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

The divisions will be separated by the minor time lines.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerFillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerFillType Property

Gets or sets the fill style for the ruler area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumFillType

instance.RulerFillType = value

value = instance.RulerFillType
C#
public enumFillType RulerFillType {get; set;}

Property Value

A Dbi.enumFillType member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Remarks

The primary and secondary background colors are defined by the RulerBackColor and RulerBackColorTo properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerFont Property

Gets or sets the ruler font in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Font

instance.RulerFont = value

value = instance.RulerFont
C#
public System.Drawing.Font RulerFont {get; set;}

Property Value

A Font object

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).RulerFont = New Font("Verdana", 10)
C# Copy Code
this.dbiSchedule1.Schedules[0].RulerFont = new Font("Verdana", 10);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerForeColor Property

Gets or sets the text color of the ruler area in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerForeColor = value

value = instance.RulerForeColor
C#
public virtual System.Drawing.Color RulerForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).RulerForeColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule1.Schedules(0).RulerForeColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerLineColor Property

Gets or sets the color of the lines in the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerLineColor = value

value = instance.RulerLineColor
C#
public virtual System.Drawing.Color RulerLineColor {get; set;}

Property Value

A System.Drawing.Color value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).RulerLineColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.Schedules[0].RulerLineColor = System.Drawing.Color.Black;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerOffset Property

Gets or sets the vertical and horizontal offset values of the ruler text in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Point

instance.RulerOffset = value

value = instance.RulerOffset
C#
public System.Drawing.Point RulerOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).RulerOffset = New Point(2,-5)
C# Copy Code
this.dbiSchedule.Schedules[0].RulerOffset = new Point(2,-5);

Remarks

This property will only be applied to the bottom area of the ruler when SplitRuler is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerThreeD Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerThreeD Property

Determines if the ruler area will appear with some three dimensional features.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.RulerThreeD = value

value = instance.RulerThreeD
C#
public virtual System.bool RulerThreeD {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).RulerThreeD = True
C# Copy Code
this.dbiSchedule1.Schedules[0].RulerThreeD = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitle Property

Gets or sets the ruler title in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.RulerTitle = value

value = instance.RulerTitle
C#
public virtual System.string RulerTitle {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).RulerTitle = "Schedule 1"
C# Copy Code
this.dbiSchedule.Schedules[0].RulerTitle = "Schedule 1";

Remarks

The title area is only displayed when SplitRuler is equal to true. If no value is defined for this property, the RulerText will a date based on the DateFormat property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitleBackColor Property

Determines the background color of the title area of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerTitleBackColor = value

value = instance.RulerTitleBackColor
C#
public virtual System.Drawing.Color RulerTitleBackColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleBackColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitleBackColorTo Property

Determines the secondary background color of the title area of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerTitleBackColorTo = value

value = instance.RulerTitleBackColorTo
C#
public virtual System.Drawing.Color RulerTitleBackColorTo {get; set;}

Property Value

color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitleFillType Property

Determines the background pattern for the title area of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumFillType

instance.RulerTitleFillType = value

value = instance.RulerTitleFillType
C#
public enumFillType RulerTitleFillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleFont Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitleFont Property

Determines the font used for the text in the title area of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Font

instance.RulerTitleFont = value

value = instance.RulerTitleFont
C#
public System.Drawing.Font RulerTitleFont {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RulerTitleForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RulerTitleForeColor Property

Determines the foreground color used for the title area of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.RulerTitleForeColor = value

value = instance.RulerTitleForeColor
C#
public virtual System.Drawing.Color RulerTitleForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ScheduleLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ScheduleLineColor Property

Gets or sets the color of the horizontal lines seperating the list items in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.ScheduleLineColor = value

value = instance.ScheduleLineColor
C#
public virtual System.Drawing.Color ScheduleLineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).ScheduleLineColor = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule.Schedules[0].ScheduleLineColor = System.Drawing.Color.Black;

Remarks

This color will be applied to all the seperator lines in the schedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SelectedBackColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SelectedBackColor Property

Gets or sets the background color of selected list items in the schedule area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.SelectedBackColor = value

value = instance.SelectedBackColor
C#
public virtual System.Drawing.Color SelectedBackColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Site Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Size Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Size Property

Gets or sets the height and width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SplitRuler Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SplitRuler Property

Determines if the ruler will be split along the vertical axis.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.SplitRuler = value

value = instance.SplitRuler
C#
public virtual System.bool SplitRuler {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).SplitRuler = True
C# Copy Code
this.dbiSchedule.Schedules[0].RulerTitle = true;

Remarks

If set the true, the bottom portion of the ruler will display the time units. The upper portion will display information about the current time and date being displayed. The format for the upper display is defined by the DateFormat and RulerTitle properties. The text can be further customized using the ValuePoint event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Schedules


%%PageItemTitle%%

Start Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Start Property

Gets or sets the start date and time of a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public virtual System.DateTime Start {get; set;}

Property Value

A System.DateTime value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Remarks

The end date and time of a schedule is defined by the End property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Schedules


%%PageItemTitle%%

TabIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TabIndex Property

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public System.int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TabStop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
C#
public System.bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true.This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TaskID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TaskID Property

Assign a task to the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.TaskID = value

value = instance.TaskID
C#
public virtual System.string TaskID {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).TaskID = "Task1"
C# Copy Code
this.dbiSchedule.Schedules[0].TaskID = "Task1";

Remarks

This property must equal a valid task Entry ID. Tasks are defined by dbi.PIM.dbiTaskItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeBarDateColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeBarDateColor Property

Gets or sets the color of the Timebar dates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.TimeBarDateColor = value

value = instance.TimeBarDateColor
C#
public virtual System.Drawing.Color TimeBarDateColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).TimebarDateColor = System.Drawing.Color.White
C# Copy Code
this.dbiSchedule.Schedules[0].TimebarDateColor = System.Drawing.Color.White;

Remarks

This property is only applicable when DisplayTimebarDates is equal to true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeDistance Property

Gets or sets the distance between major time units for this dbiScheduleObject

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.TimeDistance = value

value = instance.TimeDistance
C#
public virtual System.int TimeDistance {get; set;}

Property Value

Integer

Remarks

When the TimeType is equal to Hours, Days or Weeks the TimeDistance represents the distance between major time units. When TimeType is equal to Months or Years, the TimeDistance represents the distance between days.

This property is only used when assigned a value greater than 3, otherwise the schedule will use the value assigned to the main control's TimeDistance Property instead.

NOTE: When printing this property is currently ignored, and the control's PrintTimeDistance Property is used instead for all dbiScheduleObjects being printed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeFormat Property

Determines how the hours in the ruler are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.TimeFormat = value

value = instance.TimeFormat
C#
public System.string TimeFormat {get; set;}

Property Value

A String value

The following characters can be used in the time format:

s - seconds

m - minutes

h - hours

d - day of month

M - the numeric value of the month

yy - 2 digit year

yyyy - 4 digit year.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedule(0).TimeFormat = "h:mm"
C# Copy Code
this.dbiSchedule.Schedules[0].TimeFormat = "h:mm";

Remarks

This property is only applicable when TimeType is equal to Hours.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Miscellaneous Features


%%PageItemTitle%%

TimeLineBreak Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeLineBreak Property

Gets or sets the frequency of the time lines along the major time units in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.TimeLineBreak = value

value = instance.TimeLineBreak
C#
public System.int TimeLineBreak {get; set;}

Property Value

An Integer value, indicating the frequency of the time lines across major time units. For instance, if TimeType is equal to Days, and this property is equal to 2, the time lines lines will appear every 2 days.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).TimeLineBreak = 2
C# Copy Code
this.dbiSchedule1.Schedules[0].TimeLineBreak = 2;

Remarks

This property is only applicable when DisplayTimeLines is equal to true. Additional settings for the time lines can be defined in the TimeLineColor, TimeLineStart and TimeLineWidth properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeLineColor Property

Gets or sets the color of the time lines in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.TimeLineColor = value

value = instance.TimeLineColor
C#
public virtual System.Drawing.Color TimeLineColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).TimeLineBreak = System.Drawing.Color.Black
C# Copy Code
this.dbiSchedule1.Schedules[0].TimeLineBreak = System.Drawing.Color.Black;

Remarks

This property is only applicable when DisplayTimeLines is equal to true. Additional settings for the time lines can be defined in the TimeLineBreak, TimeLineStart and TimeLineWidth properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

TimeLineStart Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeLineStart Property

Gets or sets the major division where the first time line will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.TimeLineStart = value

value = instance.TimeLineStart
C#
public System.int TimeLineStart {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
'The first time line will appear at the second major division
Me.dbiSchedule1.Schedules(0).TimeLineStart = 2
C# Copy Code
//The first time line will appear at the second major division
this.dbiSchedule1.Schedules[0].TimeLineStart = 2

Remarks

This property is only applicable when DisplayTimeLines is equal to true. Additional settings for the time lines can be defined in the TimeLineBreak, TimeLineColor, and TimeLineWidth properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TimeLineWidth Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeLineWidth Property

Gets or sets the width of the time lines in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumTimeLineWidth

instance.TimeLineWidth = value

value = instance.TimeLineWidth
C#
public dbiScheduleObject.enumTimeLineWidth TimeLineWidth {get; set;}

Property Value

A dbiScheduleObject.enumTimeLineWidth member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).TimeLineWidth = Dbi.WinControl.Schedule.dbiScheduleObject.enumTimeLineWidth.Solid
C# Copy Code
this.dbiSchedule1.Schedules[0].TimeLineWidth = Dbi.WinControl.Schedule.dbiScheduleObject.enumTimeLineWidth.Solid;

Remarks

This property is only applicable when DisplayTimeLines is equal to true. Additional settings for the time lines can be defined in the TimeLineBreak, TimeLineColor, and TimeLineStart properties.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

TimeType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TimeType Property

Gets or sets the type of unit to display in the ruler of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As enumTimeType

instance.TimeType = value

value = instance.TimeType
C#
public enumTimeType TimeType {get; set;}

Property Value

A Dbi.WinControl.Schedule.enumTimeType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedules(0).TimeType = Dbi.WinControl.Schedule.enumTimeType.Days
C# Copy Code
this.dbiSchedule.Schedules[0].TimeType = Dbi.WinControl.Schedule.enumTimeType.Days;

Remarks

The YearFormat or MonthFormat properties indicate how the rulers are displayed when the TimeType is equal to Years and Months.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule
Setting Up Different Views
Schedules


%%PageItemTitle%%

Top Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TopLevelControl Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

UseWaitCursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
public System.bool UseWaitCursor {get; set;}

Property Value

true to use the wait cursor for the current control and all child controls; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Visible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Visible Property

Gets or sets a value indicating whether the dbiScheduleObject will be visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public new System.bool Visible {get; set;}

Property Value

Boolantrue if the control and all its child controls are displayed; otherwise, false. The default is true.

Remarks

**Used in Enterprise Version Only**

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

WeekendColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : WeekendColor Property

Gets or sets the background color for weekend columns.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Drawing.Color

instance.WeekendColor = value

value = instance.WeekendColor
C#
public virtual System.Drawing.Color WeekendColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Schedule(0).WeekendColor = System.Drawing.Color.Silver
C# Copy Code
this.dbiSchedule.Schedule[0].WeekendColor = System.Drawing.Color.Silver;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Coloring the Background of a Schedule


%%PageItemTitle%%

WeekFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : WeekFormat Property

Determines how the monthly ruler is displayed in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumWeekFormat

instance.WeekFormat = value

value = instance.WeekFormat
C#
public dbiScheduleObject.enumWeekFormat WeekFormat {get; set;}

Property Value

A dbiScheduleObject.enumWeekFormat value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).WeekFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumWeekFormat.FourDayWeek
C# Copy Code
this.dbiSchedule1.Schedules[0].WeekFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumWeekFormat.FourDayWeek;

Remarks

This property is only applicable when TimeType is equal to Weeks. The TimeDistance property is used to adjust the amount of space between each major time segment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Width Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : XMLString Property

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = objSchedule.XMLString()
C# Copy Code
string strXML;
strXML = objSchedule.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

YearFormat Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : YearFormat Property

Determines how the yearly ruler is displayed in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim value As dbiScheduleObject.enumYearFormat

instance.YearFormat = value

value = instance.YearFormat
C#
public dbiScheduleObject.enumYearFormat YearFormat {get; set;}

Property Value

A dbiScheduleObject.enumYearFormat value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Schedules(0).YearFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumYearFormat.Months
C# Copy Code
this.dbiSchedule1.Schedules[0].YearFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumYearFormat.Months;

Remarks

This property is only applicable when TimeType is equal to Years. The TimeDistance property is used to adjust the amount of space between each major time segment.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BackColorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BackgroundImageChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackgroundImageChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event System.EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BackgroundImageLayoutChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BackgroundImageLayoutChanged Event

Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
public event System.EventHandler BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ChangeUICues Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Click Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ClientSizeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ClientSizeChanged Event

Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
public event System.EventHandler ClientSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ContextMenuStripChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ContextMenuStripChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
public event System.EventHandler ContextMenuStripChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ControlAdded Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ControlRemoved Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

CursorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Disposed Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DockChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DpiChangedAfterParent Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DpiChangedAfterParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.DpiChangedAfterParent, handler
C#
public event System.EventHandler DpiChangedAfterParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DpiChangedBeforeParent Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DpiChangedBeforeParent Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.DpiChangedBeforeParent, handler
C#
public event System.EventHandler DpiChangedBeforeParent

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DragDrop Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DragEnter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DragLeave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

DragOver Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

EnabledChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Enter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

FontChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GiveFeedback Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

GotFocus Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HandleCreated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

HelpRequested Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Invalidated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

KeyDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

KeyPress Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

KeyUp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Layout Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Leave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LocationChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

LostFocus Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MarginChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MarginChanged Event

Occurs when the control's margin changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.MarginChanged, handler
C#
public event System.EventHandler MarginChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseCaptureChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseCaptureChanged Event

Occurs when the control loses mouse capture.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
public event System.EventHandler MouseCaptureChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseClick Event

Occurs when the control is clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseDoubleClick Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseDoubleClick Event

Occurs when the control is double clicked by the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseEnter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseHover Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseLeave Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseMove Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseUp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

MouseWheel Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Move Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PaddingChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PaddingChanged Event

Occurs when the control's padding changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
public event System.EventHandler PaddingChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Paint Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Paint Event

Occurs when the control is redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
public event System.Windows.Forms.PaintEventHandler Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

ParentChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

PreviewKeyDown Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : PreviewKeyDown Event

Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RegionChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RegionChanged Event

Occurs when the value of the System.Windows.Forms.Control.Region property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
public event System.EventHandler RegionChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Resize Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SizeChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

StyleChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TabIndexChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TabIndexChanged Event

Occurs when the System.Windows.Forms.Control.TabIndex property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.TabIndexChanged, handler
C#
public event System.EventHandler TabIndexChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TabStopChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TabStopChanged Event

Occurs when the System.Windows.Forms.Control.TabStop property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.TabStopChanged, handler
C#
public event System.EventHandler TabStopChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

TextChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Validated Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Validating Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

VisibleChanged Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

dbiTimeBarItem Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarItem Class

Provides properties for defining a Timebar.

Object Model

dbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
C#
public class dbiTimeBarItem : Dbi.PIM.dbiAppointmentItem

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiAppointmentItem
Dbi.WinControl.Schedule.dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiTimeBarItem Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : dbiTimeBarItem Constructor

Initializes a new instance of the dbiAppointmentItem class.

Overload List

Overload | Description
dbiTimeBarItem Constructor() | Initializes a new instance of the dbiTimebarItem class.
dbiTimeBarItem Constructor(DateTime,DateTime) | Initializes a new instance of the dbiTimebarItem class.
dbiTimeBarItem Constructor(dbiTimeBarItem) | Initializes a new instance of the dbiTimebarItem class.
dbiTimeBarItem Constructor(dbiAppointmentItem) | Initializes a new instance of the dbiTimebarItem class.
dbiTimeBarItem Constructor(XmlNodeList) | Initializes a new instance of the dbiTimebarItem class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

dbiTimeBarItem Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor()

Initializes a new instance of the dbiTimebarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTimeBarItem()
C#
public dbiTimeBarItem()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(DateTime,DateTime)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(DateTime,DateTime)

dtStart
The start date and time of the Timebar.
dtEnd
The end date and time of the Timebar.
Initializes a new instance of the dbiTimebarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim dtStart As System.Date
Dim dtEnd As System.Date

Dim instance As New dbiTimeBarItem(dtStart, dtEnd)
C#
public dbiTimeBarItem(
   System.DateTime dtStart,
   System.DateTime dtEnd
)

Parameters

dtStart
The start date and time of the Timebar.
dtEnd
The end date and time of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(dbiTimeBarItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(dbiTimeBarItem)

objItem
The dbiTimebarItem containing the Timebar information.
Initializes a new instance of the dbiTimebarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objItem As dbiTimeBarItem

Dim instance As New dbiTimeBarItem(objItem)
C#
public dbiTimeBarItem(
   dbiTimeBarItem objItem
)

Parameters

objItem
The dbiTimebarItem containing the Timebar information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(dbiAppointmentItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(dbiAppointmentItem)

objItem
The dbiAppointmentItem containing the Timebar information.
Initializes a new instance of the dbiTimebarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim objItem As dbiAppointmentItem

Dim instance As New dbiTimeBarItem(objItem)
C#
public dbiTimeBarItem(
   dbiAppointmentItem objItem
)

Parameters

objItem
The dbiAppointmentItem containing the Timebar information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

dbiTimeBarItem Constructor(XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class > dbiTimeBarItem Constructor : dbiTimeBarItem Constructor(XmlNodeList)

xmlNodes
The XMLNodeList containing appointment information.
Initializes a new instance of the dbiTimebarItem class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiTimeBarItem(xmlNodes)
C#
public dbiTimeBarItem(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XMLNodeList containing appointment information.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Overload List


%%PageItemTitle%%

Clone Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Clone Method

Creates a new object that is a copy of the current instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Object

value = instance.Clone()
C#
public System.object Clone()

Return Value

object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

AlarmEnd Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : AlarmEnd Property

Determines if an alarm will fire when the Timebar ends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.AlarmEnd = value

value = instance.AlarmEnd
C#
public virtual System.bool AlarmEnd {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(1).Timebars(0).AlarmEnd = True
C# Copy Code
this.dbiSchedule.Items[1].Timebars[0].AlarmEnd = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Timebar Alarms


%%PageItemTitle%%

AlarmStart Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : AlarmStart Property

Determines if an alarm will fire when the Timebar begins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.AlarmStart = value

value = instance.AlarmStart
C#
public virtual System.bool AlarmStart {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(1).Timebars[0].AlarmStart = True
C# Copy Code
this.dbiSchedule.Items[1].Timebars[0].AlarmStart = true;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Timebar Alarms


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : BackColor Property

Gets or sets the primary background color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem
DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar
'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;
DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();
DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar
this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : BackColorTo Property

Gets or sets the secondary background color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public virtual System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem objTimebar;

objTimeBar = new Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1),System.DateTime.Today.AddDays(4));

objTimebar.BackColor = System.Drawing.Color.SteelBlue; //Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal; //Sets the background fill type
objTimebar.Text = "Time Bar Text"; //Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center; //Sets the alignment of the primary text

objTimebar.StartImage = -2; //Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6; //Sets the image to appear after the time bar

//Inserts the time bar into the collection.  This time bar is now the first item in the collection
this.dbiSchedule1.Items[1].Timebars.Insert(0,objTimebar);

this.dbiSchedule1.BarToFront(objTimebar);

Remarks

This property is only applicable when dbiTimebarItem.FillType is not equal to Solid. The primary background color is defined by the dbiTimebarItem.BackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Body Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Body Property

Gets or sets the subtext of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.Body = value

value = instance.Body
C#
public virtual System.string Body {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Remarks

The body text is visible when DbiScheduleObject.DisplayBody is set to True.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

BodyForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : BodyForeColor Property

Determines the foreground color used for body text on a dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.BodyForeColor = value

value = instance.BodyForeColor
C#
public System.Drawing.Color BodyForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

BorderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : BorderColor Property

Gets or sets the border color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public virtual System.Drawing.Color BorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Remarks

This property is only applied when the dbiTimebarItem.BorderType is equal to Regular or RoundedEdge.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

BorderType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : BorderType Property

Gets or sets the type of border to place around the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As enumBorderType

instance.BorderType = value

value = instance.BorderType
C#
public override enumBorderType BorderType {get; set;}

Property Value

A dbi.enumBorderType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Base Implementation in BorderType


%%PageItemTitle%%

Cargo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Cargo Property

Gets or sets a non-visible text value for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.Cargo = value

value = instance.Cargo
C#
public virtual System.string Cargo {get; set;}

Property Value

A String value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(0).Cargo = "Value 1234"
C# Copy Code
this.dbiSchedule.Items[0].Timebars[0].Cargo = "Value 1234";

Remarks

This property is not visible to the end user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ContactID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ContactID Property

Assigns a contact to the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.ContactID = value

value = instance.ContactID
C#
public virtual System.string ContactID {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(0).ContactID = "Contact99"
C# Copy Code
this.dbiSchedule.Items[0].Timebars[0].ContactID = "Contact99";

Remarks

This property defines which contact to assign to the Timebar. The contact identication must be a valid contact Entry ID.

This property was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Working with Entry ID's


%%PageItemTitle%%

Data Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Data Property

Gets or sets a non-visible numeric value for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.Data = value

value = instance.Data
C#
public virtual System.int Data {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
this.dbiSchedule.Items(0).Timebars(0).Data = 222
C# Copy Code
this.dbiSchedule.Items[0].Timebars[0].Data = 222;

Remarks

This property defines a non-visible numeric value for the Timebar. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

DateColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : DateColor Property

Determines the foreground color used when displaying dates inside a dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.DateColor = value

value = instance.DateColor
C#
public System.Drawing.Color DateColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

End Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : End Property

Gets or sets the ending date and time for a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Date

instance.End = value

value = instance.End
C#
public virtual System.DateTime End {get; set;}

Property Value

A DateTime value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Remarks

This property must be greater than the Start property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

EndImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : EndImage Property

Gets or sets the image to place after the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.EndImage = value

value = instance.EndImage
C#
public System.int EndImage {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem objTimebar;

objTimeBar = new Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1),System.DateTime.Today.AddDays(4));

objTimebar.BackColor = System.Drawing.Color.SteelBlue; //Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal; //Sets the background fill type
objTimebar.Text = "Time Bar Text"; //Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center; //Sets the alignment of the primary text

objTimebar.StartImage = -2; //Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6; //Sets the image to appear after the time bar

//Inserts the time bar into the collection.  This time bar is now the first item in the collection
this.dbiSchedule1.Items[1].Timebars.Insert(0,objTimebar);

this.dbiSchedule1.BarToFront(objTimebar);

Remarks

When set to a negative value, this property will reference a stock image. When set to a positive, an image is reference from the defined image list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

EntryID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : EntryID Property

Gets or sets a non-visible text value for the Timebar..

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.EntryID = value

value = instance.EntryID
C#
public virtual System.string EntryID {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(0).EntryID = "Record 1"
C# Copy Code
this.dbiSchedule.Items[0].Timebars[0].EntryId = "Record 1";

Remarks

This property indicates a non-visible text value for the Timebar. It is recommended that the Record ID is stored as a string in this property. If this property is not manually defined, a value will be generated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Working with Entry ID's


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : FillType Property

Gets or sets the background fill pattern of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public virtual enumFillType FillType {get; set;}

Property Value

A dbi.enumFillType member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem objTimebar;

objTimeBar = new Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1),System.DateTime.Today.AddDays(4));

objTimebar.BackColor = System.Drawing.Color.SteelBlue; //Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal; //Sets the background fill type
objTimebar.Text = "Time Bar Text"; //Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center; //Sets the alignment of the primary text

objTimebar.StartImage = -2; //Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6; //Sets the image to appear after the time bar

//Inserts the time bar into the collection.  This time bar is now the first item in the collection
this.dbiSchedule1.Items[1].Timebars.Insert(0,objTimebar);

this.dbiSchedule1.BarToFront(objTimebar);

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties. The HatchStyle property provides additional fill pattern for the Timebar. A Timebar cannot display both a hatch style and a fill style. The property which was last defined will be applied.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Font Property

Gets or sets the font for the main text in the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

A Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

Font2 Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Font2 Property

Gets or sets the font of the Timebar body text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Font

instance.Font2 = value

value = instance.Font2
C#
public virtual System.Drawing.Font Font2 {get; set;}

Property Value

A System.Drawing.Font value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3)
DbiTimebar1.Text = "Primary Text"
DbiTimebar1.Body = "Body Text"
DbiTimebar1.Font2 = New System.Drawing.Font("Verdana", 8.25)
DbiTimebar1.ForeColor = Color.Indigo
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;
DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = Today;
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3);
DbiTimebar1.Text = "Primary Text";
DbiTimebar1.Body = "Body Text";
DbiTimebar1.Font2 = new System.Drawing.Font("Verdana", 8.25);
DbiTimebar1.ForeColor = Color.Indigo;
Me.DbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Remarks

The SubTextFont property can also be used to set the font of the body text.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ForeColor Property

Gets or sets the fore color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

HatchStyle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : HatchStyle Property

Gets or sets the background pattern of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Drawing2D.HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public virtual System.Drawing.Drawing2D.HatchStyle HatchStyle {get; set;}

Property Value

A Drawing2.HatchStyle value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.Items(0).Timebars(0).HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal
C# Copy Code
Me.dbiSchedule1.Items[0].Timebars[0].HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal;

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties. The FillType property provides additional gradiant fill patterns for the bar style. A Timebar cannot display both a hatch style and a fill style. The property which was last defined will be applied.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Image1 Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Image1 Property

Gets or sets the primary image associated with the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.Image1 = value

value = instance.Image1
C#
public virtual System.int Image1 {get; set;}

Property Value

An Integer value.

Remarks

This property indicates the primary image associated with the Time Bar. A positive value will use the image list associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ImageAlign Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ImageAlign Property

Gets or sets the alignment of Image1.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.ContentAlignment

instance.ImageAlign = value

value = instance.ImageAlign
C#
public System.Drawing.ContentAlignment ImageAlign {get; set;}

Property Value

A System.Drawing.ContentAlignment member.

Remarks

This property will only affect the alignment of the Image1 image within the display of the timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

IsSelected Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : IsSelected Property

Determines if a Timebar is selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.IsSelected = value

value = instance.IsSelected
C#
public System.bool IsSelected {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).IsSelected = True
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).IsSelected = true;

Remarks

Multiple Timebars can be selected at a time. If a Timebar is selected through this property, the Timebar which was previously selected will remain selected.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Location Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Location Property

Gets or sets the appointment location.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.Location = value

value = instance.Location
C#
public virtual System.string Location {get; set;}

Property Value

A String value

Remarks

This property was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

LocationID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : LocationID Property

Assigns a location to the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.LocationID = value

value = instance.LocationID
C#
public virtual System.string LocationID {get; set;}

Property Value

A String value, indicating the location to assign to the appointment.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).LocationID = "LOCATION1"
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).LocationID = "LOCATION1";

Remarks

This property defines which location to assign to the Timebar. The location identication must be a valid location Entry ID.

This property was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Locked Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Locked Property

Determines if the appointment can be moves or sized by user-interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.Locked = value

value = instance.Locked
C#
public virtual System.bool Locked {get; set;}

Property Value

A Boolean value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).Locked = False
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).Locked = false;

Remarks

If this property value is set to true, the Timebar can be moved and resized programmatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Schedule Edit Modes


%%PageItemTitle%%

MaxTime Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : MaxTime Property

Gets or sets the maximum end time of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.TimeSpan

instance.MaxTime = value

value = instance.MaxTime
C#
public virtual System.TimeSpan MaxTime {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set a maximum time of 1 day to the second Timebar in the first item.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).MaxTime = New System.TimeSpan(1,0,0,0)
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).MaxTime = new System.TimeSpan(1,0,0,0);

Remarks

This property will effect a Timebar when it is being resized. It will not apply when a Timebar is added.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

MinTime Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : MinTime Property

Gets or sets the minimum start time of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.TimeSpan

instance.MinTime = value

value = instance.MinTime
C#
public virtual System.TimeSpan MinTime {get; set;}

Property Value

An Integer value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will assign a minimum time of 1 hour to the second Timebar in the first item.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).MinTime = New System.TimeSpan(1,0,0)
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).MinTime = new System.TimeSpan(1,0,0);

Remarks

This property will effect a Timebar when it is being resized. It will not apply when a Timebar is added.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Schedule Edit Modes


%%PageItemTitle%%

PercentBorderColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentBorderColor Property

Determines the color used for the border of the percent bar in the dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.PercentBorderColor = value

value = instance.PercentBorderColor
C#
public System.Drawing.Color PercentBorderColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentColor Property

Gets or sets the color of the percent complete bar inside the regular time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.PercentColor = value

value = instance.PercentColor
C#
public System.Drawing.Color PercentColor {get; set;}

Property Value

System.Drawing.Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentColorTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentColorTo Property

Determines the secondary background color of the percent bar in the dbiTimeBarItem

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Color

instance.PercentColorTo = value

value = instance.PercentColorTo
C#
public System.Drawing.Color PercentColorTo {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentFillType Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentFillType Property

Determines the background pattern to paint the percent bar in the dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As enumFillType

instance.PercentFillType = value

value = instance.PercentFillType
C#
public enumFillType PercentFillType {get; set;}

Property Value

enumFillType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentHeight Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentHeight Property

Gets or sets the height of the percent complete bar inside the regular time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.PercentHeight = value

value = instance.PercentHeight
C#
public System.int PercentHeight {get; set;}

Property Value

System.Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentValue Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentValue Property

Gets or sets the value of the percent complete bar inside the regular time bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.PercentValue = value

value = instance.PercentValue
C#
public System.int PercentValue {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

PercentVOffset Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : PercentVOffset Property

Determines the vertical offset for displaying the percent bar inside a dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.PercentVOffset = value

value = instance.PercentVOffset
C#
public System.int PercentVOffset {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReadOnly Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReadOnly Property

Determines if the appointment info can be edited.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
public virtual System.bool ReadOnly {get; set;}

Property Value

A Boolean value.

Remarks

REadOnly was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Schedule Edit Modes


%%PageItemTitle%%

RecordID Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : RecordID Property

Gets or sets a hidden numeric value for the appoinment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.RecordID = value

value = instance.RecordID
C#
public virtual System.int RecordID {get; set;}

Property Value

An Integer value.

Remarks

This property is not visible to the end user. The purpose of this property is to be determined by the developer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReminderMinutesBeforeStart Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReminderMinutesBeforeStart Property

Determines how many minutes before the Timebar starts an alarm is fired.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.ReminderMinutesBeforeStart = value

value = instance.ReminderMinutesBeforeStart
C#
public virtual System.int ReminderMinutesBeforeStart {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

In the following syntax, an alarm will fire 5 minutes before the start of a Timebar.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).ReminderMinutesBeforeStart = 5
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).ReminderMinutesBeforeStart = 5;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReminderPlaySound Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReminderPlaySound Property

Determines if a reminder sound will be played when the Timebar alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.ReminderPlaySound = value

value = instance.ReminderPlaySound
C#
public virtual System.bool ReminderPlaySound {get; set;}

Property Value

A Boolean value, indicating is a reminder sound will be played when the alarm is triggered.

Remarks

The reminder sound is defined by the ReminderSoundFile property.

ReminderPlaySound was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReminderSet Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReminderSet Property

Determines if a reminder has been set for the start of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.ReminderSet = value

value = instance.ReminderSet
C#
public virtual System.bool ReminderSet {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).ReminderSet = True
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).ReminderSet = true;

Remarks

To set a reminder for the end of the Timebar, use the ReminderSetEnd property. When the alarm occurs, the AlarmTimebarStart event will fire.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReminderSetEnd Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReminderSetEnd Property

Determines if a reminder has been set for the end of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.ReminderSetEnd = value

value = instance.ReminderSetEnd
C#
public virtual System.bool ReminderSetEnd {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).ReminderSetEnd = True
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).ReminderSetEnd = true;

Remarks

To set a reminder for the start of the Timebar, use the ReminderSet property. When the alarm occurs, the AlarmTimebarEnd event will fire.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

ReminderSoundFile Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : ReminderSoundFile Property

Gets or sets the reminder sound to be played when the appointment alarm is triggered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.ReminderSoundFile = value

value = instance.ReminderSoundFile
C#
public virtual System.string ReminderSoundFile {get; set;}

Property Value

A String value, indicating the sound file used when the appointment alarm is triggered.

Remarks

This sound will only be played when the ReminderPlaySound property is set to true.

ReminderSoundFile was inherited from the dbiAppointmentItem class. It is not used by the dbiSchedule. However, this property may be used to extend the definition of the Timebar for use outside the control. For example, dragging to or from the dbiDayView control, dbiCalendar control, etc.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Start Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Start Property

Gets or sets the starting date and time of an appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public virtual System.DateTime Start {get; set;}

Property Value

A DateTime value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

StartImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : StartImage Property

Gets or sets the image to place before the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.StartImage = value

value = instance.StartImage
C#
public System.int StartImage {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)

Remarks

When set to a negative value, this property will reference a stock image. When set to a positive, an image is reference from the defined image list.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

Style Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Style Property

Gets or sets a pre-defined style assigned to the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Integer

instance.Style = value

value = instance.Style
C#
public override System.int Style {get; set;}

Property Value

An Integer value, representing the index value of the bar style. A value of -1 indicates that no style is assigned to the Timebar.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(1).Style = 1
C# Copy Code
this.dbiSchedule.Items(0).Timebars(1).Style = 1;

Remarks

The Timebar styled are assigned to the control through the dbiSchedule.TimebarStyles property. The properties of the bar styles are defined through the dbiTimebarStyle class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Base Implementation in Style
Creating Timebar Styles


%%PageItemTitle%%

SubTextFont Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : SubTextFont Property

Gets or sets the sub text font of the appointment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Drawing.Font

instance.SubTextFont = value

value = instance.SubTextFont
C#
public virtual System.Drawing.Font SubTextFont {get; set;}

Property Value

A Font value

Example

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Remarks

The Font2 property can also be used to set the font of the body text.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Time Bar Object


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Tag Property

Determines an object that contains data about the dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public virtual System.object Tag {get; set;}

Property Value

Object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

TaskID Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : TaskID Property

Assigns a task to the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.TaskID = value

value = instance.TaskID
C#
public virtual System.string TaskID {get; set;}

Property Value

A String value, indicating the task to assign to the Timebar.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule.Items(0).Timebars(0).TaskID = "TASK1234"
C# Copy Code
this.dbiSchedule.Items[0].Timebars[0].TaskID = "TASK1234";

Remarks

The task identication must be a valid task Entry ID.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Working with Entry ID's


%%PageItemTitle%%

Text Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Text Property

Gets or sets the Timebar text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

A String value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
An Overview of the Timebar Object


%%PageItemTitle%%

TextAlign Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : TextAlign Property

Gets or sets the horizontal and vertical alignment of the primary text in the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As dbiTimeBarItem.enumTextAlign

instance.TextAlign = value

value = instance.TextAlign
C#
public dbiTimeBarItem.enumTextAlign TextAlign {get; set;}

Property Value

A dbiTimebarItem.enumTextAlign value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem objTimebar;

objTimeBar = new Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1),System.DateTime.Today.AddDays(4));

objTimebar.BackColor = System.Drawing.Color.SteelBlue; //Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal; //Sets the background fill type
objTimebar.Text = "Time Bar Text"; //Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center; //Sets the alignment of the primary text

objTimebar.StartImage = -2; //Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6; //Sets the image to appear after the time bar

//Inserts the time bar into the collection.  This time bar is now the first item in the collection
this.dbiSchedule1.Items[1].Timebars.Insert(0,objTimebar);

this.dbiSchedule1.BarToFront(objTimebar);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

VCalendar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : VCalendar Property

Gets or sets the VCalendar specification for the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.VCalendar = value

value = instance.VCalendar
C#
public virtual System.string VCalendar {get; set;}

Property Value

A String value, indicating the VCalendar specification of the Timebar.

Remarks

For additional information on using VCalendar, please see VCalendar Support.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

Visible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : Visible Property

Gets or sets a value indicating whether the time bar will be visible.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarItem Class : XMLString Property

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public new System.string XMLString {get; set;}

Property Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = objTimebarItem.XMLString()
C# Copy Code
string strXML
strXML = objTimebarItem.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarItem Class
dbiTimeBarItem Members
Reading and Writing XML Data


%%PageItemTitle%%

dbiTimeBarStyle Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarStyle Class

Provides properties for defining Timebar styles.

Object Model

dbiTimeBarStyle Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
C#
public class dbiTimeBarStyle

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiTimeBarStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiTimeBarStyle Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarStyle Class

"

The following tables list the members exposed by dbiTimeBarStyle.

"

Public Constructors

 | Name | Description
public Constructor | dbiTimeBarStyle Constructor | Overloaded. Initializes a new instance of the dbiTimebarStyle class.
Top

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the Timebar.
public Property | BackColorTo | Gets or sets the secondary background color of the Timebar.
public Property | BarHeight | Gets or sets the bar height.
public Property | BorderColor | Gets or sets the border color of the Timebar.
public Property | EndImage | Gets or sets the image to be placed at the end of the Timebar.
public Property | EndImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the EndImage.
public Property | EndImageOrder | Determines if the EndImage will appear in front of or behind the Timebar.
public Property | FillType | Gets or sets the background gradiant fill pattern of the bar style.
public Property | Font | Gets or sets the font of the Timebar.
public Property | ForeColor | Gets or sets the forecolor of the Timebar.
public Property | HatchStyle | Gets or sets the background pattern of the bar style.
public Property | Milestone | Determines if the Timebar will be defined as a milestrone marker.
public Property | StartImage | Gets or sets the image to be placed at the front of the Timebar.
public Property | StartImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the StartImage.
public Property | StartImageOrder | Determines if the StartImage will appear in front of or behind the Timebar.
public Property | TextOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the text within the Timebar.
public Property | VerticalOffset | Gets or sets the vertical offset value used to calculate the position of the Timebar.
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiTimeBarStyle Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiTimeBarStyle Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : dbiTimeBarStyle Constructor

Initializes a new instance of the dbiTimebarStyle class.

Overload List

Overload | Description
dbiTimeBarStyle Constructor() | Initializes a new instance of the dbiTimebarStyle class.
dbiTimeBarStyle Constructor(Int32,Int32) | Initializes a new instance of the dbiTimebarStyle class.
dbiTimeBarStyle Constructor(Int32,Int32,Color) | Initializes a new instance of the dbiTimebarStyle class.
dbiTimeBarStyle Constructor(XmlNodeList) | Initializes a new instance of the dbiTimebarStyle class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

dbiTimeBarStyle Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class > dbiTimeBarStyle Constructor : dbiTimeBarStyle Constructor()

Initializes a new instance of the dbiTimebarStyle class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiTimeBarStyle()
C#
public dbiTimeBarStyle()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members
Overload List


%%PageItemTitle%%

dbiTimeBarStyle Constructor(Int32,Int32)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class > dbiTimeBarStyle Constructor : dbiTimeBarStyle Constructor(Int32,Int32)

nBarHeight
An integer value indicating the height of the Timebar style.
nVerticalOffset
An integer value used to calculate the vertical position of the style.
Initializes a new instance of the dbiTimebarStyle class.

Syntax

Visual Basic (Usage) Copy Code
Dim nBarHeight As System.Integer
Dim nVerticalOffset As System.Integer

Dim instance As New dbiTimeBarStyle(nBarHeight, nVerticalOffset)
C#
public dbiTimeBarStyle(
   System.int nBarHeight,
   System.int nVerticalOffset
)

Parameters

nBarHeight
An integer value indicating the height of the Timebar style.
nVerticalOffset
An integer value used to calculate the vertical position of the style.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members
Overload List


%%PageItemTitle%%

dbiTimeBarStyle Constructor(Int32,Int32,Color)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class > dbiTimeBarStyle Constructor : dbiTimeBarStyle Constructor(Int32,Int32,Color)

nBarHeight
An Integer value representing the height of the Timebar.
nVerticalOffset
An Integer value representing the vertical position of the Timebar.
clrBackColor
A System.Drawing.Color value.
Initializes a new instance of the dbiTimebarStyle class.

Syntax

Visual Basic (Usage) Copy Code
Dim nBarHeight As System.Integer
Dim nVerticalOffset As System.Integer
Dim clrBackColor As System.Drawing.Color

Dim instance As New dbiTimeBarStyle(nBarHeight, nVerticalOffset, clrBackColor)
C#
public dbiTimeBarStyle(
   System.int nBarHeight,
   System.int nVerticalOffset,
   System.Drawing.Color clrBackColor
)

Parameters

nBarHeight
An Integer value representing the height of the Timebar.
nVerticalOffset
An Integer value representing the vertical position of the Timebar.
clrBackColor
A System.Drawing.Color value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members
Overload List


%%PageItemTitle%%

dbiTimeBarStyle Constructor(XmlNodeList)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class > dbiTimeBarStyle Constructor : dbiTimeBarStyle Constructor(XmlNodeList)

xmlNodes
The XmlNodeList containing the values to base the new dbiTimeBarStyle on.
Initializes a new instance of the dbiTimebarStyle class.

Syntax

Visual Basic (Usage) Copy Code
Dim xmlNodes As System.Xml.XmlNodeList

Dim instance As New dbiTimeBarStyle(xmlNodes)
C#
public dbiTimeBarStyle(
   System.Xml.XmlNodeList xmlNodes
)

Parameters

xmlNodes
The XmlNodeList containing the values to base the new dbiTimeBarStyle on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members
Overload List


%%PageItemTitle%%

BackColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : BackColor Property

Gets or sets the primary background color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Remarks

The secondary background color is defined by the BackColorTo property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

BackColorTo Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : BackColorTo Property

Gets or sets the secondary background color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Color

instance.BackColorTo = value

value = instance.BackColorTo
C#
public System.Drawing.Color BackColorTo {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Remarks

This property is only applicable when FillType is not equal to Solid, or HatchStyle is not equal to LargeGrid.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

BarHeight Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : BarHeight Property

Gets or sets the bar height.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Integer

instance.BarHeight = value

value = instance.BarHeight
C#
public System.int BarHeight {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

BorderColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : BorderColor Property

Gets or sets the border color of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
public System.Drawing.Color BorderColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

EndImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : EndImage Property

Gets or sets the image to be placed at the end of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Integer

instance.EndImage = value

value = instance.EndImage
C#
public System.int EndImage {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Remarks

dbiSchedule contains 16 stock images. To access these image set this property to a negative value (-1 - -16). If this property is set to a positive value, an image from the image list assigned to dbiSchedule will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

EndImageOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : EndImageOffset Property

Gets or sets the vertical and horizontal offset values used to calculate the position of the EndImage.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Point

instance.EndImageOffset = value

value = instance.EndImageOffset
C#
public System.Drawing.Point EndImageOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

EndImageOrder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : EndImageOrder Property

Determines if the EndImage will appear in front of or behind the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As dbiTimeBarStyle.enumImageOrder

instance.EndImageOrder = value

value = instance.EndImageOrder
C#
public dbiTimeBarStyle.enumImageOrder EndImageOrder {get; set;}

Property Value

A Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

FillType Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : FillType Property

Gets or sets the background gradiant fill pattern of the bar style.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As enumFillType

instance.FillType = value

value = instance.FillType
C#
public enumFillType FillType {get; set;}

Property Value

A Dbi.enumFillType value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties. The HatchStyle property provides additional fill pattern for the bar style. A Timebar cannot display both a hatch style and a fill style. The property which was last defined will be applied.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

Font Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : Font Property

Gets or sets the font of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

A System.Drawing.Font value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

ForeColor Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : ForeColor Property

Gets or sets the forecolor of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

A System.Drawing.Color value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

this.dbiSchedule1.Items[0].Timebars[0].Style = this.dbiSchedule1.TimebarStyles.IndexOf(newStyle);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

HatchStyle Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : HatchStyle Property

Gets or sets the background pattern of the bar style.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Drawing2D.HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
C#
public System.Drawing.Drawing2D.HatchStyle HatchStyle {get; set;}

Property Value

A Drawing2.HatchStyle value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles(0).HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal
C# Copy Code
this.dbiSchedule1.TimebarStyles[0].HatchStyle = System.Drawing.Drawing2D.HatchStyle.DashedUpwardDiagonal;

Remarks

The primary and secondary background colors are defined by the BackColor and BackColorTo properties. The FillType property provides additional gradiant fill patterns for the bar style. A Timebar cannot display both a hatch style and a fill style. The property which was last defined will be applied.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

Milestone Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : Milestone Property

Determines if the Timebar will be defined as a milestrone marker.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Boolean

instance.Milestone = value

value = instance.Milestone
C#
public System.bool Milestone {get; set;}

Property Value

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles(0).Milestone = True
C# Copy Code
this.dbiSchedule1.TimebarStyles[0].Milestone = true;

Remarks

When set to true, the Timebar width will decrease to thin vertical line.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

StartImage Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : StartImage Property

Gets or sets the image to be placed at the front of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Integer

instance.StartImage = value

value = instance.StartImage
C#
public System.int StartImage {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Remarks

dbiSchedule contains 16 stock images. To access these image set this property to a negative value (-1 - -16). If this property is set to a positive value, an image from the image list assigned to dbiSchedule will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

StartImageOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : StartImageOffset Property

Gets or sets the vertical and horizontal offset values used to calculate the position of the StartImage.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Point

instance.StartImageOffset = value

value = instance.StartImageOffset
C#
public System.Drawing.Point StartImageOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

StartImageOrder Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : StartImageOrder Property

Determines if the StartImage will appear in front of or behind the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As dbiTimeBarStyle.enumImageOrder

instance.StartImageOrder = value

value = instance.StartImageOrder
C#
public dbiTimeBarStyle.enumImageOrder StartImageOrder {get; set;}

Property Value

A Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

TextOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : TextOffset Property

Gets or sets the vertical and horizontal offset values used to calculate the position of the text within the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Drawing.Point

instance.TextOffset = value

value = instance.TextOffset
C#
public System.Drawing.Point TextOffset {get; set;}

Property Value

A System.Drawing.Point value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles(0).TextOffset = New System.Drawing.Point(15, -5)
C# Copy Code
this.dbiSchedule1.TimebarStyles[0].TextOffset = new System.Drawing.Point(15, -5);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

VerticalOffset Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : VerticalOffset Property

Gets or sets the vertical offset value used to calculate the position of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.Integer

instance.VerticalOffset = value

value = instance.VerticalOffset
C#
public System.int VerticalOffset {get; set;}

Property Value

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles(0).VerticalOffset = -10
C# Copy Code
this.dbiSchedule1.TimebarStyles[0].VerticalOffset = -10;

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members


%%PageItemTitle%%

XMLString Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiTimeBarStyle Class : XMLString Property

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle
Dim value As System.String

instance.XMLString = value

value = instance.XMLString
C#
public System.string XMLString {get; set;}

Property Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = objTimebarStyle.XMLString()
C# Copy Code
string strXML;
strXML = objTimebarStyle.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarStyle Class
dbiTimeBarStyle Members
Reading and Writing XML Data


%%PageItemTitle%%

dbiUserDrawnBar Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBar Class

Provides properties for custom drawing TimeBars in the UserDrawnTimeBars Event

Object Model

dbiUserDrawnBar ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBar
C#
public class dbiUserDrawnBar

Inheritance Hierarchy

System.Object
Dbi.WinControl.Schedule.dbiUserDrawnBar

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiUserDrawnBar Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBar Class

"

The following tables list the members exposed by dbiUserDrawnBar.

"

Public Constructors

 | Name | Description
public Constructor | dbiUserDrawnBar Constructor | Overloaded. Initializes a new instance of the dbiUserDrawnBar class.
Top

Public Properties

 | Name | Description
public Property | Rect | Determines the rectangle representing the size and location of the dbiTimeBarItem.
public Property | ScheduleItem | Determines the dbiScheduleItem that contains the dbiTimeBarItem being drawn.
public Property | ScheduleObject | Determines the dbiScheduleObject where the dbiTimeBarItem is being drawn.
public Property | TimeBarItem | Determines the dbiTimeBarItem being drawn.
Top

See Also

Reference

dbiUserDrawnBar Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiUserDrawnBar Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class : dbiUserDrawnBar Constructor

Initializes a new instance of the dbiUserDrawnBar class.

Overload List

Overload | Description
dbiUserDrawnBar Constructor() | Initializes a new instance of the dbiUserDrawnBar class.
dbiUserDrawnBar Constructor(dbiTimeBarItem,dbiScheduleItem,dbiScheduleObject,Rectangle) | Initializes a new instance of the dbiUserDrawnBar class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members


%%PageItemTitle%%

dbiUserDrawnBar Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class > dbiUserDrawnBar Constructor : dbiUserDrawnBar Constructor()

Initializes a new instance of the dbiUserDrawnBar class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiUserDrawnBar()
C#
public dbiUserDrawnBar()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members
Overload List


%%PageItemTitle%%

dbiUserDrawnBar Constructor(dbiTimeBarItem,dbiScheduleItem,dbiScheduleObject,Rectangle)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class > dbiUserDrawnBar Constructor : dbiUserDrawnBar Constructor(dbiTimeBarItem,dbiScheduleItem,dbiScheduleObject,Rectangle)

objTimeBar
The dbiTimeBarItem being drawn.
objLineItem
The dbiScheduleItem that contains the dbiTimeBarItem being drawn.
objSchedule
The dbiScheduleObject where the dbiTimeBarItem is being drawn.
rcTimeBar
The rectangle representing the size and location of the dbiTimeBarItem.
Initializes a new instance of the dbiUserDrawnBar class.

Syntax

Visual Basic (Usage) Copy Code
Dim objTimeBar As dbiTimeBarItem
Dim objLineItem As dbiScheduleItem
Dim objSchedule As dbiScheduleObject
Dim rcTimeBar As System.Drawing.Rectangle

Dim instance As New dbiUserDrawnBar(objTimeBar, objLineItem, objSchedule, rcTimeBar)
C#
public dbiUserDrawnBar(
   dbiTimeBarItem objTimeBar,
   dbiScheduleItem objLineItem,
   dbiScheduleObject objSchedule,
   System.Drawing.Rectangle rcTimeBar
)

Parameters

objTimeBar
The dbiTimeBarItem being drawn.
objLineItem
The dbiScheduleItem that contains the dbiTimeBarItem being drawn.
objSchedule
The dbiScheduleObject where the dbiTimeBarItem is being drawn.
rcTimeBar
The rectangle representing the size and location of the dbiTimeBarItem.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members
Overload List


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class : Rect Property

Determines the rectangle representing the size and location of the dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBar
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class : ScheduleItem Property

Determines the dbiScheduleItem that contains the dbiTimeBarItem being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBar
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class : ScheduleObject Property

Determines the dbiScheduleObject where the dbiTimeBarItem is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBar
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBar Class : TimeBarItem Property

Determines the dbiTimeBarItem being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBar
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBar Class
dbiUserDrawnBar Members


%%PageItemTitle%%

dbiUserDrawnBarCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBarCollection Class

A collection of dbiUserDrawnBar Class

Object Model

dbiUserDrawnBarCollection ClassdbiUserDrawnBar ClassdbiScheduleItem ClassdbiScheduleObject ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
C#
public class dbiUserDrawnBarCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.dbiUserDrawnBarCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

dbiUserDrawnBarCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBarCollection Class

"

The following tables list the members exposed by dbiUserDrawnBarCollection.

"

Public Constructors

 | Name | Description
public Constructor | dbiUserDrawnBarCollection Constructor | Initializes a new instance of the dbiUserDrawnBarCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiUserDrawnBar object located in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a dbiUserDrawnBar to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiUserDrawnBar object.
public Method | Insert | Inserts a dbiUserDrawnBar into the collection at the specified index.
public Method | Remove | Removes a dbiUserDrawnBar from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

dbiUserDrawnBarCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiUserDrawnBarCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : dbiUserDrawnBarCollection Constructor

objOwner
The dbiScheduleObject which displays the TimeBars being drawn.
Initializes a new instance of the dbiUserDrawnBarCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiScheduleObject

Dim instance As New dbiUserDrawnBarCollection(objOwner)
C#
public dbiUserDrawnBarCollection(
   dbiScheduleObject objOwner
)

Parameters

objOwner
The dbiScheduleObject which displays the TimeBars being drawn.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Add Method

obj
dbiUserDrawnBar to add to the collection
Adds a dbiUserDrawnBar to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim obj As dbiUserDrawnBar
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiUserDrawnBar obj
)

Parameters

obj
dbiUserDrawnBar to add to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

IndexOf(dbiUserDrawnBar) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : IndexOf(dbiUserDrawnBar) Method

obj
The dbiUserDrawnBar to retrieve the index of.
Returns the internal index of the dbiUserDrawnBar object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim obj As dbiUserDrawnBar
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiUserDrawnBar obj
)

Parameters

obj
The dbiUserDrawnBar to retrieve the index of.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Insert Method

nIndex
The index value to insert the new object at.
obj
The dbiUserDrawnBar object to insert in to the collection.
Inserts a dbiUserDrawnBar into the collection at the specified index.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim nIndex As System.Integer
Dim obj As dbiUserDrawnBar

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiUserDrawnBar obj
)

Parameters

nIndex
The index value to insert the new object at.
obj
The dbiUserDrawnBar object to insert in to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Remove Method

obj
The dbiUserDrawnBar to remove from the collection.
Removes a dbiUserDrawnBar from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim obj As dbiUserDrawnBar

instance.Remove(obj)
C#
public void Remove(
   dbiUserDrawnBar obj
)

Parameters

obj
The dbiUserDrawnBar to remove from the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : Item Property

nIndex
The zero-based index of the dbiUserDrawnBar to reference.
A dbiUserDrawnBar object located in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiUserDrawnBarCollection
Dim nIndex As System.Integer
Dim value As dbiUserDrawnBar

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiUserDrawnBar this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the dbiUserDrawnBar to reference.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%%

DeadZoneDropEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : DeadZoneDropEventArgs Class

Provides data for the DeadZoneDrop Event.

Object Model

DeadZoneDropEventArgs ClassdbiCustomArea ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
C#
public class DeadZoneDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.DeadZoneDropEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

DeadZoneDropEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : DeadZoneDropEventArgs Class

"

The following tables list the members exposed by DeadZoneDropEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | DeadZoneDropEventArgs Constructor | Initializes a new instance of the DeadZoneDropEventArgs class.
Top

Public Properties

 | Name | Description
public Property | AllowDrop | Determines if the time bar will be allowed to intersect the dead zone.
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | End | Determines the ending datetime value of the time bar when it intersects the dead zone.
public Property | ScheduleItem | Determines the dbiScheduleItem where the time bar encounters the dead zone
public Property | Start | Determines the starting datetime value of the time bar when it intersects the dead zone.
public Property | TimeBar | The timebar source of the deadzonedrop.
Top

See Also

Reference

DeadZoneDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

DeadZoneDropEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : DeadZoneDropEventArgs Constructor

Initializes a new instance of the DeadZoneDropEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New DeadZoneDropEventArgs()
C#
public DeadZoneDropEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : AllowDrop Property

Determines if the time bar will be allowed to intersect the dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public System.bool AllowDrop {get; set;}

Property Value

Boolean

Remarks

By default this property is false and the time bar wil either be cancelled (creation) or reset (move/size), setting it to true in the event will allow the creation/change of the time bar to be allowed to intersect the dead zone

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

CustomArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : CustomArea Property

The dbiCustomArea that is designated as a deadzone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As dbiCustomArea

instance.CustomArea = value

value = instance.CustomArea
C#
public dbiCustomArea CustomArea {get; set;}

Property Value

dbiCustomArea

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : End Property

Determines the ending datetime value of the time bar when it intersects the dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : ScheduleItem Property

Determines the dbiScheduleItem where the time bar encounters the dead zone

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : Start Property

Determines the starting datetime value of the time bar when it intersects the dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

TimeBar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > DeadZoneDropEventArgs Class : TimeBar Property

The timebar source of the deadzonedrop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DeadZoneDropEventArgs
Dim value As dbiTimeBarItem

instance.TimeBar = value

value = instance.TimeBar
C#
public dbiTimeBarItem TimeBar {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DeadZoneDropEventArgs Class
DeadZoneDropEventArgs Members


%%PageItemTitle%%

EditModeChangedEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : EditModeChangedEventArgs Class

Provides data for the EditModeChanged event of the dbiSchedule control.

Object Model

EditModeChangedEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditModeChangedEventArgs
C#
public class EditModeChangedEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.EditModeChangedEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditModeChangedEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

EditModeChangedEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : EditModeChangedEventArgs Class

"

The following tables list the members exposed by EditModeChangedEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | EditModeChangedEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | EditMode | The new EditMode for the control.
Top

See Also

Reference

EditModeChangedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

EditModeChangedEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > EditModeChangedEventArgs Class : EditModeChangedEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New EditModeChangedEventArgs()
C#
public EditModeChangedEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditModeChangedEventArgs Class
EditModeChangedEventArgs Members


%%PageItemTitle%%

EditMode Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > EditModeChangedEventArgs Class : EditMode Property

The new EditMode for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As EditModeChangedEventArgs
Dim value As enumEditMode

instance.EditMode = value

value = instance.EditMode
C#
public enumEditMode EditMode {get; set;}

Property Value

enumEditMode

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

EditModeChangedEventArgs Class
EditModeChangedEventArgs Members


%%PageItemTitle%%

FirstDrawEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : FirstDrawEventArgs Class

Provides data for the FirstDraw event.

Object Model

FirstDrawEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As FirstDrawEventArgs
C#
public class FirstDrawEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.FirstDrawEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

FirstDrawEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

FirstDrawEventArgs Class Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : FirstDrawEventArgs Class

"

The following tables list the members exposed by FirstDrawEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | FirstDrawEventArgs Constructor | Initializes a new instance of the FirstDrawEventArgs class.
Top

See Also

Reference

FirstDrawEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

FirstDrawEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > FirstDrawEventArgs Class : FirstDrawEventArgs Constructor

Initializes a new instance of the FirstDrawEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New FirstDrawEventArgs()
C#
public FirstDrawEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

FirstDrawEventArgs Class
FirstDrawEventArgs Members


%%PageItemTitle%%

GuideLineClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineClickEventArgs Class

Provides data for the GuideLineClick Event.

Object Model

GuideLineClickEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
C#
public class GuideLineClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.GuideLineClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

GuideLineClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineClickEventArgs Class

"

The following tables list the members exposed by GuideLineClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | GuideLineClickEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | Button | The mouse button that was used to click the GuideLine.
public Property | GuideLine | The dbiGuideLine that was clicked.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | OnImage | Determines if the GuideLine image was clicked or the GuideLine itself.
public Property | ScheduleObject | The dbiScheduleObject where the GuideLine was clicked.
public Property | X | The X position of the mouse where the click occurred.
public Property | Y | The Y position of the mouse where the click occurred.
Top

See Also

Reference

GuideLineClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

GuideLineClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : GuideLineClickEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New GuideLineClickEventArgs()
C#
public GuideLineClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : Button Property

The mouse button that was used to click the GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

MouseButtons

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : GuideLine Property

The dbiGuideLine that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

LineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : LineIndex Property

The zero-based index of the GuideLine in the GuideLines collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As System.Integer

instance.LineIndex = value

value = instance.LineIndex
C#
public System.int LineIndex {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

OnImage Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : OnImage Property

Determines if the GuideLine image was clicked or the GuideLine itself.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As System.Boolean

instance.OnImage = value

value = instance.OnImage
C#
public System.bool OnImage {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the GuideLine was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : X Property

The X position of the mouse where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineClickEventArgs Class : Y Property

The Y position of the mouse where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineClickEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineClickEventArgs Class
GuideLineClickEventArgs Members


%%PageItemTitle%%

GuideLineInDeadZoneEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineInDeadZoneEventArgs Class

Provides data for the GuideLineInDeadZone Event

Object Model

GuideLineInDeadZoneEventArgs ClassdbiCustomArea ClassdbiGuideLine ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineInDeadZoneEventArgs
C#
public class GuideLineInDeadZoneEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.GuideLineInDeadZoneEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

GuideLineInDeadZoneEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineInDeadZoneEventArgs Class

"

The following tables list the members exposed by GuideLineInDeadZoneEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | GuideLineInDeadZoneEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | GuideLine | The dbiGuideLine that is in the dead zone.
public Property | IgnoreDeadZone | Determines if the dead zone should be treated as a standard custom area instead of a dead zone
public Property | ScheduleItem | The dbiScheduleItem containing the dead zone
Top

See Also

Reference

GuideLineInDeadZoneEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

GuideLineInDeadZoneEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineInDeadZoneEventArgs Class : GuideLineInDeadZoneEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New GuideLineInDeadZoneEventArgs()
C#
public GuideLineInDeadZoneEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Class
GuideLineInDeadZoneEventArgs Members


%%PageItemTitle%%

CustomArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineInDeadZoneEventArgs Class : CustomArea Property

The dbiCustomArea that is designated as a deadzone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineInDeadZoneEventArgs
Dim value As dbiCustomArea

instance.CustomArea = value

value = instance.CustomArea
C#
public dbiCustomArea CustomArea {get; set;}

Property Value

dbiCustomArea

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Class
GuideLineInDeadZoneEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineInDeadZoneEventArgs Class : GuideLine Property

The dbiGuideLine that is in the dead zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineInDeadZoneEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Property Value

dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Class
GuideLineInDeadZoneEventArgs Members


%%PageItemTitle%%

IgnoreDeadZone Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineInDeadZoneEventArgs Class : IgnoreDeadZone Property

Determines if the dead zone should be treated as a standard custom area instead of a dead zone

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineInDeadZoneEventArgs
Dim value As System.Boolean

instance.IgnoreDeadZone = value

value = instance.IgnoreDeadZone
C#
public System.bool IgnoreDeadZone {get; set;}

Property Value

Boolean

Remarks

Guidelines can freely intersect dead zones in the control by default. Users can move or create a guideline inside a dead zone using the GuideLine editmode.

Setting this property to true will ignore the current dead zone and report it as a regular custom area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Class
GuideLineInDeadZoneEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineInDeadZoneEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the dead zone

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineInDeadZoneEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Remarks

If the custom area in question is contained in the control's CustomAreas proeprty, thei property will be null/nothing.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineInDeadZoneEventArgs Class
GuideLineInDeadZoneEventArgs Members


%%PageItemTitle%%

GuideLineMoveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineMoveEventArgs Class

Provides data for the GuideLineMove Event.

Object Model

GuideLineMoveEventArgs ClassdbiGuideLine ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
C#
public class GuideLineMoveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.GuideLineMoveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

GuideLineMoveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineMoveEventArgs Class

"

The following tables list the members exposed by GuideLineMoveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | GuideLineMoveEventArgs Constructor | Initializes a new instance of the Class.
Top

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that is moving.
public Property | LineTime | The current date/time value of the GuideLine that is being moved.
public Property | NewLine | Indicates if the GuideLine being moved is a newly added GuideLine or an existing GuideLine.
public Property | ScheduleObject | The dbiScheduleObject where the GuideLine is moving.
Top

See Also

Reference

GuideLineMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

GuideLineMoveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineMoveEventArgs Class : GuideLineMoveEventArgs Constructor

Initializes a new instance of the Class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New GuideLineMoveEventArgs()
C#
public GuideLineMoveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

GuideLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineMoveEventArgs Class : GuideLine Property

The dbiGuideLine that is moving.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As dbiGuideLine

instance.GuideLine = value

value = instance.GuideLine
C#
public dbiGuideLine GuideLine {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

LineTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineMoveEventArgs Class : LineTime Property

The current date/time value of the GuideLine that is being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As System.Date

instance.LineTime = value

value = instance.LineTime
C#
public System.DateTime LineTime {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

NewLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineMoveEventArgs Class : NewLine Property

Indicates if the GuideLine being moved is a newly added GuideLine or an existing GuideLine.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As System.Boolean

instance.NewLine = value

value = instance.NewLine
C#
public System.bool NewLine {get; set;}

Property Value

Boolean

Remarks

When the EditMode Property is in GuideLine mode, clicking and dragging in the Schedule Area will create a new GuideLine and fire the GuideLineMove event. This can be used to show a tip or text area detailing the exact time of the GuideLine. If a new GuideLine is created in this manner the Value will be True, otherwise if an existing GuideLine is left clicked and dragged then the Value will return False.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > GuideLineMoveEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the GuideLine is moving.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As GuideLineMoveEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

When using *Enterprise* the GuideLine cannot be moved between Schedule Objects, it can only be moved inside the originating dbiScheduleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

GuideLineMoveEventArgs Class
GuideLineMoveEventArgs Members


%%PageItemTitle%%

HistoryChangeEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryChangeEventArgs Class

Provides data for the HistoryChange event.

Object Model

HistoryChangeEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
C#
public class HistoryChangeEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.HistoryChangeEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryChangeEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

HistoryChangeEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryChangeEventArgs Class

"

The following tables list the members exposed by HistoryChangeEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | HistoryChangeEventArgs Constructor | Initializes a new instance of the HistoryChangeEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Redo | Determines if an item in the RedoHistory collection has changed.
public Property | Undo | Determines if an item in the UndoHistory collection has changed.
Top

See Also

Reference

HistoryChangeEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

HistoryChangeEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryChangeEventArgs Class : HistoryChangeEventArgs Constructor

Initializes a new instance of the HistoryChangeEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New HistoryChangeEventArgs()
C#
public HistoryChangeEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%%

Redo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryChangeEventArgs Class : Redo Property

Determines if an item in the RedoHistory collection has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
Dim value As System.Boolean

instance.Redo = value

value = instance.Redo
C#
public System.bool Redo {get; set;}

Property Value

A Boolean value indicating if an item in the RedoHistory collection has changed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%%

Undo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryChangeEventArgs Class : Undo Property

Determines if an item in the UndoHistory collection has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryChangeEventArgs
Dim value As System.Boolean

instance.Undo = value

value = instance.Undo
C#
public System.bool Undo {get; set;}

Property Value

A Boolean value indicating if an item in the UndoHistory collection has changed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryChangeEventArgs Class
HistoryChangeEventArgs Members


%%PageItemTitle%%

HistoryCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryCollection Class

Represents a collection of history items.

Object Model

HistoryCollection ClassdbiHistoryItem ClassdbiLinkItem ClassdbiScheduleItem ClassdbiScheduleItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
C#
public class HistoryCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.HistoryCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

HistoryCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryCollection Class

"

The following tables list the members exposed by HistoryCollection.

"

Public Constructors

 | Name | Description
public Constructor | HistoryCollection Constructor | Initializes a new instance of the HistoryCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets a history item at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new item to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item in the collection.
public Method | Insert | Inserts a new item into the collection
public Method | Remove | Removes an item from the collection.
public Method | RemoveAt | Removes a history item at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

HistoryCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

HistoryCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : HistoryCollection Constructor

objOwner
The dbiSchedule control that will contain the HistoryCollection.
Initializes a new instance of the HistoryCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiSchedule

Dim instance As New HistoryCollection(objOwner)
C#
public HistoryCollection(
   dbiSchedule objOwner
)

Parameters

objOwner
The dbiSchedule control that will contain the HistoryCollection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Add Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Add Method

obj
The dbiHistoryItem added to the collection
Adds a new item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim obj As dbiHistoryItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiHistoryItem obj
)

Parameters

obj
The dbiHistoryItem added to the collection

Return Value

The zero-based index value of the added item.

Remarks

Items are added to this collection internally. Items cannot be added to this collection programmatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection

instance.Clear()
C#
public void Clear()

Example

The following will clear the UndoHistory and RedoHistory collections.
Visual Basic Copy Code
Me.dbiSchedule.UndoHistory.Clear
Me.dbiSchedule.RedoHistory.Clear
C# Copy Code
this.dbiSchedule.UndoHistory.Clear();
this.dbiSchedule.RedoHistory.Clear();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

IndexOf(dbiHistoryItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : IndexOf(dbiHistoryItem) Method

obj
The dbiHistoryItem to locate in the collection.
Returns the index of a specified item in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim obj As dbiHistoryItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiHistoryItem obj
)

Parameters

obj
The dbiHistoryItem to locate in the collection.

Return Value

The zero-based index value of the node item.

Example

Visual Basic Copy Code
intIndex = Me.dbiSchedule.UndoHistory.IndexOf(objHistoryItem)
intIndex = Me.dbiSchedule.RedoHistory.IndexOf(objHistoryItem)
C# Copy Code
intIndex = this.dbiSchedule.UndoHistory.IndexOf(ObjHistoryItem);
intIndex = this.dbiSchedule.RedoHistory.IndexOf(objHistoryItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiHistoryItem added to the collection
Inserts a new item into the collection

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim nIndex As System.Integer
Dim obj As dbiHistoryItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiHistoryItem obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiHistoryItem added to the collection

Return Value

The zero-based index value of the added item

Remarks

Items are added to this collection internally. Items cannot be added/inserted to this collection programmatically.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Remove Method

obj
The dbiHistoryItem to remove from the collection.
Removes an item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim obj As dbiHistoryItem

instance.Remove(obj)
C#
public void Remove(
   dbiHistoryItem obj
)

Parameters

obj
The dbiHistoryItem to remove from the collection.

Example

Visual Basic Copy Code
Me.dbiSchedule.UndoHistory.Remove(objHistoryItem)
Me.dbiSchedule.RedoHistory.Remove(objHistoryItem)
Copy Code
this.dbiSchedule.UndoHistory.Remove(ObjHistoryItem);
this.dbiSchedule.RedoHistory.Remove(objHistoryItem);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : RemoveAt Method

index
The zero-based index of the item to remove.
Removes a history item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Example

Visual Basic Copy Code
Me.dbiSchedule.UndoHistory.RemoveAt(intHistoryItem)
Me.dbiSchedule.RedoHistory.RemoveAt(intHistoryItem)
C# Copy Code
this.dbiSchedule.UndoHistory.RemoveAt(intHistoryItem);
this.dbiSchedule.RedoHistory.RemoveAt(intHistoryItem);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer valueThe number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : Item Property

nIndex
The zero-based index of the history item to get or set in the collection.
Gets or sets a history item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As HistoryCollection
Dim nIndex As System.Integer
Dim value As dbiHistoryItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiHistoryItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the history item to get or set in the collection.

Property Value

A dbiHistoryItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%%

ItemMouseOverEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ItemMouseOverEventArgs Class

Provides data for the ItemMouseOver event.

Object Model

ItemMouseOverEventArgs ClassdbiGuideLine ClassdbiScheduleNote ClassdbiScheduleObject ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
C#
public class ItemMouseOverEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ItemMouseOverEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ItemMouseOverEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ItemMouseOverEventArgs Class

"

The following tables list the members exposed by ItemMouseOverEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ItemMouseOverEventArgs Constructor | Initializes a new instance of the ItemMouseOverEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
public Property | GuideLineItem | The dbiGuideLine the mouse is over.
public Property | NoteIndex | The zero-based index value of the note the mouse is over.
public Property | NoteItem | The dbiScheduleNote the mouse is over.
public Property | ScheduleIndex | The zero-based index value of the schedule the mouse is over.
public Property | ScheduleItem | The dbiScheduleItem the mouse is over.
public Property | ScheduleObject | The dbiScheduleObject the mouse is over.
public Property | TimeBarItem | The dbiTimeBarItem the mouse is over.
Top

See Also

Reference

ItemMouseOverEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ItemMouseOverEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : ItemMouseOverEventArgs Constructor

Initializes a new instance of the ItemMouseOverEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ItemMouseOverEventArgs()
C#
public ItemMouseOverEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : BarIndex Property

The zero-based index value of the Timebar the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

GuideLineIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : GuideLineIndex Property

The zero-based index value of the GuideLine the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As System.Integer

instance.GuideLineIndex = value

value = instance.GuideLineIndex
C#
public System.int GuideLineIndex {get; set;}

Property Value

The zero-based index value of the GuideLine the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

GuideLineItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : GuideLineItem Property

The dbiGuideLine the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiGuideLine

instance.GuideLineItem = value

value = instance.GuideLineItem
C#
public dbiGuideLine GuideLineItem {get; set;}

Property Value

The dbiGuideLine the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

NoteIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : NoteIndex Property

The zero-based index value of the note the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As System.Integer

instance.NoteIndex = value

value = instance.NoteIndex
C#
public System.int NoteIndex {get; set;}

Property Value

The zero-based index value of the note the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

NoteItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : NoteItem Property

The dbiScheduleNote the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiScheduleNote

instance.NoteItem = value

value = instance.NoteItem
C#
public dbiScheduleNote NoteItem {get; set;}

Property Value

The dbiScheduleNote the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : ScheduleIndex Property

The zero-based index value of the schedule the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As System.Integer

instance.ScheduleIndex = value

value = instance.ScheduleIndex
C#
public System.int ScheduleIndex {get; set;}

Property Value

The zero-based index value of the schedule the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : ScheduleItem Property

The dbiScheduleItem the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : ScheduleObject Property

The dbiScheduleObject the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

The dbiScheduleObject the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ItemMouseOverEventArgs Class : TimeBarItem Property

The dbiTimeBarItem the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ItemMouseOverEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimeBarItem the mouse is over.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ItemMouseOverEventArgs Class
ItemMouseOverEventArgs Members


%%PageItemTitle%%

LineArrowClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowClickEventArgs Class

Provides data for the LineArrowClick Event.

Object Model

LineArrowClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
C#
public class LineArrowClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.LineArrowClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

LineArrowClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowClickEventArgs Class

"

The following tables list the members exposed by LineArrowClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | LineArrowClickEventArgs Constructor | Initializes a new instance of the LineArrowClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow exists.
public Property | ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.
Top

See Also

Reference

LineArrowClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

LineArrowClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowClickEventArgs Class : LineArrowClickEventArgs Constructor

Initializes a new instance of the LineArrowClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New LineArrowClickEventArgs()
C#
public LineArrowClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowClickEventArgs Class : Button Property

The MouseButton that performed the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

MouseButtons

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

Direction Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowClickEventArgs Class : Direction Property

The direction of the clicked Line Arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As enumLineArrowDirection

instance.Direction = value

value = instance.Direction
C#
public enumLineArrowDirection Direction {get; set;}

Property Value

enumLineArrowDirection Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowClickEventArgs Class : ScheduleItem Property

The ScheduleItem where the Line Arrow exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowClickEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the Line Arrow was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowClickEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowClickEventArgs Class
LineArrowClickEventArgs Members


%%PageItemTitle%%

LineArrowDoubleClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowDoubleClickEventArgs Class

Provides data for the LineArrowDoubleClick Event

Object Model

LineArrowDoubleClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowDoubleClickEventArgs
C#
public class LineArrowDoubleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.LineArrowDoubleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowDoubleClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

LineArrowDoubleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowDoubleClickEventArgs Class

"

The following tables list the members exposed by LineArrowDoubleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | LineArrowDoubleClickEventArgs Constructor | Initializes a new instance of the LineArrowDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow exists.
public Property | ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.
Top

See Also

Reference

LineArrowDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

LineArrowDoubleClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowDoubleClickEventArgs Class : LineArrowDoubleClickEventArgs Constructor

Initializes a new instance of the LineArrowDoubleClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New LineArrowDoubleClickEventArgs()
C#
public LineArrowDoubleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowDoubleClickEventArgs Class
LineArrowDoubleClickEventArgs Members


%%PageItemTitle%%

Direction Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowDoubleClickEventArgs Class : Direction Property

The direction of the clicked Line Arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowDoubleClickEventArgs
Dim value As enumLineArrowDirection

instance.Direction = value

value = instance.Direction
C#
public enumLineArrowDirection Direction {get; set;}

Property Value

enumLineArrowDirection Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowDoubleClickEventArgs Class
LineArrowDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowDoubleClickEventArgs Class : ScheduleItem Property

The ScheduleItem where the Line Arrow exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowDoubleClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowDoubleClickEventArgs Class
LineArrowDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowDoubleClickEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the Line Arrow was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowDoubleClickEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowDoubleClickEventArgs Class
LineArrowDoubleClickEventArgs Members


%%PageItemTitle%%

LineArrowMouseOverEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowMouseOverEventArgs Class

Provides data for the LineArrowMouseOver Event

Object Model

LineArrowMouseOverEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
C#
public class LineArrowMouseOverEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.LineArrowMouseOverEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

LineArrowMouseOverEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowMouseOverEventArgs Class

"

The following tables list the members exposed by LineArrowMouseOverEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | LineArrowMouseOverEventArgs Constructor | Initializes a new instance of the LineArrowMouseOverEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Direction | The direction of the Line Arrow the mouse is over.
public Property | ScheduleIndex | The zero-based index value of the dbiScheduleObject where the mouse is over the Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow the mouse is over exists.
public Property | ScheduleObject | The dbiScheduleObject where the mouse is over the Line Arrow
Top

See Also

Reference

LineArrowMouseOverEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

LineArrowMouseOverEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowMouseOverEventArgs Class : LineArrowMouseOverEventArgs Constructor

Initializes a new instance of the LineArrowMouseOverEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New LineArrowMouseOverEventArgs()
C#
public LineArrowMouseOverEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

Direction Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowMouseOverEventArgs Class : Direction Property

The direction of the Line Arrow the mouse is over.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As enumLineArrowDirection

instance.Direction = value

value = instance.Direction
C#
public enumLineArrowDirection Direction {get; set;}

Property Value

enumLineArrowDirection Enumeration

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowMouseOverEventArgs Class : ScheduleIndex Property

The zero-based index value of the dbiScheduleObject where the mouse is over the Line Arrow.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As System.Integer

instance.ScheduleIndex = value

value = instance.ScheduleIndex
C#
public System.int ScheduleIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowMouseOverEventArgs Class : ScheduleItem Property

The ScheduleItem where the Line Arrow the mouse is over exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LineArrowMouseOverEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the mouse is over the Line Arrow

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LineArrowMouseOverEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LineArrowMouseOverEventArgs Class
LineArrowMouseOverEventArgs Members


%%PageItemTitle%%

ListClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListClickEventArgs Class

Provides data to the ListClick event in dbiSchedule.

Object Model

ListClickEventArgs ClassdbiColumnItem ClassdbiColumnFormat ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListClickEventArgs
C#
public class ListClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ListClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ListClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListClickEventArgs Class

"

The following tables list the members exposed by ListClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ListClickEventArgs Constructor | Initializes a new instance of the ListClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Button | Gets which mouse button was pressed.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the click occurred.
public Property | ColumnItem | The dbiColumnItem where the click occurred.
public Property | ScheduleItem | The dbiScheduleItem which has been clicked.
Top

See Also

Reference

ListClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ListClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListClickEventArgs Class : ListClickEventArgs Constructor

Initializes a new instance of the ListClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ListClickEventArgs()
C#
public ListClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Class
ListClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListClickEventArgs Class : Button Property

Gets which mouse button was pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

One of the MouseButtons values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Class
ListClickEventArgs Members


%%PageItemTitle%%

ColumnIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListClickEventArgs Class : ColumnIndex Property

The zero-based index of the dbiColumnItem where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListClickEventArgs
Dim value As System.Integer

instance.ColumnIndex = value

value = instance.ColumnIndex
C#
public System.int ColumnIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Class
ListClickEventArgs Members


%%PageItemTitle%%

ColumnItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListClickEventArgs Class : ColumnItem Property

The dbiColumnItem where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListClickEventArgs
Dim value As dbiColumnItem

instance.ColumnItem = value

value = instance.ColumnItem
C#
public dbiColumnItem ColumnItem {get; set;}

Property Value

dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Class
ListClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListClickEventArgs Class : ScheduleItem Property

The dbiScheduleItem which has been clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

A dbiScheduleItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListClickEventArgs Class
ListClickEventArgs Members


%%PageItemTitle%%

ListDoubleClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDoubleClickEventArgs Class

Provides data to the ListDoubleClick event in dbiSchedule.

Object Model

ListDoubleClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDoubleClickEventArgs
C#
public class ListDoubleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ListDoubleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDoubleClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ListDoubleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDoubleClickEventArgs Class

"

The following tables list the members exposed by ListDoubleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ListDoubleClickEventArgs Constructor | Initializes a new instance of the ListDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Column | The column which has been double clicked on.
public Property | ScheduleItem | The dbiScheduleItem which has been double clicked.
Top

See Also

Reference

ListDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ListDoubleClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDoubleClickEventArgs Class : ListDoubleClickEventArgs Constructor

Initializes a new instance of the ListDoubleClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ListDoubleClickEventArgs()
C#
public ListDoubleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDoubleClickEventArgs Class
ListDoubleClickEventArgs Members


%%PageItemTitle%%

Column Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDoubleClickEventArgs Class : Column Property

The column which has been double clicked on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDoubleClickEventArgs
Dim value As System.Integer

instance.Column = value

value = instance.Column
C#
public System.int Column {get; set;}

Property Value

The zero-based index value of the column which has been clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDoubleClickEventArgs Class
ListDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDoubleClickEventArgs Class : ScheduleItem Property

The dbiScheduleItem which has been double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDoubleClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

A dbiScheduleItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDoubleClickEventArgs Class
ListDoubleClickEventArgs Members


%%PageItemTitle%%

ListDropEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDropEventArgs Class

Provides data to the ListDrop event in dbiSchedule.

Object Model

ListDropEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDropEventArgs
C#
public class ListDropEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ListDropEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDropEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ListDropEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDropEventArgs Class

"

The following tables list the members exposed by ListDropEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ListDropEventArgs Constructor | Initializes a new instance of the ListDropEventArgs class.
Top

Public Properties

 | Name | Description
public Property | drgevent | Gets or sets the drag and drop information of the ScheduleItem where the drop occurred.
public Property | ScheduleItem | Gets or sets the dbiScheduleItem where a drop has occurred.
Top

See Also

Reference

ListDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ListDropEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDropEventArgs Class : ListDropEventArgs Constructor

Initializes a new instance of the ListDropEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ListDropEventArgs()
C#
public ListDropEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDropEventArgs Class
ListDropEventArgs Members


%%PageItemTitle%%

drgevent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDropEventArgs Class : drgevent Property

Gets or sets the drag and drop information of the ScheduleItem where the drop occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDropEventArgs
Dim value As System.Windows.Forms.DragEventArgs

instance.drgevent = value

value = instance.drgevent
C#
public System.Windows.Forms.DragEventArgs drgevent {get; set;}

Remarks

The drgevent property specifies any data associated with this event; the current state of the SHIFT, CTRL, and ALT keys; the location of the mouse pointer; and the drag-and-drop effects allowed by the source and target of the drag event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDropEventArgs Class
ListDropEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ListDropEventArgs Class : ScheduleItem Property

Gets or sets the dbiScheduleItem where a drop has occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ListDropEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem which has received the drop.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ListDropEventArgs Class
ListDropEventArgs Members


%%PageItemTitle%%

MouseWheelCheckEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : MouseWheelCheckEventArgs Class

Provides data for the MouseWheelCheck Event

Object Model

MouseWheelCheckEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As MouseWheelCheckEventArgs
C#
public class MouseWheelCheckEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.MouseWheelCheckEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

MouseWheelCheckEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

MouseWheelCheckEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : MouseWheelCheckEventArgs Class

"

The following tables list the members exposed by MouseWheelCheckEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | MouseWheelCheckEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Allow | Determines if the default MouseWheel behavior will occur (scrolling the vertical scrollbar)
public Property | MouseEvents | The MouseEventArgs related to the MouseWheel scroll that triggered the event.
Top

See Also

Reference

MouseWheelCheckEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

MouseWheelCheckEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > MouseWheelCheckEventArgs Class : MouseWheelCheckEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New MouseWheelCheckEventArgs()
C#
public MouseWheelCheckEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

MouseWheelCheckEventArgs Class
MouseWheelCheckEventArgs Members


%%PageItemTitle%%

Allow Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > MouseWheelCheckEventArgs Class : Allow Property

Determines if the default MouseWheel behavior will occur (scrolling the vertical scrollbar)

Syntax

Visual Basic (Usage) Copy Code
Dim instance As MouseWheelCheckEventArgs
Dim value As System.Boolean

instance.Allow = value

value = instance.Allow
C#
public System.bool Allow {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

MouseWheelCheckEventArgs Class
MouseWheelCheckEventArgs Members


%%PageItemTitle%%

MouseEvents Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > MouseWheelCheckEventArgs Class : MouseEvents Property

The MouseEventArgs related to the MouseWheel scroll that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As MouseWheelCheckEventArgs
Dim value As System.Windows.Forms.MouseEventArgs

instance.MouseEvents = value

value = instance.MouseEvents
C#
public System.Windows.Forms.MouseEventArgs MouseEvents {get; set;}

Property Value

MouseEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

MouseWheelCheckEventArgs Class
MouseWheelCheckEventArgs Members


%%PageItemTitle%%

NoteClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteClickEventArgs Class

Provides data for the NoteClick Event

Object Model

NoteClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleNote ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
C#
public class NoteClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.NoteClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

NoteClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteClickEventArgs Class

"

The following tables list the members exposed by NoteClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | NoteClickEventArgs Constructor | Initializes a new instance of the NoteClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | ScheduleItem | The ScheduleItem where the clicked note exists.
public Property | ScheduleNote | the dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

NoteClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteClickEventArgs Class : NoteClickEventArgs Constructor

Initializes a new instance of the NoteClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NoteClickEventArgs()
C#
public NoteClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteClickEventArgs Class : Button Property

The MouseButton that performed the click.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

MouseButtons

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteClickEventArgs Class : ScheduleItem Property

The ScheduleItem where the clicked note exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

ScheduleNote Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteClickEventArgs Class : ScheduleNote Property

the dbiScheduleNote that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteClickEventArgs
Dim value As dbiScheduleNote

instance.ScheduleNote = value

value = instance.ScheduleNote
C#
public dbiScheduleNote ScheduleNote {get; set;}

Property Value

dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteClickEventArgs Class
NoteClickEventArgs Members


%%PageItemTitle%%

NoteDoubleClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteDoubleClickEventArgs Class

Provides data for the NoteDoubleClick Event

Object Model

NoteDoubleClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleNote ClassdbiScheduleObject Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteDoubleClickEventArgs
C#
public class NoteDoubleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.NoteDoubleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteDoubleClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

NoteDoubleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteDoubleClickEventArgs Class

"

The following tables list the members exposed by NoteDoubleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | NoteDoubleClickEventArgs Constructor | Initializes a new instance of the NoteDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ScheduleItem | The ScheduleItem where the clicked note exists.
public Property | ScheduleNote | the dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

NoteDoubleClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteDoubleClickEventArgs Class : NoteDoubleClickEventArgs Constructor

Initializes a new instance of the NoteDoubleClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New NoteDoubleClickEventArgs()
C#
public NoteDoubleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteDoubleClickEventArgs Class
NoteDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteDoubleClickEventArgs Class : ScheduleItem Property

The ScheduleItem where the clicked note exists.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteDoubleClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteDoubleClickEventArgs Class
NoteDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleNote Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > NoteDoubleClickEventArgs Class : ScheduleNote Property

the dbiScheduleNote that was clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As NoteDoubleClickEventArgs
Dim value As dbiScheduleNote

instance.ScheduleNote = value

value = instance.ScheduleNote
C#
public dbiScheduleNote ScheduleNote {get; set;}

Property Value

dbiScheduleNote Class

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NoteDoubleClickEventArgs Class
NoteDoubleClickEventArgs Members


%%PageItemTitle%%

RedoActionEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RedoActionEventArgs Class

Provides data to the RedoAction event in dbiSchedule.

Object Model

RedoActionEventArgs ClassdbiHistoryItem ClassdbiLinkItem ClassdbiScheduleItem ClassdbiScheduleItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RedoActionEventArgs
C#
public class RedoActionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.RedoActionEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RedoActionEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

RedoActionEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RedoActionEventArgs Class

"

The following tables list the members exposed by RedoActionEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | RedoActionEventArgs Constructor | Initializes a new instance of the RedoActionEventArgs class.
Top

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the RedoActionEvent.
Top

See Also

Reference

RedoActionEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

RedoActionEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RedoActionEventArgs Class : RedoActionEventArgs Constructor

Initializes a new instance of the RedoActionEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New RedoActionEventArgs()
C#
public RedoActionEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RedoActionEventArgs Class
RedoActionEventArgs Members


%%PageItemTitle%%

HistoryItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RedoActionEventArgs Class : HistoryItem Property

Gets the history item for the RedoActionEvent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RedoActionEventArgs
Dim value As dbiHistoryItem

instance.HistoryItem = value

value = instance.HistoryItem
C#
public dbiHistoryItem HistoryItem {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RedoActionEventArgs Class
RedoActionEventArgs Members


%%PageItemTitle%%

RulerDragEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RulerDragEventArgs Class

Provides data to the RulerDrag Event

Object Model

RulerDragEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RulerDragEventArgs
C#
public class RulerDragEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.RulerDragEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

RulerDragEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RulerDragEventArgs Class

"

The following tables list the members exposed by RulerDragEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | RulerDragEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | ScheduleObject | The dbiScheduleObject that contains the ruler that triggered the event.
public Property | Source | The location where the drag started.
public Property | Target | The location where the cursor currently is.
public Property | TimeDistance | The current TimeDistance (pixels between major time units) for the dbiScheduleObject which contains the ruler where the drag is occurring.
Top

See Also

Reference

RulerDragEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

RulerDragEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RulerDragEventArgs Class : RulerDragEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New RulerDragEventArgs()
C#
public RulerDragEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Class
RulerDragEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RulerDragEventArgs Class : ScheduleObject Property

The dbiScheduleObject that contains the ruler that triggered the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RulerDragEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Class
RulerDragEventArgs Members


%%PageItemTitle%%

Source Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RulerDragEventArgs Class : Source Property

The location where the drag started.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RulerDragEventArgs
Dim value As System.Drawing.Point

instance.Source = value

value = instance.Source
C#
public System.Drawing.Point Source {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Class
RulerDragEventArgs Members


%%PageItemTitle%%

Target Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RulerDragEventArgs Class : Target Property

The location where the cursor currently is.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RulerDragEventArgs
Dim value As System.Drawing.Point

instance.Target = value

value = instance.Target
C#
public System.Drawing.Point Target {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Class
RulerDragEventArgs Members


%%PageItemTitle%%

TimeDistance Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > RulerDragEventArgs Class : TimeDistance Property

The current TimeDistance (pixels between major time units) for the dbiScheduleObject which contains the ruler where the drag is occurring.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As RulerDragEventArgs
Dim value As System.Integer

instance.TimeDistance = value

value = instance.TimeDistance
C#
public System.int TimeDistance {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

RulerDragEventArgs Class
RulerDragEventArgs Members


%%PageItemTitle%%

ScheduleClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleClickEventArgs Class

Provides data to the ScheduleClick Event

Object Model

ScheduleClickEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
C#
public class ScheduleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ScheduleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleClickEventArgs Class

"

The following tables list the members exposed by ScheduleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleClickEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Button | The MouseButton that was used to click the schedule.
public Property | RulerClick | Indicates if the click occurred in the ruler area.
public Property | ScheduleObject | The dbiScheduleObject where the click occurred.
public Property | ScheduleX | The X-coordinate (relative to the dbiScheduleObject) where the click occurred
public Property | ScheduleY | The Y-coordinate (relative to the dbiScheduleObject) where the click occurred
public Property | X | The X-coordinate where the click occurred
public Property | Y | The Y-coordinate where the click occurred
Top

See Also

Reference

ScheduleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScheduleClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : ScheduleClickEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleClickEventArgs()
C#
public ScheduleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : Button Property

The MouseButton that was used to click the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

MouseButtons

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

RulerClick Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : RulerClick Property

Indicates if the click occurred in the ruler area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Boolean

instance.RulerClick = value

value = instance.RulerClick
C#
public System.bool RulerClick {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the click occurred.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

ScheduleX Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : ScheduleX Property

The X-coordinate (relative to the dbiScheduleObject) where the click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Integer

instance.ScheduleX = value

value = instance.ScheduleX
C#
public System.int ScheduleX {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

ScheduleY Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : ScheduleY Property

The Y-coordinate (relative to the dbiScheduleObject) where the click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Integer

instance.ScheduleY = value

value = instance.ScheduleY
C#
public System.int ScheduleY {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : X Property

The X-coordinate where the click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleClickEventArgs Class : Y Property

The Y-coordinate where the click occurred

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleClickEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleClickEventArgs Class
ScheduleClickEventArgs Members


%%PageItemTitle%%

ScheduleScrollBarsOffsetAreaEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleScrollBarsOffsetAreaEventArgs Class

Provides data to the ScheduleScrollBarsOffsetArea Event

Object Model

ScheduleScrollBarsOffsetAreaEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleScrollBarsOffsetAreaEventArgs
C#
public class ScheduleScrollBarsOffsetAreaEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ScheduleScrollBarsOffsetAreaEventArgs

Requirements

**Available in Enterprise Version Only**

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleScrollBarsOffsetAreaEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleScrollBarsOffsetAreaEventArgs Class

"

The following tables list the members exposed by ScheduleScrollBarsOffsetAreaEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleScrollBarsOffsetAreaEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Area | Determines the available area based on the current scroll bar offset.
public Property | Length | Determines the total width/height of the scroll bar area
public Property | ScrollBar | Determines which scroll bar area is raising the event.
Top

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScheduleScrollBarsOffsetAreaEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleScrollBarsOffsetAreaEventArgs Class : ScheduleScrollBarsOffsetAreaEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleScrollBarsOffsetAreaEventArgs()
C#
public ScheduleScrollBarsOffsetAreaEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
ScheduleScrollBarsOffsetAreaEventArgs Members


%%PageItemTitle%%

Area Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleScrollBarsOffsetAreaEventArgs Class : Area Property

Determines the available area based on the current scroll bar offset.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleScrollBarsOffsetAreaEventArgs
Dim value As System.Drawing.Rectangle

instance.Area = value

value = instance.Area
C#
public System.Drawing.Rectangle Area {get; set;}

Property Value

Rectangle

Remarks

When the event is firing for the horizontal scroll bar, the width of the area will equal the HorzScheduleScrollOffset Property .

When the event is firing for the vertical scroll bar, the height of the area will equal the VertScrollOffset Property .

The horizontal scroll bar has a minimum width of 42, while the vertical scroll bar has a minimum height of 42. If the difference between the total available space and the respective offset is less than that, the available space for the offset area will be reduced to accomodate the control's scroll bar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
ScheduleScrollBarsOffsetAreaEventArgs Members


%%PageItemTitle%%

Length Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleScrollBarsOffsetAreaEventArgs Class : Length Property

Determines the total width/height of the scroll bar area

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleScrollBarsOffsetAreaEventArgs
Dim value As System.Integer

instance.Length = value

value = instance.Length
C#
public System.int Length {get; set;}

Property Value

Integer

Remarks

For the horizontal scroll bar area this represents the total width. For the vertical scroll bar area this represents the total height.

This value includes the height/width the vertical/horizontal scroll bar will be rendered with as well as the respective area for the offset.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
ScheduleScrollBarsOffsetAreaEventArgs Members


%%PageItemTitle%%

ScrollBar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleScrollBarsOffsetAreaEventArgs Class : ScrollBar Property

Determines which scroll bar area is raising the event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleScrollBarsOffsetAreaEventArgs
Dim value As enumScrollBarType

instance.ScrollBar = value

value = instance.ScrollBar
C#
public enumScrollBarType ScrollBar {get; set;}

Property Value

enumScrollBarType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
ScheduleScrollBarsOffsetAreaEventArgs Members


%%PageItemTitle%%

ScrollBufferResizeArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollBufferResizeArgs Class

Provides data to the ScrollBufferResize Event in dbiSchedule.

Object Model

ScrollBufferResizeArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollBufferResizeArgs
C#
public class ScrollBufferResizeArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ScrollBufferResizeArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollBufferResizeArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScrollBufferResizeArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollBufferResizeArgs Class

"

The following tables list the members exposed by ScrollBufferResizeArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScrollBufferResizeArgs Constructor | Initializes a new instance of the ScrollBufferResizeArgs class.
Top

Public Properties

 | Name | Description
public Property | HorzBufferVisible | Determines if the Horizontal Buffer is visible after a resize.
public Property | HorzScrollRight | Gets the current rightmost position of the Horizontal Scroll Bar for determining the position of any controls placed in the buffer zone.
Top

See Also

Reference

ScrollBufferResizeArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScrollBufferResizeArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollBufferResizeArgs Class : ScrollBufferResizeArgs Constructor

Initializes a new instance of the ScrollBufferResizeArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScrollBufferResizeArgs()
C#
public ScrollBufferResizeArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollBufferResizeArgs Class
ScrollBufferResizeArgs Members


%%PageItemTitle%%

HorzBufferVisible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollBufferResizeArgs Class : HorzBufferVisible Property

Determines if the Horizontal Buffer is visible after a resize.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollBufferResizeArgs
Dim value As System.Boolean

instance.HorzBufferVisible = value

value = instance.HorzBufferVisible
C#
public System.bool HorzBufferVisible {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollBufferResizeArgs Class
ScrollBufferResizeArgs Members


%%PageItemTitle%%

HorzScrollRight Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollBufferResizeArgs Class : HorzScrollRight Property

Gets the current rightmost position of the Horizontal Scroll Bar for determining the position of any controls placed in the buffer zone.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollBufferResizeArgs
Dim value As System.Integer

instance.HorzScrollRight = value

value = instance.HorzScrollRight
C#
public System.int HorzScrollRight {get; set;}

Property Value

System.Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollBufferResizeArgs Class
ScrollBufferResizeArgs Members


%%PageItemTitle%%

ScrollTrackEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollTrackEventArgs Class

Provides the scroll bar used in the ScrollTrackEvent as well as the current value of the scroll bar.

Object Model

ScrollTrackEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollTrackEventArgs
C#
public class ScrollTrackEventArgs : System.EventArgs

Remarks

This class is only available in the Enterprise Edition.

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ScrollTrackEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollTrackEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScrollTrackEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollTrackEventArgs Class

"

The following tables list the members exposed by ScrollTrackEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ScrollTrackEventArgs Constructor | Initializes a new instance of the ScrollTrackEventArgs class.
Top

Public Properties

 | Name | Description
public Property | ScrollBar | An integer value representing the scrollbar that has been moved.
public Property | Value | An integer value used to calculate the scroll bar position.
Top

See Also

Reference

ScrollTrackEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScrollTrackEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollTrackEventArgs Class : ScrollTrackEventArgs Constructor

Initializes a new instance of the ScrollTrackEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScrollTrackEventArgs()
C#
public ScrollTrackEventArgs()

Remarks

This method is only available in the Enterprise Edition.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollTrackEventArgs Class
ScrollTrackEventArgs Members


%%PageItemTitle%%

ScrollBar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollTrackEventArgs Class : ScrollBar Property

An integer value representing the scrollbar that has been moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollTrackEventArgs
Dim value As System.Integer

instance.ScrollBar = value

value = instance.ScrollBar
C#
public System.int ScrollBar {get; set;}

Property Value

Integer value representing the scrollbar that has moved.

0 | Vertical Scroll Bar
1 | List Horizontal Scroll Bar
2 | Schedule Horizontal Scroll Bar

Remarks

This property is only available in the Enterprise Edition.

You can use these values to synchronize multiple schedules with similar views.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollTrackEventArgs Class
ScrollTrackEventArgs Members


%%PageItemTitle%%

Value Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScrollTrackEventArgs Class : Value Property

An integer value used to calculate the scroll bar position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScrollTrackEventArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}

Property Value

Integer

Remarks

This property is only available in the Enterprise Edition.

This is calculated based on a number of factors including visible time units, days in the schedule and time type. This should only be used to synchronize two independent schedules.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScrollTrackEventArgs Class
ScrollTrackEventArgs Members


%%PageItemTitle%%

TimeBarClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarClickEventArgs Class

Provides data to the TimebarClick event in dbiSchedule.

Object Model

TimeBarClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
C#
public class TimeBarClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarClickEventArgs Class

"

The following tables list the members exposed by TimeBarClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarClickEventArgs Constructor | Initializes a new instance of the TimebarClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | Button | The MouseButton being clicked.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being clicked.
public Property | TimeBarItem | The dbiTimebarItem being clicked.
public Property | X | The x-Coordinate when the TimeBar was clicked
public Property | Y | The y-Coordinate when the TimeBar was clicked
Top

See Also

Reference

TimeBarClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : TimeBarClickEventArgs Constructor

Initializes a new instance of the TimebarClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarClickEventArgs()
C#
public TimeBarClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

Button Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : Button Property

The MouseButton being clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As System.Windows.Forms.MouseButtons

instance.Button = value

value = instance.Button
C#
public System.Windows.Forms.MouseButtons Button {get; set;}

Property Value

The MouseButton being clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar being clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar being clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : TimeBarItem Property

The dbiTimebarItem being clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem being clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

X Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : X Property

The x-Coordinate when the TimeBar was clicked

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As System.Integer

instance.X = value

value = instance.X
C#
public System.int X {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

Y Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarClickEventArgs Class : Y Property

The y-Coordinate when the TimeBar was clicked

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarClickEventArgs
Dim value As System.Integer

instance.Y = value

value = instance.Y
C#
public System.int Y {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarClickEventArgs Class
TimeBarClickEventArgs Members


%%PageItemTitle%%

TimeBarDateTextEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDateTextEventArgs Class

Provides data to the TimeBarDateText Event in dbiSchedule.

Object Model

TimeBarDateTextEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
C#
public class TimeBarDateTextEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarDateTextEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarDateTextEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDateTextEventArgs Class

"

The following tables list the members exposed by TimeBarDateTextEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarDateTextEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | DateTime | The DateTime value of the edge of the TimeBar being drawn.
public Property | ForeColor | The color used to paint the text at the edge of the TimeBar.
public Property | IsStart | Determines if the current DateTime is for the start or end of the timebar.
public Property | ScheduleObject | The dbiScheduleOject where the TimeBar is being drawn.
public Property | Text | The text string to be drawn at the edge of the timebar.
public Property | TimeBarItem | The dbiTimeBarITem being drawn.
Top

See Also

Reference

TimeBarDateTextEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarDateTextEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : TimeBarDateTextEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarDateTextEventArgs()
C#
public TimeBarDateTextEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

DateTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : DateTime Property

The DateTime value of the edge of the TimeBar being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As System.Date

instance.DateTime = value

value = instance.DateTime
C#
public System.DateTime DateTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : ForeColor Property

The color used to paint the text at the edge of the TimeBar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

IsStart Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : IsStart Property

Determines if the current DateTime is for the start or end of the timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As System.Boolean

instance.IsStart = value

value = instance.IsStart
C#
public System.bool IsStart {get; set;}

Property Value

Boolean

Remarks

A value of True indicates the Start of the TimeBar, while a value of False indicates the End.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : ScheduleObject Property

The dbiScheduleOject where the TimeBar is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : Text Property

The text string to be drawn at the edge of the timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

String

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDateTextEventArgs Class : TimeBarItem Property

The dbiTimeBarITem being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDateTextEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDateTextEventArgs Class
TimeBarDateTextEventArgs Members


%%PageItemTitle%%

TimeBarDoubleClickEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDoubleClickEventArgs Class

Provides data to the TimebarDoubleClick event in dbiSchedule.

Object Model

TimeBarDoubleClickEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDoubleClickEventArgs
C#
public class TimeBarDoubleClickEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarDoubleClickEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDoubleClickEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarDoubleClickEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDoubleClickEventArgs Class

"

The following tables list the members exposed by TimeBarDoubleClickEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarDoubleClickEventArgs Constructor | Initializes a new instance of the TimebarDoubleClickEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being double clicked.
public Property | TimeBarItem | The dbiTimebarItem being double clicked.
Top

See Also

Reference

TimeBarDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarDoubleClickEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDoubleClickEventArgs Class : TimeBarDoubleClickEventArgs Constructor

Initializes a new instance of the TimebarDoubleClickEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarDoubleClickEventArgs()
C#
public TimeBarDoubleClickEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDoubleClickEventArgs Class
TimeBarDoubleClickEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDoubleClickEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDoubleClickEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDoubleClickEventArgs Class
TimeBarDoubleClickEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDoubleClickEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar being double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDoubleClickEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar being double clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDoubleClickEventArgs Class
TimeBarDoubleClickEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarDoubleClickEventArgs Class : TimeBarItem Property

The dbiTimebarItem being double clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarDoubleClickEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem being double clicked.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarDoubleClickEventArgs Class
TimeBarDoubleClickEventArgs Members


%%PageItemTitle%%

TimeBarItemCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarItemCollection Class

Represents a collection of Timebars.

Object Model

TimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
C#
public class TimeBarItemCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.TimeBarItemCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarItemCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarItemCollection Class

"

The following tables list the members exposed by TimeBarItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarItemCollection Constructor | Overloaded. Initializes a new instance of the TimebarItemCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the Timebar at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new schedule to the collection.
public Method | Clear | Clears all of the Timebars from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified Timebar in the collection.
public Method | Insert | Inserts a new Timebar into the collection.
public Method | Remove | Removes a Timebar from the collection.
public Method | RemoveAt | Removes a Timebar at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

TimeBarItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarItemCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : TimeBarItemCollection Constructor

Initializes a new instance of the TimebarItemCollection class.

Overload List

Overload | Description
TimeBarItemCollection Constructor(dbiScheduleItem) | Initializes a new instance of the class.
TimeBarItemCollection Constructor(dbiSchedule) | Initializes a new instance of the class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

TimeBarItemCollection Constructor(dbiScheduleItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class > TimeBarItemCollection Constructor : TimeBarItemCollection Constructor(dbiScheduleItem)

objOwner
The dbiScheduleItem that will contain the collection.
Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiScheduleItem

Dim instance As New TimeBarItemCollection(objOwner)
C#
public TimeBarItemCollection(
   dbiScheduleItem objOwner
)

Parameters

objOwner
The dbiScheduleItem that will contain the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members
Overload List


%%PageItemTitle%%

TimeBarItemCollection Constructor(dbiSchedule)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class > TimeBarItemCollection Constructor : TimeBarItemCollection Constructor(dbiSchedule)

objControl
The dbiSchedule control that the collection will belong to.
Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim objControl As dbiSchedule

Dim instance As New TimeBarItemCollection(objControl)
C#
public TimeBarItemCollection(
   dbiSchedule objControl
)

Parameters

objControl
The dbiSchedule control that the collection will belong to.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members
Overload List


%%PageItemTitle%%

Add Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Add Method

obj
The dbiScheduleObject to add to dbiSchedule.
Adds a new schedule to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim obj As dbiTimeBarItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiScheduleObject to add to dbiSchedule.

Return Value

The zero-based index of the item in the collection.
The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
Dim DbiTimebar1 As New Dbi.WinControl.Schedule.dbiTimebarItem

DbiTimebar1.Start = Today 'Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3) 'Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text" 'Sets the primary text
DbiTimebar1.Body = "Body Text" 'Sets the body (secondary) text
DbiTimebar1.Font = New System.Drawing.Font("Verdana", 8.25) 'Sets the font for the primary text
DbiTimebar1.SubTextFont = New System.Drawing.Font("Verdana", 7, FontStyle.Italic) 'Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo 'Sets the primary font color
DbiTimebar1.BackColor = Color.White 'Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia 'Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular 'Sets the type of border to place around the time bar

'Adds the timebar to the collection
Me.DbiSchedule1.Items(1).Timebars.Add(DbiTimebar1)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem DbiTimebar1;

DbiTimebar1 = new Dbi.WinControl.Schedule.dbiTimebarItem();

DbiTimebar1.Start = System.DateTime.Today; //Sets the start date time of the time bar
DbiTimebar1.End = DbiTimebar1.Start.AddDays(3); //Sets the end date time of the time bar
DbiTimebar1.Text = "Primary Text"; //Sets the primary text
DbiTimebar1.Body = "Body Text"; //Sets the body (secondary) text
DbiTimebar1.Font = new System.Drawing.Font("Verdana", 9); //Sets the font for the primary text
DbiTimebar1.SubTextFont = new System.Drawing.Font("Verdana", 7, FontStyle.Italic); //Sets the font for the body text
DbiTimebar1.ForeColor = Color.Indigo; //Sets the primary font color
DbiTimebar1.BackColor = Color.White; //Sets the background color of the time bar
DbiTimebar1.BorderColor = Color.Fuchsia; //Sets the border color of the time bar
DbiTimebar1.BorderType = Dbi.enumBorderType.Regular; //Sets the type of border to place around the time bar

this.dbiSchedule1.Items[1].Timebars.Add(DbiTimebar1);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Clear Method

Clears all of the Timebars from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection

instance.Clear()
C#
public void Clear()

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(1).Timebars.Clear()
C# Copy Code
this.dbiSchedule.Items(1).Timebars.Clear();

Remarks

This method will delete all the items from the collection. To remove a single item, use Remove method or the RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

IndexOf(dbiTimeBarItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : IndexOf(dbiTimeBarItem) Method

obj
The dbiTimebarItem to insert.
Returns the index of a specified Timebar in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim obj As dbiTimeBarItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiTimebarItem to insert.

Return Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

Insert Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.The zero-based index location where the item is inserted.
obj
The dbiTimebarItem to insert.
Inserts a new Timebar into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim nIndex As System.Integer
Dim obj As dbiTimeBarItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiTimeBarItem obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.The zero-based index location where the item is inserted.
obj
The dbiTimebarItem to insert.

Example

Visual Basic Copy Code
Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1), System.DateTime.Today.AddDays(4))

objTimebar.BackColor = System.Drawing.Color.SteelBlue 'Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal 'Sets the background fill type
objTimebar.Text = "Time Bar Text" 'Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center 'Sets the alignment of the primary text

objTimebar.StartImage = -2 'Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6 'Sets the image to appear after the time bar

'Inserts the time bar into the collection.  This time bar is now the first item in the collection
Me.DbiSchedule1.Items(1).Timebars.Insert(0, objTimebar)
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarItem objTimebar;

objTimeBar = new Dbi.WinControl.Schedule.dbiTimebarItem(System.DateTime.Today.AddDays(1),System.DateTime.Today.AddDays(4));

objTimebar.BackColor = System.Drawing.Color.SteelBlue; //Sets the primary background color
objTimebar.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color
objTimebar.FillType = Dbi.enumFillType.Diagonal; //Sets the background fill type
objTimebar.Text = "Time Bar Text"; //Sets the primary text
objTimebar.TextAlign = Dbi.WinControl.Schedule.dbiTimebarItem.enumTextAlign.Center; //Sets the alignment of the primary text

objTimebar.StartImage = -2; //Sets the image to appear at the start of the time bar
objTimebar.EndImage = -6; //Sets the image to appear after the time bar

//Inserts the time bar into the collection.  This time bar is now the first item in the collection
this.dbiSchedule1.Items[1].Timebars.Insert(0,objTimebar);

this.dbiSchedule1.BarToFront(objTimebar);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Remove Method

obj
The dbiTimebarItem to remove.
Removes a Timebar from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim obj As dbiTimeBarItem

instance.Remove(obj)
C#
public void Remove(
   dbiTimeBarItem obj
)

Parameters

obj
The dbiTimebarItem to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(1).Timebars.Remove(objTimebar)
C# Copy Code
this.dbiSchedule.Items[1].Timebars.Remove(objTimebar);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : RemoveAt Method

index
The zero-based index of the Timebar to remove.
Removes a Timebar at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the Timebar to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items(1).Timebars.RemoveAt(0)
C# Copy Code
this.dbiSchedule.Items[1].Timebars.RemoveAt(0);

Remarks

If the index value provided in less that zero, or greater than the value in Count property of the TimebarItemCollection an ArgumentExceptionOutOfRange will occur.

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

WriteXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the XML file.
Writes the data in the collection to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the XML file.

Return Value

A Boolean value. If true, and method was successful.

Example

Visual Basic Copy Code
Me.dbiSchedule1.Items(0).Timebars.WriteXMLFile("C:\XMLTimebars.XML")
C# Copy Code
this.dbiSchedule1.Items[0].Timebars.WriteXMLFile("C:\\XMLTimebars.XML");

Remarks

If no extension is provided in the strFileName parameter, the default extension is .XML

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

XMLString Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : XMLString Method

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = Me.dbiSchedule.Items(0).Timebars.XMLString()
C# Copy Code
string strXML;
strXML = Me.dbiSchedule.Items[0].Timebars.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

Count Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the number of Timebars of a single list item in dbiSchedule.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Example

Visual Basic Copy Code
Dim intCount As Integer
intCount = Me.dbiSchedule.Item(0).Timebars.Count
C# Copy Code
int intCount;
intCount = this.dbiSchedule.Items[0].Timebars.Count();

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : Item Property

nIndex
The zero-based index of the Timebar to get or set in the collection.
Gets or sets the Timebar at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarItemCollection
Dim nIndex As System.Integer
Dim value As dbiTimeBarItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiTimeBarItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the Timebar to get or set in the collection.

Property Value

The dbiTimebarItem object.

Remarks

If the index value provided in less than zero, or greater than the value in dbiTimebarItemCollection.Count property an ArgumentExceptionOutOfRange error will occur.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%%

TimeBarMouseEnterEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseEnterEventArgs Class

Provides data for the TimeBarMouseEnter event.

Object Model

TimeBarMouseEnterEventArgs ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMouseEnterEventArgs
C#
public class TimeBarMouseEnterEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarMouseEnterEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseEnterEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarMouseEnterEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseEnterEventArgs Class

"

The following tables list the members exposed by TimeBarMouseEnterEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarMouseEnterEventArgs Constructor | Initializes a new instance of the TimeBarMouseEnterEventArgs class.
Top

Public Properties

 | Name | Description
public Property | TimeBarItem | The dbiTimeBarItem the mouse has moved into.
Top

See Also

Reference

TimeBarMouseEnterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarMouseEnterEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMouseEnterEventArgs Class : TimeBarMouseEnterEventArgs Constructor

Initializes a new instance of the TimeBarMouseEnterEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarMouseEnterEventArgs()
C#
public TimeBarMouseEnterEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseEnterEventArgs Class
TimeBarMouseEnterEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMouseEnterEventArgs Class : TimeBarItem Property

The dbiTimeBarItem the mouse has moved into.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMouseEnterEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseEnterEventArgs Class
TimeBarMouseEnterEventArgs Members


%%PageItemTitle%%

TimeBarMouseLeaveEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseLeaveEventArgs Class

Provides data for the TimeBarMouseLeave event.

Object Model

TimeBarMouseLeaveEventArgs ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMouseLeaveEventArgs
C#
public class TimeBarMouseLeaveEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarMouseLeaveEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseLeaveEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarMouseLeaveEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseLeaveEventArgs Class

"

The following tables list the members exposed by TimeBarMouseLeaveEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarMouseLeaveEventArgs Constructor | Initializes a new instance of the TimeBarMouseLeaveEventArgs class.
Top

Public Properties

 | Name | Description
public Property | TimeBarItem | The dbiTimeBarItem the mouse has moved from.
Top

See Also

Reference

TimeBarMouseLeaveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarMouseLeaveEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMouseLeaveEventArgs Class : TimeBarMouseLeaveEventArgs Constructor

Initializes a new instance of the TimeBarMouseLeaveEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarMouseLeaveEventArgs()
C#
public TimeBarMouseLeaveEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseLeaveEventArgs Class
TimeBarMouseLeaveEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMouseLeaveEventArgs Class : TimeBarItem Property

The dbiTimeBarItem the mouse has moved from.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMouseLeaveEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMouseLeaveEventArgs Class
TimeBarMouseLeaveEventArgs Members


%%PageItemTitle%%

TimeBarMovingEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMovingEventArgs Class

Provides data to the TimeBarMoving Event

Object Model

TimeBarMovingEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
C#
public class TimeBarMovingEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarMovingEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarMovingEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMovingEventArgs Class

"

The following tables list the members exposed by TimeBarMovingEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarMovingEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index of the dbiTimeBarItem being moved.
public Property | End | The new End DateTime value for the dbiTimeBarItem
public Property | ScheduleItem | The dbiScheduleItem where the dbiTimeBarItem is currently being moved.
public Property | Start | The new Start DateTime value for the dbiTimeBarItem.
public Property | TimeBarItem | The dbiTimeBarItem being moved.
Top

See Also

Reference

TimeBarMovingEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarMovingEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : TimeBarMovingEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarMovingEventArgs()
C#
public TimeBarMovingEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : BarIndex Property

The zero-based index of the dbiTimeBarItem being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : End Property

The new End DateTime value for the dbiTimeBarItem

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : ScheduleItem Property

The dbiScheduleItem where the dbiTimeBarItem is currently being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : Start Property

The new Start DateTime value for the dbiTimeBarItem.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarMovingEventArgs Class : TimeBarItem Property

The dbiTimeBarItem being moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarMovingEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarMovingEventArgs Class
TimeBarMovingEventArgs Members


%%PageItemTitle%%

TimeBarSizingEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarSizingEventArgs Class

Provides data to the TimebarSizing event in dbiSchedule.

Object Model

TimeBarSizingEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
C#
public class TimeBarSizingEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.TimeBarSizingEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarSizingEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarSizingEventArgs Class

"

The following tables list the members exposed by TimeBarSizingEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarSizingEventArgs Constructor | Initializes a new instance of the TimebarSizingEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | End | The ending date time value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being sized.
public Property | Start | The starting date time value of the Timebar.
public Property | TimeBarItem | The dbiTimebarItem being sized.
Top

See Also

Reference

TimeBarSizingEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarSizingEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : TimeBarSizingEventArgs Constructor

Initializes a new instance of the TimebarSizingEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New TimeBarSizingEventArgs()
C#
public TimeBarSizingEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : BarIndex Property

The zero-based index value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

The zero-based index value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : End Property

The ending date time value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

The ending date time value of the Timebar

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : ScheduleItem Property

The dbiScheduleItem containing the Timebar being sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

The dbiScheduleItem containing the Timebar being sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : Start Property

The starting date time value of the Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

The starting date time value of the Timebar.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarSizingEventArgs Class : TimeBarItem Property

The dbiTimebarItem being sized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarSizingEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

The dbiTimebarItem being sized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarSizingEventArgs Class
TimeBarSizingEventArgs Members


%%PageItemTitle%%

UndoActionEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UndoActionEventArgs Class

Provides data to the UndoAction event in dbiSchedule.

Object Model

UndoActionEventArgs ClassdbiHistoryItem ClassdbiLinkItem ClassdbiScheduleItem ClassdbiScheduleItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UndoActionEventArgs
C#
public class UndoActionEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UndoActionEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UndoActionEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UndoActionEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UndoActionEventArgs Class

"

The following tables list the members exposed by UndoActionEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UndoActionEventArgs Constructor | Initializes a new instance of the UndoActionEventArgs class.
Top

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the UndoActionEvent.
Top

See Also

Reference

UndoActionEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UndoActionEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UndoActionEventArgs Class : UndoActionEventArgs Constructor

Initializes a new instance of the UndoActionEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UndoActionEventArgs()
C#
public UndoActionEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UndoActionEventArgs Class
UndoActionEventArgs Members


%%PageItemTitle%%

HistoryItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UndoActionEventArgs Class : HistoryItem Property

Gets the history item for the UndoActionEvent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UndoActionEventArgs
Dim value As dbiHistoryItem

instance.HistoryItem = value

value = instance.HistoryItem
C#
public dbiHistoryItem HistoryItem {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UndoActionEventArgs Class
UndoActionEventArgs Members


%%PageItemTitle%%

UserDrawnBarAfterEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarAfterEventArgs Class

Provides data to the UserDrawnBarAfter Event in dbiSchedule.

Object Model

UserDrawnBarAfterEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
C#
public class UserDrawnBarAfterEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnBarAfterEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnBarAfterEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarAfterEventArgs Class

"

The following tables list the members exposed by UserDrawnBarAfterEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnBarAfterEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
public Property | Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
public Property | ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
public Property | TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.
Top

See Also

Reference

UserDrawnBarAfterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnBarAfterEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : UserDrawnBarAfterEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnBarAfterEventArgs()
C#
public UserDrawnBarAfterEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : BarIndex Property

The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : Graphics Property

A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

MapArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : MapArea Property

Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As System.Boolean

instance.MapArea = value

value = instance.MapArea
C#
public System.bool MapArea {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : Rect Property

A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : ScheduleItem Property

This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : ScheduleObject Property

This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarAfterEventArgs Class : TimeBarItem Property

This property provides a handle back to the dbiTimeBarItem being rendered in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarAfterEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarAfterEventArgs Class
UserDrawnBarAfterEventArgs Members


%%PageItemTitle%%

UserDrawnBarEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarEventArgs Class

Provides data to the UserDrawnBar Event in dbiSchedule.

Object Model

UserDrawnBarEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
C#
public class UserDrawnBarEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnBarEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnBarEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarEventArgs Class

"

The following tables list the members exposed by UserDrawnBarEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnBarEventArgs Constructor | Initializes a new instance of the UserDrawnBarEventArgs class.
Top

Public Properties

 | Name | Description
public Property | BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
public Property | Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | PaintBar | Indicates to the control if the internal PaintBar routine is to be used to paint the Time Bar. When the e.PaintBar property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar.
public Property | PaintText | Indicates to the control if the internal PaintText routine is to be used to paint the Time Bar Text. When the e.PaintText property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar Text.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
public Property | ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
public Property | TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.
Top

See Also

Reference

UserDrawnBarEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnBarEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : UserDrawnBarEventArgs Constructor

Initializes a new instance of the UserDrawnBarEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnBarEventArgs()
C#
public UserDrawnBarEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

BarIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : BarIndex Property

The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Integer

instance.BarIndex = value

value = instance.BarIndex
C#
public System.int BarIndex {get; set;}

Property Value

System.Integer

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : Graphics Property

A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

System.Drawing.Graphics

Remarks

The e.Graphics handle is different for each area reported in the event (schedule area of the control or map area of the control).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

MapArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : MapArea Property

Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Boolean

instance.MapArea = value

value = instance.MapArea
C#
public System.bool MapArea {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

PaintBar Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : PaintBar Property

Indicates to the control if the internal PaintBar routine is to be used to paint the Time Bar. When the e.PaintBar property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Boolean

instance.PaintBar = value

value = instance.PaintBar
C#
public System.bool PaintBar {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

PaintText Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : PaintText Property

Indicates to the control if the internal PaintText routine is to be used to paint the Time Bar Text. When the e.PaintText property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar Text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Boolean

instance.PaintText = value

value = instance.PaintText
C#
public System.bool PaintText {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : Rect Property

A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

System.Drawing.Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : ScheduleItem Property

This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : ScheduleObject Property

This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

The UserDrawnTimeBar event fires once for each ScheduleObject in the visible Schedule Area for which the Time Bar being drawn is eligible for rendering (based on the start and end of the time bar relative to the ScheduleObject’s start and end). If the Map Area of the control is visible, the UserDrawnTimeBar event fires once for each ScheduleObject in the control’s Schedules collection for which the Time Bar is elgible for rendering when painting the Map Area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

TimeBarItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnBarEventArgs Class : TimeBarItem Property

This property provides a handle back to the dbiTimeBarItem being rendered in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnBarEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarItem = value

value = instance.TimeBarItem
C#
public dbiTimeBarItem TimeBarItem {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnBarEventArgs Class
UserDrawnBarEventArgs Members


%%PageItemTitle%%

UserDrawnCustomAreaEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnCustomAreaEventArgs Class

Provides data to the UserDrawnCustomArea Event

Object Model

UserDrawnCustomAreaEventArgs ClassdbiCustomArea ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
C#
public class UserDrawnCustomAreaEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnCustomAreaEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnCustomAreaEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnCustomAreaEventArgs Class

"

The following tables list the members exposed by UserDrawnCustomAreaEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnCustomAreaEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea being drawn.
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | MapArea | Determines if the custom area is currently being drawn in the map area.
public Property | PaintArea | Indicates to the control if the custom area should be drawn with the standard routines.
public Property | Rect | The rectangle representing the size and location of the custom area.
public Property | ScheduleItem | The dbiScheduleItem where the dbiCustomArea is being drawn.
public Property | ScheduleObject | The dbiScheduleObject where the dbiCustomArea is being drawn.
Top

See Also

Reference

UserDrawnCustomAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnCustomAreaEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : UserDrawnCustomAreaEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnCustomAreaEventArgs()
C#
public UserDrawnCustomAreaEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

CustomArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : CustomArea Property

The dbiCustomArea being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As dbiCustomArea

instance.CustomArea = value

value = instance.CustomArea
C#
public dbiCustomArea CustomArea {get; set;}

Property Value

dbiCustomArea

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : Graphics Property

A handle to the Graphics object responsible for the drawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

MapArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : MapArea Property

Determines if the custom area is currently being drawn in the map area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As System.Boolean

instance.MapArea = value

value = instance.MapArea
C#
public System.bool MapArea {get; set;}

Property Value

Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

PaintArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : PaintArea Property

Indicates to the control if the custom area should be drawn with the standard routines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As System.Boolean

instance.PaintArea = value

value = instance.PaintArea
C#
public System.bool PaintArea {get; set;}

Remarks

When the e.PaintArea property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Custom Area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : Rect Property

The rectangle representing the size and location of the custom area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : ScheduleItem Property

The dbiScheduleItem where the dbiCustomArea is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnCustomAreaEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the dbiCustomArea is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnCustomAreaEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnCustomAreaEventArgs Class
UserDrawnCustomAreaEventArgs Members


%%PageItemTitle%%

UserDrawnFooterEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnFooterEventArgs Class

Provides data to the UserDrawnFooter Event in dbiSchedule.

Object Model

UserDrawnFooterEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
C#
public class UserDrawnFooterEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnFooterEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnFooterEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnFooterEventArgs Class

"

The following tables list the members exposed by UserDrawnFooterEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnFooterEventArgs Constructor | Initializes a new instance of the UserDrawnFooterEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the footer area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
public Property | ListArea | Reports True if the UserDrawnFooter event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnFooter event is being fired when the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnFooter event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnFooter Event fires once for each area in the footer to be painted; the list, and each ScheduleObject visible in the schedule area of the control.
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.
Top

See Also

Reference

UserDrawnFooterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnFooterEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : UserDrawnFooterEventArgs Constructor

Initializes a new instance of the UserDrawnFooterEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnFooterEventArgs()
C#
public UserDrawnFooterEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : Graphics Property

A graphics handle to the custom area provided to the developer within the footer area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

System.Drawing.Graphics

Remarks

The e.Graphics handle is different for each area in the footer (List/Schedule).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

LineStart Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : LineStart Property

This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
Dim value As System.Date

instance.LineStart = value

value = instance.LineStart
C#
public System.DateTime LineStart {get; set;}

Property Value

System.DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

ListArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : ListArea Property

Reports True if the UserDrawnFooter event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnFooter event is being fired when the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
Dim value As System.Boolean

instance.ListArea = value

value = instance.ListArea
C#
public System.bool ListArea {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : Rect Property

A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnFooter event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnFooter Event fires once for each area in the footer to be painted; the list, and each ScheduleObject visible in the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

System.Drawing.Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnFooterEventArgs Class : ScheduleObject Property

This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnFooterEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

If the Schedule area of the control contains more than one visible ScheduleObject, the UserDrawnFooter event fires once for each visible ScheduleObject. The developer can custom code the painting of each area based on the e.ScheduleObject parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnFooterEventArgs Class
UserDrawnFooterEventArgs Members


%%PageItemTitle%%

UserDrawnHeaderEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnHeaderEventArgs Class

Provides data to the UserDrawnHeader Event in dbiSchedule.

Object Model

UserDrawnHeaderEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
C#
public class UserDrawnHeaderEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnHeaderEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnHeaderEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnHeaderEventArgs Class

"

The following tables list the members exposed by UserDrawnHeaderEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnHeaderEventArgs Constructor | Initializes a new instance of the UserDrawnHeaderEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the header area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
public Property | ListArea | Reports True if UserDrawnHeader event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnHeader event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnHeader event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnHeader Event fires once for each area in the header to be painted; the List, and each ScheduleObject visible in the schedule area of the control
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.
Top

See Also

Reference

UserDrawnHeaderEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnHeaderEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : UserDrawnHeaderEventArgs Constructor

Initializes a new instance of the UserDrawnHeaderEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnHeaderEventArgs()
C#
public UserDrawnHeaderEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : Graphics Property

A graphics handle to the custom area provided to the developer within the header area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

System.Drawing.Graphics

Remarks

The e.Graphics handle is different for each area in the header (List/Schedule).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

LineStart Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : LineStart Property

This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
Dim value As System.Date

instance.LineStart = value

value = instance.LineStart
C#
public System.DateTime LineStart {get; set;}

Property Value

System.DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

ListArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : ListArea Property

Reports True if UserDrawnHeader event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnHeader event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
Dim value As System.Boolean

instance.ListArea = value

value = instance.ListArea
C#
public System.bool ListArea {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : Rect Property

A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnHeader event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnHeader Event fires once for each area in the header to be painted; the List, and each ScheduleObject visible in the schedule area of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

System.Drawing.Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnHeaderEventArgs Class : ScheduleObject Property

This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnHeaderEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

If the Schedule area of the control contains more than one visible ScheduleObject, the UserDrawnHeader event fires once for each visible ScheduleObject. The developer can custom code the painting of each area based on the e.ScheduleObject parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnHeaderEventArgs Class
UserDrawnHeaderEventArgs Members


%%PageItemTitle%%

UserDrawnLineEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLineEventArgs Class

Provides data to the UserDrawnLine Event in dbiSchedule.

Object Model

UserDrawnLineEventArgs ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
C#
public class UserDrawnLineEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnLineEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnLineEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLineEventArgs Class

"

The following tables list the members exposed by UserDrawnLineEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnLineEventArgs Constructor | Initializes a new instance of the UserDrawnLineEventArgs class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the schedule area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area or map area of the control.
public Property | MapArea | Reports True if UserDrawnLine event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnLine event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | Rect | rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnLine event the e.Rect object represents the item area to be drawn in schedule area specific to the ScheduleObject being drawn when the e.MapArea property is False (i.e. the control is painting the schedule area of the control), or the item area within the map area to be painted specific to the ScheduleOjbect being painted.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem being painted. The developer can read or interract with the properties of the item such as its text, backcolor, etc. within the UserDrawnLine event.
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control.
Top

See Also

Reference

UserDrawnLineEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnLineEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : UserDrawnLineEventArgs Constructor

Initializes a new instance of the UserDrawnLineEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnLineEventArgs()
C#
public UserDrawnLineEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : Graphics Property

A graphics handle to the custom area provided to the developer within the schedule area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

System.Drawing.Graphics

Remarks

The e.Graphics handle is different for each area reported in the event (schedule area of the control ->ScheduleObject and map area of the control - >ScheduleObject).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

LineStart Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : LineStart Property

This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area or map area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As System.Date

instance.LineStart = value

value = instance.LineStart
C#
public System.DateTime LineStart {get; set;}

Property Value

System.DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

MapArea Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : MapArea Property

Reports True if UserDrawnLine event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnLine event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As System.Boolean

instance.MapArea = value

value = instance.MapArea
C#
public System.bool MapArea {get; set;}

Property Value

System.Boolean

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : Rect Property

rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnLine event the e.Rect object represents the item area to be drawn in schedule area specific to the ScheduleObject being drawn when the e.MapArea property is False (i.e. the control is painting the schedule area of the control), or the item area within the map area to be painted specific to the ScheduleOjbect being painted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

System.Drawing.Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

ScheduleItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : ScheduleItem Property

This property provides a handle back to the dbiScheduleItem being painted. The developer can read or interract with the properties of the item such as its text, backcolor, etc. within the UserDrawnLine event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItem = value

value = instance.ScheduleItem
C#
public dbiScheduleItem ScheduleItem {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLineEventArgs Class : ScheduleObject Property

This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLineEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Remarks

The UserDrawnLine event fires once for each ScheduleObject visible in the Schedule area of the control. If the Map Area of the control is visible, the UserDrawnLine event fires once for each ScheduleObject in the control’s Schedules collection when painting the Map Area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLineEventArgs Class
UserDrawnLineEventArgs Members


%%PageItemTitle%%

UserDrawnLinkLineEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLinkLineEventArgs Class

Provides data to the UserDrawnLinkLine Event in dbiSchedule.

Object Model

UserDrawnLinkLineEventArgs ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
C#
public class UserDrawnLinkLineEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnLinkLineEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnLinkLineEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLinkLineEventArgs Class

"

The following tables list the members exposed by UserDrawnLinkLineEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnLinkLineEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Graphics | The Graphics object where the dbiLinkItem will be drawn.
public Property | LinkItem | The dbiLinkItem being drawn.
public Property | PaintLinkLine | Determines if the control should draw the dbiLinkItem with the default appearance.
public Property | PointFrom | The starting coordinate of the dbiLinkItem in the display.
public Property | PointTo | The ending coordinate of the dbiLinkItem in the display.
public Property | Printing | Determines if the event is being raised by the printing routines.
public Property | ScheduleItemFrom | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem begins.
public Property | ScheduleItemTo | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem ends.
public Property | ScheduleObject | The dbiScheduleObject where the dbiLinkItem is being rendered.
public Property | TimeBarFrom | The dbiTimeBarItem where the dbiLinkItem begins.
public Property | TimeBarTo | The dbiTimeBarItem where the dbiLinkItem ends.
Top

See Also

Reference

UserDrawnLinkLineEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnLinkLineEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : UserDrawnLinkLineEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnLinkLineEventArgs()
C#
public UserDrawnLinkLineEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : Graphics Property

The Graphics object where the dbiLinkItem will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

LinkItem Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : LinkItem Property

The dbiLinkItem being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiLinkItem

instance.LinkItem = value

value = instance.LinkItem
C#
public dbiLinkItem LinkItem {get; set;}

Property Value

dbiLinkItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

PaintLinkLine Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : PaintLinkLine Property

Determines if the control should draw the dbiLinkItem with the default appearance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As System.Boolean

instance.PaintLinkLine = value

value = instance.PaintLinkLine
C#
public System.bool PaintLinkLine {get; set;}

Property Value

Boolean

Remarks

Set this property to False to prevent the control from drawing the dbiLinkItem, allowing the developer to draw it in a manner of their choosing.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

PointFrom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : PointFrom Property

The starting coordinate of the dbiLinkItem in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As System.Drawing.Point

instance.PointFrom = value

value = instance.PointFrom
C#
public System.Drawing.Point PointFrom {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

PointTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : PointTo Property

The ending coordinate of the dbiLinkItem in the display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As System.Drawing.Point

instance.PointTo = value

value = instance.PointTo
C#
public System.Drawing.Point PointTo {get; set;}

Property Value

Point

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

Printing Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : Printing Property

Determines if the event is being raised by the printing routines.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As System.Boolean

instance.Printing = value

value = instance.Printing
C#
public System.bool Printing {get; set;}

Property Value

Boolean.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

ScheduleItemFrom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : ScheduleItemFrom Property

The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem begins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemFrom = value

value = instance.ScheduleItemFrom
C#
public dbiScheduleItem ScheduleItemFrom {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

ScheduleItemTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : ScheduleItemTo Property

The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem ends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiScheduleItem

instance.ScheduleItemTo = value

value = instance.ScheduleItemTo
C#
public dbiScheduleItem ScheduleItemTo {get; set;}

Property Value

dbiScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : ScheduleObject Property

The dbiScheduleObject where the dbiLinkItem is being rendered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

TimeBarFrom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : TimeBarFrom Property

The dbiTimeBarItem where the dbiLinkItem begins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarFrom = value

value = instance.TimeBarFrom
C#
public dbiTimeBarItem TimeBarFrom {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

TimeBarTo Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnLinkLineEventArgs Class : TimeBarTo Property

The dbiTimeBarItem where the dbiLinkItem ends.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnLinkLineEventArgs
Dim value As dbiTimeBarItem

instance.TimeBarTo = value

value = instance.TimeBarTo
C#
public dbiTimeBarItem TimeBarTo {get; set;}

Property Value

dbiTimeBarItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnLinkLineEventArgs Class
UserDrawnLinkLineEventArgs Members


%%PageItemTitle%%

UserDrawnListScrollAreaEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnListScrollAreaEventArgs Class

Provides data to the UserDrawnListScrollArea Event

Object Model

UserDrawnListScrollAreaEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnListScrollAreaEventArgs
C#
public class UserDrawnListScrollAreaEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnListScrollAreaEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnListScrollAreaEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnListScrollAreaEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnListScrollAreaEventArgs Class

"

The following tables list the members exposed by UserDrawnListScrollAreaEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnListScrollAreaEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | Rect | The rectangle representing the size and location of the scroll bar area.
Top

See Also

Reference

UserDrawnListScrollAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnListScrollAreaEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnListScrollAreaEventArgs Class : UserDrawnListScrollAreaEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnListScrollAreaEventArgs()
C#
public UserDrawnListScrollAreaEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnListScrollAreaEventArgs Class
UserDrawnListScrollAreaEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnListScrollAreaEventArgs Class : Graphics Property

A handle to the Graphics object responsible for the drawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnListScrollAreaEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnListScrollAreaEventArgs Class
UserDrawnListScrollAreaEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnListScrollAreaEventArgs Class : Rect Property

The rectangle representing the size and location of the scroll bar area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnListScrollAreaEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnListScrollAreaEventArgs Class
UserDrawnListScrollAreaEventArgs Members


%%PageItemTitle%%

UserDrawnRulerEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerEventArgs Class

Provides data to the UserDrawnRuler Event

Object Model

UserDrawnRulerEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
C#
public class UserDrawnRulerEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnRulerEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnRulerEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerEventArgs Class

"

The following tables list the members exposed by UserDrawnRulerEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnRulerEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | End | The End value of the visible portion of the ruler.
public Property | FirstDraw | Determines if the event is firing before painting the background of the ruler.
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | Rect | The rectangle representing the size and location of the ruler.
public Property | ScheduleObject | The dbiScheduleObject whose ruler is being drawn.
public Property | Start | The End value of the visible portion of the ruler.
Top

See Also

Reference

UserDrawnRulerEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnRulerEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : UserDrawnRulerEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnRulerEventArgs()
C#
public UserDrawnRulerEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

End Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : End Property

The End value of the visible portion of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As System.Date

instance.End = value

value = instance.End
C#
public System.DateTime End {get; set;}

Property Value

DateTime

Remarks

This value will be rounded up to the next major time unit.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

FirstDraw Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : FirstDraw Property

Determines if the event is firing before painting the background of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As System.Boolean

instance.FirstDraw = value

value = instance.FirstDraw
C#
public System.bool FirstDraw {get; set;}

Property Value

Boolean

Remarks

If True, the background of the ruler hasn't been painted yet.

If False, the event is firing for a second time after all the text and lines have been drawn in the ruler area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : Graphics Property

A handle to the Graphics object responsible for the drawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : Rect Property

The rectangle representing the size and location of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : ScheduleObject Property

The dbiScheduleObject whose ruler is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

Start Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerEventArgs Class : Start Property

The End value of the visible portion of the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerEventArgs
Dim value As System.Date

instance.Start = value

value = instance.Start
C#
public System.DateTime Start {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerEventArgs Class
UserDrawnRulerEventArgs Members


%%PageItemTitle%%

UserDrawnRulerSegmentEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerSegmentEventArgs Class

Provides data to the UserDrawnRulerSegment Event in dbiSchedule.

Object Model

UserDrawnRulerSegmentEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
C#
public class UserDrawnRulerSegmentEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnRulerSegmentEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnRulerSegmentEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerSegmentEventArgs Class

"

The following tables list the members exposed by UserDrawnRulerSegmentEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnRulerSegmentEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | DateTime | The DateTime value of the segment.
public Property | Font | The Font the control will use to draw text in the segment.
public Property | ForeColor | The color the control will use to draw text in the segment.
public Property | Graphics | A handle to the Graphics object where the ruler segment will be rendered.
public Property | Rect | The rectangle representing the size and location of the ruler segment within the ruler.
public Property | Schedule | The dbiScheduleObject that the ruler and ruler segment belong to.
public Property | Segment | The index of the current segment being drawn
public Property | SegmentWidth | The current width of the segment to be drawn.
public Property | Text | The text string the control should draw within the segment in the ruler.
public Property | TextAlign | The alignment of the text when rendered by the control within the ruler segment.
Top

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnRulerSegmentEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : UserDrawnRulerSegmentEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnRulerSegmentEventArgs()
C#
public UserDrawnRulerSegmentEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

DateTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : DateTime Property

The DateTime value of the segment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Date

instance.DateTime = value

value = instance.DateTime
C#
public System.DateTime DateTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Font Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Font Property

The Font the control will use to draw text in the segment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

Font

Remarks

The value of this property only needs to be changed if you are assigning a value to the Text property that you want the control to draw for you.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : ForeColor Property

The color the control will use to draw text in the segment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Remarks

The value of this property only needs to be changed if you are assigning a value to the Text property that you want the control to draw for you.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Graphics Property

A handle to the Graphics object where the ruler segment will be rendered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Rect Property

The rectangle representing the size and location of the ruler segment within the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Schedule Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Schedule Property

The dbiScheduleObject that the ruler and ruler segment belong to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As dbiScheduleObject

instance.Schedule = value

value = instance.Schedule
C#
public dbiScheduleObject Schedule {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Segment Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Segment Property

The index of the current segment being drawn

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Integer

instance.Segment = value

value = instance.Segment
C#
public System.int Segment {get; set;}

Property Value

Integer

Remarks

The first segment in the display (left most in the ruler) is always 0. The total number of segments will depend on the current setup of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

SegmentWidth Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : SegmentWidth Property

The current width of the segment to be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Integer

instance.SegmentWidth = value

value = instance.SegmentWidth
C#
public System.int SegmentWidth {get; set;}

Property Value

Integer

Remarks

Increasing the value of this property will allow the control to draw the value defined in the Text property over multiple segments.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : Text Property

The text string the control should draw within the segment in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

String

Remarks

Leave this property empty if you wish to draw the text yourself within the event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

TextAlign Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerSegmentEventArgs Class : TextAlign Property

The alignment of the text when rendered by the control within the ruler segment.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerSegmentEventArgs
Dim value As System.Drawing.ContentAlignment

instance.TextAlign = value

value = instance.TextAlign
C#
public System.Drawing.ContentAlignment TextAlign {get; set;}

Property Value

ContentAlignment

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
UserDrawnRulerSegmentEventArgs Members


%%PageItemTitle%%

UserDrawnRulerTitleEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerTitleEventArgs Class

Provides data to the UserDrawnRulerTitle Event

Object Model

UserDrawnRulerTitleEventArgs ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerTitleEventArgs
C#
public class UserDrawnRulerTitleEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnRulerTitleEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerTitleEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnRulerTitleEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerTitleEventArgs Class

"

The following tables list the members exposed by UserDrawnRulerTitleEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnRulerTitleEventArgs Constructor | Initializes a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | DateTime | The Date value to be written in the title area.
public Property | ScheduleObject | The dbiScheduleObject whose ruler title is being drawn.
public Property | Text | The text that will be displayed in the ruler title.
Top

See Also

Reference

UserDrawnRulerTitleEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnRulerTitleEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerTitleEventArgs Class : UserDrawnRulerTitleEventArgs Constructor

Initializes a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnRulerTitleEventArgs()
C#
public UserDrawnRulerTitleEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerTitleEventArgs Class
UserDrawnRulerTitleEventArgs Members


%%PageItemTitle%%

DateTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerTitleEventArgs Class : DateTime Property

The Date value to be written in the title area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerTitleEventArgs
Dim value As System.Date

instance.DateTime = value

value = instance.DateTime
C#
public System.DateTime DateTime {get; set;}

Property Value

DateTime

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerTitleEventArgs Class
UserDrawnRulerTitleEventArgs Members


%%PageItemTitle%%

ScheduleObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerTitleEventArgs Class : ScheduleObject Property

The dbiScheduleObject whose ruler title is being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerTitleEventArgs
Dim value As dbiScheduleObject

instance.ScheduleObject = value

value = instance.ScheduleObject
C#
public dbiScheduleObject ScheduleObject {get; set;}

Property Value

dbiScheduleObject

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerTitleEventArgs Class
UserDrawnRulerTitleEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnRulerTitleEventArgs Class : Text Property

The text that will be displayed in the ruler title.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnRulerTitleEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

string

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnRulerTitleEventArgs Class
UserDrawnRulerTitleEventArgs Members


%%PageItemTitle%%

UserDrawnTimeBarsEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnTimeBarsEventArgs Class

Provides data to the UserDrawnTimeBars Event

Object Model

UserDrawnTimeBarsEventArgs ClassdbiUserDrawnBarCollection ClassdbiUserDrawnBar Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTimeBarsEventArgs
C#
public class UserDrawnTimeBarsEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnTimeBarsEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTimeBarsEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnTimeBarsEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnTimeBarsEventArgs Class

"

The following tables list the members exposed by UserDrawnTimeBarsEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnTimeBarsEventArgs Constructor | Initializes a new instance of the class
Top

Public Properties

 | Name | Description
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | TimeBars | The collection of dbiUserDrawnBars that can be drawn.
Top

See Also

Reference

UserDrawnTimeBarsEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnTimeBarsEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnTimeBarsEventArgs Class : UserDrawnTimeBarsEventArgs Constructor

Initializes a new instance of the class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnTimeBarsEventArgs()
C#
public UserDrawnTimeBarsEventArgs()

Return Value

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTimeBarsEventArgs Class
UserDrawnTimeBarsEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnTimeBarsEventArgs Class : Graphics Property

A handle to the Graphics object responsible for the drawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTimeBarsEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTimeBarsEventArgs Class
UserDrawnTimeBarsEventArgs Members


%%PageItemTitle%%

TimeBars Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnTimeBarsEventArgs Class : TimeBars Property

The collection of dbiUserDrawnBars that can be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnTimeBarsEventArgs
Dim value As dbiUserDrawnBarCollection

instance.TimeBars = value

value = instance.TimeBars
C#
public dbiUserDrawnBarCollection TimeBars {get; set;}

Property Value

dbiUserDrawnBarCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnTimeBarsEventArgs Class
UserDrawnTimeBarsEventArgs Members


%%PageItemTitle%%

UserDrawnWaterMarkEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnWaterMarkEventArgs Class

Provides data to the UserDrawnWaterMark Event

Object Model

UserDrawnWaterMarkEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnWaterMarkEventArgs
C#
public class UserDrawnWaterMarkEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.UserDrawnWaterMarkEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

UserDrawnWaterMarkEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnWaterMarkEventArgs Class

"

The following tables list the members exposed by UserDrawnWaterMarkEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | UserDrawnWaterMarkEventArgs Constructor | Initialize a new instance of the class.
Top

Public Properties

 | Name | Description
public Property | Graphics | The Graphics object for the display of the schedule.
public Property | PaintWaterMark | Determines if the control should still generate the WaterMark based on the associated properties.
public Property | Printing | Determines if the event is being raised during the printing process.
public Property | ScheduleAreaRect | Represents the size and location of the schedulea area relative to the Graphics.
Top

See Also

Reference

UserDrawnWaterMarkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

UserDrawnWaterMarkEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnWaterMarkEventArgs Class : UserDrawnWaterMarkEventArgs Constructor

Initialize a new instance of the class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New UserDrawnWaterMarkEventArgs()
C#
public UserDrawnWaterMarkEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Class
UserDrawnWaterMarkEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnWaterMarkEventArgs Class : Graphics Property

The Graphics object for the display of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnWaterMarkEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Class
UserDrawnWaterMarkEventArgs Members


%%PageItemTitle%%

PaintWaterMark Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnWaterMarkEventArgs Class : PaintWaterMark Property

Determines if the control should still generate the WaterMark based on the associated properties.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnWaterMarkEventArgs
Dim value As System.Boolean

instance.PaintWaterMark = value

value = instance.PaintWaterMark
C#
public System.bool PaintWaterMark {get; set;}

Property Value

Boolean

Remarks

This property is only used if a value has been assigned to the WaterMarkText property of the control and the developer wishes to disable the display of that WaterMark for their own custom one.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Class
UserDrawnWaterMarkEventArgs Members


%%PageItemTitle%%

Printing Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnWaterMarkEventArgs Class : Printing Property

Determines if the event is being raised during the printing process.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnWaterMarkEventArgs
Dim value As System.Boolean

instance.Printing = value

value = instance.Printing
C#
public System.bool Printing {get; set;}

Property Value

Boolean

Remarks

The event will be raised for each page of a printed report where the schedule area is included.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Class
UserDrawnWaterMarkEventArgs Members


%%PageItemTitle%%

ScheduleAreaRect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > UserDrawnWaterMarkEventArgs Class : ScheduleAreaRect Property

Represents the size and location of the schedulea area relative to the Graphics.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As UserDrawnWaterMarkEventArgs
Dim value As System.Drawing.Rectangle

instance.ScheduleAreaRect = value

value = instance.ScheduleAreaRect
C#
public System.Drawing.Rectangle ScheduleAreaRect {get; set;}

Property Value

Rectangle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

UserDrawnWaterMarkEventArgs Class
UserDrawnWaterMarkEventArgs Members


%%PageItemTitle%%

ValuePointEventArgs Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ValuePointEventArgs Class

Provides data to the ValuePoint event in dbiSchedule.

Object Model

ValuePointEventArgs Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
C#
public class ValuePointEventArgs : System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Dbi.WinControl.Schedule.ValuePointEventArgs

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ValuePointEventArgs Class Members
See Also Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ValuePointEventArgs Class

"

The following tables list the members exposed by ValuePointEventArgs.

"

Public Constructors

 | Name | Description
public Constructor | ValuePointEventArgs Constructor | Initializes a new instance of the ValuePointEventArgs class.
Top

Public Properties

 | Name | Description
public Property | CurrentTime | The DateTime value of the major unit being drawn.
public Property | Font | The font value of the major unit being drawn.
public Property | ForeColor | The fore color used to paint the major time unit.
public Property | Graphics | A handle to the Graphics object where the value point section will be drawn.
public Property | Rect | A rectangle representing the size and location of the Value Point within the Graphics object.
public Property | ScheduleIndex | The zero-based index value of the schedule.
public Property | Text | The text to display in the ruler.
public Property | Value | The value of major time unit.
Top

See Also

Reference

ValuePointEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ValuePointEventArgs Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : ValuePointEventArgs Constructor

Initializes a new instance of the ValuePointEventArgs class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ValuePointEventArgs()
C#
public ValuePointEventArgs()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

CurrentTime Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : CurrentTime Property

The DateTime value of the major unit being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Date

instance.CurrentTime = value

value = instance.CurrentTime
C#
public System.DateTime CurrentTime {get; set;}

Property Value

A DateTime value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Font Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : Font Property

The font value of the major unit being drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public System.Drawing.Font Font {get; set;}

Property Value

Font

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : ForeColor Property

The fore color used to paint the major time unit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public System.Drawing.Color ForeColor {get; set;}

Property Value

Color

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Graphics Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : Graphics Property

A handle to the Graphics object where the value point section will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Drawing.Graphics

instance.Graphics = value

value = instance.Graphics
C#
public System.Drawing.Graphics Graphics {get; set;}

Property Value

Graphics

Remarks

***Enterprise Only***

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Rect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : Rect Property

A rectangle representing the size and location of the Value Point within the Graphics object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Drawing.Rectangle

instance.Rect = value

value = instance.Rect
C#
public System.Drawing.Rectangle Rect {get; set;}

Property Value

Rectangle

Remarks

***Enterprise Only***

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

ScheduleIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : ScheduleIndex Property

The zero-based index value of the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Integer

instance.ScheduleIndex = value

value = instance.ScheduleIndex
C#
public System.int ScheduleIndex {get; set;}

Property Value

The zero-based index value of the schedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : Text Property

The text to display in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public System.string Text {get; set;}

Property Value

A String value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

Value Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ValuePointEventArgs Class : Value Property

The value of major time unit.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ValuePointEventArgs
Dim value As System.Integer

instance.Value = value

value = instance.Value
C#
public System.int Value {get; set;}

Property Value

An Integer value

Remarks

This property is dependant on the dbiScheduleObject.TimeType property:

TimeType is Hours Value = Hour (0-24)

TimeType is Days Value = Day of Month (1-31)

TimeType is Weeks Value = Day of Week (0-6)

TimeType is Month and WeekFormat = Weeks Value = Week of Year (1-52)

TimeType is Month and WeekFormat = Dates Value = Day of Month (1-31)

TimeType is Year and YearFormat = Weeks Value = Week of Year (1-52)

TimeType is Year and YearFormat = Months Value = Month of Year (1-12)

TimeType is Year and YearFormat = Quaters Value = Quarter (1-4)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ValuePointEventArgs Class
ValuePointEventArgs Members


%%PageItemTitle%%

dbiHistoryItem.enumActionType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiHistoryItem.enumActionType Enumeration

Specifies the type of Undo/Redo action added to the HistoryCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiHistoryItem.enumActionType
C#
public enum dbiHistoryItem.enumActionType : System.Enum

Members

Member | Description
Create | An new Timebar has been created. Undo - The Timebar will be removed. Redo - The Timebar will be re-created
Empty | Undo - No items in the collection. Redo - No items in the collection.
Link | A new link has been created. Undo - The new link will be removed. Redo - the removed link will be re-created.
Move | An existing Timebar has been moved. Undo - The Timebar will be moved back to the last location. Redo - The Timebar will be moved to the newer location.
Remove | An existing Timebar was deleted. Undo - The deleted Timebar will be re-added. Redo - The re-added Timebar will be removed.
Size | An existing Timebar has been sized. Undo - The Timebar will be resized to the last size. Redo - The resized Timebar will be resized to the newer size.
UnLink | An existing link is removed. Undo - The removed link will be re-added. Redo - The re-added link will be removed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace

Developing with dbiSchedule

History


%%PageItemTitle%%

dbiLinkItem.enumLinkDirection Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiLinkItem.enumLinkDirection Enumeration

Specifies the direction of a link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem.enumLinkDirection
C#
public enum dbiLinkItem.enumLinkDirection : System.Enum

Members

Member | Description
EndToEnd | Links from the end of the Timebar from to the end of the Timebar to.
EndToStart | Links from the end of the Timebar from to the start of the Timebar to.
StartToEnd | Links from the start of the Timebar from to the end of the Timebar to.
StartToStart | Links from the start of the Timebar from to the start of the Timebar to.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiLinkItem.enumLinkDirection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiLinkItem.enumLinkType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiLinkItem.enumLinkType Enumeration

Specifies the type of link to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiLinkItem.enumLinkType
C#
public enum dbiLinkItem.enumLinkType : System.Enum

Members

Member | Description
Direct | A straight line between 2 Timebars with no arrows.
Reciprocal | A line with a right angle and arrows at the source and destination Timebars.
Standard | A line with a right angle and arrows at the destination Timebar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumFirstDayOfWeek Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumFirstDayOfWeek Enumeration

Specifies the first day of the week in the ruler.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumFirstDayOfWeek
C#
public enum dbiScheduleObject.enumFirstDayOfWeek : System.Enum

Members

Member | Description
Friday | Weeks will begin on Friday.
Monday | Weeks will begin on Monday.
Saturday | Weeks will begin on Saturday.
Sunday | Weeks will begin on Sunday.
Thursday | Weeks will begin on Thursday.
Tuesday | Weeks will begin on Tuesday.
Wednesday | Weeks will begin on Wednesday.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumFirstDayOfWeek

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumImageEffect Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumImageEffect Enumeration

Specifies how the background image in the schedule is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumImageEffect
C#
public enum dbiScheduleObject.enumImageEffect : System.Enum

Members

Member | Description
Align | The ImageAlignment property is applied to background image.
Tile | The background image will tile to fill the schedule area.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumImageEffect

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumMonthFormat Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumMonthFormat Enumeration

Specifies how the monthly ruler is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumMonthFormat
C#
public enum dbiScheduleObject.enumMonthFormat : System.Enum

Members

Member | Description
Dates | The major time segments will display dates.
Weeks | The major time segments will display week numbers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumMonthFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumRulerAlign Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumRulerAlign Enumeration

Specifies the alignment of the ruler text in a schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumRulerAlign
C#
public enum dbiScheduleObject.enumRulerAlign : System.Enum

Members

Member | Description
Center | Ruler text will be placed between of major time divisions.
Default | Ruler text alignment will be based on the parent's RulerAlign value.
Left | Ruler text will be placed to the left of major time divisions.
Over | Ruler text will be placed over major time divisions.
Right | Ruler text will be placed to the right of major time divisions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumTimeLineWidth Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumTimeLineWidth Enumeration

Specifies how the time lines will be drawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumTimeLineWidth
C#
public enum dbiScheduleObject.enumTimeLineWidth : System.Enum

Members

Member | Description
Solid | Time lines will appear in a solid line
Thick | Time lines will appear in a thick dotted line
Thin | Time lines will appear in a thin dotted line

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumTimeLineWidth

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumWeekFormat Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumWeekFormat Enumeration

Determines how the first week of the year is identified.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumWeekFormat
C#
public enum dbiScheduleObject.enumWeekFormat : System.Enum

Members

Member | Description
Culture | The first week is determined by the system settings.
FourDayWeek | The first week that has at least four days in the new year

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumWeekFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiScheduleObject.enumYearFormat Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject.enumYearFormat Enumeration

Specifies how the yearly ruler is displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject.enumYearFormat
C#
public enum dbiScheduleObject.enumYearFormat : System.Enum

Members

Member | Description
Months | The major time segments will displayed for each month.
Quarters | Each year will be displayed with 4 major time segments.
Weeks | The major time segments will display week numbers.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiScheduleObject.enumYearFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiTimeBarItem.enumTextAlign Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarItem.enumTextAlign Enumeration

Specifies the position of the primary text of a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarItem.enumTextAlign
C#
public enum dbiTimeBarItem.enumTextAlign : System.Enum

Members

Member | Description
Center | The primary text will appear centered in the Timebar.
Left | The primary text will appear left justified in the Timebar.
LeftOfBar | The primary text will appear to the left of the Timebar.
Right | The primary text will appear right justified in the Timebar.
RightOfBar | The primary text will appear to the right of the Timebar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiTimeBarItem.enumTextAlign

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiTimeBarStyle.enumImageOrder Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarStyle.enumImageOrder Enumeration

Specifies where the start and end images will be placed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarStyle.enumImageOrder
C#
public enum dbiTimeBarStyle.enumImageOrder : System.Enum

Members

Member | Description
Back | The image will be placed behind the Timebar.
Front | The image will be placed in front of the Timebar.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.dbiTimeBarStyle.enumImageOrder

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumAlignment Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumAlignment Enumeration

Specifies the vertical and horizontal alignments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumAlignment
C#
public enum enumAlignment : System.Enum

Members

Member | Description
BottomCenter | Content is vertically aligned at the bottom, and horizontally aligned on the center.
BottomLeft | Content is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Content is vertically aligned at the bottom, and horizontally aligned on the right.
Default | The default alignment.
MiddleCenter | Content is vertically aligned in the middle, and horizontally aligned on the center.
MiddleLeft | Content is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Content is vertically aligned in the middle, and horizontally aligned on the right.
TopCenter | Content is vertically aligned at the top, and horizontally aligned on the center.
TopLeft | Content is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Content is vertically aligned at the top, and horizontally aligned on the right.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumAlignment

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumControlStyle Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumControlStyle Enumeration

The style of dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumControlStyle
C#
public enum enumControlStyle : System.Enum

Members

Member | Description
Default | This is the default setting, it is only used once the other properties have been set.
Vista_Blue | Sets the properties of the dbiTips to use a Vista Blue style with fill effects.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumControlStyle

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumCurrentTimePosition Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumCurrentTimePosition Enumeration

The position of the CurrentTimeLine relative to the timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumCurrentTimePosition
C#
public enum enumCurrentTimePosition : System.Enum

Members

Member | Description
Back | The CurrentTimeLine will appear behind the TimeBars
Front | The CurrentTimeLine will appear in front of TimeBars

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumCurrentTimePosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumEditMode Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumEditMode Enumeration

Specifies the type of action to perform on a Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumEditMode
C#
public enum enumEditMode : System.Enum

Members

Member | Description
Edit | Enables the user to create/edit a Timebar.
Erase | Enables the user to remove a Timebar.
GuideLine | Enable the user to add, move and remove GuideLines in the main Schedule Area. Left clicking in the Schedule Area will add a GuideLine, left clicking and dragging a GuideLine will move it. If you wish to remove a GuideLine in this manner, drag the line off the Schedule either to the left of right. While in this mode, the BeforeGuideLineInsert Event, BeforeGuideLineMove Event, BeforeGuideLineRemove Event will fire before the GuideLine is manipulated while the AfterGuideLineInserted Event, AfterGuideLineMoved Event, AfterGuideLineRemoved Event will fire after the GuideLine has been added to the respective dbiScheduleObject.GuideLines collection.
Link | Enables the user to link 2 Timebars together.
Select | Enables the user to select a Timebar.
Split | Enable the user to split one Timebar into two Timebars, one retaining the original properties, while the second Timebar is a newly created Timebar.
Unlink | Enabled the user to unlink 2 Timebars.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumEditMode

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumGuideImagePosition Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumGuideImagePosition Enumeration

Specifies the ZOrder of the Guide Image in relation to the ruler text.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumGuideImagePosition
C#
public enum enumGuideImagePosition : System.Enum

Members

Member | Description
Back | Behind ruler text.
Front | In front of ruler text.

Example

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumGuideImagePosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumGuideLinePosition Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumGuideLinePosition Enumeration

Specifies the ZOrder of the GuideLine in relation to the TimeBars in the Schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumGuideLinePosition
C#
public enum enumGuideLinePosition : System.Enum

Members

Member | Description
Back | GuideLine appears behind the TimeBars
Front | GuideLine appears in front of the TimeBars

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumGuideLinePosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumImageIntoView Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumImageIntoView Enumeration

Specifies which image on a timebar will be kept in view..

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumImageIntoView
C#
public enum enumImageIntoView : System.Enum

Members

Member | Description
Both | Both images
End | Only the End image.
None | Neither of the images.
Start | Only the Start image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumImageIntoView

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumImageType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumImageType Enumeration

Specifies what type of image to create with the CreateImage method.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumImageType
C#
public enum enumImageType : System.Enum

Members

Member | Description
Bmp | The image will be of type Bmp.
Gif | The image will be of type Gif.
Jpeg | The image will be of type Jpeg.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumImageType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumLineArrowDirection Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumLineArrowDirection Enumeration

Specifies which direction on the schedule, the LineArrow is pointing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowDirection
C#
public enum enumLineArrowDirection : System.Enum

Members

Member | Description
After | After the visible area
Before | Before the visible area
Null | Neither direction

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumLineArrowDirection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumLineArrowDisplay Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumLineArrowDisplay Enumeration

Specifies if a TimeBar must exist inside the Schedule's start and end values or not, when determining to show the LineArrows.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowDisplay
C#
public enum enumLineArrowDisplay : System.Enum

Members

Member | Description
All | Any TimeBars that exist outside the current visible area.
Inside | Must exist inside the bounds of the ScheduleObject.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumLineArrowDisplay

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumLineArrowPosition Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumLineArrowPosition Enumeration

Specifies how the LineArrow is shown inside the Schedule, in relation to the other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumLineArrowPosition
C#
public enum enumLineArrowPosition : System.Enum

Members

Member | Description
Back | LineArrows will appear behind other objects.
Front | LineArrows will appear in front of other objects.
None | No LineArrows will be displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumLineArrowPosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumListScrollViewType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumListScrollViewType Enumeration

Specifies the display behavior of the scroll bar in the list area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumListScrollViewType
C#
public enum enumListScrollViewType : System.Enum

Members

Member | Description
Block | The scroll bar is replaced with a blank space (allows user drawn functionality).
None | Nothing is displayed.
Regular | The scroll bar is displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumListScrollViewType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumNotesPosition Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumNotesPosition Enumeration

Specifies how the Notes are shown inside the Schedule, in relation to the other objects.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumNotesPosition
C#
public enum enumNotesPosition : System.Enum

Members

Member | Description
Back | Notes are displayed behind other objects.
Front | Notes are displayed in front of other objects.
None | No notes are displayed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumNotesPosition

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumPrintListFormat Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumPrintListFormat Enumeration

Determines how the list items are printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPrintListFormat
C#
public enum enumPrintListFormat : System.Enum

Members

Member | Description
All | All the schedule items will be printed.
Current | Only the visible schedule items will be printed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumPrintListFormat

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumPrintReportType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumPrintReportType Enumeration

Specifies how dbiSchedule will be printed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumPrintReportType
C#
public enum enumPrintReportType : System.Enum

Members

Member | Description
Current | Only the visible portion of the schedule will be printed
Full | The entire schedule will be printed.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumPrintReportType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumScheduleItem Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumScheduleItem Enumeration

Specifies where the current point is in the dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumScheduleItem
C#
public enum enumScheduleItem : System.Enum

Members

Member | Description
List | The point is over the list area.
MapArea | The point is over the map area of the schedule providing the MapVisible Property is set to true.
None | The point is not in the dbiSchedule.
Ruler | The point is over the ruler.
Schedule | The point is over the schedule area.
SplitterBar | The point is over the splitter bar between the list and schedule areas.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumScheduleItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumScrollBarType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumScrollBarType Enumeration

Specifies the type of scroll bar

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumScrollBarType
C#
public enum enumScrollBarType : System.Enum

Members

Member | Description
Horizontal | horizontal scroll bar
Vertical | vertical scroll bar

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumScrollBarType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumSetViewReturnCodes Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumSetViewReturnCodes Enumeration

Specifies the available return codes of the SetView Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSetViewReturnCodes
C#
public enum enumSetViewReturnCodes : System.Enum

Members

Member | Description
EndAfterSchedule | The supplied end DateTime value is after the end of the schedule period.
MinSizeTooLarge | The supplied minimum size is too large to fit the desired timespan in the visible area.
OK | The method was successful.
StartBeforeSchedule | The supplied start DateTime value is before the start of the schedule period.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumSetViewReturnCodes

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumSnapToDivisions Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumSnapToDivisions Enumeration

Specifies how the mouse will snap to the divisions in the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumSnapToDivisions
C#
public enum enumSnapToDivisions : System.Enum

Members

Member | Description
Absolute | Always snap to a division.
Nearing | Snap when within DivisionDistance of a division.
None | Do not snap to the divisions.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumSnapToDivisions

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumTimeType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumTimeType Enumeration

Specifies the type of unit to display in the rules.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumTimeType
C#
public enum enumTimeType : System.Enum

Members

Member | Description
Days | Sets the ruler to display days of the month.
Hours | Sets the ruler to display hours.
Months | Sets the ruler to primarily group by months and subgroup by dbiScheduleObject.enumMonthFormat (weeks or dates).
Weeks | Sets the ruler to display weeks of the month (as defined by dbiScheduleObject.enumWeekFormat).
Years | Sets the ruler to primarily group by years and subgroup by dbiScheduleObject.enumYearFormat (weeks, months or quarters).

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumTimeType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumTipsType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumTipsType Enumeration

Specifies the type of tool tip to display.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumTipsType
C#
public enum enumTipsType : System.Enum

Members

Member | Description
Move | Tool tip is displayed when the Timebar is moving.
Note | Tool tip is displayed when mousing over a dbiScheduleNote
Over | Tool tip is displayed when the mouse moves over a Timebar.
Scroll | Tool tip is displayed when the thumb of the vertical scroll is in a down state.
Size | Tool tip is displayed when a Timebar is being sized.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumTipsType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

enumXMLExportType Enumeration
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : enumXMLExportType Enumeration

Specifies how the XML export will perform.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As enumXMLExportType
C#
public enum enumXMLExportType : System.Enum

Members

Member | Description
All | Export the properties and data.
Data | Export only the data.
Properties | Export only the property settings.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Dbi.WinControl.Schedule.enumXMLExportType

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterGuideLineInsertedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterGuideLineInsertedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterGuideLineInserted Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterGuideLineInsertedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterGuideLineInsertedHandler(
   System.object sender,
   AfterGuideLineInsertedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterGuideLineInsertedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterGuideLineMovedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterGuideLineMovedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterGuideLineMoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterGuideLineMovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterGuideLineMovedHandler(
   System.object sender,
   AfterGuideLineMovedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterGuideLineMovedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterGuideLineRemovedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterGuideLineRemovedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterGuideLineRemoved Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterGuideLineRemovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterGuideLineRemovedHandler(
   System.object sender,
   AfterGuideLineRemovedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterGuideLineRemovedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarDropHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarDropHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarDrop event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarDropHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarDropHandler(
   System.object sender,
   AfterTimeBarDropEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarDropHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarInsertedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarInsertedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarInserted event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarInsertedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarInsertedHandler(
   System.object sender,
   AfterTimeBarInsertedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarInsertedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarLinkedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarLinkedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarLinked event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarLinkedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarLinkedHandler(
   System.object sender,
   AfterTimeBarLinkedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarLinkedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarMovedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarMovedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarMoved event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarMovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarMovedHandler(
   System.object sender,
   AfterTimeBarMovedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarMovedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarRemovedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarRemovedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarRemoved event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarRemovedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarRemovedHandler(
   System.object sender,
   AfterTimeBarRemovedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarRemovedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarSelectHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimeBarSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarSelectHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarSelectHandler(
   System.object sender,
   AfterTimeBarSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarSelectHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarSizedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarSizedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarSized event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarSizedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarSizedHandler(
   System.object sender,
   AfterTimeBarSizedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarSizedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarSplitHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarSplitHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarSplit event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarSplitHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarSplitHandler(
   System.object sender,
   AfterTimeBarSplitEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarSplitHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarUnlinkedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarUnlinkedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimebarUnlinked event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarUnlinkedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarUnlinkedHandler(
   System.object sender,
   AfterTimeBarUnlinkedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarUnlinkedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAfterTimeBarUnSelectHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAfterTimeBarUnSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AfterTimeBarUnSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAfterTimeBarUnSelectHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAfterTimeBarUnSelectHandler(
   System.object sender,
   AfterTimeBarUnSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAfterTimeBarUnSelectHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAlarmTimeBarEndHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAlarmTimeBarEndHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AlarmTimebarEnd event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAlarmTimeBarEndHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAlarmTimeBarEndHandler(
   System.object sender,
   AlarmTimeBarEndEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAlarmTimeBarEndHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventAlarmTimeBarStartHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventAlarmTimeBarStartHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the AlarmTimebarStart event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventAlarmTimeBarStartHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventAlarmTimeBarStartHandler(
   System.object sender,
   AlarmTimeBarStartEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventAlarmTimeBarStartHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeGuideLineInsertHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeGuideLineInsertHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeGuideLineInsert Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeGuideLineInsertHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeGuideLineInsertHandler(
   System.object sender,
   BeforeGuideLineInsertEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeGuideLineInsertHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeGuideLineMoveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeGuideLineMoveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeGuideLineMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeGuideLineMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeGuideLineMoveHandler(
   System.object sender,
   BeforeGuideLineMoveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeGuideLineMoveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeGuideLineRemoveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeGuideLineRemoveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeGuideLineRemove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeGuideLineRemoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeGuideLineRemoveHandler(
   System.object sender,
   BeforeGuideLineRemoveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeGuideLineRemoveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforePrintPageNumberHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforePrintPageNumberHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforePrintPageNumber Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforePrintPageNumberHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforePrintPageNumberHandler(
   System.object sender,
   BeforePrintPageNumberEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforePrintPageNumberHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarDropHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarDropHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarDrop event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarDropHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarDropHandler(
   System.object sender,
   BeforeTimeBarDropEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarDropHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarInsertHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarInsertHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarInsert event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarInsertHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarInsertHandler(
   System.object sender,
   BeforeTimeBarInsertEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarInsertHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarLinkHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarLinkHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarLink event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarLinkHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarLinkHandler(
   System.object sender,
   BeforeTimeBarLinkEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarLinkHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarMoveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarMoveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarMove event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarMoveHandler(
   System.object sender,
   BeforeTimeBarMoveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarMoveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarRemoveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarRemoveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarRemove event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarRemoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarRemoveHandler(
   System.object sender,
   BeforeTimeBarRemoveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarRemoveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarSelectHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarSelect event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarSelectHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarSelectHandler(
   System.object sender,
   BeforeTimeBarSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarSelectHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarSizeHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarSizeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarSize event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarSizeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarSizeHandler(
   System.object sender,
   BeforeTimeBarSizeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarSizeHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarSplitHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarSplitHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimeBarSplit event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarSplitHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarSplitHandler(
   System.object sender,
   BeforeTimeBarSplitEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarSplitHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarUnlinkHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarUnlinkHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimebarUnlink event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarUnlinkHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarUnlinkHandler(
   System.object sender,
   BeforeTimeBarUnlinkEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarUnlinkHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeTimeBarUnSelectHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeTimeBarUnSelectHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeTimeBarUnSelect Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeTimeBarUnSelectHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeTimeBarUnSelectHandler(
   System.object sender,
   BeforeTimeBarUnSelectEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeTimeBarUnSelectHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventBeforeToolTipsHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventBeforeToolTipsHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the BeforeToolTips event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventBeforeToolTipsHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventBeforeToolTipsHandler(
   System.object sender,
   BeforeToolTipsEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventBeforeToolTipsHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventControlErrorHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventControlErrorHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ControError event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventControlErrorHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventControlErrorHandler(
   System.object sender,
   ControlErrorEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventControlErrorHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventDeadZoneDropHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventDeadZoneDropHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the DeadZoneDrop Event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventDeadZoneDropHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventDeadZoneDropHandler(
   System.object sender,
   DeadZoneDropEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventDeadZoneDropHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventEditModeChangedHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventEditModeChangedHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the EditModeChanged Event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventEditModeChangedHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventEditModeChangedHandler(
   System.object sender,
   EditModeChangedEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventEditModeChangedHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventFirstDrawHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventFirstDrawHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the FirstDraw event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventFirstDrawHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventFirstDrawHandler(
   System.object sender,
   FirstDrawEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventFirstDrawHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventGuideLineClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventGuideLineClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the GuideLineClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventGuideLineClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventGuideLineClickHandler(
   System.object sender,
   GuideLineClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventGuideLineClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventGuideLineInDeadZoneHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventGuideLineInDeadZoneHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the GuideLineInDeadZone Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventGuideLineInDeadZoneHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventGuideLineInDeadZoneHandler(
   System.object sender,
   GuideLineInDeadZoneEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventGuideLineInDeadZoneHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventGuideLineMoveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventGuideLineMoveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the GuideLineMove Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventGuideLineMoveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventGuideLineMoveHandler(
   System.object sender,
   GuideLineMoveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventGuideLineMoveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventHistoryChangeHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventHistoryChangeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the HistoryChange event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventHistoryChangeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventHistoryChangeHandler(
   System.object sender,
   HistoryChangeEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventHistoryChangeHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventItemMouseOverHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventItemMouseOverHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ItemMouseOver event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventItemMouseOverHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventItemMouseOverHandler(
   System.object sender,
   ItemMouseOverEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventItemMouseOverHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventLineArrowClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventLineArrowClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the LineArrowClick Event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventLineArrowClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventLineArrowClickHandler(
   System.object sender,
   LineArrowClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventLineArrowClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventLineArrowDoubleClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventLineArrowDoubleClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the LineArrowDoubleClick Event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventLineArrowDoubleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventLineArrowDoubleClickHandler(
   System.object sender,
   LineArrowDoubleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventLineArrowDoubleClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventLineArrowMouseOverHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventLineArrowMouseOverHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the LineArrowMouseOver Event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventLineArrowMouseOverHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventLineArrowMouseOverHandler(
   System.object sender,
   LineArrowMouseOverEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventLineArrowMouseOverHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventListClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventListClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ListClick event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventListClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventListClickHandler(
   System.object sender,
   ListClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventListClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventListDoubleClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventListDoubleClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ListDoubleClick event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventListDoubleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventListDoubleClickHandler(
   System.object sender,
   ListDoubleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventListDoubleClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventListDropHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventListDropHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ListDrop event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventListDropHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventListDropHandler(
   System.object sender,
   ListDropEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventListDropHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventMouseWheelCheckHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventMouseWheelCheckHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the MouseWheelCheck Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventMouseWheelCheckHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventMouseWheelCheckHandler(
   System.object sender,
   MouseWheelCheckEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventMouseWheelCheckHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventNoteClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventNoteClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the NoteClick Event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventNoteClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventNoteClickHandler(
   System.object sender,
   NoteClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventNoteClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventNoteDoubleClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventNoteDoubleClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the NoteDoubleClick Event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventNoteDoubleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventNoteDoubleClickHandler(
   System.object sender,
   NoteDoubleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventNoteDoubleClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventRedoActionHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventRedoActionHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the RedoAction event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventRedoActionHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventRedoActionHandler(
   System.object sender,
   RedoActionEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventRedoActionHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventRulerDragHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventRulerDragHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the RulerDrag Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventRulerDragHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventRulerDragHandler(
   System.object sender,
   RulerDragEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventRulerDragHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventScheduleClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventScheduleClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ScheduleClick Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventScheduleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventScheduleClickHandler(
   System.object sender,
   ScheduleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventScheduleClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler Delegate
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ScheduleScrollBarsOffsetArea Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler(
   System.object sender,
   ScheduleScrollBarsOffsetAreaEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventScheduleScrollBarsOffsetAreaHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventScrollBufferResizeHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventScrollBufferResizeHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ScrollBufferResize event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventScrollBufferResizeHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventScrollBufferResizeHandler(
   System.object sender,
   ScrollBufferResizeArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventScrollBufferResizeHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventScrollTrackHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventScrollTrackHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ScrollTrack event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventScrollTrackHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventScrollTrackHandler(
   System.object sender,
   ScrollTrackEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventScrollTrackHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimebarClick event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarClickHandler(
   System.object sender,
   TimeBarClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarDateTextHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarDateTextHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimeBarDateText Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarDateTextHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarDateTextHandler(
   System.object sender,
   TimeBarDateTextEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarDateTextHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarDoubleClickHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarDoubleClickHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimebarDoubleClick event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarDoubleClickHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarDoubleClickHandler(
   System.object sender,
   TimeBarDoubleClickEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarDoubleClickHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarMouseEnterHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarMouseEnterHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimeBarMouseEnter event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarMouseEnterHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarMouseEnterHandler(
   System.object sender,
   TimeBarMouseEnterEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarMouseEnterHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarMouseLeaveHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarMouseLeaveHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimeBarMouseLeave event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarMouseLeaveHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarMouseLeaveHandler(
   System.object sender,
   TimeBarMouseLeaveEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarMouseLeaveHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarMovingHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarMovingHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimeBarMoving Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarMovingHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarMovingHandler(
   System.object sender,
   TimeBarMovingEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarMovingHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventTimeBarSizingHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventTimeBarSizingHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the TimebarSizing event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventTimeBarSizingHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventTimeBarSizingHandler(
   System.object sender,
   TimeBarSizingEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventTimeBarSizingHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUndoActionHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUndoActionHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UndoAction event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUndoActionHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUndoActionHandler(
   System.object sender,
   UndoActionEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUndoActionHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnBarAfterHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnBarAfterHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnBarAfter Event.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnBarAfterHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnBarAfterHandler(
   System.object sender,
   UserDrawnBarAfterEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnBarAfterHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnBarHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnBarHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnBar event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnBarHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnBarHandler(
   System.object sender,
   UserDrawnBarEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnBarHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnCustomAreaHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnCustomAreaHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnCustomArea Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnCustomAreaHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnCustomAreaHandler(
   System.object sender,
   UserDrawnCustomAreaEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnCustomAreaHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnFooterHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnFooterHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnFooter event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnFooterHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnFooterHandler(
   System.object sender,
   UserDrawnFooterEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnFooterHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnHeaderHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnHeaderHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnHeader event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnHeaderHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnHeaderHandler(
   System.object sender,
   UserDrawnHeaderEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnHeaderHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnLineHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnLineHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnLine event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnLineHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnLineHandler(
   System.object sender,
   UserDrawnLineEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnLineHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnLinkLineHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnLinkLineHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnLinkLine Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnLinkLineHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnLinkLineHandler(
   System.object sender,
   UserDrawnLinkLineEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnLinkLineHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnListScrollAreaHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnListScrollAreaHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnListScrollArea Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnListScrollAreaHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnListScrollAreaHandler(
   System.object sender,
   UserDrawnListScrollAreaEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnListScrollAreaHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnRulerHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnRulerHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnRuler Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnRulerHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnRulerHandler(
   System.object sender,
   UserDrawnRulerEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnRulerHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnRulerSegmentHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnRulerSegmentHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnRulerSegment Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnRulerSegmentHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnRulerSegmentHandler(
   System.object sender,
   UserDrawnRulerSegmentEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnRulerSegmentHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnRulerTitleHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnRulerTitleHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnRulerTitle Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnRulerTitleHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnRulerTitleHandler(
   System.object sender,
   UserDrawnRulerTitleEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnRulerTitleHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnTimeBarsHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnTimeBarsHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnTimeBars Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnTimeBarsHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnTimeBarsHandler(
   System.object sender,
   UserDrawnTimeBarsEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnTimeBarsHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventUserDrawnWaterMarkHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventUserDrawnWaterMarkHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the UserDrawnWaterMark Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventUserDrawnWaterMarkHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventUserDrawnWaterMarkHandler(
   System.object sender,
   UserDrawnWaterMarkEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventUserDrawnWaterMarkHandler Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

dbiSchedule.EventValuePointHandler Delegate
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule.EventValuePointHandler Delegate

sender
The object that raised the event.
e
The arguments related to the event call.
Represents the method that handles the ValuePoint event in dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New dbiSchedule.EventValuePointHandler(AddressOf HandlerMethod)
C#
public delegate void dbiSchedule.EventValuePointHandler(
   System.object sender,
   ValuePointEventArgs e
)

Parameters

sender
The object that raised the event.
e
The arguments related to the event call.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule.EventValuePointHandler Members
Dbi.WinControl.Schedule Namespace


%%ItemTitle%%

Developing with DBISchedule - Resizing a List Item's Height

Glossary Item Box

The height of each list item is determined by the height of the Font property and the ItemHeightOffset property of the control. NOTE: The height of a dbiScheduleItem can be discretely changed by assigning a new value to its HeightOffset property.

Example:

Change the height of the third item by 20 pixels.

[VB.NET]

Me.DbiSchedule1.Items(2).HeightOffset = 20

[C#]

this.DbiSchedule1.Items[2].HeightOffset = 20;

The height of each line item can also be adjusted via user interaction with the mouse (now available in Standard and Enterprise editions). If the LockLineHeight property of the dbiSchedule control is set to a value of False, the user can click and drag the bottom of each line item vertically to increase or decrease the item's height.

NOTE: The programmer can prevent individual line items from being sized with the mouse by setting the LockHeight property of the dbiScheduleItem object to a value of True. It should be noted that The LockHeight and LockLineHeight properties prevent the height of a line item from being sized with the mouse, they do not prevent the height being changed through code.


%%ItemTitle%%

Developing with DBISchedule - Sorting Schedule Items

Glossary Item Box

The items in the dbiSchedule control can be sorted based on the values in any column or combination of columns in the list area of the control. Sorting the items can be accomplished via two different methods. The first way to sort the schedule items is to set the Sortable property of a column header to true. When the user clicks on any column header whose Sortable property has been set to true, the items are sorted using that column's values as the sort criteria. The second way to sort the schedule items is to use the Sort method in the dbiSchedule control. NOTE: When a column is used in the sort criteria, the sort will be based on the values in the column with respect to their data type as defined by the column, i.e. text is sorted by alpha, numbers are sorted numerically, and dates are sorted in date order.

Example:

Sort the schedule items in the control in descending order based on the values in the third column of the list area in the control

[VB.NET]

Me.dbiSchedule1.SortDirection = Dbi.WinControl.enumSortDirection.Descend

Me.dbiSchedule1.SortColumn = 3

Me.dbiSchedule.Sort()

[C#]

this.dbiSchedule1.SortDirection = Dbi.WinControl.enumSortDirection.Descend;

this.dbiSchedule1.SortColumn = 3;

this.dbiSchedule.Sort();

Sorting on Multiple Columns

It is possible to sort the schedule items on the values from multiple columns in the list area. To sort schedule items based on the values in multiple columns the developer can specify the sorting criteria as an array of integers (representing the order of the column values in the sort) in the Sort method of the dbiSchedule control ...

[VB.NET]

dbiSchedule1.Sort(New Integer() {1, 3}) 'Sort the schedule items on the values in the first and third columns

[C#]

int[] intColumns = {1,3};

this.DbiSchedule1.Sort(intColumns); //Sort the schedule items on the values in the first and third columns

or by setting the e.Columns property to an array of integers (representing the order of the column values in the sort) in the BeforeColumnSort event that is fired when the user clicks on a header in the list area.

Example:

Set the dbiSchedule control to sort the schedule items based on the values in the first and third columns in the list when the user clicks on the first column's header.

[VB.NET]

Private Sub DbiSchedule1_BeforeColumnSort(ByVal sender As Object, ByVal e As dbi.WinControl.BeforeColumnSortEventArgs) Handles DbiSchedule1.BeforeColumnSort

If (e.Columns(0) = 1) Then 'If the user has clicked on the first column's header

e.Columns = New Integer() {1, 3} 'Set the sort order to sort on the values in the first and third columns

End If

End Sub

[C#]

private void DbiSchedule1_BeforeColumnSort(object sender, dbi.WinControl.BeforeColumnSortEventArgs e)

{

if (e.Columns[0] == 1) //If the user has clicked on the first column's header

{

int[] intColumns = {1,3};

e.Columns = intColumns; //Set the sort order to sort on the values in the first and third columns

}

}


%%ItemTitle%%

Developing with DBISchedule - Using the Schedule Items List Area

Glossary Item Box

The left side of the dbiSchedule control is reserved for the list object in the control. The list object in dbiSchedule is derived from the dbiListControl object found in the base Dbi4.dll. NOTE: The list object in the dbiSchedule control acts as both a list and a tree control.

Defining and Creating Schedule Items in the List

The list area accepts items of the dbiScheduleItem type. The dbiScheduleItem class is a child class of the dbiNodeItem class found in the Dbi4.dll. The dbiScheduleItem class contains enhancements to support the additional requirement of time bar data and custom area definitions. All schedule items are stored in the Items or Nodes collection in the dbiSchedule control. Since the list area can act like a list or a tree, the Items and Nodes properties are synonymous. It is recommended to use dbiScheduleItems when working in the dbiSchedule control to avoid any ambiguity with respect to naming conventions. NOTE: The dbiSchedule control contains a NodeToScheduleItem method that converts a dbiNodeItem into an dbiScheduleItem.

Schedule items can be added to the dbiSchedule control's Items collection using the collection's editor at design time (through the property inspector) or at runtime through code. To add a schedule item to the control through code create an instance of a dbiScheduleItem object, set its properties and add it the control's Items collection.

Example:

Add a schedule item to the dbiSchedule control's Items collection.

[VB.NET]

Dim DbiScheduleItem1 As Dbi.WinControl.Schedule.dbiScheduleItem

DbiScheduleItem1 = New Dbi.WinControl.Schedule.dbiScheduleItem

DbiScheduleItem1.Text = "My Schedule Item"

Me.DbiSchedule1.Items.Add(DbiScheduleItem1)

[C#]

Dbi.WinControl.Schedule.dbiScheduleItem DbiScheduleItem1;

DbiScheduleItem1 = new Dbi.WinControl.Schedule.dbiScheduleItem ();

DbiScheduleItem1.Text = "My Schedule Item";

this.DbiSchedule1.Items.Add(DbiScheduleItem1);

Adding Child Items to Items in the List Area

Each schedule item in the dbiSchedule control's Items collection has its own Items collection. A child item is added to the list area in the same manner as a parent item with the exception that the child item is added to the parent item's Items collection instead of adding it to the dbiSchedule control's Items collection.

Example:

Create a parent schedule item with two child schedule items in the list area.

[VB.NET]

Dim objParent As Dbi.WinControl.Schedule.dbiScheduleItem

Dim objChild1 As Dbi.WinControl.Schedule.dbiScheduleItem

Dim objChild2 As Dbi.WinControl.Schedule.dbiScheduleItem

'Create the Parent Schedule Item

objParent = New Dbi.WinControl.Schedule.dbiScheduleItem

objParent.Text = "Parent Schedule Item"

'Create the first Child Schedule Item

objChild1 = New Dbi.WinControl.Schedule.dbiScheduleItem

objChild1.Text = "Child Schedule Item - 1"

'Add the child to the parent

objParent.Items.Add(objChild1)

'Create the Second Child Schedule Item

objChild2 = New Dbi.WinControl.Schedule.dbiScheduleItem

objChild2.Text = "Child Schedule Item - 2"

'Add the child to the parent

objParent.Items.Add(objChild1)

'Add the parent Schedule Item to the control. NOTE: Adding the parent adds the parent item and all of its children items to the control.

Me.DbiSchedule1.Items.Add(objParent)

[C#]

Dbi.WinControl.Schedule.dbiScheduleItem objParent;

Dbi.WinControl.Schedule.dbiScheduleItem objChild1;

Dbi.WinControl.Schedule.dbiScheduleItem objChild2;

//Create the Parent Schedule Item

objParent = new Dbi.WinControl.Schedule.dbiScheduleItem();

objParent.Text = "Parent Schedule Item";

//Create the first Child Schedule Item

objChild1 = new Dbi.WinControl.Schedule.dbiScheduleItem();

objChild1.Text = "Child Schedule Item - 1";

//Add the child to the parent

objParent.Items.Add(objChild1);

//Create the Second Child Schedule Item

objChild2 = new Dbi.WinControl.Schedule.dbiScheduleItem();

objChild2.Text = "Child Schedule Item - 2";

// Add the child to the parent

objParent.Items.Add(objChild1);

//Add the parent Schedule Item to the control. NOTE: Adding the parent adds the parent item and all of its children items to the control.

this.DbiSchedule1.Items.Add(objParent);

Defining and Creating Columns

The list area of the dbiSchedule control can be defined with one or many columns, each column derived from the dbiColumnItem class located in the dbi.dll. Columns are stored in the dbiSchedule control's Columns collection. Columns can be added to the list area through the Columns Collection editor (available from the property inspector) at design time, or through code at runtime.

Example:

Add a column to the list area through code and make it capable of sorting on a header click action.

[VB.NET]

Dim objColumn As dbi.WinControl.dbiColumnItem

objColumn = New dbi.WinControl.dbiColumnItem("Room", 150) 'Create a column object with a header equal to "Room", 150 pixels wide

objColumn.Sortable = True 'Make the column sortable

DbiSchedule1.Columns.Add(objColumn) 'Add the new column to the dbiSchedule control's Columns collection

[C#]

dbi.WinControl.dbiColumnItem objColumn;

objColumn = new dbi.WinControl.dbiColumnItem("Room", 150); //Create a column object with a header equal to "Room", 150 pixels wide

objColumn.Sortable = true //Make the column sortable

this.DbiSchedule1.Columns.Add(objColumn); //Add the new column to the dbiSchedule control's Columns collection

Defining the Schedule Item Text and Data for Each Column

To create a schedule item the developer must define the text/data for each column depending upon the column's data type. Typically, the schedule item is described as a string with each column's value separated by a break character as defined in the dbiSchedule control's BreakChar property (defaults to a semi-colon).

Example:

Define a schedule item with three columns; 1-text, 2-Numeric, 3-text.

[VB.NET]

DbiScheduleItem = New Dbi.WinControl.Schedule.dbiScheduleItem

'NOTE: Text values are not encased in quotes.

DbiScheduleItem.Text = "My Text;1;More Text"

[C#]

DbiScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem

//NOTE: Text values are not encased in quotes.

DbiScheduleItem.Text = "My Text;1;More Text";

In addition to creating the schedule item as one string the developer also has the choice of using the SetCellText method of the dbiScheduleItem object to set the value for a column in a schedule item discretely.

Example:

Set the first column's value to My Text in a Schedule Item

[VB.NET]

objParent.SetCellText(1, "My Text") 'Where objParent refers to an instance of a schedule item

[C#]

objParent.SetCellText(1, "My Text"); //Where objParent refers to an instance of a schedule item

NOTE: The dbiSchedule control also has a GetCellText method to retrieve the value of a schedule item in a specified column.

NOTE: The GetCellText and SetCellText properties have been set up as indexers within the class. This means that the text can be accessed directly using an index value.

Example:

Set the values for two columns in a schedule item using the indexer properties.

[VB.NET]

objScheduleItem = New Dbi.WinControl.Schedule.dbiScheduleItem

objScheduleItem(0) = "John Stewart" 'Set the first column's value

objScheduleItem(1) = "11/30/2003 17:23" 'Set the second column's value

dbiSchedule1.Items.Add(objScheduleItem) 'Add the item to the dbiSchedule Items collection

[C#]

objScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem ();

objScheduleItem[0] = "John Stewart"; //Set the first column's value

objScheduleItem[1] = "11/30/2003 17:23"; //Set the second column's value

dbiSchedule1.Items.Add(objScheduleItem); //Add the item to the dbiSchedule Items collection

Column Header Data vs. Column Format Data

The dbiColumnItem class contains many properties to define how a column header will be displayed. The dbiColumnItem class also contains a Format property that contains many properties similar to those in the main class but are used to define the appearance of the items in the list under the header.

IMPORTANT NOTE: The properties in the dbiColumnItem class define the appearance of the column header. The properties contained in the Format property in the dbiColumnItem class define the appearance of the items in the list under that column.

Example:

Paint the background of the first column header white and the background of all the items in that column blue.

[VB.NET]

Me.DbiSchedule1.Columns(0).BackColor = Color.White

Me.DbiSchedule1.Columns(0).Format.BackColor = Color.Blue

[C#]

this.DbiSchedule1.Columns[0].BackColor = System.Drawing.Color.White;

this.DbiSchedule1.Columns[0].Format.BackColor = System.Drawing.Color.Blue;

Column Data Types

The list area in the dbiSchedule control supports 4 different data types:

  • DateTime

  • Boolean

  • Image

  • Text (default)

NOTE: When a column is sorted, the value for that column is converted to the appropriate data type, and then sorted based on that type. The data type determines how a column's text is displayed in the column.

DateTime Data Type: When passed to the dbiSchedule control the data will be converted to a DateTime value. The column will display the value with formatting based on the DateFormat property of the control. If the text cannot be converted to a proper DateTime type, an error will be generated.

Example:

Set the value of a DateTime column in code using SetCellText and the dbiScheduleItem indexer.

[VB.NET] 'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "2005/10/04 10:00:00")

objScheduleItem(1) = "2005/09/01"

[C#] //NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "2005/10/04 10:00:00");

objScheduleItem[1] = "2005/09/01";

Boolean Data Type: When passed to the dbiSchedule control it is required that the value be a single character that can be converted to a Boolean value. If the text cannot be converted to a Boolean type, an error will be generated. Columns defined as "Boolean" can be set up to display as check items in the column instead of text.

Example:

Set the value of a Boolean column in code using SetCellText and the dbiScheduleItem indexer.

[VB.NET] 'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "1") 'Set the value of the second column to true.

objScheduleItem(1) = "0" 'Set the value of the second column to false

[C#] //NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "1"); //Set the value of the second column to true.

objScheduleItem[1] = "0"; //Set the value of the second column to false

Image Data Type: When passed to the dbiSchedule control it is required that the value be numeric. The value will be translated to an index value representing an image in the image list attached to the dbiSchedule control. If the text cannot be converted to a proper integer, an error will be generated.

Example:

Display the 9th image in the dbiSchedule control's image list in the second column of the item.

[VB.NET] 'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "8") 'Set the second column in the item to display the 9th image in the image list

objScheduleItem(1) = "4" 'Set the second column in the item to display the 5th image in the image list

[C#] //NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.SetCellText(1, "8"); //Set the second column in the item to display the 9th image in the image list

objScheduleItem[1] = "4"; //Set the second column in the item to display the 5th image in the image list

The CellFormat Class

The dbiCellFormat class is used to change the appearance and actions of a particular cell in a schedule item in the list. Properties that can be changed using a cell format include background and foreground colors, alignment, fill types, fonts, and images. The dbiCellFormat class item is assigned directly to the CellFormat collection of the dbiScheduleItem class.

Example:

Modify the cell format of the second column in a schedule item.

[VB.NET]

objFormat = New dbi.WinControl.dbiCellFormat

objFormat.BackColor = Color.Red 'Set the cell's back color to red

objFormat.Column = 1 'Set the format to modify the second column in the schedule item

'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.CellFormat.Add(objFormat) 'Add the format to the schedule item's CellFormat collection

[C#]

objFormat = New dbi.WinControl.dbiCellFormat

objFormat.BackColor = Color.Red 'Set the cell's back color to red

objFormat.Column = 1 'Set the format to modify the second column in the schedule item

'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.CellFormat.Add(objFormat) 'Add the format to the schedule item's CellFormat collection

Header Items

Header items are a special kind of schedule item that ignore the column definitions. A schedule item is defined as a header by setting the Header property of the dbiScheduleItem class to a value of True. Header items are capable of accepting a dbiCellFormat object, however the format must be assigned to the first column in the schedule item in order for it to be effective.

Example:

Set a Schedule item to be a Header.

[VB.NET] 'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.Header = True

[C#] //NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.Header = true;

Adding Images to the Cells

To assign an image to a cell in a schedule item, it is required that the image be stored in an image list control as identified in the dbiSchedule control's ImageList property.

There are two ways to assign an image to a cell in a schedule item.

1. The developer can declare a column type to be of type "Image". The text assigned to that column must be the integer value that represents the index of the image in the image list.

Example:

Set the first column of a schedule item to display the fourth image in the image list attached to the dbiSchedule control.

The code below assumes the first column has been defined as an Image column by the column header and that objScheduleItem is a member of the dbiSchedule control's Items collection.

[VB.NET]

objScheduleItem.Text = "3" 'or

objScheduleItem(0) = "3"

[C#]

objScheduleItem.Text = "3"; //or

objScheduleItem(0) = "3";

2. Assigning an image to a cell using the dbiCellFormat class. This has the added benefit of allowing the developer to combine text and an image into the cell.

Example:

Add an image to a cell using the dbiCellFormat class.

[VB.NET]

objFormat = New dbi.WinControl.dbiCellFormat

objFormat.ImageIndex = 3 'Assign the fourth image in the image list to the cell format

objFormat.ImageAlign = dbi.WinControl.enumAlignment.MiddleLeft 'Align the image to the middle left of the cell

objFormat.Column = 4 'Format the fifth column in the schedule item

'NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.CellFormat.Add(objFormat) 'Add the format object to the schedule item's CellFormat collection

[C#]

objFormat = new dbi.WinControl.dbiCellFormat();

objFormat.ImageIndex = 3; //Assign the fourth image in the image list to the cell format

objFormat.ImageAlign = dbi.WinControl.enumAlignment.MiddleLeft; //Align the image to the middle left of the cell

objFormat.Column = 4; //Format the fifth column in the schedule item

//NOTE: objScheduleItem is a member of the dbiSchedule control's Items collection.

objScheduleItem.CellFormat.Add(objFormat); //Add the format object to the schedule item's CellFormat collection

Displaying Body Text

The dbiSchedule control's list area supports the storage and optional display of an additional string of text to each schedule item. This additional text is defined in the Body property of the dbiScheduleItem object. The example below demonstrates what a list item with visible Body text looks like.

The blue text in each list item is defined by the Body property of that item.

The Body text is independent of any column formatting that may have been defined. NOTE: The body property will wrap its text within its given area based on the current width of the control.

In order for any body text to be displayed, a schedule item's BodyVisible property must be set to a value of true.

Example:

Create the first schedule item in the list above.

[VB.NET]

        Dim task2Add As New Dbi.WinControl.Schedule.dbiScheduleItem

        Dim dueByDate As New DateTime(2019, 06, 05)

        Dim criticalTask As Boolean = True

        task2Add.Text = "Task 1.1" + ";" + "2 days" + ";" + dueByDate.ToShortDateString + ";" + criticalTask.ToString

        task2Add.Body = "Task 1.1 Notes: Place the notes for the task in the body of the scheduleItemNode object and turn the BodyVisible property on or off."

        'Create a format object for the paperclip image in the list items

        Dim objformat As New Dbi.WinControl.dbiCellFormat

        objformat.ImageAlign = Dbi.WinControl.enumAlignment.MiddleCenter

        objformat.ImageIndex = 6

        'Assign the format to the 5th column in the list

        objformat.Column = 4

        task2Add.CellFormat.Add(objformat)

        'Make the body text visible

        task2Add.BodyVisible = True

        task2Add.HeightOffset = 40

        'Add the scheduleitem to the list

        Me.DbiSchedule1.Items.Add(task2Add)

 [C#]

        Dbi.WinControl.Schedule.dbiScheduleItem task2Add = new Dbi.WinControl.Schedule.dbiScheduleItem();

        DateTime dueByDate = new DateTime(2019, 06, 05);

        bool criticalTask = true;

        task2Add.Text = "Task 1.1" + ";" + "2 days" + ";" + dueByDate.ToShortDateString() + ";" + criticalTask.ToString();

        task2Add.Body = "Task 1.1 Notes: Place the notes for the task in the body of the scheduleItemNode object and turn the BodyVisible property on or off.";

        //Create a format object for the paperclip image in the list items

        Dbi.WinControl.dbiCellFormat objformat = new Dbi.WinControl.dbiCellFormat();

        objformat.ImageAlign = Dbi.WinControl.enumAlignment.MiddleCenter;

        objformat.ImageIndex = 6;

        //Assign the format to the 5th column in the list

        objformat.Column = 4;

        task2Add.CellFormat.Add(objformat);

        //Make the body text visible

        task2Add.BodyVisible = true;

        task2Add.HeightOffset = 40;

        //Add the scheduleitem to the list

        this.DbiSchedule1.Items.Add(task2Add);


%%ItemTitle%%

Developing with DBISchedule - Schedules

Glossary Item Box

The first step in presenting a schedule in the dbiSchedule control to create a schedule object and add it to the dbiSchedule control's Schedules collection. NOTE: A schedule must be created and displayed before any time bars can rendered or created. A schedule is an instance of the dbiScheduleObject class and is stored in the Schedules collection of the dbiSchedule control. In the standard version of the dbiSchedule control only one schedule can be viewed at any time. Other schedule objects can be made active using the ActiveSchedule property. In the enterprise version of the dbiSchedule control, all schedules in the Schedules collection are visible, placed side by side beginning with the first schedule in the collection.

A schedule object encapsulates two areas; the top section or ruler that displays the time line for the schedule, and the scheduling area that presents the interactive surface in which time bars are created, modified, and deleted.

Defining the Time Period for a Schedule

The dbiSchdeule control is capable of scheduling time bars in increments of minutes to months, based on the TimeType property of the dbiSchedule object. The duration of time presented by a dbiScheduleObject is defined by its Start and End DateTime values. The width of the schedule is determined by the TimeType property and the TimeDistance property relative to the start and end of the schedule.

For example: If a schedule starts on a Monday at 8:00 am and goes until the following Friday at 8:00 pm the start of the dbiScheduleObject would be set to Monday's date at 8:00 am and the end of the schedule would be set to Friday's date at 8:00 pm. If the TimeType of the Schedule was set to hours and TimeDistance set to 6, each hour in the day would require 6 pixels. The total width of the Schedule would be 6 * the number of hours between 8:00 am Monday and 8:00 pm Friday. NOTE: The larger the value for the TimeDistance the wider the schedule becomes as a whole.

The Ruler

The ruler defines the time line for the dbiSchedule object. The ruler is displayed in the top right hand area of the control.

By default, the ruler is split horizontally in two. The top half of the ruler displays the date of the time line in the visible area at the bottom of the ruler. NOTE: As the schedule is horizontally scrolled, the date shown in the top of the ruler reflects the day as at the point where the time line touches the splitter bar (the bar that separates the list area from the schedule area). The format of the date displayed in the top half of the ruler is defined by the DateFormat property of the dbiScheduleObject class.

Using the SplitRuler property of the dbiScheduleObject class, the developer can optionally remove the top half of the ruler (SplitRuler = False).

In addition to the split ruler option, the developer may also replace the text in the top half of the ruler with a custom text string using the RulerTitle property of the dbiScheduleObject class.

The time values placed in the bottom half of the ruler are determined by the TimeType property of the dbiScheduleObject class. Valid time types are Hours, Days, Weeks, Months, or Years. The distance between each major time value is determined by the TimeDistance property of the main control. (See Setting up Different Views for additional details).

Customizing the Time Values

Just before each time value is drawn, the ValuePoint event will be fired. In the ValuePoint event the e event arguments passed includes a Text property that can be used by the developer to change the default text for the time segment being drawn. For instance, if the dbiSchedule object was set up with a TimeType of Years with a Year format of Quarters, the text describing each time segment would simply be a number between 1 and 4.

We could then test for this number inside the ValuePoint event and change the text for ruler from the quarter number to the appropriate season.

For Example:

[VB.NET]

Private Sub DbiSchedule1_ValuePoint(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.ValuePointEventArgs) Handles DbiSchedule1.ValuePoint

If Me.DbiSchedule1.Schedules(0).TimeType = Dbi.WinControl.Schedule.enumTimeType.Years Then

If Me.DbiSchedule1.Schedules(0).YearFormat = Dbi.WinControl.Schedule.dbiScheduleObject.enumYearFormat.Quarters Then

Select Case e.Value

Case 1

e.Text = "Winter"

Case 2

e.Text = "Spring"

Case 3

e.Text = "Summer"

Case 4

e.Text = "Fall"

End Select

End If

End If

End Sub

[C#]

private void DbiSchedule1_ValuePoint(object sender, Dbi.WinControl.Schedule.ValuePointEventArgs e)

{

if (this.DbiSchedule1.Schedules[0].TimeType == Dbi.WinControl.Schedule.enumTimeType.Years)

{

if (this.DbiSchedule1.Schedules[0].YearFormat == Dbi.WinControl.Schedule.dbiScheduleObject.enumYearFormat.Quarters)

{

switch (e.Value)

{

case 1:

e.Text = "Winter";

break;

case 2:

e.Text = "Spring";

break;

case 3:

e.Text = "Summer";

break;

case 4:

e.Text = "Fall";

break;

}

}

}

}


%%ItemTitle%%

Developing with DBISchedule - Coloring the Background of the Schedule

Glossary Item Box

The primary color used to paint the schedule portion of the dbiSchedule control is defined by the BackColor property of the dbiScheduleObject class. In addition to the BackColor property, the developer can add colors and images to the schedule object using the Custom Areas, Weekend Colors, Current Time Line, Time Lines, Header Item Colors, Background Image, and Alternate Item Color properties of the schedule control itself or the dbiScheduleObjects contained in its Schedules collection.

BACKCOLOR

The BackColor property defines the default back color for all items and all days in a dbiScheduleObject.

NOTE: There may be more than one Schedule object in the control's Schedules collection. The BackColor property is specific to each schedule object in the collection.

Example:

The following will set the back color of the first schedule object to blue and the second schedule object to green.

[VB.NET]

Me.dbiSchedule1.Schedules(0).BackColor = System.Drawing.Color.Blue

Me.dbiSchedule1.Schedules(1).BackColor = System.Drawing.Color.Green

[C#]

this.dbiSchedule.Schedules[0].BackColor = System.Drawing.Color.Blue;

this.dbiSchedule.Schedules[0].BackColor = System.Drawing.Color.Green;

RULER SELECT COLOR

The RulerSelectColor property defines the background color used to highlight the current start/end, of the selected TimeBar, in the ruler.

Example:

The following will set the RulerSelectColor to blue.

[VB.NET]

Me.dbiSchedule1.RulerSelectColor = System.Drawing.Color.Blue

[C#]

this.dbiSchedule.RulerSelectColor = System.Drawing.Color.Blue;

Custom Areas

The developer can add specific areas of color to the schedule by creating an instance of a custom area object, assigning its color (and optionally a color to and fill type for gradient fills) and assigning the custom area to either the schedule as a whole (inferring all items), or to an individual line item. Custom Areas allow the developer to create columns or lines of colors anywhere on the schedule area in the control. These colors are primary, and will override any colors assigned to the schedule, such as back color. If the starting date and time for a custom area is the same as the ending date and time, the custom area will become a colored line.

NOTE: The schedule control has a CustomAreas collection, and each item in the list has a CustomAreas collection. To create a custom area that affects all items, use the control's CustomAreas collection. To assign a custom area to an individual item, use the item's CustomAreas collection.

Example:

The following will add a custom area with gradient fill (Diamond from red to white) to all items or to the fourth item in the list.

[VB.NET]

Dim objArea As New Dbi.PIM.dbiCustomArea

objArea.Start = <Start DateTime>

objArea.End = <End DateTime>

objArea.BackColor = System.Drawing.Color.Red

objArea.BackColorTo = System.Drawing.Color.White

objArea.FillType = dbi.enumFillType.Diamond

'Add the custom area to all items

Me.dbiSchedule1.CustomAreas.Add(objArea)

'Add the custom area to the fourth item

Me.dbiSchedule1.Items(3).CustomAreas.Add(objArea)

[C#]

Dbi.PIM.dbiCustomArea objArea;

objArea = new Dbi.PIM.dbiCustomArea()

objArea.Start = <Start DateTime>;

objArea.End = <End DateTime>;

objArea.BackColor = System.Drawing.Color.Red;

objArea.BackColorTo = System.Drawing.Color.White;

objArea.FillType = dbi.enumFillType.Diamond;

//Add the custom area to all items

this.dbiSchedule1.CustomAreas.Add(objArea)

//Add the custom area to the fourth item

this.dbiSchedule1.Items[3].CustomAreas.Add(objArea);

Weekend Colors

Weekend colors are simple color blocks for all items assigned to the days defined as weekends within a dbiScheduleObject in the control. Weekend colors are defined through the WeekendColor property of each dbiScheduleObject in the Schedules collection in the control.

Example:

Assign the color blue to each weekend day in the first schedule object in the control.

Me.dbiSchedule1.Schedules(0).WeekendColor = System.Drawing.Color.Blue

[C#]

this.dbiSchedule1.Schedules[0].WeekendColor = System.Draiwng.Color.Blue;

Current Time Line

A line representing the current date and time can be displayed by setting the CurrentTimeLine property of the main control to True. The developer can also specify a primary color and optional ColorTo value to provide a softer effect on the time line.

Example:

Display a current time line with a black leading edge and a yellow aura.

[VB.NET]

Me.dbiSchedule1.CurrentTimeLine = True

Me.dbiSchedule1.CurrentTimeColor = System.Drawing.Color.Black

Me.dbiSchedule1.CurrentTimeColorTo = System.Drawing.Color.Yellow

[C#]

this.dbiSchedule1.CurrentTimeLine = true;

this.dbiSchedule1.CurrentTimeColor = System.Drawing.Color.Black;

this.dbiSchedule1.CurrentTimeColorTo = System.Drawing.Color.Yellow;

Time Lines

Time lines are lines that extend for the height of the schedule area and are drawn along each major time segment of the schedule ruler. NOTE: Time lines are specific to each dbiScheduleObject contained in the control's Schedules collection. Time Lines can be displayed by setting the DisplayTimeLines property of the dbiScheduleObject class to True. The frequency of the lines is dependent upon the TimeType setting for the dbiScheduleObject; Hours would show a time line on every hour, Days would display a time line on every day, etc. The developer can also set the line style using the TimeLineWidth property, and time line color using the TimeLineColor property.

Example:

[VB.NET]

Me.dbiSchedule1.Schedules(0).DisplayTimeLines = True

Me.dbiSchedule1.Schedules(0).TimeLineWidth = Dbi.WinControl.Schedule.dbiScheduleObject.enumTimeLineWidth.Thick

Me.dbiSchedule1.Schedules(0).TimeLineColor = System.Drawing.Color.Red

[C#]

this.dbiSchedule1.Schedules[0].DisplayTimeLines = true ;

this.dbiSchedule1.Schedules[0].TimeLineWidth = Dbi.WinControl.Schedule.dbiScheduleObject.enumTimeLineWidth.Thick;

this.dbiSchedule1.Schedules[0].TimeLineColor = System.Drawing.Color.Red;

Header Colors

The background color of all line items defined as headers can be set to a unique color. This is achieved by providing a color value to the HeaderColor property of the dbiScheduleObject class. NOTE: This only affects the back color of header objects in the specified dbiScheduleObject. If the control is rendering more than one schedule object simultaneously (Enterprise version only) then the header back color would have to be specified for each dbiScheduleObject being displayed.

Example:

the following will set the back color of all header items in the first Schedule object Light Steel Blue.

[VB.NET]

Me.dbiSchedule1.Schedules(0).HeaderColor = System.Drawing.Color.LightSteelBlue

[C#]

this.dbiSchedule1.Schedules(0).HeaderColor = System.Drawing.Color.LightSteelBlue;

Alternate Item Colors

The AlternateColor property of the dbiScheduleObject class specifies the back color of each alternating item in the schedule. The AltColorEven property specifies the back color of all even numbered item groups (2,4,6, etc.) and the AltColorOdd specifies the back color of all odd numbered item groups (1,3,5, etc.). NOTE: The item groups are specified using the dbiScheduleObject AlternateItems property which determines the number of items grouped together in an even/odd pattern. For example setting the AlternateItems property to 3 would cause the control to alternate back colors every three items.

Example:

The following will alternate the back color of all items in the first schedule object between Light Cyan and Alice Blue.

[VB.NET]

Me.dbiSchedule1.Schedules(0).AltColorEven = System.Drawing.Color.LightCyan

Me.dbiSchedule1.Schedules(0).AltColorOdd = System.Drawing.Color.AliceBlue

[C#]

this.dbiSchedule1.Schedules[0].AltColorEven = System.Drawing.Color.LightCyan;

this.dbiSchedule1.Schedules[0].AltColorOdd = System.Drawing.Color.AliceBlue;

Background Image

Each Schedule object in the control's Schedules collection can display an image in the background of the schedule using the BackgroundImage property of the dbiScheduleObject class. A single image can be aligned anywhere in the schedule object, or it can be tiled by setting the ImageEffect property of the schedule to Tile.

Example:

The following will set the background image of the first schedule object to the image contained in a picture box in the form and center the image in the schedule object area.

[VB.NET]

Me.dbiSchedule1.Schedules(0).BackgroundImage = PictureBox1.Image

Me.dbiSchedule1.Schedules(0).ImageEffect = Dbi.WinControl.Schedule.dbiScheduleObject.enumImageEffect.Align

Me.dbiSchedule1.Schedules(0).ImageAlignment = ContentAlignment.MiddleCenter

[C#]

this.dbiSchedule1.Schedules[0].BackgroundImage = PictureBox1.Image;

this.dbiSchedule1.Schedules[0].ImageEffect = Dbi.WinControl.Schedule.dbiScheduleObject.enumImageEffect.Align;

this.dbiSchedule1.Schedules[0].ImageAlignment = ContentAlignment.MiddleCenter;


%%ItemTitle%%

Developing with DBISchedule - Miscellaneous Features

Glossary Item Box

Determining if a Time Bar Drop is Valid

When time bars are created or moved through code (not through user interaction with the control), the concept of "Dead Zones" is not considered by the control, i.e. time bars can be created and moved into Dead Zones through code. The dbiSchedule control's InDeadZone method can be used to assist the developer in determining if a time bar addition or move will interact with a Dead Zones before initiating the action.

Determining What Schedule Item a Time Bar Belongs To

The NodeFromTimeBar method of the dbiSchedule control can be used to determine the schedule item to which a time bar belongs. The method returns the schedule item object of a given time bar. NOTE: If no schedule item is found, the method returns a null value.

Example:

Find the schedule item to which a specified time bar belongs.

[VB.NET]

            Dim objItem As Dbi.WinControl.Schedule.dbiScheduleItem

            Dim objBar As Dbi.WinControl.Schedule.dbiTimeBarItem

            objBar = GetTimeBar() 'Some custom sub routine that returns a time bar object

            objItem = DbiSchedule1.NodeFromTimeBar(objBar)) 'Pass the time bar object into the NodeFromTimeBar method

            If (Not (objItem Is Nothing)) Then

                'If the schedule item returned is not null

                ' We found our item

            End If

[C#]

            Dbi.WinControl.Schedule.dbiScheduleItem objItem;

            Dbi.WinControl.Schedule.dbiTimeBarItem  objBar;

            objBar = GetTimeBar(); //Some custom sub routine that returns a time bar object

            objItem = DbiSchedule1.NodeFromTimeBar(objBar); //Pass the time bar object into the NodeFromTimeBar method

            if (objItem == null)

            {

                //No schedule item was found

            }

            else

            {

                //If the schedule item returned is not null

                //We found our item

            }

Time Bar Order

Time bars are painted based upon their order in the collection. Therefore, the first time bar in the collection is painted first; the second is painted second, and so on. To change the order in which time bars are painted, i.e. which time bar is painted on top of another time bar, use the dbiSchedule control's BarToBack and BarToFront methods.

Date Formatting and Internationalization

The date and time formatting in the control defaults to the regional on the computer on which the control is being run. To discretely change a date or time format use the appropriate date or time format property in the control or the control's objects (such as the ScheduleObject's DateFormat and TimeFormat properties). NOTE: These properties accept a string that is based upon the DateTimeFormatInfo class from the .NET Framework Class Library. Please refer the MSDN documentation for a complete reference as to how to create a format string using the DateTimeFormatInfo class.


%%ItemTitle%%

Developing with DBISchedule - An Overview of the Time Bar Object

Glossary Item Box

A time bar represents a period of time within a schedule item in the dbiSchedule control. A time bar is represented in the control by the dbiTimeBarItem class which is sub-classed from the dbiAppointmentItem class. Time bars are stored in the TimeBars collection found in the dbiScheduleItem class.

Text and Sub-Text

A time bar has two visible text strings; the TimeBar.Text property and the TimeBar.Body (sub-text) property. The main text displayed in a time bar is provided by the Text property of the dbiTimeBarItem class. This text can be aligned within the bar, or it can be aligned outside of the bar to the right or left. The time bar text font can be changed through the object's Font property and the text of all time bars in the control can be set to wrap within a bar using the dbiSchedule control's TimeBarWordWrap property. The sub-text of a time bar is provided by the Body property of the dbiTimeBarItem class. A new font can be assigned to the Body text through the Font2 or SubTextFont property of the dbiTimeBarItem class. NOTE: The Body text will always wrap, and it is always left aligned. NOTE: Body text will only be displayed if the DisplayBody property of the Schedule object in the Schedules collection has been set to True.

Example:

Set the first schedule object to display the body text in all time bars.

[VB.NET]

Me.dbiSchedule1.Schedules(0).DisplayBody = True

[C#]

this.dbiSchedule1.Schedules[0].DisplayBody = true;

A time bar set up with the text (left aligned) displaying sub text.

Bar Images

Images can be assigned to the front and back of a time bar by setting the StartImage and EndImage properties of the dbiTimeBarItem object respectively, or by assigning a time bar style with images to the time bar (See section on Creating Time Bar Styles for additional details.)

A time bar using the same image for the start and end from the collection of custom icons built into the control

Additional Features

Set the DisplayTimeBarDates property of the dbiScheduleObject class to True to display the starting and ending days of a time bar at its start and end.

A time bar with a gradient fill, and with starting and ending dates present in the bar.

To insure a time bar's text is always visible for time bars not fully visible at the front of the control set the dbiSchedule control's TextIntoView property to True. When a time bar is scrolled or moved to the front of the schedule area, the text will moved to the right of the bar to display as much of the text as possible in the portion of the time bar visible in the control.


%%ItemTitle%%

Developing with DBISchedule - Time Bar Alarms

Glossary Item Box

The dbiSchedule control includes the ability to optionally set alarms to fire at the beginning and end of a time bar. Alarms are initialized by setting the AlarmStart and/or AlarmEnd properties of the dbiTimeBarItem class to a value of True. When the AlarmStart property and/or the AlarmEnd property are set to true, the AlarmTimeBarStart and AlarmTimeBarEnd events will fire at the appropriate start or end time of the time bar.

NOTE: The AlarmTimeBarStart and AlarmTimeBarEnd events pass the time bar object that generated the event as a property on the "e" event arguments. The developer can use the time bar object to assess its properties and optionally relate the event back to the database for further detail when responding to the event.

After an alarm is fired, the AlarmStart and/or AlarmEnd properties will be set to False.

NOTE: The dbiSchedule control's frequency for monitoring alarms is determined by the TimerInterval property.


%%ItemTitle%%

Developing with DBISchedule - Creating Time Bars

Glossary Item Box

All time bars within the dbiSchedule control are based upon the dbiTimeBarItem class. These time bars (or appointments) are then stored in the TimeBars collection of the appropriate dbiScheduleItem object (the resource being scheduled). Before adding time bars to a schedule the item to which the time bar belongs must first be created. Time bars can be added programmatically through code or interactively with the control (using the mouse - left clicking and dragging horizontally, or via drag and drop.

Example:

Add a time bar to the first item in the list.

[VB.NET]

Dim dbiBar As Dbi.WinControl.Schedule.dbiTimeBarItem

Dim dtStart As System.DateTime

Dim dtEnd As System.DateTime

dtStart = New DateTime(2004, 8, 15, 0, 37, 0)

dtEnd = New DateTime(2004, 8, 15, 1, 25, 0)

dbiBar = New Dbi.WinControl.Schedule.dbiTimeBarItem(dtStart, dtEnd, "My App") 'Create a new time bar with the text My App

Me.dbiSchedule1.Items(0).TimeBars.Add(dbiBar) 'Add the new time bar to the first item in the list

[C#]

Dbi.WinControl.Schedule.dbiTimeBarItem dbiBar;

System.DateTime dtStart;

System.DateTime dtEnd;

dtStart = new System.DateTime(2004, 8, 15, 0, 37, 0);

dtEnd = new System.DateTime(2004, 8, 15, 1, 25, 0);

dbiBar = new Dbi.WinControl.Schedule.dbiTimeBarItem(dtStart, dtEnd, "My App"); //Create a new time bar with the text My App

this.dbiSchedule1.Items[0].TimeBars.Add(dbiBar); //Add the new time bar to the first item in the list

Entering an Appointment Interactively

A time bar can be entered directly into a schedule through mouse interaction. To create a time bar by clicking and dragging, the EditMode property of the dbiSchedule control must be set to Edit (cursor is presented as a pencil). The user can then left-click on one of the items in the schedule area and holding the button down drag the mouse horizontally to create a time bar. When the button is released the time bar is created.

For more information on Edit mode please see section on Editing Data within the Schedules.


%%ItemTitle%%

Developing with DBISchedule - Creating TimeBar Styles

Glossary Item Box

By default, a time bar is 10 pixels less in height than the height of its host list item (5 pixels from the top and 5 from the bottom) and is vertically centered within the host item. The time bar's color is determined by the TimeBarBackColor property of the main control, and it initially contains no text and no images on either side of the bar. Time Bar styles define a class of time bars different to the default, for example different heights, distances from the center of the vertical offset, text, and images on both sides of the bar. This allows the programmer to create a collection of different bar styles that can be assigned discretely to any time bar or group of time bars. A time bar style is defined in the dbiTimeBarStyle class and stored in the TimeBarStyles collection of the dbiSchedule control.

Example:

Create a time bar style and assign it to a time bar in the time bars collection.

[VB.NET]

Dim dbiTimeBarStyle As Dbi.WinControl.Schedule.dbiTimeBarStyle

dbiTimeBarStyle = New Dbi.WinControl.Schedule.dbiTimeBarStyle

dbiTimeBarStyle.StartImage = -5 'Black Down Triangle

dbiTimeBarStyle.EndImage = -5 'Black Down Triangle

dbiTimeBarStyle.BarHeight = 8 '8 pixels high

dbiTimeBarStyle.VerticalOffset = -5 'Draw the time bar 5 pixels below the middle of the item

dbiTimeBarStyle.BackColor = System.Drawing.Color.Black 'Set the back color of the time bar to black

Me.dbiSchedule1.TimeBarStyles.Add(dbiTimeBarStyle) 'Add the style to the TimeBarStyles collection

Dim DbiTimeBar As New Dbi.WinControl.Schedule.dbiTimeBarItem 'Create a new time bar

DbiTimeBar.Start = dtDate.AddDays(3)

DbiTimeBar.End = dtDate.AddDays(6)

DbiTimeBar.Style = 0 'Set the new time bar to use the style created above

Me.dbiSchedule1.Items(1).TimeBars.Add(DbiTimeBar) 'Add the time bar to the schedule

[C#]

Dbi.WinControl.Schedule.dbiTimeBarStyle dbiTimeBarStyle;

dbiTimeBarStyle = new Dbi.WinControl.Schedule.dbiTimeBarStyle()

dbiTimeBarStyle.StartImage = -5; //Black Down Triangle

dbiTimeBarStyle.EndImage = -5; //Black Down Triangle

dbiTimeBarStyle.BarHeight = 8; //8 pixels high

dbiTimeBarStyle.VerticalOffset = -5; //Draw the time bar 5 pixels below the middle of the item

dbiTimeBarStyle.BackColor = System.Drawing.Color.Black; //Set the back color of the time bar to black

this.dbiSchedule1.TimeBarStyles.Add(dbiTimeBarStyle); //Add the style to the TimeBarStyles collection

Dbi.WinControl.Schedule.dbiTimeBarItem DbiTimeBar; //Create a new time bar

DbiTimeBar = new Dbi.WinControl.Schedule.dbiTimeBarItem();

DbiTimeBar.Start = dtDate.AddDays(3);

DbiTimeBar.End = dtDate.AddDays(6);

DbiTimeBar.Style = 0; //Set the new time bar to use the style created above

this.dbiSchedule1.Items[1].TimeBars.Add(DbiTimeBar); //Add the time bar to the schedule

Time Bar Style Images

It is also possible to add images to each end of a time bar. To add an image to a time bar style use the StartImage and EndImage properties of the dbiTimeBarStyle class.

Example:

Create a time bar style using custom images stored in the dbiSchedule control's image list

[VB.NET]

Dim dbiTimeBarStyle As New Dbi.WinControl.Schedule.dbiTimeBarStyle 'Create a new time bar style

dbiTimeBarStyle.StartImage = 1 'Set its start image of the style to the first image in the ImageList attached to the dbiSchedule control

dbiTimeBarStyle.EndImage = 2 'Set the end image of the style to the second image in the ImageList attached to the dbiSchedule control

[C#]

Dbi.WinControl.Schedule.dbiTimeBarStyle dbiTimeBarStyle;

dbiTimeBarStyle = new Dbi.WinControl.Schedule.dbiTimeBarStyle(); 'Create a new time bar style

dbiTimeBarStyle.StartImage = 1; //Set its start image of the style to the first image in the ImageList attached to the dbiSchedule control

dbiTimeBarStyle.EndImage = 2; //Set the end image of the style to the second image in the ImageList attached to the dbiSchedule control

NOTE: The images used in the above code are referenced through the ImageList property of the dbiSchedule control.

The dbiSchedule control contains 15 stock icons. The stock icons can be displayed by assigning the negative numbers 2 - 16 to the StartImage and EndImage properties of the dbiTimeBarStyle class.

Example:

Create a time bar style using stock images stored in the dbiSchedule control

[VB.NET]

Dim dbiTimeBarStyle As New Dbi.WinControl.Schedule.dbiTimeBarStyle 'Create a new time bar style

dbiTimeBarStyle.StartImage = -11 'Black Up Triangle

dbiTimeBarStyle.EndImage = -2 'Blue Down Triangle

[C#]

Dbi.WinControl.Schedule.dbiTimeBarStyle dbiTimeBarStyle;

dbiTimeBarStyle = new Dbi.WinControl.Schedule.dbiTimeBarStyle(); 'Create a new time bar style

dbiTimeBarStyle.StartImage = -11; //Black Up Triangle

dbiTimeBarStyle.EndImage = -2; //Blue Down Triangle

The first five stock icons are triangles pointing down. The next five are triangles pointing up and the final five stock icons are diamonds. The stock icons come in the following colors ... blue, aqua, red, black, and white. The image below illustrates the different images. NOTE: A negative number is required to use a stock image.

The EndImageOffset, EndImageOrder, StartImageOffset, and StartImageOrder properties of the dbiTimeBarStyle class are all used to help position an image on the end of a bar. The programmer may be required to experiment with these properties to achieve a particular style.

Colors and Priorities

Any color values defined in a time bar style will take priority over any other colors assigned to a time bar. Color values from a time bar style will be ignored if the colors are defined as Empty. The same can be said about other properties in the dbiTimeBarStyle class. The order in which the control uses the properties to describe a time bar are as follows:

dbiTimeBarStyle -> dbiTimeBarItem -> dbiSchedule

Milestones

A milestone is a special type of bar style. A bar style is defined as a milestone by assigning a True value to the Milestone property of the dbiTimeBarStyle class. Milestones represent a certain place in time, therefore the starting and ending dates and times for a milestone are identical.

NOTE: Time bars marked as milestones cannot be re-sized. They can only be moved.

NOTE: A milestone bar style indicates that the bar itself will be very thin (with respect to width). It will be too thin to place text or color into it.

By default, milestone bars will have any text assigned to it displayed to the right of the bar. It will be the responsibility of the programmer to prevent the text from then being displayed within the bar. Additionally, in order to make a time bar more visible, it is good practice to assign an image to one side of the bar. (See above for information on images).

Assigning a Default Style to a Bar

A time bar style can be automatically assigned to new time bars created using mouse input into the control by setting the DefaultStyle property of the dbiSchedule control. The DefaultStyle property is used to determine what bar style is assigned to any new time bar by default. If the DefaultStyle is set to a value greater than the current number of defined bar styles a value of 0 is assigned to that property. The time bar style of any time bar can be programmatically set at any time using the Style property of the dbiTimeBarItem object.

NOTE: If a time bar style is deleted, the appearance of any time bar with an index value greater than or equal to that of the deleted style may change. It is the programmer's responsibility to adjust the time bar styles of all time bars with a time bar style greater than or equa l to the index value of the time bar style removed.


%%ItemTitle%%

Developing with DBISchedule - Time Bar Common Dialog Window

Glossary Item Box

The dbiPim component assembly (dbiPIM2.dll) contains a time bar dialog to manage the details of a time bar. The dbiSchedule control will automatically display this dialog when a time bar in that control is double clicked. NOTE: To have the dbiSchedule control automatically invoke the Time Bar Dialog when a time bar receives a double-click action, the TimeBarDialog property must be set to true.

The Time Bar Dialog can be used to edit the text, body, start and end date/times, start and end alarm states, and colors/fill patterns for the time bar.

In the case where a custom dialog is required, the developer should:

  1. Set the TimeBarDialog property to false. This will suppress the default dialog from appearing when a time bar receives a double click action.

  2. Create a custom dialog. NOTE: The custom dialog should return a standard DialogResult value.

In the TimeBarDoubleClick event of the control, the developer can create and call up an instance of the custom time bar dialog created in step 2 above.


%%ItemTitle%%

Developing with DBISchedule - Moving Time Bars Vertically

Glossary Item Box

The AllowVertMoves property of the dbiSchedule control defaults to false, preventing users from dragging time bars between items in the schedule. To enable vertical moving of time bars, set the AllowVertMoves property to true.

NOTE: The dbiSchedule control events BeforeTimeBarMove and AfterTimeBarMoved that fire in response to time bar moves pass in the ScheduleItemFrom schedule item object and ScheduleItemTo schedule item object to assist the developer in assessing the move request. The events also pass in a Vertical parameter that describes if the time bar move is between items.


%%ItemTitle%%

Developing with DBISchedule - Displaying and Determining Time Bar Conflicts

Glossary Item Box

By default there are no visual cues that two or more time bars overlap in a given area of a schedule item.

Time bars overlapping without any visual cue.

In the case where time bars overlap the developer may want to provide a visual cue to the user by displaying the overlap. The dbiSchedule control supports the display of overlapping time bars through the DisplayOverlap, OverlapColor, OverlapSpan, and OverlapWidth properties of the dbiScheduleObject class. If the DisplayOverlap property is set to a value of true, any time bars from the same list item will have their horizontal lines drawn differently at the location where the overlap occurs.

In the example above, the horizontal lines where the bars overlap become thicker.

The OverlapSpan property of the dbiScheduleObject class defines the tolerance for when two time bars are considered to be in conflict. By default, the Overlap span property is set to zero, meaning that two time bars must physically be in contact before they are considered to be in conflict. NOTE: When one time bar starts at the same time as another time bar ends they are NOT considered to be in conflict. Setting the OverlapSpan property to a timespan value greater than 0 would cause the previous case to generate a conflict and consequently draw an overlap if the DisplayOverlap property was set to true.

Example:

Set the first schedule object in the dbiSchedule control to display time bar conflicts when time bars are within 5 minutes of each other.

[VB.NET]

Dim timespanOverlap As New TimeSpan

timespanOverlap = TimeSpan.FromMinutes(5)  'Set the TimeSpanOverlap value to five minutes

Me.DbiSchedule1.Schedules(0).OverlapSpan = timespanOverlap 'Set the OverlapSpan to the timespan above

Me.DbiSchedule1.Schedules(0).DisplayOverlap = True  'Set the schedule to display overlapping time bars

[C#]

System.TimeSpan timespanOverlap;

timespanOverlap = TimeSpan.FromMinutes(5); //Set the TimeSpanOverlap value to five minutes

this.DbiSchedule1.Schedules[0].OverlapSpan = timespanOverlap; //Set the OverlapSpan to the timespan above

this.DbiSchedule1.Schedules[0].DisplayOverlap = true; //Set the schedule to display overlapping time bars

Using the TimeBarConflicts Method

When moving, sizing, or adding time bars to a schedule, the developer may want to prevent conflicts. The TimeBarConflicts method of the dbiSchedule control can be used to obtain a collection of time bars that conflict with a given time bar. The method has the option of limiting the conflict check to a single schedule item, or all schedule items.

Example:

Test for all time bars in the third schedule item that are in conflict with a given time bar (objMyBar).

[VB.NET]

Dim arrBars As Dbi.WinControl.Schedule.TimeBarItemCollection

arrBars = DbiSchedule1.TimeBarConflicts(objMyBar, DbiSchedule1.Items(2))

If (arrBars.Count > 0) Then

' Conflicting time bars found, perform some action

End If

[C#]

Dbi.WinControl.Schedule.TimeBarItemCollection arrBars;

arrBars = new Dbi.WinControl.Schedule.TimeBarItemCollection();

arrBars = this.DbiSchedule1.TimeBarConflicts(objMyBar, this.dbiSchedule1.Items[2])

If (arrBars.Count > 0)

{

// Conflicting time bars found, perform some action

}

A practical implementation of the TimeBarConflicts method would be to determine if a time bar is in conflict with another time bar when it is being moved or sized.

Example:

Test to prevent a time bar conflict in the AfterTimeBarMoved event and the BeforeTimeBarSize event of the dbiSchedule control.

[VB.NET ]

Private Sub DbiSchedule1_AfterTimeBarMoved(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.AfterTimeBarMovedEventArgs) Handles DbiSchedule1.AfterTimeBarMoved
Dim tbcBars As Dbi.WinControl.Schedule.TimeBarItemCollection

tbcBars = Me.DbiSchedule1.TimeBarConflicts(e.TimeBarItem, IIf(e.Vertical, e.ScheduleItemTo, e.ScheduleItemFrom))

'NOTE: The Vertical property on the e argument indicates if the move was vertically between two items.

'NOTE: The e argument always passes the ScheduleItemFrom object and the ScheduleItemTo object in the case of a vertical move

If tbcBars.Count > 0 Then 'Timebar overlaps another time bar

Me.DbiSchedule1.Undo() 'Deny the move action as it would cause a conflict

End If

End Sub

Private Sub DbiSchedule1_BeforeTimeBarSize(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.BeforeTimeBarSizeEventArgs) Handles DbiSchedule1.BeforeTimeBarSize

'We will create a temporary dbiTimeBar, based on the existing one and assign the e.Start and e.End values, of where the TimeBar is sizing to so we can test properly for conflicts.
Dim testTimeBar As New Dbi.WinControl.Schedule.dbiTimeBarItem(e.Start, e.End)

If Me.DbiSchedule1.TimeBarConflicts(testTimeBar, e.ScheduleItem).Count > 1 Then 'Timebar overlaps another time bar
'NOTE: We test for a .Count > 1, because the temporary TimeBar will always be in conflict with the existing TimeBar being sized

e.AllowSize = False 'Deny the resize action as it would cause an overlap

End If

End Sub

[C#]

private void dbiSchedule1_AfterTimeBarMoved(object sender, Dbi.WinControl.Schedule.AfterTimeBarMovedEventArgs e)
{
Dbi.WinControl.Schedule.TimeBarItemCollection tbcBars;

tbcBars = this.dbiSchedule1.TimeBarConflicts(e.TimeBarItem, (e.Vertical ? e.ScheduleItemTo: e.ScheduleItemFrom));

//NOTE: The Vertical property on the e argument indicates if the move was vertically between two items.

//NOTE: The e argument always passes the ScheduleItemFrom object and the ScheduleItemTo object in the case of a vertical move

if (tbcBars.Count > 0) //Timebar overlaps another time bar
{
this.dbiSchedule1.Undo(); //Deny the move action as it would cause a conflict

}
}

private void dbiSchedule1_BeforeTimeBarSize(object sender, Dbi.WinControl.Schedule.BeforeTimeBarSizeEventArgs e)
{

//We will create a temporary dbiTimeBar, based on the existing one and assign the e.Start and e.End values, of where the TimeBar is sizing to so we can test properly for conflicts.
Dbi.WinControl.Schedule.dbiTimeBarItem testTimeBar = new Dbi.WinControl.Schedule.dbiTimeBarItem(e.Start, e.End);

if (this.dbiSchedule1.TimeBarConflicts(testTimeBar, e.ScheduleItem).Count > 1) //Timebar overlaps another time bar
{
//NOTE: We test for a .Count > 1, because the temporary TimeBar will always be in conflict with the existing TimeBar being sized

e.AllowSize = false; //Deny the resize action as it would cause an overlap

}

}


%%ItemTitle%%

Developing with DBISchedule - More Time Bars Functionality

Glossary Item Box

More Time Bars Functionality

The Enterprise version of the dbiSchedule control includes two methods to return a collection of timebars on an item that are outside of the viewable area of a schedule. These methods in addition to the LineArrow UI and the ScrollToDateTime method available in the dbiSchedule control provide a powerful and easy to program means of adding extended navigation functionality inside the scheduling area of the control.

The dbiScheduleE TimbarsBeforeSchedule and TimeBarsAfterSchedule methods return a collection of TimeBars in a given schedule item situated Before or After (respectively) the area of the schedule being viewed. The method requires three parameters ...

1. The ScheduleObject in which to begin looking for more timebars.

2. The ScheduleItem in which to look for more timebars.

3. A flag indicating if the search for more timebars is restricted to the ScheduleObject noted in the first parameter or expanded to all schedule objects in the control.

The TimeBar objects returned from the method can be surfaced in a context menu displayed on the LineArrow or a List object presented outside of the dbiSchedule control to allow the user to quickly view and optionally select a timebar to have the dbiSchedule control scroll into view using the control's ScrollToDateTime method.

For an example of how to implement the TimbarsBeforeSchedule and TimeBarsAfterSchedule methods in conjunction with the LineArrow UI and ScrollToDateTime method please refer to the Schedule Notes sample that can be found via the Solutions::Schedule for .NET Enterprise Product Manager ... Samples/Demos tab.


%%ItemTitle%%

Developing with DBISchedule - Creating an Image of the DBISchedule

Glossary Item Box

The dbiSchedule control is capable of generating an image of itself into a file on a local or mapped drive. This can be very useful when posting a visual representation of the control on a web site or as an attachment to an email.

An image is created using the CreateImage method. This method accepts three parameters. The first is the name of the file to be created. The second and third parameters then determine the size of image. The image size can be set up in three different ways:

Fixed Size

If the second and third parameters are sent a value greater than 5, the height and width of the image will be that of the values sent to those parameters. The first line item in the image will be the current top visible time in the control.

Actual Size

If the second and third parameters are sent a value of 0, the height and width of the image will be set to the current size of the actual control. The first line item in the image will be the current top visible time in the control. Just what is on the screen.

Full Size

The second and third parameters can be used to specify if the generated output is to contain all of the contents of the control or just the visible area of the control. If a value of -1 is sent to the second parameter, the control will generate an image containing the entire height (all items) in the control. If a value of 0 is sent to the second parameter the generated output will display only the visible items in the control. If a value of -1 is sent to the third parameter, the control will generate output containing the entire width of the control. If a value of 0 is sent to the third parameter the generated output will display only the visible width of the control.

NOTE: In either case, the first line in the image will be based on the starting time in the control.

NOTE: A full size image (0,0) may be too large to actually produce. To ensure that the image does not get too large, the developer can set height and width limits using the MaxImageHeight and MaxImageWidth properties respectively. These properties will only take effect if their value is greater than 0 and a value of -1 was sent to the respective CreateImage parameters.

Image Type

The type of image (file format) created is determined by the ImageType property. The options for image type are JPG, GIF, or BMP (bitmap).

Example:

Create a jpg image of the entire contents of the control and store it in a file in the root of the C: drive.

[VB.NET]

Me.dbiSchedule1.ImageType = Dbi.WinControl.Schedule.enumImageType.Jpeg

Me.dbiSchedule1.CreateImage("C:\dbiSchedule.JPG", 0, 0)

[C#]

this.dbiSchedule1.ImageType = Dbi.WinControl.Schedule.enumImageType.Jpeg;

this.dbiSchedule1.CreateImage("C:\\dbiSchedule.JPG", 0, 0);


%%ItemTitle%%

Developing with DBISchedule - Creating A Printed Report

Glossary Item Box

Creating a Printed Report

The dbiSchedule control is capable of producing a printed report using the built-in Print and PrintPreview methods. The contents of the report are based upon the PrintReportType property which can be set to Current to print only those items (and their related time bars) which are currently visible in the control, or Full to print all of the items (and their time bars) in the control as a whole.

Example: Send the entire contents of the control to a printer selected by the user.

[VB.NET]

'Set the control to print all items and all time bars
Me.DbiSchedule1.PrintReportType = Dbi.WinControl.Schedule.enumPrintReportType.Full

'Send the report to the printer
Me.DbiSchedule1.Print()

[C#]

//Set the control to print all items and all time bars
this.DbiSchedule1.PrintReportType = Dbi.WinControl.Schedule.enumPrintReportType.Full;

//Send the report to the printer
this.DbiSchedule1.Print();

It is important to note that the control requires the page settings of the device that will be rendering the output, i.e. the printer or destination print preview printer prior to formatting the output. Accordingly, when the Print() or PrintPreview() methods are called directly, the user will be required to select a printer and optional page settings (Landscape/Portrait etc.) from the standard dialog before the output can be formatted. To override this behavior the developer has the option of providing the page settings to the method directly by specifying a custom printDialog object or a printerSettings object that describes the page settings for the output via one of the 2 overloads available;

DbiSchedule1.Print(printDialog As System.Windows.Forms.PrintDialog)

DbiSchedule1.Print(printSettings As System.Drawing.Printing.PrinterSettings)

DbiSchedule1.PrintPreview(printDialog As System.Windows.Forms.PrintDialog)

DbiSchedule1.PrintPreview(printSettings As System.Drawing.Printing.PrinterSettings)

If the page settings are passed in to the Print or PrintPreview methods via one of its overloads, the user will not be prompted with a printer dialog and the output will be formatted based on the page settings provided through specified parameter.

Example: Send the entire contents of the control to Print Preview using the default printer set to landscape mode.

[VB.NET]

  'Create a new PrinterSettings object

  'NOTE: When a new PrinterSettings object is created it is assigned the default printer and its default settings

  Dim printPreviewSettings As New Printing.PrinterSettings

  printPreviewSettings.DefaultPageSettings.Landscape = True

  Me.DbiSchedule1.PrintPreview(printPreviewSettings)

[C#]

  //Create a new PrinterSettings object

  //NOTE: When a new PrinterSettings object is created it is assigned the default printer and its default settings

  System.Drawing.Printing.PrinterSettings printPreviewSettings = new System.Drawing.Printing.PrinterSettings();

  printPreviewSettings.DefaultPageSettings.Landscape = true;

  this.DbiSchedule1.PrintPreview(printPreviewSettings);

Prior to sending the output to the Print or PrintPreview methods the developer can customize the report using the following properties:

Property | Type | Descirption
PrintBackImage | Boolean | Determines if the background image for the schedule is included in a printed report.
PrintFitToPage | Boolean | Determines if the PrintTimeDistance property will be adjusted by the control so that all time columns appear on a single page
PrintFont | System.Drawing.Font | Determines the font for the title in the printed report.
PrintFooterAlign | ContentAlignment | Determines the alignment for the print footer.
PrintHeaderBackColor | System.Drawing.Color | Determines the color used to paint the background of the header when printing the list area of the control.
PrintHeaderForeColor | System.Drawing.Color | Determines the color used to paint the text in the header when printing the list area of the control.
PrintItemBackColor | System.Drawing.Color | Determines the color used to paint the background of the items when printing the list area of the control.
PrintItemForeColor | System.Drawing.Color | Determines the color used to paint the text in the items when printing the list area of the control.
PrintListAlways | Boolean | When set to True prints the list area on each horizontal page in the printed report. When set to False, prints the list only on the first horizontal page.
PrintListFormat | enumPrintListFormat | Determines the type of list to produce in a printed report.
PrintPageControl | Boolean | A value indicating if the list area of the control should be printed as rendered in the form or using the Print properties set in the control.
PrintPageText | String | Determines text describing the page number in the footer.
PrintReportType | enumPrintReportType | Determines the type of printed report to produce.
PrintSubTitle | String | Determines the sub-title for the printed report.
PrintTimeDistance | Integer | Determines the distance in pixels between the major time segments in a printed report.
PrintTitle | String | Determines the title for the printed report.
PrintTitleAlign | ContentAlignment | Determines the alignment for the print title.
PrintTitleBackColor | System.Drawing.Color | Determines the color used to paint the background of the title when printing the list area of the control.
PrintTitleForeColor | System.Drawing.Color | Determines the color used to paint the text in the title when printing the list area of the control.

Creating Page Breaks

It is important to note that the dbiNodteItem and dbiScheduleItem classes contain a PageBreak property that when set to True forces a page break and causes the item to print on a new page. This can be especially useful when generating reports broken out by parent/child relationships in the list area, i.e. by Department, Project Phase, etc. Creating a Header item with its PageBreak property set to True will insure the printing of that item and its children will begin on a new page.

Example: Cause a page break to occur after the 10th item in the list in the schedule.

[VB.NET]

Me.DbiSchedule1.Items(10).PageBreak = True

[C#]

this.dbiSchedule1.Items[10].PageBreak = true;


%%ItemTitle%%

Developing with DBISchedule - dbiSchedule.NET Databinding

Glossary Item Box

Introduction

The dbiSchedule for .NET control provides a presentation and interaction surface through which the scheduling of resources can be created and maintained. The control encapsulates three basic objects: Schedules (time line over which the resources are being managed), Items (the resources being scheduled), and Time Bars (the periods of time for which the resources are being utilized).

A simple example of a scheduling application would be the management of meeting rooms. In this scenario the Schedules would represent the periods of time for which the meeting room schedules would be published, for example the days of the week or weeks of the month. The Items in the Schedule would represent the rooms being scheduled for meetings, and the Scheduled Time would represent the Meetings being held in the specified meeting room. The database structure to store the data for the application would look something like ...

The dbiSchedule for .NET control maintains 3 collections that reflect the data being stored in the database;

  1. Schedule Objects - describe the start and end dates/times for a period of time over which the schedule for the Items is being maintained/published.

  2. Schedule Items - describe the resource that is being scheduled. These could be people, rooms, positions/tasks, equipment, in essence any item that requires scheduling for its fulfillment or utilization.

  3. Time Bars - Discreet periods of time that signify the resource's utilization.

As you can see from this simple example the Items collection in the control reflects the MeetingRooms table in the database, and the TimeBars collection in the control reflects the Meetings table in the database.

DBISCHEDULE for .NET points of integration for data

There are essentially three points of integration to consider when binding the dbiSchedule for .NET control to a database:

1. Loading the control with data from the database.

2. Responding to changes (edits) in the data in the control.

3. Responding to Add and Delete events to the data in the control.

LOADING THE CONTROL FROM THE DATABASE

To programmatically load data from the database into the control the developer should use the dbiSchedule.FirstDraw event to code the retrieval/setup of the ScheduleObjects, Schedule Items, and TimeBars data from the database.

NOTE: Using the FirstDraw event insures the control is fully formed (colors, fonts, etc. are assigned correctly) before modifying its contents. The FirstDraw event only fires once therefore it provides an ideal event in which to load the control for the first time.

First create an instance of a Schedule object describing the overall start and end date of the timeline to be considered along with any special formatting for the timeline and add the Schedule object to the Schedules collection in the dbiSchedule control, and then activate the schedule object in the control. In our Meeting Rooms scenario, the Schedule object would describe a time line for a day, a week, or a month (start date of first day of month, end date of last day of month). The time line could be set to hourly mode to allow the schedule time to be in hours or sub-increments of hours such as 15 minutes, etc., or the time line can be set to days, weeks, months, or years.

Within the same FirstDraw event the next step is to programmatically add the Schedule Items (dbiScheduleItem objects) to the control's Items collection, and for each Schedule Item its associated time bars (dbiTimeBarItem object) to the dbiScheduleItem's TimeBars collection.

In our Meeting Rooms example this would require reading a Meeting Room from the MeetingRooms table, creating a dbiScheduleItem object with the properties from the MeetingRooms table record and adding that object to the dbiSchedule control's Items collection.

Once the Item (Meeting Room) has been added to the items collection, the TimeBars (Meetings) associated with the Meeting Room are read from the Meetings table and each record related to the selected MeetingRoom record is added to the Item's TimeBars collection.

IMPORTANT NOTE: The dbiScheduleItem object and dbiTimeBarItem object have two non-visual properties that can be used to store the record id to relate the object in the dbiSchedule control to the record in the table from which the object was created. The Data and Cargo properties of the dbiScheduleItem and dbiTimeBaritem objects are designed to assist the developer in persisting the link between the objects and their related database records when using traditional Insert, Update, Delete syntax against a database. When reading information in from a table the developer should assign the record id value to either the data or cargo property in the appropriate object.

A more generic option for persisting the relationship between an object and the record it represents is to store the record in the object's Tag property. Tags are typically of type Object and can therefore be used to store any kind of object, including a DataRow from a DataTable. If the data access for the application implements DataTable objects to represent the physical tables in a database and DataAdapter objects to maintain the connection between the DataTables and their related physical files, then storing the record as a DataRow in the object's Tag property can be a very powerful tool for providing fast read/write/delete access to the record being represented by the object.

IMPORTANT NOTE: When an item is added to the items collection in the control (Meeting Room), the developer should persist the relationship to the record that the item represents. This will allow the developer to identify the item's record in the database table to link new time bar records when adding new time bars to the schedule plan. Similarly, when a new time bar is created the record it represents should be persisted to allow for updates or removal when the time bar is moved or deleted.

When complete, the dbiSchedule for .NET control will display a timeline as specified in the SchedulObject, the Meeting Rooms as items in the list area of the dbiSchedule control, and the Meetings as time bars in the schedule area of the control in their respective meeting room items.

RESPONDING TO TIME BAR CHANGES (EDITS/MOVES) IN THE CONTROL

When a time bar is sized, either made larger or smaller, it represents a change in the period of time the item containing the time bar is committed within the schedule. This change in size needs to be persisted in the database record that the time bar reflects.

When a time bar is moved within an item in the dbiSchedule control (left or right) it represents a change in the schedule commitment for item to which the time bar is attached. When a time bar is moved between items in the dbiSchedule control it represents a change in the schedule commitment for two items, the item that originally contained the time bar and the item that contains the time bar after the move is finished. A move to a time bar needs to be persisted in the database record that the time bar reflects.

The dbiSchedule control has two events that fire in response to a time bar move ... BeforeTimeBarMove, and AfterTimeBarMoved.

The BeforeTimeBarMove event fires after a time bar move has been initiated but before the move is completed. This event is provided to allow the developer to test to see if the move will be allowed. The primary reason for disallowing a move is that it will cause a conflict with other time bars. There may be other reasons to disallow a move (rights to a specific item or other rule detail). Within the BeforeTimeBarMove event the developer has the option of preventing the move causing the time bar to be returned to its original position.

IMPORTANT NOTE: The BeforeTimeBarMove event arguments include the time bar object being moved. This allows the developer to query the object for its persistence scheme (record id, DataRow, etc.), thereby allowing the event to relate to the record represented by the time bar being moved.

The AfterTimeBarMoved event is fired after the move has been completed. This event is provided for the developer to store the change in the data back to the record represented by the time bar being moved.

IMPORTANT NOTE: The AfterTimeBarMoved event arguments include the time bar object being moved. This allows the developer to query the object for its persistence scheme (record id, DataRow, etc.), thereby allowing the event to relate to the record represented by the time bar being moved.

Responding to Add and Delete Time Bar events in the control

When a time bar is added to the control, programmatically or through the mouse interface (clicking and dragging) a BeforeTimeBarInsert event and an AfterTimeBarInserted event fires. In the case where the Add event is generated as the result of user interaction (clicking and dragging), the developer can recognize the addition in either event and programmatically add a record to the table representing the time bar.

IMPORTANT NOTE: Both events pass the time bar object being created as part of the event arguments. This allows the developer to query the newly added time bar and create a record in the time bar table that reflects the properties of the new object.

IMPORTANT NOTE: When a new time bar is added to the schedule and saved in the database, the persistence scheme (record id, DataRow, etc.) of the newly added record should be stored in the time bar to identify the source record for any future changes or deletions of the time bar.

SUMMARY

Databinding the dbiSchedule control requires three distinct points of integration; loading the data from the database, responding to changes (moves/edits) to the time bars in the schedule object, and responding to Adds (new) and Deletes to the time bars in the schedule plan. Each of the objects in the schedule (items and time bars) have properties that allow the developer to persist the relationship of the record in the database being reflected in the item or time bar. Each event that is fired in the schedule passes the time bar against which the event occurred (move, size, add, remove) to allow the programmer to read the necessary property values (start time, end time, etc.) and its persistence scheme (record id, DataRow, etc.) to the object in the database.

NOTE: The discussion above is based on a simple example (meeting rooms) that does not involve multiple resources against the same time bar (for example equipment such as projectors, people, etc.). These items could be added however as detail to the time bar record in the database and reflected in the schedule as detail to the time bar, either as text, sub-text, a tip, or a drill down form invoked by a mouse action on the time bar. Also, this example does not take into account the linking of time bars. Links are a separate collection in the control and therefore represent a separate table in the database. In a fashion similar to the time bars, links have their own set of events (BeforeTimeBarLink, AfterTimeBarLinked, BeforeTimeBarUnlinked, AfterTimeBarUnlinked) in which the programmer can code the binding of the objects to the database.


%%ItemTitle%%

Developing with DBISchedule - Displaying Tool Tips

Glossary Item Box

The dbiSchedule control is capable of displaying tool tips in the schedule in response to a variety of different actions. These actions include:

Creating a Time Bar: If the TipsOnCreateBar property of the dbiSchedule is set to a value of True, a tool tip will appear under a time bar as a time bar is being created. The information in the tool tip will include the start and end time for the time bar, and the time span of the time bar.

The tool tip above is displaying the start time, end time, and time span of the tool bar.

Changing a Time Bar: If the TipsOnChangeBar property is set to a value of True, a tool tip will appear when a time bar is being moved or sized. The information in the tool tip will include the start and end time for the time bar, and the time span of the time bar.

Moving the Mouse Over a Time Bar: If the TipsOnMoveBar property is set to a value of True, a tool tip will appear when the mouse moves over a time bar. The information in the tool tip will include the start and end time for the time bar.

Vertically Scrolling through the Schedule Items: If the TipsOnVScroll property is set to a value of True, a tool tip will appear when the thumb in the vertical scroll bar is being moved. NOTE: By default the information in the vertical scroll bar tool tip only includes the current value of the vertical scroll bar.

Moving the Mouse over a Schedule Note: If the TipsOnNotes property is set to a value of True, a tool tip will appear when the mouse moves over a note in the schedule NOTE: By default the information in the schedule note tool tip only includes the current text value of the schedule note.(Enterprise version only)

Intercepting the Tool Tip Text

To customize the content of a tool tip the developer can intercept it before it is displayed and either cancel the appearance of the tool tip, or change the text within the tool tip. The dbiSchedule control's BeforeToolTips event fires before a tool tip is shown and is used to modify the content of the tool tip.

Example:

Modify the tool tip text in the BeforeToolTips event when a tool tip for the vertical scroll bar is about to be displayed.

NOTE: The e argument passed in the event has a property defining the text to be displayed.

[VB.NET]

If (e.TipsType = Dbi.WinControl.Schedule.enumTipsType.Scroll) Then

e.Text = "This is item " + e.Text

End If

[C#]

if (e.TipsType == Dbi.WinControl.Schedule.enumTipsType.Scroll)

e.Text = "This is item " + e.Text;


%%ItemTitle%%

Developing with DBISchedule - Map Area

Glossary Item Box

The map area displays a compressed version of all schedules and time bars loaded in the dbiSchedule control in an area across the top of the control. NOTE: This feature is only available in the enterprise version of the control.

The image above represents a dbiSchedule control with five schedule objects loaded. The map area presents all five schedules in their entirety (all items) in a compressed image so they can be viewed simultaneously along the top of the control. A red rectangle appears in the map area that represents the approximate current viewing area in the main schedule. If the user clicks on the map area, the view in the schedule area will change to display the area where the user clicked.

NOTE: If there are many line items, or if the schedule (or schedules) are extraordinarily large, the compressed image could become blurry. It is important to note the standard schedule area of the control is drawn to display only those items in the visible scrolling area, but the map schedule has to draw everything. Accordingly the performance of the control may begin to degrade if the map area is visible and the schedules are very large.

The appearance of the map area is determined by the MapVisible property. Setting the property to true turns the map area on, setting the property to false turns the map area off. The height of the map area in pixels is determined by the MapHeight property.


%%ItemTitle%%

Developing with DBISchedule - Setting up Different Views

Glossary Item Box

Multiple Schedules

The dbiSchedule control is capable of storing one or many different schedule objects, each schedule defined by a start date/time and end date/time with its own respective time type ruler (timeline). The enterprise version of the dbiSchedule control contains a powerful feature that allows the developer to present multiple schedules simultaneously. For example, to create a schedule interface that presented Monday to Friday with only the hours from 8:00 am to 5:00 pm, the developer would create five dbiScheduleObject objects (one for each day Monday to Friday) with a time span from 8:00 am to 5:00 pm, and add them to the dbiSchedule control's Schedules collection. NOTE: The time type and hours for each schedule are unique and therefore may be different for each schedule object (i.e. one schedule based upon days and another based on hours). Each schedule object is placed side by side in the schedule viewing area. The control navigates to the various schedules by changing the value of the horizontal scroll bar in the schedule area (programmatically or by user interaction with the scroll bar).

In the standard version of the dbiSchedule control only one schedule can be viewed at any time. Other schedule objects can be made active using the ActiveSchedule property. In the enterprise version of the dbiSchedule control, all schedules in the Schedules collection are visible, placed side by side beginning with the first schedule in the collection.

The image above shows two separate schedules sitting beside each other.

Zooming

By changing the value of the TimeDistance property in the dbiSchedule control, the developer can effectively zoom in and out of the view in the schedule(s) being displayed. This ability to zoom in or out of a schedule provides the developer with the option of presenting micro or macro views of the detail in the schedule. In the case where the items being scheduled require very precise time increments the TimeDistance value can be set to a higher value. NOTE: The higher the TimeDistance value the larger the distance between major time units (a major time unit will be wider). When the distance between major time units is larger, a user is able to position a time bar more precisely with the mouse. In the case where it is desirable to see more of the schedule simultaneously set the TimeDistance property to a smaller value.

General Notes

The TimeDistance property of the control can be used to set up different views of a schedule. It specifies the distance (in pixels) between the major time units within the dbiSchedule control. If the TimeType property of the dbiScheduleobject class is set to "Hours", the TimeDistance property specifies the distance between the hours of the day. If the TimeType property is set to "Days", the TimeDistance property specifies the distance between the days of the month, and so on.

  • The TimeDistance property is the number of pixels between major time units. For maximum efficiency, the TimeDistance property should be set to a value that corresponds in equal increments to the major time unit segments. For example, if the TimeType property of the dbiScheduleobject class is set to "Hours", the TimeDistance property of the dbiSchedule control should be set to a value that corresponds to the sixty minutes in that hour (i.e. 120, 60, 30, 15). If the property is set to a value that is not incrementally equal to the minutes in an hour, for example 37, a time bar could not be moved to exactly half past the hour. If the TimeDistance property was set to a value of 60, then each pixel on the screen would represent one minute.

  • The SnapToGrid property allows the developer to coerce a time bar start time to minimum value within the time line. If the SnapToGrip property is set to a value of True a time bar can only be moved to position within the major time unit as specified by the GridFrequency setting. For example, if the major time unit is set to Hours, the TimeDistance property is set to 60 (one pixel for each minute) then the user can place a time bar to start on any minute within an hour. To insure that time bars can only start on 15 minutes after the hour, 30 minutes after the hour, 45 minutes after the hour, or on the hour, the GridFrequency would be set to 15 and the SnapToGrid property would be set to true. In this case moving or creating a time bar in the schedule would automatically snap the start time to the nearest 15 minute increment.

  • NOTE: The TimeDistance property affects all schedules in the control equally. The dbiScheduleObject class also contains a TimeDistance property which can be used to uniquely set the time distance of a single schedule.

  • NOTE: The PrintTimeDistance property is the equivalent of the TimeDistance property when printing the schedule control.


%%ItemTitle%%

Developing with DBISchedule - Creating Custom Areas

Glossary Item Box

Custom areas are discrete pieces of the schedule that are used to color the schedule and/or create "dead zones". Custom areas can be assigned to all items in a schedule or individual items in a schedule.

Using the CustomArea class

Custom areas can be created at design time using the Custom Areas Collection editor (from the property inspector) or they can be created programmatically through code at runtime.

Example:

Create a custom area for all line items in a schedule.

[VB.NET]

Dim objColor As Dbi.PIM.dbiCustomArea

Dim dtStart As System.DateTime

Dim dtEnd As System.DateTime

dtStart = New DateTime(2004, 8, 15, 1, 30, 0)

dtEnd = New DateTime(2004, 8, 15, 2, 0, 0)

'Create a new instance of the custom area object,

'set its start and end date/times, color the schedule red for the designated period of time.

objColor = New Dbi.PIM.dbiCustomArea(dtStart, dtEnd, Color.Red)

Me.dbiSchedule1.Schedules(0).CustomAreas.Add(objColor) 'Add the custom area to the Schedule's Custom Areas collection

[C#]

Dbi.PIM.dbiCustomArea objColor;

System.DateTime dtStart;

System.DateTime dtEnd;

dtStart = new System.DateTime(2004, 8, 15, 1, 30, 0);

dtEnd = new System.DateTime(2004, 8, 15, 2, 0, 0);

//Create a new instance of the custom area object,

//set its start and end date/times, color the schedule red for the designated period of time.

objColor = new Dbi.PIM2.dbiCustomArea(dtStart, dtEnd, Color.Red);

this.dbiSchedule1.Schedules[0].CustomAreas.Add(objColor); //Add the custom area to the Schedule's Custom Areas collection

Custom areas can also be assigned to a single line item. To specify an individual item in the list the custom area must be added to the item's custom areas collection.

Example:

Create the custom area for the third item in the list using the custom area created above.

[VB.NET]

Me.dbiSchedule1.Items(2).CustomAreas.Add(objColor)

[C#]

this.dbiSchedule1.Items[2].CustomAreas.Add(objColor);

Daily Areas

It is possible to set up a single entry for a custom area that is repeated on all days by setting the Daily property of the dbiCustomArea class to a value of true. NOTE: The time defined for a custom area must be less than 24 hours if it is to be repeated as a "daily" custom area.

Creating Dead Zones

A dead zone is defined as an area where an appointment cannot be created, moved, or sized into. Dead zones only apply to time bars created or changed in the control while in edit mode (i.e. through user interaction). Dead zones have no effect on time bars being added or changed through code. It is the responsibility of the programmer to obey dead zones when programmatically changing time bars. NOTE: The InDeadZone method can be used to determine if an appointment can be placed in a specified area of the schedule.


%%ItemTitle%%

Developing with DBISchedule - Editing Items in the List

Glossary Item Box

Editing Text in the List

The list area of the control can provide a direct edit interface for the resource items being scheduled. Providing the user with the ability to directly edit items in the list can be accomplished in two different ways.

1. When the LabelEdit property is set to true, the user is able to modify the text of an item by clicking the item text to select it and then clicking the item text again to put the label text into edit mode.

2. Use the EditCell method to put the control into edit mode at a certain line item or cell.

The user can then modify or replace the item's or cell’s text label. The developer can use the BeforeCellEdit and AfterCellEdit events to perform tasks before and after the user edits an item's text. The text of child line items can also be modified if the control is in edit mode.

To leave the edit mode, the user can press the <Esc> key (which restores the original text), the <Enter> key (which writes back the current text), or cause the edit label to lose focus by clicking or tabbing off of it (which will also write back the current text).

Items that cannot be edited

There are certain conditions that prevent a line item or cell from being edited. These include.

· The line item has been marked as read only or defined as a header.

· The column has been marked as read only, or has been defined as an image or Boolean.

· If there is not enough room to place the edit label on the list.


%%ItemTitle%%

Developing with DBISchedule - Auto Navigation Between Cell Edits.

Glossary Item Box

Auto Navigation

By default, going into edit mode will be finished as soon as the edit label is removed from the list. To edit another line item or cell, the user will have to click on that new line item or cell, or invoke code that will make another call to the EditCell method.

However, there may be times when the developer wants to keep the edit mode going so that the user can edit additional line items or cells. To do this, the developer must set the EditAutoNavigate property to true. When this happens, the edit mode will attempt to edit the next line item or cell in the list when the previous line item or cell has finished. This will continue until there are no longer any line items or cells to edit, or if the user clicks off the edit label. When EditAutoNavigate is true, the edit mode will recognize the following navigation keys.

· <Esc>: The original text is written back to the line item or cell, and edit mode is canceled.

· <Enter> and <Tab>: The current text in the edit label is written back to the line item or cell, and the edit label will go to the next available line item or cell.

· <Shift Tab>: The current text in the edit label is written back to the line item or cell, and the edit label will go to the previous available line item or cell.


%%ItemTitle%%

Developing with DBISchedule - Built-In Edit Controls

Glossary Item Box

Edit Controls

The control hosts both a standard text box and a combo box for its edit labels. By default, the text box will be used. If the developer wants a combo box instead, they must first make sure a column for that cell has been created and assigned to the list, and that the EditType property of the column object is set to "ComboBox”. The list items for that combo box can be assigned when the column object is created, or in the BeforeCellEdit event.

The text and combo boxes are fully exposed to the developer. Therefore the developer is able to make changes to those controls as if they created the controls themselves (i.e. Colors, border styles, etc).


%%ItemTitle%%

Developing with DBISchedule - Edit Control Placement.

Glossary Item Box

Placement of the Edit Control

When an edit control is made visible, its initial height will be the same as the entire line item. If the control has defined column objects, or if the EditAutoSize property is false, the width of the edit label will be the same as the column or control from where the actual text starts. If no columns are defined, and the EditAutoSize property is true, the width is determined by the width of the text.

There may be times when the size and placement of the edit label is not acceptable. If that is the case, the developer can change the size and placement of the edit label in the BeforeCellEdit event. The code below illustrates how to cause the edit label to be vertically centered in a line item along with being the same height as the text.

C#

void dbiSchedule1_BeforeCellEdit(object sender, Dbi.WinControl.BeforeCellEditEventArgs e)

{

e.Y += 8;

e.Height -= 16;

}

VB.NET

Private Sub DbiSchedule1_BeforeCellEdit(sender As System.Object, e As Dbi.WinControl.BeforeCellEditEventArgs) Handles DbiSchedule1.BeforeCellEdit

        e.Y = e.Y + 8

        e.Height = e.Height – 16

End Sub


%%ItemTitle%%

Developing with DBISchedule - Conditional Editing.

Glossary Item Box

Conditional Editing

When the edit mode is active, and the EditAutoNavigate property is true, the edit label will move from one line item or cell to the next when a navigation key is pressed. The default edit mode will skip over cells with columns defined as Boolean, image or are read only. The navigation will also skip over items marked as read only, or a header item.

However, there may be special cases where a particular line item or cell must be skipped. If this is the case, the programmer must use the InitializeCellEdit event to determine if the cell or line item can be edited. If not, the control will look for the next cell item to edit and try again (or previous cell item if <Shift Tab> is pressed). This is different from the BeforeCellEdit event in that if the developer cancels the editing in that event, the edit mode will no longer be active.

C#

void dbiSchedule1_InitializeCellEdit(object sender, Dbi.WinControl.InitializeCellEditEventArgs e)

{

if (CanWeEditTheCell(e.NodeItem, e.ColumnIndex) == false)

e.AllowEdit = false;

}

VB.NET

Private Sub DbiSchedule1_InitializeCellEdit(sender As System.Object, e As Dbi.WinControl.InitializeCellEditEventArgs) Handles DbiSchedule1.InitializeCellEdit

If (CanWeEditTheCell(e.NodeItem, e.ColumnIndex) = False) Then

            e.AllowEdit = False

        End If

End Sub


%%ItemTitle%%

Developing with DBISchedule - Extending Edit Navigation.

Glossary Item Box

Using Other Keys for Navigation

By default, the edit mode recognizes four keys to use for navigation (<Enter>, <Esc>, <Tab>, and <Shift Tab>). However, there may be cases when other keys will be required for navigation as well (i.e. the up and down arrow keys). If that is the case, the following events and methods must be used…

1. Use the EditInputKey event to identify the new keys being used.
C#

void dbiSchedule1_EditInputKey(object sender, Dbi.WinControl.EditInputKeyEventArgs e)

{

switch (e.KeyData)

{

case Keys.Up:                   // We are adding a new key

case Keys.Down:                 // We are adding a new key

e.Handled = true;

break;

    }

}

VB.NET

Private Sub DbiSchedule1_EditInputKey(sender As System.Object, e As Dbi.WinControl.EditInputKeyEventArgs) Handles DbiSchedule1.EditInputKey

        Select e.KeyData

            Case Keys.Up

                'We are adding a new key

            Case Keys.Down

                'We are adding a new key

                e.Handled = True

        End Select

End Sub

2. Monitor the AfterCellEdit event for those keys, and take the appropriate action when they are pressed. NOTE: Use the EditCell method to put the control back into edit mode.

C#

void dbiSchedule1_AfterCellEdit(object sender, Dbi.WinControl.AfterCellEditEventArgs e)

{

if (e.Key == Keys.Up)

dbiSchedule1.EditCell(e.NodeItem.PrevVisibleNode(), e.ColumnItem);

else if (e.Key == Keys.Down)

dbiSchedule1.EditCell(e.NodeItem.NextVisibleNode(), e.ColumnItem);

}

VB.NET

Private Sub DbiSchedule1_AfterCellEdit(sender As System.Object, e As Dbi.WinControl.AfterCellEditEventArgs) Handles DbiSchedule1.AfterCellEdit

        Select e.Key

            Case Keys.Up

                DbiSchedule1.EditCell(e.NodeItem.PrevVisibleNode(), e.ColumnItem)

            Case Keys.Down

                DbiSchedule1.EditCell(e.NodeItem.NextVisibleNode(), e.ColumnItem)

        End Select

End Sub


%%ItemTitle%%

Developing with DBISchedule - Using Custom Edit Controls.

Glossary Item Box

Using Custom Controls as an Edit Control

The dbiSchedule uses a standard text box and combo box as its edit control. However, there may be cases where a third party control needs to be used. A good example of this may be a date picker control with a drop down calendar.

In order to use a third party control in the list, that control needs to expose the keys being pressed in it to the host. This is because the host control does not monitor key strokes of the third party control. To use a third party control the developer must interrupt the control’s current edit mode process, monitor the third party control for the navigation keys being used, determine the new cell to go to after a navigation key is pressed, and then put the list back into edit mode.

It should also be noted that the developer must be responsible for moving the data back and forth between the item and the third party control.

The following steps are required to use a third party control.

· A column object for that control must be created and added to the list.  NOTE: The EditType property of that column must be set to “UserControl”.

· If the third party control has a “Parent” property, it is advised to set it to the host schedule. It will make it easier to position it later on.

· Use the BeforeCellEdit event to test if the focus is on the appropriate column. If so, the data from the cell must be moved to the user control.

The following code assumes we are working with a standard date time picker control.

C#

void dbiSchedule1_BeforeCellEdit(object sender, Dbi.WinControl.BeforeCellEditEventArgs e)

{

    string strText;

    if (e.ColumnIndex == m_nUserControlColumn)

    {

        strText = e.NodeItem.GetCellText(e.ColumnIndex);

        dateTimePicker1.Value = Convert.ToDateTime(strText);

    }

}

VB.NET

Private Sub DbiSchedule1_BeforeCellEdit(sender As System.Object, e As Dbi.WinControl.BeforeCellEditEventArgs) Handles DbiSchedule1.BeforeCellEdit

        Dim strText As String

        If e.ColumnIndex = m_nUserControlColumn Then

            strText = e.NodeItem.GetCellText(e.ColumnIndex)

            dateTimePicker1.Value = Convert.ToDateTime(strText)

        End If

End Sub

· Use the DisplayUserControl event to actually display the user control. Once again test to make sure the focus is in the correct column or else the user control will be showing up where it is not desired.

C#

void dbiSchedule1_DisplayUserControl(object sender, Dbi.WinControl.DisplayUserControlEventArgs e)

{

    if (e.ColumnIndex == m_nUserControlColumn)

    {

        dateTimePicker1.SuspendLayout();

        dateTimePicker1.Visible = false;

        dateTimePicker1.Location = new Point(e.X, e.Y);

        dateTimePicker1.Width = e.Width;

        dateTimePicker1.Visible = true;

        dateTimePicker1.ResumeLayout();

        dateTimePicker1.Focus();

    }

}

VB.NET

Private Sub DbiSchedule1_DisplayUserControl(sender As System.Object, e As Dbi.WinControl.DisplayUserControlEventArgs) Handles DbiSchedule1.DisplayUserControl

        If e.ColumnIndex = m_nUserControlColumn Then

            dateTimePicker1.SuspendLayout()

            dateTimePicker1.Visible = False

            dateTimePicker1.Location = New Point(e.X, e.Y)

            dateTimePicker1.Width = e.Width

            dateTimePicker1.Visible = True

            dateTimePicker1.ResumeLayout()

            dateTimePicker1.Focus()

        End If

End Sub

· Use the RemoveUserControls event to write back the data from the user control and then hide the user control. NOTE: The developer must test that the focus is in the proper column or the data from the user control may be written back to all cells being edited.

C#

void dbiSchedule1_RemoveUserControls(object sender, Dbi.WinControl.RemoveUserControlsEventArgs e)

{

    if (e.ColumnIndex == m_nUserControlColumn)

        WriteDateTimeBack(e.ColumnIndex);

    dateTimePicker1.Visible = false;

}

VB.NET

Private Sub DbiSchedule1_RemoveUserControls(sender As System.Object, e As Dbi.WinControl.RemoveUserControlsEventArgs) Handles DbiSchedule1.RemoveUserControls

If e.ColumnIndex = m_nUserControlColumn Then

            WriteDateTimeBack(e.ColumnIndex)

        End If

        dateTimePicker1.Visible = False

End Sub

The above represents the code required for the events in the host control. All that remains is the code to monitor the keystrokes of the user control to support navigation to other cells. By default, the host control monitors for the <Enter>, <Esc>, <Tab> and <Shift Tab> keys. But if the developer is causing the host control to use other keys for navigation, those keys will have to be monitored and acted upon by the user control as well.


%%ItemTitle%%

Developing with DBISchedule - Schedule Edit Modes

Glossary Item Box

Using the mouse, time bars can be selected, created, moved, sized, erased and linked/unlinked within the schedule. The type of edit action is determined by the EditMode property of the control. The edit modes available are Edit, Erase, Select, Link, Unlink and GuideLine.

Edit

Indicated by the pencil cursor, the edit mode allows the user to create, size and move time bars. In order to create a new time bar, left click in an item in the schedule and drag the mouse to the left or right. When the mouse button is released, a new time bar is created.

To size a time bar, left click on either end of a time bar and drag horizontally in either direction. Release the mouse button to complete the operation.

NOTE: If a time bar is sized so that its end time is less than or equal to the start time, one of two actions can occur;

  1. By default, the time bar will be erased.

  2. If the MinTime property from the dbiTimeBarItem class or the MinBarTime property from the control are set to a value greater than 0, the time bar will be set to that minimum time span. If both those properties are greater than 0, the time span for the time bar will be set to the greater value.

There are a variety of restrictions that can be placed into the schedules to prevent a time bar from being created, moved or sized. These include:

  • Actions (move, size, create) that would place the time bar in a dead zone (See section on Creating Custom Areas for more details)

  • Actions (vertical move or create) that would cause the number of time bars in an item to exceed the maximum number of time bars allowed for that item. NOTE: The limit for the number of time bars allowed on an item is set in the MaxTimeBars property of the dbiScheduleItem object.

  • Actions (select, move, create, size, erase, link) to time bars in an item that has been set to a read only state through the ReadOnly property of the dbiScheduleItem class.

  • Actions (select, move, create, size, erase, link) to a time bar whose Locked or ReadOnly property is set to True. To set a time bar to be locked or read only, use the appropriate dbiTimeBarItem class property.

  • The modification of actions (such as cancelling) in the BeforeTimeBarInsert, BeforeTimeBarSize or BeforeTimeBarMove events.

  • The prevention/allowing of vertical time bar moves using the AllowVertMoves property of the control. Setting the property to true allows time bars to moved vertically between items, setting the property to false restricts movement of a time bar to horizontal moves only within its host item.

  • NOTE: In a situation where more than one Schedule object is being displayed simultaneously, time bars cannot be moved with the mouse from one schedule to another. Each schedule is a unique object, and does not interact with other schedules.

Erase

Indicated by the eraser mouse cursor. This mode allows the user to erase individual time bars by clicking on them.

Select

Indicated by the large "+" mouse cursor, this mode allows the user to click and drag an area in the schedule, creating a loop and selecting all time bars within or touching the edge of the loop. NOTE: The Select mode allows users to select more than one time bar simultaneously. Once selected, the time bars can then all be moved or sized at the same time. The restrictions for moving or sizing time bars in this mode are the same as the Edit mode noted above.

NOTE: Multiple time bars can also be selected discretely by setting the EditMode property to Select and holding down the Ctrl key while left clicking on the desired time bars.

Link

Indicated by the chain link mouse cursor. This mode allows the user to click on one time bar, drag the link to another time bar and release the mouse to create a link. When complete, a link between the two time bars is created. (See section on Time Bar Linking for more details and restrictions.)

Unlink

Indicated by the broken chain link mouse cursor. This mode allows the user to click and drag between two linked time bars to break the link. (See section on Time Bar Linking for more details and restrictions.)

SPLIT

Indicated by the scissors mouse cursor. This mode allows the user to click in an existing timebar and effectively split the timebar into two sections at the cursor position.


%%ItemTitle%%

Developing with DBISchedule - Error Messages

Glossary Item Box

There are eight trappable errors that may be raised by the control during its operation. NOTE: All error messages are sent directly to the ControlError event and are parameterized as an integer value and text message. These errors include:

1 - Create In Dead Zone: An attempt was made to create a time bar in a dead zone.

2 - Move In Dead Zone: An attempt was made to move a time bar into a dead zone.

3 - Drop In Dead Zone: An attempt was made to drop a time bar into a dead zone.

100 - File Not Found: An attempt was made to read in a file that does not exist, or could not be found

101 - Invalid XML File: An attempt was made to read an XML file that the control did not recognize.

1000 - Invalid Time Bar: An attempt was made to call a function with an invalid time bar.

1001 - Max Time Bars Exceeded: An attempt was made to create or move a time bar on a line item where the maximum number of time bars has already been placed.

1002 - Invalid Time Bar Move: An attempt was made to move a time bar into an invalid area.


%%ItemTitle%%

Developing with DBISchedule - Implementing Drag and Drop

Glossary Item Box

The dbiSchedule control supports dragging and dropping of objects from outside of the control into the schedule area of the control to create time bars and into the list area of the control to create list items.

To implement the dragging and dropping of an object into the schedule ...

  1. Set the AllowDrop property of the control to true

  2. In the DragEnter event of the control, place the following code: e.Effect = DragDropEffects.All

  3. In the object from which the drag operation is initiated set the required drag information. For example: DoDragDrop(New DataObject(DataFormats.Text, "Drag info"), DragDropEffects.All)

Dragging and Dropping Time Bars

When an object is dragged over the schedule area in the control, the cursor will indicate the drag operation is valid. When the mouse button is released, in effect dropping the object being dragged on to the schedule, the BeforeTimeBarDrop event will be fired. This event allows for the examination of the data in the drop object before deciding if the drop event is to be completed. This is also a good event to make any changes to the item being dropped before finalizing the process. For example, in the BeforeTimeBarDrop event the programmer can choose to accept the drop request, e.AllowDrop = True or deny the drop request, e.AllowDrop = False. If the drop event is accepted, the developer has the option of inspecting and changing the parameters of the object being dropped before the time bar is created. NOTE: The BeforeTimeBarDrop event passes the new time bar being created as a parameter on its "e" event arguments as a TimeBarItem object.

Example:

Set the properties of the newly created time bar in the BeforeTimeBarDrop event.

[VB.NET]

Private Sub DbiSchedule1_BeforeTimeBarDrop(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.BeforeTimeBarDropEventArgs) Handles DbiSchedule1.BeforeTimeBarDrop

e.TimeBarItem.BackColor = Color.Red

e.TimeBarItem.Text = "New Time Bar Text"

e.TimeBarItem.End = e.TimeBarItem.Start.AddMinutes(60)

End Sub

[C#]

private void dbiSchedule1_BeforeTimeBarDrop(object sender, Dbi.WinControl.Schedule.BeforeTimeBarDropEventArgs e)

{

e.TimeBarItem.BackColor = System.Drawing.Color.Red;

e.TimeBarItem.Text = "New Time Bar Text";

e.TimeBarItem.End = e.TimeBarItem.Start.AddMinutes(60);

}

If the time bar drop is allowed in the BeforeTimeBarDrop event (e.AllowDrop = True) the control fires an AfterTimeBarDrop event. This event occurs after the new time bar has been physically added to and rendered in the control. This event is recommended for saving newly added time bars back to the database. For more information on Databinding the dbiSchedule control please see the Procedural Help on Databinding).

Dragging and Dropping List Items

When an object is dragged over the list area in the control, the cursor will indicate the drag operation is valid. When the mouse button is released, in effect dropping the object being dragged on to the list, the DropList event will be fired. This event allows for the examination of the data in the drop object before inserting or adding the item to the list. NOTE: The DropList event does not automatically create a list item, that is the responsibility of the developer.

Example:

Create a new list item from a drop action on an existing item in the list.

[VB.NET]

Private Sub DbiSchedule1_DropList(ByVal sender As Object, ByVal e As dbi.WinControl.DropListEventArgs) Handles DbiSchedule1.DropList

Dim objScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

Dim intItemIndex As Integer

If NOT e.Item Is Nothing Then 'If the drop event occurs on the header and not an item no item is passed into the event

intItemIndex = Me.DbiSchedule1.Items.IndexOf(e.Item) 'Determine the index value of the item on which the drop occurred

If intItemIndex < 0 Then 'Drop occurred on a child item ... NOTE: A Child item returns a -1

Dim objParent As New Dbi.WinControl.Schedule.dbiScheduleItem

objParent = e.Item.Parent 'Store the parent item in objParent

'Insert the item as a child node

objScheduleItem.Text = objParent.Text + "Child" 'Set the text of the new schedule item object to be the text of the parent item plus the word "Child"

objParent.Items.Add(objScheduleItem) 'Create a child item under the same parent as the child item on which the drop took place

Else 'Drop occurred on a Top level Schedule item

objScheduleItem.Text = e.Item.Text + " -2" 'Set the text of the new schedule item to the text of the schedule item on which the drop occurred plus "-2"

'Create the new item below the item on which the drop event took place (NOTE: The +1 to place the item under and not above)

Me.DbiSchedule1.Items.Insert(intItemIndex + 1, objScheduleItem)

End If

End If

End Sub

[C#]

private void DbiSchedule1_DropList(object sender, Dbi.WinControl.DropListEventArgs e)

{

Dbi.WinControl.Schedule.dbiScheduleItem objScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

int intItemIndex;

if (e.Item == null) //If the drop event occurs on the header and not an item no item is passed into the event

{

intItemIndex = this.DbiSchedule1.Items.IndexOf(e.Item); //Determine the index value of the item on which the drop occurred

if (intItemIndex < 0) //Drop occurred on a child item ... NOTE: A Child item returns a -1

{

Dbi.WinControl.Schedule.dbiScheduleItem objParent = new Dbi.WinControl.Schedule.dbiScheduleItem();

objParent = (Dbi.WinControl.Schedule.dbiScheduleItem) e.Item.Parent; //Store the parent item in objParent

//Insert the item as a child node

objScheduleItem.Text = objParent.Text + "Child"; //Set the text of the new schedule item object to be the text of the parent item plus the word "Child"

objParent.Items.Add(objScheduleItem); //Create a child item under the same parent as the child item on which the drop took place

}

else //Drop occurred on a Top level Schedule item

{

objScheduleItem.Text = e.Item.Text + " -2"; //Set the text of the new schedule item to the text of the schedule item on which the drop occurred plus "-2"

//Create the new item below the item on which the drop event took place (NOTE: The +1 to place the item under and not above)

this.DbiSchedule1.Items.Insert(intItemIndex + 1, objScheduleItem);

}

}

}


%%ItemTitle%%

Developing with DBISchedule - Implementing Scroll Bars

Glossary Item Box

Programmatically setting the viewing areas of the dbiSchedule Control

The dbiSchedule control provides the developer with multiple methods to programmatically set the viewing areas of the control. There are three scroll bars that manage the list and schedule regions within the control; the vertical scroll bar, a List horizontal scroll bar, and a Schedule horizontal scroll bar. These scroll bars can be programmatically set using their respective scroll values. The control also includes a ScrollToDateTime method (Enterprise version only) to allow the developer to programmatically navigate to a given date and time within a schedule object.

In addition to the functionality noted above, the control generates a ScrollTrack event to assist developers in responding to user initiated scroll bar input. The Enterprise version of the control provides three additional properties for tracking and manipulating the scroll bars within the control; ListScrollValue, SchedScrollValue, VertScrollValue . This extended functionality provides the developer with the tools necessary for the programmatic positioning of the schedule control necessary to address issues such as schedule synchronization (multiple instances of the dbiSchedule control), or “Go To’ functionality (Date/Time, List item, etc.) within an application.

The ScrollTrack event

This event fires anytime a scrollbar is moved programmatically or by user interaction. The e.ScrollBar (Integer) argument returns the following value indicating which scroll bar has been moved

0 - Vertical Scroll Bar

1 - List Horizontal Scroll Bar

2 - Schedule Horizontal Scroll Bar

The ScrollTrack event also passes an e.value (integer) representing the new value of the scroll bar that was moved. The scroll bar's value, min and max calculations are based on several factors including the visible size of the control, the number of items, the number of time units and the overall start and end dates. NOTE: The e.value parameter is passed to allow the developer to take a snapshot of the position of a scroll bar in order to restore a particular view or synchronize multiple instances of the schedule control (Enterprise version only).

.

Example

Synchronize multiple schedule controls on the same form.

[VB.NET]

'Two schedule controls on the same form with identical time intervals and time type 'settings: Synchronize the movement between the two controls.

Private Sub DbiSchedule1_ScrollTrack(ByVal sender As Object, ByVal e As Dbi.WinControl.Schedule.ScrollTrackEventArgs) Handles DbiSchedule1.ScrollTrack

If e.ScrollBar = 2 Then 'Horizontal Scroll bar in the schedule area

Me.DbiSchedule2.SchedScrollValue = e.Value

End If

End Sub

[C#] Synchronize multiple schedule controls on the same form.

//Two schedule controls on the same form with identical time intervals and time type //settings: Synchronize the movement between the two controls.

private void dbiSchedule1_ScrollTrack(object sender, Dbi.WinControl.Schedule.ScrollTrackEventArgs e)

{

if (e.ScrollBar == 2) //Horizontal Scroll bar in the schedule area

this.dbiSchedule2.SchedScrollValue = e.Value.ToString();

}

To get and set the values of the scroll bars in the control there are three properties (Enterprise version only):

dbiSched.VertScrollValue The current scroll value of the Vertical Scrollbar

dbiSched.ListScrollValue The current scroll value of the List Scrollbar

dbiSched.SchedScrollValue The current scroll value of the Schedule Scrollbar

Each ScrollValue property represents the value of the associated scroll bar.

ScrollToDateTime(Enterprise version only)

The ScrollToDateTime method of the dbiSchedule control allows the developer to programmatically move to any date/time within a ScheduleObject in the dbiSchedule.Schedules collection. The method requires two parameters:

dtValue (DateTime) - The date/time to locate and make visible in the viewing area of the schedule control.

nOffset (short) - The number of major time units in the ScheduleObject to display the dtValue relative to the left side of the schedule area in the control. Using an nOffset value of 0 displays the dtValue as the first time in the scheduling area of the control. Setting a positive or negative value in the nOffset parameter moves the viewing area left (positive) or right (negative) the specified number of major time units.

If the dbiSchedule control's Schedules collection contains more than one ScheduleObject the ScrollToDateTime method will start with the first schedule, and cycle through the remaining schedule objects to find the appropriate date. If the DateTime value is not found, the method will return a value of False.

Example

Scroll the schedule control horizontally to the start date/time of the 4th schedule object in the control's schedules collection.

[VB.NET]

Me.DbiSchedule1.ScrollToDateTime(Me.DbiSchedule1.Schedules(3).Start, 0)

[C#]

this.DbiSchedule1.ScrollToDateTime(this.DbiSchedule1.Schedules(3).Start, 0);


%%ItemTitle%%

Developing with DBISchedule - Time Bar Linking

Glossary Item Box

Time bar links are defined by the dbiLinkItem class. Time bar links can be created in two different ways; programmatically through code, or through user interaction with the control when in the Link edit mode.

Example:

Programmatically create a link between two time time bars

[VB.NET]

Dim objLink as New dbiLinkItem(objTimeBar1, objTimeBar2) 'Create a new link item object between to time bar objects

Me.dbiSchedule1.Links.Add(objLink) 'Add the link to the dbiSchedule control's links collection

[C#]

Dbi.WinControl.Schedule.dbiLinkItem objLink;

objLink = new Dbi.WinControl.Schedule.dbiLinkItem(objTimeBar1, objTimeBar2); //Create a new link item object between to time bar objects

this.dbiSchedule1.Links.Add(objLink); //Add the link to the dbiSchedule control's links collection

IMPORTANT NOTE: All time bar links are defined with a source (the time bar from which the link originates) and a destination (the time bar on which the link terminates). A time bar that is the source of a link is said to be "linked to" another time bar. A time bar that is the destination of a link is said to be "linked from another time bar".

To allow the user to create links between time bars in the schedule, set the control's EditMode to "Link". The user can then click on one time bar, drag the mouse to another time bar and release the mouse. A link is visually displayed between the two time bars. NOTE: The control responds to user input when in link mode by firing a BeforeTimeBarLink event and AfterTimeBarLinked event. These events can be used to validate the input, optionally cancel or allow link, and to code the necessary data binding logic to persist the link in the database.

In the standard version of the dbiSchedule control, a time bar can only be linked to one other time bar. A one-to-one relationship. In the enterprise version of the dbiSchedule control, a single time bar can link to any number of other time bars. A one-to-many relationship.

Time bar links can be broken using the mouse by setting the EditMode property to "Unlink". Clicking and dragging on the time bars connected by a link causes the link to be removed when the mouse button is released on the second time bar. If two time bars are loop linked (one time bar links to another, and then another link goes back to the first time bar), the primary link will be removed first.

There are three different types of time bar links (dbi.WinControl.Schedule.dbiLinkItem.LinkType):

1. Standard Link: A link with square lines and an arrow at the destination time bar.

2. Reciprocal Link: A link with square lines and arrows at the source and destination time bar.

3. Direct Link: A straight line between two time bars with no arrows.

And there are four different directions available (dbi.WinControl.Schedule.dbiLinkItem.LinkDirection):

1. Start to End: A link that begins at the start of the source timebar and terminates at the end of the destination timebar.

2. Start to Start: A link that begins at the start of the source timebar and terminates at the start of the destination timebar..

3. End to Start: A link that begins at the end of the source timebar and terminates at the start of the destination timebar..

3. End to End: A link that begins at the end of the source timebar and terminates at the end of the destination timebar..

LINK TYPE LINK DIRECTION | Standard | Reciprocal | Direct
Start to End |  |  |
Start to Start |  |  |
End to Start |  |  |
End to End |  |  |

Link Navigation

The Links collection in the dbiSchedule control keeps track of all time bars links. NOTE: A time bar does not store any information concerning its links. To determine what time bar links exist and to navigate the links the developer must refer to the Links collection in the dbiSchedule control.

To determine how many time bars a given time bar is linked to (how many links a given time bar is the source), use the LinksToCount function in the dbiSchedule LinksCollection object. This will return the number of links in the Links collection for which the specified time bar is the source.

nCount = Me.dbiSchedule1.Links.LinksToCount(objBar)

nCount = this.dbiSchedule.Links.LinksToCount(objBar);

To determine how many time bars are linked to a certain time bar, use the LinksFromCount function in the dbiSchedule LinksCollection object. This will return the number of links for which the specified bar is the destination (or termination) of the link.

nCount = Me.dbiSchedule1.Links.LinksFromCount(objBar)

nCount = this.dbiSchedule.Links.LinksFromCount(objBar);

To retrieve the actual time bar object that a link is going to or coming from, use the LinksTo and LinksFrom methods in the dbiSchedule LinksCollection.

NOTE: When time bars are linked, there are no methods or events to automatically adjust the position of destination time bars when the source time bar is moved or changed.

[VB.NET]

Private Sub MoveLinkedTimeBars(ByVal objBarMoved As Dbi.WinControl.Schedule.dbiTimeBarItem, timespanDelta as TimeSpan)

'Custom Sub routine to move all time bars linked from a given time bar.

'NOTE: The timespanDelta value is calculated as the change in start date/time of the source time bar prior to calling the sub routine

Dim nCount as Integer

nCount = DbiSchedule1.Links.LinksToCount(objBarMoved) 'Return a count of the links where objBarMoved is the source of the link

For nIndex = 0 To nCount - 1 'Inspect each of the links to return the destination time bar in the link

Dim objTimeBar As New Dbi.WinControl.Schedule.dbiTimeBarItem

objTimeBar = DbiSchedule1.Links.LinksTo(objBarMoved, nIndex) 'Returns the destination time bar in the link

objTimeBar.Start = objTimeBar.Start.Add(timespanDelta ) 'Adjust the start time of the destination time bar by the change in the start time of the source time bar

objTimeBar.End = objTimeBar.End.Add(timespanDelta ) 'Adjust the end time of the destination time bar by the change in the start time of the source time bar

Next 'Inspect the next link

End Sub

[C#]

private void MoveLinkedTimeBars(Dbi.WinControl.Schedule.dbiTimeBarItem objBarMoved, TimeSpan timespanDelta)

{

//Custom Sub routine to move all time bars linked from a given time bar.

//NOTE: The timespanDelta value is calculated as the change in start date/time of the source time bar prior to calling the sub routine

int nCount;

nCount = DbiSchedule1.Links.LinksToCount(objBarMoved); //Return a count of the links where objBarMoved is the source of the link

for (int nIndex = 0; nIndex < nCount; nIndex++) //Inspect each of the links to return the destination time bar in the link

{

Dbi.WinControl.Schedule.dbiTimeBarItem objTimeBar = new Dbi.WinControl.Schedule.dbiTimeBarItem();

objTimeBar = DbiSchedule1.Links.LinksTo(objBarMoved, nIndex); //Returns the destination time bar in the link

objTimeBar.Start = objTimeBar.Start.Add(timespanDelta); //Adjust the start time of the destination time bar by the change in the start time of the source time bar

objTimeBar.End = objTimeBar.End.Add(timespanDelta); //Adjust the end time of the destination time bar by the change in the start time of the source time bar

}

}

The Links collection can also determine if a link exists between two time bars using the LinkIndex function. If a link exists between the two time bars specified the method returns the index value of the link. If no link exists, the method returns a -1.

The following routines from the LinksCollection can be used to navigate through the links in the dbiSchedule control:

Method | Parameters | Returns | Description
LinksFrom | dbiTimeBarItem and an Integer representing the index of the link | dbiTimeBarItem | Determines the time bar where a given time bar is the destination of the link.
LinksFromCount | dbiTimeBarItem (link destination time bar) | Integer | Determines the number of links for which a given time bar is the destination.
LinkIndex | dbiTimeBarItem (link source time bar) and dbiTimeBarItem (link destination time bar) | Integer | Determines the index value of a link based upon two time bars.
LinksTo | dbiTimeBarItem and an Integer representing the index of the link | dbiTimeBarItem | Determines the time bar where a given time bar is the source of the link.
LinksToCount | dbiTimeBarItem (link source time bar) | Integer | Determines the number of links for which a given time bar is the source.


%%ItemTitle%%

Developing with DBISchedule - Extending UndoRedo Functionality

Glossary Item Box

Extending the Undo/Redo Feature

The dbiSchedule control includes built-in Undo/Redo functionality to assist the developer in providing Undo/Redo functionality in their applications. The control contains two collections; UndoHistory and RedoHistory to record user interaction with the objects in the control. The following actions are logged by the history collections:

  • Creating a Time Bar

  • Moving a Time Bar

  • Sizing a Time Bar

  • Erasing a Time Bar

  • Linking a Time Bar

  • Unlinking a Time Bar

The standard version of the control maintains only the last action performed. The Enterprise version of the control can record as many actions as the control's HistorySize property (the larger the value the more actions can be recorded).

By default, every time a time bar in the control is created, deleted, moved, sized, split, or linked using the mouse, an entry is created in the controls history collection to record that action. That history collection is then used for the undo/redo feature. However, if the action is executed as the result of code that action is not recorded in the history collection. The history collection includes a dbiHistoryItem class to allow the developer to maintain programmatic actions for Undo/Redo in the same fashion as user actions. The dbiHistoryItem class is comprised of the following.

ActionType - determines the type of action that is taking place

Type: Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType

BarIndex - determines the index value of the bar where the action is occurring.

Type: Integer

End - determines the ending time of a time bar.

Type: DateTime

Group - an internal number to identify the sequence where the action takes place. This number should not be directly manipulated. The methods used by the programmer to add a history object to the control will do that for them.

Type: Integer

Link - determines the link object between the time bars.

Type: dbiLinkItem

ScheduleItem - Determines the schedule item for the action

Type: dbiScheduleItem

ScheduleItemTo - Determines the schedule item for the action. This is only required if the moving of a time bar involves more than one schedule item (i.e. a vertical move).

Type: dbiScheduleItem

Start - determines the starting time of a time bar.

Type: DateTime

TimeBar - Determines the time bar source for the action.

Type: dbiTimeBarItem

TimeBarTo - Determines the time bar destination for the action. This is for internal use only and should not be used by the developer.

Type: dbiTimeBarItem

Programmatically Adding a Time Bar

The following example illustrate the programmatic addition of time bar to an item and the programmatic reflection of that action in the dbiHistory collection.

[VB.NET]

Dim objHistory As New Dbi.WinControl.Schedule.dbiHistoryItem

Dim objTimebar As New Dbi.WinControl.Schedule.dbiTimeBarItem

' Create a TimeBar

objTimebar.Start = New DateTime(2007, 5, 23, 2, 0, 0)

objTimebar.End = New DateTime(2007, 5, 23, 4, 0, 0)

' Add the TimeBar to an item

DbiSchedule1.Items(1).TimeBars.Add(objTimebar)

'Reflect the action in the History Collection

' Set the action type

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Create

' The schedule item for the history object is the same as the

' schedule item we added the time bar to.

objHistory.ScheduleItem = DbiSchedule1.Items(1)

' Record the time bar

objHistory.TimeBar = objTimebar

' Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory)

[C#]

Dbi.WinControl.Schedule.dbiHistoryItem objHistory = new Dbi.WinControl.Schedule.dbiHistoryItem();

Dbi.WinControl.Schedule.dbiTimeBarItem objTimebar = new Dbi.WinControl.Schedule.dbiTimeBarItem();

// Create a general time bar

objTimebar.Start = new DateTime(2007, 5, 23, 2, 0, 0);

objTimebar.End = new DateTime(2007, 5, 23, 4, 0, 0);

// In this case, we know what schedule item we adding the time bar to

DbiSchedule1.Items[1].TimeBars.Add(objTimebar);

// Set the action type

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Create;

// The schedule item for the history object is the same as the

// schedule item we added the time bar to.

objHistory.ScheduleItem = DbiSchedule1.Items[1];

// Record the time bar

objHistory.TimeBar = objTimebar;

// Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory);

Moving or Changing a Time Bar

The following example illustrates the programmatic moving/sizing of time bar and the programmatic reflection of that action in the dbiHistory collection.

NOTE: For the most part, moving or sizing a time bar are the same actions. The only time that it becomes essential that the proper action be specified is when the time bar is moving from one schedule item to another (vertical move).

[VB.NET]

Dim objHistory As New Dbi.WinControl.Schedule.dbiHistoryItem

Dim objTimebar As New Dbi.WinControl.Schedule.dbiTimeBarItem

Dim objScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

Dim objScheduleItemTo As New Dbi.WinControl.Schedule.dbiScheduleItem

Dim dtStartTime As DateTime

Dim dtEndTime As DateTime

' Record the original start and end time of the time bar before the action.

dtStartTime = objTimeBar.Start

dtEndTime = objTimeBar.End

' Make the change to the time bar (move or resize)

' Set the action type

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Move
     --OR--

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Size

' Record the original start time for the bar

objHistory.Start = dtStartTime

' Record the original end time for the bar

objHistory.End = dtEndTime

' Record the original schedule item where the time bar started

objHistory.ScheduleItem = objScheduleItem

' Record the destination schedule item where the time bar is being moved to.

' NOTE: This step is only required the time bar is being moved vertically.

objHistory.ScheduleItemTo = objScheduleItemTo

' Record the time bar being moved/resized

objHistory.TimeBar = objTimebar

' Add the history object to the history collectionn

DbiSchedule1.AddHistoryItem(objHistory)

[C#]

Dbi.WinControl.Schedule.dbiHistoryItem objHistory = new Dbi.WinControl.Schedule.dbiHistoryItem();

Dbi.WinControl.Schedule.dbiTimeBarItem objTimebar = new Dbi.WinControl.Schedule.dbiTimeBarItem();

Dbi.WinControl.Schedule.dbiScheduleItem objScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

Dbi.WinControl.Schedule.dbiScheduleItem objScheduleItemTo = new Dbi.WinControl.Schedule.dbiScheduleItem();

DateTime dtStartTime;

DateTime dtEndTime;

// Record the original start and end time of the time bar before the action.

dtStartTime = objTimeBar.Start;

dtEndTime = objTimeBar.End;

// Make the change to the time bar (move or resize)

// Set the action type

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Move;

    -- or --

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Size;

// Record the original start time for the bar

objHistory.Start = dtStartTime;

// Record the original end time for the bar

objHistory.End = dtEndTime;

// Record the original schedule item where the time bar started

objHistory.ScheduleItem = objScheduleItem;

// Record the destination schedule item where the time bar is being moved to.

// NOTE: This step is only required the time bar is being moved vertically.

objHistory.ScheduleItemTo = objScheduleItemTo;

// Record the time bar

objHistory.TimeBar = objTimebar;

// Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory);

Removing a Time Bar

The following example illustrates the programmatic reflection of a time bar removal (deletion) in the dbiHistory collection.

[VB.NET]

Dim nBar As Integer

Dim objItem As New Dbi.WinControl.Schedule.dbiScheduleItem

' Set the action type to Remove

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Remove

' Record the index value of the bar being removed

objHistory.BarIndex = nBar

' Record the actual time bar being removed

objHistory.TimeBar = objItem.TimeBars(nBar)

' Record the schedule item from which the bar is being removed

objHistory.ScheduleItem = objItem

' Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory)

[C#]

int nBar;

Dbi.WinControl.Schedule.dbiScheduleItem objItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

// Set the action type to Remove

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Remove;

// Record the index value of the bar being removed

objHistory.BarIndex = nBar;

// Record the actual time bar being removed

objHistory.TimeBar = objItem.TimeBars[nBar];

// Record the schedule item from which the bar is being removed

objHistory.ScheduleItem = objItem;

// Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory);

Linking a Time Bar

The following example illustrates the programmatic reflection of a linking action in the dbiHistory collection.

[VB.NET]

Dim objItemFrom As New Dbi.WinControl.Schedule.dbiTimeBarItem

Dim objItemTo As New Dbi.WinControl.Schedule.dbiTimeBarItem

Dim objLink As New Dbi.WinControl.Schedule.dbiLinkItem

objItemFrom = ' Your source time bar

objItemTo = ' Your destination time bar

objLink = new dbiLinkItem(objItemFrom, objItemTo)

' Set the action type to Link

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Link

' Record the link object

objHistory.Link = objLink

' Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory)

[C#]

Dbi.WinControl.Schedule.dbiTimeBarItem objItemFrom = new Dbi.WinControl.Schedule.dbiTimeBarItem();

Dbi.WinControl.Schedule.dbiTimeBarItem objItemTo = new Dbi.WinControl.Schedule.dbiTimeBarItem();

Dbi.WinControl.Schedule.dbiLinkItem objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

objItemFrom = //Your source time bar

objItemTo = //Your destination time bar

objLink = new dbiLinkItem(objItemFrom, objItemTo);

// Set the action type

objHistory.ActionType = Dbi.WinControl.Schedule.dbiHistoryItem.enumActionType.Link;

// Record the link object

objHistory.Link = objLink;

// Add the history object to the history collection

DbiSchedule1.AddHistoryItem(objHistory);

Adding many items to the same group number

In the above discussion the examples have focused on reflecting a single action in the dbiHistory collection. It is important to note that when the Undo method is called a single action will be undone. To link multiple actions together to execute them as one Undo action, the dbiHistory class implements a group number. By default, the group number is automatically incremented each time the AddHistoryItem method is executed. The developer however has the option of overriding the default behavior of the AddHistoryItem method by executing the first action as described above and then setting the second parameter to False for all subsequent actions in the group which results in each action receiving the same group number as the first, creating a group of actions that are managed as one Undo action.

// Add multiple actions to the history collection

DbiSchedule1.AddHistoryItem(objHistory1)

- OR -

DbiSchedule1.AddHistoryItem(objHistory1, True)

// All further calls must set the second parameter to false

DbiSchedule1.AddHistoryItem(objHistory2, False)

DbiSchedule1.AddHistoryItem(objHistory3, False)

DbiSchedule1.AddHistoryItem(objHistory4, False)


%%ItemTitle%%

Developing with DBISchedule - User Drawn Functionality

Glossary Item Box

User Drawn Functionality

The dbiSchedule “User Drawn” functionality allows the developer to take control of the painting of specific areas within the List area and the Schedule area of the control. User Drawn functionality is surfaced through 10 different objects in the control …

NOTE: Only the Enterprise version of dbiSchedule contains User Drawn functionality marked with an asterisk (*).

User Drawn Node: A static item painted in the List area of the control representing a node item in the list. NOTE: Any individual, combination, or all of the nodes in the list can be user drawn.

User Drawn Cell: A static item painted in a given column and item in an item in the List area of the control. NOTE: Any cell in the list area can be user drawn and an item can contain any combination of user drawn and control drawn cells.

User Drawn Column Header: A static item painted in a given column in the header of the List area of the control. NOTE: The List Header can contain any combination of user drawn and control drawn column headers.

User Drawn Title: A static item painted at the top of the List area of the control.

*User Drawn List Scroll area: A static item painted at the bottom of the List area of the control, replacing the scroll bar display.

*User Drawn Header: A static item painted through the list and schedule area at the top of the control below the list title and ruler (time line). NOTE: The User Drawn Header does not scroll when the vertical scroll bar is moved. NOTE: The User Drawn Header is not reflected in the Map Area of the control.

*User Drawn Footer: A static item painted through the list and schedule area at the bottom of the control above the horizontal scroll bars. NOTE: The User Drawn Footer does not scroll when the vertical scroll bar is moved. NOTE: The User Drawn Footer is not reflected in the Map Area of the control.

*User Drawn Line: Rendered in the dbiSchedule Items collection(s) to provide custom painting of the rectangle inside the schedule area of the control. NOTE: A User Drawn Line does not allow for custom painting in the List area of the control (see User Drawn Node).

* User Drawn Link Line: Rendered at the time a dbiLinkItem is drawn in the control, allowing the developer to customize the appearance of the dbiLinkItem in the display.

*User Drawn Time Bar: Rendered at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.

*User Drawn Ruler Title: A static item painted across the top of the ruler when the schedule object’s SplitRuler property is set to true. NOTE: If the schedule object’s SplitRuler property is set to false a Ruler Title is not presented in the control.

*User Drawn Ruler: A static item painted at the top of the schedule object.

* User Drawn Ruler Segment: Rendered as parts of an additional row in the ruler portion of a dbiScheduleObject.

* User Drawn WaterMark: Rendered after the control has finished drawing the schedule area, allowing the developer to further customize the final display.

* User Drawn Custom Area: Rendered at the point a custom area is drawn to provide custom painting of the custom area display. NOTE: Any custom area can be “User Drawn” and the control (or an item) can contain any combination of user drawn and control drawn custom areas.

IMPORTANT NOTE: Instructive examples of all the UserDrawn functionality can be found in the ProductManager - Demos – Timebar Options, Time Types, User Drawn List, User Drawn Schedule , and User Drawn Timebar.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Nodes

Glossary Item Box

User Drawn Node

A User Drawn Node allows the developer to take over complete control of the node item presentation in the List area. It can be used to inject interactive presentation or provide alternate UI to the default presentation of a list node item.

The User Drawn Node event fires before a node is painted. The event passes an e argument that contains the following custom properties …

· e.Graphics (of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e.NodeItem (of type dbiNodeItem): The dbiNodeItem that will be drawn.

· e.PaintNode (of type Boolean): Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.

· e.Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. . In the UserDrawnNode event the e.Rect object represents the Node Item area to be painted in the List area.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Cells

Glossary Item Box

User Drawn Cell

A User Drawn Cell allows the developer to take over complete control of the presentation of any individual cell in any column in any item in the List area. The User Drawn Cell is ideal for implementing UI in a cell that is outside of the default presentation offered in the List area.

The UserDrawnCell event is fired before a cell is painted. The event handler receives an argument of type UserDrawnCellEventArgs containing the following data related to this event:

· e.ColumnIndex (of type Integer): The zero-based index of the dbiColumnItem where the cell is being drawn.

· e.ColumnItem(of type Dbi.WinControl.dbiColumnItem): The dbiColumnItem where the cell is being drawn.

· e.Graphics(of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e.NodeItem(of type Dbi.WinControl.dbiNodeItem): The dbiNodeItem that contains the cell being drawn.

· e.PaintCell(of type Boolean): Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.

· e. Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Column Headers

Glossary Item Box

User Drawn Column Header

A User Drawn Column Header allows the developer to take over complete control of the presentation of any or all of the column headers in the List area to provide an alternate presentation to that available by default in the control.

The UserDrawnColumnHeader event is fired before a column header is painted. The event handler receives an argument of type UserDrawnColumnHeaderEventArgs containing the following data related to this event:

· e.ColumnIndex (of type Integer): The zero-based index of the dbiColumnItem where the header is being drawn.

· e.ColumnItem (of type Dbi.WinControl.dbiColumnItem): The dbiColumnItem where the header is being drawn.

· e.Graphics(of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e.PaintHeader(of type Boolean): Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.

· e.Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control.

· e.Status(of type Dbi.WinControl.enumColHeaderStatus): Determines the current status of the header column in the display.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Title

Glossary Item Box

User Drawn Title

A User Drawn Title allows the developer to customize the default presentation of the Title in the List area.

The UserDrawnTitle event is fired before the Title in the List area is painted. The event passes an e argument with the following custom properties …

· e.Graphics(of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e.PaintTitle(of type Boolean): Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.

· e.Rect(of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control.


%%ItemTitle%%

Developing with DBISchedule - User Drawn List Scroll Area

Glossary Item Box

User Drawn List Scroll area

The User Drawn List Scroll area allows the developer to take over complete control of the presentation of the area where the horizontal scrollbar would have been rendered in the List Area.

The UserDrawnListScrollArea event is fired after the List Scroll area is painted with the ListScrollBackColor property. The event handler receives an argument of type UserDrawnListScrollAreaEventArgs containing the following data related to this event:

· e.Graphics (of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the List Scroll area. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e. Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Header

Glossary Item Box

User Drawn Header

A User Drawn Header is ideal for summarizing the activity of all the schedule items as whole, independent of list item headers, items, and time bar detail. A User Drawn Header might also be used to “brand” the contents of the schedule control with corporate logos, schedule information, etc. For example, in a schedule that represented a series of projects running concurrently, a UserDrawnHeader might be used to illustrate the status of all the projects contained in the schedule detail.

To implement a user drawn header set the dbiSchedule.HeaderLine property to “True”. NOTE: The HeaderLine property can be set in design time using the property inspector or at runtime in code.

When the HeaderLine property is set to true the control fires a UserDrawnHeader event when the control is painted or repainted to allow the developer to custom code the contents of the UserDrawn area. The event is fired once for the list area, and once for each ScheduleObject visible in the schedule area. The UserDrawnHeader event is used by the developer to code the drawing routines specific to each area within the UserDrawnHeader area.

The UserDrawnHeader event passes an “e” argument (event argument) that contains the following custom properties:

· e.Graphics (of type System.Drawing.Graphics): A graphics handle to the custom area provided to the developer within the header area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device. NOTE: The e.Graphics handle is different for each area in the header (List/Schedule).

· e.ListArea (of type Boolean): Reports True if UserDrawnHeader event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnHeader event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.

· e.Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnHeader event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnHeader Event fires once for each area in the header to be painted; the List, and each ScheduleObject visible in the schedule area of the control.

· e.LineStart (of type System.Date): This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.

· e.ScheduleObject( of type Dbi.WinControl.Schedule.dbiScheduleObject): This property provides a handle back to the ScheduleObject being painted in the schedule area of the control. NOTE: If the Schedule area of the control contains more than one visible ScheduleObject, the UserDrawnHeader event fires once for each visible ScheduleObject. The developer can custom code the painting of each area based on the e.ScheduleObject parameter.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Footer

Glossary Item Box

User Drawn Footer

A UserDrawnFooter is ideal for summarizing the activity of all the schedule items as whole, independent of list item headers, items, and time bar detail and / or providing intstruction to user regarding the contents of the schedule control. For example in a staff scheduling implementation the UserDrawnFooter could be used to illustrate the “coverage” or number of persons scheduled per hour for each hour in the schedule.

To implement a UserDrawnFooter set the dbiSchedule.FooterLine property to “True”. NOTE: This can be set in design time using the property inspector or at runtime in code.

When the FooterLine property is set to true the control fires a UserDrawnFooter event when the control is painted or repainted to allow the developer to custom code the contents of the UserDrawn area. The event is fired once for the list area, and once for each ScheduleObject visible in the schedule area. The UserDrawnFooter event is used by the developer to code the drawing routines specific to each area within the UserDrawnFooter.

The UserDrawnFooter event passes an “e” argument (event argument) that contains the following custom properties:

· e.Graphics (of type System.Drawing.Graphics): A graphics handle to the custom area provided to the developer within the footer area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device. NOTE: The e.Graphics handle is different for each area in the footer (List/Schedule).

· e.ListArea (of type Boolean): Reports True if the UserDrawnFooter event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnFooter event is being fired when the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.

· e.Rect(of type System.Drawing.Rectangle): A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnFooter event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnFooter Event fires once for each area in the footer to be painted; the list, and each ScheduleObject visible in the schedule area of the control.

· e.LineStart(of type Date): This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.

· e.ScheduleObject(of type Dbi.WinControl.Schedule.dbiScheduleObject): This property provides a handle back to the ScheduleObject being painted in the schedule area of the control. NOTE: If the Schedule area of the control contains more than one visible ScheduleObject, the UserDrawnFooter event fires once for each visible ScheduleObject. The developer can custom code the painting of each area based on the e.ScheduleObject parameter.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Line

Glossary Item Box

User Drawn Line

A User Drawn Line provides the developer a custom painting area within the body of the schedule items inside the schedule area of the control and within the map area of the control. User Drawn Lines behave the same as standard items and scroll with the movement of the vertical scroll bar, as opposed to the UserDrawnHeader or UserDrawnFooter areas which are static within the control viewing area.

A User Drawn Line is a standard dbiScheduleItem with its UserDrawn property set to True. This indicates to the control that the region being painted in the visible schedule area will be handled by the developer and causes the control to raise a UserDrawnLine Event in which the developer can take control of the custom painting of the item in the schedule area. NOTE: If the developer does not wish to allow the user to interact with the item’s Time Bar collection then the dbiScheduleitems ReadOnly property should be set to True. For each dbiScheduleItem with its UserDrawn property set to true the control fires a UserDrawnLine Event for each ScheduleObject visible in the schedule area of the control. Additionally, if the MapArea of the control is visible, the UserDrawnLine Event is fired once for each ScheduleObject in the Schedules collection of the control while painting the map area.

The UserDrawnLine event passes the following parameters within its e argument:

· e.Graphics (of type System.Drawing.Graphics): A graphics handle to the custom area provided to the developer within the schedule area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device. NOTE: The e.Graphics handle is different for each area reported in the event (schedule area and map area).

· e.LineStart (of type Date): This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area or map area of the control.

· e.MapArea (of type Boolean): Reports True if UserDrawnLine event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnLine event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.

· e.Rect (of type System.Drawing.Rectangle): A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnLine event the e.Rect object represents the item area to be drawn in schedule area specific to the ScheduleObject being drawn when the e.MapArea property is False (i.e. the control is painting the schedule area of the control), or the item area within the map area to be painted specific to the ScheduleOjbect being painted.

· e.ScheduleItem (of type Dbi.WinControl.Schedule.dbiScheduleItem): This property provides a handle back to the dbiScheduleItem being painted. The developer can read or interract with the properties of the item such as its text, backcolor, etc. within the UserDrawnLine event.

· e.ScheduleObject (of type Dbi.WinControl.Schedule.dbiScheduleObject): This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control. NOTE: The UserDrawnLine event fires once for each ScheduleObject visible in the Schedule area of the control. If the Map Area of the control is visible, the UserDrawnLine event fires once for each ScheduleObject in the control’s Schedules collection when painting the Map Area of the control.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Time Bars

Glossary Item Box

User Drawn Time Bar

A User Drawn Time Bar provides the developer an opportunity to take over the painting of any or all time bars in the dbiSchedule control. User Drawn Time Bars behave the same as standard time bars and scroll with the movement of the vertical and horizontal scroll bars.

The drawing of any time bar causes the dbiSchedule control to fire the UserDrawnBar Event before they are painted. If no code is placed in the event, all time bars will be drawn in accordance with their associated style, or in the absence of a style, in accordance with dbiSchedule TimeBar properties (i.e. .TimeBarBackColor, .TimeBarBackColorTo, .TimeBarFillType, etc.).

To override the control’s drawing of a time bar the developer is provided with two properties in the e argument of the UserDrawnBar Event; e.PaintBar and e.PaintText. Setting these properties to False cancels the control’s painting of the time bar’s rectangle and text properties and allows the developer to implement their own custom drawing code.

The UserDrawnBar event passes the following parameters within its e argument:

· e.BarIndex (of type Integer): The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.

· e.Graphics (of type System.Drawing.Graphics): A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device. NOTE: The e.Graphics handle is different for each area reported in the event (schedule area of the control or map area of the control).

· e.MapArea (of type Boolean): Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.

· e.PaintBar (of type Boolean): Indicates to the control if the internal PaintBar routine is to be used to paint the Time Bar. When the e.PaintBar property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar.

· e.PaintText (of type Boolean): Indicates to the control if the internal PaintText routine is to be used to paint the Time Bar Text. When the e.PaintText property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar Text.

· e.Rect (of type System.Drawing.Rectangle): A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.

· e.ScheduleItem (of type Dbi.WinControl.Schedule.dbiScheduleItem): This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..

· e.ScheduleObject (of type Dbi.WinControl.Schedule.dbiScheduleObject): This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control. NOTE: The UserDrawnBar event fires once for each ScheduleObject in the visible Schedule Area for which the Time Bar being drawn is eligible for rendering (based on the start and end of the time bar relative to the ScheduleObject’s start and end). If the Map Area of the control is visible, the UserDrawnBar event fires once for each ScheduleObject in the control’s Schedules collection for which the Time Bar is elgible for rendering when painting the Map Area of the control.

· e.TimeBarItem (of type Dbi.WinControl.Schedule.dbiTimeBarItem): This property provides a handle back to the dbiTimeBarItem being rendered in the control.

In addition to the UserDrawnBar event there is also a UserDrawnBarAfter event and a UserDrawnTimeBars event.

The UserDrawnBarAfter event will fire after each timebar is drawn in the control (drawn either by the control or by the developer using the UserDrawnBar event) and will provide that timebar as a canvas to work with in the e.graphics property of the event arguments. This can be used in combination with the UserDrawnBar event. For example, you can set the e.PaintText = False in the UserDrawnBar event, then create your own icons and text that fit inside the timebar in the UserDrawnBarAfter event.

The UserDrawnTimeBars event fires after all other drawing has completed. This event receives all dbiTimeBarItems that were marked to be UserDrawn (PaintBar= false) in the UserDrawnBar event. This event allows the developer to draw the dbiTimeBarItems overtop of all existing objects in the control. Changes to the size or location of the dbiTimeBarItems can be reported back to the control (by making changes to the values of the respective TimeBars.Rect property). This will allow users to properly interact with the newly moved/resized display of the TimeBar.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Link Line

Glossary Item Box

User Drawn Link Line

The User Drawn Link Line event allows the developer to customize the default appearance of each individual dbiLinkItem presented by the control.

The UserDrawnLinkLine event fires whenever a portion of the dbiLinkItem is within the visible area of a dbiScheduleObject being rendered in the control. The event passes an e argument with the following custom properties …

· e.Graphics (of type System.Drawing.Graphics): A handle to the Graphics object responsible for the drawing.

· e.LinkItem (of type Dbi.WinControl.Schedule.dbiLinkItem): The dbiLinkItem being drawn.

· e.PaintLinkLine (of type Boolean): Determines if the control should draw the dbiLinkItem with the default appearance.

· e.PointFrom(of type System.Drawing.Point): The starting coordinate of the dbiLinkItem in the display.

· e.PointTo (of type System.Drawing.Point): The ending coordinate of the dbiLinkItem in the display.

· e.Printing (of type Boolean): Determines if the event is being raised by the printing routines.

· e.ScheduleItemFrom (of type Dbi.WinControl.Schedule.dbiScheduleItem): The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem begins.

· e.ScheduleItemTo (of type Dbi.WinControl.Schedule.dbiScheduleItem): The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem ends.

· e.ScheduleObject (of type Dbi.WinControl.Schedule.dbiScheduleObject): The dbiScheduleObject where the dbiLinkItem is being drawn.

· e.TimeBarFrom (of type Dbi.WinControl.Schedule.dbiTimeBarItem): The dbiTimeBarItem where the dbiLinkItem begins.

· e.TimeBarTo (of type Dbi.WinControl.Schedule.dbiTimeBarItem): The dbiTimeBarItem where the dbiLinkItem ends.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Ruler Title

Glossary Item Box

User Drawn Ruler Title

A User Drawn Title allows the developer to customize the default Ruler Title text presented by the control.

The UserDrawnRulerTitle event fires before the Ruler Title is painted. The event passes an e argument containing the following custom properties …

· e.DateTime(of type System.DateTime): The Date value to be written in the title area.

· e.ScheduleObject (of type Dbi.WinControl.Schedule.dbiScheduleObject): The dbiScheduleObject whose ruler title is being drawn.

· e.Text (of type Text): The text that will be displayed in the ruler title.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Ruler

Glossary Item Box

User Drawn Ruler

The User Drawn Ruler along with the ValuePoint event allows the developer to customize the default ruler presented by the control.

The UserDrawnRuler event fires twice before the Ruler is fully painted in each schedule object. If the FirstDraw property is True, the background of the ruler hasn't been painted yet. If the FirstDraw property is False, the event is firing for a second time after all the text and lines have been drawn in the ruler area. The event passes an e argument with the following custom properties …

· e.End (of type System.DateTime): The End value of the visible portion of the ruler.

· e.FirstDraw (of type Boolean): Determines if the event is firing before painting the background of the ruler.

· e.Graphics(of type System.Drawing.Graphics): A handle to the Graphics object responsible for the drawing.

· e.Rect(of type System.Drawing.Rectangle): The rectangle representing the size and location of the ruler.

· e.ScheduleObject (of type Dbi.WinControl.Schedule.dbiScheduleObject): The dbiScheduleObject whose ruler is being drawn.

· e.Start(of type System.DateTime): The Start value of the visible portion of the ruler.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Ruler Segment

Glossary Item Box

User Drawn Ruler Segment

The User Drawn Ruler Segment event allows the developer to customize the appearance of each individual segment is drawn in the middle row of the ruler. The DisplayUserDrawnRulerSegments Property must be set to true for the customizable row to be drawn in the ruler of the dbiScheduleObject

The UserDrawnRulerSegment event fires for each segment displayed in the ruler (the segments correlate to each of the visible major time units in the bottom portion of the ruler. The event passes an e argument with the following custom properties …

· e.DateTime (of type DateTime): The DateTime value of the segment.

· e.Font (of type Font): The Font the control will use to draw text in the segment.

· e.ForeColor (of type Color): The color the control will use to draw text in the segment.

· e.Graphics (of type System.Drawing.Graphics): A handle to the Graphics object responsible for the drawing.

· e.Rect (of type Rectangle): The rectangle representing the size and location of the ruler segment in the ruler.

· e.Schedule (of type Dbi.WinControl.Schedule.dbiScheduleObject): The dbiScheduleObject that the ruler and ruler segment belong to.

· e.Segment (of type Integer): The index of the current segment being drawn.

· e.SegmentWidth (of type Integer): The current width of the segment being drawn.

· e.Text (of type String): The text string the control should draw within the segment in the ruler.

· e.TextAlign (of type ContentAlignment): The alignment of the text when rendered by the control within the ruler segment..


%%ItemTitle%%

Developing with DBISchedule - User Drawn WaterMark

Glossary Item Box

User Drawn WaterMark

The User Drawn WaterMark event allows the developer to add some additional enhancements to the display of the control after it has finished drawing its contents.

The UserDrawnWaterMark Event fires after the schedule area has finished drawing in the control, or after the output of a schedule area on a page in a printed report has been generated. The event passes an e argument with the following custom properties …

· e.Graphics(of type System.Drawing.Graphics): A handle to the Graphics object responsible for the drawing.

· e.PaintWaterMark (of type Boolean): Determines if the control should still generate the WaterMark based on the associated properties.

· e.Printing (of type Boolean): Determines if the event is being raised during the printing process..

· e.ScheduleAreaRect (of type System.Drawing.Rectangle): The rectangle representing the size and location of the Schedule area of the control.


%%ItemTitle%%

Developing with DBISchedule - User Drawn Custom Areas

Glossary Item Box

User Drawn Custom Area

A User Drawn Custom Area allows the developer to take over complete control of the presentation of any individual custom area rendered within the schedule area. The User Drawn Custom Area is ideal for implementing additional visual elements to the standard Custom Area display, such as text or images.

The UserDrawnCustomArea event is fired before a Custom Area is painted. The event handler receives an argument of type UserDrawnCustomAreaEventArgs containing the following data related to this event:

· e.CustomArea (of type Dbi.PIM.dbiCustomArea): The dbiCustomArea being drawn.

· e.Graphics (of type System.Drawing.Graphics): A handle to the graphics object responsible for drawing the Custom Area. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.

· e.MapArea (of type Boolean): Determines if the Custom Area is currently being drawn in the map area.

· e.PaintArea (of type Boolean): Determines if the internal routines of the control should draw the Custom Area. When the PaintArea property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Custom Area.

· e. Rect (of type System.Drawing.Rectangle): A rectangle representing the area being painted in the control.

· e.ScheduleItem (of type Dbi.WinControl.dbiNodeItem): The dbiScheduleItem where the Custom Area is being drawn.

· e.ScheduleObject (of type Dbi.WinControl.dbiNodeItem): The dbiScheduleObject where the Custom Area is being drawn.


%%ItemTitle%%

Developing with DBISchedule - GuideLines

Glossary Item Box

Working with Guide Lines

Guide Lines are vertical lines used to represent specific times in a schedule. Guide lines provide the user with discrete “snap-to” functionality making it easier to position time bars.

Guide lines enhance the process of creating and maintaining a schedule. Guide lines are not intended to be included in the static display functionality of the schedule and accordingly they have certain limitations. Guide lines are not rendered in a print or print preview report, and are not part of the Undo/Redo functionality.

Adding Guide Lines to the Schedules

Guide lines are assigned to a specific schedule object. Therefore, if the user wants to display a guide line in multiple schedules for a specific time the guide line must be created for each schedule object in which it is to appear. There are two ways to add a guide line to a schedule …

1.) User Interaction: Set the EditMode property of the control to GuideLine. Click a point on the schedule. On the OnMouseUp event, the new guide line will be created.

2.) Programmatically: Create a dbiGuideLine object through code and assign it to a schedule. For example…

objGuideLine = New Dbi.WinControl.Schedule.dbiGuideLine

objGuideLine.LineTime = New DateTime(nYear, nMonth, nDay, 4, 8, 0)

DbiSchedule1.Schedules(nSchedule).GuideLines.Add(objGuideLine)

When a guide line is added with the mouse a BeforeGuideLineInsert and AfterGuideLineInserted event will be fired by the dbiSchedule control. These events can be used to validate the action and optionally prevent the guide line from being inserted, and to set the appearance of the guide line.

Changing the Position of a Guide Line

The position of a guide line in a schedule is based on the DateTime value assigned to the LineTime property of the dbiGuideLine object. Changing the position of a guide line can be achieved in one of three ways ...

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally in the schedule. On the OnMouseUp event, the guide line will be set at its new position and time. NOTE: To move the guideline inside the schedule area the EditMode must be set to GuideLine.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line the image appears in the ruler area. Click and drag the image horizontally in the ruler to change its time. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine.

3.) Programmatically: Change the value of the LineTime property of the dbiGuideLine object through code. For example …

dtTime = new DateTime( Year, nMonth, nDay, nHour, nMinute, 0 )

DbiSchedule1.Schedules(nSchedule).GuideLines(nLine) = dtTime

When a guide line is moved with the mouse a BeforeGuideLineMove and AfterGuideLineMoved event will be fired. The “Before” event can be used to validate and optionally prevent the guide line from being moved. NOTE: As a guide line is being moved with the mouse, the GuideLineMove event will be firing.

Removing Guide Lines from the Schedules

Guide lines can be removed from a Schedule Object in one of three ways …

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally off of the schedule. On the OnMouseUp event, the guide line will be removed.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line, click and drag the image horizontally off of the schedule. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine

3.) Programmatically: Remove the guide line through code. For example ...

DbiSchedule1.Schedules(nSchedule).GuideLines(nLine) = dtTime

When a guide line is being removed with the mouse a BeforeGuideLineRemove and AfterGuideLineRemoved event will be fired. The “Before” event can be used to validate the action and optionally prevent the guide line from being removed.

Adding Images to a Guide Line

Each guide line can be assigned an image that is rendered in the ruler section of the control. By default the image will be vertically aligned to the bottom of the ruler and horizontally aligned so that the middle of the image is on top of the guide line. The position can be changed though the image offset properties of the GuidelIne object. NOTE: It is possible to display an image for a time line inside the actual schedule instead of the ruler area however this is NOT a recommended practice as the logic for the guide line images assumes they are within the ruler area of the schedule. Unpredictable results may occur by placing them elsewhere. To add an image to a guide line perform the following …

1.) Add an image list control to the form containing the dbiSchedule control. Assign the Guide Line images to the image list.

2.) Assign the image list control to the GuideImages property of the dbiSchedule control instance.

3.) To set the default image for all Guide Lines in the dbiSchedule control, assign the index value of an image in the Image list to the GuideImageIndex property of the dbiSchedule control. After that, all guide lines will use that image unless the ImageIndex property of a dbiGuideLine object is set discretely to the index value of a different image in the ImageList object. Setting the ImageIndex property of a Guide Line overrides any default image assigned to the guide lines.

Snapping a Time Bar to a Guide Line

To cause time bars to be snapped to a guide line, the SnapToGuideLines property of the dbiSchedule control must be set to True. As one end of a time bar approaches a guide line the edge of the time bar will become aligned with the guide line. The distance at which the time bar is “snapped” to the guide line is determined in pixels and is defined in the GuideLineDistance property of the dbiSchedule control. The maximum value for the GuideLineDistance property is 10.

When a time bar is “snapped” to a guide line, it is assigned the actual time of that guide line. For example, if a guide line is set to 1:13:15 (1 hour, 13 minutes, 15 seconds), when a time bar is snapped to the guide line, its beginning (or end depending on the proximity of the guide line) will be set to the 1:13:15 setting.

NOTE : Because the Snap to Guide Lines feature is based on pixels, a time bar will only snap to a guide line that is visible within the schedule object. If a guide line is not visible in the schedule object the time bar will not snap to its value.

NOTE : Working with GuideLines and SnapToGrid... please be aware that if you have snap-to-grid enabled with snap-to-guidelines, be sure to synchronize the guidelines to the GridFrequency. If the guidelines fall too close to the GridFrequency but not exactly then there may be issues related to the drawing of the timebars as they attempt to position themselves to accommodate both values.


%%ItemTitle%%

Developing with DBISchedule - Schedule Notes

Glossary Item Box

Schedule Item Notes

The Enterprise version of the dbiSchedule control includes Schedule Notes functionality to allow the developer to embed notes in the schedule object area of the control to assist the user in creating and maintaining efficient and effective schedules.

Schedule Notes are represented with an image. The developer has the option of using the built in image

Default Notes Image

or assigning a custom image

Schedule NotesImages Property

from the ImageList assigned in the NoteImages property of the control.

Custom Notes Image

Notes can be rendered specific to a date and time or locked to one or all schedule objects.

Schedule Note Alignment

When a Note is locked to one or all schedule objects, the developer must specify a value for the alignment of the Note within the item. This insures that the Note is always displayed in the the area of the Schedule Object being viewed.

To have a Note appear in all schedule objects set the Schedule property of the Note to Nothing. To have a Note appear in only one Schedule Object, set the Note's Schedule property to the Schedule Object in which the Note is to be displayed and optionally set the Locked and ImageAlignment properties.

NOTE: If the Note object is set to a specific schedule without having its Locked property set to true, the Note will only be rendered at the date and time assigned to its NoteTime property.

To automatically render the text of the Note in a tooltip when the user hovers the mouse over a Note, set the dbiScheduleE's TipsOnNotes property to true.

For an example of how to programmatically manipulate the Schedule Item Note object, please refer to the Schedule Notes sample that can be found via the Solutions::Schedule for .NET Enterprise Product Manager ... Samples/Demos tab.

IMPORTANT: Notes are not rendered in the Map Area or in the dbiScheduleE Print functionality.


%%ItemTitle%%

Developing with DBISchedule - Reading and Writing XML Data

Glossary Item Box

The dbiSchedule control is capable of reading and writing XML data. The data can be read and written as a string into or from memory, or to and from a file. The control is also capable of creating XML data for the entire control, or from a specific class.

The use of XML makes it easy to create a snapshot of the current state of the control, save it, and then reload it again at a later time. XML support also makes it easy to send an XML file to another instance of the object (user, application, etc.) to restore the state of one instance into another.

Reading and Writing an XML File

The dbiSchedule control contains a ReadXMLFile method and a WriteXMLFile method. A valid XML file can be read from a local drive, a mapped drive, or from a valid URL. NOTE: XML files can not be written to a URL, they can only be written to a local or mapped drive.

The Schedules, Items, Columns, Links, TimeBarStyles, and CustomAreas collections of the dbiSchedule control each have their own WriteXMLFile method. Unlike the main WriteXMLFile for the control, these methods will only create a file based on the data in the collection (i.e. no control properties are included).

Example:

Create a file of all data in the control and a file of just the time bar links.

[VB.NET]

DbiSchedule1.WriteXMLFile("C:\ScheduleXML.xml") 'Create a file C:\ScheduleXML.xml containing all the data in the control

DbiSchedule1.Links.WriteXMLFile("C:\LinksXML.xml") 'Create a file C:\LinksXML containing just the list time bar links data

[C#]

this.DbiSchedule1.WriteXMLFile("C:\\ScheduleXML.xml"); //Create a file C:\ScheduleXML.xml containing all the data in the control

this.DbiSchedule1.Links.WriteXMLFile("C:\\LinksXML.xml"); //Create a file C:\LinksXML containing just the list time bar links data

NOTE: The collections do not contain a method to read an XML file. The ReadXMLFile method from the main control is capable of determining the type of data being read and load it appropriately.

Example:

Read XML data for the control regardless of the dbiSchedule control method used to create it.

[VB.NET] 'Read an XML file

DbiSchedule1.ReadXMLFile("C:\ScheduleXML.xml")

[C#]

this.dbiSchedule1.ReadXMLFile("C:\\ScheduleXML.xml");

Reading and Writing XML Strings

The dbiSchedule control contains an XMLString property. This property is capable of of being used to read and write data for the control in an XML format. The Schedules, Items, Columns, Links, TimeBarStyles, and CustomAreas collections also contain an XMLString property. NOTE: The XMLString property for the collections is read only, that is they can be read to ascertain the state of the data being held in the collection. These properties cannot be written to in order to set their values. Just like the ReadXMLFile method, the XMLString property for the dbiSchedule control is used to read any and all types of XML for the control.

Reading and Writing XML Files at Design Time

One of the benefits of the XML functionality built into the dbiSchedule control is the ability to read and write XML files at design time. This can be very useful in instances where a control is being upgraded from one version to another (i.e. save the properties, upgrade, and then load in the new control), or to share control styles between developers.

The property window for the dbiSchedule includes an XMLRead property and an XMLWrite property. When a character string is entered into one of these fields, an Open (XMLRead) or Save File (XMLWrite) dialog will appear to allow the developer to specify the path to read or write an XML file. NOTE: The XMLWrite property will only write data for the entire control (i.e. not individual collection data).

Write Many, Read Once

This refers to the fact as explained above that there are a variety of methods to write an XML file or get an XML string, but there is only one way to read XML into the dbiSchedule control. To write or get XML data, the developer can use a method or property directly from the control as whole (all data) or from the individual collection that is storing the pertinent data.

The data created by any of the write methods will contain the proper header identifying the type of data in the XML string. This header is used by the ReadXMLFile method or the XMLString property of the main control to identify the type of data being loaded and apply it appropriately.

NOTE: When data for the entire control is read, all collection data for the control is cleared in anticipation of the new data. If data for a collection only is read, the collection being updated will not be cleared. Data for an individual collection will be appended to the data currently stored in the collection. It is the responsibility of the developer to clear a collection before loading the collection specific XML data.

Reading ctSchedule OCX XML Files

The dbiSchedule control will accept XML files created with the ctSchedule OCX (ActiveX) control. It should be noted that the Activex and .NET controls do contain architectural differences, and not all data is compatible. Approximately 85% of the data from the ActiveX control will be accepted by the .NET version of the control. This feature was added to assist developers in migrating from the ActiveX version of the control to the .NET version.

To migrate the "look and feel" from an ActiveX instance to a .NET instance, create an XML file from the formatted ActiveX instance. Import the ActiveX XML file into the .NET instance in design mode (see above). Most of the properties in the .NET version will be set to a similar state as those in the ActiveX version. NOTE: The developer may be required to tweak some of the properties in the .NET instance to achieve the final desired result.

NOTE: An important item to consider when importing XML data from an ActiveX instance is the date formatting properties in the ActiveX control. The differences between COM and .NET with respect to data types, especially dates requires that the developer pay special attention to formatting the date values in a fashion that can be easily read into a .NET environment. (See section on Date Formatting and Internationalization for more details)


%%ItemTitle%%

Support Policy

Glossary Item Box

Please see the support website at http://www.dbi-tech.com/SupportPolicies.aspx for information on our support policies and plans, or visit our FAQ at http://www.dbi-tech.com/Support/FAQ/default.aspx


%%ItemTitle%%

Product License and Transfers

Glossary Item Box

Product Ownership

The ownership of the product license is automatically registered to the contact and company noted at the time of purchase. To transfer ownership of the license from one organization to another please contact DBI Sales at sales@dbi-tech.com with the license transfer details.

Registered Developers

Site Licenses:

Product Site Licenses allow for the activation of the product license on all developer machines at the named location specified at the time of purchase.

Individual Developer Licenses:

DBI's policy allows for the registered developer to activate the license on up to two machines simultaneously for their use only.

Developer Licenses

Developer Licenses are registered to the email address submitted at the time of license activation. To transfer a developer license from one developer email to another, please use the Online Transfer facility found in the related dbi Product Manager.

IMPORTANT NOTE: Online Transfer Facilities are only available to licenses with a current subscription.

DBI Technologies Inc.

http://www.dbi-tech.com

204-985-5770

800-670-8045 (sales)

204-943-0738 (fax)

sales@dbi-tech.com

700 – 44 Princess Street

Winnipeg, Manitoba

Canada, R3B 1K2


%%phrase%%

Dbi4 Assembly
DBI Base Assembly Version 4

Namespaces

Namespace | Description
Dbi |
Dbi.WinControl |

Remarks

© DBI Technologies Inc. All Rights Reserved.


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started


$$INTRODUCTION$$ - %%projecttitle%%

Introduction


%%PageItemTitle%% $$Properties$$

AfterCellEditEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterCellEditEventArgs Class

"

For a list of all members of this type, see AfterCellEditEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The index of the column where the edit occurred.
public Property | ColumnItem | The dbiColumnItem where the cell is located
public Property | Key | The Key code and modifiers that were pressed to end the edit session
public Property | NodeItem | The dbiNodeItem that contains the cell that was edited.
public Property | Text | The text that was assigned back to the cell.
Top

See Also

Reference

AfterCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

AfterColumnSortEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterColumnSortEventArgs Class

"

For a list of all members of this type, see AfterColumnSortEventArgs members.

"

Public Properties

 | Name | Description
public Property | Columns | An array of columns in the order in which the sort is to occur. See Sort Method
Top

See Also

Reference

AfterColumnSortEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

AfterNodeCollapseEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeCollapseEventArgs Class

"

For a list of all members of this type, see AfterNodeCollapseEventArgs members.

"

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | NodeItem | The dbiNodeItem that was collapsed.
Top

See Also

Reference

AfterNodeCollapseEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

AfterNodeExchangeEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExchangeEventArgs Class

"

For a list of all members of this type, see AfterNodeExchangeEventArgs members.

"

Public Properties

 | Name | Description
public Property | NodeItemSource | The node item that was dragged.
public Property | NodeItemTarget | The node item that received the drop.
Top

See Also

Reference

AfterNodeExchangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

AfterNodeExpandEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeExpandEventArgs Class

"

For a list of all members of this type, see AfterNodeExpandEventArgs members.

"

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | NodeItem | The dbiNodeItem that was expanded.
Top

See Also

Reference

AfterNodeExpandEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

AfterNodeSelectEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : AfterNodeSelectEventArgs Class

"

For a list of all members of this type, see AfterNodeSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that was selected.
Top

See Also

Reference

AfterNodeSelectEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeCellEditEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellEditEventArgs Class

"

For a list of all members of this type, see BeforeCellEditEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowEdit | Determines if the edit is allowed
public Property | ColumnIndex | The zero-based index of the column where the cell exists.
public Property | ColumnItem | The dbiColumnItem where the cell exists.
public Property | ComboBox | The ComboBox that will be used to edit values in the cell.
public Property | Height | The height of the cell to edit.
public Property | NodeItem | The dbiNodeItem that contains the cell to edit.
public Property | Text | The current text of the cell.
public Property | TextBox | The TextBox that will be used to edit values in the cell.
public Property | Width | The width of the cell to edit.
public Property | X | The X coordinate of the cell to edit.
public Property | Y | The Y coordinate of the cell to edit.
Top

See Also

Reference

BeforeCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeCellTextDisplayEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeCellTextDisplayEventArgs Class

"

For a list of all members of this type, see BeforeCellTextDisplayEventArgs members.

"

Public Properties

 | Name | Description
public Property | CellFormat | The dbiCellFormat that was applied to the cell that contains the text.
public Property | CellText | The text that will be displayed in the cell
public Property | ColumnIndex | The zero-based index of the column where the cell exists.
public Property | ColumnItem | The dbiColumnItem where the cell exists.
public Property | Font | The font that will be used to drawn the cell's text.
public Property | NodeItem | The dbiNodeItem that contains the cell.
public Property | NodeLevel | Returns the zero-based level within the nested structure that the node containing the cell exists.
public Property | TextAlignment | Determines the horizontal/vertical alignment of the text within the cell.
public Property | TextColor | Determines the color of the text in the cell.
Top

See Also

Reference

BeforeCellTextDisplayEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeColumnSortEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeColumnSortEventArgs Class

"

For a list of all members of this type, see BeforeColumnSortEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSort | Indicate wether or not to proceed with the Sort. To cancel the sort set e.AllowSort = False in the BeforeColumnSort Event.
public Property | Columns | An array of columns in the order in which the sort is to occur. See Sort Method
Top

See Also

Reference

BeforeColumnSortEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeNodeCollapseEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeCollapseEventArgs Class

"

For a list of all members of this type, see BeforeNodeCollapseEventArgs members.

"

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | AllowCollapse | Determines if the node will be collapsed.
public Property | NodeItem | The dbiNodeItem being collapsed.
Top

See Also

Reference

BeforeNodeCollapseEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeNodeExchangeEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExchangeEventArgs Class

"

For a list of all members of this type, see BeforeNodeExchangeEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowNodeExchange | Determines if the exchange will be allowed
public Property | NodeItemSource | The node item being dragged.
public Property | NodeItemTarget | The node item receiving the drop
Top

See Also

Reference

BeforeNodeExchangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeNodeExpandEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeExpandEventArgs Class

"

For a list of all members of this type, see BeforeNodeExpandEventArgs members.

"

Public Properties

 | Name | Description
public Property | Action | An enumerated value indicating the action against the control that triggered the event.
public Property | AllowExpand | Determines if the node will be expanded.
public Property | NodeItem | The dbiNodeItem being expanded.
Top

See Also

Reference

BeforeNodeExpandEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

BeforeNodeSelectEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : BeforeNodeSelectEventArgs Class

"

For a list of all members of this type, see BeforeNodeSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the node will be selected.
public Property | NodeItem | The dbiNodeItem that will be selected.
public Property | X | The X coordinate where the selection is occurring
public Property | Y | The Y coordinate where the selection is occurring.
Top

See Also

Reference

BeforeNodeSelectEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

CellFormatCollection Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CellFormatCollection Class

"

For a list of all members of this type, see CellFormatCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiCellFormat object to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index value (integer) for the supplied dbiCellFormat.
public Method | Insert | Insert a dbiCellFormat Item into the collection in a specified nIndex location.
public Method | Remove | Remove the specified dbiCellFormat Item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Export the CellFormats to an XML file specified by strFileName
public Method | XMLString | Converts the CellFormat Collection to an XML string.
Top

See Also

Reference

CellFormatCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

CellFormatCollection Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CellFormatCollection Class

"

For a list of all members of this type, see CellFormatCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | The object which contains the dbiCellFormat Item.
Top

See Also

Reference

CellFormatCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

IndexOf Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > CellFormatCollection Class : IndexOf Method

Returns the index value (integer) for the supplied dbiCellFormat. Returns the index value of a given dbiCellFormat

Overload List

Overload | Description
IndexOf | Returns the index value (integer) for the supplied dbiCellFormat.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

CellFormatCollection Class
CellFormatCollection Members


%%PageItemTitle%% $$Properties$$

ChangeEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ChangeEventArgs Class

"

For a list of all members of this type, see ChangeEventArgs members.

"

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that has been selected.
Top

See Also

Reference

ChangeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

CheckEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : CheckEventArgs Class

"

For a list of all members of this type, see CheckEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The index value of the dbiColumnItem where the check occurred.
public Property | NodeItem | The dbiNodeItem where the check occurred.
Top

See Also

Reference

CheckEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

ColumnEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnEventArgs Class

"

For a list of all members of this type, see ColumnEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mousebutton that was used in the event.
public Property | ColumnIndex | The index of the column where the event occurred.
Top

See Also

Reference

ColumnEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

ColumnItemCollection Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnItemCollection Class

"

For a list of all members of this type, see ColumnItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a column item to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the integer index value of the dbiColumnItem Class from the collection.
public Method | Insert | Insert a dbiColumnItem Class into the collection in a specified nIndex location.
public Method | Remove | Remove the specified dbiColumnItem Class from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Export the Columns to an XML file specified by strFileName.
public Method | XMLString | Converts the Column Collection to an XML string.
Top

See Also

Reference

ColumnItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

ColumnItemCollection Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ColumnItemCollection Class

"

For a list of all members of this type, see ColumnItemCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | The object which contains the dbiColumnItem Class.
Top

See Also

Reference

ColumnItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

IndexOf Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > ColumnItemCollection Class : IndexOf Method

Returns the integer index value of the dbiColumnItem Class from the collection. Returns the integer index value of the dbiColumnItem Class from the collection.

Overload List

Overload | Description
IndexOf | Returns the integer index value of the dbiColumnItem Class from the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ColumnItemCollection Class
ColumnItemCollection Members


%%PageItemTitle%% $$Properties$$

dbiCellFormat Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiCellFormat Class

"

For a list of all members of this type, see dbiCellFormat members.

"

Public Properties

 | Name | Description
public Property | AlignmentOffset | Determines the vertical and horizontal offset values used to calculate the position of the text/image.
public Property | BackColor | Determines the background color of a cell.
public Property | BackColorTo | Determines the secondary background color of a cell.
public Property | Column | Determines the column to apply the format.
public Property | DateFormat | Defines how DateTime values are formatted and displayed in the cell, depending on the culture.
public Property | FillType | Determines the fill pattern of a cell.
public Property | Font | Determines the font of a cell.
public Property | ForeColor | Determines the forecolor of a cell.
public Property | ImageAlign | Determines the vertical and horizontal alignment of an image in a cell.
public Property | ImageIndex | Determines the image to place in a cell.
public Property | TextAlign | Determines the vertical and horizontal alignment of the text in a cell.
public Property | XMLString | Determines an Xml string to read the data or write the data to the cell.
Top

See Also

Reference

dbiCellFormat Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

dbiColumnFormat Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnFormat Class

"

For a list of all members of this type, see dbiColumnFormat members.

"

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the column.
public Property | BackColorTo | Determines the secondary background color of the column.
public Property | CheckAlign | Determines the alignment of the check box in the column.
public Property | CheckBox | Determines the style of the checkbox to use in the column.
public Property | DateFormat | Defines how DateTime values are formatted and displayed in each cell of the column, depending on the culture.
public Property | FillType | Determines the fill pattern of the column.
public Property | Font | Determines the font of the column.
public Property | ForeColor | Determines the forecolor of the column.
public Property | ImageAlign | Determines the vertical and horizontal alignment of the image in the column.
public Property | TextAlign | Determines the vertical and horizontal alignment of the text in the column.
public Property | WordWrap | Determines if the text in the column will wrap.
public Property | XMLString | Determines an Xml string to read the data or write the data.
Top

See Also

Reference

dbiColumnFormat Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

dbiColumnItem Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnItem Class

"

For a list of all members of this type, see dbiColumnItem members.

"

Public Methods

 | Name | Description
public Method | SetXMLValues | Sets the properties of the dbiColumnItem, based on the supplied XmlNodeList.
Top

See Also

Reference

dbiColumnItem Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

dbiColumnItem Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiColumnItem Class

"

For a list of all members of this type, see dbiColumnItem members.

"

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the column header.
public Property | BackColorTo | Determines the secondary background color of the column header.
public Property | DataType | Determines the data type to assign to the column.
public Property | EditType | Determines the type of edit control to be used when editing cells in the column.
public Property | FillType | Determines the fill pattern of the column header.
public Property | ForeColor | Determines the forecolor of the column header.
public Property | Format | Determines a format for the column in the list.
public Property | ImageAlign | Determines the alignment of the image in the column.
public Property | ImageIndex | Determines the column header image.
public Property | Items | Determines the list of items used to populate a combo box that belongs to this column
public Property | LockWidth | Determines if the column can be resized.
public Property | ReadOnly | Determines if the column is readonly.
public Property | Sortable | Determines if the column is sortable.
public Property | Text | The column header text.
public Property | TextAlign | Determines the alignment of the column header
public Property | Visible | Determines if the column is visible.
public Property | Width | Determines the width of the column.
public Property | XMLString | Determines an Xml string to read the data or write the data.
Top

See Also

Reference

dbiColumnItem Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Events$$

dbiComboBox Class Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiComboBox Class

"

For a list of all members of this type, see dbiComboBox members.

"

Public Events

 | Name | Description
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DataSourceChanged | Occurs when the System.Windows.Forms.ListControl.DataSource changes. (Inherited from System.Windows.Forms.ListControl)
public Event | DisplayMemberChanged | Occurs when the System.Windows.Forms.ListControl.DisplayMember property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DrawItem | Occurs when a visual aspect of an owner-drawn System.Windows.Forms.ComboBox changes. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDown | Occurs when the drop-down portion of a System.Windows.Forms.ComboBox is shown. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDownClosed | Occurs when the drop-down portion of the System.Windows.Forms.ComboBox is no longer visible. (Inherited from System.Windows.Forms.ComboBox)
public Event | DropDownStyleChanged | Occurs when the System.Windows.Forms.ComboBox.DropDownStyle property has changed. (Inherited from System.Windows.Forms.ComboBox)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Format | Occurs when the control is bound to a data value. (Inherited from System.Windows.Forms.ListControl)
public Event | FormatInfoChanged | Occurs when the value of the System.Windows.Forms.ListControl.FormatInfo property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | FormatStringChanged | Occurs when value of the System.Windows.Forms.ListControl.FormatString property changes (Inherited from System.Windows.Forms.ListControl)
public Event | FormattingEnabledChanged | Occurs when the value of the System.Windows.Forms.ListControl.FormattingEnabled property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MeasureItem | Occurs each time an owner-drawn System.Windows.Forms.ComboBox item needs to be drawn and when the sizes of the list items are determined. (Inherited from System.Windows.Forms.ComboBox)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SelectedIndexChanged | Occurs when the System.Windows.Forms.ComboBox.SelectedIndex property has changed. (Inherited from System.Windows.Forms.ComboBox)
public Event | SelectedValueChanged | Occurs when the System.Windows.Forms.ListControl.SelectedValue property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | SelectionChangeCommitted | Occurs when the user changes the selected item and that change is displayed in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextUpdate | Occurs when the control has formatted the text, but before the text is displayed. (Inherited from System.Windows.Forms.ComboBox)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | ValueMemberChanged | Occurs when the System.Windows.Forms.ListControl.ValueMember property changes. (Inherited from System.Windows.Forms.ListControl)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiComboBox Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

dbiComboBox Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiComboBox Class

"

For a list of all members of this type, see dbiComboBox members.

"

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BeginUpdate | Maintains performance when items are added to the System.Windows.Forms.ComboBox one at a time. (Inherited from System.Windows.Forms.ComboBox)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EndUpdate | Resumes painting the System.Windows.Forms.ComboBox control after painting is suspended by the System.Windows.Forms.ComboBox.BeginUpdate method. (Inherited from System.Windows.Forms.ComboBox)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | FindString | Overloaded. Returns the index of the first item in the System.Windows.Forms.ComboBox that starts with the specified string. (Inherited from System.Windows.Forms.ComboBox)
public Method | FindStringExact | Overloaded. Finds the first item in the combo box that matches the specified string. (Inherited from System.Windows.Forms.ComboBox)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetItemHeight | Returns the height of an item in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | GetItemText | Returns the text representation of the specified item. (Inherited from System.Windows.Forms.ListControl)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.ComboBox)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | Select | Overloaded. Selects a range of text in the editable portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | SelectAll | Selects all the text in the editable portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Returns a string that represents the System.Windows.Forms.ComboBox control. (Inherited from System.Windows.Forms.ComboBox)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiComboBox Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

dbiComboBox Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiComboBox Class

"

For a list of all members of this type, see dbiComboBox members.

"

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoCompleteCustomSource | Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.ComboBox.AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.ComboBox)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.ComboBox)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DataSource | Gets or sets the data source for this System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayMember | Gets or sets the property to display for this System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | DrawMode | Gets or sets a value indicating whether your code or the operating system will handle drawing of elements in the list. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownHeight | Gets or sets the height in pixels of the drop-down portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownStyle | Gets or sets a value specifying the style of the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | DroppedDown | Gets or sets a value indicating whether the combo box is displaying its drop-down portion. (Inherited from System.Windows.Forms.ComboBox)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | FlatStyle | Gets or sets the appearance of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | Focused | Gets a value indicating whether the System.Windows.Forms.ComboBox has focus. (Inherited from System.Windows.Forms.ComboBox)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.ComboBox)
public Property | FormatInfo | Gets or sets the System.IFormatProvider that provides custom formatting behavior. (Inherited from System.Windows.Forms.ListControl)
public Property | FormatString | Gets or sets the format-specifier characters that indicate how a value is to be displayed. (Inherited from System.Windows.Forms.ListControl)
public Property | FormattingEnabled | Gets or sets a value indicating whether formatting is applied to the System.Windows.Forms.ListControl.DisplayMember property of the System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items. (Inherited from System.Windows.Forms.ComboBox)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemHeight | Gets or sets the height of an item in the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | Items | Gets an object representing the collection of the items contained in this System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | MaximumSize | Gets or sets the size that is the upper limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify. (Inherited from System.Windows.Forms.ComboBox)
public Property | MaxLength | Gets or sets the number of characters a user can type into the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | MinimumSize | Gets or sets the size that is the lower limit that the System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) method can specify. (Inherited from System.Windows.Forms.ComboBox)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PreferredHeight | Gets the preferred height of the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | SelectedIndex | Gets or sets the index specifying the currently selected item. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedItem | Gets or sets currently selected item in the System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedText | Gets or sets the text that is selected in the editable portion of a System.Windows.Forms.ComboBox. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectedValue | Gets or sets the value of the member property specified by the System.Windows.Forms.ListControl.ValueMember property. (Inherited from System.Windows.Forms.ListControl)
public Property | SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | SelectionStart | Gets or sets the starting index of text selected in the combo box. (Inherited from System.Windows.Forms.ComboBox)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | Sorted | Gets or sets a value indicating whether the items in the combo box are sorted. (Inherited from System.Windows.Forms.ComboBox)
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.ComboBox)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | ValueMember | Gets or sets the path of the property to use as the actual value for the items in the System.Windows.Forms.ListControl. (Inherited from System.Windows.Forms.ListControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiComboBox Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

CreateControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Dispose Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Dispose Method

Releases the unmanaged resources used by the System.Windows.Forms.ComboBox and optionally releases the managed resources.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

FindString(String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > FindString Method : FindString(String) Method

s
The System.String to search for.
Returns the index of the first item in the System.Windows.Forms.ComboBox that starts with the specified string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim s As System.String
Dim value As System.Integer

value = instance.FindString(s)
C#
public System.int FindString(
   System.string s
)

Parameters

s
The System.String to search for.

Return Value

The zero-based index of the first item found; returns -1 if no match is found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

FindString(String,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > FindString Method : FindString(String,Int32) Method

s
The System.String to search for.
startIndex
The zero-based index of the item before the first item to be searched. Set to -1 to search from the beginning of the control.
Returns the index of the first item in the System.Windows.Forms.ComboBox beyond the specified index that contains the specified string. The search is not case sensitive.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim s As System.String
Dim startIndex As System.Integer
Dim value As System.Integer

value = instance.FindString(s, startIndex)
C#
public System.int FindString(
   System.string s,
   System.int startIndex
)

Parameters

s
The System.String to search for.
startIndex
The zero-based index of the item before the first item to be searched. Set to -1 to search from the beginning of the control.

Return Value

The zero-based index of the first item found; returns -1 if no match is found, or 0 if the s parameter specifies System.String.Empty.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The startIndex is less than -1.-or- The startIndex is greater than the last index in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

FindStringExact(String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > FindStringExact Method : FindStringExact(String) Method

s
The System.String to search for.
Finds the first item in the combo box that matches the specified string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim s As System.String
Dim value As System.Integer

value = instance.FindStringExact(s)
C#
public System.int FindStringExact(
   System.string s
)

Parameters

s
The System.String to search for.

Return Value

The zero-based index of the first item found; returns -1 if no match is found, or 0 if the s parameter specifies System.String.Empty.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

FindStringExact(String,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > FindStringExact Method : FindStringExact(String,Int32) Method

s
The System.String to search for.
startIndex
The zero-based index of the item before the first item to be searched. Set to -1 to search from the beginning of the control.
Finds the first item after the specified index that matches the specified string.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim s As System.String
Dim startIndex As System.Integer
Dim value As System.Integer

value = instance.FindStringExact(s, startIndex)
C#
public System.int FindStringExact(
   System.string s,
   System.int startIndex
)

Parameters

s
The System.String to search for.
startIndex
The zero-based index of the item before the first item to be searched. Set to -1 to search from the beginning of the control.

Return Value

The zero-based index of the first item found; returns -1 if no match is found, or 0 if the s parameter specifies System.String.Empty.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The startIndex is less than -1.-or- The startIndex is equal to the last index in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

PerformLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

ResumeLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Scale Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members


%%PageItemTitle%%

Select() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Select Method : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

Select(Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > Select Method : Select(Int32,Int32) Method

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.
Selects a range of text in the editable portion of the System.Windows.Forms.ComboBox.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim start As System.Integer
Dim length As System.Integer

instance.Select(start, length)
C#
public void Select(
   System.int start,
   System.int length
)

Parameters

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.

Exceptions

Exception | Description
System.ArgumentException | The start is less than zero.-or- start plus length is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiComboBox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiComboBox
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiComboBox Class
dbiComboBox Members
Overload List


%%PageItemTitle%% $$Events$$

DbiListControl Class Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl Class

"

For a list of all members of this type, see DbiListControl members.

"

Public Events

 | Name | Description
public Event | AfterCellEdit | Event fired after the editing of a cell has completed.
public Event | AfterColumnSort | Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired after the actual sort is performed.
public Event | AfterNodeCollapse | Event fired after a parent node has collapsed (hiding its child nodes).
public Event | AfterNodeExchange | Event fired after a node has been internally dragged/dropped was moved.
public Event | AfterNodeExpand | Event fired after a parent node has expanded (showing its child nodes).
public Event | AfterNodeSelect | Event fired after a node has been selected.
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BeforeCellEdit | Event fired before a cell is placed into an editable state.
public Event | BeforeCellTextDisplay | Event fires before the text is drawn in each cell.
public Event | BeforeColumnSort | Event fired when the header of a column defined as sortable receives a left mouse click. NOTE: Event is fired BEFORE the actual sort is performed.
public Event | BeforeNodeCollapse | Event fired before a parent node is collapsed (child nodes will be hidden).
public Event | BeforeNodeExchange | Event fired before a node that has been internally dragged/dropped is moved.
public Event | BeforeNodeExpand | Event fired before a parent node is expanded (child nodes will be made visible).
public Event | BeforeNodeSelect | Event fired before a node is selected in the control.
public Event | BeforePaint | Event fired before the control has painted the list.
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | Change | Event fired when a list item is selected.
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | CheckClick | Event fired when a check box in the list is clicked.
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DisplayUserControl | Event fired before a cell is placed into edit mode, allowing the developer to prepare and display their own control for the editing process.
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DropList | Event fired when an item is dropped into the list.
public Event | EditInputKey | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyDown | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyPress | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell.
public Event | EditKeyUp | Event fired when a key is released inside the TextBox or ComboBox when editing a cell.
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HeaderClick | Event fired when the left mouse button clicks on a column header.
public Event | HeaderDoubleClick | Event fired when the left mouse button double clicks on a column header.
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InitializeCellEdit | Event fired before the cell edit operation is started
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | ItemLineHeightChanged | Event fired when the item height is changed.
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | ListMouseOver | Event fired when the mouse moves over a cell.
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | NodeClick | Event fired when the mouse clicks on a list item.
public Event | NodeDoubleClick | Event fired when the item is double-clicked.
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | RemoveUserControls | Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control.
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | UserDrawnCell | Event fired before a cell is drawn, allowing the developer to customize the display.
public Event | UserDrawnColumnHeader | Event fired before a column header is drawn, allowing the developer to customize the display.
public Event | UserDrawnNode | Event fired before a node is drawn, allowing the developer to customize the display.
public Event | UserDrawnTitle | Event fired before the title area is drawn, allowing the developer to customize the display.
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DbiListControl Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

DbiListControl Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl Class

"

For a list of all members of this type, see DbiListControl members.

"

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ColumnAt | Overloaded. Gets the dbiColumnItem at a specified location
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EnsureVisible | Method to move the visible portion of the control to ensure that the node item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate.
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetNodeLevel | Returns the zero-based level within the nested structure of a specified node.
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RestoreCell | Reset internal items required for the edit mode.
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollToNode | Attempts to make a specified dbiNodeItem visible in the list display.
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | Sort | Overloaded. Will sort the list based on the dbiListControl.SortColumn property.
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DbiListControl Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

DbiListControl Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DbiListControl Class

"

For a list of all members of this type, see DbiListControl members.

"

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowItemDrag | Determines if dbiNodeItems can be dragged and dropped within the list area.
public Property | AltColorEven | Determines the background color of an even numbered list item in the control.
public Property | AltColorOdd | Determines the background color of an odd numbered list item in the control.
public Property | AlternateColor | Determines whether or not the list items will be drawn with alternating background colors.
public Property | AlternateItems | Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd.
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | ArrowAlign | Determines on what side of a column header the sort arrows will be placed.
public Property | ArrowOffset | Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header.
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Determines the background color of the list items section.
public Property | BackgroundImage | Determines the background image for the control.
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BodyColumnEnd | Determines the final column for the body text in the items.
public Property | BodyColumnStart | Determines the starting column for the body text in the items.
public Property | BodyFont | Determines the font used to draw the body text of a item.
public Property | BodyForeColor | Determines the color used to paint the body text of an item.
public Property | BodyIndent | Determines the indent of the left margin spacing for the body text in the items.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | BreakChar | Determines the character used to delimit the text within the different columns.
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Columns | Gets the collection of columns.
public Property | ComboBox | Gets the current dbiComboBox control used for editing cells in the list.
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Culture | Determines information about a specific culture including the names of the culture, the writing system, and the calendar used, as well as access to culture-specific objects that provide information for common operations, such as formatting dates and sorting strings.
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Defines how DateTime values are formatted and displayed, depending on the culture.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayHeader | Determines whether or not the column headers will be displayed.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTitle | Determines whether or not the title will be displayed.
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | EditAutoNavigate | Determines if the control will automatically navigate to the next/previous cell when editing.
public Property | EditAutoSize | Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length.
public Property | EditColumn | Gets the dbiColumnItem relative to the current cell edit operation.
public Property | EditNode | Gets the dbiNodeItem that contains the cell being edited.
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | FillList | Determines whether the last column in a list will always extend the the edge of the list.
public Property | FocusBorder | Determines if a focus line will be drawn around the selected dbiNodeItem when the control has focus.
public Property | FocusColor | Determines the color used to paint the focus border.
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Overridden. Determines the foreground color of the items.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderAlign | Determines how the text in the column headers will be aligned.
public Property | HeaderBackColor | Determines the background color of the column headers.
public Property | HeaderBackColorMiddle | Determines the middle back color of the column header allowing for greater readability with certain fill types.
public Property | HeaderBackColorTo | Determines the secondary background color of the column headers.
public Property | HeaderBorder | Determines the border type for the column headers.
public Property | HeaderDownColor | Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed.
public Property | HeaderFillType | Determines the pattern used to paint the background of the column headers.
public Property | HeaderFont | Determines the font used for the text in the column headers of the control.
public Property | HeaderForeColor | Determines the foreground color of the column headers.
public Property | HeaderHeight | Determines the height of the column headers.
public Property | HeaderImageOffset | Determines the value used to calculate the horizontal and vertical position of the images within the column headers.
public Property | HeaderOverColor | Determines the color used to paint background when the mouse pointer is over the column header.
public Property | HeaderStyle | Determines the style of the column header.
public Property | HeaderTextImageRelation | Determines how the column header position of text and image relate to each other.
public Property | HeaderTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the column headers.
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HorzGridColor | Determines the color of the horizontal grid lines.
public Property | HorzGridLines | Determines whether or not horizontal grid lines will be drawn between the items.
public Property | HorzGridWidth | Determines the width of the horizontal grid lines.
public Property | HorzScrollType | Determines the horizontal scrolling action for the list.
public Property | ImageCheckDisabled | Determines the image used to replace the stock check disabled state item image.
public Property | ImageCheckDown | Determines the image used to replace the stock check down state item image.
public Property | ImageCheckUp | Determines the image used to replace the stock check up state item image.
public Property | ImageList | The image list for the control.
public Property | ImageMinus | Determines the image used to replace the stock close node image.
public Property | ImagePlus | Determines the image used to replace the stock open node image.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InactiveBackColor | Determines the color used to paint the background of a selected item when the control no longer has focus.
public Property | InactiveForeColor | Determines the color used to paint the text of a selected item when the control no longer has focus.
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemBorder | Determines the border type for the node items.
public Property | ItemDragColor | Determines the color of the drag bar when an item is dragged inside the list area.
public Property | ItemDragHeight | Determines the height of the drag bar when an item is dragged inside the list area.
public Property | ItemHeaderBackColor | Determines the default background color of all Header Items in the list.
public Property | ItemHeaderForeColor | Determines the default foreground color of all Header Items in the list.
public Property | ItemHeightOffset | Determines the offset value used to calculate the height of the line items.
public Property | ItemHeightType | Determines how the line item heights are calculated.
public Property | LabelEdit | Determines if a cell will be put into edit mode automatically, if the user double clicks it.
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineColor | Determines the color of list/tree connector lines.
public Property | LineType | Determines the list/tree connector line type.
public Property | ListType | Determines how the node items will be drawn in the control.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LockLineHeight | Determines whether the line items can be resized with the mouse.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MultiSelect | Allow the list to utilize multi-select mode (using ctrl/click and shift/click).
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PlusMinusStyle | Determines the style used when rendering the Plus/Minus boxes on parent nodes.
public Property | PreColumnBackColor | Determines the background color of the pre-column section of a non-selected item.
public Property | PreColumnBackColorTo | Determines the secondary background color of the pre-column section of a non-selected item.
public Property | PreColumnBorder | Determines the type of border to place around the pre-column section of a non-selected item.
public Property | PreColumnFillType | Determines the pattern used to paint the background of the pre-column section.
public Property | PreColumnFont | Determines the font used for the text in the pre-column section.
public Property | PreColumnForeColor | Determines the text color of the pre-column section of a non-selected item.
public Property | PreColumnPicture | Determines the picture clip within the pre-column section.
public Property | PreColumnType | Determines the pre-column to be used on the list part of the control.
public Property | PreColumnWidth | Determines the width of the pre-column in the list.
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | PreSelectBackColor | Determines the background color of the pre-column section of a selected list item.
public Property | PreSelectBorder | Determines the type of border to place around the pre-column section of a selected list item.
public Property | PreSelectForeColor | Determines the type of border to place around the pre-column section of a selected list item.
public Property | PrintHeaderBackColor | Determines the background color of the header in a printed report.
public Property | PrintHeaderForeColor | Determines the text color of the header in a printed report.
public Property | PrintItemBackColor | Determines the background color of the item in a printed report.
public Property | PrintItemForeColor | Determines the text color of the item in a printed report.
public Property | PrintPageControl | Used to determine if the control should print using the colors as rendered in the form (true) or as described in the PrintItemBackColor Property and PrintItemForeColor Property (false). Default is true.
public Property | PrintTitleBackColor | Determines the background color of the title in a printed report.
public Property | PrintTitleForeColor | Determines the text color of the title in a printed report.
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | SelectedBackColor | Determines the background color of a selected list item.
public Property | SelectedBackColorTo | Determines the second background color of a selected list item.
public Property | SelectedBorder | Determines the type of border to place around the selected item.
public Property | SelectedBorderColor | Determines the border color of a selected item.
public Property | SelectedFillType | Determines the pattern used to paint the background of the selected item.
public Property | SelectedFont | Determines the font used to draw the text of a selected item.
public Property | SelectedForeColor | Determines the text color of a selected list item.
public Property | SelectedStyle | Determines how the selection will be applied to the selected node(s). See enumSelectedStyle Enumeration for values.
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SortArrows | Determines whether or not arrows indicating the direction of the sort order will be displayed in the column headers.
public Property | SortColumn | Determines the column whose data a sort will be performed on. See Sort Method for more information on sorting in the list.
public Property | SortDirection | Determines the direction a sort operation will perform.
public Property | Sorted | Determines whether or not the list is currently sorted.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TextAntiAlias | Determines if the text within the control will be rendered using the Anti Alias option.
public Property | TextBox | Gets the current dbiTextBox control used for editing cells in the list.
public Property | TitleAlign | Determines the alignment for the text within the title section.
public Property | TitleBackColor | Determines the background color of the title section.
public Property | TitleBackColorMiddle | Determines the middle back color of the title section allowing for greater readability with certain fill types.
public Property | TitleBackColorTo | Determines the secondary background color of the title setction.
public Property | TitleBorder | Determines the border type for the title section.
public Property | TitleFillType | Determines the pattern used to paint the background of the title section.
public Property | TitleFont | Determines the font used for the text in the title of the control.
public Property | TitleForeColor | Determines the text color of the title section.
public Property | TitleHeight | Determines the height of the title setction.
public Property | TitleImage | Determines the image for the title section.
public Property | TitleImageAlign | Determines the image alignment for the title section.
public Property | TitleText | Determines the text of the title area.
public Property | TitleTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the title.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TreeLevelIndent | Determines the indent used to offset the text of each level of child nodes.
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VertGridColor | Determines the color of the vertical grid lines.
public Property | VertGridLines | Determines whether or not to draw vertical grid lines between the columns.
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

DbiListControl Class
Dbi.WinControl Namespace


%%PageItemTitle%%

DbiListControl Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : DbiListControl Constructor

Creates a new instance of the dbiList control base class.

Overload List

Overload | Description
DbiListControl Constructor | Initializes a new instance of the class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

CreateControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Dispose Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Dispose Method

Dispose of the dbiListControl

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Base Implementation in Dispose


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

PerformLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

ResumeLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

Scale Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

Select Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class : Select Method

Activates the control.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > DbiListControl Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DbiListControl
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DbiListControl Class
DbiListControl Members
Overload List


%%PageItemTitle%% $$Methods$$

dbiNodeItem Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiNodeItem Class

"

For a list of all members of this type, see dbiNodeItem members.

"

Public Methods

 | Name | Description
public Method | Collapse | Closes a parent node so that the children are not visible.
public Method | EnsureVisible | Adjusts the vertical scroll bar to ensure the dbiNodeItem is visible in the list.
public Method | Expand | Expands a node so that the child nodes are visible.
public Method | ExpandAll | Expands all nodes of a given node including all layers of nodes under that node.
public Method | GetCellChecked | Gets the boolean value at a specific cell in the item.
public Method | GetCellFormat | Gets the dbiCellFormat assigned to a specific cell in the item.
public Method | GetCellInteger | Gets the integer value at a specific cell in the item.
public Method | GetCellText | Gets the text at a specific cell in the item.
public Method | GetNodeCount | Gets the number of children nodes of a item in the list.
public Method | IsVisible | Determines if a node is visible.
public Method | NextVisibleNode | Gets the next visible node.
public Method | NodeFullPath | Gets the node full path as a string.
public Method | PrevVisibleNode | Gets the previous visible node item.
public Method | SetCellChecked | Sets the boolean value at a specific cell in the item.
public Method | SetCellInteger | Sets the integer value at a specific cell in the item.
public Method | SetCellText | Sets the text of a specific cell.
public Method | Toggle | Toggle the node to either expand or collapse it.
Top

See Also

Reference

dbiNodeItem Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

dbiNodeItem Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiNodeItem Class

"

For a list of all members of this type, see dbiNodeItem members.

"

Public Properties

 | Name | Description
public Property | BackColor | Determines the background color of the node item.
public Property | BackColorTo | Determines the secondary background color of the node item.
public Property | Body | Determines the body text for the node item.
public Property | BodyVisible | Determines if the body text is visible for the node item.
public Property | Cargo | Determines a non-visible text value for the node item.
public Property | CellFormat | Gets or sets the cell format assigned to the node item.
public Property | Checked | Determines whether the node item is in a checked state.
public Property | Control | Gets or sets the name of the object containing the node.
public Property | Data | Gets or sets a non-visible integer value for the node item.
public Property | FillType | Gets or sets the background fill pattern of the node item based on the enumFillType Enumeration.
public Property | Font | Gets or sets the font of the node item.
public Property | ForeColor | Gets or sets the forecolor of the node.
public Property | FullPath | Gets the full path of the node in the list.
public Property | Header | Determines if the node item will act as a header.
public Property | HeaderBackColor | Determines the background color for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderBackColorTo | Determines the secondary background color for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderFillType | Determines the background fill pattern for the dbiNodeItem when it is marked as a Header item.
public Property | HeaderForeColor | Determines the foreground color for the dbiNodeItem when it is marked as a Header item.
public Property | HeightOffset | Gets or sets the vertical offset value used to calculate the height of the node.
public Property | HorzGridColor | Gets or sets the color of the horizontal grid line below the node item.
public Property | HorzGridWidth | Gets or sets the width of the horizontal grid line below the node item.
public Property | ImageAlign | Gets or sets the vertical and horizontal alignment of the image associated with the node.
public Property | ImageIndex | Gets or sets the image associated with the node. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.
public Property | ImageOffset | Determines the vertical and horizontal offset values used to calculate the position of the image associated with the node.
public Property | IsExpanded | Determines if the node item is expanded, displaying child nodes.
public Property | Item | Determines the node item at a specific location in the collection.
public Property | Items | This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections. Same as the nodes collection but included here for compatibility.
public Property | Level | Gets the current tree level of the dbiNodeItem.
public Property | LockHeight | Determines if the node height can be adjusted through user interaction.
public Property | Nodes | This property contains a collection of dbiNodeItem Class items that represent the children of the node. As each child node can belong to the collection of a parent node, you can extend the tree out for several generations by adding individual node items to each successive generation of items collections.
public Property | PageBreak | Sets the item as a pagebreak item causing the printer functions to start a new page after that item.
public Property | Parent | Determines the parent node of a given node item.
public Property | ReadOnly | Determines if the node is readonly.
public Property | Selected | Determines if a node item is selected.
public Property | SelectedImageIndex | Determines the image associated with the node when it is selected. This is based on the imagelist referenced by ImageList Property and references the ImageIndex for the image within the ImageList.
public Property | Subject | Determines the subject of the list item.
public Property | Tag | Determines the object that contains data about the control. This property can be used to attach a data row to the node for reference elsewhere or a custom class can be created and attached.
public Property | Text | Determines the node text.
public Property | XMLString | Sets or gets the XML based description of the node item.
Top

See Also

Reference

dbiNodeItem Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Events$$

dbiTextBox Class Events
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiTextBox Class

"

For a list of all members of this type, see dbiTextBox members.

"

Public Events

 | Name | Description
public Event | AcceptsTabChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.AcceptsTab property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | BorderStyleChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.BorderStyle property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the text box is clicked. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | HideSelectionChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.HideSelection property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | ModifiedChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.Modified property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | MultilineChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.Multiline property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | ReadOnlyChanged | Occurs when the value of the System.Windows.Forms.TextBoxBase.ReadOnly property has changed. (Inherited from System.Windows.Forms.TextBoxBase)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextAlignChanged | Occurs when the value of the System.Windows.Forms.TextBox.TextAlign property has changed. (Inherited from System.Windows.Forms.TextBox)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiTextBox Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

dbiTextBox Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiTextBox Class

"

For a list of all members of this type, see dbiTextBox members.

"

Public Methods

 | Name | Description
public Method | AppendText | Appends text to the current text of a text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Clear | Clears all text from the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | ClearUndo | Clears information about the most recent operation from the undo buffer of the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | Copy | Copies the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Cut | Moves the current selection in the text box to the Clipboard. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | DeselectAll | Specifies that the value of the System.Windows.Forms.TextBoxBase.SelectionLength property is zero so that no characters are selected in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetCharFromPosition | Retrieves the character that is closest to the specified location within the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetCharIndexFromPosition | Retrieves the index of the character nearest to the specified location. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetFirstCharIndexFromLine | Retrieves the index of the first character of a given line. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetFirstCharIndexOfCurrentLine | Retrieves the index of the first character of the current line. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetLineFromCharIndex | Retrieves the line number from the specified character position within the text of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPositionFromCharIndex | Retrieves the location within the control at the specified character index. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | Paste | Overloaded. Sets the selected text to the specified text without clearing the undo buffer. (Inherited from System.Windows.Forms.TextBox)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollToCaret | Scrolls the contents of the control to the current caret position. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Select | Overloaded. Selects a range of text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | SelectAll | Selects all text in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Returns a string that represents the System.Windows.Forms.TextBoxBase control. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Undo | Undoes the last edit operation in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiTextBox Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

dbiTextBox Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : dbiTextBox Class

"

For a list of all members of this type, see dbiTextBox members.

"

Public Properties

 | Name | Description
public Property | AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline System.Windows.Forms.TextBox control creates a new line of text in the control or activates the default button for the form. (Inherited from System.Windows.Forms.TextBox)
public Property | AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoCompleteCustomSource | Gets or sets a custom System.Collections.Specialized.StringCollection to use when the System.Windows.Forms.TextBox.AutoCompleteSource property is set to CustomSource. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoCompleteMode | Gets or sets an option that controls how automatic completion works for the System.Windows.Forms.TextBox. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoCompleteSource | Gets or sets a value specifying the source of complete strings used for automatic completion. (Inherited from System.Windows.Forms.TextBox)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BorderStyle | Gets or sets the border type of the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | CharacterCasing | Gets or sets whether the System.Windows.Forms.TextBox control modifies the case of characters as they are typed. (Inherited from System.Windows.Forms.TextBox)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Lines | Gets or sets the lines of text in a text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MaxLength | Gets or sets the maximum number of characters the user can type or paste into the text box control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Multiline | Gets or sets a value indicating whether this is a multiline System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PasswordChar | Gets or sets the character used to mask characters of a password in a single-line System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | PreferredHeight | Gets the preferred height for a text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ReadOnly | Gets or sets a value indicating whether text in the text box is read-only. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | ScrollBars | Gets or sets which scroll bars should appear in a multiline System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | ShortcutsEnabled | Gets or sets a value indicating whether the defined shortcuts are enabled. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.TextBox)
public Property | TextAlign | Gets or sets how text is aligned in a System.Windows.Forms.TextBox control. (Inherited from System.Windows.Forms.TextBox)
public Property | TextLength | Gets the length of text in the control. (Inherited from System.Windows.Forms.TextBoxBase)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseSystemPasswordChar | Gets or sets a value indicating whether the text in the System.Windows.Forms.TextBox control should appear as the default password character. (Inherited from System.Windows.Forms.TextBox)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary. (Inherited from System.Windows.Forms.TextBoxBase)
Top

See Also

Reference

dbiTextBox Class
Dbi.WinControl Namespace


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

CreateControl Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Dispose Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Dispose Method

Releases the unmanaged resources used by the System.Windows.Forms.TextBox and optionally releases the managed resources.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Paste() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Paste Method : Paste() Method

Replaces the current selection in the text box with the contents of the Clipboard.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Paste()
C#
public void Paste()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Paste(String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Paste Method : Paste(String) Method

text
The text to replace.
Sets the selected text to the specified text without clearing the undo buffer.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim text As System.String

instance.Paste(text)
C#
public void Paste(
   System.string text
)

Parameters

text
The text to replace.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

PerformLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

ResumeLayout() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Scale Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members


%%PageItemTitle%%

Select() Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Select Method : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

Select(Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > Select Method : Select(Int32,Int32) Method

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.
Selects a range of text in the text box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim start As System.Integer
Dim length As System.Integer

instance.Select(start, length)
C#
public void Select(
   System.int start,
   System.int length
)

Parameters

start
The position of the first character in the current text selection within the text box.
length
The number of characters to select.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The value of the start parameter is less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > dbiTextBox Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTextBox
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTextBox Class
dbiTextBox Members
Overload List


%%PageItemTitle%% $$Properties$$

DisplayUserControlEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DisplayUserControlEventArgs Class

"

For a list of all members of this type, see DisplayUserControlEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the editable cell exists.
public Property | ColumnItem | The dbiColumnItem where the editable cell exists.
public Property | Height | The height of the cell to be edited.
public Property | NodeItem | The dbiNodeItem that contains the cell to be edited.
public Property | Text | The current text of the cell to be edited.
public Property | Width | The width of the cell to be edited.
public Property | X | The X coordinate of the cell being edited.
public Property | Y | The Y coordinate of the cell to be edited.
Top

See Also

Reference

DisplayUserControlEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

DropListEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : DropListEventArgs Class

"

For a list of all members of this type, see DropListEventArgs members.

"

Public Properties

 | Name | Description
public Property | DragEvent | The DragEventArgs related to the Drag/Drop operation.
public Property | NodeItem | The dbiNodeItem where the drop operation occurred.
Top

See Also

Reference

DropListEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

EditInputKeyEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditInputKeyEventArgs Class

"

For a list of all members of this type, see EditInputKeyEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | Handled | A flag the developer can set to inform the control that the operation has been handled.
public Property | KeyData | The KeyData that triggered the event.
public Property | NodeItem | The dbiNodeItem that contains the cell being edited.
Top

See Also

Reference

EditInputKeyEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

EditKeyDownEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyDownEventArgs Class

"

For a list of all members of this type, see EditKeyDownEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyDownEvents | The EventArguments for the KeyDown event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyDown event has been processed yet.
Top

See Also

Reference

EditKeyDownEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

EditKeyPressEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyPressEventArgs Class

"

For a list of all members of this type, see EditKeyPressEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyPressEvents | The EventArguments for the KeyPress event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyPress event has been processed yet.
Top

See Also

Reference

EditKeyPressEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

EditKeyUpEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : EditKeyUpEventArgs Class

"

For a list of all members of this type, see EditKeyUpEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit control resides.
public Property | ColumnItem | The dbiColumnItem where the edit control resides.
public Property | KeyUpEvents | The EventArguments for the KeyUp event triggered by the edit control.
public Property | NodeItem | The dbiNodeItem containing the cell being edited.
public Property | Processed | Determines if the edit control's KeyUp event has been processed yet.
Top

See Also

Reference

EditKeyUpEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

InitializeCellEditEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : InitializeCellEditEventArgs Class

"

For a list of all members of this type, see InitializeCellEditEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowEdit | Determines if the edit process will be allowed.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the edit will take place.
public Property | ColumnItem | The dbiColumnItem where the edit will take place.
public Property | NodeItem | The dbiNodeItem where the edit will take place.
Top

See Also

Reference

InitializeCellEditEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

ItemEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ItemEventArgs Class

"

For a list of all members of this type, see ItemEventArgs members.

"

Public Properties

 | Name | Description
public Property | NodeItem | The dbiNodeItem that triggered the event
Top

See Also

Reference

ItemEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

ListMouseOverEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : ListMouseOverEventArgs Class

"

For a list of all members of this type, see ListMouseOverEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem being moused over.
public Property | NodeItem | The dbiNodeItem which the mouse is over
Top

See Also

Reference

ListMouseOverEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

NodeClickEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeClickEventArgs Class

"

For a list of all members of this type, see NodeClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mouse button used to click the node.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem at the point where the node was clicked.
public Property | ColumnItem | The dbiColumnItem at the point where the node was clicked.
public Property | Handled | Determines if the developer has handled the click operation themselves.
public Property | NodeItem | The dbiNodeItem that was clicked.
public Property | X | The X coordinate where the click occurred.
public Property | Y | The Y coordinate where the click occurred.
Top

See Also

Reference

NodeClickEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

NodeDoubleClickEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeDoubleClickEventArgs Class

"

For a list of all members of this type, see NodeDoubleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mouse button used to double click the node.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the double click occurred.
public Property | ColumnItem | The dbiColumnItem where the double click occurred
public Property | NodeItem | The dbiNodeItem that was double clicked
public Property | X | The X coordinate where the double click occurred
public Property | Y | The Y coordinate where the double click occurred.
Top

See Also

Reference

NodeDoubleClickEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Methods$$

NodeItemCollection Class Methods
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeItemCollection Class

"

For a list of all members of this type, see NodeItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a new node to the collection
public Method | AddRange | Adds multiple node items to the list.
public Method | Clear | This method will remove all the items from the collection. To remove a single item, use Remove Method.
public Method | CopyTo | Copies the NodeItem elements to a one-dimensional Array instance at the specified index.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item in the collection based on the dbiNodeItem parameter.
public Method | Insert | Inserts a new dbiNodeItem object into the collection.
public Method | Remove | Removes an item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | Sort | Overloaded. Sorts the items within the collection.
public Method | WriteXMLFile | Writes the data in the collection to an xml file.
public Method | XMLString | Converts the Item Collection to an XML string.
Top

See Also

Reference

NodeItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

NodeItemCollection Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : NodeItemCollection Class

"

For a list of all members of this type, see NodeItemCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Control | Gets the control this NodeItem is attached to.
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Determines the node item at a specific location in the collection.
public Property | Parent | Gets the parent node for this node item. Will return nothing if this node is the parent node.
Top

See Also

Reference

NodeItemCollection Class
Dbi.WinControl Namespace


%%PageItemTitle%%

NodeItemCollection Constructor
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : NodeItemCollection Constructor

Initializes a new instance of the NodeItemCollection class.

Overload List

Overload | Description
NodeItemCollection Constructor | Initializes a new instance of the NodeItemCollection class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
Dbi4 Assembly > Dbi.WinControl Namespace > NodeItemCollection Class : IndexOf Method

Returns the index of a specified item in the collection based on the dbiNodeItem parameter. Returns the index of a specified item in the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item in the collection based on the dbiNodeItem parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

NodeItemCollection Class
NodeItemCollection Members


%%PageItemTitle%% $$Properties$$

RemoveUserControlsEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : RemoveUserControlsEventArgs Class

"

For a list of all members of this type, see RemoveUserControlsEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem the UserControl is being displayed over.
public Property | ColumnItem | The dbiColumnItem the UserControl is being displayed over.
public Property | NodeItem | The dbiNodeItem that contains the cell the UserControl is displayed over.
Top

See Also

Reference

RemoveUserControlsEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnCellEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnCellEventArgs Class

"

For a list of all members of this type, see UserDrawnCellEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the cell is being drawn.
public Property | ColumnItem | The dbiColumnItem where the cell is being drawn.
public Property | Graphics | A handle to the graphics object responsible for drawing the cell. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | NodeItem | The dbiNodeItem that contains the cell being drawn.
public Property | PaintCell | Determines if the internal routines of the control should draw the cell. When the PaintCell property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the cell.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnCellEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnColumnHeaderEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnColumnHeaderEventArgs Class

"

For a list of all members of this type, see UserDrawnColumnHeaderEventArgs members.

"

Public Properties

 | Name | Description
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the header is being drawn.
public Property | ColumnItem | The dbiColumnItem where the header is being drawn.
public Property | Graphics | A handle to the graphics object responsible for drawing the column header. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | PaintHeader | Determines if the internal routines of the control should draw the column header. When the PaintHeader property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the column header.
public Property | Rect | A rectangle representing the area being painted in the control.
public Property | Status | Determines the current status of the header column in the display.
Top

See Also

Reference

UserDrawnColumnHeaderEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnNodeEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnNodeEventArgs Class

"

For a list of all members of this type, see UserDrawnNodeEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A handle to the graphics object responsible for drawing the node. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | NodeItem | The dbiNodeItem that will be drawn
public Property | PaintNode | Determines if the internal routines of the control should draw the node. When the PaintNode property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the node.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnNodeEventArgs Class
Dbi.WinControl Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnTitleEventArgs Class Properties
[image]
Dbi4 Assembly > Dbi.WinControl Namespace : UserDrawnTitleEventArgs Class

"

For a list of all members of this type, see UserDrawnTitleEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A handle to the graphics object responsible for drawing the title. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | PaintTitle | Determines if the internal routines of the control should draw the title. When the PaintTitle property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the title.
public Property | Rect | A rectangle representing the area being painted in the control.
Top

See Also

Reference

UserDrawnTitleEventArgs Class
Dbi.WinControl Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Dbi.WinControl Namespace Inheritance Hierarchy
Dbi4 Assembly : Dbi.WinControl Namespace

Inheritance Hierarchy

System.Object
Dbi.WinControl.dbiCellFormat
Dbi.WinControl.dbiColumnFormat
Dbi.WinControl.dbiColumnItem
Dbi.WinControl.dbiNodeItem
System.Collections.CollectionBase
Dbi.CollectionBaseEvents
Dbi.WinControl.CellFormatCollection
Dbi.WinControl.ColumnItemCollection
Dbi.WinControl.NodeItemCollection
System.EventArgs
Dbi.WinControl.AfterCellEditEventArgs
Dbi.WinControl.AfterColumnSortEventArgs
Dbi.WinControl.AfterNodeCollapseEventArgs
Dbi.WinControl.AfterNodeExchangeEventArgs
Dbi.WinControl.AfterNodeExpandEventArgs
Dbi.WinControl.AfterNodeSelectEventArgs
Dbi.WinControl.BeforeCellEditEventArgs
Dbi.WinControl.BeforeCellTextDisplayEventArgs
Dbi.WinControl.BeforeColumnSortEventArgs
Dbi.WinControl.BeforeNodeCollapseEventArgs
Dbi.WinControl.BeforeNodeExchangeEventArgs
Dbi.WinControl.BeforeNodeExpandEventArgs
Dbi.WinControl.BeforeNodeSelectEventArgs
Dbi.WinControl.BeforePaintEventArgs
Dbi.WinControl.ChangeEventArgs
Dbi.WinControl.CheckEventArgs
Dbi.WinControl.ColumnEventArgs
Dbi.WinControl.DisplayUserControlEventArgs
Dbi.WinControl.DropListEventArgs
Dbi.WinControl.EditInputKeyEventArgs
Dbi.WinControl.EditKeyDownEventArgs
Dbi.WinControl.EditKeyPressEventArgs
Dbi.WinControl.EditKeyUpEventArgs
Dbi.WinControl.InitializeCellEditEventArgs
Dbi.WinControl.ItemEventArgs
Dbi.WinControl.ListMouseOverEventArgs
Dbi.WinControl.NodeClickEventArgs
Dbi.WinControl.NodeDoubleClickEventArgs
Dbi.WinControl.RemoveUserControlsEventArgs
Dbi.WinControl.UserDrawnCellEventArgs
Dbi.WinControl.UserDrawnColumnHeaderEventArgs
Dbi.WinControl.UserDrawnNodeEventArgs
Dbi.WinControl.UserDrawnTitleEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Dbi.dbiControl
Dbi.WinControl.DbiListControl
System.Windows.Forms.ListControl
System.Windows.Forms.ComboBox
Dbi.WinControl.dbiComboBox
System.Windows.Forms.TextBoxBase
System.Windows.Forms.TextBox
Dbi.WinControl.dbiTextBox

See Also

Reference

Dbi4 Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Dbi Namespace Inheritance Hierarchy
Dbi4 Assembly : Dbi Namespace

Inheritance Hierarchy

System.Object

See Also

Reference

Dbi4 Assembly


%%phrase%%

dbiPim4 Assembly

Namespaces

Namespace | Description
Dbi.PIM |


%%PageItemTitle%% $$Properties$$

AlarmEventArgs Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmEventArgs Class

"

For a list of all members of this type, see AlarmEventArgs members.

"

Public Properties

 | Name | Description
public Property | Appointment | The dbiAppointmentItem triggering the alarm.
public Property | Index | The index value of the alarm.
Top

See Also

Reference

AlarmEventArgs Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

AlarmItemCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmItemCollection Class

"

For a list of all members of this type, see AlarmItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new contact to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

AlarmItemCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

AlarmItemCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : AlarmItemCollection Class

"

For a list of all members of this type, see AlarmItemCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

See Also

Reference

AlarmItemCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
See Also Example
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > AlarmItemCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Example

Visual Basic Copy Code
Me.dbiPim.Alarms.IndexOf(objAppointment)
C# Copy Code
this.dbiPim.Alarms.IndexOf(objAppointment);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

AlarmItemCollection Class
AlarmItemCollection Members


%%PageItemTitle%%

CustomAreaCollection Class
See Also Members
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : CustomAreaCollection Class

**Used for backwards compatibility see dbiCustomAreaCollection**

Object Model

CustomAreaCollection ClassdbiCustomArea Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
C#
public class CustomAreaCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.PIM.CustomAreaCollection

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Members
Dbi.PIM Namespace


%%PageItemTitle%% $$Members$$

CustomAreaCollection Class Members
See Also Properties Methods Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : CustomAreaCollection Class

"

The following tables list the members exposed by CustomAreaCollection.

"

Public Constructors

 | Name | Description
public Constructor | CustomAreaCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item |
Top

Public Methods

 | Name | Description
public Method | Add |
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf |
public Method | Insert |
public Method | Remove |
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile |
Top

Public Events

 | Name | Description
public Event | AreaPropertyChanged |
public Event | Changed |
public Event | Cleared | (Inherited from Dbi.CollectionBaseEvents)
public Event | Clearing | (Inherited from Dbi.CollectionBaseEvents)
public Event | Inserted | (Inherited from Dbi.CollectionBaseEvents)
public Event | Inserting | (Inherited from Dbi.CollectionBaseEvents)
public Event | Removed | (Inherited from Dbi.CollectionBaseEvents)
public Event | Removing | (Inherited from Dbi.CollectionBaseEvents)
public Event | Set | (Inherited from Dbi.CollectionBaseEvents)
public Event | SetComplete | (Inherited from Dbi.CollectionBaseEvents)
Top

See Also

Reference

CustomAreaCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

CustomAreaCollection Constructor
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : CustomAreaCollection Constructor

Overload List

Overload | Description
CustomAreaCollection Constructor() |
CustomAreaCollection Constructor(dbiControl) |

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

CustomAreaCollection Constructor()
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class > CustomAreaCollection Constructor : CustomAreaCollection Constructor()

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New CustomAreaCollection()
C#
public CustomAreaCollection()

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members
Overload List


%%PageItemTitle%%

CustomAreaCollection Constructor(dbiControl)
See Also
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class > CustomAreaCollection Constructor : CustomAreaCollection Constructor(dbiControl)

objControl

Syntax

Visual Basic (Usage) Copy Code
Dim objControl As dbiControl

Dim instance As New CustomAreaCollection(objControl)
C#
public CustomAreaCollection(
   dbiControl objControl
)

Parameters

objControl

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members
Overload List


%%PageItemTitle%%

Add Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Add Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim obj As dbiCustomArea
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiCustomArea obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

AreaPropertyChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : AreaPropertyChanged Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As dbiCustomArea.PropChangeHandler

AddHandler instance.AreaPropertyChanged, handler
C#
public event dbiCustomArea.PropChangeHandler AreaPropertyChanged

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Changed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Changed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CustomAreaCollectionChange

AddHandler instance.Changed, handler
C#
public event CustomAreaCollectionChange Changed

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Clear Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection

instance.Clear()
C#
public void Clear()

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Cleared Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Cleared Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionClear

AddHandler instance.Cleared, handler
C#
public event CollectionClear Cleared

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Clearing Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Clearing Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionClear

AddHandler instance.Clearing, handler
C#
public event CollectionClear Clearing

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

IndexOf(dbiCustomArea) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : IndexOf(dbiCustomArea) Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim obj As dbiCustomArea
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiCustomArea obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Insert Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Insert Method

nIndex
obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim nIndex As System.Integer
Dim obj As dbiCustomArea

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiCustomArea obj
)

Parameters

nIndex
obj

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Inserted Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Inserted Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionChange

AddHandler instance.Inserted, handler
C#
public event CollectionChange Inserted

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Inserting Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Inserting Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionChange

AddHandler instance.Inserting, handler
C#
public event CollectionChange Inserting

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Item Property

nIndex

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim nIndex As System.Integer
Dim value As dbiCustomArea

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiCustomArea this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Remove Method

obj

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim obj As dbiCustomArea

instance.Remove(obj)
C#
public void Remove(
   dbiCustomArea obj
)

Parameters

obj

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

RemoveAt Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : RemoveAt Method

index
The zero-based index of the element to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Removed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Removed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionChange

AddHandler instance.Removed, handler
C#
public event CollectionChange Removed

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Removing Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Removing Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionChange

AddHandler instance.Removing, handler
C#
public event CollectionChange Removing

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

Set Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : Set Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionSet

AddHandler instance.Set, handler
C#
public event CollectionSet Set

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

SetComplete Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : SetComplete Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim handler As CollectionSet

AddHandler instance.SetComplete, handler
C#
public event CollectionSet SetComplete

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%%

WriteXMLFile Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > CustomAreaCollection Class : WriteXMLFile Method

strFileName

Syntax

Visual Basic (Usage) Copy Code
Dim instance As CustomAreaCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName

Requirements

Target Platforms: Windows XP,Windows Server 2003/2008 family, Windows Vista, Windows 7

See Also

Reference

CustomAreaCollection Class
CustomAreaCollection Members


%%PageItemTitle%% $$Methods$$

DaysWeekendCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : DaysWeekendCollection Class

"

For a list of all members of this type, see DaysWeekendCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new day to the DayWeekendCollection object.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if a specific day of the week has been added to the DaysWeekendCollection.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

DaysWeekendCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

DaysWeekendCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : DaysWeekendCollection Class

"

For a list of all members of this type, see DaysWeekendCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

See Also

Reference

DaysWeekendCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > DaysWeekendCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As DaysWeekendCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

DaysWeekendCollection Class
DaysWeekendCollection Members


%%PageItemTitle%% $$Methods$$

dbiAppointmentCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentCollection Class

"

For a list of all members of this type, see dbiAppointmentCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiAppointmentItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetAppointment | ** Method has been deprecated, it will no longer return values. Please use a for..each loop to select appointments from a date. See examples below**
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | Sort | Sorts the elements of the collection.
public Method | WriteXMLFile | Creates an XML File containing the Appointments collection.
public Method | XMLString | Creates a string that contains the XML information for the Appointments collection.
Top

See Also

Reference

dbiAppointmentCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiAppointmentCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentCollection Class

"

For a list of all members of this type, see dbiAppointmentCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiAppointmentItem at a specific index value.
Top

See Also

Reference

dbiAppointmentCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiAppointmentCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiAppointmentCollection Class
dbiAppointmentCollection Members


%%PageItemTitle%% $$Methods$$

dbiAppointmentItem Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentItem Class

"

For a list of all members of this type, see dbiAppointmentItem members.

"

Public Methods

 | Name | Description
public Method | Clone | reates a new object that is a copy of the current instance.
public Method | ResetFonts | Clears all the fonts for the appointment.
public Method | XMLProperties | Return an XML string of the properties from dbiAppointmentItem
Top

See Also

Reference

dbiAppointmentItem Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiAppointmentItem Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiAppointmentItem Class

"

For a list of all members of this type, see dbiAppointmentItem members.

"

Public Properties

 | Name | Description
public Property | AlarmEnd | Determines if an alarm will fire when the appointment ends.
public Property | AlarmStart | Determines if an alarm will fire when the appointment starts.
public Property | AllDayEvent | Determines if the appointment will be an all day appointment.
public Property | BackColor | Gets or sets the primary background color of the appointment.
public Property | BackColorTo | Gets or sets the secondary background color of the appointment.
public Property | Body | Gets or sets any additional details of the appointment.
public Property | BorderColor | Gets or sets the border color of the appointment.
public Property | BorderType | Gets or sets the type of border to place around the appointment.
public Property | Cargo | Gets or sets a non-visible text value for the appointment.
public Property | ContactID | Assigns a contact to the appointment.
public Property | Data | Gets or sets a non-visible numeric value for the appointment.
public Property | End | Gets or sets the ending date and time for an appointment.
public Property | EntryID | Gets or sets a non-visible text value for the appointment.
public Property | FillType | Gets or sets the type of pattern to paint the background of the appointment.
public Property | Font | Gets or sets the font for the main text in the appointment.
public Property | Font2 | Gets or sets the font of the information line in the appointment.
public Property | ForeColor | Gets or sets the fore color of the appointment.
public Property | HatchStyle | Gets or sets the background pattern of the appointment.
public Property | Image1 | Gets or sets the primary image associated with the appointment.
public Property | Image2 | Gets or sets the secondary image associated with the appointment.
public Property | Image3 | Gets or sets the tertiary image associated with the appointment.
public Property | InfoFont | Gets or sets the font of the information line in the appointment.
public Property | IsRecurring | Determines if the appointment will be recurring.
public Property | Location | Gets or sets the appointment location.
public Property | LocationID | Assigns a location to the appointment.
public Property | Locked | Determines if the appointment can be moves or sized by user-interaction.
public Property | MaxTime | Gets or sets the maximum end time of the appointment.
public Property | MinTime | Gets or sets the minimum start time of the appointment.
public Property | ReadOnly | Determines if the appointment can be modified by user interaction.
public Property | RecordID | Gets or sets a hidden numeric value for the appoinment.
public Property | ReminderMinutesBeforeStart | Determines how many minutes before the appointment an alarm is fired.
public Property | ReminderPlaySound | Determines if a reminder sound will be played when the appointment alarm is triggered.
public Property | ReminderSet | Determines if a reminder has been set for the appointment.
public Property | ReminderSetEnd | Determines if a reminder has been set for the end of the appointment.
public Property | ReminderSoundFile | Gets or sets the reminder sound to be played when the appointment alarm is triggered.
public Property | Start | Gets or sets the starting date and time of an appointment.
public Property | Style | Gets or sets a pre-defined style assigned to the appointment.
public Property | SubTextFont | Gets or sets the sub text font of the appointment.
public Property | Tag | A property where you can store an object relative to the dbiAppointmentItem. Good property for storing datarow or record information.
public Property | TaskBarColor | Gets or sets the color of the taskbar of the appointment.
public Property | TaskID | Assigns a task to the appointment.
public Property | Text | Gets or sets the appointment text.
public Property | VCalendar | Gets or sets the VCalendar specification for the appointment.
public Property | XMLString | Gets or sets an xml string to read or write the appointment data.
Top

See Also

Reference

dbiAppointmentItem Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiContactCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactCollection Class

"

For a list of all members of this type, see dbiContactCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiContactItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiContactItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the Contacts collection.
public Method | XMLString | Creates a string that contains the XML information for the Contacts collection.
Top

See Also

Reference

dbiContactCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiContactCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactCollection Class

"

For a list of all members of this type, see dbiContactCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiContactItem at a specific index value.
Top

See Also

Reference

dbiContactCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiContactCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiContactCollection Class
dbiContactCollection Members


%%PageItemTitle%% $$Properties$$

dbiContactItem Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiContactItem Class

"

For a list of all members of this type, see dbiContactItem members.

"

Public Properties

 | Name | Description
public Property | Address | Gets or sets the address of the contact.
public Property | BackColor | Gets or sets the primary background color of the contact.
public Property | BackColorTo | Gets or sets the secondary background color of the contact.
public Property | Body | Gets or sets additional information for the contact.
public Property | Cargo | Gets or sets a non-visible text value for the contact.
public Property | City | Gets or sets the city of the contact.
public Property | CompanyName | Gets or sets the company name of the contact.
public Property | Country | Gets or sets the country of the contact.
public Property | Data | Gets or sets a non-visible numeric value for the contact.
public Property | Email | Gets or sets the email address of the contact.
public Property | EntryID | Gets or sets a non-visible text value for the contact.
public Property | FaxNumber | Gets or sets the fax number of the contact.
public Property | FirstName | Gets or sets the first name of the contact.
public Property | ForeColor | Gets or sets the fore color of the contact.
public Property | Image | Gets or sets the image to display with the contact.
public Property | LastName | Gets or sets the last name of the contact.
public Property | PostalCode | Gets or sets the postal code (or zip code) for the contact.
public Property | RecordID | Gets or sets a non-visible numeric value for the contact.
public Property | State | Gets or sets the state of the contact.
public Property | Subject | Gets or sets a short description of the contact.
public Property | Tag | A property where you can store an object relative to the dbiContactItem. Good property for storing datarow or record information.
public Property | TelephoneNumber | Gets or sets a phone number for the contact.
public Property | Title | Gets or sets the title or job position of the contact.
public Property | XMLString | Gets or sets an xml string to read or write the contact data.
Top

See Also

Reference

dbiContactItem Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiCustomArea Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomArea Class

"

For a list of all members of this type, see dbiCustomArea members.

"

Public Methods

 | Name | Description
public Method | SetXMLValues | Sets the CustomArea to the XmlNodeList passed into the method.
Top

See Also

Reference

dbiCustomArea Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiCustomArea Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomArea Class

"

For a list of all members of this type, see dbiCustomArea members.

"

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the custom area.
public Property | BackColorTo | Gets or sets the secondary background color of the custom area.
public Property | Cargo | Gets or sets a non-visible text value for the custom area.
public Property | ContactID | Gets or sets the ContactID used to filter the custom areas.
public Property | Daily | Determines if the custom area will appear daily.
public Property | Data | Gets or sets a non-visible numeric value for the custom area.
public Property | DeadZone | Determines if the custom area will be a dead zone.
public Property | End | Gets or sets the ending time of the custom area.
public Property | FillType | Gets or sets the background fill pattern of the custom area.
public Property | LocationID | Gets or sets the LocationID used to filter the custom areas.
public Property | Start | Gets or sets the starting time of the custom area.
public Property | Tag | Determines an object that contains data about the dbiCustomArea
public Property | TaskID | Gets or sets the TaskID used to filter the custom areas.
public Property | VertOffset | Determines the vertical offset used when drawing a custom area.
public Property | XMLString | Gets or sets an xml string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiCustomArea Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiCustomAreaCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomAreaCollection Class

"

For a list of all members of this type, see dbiCustomAreaCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new item to the CustomAreaCollection object.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified time bar style within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an xml file.
public Method | XMLString | Gets or sets an xml string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiCustomAreaCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiCustomAreaCollection Class

"

For a list of all members of this type, see dbiCustomAreaCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

See Also

Reference

dbiCustomAreaCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiCustomAreaCollection Class : IndexOf Method

Returns the index of a specified time bar style within the collection. Returns the index of a specified time bar style within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified time bar style within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiCustomAreaCollection Class
dbiCustomAreaCollection Members


%%PageItemTitle%% $$Properties$$

dbiDayFormat Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormat Class

"

For a list of all members of this type, see dbiDayFormat members.

"

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the background color of the day format.
public Property | BackColorTo | Gets or sets the secondary background color of the day format.
public Property | ContactID | Gets or sets the unique identification to a contact item.
public Property | Enabled | Determines if a specific date can be selected.
public Property | End | Gets or sets the ending date of the day format.
public Property | FillType | Gets or sets the background pattern of the day format.
public Property | Font | Gets or sets the font for the day format.
public Property | ForeColor | Gets or sets the foreground color of the day format.
public Property | Image | Gets or sets the image to display with the day format.
public Property | LocationID | Gets or sets the unique identification to a location item.
public Property | Start | Gets or sets the starting date of the formatted area.
public Property | TaskID | Gets or sets the unique identification to a task item.
public Property | Text | Gets or sets the general text for a date.
public Property | XMLString | Gets or sets an xml string to read or write the day format data.
Top

See Also

Reference

dbiDayFormat Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiDayFormatCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormatCollection Class

"

For a list of all members of this type, see dbiDayFormatCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiDayFormat to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiDayFormat.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiDayFormatCollection collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiDayFormatCollection collection.
Top

See Also

Reference

dbiDayFormatCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiDayFormatCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiDayFormatCollection Class

"

For a list of all members of this type, see dbiDayFormatCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiContactItem at a specific index value.
Top

See Also

Reference

dbiDayFormatCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiDayFormatCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiDayFormatCollection Class
dbiDayFormatCollection Members


%%PageItemTitle%% $$Methods$$

dbiLocationCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationCollection Class

"

For a list of all members of this type, see dbiLocationCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiLocationItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiLocationItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiLocationCollection collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiLocationCollection collection.
Top

See Also

Reference

dbiLocationCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiLocationCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationCollection Class

"

For a list of all members of this type, see dbiLocationCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiLocationItem at a specific index value.
Top

See Also

Reference

dbiLocationCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiLocationCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiLocationCollection Class
dbiLocationCollection Members


%%PageItemTitle%% $$Properties$$

dbiLocationItem Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiLocationItem Class

"

For a list of all members of this type, see dbiLocationItem members.

"

Public Properties

 | Name | Description
public Property | Address | Gets or sets the primary address of the location.
public Property | Address2 | Gets or sets the seconary address of the location.
public Property | BackColor | Gets or sets the background color of the location.
public Property | BackColorTo | Gets or sets the secondary background color of the location.
public Property | Cargo | Gets or sets a non-visible text value for the location.
public Property | City | Gets or sets the city of the location.
public Property | Country | Gets or sets the country of the location
public Property | Data | Gets or sets a non-visible numeric value for the location.
public Property | EntryID | Gets or sets a non-visible text value for the location.
public Property | ForeColor | Gets or sets the fore color of the location.
public Property | Image | Gets or sets the image to display with the location.
public Property | RecordID | Gets or sets a hidden numeric value for the location.
public Property | State | Gets or sets the state of the location.
public Property | Tag | Determines an object that contains data about the dbiLocationItem
public Property | Title | Gets or sets the name of the location.
public Property | XMLString | Gets or sets an xml string to read the location data or write the location data.
public Property | ZipCode | Gets or sets the zip code of the location.
Top

See Also

Reference

dbiLocationItem Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Events$$

dbiPIM Class Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM Class

"

For a list of all members of this type, see dbiPIM members.

"

Public Events

 | Name | Description
public Event | Alarm | Occurs when an alarm is triggered.
Top

See Also

Reference

dbiPIM Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiPIM Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM Class

"

For a list of all members of this type, see dbiPIM members.

"

Public Methods

 | Name | Description
public Method | ToString | (Inherited from System.ComponentModel.Component)
Top

See Also

Reference

dbiPIM Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiPIM Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiPIM Class

"

For a list of all members of this type, see dbiPIM members.

"

Public Properties

 | Name | Description
public Property | AlarmAutoClear | Determines if the appointments will automatically be cleared from the collection after their alarm has been triggered.
public Property | AlarmInterval | Determines how often to review the alarms collection.
public Property | Alarms | Gets the alarms in dbiPIM.
public Property | Appointments | Collection of Appointments in dbiPIM
public Property | Contacts | Collection of Contacts in dbiPIM
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | CustomAreas | Collection of CustomAreas in dbiPIM
public Property | Locations | Collection of Locations in dbiPIM
public Property | ReminderDialog | Determines if the ReminderDialog will be displayed when an alarm is triggered.
public Property | Site | (Inherited from System.ComponentModel.Component)
public Property | Tasks | Collection of Tasks in dbiPIM
Top

See Also

Reference

dbiPIM Class
Dbi.PIM Namespace


%%PageItemTitle%%

Container Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

Site Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : Site Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%%

ToString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiPIM Class : ToString Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiPIM
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiPIM Class
dbiPIM Members


%%PageItemTitle%% $$Events$$

dbiReminderDialog Class Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog Class

"

For a list of all members of this type, see dbiReminderDialog members.

"

Public Events

 | Name | Description
public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from System.Windows.Forms.Form)
public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.Form.AutoSize property changes. (Inherited from System.Windows.Forms.Form)
public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.Form.AutoValidate property changes. (Inherited from System.Windows.Forms.Form)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from System.Windows.Forms.Form)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | FormClosed | Occurs after the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | FormClosing | Occurs before the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from System.Windows.Forms.Form)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from System.Windows.Forms.Form)
public Event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from System.Windows.Forms.Form)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | Load | Occurs before a form is displayed for the first time. (Inherited from System.Windows.Forms.Form)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MaximizedBoundsChanged | Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MaximumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from System.Windows.Forms.Form)
public Event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from System.Windows.Forms.Form)
public Event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from System.Windows.Forms.Form)
public Event | MinimumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftLayoutChanged | Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.Form)
public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
public Event | Shown | Occurs whenever the form is first displayed. (Inherited from System.Windows.Forms.Form)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiReminderDialog Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiReminderDialog Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog Class

"

For a list of all members of this type, see dbiReminderDialog members.

"

Public Methods

 | Name | Description
public Method | Activate | Activates the form and gives it focus. (Inherited from System.Windows.Forms.Form)
public Method | AddOwnedForm | Adds an owned form to this form. (Inherited from System.Windows.Forms.Form)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ClearState | Clears the ReminderState property.
public Method | Close | Closes the form. (Inherited from System.Windows.Forms.Form)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from System.Windows.Forms.Form)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from System.Windows.Forms.Form)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | Show | Overloaded. Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
public Method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Gets a string representing the current instance of the form. (Inherited from System.Windows.Forms.Form)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

dbiReminderDialog Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiReminderDialog Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiReminderDialog Class

"

For a list of all members of this type, see dbiReminderDialog members.

"

Public Properties

 | Name | Description
public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from System.Windows.Forms.Form)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from System.Windows.Forms.Form)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from System.Windows.Forms.Form)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Appointment | Gets or sets the appointment to display in the reminder dialog.
public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from System.Windows.Forms.Form)
public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoSize | Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode. (Inherited from System.Windows.Forms.Form)
public Property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from System.Windows.Forms.Form)
public Property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from System.Windows.Forms.Form)
public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Form)
public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from System.Windows.Forms.Form)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from System.Windows.Forms.Form)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DialogResult | Gets or sets the dialog result for the form. (Inherited from System.Windows.Forms.Form)
public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
public Property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from System.Windows.Forms.Form)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from System.Windows.Forms.Form)
public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Icon | Gets or sets the icon for the form. (Inherited from System.Windows.Forms.Form)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from System.Windows.Forms.Form)
public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from System.Windows.Forms.Form)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from System.Windows.Forms.Form)
public Property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from System.Windows.Forms.Form)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates. (Inherited from System.Windows.Forms.Form)
public Property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from System.Windows.Forms.Form)
public Property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from System.Windows.Forms.Form)
public Property | Menu | Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form. (Inherited from System.Windows.Forms.Form)
public Property | MergedMenu | Gets the merged menu for the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from System.Windows.Forms.Form)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Opacity | Gets or sets the opacity level of the form. (Inherited from System.Windows.Forms.Form)
public Property | OwnedForms | Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form. (Inherited from System.Windows.Forms.Form)
public Property | Owner | Gets or sets the form that owns this form. (Inherited from System.Windows.Forms.Form)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ReminderState | Gets the state of the reminder dialog.
public Property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from System.Windows.Forms.Form)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from System.Windows.Forms.Form)
public Property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from System.Windows.Forms.Form)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the size of the form. (Inherited from System.Windows.Forms.Form)
public Property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from System.Windows.Forms.Form)
public Property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from System.Windows.Forms.Form)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Form)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from System.Windows.Forms.Form)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from System.Windows.Forms.Form)
public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from System.Windows.Forms.Form)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

dbiReminderDialog Class
Dbi.PIM Namespace


%%PageItemTitle%%

AcceptButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AcceptButton Property

Gets or sets the button on the form that is clicked when the user presses the ENTER key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}

Property Value

An System.Windows.Forms.IButtonControl that represents the button to use as the accept button for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AccessibleName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AccessibleRole Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Activate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Activate Method

Activates the form and gives it focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Activate()
C#
public void Activate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Activated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Activated Event

Occurs when the form is activated in code or by the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
public event System.EventHandler Activated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ActiveControl Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ActiveControl Property

Gets or sets the active control on the container control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
public System.Windows.Forms.Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ActiveMdiChild Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ActiveMdiChild Property

Gets the currently active multiple-document interface (MDI) child window.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Form

value = instance.ActiveMdiChild
C#
public System.Windows.Forms.Form ActiveMdiChild {get;}

Property Value

Returns a System.Windows.Forms.Form that represents the currently active MDI child window, or null if there are currently no child windows present.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AddOwnedForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AddOwnedForm Method

ownedForm
The System.Windows.Forms.Form that this form will own.
Adds an owned form to this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)

Parameters

ownedForm
The System.Windows.Forms.Form that this form will own.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AllowTransparency Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AllowTransparency Property

Gets or sets a value indicating whether the opacity of the form can be adjusted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.AllowTransparency = value

value = instance.AllowTransparency
C#
public System.bool AllowTransparency {get; set;}

Property Value

true if the opacity of the form can be changed; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Anchor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScroll Property

Gets or sets a value indicating whether the form enables autoscrolling.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
public virtual System.bool AutoScroll {get; set;}

Property Value

true to enable autoscrolling on the form; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScrollMargin Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScrollMargin Property

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
public System.Drawing.Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScrollMinSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScrollMinSize Property

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
public System.Drawing.Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

AutoScrollPosition Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : AutoScrollPosition Property

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Point

instance.AutoScrollPosition = value

value = instance.AutoScrollPosition
C#
public System.Drawing.Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackColor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackColor Property

Gets or sets the background color for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}

Property Value

A System.Drawing.Color that represents the background color of the control. The default is the value of the System.Windows.Forms.Control.DefaultBackColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackColorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackgroundImage Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackgroundImage Property

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public virtual System.Drawing.Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BackgroundImageChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BackgroundImageChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event System.EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BeginInvoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

BindingContext Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Bottom Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Bounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

BringToFront Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CancelButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CancelButton Property

Gets or sets the button control that is clicked when the user presses the ESC key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
public System.Windows.Forms.IButtonControl CancelButton {get; set;}

Property Value

An System.Windows.Forms.IButtonControl that represents the cancel button for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CanFocus Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CanSelect Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Capture Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CausesValidation Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ChangeUICues Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Click Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ClientRectangle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ClientSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ClientSize Property

Gets or sets the size of the client area of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the size of the form's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Close Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Close Method

Closes the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Close()
C#
public void Close()

Exceptions

Exception | Description
System.InvalidOperationException | The form was closed while a handle was being created.
System.ObjectDisposedException | You cannot call this method from the System.Windows.Forms.Form.Activated event when System.Windows.Forms.Form.WindowState is set to System.Windows.Forms.FormWindowState.Maximized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CompanyName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Container Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ContainsFocus Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ContextMenu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ControlAdded Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ControlBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ControlBox Property

Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
public System.bool ControlBox {get; set;}

Property Value

true if the form displays a control box in the upper left corner of the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ControlRemoved Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Controls Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CreateControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Created Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CreateGraphics Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CreateObjRef Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Cursor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

CursorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DataBindings Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Deactivate Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Deactivate Event

Occurs when the form loses focus and is no longer the active form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
public event System.EventHandler Deactivate

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DesktopBounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DesktopBounds Property

Gets or sets the size and location of the form on the Windows desktop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Rectangle

instance.DesktopBounds = value

value = instance.DesktopBounds
C#
public System.Drawing.Rectangle DesktopBounds {get; set;}

Property Value

A System.Drawing.Rectangle that represents the bounds of the form on the Windows desktop using desktop coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DesktopLocation Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DesktopLocation Property

Gets or sets the location of the form on the Windows desktop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Point

instance.DesktopLocation = value

value = instance.DesktopLocation
C#
public System.Drawing.Point DesktopLocation {get; set;}

Property Value

A System.Drawing.Point that represents the location of the form on the desktop.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DialogResult Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DialogResult Property

Gets or sets the dialog result for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
public System.Windows.Forms.DialogResult DialogResult {get; set;}

Property Value

A System.Windows.Forms.DialogResult that represents the result of the form when used as a dialog box.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DisplayRectangle Property

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Dispose Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Dispose Method

Dispose of the dbiReminderDialog, freeing the memory space it occupied.

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Base Implementation in Dispose


%%PageItemTitle%%

Dispose() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Dispose() Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Disposed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Disposing Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Dock Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DockChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DoDragDrop Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DoubleClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DragDrop Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DragEnter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DragLeave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

DragOver Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Enabled Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

EnabledChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

EndInvoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Enter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

FindForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Focus Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Focused Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Font Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

FontChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ForeColor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ForeColor Property

Gets or sets the foreground color of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
public virtual System.Drawing.Color ForeColor {get; set;}

Property Value

The foreground System.Drawing.Color of the control. The default is the value of the System.Windows.Forms.Control.DefaultForeColor property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

FormBorderStyle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : FormBorderStyle Property

Gets or sets the border style of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}

Property Value

A System.Windows.Forms.FormBorderStyle that represents the style of border to display for the form. The default is FormBorderStyle.Sizable.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

GetContainerControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GetNextControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GiveFeedback Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

GotFocus Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Handle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HandleCreated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HasChildren Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Height Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HelpButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HelpButton Property

Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
public System.bool HelpButton {get; set;}

Property Value

true to display a Help button in the form's caption bar; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

HelpRequested Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Hide Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Icon Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Icon Property

Gets or sets the icon for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
public System.Drawing.Icon Icon {get; set;}

Property Value

An System.Drawing.Icon that represents the icon for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ImeMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

InputLanguageChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : InputLanguageChanged Event

Occurs after the input language of the form has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

InputLanguageChanging Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : InputLanguageChanging Event

Occurs when the user attempts to change the input language for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Invalidate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Invalidate() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invalidated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Invoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

InvokeRequired Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsAccessible Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsDisposed Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsMdiChild Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsMdiChild Property

Gets a value indicating whether the form is a multiple-document interface (MDI) child form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.IsMdiChild
C#
public System.bool IsMdiChild {get;}

Property Value

true if the form is an MDI child form; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsMdiContainer Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsMdiContainer Property

Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
public System.bool IsMdiContainer {get; set;}

Property Value

true if the form is a container for MDI child forms; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

IsRestrictedWindow Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : IsRestrictedWindow Property

Gets a value indicating whether the form can use all windows and user input events without restriction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.IsRestrictedWindow
C#
public System.bool IsRestrictedWindow {get;}

Property Value

true if the form has restrictions; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

KeyDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

KeyPress Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

KeyPreview Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : KeyPreview Property

Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
public System.bool KeyPreview {get; set;}

Property Value

true if the form will receive all key events; false if the currently selected control on the form receives key events. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

KeyUp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Layout Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

LayoutMdi Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : LayoutMdi Method

value
One of the System.Windows.Forms.MdiLayout values that defines the layout of MDI child forms.
Arranges the multiple-document interface (MDI) child forms within the MDI parent form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value
One of the System.Windows.Forms.MdiLayout values that defines the layout of MDI child forms.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Leave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Left Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Load Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Load Event

Occurs before a form is displayed for the first time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
public event System.EventHandler Load

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Location Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Location Property

Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

LocationChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

LostFocus Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MaximizeBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MaximizeBox Property

Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
public System.bool MaximizeBox {get; set;}

Property Value

true to display a Maximize button for the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MaximizedBoundsChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MaximizedBoundsChanged Event

Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
public event System.EventHandler MaximizedBoundsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MaximumSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MaximumSize Property

Gets the maximum size the form can be resized to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

A System.Drawing.Size that represents the maximum size for the form.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The values of the height or width within the System.Drawing.Size object are less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MaximumSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MaximumSizeChanged Event

Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
public event System.EventHandler MaximumSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MdiChildActivate Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MdiChildActivate Event

Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
public event System.EventHandler MdiChildActivate

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MdiChildren Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MdiChildren Property

Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value() As System.Windows.Forms.Form

value = instance.MdiChildren
C#
public System.Windows.Forms.Form[] MdiChildren {get;}

Property Value

An array of System.Windows.Forms.Form objects, each of which identifies one of this form's MDI child forms.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MdiParent Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MdiParent Property

Gets or sets the current multiple-document interface (MDI) parent form of this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Form

instance.MdiParent = value

value = instance.MdiParent
C#
public System.Windows.Forms.Form MdiParent {get; set;}

Property Value

A System.Windows.Forms.Form that represents the MDI parent form.

Exceptions

Exception | Description
System.Exception | The System.Windows.Forms.Form assigned to this property is not marked as an MDI container.-or- The System.Windows.Forms.Form assigned to this property is both a child and an MDI container form.-or- The System.Windows.Forms.Form assigned to this property is located on a different thread.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Menu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Menu Property

Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.MainMenu

instance.Menu = value

value = instance.Menu
C#
public System.Windows.Forms.MainMenu Menu {get; set;}

Property Value

A System.Windows.Forms.MainMenu that represents the menu to display in the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MenuComplete Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MenuComplete Event

Occurs when the menu of a form loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MenuComplete, handler
C#
public event System.EventHandler MenuComplete

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MenuStart Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MenuStart Event

Occurs when the menu of a form receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MenuStart, handler
C#
public event System.EventHandler MenuStart

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MergedMenu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MergedMenu Property

Gets the merged menu for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.MainMenu

value = instance.MergedMenu
C#
public System.Windows.Forms.MainMenu MergedMenu {get;}

Property Value

A System.Windows.Forms.MainMenu that represents the merged menu of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MinimizeBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MinimizeBox Property

Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
public System.bool MinimizeBox {get; set;}

Property Value

true to display a Minimize button for the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MinimumSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MinimumSize Property

Gets or sets the minimum size the form can be resized to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

A System.Drawing.Size that represents the minimum size for the form.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The values of the height or width within the System.Drawing.Size object are less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MinimumSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MinimumSizeChanged Event

Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
public event System.EventHandler MinimumSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Modal Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Modal Property

Gets a value indicating whether this form is displayed modally.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Modal
C#
public System.bool Modal {get;}

Property Value

true if the form is displayed modally; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseEnter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseHover Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseLeave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseMove Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseUp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

MouseWheel Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Move Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Name Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Opacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Opacity Property

Gets or sets the opacity level of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
public System.double Opacity {get; set;}

Property Value

The level of opacity for the form. The default is 1.00.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

OwnedForms Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : OwnedForms Property

Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value() As System.Windows.Forms.Form

value = instance.OwnedForms
C#
public System.Windows.Forms.Form[] OwnedForms {get;}

Property Value

A System.Windows.Forms.Form array that represents the owned forms for this form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Owner Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Owner Property

Gets or sets the form that owns this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Form

instance.Owner = value

value = instance.Owner
C#
public System.Windows.Forms.Form Owner {get; set;}

Property Value

A System.Windows.Forms.Form that represents the form that is the owner of this form.

Exceptions

Exception | Description
System.Exception | A top-level window cannot have an owner.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Paint Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Paint Event

Occurs when the control is redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
public event System.Windows.Forms.PaintEventHandler Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Parent Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ParentChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ParentForm Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ParentForm Property

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Form

value = instance.ParentForm
C#
public System.Windows.Forms.Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PerformLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PerformLayout() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

PointToClient Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PointToScreen Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ProductName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ProductVersion Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RectangleToClient Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Refresh Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Region Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RemoveOwnedForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RemoveOwnedForm Method

ownedForm
A System.Windows.Forms.Form representing the form to remove from the list of owned forms for this form.
Removes an owned form from this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)

Parameters

ownedForm
A System.Windows.Forms.Form representing the form to remove from the list of owned forms for this form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ResetText Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ResetText Method

Resets the System.Windows.Forms.Control.Text property to its default value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Resize Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ResumeLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ResumeLayout() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Right Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RightToLeft Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Scale Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ScrollControlIntoView Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.
Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Select Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Select Method

Selects this form, and optionally selects the next or previous control.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Select() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SelectNextControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SendToBack Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SetAutoScrollMargin Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.
Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SetBounds Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

SetDesktopBounds Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SetDesktopBounds Method

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
width
The width of the form.
height
The height of the form.
Sets the bounds of the form in desktop coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
width
The width of the form.
height
The height of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SetDesktopLocation Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SetDesktopLocation Method

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
Sets the location of the form in desktop coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Show Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Show Method

Shows the form with the specified owner to the user.

Overload List

Overload | Description
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
Show() | Displays the control to the user. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Show() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Show Method : Show() Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Show(IWin32Window) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Show Method : Show(IWin32Window) Method

owner
Any object that implements System.Windows.Forms.IWin32Window and represents the top-level window that will own this form.
Shows the form with the specified owner to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)

Parameters

owner
Any object that implements System.Windows.Forms.IWin32Window and represents the top-level window that will own this form.

Exceptions

Exception | Description
System.InvalidOperationException | The form being shown is already visible.-or- The form specified in the owner parameter is the same as the form being shown.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ShowDialog Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ShowDialog Method

Shows the form as a modal dialog box.

Overload List

Overload | Description
ShowDialog() | Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ShowDialog() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ShowDialog Method : ShowDialog() Method

Shows the form as a modal dialog box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
public System.Windows.Forms.DialogResult ShowDialog()

Return Value

One of the System.Windows.Forms.DialogResult values.

Exceptions

Exception | Description
System.InvalidOperationException | The form being shown is already visible.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ShowDialog(IWin32Window) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog box.
Shows the form as a modal dialog box with the specified owner.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)

Parameters

owner
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

One of the System.Windows.Forms.DialogResult values.

Exceptions

Exception | Description
System.ArgumentException | The form specified in the owner parameter is the same as the form being shown.
System.InvalidOperationException | The form being shown is already visible.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ShowInTaskbar Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ShowInTaskbar Property

Gets or sets a value indicating whether the form is displayed in the Windows taskbar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
public System.bool ShowInTaskbar {get; set;}

Property Value

true to display the form in the Windows taskbar at run time; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Site Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Size Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Size Property

Gets or sets the size of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

A System.Drawing.Size that represents the size of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SizeGripStyle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SizeGripStyle Property

Gets or sets the style of the size grip to display in the lower-right corner of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}

Property Value

A System.Windows.Forms.SizeGripStyle that represents the style of the size grip to display. The default is System.Windows.Forms.SizeGripStyle.Auto

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

StartPosition Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : StartPosition Property

Gets or sets the starting position of the form at run time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}

Property Value

A System.Windows.Forms.FormStartPosition that represents the starting position of the form.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

StyleChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SuspendLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Text Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

TextChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Top Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

TopLevel Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : TopLevel Property

Gets or sets a value indicating whether to display the form as a top-level window.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.TopLevel = value

value = instance.TopLevel
C#
public System.bool TopLevel {get; set;}

Property Value

true to display the form as a top-level window; otherwise, false. The default is true.

Exceptions

Exception | Description
System.Exception | A Multiple-document interface (MDI) parent form must be a top-level window.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

TopLevelControl Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

TopMost Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : TopMost Property

Gets or sets a value indicating whether the form should be displayed as a topmost form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
public System.bool TopMost {get; set;}

Property Value

true to display the form as a topmost form; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

ToString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : ToString Method

Gets a string representing the current instance of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Return Value

A string consisting of the fully qualified name of the form object's class, with the System.Windows.Forms.Form.Text property of the form appended to the end. For example, if the form is derived from the class MyForm in the MyNamespace namespace, and the System.Windows.Forms.Form.Text property is set to Hello, World, this method will return MyNamespace.MyForm, Text: Hello, World.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

TransparencyKey Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : TransparencyKey Property

Gets or sets the color that will represent transparent areas of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
public System.Drawing.Color TransparencyKey {get; set;}

Property Value

A System.Drawing.Color that represents the color to display transparently on the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Update Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Validate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Validate Method

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Validate() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Validate Method : Validate() Method

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.Validate()
C#
public System.bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Validate(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.
Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ValidateChildren() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ValidateChildren Method : ValidateChildren() Method

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
public virtual System.bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

ValidateChildren(ValidationConstraints) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.
Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members
Overload List


%%PageItemTitle%%

Validated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Validating Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Visible Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

VisibleChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

Width Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%%

WindowState Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiReminderDialog Class : WindowState Property

Gets or sets a value that indicates whether form is minimized, maximized, or normal.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiReminderDialog
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
public System.Windows.Forms.FormWindowState WindowState {get; set;}

Property Value

A System.Windows.Forms.FormWindowState that represents whether form is minimized, maximized, or normal. The default is FormWindowState.Normal.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiReminderDialog Class
dbiReminderDialog Members


%%PageItemTitle%% $$Methods$$

dbiTaskCollection Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskCollection Class

"

For a list of all members of this type, see dbiTaskCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Add a dbiTaskItem to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | Contains | Determines if the Contact collection contains a specific dbiTaskItem.
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item within the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Creates an XML File containing the dbiTaskItem collection.
public Method | XMLString | Creates a string that contains the XML information for the dbiTaskCollection collection.
Top

See Also

Reference

dbiTaskCollection Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiTaskCollection Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskCollection Class

"

For a list of all members of this type, see dbiTaskCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the dbiTaskItem at a specific index value.
Top

See Also

Reference

dbiTaskCollection Class
Dbi.PIM Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTaskCollection Class : IndexOf Method

Returns the index of a specified item within the collection. Returns the index of a specified item within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTaskCollection Class
dbiTaskCollection Members


%%PageItemTitle%% $$Properties$$

dbiTaskItem Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTaskItem Class

"

For a list of all members of this type, see dbiTaskItem members.

"

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the task.
public Property | BackColorTo | Gets or sets the secondary background color of the task.
public Property | Body | Gets or sets additional information for the task.
public Property | Cargo | Gets or sets a non-visible text value for the task.
public Property | Categories | Gets or sets the category of the task.
public Property | Complete | Determines if the task has been completed.
public Property | Data | Gets or sets a non-visible numeric value for the task.
public Property | DueDate | Gets or sets the due date for the task.
public Property | EntryID | Gets or sets a non-visible text value for the task.
public Property | ForeColor | Gets or sets the fore color of the task.
public Property | Image | Gets or sets the image to display with the task.
public Property | PercentComplete | Determines how much of the task has been completed.
public Property | RecordID | Gets or sets a non-visible numeric value for the task.
public Property | StartDate | Gets or sets the start date of the task.
public Property | Status | Gets or sets the status of the task.
public Property | Subject | Gets or sets the name of the task.
public Property | Tag | Determines an object that contains data about the dbiTaskItem
public Property | XMLString | Gets or sets an xml string to read or write the task data.
Top

See Also

Reference

dbiTaskItem Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Events$$

dbiTimeBarDialog Class Events
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTimeBarDialog Class

"

For a list of all members of this type, see dbiTimeBarDialog members.

"

Public Events

 | Name | Description
public Event | Activated | Occurs when the form is activated in code or by the user. (Inherited from System.Windows.Forms.Form)
public Event | AutoSizeChanged | Occurs when the System.Windows.Forms.Form.AutoSize property changes. (Inherited from System.Windows.Forms.Form)
public Event | AutoValidateChanged | Occurs when the System.Windows.Forms.Form.AutoValidate property changes. (Inherited from System.Windows.Forms.Form)
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from System.Windows.Forms.Form)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChanged | (Inherited from System.Windows.Forms.Form)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | FormClosed | Occurs after the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | FormClosing | Occurs before the form is closed. (Inherited from System.Windows.Forms.Form)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from System.Windows.Forms.Form)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from System.Windows.Forms.Form)
public Event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from System.Windows.Forms.Form)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | Load | Occurs before a form is displayed for the first time. (Inherited from System.Windows.Forms.Form)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MaximizedBoundsChanged | Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MaximumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from System.Windows.Forms.Form)
public Event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from System.Windows.Forms.Form)
public Event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from System.Windows.Forms.Form)
public Event | MinimumSizeChanged | Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed. (Inherited from System.Windows.Forms.Form)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from System.Windows.Forms.Form)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftLayoutChanged | Occurs after the value of the System.Windows.Forms.Form.RightToLeftLayout property changes. (Inherited from System.Windows.Forms.Form)
public Event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from System.Windows.Forms.ScrollableControl)
public Event | Shown | Occurs whenever the form is first displayed. (Inherited from System.Windows.Forms.Form)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiTimeBarDialog Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Methods$$

dbiTimeBarDialog Class Methods
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTimeBarDialog Class

"

For a list of all members of this type, see dbiTimeBarDialog members.

"

Public Methods

 | Name | Description
public Method | Activate | Activates the form and gives it focus. (Inherited from System.Windows.Forms.Form)
public Method | AddOwnedForm | Adds an owned form to this form. (Inherited from System.Windows.Forms.Form)
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Close | Closes the form. (Inherited from System.Windows.Forms.Form)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from System.Windows.Forms.Form)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from System.Windows.Forms.ContainerControl)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from System.Windows.Forms.Form)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from System.Windows.Forms.ScrollableControl)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from System.Windows.Forms.Form)
public Method | Show | Overloaded. Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
public Method | ShowDialog | Overloaded. Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | Gets a string representing the current instance of the form. (Inherited from System.Windows.Forms.Form)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | Validate | Overloaded. Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
public Method | ValidateChildren | Overloaded. Causes all of the child controls within a control that support validation to validate their data. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

dbiTimeBarDialog Class
Dbi.PIM Namespace


%%PageItemTitle%% $$Properties$$

dbiTimeBarDialog Class Properties
[image]
dbiPim4 Assembly > Dbi.PIM Namespace : dbiTimeBarDialog Class

"

For a list of all members of this type, see dbiTimeBarDialog members.

"

Public Properties

 | Name | Description
public Property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from System.Windows.Forms.Form)
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveControl | Gets or sets the active control on the container control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from System.Windows.Forms.Form)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from System.Windows.Forms.Form)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Appointment | Gets or sets the appointment/time bar in the dbiTimeBarDialog object.
public Property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from System.Windows.Forms.Form)
public Property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | AutoSize | Resize the form according to the setting of System.Windows.Forms.Form.AutoSizeMode. (Inherited from System.Windows.Forms.Form)
public Property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from System.Windows.Forms.Form)
public Property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from System.Windows.Forms.Form)
public Property | BackColor | Gets or sets the backcolor of the time bar.
public Property | BackColorTo | Gets or sets the secondary backcolor of the time bar.
public Property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from System.Windows.Forms.Control)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.ContainerControl)
public Property | BorderColor | Gets or sets the border color of the time bar.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from System.Windows.Forms.Form)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from System.Windows.Forms.Form)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from System.Windows.Forms.ContainerControl)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | Delete | Determines if the Delete button was click in the dbiTimeBarDialog object.
public Property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from System.Windows.Forms.Form)
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DialogResult | Gets or sets the dialog result for the form. (Inherited from System.Windows.Forms.Form)
public Property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the forecolor of the time bar.
public Property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from System.Windows.Forms.Form)
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from System.Windows.Forms.Form)
public Property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Icon | Gets or sets the icon for the form. (Inherited from System.Windows.Forms.Form)
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from System.Windows.Forms.Form)
public Property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from System.Windows.Forms.Form)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from System.Windows.Forms.Form)
public Property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from System.Windows.Forms.Form)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Location | Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates. (Inherited from System.Windows.Forms.Form)
public Property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from System.Windows.Forms.Form)
public Property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from System.Windows.Forms.Form)
public Property | Menu | Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form. (Inherited from System.Windows.Forms.Form)
public Property | MergedMenu | Gets the merged menu for the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from System.Windows.Forms.Form)
public Property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from System.Windows.Forms.Form)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | Opacity | Gets or sets the opacity level of the form. (Inherited from System.Windows.Forms.Form)
public Property | OwnedForms | Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form. (Inherited from System.Windows.Forms.Form)
public Property | Owner | Gets or sets the form that owns this form. (Inherited from System.Windows.Forms.Form)
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | ParentForm | Gets the form that the container control is assigned to. (Inherited from System.Windows.Forms.ContainerControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from System.Windows.Forms.Form)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from System.Windows.Forms.Form)
public Property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from System.Windows.Forms.Form)
public Property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from System.Windows.Forms.Form)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the size of the form. (Inherited from System.Windows.Forms.Form)
public Property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from System.Windows.Forms.Form)
public Property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from System.Windows.Forms.Form)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Form)
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from System.Windows.Forms.Form)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from System.Windows.Forms.Form)
public Property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from System.Windows.Forms.Form)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from System.Windows.Forms.ScrollableControl)
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

dbiTimeBarDialog Class
Dbi.PIM Namespace


%%PageItemTitle%%

AcceptButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AcceptButton Property

Gets or sets the button on the form that is clicked when the user presses the ENTER key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}

Property Value

An System.Windows.Forms.IButtonControl that represents the button to use as the accept button for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AccessibilityObject Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AccessibleName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AccessibleRole Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Activate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Activate Method

Activates the form and gives it focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Activate()
C#
public void Activate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Activated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Activated Event

Occurs when the form is activated in code or by the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
public event System.EventHandler Activated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ActiveControl Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ActiveControl Property

Gets or sets the active control on the container control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
public System.Windows.Forms.Control ActiveControl {get; set;}

Property Value

The System.Windows.Forms.Control that is currently active on the System.Windows.Forms.ContainerControl.

Exceptions

Exception | Description
System.ArgumentException | The System.Windows.Forms.Control assigned could not be activated.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ActiveMdiChild Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ActiveMdiChild Property

Gets the currently active multiple-document interface (MDI) child window.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Form

value = instance.ActiveMdiChild
C#
public System.Windows.Forms.Form ActiveMdiChild {get;}

Property Value

Returns a System.Windows.Forms.Form that represents the currently active MDI child window, or null if there are currently no child windows present.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AddOwnedForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AddOwnedForm Method

ownedForm
The System.Windows.Forms.Form that this form will own.
Adds an owned form to this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)

Parameters

ownedForm
The System.Windows.Forms.Form that this form will own.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AllowTransparency Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AllowTransparency Property

Gets or sets a value indicating whether the opacity of the form can be adjusted.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.AllowTransparency = value

value = instance.AllowTransparency
C#
public System.bool AllowTransparency {get; set;}

Property Value

true if the opacity of the form can be changed; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Anchor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScroll Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScroll Property

Gets or sets a value indicating whether the form enables autoscrolling.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
public virtual System.bool AutoScroll {get; set;}

Property Value

true to enable autoscrolling on the form; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScrollMargin Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScrollMargin Property

Gets or sets the size of the auto-scroll margin.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
public System.Drawing.Size AutoScrollMargin {get; set;}

Property Value

A System.Drawing.Size that represents the height and width of the auto-scroll margin in pixels.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The System.Drawing.Size.Height or System.Drawing.Size.Width value assigned is less than 0.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScrollMinSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScrollMinSize Property

Gets or sets the minimum size of the auto-scroll.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
public System.Drawing.Size AutoScrollMinSize {get; set;}

Property Value

A System.Drawing.Size that determines the minimum size of the virtual area through which the user can scroll.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

AutoScrollPosition Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : AutoScrollPosition Property

Gets or sets the location of the auto-scroll position.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Point

instance.AutoScrollPosition = value

value = instance.AutoScrollPosition
C#
public System.Drawing.Point AutoScrollPosition {get; set;}

Property Value

A System.Drawing.Point that represents the auto-scroll position in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackColorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackColorChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackColor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
public event System.EventHandler BackColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackgroundImage Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackgroundImage Property

Gets or sets the background image displayed in the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public virtual System.Drawing.Image BackgroundImage {get; set;}

Property Value

An System.Drawing.Image that represents the image to display in the background of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BackgroundImageChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BackgroundImageChanged Event

Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
public event System.EventHandler BackgroundImageChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BeginInvoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BeginInvoke Method

Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Overload List

Overload | Description
BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

BindingContext Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BindingContextChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BindingContextChanged Event

Occurs when the value of the System.Windows.Forms.BindingContext property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
public event System.EventHandler BindingContextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Bottom Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Bounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

BringToFront Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CancelButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CancelButton Property

Gets or sets the button control that is clicked when the user presses the ESC key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
public System.Windows.Forms.IButtonControl CancelButton {get; set;}

Property Value

An System.Windows.Forms.IButtonControl that represents the cancel button for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CanFocus Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CanSelect Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Capture Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CausesValidation Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CausesValidationChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CausesValidationChanged Event

Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
public event System.EventHandler CausesValidationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ChangeUICues Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ChangeUICues Event

Occurs when the focus or keyboard user interface (UI) cues change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
public event System.Windows.Forms.UICuesEventHandler ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Click Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Click Event

Occurs when the control is clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
public event System.EventHandler Click

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ClientRectangle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ClientSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ClientSize Property

Gets or sets the size of the client area of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the size of the form's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Close Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Close Method

Closes the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Close()
C#
public void Close()

Exceptions

Exception | Description
System.InvalidOperationException | The form was closed while a handle was being created.
System.ObjectDisposedException | You cannot call this method from the System.Windows.Forms.Form.Activated event when System.Windows.Forms.Form.WindowState is set to System.Windows.Forms.FormWindowState.Maximized.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CompanyName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Container Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Contains Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ContainsFocus Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ContextMenu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ContextMenuChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ContextMenuChanged Event

Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
public event System.EventHandler ContextMenuChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ControlAdded Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ControlAdded Event

Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ControlBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ControlBox Property

Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
public System.bool ControlBox {get; set;}

Property Value

true if the form displays a control box in the upper left corner of the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ControlRemoved Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ControlRemoved Event

Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
public event System.Windows.Forms.ControlEventHandler ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Controls Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CreateControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Created Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CreateGraphics Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CreateObjRef Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Cursor Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

CursorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : CursorChanged Event

Occurs when the value of the System.Windows.Forms.Control.Cursor property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
public event System.EventHandler CursorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DataBindings Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Deactivate Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Deactivate Event

Occurs when the form loses focus and is no longer the active form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
public event System.EventHandler Deactivate

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DesktopBounds Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DesktopBounds Property

Gets or sets the size and location of the form on the Windows desktop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Rectangle

instance.DesktopBounds = value

value = instance.DesktopBounds
C#
public System.Drawing.Rectangle DesktopBounds {get; set;}

Property Value

A System.Drawing.Rectangle that represents the bounds of the form on the Windows desktop using desktop coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DesktopLocation Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DesktopLocation Property

Gets or sets the location of the form on the Windows desktop.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Point

instance.DesktopLocation = value

value = instance.DesktopLocation
C#
public System.Drawing.Point DesktopLocation {get; set;}

Property Value

A System.Drawing.Point that represents the location of the form on the desktop.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DialogResult Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DialogResult Property

Gets or sets the dialog result for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
public System.Windows.Forms.DialogResult DialogResult {get; set;}

Property Value

A System.Windows.Forms.DialogResult that represents the result of the form when used as a dialog box.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DisplayRectangle Property

Gets the rectangle that represents the virtual display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Disposed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Disposed Event

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
public event System.EventHandler Disposed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Disposing Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Dock Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DockChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DockChanged Event

Occurs when the value of the System.Windows.Forms.Control.Dock property changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
public event System.EventHandler DockChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DoDragDrop Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DoubleClick Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DoubleClick Event

Occurs when the control is double-clicked.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
public event System.EventHandler DoubleClick

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DragDrop Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DragDrop Event

Occurs when a drag-and-drop operation is completed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
public event System.Windows.Forms.DragEventHandler DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DragEnter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DragLeave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DragLeave Event

Occurs when an object is dragged out of the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
public event System.EventHandler DragLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

DragOver Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : DragOver Event

Occurs when an object is dragged over the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
public event System.Windows.Forms.DragEventHandler DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Enabled Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

EnabledChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : EnabledChanged Event

Occurs when the System.Windows.Forms.Control.Enabled property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
public event System.EventHandler EnabledChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

EndInvoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Enter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Enter Event

Occurs when the control is entered.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
public event System.EventHandler Enter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

FindForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Focus Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Focused Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Font Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Font Property

Gets or sets the font of the text displayed by the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
public virtual System.Drawing.Font Font {get; set;}

Property Value

The System.Drawing.Font to apply to the text displayed by the control. The default is the value of the System.Windows.Forms.Control.DefaultFont property.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

FontChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : FontChanged Event

Occurs when the System.Windows.Forms.Control.Font property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
public event System.EventHandler FontChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ForeColorChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ForeColorChanged Event

Occurs when the System.Windows.Forms.Control.ForeColor property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
public event System.EventHandler ForeColorChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

FormBorderStyle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : FormBorderStyle Property

Gets or sets the border style of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}

Property Value

A System.Windows.Forms.FormBorderStyle that represents the style of border to display for the form. The default is FormBorderStyle.Sizable.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

GetContainerControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GetNextControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GiveFeedback Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GiveFeedback Event

Occurs during a drag operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

GotFocus Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : GotFocus Event

Occurs when the control receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
public event System.EventHandler GotFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Handle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HandleCreated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HandleCreated Event

Occurs when a handle is created for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
public event System.EventHandler HandleCreated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HandleDestroyed Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HandleDestroyed Event

Occurs when the control's handle is in the process of being destroyed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
public event System.EventHandler HandleDestroyed

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HasChildren Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Height Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HelpButton Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HelpButton Property

Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
public System.bool HelpButton {get; set;}

Property Value

true to display a Help button in the form's caption bar; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

HelpRequested Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : HelpRequested Event

Occurs when the user requests help for a control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
public event System.Windows.Forms.HelpEventHandler HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Hide Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Icon Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Icon Property

Gets or sets the icon for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
public System.Drawing.Icon Icon {get; set;}

Property Value

An System.Drawing.Icon that represents the icon for the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ImeMode Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ImeModeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ImeModeChanged Event

Occurs when the System.Windows.Forms.Control.ImeMode property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
public event System.EventHandler ImeModeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

InputLanguageChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : InputLanguageChanged Event

Occurs after the input language of the form has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

InputLanguageChanging Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : InputLanguageChanging Event

Occurs when the user attempts to change the input language for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Invalidate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Invalidate() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invalidated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Invalidated Event

Occurs when a control's display requires redrawing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
public event System.Windows.Forms.InvalidateEventHandler Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Invoke Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
N
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
N

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

InvokeRequired Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsAccessible Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsDisposed Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsMdiChild Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsMdiChild Property

Gets a value indicating whether the form is a multiple-document interface (MDI) child form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.IsMdiChild
C#
public System.bool IsMdiChild {get;}

Property Value

true if the form is an MDI child form; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsMdiContainer Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsMdiContainer Property

Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
public System.bool IsMdiContainer {get; set;}

Property Value

true if the form is a container for MDI child forms; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

IsRestrictedWindow Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : IsRestrictedWindow Property

Gets a value indicating whether the form can use all windows and user input events without restriction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.IsRestrictedWindow
C#
public System.bool IsRestrictedWindow {get;}

Property Value

true if the form has restrictions; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

KeyDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : KeyDown Event

Occurs when a key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

KeyPress Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : KeyPress Event

Occurs when a character. space or backspace key is pressed while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
public event System.Windows.Forms.KeyPressEventHandler KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

KeyPreview Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : KeyPreview Property

Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
public System.bool KeyPreview {get; set;}

Property Value

true if the form will receive all key events; false if the currently selected control on the form receives key events. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

KeyUp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : KeyUp Event

Occurs when a key is released while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
public event System.Windows.Forms.KeyEventHandler KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Layout Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Layout Event

Occurs when a control should reposition its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
public event System.Windows.Forms.LayoutEventHandler Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

LayoutMdi Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : LayoutMdi Method

value
One of the System.Windows.Forms.MdiLayout values that defines the layout of MDI child forms.
Arranges the multiple-document interface (MDI) child forms within the MDI parent form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value
One of the System.Windows.Forms.MdiLayout values that defines the layout of MDI child forms.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Leave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Leave Event

Occurs when the input focus leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
public event System.EventHandler Leave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Left Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Load Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Load Event

Occurs before a form is displayed for the first time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
public event System.EventHandler Load

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Location Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Location Property

Gets or sets the System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the System.Windows.Forms.Form in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

LocationChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : LocationChanged Event

Occurs when the System.Windows.Forms.Control.Location property value has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
public event System.EventHandler LocationChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

LostFocus Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : LostFocus Event

Occurs when the control loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
public event System.EventHandler LostFocus

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MaximizeBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MaximizeBox Property

Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
public System.bool MaximizeBox {get; set;}

Property Value

true to display a Maximize button for the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MaximizedBoundsChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MaximizedBoundsChanged Event

Occurs when the value of the System.Windows.Forms.Form.MaximizedBounds property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
public event System.EventHandler MaximizedBoundsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MaximumSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MaximumSize Property

Gets the maximum size the form can be resized to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
public virtual System.Drawing.Size MaximumSize {get; set;}

Property Value

A System.Drawing.Size that represents the maximum size for the form.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The values of the height or width within the System.Drawing.Size object are less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MaximumSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MaximumSizeChanged Event

Occurs when the value of the System.Windows.Forms.Form.MaximumSize property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
public event System.EventHandler MaximumSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MdiChildActivate Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MdiChildActivate Event

Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
public event System.EventHandler MdiChildActivate

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MdiChildren Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MdiChildren Property

Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value() As System.Windows.Forms.Form

value = instance.MdiChildren
C#
public System.Windows.Forms.Form[] MdiChildren {get;}

Property Value

An array of System.Windows.Forms.Form objects, each of which identifies one of this form's MDI child forms.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MdiParent Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MdiParent Property

Gets or sets the current multiple-document interface (MDI) parent form of this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Form

instance.MdiParent = value

value = instance.MdiParent
C#
public System.Windows.Forms.Form MdiParent {get; set;}

Property Value

A System.Windows.Forms.Form that represents the MDI parent form.

Exceptions

Exception | Description
System.Exception | The System.Windows.Forms.Form assigned to this property is not marked as an MDI container.-or- The System.Windows.Forms.Form assigned to this property is both a child and an MDI container form.-or- The System.Windows.Forms.Form assigned to this property is located on a different thread.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Menu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Menu Property

Gets or sets the System.Windows.Forms.MainMenu that is displayed in the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.MainMenu

instance.Menu = value

value = instance.Menu
C#
public System.Windows.Forms.MainMenu Menu {get; set;}

Property Value

A System.Windows.Forms.MainMenu that represents the menu to display in the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MenuComplete Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MenuComplete Event

Occurs when the menu of a form loses focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MenuComplete, handler
C#
public event System.EventHandler MenuComplete

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MenuStart Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MenuStart Event

Occurs when the menu of a form receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MenuStart, handler
C#
public event System.EventHandler MenuStart

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MergedMenu Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MergedMenu Property

Gets the merged menu for the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.MainMenu

value = instance.MergedMenu
C#
public System.Windows.Forms.MainMenu MergedMenu {get;}

Property Value

A System.Windows.Forms.MainMenu that represents the merged menu of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MinimizeBox Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MinimizeBox Property

Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
public System.bool MinimizeBox {get; set;}

Property Value

true to display a Minimize button for the form; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MinimumSize Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MinimumSize Property

Gets or sets the minimum size the form can be resized to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
public virtual System.Drawing.Size MinimumSize {get; set;}

Property Value

A System.Drawing.Size that represents the minimum size for the form.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | The values of the height or width within the System.Drawing.Size object are less than zero.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MinimumSizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MinimumSizeChanged Event

Occurs when the value of the System.Windows.Forms.Form.MinimumSize property has changed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
public event System.EventHandler MinimumSizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Modal Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Modal Property

Gets a value indicating whether this form is displayed modally.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Modal
C#
public System.bool Modal {get;}

Property Value

true if the form is displayed modally; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseDown Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseDown Event

Occurs when the mouse pointer is over the control and a mouse button is pressed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseEnter Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseEnter Event

Occurs when the mouse pointer enters the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
public event System.EventHandler MouseEnter

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseHover Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseHover Event

Occurs when the mouse pointer rests on the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
public event System.EventHandler MouseHover

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseLeave Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseLeave Event

Occurs when the mouse pointer leaves the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
public event System.EventHandler MouseLeave

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseMove Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseMove Event

Occurs when the mouse pointer is moved over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseUp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseUp Event

Occurs when the mouse pointer is over the control and a mouse button is released.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

MouseWheel Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : MouseWheel Event

Occurs when the mouse wheel moves while the control has focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
public event System.Windows.Forms.MouseEventHandler MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Move Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Move Event

Occurs when the control is moved.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
public event System.EventHandler Move

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Name Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Opacity Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Opacity Property

Gets or sets the opacity level of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
public System.double Opacity {get; set;}

Property Value

The level of opacity for the form. The default is 1.00.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

OwnedForms Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : OwnedForms Property

Gets an array of System.Windows.Forms.Form objects that represent all forms that are owned by this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value() As System.Windows.Forms.Form

value = instance.OwnedForms
C#
public System.Windows.Forms.Form[] OwnedForms {get;}

Property Value

A System.Windows.Forms.Form array that represents the owned forms for this form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Owner Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Owner Property

Gets or sets the form that owns this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Form

instance.Owner = value

value = instance.Owner
C#
public System.Windows.Forms.Form Owner {get; set;}

Property Value

A System.Windows.Forms.Form that represents the form that is the owner of this form.

Exceptions

Exception | Description
System.Exception | A top-level window cannot have an owner.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Paint Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Paint Event

Occurs when the control is redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
public event System.Windows.Forms.PaintEventHandler Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Parent Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ParentChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ParentChanged Event

Occurs when the System.Windows.Forms.Control.Parent property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
public event System.EventHandler ParentChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ParentForm Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ParentForm Property

Gets the form that the container control is assigned to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Form

value = instance.ParentForm
C#
public System.Windows.Forms.Form ParentForm {get;}

Property Value

The System.Windows.Forms.Form that the container control is assigned to. This property will return null if the control is hosted inside of Internet Explorer or in another hosting context where there is no parent form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PerformLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PerformLayout() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

PointToClient Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PointToScreen Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ProductName Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ProductVersion Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

QueryAccessibilityHelp Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : QueryAccessibilityHelp Event

Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

QueryContinueDrag Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : QueryContinueDrag Event

Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RectangleToClient Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RectangleToClient Method

r
The screen coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified screen rectangle in client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r
The screen coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, r, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RectangleToScreen Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RectangleToScreen Method

r
The client coordinate System.Drawing.Rectangle to convert.
Computes the size and location of the specified client rectangle in screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r
The client coordinate System.Drawing.Rectangle to convert.

Return Value

A System.Drawing.Rectangle that represents the converted System.Drawing.Rectangle, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Refresh Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Region Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RemoveOwnedForm Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RemoveOwnedForm Method

ownedForm
A System.Windows.Forms.Form representing the form to remove from the list of owned forms for this form.
Removes an owned form from this form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)

Parameters

ownedForm
A System.Windows.Forms.Form representing the form to remove from the list of owned forms for this form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ResetText Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ResetText Method

Resets the System.Windows.Forms.Control.Text property to its default value.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.ResetText()
C#
public virtual void ResetText()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Resize Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Resize Event

Occurs when the control is resized.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
public event System.EventHandler Resize

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ResumeLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ResumeLayout() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Right Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RightToLeft Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

RightToLeftChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : RightToLeftChanged Event

Occurs when the System.Windows.Forms.Control.RightToLeft property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
public event System.EventHandler RightToLeftChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Scale Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ScrollControlIntoView Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ScrollControlIntoView Method

activeControl
The child control to scroll into view.
Scrolls the specified child control into view on an auto-scroll enabled control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)

Parameters

activeControl
The child control to scroll into view.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Select Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Select Method

Selects this form, and optionally selects the next or previous control.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Select() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Select() Method

Activates the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Select()
C#
public void Select()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SelectNextControl Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SelectNextControl Method

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.
Activates the next control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
The System.Windows.Forms.Control at which to start the search.
forward
true to move forward in the tab order; false to move backward in the tab order.
tabStopOnly
true to ignore the controls with the System.Windows.Forms.Control.TabStop property set to false; otherwise, false.
nested
true to include nested (children of child controls) child controls; otherwise, false.
wrap
true to continue searching from the first control in the tab order after the last control has been reached; otherwise, false.

Return Value

true if a control was activated; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SendToBack Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SetAutoScrollMargin Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SetAutoScrollMargin Method

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.
Sets the size of the auto-scroll margins.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
The System.Drawing.Size.Width value.
y
The System.Drawing.Size.Height value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SetBounds Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SetBounds Method

Sets the bounds of the control to the specified location and size.

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

SetDesktopBounds Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SetDesktopBounds Method

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
width
The width of the form.
height
The height of the form.
Sets the bounds of the form in desktop coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
width
The width of the form.
height
The height of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SetDesktopLocation Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SetDesktopLocation Method

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.
Sets the location of the form in desktop coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
The x-coordinate of the form's location.
y
The y-coordinate of the form's location.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Show Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Show Method

Shows the form with the specified owner to the user.

Overload List

Overload | Description
Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from System.Windows.Forms.Form)
Show() | Displays the control to the user. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Show() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Show Method : Show() Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Show(IWin32Window) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Show Method : Show(IWin32Window) Method

owner
Any object that implements System.Windows.Forms.IWin32Window and represents the top-level window that will own this form.
Shows the form with the specified owner to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)

Parameters

owner
Any object that implements System.Windows.Forms.IWin32Window and represents the top-level window that will own this form.

Exceptions

Exception | Description
System.InvalidOperationException | The form being shown is already visible.-or- The form specified in the owner parameter is the same as the form being shown.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ShowDialog Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ShowDialog Method

Shows the form as a modal dialog box.

Overload List

Overload | Description
ShowDialog() | Shows the form as a modal dialog box. (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ShowDialog() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ShowDialog Method : ShowDialog() Method

Shows the form as a modal dialog box.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
public System.Windows.Forms.DialogResult ShowDialog()

Return Value

One of the System.Windows.Forms.DialogResult values.

Exceptions

Exception | Description
System.InvalidOperationException | The form being shown is already visible.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ShowDialog(IWin32Window) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog box.
Shows the form as a modal dialog box with the specified owner.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)

Parameters

owner
Any object that implements System.Windows.Forms.IWin32Window that represents the top-level window that will own the modal dialog box.

Return Value

One of the System.Windows.Forms.DialogResult values.

Exceptions

Exception | Description
System.ArgumentException | The form specified in the owner parameter is the same as the form being shown.
System.InvalidOperationException | The form being shown is already visible.-or- The form being shown is disabled.-or- The form being shown is not a top-level window.-or- The form being shown as a dialog box is already a modal form.-or-The current process is not running in user interactive mode (for more information, see System.Windows.Forms.SystemInformation.UserInteractive).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ShowInTaskbar Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ShowInTaskbar Property

Gets or sets a value indicating whether the form is displayed in the Windows taskbar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
public System.bool ShowInTaskbar {get; set;}

Property Value

true to display the form in the Windows taskbar at run time; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Site Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Size Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Size Property

Gets or sets the size of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

A System.Drawing.Size that represents the size of the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SizeChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SizeChanged Event

Occurs when the System.Windows.Forms.Control.Size property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
public event System.EventHandler SizeChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SizeGripStyle Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SizeGripStyle Property

Gets or sets the style of the size grip to display in the lower-right corner of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}

Property Value

A System.Windows.Forms.SizeGripStyle that represents the style of the size grip to display. The default is System.Windows.Forms.SizeGripStyle.Auto

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

StartPosition Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : StartPosition Property

Gets or sets the starting position of the form at run time.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}

Property Value

A System.Windows.Forms.FormStartPosition that represents the starting position of the form.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

StyleChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : StyleChanged Event

Occurs when the control style changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
public event System.EventHandler StyleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SuspendLayout Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

SystemColorsChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : SystemColorsChanged Event

Occurs when the system colors change.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
public event System.EventHandler SystemColorsChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Tag Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Text Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

TextChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : TextChanged Event

Occurs when the System.Windows.Forms.Control.Text property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
public event System.EventHandler TextChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Top Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

TopLevel Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : TopLevel Property

Gets or sets a value indicating whether to display the form as a top-level window.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.TopLevel = value

value = instance.TopLevel
C#
public System.bool TopLevel {get; set;}

Property Value

true to display the form as a top-level window; otherwise, false. The default is true.

Exceptions

Exception | Description
System.Exception | A Multiple-document interface (MDI) parent form must be a top-level window.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

TopLevelControl Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

TopMost Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : TopMost Property

Gets or sets a value indicating whether the form should be displayed as a topmost form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
public System.bool TopMost {get; set;}

Property Value

true to display the form as a topmost form; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

ToString Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : ToString Method

Gets a string representing the current instance of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Return Value

A string consisting of the fully qualified name of the form object's class, with the System.Windows.Forms.Form.Text property of the form appended to the end. For example, if the form is derived from the class MyForm in the MyNamespace namespace, and the System.Windows.Forms.Form.Text property is set to Hello, World, this method will return MyNamespace.MyForm, Text: Hello, World.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

TransparencyKey Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : TransparencyKey Property

Gets or sets the color that will represent transparent areas of the form.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
public System.Drawing.Color TransparencyKey {get; set;}

Property Value

A System.Drawing.Color that represents the color to display transparently on the form.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Update Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Validate Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Validate Method

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Overload List

Overload | Description
Validate() | Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order. (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Validate() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Validate Method : Validate() Method

Verifies the value of the control losing focus by causing the System.Windows.Forms.Control.Validating and System.Windows.Forms.Control.Validated events to occur, in that order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.Validate()
C#
public System.bool Validate()

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Validate(Boolean) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > Validate Method : Validate(Boolean) Method

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.
Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate
If true, the value of the System.Windows.Forms.ContainerControl.AutoValidate property is used to determine if validation should be performed; if false, validation is unconditionally performed.

Return Value

true if validation is successful; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ValidateChildren() Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ValidateChildren Method : ValidateChildren() Method

Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
public virtual System.bool ValidateChildren()

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

ValidateChildren(ValidationConstraints) Method
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.
Causes all of the child controls within a control that support validation to validate their data.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints
Places restrictions on which controls have their System.Windows.Forms.Control.Validating event raised.

Return Value

true if all of the children validated successfully; otherwise, false. If called from the System.Windows.Forms.Control.Validating or System.Windows.Forms.Control.Validated event handlers, this method will always return false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members
Overload List


%%PageItemTitle%%

Validated Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Validated Event

Occurs when the control is finished validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
public event System.EventHandler Validated

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Validating Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Validating Event

Occurs when the control is validating.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
public event System.ComponentModel.CancelEventHandler Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Visible Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

VisibleChanged Event
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : VisibleChanged Event

Occurs when the System.Windows.Forms.Control.Visible property value changes.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
public event System.EventHandler VisibleChanged

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

Width Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%PageItemTitle%%

WindowState Property
[image]
dbiPim4 Assembly > Dbi.PIM Namespace > dbiTimeBarDialog Class : WindowState Property

Gets or sets a value that indicates whether form is minimized, maximized, or normal.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiTimeBarDialog
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
public System.Windows.Forms.FormWindowState WindowState {get; set;}

Property Value

A System.Windows.Forms.FormWindowState that represents whether form is minimized, maximized, or normal. The default is FormWindowState.Normal.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value specified is outside the range of valid values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiTimeBarDialog Class
dbiTimeBarDialog Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Dbi.PIM Namespace Inheritance Hierarchy
dbiPim4 Assembly : Dbi.PIM Namespace

Inheritance Hierarchy

System.Object
Dbi.PIM.AlarmEventArgs
Dbi.PIM.dbiAppointmentItem
Dbi.PIM.dbiContactItem
Dbi.PIM.dbiCustomArea
Dbi.PIM.CustomArea
Dbi.PIM.dbiDayFormat
Dbi.PIM.dbiLocationItem
Dbi.PIM.dbiTaskItem
System.Collections.CollectionBase
Dbi.CollectionBaseEvents
Dbi.PIM.AlarmItemCollection
Dbi.PIM.dbiAppointmentCollection
Dbi.PIM.dbiContactCollection
Dbi.PIM.dbiCustomAreaCollection
Dbi.PIM.dbiDayFormatCollection
Dbi.PIM.dbiLocationCollection
Dbi.PIM.dbiTaskCollection
Dbi.PIM.DaysWeekendCollection
System.MarshalByRefObject
System.ComponentModel.Component
Dbi.PIM.dbiPIM
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
Dbi.PIM.dbiReminderDialog
Dbi.PIM.dbiTimeBarDialog

See Also

Reference

dbiPim4 Assembly


%%phrase%%

dbiScheduleE Assembly

Object Model

dbiSchedule ClassdbiColumnItem ClassdbiColumnFormat ClassColumnItemCollection ClassdbiColumnItem ClassdbiColumnFormat ClassdbiComboBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiColumnItem ClassdbiColumnFormat ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassScheduleItemCollection ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassLinkCollection ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiColumnItem ClassColumnItemCollection ClassdbiColumnItem ClassdbiComboBox ClassdbiColumnItem ClassdbiNodeItem ClassdbiTextBox ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassHistoryCollection ClassdbiHistoryItem ClassdbiLinkItem ClassdbiScheduleItem ClassdbiScheduleItem ClassdbiTimeBarItem ClassdbiTimeBarItem ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassScheduleCollection ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine ClassTimeBarItemCollection ClassdbiTimeBarItem ClassdbiTextBox ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassTimeBarStyleCollection ClassdbiTimeBarStyle ClassHistoryCollection ClassdbiHistoryItem ClassdbiLinkItem ClassdbiScheduleItem ClassdbiScheduleItem ClassdbiTimeBarItem ClassdbiTimeBarItem ClassDaysWeekendCollection Class
The dbiSchedule control.

Namespaces

Namespace | Description
Dbi.WinControl.Schedule |


%%PageItemTitle%% $$Properties$$

AfterGuideLineInsertedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineInsertedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineInsertedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was inserted.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was inserted into.
Top

See Also

Reference

AfterGuideLineInsertedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterGuideLineMovedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineMovedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineMovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was moved.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was moved into.
Top

See Also

Reference

AfterGuideLineMovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterGuideLineRemovedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterGuideLineRemovedEventArgs Class

"

For a list of all members of this type, see AfterGuideLineRemovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that was removed.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine was removed from.
Top

See Also

Reference

AfterGuideLineRemovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarDropEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarDropEventArgs Class

"

For a list of all members of this type, see AfterTimeBarDropEventArgs members.

"

Public Properties

 | Name | Description
public Property | drgevent | Gets or sets the drag and drop information after a Timebar has been dropped.
public Property | ScheduleItem | The dbiScheduleItem the timebar has been added to.
public Property | TimeBarItem | The dbiTimeBar that was modified in the BeforeTimeBarDrop event.
Top

See Also

Reference

AfterTimeBarDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarInsertedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarInsertedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarInsertedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the inserted Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar after it was inserted.
public Property | TimeBarItem | The dbiTimebarItem after it has been inserted.
public Property | WasDropped | Indicates if the inserted TimeBar came from a Drag and Drop operation.
Top

See Also

Reference

AfterTimeBarInsertedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarLinkedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarLinkedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarLinkedEventArgs members.

"

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem after it is applied between two Timebars.
Top

See Also

Reference

AfterTimeBarLinkedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarMovedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarMovedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarMovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it was moved.
public Property | ScheduleItemTo | The dbiScheduleItem containing the Timebar after it has been moved.
public Property | TimeBarItem | The dbiTimebarItem after it has been moved.
public Property | Vertical | Determines if the Timebar was moved vertically.
Top

See Also

Reference

AfterTimeBarMovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarRemovedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarRemovedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarRemovedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it was removed.
Top

See Also

Reference

AfterTimeBarRemovedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarSelectEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSelectEventArgs Class

"

For a list of all members of this type, see AfterTimeBarSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem that was selected.
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was selected.
public Property | TimeBarItem | The dbiTimeBarItem that was selected.
Top

See Also

Reference

AfterTimeBarSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarSizedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSizedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarSizedEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar after it has been sized.
public Property | TimeBarItem | The dbiTimebarItem after it has been sized.
Top

See Also

Reference

AfterTimeBarSizedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarSplitEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarSplitEventArgs Class

"

For a list of all members of this type, see AfterTimeBarSplitEventArgs members.

"

Public Properties

 | Name | Description
public Property | ScheduleItem | The dbiScheduleItem containing the Timebars after they have been split.
public Property | TimeBarNew | The newly created dbiTimebarItem.
public Property | TimeBarOld | The original dbiTimebarItem.
Top

See Also

Reference

AfterTimeBarSplitEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarUnlinkedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnlinkedEventArgs Class

"

For a list of all members of this type, see AfterTimeBarUnlinkedEventArgs members.

"

Public Properties

 | Name | Description
public Property | Link | The dbiLinkItem which was removed between two Timebars.
Top

See Also

Reference

AfterTimeBarUnlinkedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AfterTimeBarUnSelectEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AfterTimeBarUnSelectEventArgs Class

"

For a list of all members of this type, see AfterTimeBarUnSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem that was unselected.
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem that was unselected.
public Property | TimeBarItem | The dbiTimeBarItem that was unselected
Top

See Also

Reference

AfterTimeBarUnSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AlarmTimeBarEndEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarEndEventArgs Class

"

For a list of all members of this type, see AlarmTimeBarEndEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
public Property | TimeBarItem | The dbiTimebarItem whose alarm has fired.
Top

See Also

Reference

AlarmTimeBarEndEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

AlarmTimeBarStartEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : AlarmTimeBarStartEventArgs Class

"

For a list of all members of this type, see AlarmTimeBarStartEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar whose alarm fired.
public Property | TimeBarItem | The dbiTimebarItem whose alarm has fired.
Top

See Also

Reference

AlarmTimeBarStartEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeGuideLineInsertEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineInsertEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineInsertEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the GuideLine can be added.
public Property | GuideLine | The dbiGuideLine that is being inserted.
public Property | InDeadZone | Determines if the new GuideLine intersects with a dbiCustomArea flagged as a DeadZone.
public Property | LineTime | The date/time value for the GuideLine.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being inserted into.
Top

See Also

Reference

BeforeGuideLineInsertEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeGuideLineMoveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineMoveEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the GuideLine can be moved.
public Property | GuideLine | The dbiGuideLine that is being moved.
public Property | InDeadZone | Indicates if the dbiGuideLine is moving into a dead zone. You can then set the AllowMove accordingly.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The date/time value for the GuideLine.
public Property | OldLineTime | The old date/time value for the GuideLine
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being moved into.
Top

See Also

Reference

BeforeGuideLineMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeGuideLineRemoveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeGuideLineRemoveEventArgs Class

"

For a list of all members of this type, see BeforeGuideLineRemoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the GuideLine can be removed.
public Property | GuideLine | The dbiGuideLine that is being removed.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | LineTime | The original time of the guideline. Setting AllowRemoval Property = False and modifying this property will place the guideline at this value.
public Property | ScheduleObject | The dbiScheduleObject the GuideLine is being removed from.
Top

See Also

Reference

BeforeGuideLineRemoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforePrintPageNumberEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforePrintPageNumberEventArgs Class

"

For a list of all members of this type, see BeforePrintPageNumberEventArgs members.

"

Public Properties

 | Name | Description
public Property | CurrentPage | The number of the page to be printed.
public Property | Text | Gets/sets the text printed on the page to display the current/max page number.
public Property | TotalPages | The total number of pages to be printed.
Top

See Also

Reference

BeforePrintPageNumberEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarDropEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarDropEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarDropEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowDrop | Determines if the Timebar can be dropped.
public Property | drgevent | Gets or sets the drag and drop information before a Timebar has been dropped.
public Property | ScheduleItem | The dbiScheduleItem the drop occurred on.
public Property | TimeBarItem | The dbiTimebarItem before it is dropped.
Top

See Also

Reference

BeforeTimeBarDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarInsertEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarInsertEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarInsertEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowInsert | Determines if the Timebar can be inserted.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is inserted.
public Property | TimeBarItem | The dbiTimebarItem before it is inserted.
Top

See Also

Reference

BeforeTimeBarInsertEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarLinkEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarLinkEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarLinkEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowLink | Determines if the Timebars can be linked together.
public Property | Link | The dbiLinkItem before it is applied between two Timebars.
Top

See Also

Reference

BeforeTimeBarLinkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarMoveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarMoveEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowMove | Determines if the Timebar can be moved.
public Property | End | The new ending DateTime for the Timebar.
public Property | ScheduleItemFrom | The dbiScheduleItem containing the Timebar before it is moved.
public Property | ScheduleItemTo | The dbiScheduleItem containing the Timebar after it is moved.
public Property | Start | The new starting DateTime for the Timebar.
public Property | TimeBarItem | The dbiTimebarItem before it is moved.
public Property | Vertical | Determines if the Timebar is being moved vertically.
Top

See Also

Reference

BeforeTimeBarMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarRemoveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarRemoveEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarRemoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowRemoval | Determines if the Timebar can be removed.
public Property | BarIndex | The zero-based index value of the Timebar to be removed.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is removed.
public Property | TimeBarItem | The dbiTimebarItem before it is removed.
Top

See Also

Reference

BeforeTimeBarRemoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSelectEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSelectEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSelect | Determines if the Timebar can be selected.
public Property | BarIndex | The zero-based index value of the Timebar being selected.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is selected.
public Property | TimeBarItem | The dbiTimebarItem before it is selected.
Top

See Also

Reference

BeforeTimeBarSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSizeEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSizeEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSizeEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSize | Determines if the Timebar can be sized.
public Property | BarIndex | The zero-based index value of the Timebar to be sized.
public Property | End | The new starting DateTime for the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar before it is sized.
public Property | Start | The new starting DateTime for the Timebar.
public Property | TimeBarItem | The dbiTimebarItem before it is sized.
Top

See Also

Reference

BeforeTimeBarSizeEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarSplitEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarSplitEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarSplitEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowSplit | Determines if the split will be allowed to process. This can be set to False to cancel the split.
public Property | BarIndex | Gets the bar index value that is being split.
public Property | ScheduleItem | Get the schedule item of the Timebar that is being split.
public Property | SplitAt | Gets the Date/Time value where the split is occuring.
public Property | TimeBarItem | Gets the Timebar where the split is occurring.
Top

See Also

Reference

BeforeTimeBarSplitEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarUnlinkEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnlinkEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarUnlinkEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowUnlink | Determines if the dbiLinkItem can be removed.
public Property | Link | The dbiLinkItem to remove.
Top

See Also

Reference

BeforeTimeBarUnlinkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeTimeBarUnSelectEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeTimeBarUnSelectEventArgs Class

"

For a list of all members of this type, see BeforeTimeBarUnSelectEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowUnSelect | Determines if the unselect will be allowed.
public Property | BarIndex | The zero-based index value of the dbiTimeBarItem to unselect
public Property | ScheduleItem | The dbiScheduleItem that contains the dbiTimeBarItem being unselected.
public Property | TimeBarItem | The dbiTimeBarItem being unselected
Top

See Also

Reference

BeforeTimeBarUnSelectEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

BeforeToolTipsEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : BeforeToolTipsEventArgs Class

"

For a list of all members of this type, see BeforeToolTipsEventArgs members.

"

Public Properties

 | Name | Description
public Property | Align | Determines the alignment of the text displayed within the tool tip.
public Property | BackColor | Determines the primary color that will be used to paint the background of the tool tip.
public Property | BackColorTo | Determines the secondary color that will be used to paint the background of the tool tip.
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | BorderColor | Determines the color that will be used to paint the border of the tool tip.
public Property | BorderType | Determines the type of border to apply to the tool tip.
public Property | Display | Determines if the tool tip will be displayed.
public Property | Duration | Determines how long (in milliseconds) the tool tip remains visible when the mouse is static.
public Property | FillType | Determines the pattern used to paint the background of the tool tip.
public Property | Font | Determines the font used to draw the text in the tool tip.
public Property | ForeColor | Determines the color that will be used to draw the textof the tool tip.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar where the tool tip will be displayed.
public Property | ScheduleNote | The dbiScheduleNote to display a Tool Tip for.
public Property | ScrollValue | The position of the vertical scroll bar.
public Property | Text | The text to display in the tool tip.
public Property | TipsType | The type of tool tip to display.
Top

See Also

Reference

BeforeToolTipsEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ControlErrorEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ControlErrorEventArgs Class

"

For a list of all members of this type, see ControlErrorEventArgs members.

"

Public Properties

 | Name | Description
public Property | Error | The ID number of the error which has occurred.
public Property | Message | The description of the error which has occurred.
Top

See Also

Reference

ControlErrorEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiGuideLine Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLine Class

"

For a list of all members of this type, see dbiGuideLine members.

"

Public Properties

 | Name | Description
public Property | ImageIndex | The image index of the desired icon attached to the GuideImages Property.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a guide line image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a GuideLine.
public Property | LineColor | Determines the color of a GuideLine.
public Property | LineTime | Determines the date and time value of the GuideLine.
public Property | Locked | Determines if a GuideLine can be moved/removed with the mouse.
public Property | Tag | Allows an object to be stored on the dbiGuideLine.
public Property | Width | Gets and sets the width of the GuideLine
public Property | XMLString | Gets or sets the properties based on an XML String.
Top

See Also

Reference

dbiGuideLine Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiGuideLineCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLineCollection Class

"

For a list of all members of this type, see dbiGuideLineCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a dbiGuideLine to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiGuideLine
public Method | Insert | Inserts a dbiGuideLine into the collection at the specified index.
public Method | Remove | Removes a dbiGuideLine from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the collection to an XML file specified in strFileName
public Method | XMLString | Returns the GuideLine collection as an XML String.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiGuideLineCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiGuideLineCollection Class

"

For a list of all members of this type, see dbiGuideLineCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiGuideLine added to the dbiScheduleObject.
Top

See Also

Reference

dbiGuideLineCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiGuideLineCollection Class : IndexOf Method

Returns the internal index of the dbiGuideLine

Overload List

Overload | Description
IndexOf | Returns the internal index of the dbiGuideLine

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiGuideLineCollection Class
dbiGuideLineCollection Members


%%PageItemTitle%% $$Properties$$

dbiHistoryItem Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiHistoryItem Class

"

For a list of all members of this type, see dbiHistoryItem members.

"

Public Properties

 | Name | Description
public Property | ActionType | Determines the type of action that is taking place.
public Property | BarIndex | Gets or sets the index of the Timebar where the action is occuring.
public Property | End | The end date and time of the Timebar before the action has been performed.
public Property | Group | Gets or sets an internal number to identify the sequence where the action takes place.
public Property | Link | Gets the dbiLinkItem which was added to or removed from the schedule.
public Property | ScheduleItem | The original dbiScheduleItem the action was performed on.
public Property | ScheduleItemTo | The dbiScheduleItem a Timebar has been vertically moved to.
public Property | Start | The start date and time of the Timebar before the action has been performed.
public Property | TimeBar | The original dbiTimebarItem the action was performed on.
public Property | TimeBarTo | The dbiTimebarItem after it has been moved vertically.
Top

See Also

Reference

dbiHistoryItem Class
Dbi.WinControl.Schedule Namespace

Developing with dbiSchedule

History


%%PageItemTitle%% $$Properties$$

dbiLinkItem Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiLinkItem Class

"

For a list of all members of this type, see dbiLinkItem members.

"

Public Properties

 | Name | Description
public Property | DashPattern | An array of real numbers that specifies the lengths of alternating dashes and spaces representing the line.
public Property | LineColor | Gets or sets the color of the link line.
public Property | LineStyle | Determines the line style of the time bar link.
public Property | LinkDirection | Gets or sets the link direction between two Timebars.
public Property | LinkType | Gets or sets the type of link to create.
public Property | TimeBarFrom | Gets or sets the dbiTimebarItem receiving the link.
public Property | TimeBarTo | Gets or sets the dbiTimebarItem initiating the link.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to link.
Top

See Also

Reference

dbiLinkItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Events$$

dbiSchedule Class Events
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule Class

"

For a list of all members of this type, see dbiSchedule members.

"

Public Events

 | Name | Description
public Event | AfterCellEdit | Event fired after the editing of a cell has completed. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterColumnSort | Occurs after a column has been sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterGuideLineInserted | Event fired after a new GuideLine is inserted with the mouse.
public Event | AfterGuideLineMoved | Event fired after a GuideLine is moved with the mouse.
public Event | AfterGuideLineRemoved | Event fired after a GuideLine is removed with the mouse.
public Event | AfterNodeCollapse | Event fired after a parent node has collapsed (hiding its child nodes). (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeExchange | Event fired after a node has been internally dragged/dropped was moved. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeExpand | Event fired after a parent node has expanded (showing its child nodes). (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterNodeSelect | Event fired after a node has been selected. (Inherited from Dbi.WinControl.DbiListControl)
public Event | AfterTimeBarDrop | Occurs after a Timebar has been dropped onto the schedule.
public Event | AfterTimeBarInserted | Occurs after a Timebar is inserted.
public Event | AfterTimeBarLinked | Occurs after 2 Timebars have been linked together.
public Event | AfterTimeBarMoved | Occurs after a Timebar has been moved.
public Event | AfterTimeBarRemoved | Occurs after a Timebar is removed.
public Event | AfterTimeBarSelect | Occurs after a TimeBar is selected.
public Event | AfterTimeBarSized | Occurs after a Timebar has been sized.
public Event | AfterTimeBarSplit | Occurs after a Timebar has been split while the edit mode is in split mode.
public Event | AfterTimeBarUnlinked | Occurs after the link between two Timebars has been removed.
public Event | AfterTimeBarUnSelect | Occurs after a TimeBar has been unselected.
public Event | AlarmTimeBarEnd | Occurs when an alarm has fired at the end of a Timebar.
public Event | AlarmTimeBarStart | Occurs when an alarm is fired at the beginning of a Timebar.
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BeforeCellEdit | Event fired before a cell is placed in to an editable state. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeCellTextDisplay | Event fires before the text is drawn in each cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeColumnSort | Occurs before a column is sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeGuideLineInsert | Event fired before a new GuideLine is inserted with the mouse.
public Event | BeforeGuideLineMove | Event fired before a GuideLine is moved with the mouse.
public Event | BeforeGuideLineRemove | Event fired before a GuideLine is removed with the mouse.
public Event | BeforeNodeCollapse | Event fired before a parent node is collapsed (child nodes will be hidden). (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeExchange | Event fired before a node that has been internally dragged/dropped is moved. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeExpand | Event fired before a parent node is expanded (child nodes will be made visible). (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforeNodeSelect | Event fired before a node is selected in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforePaint | Event fired before the control has painted the list. (Inherited from Dbi.WinControl.DbiListControl)
public Event | BeforePrintPageNumber | Occurs before each page number is prepared for the printed report.
public Event | BeforeTimeBarDrop | Occurs before a Timebar is dropped onto the schedule.
public Event | BeforeTimeBarInsert | Occurs before a Timebar is inserted.
public Event | BeforeTimeBarLink | Occurs before 2 times bars are linked together.
public Event | BeforeTimeBarMove | Occurs before a Timebar is moved.
public Event | BeforeTimeBarRemove | Occurs before a Timebar is removed.
public Event | BeforeTimeBarSelect | Occurs before a Timebar is selected.
public Event | BeforeTimeBarSize | Occurs before a Timebar is sized.
public Event | BeforeTimeBarSplit | Occurs before a Timebar has been split while the edit mode is in split mode.
public Event | BeforeTimeBarUnlink | Occurs before the link between two Timebars has been removed.
public Event | BeforeTimeBarUnSelect | Occurs before a TimeBar is unselected.
public Event | BeforeToolTips | Occurs before a tool tip is displayed.
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | Change | Event fired when a list item is selected. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | CheckClick | Event fired when a check box in the list is clicked. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlError | Occurs when an error takes place in the control.
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | DeadZoneDrop | Event fired when a time bar is moved onto a dead zone area with the mouse.
public Event | DisplayUserControl | Event fired before a cell is placed in to edit mode, allowing the developer to prepare and display their own control for the editing process. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DropList | Occurs when an item is dropped into the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditInputKey | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyDown | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyPress | Event fired when a key is pressed inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditKeyUp | Event fired when a key is released inside the TextBox or ComboBox when editing a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | EditModeChanged | Event fired when the EditMode is changed on the control.
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FirstDraw | Occurs after dbiSchedule has been drawn for the first time.
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | GuideLineClick | Event fired when a GuideLine is clicked.
public Event | GuideLineInDeadZone | Fires when a dbiGuideLine is detected to intersect with a custom area marked as a dead zone.
public Event | GuideLineMove | Event fired when a GuideLine is moved.
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HeaderClick | Event fired when the left mouse button clicks on a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Event | HeaderDoubleClick | Event fired when the left mouse button double clicks on a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | HistoryChange | Occurs when an item in the RedoHistory or UndoHistory collections change.
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | InitializeCellEdit | Event fired before the cell edit operation is started (Inherited from Dbi.WinControl.DbiListControl)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | ItemLineHeightChanged | Event fired when the item height is changed. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ItemMouseOver | Occurs when the mouse moves over a new schedule item.
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LineArrowClick | Event fired when a line arrow is clicked.
public Event | LineArrowDoubleClick | Event fired when a line arrow is double clicked.
public Event | LineArrowMouseOver | Event fired when the mouse moves over a line arrow.
public Event | ListClick | Occurs when a schedule item is clicked.
public Event | ListDoubleClick | Occurs when a schedule item is double clicked.
public Event | ListDrop | Occurs when an item is dropped into the list area.
public Event | ListMouseOver | Event fired when the mouse moves over a cell. (Inherited from Dbi.WinControl.DbiListControl)
public Event | ListWidthChanged | Occurs when the list width has changed.
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheelCheck | Occurs when the wheel on the users mouse is scrolled.
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | NodeClick | Occurs when a schedule item is clicked on. (Inherited from Dbi.WinControl.DbiListControl)
public Event | NodeDoubleClick | Occurs when a schedule item is double clicked. (Inherited from Dbi.WinControl.DbiListControl)
public Event | NoteClick | Event fired when a schedule note is clicked.
public Event | NoteDoubleClick | Event fired when a schedule note is double clicked.
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RedoAction | Occurs after a redo action has taken place.
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | RemoveUserControls | Event fired after a cell has finished being edited, allowing the developer to remove and dispose of their edit control. (Inherited from Dbi.WinControl.DbiListControl)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | RulerDrag | Occurs when the user mouses down in the ruler area, and drags.
public Event | ScheduleClick | Occurs when the user clicks in the schedule area
public Event | ScheduleScrollBarsOffsetArea | Occurs before the control renders either the horizontal or vertical scroll bar in the display.
public Event | ScrollBufferResize | Event fired when the Scroll Buffer is resized to allow for the repositioning of any controls in the buffer zone.
public Event | ScrollTrack | Occurs when a scroll bar within the control is moved either manually or programmatically.
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TimeBarClick | Occurs when a Timebar is clicked on.
public Event | TimeBarDateText | Occurs just before the text is written at each end of a timebar in the display, when a dbiScheduleObject's DisplayTimeBarDates property is true.
public Event | TimeBarDoubleClick | Occurs when a Timebar is double clicked on.
public Event | TimeBarMouseEnter | Occurs when the mouse moves into a time bar.
public Event | TimeBarMouseLeave | Occurs when the mouse moves out of a time bar.
public Event | TimeBarMoving | Occurs while a TimeBar is moving in the schedule area.
public Event | TimeBarSizing | Occurs as the size of the Timebar is being changed by the mouse.
public Event | UndoAction | Occurs after an undo action has taken place.
public Event | UserDrawnBar | Occurs at the point a time bar is drawn to provide custom painting of the time bar area. NOTE: Any time bar can be “User Drawn” and an item can contain any combination of user drawn and control drawn time bars.
public Event | UserDrawnBarAfter | This event fires after the timebar image has been created. This allows the developer to work with the graphics of an already drawn timebar.
public Event | UserDrawnCell | Event fired before a cell is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnColumnHeader | Event fired before a column header is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnCustomArea | Occurs at the point a custom area is drawn to provide custom painting of the display of the custom area.
public Event | UserDrawnFooter | A static item painted through the list and schedule area at the bottom of the control above the horizontal scroll bars.
public Event | UserDrawnHeader | A static item painted through the list and schedule area at the top of the control below the list title and ruler (time line).
public Event | UserDrawnLine | Rendered in the dbiSchedule Items collection(s) to provide custom painting of the rectangle inside the schedule area of the control.
public Event | UserDrawnLinkLine | Occurs before a Link is drawn in the control.
public Event | UserDrawnListScrollArea | Allows for custom painting of the background of the area containing the horizontal scroll bar of the list.
public Event | UserDrawnNode | Event fired before a node is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnRuler | Occurs before the ruler is painted in each schedule; once when the background is painted and then a second time after the rest of the ruler is painted.
public Event | UserDrawnRulerSegment | Occurs just before a segment is drawn in the middle row of the ruler in a dbiScheduleObject. The DisplayUserDrawnRulerSegments property of the dbiScheduleObject must be set to True.
public Event | UserDrawnRulerTitle | Occurs before the title text is written in the ruler of each schedule.
public Event | UserDrawnTimeBars | Occurs after all other drawing has completed for each dbiScheduleObject in the visible schedule area.
public Event | UserDrawnTitle | Event fired before the title area is drawn, allowing the developer to customize the display. (Inherited from Dbi.WinControl.DbiListControl)
public Event | UserDrawnWaterMark | Occurs after the control has finished painting all the objects in the schedule area.
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | ValuePoint | Occurs before each time value is drawn in the ruler.
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiSchedule Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiSchedule Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule Class

"

For a list of all members of this type, see dbiSchedule members.

"

Public Methods

 | Name | Description
public Method | AddHistoryItem | Overloaded. Adds a dbiHistoryItem to the history collection.
public Method | AutoSetNodeHeight | Automatically sets the HeightOffset for the dbiScheduleItem passed as a parameter.
public Method | BarToBack | Moves a specified Timebar behind any conflicting Timebars.
public Method | BarToFront | Moves a specified Timebar in front of any conflicting Timebars.
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | ColumnAt | Overloaded. Gets the dbiColumnItem at a specified location (Inherited from Dbi.WinControl.DbiListControl)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateImage | Creates an image of dbiSchedule.
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | CustomAreasAt | Overloaded. This function will receive a cursor location, and return a dbiCustomAreaCollection Class
public Method | DateTimeAt | Overloaded. Gets the DateTime value at a specific location.
public Method | DisplayToolbar | Overloaded. Displays a Toolbar with the available EditModes for the control, at a specified location.
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EditCell | Overloaded. Places the desired cell into edit mode.
public Method | EditNextCell | Places the next logical cell in to edit
public Method | EditPrevCell | Places the previous logical cell in to edit
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | EnsureVisible | Method to move the visible portion of the control to ensure that the item passed to the method is visible. Due to the nature of the node/subnode collections, the exact location of the item in the display may deviate. (Inherited from Dbi.WinControl.DbiListControl)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetExpandedItemCount | Gets or sets the number of visible child nodes of a given dbiNodeItem.
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetNodeLevel | Returns the zero-based level within the nested structure of a specified node. (Inherited from Dbi.WinControl.DbiListControl)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InDeadZone | Overloaded. Determines if a dbiTimeBarItem, dbiAppointmentItem, dbiGuideLine or a TimeSpan is in a dead zone.
public Method | IndexesFromTimeBar | Gets the dbiScheduleItem index value and the dbiTimebarItem index value of a given Timebar.
public Method | IndexFromNode | Gets the index value of a node.
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | InvalidateControl | Overloaded. The dbiSchedule control will redraw itself.
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | IsMilestone | Determines if a Timebar item is a milestone.
public Method | ItemAt | Overloaded. This function will receive a cursor location, and return the dbiScheduleItem located at that position.
public Method | LineHeight | Overloaded. Gets the physical height of a dbiScheduleItem in pixels.
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | MoveTimeBarEnd | Move the end of a time bar while keeping the original time span of the time bar.
public Method | MoveTimeBarStart | Move the start of a time bar while keeping the original time span of the time bar.
public Method | NodeFromIndex | Returns a dbiScheduleItem given the index value.
public Method | NodeFromTimeBar | Gets the dbiScheduleItem associated with a specified dbiTimebarItem.
public Method | NodeToScheduleItem | Converts a dbiNodeItem to a dbiScheduleItem.
public Method | PaintBackground | Overloaded. Paints individual backgrounds on a specific graphics handle.
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | Print | Overloaded. Prints the dbiSchedule.
public Method | PrintPreview | Overloaded. Creates a preview of a printed report.
public Method | ReadXMLFile | Reads the data from an XML file into dbiSchedule.
public Method | Redo | Performs a redo operation on dbiSchedule.
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | RestoreCell | Reset internal items required for the edit mode. (Inherited from Dbi.WinControl.DbiListControl)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | RulerHeight | Returns the internally calculated height of the ruler area based on the current control setup.
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | ScheduleAt | Overloaded. This function will receive a cursor location, and return the dbiScheduleObject located at that position.
public Method | ScheduleDocument | Returns a dbiPrintSchedule document object.
public Method | ScheduleItemAt | Overloaded. Returns the area of the dbiSchedule Control at the mouse point provided.
public Method | ScrollToCell | Overloaded. Attempt to scroll a desired cell in to the visible portion of the list area.
public Method | ScrollToColumn | Overloaded. Attempt to scroll a desired column in to the visible portion of the list area
public Method | ScrollToDateTime | Overloaded. Scrolls the dbiSchedule control to the specified date/time value.
public Method | ScrollToNode | Attempts to make a specified dbiScheduleItem visible in the list display. (Inherited from Dbi.WinControl.DbiListControl)
public Method | SelectedTimeBars | Gets a collection representing the currently selected Timebars in dbiSchedule.
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetView | Overloaded. Will attempt to adjust the display of the schedule area to show the specified timespan in a single view.
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | Sort | Overloaded. Sort the data of the list portion of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | TimeBarConflicts | Overloaded. Gets a collection of time bars that conflict with a specified time bar.
public Method | TimeBarsAfterSchedule | This function returns a collection of timebars that exist after the visible area of a schedule.
public Method | TimeBarsAt | Overloaded. This function will receive a cursor location, and return a TimeBarItemCollection.
public Method | TimeBarsBeforeSchedule | This function returns a collection of timebars that exist before the visible area of a schedule.
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Undo | Performs an undo operation on dbiSchedule.
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
public Method | WriteXMLData | Writes only the data elements of the dbiSchedule.
public Method | WriteXMLFile | Overloaded. Writes the data in dbiSchedule to an XML file.
Top

See Also

Reference

dbiSchedule Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiSchedule Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiSchedule Class

"

For a list of all members of this type, see dbiSchedule members.

"

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | ActiveSchedule | Gets or sets the active schedule in the control.
public Property | AlignmentLineColor | Determines the color used to paint the AlignmentLines when they are shown.
public Property | AlignmentLines | Determines if alignment lines will be drawn as the user interacts with dbiTimeBarItems in the control.
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AllowHorzMoves | Determines whether time bars can be moved horizontally with the mouse.
public Property | AllowItemDrag | Determines if users will be allowed to re-order items in the list by dragging and dropping them within their current level. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AllowNewBars | Determines whether new time bars can be created in a schedule with the mouse.
public Property | AllowResizeBars | Determines whether new time bars can be resized with the mouse.
public Property | AllowVertMoves | Determines if Timebars can be moved vertically.
public Property | AltColorEven | Determines the background color of an even numbered list item in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AltColorOdd | Determines the background color of an odd numbered list item in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AlternateColor | Determines whether or not the list items will be drawn with alternating background colors. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AlternateItems | Determines the amount of lines to color with the AlternateColors before the opposite color is used. See AltColorEven and AltColorOdd. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | ArrowAlign | Determines on what side of a column header the sort arrows will be placed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ArrowOffset | Determines the horizontal and vertical offset used for the calculated position of a sort arrow in a column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | AutoDuplicate | Determines whether a duplicate time bar will be created when the <Shift> key is pressed, and a time bar is clicked and dragged.
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Determines the background color of the list items section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BackgroundImage | Determines the background image for the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BarSelectBackColor | Gets or sets the background color of the selected Timebar.
public Property | BarSelectBackColorTo | Gets or sets the background color to of the selected Timebar.
public Property | BarSelectBorderColor | Gets or sets the border color of the selected Timebar.
public Property | BarSelectFillType | Gets or sets the background fill pattern of the selected Timebar based on the enumFillType.
public Property | BarSelectForeColor | Gets or sets the forecolor of the selected Timebar.
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | BodyColumnEnd | Determines the final column for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyColumnStart | Determines the starting column for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyFont | Determines the font used to draw the body text of a item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyForeColor | Determines the color used to paint the body text of an item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BodyIndent | Determines the indent of the left margin spacing for the body text in the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | BorderColor | Gets or sets the border color around the control.
public Property | BorderType | Gets or sets the type of border to place around the control.
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | BreakChar | Gets or sets the character used to seperate the item text into columns. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClosedSchedules | Determines if dbiTimeBarItems will be restricted to a single dbiScheduleObject inside the control's display.
public Property | Columns | Gets or sets the columns assigned to dbiSchedule. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ComboBox | Returns the dbiComboBox that will be used for editing cells in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | ControlStyle | Set the appearance of the control to a particular style. By setting this property, the control will set font and color properties consistent with the enumControlStyle Enumeration. Once these properties are set they can be modified to further refine the style or you can skip setting this property and manually set colors and fonts to achieve the style you are looking for. Once this property has been set, it will then revert to default. Setting this property to default has no effect on the control.
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Culture | Gets or sets the culture information specifically for dbiSchedule. (Inherited from Dbi.WinControl.DbiListControl)
public Property | CurrentTimeColor | Gets or sets the primary color for the current time line.
public Property | CurrentTimeColorTo | Gets or sets the secondary color for the current time line.
public Property | CurrentTimeLine | Determines if a time line will be drawn for the current date and time.
public Property | CurrentTimeOffset | Determines the offset used for displaying the CurrentTimeLine.
public Property | CurrentTimePosition | Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | CustomAreas | Gets the custom areas assigned to dbiSchedule.
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Defines how DateTime values are formatted and displayed, depending on the culture. (Inherited from Dbi.WinControl.DbiListControl)
public Property | DayMonthOffset | Determines the offset used to calculate the starting day of the week in a monthly ruler.
public Property | DayNames | Gets or sets the day names in dbiSchedule.
public Property | DefaultStyle | Gets or sets the default Timebar style.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayGuideLines | Determines if the GuideLines are shown in the dbiSchedule.
public Property | DisplayHeader | Determines whether or not the column headers will be displayed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | DisplayListGuide | Determines whether a list guide will appear in the schedule.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTitle | Determines whether or not the title will be displayed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | DivisionDistance | Determines how close the edge of a time bar must be to a major time division point before the time bar is snapped to that point (in pixels).
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | DragLineColor | Gets or sets the border color of the splitter bar when the mouse clicks it.
public Property | DragTimerInterval | Determines the current postion of the CurrentTimeLine relative to the dbiTimeBarItems in the display.
public Property | EditAutoNavigate | Determines if the control will automatically navigate to the next/previous cell when editing. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditAutoSize | Determines if the dbiTextBox displayed when editing cells, will be automatically resized based on the font size and current text length. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditColumn | Returns the dbiColumnItem that contains the cell being edited. (Inherited from Dbi.WinControl.DbiListControl)
public Property | EditMode | Gets or sets the type of action which can be performed on a Timebar.
public Property | EditNode | Returns the dbiNodeItem that contains the cell to be edited (Inherited from Dbi.WinControl.DbiListControl)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | ErasorCursor | Allows a custom image to be used in place of the default erase cursor.
public Property | ErasorHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | FillList | Determines whether the last column in a list will always extend to the edge of the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | FocusBorder | Determines if a focus line will be drawn around the selected item in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | FocusColor | Determines the color used to paint the FocusBorder (Inherited from Dbi.WinControl.DbiListControl)
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | FooterLine | Determines if the user drawn footer line is displayed on the bottom of the List in the dbiSchedule.
public Property | FooterLineHeight | Gets or sets the height of a user drawn footer line in the List of dbiSchedule.
public Property | ForeColor | Determines the foreground color of the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | GridFrequency | Gets or sets the distance (in pixels) where a Timebar can be moved or sized to with SnapToGrid enabled.
public Property | GuideDashPattern | An array of real numbers that specifies the lengths of alternating dashes and spaces representing the lines of each GuideLine.
public Property | GuideImageIndex | Determines the default images used when adding GuideLines to the dbiScheduleObject.GuideLines collection.
public Property | GuideImagePosition | Determines whether GuideLine images will be in the front or back of the ruler numbers and markers.
public Property | GuideImages | Attaches an ImageList control to the dbiSchedule for use with the GuideLines.
public Property | GuideImageXOffset | Determines the horizontal offset used to calculate the position of the guide line image. This property only applies to the GuideImgeIndex property.
public Property | GuideImageYOffset | Determines the vertical offset used to calculate the position of the guide line image. This property only applies to the GuideImageIndex property.
public Property | GuideLineColor | Determines the default color of the GuideLines.
public Property | GuideLineDistance | Determines how close the edge of a time bar must be to a GuideLine before the time bar is snapped to the GuideLine location (in pixels). The maximum value is 10 pixels.
public Property | GuideLinePosition | Determines the ZOrder for Guide Lines, relative to the Timebars in the control.
public Property | GuideLineWidth | Determines the default width of all guide lines.
public Property | GuideSelectColor | Determines the default color of a selected guide line.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderAlign | Determines how the text in the column headers will be aligned. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColor | Determines the background color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColorMiddle | Determines the middle back color of the column header allowing for greater readability with certain fill types. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBackColorTo | Determines the secondary background color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderBorder | Determines the border type for the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderColor | Determines the default line color for a header defined schedule line.
public Property | HeaderDownColor | Determines the color used to paint background when the mouse pointer is over the column header and a mouse button is pressed. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderFillType | Determines the pattern used to paint the background of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderFont | Determines the font used for the text in the column headers of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderForeColor | Determines the foreground color of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderHeight | Determines the height of the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderImageOffset | Determines the value used to calculate the horizontal and vertical position of the images within the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderLine | Determines if the user drawn header line is displayed on the top of the List in the dbiSchedule.
public Property | HeaderLineHeight | Gets or sets the height of a user drawn header line in the List of dbiSchedule.
public Property | HeaderOverColor | Determines the color used to paint background when the mouse pointer is over the column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderStyle | Determines the style of the column header. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderTextImageRelation | Determines how the column header position of text and image relate to each other. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HeaderTextOffset | Determines the value used to calculate the horizontal and vertical position of the text within the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HistorySize | Gets or sets the maximum number of items stored in the Undo/Redo history collection.
public Property | HorzGridColor | Determines the color of the horizontal grid lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzGridLines | Determines whether or not horizontal grid lines will be drawn between the items. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzGridWidth | Determines the width of the horizontal grid lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | HorzListLargeChange | Determines the large change when scrolling the list area's Horizontal scroll bar.
public Property | HorzListSmallChange | Determines the small change when scrolling the list area's Horizontal scroll bar.
public Property | HorzScheduleLargeChange | Determines the large change when scrolling the schedule area's Horizontal scroll bar.
public Property | HorzScheduleScrollOffset | Determines the offset used to calculate the width of the horizontal scroll bar in the schedule area.
public Property | HorzScheduleSmallChange | Determines the small change when scrolling the schedule area's Horizontal scroll bar.
public Property | HorzScrollType | Determines the horizontal scrolling action for the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckDisabled | Determines the image used to replace the stock check disabled state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckDown | Determines the image used to replace the stock check down state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageCheckUp | Determines the image used to replace the stock check up state checkbox image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageIntoView | Determines if images applied to timebars as Start and End images will be forced into the display when the respective edge of the timebar is partially outside the view.
public Property | ImageList | The image list for the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageMinus | Determines the image used to replace the stock collapse parent item image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImagePlus | Determines the image used to replace the stock expand parent item image. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ImageType | Gets or sets the type of image to create with the CreateImage method.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InactiveBackColor | Determines the color used to paint the background of a selected item when the control no longer has focus. (Inherited from Dbi.WinControl.DbiListControl)
public Property | InactiveForeColor | Determines the color used to paint the text of a selected item when the control no longer has focus. (Inherited from Dbi.WinControl.DbiListControl)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | ItemBorder | Determines the border type for the items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemDragColor | Determines the color of the drag bar when an item is dragged inside the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemDragHeight | Determines the height of the drag bar when an item is dragged inside the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeaderBackColor | Determines the default background color for all Header items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeaderForeColor | Determines the default foreground color for all Header items in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ItemHeightOffset | Overridden. Gets or sets the vertical offset value used to calculate the height of the items in the list.
public Property | Items | Gets the list items in dbiSchedule.
public Property | LabelEdit | Determines if a cell will be put in to edit mode automatically, if the user double clicks it. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineArrowAfter | Determines the image used to indicate more timebars are after the visible area of the schedule.
public Property | LineArrowBefore | Determines the image used to indicate more timebars are before the visible area of the schedule.
public Property | LineArrowColor | Determines the color used to paint the arrows used to indicate additional timebars before or after the visible area of a schedule.
public Property | LineArrowDisplay | Determines the condition of how a line arrow will be displayed.
public Property | LineArrowPosition | Determines where the line arrows will be drawn in the schedules, in relation to other objects.
public Property | LineColor | Determines the color of list/tree connector lines. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LineType | Determines the list/tree connector line type. (Inherited from Dbi.WinControl.DbiListControl)
public Property | LinkCursor | Allows a custom image to be used in place of the default link cursor.
public Property | LinkHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | LinkLineColor | Gets or sets the default color of the link lines in dbiSchedule.
public Property | Links | Gets the links in dbiSchedule.
public Property | ListBackColor | Gets or sets the background color of the list area in the schedule.
public Property | ListFont | Gets or sets the default font for the list area in the schedule.
public Property | ListForeColor | Gets or sets the
public Property | ListGuideColumn | Determines the zero-based index of the column that will be used as part of the ListGuide display.
public Property | ListGuideDistance | Determines how far, in pixels, the cusro needs to be from the ListArea before the ListGuide will display.
public Property | ListGuideInterval | Determines the interval (milliseconds) used to cause a fade in effect for the ListGuide.
public Property | ListGuideOpacity | Determines the opacity of the ListGuide.
public Property | ListGuideWidth | Determines the width of the ListGuide.
public Property | ListGuideXPosn | Determines the horizontal coordinate where the ListGuide will be painted.
public Property | ListScrollBackColor | Determines the color used to paint the background of the horizontal scroll bar area.
public Property | ListScrollMaximum | Returns the current maximum value of the horizontal scroll bar in the ListArea
public Property | ListScrollValue | Gets or sets the horizontal scroll value of the List in dbiSchedule.
public Property | ListScrollViewType | Determines the display behavior of the horizontal scroll bar in the ListArea.
public Property | ListType | Determines how the list items will be drawn in the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ListWidth | Gets or sets the width of the list area.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LockLineHeight | Overridden. Determines if the height of the items can be resized.
public Property | LockSplitterBar | Determines if the splitter bar can be moved.
public Property | MapBorder | Gets or sets the type of border to place around the map area.
public Property | MapHeight | Gets or sets the height of the map area in the schedule.
public Property | MapLineColor | Gets or sets the color to place around the current view in the map area of the schedule.
public Property | MapVisible | Determines if the map area will be visible in the schedule.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaskColor | Gets or sets the mask color for the images in the schedule.
public Property | MaxImageHeight | Gets or sets the maximum height of a user created image of dbiSchedule.
public Property | MaxImageWidth | Gets or sets the maximum width of a user created image of dbiSchedule.
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinBarTime | Gets or sets the minimum time for a Timebar when it is resized.
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MonthNames | Gets or sets the names of the months in dbiSchedule.
public Property | MultiSelect | Determines if the list area will allow a multi-select mode (using ctrl/click and shift/click). (Inherited from Dbi.WinControl.DbiListControl)
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | NoteImages | The image list for the schedule notes.
public Property | NotesDistance | Determines the distance separating locked notes on a line.
public Property | NotesPosition | Determines where the schedule notes will be drawn in the schedules, in relation to the other objects.
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PencilCursor | Allows a custom image to be used in place of the default pencil (create timebar) cursor.
public Property | PencilHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | PercentColor | Determines the default color of all Percent complete bars rendered inside dbiTimeBarItems
public Property | PlusMinusStyle | Determines the style used when rendering the Plus/Minus boxes on parent nodes. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBackColor | Determines the background color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBackColorTo | Determines the secondary background color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnBorder | Determines the type of border to place around the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnFillType | Determines the pattern used to paint the background of the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnFont | Determines the font used for the text in the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnForeColor | Determines the foreground color of the pre-column section of a non-selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnPicture | Determines the picture clip within the pre-column section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnType | Determines the pre-column to be used on the list part of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreColumnWidth | Determines the width of the pre-column in the list. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | PreSelectBackColor | Determines the background color of the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreSelectBorder | Determines the type of border to place around the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PreSelectForeColor | Determines the type of border to place around the pre-column section of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintBackImage | Determines if the back image will be visible in a printed report.
public Property | PrintFitToPage | Determines if the PrintTimeDistance property will be adjusted so the entire control can be printed on a single page.
public Property | PrintFont | Gets or sets the font of a printed report.
public Property | PrintFooterAlign | Gets or sets the vertical and horizontal position of the footer in a printed report.
public Property | PrintHeaderBackColor | Determines the background color of the column headers in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintHeaderForeColor | Determines the foreground color of the column headers in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintItemBackColor | Determines the background color of the items in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintItemForeColor | Determines the foreground color of the items in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintListAlways | Determines whether the list will be printed on every page of a report.
public Property | PrintListFormat | Gets or sets the type of list to display in a printed report.
public Property | PrintPageControl | Determines if the control should print using the current colors rendered in the control (True) or if the specified "Print" related colors should be used (False). (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintPageText | Gets or sets the text descibing the page number on the report footer.
public Property | PrintReportType | Determines how dbiSchedule is printed.
public Property | PrintSubTitle | Gets or sets the sub-title of a printed report.
public Property | PrintTimeDistance | Gets or sets the distance between the major time segments in a printed report.
public Property | PrintTitle | Gets or sets the title of a printed report.
public Property | PrintTitleAlign | Gets or sets the vertical and horizontal alignment of the title in a printed report.
public Property | PrintTitleBackColor | Determines the background color of the list area title in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | PrintTitleForeColor | Determines the foreground color of the list area title in a printed report. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | RedoHistory | Gets the redo actions which can be performed on the Timebars in the schedule.
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RulerAlign | Determines the default alignment for the text within the ruler.
public Property | RulerBackColor | Determines the default background color of the ruler.
public Property | RulerBackColorTo | Determines the default secondary background color of the ruler.
public Property | RulerBorder | Determines the default border type for the ruler area.
public Property | RulerFillType | Determines the default fill effect used to paint the background of the ruler.
public Property | RulerFont | Determines the default font used for rendering the time units in the ruler of the schedule.
public Property | RulerForeColor | Determines the default foreground color of the ruler.
public Property | RulerLineColor | Determines the default line color of the ruler.
public Property | RulerSelectColor | Determines the background color used to highlight the current start/end, of the selected TimeBar, in the ruler.
public Property | RulerSelectOffset | Determines the vertical offset for displaying the selected TimeBar in the ruler.
public Property | RulerTitleBackColor | Determines the default primary background color of the title area of the ruler in a schedule.
public Property | RulerTitleBackColorTo | Determines the default secondary background color of the title area of the ruler in a schedule.
public Property | RulerTitleFillType | Determines the default background fill pattern of the title area of the ruler in a schedule.
public Property | RulerTitleFont | Determines the default font used for the title area of the ruler in a schedule.
public Property | RulerTitleForeColor | Determines the default foreground color of the title area of the ruler in a schedule.
public Property | SchedAltColorEven | Determines one of the default alternating line colors for a schedule line.
public Property | SchedAltColorOdd | Determines one of the default alternating line colors for a schedule line.
public Property | SchedScrollValue | Gets or sets the horizontal scroll value of the Schedule(s) area in dbiSchedule.
public Property | ScheduleBackColor | Determines the default background color of a schedule.
public Property | ScheduleLineColor | Determines the default line color of the schedules.
public Property | Schedules | Gets the Schedules in dbiSchedule.
public Property | ScrollHorzBuffer | Gets or sets the size of a buffer area in the dbiSchedule horizontal schedule scroll bar where another control can be placed.
public Property | SelectedBackColor | Determines the background color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBackColorTo | Determines the second background color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBorder | Determines the type of border to place around the selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedBorderColor | Determines the border color of a selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedFillType | Determines the pattern used to paint the background of the selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedFont | Determines the font used to draw the text of a selected item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedForeColor | Determines the foreground color of a selected list item. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SelectedStyle | Determines how the selection will be applied to the selected node(s). (Inherited from Dbi.WinControl.DbiListControl)
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SnapToDivisions | Determines if a time bar will snap to the Minor Time divisions (created with RulerDivisions Property)when they are moved/added/resized using the mouse. Snap to Divisions will not affect programmatically added time bars.
public Property | SnapToGrid | Determines if the Timebars will automatically align to the control.
public Property | SnapToGuideLines | Determines if a time bar will snap to the GuideLines when they are moved/added/resized using the mouse. Snap to GuideLine will not affect programmatically added time bars.
public Property | SortArrows | Determines whether arrows indicating the direction of the sort order will be displayed in the column headers. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SortColumn | Determines the zero-based index of the column whose data a sort will be performed on. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SortDirection | Determines the direction a sort operation will perform. (Inherited from Dbi.WinControl.DbiListControl)
public Property | Sorted | Determines whether the list is currently considered sorted. (Inherited from Dbi.WinControl.DbiListControl)
public Property | SplitCursor | Allows a custom image to be used in place of the default split timebar cursor.
public Property | SplitHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | SplitterBarBorder | Gets or sets the dbi.enumBorderType for the splitter bar in the dbiSchedule.
public Property | SplitterBarColor | Gets or sets the color of the splitter bar.
public Property | SplitterBarWidth | Gets or sets the width of the splitter bar.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TextAntiAlias | Determines if the text within the control will be rendered using the Anti Alias option. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TextBox | Returns the dbiTextBox that will be used for editing cells in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TextIntoView | Determines if the text of a Timebar will always be in view.
public Property | TimeBarBackColor | Gets or sets the default background color of a Timebar.
public Property | TimeBarBackColorTo | Gets or sets the default background color to of a Timebar.
public Property | TimeBarBorderColor | Gets or sets the default border color of a Timebar
public Property | TimeBarBorderType | Gets or sets the default border type of a Timebar.
public Property | TimeBarDialog | Determines if the Timebar dialog will appear when a Timebar is double clicked on.
public Property | TimeBarExtension | Gets or sets the distance from the Timebar border at which the resizing handle (mouse cursor) appears.
public Property | TimeBarFillType | Gets or sets the default background fill pattern of a Timebar based on the enumFillType.
public Property | TimeBarFont | Gets or sets the default font of the Timebars.
public Property | TimeBarForeColor | Gets or sets the default forecolor of a Timebar.
public Property | TimeBarMargin | Gets or sets the margin size on each side of a Timebar when being resized with the mouse.
public Property | TimeBarMinWidth | Gets or sets the minimum width of a Timebar.
public Property | TimeBarShadows | Determines wether the timebars should be drawn with an opaque shadow. This will give the schedule some depth.
public Property | TimeBarStyles | Gets the Timebar styles assigned to dbiSchedule.
public Property | TimeBarWordWrap | Determines if the Timebar text will automatically wrap.
public Property | TimeDistance | Gets or sets the distance between major time units.
public Property | TimeLineColor | Determines the default line color of the schedule time lines.
public Property | TimerInterval | Determines how often to check for Timebar alarms.
public Property | TipsBackColor | Gets or sets the background color of the tool tip.
public Property | TipsBackColorTo | Gets or sets the background color to of the tool tip.
public Property | TipsBorderColor | Gets or sets the border color to of the tool tip.
public Property | TipsBorderType | Gets or sets the type of border for the tool tip.
public Property | TipsDuration | Gets or sets how long (in milliseconds) the tool tip remains visible when the mouse is static.
public Property | TipsFillType | Gets or sets fill type for the background colors of a tool tip.
public Property | TipsFont | Gets or sets the font of the tool tips.
public Property | TipsForeColor | Gets or sets the forecolor of the tool tips.
public Property | TipsOnChangeBar | Determines if the tool tips will be displayed when a Timebar is being moved or sized.
public Property | TipsOnCreateBar | Determines if the tool tips will be displayed when a bar is being created.
public Property | TipsOnNotes | Determines whether a tool tip will be displayed when the mouse is over a note.
public Property | TipsOnOverBar | Determines if the tool tips will be displayed when the mouse moves over a Timebar.
public Property | TipsOnVScroll | Determines if the tool tips will be displayed when the vertical scroll is being clicked on.
public Property | TitleAlign | Determines the alignment for the text within the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColor | Determines the background color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColorMiddle | Determines the middle back color of the list area title section allowing for greater readability with certain fill types. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBackColorTo | Determines the secondary background color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleBorder | Determines the border type for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleFillType | Determines the pattern used to paint the background of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleFont | Determines the font used for the text in the list area title of the control. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleForeColor | Determines the foreground color of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleHeight | Determines the height of the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleImage | Determines the image for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleImageAlign | Determines the image alignment for the list area title section. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleText | Determines the text of the list area title. (Inherited from Dbi.WinControl.DbiListControl)
public Property | TitleTextOffset | Determines the values used to calculate the horizontal and vertical position of the text within the list area title. (Inherited from Dbi.WinControl.DbiListControl)
public Property | ToolbarBackColor | Determines the backcolor used when displaying the built in EditMode ToolBar.
public Property | ToolbarOnRightClick | Determines if the built in EditMode ToolBar will display when the user right-clicks the control.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | TreeLevelIndent | Determines the indent used to offset the text of each level of child items in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | UndoHistory | Gets the undo actions which can be performed on the Timebars in the schedule.
public Property | UnlinkCursor | Allows a custom image to be used in place of the default unlink cursor.
public Property | UnlinkHotSpot | Determines the hotspot (point) in the image to use for the cursor pointer.
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | VertGridColor | Determines the color of the vertical grid lines in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | VertGridLines | Determines whether or not to draw vertical grid lines between the columns in the list area. (Inherited from Dbi.WinControl.DbiListControl)
public Property | VertScrollLargeChange | Determines the large change when scrolling the Vertical scroll bar.
public Property | VertScrollOffset | Determines the offset used to calculate the height of the vertical scroll bar.
public Property | VertScrollSmallChange | Determines the small change when scrolling the Vertical scroll bar.
public Property | VertScrollValue | Gets or sets the vertical scroll value of the List/Schedule(s) areas in dbiSchedule.
public Property | VertThumbTrack | Determines whether the list will scroll as the vertical mouse thumb is tracked.
public Property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from System.Windows.Forms.Control)
public Property | WatermarkAlign | Determines the vertical and horizontal alignment of the WaterMarkText in the schedule area.
public Property | WatermarkFont | Determines the Font used when drawing the WaterMarkText in the schedule area.
public Property | WatermarkForeColor | Determines the color used to paint the WaterMarkText in the schedule area.
public Property | WatermarkOffset | Determines the vertical and horizontal offset used when painting the WaterMarkText in the schedule area.
public Property | WatermarkText | Determines the text displayed as a WaterMark in the the schedule area.
public Property | WeekendDays | Gets or sets the days of the week considered to be the weekend.
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | XMLRead | Gets or sets an XML file to read the data to dbiSchedule.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to dbiSchedule.
public Property | XMLWrite | Gets or sets an XML file to write the data from dbiSchedule.
Top

See Also

Reference

dbiSchedule Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiScheduleItem Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleItem Class

"

For a list of all members of this type, see dbiScheduleItem members.

"

Public Methods

 | Name | Description
public Method | Collapse | Closes a parent item so that the children are not visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | EnsureVisible | Attempts to adjust the Vertical scroll bar to ensure the item is visible in the list. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | Expand | Expands the item so that its child items are visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | ExpandAll | Expands the item, and all items below the calling item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellChecked | Gets the boolean value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellFormat | Gets the dbiCellFormat assigned to a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellInteger | Gets the integer value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetCellText | Gets the text at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | GetNodeCount | Gets the number of child nodes in an item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | IsVisible | Determines if a given node is visible. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | NextListNode | Gets the next node in the list.
public Method | NextVisibleNode | Gets the next visible item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | NodeFullPath | Gets the full text path of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | PrevVisibleNode | Gets the previous visible item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellChecked | Sets the boolean value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellInteger | Sets the integer value at a specific cell in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | SetCellText | Sets the text for a specific column in the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Method | Toggle | Expands/Collapes a parent node. (Inherited from Dbi.WinControl.dbiNodeItem)
Top

See Also

Reference

dbiScheduleItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiScheduleItem Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleItem Class

"

For a list of all members of this type, see dbiScheduleItem members.

"

Public Properties

 | Name | Description
public Property | Appointments | Gets the Timebars assigned to a schedule item.
public Property | BackColor | Gets or sets the background color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | BackColorTo | Gets or sets the secondary background color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Body | Gets or sets the body text for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | BodyVisible | Determines if the body text is visible for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Cargo | Gets or sets a non-visible text value for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | CellFormat | Gets the cell formats assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Control | Gets or sets the name of the object containing the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | CustomAreas | Gets the custom areas assigned to the schedule item.
public Property | Data | Gets or sets a non-visible integer value for the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | FillType | Gets or sets the background fill pattern of the item based on the enumFillType Enumeration. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Font | Gets or sets the font of the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ForeColor | Gets or sets the foreground color of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | FullPath | Gets the full text path of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Header | Determines if the schedule item will act as a header. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderBackColor | Determines the background color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderBackColorTo | Determines the secondary background color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderFillType | Determines the background pattern of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeaderForeColor | Determines the foreground color of the item when marked as a Header (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HeightOffset | Gets or sets the vertical offset value used to calculate the height of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HorzGridColor | Gets or sets the color of horizontal grid line below the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | HorzGridWidth | Gets or sets the width of the horizontal grid line below the schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageAlign | Determines the vertical and horizontal alignment of the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageIndex | Determines the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ImageOffset | Determines the vertical and horizontal offset values used to calculate the position of the image associated with the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | IsExpanded | Determines if the node item is expanded, displaying child items. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Item | Gets or sets the schedule item at a specific location in the collection. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Items | Gets the child nodes assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Level | Gets the current tree level of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | LockHeight | Determines if the item height can be adjusted through user interaction. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | MaxTimeBars | Gets or sets the maximum number of Timebars an item can contain.
public Property | Nodes | Gets the child nodes assigned to a schedule item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Notes | The collection of ScheduleNotes assigned to this dbiScheduleItem.
public Property | PageBreak | Determines if a page break will occur after a given item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Parent | Gets the parent item of the current item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | ReadOnly | Determines if the item is ReadOnly. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Selected | Determines if the item is selected (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | SelectedImageIndex | Determines the index of the image to use when the item is selected. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Subject | Determines the subject of the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Tag | Determines an object value that contains additional data about the item. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | Text | Determines the items text. (Inherited from Dbi.WinControl.dbiNodeItem)
public Property | TimeBars | The collection of TimeBars assigned to this dbiScheduleItem.
public Property | UserDrawn | Determines if the line item can be drawn by the user.
public Property | XMLString | Overridden. Gets or sets an XML string to read the data from or write the data to dbiSchedule.
Top

See Also

Reference

dbiScheduleItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiScheduleNote Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNote Class

"

For a list of all members of this type, see dbiScheduleNote members.

"

Public Properties

 | Name | Description
public Property | ImageAlignment | Determines the alignment of the dbiScheduleNote's image inside of the dbiSchedule.
public Property | ImageIndex | Defines the index of the image in the NoteImages Image list to use for the dbiScheduleNote.
public Property | ImageXOffset | Determines the horizontal offset used to calculate the position of a schedule note image.
public Property | ImageYOffset | Determines the vertical offset used to calculate the position of a schedule note image.
public Property | Locked | Determines if the dbiScheduleNote is always rendered inside the visible area of the dbiSchedule.
public Property | NoteTime | Determines the date and time for a dbiScheduleNote.
public Property | Schedule | Determines the schedule object that the note is assigned to.
public Property | Tag | Allows an object to be stored on the dbiScheduleNote.
public Property | Text | Determines the text for the dbiScheduleNote.
public Property | XMLString | Gets or sets an XML string to read the data from or write the data to dbiSchedule.
Top

See Also

Reference

dbiScheduleNote Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiScheduleNoteCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNoteCollection Class

"

For a list of all members of this type, see dbiScheduleNoteCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a dbiScheduleNote to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiScheduleNote
public Method | Insert | Inserts a dbiScheduleNote into the collection at the specified index.
public Method | Remove | Removes a dbiScheduleNote from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the collection to an XML file specified in strFileName
public Method | XMLString | Returns the dbiScheduleNote collection as an XML String.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiScheduleNoteCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleNoteCollection Class

"

For a list of all members of this type, see dbiScheduleNoteCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiScheduleNote added to the dbiScheduleItem.
Top

See Also

Reference

dbiScheduleNoteCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleNoteCollection Class : IndexOf Method

Returns the internal index of the dbiScheduleNote

Overload List

Overload | Description
IndexOf | Returns the internal index of the dbiScheduleNote

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleNoteCollection Class
dbiScheduleNoteCollection Members


%%PageItemTitle%% $$Events$$

dbiScheduleObject Class Events
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

Public Events

 | Name | Description
public Event | BackColorChanged | Occurs when the value of the System.Windows.Forms.Control.BackColor property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageChanged | Occurs when the value of the System.Windows.Forms.Control.BackgroundImage property changes. (Inherited from System.Windows.Forms.Control)
public Event | BackgroundImageLayoutChanged | Occurs when the System.Windows.Forms.Control.BackgroundImageLayout property changes. (Inherited from System.Windows.Forms.Control)
public Event | BindingContextChanged | Occurs when the value of the System.Windows.Forms.BindingContext property changes. (Inherited from System.Windows.Forms.Control)
public Event | CausesValidationChanged | Occurs when the value of the System.Windows.Forms.Control.CausesValidation property changes. (Inherited from System.Windows.Forms.Control)
public Event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from System.Windows.Forms.Control)
public Event | Click | Occurs when the control is clicked. (Inherited from System.Windows.Forms.Control)
public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenu property changes. (Inherited from System.Windows.Forms.Control)
public Event | ContextMenuStripChanged | Occurs when the value of the System.Windows.Forms.Control.ContextMenuStrip property changes. (Inherited from System.Windows.Forms.Control)
public Event | ControlAdded | Occurs when a new control is added to the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | ControlRemoved | Occurs when a control is removed from the System.Windows.Forms.Control.ControlCollection. (Inherited from System.Windows.Forms.Control)
public Event | CursorChanged | Occurs when the value of the System.Windows.Forms.Control.Cursor property changes. (Inherited from System.Windows.Forms.Control)
public Event | Disposed | (Inherited from System.ComponentModel.Component)
public Event | DockChanged | Occurs when the value of the System.Windows.Forms.Control.Dock property changes. (Inherited from System.Windows.Forms.Control)
public Event | DoubleClick | Occurs when the control is double-clicked. (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedAfterParent | (Inherited from System.Windows.Forms.Control)
public Event | DpiChangedBeforeParent | (Inherited from System.Windows.Forms.Control)
public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
public Event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
public Event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from System.Windows.Forms.Control)
public Event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from System.Windows.Forms.Control)
public Event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from System.Windows.Forms.Control)
public Event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from System.Windows.Forms.Control)
public Event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from System.Windows.Forms.Control)
public Event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from System.Windows.Forms.Control)
public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
public Event | PreviewKeyDown | Occurs before the System.Windows.Forms.Control.KeyDown event when a key is pressed while focus is on this control. (Inherited from System.Windows.Forms.Control)
public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiScheduleObject Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

Public Methods

 | Name | Description
public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)
public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
public Method | Dispose | (Inherited from System.ComponentModel.Component)
public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
public Method | LogicalToDeviceUnits | (Inherited from System.Windows.Forms.Control)
public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
public Method | Scale | (Inherited from System.Windows.Forms.Control)
public Method | ScaleBitmapLogicalToDevice | (Inherited from System.Windows.Forms.Control)
public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
public Method | ToString | (Inherited from System.ComponentModel.Component)
public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiScheduleObject Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiScheduleObject Class

"

For a list of all members of this type, see dbiScheduleObject members.

"

Public Properties

 | Name | Description
public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
public Property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from System.Windows.Forms.Control)
public Property | AltColorEven | Gets or sets the background color of the even numbers list items in the schedule area.
public Property | AltColorOdd | Gets or sets the background color of the odd numbers list items in the schedule area.
public Property | AlternateColor | Determines if the item background colors in the schedule area will be painted with alternating colors.
public Property | AlternateItems | Gets or sets the frequency of the alternating background colors.
public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
public Property | BackColor | Gets or sets the background color of the schedule.
public Property | BackgroundImage | Gets or sets the background image for the schedule.
public Property | BackgroundImageLayout | Gets or sets the background image layout as defined in the System.Windows.Forms.ImageLayout enumeration. (Inherited from System.Windows.Forms.Control)
public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ContactID | Assigns a contact to the schedule.
public Property | Container | (Inherited from System.ComponentModel.Component)
public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | ContextMenuStrip | Gets or sets the System.Windows.Forms.ContextMenuStrip associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
public Property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from System.Windows.Forms.Control)
public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
public Property | DateFormat | Gets or sets the date format of the schedule.
public Property | DayLength | Gets or sets the number of characters used to represent the days of the week.
public Property | DeviceDpi | (Inherited from System.Windows.Forms.Control)
public Property | DisplayBody | Determines if the body text will be displayed in the Timebars.
public Property | DisplayDays | Determines if the days of the week will be displayed with the major time segments.
public Property | DisplayOverlap | Determines if overlap lines will be displayed.
public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
public Property | DisplayTimeBarDates | Determines if the start and end date will be displayed in the Timebar.
public Property | DisplayTimeLines | Determines if lines will be displayed for major time segments through the schedule.
public Property | DisplayUserDrawnRulerSegments | Determines if an additional row will be displayed inside the ruler, between the title and timeline areas.
public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
public Property | End | Gets or sets the end date and time of a schedule.
public Property | FirstDayOfWeek | Gets or sets the starting day of the week in the schedule.
public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
public Property | Font | Gets or sets the font of the text displayed by the control. (Inherited from System.Windows.Forms.Control)
public Property | ForeColor | Gets or sets the foreground color of the control. (Inherited from System.Windows.Forms.Control)
public Property | GuideLines | A collection of GuideLines to display in the Schedule.
public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
public Property | HeaderColor | Gets or sets the background color of a header item in the schedule.
public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
public Property | HorzGridLines | Determines if horizontal grid lines will be displayed in the schedule.
public Property | ImageAlignment | Gets or sets the vertical and horizontal alignment of the background image in the schedule.
public Property | ImageEffect | Determines how the background image in the schedule will be displayed.
public Property | ImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the background image.
public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | LineMaxSize | Gets or sets the height of the lines marking the major time segments in the ruler of the schedule.
public Property | LineMinSize | Gets or sets the height of the lines marking the minor time segments in the ruler of the schedule.
public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
public Property | LocationID | Assigns a location to the schedule.
public Property | MajorTimeLine | Determines whether a full vertical line will be drawn at major time segments in the ruler.
public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
public Property | MonthFormat | Determines how the monthly ruler is displayed in the schedule.
public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
public Property | OverlapColor | Gets or sets the color of the overlap lines in the schedule.
public Property | OverlapSpan | Determines when the overlap lines will appear between 2 Timebars.
public Property | OverlapWidth | Gets or sets the width of the overlap lines in the schedule.
public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from System.Windows.Forms.Control)
public Property | RulerAlign | Gets or sets the position of the ruler text in the schedule
public Property | RulerBackColor | Gets or sets the primary background color of the ruler area in the schedule.
public Property | RulerBackColorTo | Gets or sets the secondary background color of the ruler area in the schedule.
public Property | RulerBorder | Gets or sets the type of border to place around the ruler area in the schedule.
public Property | RulerDivisions | Gets or sets the number of divisions to place in the ruler area between major time units
public Property | RulerFillType | Gets or sets the fill style for the ruler area in the schedule.
public Property | RulerFont | Gets or sets the ruler font in the schedule.
public Property | RulerForeColor | Gets or sets the text color of the ruler area in the schedule.
public Property | RulerLineColor | Gets or sets the color of the lines in the ruler area.
public Property | RulerOffset | Gets or sets the vertical and horizontal offset values of the ruler text in a schedule.
public Property | RulerThreeD | Determines if the ruler area will appear with some three dimensional features.
public Property | RulerTitle | Gets or sets the ruler title in the schedule.
public Property | RulerTitleBackColor | Determines the background color of the title area of the ruler.
public Property | RulerTitleBackColorTo | Determines the secondary background color of the title area of the ruler.
public Property | RulerTitleFillType | Determines the background pattern for the title area of the ruler.
public Property | RulerTitleFont | Determines the font used for the text in the title area of the ruler.
public Property | RulerTitleForeColor | Determines the foreground color used for the title area of the ruler.
public Property | ScheduleLineColor | Gets or sets the color of the horizontal lines seperating the list items in the schedule.
public Property | SelectedBackColor | Gets or sets the background color of selected list items in the schedule area.
public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
public Property | SplitRuler | Determines if the ruler will be split along the vertical axis.
public Property | Start | Gets or sets the start date and time of a schedule.
public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
public Property | TaskID | Assign a task to the schedule.
public Property | Text | Gets or sets the text associated with this control. (Inherited from System.Windows.Forms.Control)
public Property | TimeBarDateColor | Gets or sets the color of the Timebar dates.
public Property | TimeDistance | Gets or sets the distance between major time units for this dbiScheduleObject
public Property | TimeFormat | Determines how the hours in the ruler are displayed.
public Property | TimeLineBreak | Gets or sets the frequency of the time lines along the major time units in a schedule.
public Property | TimeLineColor | Gets or sets the color of the time lines in a schedule.
public Property | TimeLineStart | Gets or sets the major division where the first time line will be drawn.
public Property | TimeLineWidth | Gets or sets the width of the time lines in the schedule.
public Property | TimeType | Gets or sets the type of unit to display in the ruler of the schedule.
public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
public Property | Visible | Gets or sets a value indicating whether the dbiScheduleObject will be visible.
public Property | WeekendColor | Gets or sets the background color for weekend columns.
public Property | WeekFormat | Determines how the monthly ruler is displayed in the schedule.
public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
public Property | YearFormat | Determines how the yearly ruler is displayed in the schedule.
Top

See Also

Reference

dbiScheduleObject Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

BeginInvoke(Delegate) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method
A delegate to a method that takes no parameters.
Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)

Parameters

method
A delegate to a method that takes no parameters.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

BeginInvoke(Delegate,Object[]) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.
Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the given method. This can be null if no arguments are needed.

Return Value

An System.IAsyncResult that represents the result of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) operation.

Exceptions

Exception | Description
System.InvalidOperationException | No appropriate window handle can be found.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

CreateControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Dispose Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Dispose Method

Overload List

Overload | Description
Dispose | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Base Implementation in Dispose


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

PerformLayout() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

ResumeLayout() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

Scale Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

Select Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class : Select Method

Activates the control.

Overload List

Overload | Description
Select | Activates the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
Sets the bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiScheduleObject Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.
Sets the specified bounds of the control to the specified location and size.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiScheduleObject
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
The new System.Windows.Forms.Control.Left property value of the control.
y
The new System.Windows.Forms.Control.Top property value of the control.
width
The new System.Windows.Forms.Control.Width property value of the control.
height
The new System.Windows.Forms.Control.Height property value of the control.
specified
A bitwise combination of the System.Windows.Forms.BoundsSpecified values. For any parameter not specified, the current value will be used.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiScheduleObject Class
dbiScheduleObject Members
Overload List


%%PageItemTitle%%

AccessibilityObject Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AccessibilityObject Property

Gets the System.Windows.Forms.AccessibleObject assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}

Property Value

The System.Windows.Forms.AccessibleObject assigned to the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AccessibleDefaultActionDescription Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AccessibleDefaultActionDescription Property

Gets or sets the default action description of the control for use by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
public System.string AccessibleDefaultActionDescription {get; set;}

Property Value

The default action description of the control for use by accessibility client applications.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AccessibleDescription Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AccessibleDescription Property

Gets or sets the description of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
public System.string AccessibleDescription {get; set;}

Property Value

The description of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AccessibleName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AccessibleName Property

Gets or sets the name of the control used by accessibility client applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
public System.string AccessibleName {get; set;}

Property Value

The name of the control used by accessibility client applications. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AccessibleRole Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AccessibleRole Property

Gets or sets the accessible role of the control

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}

Property Value

One of the values of System.Windows.Forms.AccessibleRole. The default is Default.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.AccessibleRole values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AllowDrop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AllowDrop Property

Gets or sets a value indicating whether the control can accept data that the user drags onto it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
public virtual System.bool AllowDrop {get; set;}

Property Value

true if drag-and-drop operations are allowed in the control; otherwise, false. The default is false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Implementing Drag and Drop


%%PageItemTitle%%

Anchor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Anchor Property

Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}

Property Value

A bitwise combination of the System.Windows.Forms.AnchorStyles values. The default is Top and Left.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

AutoSetNodeHeight Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : AutoSetNodeHeight Method

Automatically sets the HeightOffset for the dbiScheduleItem passed as a parameter.

Overload List

Overload | Description
AutoSetNodeHeight | Automatically sets the HeightOffset for the dbiScheduleItem passed as a parameter.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BackgroundImage Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BackgroundImage Property

Determines the background image for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
public virtual System.Drawing.Image BackgroundImage {get; set;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BindingContext Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BindingContext Property

Gets or sets the System.Windows.Forms.BindingContext for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}

Property Value

A System.Windows.Forms.BindingContext for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Bottom Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Bottom Property

Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

value = instance.Bottom
C#
public System.int Bottom {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Bounds Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Bounds Property

Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
public System.Drawing.Rectangle Bounds {get; set;}

Property Value

A System.Drawing.Rectangle in pixels relative to the parent control that represents the size and location of the control including its nonclient elements.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

BringToFront Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : BringToFront Method

Brings the control to the front of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.BringToFront()
C#
public void BringToFront()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CanFocus Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CanFocus Property

Gets a value indicating whether the control can receive focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.CanFocus
C#
public System.bool CanFocus {get;}

Property Value

true if the control can receive focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CanSelect Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CanSelect Property

Gets a value indicating whether the control can be selected.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.CanSelect
C#
public System.bool CanSelect {get;}

Property Value

true if the control can be selected; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Capture Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Capture Property

Gets or sets a value indicating whether the control has captured the mouse.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
public System.bool Capture {get; set;}

Property Value

true if the control has captured the mouse; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CausesValidation Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CausesValidation Property

Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
public System.bool CausesValidation {get; set;}

Property Value

true if the control causes validation to be performed on any controls requiring validation when it receives focus; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ClientRectangle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ClientRectangle Property

Gets the rectangle that represents the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
public System.Drawing.Rectangle ClientRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ClientSize Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ClientSize Property

Gets or sets the height and width of the client area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
public System.Drawing.Size ClientSize {get; set;}

Property Value

A System.Drawing.Size that represents the dimensions of the client area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ColumnAt(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ColumnAt Method : ColumnAt(Int32,Int32) Method

nX
The X coordinate to test for a dbiColumnItem
nY
The Y coordinate to test for a dbiColumnItem
Gets the dbiColumnItem at a specified location

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nX As System.Integer
Dim nY As System.Integer
Dim value As dbiColumnItem

value = instance.ColumnAt(nX, nY)
C#
public dbiColumnItem ColumnAt(
   System.int nX,
   System.int nY
)

Parameters

nX
The X coordinate to test for a dbiColumnItem
nY
The Y coordinate to test for a dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ColumnAt(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ColumnAt Method : ColumnAt(Point) Method

ptPoint
The Point (X and Y coordinates) to test for the dbiColumnItem
Gets the dbiColumnItem at a specified location

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ptPoint As System.Drawing.Point
Dim value As dbiColumnItem

value = instance.ColumnAt(ptPoint)
C#
public dbiColumnItem ColumnAt(
   System.Drawing.Point ptPoint
)

Parameters

ptPoint
The Point (X and Y coordinates) to test for the dbiColumnItem

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

CompanyName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CompanyName Property

Gets the name of the company or creator of the application containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

value = instance.CompanyName
C#
public System.string CompanyName {get;}

Property Value

The company name or creator of the application containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Container Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Container Property

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
public System.ComponentModel.IContainer Container {get;}

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Contains Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Contains Method

ctl
The System.Windows.Forms.Control to evaluate.
Retrieves a value indicating whether the specified control is a child of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)

Parameters

ctl
The System.Windows.Forms.Control to evaluate.

Return Value

true if the specified control is a child of the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ContainsFocus Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ContainsFocus Property

Gets a value indicating whether the control, or one of its child controls, currently has the input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.ContainsFocus
C#
public System.bool ContainsFocus {get;}

Property Value

true if the control or one of its child controls currently has the input focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ContextMenu Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ContextMenu Property

Gets or sets the shortcut menu associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}

Property Value

A System.Windows.Forms.ContextMenu that represents the shortcut menu associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Controls Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Controls Property

Gets the collection of controls contained within the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
public System.Windows.Forms.Control.ControlCollection Controls {get;}

Property Value

A System.Windows.Forms.Control.ControlCollection representing the collection of controls contained within the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CreateControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CreateControl Method

Forces the creation of the visible control, including the creation of the handle and any visible child controls.

Overload List

Overload | Description
CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Created Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Created Property

Gets a value indicating whether the control has been created.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Created
C#
public System.bool Created {get;}

Property Value

true if the control has been created; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CreateGraphics Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CreateGraphics Method

Creates the System.Drawing.Graphics for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()

Return Value

The System.Drawing.Graphics for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

CreateObjRef Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : CreateObjRef Method

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.
Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)

Parameters

requestedType
The System.Type of the object that the new System.Runtime.Remoting.ObjRef will reference.

Return Value

Information required to generate a proxy.

Exceptions

Exception | Description
System.Runtime.Remoting.RemotingException | This instance is not a valid remoting object.
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Cursor Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
public virtual System.Windows.Forms.Cursor Cursor {get; set;}

Property Value

A System.Windows.Forms.Cursor that represents the cursor to display when the mouse pointer is over the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DataBindings Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DataBindings Property

Gets the data bindings for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}

Property Value

A System.Windows.Forms.ControlBindingsCollection that contains the System.Windows.Forms.Binding objects for the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DisplayRectangle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DisplayRectangle Property

Gets the rectangle that represents the display area of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}

Property Value

A System.Drawing.Rectangle that represents the display area of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Disposing Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Disposing Property

Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Disposing
C#
public System.bool Disposing {get;}

Property Value

true if the base System.Windows.Forms.Control class is in the process of disposing; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Dock Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Dock Property

Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
public virtual System.Windows.Forms.DockStyle Dock {get; set;}

Property Value

One of the System.Windows.Forms.DockStyle values. The default is System.Windows.Forms.DockStyle.None.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The value assigned is not one of the System.Windows.Forms.DockStyle values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DoDragDrop Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DoDragDrop Method

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.
Begins a drag-and-drop operation.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
The data to drag.
allowedEffects
One of the System.Windows.Forms.DragDropEffects values.

Return Value

A value from the System.Windows.Forms.DragDropEffects enumeration that represents the final effect that was performed during the drag-and-drop operation.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

DragEnter Event
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : DragEnter Event

Occurs when an object is dragged into the control's bounds.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
public event System.Windows.Forms.DragEventHandler DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Implementing Drag and Drop


%%PageItemTitle%%

Enabled Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
public System.bool Enabled {get; set;}

Property Value

true if the control can respond to user interaction; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

EndInvoke Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : EndInvoke Method

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).
Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)

Parameters

asyncResult
The System.IAsyncResult that represents a specific invoke asynchronous operation, returned when calling System.Windows.Forms.Control.BeginInvoke(System.Delegate).

Return Value

The System.Object generated by the asynchronous operation.

Exceptions

Exception | Description
System.ArgumentNullException | The asyncResult parameter value is null.
System.ArgumentException | The asyncResult object was not created by a preceding call of the System.Windows.Forms.Control.BeginInvoke(System.Delegate) method from the same control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

FindForm Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : FindForm Method

Retrieves the form that the control is on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
public System.Windows.Forms.Form FindForm()

Return Value

The System.Windows.Forms.Form that the control is on.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Focus Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Focus Method

Sets input focus to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Focus()
C#
public System.bool Focus()

Return Value

true if the input focus request was successful; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Focused Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Focused Property

Gets a value indicating whether the control has input focus.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Focused
C#
public virtual System.bool Focused {get;}

Property Value

true if the control has focus; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetChildAtPoint Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetChildAtPoint(Point) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
Retrieves the child control that is located at the specified coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.

Return Value

A System.Windows.Forms.Control that represents the control that is located at the specified point.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

GetChildAtPoint(Point,GetChildAtPointSkip) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.
Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
A System.Drawing.Point that contains the coordinates where you want to look for a control. Coordinates are expressed relative to the upper-left corner of the control's client area.
skipValue
One of the values of System.Windows.Forms.GetChildAtPointSkip, determining whether to ignore child controls of a certain type.

Return Value

The child System.Windows.Forms.Control at the specified coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

GetContainerControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetContainerControl Method

Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()

Return Value

An System.Windows.Forms.IContainerControl, that represents the parent of the System.Windows.Forms.Control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetLifetimeService Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetLifetimeService Method

Retrieves the current lifetime service object that controls the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Object

value = instance.GetLifetimeService()
C#
public System.object GetLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

GetNextControl Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : GetNextControl Method

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.
Retrieves the next control forward or back in the tab order of child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)

Parameters

ctl
The System.Windows.Forms.Control to start the search with.
forward
true to search forward in the tab order; false to search backward.

Return Value

The next System.Windows.Forms.Control in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Handle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Handle Property

Gets the window handle that the control is bound to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.IntPtr

value = instance.Handle
C#
public System.IntPtr Handle {get;}

Property Value

An System.IntPtr that contains the window handle (HWND) of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

HasChildren Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : HasChildren Property

Gets a value indicating whether the control contains one or more child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.HasChildren
C#
public System.bool HasChildren {get;}

Property Value

true if the control contains one or more child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Height Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Height Property

Gets or sets the height of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
public System.int Height {get; set;}

Property Value

The height of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Hide Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Hide Method

Conceals the control from the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.Hide()
C#
public void Hide()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ImeMode Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ImeMode Property

Gets or sets the Input Method Editor (IME) mode of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
public System.Windows.Forms.ImeMode ImeMode {get; set;}

Property Value

One of the System.Windows.Forms.ImeMode values. The default is System.Windows.Forms.ImeMode.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.ImeMode enumeration values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

InitializeLifetimeService Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InitializeLifetimeService Method

Obtains a lifetime service object to control the lifetime policy for this instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
public virtual System.object InitializeLifetimeService()

Return Value

An object of type System.Runtime.Remoting.Lifetime.ILease used to control the lifetime policy for this instance. This is the current lifetime service object for this instance if one exists; otherwise, a new lifetime service object initialized to the value of the System.Runtime.Remoting.Lifetime.LifetimeServices.LeaseManagerPollTime property.

Exceptions

Exception | Description
System.Security.SecurityException | The immediate caller does not have infrastructure permission.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Invalidate Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Invalidate Method

Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Overload List

Overload | Description
Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Invalidate() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate() Method

Invalidates the entire surface of the control and causes the control to be redrawn.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.Invalidate()
C#
public void Invalidate()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invalidate(Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate(Rectangle) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
public void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invalidate(Rectangle,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
A System.Drawing.Rectangle that represents the region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invalidate(Region) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate(Region) Method

region
The System.Drawing.Region to invalidate.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
public void Invalidate(
   System.Drawing.Region region
)

Parameters

region
The System.Drawing.Region to invalidate.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invalidate(Region,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.
Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)

Parameters

region
The System.Drawing.Region to invalidate.
invalidateChildren
true to invalidate the control's child controls; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invoke Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Invoke Method

Executes the specified delegate on the thread that owns the control's underlying window handle.

Overload List

Overload | Description
Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Invoke(Delegate) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invoke Method : Invoke(Delegate) Method

method
A delegate that contains a method to be called in the control's thread context.
Executes the specified delegate on the thread that owns the control's underlying window handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
public System.object Invoke(
   System.Delegate method
)

Parameters

method
A delegate that contains a method to be called in the control's thread context.

Return Value

The return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Invoke(Delegate,Object[]) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.
Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)

Parameters

method
A delegate to a method that takes parameters of the same number and type that are contained in the args parameter.
args
An array of objects to pass as arguments to the specified method. This parameter can be null if the method takes no arguments.

Return Value

An System.Object that contains the return value from the delegate being invoked, or null if the delegate has no return value.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

InvokeRequired Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : InvokeRequired Property

Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.InvokeRequired
C#
public System.bool InvokeRequired {get;}

Property Value

true if the control's System.Windows.Forms.Control.Handle was created on a different thread than the calling thread (indicating that you must make calls to the control through an invoke method); otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

IsAccessible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IsAccessible Property

Gets or sets a value indicating whether the control is visible to accessibility applications.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
public System.bool IsAccessible {get; set;}

Property Value

true if the control is visible to accessibility applications; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

IsDisposed Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IsDisposed Property

Gets a value indicating whether the control has been disposed of.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.IsDisposed
C#
public System.bool IsDisposed {get;}

Property Value

true if the control has been disposed of; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

IsHandleCreated Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : IsHandleCreated Property

Gets a value indicating whether the control has a handle associated with it.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
public System.bool IsHandleCreated {get;}

Property Value

true if a handle has been assigned to the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Left Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Left Property

Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
public System.int Left {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the left edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Location Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
public System.Drawing.Point Location {get; set;}

Property Value

The System.Drawing.Point that represents the upper-left corner of the control relative to the upper-left corner of its container.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Name Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Name Property

Gets or sets the name of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.Name = value

value = instance.Name
C#
public System.string Name {get; set;}

Property Value

The name of the control. The default is an empty string ("").

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Parent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Parent Property

Gets or sets the parent container of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
public System.Windows.Forms.Control Parent {get; set;}

Property Value

A System.Windows.Forms.Control that represents the parent or container control of the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PerformLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PerformLayout Method

Forces the control to apply layout logic to all its child controls.

Overload List

Overload | Description
PerformLayout() | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PerformLayout() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PerformLayout Method : PerformLayout() Method

Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.PerformLayout()
C#
public void PerformLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PerformLayout(Control,String) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.
Forces the control to apply layout logic to all its child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)

Parameters

affectedControl
A System.Windows.Forms.Control that represents the most recently changed control.
affectedProperty
The name of the most recently changed property on the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

PointToClient Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PointToClient Method

p
The screen coordinate System.Drawing.Point to convert.
Computes the location of the specified screen point into client coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p
The screen coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in client coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PointToScreen Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PointToScreen Method

p
The client coordinate System.Drawing.Point to convert.
Computes the location of the specified client point into screen coordinates.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p
The client coordinate System.Drawing.Point to convert.

Return Value

A System.Drawing.Point that represents the converted System.Drawing.Point, p, in screen coordinates.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

PreProcessMessage Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : PreProcessMessage Method

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.
Preprocesses keyboard or input messages within the message loop before they are dispatched.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)

Parameters

msg
A System.Windows.Forms.Message, passed by reference, that represents the message to process. The possible values are WM_KEYDOWN, WM_SYSKEYDOWN, WM_CHAR, and WM_SYSCHAR.

Return Value

true if the message was processed by the control; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ProductName Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ProductName Property

Gets the product name of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

value = instance.ProductName
C#
public System.string ProductName {get;}

Property Value

The product name of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ProductVersion Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ProductVersion Property

Gets the version of the assembly containing the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

value = instance.ProductVersion
C#
public System.string ProductVersion {get;}

Property Value

The file version of the assembly containing the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RecreatingHandle Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RecreatingHandle Property

Gets a value indicating whether the control is currently re-creating its handle.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
public System.bool RecreatingHandle {get;}

Property Value

true if the control is currently re-creating its handle; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Refresh Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.Refresh()
C#
public virtual void Refresh()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Region Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Region Property

Gets or sets the window region associated with the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
public System.Drawing.Region Region {get; set;}

Property Value

The window System.Drawing.Region associated with the control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ResumeLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ResumeLayout Method

Resumes usual layout logic.

Overload List

Overload | Description
ResumeLayout() | Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ResumeLayout() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ResumeLayout Method : ResumeLayout() Method

Resumes usual layout logic.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.ResumeLayout()
C#
public void ResumeLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

ResumeLayout(Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout
true to execute pending layout requests; otherwise, false.
Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout
true to execute pending layout requests; otherwise, false.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Right Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Right Property

Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

value = instance.Right
C#
public System.int Right {get;}

Property Value

An System.Int32 representing the distance, in pixels, between the right edge of the control and the left edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

RightToLeft Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : RightToLeft Property

Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}

Property Value

One of the System.Windows.Forms.RightToLeft values. The default is System.Windows.Forms.RightToLeft.Inherit.

Exceptions

Exception | Description
System.ComponentModel.InvalidEnumArgumentException | The assigned value is not one of the System.Windows.Forms.RightToLeft values.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Scale Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Scale Method

Scales the control and any child controls.

Overload List

Overload | Description
Scale | Scales the control and all child controls by the specified scaling factor. (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

SendToBack Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SendToBack Method

Sends the control to the back of the z-order.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.SendToBack()
C#
public void SendToBack()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Show Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Show Method

Displays the control to the user.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.Show()
C#
public void Show()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Site Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Site Property

Gets or sets the site of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
public virtual System.ComponentModel.ISite Site {get; set;}

Property Value

The System.ComponentModel.ISite associated with the System.Windows.Forms.Control, if any.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Size Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Size Property

Gets or sets the height and width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
public System.Drawing.Size Size {get; set;}

Property Value

The System.Drawing.Size that represents the height and width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Sort() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Sort Method : Sort() Method

Sort the data of the list portion of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

value = instance.Sort()
C#
public System.bool Sort()

Return Value

A Boolean value, indicating if the operation was successful.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Sort(Int32) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Sort Method : Sort(Int32) Method

nColumn
The zero-based index value of the column to sort
Will sort the list based on the 0-based column parameter. The SortColumn Property will change to reflect the value entered here.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nColumn As System.Integer
Dim value As System.Boolean

value = instance.Sort(nColumn)
C#
public System.bool Sort(
   System.int nColumn
)

Parameters

nColumn
The zero-based index value of the column to sort

Return Value

Boolean value indicating the success of the sort.

Example

The sort will be performed on the first column.
Visual Basic Copy Code
Dim booReturn As Boolean
booReturn = Me.dbiSchedule.Sort(0)
C# Copy Code
bool booReturn
booReturn = this.dbiSchedule.Sort(0);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Sort(Int32,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Sort Method : Sort(Int32,Int32) Method

nColumn
The zero-based index of the column to perform the sort against.
nLevels
The level of items to start the sort operation (0 indicates the top most level of items in the control)
Sort the data of the list portion of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim nColumn As System.Integer
Dim nLevels As System.Integer
Dim value As System.Boolean

value = instance.Sort(nColumn, nLevels)
C#
public System.bool Sort(
   System.int nColumn,
   System.int nLevels
)

Parameters

nColumn
The zero-based index of the column to perform the sort against.
nLevels
The level of items to start the sort operation (0 indicates the top most level of items in the control)

Return Value

Boolean value indicating the success of the sort.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

Sort(Int32[]) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class > Sort Method : Sort(Int32[]) Method

arrayColumns
An Integer array containg the columns to sort.
Will sort the list based on the column(s) passed in the array parameter. The SortColumn Property will change to reflect the first column value entered here.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim arrayColumns() As System.Integer
Dim value As System.Boolean

value = instance.Sort(arrayColumns)
C#
public System.bool Sort(
   System.int[] arrayColumns
)

Parameters

arrayColumns
An Integer array containg the columns to sort.

Return Value

Boolean value indicating the success of the sort.

Example

The primary sort will be performed on the first column, then the second and third.

Visual Basic Copy Code
Dim intSorting As Integer()
intSorting = New Integer() {0, 1, 2}
Me.DbiSchedule1.Sort(intSorting)
C# Copy Code
int[] intSorting = {0,1,2};
this.dbiSchedule1.Sort(intSorting);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members
Overload List


%%PageItemTitle%%

SuspendLayout Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : SuspendLayout Method

Temporarily suspends the layout logic for the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.SuspendLayout()
C#
public void SuspendLayout()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TabIndex Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TabIndex Property

Gets or sets the tab order of the control within its container.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.TabIndex = value

value = instance.TabIndex
C#
public System.int TabIndex {get; set;}

Property Value

The index value of the control within the set of controls within its container. The controls in the container are included in the tab order.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TabStop Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.TabStop = value

value = instance.TabStop
C#
public System.bool TabStop {get; set;}

Property Value

true if the user can give the focus to the control using the TAB key; otherwise, false. The default is true.This property will always return true for an instance of the System.Windows.Forms.Form class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Tag Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Tag Property

Gets or sets the object that contains data about the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
public System.object Tag {get; set;}

Property Value

An System.Object that contains data about the control. The default is null.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Text Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Text Property

Gets or sets the text associated with this control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

instance.Text = value

value = instance.Text
C#
public virtual System.string Text {get; set;}

Property Value

The text associated with this control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Top Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Top Property

Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
public System.int Top {get; set;}

Property Value

An System.Int32 representing the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

TopLevelControl Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
public System.Windows.Forms.Control TopLevelControl {get;}

Property Value

The System.Windows.Forms.Control that represents the top-level control that contains the current control.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

ToString Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : ToString Method

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Update Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Update Method

Causes the control to redraw the invalidated regions within its client area.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule

instance.Update()
C#
public void Update()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Visible Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Visible Property

Gets or sets a value indicating whether the control and all its child controls are displayed.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
public System.bool Visible {get; set;}

Property Value

true if the control and all its child controls are displayed; otherwise, false. The default is true.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%%

Width Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiSchedule Class : Width Property

Gets or sets the width of the control.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As dbiSchedule
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
public System.int Width {get; set;}

Property Value

The width of the control in pixels.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiSchedule Class
dbiSchedule Members


%%PageItemTitle%% $$Methods$$

dbiTimeBarItem Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarItem Class

"

For a list of all members of this type, see dbiTimeBarItem members.

"

Public Methods

 | Name | Description
public Method | Clone | Creates a new object that is a copy of the current instance. (Inherited from Dbi.PIM.dbiAppointmentItem)
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiTimeBarItem Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarItem Class

"

For a list of all members of this type, see dbiTimeBarItem members.

"

Public Properties

 | Name | Description
public Property | AlarmEnd | Determines if an alarm will fire when the Timebar ends. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | AlarmStart | Determines if an alarm will fire when the Timebar begins. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BackColor | Gets or sets the primary background color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BackColorTo | Gets or sets the secondary background color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Body | Gets or sets the subtext of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BodyForeColor | Determines the foreground color used for body text on a dbiTimeBarItem.
public Property | BorderColor | Gets or sets the border color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | BorderType | Overridden. Gets or sets the type of border to place around the Timebar.
public Property | Cargo | Gets or sets a non-visible text value for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ContactID | Assigns a contact to the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Data | Gets or sets a non-visible numeric value for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | DateColor | Determines the foreground color used when displaying dates inside a dbiTimeBarItem.
public Property | End | Gets or sets the ending date and time for a Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | EndImage | Gets or sets the image to place after the Timebar.
public Property | EntryID | Gets or sets a non-visible text value for the Timebar.. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | FillType | Gets or sets the background fill pattern of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Font | Gets or sets the font for the main text in the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Font2 | Gets or sets the font of the Timebar body text. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ForeColor | Gets or sets the fore color of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | HatchStyle | Gets or sets the background pattern of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Image1 | Gets or sets the primary image associated with the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ImageAlign | Gets or sets the alignment of Image1.
public Property | IsSelected | Determines if a Timebar is selected.
public Property | Location | Gets or sets the appointment location. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | LocationID | Assigns a location to the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Locked | Determines if the appointment can be moves or sized by user-interaction. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | MaxTime | Gets or sets the maximum end time of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | MinTime | Gets or sets the minimum start time of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | PercentBorderColor | Determines the color used for the border of the percent bar in the dbiTimeBarItem.
public Property | PercentColor | Gets or sets the color of the percent complete bar inside the regular time bar.
public Property | PercentColorTo | Determines the secondary background color of the percent bar in the dbiTimeBarItem
public Property | PercentFillType | Determines the background pattern to paint the percent bar in the dbiTimeBarItem.
public Property | PercentHeight | Gets or sets the height of the percent complete bar inside the regular time bar.
public Property | PercentValue | Gets or sets the value of the percent complete bar inside the regular time bar.
public Property | PercentVOffset | Determines the vertical offset for displaying the percent bar inside a dbiTimeBarItem.
public Property | ReadOnly | Determines if the appointment info can be edited. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | RecordID | Gets or sets a hidden numeric value for the appoinment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderMinutesBeforeStart | Determines how many minutes before the Timebar starts an alarm is fired. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderPlaySound | Determines if a reminder sound will be played when the Timebar alarm is triggered. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSet | Determines if a reminder has been set for the start of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSetEnd | Determines if a reminder has been set for the end of the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | ReminderSoundFile | Gets or sets the reminder sound to be played when the appointment alarm is triggered. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Start | Gets or sets the starting date and time of an appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | StartImage | Gets or sets the image to place before the Timebar.
public Property | Style | Overridden. Gets or sets a pre-defined style assigned to the Timebar.
public Property | SubTextFont | Gets or sets the sub text font of the appointment. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Tag | Determines an object that contains data about the dbiTimeBarItem. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | TaskID | Assigns a task to the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Text | Gets or sets the Timebar text. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | TextAlign | Gets or sets the horizontal and vertical alignment of the primary text in the Timebar.
public Property | VCalendar | Gets or sets the VCalendar specification for the Timebar. (Inherited from Dbi.PIM.dbiAppointmentItem)
public Property | Visible | Gets or sets a value indicating whether the time bar will be visible.
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiTimeBarItem Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiTimeBarStyle Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiTimeBarStyle Class

"

For a list of all members of this type, see dbiTimeBarStyle members.

"

Public Properties

 | Name | Description
public Property | BackColor | Gets or sets the primary background color of the Timebar.
public Property | BackColorTo | Gets or sets the secondary background color of the Timebar.
public Property | BarHeight | Gets or sets the bar height.
public Property | BorderColor | Gets or sets the border color of the Timebar.
public Property | EndImage | Gets or sets the image to be placed at the end of the Timebar.
public Property | EndImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the EndImage.
public Property | EndImageOrder | Determines if the EndImage will appear in front of or behind the Timebar.
public Property | FillType | Gets or sets the background gradiant fill pattern of the bar style.
public Property | Font | Gets or sets the font of the Timebar.
public Property | ForeColor | Gets or sets the forecolor of the Timebar.
public Property | HatchStyle | Gets or sets the background pattern of the bar style.
public Property | Milestone | Determines if the Timebar will be defined as a milestrone marker.
public Property | StartImage | Gets or sets the image to be placed at the front of the Timebar.
public Property | StartImageOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the StartImage.
public Property | StartImageOrder | Determines if the StartImage will appear in front of or behind the Timebar.
public Property | TextOffset | Gets or sets the vertical and horizontal offset values used to calculate the position of the text within the Timebar.
public Property | VerticalOffset | Gets or sets the vertical offset value used to calculate the position of the Timebar.
public Property | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

dbiTimeBarStyle Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiUserDrawnBar Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBar Class

"

For a list of all members of this type, see dbiUserDrawnBar members.

"

Public Properties

 | Name | Description
public Property | Rect | Determines the rectangle representing the size and location of the dbiTimeBarItem.
public Property | ScheduleItem | Determines the dbiScheduleItem that contains the dbiTimeBarItem being drawn.
public Property | ScheduleObject | Determines the dbiScheduleObject where the dbiTimeBarItem is being drawn.
public Property | TimeBarItem | Determines the dbiTimeBarItem being drawn.
Top

See Also

Reference

dbiUserDrawnBar Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

dbiUserDrawnBarCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBarCollection Class

"

For a list of all members of this type, see dbiUserDrawnBarCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a dbiUserDrawnBar to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the internal index of the dbiUserDrawnBar object.
public Method | Insert | Inserts a dbiUserDrawnBar into the collection at the specified index.
public Method | Remove | Removes a dbiUserDrawnBar from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

dbiUserDrawnBarCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

dbiUserDrawnBarCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : dbiUserDrawnBarCollection Class

"

For a list of all members of this type, see dbiUserDrawnBarCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | A dbiUserDrawnBar object located in the collection.
Top

See Also

Reference

dbiUserDrawnBarCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > dbiUserDrawnBarCollection Class : IndexOf Method

Returns the internal index of the dbiUserDrawnBar object.

Overload List

Overload | Description
IndexOf | Returns the internal index of the dbiUserDrawnBar object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

dbiUserDrawnBarCollection Class
dbiUserDrawnBarCollection Members


%%PageItemTitle%% $$Properties$$

DeadZoneDropEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : DeadZoneDropEventArgs Class

"

For a list of all members of this type, see DeadZoneDropEventArgs members.

"

Public Properties

 | Name | Description
public Property | AllowDrop | Determines if the time bar will be allowed to intersect the dead zone.
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | End | Determines the ending datetime value of the time bar when it intersects the dead zone.
public Property | ScheduleItem | Determines the dbiScheduleItem where the time bar encounters the dead zone
public Property | Start | Determines the starting datetime value of the time bar when it intersects the dead zone.
public Property | TimeBar | The timebar source of the deadzonedrop.
Top

See Also

Reference

DeadZoneDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

EditModeChangedEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : EditModeChangedEventArgs Class

"

For a list of all members of this type, see EditModeChangedEventArgs members.

"

Public Properties

 | Name | Description
public Property | EditMode | The new EditMode for the control.
Top

See Also

Reference

EditModeChangedEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

GuideLineClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineClickEventArgs Class

"

For a list of all members of this type, see GuideLineClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The mouse button that was used to click the GuideLine.
public Property | GuideLine | The dbiGuideLine that was clicked.
public Property | LineIndex | The zero-based index of the GuideLine in the GuideLines collection.
public Property | OnImage | Determines if the GuideLine image was clicked or the GuideLine itself.
public Property | ScheduleObject | The dbiScheduleObject where the GuideLine was clicked.
public Property | X | The X position of the mouse where the click occurred.
public Property | Y | The Y position of the mouse where the click occurred.
Top

See Also

Reference

GuideLineClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

GuideLineInDeadZoneEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineInDeadZoneEventArgs Class

"

For a list of all members of this type, see GuideLineInDeadZoneEventArgs members.

"

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea that is designated as a deadzone.
public Property | GuideLine | The dbiGuideLine that is in the dead zone.
public Property | IgnoreDeadZone | Determines if the dead zone should be treated as a standard custom area instead of a dead zone
public Property | ScheduleItem | The dbiScheduleItem containing the dead zone
Top

See Also

Reference

GuideLineInDeadZoneEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

GuideLineMoveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : GuideLineMoveEventArgs Class

"

For a list of all members of this type, see GuideLineMoveEventArgs members.

"

Public Properties

 | Name | Description
public Property | GuideLine | The dbiGuideLine that is moving.
public Property | LineTime | The current date/time value of the GuideLine that is being moved.
public Property | NewLine | Indicates if the GuideLine being moved is a newly added GuideLine or an existing GuideLine.
public Property | ScheduleObject | The dbiScheduleObject where the GuideLine is moving.
Top

See Also

Reference

GuideLineMoveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

HistoryChangeEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryChangeEventArgs Class

"

For a list of all members of this type, see HistoryChangeEventArgs members.

"

Public Properties

 | Name | Description
public Property | Redo | Determines if an item in the RedoHistory collection has changed.
public Property | Undo | Determines if an item in the UndoHistory collection has changed.
Top

See Also

Reference

HistoryChangeEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

HistoryCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryCollection Class

"

For a list of all members of this type, see HistoryCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new item to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified item in the collection.
public Method | Insert | Inserts a new item into the collection
public Method | Remove | Removes an item from the collection.
public Method | RemoveAt | Removes a history item at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

HistoryCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

HistoryCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : HistoryCollection Class

"

For a list of all members of this type, see HistoryCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets a history item at a specific location in the collection.
Top

See Also

Reference

HistoryCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > HistoryCollection Class : IndexOf Method

Returns the index of a specified item in the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified item in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

HistoryCollection Class
HistoryCollection Members


%%PageItemTitle%% $$Properties$$

ItemMouseOverEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ItemMouseOverEventArgs Class

"

For a list of all members of this type, see ItemMouseOverEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar the mouse is over.
public Property | GuideLineIndex | The zero-based index value of the GuideLine the mouse is over.
public Property | GuideLineItem | The dbiGuideLine the mouse is over.
public Property | NoteIndex | The zero-based index value of the note the mouse is over.
public Property | NoteItem | The dbiScheduleNote the mouse is over.
public Property | ScheduleIndex | The zero-based index value of the schedule the mouse is over.
public Property | ScheduleItem | The dbiScheduleItem the mouse is over.
public Property | ScheduleObject | The dbiScheduleObject the mouse is over.
public Property | TimeBarItem | The dbiTimeBarItem the mouse is over.
Top

See Also

Reference

ItemMouseOverEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

LineArrowClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowClickEventArgs Class

"

For a list of all members of this type, see LineArrowClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow exists.
public Property | ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.
Top

See Also

Reference

LineArrowClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

LineArrowDoubleClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowDoubleClickEventArgs Class

"

For a list of all members of this type, see LineArrowDoubleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Direction | The direction of the clicked Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow exists.
public Property | ScheduleObject | The dbiScheduleObject where the Line Arrow was clicked.
Top

See Also

Reference

LineArrowDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

LineArrowMouseOverEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LineArrowMouseOverEventArgs Class

"

For a list of all members of this type, see LineArrowMouseOverEventArgs members.

"

Public Properties

 | Name | Description
public Property | Direction | The direction of the Line Arrow the mouse is over.
public Property | ScheduleIndex | The zero-based index value of the dbiScheduleObject where the mouse is over the Line Arrow.
public Property | ScheduleItem | The ScheduleItem where the Line Arrow the mouse is over exists.
public Property | ScheduleObject | The dbiScheduleObject where the mouse is over the Line Arrow
Top

See Also

Reference

LineArrowMouseOverEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

LinkCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LinkCollection Class

Represents a collection of link items.

Object Model

LinkCollection ClassdbiLinkItem ClassdbiTimeBarItem ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
C#
public class LinkCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.LinkCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

LinkCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LinkCollection Class

"

The following tables list the members exposed by LinkCollection.

"

Public Constructors

 | Name | Description
public Constructor | LinkCollection Constructor | Initializes a new instance of the LinkCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the link at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new link to the collection.
public Method | Clear | Clears all of the links from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified link in the collection.
public Method | Insert | Inserts a link into the collection.
public Method | LinkIndex | Gets or sets the index value of a link based on 2 Timebars.
public Method | LinksFrom | Gets the destination Timebar of the link.
public Method | LinksFromCount | Gets the number of Timebars linking to another Timebar.
public Method | LinksTo | Gets the originating Timebar of the link.
public Method | LinksToCount | Gets the number of Timebars that a given Timebar links to.
public Method | Remove | Removes a link from the collection.
public Method | RemoveAt | Removes a link at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

LinkCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

LinkCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LinkCollection Class

"

For a list of all members of this type, see LinkCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new link to the collection.
public Method | Clear | Clears all of the links from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified link in the collection.
public Method | Insert | Inserts a link into the collection.
public Method | LinkIndex | Gets or sets the index value of a link based on 2 Timebars.
public Method | LinksFrom | Gets the destination Timebar of the link.
public Method | LinksFromCount | Gets the number of Timebars linking to another Timebar.
public Method | LinksTo | Gets the originating Timebar of the link.
public Method | LinksToCount | Gets the number of Timebars that a given Timebar links to.
public Method | Remove | Removes a link from the collection.
public Method | RemoveAt | Removes a link at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

LinkCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

LinkCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : LinkCollection Class

"

For a list of all members of this type, see LinkCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the link at a specific location in the collection.
Top

See Also

Reference

LinkCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

LinkCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinkCollection Constructor

objOwner
The dbiSchedule control that will contain the LinkCollection.
Initializes a new instance of the LinkCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiSchedule

Dim instance As New LinkCollection(objOwner)
C#
public LinkCollection(
   dbiSchedule objOwner
)

Parameters

objOwner
The dbiSchedule control that will contain the LinkCollection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Add Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Add Method

obj
A dbiLinkItem object.
Adds a new link to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim obj As dbiLinkItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiLinkItem obj
)

Parameters

obj
A dbiLinkItem object.

Return Value

The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
objLink = New Dbi.WinControl.Schedule.dbiLinkItem
'Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23
'Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39
'Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct

'Adds the new link
Me.dbiSchedule1.Links.Add(objLink)
C# Copy Code
Dbi.WinControl.Schedule.dbiLinkItem objLink;
objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

//Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23;
//Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39;

//Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct;

//Adds the new link
this.dbiSchedule1.Links.Add(objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Clear Method

Clears all of the links from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection

instance.Clear()
C#
public void Clear()

Example

Visual Basic Copy Code
Me.dbiSchedule.Links.Clear()
C# Copy Code
this.dbiSchedule.Links.Clear();

Remarks

This method will delete all the items from the collection. To remove a single item, use Remove method or the RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Count Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the number of links in the collection.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Example

Visual Basic Copy Code
Dim intCount As Integer
intCount = Me.dbiSchedule.Links.Count()
C# Copy Code
int intCount;
intCount = this.dbiSchedule.Links.Count();

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : IndexOf Method

Returns the index of a specified link in the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified link in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

IndexOf(dbiLinkItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : IndexOf(dbiLinkItem) Method

obj
The dbiLinkItem to locate in the collection.
Returns the index of a specified link in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim obj As dbiLinkItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiLinkItem obj
)

Parameters

obj
The dbiLinkItem to locate in the collection.

Return Value

The zero-based index value of the link.

Example

Visual Basic Copy Code
Dim intLinkIndex As Integer

intLinkIndex = Me.dbiSchedule.Link.IndexOf(objLink);
C# Copy Code
int intLinkIndex;

intLinkIndex = this.dbiSchedule.Links.IndexOf(objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Insert Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiLinkItem to insert into the collection.
Inserts a link into the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim nIndex As System.Integer
Dim obj As dbiLinkItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiLinkItem obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiLinkItem to insert into the collection.

Example

Visual Basic Copy Code
objLink = New Dbi.WinControl.Schedule.dbiLinkItem
'Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23
'Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39
'Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct

'Adds the new link
Me.dbiSchedule1.Links.Insert(0, objLink)
C# Copy Code
Dbi.WinControl.Schedule.dbiLinkItem objLink;
objLink = new Dbi.WinControl.Schedule.dbiLinkItem();

//Sets the time bar to begin the link
objLink.TimebarFrom = objTimebar23;
//Sets the time bar which is linked to
objLink.TimebarTo = objTimebar39;

//Sets the link type
objLink.LinkType = Dbi.WinControl.Schedule.dbiLinkItem.enumLinkType.Direct;

//Adds the new link
this.dbiSchedule1.Links.Insert(0, objLink);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Item Property

nIndex
The zero-based index of the link to get or set in the collection.
Gets or sets the link at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim nIndex As System.Integer
Dim value As dbiLinkItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiLinkItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the link to get or set in the collection.

Property Value

The dbiLinkItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

LinkIndex Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinkIndex Method

objFrom
The dbiTimebarItem where the link originates.
objTo
The dbiTimebarItem where the link terminates.
Gets or sets the index value of a link based on 2 Timebars.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim objFrom As dbiTimeBarItem
Dim objTo As dbiTimeBarItem
Dim value As System.Integer

value = instance.LinkIndex(objFrom, objTo)
C#
public System.int LinkIndex(
   dbiTimeBarItem objFrom,
   dbiTimeBarItem objTo
)

Parameters

objFrom
The dbiTimebarItem where the link originates.
objTo
The dbiTimebarItem where the link terminates.

Return Value

An Integer value, indicating the index of the link item. If there is no link between objFrom and objTo a -1 is returned.

Example

Visual Basic Copy Code
Dim intLinkIndex As Integer
intLinkIndex = Me.dbiSchedule.Links.LinkIndex(objLink1, objLink2)
C# Copy Code
int intLinkIndex;
intLinkIndex = this.dbiSchedule.Links.LinkIndex(objLink1, objLink2);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members
Timebar Linking


%%PageItemTitle%%

LinksFrom Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinksFrom Method

objBar
The dbiTimebarItem where the link originates.
nIndex
The zero-based index value of the link to evaluate.
Gets the destination Timebar of the link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim objBar As dbiTimeBarItem
Dim nIndex As System.Integer
Dim value As dbiTimeBarItem

value = instance.LinksFrom(objBar, nIndex)
C#
public dbiTimeBarItem LinksFrom(
   dbiTimeBarItem objBar,
   System.int nIndex
)

Parameters

objBar
The dbiTimebarItem where the link originates.
nIndex
The zero-based index value of the link to evaluate.

Return Value

A dbiTimebarItem object, representing the destination of a link.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members
Timebar Linking


%%PageItemTitle%%

LinksFromCount Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinksFromCount Method

objBar
The dbiTimebarItem to evaluate.
Gets the number of Timebars linking to another Timebar.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim objBar As dbiTimeBarItem
Dim value As System.Integer

value = instance.LinksFromCount(objBar)
C#
public System.int LinksFromCount(
   dbiTimeBarItem objBar
)

Parameters

objBar
The dbiTimebarItem to evaluate.

Return Value

An Integer value, indicatin how many Timebars link to the objBar.

Example

Visual Basic Copy Code
Dim intLinksCount As Integer
intLinksCount = Me.dbiSchedule.LinksLinksFromCount(objTimebarItem)
C# Copy Code
int intLinksCount;
intLinksCount = this.dbiSchedule.LinksLinksToCount(objTimebarItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members
Timebar Linking


%%PageItemTitle%%

LinksTo Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinksTo Method

objBar
The destination dbiTimebarItem object of the link.
nIndex
The zero-based index value of the link to evaluate.
Gets the originating Timebar of the link.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim objBar As dbiTimeBarItem
Dim nIndex As System.Integer
Dim value As dbiTimeBarItem

value = instance.LinksTo(objBar, nIndex)
C#
public dbiTimeBarItem LinksTo(
   dbiTimeBarItem objBar,
   System.int nIndex
)

Parameters

objBar
The destination dbiTimebarItem object of the link.
nIndex
The zero-based index value of the link to evaluate.

Return Value

A dbiTimebarItem object, representing the origin of a link.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members
Timebar Linking


%%PageItemTitle%%

LinksToCount Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : LinksToCount Method

objBar
The dbiTimebarItem to evaluate.
Gets the number of Timebars that a given Timebar links to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim objBar As dbiTimeBarItem
Dim value As System.Integer

value = instance.LinksToCount(objBar)
C#
public System.int LinksToCount(
   dbiTimeBarItem objBar
)

Parameters

objBar
The dbiTimebarItem to evaluate.

Return Value

An Integer value, indicating how many Timebars the objBar links to.

Example

Visual Basic Copy Code
Dim intLinksCount As Integer
intLinksCount = Me.dbiSchedule.LinksLinksToCount(objTimebarItem)
C# Copy Code
int intLinksCount;
intLinksCount = this.dbiSchedule.LinksLinksToCount(objTimebarItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members
Timebar Linking


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : Remove Method

obj
The dbiLinkItem to remove.
Removes a link from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim obj As dbiLinkItem

instance.Remove(obj)
C#
public void Remove(
   dbiLinkItem obj
)

Parameters

obj
The dbiLinkItem to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Links.Remove(objLink)
C# Copy Code
this.dbiSchedule.Links.Remove(objLink);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > LinkCollection Class : RemoveAt Method

index
The zero-based index of the link to remove.
Removes a link at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As LinkCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the link to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Example

Visual Basic Copy Code
Me.dbiSchedule.Links.RemoveAt(0)
C# Copy Code
this.dbiSchedule.Links.RemoveAt(0);

Remarks

If the index value provided in less that zero, or greater than the value in Count property of the TimebarItemCollection an ArgumentExceptionOutOfRange will occur.

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

LinkCollection Class
LinkCollection Members


%%PageItemTitle%% $$Properties$$

ListClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListClickEventArgs Class

"

For a list of all members of this type, see ListClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | Gets which mouse button was pressed.
public Property | ColumnIndex | The zero-based index of the dbiColumnItem where the click occurred.
public Property | ColumnItem | The dbiColumnItem where the click occurred.
public Property | ScheduleItem | The dbiScheduleItem which has been clicked.
Top

See Also

Reference

ListClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ListDoubleClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDoubleClickEventArgs Class

"

For a list of all members of this type, see ListDoubleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Column | The column which has been double clicked on.
public Property | ScheduleItem | The dbiScheduleItem which has been double clicked.
Top

See Also

Reference

ListDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ListDropEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ListDropEventArgs Class

"

For a list of all members of this type, see ListDropEventArgs members.

"

Public Properties

 | Name | Description
public Property | drgevent | Gets or sets the drag and drop information of the ScheduleItem where the drop occurred.
public Property | ScheduleItem | Gets or sets the dbiScheduleItem where a drop has occurred.
Top

See Also

Reference

ListDropEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

MouseWheelCheckEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : MouseWheelCheckEventArgs Class

"

For a list of all members of this type, see MouseWheelCheckEventArgs members.

"

Public Properties

 | Name | Description
public Property | Allow | Determines if the default MouseWheel behavior will occur (scrolling the vertical scrollbar)
public Property | MouseEvents | The MouseEventArgs related to the MouseWheel scroll that triggered the event.
Top

See Also

Reference

MouseWheelCheckEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

NoteClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteClickEventArgs Class

"

For a list of all members of this type, see NoteClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that performed the click.
public Property | ScheduleItem | The ScheduleItem where the clicked note exists.
public Property | ScheduleNote | the dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

NoteDoubleClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : NoteDoubleClickEventArgs Class

"

For a list of all members of this type, see NoteDoubleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | ScheduleItem | The ScheduleItem where the clicked note exists.
public Property | ScheduleNote | the dbiScheduleNote that was clicked.
Top

See Also

Reference

NoteDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

RedoActionEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RedoActionEventArgs Class

"

For a list of all members of this type, see RedoActionEventArgs members.

"

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the RedoActionEvent.
Top

See Also

Reference

RedoActionEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

RulerDragEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : RulerDragEventArgs Class

"

For a list of all members of this type, see RulerDragEventArgs members.

"

Public Properties

 | Name | Description
public Property | ScheduleObject | The dbiScheduleObject that contains the ruler that triggered the event.
public Property | Source | The location where the drag started.
public Property | Target | The location where the cursor currently is.
public Property | TimeDistance | The current TimeDistance (pixels between major time units) for the dbiScheduleObject which contains the ruler where the drag is occurring.
Top

See Also

Reference

RulerDragEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ScheduleClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleClickEventArgs Class

"

For a list of all members of this type, see ScheduleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | Button | The MouseButton that was used to click the schedule.
public Property | RulerClick | Indicates if the click occurred in the ruler area.
public Property | ScheduleObject | The dbiScheduleObject where the click occurred.
public Property | ScheduleX | The X-coordinate (relative to the dbiScheduleObject) where the click occurred
public Property | ScheduleY | The Y-coordinate (relative to the dbiScheduleObject) where the click occurred
public Property | X | The X-coordinate where the click occurred
public Property | Y | The Y-coordinate where the click occurred
Top

See Also

Reference

ScheduleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScheduleCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleCollection Class

Represents a collection of schedules.

Object Model

ScheduleCollection ClassdbiScheduleObject ClassdbiGuideLineCollection ClassdbiGuideLine Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
C#
public class ScheduleCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.ScheduleCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleCollection Class

"

The following tables list the members exposed by ScheduleCollection.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleCollection Constructor | Overloaded. Initializes a new instance of the ScheduleCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the schedule at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new schedule to the collection.
public Method | Clear | Clears all of the schedules from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified schedule in the collection.
public Method | Insert | Inserts a new schedule into dbiSchedule.
public Method | Remove | Removes a schedule from the collection.
public Method | RemoveAt | Removes a schedule at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets or sets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

ScheduleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

ScheduleCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleCollection Class

"

For a list of all members of this type, see ScheduleCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new schedule to the collection.
public Method | Clear | Clears all of the schedules from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified schedule in the collection.
public Method | Insert | Inserts a new schedule into dbiSchedule.
public Method | Remove | Removes a schedule from the collection.
public Method | RemoveAt | Removes a schedule at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets or sets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

ScheduleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ScheduleCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleCollection Class

"

For a list of all members of this type, see ScheduleCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the schedule at a specific location in the collection.
Top

See Also

Reference

ScheduleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScheduleCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : ScheduleCollection Constructor

Initializes a new instance of the ScheduleCollection class.

Overload List

Overload | Description
ScheduleCollection Constructor() | Initializes a new instance of the ScheduleCollection class.
ScheduleCollection Constructor(DbiListControl) | Initializes a new instance of the ScheduleCollection class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

ScheduleCollection Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class > ScheduleCollection Constructor : ScheduleCollection Constructor()

Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleCollection()
C#
public ScheduleCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members
Overload List


%%PageItemTitle%%

ScheduleCollection Constructor(DbiListControl)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class > ScheduleCollection Constructor : ScheduleCollection Constructor(DbiListControl)

objControl
The dbiListControl to add to the schedule.
Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objControl As DbiListControl

Dim instance As New ScheduleCollection(objControl)
C#
public ScheduleCollection(
   DbiListControl objControl
)

Parameters

objControl
The dbiListControl to add to the schedule.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members
Overload List


%%PageItemTitle%%

Add Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Add Method

obj
The dbiScheduleObject to add to dbiSchedule.
Adds a new schedule to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim obj As dbiScheduleObject
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to add to dbiSchedule.

Return Value

The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

'The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive 'The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke 'The background color for the even numbered items
newScheduleObj.AlternateItems = 2 'sets the frequency of the background colors
newScheduleObj.AlternateColor = True 'determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = Today.Now 'Sets the beginning of the schedule
newScheduleObj.End = Today.Now.AddDays(6) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Add(newScheduleObj) 'Adds the object to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

//The following will set the background colors for the items in the schedule area
newScheduleObj.AltColorOdd = System.Drawing.Color.Olive; //The background color for the odd numbered items
newScheduleObj.AltColorEven = System.Drawing.Color.WhiteSmoke; //The background color for the even numbered items
newScheduleObj.AlternateItems = 2; //sets the frequency of the background colors
newScheduleObj.AlternateColor = true; //determines if the AltColorOdd and AltColorEven are used

newScheduleObj.Start = System.DateTime.Today; //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(6); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Add(newScheduleObj); //Adds the object to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Clear Method

Clears all of the schedules from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection

instance.Clear()
C#
public void Clear()

Example

Visual Basic Copy Code
Me.dbiSchedule.Schedules.Clear()
C# Copy Code
this.dbiSchedule.Schedules.Clear();

Remarks

This method will delete all the items from the collection. To remove a single item, use Remove method or the RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the schedules in dbiSchedule.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : IndexOf Method

Returns the index of a specified schedule in the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified schedule in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

IndexOf(dbiScheduleObject) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : IndexOf(dbiScheduleObject) Method

obj
The dbiScheduleObject to locate in the collection.
Returns the index of a specified schedule in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim obj As dbiScheduleObject
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to locate in the collection.

Return Value

The zero-based index value of the schedule.

Example

Visual Basic Copy Code
Dim intScheduleIndex As Integer

intScheduleIndex = Me.dbiSchedule.Schedules.IndexOf(objSched)
C# Copy Code
int intScheduleIndex;

intScheduleIndex = this.dbiSchedule.Schedules.IndexOf(objSched);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Insert Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiScheduleObject to insert.
Inserts a new schedule into dbiSchedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim nIndex As System.Integer
Dim obj As dbiScheduleObject

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiScheduleObject obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiScheduleObject to insert.

Example

Visual Basic Copy Code
Dim newScheduleObj As New Dbi.WinControl.Schedule.dbiScheduleObject

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over 'Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray 'Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3 'Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal 'Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White 'Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2) 'Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3) 'Sets the end of the schedule

Me.DbiSchedule1.Schedules.Insert(1, newScheduleObj) 'Inserts the new schedule object into the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleObject newScheduleObj;
newScheduleObj = new Dbi.WinControl.Schedule.dbiScheduleObject();

newScheduleObj.RulerAlign = Dbi.WinControl.Schedule.dbiScheduleObject.enumRulerAlign.Over; //Sets the position of the ruler text
newScheduleObj.RulerBackColor = System.Drawing.Color.DimGray; //Sets the primary background color for the ruler
newScheduleObj.RulerBackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondary background color for the ruler
newScheduleObj.RulerDivisions = 3; //Sets the number of divisions to place between the major divisions.
newScheduleObj.RulerFillType = Dbi.enumFillType.Diagonal; //Sets the ruler fill style

newScheduleObj.BackColor = System.Drawing.Color.White; //Sets the background color of the schedule area
newScheduleObj.Start = System.DateTime.Today.AddDays(2); //Sets the beginning of the schedule
newScheduleObj.End = System.DateTime.Today.AddDays(3); //Sets the end of the schedule

this.dbiSchedule1.Schedules.Insert(1,newScheduleObj); //Inserts the object to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Item Property

nIndex
The zero-based index of the schedule to get or set in the collection.
Gets or sets the schedule at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim nIndex As System.Integer
Dim value As dbiScheduleObject

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiScheduleObject this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the schedule to get or set in the collection.

Property Value

The dbiScheduleObject object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : Remove Method

obj
The dbiScheduleObject to remove.
Removes a schedule from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim obj As dbiScheduleObject

instance.Remove(obj)
C#
public void Remove(
   dbiScheduleObject obj
)

Parameters

obj
The dbiScheduleObject to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Schedules.Remove(objSched)
C# Copy Code
this.dbiSchedule.Schedules.Remove(objSched);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : RemoveAt Method

index
The zero-based index of the schedule to remove.
Removes a schedule at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the schedule to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Example

Visual Basic Copy Code
Me.dbiSchedule.Schedules.RemoveAt(1)
C# Copy Code
this.dbiSchedule.Schedules.RemoveAt(1);

Remarks

If the index value provided in less that zero, or greater than the value in Count property of the ScheduleCollection an ArgumentExceptionOutOfRange will occur.

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members


%%PageItemTitle%%

WriteXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the XML file.
Writes the data in the collection to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the XML file.

Return Value

A Boolean value. If true, and method was successful.

Example

Visual Basic Copy Code
Me.dbiSchedule.Schedule(0).WriteXMLFile("C:\XMLSchedule.XML")
C# Copy Code
this.dbiSchedule.Schedules[0].WriteXMLFile("C:\\ScheduleXML.XML");

Remarks

If no extension is provided in the strFileName parameter, the default extension is .XML

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

XMLString Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleCollection Class : XMLString Method

Gets or sets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

A String value representing the data to read or write to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleCollection Class
ScheduleCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

ScheduleItemCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleItemCollection Class

Represents a collection of schedules items.

Object Model

ScheduleItemCollection ClassdbiScheduleItem ClassTimeBarItemCollection ClassdbiTimeBarItem ClassCellFormatCollection ClassdbiCellFormat ClassDbiListControl ClassdbiCustomAreaCollection ClassdbiCustomArea ClassdbiCellFormat ClassNodeItemCollection ClassdbiNodeItem ClassdbiNodeItem ClassdbiNodeItem ClassNodeItemCollection ClassdbiNodeItem ClassdbiScheduleNoteCollection ClassdbiScheduleNote ClassdbiNodeItem ClassdbiNodeItem ClassTimeBarItemCollection ClassdbiTimeBarItem Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
C#
public class ScheduleItemCollection : Dbi.WinControl.NodeItemCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.NodeItemCollection
Dbi.WinControl.Schedule.ScheduleItemCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

ScheduleItemCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleItemCollection Class

"

The following tables list the members exposed by ScheduleItemCollection.

"

Public Constructors

 | Name | Description
public Constructor | ScheduleItemCollection Constructor | Overloaded. Initializes a new instance of the ScheduleCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Control | Gets the control this collection is attached to. (Inherited from Dbi.WinControl.NodeItemCollection)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the schedule item at a specific location in the collection.
public Property | Parent | Gets the parent item that contains the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a schedule item to the collection.
public Method | AddRange | Add Multiple Items to the collection at once. (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | Clear | Clears all the items from the schedule.
public Method | CopyTo | Copies the contents of the collection to a one-dimensional Array (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Returns the index of a specified link in the collection.
public Method | Insert | Overloaded. Inserts a new item into the schedule.
public Method | Remove | Overloaded. Removes an item from the schedule.
public Method | RemoveAt | Removes a schedule item at a specific location in the collection.
public Method | Sort | Overloaded. Sorts the items within the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

ScheduleItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

ScheduleItemCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleItemCollection Class

"

For a list of all members of this type, see ScheduleItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds a schedule item to the collection.
public Method | AddRange | Add Multiple Items to the collection at once. (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | Clear | Clears all the items from the schedule.
public Method | CopyTo | Copies the contents of the collection to a one-dimensional Array (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Overloaded. Returns the index of a specified link in the collection.
public Method | Insert | Overloaded. Inserts a new item into the schedule.
public Method | Remove | Overloaded. Removes an item from the schedule.
public Method | RemoveAt | Removes a schedule item at a specific location in the collection.
public Method | Sort | Overloaded. Sorts the items within the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

ScheduleItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ScheduleItemCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleItemCollection Class

"

For a list of all members of this type, see ScheduleItemCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Control | Gets the control this collection is attached to. (Inherited from Dbi.WinControl.NodeItemCollection)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the schedule item at a specific location in the collection.
public Property | Parent | Gets the parent item that contains the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
Top

See Also

Reference

ScheduleItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

ScheduleItemCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : ScheduleItemCollection Constructor

Initializes a new instance of the ScheduleCollection class.

Overload List

Overload | Description
ScheduleItemCollection Constructor() | Initializes a new instance of the ScheduleCollection class.
ScheduleItemCollection Constructor(DbiListControl) | Initializes a new instance of the ScheduleCollection class.
ScheduleItemCollection Constructor(dbiScheduleItem) | Initializes a new instance of the ScheduleCollection class.
ScheduleItemCollection Constructor(DbiListControl,dbiScheduleItem) | Initializes a new instance of the ScheduleCollection class.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

ScheduleItemCollection Constructor()
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > ScheduleItemCollection Constructor : ScheduleItemCollection Constructor()

Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As New ScheduleItemCollection()
C#
public ScheduleItemCollection()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

ScheduleItemCollection Constructor(DbiListControl)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > ScheduleItemCollection Constructor : ScheduleItemCollection Constructor(DbiListControl)

objControl
A dbi.WinControl.dbiListControl object.
Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objControl As DbiListControl

Dim instance As New ScheduleItemCollection(objControl)
C#
public ScheduleItemCollection(
   DbiListControl objControl
)

Parameters

objControl
A dbi.WinControl.dbiListControl object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

ScheduleItemCollection Constructor(DbiListControl,dbiScheduleItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > ScheduleItemCollection Constructor : ScheduleItemCollection Constructor(DbiListControl,dbiScheduleItem)

objControl
A dbi.WinControl.dbiListControl object.
objParent
The parent dbiScheduleItem object of the objControl.
Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objControl As DbiListControl
Dim objParent As dbiScheduleItem

Dim instance As New ScheduleItemCollection(objControl, objParent)
C#
public ScheduleItemCollection(
   DbiListControl objControl,
   dbiScheduleItem objParent
)

Parameters

objControl
A dbi.WinControl.dbiListControl object.
objParent
The parent dbiScheduleItem object of the objControl.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

ScheduleItemCollection Constructor(dbiScheduleItem)
See Also
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > ScheduleItemCollection Constructor : ScheduleItemCollection Constructor(dbiScheduleItem)

objParent
The parent dbiScheduleItem object
Initializes a new instance of the ScheduleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objParent As dbiScheduleItem

Dim instance As New ScheduleItemCollection(objParent)
C#
public ScheduleItemCollection(
   dbiScheduleItem objParent
)

Parameters

objParent
The parent dbiScheduleItem object

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Add Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Add Method

Adds a schedule item to the collection.

Overload List

Overload | Description
Add(dbiScheduleItem) | Adds a schedule item to the collection.
Add(dbiNodeItem) | Adds a schedule item to the collection.
Add(String) | Creates and adds an item to the collection.
Add(String,Color) | Adds a new node item to the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
Add(String,Color,Color) | Adds a new node item to the collection. (Inherited from Dbi.WinControl.NodeItemCollection)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Add(dbiNodeItem) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Add Method : Add(dbiNodeItem) Method

objItem
The dbiNodeItem to add to the collection.
Adds a schedule item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim objItem As dbiNodeItem
Dim value As System.Integer

value = instance.Add(objItem)
C#
public new System.int Add(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to add to the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Add(dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Add Method : Add(dbiScheduleItem) Method

obj
The dbiScheduleItem to add.
Adds a schedule item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim obj As dbiScheduleItem
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiScheduleItem obj
)

Parameters

obj
The dbiScheduleItem to add.

Return Value

The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
Dim newScheduleItem As New Dbi.WinControl.Schedule.dbiScheduleItem

newScheduleItem.BackColor = System.Drawing.Color.Olive 'Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite 'Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid 'Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black 'sets the forecolor of the item

newScheduleItem.Text = "Item 1" 'Sets the text of the item

Me.DbiSchedule1.Items.Add(newScheduleItem)
C# Copy Code
Dbi.WinControl.Schedule.dbiScheduleItem newScheduleItem;

newScheduleItem = new Dbi.WinControl.Schedule.dbiScheduleItem();

newScheduleItem.BackColor = System.Drawing.Color.Olive; //Sets the background color of the item
newScheduleItem.BackColorTo = System.Drawing.Color.GhostWhite; //Sets the secondary background color of the item
newScheduleItem.FillType = Dbi.enumFillType.Pyramid; //Sets the fill pattern of the item
newScheduleItem.ForeColor = System.Drawing.Color.Black; //sets the forecolor of the item

newScheduleItem.Text = "Item 1"; //Sets the text of the item

this.dbiSchedule1.Items.Add(newScheduleItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Add(String) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Add Method : Add(String) Method

strText
The text for the new item.
Creates and adds an item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim strText As System.String
Dim value As System.Integer

value = instance.Add(strText)
C#
public new System.int Add(
   System.string strText
)

Parameters

strText
The text for the new item.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Color) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Add Method : Add(String,Color) Method

strText
The text of the new node.
colorFore
The fore color of the new node.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim strText As System.String
Dim colorFore As System.Drawing.Color
Dim value As System.Integer

value = instance.Add(strText, colorFore)
C#
public System.int Add(
   System.string strText,
   System.Drawing.Color colorFore
)

Parameters

strText
The text of the new node.
colorFore
The fore color of the new node.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Add(String,Color,Color) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Add Method : Add(String,Color,Color) Method

strText
The text of the new node.
colorFore
The fore color of the new node.
colorBack
The back color of the new node.
Adds a new node item to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim strText As System.String
Dim colorFore As System.Drawing.Color
Dim colorBack As System.Drawing.Color
Dim value As System.Integer

value = instance.Add(strText, colorFore, colorBack)
C#
public System.int Add(
   System.string strText,
   System.Drawing.Color colorFore,
   System.Drawing.Color colorBack
)

Parameters

strText
The text of the new node.
colorFore
The fore color of the new node.
colorBack
The back color of the new node.

Return Value

The zero-based index value of the new node.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

AddRange Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : AddRange Method

arrayItems
An array of dbiNodeitem objects.
Add Multiple Items to the collection at once.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim arrayItems() As dbiNodeItem

instance.AddRange(arrayItems)
C#
public void AddRange(
   dbiNodeItem[] arrayItems
)

Parameters

arrayItems
An array of dbiNodeitem objects.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Clear Method

Clears all the items from the schedule.

Overload List

Overload | Description
Clear | Clears all the items from the schedule.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.Clear()
C# Copy Code
this.dbiSchedule.Clear();

Remarks

This method will delete all the items from the collection. To remove a single item, use Remove method or the RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Clear() Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Clear() Method

Clears all the items from the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection

instance.Clear()
C#
public new void Clear()

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Control Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Control Property

Gets the control this collection is attached to.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As DbiListControl

instance.Control = value

value = instance.Control
C#
public DbiListControl Control {get; set;}

Property Value

A dbi.WinControl.dbiListControl/dbiSchedule object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

CopyTo Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : CopyTo Method

arrayDestination
The one-dimensional Array that is the destination of the items. The Array must have zero-based indexing.
nIndex
The zero-based index in the Array at which copying begins.
Copies the contents of the collection to a one-dimensional Array

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim arrayDestination As System.Array
Dim nIndex As System.Integer

instance.CopyTo(arrayDestination, nIndex)
C#
public void CopyTo(
   System.Array arrayDestination,
   System.int nIndex
)

Parameters

arrayDestination
The one-dimensional Array that is the destination of the items. The Array must have zero-based indexing.
nIndex
The zero-based index in the Array at which copying begins.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Count Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Count Property

Gets the number of items in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : IndexOf Method

Returns the index of a specified link in the collection.

Overload List

Overload | Description
IndexOf(dbiScheduleItem) | Returns the index of a specified item in the collection.
IndexOf(dbiNodeItem) | Returns the index of a specified item in the collection. (Inherited from Dbi.WinControl.NodeItemCollection)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

IndexOf(dbiNodeItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > IndexOf Method : IndexOf(dbiNodeItem) Method

obj
The dbi.WinControl.dbiNodeItem to locate in the collection.
Returns the index of a specified item in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim obj As dbiNodeItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiNodeItem obj
)

Parameters

obj
The dbi.WinControl.dbiNodeItem to locate in the collection.

Return Value

The zero-based index value of the node item.

Example

Visual Basic Copy Code
Dim intItemIndex As Integer

intItemIndex = Me.dbiSchedule.Items.IndexOf(objItem);
C# Copy Code
int intItemIndex;

intItemIndex = this.dbiSchedule.Item.IndexOf(objItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

IndexOf(dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > IndexOf Method : IndexOf(dbiScheduleItem) Method

obj
The dbiScheduleItem to locate in the collection.
Returns the index of a specified item in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim obj As dbiScheduleItem
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiScheduleItem obj
)

Parameters

obj
The dbiScheduleItem to locate in the collection.

Return Value

The zero-based index value of the schedule item.

Example

Visual Basic Copy Code
Dim intItemIndex As Integer

intItemIndex = Me.dbiSchedule.Items.IndexOf(objItem);
C# Copy Code
int intItemIndex;

intItemIndex = this.dbiSchedule.Item.IndexOf(objItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Insert Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Insert Method

Inserts a new item into the schedule.

Overload List

Overload | Description
Insert(Int32,dbiScheduleItem) | Inserts a new item into the schedule.
Insert(Int32,dbiNodeItem) | Inserts a new item into the schedule. (Inherited from Dbi.WinControl.NodeItemCollection)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Insert(Int32,dbiNodeItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Insert Method : Insert(Int32,dbiNodeItem) Method

nIndex
The zero-based index location where the item is inserted.
objItem
The dbi.WinControl.dbiNodeItem to insert into the collection.
Inserts a new item into the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim nIndex As System.Integer
Dim objItem As dbiNodeItem

instance.Insert(nIndex, objItem)
C#
public void Insert(
   System.int nIndex,
   dbiNodeItem objItem
)

Parameters

nIndex
The zero-based index location where the item is inserted.
objItem
The dbi.WinControl.dbiNodeItem to insert into the collection.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.Insert(0, objItem)
C# Copy Code
this.dbiSchedule.Items.Insert(0, objItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Insert(Int32,dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Insert Method : Insert(Int32,dbiScheduleItem) Method

nIndex
The zero-based index location where the item is inserted.
obj
The dbiScheduleItem to insert into the collection.
Inserts a new item into the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim nIndex As System.Integer
Dim obj As dbiScheduleItem

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiScheduleItem obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
The dbiScheduleItem to insert into the collection.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.Insert(0, objItem)
C# Copy Code
this.dbiSchedule.Items.Insert(0, objItem);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Item Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Item Property

nIndex
The zero-based index of the schedule item to get or set in the collection.
Gets or sets the schedule item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim nIndex As System.Integer
Dim value As dbiScheduleItem

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public new dbiScheduleItem this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The zero-based index of the schedule item to get or set in the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Parent Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Parent Property

Gets the parent item that contains the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As dbiNodeItem

instance.Parent = value

value = instance.Parent
C#
public dbiNodeItem Parent {get; set;}

Property Value

A dbi.WinControl.dbiNodeItem object.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Remove Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Remove Method

Removes an item from the schedule.

Overload List

Overload | Description
Remove(dbiScheduleItem) | Removes an item from the schedule.
Remove(dbiNodeItem) | Removes an item from the schedule. (Inherited from Dbi.WinControl.NodeItemCollection)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Remove(dbiNodeItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Remove Method : Remove(dbiNodeItem) Method

objItem
The dbiNodeItem to remove.
Removes an item from the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim objItem As dbiNodeItem

instance.Remove(objItem)
C#
public void Remove(
   dbiNodeItem objItem
)

Parameters

objItem
The dbiNodeItem to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.Remove(objNodeItem)
C# Copy Code
this.dbiSchedule.Items.Remove(objNodeItem);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Remove(dbiScheduleItem) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Remove Method : Remove(dbiScheduleItem) Method

obj
The dbiScheduleItem to remove.
Removes an item from the schedule.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim obj As dbiScheduleItem

instance.Remove(obj)
C#
public void Remove(
   dbiScheduleItem obj
)

Parameters

obj
The dbiScheduleItem to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.Remove(objItem)
C# Copy Code
this.dbiSchedule.Items.Remove(objItem);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : RemoveAt Method

nIndex
The zero-based index of the item to remove.
Removes a schedule item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim nIndex As System.Integer

instance.RemoveAt(nIndex)
C#
public new void RemoveAt(
   System.int nIndex
)

Parameters

nIndex
The zero-based index of the item to remove.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.RemoveAt(0)
C# Copy Code
this.dbiSchedule.Items.RemoveAt(0);

Remarks

If the index value provided in less that zero, or greater than the value in Count property of the TimebarItemCollection an ArgumentExceptionOutOfRange will occur.

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Sort Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : Sort Method

Sorts the items within the collection.

Overload List

Overload | Description
Sort(Int32[],Boolean,Boolean) | Sorts the items within the collection. (Inherited from Dbi.WinControl.NodeItemCollection)
Sort(Int32[],Boolean,Boolean,Int32) | Sorts the items within the collection. (Inherited from Dbi.WinControl.NodeItemCollection)

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members


%%PageItemTitle%%

Sort(Int32[],Boolean,Boolean) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Sort Method : Sort(Int32[],Boolean,Boolean) Method

arrSortColumns
An array of column indexes to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
Sorts the items within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim arrSortColumns() As System.Integer
Dim bSortAsc As System.Boolean
Dim bIgnoreCase As System.Boolean

instance.Sort(arrSortColumns, bSortAsc, bIgnoreCase)
C#
public void Sort(
   System.int[] arrSortColumns,
   System.bool bSortAsc,
   System.bool bIgnoreCase
)

Parameters

arrSortColumns
An array of column indexes to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

Sort(Int32[],Boolean,Boolean,Int32) Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class > Sort Method : Sort(Int32[],Boolean,Boolean,Int32) Method

arrSortColumns
An array of column indexes to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
nLevels
The level in the parent/child structure to begin the sort operation at (0 indicates the top most level).
Sorts the items within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim arrSortColumns() As System.Integer
Dim bSortAsc As System.Boolean
Dim bIgnoreCase As System.Boolean
Dim nLevels As System.Integer

instance.Sort(arrSortColumns, bSortAsc, bIgnoreCase, nLevels)
C#
public void Sort(
   System.int[] arrSortColumns,
   System.bool bSortAsc,
   System.bool bIgnoreCase,
   System.int nLevels
)

Parameters

arrSortColumns
An array of column indexes to perform the sort against.
bSortAsc
Determines if the sort will be ascending.
bIgnoreCase
Determines if the sort will be case sensitive.
nLevels
The level in the parent/child structure to begin the sort operation at (0 indicates the top most level).

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Overload List


%%PageItemTitle%%

WriteXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the XML file.
Writes the data in the collection to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public new System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the XML file.

Return Value

A Boolean value. If true, and method was successful.

Example

Visual Basic Copy Code
Me.dbiSchedule.Items.WriteXML("C:\ScheduleItems.XML")
C# Copy Code
this.dbiSchedule.Items.WriteXML("C:\\ScheduleItems.XML");

Remarks

If no extension is provided in the strFileName parameter, the default extension is .XML

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

XMLString Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > ScheduleItemCollection Class : XMLString Method

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As ScheduleItemCollection
Dim value As System.String

value = instance.XMLString()
C#
public new System.string XMLString()

Return Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = Me.dbiSchedule.Items.XMLString()
C# Copy Code
string strXML;
strXML = Me.dbiSchedule.Items.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

ScheduleItemCollection Class
ScheduleItemCollection Members
Reading and Writing XML Data


%%PageItemTitle%% $$Properties$$

ScheduleScrollBarsOffsetAreaEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScheduleScrollBarsOffsetAreaEventArgs Class

"

For a list of all members of this type, see ScheduleScrollBarsOffsetAreaEventArgs members.

"

Public Properties

 | Name | Description
public Property | Area | Determines the available area based on the current scroll bar offset.
public Property | Length | Determines the total width/height of the scroll bar area
public Property | ScrollBar | Determines which scroll bar area is raising the event.
Top

See Also

Reference

ScheduleScrollBarsOffsetAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ScrollBufferResizeArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollBufferResizeArgs Class

"

For a list of all members of this type, see ScrollBufferResizeArgs members.

"

Public Properties

 | Name | Description
public Property | HorzBufferVisible | Determines if the Horizontal Buffer is visible after a resize.
public Property | HorzScrollRight | Gets the current rightmost position of the Horizontal Scroll Bar for determining the position of any controls placed in the buffer zone.
Top

See Also

Reference

ScrollBufferResizeArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ScrollTrackEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ScrollTrackEventArgs Class

"

For a list of all members of this type, see ScrollTrackEventArgs members.

"

Public Properties

 | Name | Description
public Property | ScrollBar | An integer value representing the scrollbar that has been moved.
public Property | Value | An integer value used to calculate the scroll bar position.
Top

See Also

Reference

ScrollTrackEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarClickEventArgs Class

"

For a list of all members of this type, see TimeBarClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | Button | The MouseButton being clicked.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being clicked.
public Property | TimeBarItem | The dbiTimebarItem being clicked.
public Property | X | The x-Coordinate when the TimeBar was clicked
public Property | Y | The y-Coordinate when the TimeBar was clicked
Top

See Also

Reference

TimeBarClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarDateTextEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDateTextEventArgs Class

"

For a list of all members of this type, see TimeBarDateTextEventArgs members.

"

Public Properties

 | Name | Description
public Property | DateTime | The DateTime value of the edge of the TimeBar being drawn.
public Property | ForeColor | The color used to paint the text at the edge of the TimeBar.
public Property | IsStart | Determines if the current DateTime is for the start or end of the timebar.
public Property | ScheduleObject | The dbiScheduleOject where the TimeBar is being drawn.
public Property | Text | The text string to be drawn at the edge of the timebar.
public Property | TimeBarItem | The dbiTimeBarITem being drawn.
Top

See Also

Reference

TimeBarDateTextEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarDoubleClickEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarDoubleClickEventArgs Class

"

For a list of all members of this type, see TimeBarDoubleClickEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being double clicked.
public Property | TimeBarItem | The dbiTimebarItem being double clicked.
Top

See Also

Reference

TimeBarDoubleClickEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

TimeBarItemCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarItemCollection Class

"

For a list of all members of this type, see TimeBarItemCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new schedule to the collection.
public Method | Clear | Clears all of the Timebars from the collection. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified Timebar in the collection.
public Method | Insert | Inserts a new Timebar into the collection.
public Method | Remove | Removes a Timebar from the collection.
public Method | RemoveAt | Removes a Timebar at a specific location in the collection. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

TimeBarItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarItemCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarItemCollection Class

"

For a list of all members of this type, see TimeBarItemCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of items in the collection. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the Timebar at a specific location in the collection.
Top

See Also

Reference

TimeBarItemCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

IndexOf Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarItemCollection Class : IndexOf Method

Returns the index of a specified schedule in the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified Timebar in the collection.

Example

Visual Basic Copy Code
Dim intTimebarIndex As Integer
intTimebarIndex = Me.dbiSchedule.Items(0).Timebars.IndexOf(objTimebar)
C# Copy Code
int intTimebarIndex;
intTimebarIndex = this.dbiSchedule.Items[0].Timebars.IndexOf(objTimebar);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarItemCollection Class
TimeBarItemCollection Members


%%PageItemTitle%% $$Properties$$

TimeBarMouseEnterEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseEnterEventArgs Class

"

For a list of all members of this type, see TimeBarMouseEnterEventArgs members.

"

Public Properties

 | Name | Description
public Property | TimeBarItem | The dbiTimeBarItem the mouse has moved into.
Top

See Also

Reference

TimeBarMouseEnterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarMouseLeaveEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMouseLeaveEventArgs Class

"

For a list of all members of this type, see TimeBarMouseLeaveEventArgs members.

"

Public Properties

 | Name | Description
public Property | TimeBarItem | The dbiTimeBarItem the mouse has moved from.
Top

See Also

Reference

TimeBarMouseLeaveEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarMovingEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarMovingEventArgs Class

"

For a list of all members of this type, see TimeBarMovingEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index of the dbiTimeBarItem being moved.
public Property | End | The new End DateTime value for the dbiTimeBarItem
public Property | ScheduleItem | The dbiScheduleItem where the dbiTimeBarItem is currently being moved.
public Property | Start | The new Start DateTime value for the dbiTimeBarItem.
public Property | TimeBarItem | The dbiTimeBarItem being moved.
Top

See Also

Reference

TimeBarMovingEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarSizingEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarSizingEventArgs Class

"

For a list of all members of this type, see TimeBarSizingEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The zero-based index value of the Timebar.
public Property | End | The ending date time value of the Timebar.
public Property | ScheduleItem | The dbiScheduleItem containing the Timebar being sized.
public Property | Start | The starting date time value of the Timebar.
public Property | TimeBarItem | The dbiTimebarItem being sized.
Top

See Also

Reference

TimeBarSizingEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarStyleCollection Class
See Also Members
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarStyleCollection Class

Represents a collections of Timebar styles.

Object Model

TimeBarStyleCollection ClassdbiTimeBarStyle Class

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
C#
public class TimeBarStyleCollection : Dbi.CollectionBaseEvents

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Dbi.WinControl.Schedule.TimeBarStyleCollection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Members
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Members$$

TimeBarStyleCollection Class Members
See Also Properties Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarStyleCollection Class

"

The following tables list the members exposed by TimeBarStyleCollection.

"

Public Constructors

 | Name | Description
public Constructor | TimeBarStyleCollection Constructor | Initializes a new instance of the TimebarStyleCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

Public Methods

 | Name | Description
public Method | Add | Adds a new Timebar style to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified Timebar style within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

TimeBarStyleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Methods$$

TimeBarStyleCollection Class Methods
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarStyleCollection Class

"

For a list of all members of this type, see TimeBarStyleCollection members.

"

Public Methods

 | Name | Description
public Method | Add | Adds a new Timebar style to the collection.
public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
public Method | IndexOf | Returns the index of a specified Timebar style within the collection.
public Method | Insert | Inserts an item at a specific location in the collection.
public Method | Remove | Removes a specific item from the collection.
public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
public Method | WriteXMLFile | Writes the data in the collection to an XML file.
public Method | XMLString | Gets an XML string to read the data from or write the data to the collection.
Top

See Also

Reference

TimeBarStyleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

TimeBarStyleCollection Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : TimeBarStyleCollection Class

"

For a list of all members of this type, see TimeBarStyleCollection members.

"

Public Properties

 | Name | Description
public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
public Property | Item | Gets or sets the item at a specific location in the collection.
Top

See Also

Reference

TimeBarStyleCollection Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%%

TimeBarStyleCollection Constructor
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : TimeBarStyleCollection Constructor

objOwner
The dbiSchedule control that will contain the collection
Initializes a new instance of the TimebarStyleCollection class.

Syntax

Visual Basic (Usage) Copy Code
Dim objOwner As dbiSchedule

Dim instance As New TimeBarStyleCollection(objOwner)
C#
public TimeBarStyleCollection(
   dbiSchedule objOwner
)

Parameters

objOwner
The dbiSchedule control that will contain the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Add Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Add Method

obj
A dbiTimebarStyle to add to the collection.
Adds a new Timebar style to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim obj As dbiTimeBarStyle
Dim value As System.Integer

value = instance.Add(obj)
C#
public System.int Add(
   dbiTimeBarStyle obj
)

Parameters

obj
A dbiTimebarStyle to add to the collection.

Return Value

The zero-based index of the item in the collection.

Example

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.BackColor = System.Drawing.Color.Olive 'Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke 'Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal 'Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black 'Sets the fore color
newStyle.Font = New Font("Verdana", 8, FontStyle.Italic) 'Sets the font
newStyle.BarHeight = 20 'Sets the bar height

Me.DbiSchedule1.TimebarStyles.Add(newStyle) 'Add the style to the collection
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;
newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.BackColor = System.Drawing.Color.Olive; //Sets the primary background color
newStyle.BackColorTo = System.Drawing.Color.WhiteSmoke; //Sets the secondardary background color
newStyle.FillType = Dbi.enumFillType.Diagonal; //Sets the fill pattern
newStyle.ForeColor = System.Drawing.Color.Black ; //Sets the fore color
newStyle.Font = new Font("Verdana", 8, FontStyle.Italic); //Sets the font
newStyle.BarHeight = 20; //Sets the bar height

this.dbiSchedule1.TimebarStyles.Add(newStyle); //Add the style to the collection

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Capacity Property
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Capacity Property

Gets or sets the number of elements that the System.Collections.CollectionBase can contain.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
public System.int Capacity {get; set;}

Property Value

The number of elements that the System.Collections.CollectionBase can contain.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | System.Collections.CollectionBase.Capacity is set to a value that is less than System.Collections.CollectionBase.Count.
System.OutOfMemoryException | There is not enough memory available on the system.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Clear Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Clear Method

Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection

instance.Clear()
C#
public void Clear()

Example

Visual Basic Copy Code
Me.dbiSchedule.TimebarStyles.Clear
C# Copy Code
this.dbiSchedule.TimebarStyles.Clear();

Remarks

This method will delete all the items from the collection. To remove a single item, use the Remove or RemoveAt method.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Count Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Count Property

Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}

Property Value

An Integer value, indicating the number of Timebar styles in dbiSchedule.The number of elements contained in the System.Collections.CollectionBase instance.Retrieving the value of this property is an O(1) operation.

Example

Visual Basic Copy Code
intTimebarTotal = Me.dbiSchedule.TimebarStyles.Count
C# Copy Code
intTimebarTotal = this.dbiSchedule.TimebarStyles.Count;

Remarks

This property is read-only and can only be obtained at runtime.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

GetEnumerator Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : GetEnumerator Method

Returns an enumerator that iterates through the System.Collections.CollectionBase instance.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
public System.Collections.IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator for the System.Collections.CollectionBase instance.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

IndexOf Method
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : IndexOf Method

Returns the index of a specified Timebar style within the collection.

Overload List

Overload | Description
IndexOf | Returns the index of a specified Timebar style within the collection.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

IndexOf(dbiTimeBarStyle) Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : IndexOf(dbiTimeBarStyle) Method

obj
A dbiTimebarStyle to locate in the collection.
Returns the index of a specified Timebar style within the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim obj As dbiTimeBarStyle
Dim value As System.Integer

value = instance.IndexOf(obj)
C#
public System.int IndexOf(
   dbiTimeBarStyle obj
)

Parameters

obj
A dbiTimebarStyle to locate in the collection.

Return Value

An Integer value representing the index of a specific item in the collection.

Example

Visual Basic Copy Code
intStyle = Me.dbiSchedule.TimebarStyles.IndexOf(objStyle)
C# Copy Code
intStyle = this.dbiSchedule.TimebarStyles.IndexOf(objStyle);

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Insert Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Insert Method

nIndex
The zero-based index location where the item is inserted.
obj
A dbiTimebarStyle to add to the collection.
Inserts an item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim nIndex As System.Integer
Dim obj As dbiTimeBarStyle

instance.Insert(nIndex, obj)
C#
public void Insert(
   System.int nIndex,
   dbiTimeBarStyle obj
)

Parameters

nIndex
The zero-based index location where the item is inserted.
obj
A dbiTimebarStyle to add to the collection.

Example

Visual Basic Copy Code
Dim newStyle As New Dbi.WinControl.Schedule.dbiTimebarStyle

newStyle.StartImage = -10 'Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = New Point(1, -2) 'Sets the vertical and horizontal offsets values
'sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front

newStyle.EndImage = 2 'Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = New Point(10, 0) 'Sets the vertical and horizontal offsets values
'sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen 'Sets the border color

Me.DbiSchedule1.TimebarStyles.Insert(0, newStyle) 'Inserts the style into the first position
C# Copy Code
Dbi.WinControl.Schedule.dbiTimebarStyle newStyle;

newStyle = new Dbi.WinControl.Schedule.dbiTimebarStyle();

newStyle.StartImage = -10; //Sets the StartImage to the 10th image in the stock images
newStyle.StartImageOffset = new Point(1, -2); //Sets the vertical and horizontal offsets values
//sets the image to appear in front of the Timebar
newStyle.StartImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Front;

newStyle.EndImage = 2; //Sets the EndImage to the 2 image in the imagelist
newStyle.EndImageOffset = new Point(10, 0); //Sets the vertical and horizontal offsets values
//sets the image to appear behind the Timebar
newStyle.EndImageOrder = Dbi.WinControl.Schedule.dbiTimebarStyle.enumImageOrder.Back;

newStyle.BorderColor = System.Drawing.Color.DarkSeaGreen; //Sets the border color

this.dbiSchedule1.TimebarStyles.Insert(0, newStyle); //Inserts the style into the first position

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Item Property
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Item Property

nIndex
The index of the item to get or set in the collection.
Gets or sets the item at a specific location in the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim nIndex As System.Integer
Dim value As dbiTimeBarStyle

instance.Item(nIndex) = value

value = instance.Item(nIndex)
C#
public dbiTimeBarStyle this[
   System.int nIndex
]; {get; set;}

Parameters

nIndex
The index of the item to get or set in the collection.

Property Value

The dbiTimebarStyle item.

Example

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles(0).BackColor = System.Drawing.Color.Red
C# Copy Code
Me.dbiSchedule1.TimebarStyles[0].BackColor = System.Drawing.Color.Red;

Remarks

If the index value provided in less than zero, or greater than the value in dbiTimebarCollection.Count property an ArgumentExceptionOutOfRange error will occur.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

Remove Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : Remove Method

obj
A dbiTimebarStyle to remove from the collection.
Removes a specific item from the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim obj As dbiTimeBarStyle

instance.Remove(obj)
C#
public void Remove(
   dbiTimeBarStyle obj
)

Parameters

obj
A dbiTimebarStyle to remove from the collection.

Example

The following will remove the first item in the collection
Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles.Remove(Me.dbiSchedule1.TimebarStyles(0))
C# Copy Code
this.dbiSchedule1.TimebarStyles.Remove(this.dbiSchedule1.TimebarStyles[0]);

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

RemoveAt Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : RemoveAt Method

index
The zero-based index of the item to remove.
Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
public void RemoveAt(
   System.int index
)

Parameters

index
The zero-based index of the item to remove.

Exceptions

Exception | Description
System.ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than System.Collections.CollectionBase.Count.

Example

The following will remove the second item in the collection.
Visual Basic Copy Code
Me.dbiSchedule.TimebarStyles.RemoveAt(1)
C# Copy Code
this.dbiSchedule.TimebarStyles.RemoveAt[1];

Remarks

When an item is removed from the collection, the index value for the subsequent items change. All the information about the removed item is deleted.

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members


%%PageItemTitle%%

WriteXMLFile Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : WriteXMLFile Method

strFileName
The full path and file name of the XML file.
Writes the data in the collection to an XML file.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim strFileName As System.String
Dim value As System.Boolean

value = instance.WriteXMLFile(strFileName)
C#
public System.bool WriteXMLFile(
   System.string strFileName
)

Parameters

strFileName
The full path and file name of the XML file.

Return Value

A Boolean value. If true, and method was successful.

Example

Visual Basic Copy Code
Me.dbiSchedule1.TimebarStyles.WriteXMLFile("C:\XMLTimebars.XML")
C# Copy Code
this.dbiSchedule1.TimebarStyles.WriteXMLFile("C:\\XMLTimebars.XML");

Remarks

If no extension is provided in the strFileName parameter, the default extension is .XML

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members
Reading and Writing XML Data


%%PageItemTitle%%

XMLString Method
See Also Example
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace > TimeBarStyleCollection Class : XMLString Method

Gets an XML string to read the data from or write the data to the collection.

Syntax

Visual Basic (Usage) Copy Code
Dim instance As TimeBarStyleCollection
Dim value As System.String

value = instance.XMLString()
C#
public System.string XMLString()

Return Value

A String value.

Example

Visual Basic Copy Code
Dim strXML As String
strXML = Me.dbiSchedule.TimebarStyles.XMLString()
C# Copy Code
string strXML;
strXML = Me.dbiSchedule.TimebarStyles.XMLString();

Requirements

Target Platforms: Windows Server 2008/2012 family, Windows 7, Windows 8, Windows 10

See Also

Reference

TimeBarStyleCollection Class
TimeBarStyleCollection Members
Reading and Writing XML Data


%%PageItemTitle%% $$Properties$$

UndoActionEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UndoActionEventArgs Class

"

For a list of all members of this type, see UndoActionEventArgs members.

"

Public Properties

 | Name | Description
public Property | HistoryItem | Gets the history item for the UndoActionEvent.
Top

See Also

Reference

UndoActionEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnBarAfterEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarAfterEventArgs Class

"

For a list of all members of this type, see UserDrawnBarAfterEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
public Property | Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
public Property | ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
public Property | TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.
Top

See Also

Reference

UserDrawnBarAfterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnBarEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnBarEventArgs Class

"

For a list of all members of this type, see UserDrawnBarEventArgs members.

"

Public Properties

 | Name | Description
public Property | BarIndex | The index value to reference the Time Bar in the associated dbiScheduleItem’s TimeBars collection.
public Property | Graphics | A graphics handle to the custom area provided to the developer within the dbiScheduleItem being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | MapArea | Reports True if UserDrawnBar event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnBar event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | PaintBar | Indicates to the control if the internal PaintBar routine is to be used to paint the Time Bar. When the e.PaintBar property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar.
public Property | PaintText | Indicates to the control if the internal PaintText routine is to be used to paint the Time Bar Text. When the e.PaintText property is set to False the control does not execute its internal paint routine and the developer has control over the painting of the Time Bar Text.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnBar event the e.Rect object represents the Time Bar area to be painted in Schedule Area or the Map Area of the control, depending upon the value of the e.MapArea property.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem to which the Time Bar being painted belongs..
public Property | ScheduleObject | This property provides a handle back to the dbiScheduleObject being painted in the schedule area or map area of the control.
public Property | TimeBarItem | This property provides a handle back to the dbiTimeBarItem being rendered in the control.
Top

See Also

Reference

UserDrawnBarEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnCustomAreaEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnCustomAreaEventArgs Class

"

For a list of all members of this type, see UserDrawnCustomAreaEventArgs members.

"

Public Properties

 | Name | Description
public Property | CustomArea | The dbiCustomArea being drawn.
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | MapArea | Determines if the custom area is currently being drawn in the map area.
public Property | PaintArea | Indicates to the control if the custom area should be drawn with the standard routines.
public Property | Rect | The rectangle representing the size and location of the custom area.
public Property | ScheduleItem | The dbiScheduleItem where the dbiCustomArea is being drawn.
public Property | ScheduleObject | The dbiScheduleObject where the dbiCustomArea is being drawn.
Top

See Also

Reference

UserDrawnCustomAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnFooterEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnFooterEventArgs Class

"

For a list of all members of this type, see UserDrawnFooterEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the footer area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
public Property | ListArea | Reports True if the UserDrawnFooter event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnFooter event is being fired when the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnFooter event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnFooter Event fires once for each area in the footer to be painted; the list, and each ScheduleObject visible in the schedule area of the control.
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.
Top

See Also

Reference

UserDrawnFooterEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnHeaderEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnHeaderEventArgs Class

"

For a list of all members of this type, see UserDrawnHeaderEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the header area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area of the control.
public Property | ListArea | Reports True if UserDrawnHeader event is being fired when the list area of the control is being drawn. This argument reports False when the UserDrawnHeader event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (List or Schedule) of the control is being drawn.
public Property | Rect | A rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnHeader event the e.Rect object represents the list area to be drawn when the e.ListArea property is True (i.e. the control is painting the list area), or the schedule area to be painted specific to the ScheduleObject being painted when the e.ListArea property is False. It is important to note that the UserDrawnHeader Event fires once for each area in the header to be painted; the List, and each ScheduleObject visible in the schedule area of the control
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area of the control.
Top

See Also

Reference

UserDrawnHeaderEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnLineEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLineEventArgs Class

"

For a list of all members of this type, see UserDrawnLineEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A graphics handle to the custom area provided to the developer within the schedule area being drawn. Through the e.Graphics object the developer has access to the GDI+ methods for drawing objects to a display device.
public Property | LineStart | This property indicates the start DateTime value of the ScheduleObject being painted in the schedule area or map area of the control.
public Property | MapArea | Reports True if UserDrawnLine event is being fired when the map area of the control is being drawn. This argument reports False when the UserDrawnLine event is being fired as the Schedule area of the control is being drawn. This allows the developer to determine which general area (Map Area or Schedule) of the control is being drawn.
public Property | Rect | rectangle representing the custom area being painted in the control. The rectangle is defined by an X,Y coordinate (top left of rectangle) and a width and height of the area being painted. All values are in pixels. In the UserDrawnLine event the e.Rect object represents the item area to be drawn in schedule area specific to the ScheduleObject being drawn when the e.MapArea property is False (i.e. the control is painting the schedule area of the control), or the item area within the map area to be painted specific to the ScheduleOjbect being painted.
public Property | ScheduleItem | This property provides a handle back to the dbiScheduleItem being painted. The developer can read or interract with the properties of the item such as its text, backcolor, etc. within the UserDrawnLine event.
public Property | ScheduleObject | This property provides a handle back to the ScheduleObject being painted in the schedule area or map area of the control.
Top

See Also

Reference

UserDrawnLineEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnLinkLineEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnLinkLineEventArgs Class

"

For a list of all members of this type, see UserDrawnLinkLineEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | The Graphics object where the dbiLinkItem will be drawn.
public Property | LinkItem | The dbiLinkItem being drawn.
public Property | PaintLinkLine | Determines if the control should draw the dbiLinkItem with the default appearance.
public Property | PointFrom | The starting coordinate of the dbiLinkItem in the display.
public Property | PointTo | The ending coordinate of the dbiLinkItem in the display.
public Property | Printing | Determines if the event is being raised by the printing routines.
public Property | ScheduleItemFrom | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem begins.
public Property | ScheduleItemTo | The dbiScheduleItem containing the dbiTimeBarItem where the dbiLinkItem ends.
public Property | ScheduleObject | The dbiScheduleObject where the dbiLinkItem is being rendered.
public Property | TimeBarFrom | The dbiTimeBarItem where the dbiLinkItem begins.
public Property | TimeBarTo | The dbiTimeBarItem where the dbiLinkItem ends.
Top

See Also

Reference

UserDrawnLinkLineEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnListScrollAreaEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnListScrollAreaEventArgs Class

"

For a list of all members of this type, see UserDrawnListScrollAreaEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | Rect | The rectangle representing the size and location of the scroll bar area.
Top

See Also

Reference

UserDrawnListScrollAreaEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnRulerEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerEventArgs Class

"

For a list of all members of this type, see UserDrawnRulerEventArgs members.

"

Public Properties

 | Name | Description
public Property | End | The End value of the visible portion of the ruler.
public Property | FirstDraw | Determines if the event is firing before painting the background of the ruler.
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | Rect | The rectangle representing the size and location of the ruler.
public Property | ScheduleObject | The dbiScheduleObject whose ruler is being drawn.
public Property | Start | The End value of the visible portion of the ruler.
Top

See Also

Reference

UserDrawnRulerEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnRulerSegmentEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerSegmentEventArgs Class

"

For a list of all members of this type, see UserDrawnRulerSegmentEventArgs members.

"

Public Properties

 | Name | Description
public Property | DateTime | The DateTime value of the segment.
public Property | Font | The Font the control will use to draw text in the segment.
public Property | ForeColor | The color the control will use to draw text in the segment.
public Property | Graphics | A handle to the Graphics object where the ruler segment will be rendered.
public Property | Rect | The rectangle representing the size and location of the ruler segment within the ruler.
public Property | Schedule | The dbiScheduleObject that the ruler and ruler segment belong to.
public Property | Segment | The index of the current segment being drawn
public Property | SegmentWidth | The current width of the segment to be drawn.
public Property | Text | The text string the control should draw within the segment in the ruler.
public Property | TextAlign | The alignment of the text when rendered by the control within the ruler segment.
Top

See Also

Reference

UserDrawnRulerSegmentEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnRulerTitleEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnRulerTitleEventArgs Class

"

For a list of all members of this type, see UserDrawnRulerTitleEventArgs members.

"

Public Properties

 | Name | Description
public Property | DateTime | The Date value to be written in the title area.
public Property | ScheduleObject | The dbiScheduleObject whose ruler title is being drawn.
public Property | Text | The text that will be displayed in the ruler title.
Top

See Also

Reference

UserDrawnRulerTitleEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnTimeBarsEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnTimeBarsEventArgs Class

"

For a list of all members of this type, see UserDrawnTimeBarsEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | A handle to the Graphics object responsible for the drawing.
public Property | TimeBars | The collection of dbiUserDrawnBars that can be drawn.
Top

See Also

Reference

UserDrawnTimeBarsEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

UserDrawnWaterMarkEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : UserDrawnWaterMarkEventArgs Class

"

For a list of all members of this type, see UserDrawnWaterMarkEventArgs members.

"

Public Properties

 | Name | Description
public Property | Graphics | The Graphics object for the display of the schedule.
public Property | PaintWaterMark | Determines if the control should still generate the WaterMark based on the associated properties.
public Property | Printing | Determines if the event is being raised during the printing process.
public Property | ScheduleAreaRect | Represents the size and location of the schedulea area relative to the Graphics.
Top

See Also

Reference

UserDrawnWaterMarkEventArgs Class
Dbi.WinControl.Schedule Namespace


%%PageItemTitle%% $$Properties$$

ValuePointEventArgs Class Properties
[image]
dbiScheduleE Assembly > Dbi.WinControl.Schedule Namespace : ValuePointEventArgs Class

"

For a list of all members of this type, see ValuePointEventArgs members.

"

Public Properties

 | Name | Description
public Property | CurrentTime | The DateTime value of the major unit being drawn.
public Property | Font | The font value of the major unit being drawn.
public Property | ForeColor | The fore color used to paint the major time unit.
public Property | Graphics | A handle to the Graphics object where the value point section will be drawn.
public Property | Rect | A rectangle representing the size and location of the Value Point within the Graphics object.
public Property | ScheduleIndex | The zero-based index value of the schedule.
public Property | Text | The text to display in the ruler.
public Property | Value | The value of major time unit.
Top

See Also

Reference

ValuePointEventArgs Class
Dbi.WinControl.Schedule Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Dbi.WinControl.Schedule Namespace Inheritance Hierarchy
dbiScheduleE Assembly : Dbi.WinControl.Schedule Namespace

Inheritance Hierarchy

System.Object
Dbi.PIM.dbiAppointmentItem
Dbi.WinControl.Schedule.dbiTimeBarItem
Dbi.WinControl.dbiNodeItem
Dbi.WinControl.Schedule.dbiScheduleItem
Dbi.WinControl.Schedule.dbiGuideLine
Dbi.WinControl.Schedule.dbiHistoryItem
Dbi.WinControl.Schedule.dbiLinkItem
Dbi.WinControl.Schedule.dbiScheduleNote
Dbi.WinControl.Schedule.dbiTimeBarStyle
Dbi.WinControl.Schedule.dbiUserDrawnBar
System.Collections.CollectionBase
Dbi.CollectionBaseEvents
Dbi.WinControl.NodeItemCollection
Dbi.WinControl.Schedule.ScheduleItemCollection
Dbi.WinControl.Schedule.dbiGuideLineCollection
Dbi.WinControl.Schedule.dbiScheduleNoteCollection
Dbi.WinControl.Schedule.dbiUserDrawnBarCollection
Dbi.WinControl.Schedule.HistoryCollection
Dbi.WinControl.Schedule.LinkCollection
Dbi.WinControl.Schedule.ScheduleCollection
Dbi.WinControl.Schedule.TimeBarItemCollection
Dbi.WinControl.Schedule.TimeBarStyleCollection
System.EventArgs
Dbi.WinControl.Schedule.AfterGuideLineInsertedEventArgs
Dbi.WinControl.Schedule.AfterGuideLineMovedEventArgs
Dbi.WinControl.Schedule.AfterGuideLineRemovedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarDropEventArgs
Dbi.WinControl.Schedule.AfterTimeBarInsertedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarLinkedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarMovedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarRemovedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarSelectEventArgs
Dbi.WinControl.Schedule.AfterTimeBarSizedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarSplitEventArgs
Dbi.WinControl.Schedule.AfterTimeBarUnlinkedEventArgs
Dbi.WinControl.Schedule.AfterTimeBarUnSelectEventArgs
Dbi.WinControl.Schedule.AlarmTimeBarEndEventArgs
Dbi.WinControl.Schedule.AlarmTimeBarStartEventArgs
Dbi.WinControl.Schedule.BeforeGuideLineInsertEventArgs
Dbi.WinControl.Schedule.BeforeGuideLineMoveEventArgs
Dbi.WinControl.Schedule.BeforeGuideLineRemoveEventArgs
Dbi.WinControl.Schedule.BeforePrintPageNumberEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarDropEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarInsertEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarLinkEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarMoveEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarRemoveEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSelectEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSizeEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarSplitEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarUnlinkEventArgs
Dbi.WinControl.Schedule.BeforeTimeBarUnSelectEventArgs
Dbi.WinControl.Schedule.BeforeToolTipsEventArgs
Dbi.WinControl.Schedule.ControlErrorEventArgs
Dbi.WinControl.Schedule.DeadZoneDropEventArgs
Dbi.WinControl.Schedule.EditModeChangedEventArgs
Dbi.WinControl.Schedule.FirstDrawEventArgs
Dbi.WinControl.Schedule.GuideLineClickEventArgs
Dbi.WinControl.Schedule.GuideLineInDeadZoneEventArgs
Dbi.WinControl.Schedule.GuideLineMoveEventArgs
Dbi.WinControl.Schedule.HistoryChangeEventArgs
Dbi.WinControl.Schedule.ItemMouseOverEventArgs
Dbi.WinControl.Schedule.LineArrowClickEventArgs
Dbi.WinControl.Schedule.LineArrowDoubleClickEventArgs
Dbi.WinControl.Schedule.LineArrowMouseOverEventArgs
Dbi.WinControl.Schedule.ListClickEventArgs
Dbi.WinControl.Schedule.ListDoubleClickEventArgs
Dbi.WinControl.Schedule.ListDropEventArgs
Dbi.WinControl.Schedule.MouseWheelCheckEventArgs
Dbi.WinControl.Schedule.NoteClickEventArgs
Dbi.WinControl.Schedule.NoteDoubleClickEventArgs
Dbi.WinControl.Schedule.RedoActionEventArgs
Dbi.WinControl.Schedule.RulerDragEventArgs
Dbi.WinControl.Schedule.ScheduleClickEventArgs
Dbi.WinControl.Schedule.ScheduleScrollBarsOffsetAreaEventArgs
Dbi.WinControl.Schedule.ScrollBufferResizeArgs
Dbi.WinControl.Schedule.ScrollTrackEventArgs
Dbi.WinControl.Schedule.TimeBarClickEventArgs
Dbi.WinControl.Schedule.TimeBarDateTextEventArgs
Dbi.WinControl.Schedule.TimeBarDoubleClickEventArgs
Dbi.WinControl.Schedule.TimeBarMouseEnterEventArgs
Dbi.WinControl.Schedule.TimeBarMouseLeaveEventArgs
Dbi.WinControl.Schedule.TimeBarMovingEventArgs
Dbi.WinControl.Schedule.TimeBarSizingEventArgs
Dbi.WinControl.Schedule.UndoActionEventArgs
Dbi.WinControl.Schedule.UserDrawnBarAfterEventArgs
Dbi.WinControl.Schedule.UserDrawnBarEventArgs
Dbi.WinControl.Schedule.UserDrawnCustomAreaEventArgs
Dbi.WinControl.Schedule.UserDrawnFooterEventArgs
Dbi.WinControl.Schedule.UserDrawnHeaderEventArgs
Dbi.WinControl.Schedule.UserDrawnLineEventArgs
Dbi.WinControl.Schedule.UserDrawnLinkLineEventArgs
Dbi.WinControl.Schedule.UserDrawnListScrollAreaEventArgs
Dbi.WinControl.Schedule.UserDrawnRulerEventArgs
Dbi.WinControl.Schedule.UserDrawnRulerSegmentEventArgs
Dbi.WinControl.Schedule.UserDrawnRulerTitleEventArgs
Dbi.WinControl.Schedule.UserDrawnTimeBarsEventArgs
Dbi.WinControl.Schedule.UserDrawnWaterMarkEventArgs
Dbi.WinControl.Schedule.ValuePointEventArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Dbi.dbiControl
Dbi.WinControl.DbiListControl
Dbi.WinControl.Schedule.dbiSchedule
Dbi.WinControl.Schedule.dbiScheduleObject

See Also

Reference

dbiScheduleE Assembly


%%Phrase%%

Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


DBI

DBI.dll (DBI4.dll)

DBI Base Class

for use with most DBI controls

This should only appear as a base class when using other dbi Controls.

If you have no other DBI Controls in your project, you can remove this reference as needed.