%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Introduction

Glossary Item Box

Three Calendar Views in One Control
  • Monthly Calendar View
  • Multi Column View
  • Week View
Feature Highlights Include
  • Appointment Objects for All Views
  • Variable Appointment Time Line - schedule appointments based on any increment between 1 and 60
  • Appointment Background Image (built-in image list or host your own)
  • Control Background Image (built-in image list or host your own)
  • Multi Column View - Time Guide
  • Manage Horizontal and Vertical Scrolling - support for multiple instances of the control
  • 12 hour or 24 hour clock
  • define custom areas - Multi-Column View
  • ICal / VCal support
  • Built-in Printing
  • Built-in XML Read / Write support
  • Define and Format Titles
  • Define Page Numbers
  • Drag and Drop Scheduling
  • Set your own AM / PM designations
  • TimeLine / Virtical Scroll Bar set Visible
  • Built-in Reporting
  • Built-in Save to Image
  • Define and Format Sub-Titles
  • Define Viewing Margins
  • Direct Inline Editing - Multi Column View
  • More appointments indicator (stock or custom)
  • Data - manage scheduling entities with ease
    • Appointments
    • Contacts
    • Date
    • Location
    • Tasks

  • Multi-Column Day View Sorting
    • Sort by Contact
    • Sort by Day
    • Sort by Location
  • Appointment Features
    • Appointment background image
    • Appointment border
    • Appointment reminder image
    • Appointment shadow
    • Appointment task bar color
    • Appointment task bar image
  • Appointment Sorting by Type for:
    • Day View, Calendar View and Week View per:
      • Contact
      • Date
      • Location
      • Task
  • Multi-Column View Appointment Grouping
    • by Date by Contact
    • by Date by Location
    • by Date by Task
    • by Contact by Date
    • by Contact by Location
    • by Contact by Task
    • by Location by Date
    • by Location by Contact
    • by Location by Task
    • by Task by Date
    • by Task by Contact
    • by Task by Location
  • Appointment Navigation - scroll appointments in the All Day area, Calendar and Week Views

© 2020 DBI Technologies Inc. All Rights Reserved.


%%phrase%%

ctxCalendar (4.0) Calendar and Day View Control
Project Overview
Send comments on this topic.

Description

ctxCalendar (3.0) Calendar and Day View Control

Classes

Class Module | Description
ctxCalendar | ctxCalendar Control

Public Enumerations

Enumeration | Description
enumAlignment | Specifies a horizontal alignment
enumAmPmPosition | Available positions for placing the AM/PM text.
enumAppInfoLinePriority | Available options for setting a priority of the infoline on individual appointments.
enumAppointmentType | Available options for grouping appointments in the display
enumArrowPosition | Available display options for the arrows indicating additional appointments.
enumBorderType | Available border types for the control.
enumControlStyle | Available built-in styles for the control.
enumCustomAreasFilter | Available options for filtering the display of custom areas.
enumDateHorzLines | Available drawing styles for the horizontal line separating the rows of dates in the monthly view.
enumDateSelectType | Available options for highlighting the dates in the weekly and monthly views.
enumDayOfWeek | The available days of the week for setting the FirstDayOfWeek property.
enumEnterKey | Available behavior for the Enter key when editing appointment text.
enumFillType | Specifies the fill pattern.
enumGroupType | Available options for secondary grouping of appointments.
enumHeaderBorderStyle | Available border styles for the weekday headers in the monthly view.
enumHourStyle | Available display options for the Hour integer in the Time Line of a daily view.
enumItemTypes | The types of objects that can be recorded by the advanced hittest functionality
enumMinuteDisplay | Available options for where the Minutes will be drawn relative to the Hours in a daily time line.
enumMinuteFormat | Available formats for displaying the minutes of each Hour in the time line, when TimeType is Split.
enumPosition | Available positions for the appointment indicators inside the daily view of the control.
enumPrintReportType | AVialable types of printed reports.
enumProperties | Options for displaying the custom property pages of the control.
enumShowTimes | Available options for displaying times in the appointments in week and month views.
enumTextAngle | Available options for adjusting the angle of the display of text.
enumTimeBorderType | Available options for the border displayed around the hours in the daily view time line.
enumTimeType | Available options for the display of the hours and minutes along the time line of a daily view.
enumTodayStyle | Available options for styling the current date in the daily view of the control.
enumViewType | Available display options for the control.
enumYearDisplay | Available options for the display of the year value of a date in the Monthly and weekly views.


Getting Started

CTX Controls

Getting Started

System Requirements

All of the DBI "CTX" pre-fixed activeX controls can be used in any development environment that supports 32/64 bit OCX/ActiveX™ OLE components.

Supporting Files

In order to use the OCX components the following support files are required:

  • MFC110U.DLL (version 11.0)-this is the Microsoft Foundation Class Library. It must be registered with your system registry.
  • MSVCR110.DLL - (version 11.0)-this is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL, -required to display the stock property pages of the components in development mode (or at runtime if desired, with the "PropertyPages" property on each control). NOTE: The MSSTKPRP.dll is currently only available in 32-bit environments and applications

Additionally, MSHTML.DLL and MLANG.DLL-these are Microsoft dll's required for the operation of the cxtHTML View component. These dll's are present on all versions of Windows with at least a minimum install of IE 4.0.

These files must be distributed (and registered where necessary) with your applications. You may require additional OCX or OLE support files if your application requires them-check with the host language manual to determine what those files (if any) might be.

Versioning

All components that receive new properties, new events, or new methods, that change the structure of the ODL file, will receive an increment in its whole version number (i.e. from version 1.0 to version 2.0). These components will be compiled with a new GUID—the GUID is the unique identifier used to identify the control within the system registry. All components that receive bug fixes or enhancements that do not change the structure of the ODL file will receive an increment in the decimal version number (e.g. from version 1.0 to 1.1). These components will not be compiled with a new GUID. All components will contain a description string (that reflects the component name), version number (to identify the version of source code that was used to compile the component), and product identifier (to indicate whether the component is generic to a component package or a custom compile for a specific customer).

Note: Globally unique identifiers (GUIDs) are 128-bit integer values that are used to assign world-wide unique identifiers for COM interfaces and CoClasses

BACKWARD COMPATIBILITY

To address the problem of maintaining compatibility with previous versions, DBI Technologies has elected to generate new GUIDs as described above. In essence, new versions that are compiled with new GUIDs become new components. These may be registered and referenced on a system with an older version of the same component without conflict. This co-existence will allow developers to release new applications utilizing new component versions without effecting the performance or functionality of existing applications using older component versions.


%%PageItemTitle%%

AddAppointment Method
See Also Send comments on this topic.
nStartTime
The starting time of the appointment, as minutes past midnight.
nEndTime
The ending time of the appointment, as minutes past midnight
dtDate
The date of the appointment
strText
The text for the appointment.
ctxCalendar Object : AddAppointment Method

Description

Add an appointment to the control

Syntax

Visual Basic
Public Function AddAppointment( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal strText As String _
) As Integer

Parameters

nStartTime
The starting time of the appointment, as minutes past midnight.
nEndTime
The ending time of the appointment, as minutes past midnight
dtDate
The date of the appointment
strText
The text for the appointment.

Return Type

The index value of the new appointment. a value of 0 indicates the operation failed.

See Also

ctxCalendar Object | ctxCalendar Members


%%PageItemTitle%%

AddContact Method
nCode
The column code identifying the contact.
strText
The text for the Contact's header.
ctxCalendar Object : AddContact Method

Description

Add a Contact to the control

Syntax

Visual Basic
Public Function AddContact( _
   ByVal nCode As Integer, _
   ByVal strText As String _
) As Integer

Parameters

nCode
The column code identifying the contact.
strText
The text for the Contact's header.

Return Type

The index value of the new contact. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddCustomArea Method
dtDate
The date of the custom area.
nTimeStart
The start time of the custom area.
nTimeEnd
The end time of the custom area.
clrColor
The color of the custom area.
bDeadZone
Indicates if the custom area should be a dead zone or not.
ctxCalendar Object : AddCustomArea Method

Description

Add a new custom area to the control

Syntax

Visual Basic
Public Function AddCustomArea( _
   ByVal dtDate As Date, _
   ByVal nTimeStart As Integer, _
   ByVal nTimeEnd As Integer, _
   ByVal clrColor As ULong, _
   ByVal bDeadZone As Boolean _
) As Integer

Parameters

dtDate
The date of the custom area.
nTimeStart
The start time of the custom area.
nTimeEnd
The end time of the custom area.
clrColor
The color of the custom area.
bDeadZone
Indicates if the custom area should be a dead zone or not.

Return Type

the index of the new custom area. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddDayFormat Method
dtDate
The date that the format will apply to.
ctxCalendar Object : AddDayFormat Method

Description

Add a new day format to the control.

Syntax

Visual Basic
Public Function AddDayFormat( _
   ByVal dtDate As Date _
) As Integer

Parameters

dtDate
The date that the format will apply to.

Return Type

The index value of the new day format. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddImage Method
picImage
An olePicture to add to the internal list.
ctxCalendar Object : AddImage Method

Description

Add a new picture to the internal image list of the control.

Syntax

Visual Basic
Public Function AddImage( _
   ByVal picImage As Picture _
) As Integer

Parameters

picImage
An olePicture to add to the internal list.

Return Type

The index value of the new picture. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddKeyAppointment Method
nStartTime
The starting time of the appointment, as minutes past midnight.
nEndTime
The ending time of the appointment, as minutes past midnight
dtDate
The date of the appointment
strText
The text for the appointment.
strKeyID
A unique ID value assigned to the appointment.
ctxCalendar Object : AddKeyAppointment Method

Description

Add a new appointment to the control

Syntax

Visual Basic
Public Function AddKeyAppointment( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal strText As String, _
   ByVal strKeyID As String _
) As Integer

Parameters

nStartTime
The starting time of the appointment, as minutes past midnight.
nEndTime
The ending time of the appointment, as minutes past midnight
dtDate
The date of the appointment
strText
The text for the appointment.
strKeyID
A unique ID value assigned to the appointment.

Return Type

The index of the new appointment. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddKeyContact Method
nCode
The column code identifying the contact.
strText
The text for the Contact's header.
strKeyID
A unique ID value assigned to the Contact.
ctxCalendar Object : AddKeyContact Method

Description

Add a Contact to the control

Syntax

Visual Basic
Public Function AddKeyContact( _
   ByVal nCode As Integer, _
   ByVal strText As String, _
   ByVal strKeyID As String _
) As Integer

Parameters

nCode
The column code identifying the contact.
strText
The text for the Contact's header.
strKeyID
A unique ID value assigned to the Contact.

Return Type

The index value of the new contact. A value of 0 indicates the method failed.

Example

See Also


%%PageItemTitle%%

AddKeyLocation Method
nCode
The column code identifying the location.
strText
The text for the Location's header.
strKeyID
A unique ID value assigned to the Location.
ctxCalendar Object : AddKeyLocation Method

Description

Add a Location to the control

Syntax

Visual Basic
Public Function AddKeyLocation( _
   ByVal nCode As Integer, _
   ByVal strText As String, _
   ByVal strKeyID As String _
) As Integer

Parameters

nCode
The column code identifying the location.
strText
The text for the Location's header.
strKeyID
A unique ID value assigned to the Location.

Return Type

The index value of the new location. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddKeyTask Method
nCode
The column code identifying the task.
strText
The text for the Task's header.
strKeyID
A unique ID value assigned to the Task.
ctxCalendar Object : AddKeyTask Method

Description

Add a Task to the control

Syntax

Visual Basic
Public Function AddKeyTask( _
   ByVal nCode As Integer, _
   ByVal strText As String, _
   ByVal strKeyID As String _
) As Integer

Parameters

nCode
The column code identifying the task.
strText
The text for the Task's header.
strKeyID
A unique ID value assigned to the Task.

Return Type

The index value of the new task. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddLocation Method
nCode
The column code identifying the location.
strText
The text for the Location's header.
ctxCalendar Object : AddLocation Method

Description

Add a Location to the control

Syntax

Visual Basic
Public Function AddLocation( _
   ByVal nCode As Integer, _
   ByVal strText As String _
) As Integer

Parameters

nCode
The column code identifying the location.
strText
The text for the Location's header.

Return Type

The index value of the new location. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddTask Method
nCode
The column code identifying the task.
strText
The text for the Task's header.
ctxCalendar Object : AddTask Method

Description

Add a Task to the control

Syntax

Visual Basic
Public Function AddTask( _
   ByVal nCode As Integer, _
   ByVal strText As String _
) As Integer

Parameters

nCode
The column code identifying the task.
strText
The text for the Task's header.

Return Type

The index value of the new task. A value of 0 indicates the method failed.

See Also


%%PageItemTitle%%

AddvCalAppointment Method
strText
The vCal generated string to base the appointment off.
ctxCalendar Object : AddvCalAppointment Method

Description

Adds an appointment to the control based a string in the vCal format.

Syntax

Visual Basic
Public Function AddvCalAppointment( _
   ByVal strText As String _
) As Integer

Parameters

strText
The vCal generated string to base the appointment off.

Return Type

The index value for the newly created appointment. A value of 0 indicates the operation failed.

See Also


%%PageItemTitle%%

AppointmentAt Method
nxPoint
The X-coordinate to test for an appointment.
nyPoint
The Y-Coordinate to test for an appointment.
ctxCalendar Object : AppointmentAt Method

Description

Returns the index of the first appointment found at a specified point in the control.

Syntax

Visual Basic
Public Function AppointmentAt( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer _
) As Integer

Parameters

nxPoint
The X-coordinate to test for an appointment.
nyPoint
The Y-Coordinate to test for an appointment.

Return Type

The 1-based index of the appointment found at the position. A value of 0 indicates there is no appointment there.

Example

See Also


%%PageItemTitle%%

AppointmentDrawnHeight Method
nIndex
1-based index value of the appointment.
ctxCalendar Object : AppointmentDrawnHeight Method

Description

Returns the height of a currently rendered appointment.

Syntax

Visual Basic
Public Function AppointmentDrawnHeight( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
1-based index value of the appointment.

Return Type

Integer

Remarks

The appointment must be in the current visible area of the control for this method to return a valid value.

If either the appointment is not currently visible, or an invalid index value is supplied to the method, a value of -1 will be returned.

Example

See Also


%%PageItemTitle%%

AppointmentDrawnLeft Method
nIndex
1-based index value of the appointment.
ctxCalendar Object : AppointmentDrawnLeft Method

Description

Returns the left edge of a currently rendered appointment.

Syntax

Visual Basic
Public Function AppointmentDrawnLeft( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
1-based index value of the appointment.

Return Type

Integer

Remarks

The appointment must be in the current visible area of the control for this method to return a valid value.

If either the appointment is not currently visible, or an invalid index value is supplied to the method, a value of -1 will be returned.

Example

See Also


%%PageItemTitle%%

AppointmentDrawnTop Method
nIndex
1-based index value of the appointment.
ctxCalendar Object : AppointmentDrawnTop Method

Description

Returns the top edge of a currently rendered appointment.

Syntax

Visual Basic
Public Function AppointmentDrawnTop( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
1-based index value of the appointment.

Return Type

Integer

Remarks

The appointment must be in the current visible area of the control for this method to return a valid value.

If either the appointment is not currently visible, or an invalid index value is supplied to the method, a value of -1 will be returned.

Example

See Also


%%PageItemTitle%%

AppointmentDrawnWidth Method
nIndex
1-based index value of the appointment.
ctxCalendar Object : AppointmentDrawnWidth Method

Description

Returns the width of a currently rendered appointment.

Syntax

Visual Basic
Public Function AppointmentDrawnWidth( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
1-based index value of the appointment.

Return Type

Integer

Remarks

The appointment must be in the current visible area of the control for this method to return a valid value.

If either the appointment is not currently visible, or an invalid index value is supplied to the method, a value of -1 will be returned.

Example

See Also


%%PageItemTitle%%

AppointmentInColumn Method
nIndex
The index value of the appointment to find.
ctxCalendar Object : AppointmentInColumn Method

Description

Finds the index value relative to the column that contains a specified appointment.

Syntax

Visual Basic
Public Function AppointmentInColumn( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The index value of the appointment to find.

Return Type

The index value of the column where the appointment is currently displayed. A return value of 0 indicates the appointment was not found in a current column.

See Also


%%PageItemTitle%%

AppointmentIndex Method
strKeyID
The ID value to search for
bCase
Determines if the search should be case sensative when comparing the supplied string to those stored on appointments.
ctxCalendar Object : AppointmentIndex Method

Description

Returns the 1-based index of an appointment based on a supplied Appointment_KeyID value

Syntax

Visual Basic
Public Function AppointmentIndex( _
   ByVal strKeyID As String, _
   ByVal bCase As Boolean _
) As Integer

Parameters

strKeyID
The ID value to search for
bCase
Determines if the search should be case sensative when comparing the supplied string to those stored on appointments.

Return Type

The 1-based index of the appointment containing the supplied ID. A value of 0 indicates no appointment was found.

See Also


%%PageItemTitle%%

BeginDrag Method
ctxCalendar Object : BeginDrag Method

Description

Notifies the control that the developer is starting an external drag operation and to cancel/reset any internal movement that may have occurred.

Syntax

Visual Basic
Public Sub BeginDrag()

Remarks

Calling this event from the StartDragOut event will tell the control to cancel and reset all internal movement of an appointment.

Example

Private Sub ctxCalendar1_StartDragOut(ByVal nIndex As Integer)
ctxCalendar1.BeginDrag
ctxCalendar1.Drag vbBeginDrag
End Sub

See Also


%%PageItemTitle%%

Cancel Method
ctxCalendar Object : Cancel Method

Description

Cancels an operation from occurring inside the control.

Syntax

Visual Basic
Public Sub Cancel()

Remarks

There are some IDEs and development environments where Cancel is a reserved word. In those environments the CancelAction method can be used instead.

This method can be called inside multiple "Before" prefixed events to prevent the operation that triggered the event from occurring.

The method can be used in the following events:

BeforeTimeSelect
BeforeAppointmentChange
BeforeAppointmentSelect
BeforeAppointmentAdd
BeforeDateSelect

See Also


%%PageItemTitle%%

CancelAction Method
ctxCalendar Object : CancelAction Method

Description

Cancels an operation from occurring inside the control.

Syntax

Visual Basic
Public Sub CancelAction()

Remarks

This method can be used instead of the Cancel method, in environments where Cancel is a reserved word.

This method can be called inside multiple "Before" prefixed events to prevent the operation that triggered the event from occurring.

The method can be used in the following events:

BeforeTimeSelect
BeforeAppointmentChange
BeforeAppointmentSelect
BeforeAppointmentAdd
BeforeDateSelect

See Also


%%PageItemTitle%%

ClearAppointments Method
ctxCalendar Object : ClearAppointments Method

Description

Clears all the appointments from the control.

Syntax

Visual Basic
Public Sub ClearAppointments()

See Also


%%PageItemTitle%%

ClearContacts Method
ctxCalendar Object : ClearContacts Method

Description

Clears all the Contacts from the control.

Syntax

Visual Basic
Public Sub ClearContacts()

Remarks

Clearing the Contacts from the control will not affect the current value of the Appointment_ContactCode property of any appointments.

See Also


%%PageItemTitle%%

ClearCustomAreas Method
ctxCalendar Object : ClearCustomAreas Method

Description

Clears all the Custom Areas from the control.

Syntax

Visual Basic
Public Sub ClearCustomAreas()

See Also


%%PageItemTitle%%

ClearDayFormats Method
ctxCalendar Object : ClearDayFormats Method

Description

Clears all the Day Formats from the control.

Syntax

Visual Basic
Public Sub ClearDayFormats()

See Also


%%PageItemTitle%%

ClearLocations Method
ctxCalendar Object : ClearLocations Method

Description

Clears all the Locations from the control.

Syntax

Visual Basic
Public Sub ClearLocations()

Remarks

Clearing the Locations from the control will not affect the current value of the Appointment_LocationCode property of any appointments.

See Also


%%PageItemTitle%%

ClearTasks Method
ctxCalendar Object : ClearTasks Method

Description

Clears all the Tasks from the control.

Syntax

Visual Basic
Public Sub ClearTasks()

Remarks

Clearing the Tasks from the control will not affect the current value of the Appointment_TaskCode property of any appointments.

See Also


%%PageItemTitle%%

ColumnAt Method
nxPoint
The X-coordinate of the column.
ctxCalendar Object : ColumnAt Method

Description

Returns the column index at the provided X-coordinate.

Syntax

Visual Basic
Public Function ColumnAt( _
   ByVal nxPoint As Integer _
) As Integer

Parameters

nxPoint
The X-coordinate of the column.

Return Type

The 1-based index of the column located at the specified coordinate.

Remarks

A value of 0 means you are in the time area.

See Also


%%PageItemTitle%%

ColumnContact Method
nColumn
The 1-based index value of the column to retrieve the contact from.
ctxCalendar Object : ColumnContact Method

Description

Returns the Contact_Code of the Contact associated with the column specified.

Syntax

Visual Basic
Public Function ColumnContact( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index value of the column to retrieve the contact from.

Return Type

The Contact_Code of the Contact located at the column. A value of 0 indicates there is no contact at that column.

See Also


%%PageItemTitle%%

ColumnDate Method
nColumn
The 1-based index value of the column to retrieve the date from.
ctxCalendar Object : ColumnDate Method

Description

Returns the date associated with a specified column index.

Syntax

Visual Basic
Public Function ColumnDate( _
   ByVal nColumn As Integer _
) As Date

Parameters

nColumn
The 1-based index value of the column to retrieve the date from.

Return Type

The date of the specified column.

Example

See Also


%%PageItemTitle%%

ColumnLocation Method
nColumn
The 1-based index value of the column to retrieve the location from.
ctxCalendar Object : ColumnLocation Method

Description

Returns the Location_Code of the Location associated with the column specified.

Syntax

Visual Basic
Public Function ColumnLocation( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index value of the column to retrieve the location from.

Return Type

The Location_Code of the Location located at the column. A value of 0 indicates there is no location at that column.

See Also


%%PageItemTitle%%

ColumnTask Method
nColumn
The 1-based index value of the column to retrieve the task from.
ctxCalendar Object : ColumnTask Method

Description

Returns the Task_Code of the Task associated with the column specified.

Syntax

Visual Basic
Public Function ColumnTask( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index value of the column to retrieve the task from.

Return Type

The Task_Code of the Task located at the column. A value of 0 indicates there is no task at that column.

See Also


%%PageItemTitle%%

ContactIndexFromCode Method
nCode
The Code of the Contact to be found.
ctxCalendar Object : ContactIndexFromCode Method

Description

Returns the index of a Contact in the control, based on a supplied Contact_Code

Syntax

Visual Basic
Public Function ContactIndexFromCode( _
   ByVal nCode As Integer _
) As Integer

Parameters

nCode
The Code of the Contact to be found.

Return Type

The 1-based index of the Contact containing the supplied Code. A value of 0 indicates no Contact found with that code.

See Also


%%PageItemTitle%%

ContactIndexFromKeyID Method
strKeyID
The ID value of the contact to find
bCase
Determines if the search should be case sensative.
ctxCalendar Object : ContactIndexFromKeyID Method

Description

Returns the index of a Contact in the control, based on a supplied ID string.

Syntax

Visual Basic
Public Function ContactIndexFromKeyID( _
   ByVal strKeyID As String, _
   ByVal bCase As Boolean _
) As Integer

Parameters

strKeyID
The ID value of the contact to find
bCase
Determines if the search should be case sensative.

Return Type

The 1-based index of the Contact containing the supplied ID. A value of 0 indicates no Contact found.

See Also


%%PageItemTitle%%

CreateImage Method
strFileName
The name of the image file to create.
nWidth
The width of the image
nHeight
The height of the image
nType

The type of image to generate

BMP = 0
JPG = 1
GIF = 2
TIF = 3
PNG = 4

ctxCalendar Object : CreateImage Method

Description

Creates an image file based on the current content of the control.

Syntax

Visual Basic
Public Function CreateImage( _
   ByVal strFileName As String, _
   ByVal nWidth As Integer, _
   ByVal nHeight As Integer, _
   ByVal nType As Integer _
) As Boolean

Parameters

strFileName
The name of the image file to create.
nWidth
The width of the image
nHeight
The height of the image
nType

The type of image to generate

BMP = 0
JPG = 1
GIF = 2
TIF = 3
PNG = 4

Return Type

A value indicating if the method was successful or not.

Remarks

The file name should include the full path where the image should be saved to. The file extension on the name is optional, and if not included the control will append an extension based on the nType value.

The Width and Height parameters can accept a value of 0 or -1 to change the behavior of how the image is created. If a value of 0 is sent to either of these parameters, the width and/or height of the JPG will be the same as what is visible on screen. If a value of -1 is sent to either of these parameters, the width and/or height of the image will be the entire width and/or height of the control (i.e. all time values or all List items). When the height and/or width parameter is equal to -1, the MaxImageHeight and MaxImageWidth properties are used to set the maximum height and width of the image.

See Also


%%PageItemTitle%%

DateAt Method
nxPoint
The X-Coordinate to test for the date.
nyPoint
The Y-Coordinate to test for the date.
ctxCalendar Object : DateAt Method

Description

Returns the date located at a specified position in the control.

Syntax

Visual Basic
Public Function DateAt( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer _
) As Date

Parameters

nxPoint
The X-Coordinate to test for the date.
nyPoint
The Y-Coordinate to test for the date.

Return Type

The Date located at the specified coordinates.

Example

See Also


%%PageItemTitle%%

DateAtColumn Method
nColumn
The relative index value of the column to retrieve the date of
ctxCalendar Object : DateAtColumn Method

Description

Returns the date value associated with a column in the daily view.

Syntax

Visual Basic
Public Function DateAtColumn( _
   ByVal nColumn As Integer _
) As Date

Parameters

nColumn
The relative index value of the column to retrieve the date of

Return Type

The date value located at the column.

Remarks

If no unique date is associated with the column, the DateStart value will be returned.

Example

See Also


%%PageItemTitle%%

Day Method
dtDate
The date to retrieve the Day from.
ctxCalendar Object : Day Method

Description

Returns the day portion of a supplied date value.

Syntax

Visual Basic
Public Function Day( _
   ByVal dtDate As Date _
) As Integer

Parameters

dtDate
The date to retrieve the Day from.

Return Type

A value 1-31 indicating the day of the month of the supplied date value.

See Also


%%PageItemTitle%%

DeleteAppointment Method
nIndex
Index value of the appointment to delete.
ctxCalendar Object : DeleteAppointment Method

Description

Deletes a current appointment from the control.

Syntax

Visual Basic
Public Function DeleteAppointment( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the appointment to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once an appointment is deleted, all other appointments with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DeleteContact Method
nIndex
Index value of the contact to delete.
ctxCalendar Object : DeleteContact Method

Description

Deletes a current contact from the control.

Syntax

Visual Basic
Public Function DeleteContact( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the contact to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once a contact is deleted, all other contacts with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DeleteCustomArea Method
nIndex
Index value of the customarea to delete.
ctxCalendar Object : DeleteCustomArea Method

Description

Deletes a current customarea from the control.

Syntax

Visual Basic
Public Function DeleteCustomArea( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the customarea to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once a custom area is deleted, all other customareas with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DeleteDayFormat Method
nIndex
Index value of the dayformat to delete.
ctxCalendar Object : DeleteDayFormat Method

Description

Deletes a current dayformat from the control.

Syntax

Visual Basic
Public Function DeleteDayFormat( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the dayformat to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once a dayformat is deleted, all other dayformats with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DeleteKeyAppointment Method
strKey
ID Key of the appointment to delete.
ctxCalendar Object : DeleteKeyAppointment Method

Description

Deletes a current appointment from the control based on a ID key value.

Syntax

Visual Basic
Public Function DeleteKeyAppointment( _
   ByVal strKey As String _
) As Boolean

Parameters

strKey
ID Key of the appointment to delete.

Return Type

Determines whether the operation was successful or not.

See Also


%%PageItemTitle%%

DeleteKeyContact Method
strKey
ID Key of the contact to delete.
ctxCalendar Object : DeleteKeyContact Method

Description

Deletes a current contact from the control based on a ID key value.

Syntax

Visual Basic
Public Function DeleteKeyContact( _
   ByVal strKey As String _
) As Boolean

Parameters

strKey
ID Key of the contact to delete.

Return Type

Determines whether the operation was successful or not.

See Also


%%PageItemTitle%%

DeleteKeyLocation Method
strKey
ID Key of the location to delete.
ctxCalendar Object : DeleteKeyLocation Method

Description

Deletes a current location from the control based on a ID key value.

Syntax

Visual Basic
Public Function DeleteKeyLocation( _
   ByVal strKey As String _
) As Boolean

Parameters

strKey
ID Key of the location to delete.

Return Type

Determines whether the operation was successful or not.

See Also


%%PageItemTitle%%

DeleteKeyTask Method
strKey
ID Key of the task to delete.
ctxCalendar Object : DeleteKeyTask Method

Description

Deletes a current task from the control based on a ID key value.

Syntax

Visual Basic
Public Function DeleteKeyTask( _
   ByVal strKey As String _
) As Boolean

Parameters

strKey
ID Key of the task to delete.

Return Type

Determines whether the operation was successful or not.

See Also


%%PageItemTitle%%

DeleteLocation Method
nIndex
Index value of the location to delete.
ctxCalendar Object : DeleteLocation Method

Description

Deletes a current location from the control.

Syntax

Visual Basic
Public Function DeleteLocation( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the location to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once a location is deleted, all other locations with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DeleteTask Method
nIndex
Index value of the task to delete.
ctxCalendar Object : DeleteTask Method

Description

Deletes a current task from the control.

Syntax

Visual Basic
Public Function DeleteTask( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Index value of the task to delete.

Return Type

Determines whether the operation was successful or not.

Remarks

Once a task is deleted, all other tasks with an index value greater than the one being deleted will have their index value reduced by a value of 1.

See Also


%%PageItemTitle%%

DragDrop Method
nxPoint
The X coordinates of the mouse during the drop.
nyPoint
The Y coordinate of the mouse during the drop.
ctxCalendar Object : DragDrop Method

Description

Set the Drag Drop information for the control.

Syntax

Visual Basic
Public Function DragDrop( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer _
) As Date

Parameters

nxPoint
The X coordinates of the mouse during the drop.
nyPoint
The Y coordinate of the mouse during the drop.

Return Type

The date and time where the drop occurred.

See Also


%%PageItemTitle%%

DragOver Method
nxPoint
The X coordinate during the drag.
nyPoint
The Y coordinate during the drag.
nState
The current state of the drag.
ctxCalendar Object : DragOver Method

Description

Set the Drag Over information for the control.

Syntax

Visual Basic
Public Function DragOver( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer, _
   ByVal nState As Integer _
) As Date

Parameters

nxPoint
The X coordinate during the drag.
nyPoint
The Y coordinate during the drag.
nState
The current state of the drag.

Return Type

The date and time where the drag over occurred.

Remarks

Since the control may be required to only accept drag information from certain items, it is possible to block drag information to the control from invalid items. A DragOver event usually includes information on the source control of the drag. If required, the programmer can determine if the source control is a valid one before calling this method.

See Also


%%PageItemTitle%%

FindFirstConflict Method
nIndex
Index value of the appointment looking for the conflict.
bSearchAll
Determines if search is universal or within the column
ctxCalendar Object : FindFirstConflict Method

Description

Determine the first appointment that conflicts with a given appointment.

Syntax

Visual Basic
Public Function FindFirstConflict( _
   ByVal nIndex As Integer, _
   ByVal bSearchAll As Boolean _
) As Integer

Parameters

nIndex
Index value of the appointment looking for the conflict.
bSearchAll
Determines if search is universal or within the column

Return Type

The index value of the conflicting appointment

Remarks

A value of 0 indicates no conflicts. Any other value indicates the index value of the appointment that is in conflict. This method must be used before the FindNextConflict Method is used.

Note : The bSearchAll parameter determines how the search is performed. If it is sent a value of False, the search will include all appointments within the control. If it is sent a value of True, it will only examine appointments that are part of the same column.

Note : The time between appointments when searching for conflicts can be changed by assigning a new value to the ConflictOffset Property.

Note : This method does not check to determine if an appointment is an all day appointment. The programmer will have to adjust for this if they want to ignore all day appointments.

Since this method requires an appointment index, it can only be used with appointments that already exist in the control. To test for conflicts when the appointment doesn't already exist, such as when dragging and dropping an appointment into the control, the IsAppointmentAt Method is recommended.

See Also


%%PageItemTitle%%

FindNextColumnAppointment Method
nColumn
The 1-based index of the column to start searching after.
ctxCalendar Object : FindNextColumnAppointment Method

Description

Gets the appointment index of the next available appointment past a specific column in the day view.

Syntax

Visual Basic
Public Function FindNextColumnAppointment( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index of the column to start searching after.

Return Type

The 1-based index of the appointment.

Remarks

A value of 0 indicates that no appointment was found.

This method can be used with the AppIndicatorClick Event to navigate the control.

See Also


%%PageItemTitle%%

FindNextConflict Method
nIndex
Index value of the appointment looking for the conflict.
bSearchAll
Determines if search is universal or within the column
ctxCalendar Object : FindNextConflict Method

Description

Determine the next appointment that conflicts with a given appointment.

Syntax

Visual Basic
Public Function FindNextConflict( _
   ByVal nIndex As Integer, _
   ByVal bSearchAll As Boolean _
) As Integer

Parameters

nIndex
Index value of the appointment looking for the conflict.
bSearchAll
Determines if search is universal or within the column

Return Type

The index value of the conflicting appointment

Remarks

A value of 0 indicates no conflicts. Any other value indicates the index value of the appointment that is in conflict. The FindFirstConflict Method must be used first before this method may be used.

Note : The bSearchAll parameter determines how the search is performed. If it is sent a value of False, the search will include all appointments within the control. If it is sent a value of True, it will only examine appointments that are part of the same column.

Note : The time between appointments when searching for conflicts can be changed by assigning a new value to the ConflictOffset Property.

Note : This method does not check to determine if an appointment is an all day appointment. The programmer will have to adjust for this if they want to ignore all day appointments.

See Also


%%PageItemTitle%%

FindNextTimeAppointment Method
nColumn
The 1-based index of the column to check.
ctxCalendar Object : FindNextTimeAppointment Method

Description

Get the appointment index of an appointment, that exists in a column after the current visible area of the day view.

Syntax

Visual Basic
Public Function FindNextTimeAppointment( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index of the column to check.

Return Type

The 1-based index of the appointment.

Remarks

A value of 0 indicates there is no appointment.

This method can be useful to navigate to an appointment using the ArrowClick Event.

See Also


%%PageItemTitle%%

FindPrevColumnAppointment Method
nColumn
The 1-based index of the column to start searching before.
ctxCalendar Object : FindPrevColumnAppointment Method

Description

Gets the appointment index of the next available appointment before a specific column in the day view.

Syntax

Visual Basic
Public Function FindPrevColumnAppointment( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index of the column to start searching before.

Return Type

The 1-based index of the appointment.

Remarks

A value of 0 indicates that no appointment was found.

This method can be used with the AppIndicatorClick Event to navigate the control.

See Also


%%PageItemTitle%%

FindPrevTimeAppointment Method
nColumn
The 1-based index of the column to check.
ctxCalendar Object : FindPrevTimeAppointment Method

Description

Get the appointment index of an appointment, that exists in a column before the current visible area of the day view.

Syntax

Visual Basic
Public Function FindPrevTimeAppointment( _
   ByVal nColumn As Integer _
) As Integer

Parameters

nColumn
The 1-based index of the column to check.

Return Type

The 1-based index of the appointment.

Remarks

A value of 0 indicates there is no appointment.

This method can be useful to navigate to an appointment using the ArrowClick Event.

See Also


%%PageItemTitle%%

Invalidate Method
ctxCalendar Object : Invalidate Method

Description

Forces the control to invalidate itself so that a re-draw occurs.

Syntax

Visual Basic
Public Sub Invalidate()

See Also


%%PageItemTitle%%

IsAppointmentAt Method
nTimeStart
The time value for the check.
nColumn
The column where the check should take place
ctxCalendar Object : IsAppointmentAt Method

Description

Determines if an appointment already exists at a certain time in a certain column.

Syntax

Visual Basic
Public Function IsAppointmentAt( _
   ByVal nTimeStart As Integer, _
   ByVal nColumn As Integer _
) As Integer

Parameters

nTimeStart
The time value for the check.
nColumn
The column where the check should take place

Return Type

The 1-based index of the first appointment found.

Remarks

This can be useful if you want to prevent appointments from overlapping when dragging and dropping appointments into the control.

If you need to test for conflicts when moving appointments inside the control, the FindFirstConflict and FindNextConflict methods are the recommended methods.

See Also


%%PageItemTitle%%

ItemAppointment Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemAppointment Method

Description

Returns the 1-based index of the appointment related to a hittest object.

Syntax

Visual Basic
Public Function ItemAppointment( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no appointment related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemAt Method
nxPoint
The X coordinate to test for an object.
nyPoint
The Y coordinate to test for an object
nIndex
The index to begin the test at
nType
The type of hittest object to report on
ctxCalendar Object : ItemAt Method

Description

Returns the 1-based index of a hittest object located at the specified location

Syntax

Visual Basic
Public Function ItemAt( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer, _
   ByVal nIndex As Integer, _
   ByVal nType As Integer _
) As Integer

Parameters

nxPoint
The X coordinate to test for an object.
nyPoint
The Y coordinate to test for an object
nIndex
The index to begin the test at
nType
The type of hittest object to report on

Return Type

Integer (1-based index)

Remarks

The 1-based index of the hittest object found. A value of 0 indicates nothing was found.

the nIndex parameter can be used in a loop to find all objects located at a specific set of coordinates, as the method will return only one index value at a time.

The nType parameter can be used to filter the search to a specific object type, or a value of 0 will have it search for all objects.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemColumn Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemColumn Method

Description

Returns the 1-based index indicating the column related to the hittest object

Syntax

Visual Basic
Public Function ItemColumn( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no column related to the hittest object.

In the Monthly view, the value will range from 1-7 and will represent a day of the week in each calendar.
In the Weekly view, the value will range from 1-2 and will represent either the left (3 days) or right (4 days) side of each calendar
In the Daily view, the value will relate to the columns (or sub columns if a grouptype has been specified) in the main part of the control and range from 1 to the max number of defined columns.
Additionally, when in the TimeArea of the Daily view, the value will represent which timezone. A value of 1 indicates the primary (or left) timezone while a value of 2 will indicate the offset/secondary timezone (the right one). The ability to display multiple timezones is controlled by the MultipleZones Property.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemContact Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemContact Method

Description

Returns the 1-based index of the contact related to a hittest object.

Syntax

Visual Basic
Public Function ItemContact( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no contact related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemCustomArea Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemCustomArea Method

Description

Returns the 1-based index of the customarea related to a hittest object.

Syntax

Visual Basic
Public Function ItemCustomArea( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no customarea related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemDate Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemDate Method

Description

Returns the date related to a hittest object

Syntax

Visual Basic
Public Function ItemDate( _
   ByVal nIndex As Integer _
) As Date

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Date

Remarks

This method will return a value of 0 if there is no date related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemLocation Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemLocation Method

Description

Returns the 1-based index of the location related to a hittest object.

Syntax

Visual Basic
Public Function ItemLocation( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no location related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemRow Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemRow Method

Description

Returns the 1-based count of the row within the main part of the control related to a hittest object.

Syntax

Visual Basic
Public Function ItemRow( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based count)

Remarks

In the Daily view, this value will indicate the time cell row (relative to the start of the control).

In the Monthly/Weekly views, this value will indicate the date row (relative to the start of the control).

In the monthly view, each row will contain 7 days.
In the weekly view, each week contains 4 rows. The first three rows contain two days, while the fourth day contains only the secondary weekend date (the bottom one in the display).

This method will return a value of 0 when there is no row related to the specified hittest object.

Example

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemTask Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemTask Method

Description

Returns the 1-based index of the task related to a hittest object.

Syntax

Visual Basic
Public Function ItemTask( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

Integer (1-based index)

Remarks

This method will return a value of 0 if there is no task related to the specified hittest object.

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

ItemType Method
nIndex
The 1-based index of the hittest object to retrieve the value from.
ctxCalendar Object : ItemType Method

Description

Returns the type of hittest object stored at a specified index.

Syntax

Visual Basic
Public Function ItemType( _
   ByVal nIndex As Integer _
) As enumItemTypes

Parameters

nIndex
The 1-based index of the hittest object to retrieve the value from.

Return Type

enumItemTypes

See Also

ctxCalendar Object | ctxCalendar Members | Using the HitTest Methods


%%PageItemTitle%%

LocationIndexFromCode Method
nCode
The Code of the Location to find
ctxCalendar Object : LocationIndexFromCode Method

Description

Returns the index of a Location in the control based on a Location_Code

Syntax

Visual Basic
Public Function LocationIndexFromCode( _
   ByVal nCode As Integer _
) As Integer

Parameters

nCode
The Code of the Location to find

Return Type

The 1-based index of the Location containing the supplied Code. A value of 0 indicates no Location found with that code.

See Also


%%PageItemTitle%%

LocationIndexFromKeyID Method
strKeyID
The ID value of the location to find
bCase
Determines if the search should be case sensative.
ctxCalendar Object : LocationIndexFromKeyID Method

Description

Returns the index of a Location in the control, based on a supplied ID string.

Syntax

Visual Basic
Public Function LocationIndexFromKeyID( _
   ByVal strKeyID As String, _
   ByVal bCase As Boolean _
) As Integer

Parameters

strKeyID
The ID value of the location to find
bCase
Determines if the search should be case sensative.

Return Type

The 1-based index of the Location containing the supplied ID. A value of 0 indicates no Location found.

See Also


%%PageItemTitle%%

LongDate Method
nDay
The Day value of the new Date.
nMonth
The Month value of the new Date.
nYear
The Year value of the new Date.
ctxCalendar Object : LongDate Method

Description

Create a Date value based on supplied Day, Month and Year values.

Syntax

Visual Basic
Public Function LongDate( _
   ByVal nDay As Integer, _
   ByVal nMonth As Integer, _
   ByVal nYear As Integer _
) As Date

Parameters

nDay
The Day value of the new Date.
nMonth
The Month value of the new Date.
nYear
The Year value of the new Date.

Return Type

The newly created Date.

See Also


%%PageItemTitle%%

MakeAppointmentVisible Method
nIndex
The 1-based index value of the appointment to scroll the control to.
ctxCalendar Object : MakeAppointmentVisible Method

Description

Scrolls the control so that a desired appointment is within the visible area.

Syntax

Visual Basic
Public Function MakeAppointmentVisible( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the appointment to scroll the control to.

Return Type

A boolean value indicating if the operation was successful.

See Also


%%PageItemTitle%%

MakeDateVisible Method
dtDate
The date to scroll in to view.
bFirstLine
If the control should try and force the line containing the date to be the top most after scrolling.
ctxCalendar Object : MakeDateVisible Method

Description

Scrolls the control to bring a desired date in to view when displaying as a weekly or monthly calendar.

Syntax

Visual Basic
Public Function MakeDateVisible( _
   ByVal dtDate As Date, _
   ByVal bFirstLine As Boolean _
) As Boolean

Parameters

dtDate
The date to scroll in to view.
bFirstLine
If the control should try and force the line containing the date to be the top most after scrolling.

Return Type

A boolean value indicating if the operation was successful.

See Also


%%PageItemTitle%%

Month Method
dtDate
The date to retrieve the month value from.
ctxCalendar Object : Month Method

Description

Returns the month portion of a supplied date value.

Syntax

Visual Basic
Public Function Month( _
   ByVal dtDate As Date _
) As Integer

Parameters

dtDate
The date to retrieve the month value from.

Return Type

A value from 1-12 indicating the month of the date.

See Also


%%PageItemTitle%%

PrintCalendar Method
ctxCalendar Object : PrintCalendar Method

Description

Send the contents of the current calendar to the printer.

Syntax

Visual Basic
Public Function PrintCalendar() As Boolean

Return Type

Determines whether the operation was successful or not.

See Also


%%PageItemTitle%%

ReadFile Method
strFileName
The full name of the xml file to read.
nFileInfo

An Integer value indicating how the file is read:

0 - All the properties of the control and other objects (including appointments) are read in.

1 - The appointments will be read. No other objects or control property information is read

2 - The property information of the control and all objects but appointments is read.

ctxCalendar Object : ReadFile Method

Description

Reads an xml document (generated by the WriteFile of this control) to populate the control.

Syntax

Visual Basic
Public Function ReadFile( _
   ByVal strFileName As String, _
   ByVal nFileInfo As Integer _
) As Boolean

Parameters

strFileName
The full name of the xml file to read.
nFileInfo

An Integer value indicating how the file is read:

0 - All the properties of the control and other objects (including appointments) are read in.

1 - The appointments will be read. No other objects or control property information is read

2 - The property information of the control and all objects but appointments is read.

Return Type

Indicates if the control was able to read the file.

See Also


%%PageItemTitle%%

ReadXMLString Method
nFileInfo

An Integer value indicating how the file is written:

0 - All the properties of the control and other objects (including appointments) are written.

1 - The appointments will be written. No other objects or control property information is written.

2 - The property information of the control and all objects but appointments is written.

ctxCalendar Object : ReadXMLString Method

Description

Reads the tree data into a memory variable

Syntax

Visual Basic
Public Function ReadXMLString( _
   ByVal nFileInfo As Integer _
) As String

Parameters

nFileInfo

An Integer value indicating how the file is written:

0 - All the properties of the control and other objects (including appointments) are written.

1 - The appointments will be written. No other objects or control property information is written.

2 - The property information of the control and all objects but appointments is written.

Return Type

The XML formatted string.

Remarks

This method is similar to the WriteFile method, but writes the data to a memory variable instead of a file.

ReadXMLString is useful for string handling or passing streams of text via various text-based protocols (such as xmlHTTP)

See Also


%%PageItemTitle%%

RemoveImage Method
nIndex
The 1-based index of the image to remove.
ctxCalendar Object : RemoveImage Method

Description

Removes an image from the internal image list.

Syntax

Visual Basic
Public Function RemoveImage( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the image to remove.

Return Type

A boolean value indicating if the method was successful.

See Also


%%PageItemTitle%%

SelectColumn Method
ctxCalendar Object : SelectColumn Method

Description

Returns the index of the column for the currently selected time cells in the daily view.

Syntax

Visual Basic
Public Function SelectColumn() As Integer

Return Type

1-based index of the column. A value of 0 indicates no selection.

Example

See Also


%%PageItemTitle%%

SelectedDays Method
nIndex
The index value of the selected date to retrieve (relative to the current count of selected dates).
ctxCalendar Object : SelectedDays Method

Description

Returns a currently selected date, based on the supplied index of the total count of selected days.

Syntax

Visual Basic
Public Function SelectedDays( _
   ByVal nIndex As Integer _
) As Date

Parameters

nIndex
The index value of the selected date to retrieve (relative to the current count of selected dates).

Return Type

The date value of the desired selected date.

See Also


%%PageItemTitle%%

SelectEndTime Method
ctxCalendar Object : SelectEndTime Method

Description

Returns the end time for the current selection of time cells in the daily view.

Syntax

Visual Basic
Public Function SelectEndTime() As Integer

Return Type

an integer representing the minutes past midnight.

Remarks

A value of -1 indicates no time cells are currently selected.

See Also


%%PageItemTitle%%

SelectStartTime Method
ctxCalendar Object : SelectStartTime Method

Description

Returns the start time for the current selection of time cells in the daily view.

Syntax

Visual Basic
Public Function SelectStartTime() As Integer

Return Type

an integer representing the minutes past midnight.

Remarks

A value of -1 indicates no time cells are currently selected.

See Also


%%PageItemTitle%%

SetVertScrollToTime Method
nTime
The time value, represented as minutes since midnight, to scroll the control to.
ctxCalendar Object : SetVertScrollToTime Method

Description

Scroll the control, when in daily view, to a specified time.

Syntax

Visual Basic
Public Function SetVertScrollToTime( _
   ByVal nTime As Integer _
) As Boolean

Parameters

nTime
The time value, represented as minutes since midnight, to scroll the control to.

Return Type

Determines whether the operation was successful or not.

Remarks

The control will attempt to place the desired time as the top most time in the display.

See Also


%%PageItemTitle%%

TaskIndexFromCode Method
nCode
The Code of the Task to find
ctxCalendar Object : TaskIndexFromCode Method

Description

Returns the index of a Task in the control based on a Task_Code

Syntax

Visual Basic
Public Function TaskIndexFromCode( _
   ByVal nCode As Integer _
) As Integer

Parameters

nCode
The Code of the Task to find

Return Type

The 1-based index of the Task containing the supplied Code. A value of 0 indicates no Task found with that code.

See Also


%%PageItemTitle%%

TaskIndexFromKeyID Method
strKeyID
The ID value of the task to find
bCase
Determines if the search should be case sensative.
ctxCalendar Object : TaskIndexFromKeyID Method

Description

Returns the index of a Task in the control, based on a supplied ID string.

Syntax

Visual Basic
Public Function TaskIndexFromKeyID( _
   ByVal strKeyID As String, _
   ByVal bCase As Boolean _
) As Integer

Parameters

strKeyID
The ID value of the task to find
bCase
Determines if the search should be case sensative.

Return Type

The 1-based index of the Task containing the supplied ID. A value of 0 indicates no Task found.

See Also


%%PageItemTitle%%

TimeAt Method
nxPoint
The X-coordinate for the time.
nyPoint
The Y-coordinate for the time.
ctxCalendar Object : TimeAt Method

Description

Returns the time value at a specified point.

Syntax

Visual Basic
Public Function TimeAt( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer _
) As Integer

Parameters

nxPoint
The X-coordinate for the time.
nyPoint
The Y-coordinate for the time.

Return Type

An integer value indicating the time value, as represented by minutes since midnight.

Remarks

A value of -1 indicates the all day area or higher.

See Also


%%PageItemTitle%%

TimeSelect Method
nStart
An integer value representing The start time of the selected range, in minutes past midnight
nEnd
An integer value representing The end time of the selected range, in minutes past midnight
nColumn
The 1-based index of the column where the cells will be selected.
ctxCalendar Object : TimeSelect Method

Description

Selects the desired time range in specified column, within the daily view.

Syntax

Visual Basic
Public Sub TimeSelect( _
   ByVal nStart As Integer, _
   ByVal nEnd As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nStart
An integer value representing The start time of the selected range, in minutes past midnight
nEnd
An integer value representing The end time of the selected range, in minutes past midnight
nColumn
The 1-based index of the column where the cells will be selected.

Remarks

Passing a value of -1 (or lower) to either time parameter, or a value of 0 or lower as the column index, will unselect all the cells in the daily view.

See Also


%%PageItemTitle%%

Today Method
ctxCalendar Object : Today Method

Description

Returns the current system date.

Syntax

Visual Basic
Public Function Today() As Date

Return Type

The current system date.

See Also


%%PageItemTitle%%

WriteFile Method
strFileName
The full path name of the xml file. The file name provided to this parameter will be the exact name used to create the file. The control will not automatically create the .xml extension.
nFileInfo

An Integer value indicating how the file is written:

0 - All the properties of the control and other objects (including appointments) are written.

1 - The appointments will be written. No other objects or control property information is written.

2 - The property information of the control and all objects but appointments is written.

ctxCalendar Object : WriteFile Method

Description

Writes the data in ctxCalendar to an xml file.

Syntax

Visual Basic
Public Function WriteFile( _
   ByVal strFileName As String, _
   ByVal nFileInfo As Integer _
) As Boolean

Parameters

strFileName
The full path name of the xml file. The file name provided to this parameter will be the exact name used to create the file. The control will not automatically create the .xml extension.
nFileInfo

An Integer value indicating how the file is written:

0 - All the properties of the control and other objects (including appointments) are written.

1 - The appointments will be written. No other objects or control property information is written.

2 - The property information of the control and all objects but appointments is written.

Return Type

Indicates if the file was generated by the control.

See Also


%%PageItemTitle%%

Year Method
dtDate
The date to retrieve the year from.
ctxCalendar Object : Year Method

Description

Returns the year portion of a supplied date value.

Syntax

Visual Basic
Public Function Year( _
   ByVal dtDate As Date _
) As Integer

Parameters

dtDate
The date to retrieve the year from.

Return Type

The year value of the supplied date.

See Also


%%PageItemTitle%%

AllDayArea Property
ctxCalendar Object : AllDayArea Property

Description

Determines if an all-day appointment area will be visible in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayArea As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

AllDayBackColor Property
ctxCalendar Object : AllDayBackColor Property

Description

Returns/sets the primary color of the background of the all-day area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayBackColor As ULong

Return Type

A ULong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AllDayBackColorTo Property
ctxCalendar Object : AllDayBackColorTo Property

Description

Returns/sets the secondary color of the background of the all-day area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AllDayFillType Property
ctxCalendar Object : AllDayFillType Property

Description

Returns/sets the background pattern of the all-day area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

AllDayHeight Property
ctxCalendar Object : AllDayHeight Property

Description

Returns/sets the height of the all-day area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayHeight As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

AllDayHeightOffset Property
ctxCalendar Object : AllDayHeightOffset Property

Description

Returns/sets the height offset used to calculate the height of an all-day appointment in the day view and regular appointment in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayHeightOffset As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

AllDayMaxApps Property
ctxCalendar Object : AllDayMaxApps Property

Description

Returns/sets the maximum of all-day appointments that can be displayed in the all-day area in the day view at one time.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllDayMaxApps As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

AmPmPosition Property
ctxCalendar Object : AmPmPosition Property

Description

Returns/sets the position of the Am/Pm letters in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AmPmPosition As enumAmPmPosition

Return Type

enumAmPmPosition Enumeration

See Also


%%PageItemTitle%%

AppIndicatorBackColor Property
ctxCalendar Object : AppIndicatorBackColor Property

Description

Returns/sets the primary color of the background of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppIndicatorBackColorTo Property
ctxCalendar Object : AppIndicatorBackColorTo Property

Description

Returns/sets the secondary color of the background of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppIndicatorBorderColor Property
ctxCalendar Object : AppIndicatorBorderColor Property

Description

Returns/sets the border color of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppIndicatorDisabled Property
ctxCalendar Object : AppIndicatorDisabled Property

Description

Returns/sets the disabled text color of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorDisabled As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppIndicatorFillType Property
ctxCalendar Object : AppIndicatorFillType Property

Description

Returns/sets the background pattern of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

AppIndicatorFont Property
ctxCalendar Object : AppIndicatorFont Property

Description

Returns/sets the font of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorFont As Font

Return Type

Font

Remarks

A TrueType font is required for the text to be displayed in the appointment indicators, due to the angle of the displayed text.

See Also


%%PageItemTitle%%

AppIndicatorForeColor Property
ctxCalendar Object : AppIndicatorForeColor Property

Description

Returns/sets the text color of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppIndicatorHeight Property
ctxCalendar Object : AppIndicatorHeight Property

Description

Returns/sets the fixed height of an appointment indicator in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorHeight As Integer

Return Type

Integer (height in pixels)

See Also


%%PageItemTitle%%

AppIndicatorNextText Property
ctxCalendar Object : AppIndicatorNextText Property

Description

Returns/sets the text in the right appointment indicator in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorNextText As String

Return Type

String

See Also


%%PageItemTitle%%

AppIndicatorOffset Property
ctxCalendar Object : AppIndicatorOffset Property

Description

Returns/sets the offset used to calculate the width of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorOffset As Integer

Return Type

Integer

Remarks

The default width of the indicators is determined based on the AppIndicatorFont Property. The developer can adjust that calculated width by assigning either a positive (increase width) or negative (decrease width) value to this property.

See Also


%%PageItemTitle%%

AppIndicatorPosition Property
ctxCalendar Object : AppIndicatorPosition Property

Description

Returns/sets the draw position of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorPosition As enumPosition

Return Type

enumPosition Enumeration

See Also


%%PageItemTitle%%

AppIndicatorPrevText Property
ctxCalendar Object : AppIndicatorPrevText Property

Description

Returns/sets the text in the left appointment indicator in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorPrevText As String

Return Type

String

See Also


%%PageItemTitle%%

AppIndicatorRadius Property
ctxCalendar Object : AppIndicatorRadius Property

Description

Returns/sets the size of the ellipse for the corners of the appointment indicators in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppIndicatorRadius As Integer

Return Type

Integer

Remarks

A value of 0 will display square corners. Higher values will round the corners, and may increase the width of the indicators if needed.

See Also


%%PageItemTitle%%

Appointment_AllDayEvent Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_AllDayEvent Property

Description

Returns/sets if an appointment is considered an AllDay event, and should be displayed in the allday area.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_AllDayEvent( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Boolean

See Also


%%PageItemTitle%%

Appointment_BackColor Property
nIndex
The 1-based index value of the appointment
ctxCalendar Object : Appointment_BackColor Property

Description

Returns/sets the primary background color of the appointment

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the appointment

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If this property is assigned a value of -1, then the background of the appointment will be rendered using the AppointmentBackColor and AppointmentBackColorTo properties.

See Also


%%PageItemTitle%%

Appointment_BackColorTo Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_BackColorTo Property

Description

Returns/sets the secondary background color of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_BackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the appointment.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If the Appointment_BackColor property is assigned a value of -1, then the background of the appointment will be rendered using the AppointmentBackColor and AppointmentBackColorTo properties.

See Also


%%PageItemTitle%%

Appointment_BackImageIndex Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_BackImageIndex Property

Description

Returns/sets the index of the image to use as the background for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_BackImageIndex( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image in the internal image list.

Remarks

The image will be tiled to fill the entire appointment.

See Also


%%PageItemTitle%%

Appointment_BorderColor Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_BorderColor Property

Description

Returns/sets the color used to paint the border around the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_BorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the appointment.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Assigning a value of -1 to this property will cause the control to use the AppointmentBorderColor property instead.

Example

See Also


%%PageItemTitle%%

Appointment_BorderWidth Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_BorderWidth Property

Description

Returns/sets the border width of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_BorderWidth( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Integer

Remarks

Assigning a value of 0 to this property will cause the control to use the AppointmentBorderWidth property instead.

Example

See Also


%%PageItemTitle%%

Appointment_Cargo Property
nIndex
The 1-based index value of the appointment
ctxCalendar Object : Appointment_Cargo Property

Description

Returns/sets a non-visible string value for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Cargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index value of the appointment

Return Type

String

See Also


%%PageItemTitle%%

Appointment_Comment Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_Comment Property

Description

Returns/sets a non-visible string value for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Comment( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

Remarks

This property comes from the VCal format.

See Also


%%PageItemTitle%%

Appointment_ContactCode Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_ContactCode Property

Description

Returns/sets the Code of the Contact associated with this appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ContactCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

Integer value that relates to a Contact_Code value of a Contact in the control.

See Also


%%PageItemTitle%%

Appointment_Count Property
ctxCalendar Object : Appointment_Count Property

Description

Returns the amount of appointment objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

Appointment_Data Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_Data Property

Description

Returns/sets a non-visible Long value for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Data( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

Long

See Also


%%PageItemTitle%%

Appointment_Date Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_Date Property

Description

Returns/sets the date of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Date( _
   ByVal nIndex As Integer _
) As Date

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

Date

See Also


%%PageItemTitle%%

Appointment_FillType Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_FillType Property

Description

Returns/sets the background pattern of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_FillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

enumFillType Enumeration or a value of -1 to ignore the property.

Remarks

A value of -1 will have the control use the AppointmentFillType property instead.

Valid patterns can be found in the enumFillType enumeration.

See Also


%%PageItemTitle%%

Appointment_ForeColor Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_ForeColor Property

Description

Returns/sets the text color of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

A value of -1 will have the control use the AppointmentForeColor property instead.

See Also


%%PageItemTitle%%

Appointment_ImageIndex1 Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_ImageIndex1 Property

Description

Returns/sets the index value of the primary image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex1( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

The 1-based index value of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

See Also


%%PageItemTitle%%

Appointment_ImageIndex2 Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageIndex2 Property

Description

Returns/sets the index value of the secondary image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex2( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index value of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

See Also


%%PageItemTitle%%

Appointment_ImageIndex3 Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageIndex3 Property

Description

Returns/sets the index value of the tertiary image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex3( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

See Also


%%PageItemTitle%%

Appointment_ImageIndex4 Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageIndex4 Property

Description

Returns/sets the index value of the fourth image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex4( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Remarks

Example

See Also


%%PageItemTitle%%

Appointment_ImageIndex5 Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageIndex5 Property

Description

Returns/sets the index value of the fifth image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex5( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

See Also


%%PageItemTitle%%

Appointment_ImageIndex6 Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageIndex6 Property

Description

Returns/sets the index value of the sixth image of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageIndex6( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

See Also


%%PageItemTitle%%

Appointment_ImageSize Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageSize Property

Description

Returns/sets the size used for images displayed in the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageSize( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Integer

Remarks

The value assigned to this property will be used for both the Height and Width of the images.

Assigning a value of 0, will have the images render based on their individual sizes.

Assigning a value of -1 to this property will cause the control to use the AppointmentImageSize property instead.

Example

See Also


%%PageItemTitle%%

Appointment_ImageString Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ImageString Property

Description

Returns/sets a string containing the indexes of the images to display in the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ImageString( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

Remarks

The images defined by this string will be displayed after the Reminder Icon and the ImageIndex1-6 images (if they are defined) in the display.
The delimiter character for the string, is determined by the BreakChar property.

The string can be assigned index values from the internal image list and for the stock images. 1-based index values will represent images from the internal list, while values from -1 to -12 indicate the use of a pre-defined image in the control.

Example

ctxCalendar1.Appointment_ImageString(nIndex) = "-3;5;6;-2"

See Also


%%PageItemTitle%%

Appointment_InfoLinePriority Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_InfoLinePriority Property

Description

Returns/sets if the InfoLineText of an appointment should be shown instead of the Text.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_InfoLinePriority( _
   ByVal nIndex As Integer _
) As enumAppInfoLinePriority

Parameters

nIndex
The 1-based index of the appointment.

Return Type

enumAppInfoLinePriority

Remarks

If an appointment spans only a single time row, by default the Text is displayed. However, setting this property to InfoLine_True will have the InfoLineText displayed instead.

Assigning a value of InfoLine_Default to this property will cause the control to use the InfoLinePriority property instead.

Example

See Also


%%PageItemTitle%%

Appointment_InfoLineText Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_InfoLineText Property

Description

Returns/sets the additional information text for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_InfoLineText( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

Remarks

This string is displayed above the main text for the appointment, and is not editable by the user.

See Also


%%PageItemTitle%%

Appointment_KeyID Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_KeyID Property

Description

Returns/sets a unique ID value for the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_KeyID( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

See Also


%%PageItemTitle%%

Appointment_Location Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_Location Property

Description

Returns/sets a non-visible string for storing the name of a location associated with the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Location( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

Remarks

This property is related to the VCal format.

See Also


%%PageItemTitle%%

Appointment_LocationCode Property
nIndex
The 1-based index value of the appointment.
ctxCalendar Object : Appointment_LocationCode Property

Description

Returns/sets the Code of the Location associated with this appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_LocationCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the appointment.

Return Type

Integer value that relates to a Location_Code value of a Location in the control.

See Also


%%PageItemTitle%%

Appointment_Locked Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_Locked Property

Description

Determines if the appointment is prevented from being moved or resized by user interactions.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Locked( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Boolean

Remarks

When set to true, the appointment cannot be moved or resized by user interaction. The appointment text can still be edited by the user.

See Also


%%PageItemTitle%%

Appointment_ReadOnly Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ReadOnly Property

Description

Determines if the appointment is restricted from all user interactions.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ReadOnly( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Boolean

Remarks

when set to true, the appointment cannot be edited, moved or resized by the user.

See Also


%%PageItemTitle%%

Appointment_ReminderSet Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_ReminderSet Property

Description

Determines if a reminder icon (bell) will be displayed in the top left corner of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_ReminderSet( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Boolean

See Also


%%PageItemTitle%%

Appointment_TaskBarColor Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_TaskBarColor Property

Description

Returns/sets the color of the taskbar (left side) of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_TaskBarColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the appointment.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The size of the TaskBar on the appointments, is determined by the TaskBarWidth property of the control. A value of -1 assigned to this property will have the control use the TaskBarColor property instead.

See Also


%%PageItemTitle%%

Appointment_TaskBarImageIndex Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_TaskBarImageIndex Property

Description

Returns/sets the index of the image from the internal image list, used to paint the TaskBar of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_TaskBarImageIndex( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

The 1-based index of the image from the internal image list.

Remarks

The size of the TaskBar on the appointments, is determined by the TaskBarWidth property of the control. The image will be tiled to fill the available space.

See Also


%%PageItemTitle%%

Appointment_TaskCode Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_TaskCode Property

Description

Returns/sets the Code of the Task associated with this appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_TaskCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Integer value that relates to a Task_Code value of a Task in the control.

See Also


%%PageItemTitle%%

Appointment_Text Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_Text Property

Description

Returns/sets the text of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_Text( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

String

See Also


%%PageItemTitle%%

Appointment_TimeEnd Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_TimeEnd Property

Description

Returns/sets the end time of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_TimeEnd( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Integer representing the number of minutes since midnight.

See Also


%%PageItemTitle%%

Appointment_TimeStart Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_TimeStart Property

Description

Returns/sets the start time of the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_TimeStart( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the appointment.

Return Type

Integer representing the number of minutes since midnight.

See Also


%%PageItemTitle%%

Appointment_vCalInfo Property
nIndex
The 1-based index of the appointment.
ctxCalendar Object : Appointment_vCalInfo Property

Description

Returns/sets a vCal formatted string related to the appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Appointment_vCalInfo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the appointment.

Return Type

vCal formatted string

See Also


%%PageItemTitle%%

AppointmentBackColor Property
ctxCalendar Object : AppointmentBackColor Property

Description

Returns/sets the default primary color of the background of appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

AppointmentBackColorTo Property
ctxCalendar Object : AppointmentBackColorTo Property

Description

Returns/sets the default secondary color of the background of appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppointmentBorderColor Property
ctxCalendar Object : AppointmentBorderColor Property

Description

Returns/sets the default border color of appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

AppointmentBorderWidth Property
ctxCalendar Object : AppointmentBorderWidth Property

Description

Returns/sets the default border width of appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentBorderWidth As Integer

Return Type

Integer

Remarks

Example

See Also


%%PageItemTitle%%

AppointmentEditWeekMonth Property
ctxCalendar Object : AppointmentEditWeekMonth Property

Description

Returns/sets if the text of an appointment can be edited in the weekly/monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentEditWeekMonth As Boolean

Return Type

Boolean

Remarks

When set to True, double clicking an appointment (or single clicking a currently selected apppointment) will place an edit window over the entire date and allow the user to edit the text of the appointment.

See Also


%%PageItemTitle%%

AppointmentFillType Property
ctxCalendar Object : AppointmentFillType Property

Description

Returns/sets the default background pattern for appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

AppointmentFont Property
ctxCalendar Object : AppointmentFont Property

Description

Returns/sets the Font for the text in the appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

AppointmentForeColor Property
ctxCalendar Object : AppointmentForeColor Property

Description

Returns/sets the default color used to paint text in the appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

AppointmentHeightOffset Property
ctxCalendar Object : AppointmentHeightOffset Property

Description

Returns/sets the height offset used to calculate the height of a regular appointment in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentHeightOffset As Integer

Return Type

Integer value indicating the height offset in pixels.

See Also


%%PageItemTitle%%

AppointmentImageSize Property
ctxCalendar Object : AppointmentImageSize Property

Description

Returns/sets the default size used for images displayed in the appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentImageSize As Integer

Return Type

Integer

Remarks

The value assigned to this property will be used for both the Height and Width of the images.

Assigning a value of 0, will have the images render based on their individual sizes.

Example

See Also


%%PageItemTitle%%

AppointmentItemMargin Property
ctxCalendar Object : AppointmentItemMargin Property

Description

Returns/sets the distance separating images in the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentItemMargin As Integer

Return Type

Integer value indicating the margin in pixels.

See Also


%%PageItemTitle%%

AppointmentMargin Property
ctxCalendar Object : AppointmentMargin Property

Description

Returns/sets the distance between appointments in the all-day area of a day view and the dates in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentMargin As Integer

Return Type

Integer value indicating the margin in pixels.

See Also


%%PageItemTitle%%

AppointmentRadius Property
ctxCalendar Object : AppointmentRadius Property

Description

Returns/sets the size of the ellipse for the corners of the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentRadius As Integer

Return Type

Integer

Remarks

A value of 0 will give the appointments square corners.

Example

See Also


%%PageItemTitle%%

AppointmentScroll Property
ctxCalendar Object : AppointmentScroll Property

Description

Determines if clicking arrows in the all-day area (day view) or dates (month and week views) will scroll the appointments displayed there.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentScroll As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

AppointmentSelected Property
ctxCalendar Object : AppointmentSelected Property

Description

Returns/sets the index value of the selected appointment in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentSelected As Integer

Return Type

Integer value indicating the 1-based index of the selected appointment.

Remarks

A value of 0 indicates there is no currently selected appointment.

Example

See Also


%%PageItemTitle%%

AppointmentSelectedBorderColor Property
ctxCalendar Object : AppointmentSelectedBorderColor Property

Description

Returns/sets the default color used to paint the border of a selected appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentSelectedBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

This property does not apply to appointments in the daily view that are Appointment_ReadOnly = True.

Example

See Also


%%PageItemTitle%%

AppointmentSelectedBorderWidth Property
ctxCalendar Object : AppointmentSelectedBorderWidth Property

Description

Returns/sets the width of the border painted around a selected appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentSelectedBorderWidth As Integer

Return Type

Integer

Remarks

This property does not apply to appointments in the daily view that are Appointment_ReadOnly = True.

Example

See Also


%%PageItemTitle%%

AppointmentShadows Property
ctxCalendar Object : AppointmentShadows Property

Description

Determines if a shadow effect will appear on the appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentShadows As Boolean

Return Type

Boolean

Example

See Also


%%PageItemTitle%%

AppointmentShowTime Property
ctxCalendar Object : AppointmentShowTime Property

Description

Returns/sets how the starting and ending time of the appointments will be displayed in themselves.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentShowTime As enumShowTimes

Return Type

enumShowTimes Enumeration

See Also


%%PageItemTitle%%

AppointmentType Property
ctxCalendar Object : AppointmentType Property

Description

Returns/sets the main filter of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AppointmentType As enumAppointmentType

Return Type

enumAppointmentType Enumeration

See Also


%%PageItemTitle%%

ArrowBackColor Property
ctxCalendar Object : ArrowBackColor Property

Description

Returns/sets the background color of the appointment arrows in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ArrowBorderColor Property
ctxCalendar Object : ArrowBorderColor Property

Description

Returns/sets the border color of the appointment arrows in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ArrowDown Property
ctxCalendar Object : ArrowDown Property

Description

Returns/sets the image used to represent a down appointment arrow in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowDown As Picture

Return Type

Picture

See Also


%%PageItemTitle%%

ArrowPosition Property
ctxCalendar Object : ArrowPosition Property

Description

Returns/sets the position of the arrows in the main portion of the control when displaying a day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowPosition As enumArrowPosition

Return Type

enumArrowPosition Enumeration

See Also


%%PageItemTitle%%

ArrowUp Property
ctxCalendar Object : ArrowUp Property

Description

Returns/sets the image used to represent an up appointment arrow in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowUp As Picture

Return Type

Picture

See Also


%%PageItemTitle%%

BackColor Property
ctxCalendar Object : BackColor Property

Description

Returns/sets the background color of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

BorderColor Property
ctxCalendar Object : BorderColor Property

Description

Returns/sets the border color of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

BreakChar Property
ctxCalendar Object : BreakChar Property

Description

Returns/sets the character used to separate the values contained in a string.

Property type

Read-write property

Syntax

Visual Basic
Public Property BreakChar As String

Return Type

String

Remarks

This property is currently used to separate the values contained in a string assigned to the Appointment_ImageString property of an appointment in the control.

While the property supports a string value, only the first character of the supplied string will be used.

The BreakChar property is case sensitive.

If no value is assigned to this property, the control will use a default value of ";" for internal calculations.

Example

See Also


%%PageItemTitle%%

CalendarColumns Property
ctxCalendar Object : CalendarColumns Property

Description

Returns/sets the maximum amount of calendars that can be seen at once in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CalendarColumns As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

CalendarSeparatorWidth Property
ctxCalendar Object : CalendarSeparatorWidth Property

Description

Returns/sets the distance between multiple calendars in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CalendarSeparatorWidth As Integer

Return Type

Integer value indicating the width in pixels.

See Also


%%PageItemTitle%%

CellColor Property
ctxCalendar Object : CellColor Property

Description

Sets the color to be used when painting a cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellColor As ULong

Return Type

Property is write only.

Remarks

This property is only valid when assigned a value in the UserDrawnColorCell event

See Also


%%PageItemTitle%%

CellFont Property
ctxCalendar Object : CellFont Property

Description

Returns/sets the default font used to draw text in cells of the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellFont As Font

Return Type

Font

Remarks

This is the value that will be assigned to the CellTextFont Property before the UserDrawnCellText Event is fired. The developer can then override the CellTextFont Property during that event if they wish to use a different font to display the text.

See Also


%%PageItemTitle%%

CellForeColor Property
ctxCalendar Object : CellForeColor Property

Description

Returns/sets the default color used to draw text in the cells of the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

This is the value that will be assigned to the CellTextColor Property before the UserDrawnCellText Event is fired. The developer can then override the CellTextColor Property during that event if they wish to use a different color to display the text.

See Also


%%PageItemTitle%%

CellText Property
ctxCalendar Object : CellText Property

Description

Sets the text to be drawn in a cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellText As String

Return Type

String (WriteOnly property)

Remarks

This property will only have an effect if assigned a value within the UserDrawnCellText Event. The default value is an empty string, indicating no text will be written in the cell.

See Also


%%PageItemTitle%%

CellTextAlign Property
ctxCalendar Object : CellTextAlign Property

Description

Sets the horizontal alignment of the text within the cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellTextAlign As enumAlignment

Return Type

enumAlignment (WriteOnly property)

Remarks

This property is only valid when assigned a value inside the UserDrawnCellText Event. The default value of the property is 0 (indicating left alignment). The property will reset to its default value each time the event is fired.

See Also


%%PageItemTitle%%

CellTextColor Property
ctxCalendar Object : CellTextColor Property

Description

Sets the color of the text within the cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellTextColor As ULong

Return Type

A Ulong value representing an OLE_COLOR (WriteOnly Property)

Remarks

This property is only valid when assigned a value inside the UserDrawnCellText Event. The default value of the property is the current value of the CellForeColor Property. The property will reset to its default value each time the event is fired.

See Also


%%PageItemTitle%%

CellTextEllipsis Property
ctxCalendar Object : CellTextEllipsis Property

Description

Determines if the cell text should display ellipsis if it is too long to fit in the cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellTextEllipsis As Boolean

Return Type

Boolean (WriteOnly property)

Remarks

This property is only valid when assigned a value inside the UserDrawnCellText Event. The default value of the property is False. The property will reset to its default value each time the event is fired.

See Also


%%PageItemTitle%%

CellTextFont Property
ctxCalendar Object : CellTextFont Property

Description

Sets the font to use for displaying the text within the cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellTextFont As Font

Return Type

Font (WriteOnly property)

Remarks

This property is only valid when assigned a value inside the UserDrawnCellText Event. The default value of the property is the current value of the CellFont Property. The property will reset to its default value each time the event is fired.

See Also


%%PageItemTitle%%

CellTextMultiline Property
ctxCalendar Object : CellTextMultiline Property

Description

Determines if the text in the cell should support multiple lines (either due to length of the text or break characters).

Property type

Read-write property

Syntax

Visual Basic
Public Property CellTextMultiline As Boolean

Return Type

Boolean (WriteOnly property)

Remarks

This property is only valid when assigned a value inside the UserDrawnCellText Event. The default value of the property is False. The property will reset to its default value each time the event is fired.

When displaying the text as a single line (default) the text is vertically centered within the cell. When this property is set to True, the text is vertically aligned to the top of the cell.

See Also


%%PageItemTitle%%

ColumnBarBackColor Property
ctxCalendar Object : ColumnBarBackColor Property

Description

Returns/sets the color of the separators, in the time area, of the columns in a day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnBarBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ColumnBarWidth Property
ctxCalendar Object : ColumnBarWidth Property

Description

Returns/sets the width of the separators, in the time area, of the columns in a day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnBarWidth As Integer

Return Type

Integer indicating the width in pixels.

See Also


%%PageItemTitle%%

ColumnLineWide Property
ctxCalendar Object : ColumnLineWide Property

Description

Determines if the line between columns in the day view should be painted in a thicker manner.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnLineWide As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

ConflictOffset Property
ctxCalendar Object : ConflictOffset Property

Description

Returns/sets the amount of time (in minutes) used to offset the length of an appointment when doing conflict searches.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConflictOffset As Integer

Return Type

Integer indicating the number of minutes to offset the conflict testing.

Remarks

Negative values indicate an overlap can exist without reporting a conflict, positive values mean the conflict can be triggered before the overlap occurs.

A value of -15 would allow appointments to overlap by up to 15 minutes before a conflict was reported, while a value of 15 would trigger a conflict when the appointments are within 15 minutes of each other or less.

This offset is used when performing conflict searches in the control using the FindFirstConflict Method and FindNextConflict Method.

See Also


%%PageItemTitle%%

Contact_AllDayBackColor Property
nIndex
The 1-based index of the contact.
ctxCalendar Object : Contact_AllDayBackColor Property

Description

Returns/sets the color of the allday area when displaying a column by Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_AllDayBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_BackColor Property
nIndex
The 1-based index of the Contact
ctxCalendar Object : Contact_BackColor Property

Description

Returns/sets the background color used to paint the weekly and monthly calendars for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_BorderColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_BorderColor Property

Description

Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_BorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_Cargo Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_Cargo Property

Description

Returns/sets a non-visible string value for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_Cargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Contact.

Return Type

String

See Also


%%PageItemTitle%%

Contact_Code Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_Code Property

Description

Returns/sets the unique code for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_Code( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Contact.

Return Type

Integer

Remarks

This is the value that will be assigned to an appointment to match it with the Contact.

See Also


%%PageItemTitle%%

Contact_Count Property
ctxCalendar Object : Contact_Count Property

Description

Returns the amount of contact objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

Contact_DateHeaderBackColor Property
nIndex
The 1-based index of the Contact
ctxCalendar Object : Contact_DateHeaderBackColor Property

Description

Returns/sets the primary background color of the date and column headers for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_DateHeaderBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Contact_DateHeaderBackColorTo Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_DateHeaderBackColorTo Property

Description

Returns/sets the secondary background color of the date and column headers for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_DateHeaderBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Contact_DateHeaderBorderColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_DateHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the date and column headers for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_DateHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Contact_DateHeaderFillType Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_DateHeaderFillType Property

Description

Returns/sets the pattern used to paint the background of the date and column headers for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_DateHeaderFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Contact.

Return Type

enumFillType Enumeration

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Contact_DateHeaderForeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_DateHeaderForeColor Property

Description

Returns/sets the color used to paint the text in the date and column headers for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_DateHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Contact_Image Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_Image Property

Description

Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_Image( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Contact.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

See Also


%%PageItemTitle%%

Contact_KeyID Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_KeyID Property

Description

Returns/sets the unique ID for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_KeyID( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Contact.

Return Type

String

Remarks

This property is an excellent spot to store the ID value of the Contact from the database.

See Also


%%PageItemTitle%%

Contact_MonthEvenBackColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_MonthEvenBackColor Property

Description

Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_MonthEvenBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_MonthHeaderBorderColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_MonthHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the Month names in a Monthly view for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_MonthHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The type of border is determined by the MonthHeaderBorderStyle Property.

See Also


%%PageItemTitle%%

Contact_MonthHeaderForeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_MonthHeaderForeColor Property

Description

Returns/sets the color used to paint the text of the month names in a monthly view for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_MonthHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_MonthOddBackColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_MonthOddBackColor Property

Description

Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_MonthOddBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_NonPrimeTimeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_NonPrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_NonPrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Contact_PrimeTimeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_PrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of prime time in the daily view for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_PrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Contact_SelectedBackColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_SelectedBackColor Property

Description

Returns/sets the color used to paint a selected date or time cell for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_SelectedBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_SelectedForeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_SelectedForeColor Property

Description

Returns/sets the color used to paint the text in a selected date for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_SelectedForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_Text Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_Text Property

Description

Returns/sets the text associated with the Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_Text( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Contact.

Return Type

String

Remarks

The Text will be displayed in the column header in daily views, and as the title text in the weekly and monthly views.

See Also


%%PageItemTitle%%

Contact_TitleForeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_TitleForeColor Property

Description

Returns/sets the color used to paint the title text in the weekly and monthly views for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_TitleForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_WeekendBackColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_WeekendBackColor Property

Description

Returns/sets the background color of the weekend dates for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekendBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_WeekSummaryBackColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_WeekSummaryBackColor Property

Description

Returns/sets the primary background color of the weeksummary areas for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekSummaryBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_WeekSummaryBackColorTo Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_WeekSummaryBackColorTo Property

Description

Returns/sets the secondary background color of the weeksummary areas for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekSummaryBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_WeekSummaryBorderColor Property
nIndex
The 1-based index.
ctxCalendar Object : Contact_WeekSummaryBorderColor Property

Description

Returns/sets the color used to paint the border around each weeksummary area for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekSummaryBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Contact_WeekSummaryFillType Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_WeekSummaryFillType Property

Description

Returns/sets the pattern used to paint the background of the weeksummary areas for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekSummaryFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Contact.

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

Contact_WeekSummaryForeColor Property
nIndex
The 1-based index of the Contact.
ctxCalendar Object : Contact_WeekSummaryForeColor Property

Description

Returns/sets the color used to paint the text in the weeksummary areas for a Contact.

Property type

Read-write property

Syntax

Visual Basic
Public Property Contact_WeekSummaryForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Contact.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

ControlStyle Property
ctxCalendar Object : ControlStyle Property

Description

Specifies the new setting for other properties so that the control mimics a certain style.

Property type

Read-write property

Syntax

Visual Basic
Public Property ControlStyle As enumControlStyle

Return Type

enumControlStyle Enumeration

Remarks

This property is not a true property in that it does not store a value. Instead, it acts more like a method because it acts upon other properties. This property always returns a value of 0.

See Also


%%PageItemTitle%%

CurrentShadowColor Property
ctxCalendar Object : CurrentShadowColor Property

Description

Returns/sets the current time line shadow (trailing) color in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentShadowColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

A value of -1 will hide the shadow effect.

See Also


%%PageItemTitle%%

CurrentTimeColor Property
ctxCalendar Object : CurrentTimeColor Property

Description

Returns/sets the current time line color in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentTimeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

CurrentTimeLine Property
ctxCalendar Object : CurrentTimeLine Property

Description

Determines if the current time line will be displayed in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentTimeLine As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

CustomArea_BackColor Property
nIndex
The 1-based index of the CustomArea
ctxCalendar Object : CustomArea_BackColor Property

Description

Returns/sets the color used to paint the background of a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the CustomArea

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

CustomArea_Cargo Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_Cargo Property

Description

Returns/sets a non visible string value for the CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_Cargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

String

See Also


%%PageItemTitle%%

CustomArea_ContactCode Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_ContactCode Property

Description

Returns/sets the Contact code associated with a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_ContactCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Integer

Remarks

The value assigned to this property should match a Contact_Code Property value currently loaded in the control.

See Also


%%PageItemTitle%%

CustomArea_Count Property
ctxCalendar Object : CustomArea_Count Property

Description

Returns the amount of custom area objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

CustomArea_Daily Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_Daily Property

Description

Determines if the CustomArea will repeat daily.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_Daily( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Boolean

See Also


%%PageItemTitle%%

CustomArea_Date Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_Date Property

Description

Returns/sets the date associated with the CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_Date( _
   ByVal nIndex As Integer _
) As Date

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Date

See Also


%%PageItemTitle%%

CustomArea_DeadZone Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_DeadZone Property

Description

Determines if the CustomArea will be treated as a DeadZone.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_DeadZone( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Boolean

Remarks

DeadZones indicate areas of the control that appointments cannot be created, moved to, or sized over.

See Also


%%PageItemTitle%%

CustomArea_LocationCode Property
nIndex
The 1-based index of the CustomArea
ctxCalendar Object : CustomArea_LocationCode Property

Description

Returns/sets the Location code associated with a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_LocationCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the CustomArea

Return Type

Integer

Remarks

The value assigned to this property should match a Location_Code Property value currently loaded in the control.

See Also


%%PageItemTitle%%

CustomArea_TaskCode Property
nIndex
The 1-based index of the CustomArea
ctxCalendar Object : CustomArea_TaskCode Property

Description

Returns/sets the Task code associated with a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_TaskCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the CustomArea

Return Type

Integer

Remarks

The value assigned to this property should match a Task_Code Property value currently loaded in the control.

See Also


%%PageItemTitle%%

CustomArea_TimeEnd Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_TimeEnd Property

Description

Returns/sets the ending time of a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_TimeEnd( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Integer indicating the number of minute since midnight.

See Also


%%PageItemTitle%%

CustomArea_TimeStart Property
nIndex
The 1-based index of the CustomArea.
ctxCalendar Object : CustomArea_TimeStart Property

Description

Returns/sets the starting time of a CustomArea.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomArea_TimeStart( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the CustomArea.

Return Type

Integer indicating the number of minutes since midnight.

See Also


%%PageItemTitle%%

CustomAreasFilter Property
ctxCalendar Object : CustomAreasFilter Property

Description

Returns/sets how the control will determine when CustomAreas will be rendered in the display, based on their properties.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomAreasFilter As enumCustomAreasFilter

Return Type

enumCustomAreasFilter

See Also


%%PageItemTitle%%

CustomColor1 Property
ctxCalendar Object : CustomColor1 Property

Description

Returns/sets the primary color used by the Custom_Flat option of the ControlStyle Property.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomColor1 As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

CustomColor2 Property
ctxCalendar Object : CustomColor2 Property

Description

Returns/sets the secondary color used by the Custom_Flat option of the ControlStyle Property.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomColor2 As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

CustomColor3 Property
ctxCalendar Object : CustomColor3 Property

Description

Returns/sets the tertiary color used by the Custom_Flat option of the ControlStyle Property.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomColor3 As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

CustomMenu Property
ctxCalendar Object : CustomMenu Property

Description

Determines if the default context menu will be displayed when the user right clicks in the edit window of the selected appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomMenu As Boolean

Return Type

Boolean

Remarks

If this property is set to False, the default menu will be displayed. If it is set to True, it will not be displayed and the DisplayMenu Event will be fired instead.

Example

See Also


%%PageItemTitle%%

Date Property
ctxCalendar Object : Date Property

Description

Returns/sets the selected date for the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property Date As Date

Return Type

Date

Remarks

A value of -1 indicates no date is selected in the control.

See Also


%%PageItemTitle%%

DateEnd Property
ctxCalendar Object : DateEnd Property

Description

Returns/sets the ending date for the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateEnd As Date

Return Type

Date

See Also


%%PageItemTitle%%

DateFormat Property
ctxCalendar Object : DateFormat Property

Description

Returns/sets how the dates will be formatted into text in the daily view date columns.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateFormat As String

Return Type

Formatted string

Remarks

d or D = Full text name of the day of the week
M = Full month name
m = 2-digit month number (leading zero when needed)
N = Day of the month with leading zero
n = Day of the month without leading zero.
Y = 4-digit year
y = 2-digit year.

See Also


%%PageItemTitle%%

DateHeaderBackColor Property
ctxCalendar Object : DateHeaderBackColor Property

Description

Returns/sets the primary background color of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderBackColorTo Property
ctxCalendar Object : DateHeaderBackColorTo Property

Description

Returns/sets the secondary background color of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderBorderColor Property
ctxCalendar Object : DateHeaderBorderColor Property

Description

Returns/sets the border color of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderBorderType Property
ctxCalendar Object : DateHeaderBorderType Property

Description

Returns/sets the border type of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderBorderType As enumBorderType

Return Type

enumBorderType Enumeration

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderFillType Property
ctxCalendar Object : DateHeaderFillType Property

Description

Returns/sets the background pattern of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderFillType As enumFillType

Return Type

enumFillType Enumeration

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderFont Property
ctxCalendar Object : DateHeaderFont Property

Description

Returns/sets the font used for the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

DateHeaderForeColor Property
ctxCalendar Object : DateHeaderForeColor Property

Description

Returns/sets the text color of the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderHeight Property
ctxCalendar Object : DateHeaderHeight Property

Description

Returns/sets the height of the date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderHeight As Integer

Return Type

Integer value indicating the height in pixels.

Remarks

The DateHeaders Property needs to be true for this property to affect the weekly and monthly views.

See Also


%%PageItemTitle%%

DateHeaderImageAlign Property
ctxCalendar Object : DateHeaderImageAlign Property

Description

Returns/sets the horizontal image alignment for the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderImageAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

DateHeaders Property
ctxCalendar Object : DateHeaders Property

Description

Determines if a header will be drawn in the dates in the weekly and monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaders As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

DateHeaderText Property
ctxCalendar Object : DateHeaderText Property

Description

Sets the text to be written in the header of a date in the weekly/monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderText As String

Return Type

String (WriteOnly property)

Remarks

This property will only have an effect if assigned a value within the UserDrawnDateHeaderText Event. The default value is the same as the value passed to the event in the strText parameter.

See Also


%%PageItemTitle%%

DateHeaderTextAlign Property
ctxCalendar Object : DateHeaderTextAlign Property

Description

Returns/sets the horizontal text alignment for the column headers in the day view and date headers in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderTextAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

DateHeaderTextColor Property
ctxCalendar Object : DateHeaderTextColor Property

Description

Gets/sets the color used to draw the text in a date header.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHeaderTextColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

This property is only effective when used in the UserDrawnDateHeaderText Event.

See Also


%%PageItemTitle%%

DateHorzLines Property
ctxCalendar Object : DateHorzLines Property

Description

Returns/sets the thickness of horizontal lines separating the date rows in the month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateHorzLines As enumDateHorzLines

Return Type

enumDateHorzLines Enumeration

See Also


%%PageItemTitle%%

DateRows Property
ctxCalendar Object : DateRows Property

Description

Returns/sets the amount of date rows to display at one time in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateRows As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

DateSelectType Property
ctxCalendar Object : DateSelectType Property

Description

Returns/sets how a selected date will appear in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateSelectType As enumDateSelectType

Return Type

enumDateSelectType Enumeration

See Also


%%PageItemTitle%%

DateStart Property
ctxCalendar Object : DateStart Property

Description

Returns/sets the starting date for the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateStart As Date

Return Type

Date

See Also


%%PageItemTitle%%

DateXOffset Property
ctxCalendar Object : DateXOffset Property

Description

Returns/sets the horizontal offset used to calculate the position of the date text in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateXOffset As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the text to the right, while a negative value will shift the text to the left.

See Also


%%PageItemTitle%%

DateYOffset Property
ctxCalendar Object : DateYOffset Property

Description

Returns/sets the vertical offset used to calculate the position of the date text in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateYOffset As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the text down, while a negative value will shift the text up.

See Also


%%PageItemTitle%%

DayBorderColor Property
ctxCalendar Object : DayBorderColor Property

Description

Returns/sets the color used to paint the border of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DayColumns Property
ctxCalendar Object : DayColumns Property

Description

Returns/sets the maximum number of columns displayed in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayColumns As Integer

Return Type

Integer

Remarks

The columns in the daily view have a minimum width of 28 pixels.

See Also


%%PageItemTitle%%

DayFormat_BackColor Property
nIndex
The 1-based index of the DayFormat
ctxCalendar Object : DayFormat_BackColor Property

Description

Returns/sets the primary background color used to paint the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the DayFormat

Return Type

A ULong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DayFormat_BackColorTo Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_BackColorTo Property

Description

Returns/sets the secondary background color used to paint the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_BackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

A ULong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DayFormat_ContactCode Property
nIndex
The 1-based index of the DayFormat
ctxCalendar Object : DayFormat_ContactCode Property

Description

Returns/sets the Contact code associated with the DayFormat

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ContactCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat

Return Type

Integer value that relates to a Contact_Code value of a Contact in the control.

See Also


%%PageItemTitle%%

DayFormat_Count Property
ctxCalendar Object : DayFormat_Count Property

Description

Returns the amount of day format objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

DayFormat_Date Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_Date Property

Description

Returns/sets the date to apply the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_Date( _
   ByVal nIndex As Integer _
) As Date

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Date

See Also


%%PageItemTitle%%

DayFormat_Enabled Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_Enabled Property

Description

Determines if the date is enabled for selection when applied with the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_Enabled( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Boolean

See Also


%%PageItemTitle%%

DayFormat_FillType Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_FillType Property

Description

Returns/sets the background pattern used to paint the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_FillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

DayFormat_ForeColor Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_ForeColor Property

Description

Returns/sets the color used to paint the text of the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

A ULong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DayFormat_ImageAlign Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_ImageAlign Property

Description

Returns/sets the alignment of the image of the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ImageAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value from 0 to 8.

Remarks

0 - TopLeft
1 - TopCenter
2 - TopRight
3 - MiddleLeft
4 - MiddleCenter
5 - MiddleRight
6 - BottomLeft
7 - BottomCenter
8 - BottomRight

See Also


%%PageItemTitle%%

DayFormat_ImageIndex Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_ImageIndex Property

Description

Returns/sets the index of the image from the internal image list to display in the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ImageIndex( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

See Also


%%PageItemTitle%%

DayFormat_ImageXOffset Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_ImageXOffset Property

Description

Returns/sets an X coordinate offset (in pixels) for the display of the image in the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ImageXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value indicating the offset in pixels.

Remarks

Positive values move the image to the right, negative values move the image to the left.

See Also


%%PageItemTitle%%

DayFormat_ImageYOffset Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_ImageYOffset Property

Description

Returns/sets a Y coordinate offset (in pixels) for the display of the image in the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_ImageYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value indicating the offset in pixels.

Remarks

Positive values move the image down, negative values move the image up.

See Also


%%PageItemTitle%%

DayFormat_LocationCode Property
nIndex
The 1-based index of the DayFormat
ctxCalendar Object : DayFormat_LocationCode Property

Description

Returns/sets the Location code associated with the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_LocationCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat

Return Type

Integer value that relates to a Location_Code value of a Location in the control.

See Also


%%PageItemTitle%%

DayFormat_TaskCode Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_TaskCode Property

Description

Returns/sets the Task code associated with the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_TaskCode( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value that relates to a Task_Code value of a Task in the control.

See Also


%%PageItemTitle%%

DayFormat_Text Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_Text Property

Description

Returns/sets the text to display in the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_Text( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

String

See Also


%%PageItemTitle%%

DayFormat_TextAlign Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_TextAlign Property

Description

Returns/sets the horizontal alignment of the DayFormat text.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_TextAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

DayFormat_TextXOffset Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_TextXOffset Property

Description

Returns/sets an X coordinate offset for the display of the text in the DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_TextXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value indicating the offset in pixels.

Remarks

Positive values move the text to the right, negative values move the text to the left.

See Also


%%PageItemTitle%%

DayFormat_TextYOffset Property
nIndex
The 1-based index of the DayFormat.
ctxCalendar Object : DayFormat_TextYOffset Property

Description

Returns/sets a Y coordinate offset for the display of the text in a DayFormat.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormat_TextYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the DayFormat.

Return Type

Integer value indicating the offset in pixels.

Remarks

Positive values move the text down, negative values move the text up.

See Also


%%PageItemTitle%%

DayFormatFont Property
ctxCalendar Object : DayFormatFont Property

Description

Returns/sets the Font used to display text in DayFormats.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormatFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

DayFormatForeColor Property
ctxCalendar Object : DayFormatForeColor Property

Description

Returns/sets the default color used to paint text in DayFormats.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayFormatForeColor As ULong

Return Type

A ULong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DayNames Property
ctxCalendar Object : DayNames Property

Description

Returns/sets the names of the day of the week.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayNames As String

Return Type

Semicolon separated values.

Remarks

This is a single string value, with the individual names of the days separated by semi-colons.

Example:

Sunday;Monday;Tuesday;Wednesday;Thursday;Friday;Saturday

See Also


%%PageItemTitle%%

DayViewHeader Property
ctxCalendar Object : DayViewHeader Property

Description

Determines if column headers will be visible in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayViewHeader As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

DayViewHeaderHeight Property
ctxCalendar Object : DayViewHeaderHeight Property

Description

Returns/sets the height of the column headers in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayViewHeaderHeight As Integer

Return Type

Integer value indicating the height in pixels.

See Also


%%PageItemTitle%%

DisabledForeColor Property
ctxCalendar Object : DisabledForeColor Property

Description

Returns/sets the text color of disabled days and dates outside the date range in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisabledForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

DragBackColor Property
ctxCalendar Object : DragBackColor Property

Description

Returns/sets the background color of a time cell (day view) or date (month and week views) when an item is being dragged over the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property DragBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

EditBackColor Property
ctxCalendar Object : EditBackColor Property

Description

Returns/sets the color used to paint the background of the edit window used for appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

EditForeColor Property
ctxCalendar Object : EditForeColor Property

Description

Returns/sets the color used to paint the text of the edit window used for appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

EditWindowFillsAppointment Property
ctxCalendar Object : EditWindowFillsAppointment Property

Description

Determines if the edit window will always cover the entire appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditWindowFillsAppointment As Boolean

Return Type

Boolean

Remarks

This property is only applicable for appointments that span multiple lines in the daily view.

When set to True, the edit window will cover the entire appointment rectangle.

When set to False, if the appointment has images and/or Appointment_InfoLineText they will still display during the edit process, while the edit window will use the remaining space.

Example

See Also


%%PageItemTitle%%

EditXOffset Property
ctxCalendar Object : EditXOffset Property

Description

Returns/sets the horizontal offset used to calculate the width of an edit box when an appointment is in edit mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditXOffset As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

Positive values will extend the width of the edit window, negative values will reduce it.

See Also


%%PageItemTitle%%

Enabled Property
ctxCalendar Object : Enabled Property

Description

Determines if the control will react to user interactions.

Property type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

EnablePressHoldGesture Property
ctxCalendar Object : EnablePressHoldGesture Property

Description

Determines if the control will respond to the "Press and Hold" gesture in a touch interface.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnablePressHoldGesture As Boolean

Return Type

Boolean

Remarks

For performance reasons Microsoft has disabled the "Press and Hold" gesture in MFC based code. Setting this property to True, will allow the control to recognize the gesture and interpret it as a right-click.

Enable Tablet press-and-fold gesture in MFC applications (external link)

Example

See Also


%%PageItemTitle%%

EnterKey Property
ctxCalendar Object : EnterKey Property

Description

Returns/sets how the Enter key will be used when typing data into an appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property EnterKey As enumEnterKey

Return Type

enumEnterKey Enumeration

See Also


%%PageItemTitle%%

FirstDayOfWeek Property
ctxCalendar Object : FirstDayOfWeek Property

Description

Returns/sets the first day of the week to start a calendar in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstDayOfWeek As enumDayOfWeek

Return Type

enumDayOfWeek Enumeration

See Also


%%PageItemTitle%%

GroupType Property
ctxCalendar Object : GroupType Property

Description

Returns/sets the secondary filter of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property GroupType As enumGroupType

Return Type

enumGroupType Enumeration

Remarks

This property is only applicable when displaying the control in a day view. This property is not user by the monthly or weekly views.

See Also


%%PageItemTitle%%

HorzScrollMax Property
ctxCalendar Object : HorzScrollMax Property

Description

Returns the maximum value or range of the horizontal scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScrollMax As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

HorzScrollPos Property
ctxCalendar Object : HorzScrollPos Property

Description

Returns/sets the value or position of the horizontal scroll bar of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScrollPos As Integer

Return Type

Integer value from 0 to HorzScrollMax.

See Also


%%PageItemTitle%%

HorzScrollVisible Property
ctxCalendar Object : HorzScrollVisible Property

Description

Determines if the horizontal scroll bar for the control will be visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScrollVisible As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

HourFont Property
ctxCalendar Object : HourFont Property

Description

Returns/sets the font for the hour values in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property HourFont As Font

Return Type

Font

Remarks

Only used when TimeType Property is set to Split.

See Also


%%PageItemTitle%%

HourFontXOffset Property
ctxCalendar Object : HourFontXOffset Property

Description

Returns/sets the horizontal offset used to calculate the position of the hour values in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property HourFontXOffset As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the text right, while a negative value will shift the text left

Only used when TimeType Property is set to Split.

See Also


%%PageItemTitle%%

HourFontYOffset Property
ctxCalendar Object : HourFontYOffset Property

Description

Returns/sets the vertical offset used to calculate the position of the hour values in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property HourFontYOffset As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the text down, while a negative value will shift the text up

Only used when TimeType Property is set to Split.

See Also


%%PageItemTitle%%

HourLineColor Property
ctxCalendar Object : HourLineColor Property

Description

Returns/sets the color used to paint the hour lines in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property HourLineColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ImageListCount Property
ctxCalendar Object : ImageListCount Property

Description

Returns the amount of images in the controls image list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImageListCount As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

InfoLinePriority Property
ctxCalendar Object : InfoLinePriority Property

Description

Determines if the InfoLineText of an appointment should be shown instead of the Text.

Property type

Read-write property

Syntax

Visual Basic
Public Property InfoLinePriority As Boolean

Return Type

Boolean

Remarks

If an appointment spans only a single time row, by default the Text is displayed. However, setting this property to true will have the InfoLineText displayed instead.

Example

See Also


%%PageItemTitle%%

ListImage Property
nIndex
The 1-based index of the image in the internal image list.
ctxCalendar Object : ListImage Property

Description

Returns/sets an image in the internal image list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListImage( _
   ByVal nIndex As Integer _
) As Picture

Parameters

nIndex
The 1-based index of the image in the internal image list.

Return Type

An OLE_PICTURE object.

Remarks

This property will not add additional images to the internal image list. For example, if 5 images have been added to the internal image list via the AddImage method, this property can only access those 5 images.

With this property, images can be loaded into other OLE objects, as well as read into ctxCalendar.

See Also


%%PageItemTitle%%

Location_AllDayBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_AllDayBackColor Property

Description

Returns/sets the color of the allday area when displaying a column by Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_AllDayBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_BackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_BackColor Property

Description

Returns/sets the background color used to paint the weekly and monthly calendars for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_BorderColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_BorderColor Property

Description

Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_BorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_Cargo Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_Cargo Property

Description

Returns/sets a non-visible string value for the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_Cargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Location.

Return Type

String

See Also


%%PageItemTitle%%

Location_Code Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_Code Property

Description

Returns/sets a non-visible string value for the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_Code( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Location.

Return Type

Integer

Remarks

This is the value that will be assigned to an appointment to match it with the Location.

See Also


%%PageItemTitle%%

Location_Count Property
ctxCalendar Object : Location_Count Property

Description

Returns the amount of location objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

Location_DateHeaderBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_DateHeaderBackColor Property

Description

Returns/sets the primary background color of the date and column headers for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_DateHeaderBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Location_DateHeaderBackColorTo Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_DateHeaderBackColorTo Property

Description

Returns/sets the secondary background color of the date and column headers for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_DateHeaderBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Location_DateHeaderBorderColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_DateHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the date and column headers for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_DateHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Location_DateHeaderFillType Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_DateHeaderFillType Property

Description

Returns/sets the pattern used to paint the background of the date and column headers for aLocation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_DateHeaderFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Location.

Return Type

enumFillType Enumeration

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Location_DateHeaderForeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_DateHeaderForeColor Property

Description

Returns/sets the color used to paint the text in the date and column headers for aLocation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_DateHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Location_Image Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_Image Property

Description

Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_Image( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Location.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

See Also


%%PageItemTitle%%

Location_KeyID Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_KeyID Property

Description

Returns/sets the unique ID for the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_KeyID( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Location.

Return Type

String

Remarks

This property is an excellent spot to store the ID value of the Location from the database.

See Also


%%PageItemTitle%%

Location_MonthEvenBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_MonthEvenBackColor Property

Description

Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Location .

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_MonthEvenBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_MonthHeaderBorderColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_MonthHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the Month names in a Monthly view for the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_MonthHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The type of border is determined by the MonthHeaderBorderStyle Property.

See Also


%%PageItemTitle%%

Location_MonthHeaderForeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_MonthHeaderForeColor Property

Description

Returns/sets the color used to paint the text of the month names in a monthly view for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_MonthHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_MonthOddBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_MonthOddBackColor Property

Description

Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_MonthOddBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_NonPrimeTimeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_NonPrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_NonPrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Location_PrimeTimeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_PrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of prime time in the daily view for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_PrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Location_SelectedBackColor Property
nIndex
the 1-based index of the Location.
ctxCalendar Object : Location_SelectedBackColor Property

Description

Returns/sets the color used to paint a selected date or time cell for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_SelectedBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
the 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_SelectedForeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_SelectedForeColor Property

Description

Returns/sets the color used to paint the text in a selected date for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_SelectedForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_Text Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_Text Property

Description

Returns/sets the text associated with the Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_Text( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Location.

Return Type

String

Remarks

The Text will be displayed in the column header in daily views, and as the title text in the weekly and monthly views.

See Also


%%PageItemTitle%%

Location_TitleForeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_TitleForeColor Property

Description

Returns/sets the color used to paint the title text in the weekly and monthly views for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_TitleForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_WeekendBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekendBackColor Property

Description

Returns/sets the background color of the weekend dates for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekendBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_WeekSummaryBackColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekSummaryBackColor Property

Description

Returns/sets the primary background color of the weeksummary areas for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekSummaryBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_WeekSummaryBackColorTo Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekSummaryBackColorTo Property

Description

Returns/sets the secondary background color of the weeksummary areas for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekSummaryBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_WeekSummaryBorderColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekSummaryBorderColor Property

Description

Returns/sets the color used to paint the border around each weeksummary area for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekSummaryBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Location_WeekSummaryFillType Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekSummaryFillType Property

Description

Returns/sets the pattern used to paint the background of the weeksummary areas for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekSummaryFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Location.

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

Location_WeekSummaryForeColor Property
nIndex
The 1-based index of the Location.
ctxCalendar Object : Location_WeekSummaryForeColor Property

Description

Returns/sets the color used to paint the text in the weeksummary areas for a Location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Location_WeekSummaryForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Location.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

MaskColor Property
ctxCalendar Object : MaskColor Property

Description

Returns/sets the masking color used for the images in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaskColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

A value of -1 disables the masking.

See Also


%%PageItemTitle%%

MaxImageCalendarColumns Property
ctxCalendar Object : MaxImageCalendarColumns Property

Description

Returns/sets the max number of calendars that can be included in the output of the CreateImage method, when a width of -1 is supplied in the Weekly/Monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageCalendarColumns As Integer

Return Type

Integer (minimum 1, maximum 100)

Remarks

This property is only effective if the AppointmentType is set to something other than Date. Otherwise the output is always 1 calendar wide. Each calendar for a Contact/Location/Task is considered a column.

This property has a maximum of 100. Depending on the size of the calendars, setting this property to too large of a value (even within the maximum) may not result in any output, as the created image may be too large to generate.

The width of each of the calendars in the output, will be the same as the width of each of the currently visible calendars in the control.

See Also


%%PageItemTitle%%

MaxImageDayColumns Property
ctxCalendar Object : MaxImageDayColumns Property

Description

Returns/sets the max number of columns that can be included in the output of the CreateImage method, when a width of -1 is supplied in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageDayColumns As Integer

Return Type

Integer (minimum 1, maximum 365)

Remarks

This property has a maximum of 365. Depending on the size of the columns in the display, setting this property to too large of a value (even within the maximum) may not result in any output, as the created image may be too large to generate.

The width of each of the columns in the output, will be the same as the width of each of the currently visible columns in the control.

See Also


%%PageItemTitle%%

MaxImageHeight Property
ctxCalendar Object : MaxImageHeight Property

Description

Returns/sets the maximum height of an image created with the CreateImage method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageHeight As Long

Return Type

Integer value representing the height in pixels.

Remarks

If this property is set to 0, the control will attempt to use the maximum height supported by the system.

See Also


%%PageItemTitle%%

MaxImageWidth Property
ctxCalendar Object : MaxImageWidth Property

Description

Returns/sets the maximum width of an image created with the CreateImage method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageWidth As Long

Return Type

Integer value representing the width in pixels.

Remarks

If this property is set to 0, the control will attempt to use the maximum width supported by the system.

See Also


%%PageItemTitle%%

MergeInfoLine Property
ctxCalendar Object : MergeInfoLine Property

Description

Determines if the regular text and info line text will be merged in the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property MergeInfoLine As Boolean

Return Type

Boolean

Remarks

The info line contains the ShowTime text for the appointment, as well as the images. This property will determine if the control should start the display of the text right after the info line, or not and start the appointment's text on a new line.

This property will only have an effect on appointments being displayed in the main area of the day view.

See Also


%%PageItemTitle%%

MilitaryTime Property
ctxCalendar Object : MilitaryTime Property

Description

Determines if the time values will be displayed in a 24-hour format in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MilitaryTime As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

MinuteDisplay Property
ctxCalendar Object : MinuteDisplay Property

Description

Returns/sets where minute values will be displayed in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinuteDisplay As enumMinuteDisplay

Return Type

enumMinuteDisplay Enumeration

See Also


%%PageItemTitle%%

MinuteFormat Property
ctxCalendar Object : MinuteFormat Property

Description

Returns/sets how the minute values will be displayed in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinuteFormat As enumMinuteFormat

Return Type

enumMinuteFormat Enumeration

See Also


%%PageItemTitle%%

MinuteLineColor Property
ctxCalendar Object : MinuteLineColor Property

Description

Returns/sets the color used to paint the minute lines in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinuteLineColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MinuteLines Property
ctxCalendar Object : MinuteLines Property

Description

Determines if lines will be drawn in the time area to indicate the minute rows.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinuteLines As Boolean

Return Type

Boolean

Remarks

This property will only have an effect if TimeType Property is set to Split.

The color for the lines in the time area are determined by the TimeBorderColor Property

See Also


%%PageItemTitle%%

MonthEvenBackColor Property
ctxCalendar Object : MonthEvenBackColor Property

Description

Returns/sets the background color of each date of an even numbered month in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthEvenBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MonthHeader Property
ctxCalendar Object : MonthHeader Property

Description

Determines if the month header (containing the days of the week) will be displayed in the monthly view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeader As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

MonthHeaderBackColor Property
ctxCalendar Object : MonthHeaderBackColor Property

Description

Returns/sets the primary background color of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MonthHeaderBackColorTo Property
ctxCalendar Object : MonthHeaderBackColorTo Property

Description

Returns/sets the secondary background color of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MonthHeaderBorderColor Property
ctxCalendar Object : MonthHeaderBorderColor Property

Description

Returns/sets the border color of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MonthHeaderBorderStyle Property
ctxCalendar Object : MonthHeaderBorderStyle Property

Description

Returns/sets the border style of the month header in the month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderBorderStyle As enumHeaderBorderStyle

Return Type

enumHeaderBorderStyle Enumeration

See Also


%%PageItemTitle%%

MonthHeaderFillType Property
ctxCalendar Object : MonthHeaderFillType Property

Description

Returns/sets the background pattern of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

MonthHeaderFont Property
ctxCalendar Object : MonthHeaderFont Property

Description

Returns/sets the font of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

MonthHeaderForeColor Property
ctxCalendar Object : MonthHeaderForeColor Property

Description

Returns/sets the text color of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MonthHeaderHeight Property
ctxCalendar Object : MonthHeaderHeight Property

Description

Returns/sets the height of the month headers in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderHeight As Integer

Return Type

Integer value indicating the height in pixels.

See Also


%%PageItemTitle%%

MonthHeaderTextAlign Property
ctxCalendar Object : MonthHeaderTextAlign Property

Description

Returns/sets the horizontal alignment of the month header text in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthHeaderTextAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

MonthNames Property
ctxCalendar Object : MonthNames Property

Description

Returns/sets the names of the month of the year.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthNames As String

Return Type

Comma separated string

Remarks

This is a single string value, with the individual names of the months separated by semi-colons.

Example:

January,February,March,April,May,June,July,August,September,October,November,December

See Also


%%PageItemTitle%%

MonthOddBackColor Property
ctxCalendar Object : MonthOddBackColor Property

Description

Returns/sets the background color of each date of an odd numbered month in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthOddBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

MoveAlpha Property
ctxCalendar Object : MoveAlpha Property

Description

Returns/sets the alpha (transparency) value assigned to the background colors of an appointment when an appointment is being moved with the mouse.

Property type

Read-write property

Syntax

Visual Basic
Public Property MoveAlpha As Integer

Return Type

Integer

Remarks

Valid values are from 0 (completely transparent) to 255 (completely opaque)

See Also


%%PageItemTitle%%

MultipleZones Property
ctxCalendar Object : MultipleZones Property

Description

Determines if two time zones will be displayed in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property MultipleZones As Boolean

Return Type

Boolean

Remarks

The difference between the two time zones is determined by the ZoneOffset Property

See Also


%%PageItemTitle%%

MultiSelect Property
ctxCalendar Object : MultiSelect Property

Description

Determines if multiple dates can be selected in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property MultiSelect As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

NonPrimeTimeColor Property
ctxCalendar Object : NonPrimeTimeColor Property

Description

Returns/sets the background color for the time cells during non-prime time in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property NonPrimeTimeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

Prime time is determined by the PrimeTimeStart Property and the PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

PrimeTimeColor Property
ctxCalendar Object : PrimeTimeColor Property

Description

Returns/sets the background color for the time cells during prime time in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimeTimeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

Prime time is determined by the PrimeTimeStart Property and the PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

PrimeTimeEnd Property
ctxCalendar Object : PrimeTimeEnd Property

Description

Returns/sets the ending prime time for the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimeTimeEnd As Integer

Return Type

Integer value indicating the number of minutes since midnight

See Also


%%PageItemTitle%%

PrimeTimeStart Property
ctxCalendar Object : PrimeTimeStart Property

Description

Returns/sets the starting prime time for the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimeTimeStart As Integer

Return Type

Integer value indicating the number of minutes since midnight

See Also


%%PageItemTitle%%

PrintColsPerPage Property
ctxCalendar Object : PrintColsPerPage Property

Description

Returns/sets the maximum number of columns to include per page of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintColsPerPage As Integer

Return Type

Integer

Remarks

This property is only effective when the PrintReportType Property is set to Print_All.

When the ViewType Property is set to either Weekly or Monthly, this property will only be effective if the AppointmentType Property is something other than Date.

The property has a maximum of 14.

See Also


%%PageItemTitle%%

PrintColumnEnd Property
ctxCalendar Object : PrintColumnEnd Property

Description

Returns/sets the last column to include in a printed report

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintColumnEnd As Integer

Return Type

Integer

Remarks

By default this property is set to 0 and is ignored, allowing the control to print to the last defined column. Setting this property to a value greater than 0 will have the output stop at that column.

This property is only effective when the PrintReportType Property is set to Print_All

See Also


%%PageItemTitle%%

PrintColumnStart Property
ctxCalendar Object : PrintColumnStart Property

Description

Returns/sets the first column to include in a printed report

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintColumnStart As Integer

Return Type

Integer

Remarks

By default this property is set to 0 and is ignored, allowing the control to print from the first defined column. Setting this property to a value greater than 0 will have the output begin at that column. Assigning a value of 1 will have the same out put as a value of 0, as in both cases the output will begin at the first column.

This property is only effective when the PrintReportType Property is set to Print_All

See Also


%%PageItemTitle%%

PrintFont Property
ctxCalendar Object : PrintFont Property

Description

Returns/sets the font of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintFont As Font

Return Type

Font

Remarks

This font will be used to render the text for the sub title and the page number text on each page of the printed report.

See Also


%%PageItemTitle%%

PrintMarginBottom Property
ctxCalendar Object : PrintMarginBottom Property

Description

Returns/sets the bottom page margin offset of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintMarginBottom As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the bottom edge of the report down (increasing the available space), while a negative value will shift the bottom edge of the report up (reducing available space).

See Also


%%PageItemTitle%%

PrintMarginLeft Property
ctxCalendar Object : PrintMarginLeft Property

Description

Returns/sets the left page margin offset of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintMarginLeft As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the left edge of the report to the right (reducing the available space), while a negative value will shift the left edge of the report left (increasing available space).

See Also


%%PageItemTitle%%

PrintMarginRight Property
ctxCalendar Object : PrintMarginRight Property

Description

Returns/sets the right page margin offset of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintMarginRight As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the right edge of the report to the right (increasing the available space), while a negative value will shift the right edge of the report left (reducing available space).

See Also


%%PageItemTitle%%

PrintMarginTop Property
ctxCalendar Object : PrintMarginTop Property

Description

Returns/sets the top page margin offset of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintMarginTop As Integer

Return Type

Integer value indicating the offset in pixels.

Remarks

A positive value will shift the top edge of the report down (reducing the available space), while a negative value will shift the top edge of the report up (increasing available space).

See Also


%%PageItemTitle%%

PrintPageNumberAlign Property
ctxCalendar Object : PrintPageNumberAlign Property

Description

Returns/sets the horizontal text alignment of page numbers in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageNumberAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

PrintPageNumbers Property
ctxCalendar Object : PrintPageNumbers Property

Description

Determines if page numbers will be placed in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageNumbers As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

PrintPageText Property
ctxCalendar Object : PrintPageText Property

Description

Sets the string to be displayed as the page number text for a printed page.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageText As String

Return Type

Property is write only.

Remarks

This property can only be assigned a value inside the UserDrawnPageNumber Event.

See Also


%%PageItemTitle%%

PrintReportType Property
ctxCalendar Object : PrintReportType Property

Description

Returns/sets the type of printed report to create.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintReportType As enumPrintReportType

Return Type

enumPrintReportType Enumeration

See Also


%%PageItemTitle%%

PrintSubTitle Property
ctxCalendar Object : PrintSubTitle Property

Description

Returns/sets the sub-title of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintSubTitle As String

Return Type

String

See Also


%%PageItemTitle%%

PrintTimeEnd Property
ctxCalendar Object : PrintTimeEnd Property

Description

Returns/sets the end time of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTimeEnd As Integer

Return Type

Integer representing the number of minutes past midnight.

Remarks

This property is only effective when ViewType is Daily and the PrintReportType Property is set to All.

By default this property has a value of -1, which tells the control to ignore it and use the current TimeEnd Property instead.

See Also


%%PageItemTitle%%

PrintTimeStart Property
ctxCalendar Object : PrintTimeStart Property

Description

Returns/sets the start time of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTimeStart As Integer

Return Type

Integer representing the number of minutes past midnight.

Remarks

This property is only effective when ViewType is Daily and the PrintReportType Property is set to All.

By default this property has a value of -1, which tells the control to ignore it and use the current TimeStart Property instead.

See Also


%%PageItemTitle%%

PrintTitle Property
ctxCalendar Object : PrintTitle Property

Description

Returns/sets the title of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitle As String

Return Type

String

See Also


%%PageItemTitle%%

PrintTitleAlign Property
ctxCalendar Object : PrintTitleAlign Property

Description

Returns/sets the horizontal text alignment of the title and sub-title of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitleAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

PrintTitleFont Property
ctxCalendar Object : PrintTitleFont Property

Description

Returns/sets the title font of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitleFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

PropertyPages Property
ctxCalendar Object : PropertyPages Property

Description

Allows for the display of the custom property pages in runtime.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyPages As enumProperties

Return Type

enumProperties Enumeration

Remarks

This property is not a true property in that it does not store a value. Instead, it acts more like a method because acts it causes the property pages to appear.

See Also


%%PageItemTitle%%

ResizeExtension Property
ctxCalendar Object : ResizeExtension Property

Description

Returns/sets the offset used to calculate internally when the mouse is over either of the appointment resize handles.

Property type

Read-write property

Syntax

Visual Basic
Public Property ResizeExtension As Integer

Return Type

Integer (0 or greater)

Remarks

The display size of the little squares that represent the resize handles won't change.

The higher the value assigned, the further (above the top resize handle, and below the bottom resize handle) the cursor can be from the respective edge of the appointment and still be able to resize it (cursor icon will change).

Example

See Also


%%PageItemTitle%%

ResizeHandleBackColor Property
ctxCalendar Object : ResizeHandleBackColor Property

Description

Returns/sets the color used to paint the square resize handles on appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property ResizeHandleBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ResizeHandleBorderColor Property
ctxCalendar Object : ResizeHandleBorderColor Property

Description

Returns/sets the color used to paint the border of the square resize handles on appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property ResizeHandleBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

ResizeHandleBorderType Property
ctxCalendar Object : ResizeHandleBorderType Property

Description

Returns/sets the type of border for the square resize handles on appointments.

Property type

Read-write property

Syntax

Visual Basic
Public Property ResizeHandleBorderType As enumBorderType

Return Type

enumBorderType

Example

See Also


%%PageItemTitle%%

SelectedBackColor Property
ctxCalendar Object : SelectedBackColor Property

Description

Returns/sets the background color of a selected cell in the day view or of a selected date in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Example

See Also


%%PageItemTitle%%

SelectedDaysCount Property
ctxCalendar Object : SelectedDaysCount Property

Description

Returns the amount of selected dates in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedDaysCount As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

SelectedForeColor Property
ctxCalendar Object : SelectedForeColor Property

Description

Returns/sets the text color of a selected date in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectedForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

ShowTimeText Property
ctxCalendar Object : ShowTimeText Property

Description

Sets the string to be displayed as the time text for an appointment.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTimeText As String

Return Type

Property is write only.

Remarks

This property can only be used inside the UserDrawnShowTime Event.

See Also


%%PageItemTitle%%

Task_AllDayBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_AllDayBackColor Property

Description

Returns/sets the color of the allday area when displaying a column by Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_AllDayBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_BackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_BackColor Property

Description

Returns/sets the background color used to paint the weekly and monthly calendars for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_BackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_BorderColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_BorderColor Property

Description

Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_BorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_Cargo Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_Cargo Property

Description

Returns/sets a non-visible string value for the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_Cargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Task.

Return Type

String

See Also


%%PageItemTitle%%

Task_Code Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_Code Property

Description

Returns/sets the unique code for the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_Code( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Task.

Return Type

Integer

Remarks

This is the value that will be assigned to an appointment to match it with the Task.

See Also


%%PageItemTitle%%

Task_Count Property
ctxCalendar Object : Task_Count Property

Description

Returns the amount of task objects in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_Count As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

Task_DateHeaderBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_DateHeaderBackColor Property

Description

Returns/sets the primary background color of the date and column headers for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_DateHeaderBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Task_DateHeaderBackColorTo Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_DateHeaderBackColorTo Property

Description

Returns/sets the secondary background color of the date and column headers for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_DateHeaderBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Task_DateHeaderBorderColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_DateHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the date and column headers for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_DateHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Task_DateHeaderFillType Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_DateHeaderFillType Property

Description

Returns/sets the pattern used to paint the background of the date and column headers for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_DateHeaderFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Task.

Return Type

enumFillType Enumeration

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Task_DateHeaderForeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_DateHeaderForeColor Property

Description

Returns/sets the color used to paint the text in the date and column headers for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_DateHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Requires the DateHeaders Property be True for the Monthly and Weekly views.

See Also


%%PageItemTitle%%

Task_Image Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_Image Property

Description

Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_Image( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Task.

Return Type

The 1-based index of the image from the internal image list. Values from -1 to -12 indicate the use of a pre-defined image in the control.

See Also


%%PageItemTitle%%

Task_KeyID Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_KeyID Property

Description

Returns/sets the unique ID for the Task

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_KeyID( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Task.

Return Type

String

Remarks

This property is an excellent spot to store the ID value of the Task from the database.

See Also


%%PageItemTitle%%

Task_MonthEvenBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_MonthEvenBackColor Property

Description

Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_MonthEvenBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_MonthHeaderBorderColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_MonthHeaderBorderColor Property

Description

Returns/sets the color used to paint the border around the Month names in a Monthly view for the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_MonthHeaderBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_MonthHeaderForeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_MonthHeaderForeColor Property

Description

Returns/sets the color used to paint the text of the month names in a monthly view for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_MonthHeaderForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_MonthOddBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_MonthOddBackColor Property

Description

Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_MonthOddBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_NonPrimeTimeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_NonPrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_NonPrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Task_PrimeTimeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_PrimeTimeColor Property

Description

Returns/sets the color used to paint the time cells of prime time in the daily view for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_PrimeTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Prime time is determined by the PrimeTimeStart Property and PrimeTimeEnd Property.

See Also


%%PageItemTitle%%

Task_SelectedBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_SelectedBackColor Property

Description

Returns/sets the color used to paint the time cells of prime time in the daily view for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_SelectedBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_SelectedForeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_SelectedForeColor Property

Description

Returns/sets the color used to paint the text in a selected date for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_SelectedForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_Text Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_Text Property

Description

Returns/sets the text associated with the Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_Text( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index of the Task.

Return Type

String

Remarks

The Text will be displayed in the column header in daily views, and as the title text in the weekly and monthly views.

See Also


%%PageItemTitle%%

Task_TitleForeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_TitleForeColor Property

Description

Returns/sets the color used to paint the title text in the weekly and monthly views for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_TitleForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_WeekendBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekendBackColor Property

Description

Returns/sets the background color of the weekend dates for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekendBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_WeekSummaryBackColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekSummaryBackColor Property

Description

Returns/sets the primary background color of the weeksummary areas for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekSummaryBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_WeekSummaryBackColorTo Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekSummaryBackColorTo Property

Description

Returns/sets the secondary background color of the weeksummary areas for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekSummaryBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_WeekSummaryBorderColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekSummaryBorderColor Property

Description

Returns/sets the color used to paint the border around each weeksummary area for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekSummaryBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

Task_WeekSummaryFillType Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekSummaryFillType Property

Description

Returns/sets the pattern used to paint the background of the weeksummary areas for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekSummaryFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the Task.

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

Task_WeekSummaryForeColor Property
nIndex
The 1-based index of the Task.
ctxCalendar Object : Task_WeekSummaryForeColor Property

Description

Returns/sets the color used to paint the text in the weeksummary areas for a Task.

Property type

Read-write property

Syntax

Visual Basic
Public Property Task_WeekSummaryForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index of the Task.

Return Type

A ULong value representing an OLE_COLOR.

See Also


%%PageItemTitle%%

TaskBarBorder Property
ctxCalendar Object : TaskBarBorder Property

Description

Determines if a border will be placed on the task bars for the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskBarBorder As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

TaskBarColor Property
ctxCalendar Object : TaskBarColor Property

Description

Returns/sets the default color of the task bars for the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskBarColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TaskBarWidth Property
ctxCalendar Object : TaskBarWidth Property

Description

Returns/sets the width of the task bars for the appointments in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskBarWidth As Integer

Return Type

Integer representing the width in pixels

See Also


%%PageItemTitle%%

TimeAMText Property
ctxCalendar Object : TimeAMText Property

Description

Returns/sets the text used to describe time values between midnight and noon.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeAMText As String

Return Type

String

See Also


%%PageItemTitle%%

TimeArea Property
ctxCalendar Object : TimeArea Property

Description

Determines if the time area will be visible in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeArea As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

TimeBackColor Property
ctxCalendar Object : TimeBackColor Property

Description

Returns/sets the primary background color for the time area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeBackColorTo Property
ctxCalendar Object : TimeBackColorTo Property

Description

Returns/sets the secondary background color for the time area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeBorderColor Property
ctxCalendar Object : TimeBorderColor Property

Description

Returns/sets the color used to paint the borders in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeBorderType Property
ctxCalendar Object : TimeBorderType Property

Description

Returns/sets the border type separating time segments of the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBorderType As enumTimeBorderType

Return Type

enumTimeBorderType Enumeration

See Also


%%PageItemTitle%%

TimeEnd Property
ctxCalendar Object : TimeEnd Property

Description

Returns/sets the ending time for the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeEnd As Integer

Return Type

Integer representing the number of minutes since midnight.

See Also


%%PageItemTitle%%

TimeFillType Property
ctxCalendar Object : TimeFillType Property

Description

Returns/sets the fill type for the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

TimeFont Property
ctxCalendar Object : TimeFont Property

Description

Returns/sets the font for the minute values in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

TimeForeColor Property
ctxCalendar Object : TimeForeColor Property

Description

Returns/sets the text color for the time area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeGuideBackColor Property
ctxCalendar Object : TimeGuideBackColor Property

Description

Returns/sets the background color of the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeGuideChange Property
ctxCalendar Object : TimeGuideChange Property

Description

Returns/sets the opacity change used with each time guide interval to fade in the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideChange As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

TimeGuideForeColor Property
ctxCalendar Object : TimeGuideForeColor Property

Description

Returns/sets the text color of the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeGuideInterval Property
ctxCalendar Object : TimeGuideInterval Property

Description

Returns/sets the time (in milliseconds) used to fade in the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideInterval As Integer

Return Type

Integer representing milliseconds.

Remarks

The smaller the value, the faster the guide will appear.

See Also


%%PageItemTitle%%

TimeGuideOnMove Property
ctxCalendar Object : TimeGuideOnMove Property

Description

Determines if the time guide will appear when an appointment is being moved with the mouse in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideOnMove As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

TimeGuideOnSelect Property
ctxCalendar Object : TimeGuideOnSelect Property

Description

Determines if the time guide will appear when multiple time cells are being selected in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideOnSelect As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

TimeGuideOpacity Property
ctxCalendar Object : TimeGuideOpacity Property

Description

Returns/sets the maximum alpha (transparency) value assigned to the background and foreground colors of the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideOpacity As Integer

Return Type

Integer

Remarks

Valid values are from 0-255.

See Also


%%PageItemTitle%%

TimeGuideWidth Property
ctxCalendar Object : TimeGuideWidth Property

Description

Returns/sets the width of the time guide.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeGuideWidth As Integer

Return Type

Integer indicating the width in pixels.

See Also


%%PageItemTitle%%

TimeHeightOffset Property
ctxCalendar Object : TimeHeightOffset Property

Description

Returns/sets the offset value used to calculate the height if the time lines in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeHeightOffset As Integer

Return Type

Integer representing the offset in pixels.

Remarks

The default height is calculated based on the TimeFont Property.

See Also


%%PageItemTitle%%

TimeIncrement Property
ctxCalendar Object : TimeIncrement Property

Description

Returns/sets the amount of time (minutes) separating each line in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeIncrement As Integer

Return Type

Integer

Remarks

Valid values are from 1-60

See Also


%%PageItemTitle%%

TimePMText Property
ctxCalendar Object : TimePMText Property

Description

Returns/sets the text used to describe time values between noon and midnight.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimePMText As String

Return Type

String

See Also


%%PageItemTitle%%

TimeSelectBackColor Property
ctxCalendar Object : TimeSelectBackColor Property

Description

Returns/sets the color used to paint the minute background of selected lines in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeSelectBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeSelectForeColor Property
ctxCalendar Object : TimeSelectForeColor Property

Description

Returns/sets the color used to paint the minute text of selected lines in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeSelectForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TimeSelectWidth Property
ctxCalendar Object : TimeSelectWidth Property

Description

Returns/sets the width of the selected area in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeSelectWidth As Integer

Return Type

Integer representing the width in pixels.

Remarks

Only applicable when TimeType is set to Split.

See Also


%%PageItemTitle%%

TimeStart Property
ctxCalendar Object : TimeStart Property

Description

Returns/sets the starting time for the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeStart As Integer

Return Type

Integer representing the number of minutes since midnight.

See Also


%%PageItemTitle%%

TimeType Property
ctxCalendar Object : TimeType Property

Description

Returns/sets how the time values are displayed in the time area of the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeType As enumTimeType

Return Type

enumTimeType Enumeration

See Also


%%PageItemTitle%%

TimeWidth Property
ctxCalendar Object : TimeWidth Property

Description

Returns/sets the width of the time area in the day view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeWidth As Integer

Return Type

Integer representing the width in pixels

See Also


%%PageItemTitle%%

TitleArea Property
ctxCalendar Object : TitleArea Property

Description

Determines if a title area is displayed in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleArea As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

TitleFont Property
ctxCalendar Object : TitleFont Property

Description

Returns/sets the font of the title area in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleFont As Font

Return Type

Font

See Also


%%PageItemTitle%%

TitleForeColor Property
ctxCalendar Object : TitleForeColor Property

Description

Returns/sets the text color of the title area in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

TitleHeight Property
ctxCalendar Object : TitleHeight Property

Description

Returns/sets the height of the title area in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleHeight As Integer

Return Type

Integer representing the height in pixels.

See Also


%%PageItemTitle%%

TitleText Property
ctxCalendar Object : TitleText Property

Description

Returns/sets the default text of the title area in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleText As String

Return Type

String

See Also


%%PageItemTitle%%

TitleTextAlign Property
ctxCalendar Object : TitleTextAlign Property

Description

Returns/sets the horizontal text alignment of the title area in a month or week view.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleTextAlign As enumAlignment

Return Type

enumAlignment Enumeration

See Also


%%PageItemTitle%%

TodayBackColor Property
ctxCalendar Object : TodayBackColor Property

Description

Returns/sets the primary color used to paint the header of a current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The TodayStyle Property determines if this property is used.

See Also


%%PageItemTitle%%

TodayBackColorTo Property
ctxCalendar Object : TodayBackColorTo Property

Description

Returns/sets the secondary color used to paint the header of a current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The TodayStyle Property determines if this property is used.

See Also


%%PageItemTitle%%

TodayBorderColor Property
ctxCalendar Object : TodayBorderColor Property

Description

Returns/sets the border color of the current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The TodayStyle Property determines if this property is used.

See Also


%%PageItemTitle%%

TodayFillType Property
ctxCalendar Object : TodayFillType Property

Description

Returns/sets the fill type used to paint the header of a current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayFillType As enumFillType

Return Type

enumFillType Enumeration

Remarks

The TodayStyle Property determines if this property is used.

See Also


%%PageItemTitle%%

TodayForeColor Property
ctxCalendar Object : TodayForeColor Property

Description

Returns/sets the color used to paint the text in a header of a current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

The TodayStyle Property determines if this property is used.

See Also


%%PageItemTitle%%

TodayStyle Property
ctxCalendar Object : TodayStyle Property

Description

Returns/sets how a column in the day view or a date in the month and week view of the current date will be presented.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayStyle As enumTodayStyle

Return Type

enumTodayStyle Enumeration

See Also


%%PageItemTitle%%

UserDrawnHeaderImage Property
ctxCalendar Object : UserDrawnHeaderImage Property

Description

Sets the index of the the image to be placed inside a date header in the weekly and monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDrawnHeaderImage As Integer

Return Type

Property is write only

Remarks

This property can only be used inside the UserDrawnHeaderImage Event.

See Also


%%PageItemTitle%%

VertScrollMax Property
ctxCalendar Object : VertScrollMax Property

Description

Returns the maximum value or range of the vertical scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollMax As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

VertScrollPos Property
ctxCalendar Object : VertScrollPos Property

Description

Returns/sets the value or position of the vertical scroll bar of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollPos As Integer

Return Type

Integer value from 0 to VertScrollMax.

See Also


%%PageItemTitle%%

VertScrollVisible Property
ctxCalendar Object : VertScrollVisible Property

Description

Determines if the vertical scroll bar for the control will be visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollVisible As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

ViewType Property
ctxCalendar Object : ViewType Property

Description

Returns/sets the current view type for the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewType As enumViewType

Return Type

enumViewType Enumeration

Remarks

Changes to this property will trigger the ViewTypeChanged Event

See Also


%%PageItemTitle%%

WeekendBackColor Property
ctxCalendar Object : WeekendBackColor Property

Description

Returns/sets the background color used to paint weekend days in the weekly and monthly views.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekendBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

Remarks

Weekend days are determined by the Weekends Property.

See Also


%%PageItemTitle%%

Weekends Property
ctxCalendar Object : Weekends Property

Description

Returns/sets the days of the weeks that will be considered weekend days.

Property type

Read-write property

Syntax

Visual Basic
Public Property Weekends As Integer

Return Type

Integer representing the days marked as weekend days.

Remarks

The weekends are determined by the bits within an integer value. Each day of the week is assigned one of those bits. To mark a day as a weekend, add up the bit value and assign it to this property.

1 = Sunday
2 = Monday
4 = Tuesday
8 = Wednesday
16 = Thursday
32 = Friday
64 = Saturday

A value of 65 assigned to the property would mark Sunday (1) and Saturday (64) as weekend days.

0 indicates that no days are marked as weekend dates, and 127 would mark all 7 days as weekend days.

See Also


%%PageItemTitle%%

WeekSummary Property
ctxCalendar Object : WeekSummary Property

Description

Determines if a week summary will be visible in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummary As Boolean

Return Type

Boolean

See Also


%%PageItemTitle%%

WeekSummaryBackColor Property
ctxCalendar Object : WeekSummaryBackColor Property

Description

Returns/sets the primary color of the background of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryBackColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

WeekSummaryBackColorTo Property
ctxCalendar Object : WeekSummaryBackColorTo Property

Description

Returns/sets the secondary color of the background of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryBackColorTo As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

WeekSummaryBorderColor Property
ctxCalendar Object : WeekSummaryBorderColor Property

Description

Returns/sets the border color of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryBorderColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

WeekSummaryFillType Property
ctxCalendar Object : WeekSummaryFillType Property

Description

Returns/sets the background pattern of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryFillType As enumFillType

Return Type

enumFillType Enumeration

See Also


%%PageItemTitle%%

WeekSummaryFont Property
ctxCalendar Object : WeekSummaryFont Property

Description

Returns/sets the font of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryFont As Font

Return Type

Font

Remarks

A TrueType font should be used due to the ability to rotate the text (WeekSummaryTextAngle Property)

See Also


%%PageItemTitle%%

WeekSummaryForeColor Property
ctxCalendar Object : WeekSummaryForeColor Property

Description

Returns/sets the text color of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryForeColor As ULong

Return Type

A Ulong value representing an OLE_COLOR

See Also


%%PageItemTitle%%

WeekSummaryText Property
ctxCalendar Object : WeekSummaryText Property

Description

Sets the text to be painted inside a week summary in the monthly view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryText As String

Return Type

Property is write only.

Remarks

This property can only be used inside the UserDrawnWeekSummary Event.

See Also


%%PageItemTitle%%

WeekSummaryTextAngle Property
ctxCalendar Object : WeekSummaryTextAngle Property

Description

Returns/sets the text angle of each week summary in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryTextAngle As enumTextAngle

Return Type

enumTextAngle Enumeration

See Also


%%PageItemTitle%%

WeekSummaryWidth Property
ctxCalendar Object : WeekSummaryWidth Property

Description

Returns/sets the width of the week summaries in a month view.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekSummaryWidth As Integer

Return Type

Integer representing the width in pixels.

See Also


%%PageItemTitle%%

XMLRead Property
ctxCalendar Object : XMLRead Property

Description

Returns/sets an XML file to read into ctxCalendar.

Property type

Read-write property

Syntax

Visual Basic
Public Property XMLRead As String

Return Type

Property is write only.

See Also


%%PageItemTitle%%

XMLWrite Property
ctxCalendar Object : XMLWrite Property

Description

Create an XML file based on the current settings of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property XMLWrite As String

Return Type

Property is write only.

See Also


%%PageItemTitle%%

YearDisplay Property
ctxCalendar Object : YearDisplay Property

Description

Returns/sets how year values will be displayed in the month and week views.

Property type

Read-write property

Syntax

Visual Basic
Public Property YearDisplay As enumYearDisplay

Return Type

enumYearDisplay Enumeration

See Also


%%PageItemTitle%%

ZoneOffset Property
ctxCalendar Object : ZoneOffset Property

Description

Returns/sets the hour offset used in a secondary time zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property ZoneOffset As Integer

Return Type

Integer

See Also


%%PageItemTitle%%

AfterAppointmentAdd Event
nIndex
The index value of the new appointment.
nStartTime
The start time of the new appointment.
nEndTime
The end time of the new appointment.
dtDate
The date of the new appointment.
nContact
The code of the Contact of the new appointment.
nLocation
The code of the Location of the new appointment.
nTask
The code of the Task of the new appointment.
bAllDay
Indicates if the appointment was created as an allday appointment at the time it was added.
strKeyID
The KeyID value of the new appointment.
ctxCalendar Object : AfterAppointmentAdd Event

Description

Occurs after an appointment has been added to the control.

Syntax

Visual Basic
Public Event AfterAppointmentAdd( _
   ByVal nIndex As Integer, _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean, _
   ByVal strKeyID As String _
)

Parameters

nIndex
The index value of the new appointment.
nStartTime
The start time of the new appointment.
nEndTime
The end time of the new appointment.
dtDate
The date of the new appointment.
nContact
The code of the Contact of the new appointment.
nLocation
The code of the Location of the new appointment.
nTask
The code of the Task of the new appointment.
bAllDay
Indicates if the appointment was created as an allday appointment at the time it was added.
strKeyID
The KeyID value of the new appointment.

Remarks

This event is fired when an appointment is added either through user interaction or by the developer using one of the "Add" methods.

See Also


%%PageItemTitle%%

AfterAppointmentChange Event
nIndex
The index value of the appointment that was changed.
nStartTime
The new start time of the appointment.
nEndTime
The new end time of the appointment.
dtDate
The new date of the appointment.
nContact
The new Contact code of the appointment.
nLocation
The new Location code of the appointment.
nTask
The new Task code of the appointment.
bAllDay
Indicates if the appointment is now in the all day area or not.
ctxCalendar Object : AfterAppointmentChange Event

Description

Fires after an appointment has been moved/resized within the control.

Syntax

Visual Basic
Public Event AfterAppointmentChange( _
   ByVal nIndex As Integer, _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean _
)

Parameters

nIndex
The index value of the appointment that was changed.
nStartTime
The new start time of the appointment.
nEndTime
The new end time of the appointment.
dtDate
The new date of the appointment.
nContact
The new Contact code of the appointment.
nLocation
The new Location code of the appointment.
nTask
The new Task code of the appointment.
bAllDay
Indicates if the appointment is now in the all day area or not.

See Also


%%PageItemTitle%%

AfterAppointmentSelect Event
nIndex
The index of the appointment that was selected.
ctxCalendar Object : AfterAppointmentSelect Event

Description

Fires after an appointment has been selected in the control.

Syntax

Visual Basic
Public Event AfterAppointmentSelect( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index of the appointment that was selected.

See Also


%%PageItemTitle%%

AfterAppointmentUnSelect Event
nIndex
The index value of the appointment that became unselected.
ctxCalendar Object : AfterAppointmentUnSelect Event

Description

Fires after an appointment is unselected in the control.

Syntax

Visual Basic
Public Event AfterAppointmentUnSelect( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index value of the appointment that became unselected.

See Also


%%PageItemTitle%%

AfterDateSelected Event
dtDate
The date value that was selected.
ctxCalendar Object : AfterDateSelected Event

Description

Fires after a date is selected in the weekly or monthly views.

Syntax

Visual Basic
Public Event AfterDateSelected( _
   ByVal dtDate As Date _
)

Parameters

dtDate
The date value that was selected.

See Also


%%PageItemTitle%%

AfterReportPrint Event
ctxCalendar Object : AfterReportPrint Event

Description

Occurs after a printed report has been created.

Syntax

Visual Basic
Public Event AfterReportPrint()

Remarks

This event can be used to reset any changes made to the control during the BeforeReportPrint Event to accommodate the desired printed output.

See Also


%%PageItemTitle%%

AfterTimeSelect Event
nStartTime
The starting time of the selection.
nEndTime
The ending time of the selection.
nColumn
The column where the selection occurred.
ctxCalendar Object : AfterTimeSelect Event

Description

Occurs after a new time cell is selected in the daily view.

Syntax

Visual Basic
Public Event AfterTimeSelect( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nStartTime
The starting time of the selection.
nEndTime
The ending time of the selection.
nColumn
The column where the selection occurred.

Remarks

When selecting multiple cells, the values passed to this event will indicate the fully selected span and not just the most recent cell.

See Also


%%PageItemTitle%%

AppIndicatorClick Event
nType

The indicator that was clicked.

0 - Previous Indicator
1 - Next Indicator

nIndex
The index of the appointment the indicator is referencing.
ctxCalendar Object : AppIndicatorClick Event

Description

Occurs when the user clicks an appointment indicator in the daily view.

Syntax

Visual Basic
Public Event AppIndicatorClick( _
   ByVal nType As Integer, _
   ByVal nIndex As Integer _
)

Parameters

nType

The indicator that was clicked.

0 - Previous Indicator
1 - Next Indicator

nIndex
The index of the appointment the indicator is referencing.

See Also


%%PageItemTitle%%

AppointmentChanging Event
nIndex
The index value of the appointment being changed.
nStartTime
The new start time for the appointment.
nEndTime
The new end time for the appointment.
dtDate
The new date for the appointment.
nContact
The new Contact code for the appointment.
nLocation
The new Location code for the appointment.
nTask
The new Task code for the appointment.
bAllDay
Indicates the new all day status of the appointment.
nOldStartTime
The original start time of the appointment.
nOldEndTime
The original end time of the appointment.
dtOldDate
The original date of the appointment.
nOldContact
The original Contact Code of the appointment.
nOldLocation
The original Location code of the appointment.
nOldTask
The original Task code of the appointment.
bOldAllDay
The original all day event status of the appointment.
ctxCalendar Object : AppointmentChanging Event

Description

Occurs while the user moves or resizes an appointment in the control.

Syntax

Visual Basic
Public Event AppointmentChanging( _
   ByVal nIndex As Integer, _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean, _
   ByVal nOldStartTime As Integer, _
   ByVal nOldEndTime As Integer, _
   ByVal dtOldDate As Date, _
   ByVal nOldContact As Integer, _
   ByVal nOldLocation As Integer, _
   ByVal nOldTask As Integer, _
   ByVal bOldAllDay As Boolean _
)

Parameters

nIndex
The index value of the appointment being changed.
nStartTime
The new start time for the appointment.
nEndTime
The new end time for the appointment.
dtDate
The new date for the appointment.
nContact
The new Contact code for the appointment.
nLocation
The new Location code for the appointment.
nTask
The new Task code for the appointment.
bAllDay
Indicates the new all day status of the appointment.
nOldStartTime
The original start time of the appointment.
nOldEndTime
The original end time of the appointment.
dtOldDate
The original date of the appointment.
nOldContact
The original Contact Code of the appointment.
nOldLocation
The original Location code of the appointment.
nOldTask
The original Task code of the appointment.
bOldAllDay
The original all day event status of the appointment.

See Also


%%PageItemTitle%%

AppointmentClick Event
nIndex
The index value of the appointment that was clicked.
ctxCalendar Object : AppointmentClick Event

Description

Fires when a user left-clicks an appointment in the control.

Syntax

Visual Basic
Public Event AppointmentClick( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index value of the appointment that was clicked.

See Also


%%PageItemTitle%%

AppointmentDblClick Event
nIndex
The index of the appointment that was double clicked.
ctxCalendar Object : AppointmentDblClick Event

Description

Fires when a user double clicks an appointment with the left mouse button.

Syntax

Visual Basic
Public Event AppointmentDblClick( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index of the appointment that was double clicked.

See Also


%%PageItemTitle%%

AppointmentMouseOver Event
nIndex
The index of the appointment under the cursor.
ctxCalendar Object : AppointmentMouseOver Event

Description

Fires when the user moves the cursor over an appointment.

Syntax

Visual Basic
Public Event AppointmentMouseOver( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index of the appointment under the cursor.

See Also


%%PageItemTitle%%

AppointmentRightClick Event
nIndex
The index value of the appointment that was right-clicked.
ctxCalendar Object : AppointmentRightClick Event

Description

Fires when a user right-clicks an appointment in the control.

Syntax

Visual Basic
Public Event AppointmentRightClick( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index value of the appointment that was right-clicked.

See Also


%%PageItemTitle%%

ArrowClick Event
nArrow

The arrow that was clicked

0 - Down Arrow in main part of the control.
1 - Up Arrow in the main part of the control.
2- Down Arrow in the AllDay area.
3- Up Arrow in the AllDay area.

nColumn
The column where the arrow was clicked. A 1-based index relative to the current display. A value of 0 is returned in the Monthly and Weekly views.
dtDate
The date where the arrow was clicked.
ctxCalendar Object : ArrowClick Event

Description

Occurs when an arrow is clicked

Syntax

Visual Basic
Public Event ArrowClick( _
   ByVal nArrow As Integer, _
   ByVal nColumn As Integer, _
   ByVal dtDate As Date _
)

Parameters

nArrow

The arrow that was clicked

0 - Down Arrow in main part of the control.
1 - Up Arrow in the main part of the control.
2- Down Arrow in the AllDay area.
3- Up Arrow in the AllDay area.

nColumn
The column where the arrow was clicked. A 1-based index relative to the current display. A value of 0 is returned in the Monthly and Weekly views.
dtDate
The date where the arrow was clicked.

See Also


%%PageItemTitle%%

BeforeAppointmentAdd Event
nStartTime
The start time that will be assigned to the appointment.
nEndTime
The end time that will be assigned to the appointment.
dtDate
The date that will be assigned to the appointment.
nContact
The code of the Contact that will be assigned to the appointment. A value of 0 indicates there is no Contact for the appointment.
nLocation
The code of the Location that will be assigned to the appointment. A value of 0 indicates there is no Location for the appointment.
nTask
The code of the Task that will be assigned to the appointment. A value of 0 indicates there is no Task for the appointment.
bAllDay
Determines if the appointment was added as an AllDAy event.
nColumn
The index of the column where the appointment was added.
ctxCalendar Object : BeforeAppointmentAdd Event

Description

Occurs before an appointment is added to the control.

Syntax

Visual Basic
Public Event BeforeAppointmentAdd( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean, _
   ByVal nColumn As Integer _
)

Parameters

nStartTime
The start time that will be assigned to the appointment.
nEndTime
The end time that will be assigned to the appointment.
dtDate
The date that will be assigned to the appointment.
nContact
The code of the Contact that will be assigned to the appointment. A value of 0 indicates there is no Contact for the appointment.
nLocation
The code of the Location that will be assigned to the appointment. A value of 0 indicates there is no Location for the appointment.
nTask
The code of the Task that will be assigned to the appointment. A value of 0 indicates there is no Task for the appointment.
bAllDay
Determines if the appointment was added as an AllDAy event.
nColumn
The index of the column where the appointment was added.

Remarks

This event will only fire when the appointment is added to the control through user interaction.

The Cancel Method can be called here to cancel the creation of the appointment.

See Also


%%PageItemTitle%%

BeforeAppointmentChange Event
nIndex
The index value of the appointment that will be changed.
nStartTime
The new start time for the appointment.
nEndTime
The new end time for the appointment.
dtDate
The new date for the appointment.
nContact
The new Contact code for the appointment.
nLocation
The new Location code for the appointment.
nTask
The new Task code for the appointment.
bAllDay
Determines if the appointment has been moved into the AllDay area or not.
nOldStartTime
The original start time of the appointment.
nOldEndTime
The original end time of the appointment.
dtOldDate
The original date of the appointment.
nOldContact
The original Contact code for the appointment.
nOldLocation
The original Location code for the appointment.
nOldTask
The original Task code for the appointment.
bOldAllDay
Determines if the appointment was originally in the AllDay area or not.
ctxCalendar Object : BeforeAppointmentChange Event

Description

Occurs before changes made to an appointment through user interactions have been fully committed to the control.

Syntax

Visual Basic
Public Event BeforeAppointmentChange( _
   ByVal nIndex As Integer, _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean, _
   ByVal nOldStartTime As Integer, _
   ByVal nOldEndTime As Integer, _
   ByVal dtOldDate As Date, _
   ByVal nOldContact As Integer, _
   ByVal nOldLocation As Integer, _
   ByVal nOldTask As Integer, _
   ByVal bOldAllDay As Boolean _
)

Parameters

nIndex
The index value of the appointment that will be changed.
nStartTime
The new start time for the appointment.
nEndTime
The new end time for the appointment.
dtDate
The new date for the appointment.
nContact
The new Contact code for the appointment.
nLocation
The new Location code for the appointment.
nTask
The new Task code for the appointment.
bAllDay
Determines if the appointment has been moved into the AllDay area or not.
nOldStartTime
The original start time of the appointment.
nOldEndTime
The original end time of the appointment.
dtOldDate
The original date of the appointment.
nOldContact
The original Contact code for the appointment.
nOldLocation
The original Location code for the appointment.
nOldTask
The original Task code for the appointment.
bOldAllDay
Determines if the appointment was originally in the AllDay area or not.

Remarks

The Cancel Method can be called in this event to revert the appointment back to its original values.

See Also


%%PageItemTitle%%

BeforeAppointmentSelect Event
nIndex
The index value of the appointment that will be selected.
ctxCalendar Object : BeforeAppointmentSelect Event

Description

Occurs before an appointment is selected in the control.

Syntax

Visual Basic
Public Event BeforeAppointmentSelect( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index value of the appointment that will be selected.

Remarks

The Cancel Method can be called here to prevent the appointment from being selected.

See Also


%%PageItemTitle%%

BeforeDateSelect Event
dtDate
The date being selected.
ctxCalendar Object : BeforeDateSelect Event

Description

Occurs just before a date is selected in the Weekly and Monthly views.

Syntax

Visual Basic
Public Event BeforeDateSelect( _
   ByVal dtDate As Date _
)

Parameters

dtDate
The date being selected.

Remarks

The Cancel Method can be called in this event to prevent the date from being selected.

See Also


%%PageItemTitle%%

BeforeReportPrint Event
nPaperSize
The paper size selected by the user (enumerated value)
nOrientation
The paper orientation selected by the user
ctxCalendar Object : BeforeReportPrint Event

Description

Occurs just before a printed report is created.

Syntax

Visual Basic
Public Event BeforeReportPrint( _
   ByVal nPaperSize As Integer, _
   ByVal nOrientation As Integer _
)

Parameters

nPaperSize
The paper size selected by the user (enumerated value)
nOrientation
The paper orientation selected by the user

Remarks

The event can be used to adjust properties and settings of the control to match requirements for the printed report. Any values changed here, should be reset by the developer in the AfterReportPrint Event, or the changes will be reflected in the control to the user.

See Also


%%PageItemTitle%%

BeforeTimeSelect Event
nStartTime
The new start time of the selected span
nEndTime
The new end time of the selected span
nColumn
The index of the column where the selection is occurring.
ctxCalendar Object : BeforeTimeSelect Event

Description

Occurs just before a new cell in the daily view is selected.

Syntax

Visual Basic
Public Event BeforeTimeSelect( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nStartTime
The new start time of the selected span
nEndTime
The new end time of the selected span
nColumn
The index of the column where the selection is occurring.

Remarks

When selecting multiple cells, the values passed to this event will indicate the fully selected span and not just the most recent cell.

The Cancel Method can be called in this event to prevent the user from seelcting a time cell.

See Also


%%PageItemTitle%%

Click Event
ctxCalendar Object : Click Event

Description

Occurs when the user clicks the control with the mouse.

Syntax

Visual Basic
Public Event Click()

See Also


%%PageItemTitle%%

ControlError Event
nError
The error code indicating the type of error encountered.
nIndex
The index of the relative object related to the error.
ctxCalendar Object : ControlError Event

Description

Occurs when the control encounters an internal error.

Syntax

Visual Basic
Public Event ControlError( _
   ByVal nError As Integer, _
   ByVal nIndex As Integer _
)

Parameters

nError
The error code indicating the type of error encountered.
nIndex
The index of the relative object related to the error.

See Also

ctxCalendar Object | ctxCalendar Members | Developing with ctxCalendar - Error Messages


%%PageItemTitle%%

DateClick Event
dtDate
The date that was clicked.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code for the calendar where the click occurred.
nLocation
The Location code for the calendar where the click occurred.
nTask
The Task code for the calendar where the click occurred.
ctxCalendar Object : DateClick Event

Description

Occurs when a date is clicked in the Weekly and Monthly views.

Syntax

Visual Basic
Public Event DateClick( _
   ByVal dtDate As Date, _
   ByVal nIndex As Integer, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer _
)

Parameters

dtDate
The date that was clicked.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code for the calendar where the click occurred.
nLocation
The Location code for the calendar where the click occurred.
nTask
The Task code for the calendar where the click occurred.

See Also


%%PageItemTitle%%

DateDblClick Event
dtDate
The date that was double clicked.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code of the calendar where the click occurred.
nLocation
The Location code of the calendar where the click occurred.
nTask
The Task code of the calendar where the click occurred.
ctxCalendar Object : DateDblClick Event

Description

Occurs when a date is double clicked in the Weekly and Monthly views.

Syntax

Visual Basic
Public Event DateDblClick( _
   ByVal dtDate As Date, _
   ByVal nIndex As Integer, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer _
)

Parameters

dtDate
The date that was double clicked.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code of the calendar where the click occurred.
nLocation
The Location code of the calendar where the click occurred.
nTask
The Task code of the calendar where the click occurred.

See Also


%%PageItemTitle%%

DateRightClick Event
dtDate
The date where the click occurred.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code of the calendar where the click occurred.
nLocation
The Location code of the calendar where the click occurred.
nTask
The Task code of the calendar where the click occurred.
ctxCalendar Object : DateRightClick Event

Description

Occurs when the user right-clicks a date in the weekly or monthly views.

Syntax

Visual Basic
Public Event DateRightClick( _
   ByVal dtDate As Date, _
   ByVal nIndex As Integer, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer _
)

Parameters

dtDate
The date where the click occurred.
nIndex
The index of the calendar where the click occurred.
nContact
The Contact code of the calendar where the click occurred.
nLocation
The Location code of the calendar where the click occurred.
nTask
The Task code of the calendar where the click occurred.

See Also


%%PageItemTitle%%

DblClick Event
ctxCalendar Object : DblClick Event

Description

Occurs when the user double clicks the control with the mouse.

Syntax

Visual Basic
Public Event DblClick()

See Also


%%PageItemTitle%%

DisplayMenu Event
ctxCalendar Object : DisplayMenu Event

Description

Occurs when the user right-clicks within the edit window of the selected appointment, and the CustomMenu Property is set to True.

Syntax

Visual Basic
Public Event DisplayMenu()

See Also


%%PageItemTitle%%

DropItem Event
nTime
Starting time where the drop occurred.
dtDate
The Date value where the drop occurred.
nContact
The Code of the contact where the drop occurred.
nLocation
The Code of the location where the drop occurred.
nTask
The Code of the task where the drop occurred.
bAllDay
Indicates if the drop was in the AllDay area.
ctxCalendar Object : DropItem Event

Description

Occurs when an item is dropped into a time cell.

Syntax

Visual Basic
Public Event DropItem( _
   ByVal nTime As Integer, _
   ByVal dtDate As Date, _
   ByVal nContact As Integer, _
   ByVal nLocation As Integer, _
   ByVal nTask As Integer, _
   ByVal bAllDay As Boolean _
)

Parameters

nTime
Starting time where the drop occurred.
dtDate
The Date value where the drop occurred.
nContact
The Code of the contact where the drop occurred.
nLocation
The Code of the location where the drop occurred.
nTask
The Code of the task where the drop occurred.
bAllDay
Indicates if the drop was in the AllDay area.

Remarks

This event is only fired if the DragDrop Method is invoked.

In the Monthly and Weekly views the nTime parameter is always 0, and the bAllDay parameter is always true. Additionally in those views only one of the nContact, nLocation and nTask parameters will contain a value based on the current AppointmentType property.

See Also


%%PageItemTitle%%

FirstDraw Event
ctxCalendar Object : FirstDraw Event

Description

Occurs immediately after the control has been painted for the first time. This can be important because some properties base their data on how the control draws itself (i.e. font information). This data will not be accurate until the control draws itself at least once.

Syntax

Visual Basic
Public Event FirstDraw()

See Also


%%PageItemTitle%%

HorzScroll Event
nValue
Horizontal scroll bar current position.
nSBCode
The ScrollBar code indicating what triggered the scroll.
ctxCalendar Object : HorzScroll Event

Description

Occurs when the value of the horizontal scroll bar is changed.

Syntax

Visual Basic
Public Event HorzScroll( _
   ByVal nValue As Integer, _
   ByVal nSBCode As Integer _
)

Parameters

nValue
Horizontal scroll bar current position.
nSBCode
The ScrollBar code indicating what triggered the scroll.

See Also


%%PageItemTitle%%

KeyDown Event
KeyCode
Contains a number which identifies the key pressed.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
ctxCalendar Object : KeyDown Event

Description

Occurs when the user presses a key while an object has the focus.

Syntax

Visual Basic
Public Event KeyDown( _
   ByRef KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
Contains a number which identifies the key pressed.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.

See Also


%%PageItemTitle%%

KeyPress Event
KeyAscii
An integer that returns a standard numeric ANSI keycode. Keyascii is passed by reference; changing it sends a different character to the object.
ctxCalendar Object : KeyPress Event

Description

Occurs when the user presses and releases an ANSI key.

Syntax

Visual Basic
Public Event KeyPress( _
   ByRef KeyAscii As Integer _
)

Parameters

KeyAscii
An integer that returns a standard numeric ANSI keycode. Keyascii is passed by reference; changing it sends a different character to the object.

See Also


%%PageItemTitle%%

KeyUp Event
KeyCode
Contains a number which identifies the key pressed.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
ctxCalendar Object : KeyUp Event

Description

Occurs when the user releases a key while an object has the focus.

Syntax

Visual Basic
Public Event KeyUp( _
   ByRef KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
Contains a number which identifies the key pressed.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.

See Also


%%PageItemTitle%%

MouseDown Event
Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.
ctxCalendar Object : MouseDown Event

Description

Occurs when the user presses a mouse button.

Syntax

Visual Basic
Public Event MouseDown( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also


%%PageItemTitle%%

MouseMove Event
Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.
ctxCalendar Object : MouseMove Event

Description

Occurs when the user moves the mouse over an object

Syntax

Visual Basic
Public Event MouseMove( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also


%%PageItemTitle%%

MouseUp Event
Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.
ctxCalendar Object : MouseUp Event

Description

Occurs when the user releases the mouse button.

Syntax

Visual Basic
Public Event MouseUp( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also


%%PageItemTitle%%

StartDragOut Event
nIndex
The index value of the appointment that is being dragged.
ctxCalendar Object : StartDragOut Event

Description

Occurs when the left mouse button is clicked and then dragged from an appointments task bar.

Syntax

Visual Basic
Public Event StartDragOut( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index value of the appointment that is being dragged.

See Also


%%PageItemTitle%%

TextChange Event
nIndex
The 1-based index of the appointment.
nKey
The ascii value of the new key being typed.
ctxCalendar Object : TextChange Event

Description

Occurs when the text in an appointment is changed.

Syntax

Visual Basic
Public Event TextChange( _
   ByVal nIndex As Integer, _
   ByVal nKey As Integer _
)

Parameters

nIndex
The 1-based index of the appointment.
nKey
The ascii value of the new key being typed.

Remarks

See Also


%%PageItemTitle%%

TimeDblClick Event
nStartTime
The start time of the cell where the double click occurred.
nEndTime
The end time of the cell where the double click occurred.
nColumn
The 1-based index of the column where the double click occurred
ctxCalendar Object : TimeDblClick Event

Description

Occurs when a time segment in the control is double clicked on.

Syntax

Visual Basic
Public Event TimeDblClick( _
   ByVal nStartTime As Integer, _
   ByVal nEndTime As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nStartTime
The start time of the cell where the double click occurred.
nEndTime
The end time of the cell where the double click occurred.
nColumn
The 1-based index of the column where the double click occurred

Remarks

The start and end times are represented as integers indicating the number of minutes since midnight.

See Also


%%PageItemTitle%%

UserDrawnCellText Event
nTime
The start time of the cell (in minutes past midnight). A value of less than 0 indicates the AllDay area.
nColumn
The 1-based index of the column containing the cell.
ctxCalendar Object : UserDrawnCellText Event

Description

Occurs after each time cell is drawn in the daily view.

Syntax

Visual Basic
Public Event UserDrawnCellText( _
   ByVal nTime As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nTime
The start time of the cell (in minutes past midnight). A value of less than 0 indicates the AllDay area.
nColumn
The 1-based index of the column containing the cell.

Remarks

The following properties can be modified in this event to adjust the appearance of individual cells in the display:

CellText Property
CellTextAlign Property
CellTextColor Property
CellTextEllipsis Property
CellTextFont Property
CellTextMultiline Property

See Also


%%PageItemTitle%%

UserDrawnColorCell Event
nTime
Starting time of the cell being drawn.
nColumn
The index of the column where the cell will be drawn.
ctxCalendar Object : UserDrawnColorCell Event

Description

Occurs just before a time a cell is drawn in the control, allowing the developer to color a cell uniquely.

Syntax

Visual Basic
Public Event UserDrawnColorCell( _
   ByVal nTime As Integer, _
   ByVal nColumn As Integer _
)

Parameters

nTime
Starting time of the cell being drawn.
nColumn
The index of the column where the cell will be drawn.

Remarks

The CellColor property can be assigned a value in this event to set a new background color for the cell to be drawn.

See Also


%%PageItemTitle%%

UserDrawnDateHeaderText Event
strText
The default text that will be written.
dtDate
The date value of the header being drawn.
ctxCalendar Object : UserDrawnDateHeaderText Event

Description

Occurs before the text is drawn in the headers of each date in the weekly/monthly view

Syntax

Visual Basic
Public Event UserDrawnDateHeaderText( _
   ByVal strText As String, _
   ByVal dtDate As Date _
)

Parameters

strText
The default text that will be written.
dtDate
The date value of the header being drawn.

Remarks

The following properties can be used in this event to override the default display of the text:

DateHeaderText Property
DateHeaderTextColor Property

See Also


%%PageItemTitle%%

UserDrawnHeaderImage Event
dtDate
The date of the column where the header is being drawn.
ctxCalendar Object : UserDrawnHeaderImage Event

Description

Occurs just before a header for a date column is drawn in the daily view.

Syntax

Visual Basic
Public Event UserDrawnHeaderImage( _
   ByVal dtDate As Date _
)

Parameters

dtDate
The date of the column where the header is being drawn.

Remarks

Allows the developer to assign a value to the UserDrawnHeaderImage Property to be displayed in the header section of the date column being drawn.

See Also


%%PageItemTitle%%

UserDrawnPageNumber Event
strText
The default text string that will be printed.
nPage
The current page number.
nSection
The current section number.
ctxCalendar Object : UserDrawnPageNumber Event

Description

Occurs just before a page number is written on a printed report.

Syntax

Visual Basic
Public Event UserDrawnPageNumber( _
   ByVal strText As String, _
   ByVal nPage As Integer, _
   ByVal nSection As Integer _
)

Parameters

strText
The default text string that will be printed.
nPage
The current page number.
nSection
The current section number.

Remarks

The PrintPageText property can be assigned a new value in this event to display a custom page number display in a printed report.

See Also


%%PageItemTitle%%

UserDrawnShowTime Event
nIndex
The index of the appointment where the text will be displayed.
ctxCalendar Object : UserDrawnShowTime Event

Description

Occurs just before the Time text is displayed in an appointment.

Syntax

Visual Basic
Public Event UserDrawnShowTime( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The index of the appointment where the text will be displayed.

Remarks

The Time text display is determined by the AppointmentShowTime Property.

The developer can override the default text by assigning a new value to the ShowTimeText Property in this event.

See Also


%%PageItemTitle%%

UserDrawnWeekSummary Event
dtDate
The first date of the week.
ctxCalendar Object : UserDrawnWeekSummary Event

Description

Occurs just before the text is displayed in a WeekSummary in the Monthly view of the control.

Syntax

Visual Basic
Public Event UserDrawnWeekSummary( _
   ByVal dtDate As Date _
)

Parameters

dtDate
The first date of the week.

Remarks

In this event, the developer can use the WeekSummaryText Property to assign a custom string to the WeekSummary about to be drawn.

See Also


%%PageItemTitle%%

VertScroll Event
nValue
The value of the scroll bar
nSBCode
The ScrollBar code indicating what triggered the scroll.
ctxCalendar Object : VertScroll Event

Description

Occurs when the value of the vertical scroll bar is changed.

Syntax

Visual Basic
Public Event VertScroll( _
   ByVal nValue As Integer, _
   ByVal nSBCode As Integer _
)

Parameters

nValue
The value of the scroll bar
nSBCode
The ScrollBar code indicating what triggered the scroll.

See Also


%%PageItemTitle%%

ViewPainted Event
dtStartDate
The first date in the new display of the control.
dtEndDate
The last date in the new display of the control.
ctxCalendar Object : ViewPainted Event

Description

Occurs just after the calendar has been painted.

Syntax

Visual Basic
Public Event ViewPainted( _
   ByVal dtStartDate As Date, _
   ByVal dtEndDate As Date _
)

Parameters

dtStartDate
The first date in the new display of the control.
dtEndDate
The last date in the new display of the control.

See Also


%%PageItemTitle%%

ViewTypeChanged Event
nViewType
The new ViewType the control is displaying.
ctxCalendar Object : ViewTypeChanged Event

Description

Occurs when the ViewType Property is changed.

Syntax

Visual Basic
Public Event ViewTypeChanged( _
   ByVal nViewType As Integer _
)

Parameters

nViewType
The new ViewType the control is displaying.

See Also


%%PageItemTitle%%

enumAlignment Enumeration

Description

Specifies a horizontal alignment

Members

Member | Value | Description
Align_Center | 2 | Center
Align_Left | 0 | Left Justify
Align_Right | 1 | Right Justify


%%PageItemTitle%%

enumAmPmPosition Enumeration

Description

Available positions for placing the AM/PM text.

Members

Member | Value | Description
AmPmPosition_InMinutes | 2 | Am/Pm will be displayed in the minutes.
AmPmPosition_Invisible | 0 | Am/Pm will not be displayed.
AmPmPosition_UnderHour | 1 | Am/Pm will be displayed under the hour.

Example

© 2020 DBI Technologies Inc. All Rights Reserved.


%%PageItemTitle%%

enumAppInfoLinePriority Enumeration

Description

Available options for setting a priority of the infoline on individual appointments.

Members

Member | Value | Description
InfoLine_Default | 0 | InfoLine priority is determined by the InfoLinePriority property
InfoLine_False | 2 | InfoLine does not have priority.
InfoLine_True | 1 | InfoLine has priority.

Example

© 2020 DBI Technologies Inc. All Rights Reserved.


%%PageItemTitle%%

enumAppointmentType Enumeration

Description

Available options for grouping appointments in the display

Members

Member | Value | Description
AppointmentType_Contact | 1 | Contact
AppointmentType_Date | 0 | Date
AppointmentType_Location | 2 | Location
AppointmentType_Task | 3 | Task


%%PageItemTitle%%

enumArrowPosition Enumeration

Description

Available display options for the arrows indicating additional appointments.

Members

Member | Value | Description
Arrow_Column | 2 | Show the arrow in the right side of the column.
Arrow_None | 0 | No arrows visible.
Arrow_Time | 1 | Show the arrow in the time ruler.


%%PageItemTitle%%

enumBorderType Enumeration

Description

Available border types for the control.

Members

Member | Value | Description
BorderLowered | 3 | Lowered 3D border
BorderNone | 1 | No border
BorderRaised | 2 | Raised 3D border
BorderRegular | 0 | Regular border


%%PageItemTitle%%

enumControlStyle Enumeration

Description

Available built-in styles for the control.

Members

Member | Value | Description
Style_CustomFlat | 6 | Custom Flat (uses the CustomColor1, CustomColor2 and CustomColor3 properties)
Style_Default | 0 | No effect on the control.
Style_LunaBlue | 1 | Luna Blue inspired style
Style_LunaGreen | 2 | Luna Green inspired style
Style_OfficeFlat | 5 | Microsoft Office inspired style
Style_RoyalBlue | 3 | Royal BLue inspired style
Style_ThemeBlack | 4 | A dark color scheme style


%%PageItemTitle%%

enumCustomAreasFilter Enumeration

Description

Available options for filtering the display of custom areas.

Members

Member | Value | Description
CAFilter_Any | 1 | If any settings on the custom area match the current view, then it will be included.
CAFilter_Exact | 2 | The current view and the current settings of the custom area must match completely to display the custom area.
CAFilter_Specific | 0 | Only properties on the custom area that have been specified a value will be required to match the current view.


%%PageItemTitle%%

enumDateHorzLines Enumeration

Description

Available drawing styles for the horizontal line separating the rows of dates in the monthly view.

Members

Member | Value | Description
DateLine_Regular | 0 | A thickness that matches the rest of the control.
DateLine_Thick | 1 | A thicker line to distinguish itself.


%%PageItemTitle%%

enumDateSelectType Enumeration

Description

Available options for highlighting the dates in the weekly and monthly views.

Members

Member | Value | Description
Select_Date | 1 | Only the top portion of the date, where the date text resides, is highlighted
Select_Full | 0 | The entire date is selected.


%%PageItemTitle%%

enumDayOfWeek Enumeration

Description

The available days of the week for setting the FirstDayOfWeek property.

Members

Member | Value | Description
Day_Friday | 5 | Friday
Day_Monday | 1 | Monday
Day_Saturday | 6 | Saturday
Day_Sunday | 0 | Sunday
Day_Thursday | 4 | Thursday
Day_Tuesday | 2 | Tuesday
Day_Wednesday | 3 | Wednesday


%%PageItemTitle%%

enumEnterKey Enumeration

Description

Available behavior for the Enter key when editing appointment text.

Members

Member | Value | Description
Enter_Hard | 1 | The editing session is ended and the text committed to the appointment.
Enter_Soft | 0 | A new line is fed into the edit window of the appointment.


%%PageItemTitle%%

enumFillType Enumeration

Description

Specifies the fill pattern.

Members

Member | Value | Description
FillCircle | 9 | Circle
FillDiagonal | 3 | Diagonal
FillDiamond | 7 | Diamond
FillEllipse | 10 | Ellipse
FillHorizontal | 1 | Horizontal
FillHorzBump | 5 | Horizontal Bump
FillHorzEdge | 11 | Horizontal Edge
FillPyramid | 8 | Pyramid
FillRevDiag | 4 | Reverse Diagonal
FillSolid | 0 | Solid
FillVertBump | 6 | Vertical Bump
FillVertEdge | 12 | Vertical Edge
FillVertEdge2 | 13 | Vertical Edge 2
FillVertical | 2 | Vertical


%%PageItemTitle%%

enumGroupType Enumeration

Description

Available options for secondary grouping of appointments.

Members

Member | Value | Description
GroupType_Contact | 1 | Contact
GroupType_Date | 0 | Date
GroupType_Location | 2 | Location
GroupType_None | 4 | None
GroupType_Task | 3 | Task


%%PageItemTitle%%

enumHeaderBorderStyle Enumeration

Description

Available border styles for the weekday headers in the monthly view.

Members

Member | Value | Description
HBorder_Line | 2 | A single line to the left and right of each day name. slightly short then the height of the header.
HBorder_None | 0 | No border applied.
HBorder_Regular | 1 | A full single line border around each weekday header.


%%PageItemTitle%%

enumHourStyle Enumeration

Description

Available display options for the Hour integer in the Time Line of a daily view.

Members

Member | Value | Description
HourStyle_Centered | 1 | The hour will be centered in the available space.
HourStyle_Floating | 0 | The Hour digit position will be static, while the Am/Pm value will scroll with the view.


%%PageItemTitle%%

enumItemTypes Enumeration

Description

The types of objects that can be recorded by the advanced hittest functionality

Members

Member | Value | Description
Type_AllDayArrowDown | 53 | A down arrow in the AllDay area of a column in the daily view.
Type_AllDayArrowUp | 54 | An up arrow in the AllDay area of of a column in the daily view.
Type_AllDayCell | 5 | An AllDay area of a column in the daily view.
Type_Appointment | 1 | An Appointment
Type_AppointSizeEnd | 63 | The resize handle for the end time of an appointment in the daily view.
Type_AppointSizeStart | 61 | The resize handle for the start time of an appointment in the daily view.
Type_Cell | 4 | A time cell within a column of the daily view.
Type_CustomArea | 8 | A CustomArea
Type_Date | 2 | A Date within the weekly or monthly views.
Type_DayArrowDown | 51 | A down arrow in either a column of the daily view, or a date in the weekly/monthly views.
Type_DayArrowUp | 52 | An up arrow in either a column of the daily view, or a date in the weekly/monthly views.
Type_Header | 7 | The header of a column or a sub column, when grouping, in the daily view , the days of the week in a monthly view, or a DateHeader in the weekly/monthly views.
Type_NextIndicate | 57 | The Next Appointment indicator in the daily view.
Type_None | 0 | Default value
Type_PrevIndicate | 56 | The Previous Appointment indicator in the daily view.
Type_TimeArea | 9 | The Time Area in the daily view.
Type_Title | 6 | The top row of a split column header when grouping in the daily view, or the title section in the weekly/monthly views.
Type_WeekSummary | 3 | The WeekSummary area in the monthly view.


%%PageItemTitle%%

enumMinuteDisplay Enumeration

Description

Available options for where the Minutes will be drawn relative to the Hours in a daily time line.

Members

Member | Value | Description
MinuteDisplay_All | 0 | Minutes will be rendered at all time segments of the hour.
MinuteDisplay_First | 1 | Minutes will only be rendered in the first time segment of the hour.


%%PageItemTitle%%

enumMinuteFormat Enumeration

Description

Available formats for displaying the minutes of each Hour in the time line, when TimeType is Split.

Members

Member | Value | Description
MinuteFormat_Colon | 3 | The minutes will appear with a colon and 2 digits (:00, :15).
MinuteFormat_Double | 2 | The minutes will appear with 2 digits (00, 15).
MinuteFormat_None | 0 | The minutes will not be displayed.
MinuteFormat_Single | 1 | The minutes will appear with 1 or 2 digits (0, 15).


%%PageItemTitle%%

enumPosition Enumeration

Description

Available positions for the appointment indicators inside the daily view of the control.

Members

Member | Value | Description
Position_Back | 2 | The indicators are drawn behind the border of the control.
Position_Front | 1 | The indicators are drawn in front of the border of the control.
Position_None | 0 | No appointment indicators are displayed.


%%PageItemTitle%%

enumPrintReportType Enumeration

Description

AVialable types of printed reports.

Members

Member | Value | Description
Print_All | 1 | The entire control will be printed.
Print_Current | 0 | Only the currently visible portion of the control will be printed.


%%PageItemTitle%%

enumProperties Enumeration

Description

Options for displaying the custom property pages of the control.

Members

Member | Value | Description
Display | 1 | Display the property pages.
None | 0 | Default value, does nothing.


%%PageItemTitle%%

enumShowTimes Enumeration

Description

Available options for displaying times in the appointments in week and month views.

Members

Member | Value | Description
Show_Both | 2 | Both the start and end times will be displayed before the appointment text.
Show_None | 0 | Neither time will be displayed in the appointment.
Show_Start | 1 | Just the start time will be displayed before the appointment text.


%%PageItemTitle%%

enumTextAngle Enumeration

Description

Available options for adjusting the angle of the display of text.

Members

Member | Value | Description
TextAngle_0 | 0 | Text is displayed at a 0 degree angle
TextAngle_180 | 2 | Text is displayed at a 180 degree angle
TextAngle_270 | 3 | Text is displayed at a 270 degree angle
TextAngle_90 | 1 | Text is displayed at a 90 degree angle


%%PageItemTitle%%

enumTimeBorderType Enumeration

Description

Available options for the border displayed around the hours in the daily view time line.

Members

Member | Value | Description
TimeBorderType_Full | 2 | A complete border around each hour
TimeBorderType_Line | 1 | A single line is rendered separating each hour
TimeBorderType_None | 0 | No border is rendered around the hours


%%PageItemTitle%%

enumTimeType Enumeration

Description

Available options for the display of the hours and minutes along the time line of a daily view.

Members

Member | Value | Description
TimeType_Full | 0 | Both the hours and minutes will be placed on a single line.
TimeType_Split | 1 | Minutes are placed on individual lines and hours are placed within a block of those minutes.


%%PageItemTitle%%

enumTodayStyle Enumeration

Description

Available options for styling the current date in the daily view of the control.

Members

Member | Value | Description
Today_Full | 2 | The header of the column will be colored and a border will be rendered around the entire column.
Today_Header | 1 | The header of the column will be colored.
Today_None | 0 | No unique styling will be applied.


%%PageItemTitle%%

enumViewType Enumeration

Description

Available display options for the control.

Members

Member | Value | Description
ViewType_Daily | 2 | A Single/Multi day (column) view.
ViewType_Monthly | 0 | A Multi-Week Month view
ViewType_Weekly | 1 | A 7-day weekly view.


%%PageItemTitle%%

enumYearDisplay Enumeration

Description

Available options for the display of the year value of a date in the Monthly and weekly views.

Members

Member | Value | Description
Display_2Digits | 1 | Only the last two digits will be used.
Display_4Digits | 2 | All four digits will be used.
Display_None | 0 | No year value will be displayed.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Creating and Saving Appointments

Glossary Item Box

There are two ways in which you can add appointments to the control.

The first is to use the mouse and keyboard. You simply select and highlight a series of time lines in the Day View area of the control, and then you start to type in some text. An appointment will automatically be created.

The second method is to use the AddAppointment or AddKeyAppointment methods.

Since an appointment can be created with a mouse, a BeforeAppointmentAdd Event is fired just before the appointment is created, and the AfterAppointmentAdd Event when a new appointment is created. When an appointment is created with the mouse, it is automatically assigned in internal ID key. This ID key can be changed at any time, it is suggested that you use it to help identify the appointment for other operations such as moving or deleting the appointment.

The AfterAppointmentAdd Event is used for both methods of adding an appointment. However, the BeforeAppointmentAdd Event is only fired is appointment is created with the mouse and keyboard. If an appointment is being created through code, the programmer will be responsible to make sure the appointment is in a valid area, and/or a database item is created for it.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Working with Appointments and a Database

Glossary Item Box

Saving Appointments in the Control

The easiest method to save appointments in the control is to capture the appointment information when the AfterAppointmentUnSelect Event is fired. This event is fired every time an appointment is un-selected. The event receives the index value (index) associated with appointment being un-selected. This information can be used to find the Key Value associated with the appointment.
Key Value = ctxCalendar.Appointment_KeyID(nIndex)

When adding appointments to the ctxCalendar using the mouse, the Appointment_KeyID is set to a random GUID string (alpha/numeric).

Relating Appointments in the Control to Appointments in a Database

When setting up a database to store appointments, it is recommended that a field be assigned a unique value for each appointment. This value is passed along with the appointment, and can be queried at any time the appointment exists in the control. To find the key value of an appointment, use the Appointment_KeyID Property, which will return the key value as specified in the AddKeyAppointment Method. For example:

If the appointment was added to the control using:
nIndex = ctxCalendar.AddKeyAppointment (Start Time, End Time, Date, Text, Key Value)
The key value could be queried using:
Key Value = ctxCalendar.Appointment_KeyID(nIndex)

In the case where a new appointment is added to the database using the ctxCalendar control, a Key Value can be assigned to the appointment in the control using:
ctxCalendar.Appointment_KeyID(nIndex) = Key Value


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Placing Restrictions on an Appointment

Glossary Item Box

There are a variety of different methods that may be used to restrict the user’s access to appointments

When an appointment is first selected, the BeforeAppointmentSelect Event will be fired. Within that event, the Cancel Method can be used to block the selection.

Use the Appointment_ReadOnly Property to set a specific appointment to read-only status. This means that selecting an appointment will not put it into edit mode, however the appointment can still be moved by the user.

Use the Appointment_Locked Property to prevent an appointment from being moved. However, locking an appointment will not prevent its text from being edited.

The IsAppointmentAt Method can be used to determine if an appointment already exists at a given time in a certain column. This can be useful to prevent appointments from overlapping.

A CustomArea Dead Zone can be created and placed in a column of the day view. If an appointment is created or moved within the area, the action will fail.

Restricting Appointments from Moving Horizontally

Just before an appointment is placed into a new time or column, the BeforeAppointmentChange Event will be fired. Within that event, the Cancel Method can be used to block the drop.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Right Clicking on a Selected Appointment

Glossary Item Box

When the user is entering or editing text within an appointment in the control, they are doing it within an edit box. By default, when the user right clicks on this edit box, a default menu for that box will appear.

In some cases however, the programmer may wish to provide their own menu or service, or have nothing happen at all when the user right clicks on the box. This can be accomplished by setting the CustomMenu Property to a value of True. After the property has been set, right clicking on the edit box will prevent the default menu from appearing, and the DisplayMenu Event will fire instead. It is within this event that the programmer can place code for their own menu or service.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Defining Multiple Columns, Calendars and Column Types

Glossary Item Box

The ctxCalendar control can be set up with multiple columns in the day view or multiple calendars in the month and week views.

The columns can be defined by date, contact, location and/or task, based on the AppoointmentType and GroupType properties.

The maximum number of visible columns/calendars that may be displayed in the control is 30 in the day view and 8 in the month and week views. However, the total amount of columns/calendars is determined by the start and end date selection, and/or the amount of contacts, locations, or tasks defined within the control, and the current values selected in the AppointmentType and GroupType properties.
The maximum amount of columns displayed in the day view is determined by the DayColumns Property. The maximum amount of calendars displayed in the month and week views is determined by the CalendarColumns Property.

Note : While it is possible for this control to hold up to 32,000 appointments, the control itself uses no methods to sort the appointments. Therefore, if you place too many appointments into the control, its performance may degrade. For maximum performance, it is the responsibility of the programmer using this control to design a methodology to ensure that only the appointments required for immediate viewing are within the control at any one time.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Implementing Drag and Drop

Glossary Item Box

Dragging Into the Control

The ctxCalendar control will only support drag and drop operations if the host language supports drag and drop within an OLE control. Languages such as Visual Basic and Delphi will automatically attach DragOver and DragDrop events to an OLE control. It is these events that are used to help to support drag and drop within the control.

Drag and drop information must be supplied by the host language and then sent to the controls DragDrop Method and DragOver Method. For example, to start a drag and drop operation, we must first start with the DragOver event supplied to the control by the host language. The example below would use Visual Basic as the host language.

Private Sub ctxCalendar_DragOver(Source As Control, X As Single, Y As Single, State As Integer)

ctxCalendar.DragOver (X/Screen.TwipsPerPixelX), (Y/Screen.TwipsPerPixelY), State

End Sub

In this case, the DragOver Method is passed the coordinates of the mouse pointer, and the current state variable of the drag. This will allow the control to draw the drag border around the appropriate time cell or date. The mouse coordinates are also converted from twips to pixels. Depending on your development language this may or may not be necessary. ctxCalendar uses pixels to determine how to draw itself.

When an item is dropped into the control, the information can be intercepted in the DragDrop event and passed to the DragDrop Method. For example ...

Private Sub ctxCalendar_DragDrop(Source As Control, X As Single, Y As Single)

ctxCalendar.DragDrop (X / Screen.TwipsPerPixelX), (Y / Screen.TwipsPerPixelY)

End Sub

With this information, the control is notified that an item was dropped into it at a certain coordinate. This will cause the control to fire the DropItem Event where it will report the details of where the the item was dropped into.

Private Sub ctxCalendar1_DropItem(ByVal nTime As Integer, ByVal dtDate As Date, ByVal nContact As Integer, ByVal nLocation As Integer, ByVal nTask As Integer, ByVal bAllDay As Boolean)
Dim nIndex As Integer

nIndex = ctxCalendar1.AddAppointment(nTime, nTime + ctxCalendar1.TimeIncrement, dtDate, "Appointment Text")
ctxCalendar1.Appointment_ContactCode(nIndex) = nContact
ctxCalendar1.Appointment_LocationCode(nIndex) = nLocation
ctxCalendar1.Appointment_TaskCode(nIndex) = nTask
ctxCalendar1.Appointment_AllDayEvent(nIndex) = bAllDay
End Sub

Note : In the code examples above, the X and Y coordinates were always divided by Screen.TwipsPerPixelX and Screen.TwipsPerPixelY. This is because Visual Basic reports all if its information in logical units, where the control uses pixels for its sizing. Sizing information comes from properties such as height, width, top, and left. Therefore, we had to convert all sizing information from logical units to pixels before we sent it to the control. In languages such as Delphi, this is not necessary since it also reports its sizing information in pixels. Refer to the host language user manuals to determine if Drag and Drop is supported in an OLE control, and for how the language reports its sizing information.

Dragging Out Of the Control

It is also possible to drag appointments out of the control. To do so, click and drag on an appointments task bar. The task bar is the vertical bar along the left side of an appointment. As soon as the drag occurs, the StartDragOut Event will be fired. At that time, you will be able to put the control into a drag mode and start the drag operation. The following Visual Basic code demonstrates how to do this ...

Private Sub ctxCalendar_StartDragOut()

ctxCalendar.Drag vbBeginDrag

End Sub

NOTE : Before the control is put into drag mode, it is highly recommended that the BeginDrag Method be called. This is because as the StartDragOut event is fired, the control is preparing to start its own internal drag operation. Calling the BeginDrag Method resets the internal drag operation, and allows for a clean external drag.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Determine the Selected Dates in a Monthly or Weekly View

Glossary Item Box

By default, the selected date of a calendar view is determined by the Date Property. However, if the MultiSelect Property is set to True, then multiple dates can be selected. To determine what these dates are, we use the SelectedDaysCount Property and SelectedDays Method.

For nCntr = 1 To ctxCalendar1.SelectedDaysCount
List1.AddItem Str(ctxCalendar1.SelectedDays(nCntr))
Next


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Using the Image list

Glossary Item Box

The ctxCalendar control can displaying a variety of different images within the control by assigning images to the internal image list. Images can be added to the internal image list at design time through the Image tab in the properties pages or at run-time using the AddImage Method. The internal image list can store up to 100 images. The valid image types are .ico and .bmp. When referencing an image within the image list, the index value is directly proportional to the position in the image list.

Image List image

The internal image list found on the Image tab in the custom property pages.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Custom Flat Control Style

Glossary Item Box

Most of the styles available to the ControlStyle Property of the control are completely hard coded internally in the control. One exception to this, is the Style_CustomFlat value, which allows the developer to select the three colors the style will use when modifying the control. The colors are chosen by the developer by assigning values to the CustomColor1, CustomColor2 and CustomColor3 properties of the control before assigning the Style_CustomFlat value to the ControlStyle Property.

The following are some examples that can be used to create an MS Office style look and feel. For the most optimal view here, our custom colors go from darkest to lightest.

ctxCalendar1.CustomColor1 = RGB(43, 87, 154) ’ &H009A572B
ctxCalendar1.CustomColor2 = RGB(118, 150, 198) ‘ &H00C69676
ctxCalendar1.CustomColor3 = RGB(194, 213, 242) ’ &H00F2D5C2
ctxCalendar1.ControlStyle = Style_CustomFlat

ctxCalendar1.CustomColor1 = RGB(33, 115, 70) ’ &H00467321
ctxCalendar1.CustomColor2 = RGB(96, 164, 126) ‘ &H007EA460
ctxCalendar1.CustomColor3 = RGB(159, 213, 183) ’ &H00B7D59F
ctxCalendar1.ControlStyle = Style_CustomFlat

ctxCalendar1.CustomColor1 = RGB(164, 55, 58) ’ &H003A37A4
ctxCalendar1.CustomColor2 = RGB(208, 124, 127) ‘ &H007F7CD0
ctxCalendar1.CustomColor3 = RGB(252, 194, 196) ’ &H00C4C2FC
ctxCalendar1.ControlStyle = Style_CustomFlat

ctxCalendar1.CustomColor1 = RGB(210, 71, 38) ’ &H00D24726
ctxCalendar1.CustomColor2 = RGB(231, 138, 100) ‘ &H00E78A64
ctxCalendar1.CustomColor3 = RGB(252, 205, 182) ’ &H00FCCDB6
ctxCalendar1.ControlStyle = Style_CustomFlat


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Creating An Image

Glossary Item Box

The ctxCalendar control is capable of generating an image of itself into a file on a local or mapped drive. This can be very useful when posting a visual representation of the control on a web site or as an attachment to an email.

An image is created using the CreateImage method. This method accepts four parameters. The first is the name of the file to be created. The second and third parameters then determine the size of image. The fourth paramater is the type of image format to genererate.

The image size can be set up in three different ways:

Fixed Size

If the second and third parameters are sent a value greater than 5, the height and width of the image will be that of the values sent to those parameters. The first line item in the image will be the current top visible time in the control.

Actual Size

If the second and third parameters are sent a value of 0, the height and width of the image will be set to the current size of the actual control. The first line item in the image will be the current top visible item in the control. The image will be what is on the screen at the time the image is created.

Full Size

The second and third parameters can be used to specify if the generated output is to contain all of the contents of the control or just the visible area of the control. If a value of -1 is sent to the second parameter, the control will generate an image containing the entire height (all items) in the control. If a value of 0 is sent to the second parameter the generated output will display only the visible items in the control. If a value of -1 is sent to the third parameter, the control will generate output containing the entire width of the control. If a value of 0 is sent to the third parameter the generated output will display only the visible width of the control.

NOTE: A full size image (-1,-1) may be too large to actually produce. To ensure that the image does not get too large, the developer can set height and width limits using the MaxImageHeight and MaxImageWidth properties respectively. Additionally, the MaxImageDayColumns and MaxImageCalendarColumns properties can be used to restrict the number of columns generated within the image (reducing the total required width). These properties will only take effect if their value is greater than 0 (for the height and width) and a value of -1 was sent to the respective CreateImage parameters.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Reading and Writing XML Data

Glossary Item Box

The ctxCalendar control is capable of reading and writing XML data. The data can be read and written as a string into or from memory, or to and from a file. The control is also capable of creating XML data for the entire control, details of just the Appointments, or all the objects except the appointments.

Read and Write an XML File

The methods used to read and write the xml files are the ReadFile and WriteFile. A valid XML file can be read from a local drive, a mapped drive, or from a web site. However, you may only write a file to a local or mapped drive.

Both of these methods accept two parameters. The first is the name of the file. When reading or writing a file, the full path, file name, and extension must be included as part of the parameter. The second parameter is used to determine what type of data is read or written. If a value of 0 is sent to either method, then all relevant data is read from the file, or written to the file. If a value of 1 is sent, then only the appointment detail information will be read or written, The general property information will be ignored. A value of 2 will have all the details of the control (properties and the objects) except for the appointments read/written. The type of data not included in an XML file include the image information.

Reading and XML string

The ctxCalendar control contains a ReadXMLString method, when read, this method will pass the data in an XML format into a memory variable. This property is similar to the WriteFile method, but instead of writing the data to a file, it is read into a memory variable.

READING AND WRITING XML FILES AT DESIGN TIME

One of the benefits of the XML functionality built into the ctxCalendar control is the ability to read and write XML files at design time. This can be very useful in instances where a control is being upgraded from one version to another (i.e. save the properties, upgrade, and then load in the new control), or to share control styles between developers.

The property window for the ctxCalendar includes an XMLRead property and an XMLWrite property. When a character string is entered into one of these fields, an Open (XMLRead) or Save File (XMLWrite) dialog will appear to allow the developer to specify the path to read or write an XML file. NOTE: The XMLWrite property will only write data for the entire control (i.e. not individual collection data such as appointments).

NOTE: The XML functionality requires MSXML4.dll be installed on the host system.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Printing Options within the Control

Glossary Item Box

The ctxCalendar control is able to produce printed output using the PrintCalendar Method. This method will produce an entire report based on the data that currently resides in the control.

The following properties are used to help create a printed schedule using the PrintCalendar Method.

Item | Type | Accessing Property
Returns/sets the maximum number of columns to include per page of a printed report. | Integer | PrintColsPerPage
Returns/sets the last column to include in a printed report. | Integer | PrintColumnEnd
Returns/sets the first column to include in a printed report. | Integer | PrintColumnStart
Returns/sets the font of a printed report. | Font | PrintFont
Returns/sets the bottom page margin of a printed report. | integer | PrintMarginBottom
Returns/sets the left page margin of a printed report. | integer | PrintMarginLeft
Returns/sets the right page margin of a printed report. | integer | PrintMarginRight
Returns/sets the top page margin of a printed report. | integer | PrintMarginTop
Returns/sets the horizontal text alignment of page numbers in a printed report. | enumAlignment | PrintPageNumberAlign
Determines if page numbers will be placed in a printed report. | boolean | PrintPageNumbers
Sets the string to be displayed as the page number text for a printed page. | string | PrintPageText
Returns/sets the type of printed report to create. | enumPrintReportType | PrintReportType
Returns/sets the sub-title of a printed report. | string | PrintSubTitle
Returns/sets the end time of a printed report. | Integer | PrintTimeEnd
Returns/sets the start time of a printed report. | Integer | PrintTimeStart
Returns/sets the title of a printed report. | string | PrintTitle
Returns/sets the horizontal text alignment of the title and sub-title of a printed report. | enumAlignment | PrintTitleAlign
Returns/sets the title font of a printed report. | Font | PrintTitleFont

The following events fire as the printing operation occurs.

Description | Event
Occurs after a printed report has been created. | AfterReportPrint
Occurs just before a printed report is created. | BeforeReportPrint
Occurs just before a page number is written on a printed report. | UserDrawnPageNumber


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - iCalendar Support

Glossary Item Box

The iCalendar specifications are meant to allow the transfer of calendaring and scheduling information between different applications. The ctxCalendar control supports a limited amount of properties from an iCalendar event. A typical iCalendar event may look like the following ...

BEGIN:VCALENDAR

VERSION:2.0

PRODID:JFHK339

BEGIN:VEVENT

DTSTART:20160402T103000

DTEND:20160402T113000

DESCRIPTION:Meeting in the board room

END:VEVENT

END:VCALENDAR

iCalendar strings can be used to add new appointments to the control by passing them to the AddvCalAppointment Method of the control. The current vCal string for an appointment can also be retireved (or a new one massigned) through the Appointment_vCalInfo Property.

The following iCalendar properties are supported in the ctxCalendar control.

iCalendar Property ctxCalendar Property

PRODID Key ID - Appointment_KeyID Property

DTSTART Start date and time - Appointment_Date Property & Appointment_TimeStart Property

DTEND End date and time - Appointment_Date Property & Appointment_TimeEnd Property

DESCRIPTION Appointment text - Appointment_Text Property

LOCATION Location - Appointment_Location Property

COMMENT General text - Appointment_Comment Property

Note : While the control does support the DTSTART and DTEND properties, there is no support at this time for time zones. The control assumes that the times sent to it have already been converted for the control.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Troubleshooting

Glossary Item Box

Cannot see the Text when Editing an Appointment

When you go to edit text in an appointment in the Day View part of the control, it may appear as if the text disappears when the editing starts. If this happens, it is because the row height of each time line is not high enough for the chosen font in the edit box.

If this is happening, simply change the TimeHeightOffset Property to a higher value until the text can become visible.

Cannot see the Text in the App Indicator or Week Summary Areas

By default, the text in the app indicator and week summary area is rotated on its side. However, only True Type fonts can be rotated. In some languages such as VB6, the default font is not a True Type font.
If this is happening, simply select a True Type font for the AppIndicatorFont and/or WeekSummaryFont properties.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Error Messages

Glossary Item Box

There are a variety of different errors that can be trapped when using this control. All error messages are sent directly to the ControlError Event and are sent as an integer value. These include:

1 - An attempt was made to create an appointment in a dead zone.
2 - An attempt was made to move an appointment in to a dead zone.

1000 - Unable to Load XML - An error occurred with trying to load the supplied XML file.
1001 - Invalid XML - The supplied XML file is not a valid format.
1002 - Unable to Retrieve XML - An error occurred with parsing the XML contents.
1003 - Unable to Initialize XML - An error occurred with initializing the internal XML routines.
1004 - Unable to Create File - The control was unable to generate the requested XML file.
1006 - Create Image Too Large - The control was unable to generate the requested Image, as it was too large.

32000 - Out of Memory - There is no longer any available memory to store new items.
32002 - Too Many Items - An attempt was made to add an item beyond the respective arrays 32000 limit.
32003 - Bad Item Index - An attempt was made to access an item that is outside the present range of the respective items.
32007 - Bad VCalendar String - An attempt was made to use a VCalendar string that was not formatted properly.
32008 - Bad VCalendar Dates and Times - An attempt was made to use a VCalendar string that did not have proper dates and times values.
32009 - Bad Code ID - An attempt was made to create a Contact/Location/Task with a Code value of 0 or less.
32020 - Too Many Images - An attempt was made to add more than 100 images to the internal image list.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Developing with ctxCalendar - Using the HitTest Methods

Glossary Item Box

The HitTest methods of the control allow the developer to determine what data is currently under the cursor or at a specified set of coordinates (x,y).

The Standard HitTest methods:

AppointmentAt

ColumnAt

DateAt

TimeAt

The Advanced HitTest methods:

ItemAt

The ItemAt method returns an index value, relative to an internal array of the control. That array contains details about the various objects that can be found within the control. The developer can then use that index to retrieve the values from specific methods on the control. Depending on the type of object stored at that index of the array, and the current ViewType of the control, only certain methods will return relevant values.

The Methods the index value can be used with are:

  1. ItemAppointment
  2. ItemColumn
  3. ItemContact
  4. ItemCustomArea
  5. ItemDate
  6. ItemLocation
  7. ItemRow
  8. ItemTask
  9. ItemType

The types of objects that are stored in the array are:

  1. Appointment
  2. Date
  3. Week Summary
  4. Time Cell
  5. All Day Cell
  6. Title area
  7. Header area
  8. Custom area
  9. Time area
  10. Day Arrow Down
  11. Day Arrow Up
  12. All Day Arrow Down
  13. All Day Arrow Up
  14. Previous Indicator
  15. Next Indicator
  16. Appointment start resize handle
  17. Appointment end resize handle

Type Appointment:

Appointments exist in all views of the control.

  • ViewType: All
  • The ItemAppointment method will return the index of the appointment.
  • The ItemContact method will return the index of the contact related to the appointment (based on the current column/calendar displaying the appointment).
  • The ItemDate method will return the date of the appointment.
  • The ItemLocation method will return the index of the location related to the appointment (based on the current column/calendar displaying the appointment).
  • The ItemTask method will return the index of the task related to the appointment (based on the current column/calendar displaying the appointment).
  • ViewType: Daily
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) containing the appointment.
  • The ItemRow method will return the index of the row relative to the appointments start time.
  • ViewType: Weekly/Monthly
  • The ItemColumn method will return the index of the column within a calendar containing the appointment (weekly = 1-2, monthly = 1-7).
  • The ItemRow method will return the index of the row of the date where the appointment exists.

Type Date:

Dates exist in Weekly/Monthly views of the control.

  • ViewType: Weekly/Monthly
  • The ItemColumn method will return the index of the column within a calendar containing the date (weekly = 1-2, monthly = 1-7).
  • The ItemContact method will return the index of the contact related to the calendar containing the date.
  • The ItemDate method will return the Date value of the date.
  • The ItemLocation method will return the index of the location related to the calendar containing the date.
  • The ItemRow method will return the index of the row of the date.
  • The ItemTask method will return the index of the task related to the calendar containing the date.

Type Week Summary:

Week Summaries exist in the Monthly view of the control.

  • ViewType: Monthly
  • The ItemContact method will return the index of the contact related to the calendar displaying the week summary.
  • The ItemDate method will return the Date value of the first day of the week.
  • The ItemLocation method will return the index of the location related to the calendar displaying the week summary.
  • The ItemRow method will return the index of the row of the week summary.
  • The ItemTask method will return the index of the task related to the calendar displaying the week summary.

Type Cell:

Cells exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemContact method will return the index of the contact related to the column containing the cell.
  • The ItemDate method will return the Date value of the column containing the cell
  • The ItemLocation method will return the index of the location related to the column containing the cell.
  • The ItemRow method will return the index of the row of the cell.
  • The ItemTask method will return the index of the task related to the column containing the cell.

Type All Day Cell:

All Day Cells exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemContact method will return the index of the contact related to the column containing the all day cell.
  • The ItemDate method will return the Date value of the column containing the all day cell
  • The ItemLocation method will return the index of the location related to the column containing the all day cell.
  • The ItemRow method will return the index of the row of the all day cell.
  • The ItemTask method will return the index of the task related to the column containing the all day cell.

Type Title Area:

Title Areas exist in all views of the control.

  • ViewType: All
  • The ItemContact method will return the index of the contact related to the title.
  • The ItemLocation method will return the index of the location related to the title.
  • The ItemTask method will return the index of the task related to the title.
  • ViewType: Daily
  • The ItemDate method will return the Date value related to the title.

Type Header Area:

Header Areas exist in all views of the control. In the Daily view they are the tops of each column. In the Weekly/Monthly views they are the tops of each Date (when DateHeaders are enabled). Additionally in the Monthly view, the top of each day column is a header.

  • ViewType: All
  • The ItemContact method will return the index of the contact related to the header.
  • The ItemDate method will return the Date value related to the header.
  • The ItemLocation method will return the index of the location related to the header.
  • The ItemTask method will return the index of the task related to the header.
  • ViewType: Daily
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) related to the header.
  • ViewType: Weekly/Monthly
  • The ItemColumn method will return the index of the column within a calendar containing the header (weekly = 1-2, monthly = 1-7).
  • The ItemRow method will return the index of the row of the date where the header exists. A value of 0 in the Monthly view, indicates the header is for the days of the week.

Type Custom Area:

Custom Areas exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) where the custom area is being displayed.
  • The ItemContact method will return the index of the contact related to the custom area (based on the current column layout).
  • The ItemCustomArea method will return the index of the custom area.
  • The ItemDate method will return the Date value of the custom area.
  • The ItemLocation method will return the index of the location related to the custom area (based on the current column layout).
  • The ItemRow method will return the index of the row in the control containing the section of the custom area.
  • The ItemTask method will return the index of the task related to the custom area (based on the current column layout).

Type Time Area:

The Time Area exists in the Daily view of the control.

  • ViewType: Daily
  • The ItemColumn method will return the index of timezone column within the time area. A value of 1 indicates the primary (left) timezone and a value of 2 indicates the secondary (right) timezone (the secondary timezone is only visible if MultipleZones is True).
  • The ItemRow method will return the index of the row in the control.

Type Day Arrow Down / Type Day Arrow Up:

Day Arrows exist in all views of the control.

  • ViewType: Daily
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) where the arrow is being displayed. A value of 0 indicates the arrow is displayed in the time area.
  • The ItemContact method will return the index of the contact related to the column displaying the day arrow.
  • The ItemDate method will return the Date value of the column the arrow is displayed in.
  • The ItemLocation method will return the index of the location related to the column displaying the day arrow.
  • The ItemTask method will return the index of the task related to the column displaying the day arrow.
  • ViewType: Weekly/Monthly
  • The ItemColumn method will return the index of the column within a calendar containing the day arrow (weekly = 1-2, monthly = 1-7).
  • The ItemContact method will return the index of the contact related to the calendar containing the day arrow.
  • The ItemDate method will return the Date where the arrow is displayed.
  • The ItemLocation method will return the index of the location related to the calendar containing the day arrow.
  • The ItemTask method will return the index of the task related to the calendar containing the day arrow.

Type All Day Arrow Down / Type All Day Arrow Up:

All Day Arrows exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) where the arrow is being displayed.
  • The ItemContact method will return the index of the contact related to the column displaying the arrow.
  • The ItemDate method will return the Date value of the column the arrow is displayed in.
  • The ItemLocation method will return the index of the location related to the column displaying the arrow.
  • The ItemTask method will return the index of the task related to the column displaying the arrow.

Type Previous Indicator / Next Indicator:

The indicators exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemAppointment method will return the 1-based index of the appointment being indicated.

Type Appointment start resize handle / Appointment end resize handle:

Appointment resize handles exist in the Daily view of the control.

  • ViewType: Daily
  • The ItemAppointment method will return the index of the appointment.
  • The ItemColumn method will return the index of the column (or sub-column if grouping is being used) containing the appointment.
  • The ItemContact method will return the index of the contact related to the appointment (based on the current column displaying the appointment).
  • The ItemDate method will return the date of the appointment.
  • The ItemLocation method will return the index of the location related to the appointment (based on the current column displaying the appointment).
  • The ItemRow method will return the index of the row relative to the appointments start time.
  • The ItemTask method will return the index of the task related to the appointment (based on the current column displaying the appointment).


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Working with Properties and special DataTypes

Glossary Item Box

Fonts

There are 2 ways to assign values to Font based properties of the ActiveX controls at runtime.

1. Assign the value from a Font property on another OleControl.

[Visual Basic and Access]

Me.ctxControl.Font = Ole_object.Font

[Visual FoxPro]

thisform.ctxControl.Font = Ole_Object.Font

2. Modify the individual properties on the Font object itself.

[Visual Basic and Access]

Me.ctxControl.Font.Name = "Verdana"

Me.ctxControl.Font.Bold = True

[Visual FoxPro]

thisform.ctxControl.Font.Name = "Verdana"

thisform.ctxControl.Font.Bold = .T.

Images

Assigning images to a control at runtime, requires the image be an olePicture object (not just a standard image).

Some IDE's such as Visual Basic, Visual Foxpro and Access have a LoadPicture method which can be used to load a picture file and will convert it to the correct format.

[Visual Basic and Access]

Me.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

[Visual Foxpro]

thisform.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

Alternatively, if the image has already been assigned to a property on an oleControl, then the value of that property can be assigned directly.

[Visual Basic and Access]

Me.ctxControl.BackImage = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxControl.BackImage = Ole_Control.Picture


Compile Error

Error Message

Compile Error: Can't Find Project or Library

PROBLEM

When attempting to run or compile a project, the following error message is generated:

Compile Error: Can't Find Project or Library

CAUSE

The project contains a reference to a file or an ActiveX control that has been changed or does not exist.

RESOLUTION

Open the References dialog and clear any references to any entries marked MISSING. If those references are required for the project, re-register the correct files.

MORE INFORMATION

This error message can appear under the following conditions:

  • The file referenced has been deleted or unregistered.
  • The GUID of the ActiveX control has been changed.
  • The file referenced was moved to a different location.


No Object in this Control

Error Message

"No Object in this control"

POSSIBLE CAUSE
  1. The most common reason for this is error is that the version of the component used to develop the application is different than the version of the component being shipped.
  2. The required component has not been registered on the user machine
  3. The component has been corrupted.
RESOLUTION
  1. Ensure that the same version of the component is being used for both development and deployment.
  2. Confirm that the component has been registered on the user machine using RegSvr32.exe
  3. If the above 2 options fail, try to redistribute the component.


Error 339

Error Message

Run-time error 339: Component "ctxControl.ocx" or one of its dependencies not correctly registered: a file is missing or invalid.

This error occurs when the component itself or one of the component dependency files are not registered or installed. All of DBI components required the following dependency files:

  • MFC110U.DLL (version 11.0) - This is the Microsoft Foundation Class Library. It must be registered with your system registry. This is the Unicode version of the library.
  • MSVCR110.DLL - (version 11.0) This is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL - Required to display the stock property pages of the components in development mode. Required for deployment, only if you are surfacing the custom Property Pages in your application.


%%ItemTitle%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Additions by Version

Glossary Item Box

Version 4.0

Architecture
Internal image list has been expanded to support storing up to 250 images.
Properties
Appointment_BorderWidth | Appointment_ImageIndex4 | Appointment_ImageIndex5
Appointment_ImageIndex6 | Appointment_ImageSize | Appointment_ImageString
Appointment_InfoLinePriority | AppointmentBorderWidth | AppointmentImageSize
AppointmentSelectedBorderColor | AppointmentSelectedBorderWidth | BreakChar
EditBackColor | EditForeColor | EditWindowFillsAppointment
EnablePressHoldGesture | InfoLinePriority | ResizeExtension
ResizeHandleBackColor | ResizeHandleBorderColor | ResizeHandleBorderType
Methods
AppointmentDrawnHeight | AppointmentDrawnLeft | AppointmentDrawnTop
AppointmentDrawnWidth
Enumerations
enumAppInfoLinePriority

Version 3.0

Properties
AppointmentEditWeekMonth | CellFont | CellForeColor
CellText | CellTextAlign | CellTextColor
CellTextEllipsis | CellTextFont | CellTextMultiline
CustomAreasFilter | DateHeaderText | DateHeaderTextColor
MaxImageCalendarColumns | MaxImageDayColumns | PrintColsPerPage
PrintColumnEnd | PrintColumnStart | PrintTimeEnd
PrintTimeStart
Methods
AppointmentIndex | CancelAction | ContactIndexFromCode
ContactIndexFromKeyID | ItemAppointment | ItemAt
ItemColumn | ItemContact | ItemCustomArea
ItemDate | ItemLocation | ItemRow
ItemTask | ItemType | LocationIndexFromCode
LocationIndexFromKeyID | SelectColumn | SelectEndTime
SelectStartTime | TaskIndexFromCode | TaskIndexFromKeyID
TimeSelect
Events
UserDrawnCellText | UserDrawnDateHeaderText
Enumerations
enumCustomAreasFilter | enumItemTypes
Procedural
Using the HitTest Methods


Distribution

Distribution Policy

DBI’s component products (COM and WinForm) are licensed per person/developer exposing the controls in a design surface.

The licensed person/developer is provided under the license agreement rights to distribute the “Run-Time” component(s) royalty-free. ”

For those situations where the intended end-user of the licensee’s software is provided the opportunity to further modify or expose DBI’s intellectual property in a design surface (ie. Source Code included, distribution of MDB’s, etc.), DBI does offer distribution licensing under its OEM product banner. For more information contact sales@dbi-tech.com

Your software-license agreement permits you to distribute the OCX files to an unlimited number of computers so long that:

  1. the OCX controls are not being made available as development controls within a development environment.

Consult the DBI Technologies " Software-License" agreement for additional information: http://www.dbi-tech.com/license_agreements.asp


Support Policy

Product Support

DBI Technologies Product Support

Please see the support website at http://www.dbi-tech.com/support_policies.asp for information on our support policies and plans, or visit our FAQ at http://www.dbi-tech.com/Support/FAQ/default.aspx


New Page 1

Frequently Asked Questions

Frequently Asked Questions

The DBI FAQ-Technical page is constantly being updated.

To view the frequently asked questions, please navigate to our FAQ page.


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send comments on this topic.


$$GETTING_STARTED$$ - %%projecttitle%%

Introduction
Send comments on this topic.


%%phrase%%

References
Send comments on this topic.


%%PageItemTitle%%

ctxCalendar Object
See Also Members Send comments on this topic.

Description

ctxCalendar Control

Object Model

ctxCalendar Object

See Also

ctxCalendar Members


%%PageItemTitle%% $$Members$$

ctxCalendar Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method AddAppointment | Add an appointment to the control
Public Method AddContact | Add a Contact to the control
Public Method AddCustomArea | Add a new custom area to the control
Public Method AddDayFormat | Add a new day format to the control.
Public Method AddImage | Add a new picture to the internal image list of the control.
Public Method AddKeyAppointment | Add a new appointment to the control
Public Method AddKeyContact | Add a Contact to the control
Public Method AddKeyLocation | Add a Location to the control
Public Method AddKeyTask | Add a Task to the control
Public Method AddLocation | Add a Location to the control
Public Method AddTask | Add a Task to the control
Public Method AddvCalAppointment | Adds an appointment to the control based a string in the vCal format.
Public Method AppointmentAt | Returns the index of the first appointment found at a specified point in the control.
Public Method AppointmentDrawnHeight | Returns the height of a currently rendered appointment.
Public Method AppointmentDrawnLeft | Returns the left edge of a currently rendered appointment.
Public Method AppointmentDrawnTop | Returns the top edge of a currently rendered appointment.
Public Method AppointmentDrawnWidth | Returns the width of a currently rendered appointment.
Public Method AppointmentInColumn | Finds the index value relative to the column that contains a specified appointment.
Public Method AppointmentIndex | Returns the 1-based index of an appointment based on a supplied Appointment_KeyID value
Public Method BeginDrag | Notifies the control that the developer is starting an external drag operation and to cancel/reset any internal movement that may have occurred.
Public Method Cancel | Cancels an operation from occurring inside the control.
Public Method CancelAction | Cancels an operation from occurring inside the control.
Public Method ClearAppointments | Clears all the appointments from the control.
Public Method ClearContacts | Clears all the Contacts from the control.
Public Method ClearCustomAreas | Clears all the Custom Areas from the control.
Public Method ClearDayFormats | Clears all the Day Formats from the control.
Public Method ClearLocations | Clears all the Locations from the control.
Public Method ClearTasks | Clears all the Tasks from the control.
Public Method ColumnAt | Returns the column index at the provided X-coordinate.
Public Method ColumnContact | Returns the Contact_Code of the Contact associated with the column specified.
Public Method ColumnDate | Returns the date associated with a specified column index.
Public Method ColumnLocation | Returns the Location_Code of the Location associated with the column specified.
Public Method ColumnTask | Returns the Task_Code of the Task associated with the column specified.
Public Method ContactIndexFromCode | Returns the index of a Contact in the control, based on a supplied Contact_Code
Public Method ContactIndexFromKeyID | Returns the index of a Contact in the control, based on a supplied ID string.
Public Method CreateImage | Creates an image file based on the current content of the control.
Public Method DateAt | Returns the date located at a specified position in the control.
Public Method DateAtColumn | Returns the date value associated with a column in the daily view.
Public Method Day | Returns the day portion of a supplied date value.
Public Method DeleteAppointment | Deletes a current appointment from the control.
Public Method DeleteContact | Deletes a current contact from the control.
Public Method DeleteCustomArea | Deletes a current customarea from the control.
Public Method DeleteDayFormat | Deletes a current dayformat from the control.
Public Method DeleteKeyAppointment | Deletes a current appointment from the control based on a ID key value.
Public Method DeleteKeyContact | Deletes a current contact from the control based on a ID key value.
Public Method DeleteKeyLocation | Deletes a current location from the control based on a ID key value.
Public Method DeleteKeyTask | Deletes a current task from the control based on a ID key value.
Public Method DeleteLocation | Deletes a current location from the control.
Public Method DeleteTask | Deletes a current task from the control.
Public Method DragDrop | Set the Drag Drop information for the control.
Public Method DragOver | Set the Drag Over information for the control.
Public Method FindFirstConflict | Determine the first appointment that conflicts with a given appointment.
Public Method FindNextColumnAppointment | Gets the appointment index of the next available appointment past a specific column in the day view.
Public Method FindNextConflict | Determine the next appointment that conflicts with a given appointment.
Public Method FindNextTimeAppointment | Get the appointment index of an appointment, that exists in a column after the current visible area of the day view.
Public Method FindPrevColumnAppointment | Gets the appointment index of the next available appointment before a specific column in the day view.
Public Method FindPrevTimeAppointment | Get the appointment index of an appointment, that exists in a column before the current visible area of the day view.
Public Method Invalidate | Forces the control to invalidate itself so that a re-draw occurs.
Public Method IsAppointmentAt | Determines if an appointment already exists at a certain time in a certain column.
Public Method ItemAppointment | Returns the 1-based index of the appointment related to a hittest object.
Public Method ItemAt | Returns the 1-based index of a hittest object located at the specified location
Public Method ItemColumn | Returns the 1-based index indicating the column related to the hittest object
Public Method ItemContact | Returns the 1-based index of the contact related to a hittest object.
Public Method ItemCustomArea | Returns the 1-based index of the customarea related to a hittest object.
Public Method ItemDate | Returns the date related to a hittest object
Public Method ItemLocation | Returns the 1-based index of the location related to a hittest object.
Public Method ItemRow | Returns the 1-based count of the row within the main part of the control related to a hittest object.
Public Method ItemTask | Returns the 1-based index of the task related to a hittest object.
Public Method ItemType | Returns the type of hittest object stored at a specified index.
Public Method LocationIndexFromCode | Returns the index of a Location in the control based on a Location_Code
Public Method LocationIndexFromKeyID | Returns the index of a Location in the control, based on a supplied ID string.
Public Method LongDate | Create a Date value based on supplied Day, Month and Year values.
Public Method MakeAppointmentVisible | Scrolls the control so that a desired appointment is within the visible area.
Public Method MakeDateVisible | Scrolls the control to bring a desired date in to view when displaying as a weekly or monthly calendar.
Public Method Month | Returns the month portion of a supplied date value.
Public Method PrintCalendar | Send the contents of the current calendar to the printer.
Public Method ReadFile | Reads an xml document (generated by the WriteFile of this control) to populate the control.
Public Method ReadXMLString | Reads the tree data into a memory variable
Public Method RemoveImage | Removes an image from the internal image list.
Public Method SelectColumn | Returns the index of the column for the currently selected time cells in the daily view.
Public Method SelectedDays | Returns a currently selected date, based on the supplied index of the total count of selected days.
Public Method SelectEndTime | Returns the end time for the current selection of time cells in the daily view.
Public Method SelectStartTime | Returns the start time for the current selection of time cells in the daily view.
Public Method SetVertScrollToTime | Scroll the control, when in daily view, to a specified time.
Public Method TaskIndexFromCode | Returns the index of a Task in the control based on a Task_Code
Public Method TaskIndexFromKeyID | Returns the index of a Task in the control, based on a supplied ID string.
Public Method TimeAt | Returns the time value at a specified point.
Public Method TimeSelect | Selects the desired time range in specified column, within the daily view.
Public Method Today | Returns the current system date.
Public Method WriteFile | Writes the data in ctxCalendar to an xml file.
Public Method Year | Returns the year portion of a supplied date value.

Public Properties

Public Property AllDayArea | Determines if an all-day appointment area will be visible in the day view.
Public Property AllDayBackColor | Returns/sets the primary color of the background of the all-day area in the day view.
Public Property AllDayBackColorTo | Returns/sets the secondary color of the background of the all-day area in the day view.
Public Property AllDayFillType | Returns/sets the background pattern of the all-day area in the day view.
Public Property AllDayHeight | Returns/sets the height of the all-day area in the day view.
Public Property AllDayHeightOffset | Returns/sets the height offset used to calculate the height of an all-day appointment in the day view and regular appointment in the month and week views.
Public Property AllDayMaxApps | Returns/sets the maximum of all-day appointments that can be displayed in the all-day area in the day view at one time.
Public Property AmPmPosition | Returns/sets the position of the Am/Pm letters in the time area of the day view.
Public Property AppIndicatorBackColor | Returns/sets the primary color of the background of the appointment indicators in the day view.
Public Property AppIndicatorBackColorTo | Returns/sets the secondary color of the background of the appointment indicators in the day view.
Public Property AppIndicatorBorderColor | Returns/sets the border color of the appointment indicators in the day view.
Public Property AppIndicatorDisabled | Returns/sets the disabled text color of the appointment indicators in the day view.
Public Property AppIndicatorFillType | Returns/sets the background pattern of the appointment indicators in the day view.
Public Property AppIndicatorFont | Returns/sets the font of the appointment indicators in the day view.
Public Property AppIndicatorForeColor | Returns/sets the text color of the appointment indicators in the day view.
Public Property AppIndicatorHeight | Returns/sets the fixed height of an appointment indicator in the day view.
Public Property AppIndicatorNextText | Returns/sets the text in the right appointment indicator in the day view.
Public Property AppIndicatorOffset | Returns/sets the offset used to calculate the width of the appointment indicators in the day view.
Public Property AppIndicatorPosition | Returns/sets the draw position of the appointment indicators in the day view.
Public Property AppIndicatorPrevText | Returns/sets the text in the left appointment indicator in the day view.
Public Property AppIndicatorRadius | Returns/sets the size of the ellipse for the corners of the appointment indicators in the day view.
Public Property Appointment_AllDayEvent | Returns/sets if an appointment is considered an AllDay event, and should be displayed in the allday area.
Public Property Appointment_BackColor | Returns/sets the primary background color of the appointment
Public Property Appointment_BackColorTo | Returns/sets the secondary background color of the appointment.
Public Property Appointment_BackImageIndex | Returns/sets the index of the image to use as the background for the appointment.
Public Property Appointment_BorderColor | Returns/sets the color used to paint the border around the appointment.
Public Property Appointment_BorderWidth | Returns/sets the border width of the appointment.
Public Property Appointment_Cargo | Returns/sets a non-visible string value for the appointment.
Public Property Appointment_Comment | Returns/sets a non-visible string value for the appointment.
Public Property Appointment_ContactCode | Returns/sets the Code of the Contact associated with this appointment.
Public Property Appointment_Count | Returns the amount of appointment objects in the control.
Public Property Appointment_Data | Returns/sets a non-visible Long value for the appointment.
Public Property Appointment_Date | Returns/sets the date of the appointment.
Public Property Appointment_FillType | Returns/sets the background pattern of the appointment.
Public Property Appointment_ForeColor | Returns/sets the text color of the appointment.
Public Property Appointment_ImageIndex1 | Returns/sets the index value of the primary image of the appointment.
Public Property Appointment_ImageIndex2 | Returns/sets the index value of the secondary image of the appointment.
Public Property Appointment_ImageIndex3 | Returns/sets the index value of the tertiary image of the appointment.
Public Property Appointment_ImageIndex4 | Returns/sets the index value of the fourth image of the appointment.
Public Property Appointment_ImageIndex5 | Returns/sets the index value of the fifth image of the appointment.
Public Property Appointment_ImageIndex6 | Returns/sets the index value of the sixth image of the appointment.
Public Property Appointment_ImageSize | Returns/sets the size used for images displayed in the appointment.
Public Property Appointment_ImageString | Returns/sets a string containing the indexes of the images to display in the appointment.
Public Property Appointment_InfoLinePriority | Returns/sets if the InfoLineText of an appointment should be shown instead of the Text.
Public Property Appointment_InfoLineText | Returns/sets the additional information text for the appointment.
Public Property Appointment_KeyID | Returns/sets a unique ID value for the appointment.
Public Property Appointment_Location | Returns/sets a non-visible string for storing the name of a location associated with the appointment.
Public Property Appointment_LocationCode | Returns/sets the Code of the Location associated with this appointment.
Public Property Appointment_Locked | Determines if the appointment is prevented from being moved or resized by user interactions.
Public Property Appointment_ReadOnly | Determines if the appointment is restricted from all user interactions.
Public Property Appointment_ReminderSet | Determines if a reminder icon (bell) will be displayed in the top left corner of the appointment.
Public Property Appointment_TaskBarColor | Returns/sets the color of the taskbar (left side) of the appointment.
Public Property Appointment_TaskBarImageIndex | Returns/sets the index of the image from the internal image list, used to paint the TaskBar of the appointment.
Public Property Appointment_TaskCode | Returns/sets the Code of the Task associated with this appointment.
Public Property Appointment_Text | Returns/sets the text of the appointment.
Public Property Appointment_TimeEnd | Returns/sets the end time of the appointment.
Public Property Appointment_TimeStart | Returns/sets the start time of the appointment.
Public Property Appointment_vCalInfo | Returns/sets a vCal formatted string related to the appointment.
Public Property AppointmentBackColor | Returns/sets the default primary color of the background of appointments in the control.
Public Property AppointmentBackColorTo | Returns/sets the default secondary color of the background of appointments in the control.
Public Property AppointmentBorderColor | Returns/sets the default border color of appointments in the control.
Public Property AppointmentBorderWidth | Returns/sets the default border width of appointments in the control.
Public Property AppointmentEditWeekMonth | Returns/sets if the text of an appointment can be edited in the weekly/monthly views.
Public Property AppointmentFillType | Returns/sets the default background pattern for appointments.
Public Property AppointmentFont | Returns/sets the Font for the text in the appointments.
Public Property AppointmentForeColor | Returns/sets the default color used to paint text in the appointments.
Public Property AppointmentHeightOffset | Returns/sets the height offset used to calculate the height of a regular appointment in the day view.
Public Property AppointmentImageSize | Returns/sets the default size used for images displayed in the appointments.
Public Property AppointmentItemMargin | Returns/sets the distance separating images in the appointments in the control.
Public Property AppointmentMargin | Returns/sets the distance between appointments in the all-day area of a day view and the dates in the month and week views.
Public Property AppointmentRadius | Returns/sets the size of the ellipse for the corners of the appointments in the control.
Public Property AppointmentScroll | Determines if clicking arrows in the all-day area (day view) or dates (month and week views) will scroll the appointments displayed there.
Public Property AppointmentSelected | Returns/sets the index value of the selected appointment in the control.
Public Property AppointmentSelectedBorderColor | Returns/sets the default color used to paint the border of a selected appointment.
Public Property AppointmentSelectedBorderWidth | Returns/sets the width of the border painted around a selected appointment.
Public Property AppointmentShadows | Determines if a shadow effect will appear on the appointments.
Public Property AppointmentShowTime | Returns/sets how the starting and ending time of the appointments will be displayed in themselves.
Public Property AppointmentType | Returns/sets the main filter of the control.
Public Property ArrowBackColor | Returns/sets the background color of the appointment arrows in the control.
Public Property ArrowBorderColor | Returns/sets the border color of the appointment arrows in the control.
Public Property ArrowDown | Returns/sets the image used to represent a down appointment arrow in the control.
Public Property ArrowPosition | Returns/sets the position of the arrows in the main portion of the control when displaying a day view.
Public Property ArrowUp | Returns/sets the image used to represent an up appointment arrow in the control.
Public Property BackColor | Returns/sets the background color of the control.
Public Property BorderColor | Returns/sets the border color of the control.
Public Property BreakChar | Returns/sets the character used to separate the values contained in a string.
Public Property CalendarColumns | Returns/sets the maximum amount of calendars that can be seen at once in a month or week view.
Public Property CalendarSeparatorWidth | Returns/sets the distance between multiple calendars in a month or week view.
Public Property CellColor | Sets the color to be used when painting a cell.
Public Property CellFont | Returns/sets the default font used to draw text in cells of the daily view.
Public Property CellForeColor | Returns/sets the default color used to draw text in the cells of the daily view.
Public Property CellText | Sets the text to be drawn in a cell.
Public Property CellTextAlign | Sets the horizontal alignment of the text within the cell.
Public Property CellTextColor | Sets the color of the text within the cell.
Public Property CellTextEllipsis | Determines if the cell text should display ellipsis if it is too long to fit in the cell.
Public Property CellTextFont | Sets the font to use for displaying the text within the cell.
Public Property CellTextMultiline | Determines if the text in the cell should support multiple lines (either due to length of the text or break characters).
Public Property ColumnBarBackColor | Returns/sets the color of the separators, in the time area, of the columns in a day view.
Public Property ColumnBarWidth | Returns/sets the width of the separators, in the time area, of the columns in a day view.
Public Property ColumnLineWide | Determines if the line between columns in the day view should be painted in a thicker manner.
Public Property ConflictOffset | Returns/sets the amount of time (in minutes) used to offset the length of an appointment when doing conflict searches.
Public Property Contact_AllDayBackColor | Returns/sets the color of the allday area when displaying a column by Contact.
Public Property Contact_BackColor | Returns/sets the background color used to paint the weekly and monthly calendars for a Contact.
Public Property Contact_BorderColor | Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Contact.
Public Property Contact_Cargo | Returns/sets a non-visible string value for the Contact.
Public Property Contact_Code | Returns/sets the unique code for the Contact.
Public Property Contact_Count | Returns the amount of contact objects in the control.
Public Property Contact_DateHeaderBackColor | Returns/sets the primary background color of the date and column headers for a Contact.
Public Property Contact_DateHeaderBackColorTo | Returns/sets the secondary background color of the date and column headers for a Contact.
Public Property Contact_DateHeaderBorderColor | Returns/sets the color used to paint the border around the date and column headers for a Contact.
Public Property Contact_DateHeaderFillType | Returns/sets the pattern used to paint the background of the date and column headers for a Contact.
Public Property Contact_DateHeaderForeColor | Returns/sets the color used to paint the text in the date and column headers for a Contact.
Public Property Contact_Image | Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.
Public Property Contact_KeyID | Returns/sets the unique ID for the Contact.
Public Property Contact_MonthEvenBackColor | Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Contact.
Public Property Contact_MonthHeaderBorderColor | Returns/sets the color used to paint the border around the Month names in a Monthly view for the Contact.
Public Property Contact_MonthHeaderForeColor | Returns/sets the color used to paint the text of the month names in a monthly view for a Contact.
Public Property Contact_MonthOddBackColor | Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Contact.
Public Property Contact_NonPrimeTimeColor | Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Contact.
Public Property Contact_PrimeTimeColor | Returns/sets the color used to paint the time cells of prime time in the daily view for a Contact.
Public Property Contact_SelectedBackColor | Returns/sets the color used to paint a selected date or time cell for a Contact.
Public Property Contact_SelectedForeColor | Returns/sets the color used to paint the text in a selected date for a Contact.
Public Property Contact_Text | Returns/sets the text associated with the Contact.
Public Property Contact_TitleForeColor | Returns/sets the color used to paint the title text in the weekly and monthly views for a Contact.
Public Property Contact_WeekendBackColor | Returns/sets the background color of the weekend dates for a Contact.
Public Property Contact_WeekSummaryBackColor | Returns/sets the primary background color of the weeksummary areas for a Contact.
Public Property Contact_WeekSummaryBackColorTo | Returns/sets the secondary background color of the weeksummary areas for a Contact.
Public Property Contact_WeekSummaryBorderColor | Returns/sets the color used to paint the border around each weeksummary area for a Contact.
Public Property Contact_WeekSummaryFillType | Returns/sets the pattern used to paint the background of the weeksummary areas for a Contact.
Public Property Contact_WeekSummaryForeColor | Returns/sets the color used to paint the text in the weeksummary areas for a Contact.
Public Property ControlStyle | Specifies the new setting for other properties so that the control mimics a certain style.
Public Property CurrentShadowColor | Returns/sets the current time line shadow (trailing) color in the day view.
Public Property CurrentTimeColor | Returns/sets the current time line color in the day view.
Public Property CurrentTimeLine | Determines if the current time line will be displayed in the time area of the day view.
Public Property CustomArea_BackColor | Returns/sets the color used to paint the background of a CustomArea.
Public Property CustomArea_Cargo | Returns/sets a non visible string value for the CustomArea.
Public Property CustomArea_ContactCode | Returns/sets the Contact code associated with a CustomArea.
Public Property CustomArea_Count | Returns the amount of custom area objects in the control.
Public Property CustomArea_Daily | Determines if the CustomArea will repeat daily.
Public Property CustomArea_Date | Returns/sets the date associated with the CustomArea.
Public Property CustomArea_DeadZone | Determines if the CustomArea will be treated as a DeadZone.
Public Property CustomArea_LocationCode | Returns/sets the Location code associated with a CustomArea.
Public Property CustomArea_TaskCode | Returns/sets the Task code associated with a CustomArea.
Public Property CustomArea_TimeEnd | Returns/sets the ending time of a CustomArea.
Public Property CustomArea_TimeStart | Returns/sets the starting time of a CustomArea.
Public Property CustomAreasFilter | Returns/sets how the control will determine when CustomAreas will be rendered in the display, based on their properties.
Public Property CustomColor1 | Returns/sets the primary color used by the Custom_Flat option of the ControlStyle Property.
Public Property CustomColor2 | Returns/sets the secondary color used by the Custom_Flat option of the ControlStyle Property.
Public Property CustomColor3 | Returns/sets the tertiary color used by the Custom_Flat option of the ControlStyle Property.
Public Property CustomMenu | Determines if the default context menu will be displayed when the user right clicks in the edit window of the selected appointment.
Public Property Date | Returns/sets the selected date for the control.
Public Property DateEnd | Returns/sets the ending date for the control.
Public Property DateFormat | Returns/sets how the dates will be formatted into text in the daily view date columns.
Public Property DateHeaderBackColor | Returns/sets the primary background color of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderBackColorTo | Returns/sets the secondary background color of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderBorderColor | Returns/sets the border color of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderBorderType | Returns/sets the border type of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderFillType | Returns/sets the background pattern of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderFont | Returns/sets the font used for the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderForeColor | Returns/sets the text color of the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderHeight | Returns/sets the height of the date headers in the month and week views.
Public Property DateHeaderImageAlign | Returns/sets the horizontal image alignment for the column headers in the day view and date headers in the month and week views.
Public Property DateHeaders | Determines if a header will be drawn in the dates in the weekly and monthly views.
Public Property DateHeaderText | Sets the text to be written in the header of a date in the weekly/monthly views.
Public Property DateHeaderTextAlign | Returns/sets the horizontal text alignment for the column headers in the day view and date headers in the month and week views.
Public Property DateHeaderTextColor | Gets/sets the color used to draw the text in a date header.
Public Property DateHorzLines | Returns/sets the thickness of horizontal lines separating the date rows in the month view.
Public Property DateRows | Returns/sets the amount of date rows to display at one time in a month view.
Public Property DateSelectType | Returns/sets how a selected date will appear in the month and week views.
Public Property DateStart | Returns/sets the starting date for the control.
Public Property DateXOffset | Returns/sets the horizontal offset used to calculate the position of the date text in the month and week views.
Public Property DateYOffset | Returns/sets the vertical offset used to calculate the position of the date text in the month and week views.
Public Property DayBorderColor | Returns/sets the color used to paint the border of the day view.
Public Property DayColumns | Returns/sets the maximum number of columns displayed in the daily view.
Public Property DayFormat_BackColor | Returns/sets the primary background color used to paint the DayFormat.
Public Property DayFormat_BackColorTo | Returns/sets the secondary background color used to paint the DayFormat.
Public Property DayFormat_ContactCode | Returns/sets the Contact code associated with the DayFormat
Public Property DayFormat_Count | Returns the amount of day format objects in the control.
Public Property DayFormat_Date | Returns/sets the date to apply the DayFormat.
Public Property DayFormat_Enabled | Determines if the date is enabled for selection when applied with the DayFormat.
Public Property DayFormat_FillType | Returns/sets the background pattern used to paint the DayFormat.
Public Property DayFormat_ForeColor | Returns/sets the color used to paint the text of the DayFormat.
Public Property DayFormat_ImageAlign | Returns/sets the alignment of the image of the DayFormat.
Public Property DayFormat_ImageIndex | Returns/sets the index of the image from the internal image list to display in the DayFormat.
Public Property DayFormat_ImageXOffset | Returns/sets an X coordinate offset (in pixels) for the display of the image in the DayFormat.
Public Property DayFormat_ImageYOffset | Returns/sets a Y coordinate offset (in pixels) for the display of the image in the DayFormat.
Public Property DayFormat_LocationCode | Returns/sets the Location code associated with the DayFormat.
Public Property DayFormat_TaskCode | Returns/sets the Task code associated with the DayFormat.
Public Property DayFormat_Text | Returns/sets the text to display in the DayFormat.
Public Property DayFormat_TextAlign | Returns/sets the horizontal alignment of the DayFormat text.
Public Property DayFormat_TextXOffset | Returns/sets an X coordinate offset for the display of the text in the DayFormat.
Public Property DayFormat_TextYOffset | Returns/sets a Y coordinate offset for the display of the text in a DayFormat.
Public Property DayFormatFont | Returns/sets the Font used to display text in DayFormats.
Public Property DayFormatForeColor | Returns/sets the default color used to paint text in DayFormats.
Public Property DayNames | Returns/sets the names of the day of the week.
Public Property DayViewHeader | Determines if column headers will be visible in the daily view.
Public Property DayViewHeaderHeight | Returns/sets the height of the column headers in the day view.
Public Property DisabledForeColor | Returns/sets the text color of disabled days and dates outside the date range in the month and week views.
Public Property DragBackColor | Returns/sets the background color of a time cell (day view) or date (month and week views) when an item is being dragged over the control.
Public Property EditBackColor | Returns/sets the color used to paint the background of the edit window used for appointments.
Public Property EditForeColor | Returns/sets the color used to paint the text of the edit window used for appointments.
Public Property EditWindowFillsAppointment | Determines if the edit window will always cover the entire appointment.
Public Property EditXOffset | Returns/sets the horizontal offset used to calculate the width of an edit box when an appointment is in edit mode.
Public Property Enabled | Determines if the control will react to user interactions.
Public Property EnablePressHoldGesture | Determines if the control will respond to the "Press and Hold" gesture in a touch interface.
Public Property EnterKey | Returns/sets how the Enter key will be used when typing data into an appointment.
Public Property FirstDayOfWeek | Returns/sets the first day of the week to start a calendar in a month or week view.
Public Property GroupType | Returns/sets the secondary filter of the control.
Public Property HorzScrollMax | Returns the maximum value or range of the horizontal scroll bar.
Public Property HorzScrollPos | Returns/sets the value or position of the horizontal scroll bar of the control.
Public Property HorzScrollVisible | Determines if the horizontal scroll bar for the control will be visible.
Public Property HourFont | Returns/sets the font for the hour values in the time area of the day view.
Public Property HourFontXOffset | Returns/sets the horizontal offset used to calculate the position of the hour values in the time area of the day view.
Public Property HourFontYOffset | Returns/sets the vertical offset used to calculate the position of the hour values in the time area of the day view.
Public Property HourLineColor | Returns/sets the color used to paint the hour lines in the day view.
Public Property ImageListCount | Returns the amount of images in the controls image list.
Public Property InfoLinePriority | Determines if the InfoLineText of an appointment should be shown instead of the Text.
Public Property ListImage | Returns/sets an image in the internal image list.
Public Property Location_AllDayBackColor | Returns/sets the color of the allday area when displaying a column by Location.
Public Property Location_BackColor | Returns/sets the background color used to paint the weekly and monthly calendars for a Location.
Public Property Location_BorderColor | Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Location.
Public Property Location_Cargo | Returns/sets a non-visible string value for the Location.
Public Property Location_Code | Returns/sets a non-visible string value for the Location.
Public Property Location_Count | Returns the amount of location objects in the control.
Public Property Location_DateHeaderBackColor | Returns/sets the primary background color of the date and column headers for a Location.
Public Property Location_DateHeaderBackColorTo | Returns/sets the secondary background color of the date and column headers for a Location.
Public Property Location_DateHeaderBorderColor | Returns/sets the color used to paint the border around the date and column headers for a Location.
Public Property Location_DateHeaderFillType | Returns/sets the pattern used to paint the background of the date and column headers for aLocation.
Public Property Location_DateHeaderForeColor | Returns/sets the color used to paint the text in the date and column headers for aLocation.
Public Property Location_Image | Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.
Public Property Location_KeyID | Returns/sets the unique ID for the Location.
Public Property Location_MonthEvenBackColor | Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Location .
Public Property Location_MonthHeaderBorderColor | Returns/sets the color used to paint the border around the Month names in a Monthly view for the Location.
Public Property Location_MonthHeaderForeColor | Returns/sets the color used to paint the text of the month names in a monthly view for a Location.
Public Property Location_MonthOddBackColor | Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Location.
Public Property Location_NonPrimeTimeColor | Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Location.
Public Property Location_PrimeTimeColor | Returns/sets the color used to paint the time cells of prime time in the daily view for a Location.
Public Property Location_SelectedBackColor | Returns/sets the color used to paint a selected date or time cell for a Location.
Public Property Location_SelectedForeColor | Returns/sets the color used to paint the text in a selected date for a Location.
Public Property Location_Text | Returns/sets the text associated with the Location.
Public Property Location_TitleForeColor | Returns/sets the color used to paint the title text in the weekly and monthly views for a Location.
Public Property Location_WeekendBackColor | Returns/sets the background color of the weekend dates for a Location.
Public Property Location_WeekSummaryBackColor | Returns/sets the primary background color of the weeksummary areas for a Location.
Public Property Location_WeekSummaryBackColorTo | Returns/sets the secondary background color of the weeksummary areas for a Location.
Public Property Location_WeekSummaryBorderColor | Returns/sets the color used to paint the border around each weeksummary area for a Location.
Public Property Location_WeekSummaryFillType | Returns/sets the pattern used to paint the background of the weeksummary areas for a Location.
Public Property Location_WeekSummaryForeColor | Returns/sets the color used to paint the text in the weeksummary areas for a Location.
Public Property MaskColor | Returns/sets the masking color used for the images in the control.
Public Property MaxImageCalendarColumns | Returns/sets the max number of calendars that can be included in the output of the CreateImage method, when a width of -1 is supplied in the Weekly/Monthly views.
Public Property MaxImageDayColumns | Returns/sets the max number of columns that can be included in the output of the CreateImage method, when a width of -1 is supplied in the daily view.
Public Property MaxImageHeight | Returns/sets the maximum height of an image created with the CreateImage method.
Public Property MaxImageWidth | Returns/sets the maximum width of an image created with the CreateImage method.
Public Property MergeInfoLine | Determines if the regular text and info line text will be merged in the appointments in the control.
Public Property MilitaryTime | Determines if the time values will be displayed in a 24-hour format in the time area of the day view.
Public Property MinuteDisplay | Returns/sets where minute values will be displayed in the time area of the day view.
Public Property MinuteFormat | Returns/sets how the minute values will be displayed in the time area of the day view.
Public Property MinuteLineColor | Returns/sets the color used to paint the minute lines in the day view.
Public Property MinuteLines | Determines if lines will be drawn in the time area to indicate the minute rows.
Public Property MonthEvenBackColor | Returns/sets the background color of each date of an even numbered month in the month and week views.
Public Property MonthHeader | Determines if the month header (containing the days of the week) will be displayed in the monthly view.
Public Property MonthHeaderBackColor | Returns/sets the primary background color of the month headers in a month view.
Public Property MonthHeaderBackColorTo | Returns/sets the secondary background color of the month headers in a month view.
Public Property MonthHeaderBorderColor | Returns/sets the border color of the month headers in a month view.
Public Property MonthHeaderBorderStyle | Returns/sets the border style of the month header in the month view.
Public Property MonthHeaderFillType | Returns/sets the background pattern of the month headers in a month view.
Public Property MonthHeaderFont | Returns/sets the font of the month headers in a month view.
Public Property MonthHeaderForeColor | Returns/sets the text color of the month headers in a month view.
Public Property MonthHeaderHeight | Returns/sets the height of the month headers in a month view.
Public Property MonthHeaderTextAlign | Returns/sets the horizontal alignment of the month header text in a month view.
Public Property MonthNames | Returns/sets the names of the month of the year.
Public Property MonthOddBackColor | Returns/sets the background color of each date of an odd numbered month in the month and week views.
Public Property MoveAlpha | Returns/sets the alpha (transparency) value assigned to the background colors of an appointment when an appointment is being moved with the mouse.
Public Property MultipleZones | Determines if two time zones will be displayed in the time area of the day view.
Public Property MultiSelect | Determines if multiple dates can be selected in the month and week views.
Public Property NonPrimeTimeColor | Returns/sets the background color for the time cells during non-prime time in the day view.
Public Property PrimeTimeColor | Returns/sets the background color for the time cells during prime time in the day view.
Public Property PrimeTimeEnd | Returns/sets the ending prime time for the day view.
Public Property PrimeTimeStart | Returns/sets the starting prime time for the day view.
Public Property PrintColsPerPage | Returns/sets the maximum number of columns to include per page of a printed report.
Public Property PrintColumnEnd | Returns/sets the last column to include in a printed report
Public Property PrintColumnStart | Returns/sets the first column to include in a printed report
Public Property PrintFont | Returns/sets the font of a printed report.
Public Property PrintMarginBottom | Returns/sets the bottom page margin offset of a printed report.
Public Property PrintMarginLeft | Returns/sets the left page margin offset of a printed report.
Public Property PrintMarginRight | Returns/sets the right page margin offset of a printed report.
Public Property PrintMarginTop | Returns/sets the top page margin offset of a printed report.
Public Property PrintPageNumberAlign | Returns/sets the horizontal text alignment of page numbers in a printed report.
Public Property PrintPageNumbers | Determines if page numbers will be placed in a printed report.
Public Property PrintPageText | Sets the string to be displayed as the page number text for a printed page.
Public Property PrintReportType | Returns/sets the type of printed report to create.
Public Property PrintSubTitle | Returns/sets the sub-title of a printed report.
Public Property PrintTimeEnd | Returns/sets the end time of a printed report.
Public Property PrintTimeStart | Returns/sets the start time of a printed report.
Public Property PrintTitle | Returns/sets the title of a printed report.
Public Property PrintTitleAlign | Returns/sets the horizontal text alignment of the title and sub-title of a printed report.
Public Property PrintTitleFont | Returns/sets the title font of a printed report.
Public Property PropertyPages | Allows for the display of the custom property pages in runtime.
Public Property ResizeExtension | Returns/sets the offset used to calculate internally when the mouse is over either of the appointment resize handles.
Public Property ResizeHandleBackColor | Returns/sets the color used to paint the square resize handles on appointments.
Public Property ResizeHandleBorderColor | Returns/sets the color used to paint the border of the square resize handles on appointments.
Public Property ResizeHandleBorderType | Returns/sets the type of border for the square resize handles on appointments.
Public Property SelectedBackColor | Returns/sets the background color of a selected cell in the day view or of a selected date in the month and week views.
Public Property SelectedDaysCount | Returns the amount of selected dates in the month and week views.
Public Property SelectedForeColor | Returns/sets the text color of a selected date in the month and week views.
Public Property ShowTimeText | Sets the string to be displayed as the time text for an appointment.
Public Property Task_AllDayBackColor | Returns/sets the color of the allday area when displaying a column by Task.
Public Property Task_BackColor | Returns/sets the background color used to paint the weekly and monthly calendars for a Task.
Public Property Task_BorderColor | Returns/sets the color used to paint the border around the dates in the weekly and monthly calendar views for a Task.
Public Property Task_Cargo | Returns/sets a non-visible string value for the Task.
Public Property Task_Code | Returns/sets the unique code for the Task.
Public Property Task_Count | Returns the amount of task objects in the control.
Public Property Task_DateHeaderBackColor | Returns/sets the primary background color of the date and column headers for a Task.
Public Property Task_DateHeaderBackColorTo | Returns/sets the secondary background color of the date and column headers for a Task.
Public Property Task_DateHeaderBorderColor | Returns/sets the color used to paint the border around the date and column headers for a Task.
Public Property Task_DateHeaderFillType | Returns/sets the pattern used to paint the background of the date and column headers for a Task.
Public Property Task_DateHeaderForeColor | Returns/sets the color used to paint the text in the date and column headers for a Task.
Public Property Task_Image | Returns/sets the index of the image displayed in the title area of the weekly and monthly views, and in the column header in the daily view.
Public Property Task_KeyID | Returns/sets the unique ID for the Task
Public Property Task_MonthEvenBackColor | Returns/sets the color used to paint the background of days in even months in the monthly and weekly views for the Task.
Public Property Task_MonthHeaderBorderColor | Returns/sets the color used to paint the border around the Month names in a Monthly view for the Task.
Public Property Task_MonthHeaderForeColor | Returns/sets the color used to paint the text of the month names in a monthly view for a Task.
Public Property Task_MonthOddBackColor | Returns/sets the color used to paint the background of days in odd months in the monthly and weekly views for the Task.
Public Property Task_NonPrimeTimeColor | Returns/sets the color used to paint the time cells of non-prime time in the daily view for a Task.
Public Property Task_PrimeTimeColor | Returns/sets the color used to paint the time cells of prime time in the daily view for a Task.
Public Property Task_SelectedBackColor | Returns/sets the color used to paint the time cells of prime time in the daily view for a Task.
Public Property Task_SelectedForeColor | Returns/sets the color used to paint the text in a selected date for a Task.
Public Property Task_Text | Returns/sets the text associated with the Task.
Public Property Task_TitleForeColor | Returns/sets the color used to paint the title text in the weekly and monthly views for a Task.
Public Property Task_WeekendBackColor | Returns/sets the background color of the weekend dates for a Task.
Public Property Task_WeekSummaryBackColor | Returns/sets the primary background color of the weeksummary areas for a Task.
Public Property Task_WeekSummaryBackColorTo | Returns/sets the secondary background color of the weeksummary areas for a Task.
Public Property Task_WeekSummaryBorderColor | Returns/sets the color used to paint the border around each weeksummary area for a Task.
Public Property Task_WeekSummaryFillType | Returns/sets the pattern used to paint the background of the weeksummary areas for a Task.
Public Property Task_WeekSummaryForeColor | Returns/sets the color used to paint the text in the weeksummary areas for a Task.
Public Property TaskBarBorder | Determines if a border will be placed on the task bars for the appointments in the control.
Public Property TaskBarColor | Returns/sets the default color of the task bars for the appointments in the control.
Public Property TaskBarWidth | Returns/sets the width of the task bars for the appointments in the control.
Public Property TimeAMText | Returns/sets the text used to describe time values between midnight and noon.
Public Property TimeArea | Determines if the time area will be visible in the day view.
Public Property TimeBackColor | Returns/sets the primary background color for the time area in the day view.
Public Property TimeBackColorTo | Returns/sets the secondary background color for the time area in the day view.
Public Property TimeBorderColor | Returns/sets the color used to paint the borders in the time area of the day view.
Public Property TimeBorderType | Returns/sets the border type separating time segments of the time area of the day view.
Public Property TimeEnd | Returns/sets the ending time for the day view.
Public Property TimeFillType | Returns/sets the fill type for the time area of the day view.
Public Property TimeFont | Returns/sets the font for the minute values in the time area of the day view.
Public Property TimeForeColor | Returns/sets the text color for the time area in the day view.
Public Property TimeGuideBackColor | Returns/sets the background color of the time guide.
Public Property TimeGuideChange | Returns/sets the opacity change used with each time guide interval to fade in the time guide.
Public Property TimeGuideForeColor | Returns/sets the text color of the time guide.
Public Property TimeGuideInterval | Returns/sets the time (in milliseconds) used to fade in the time guide.
Public Property TimeGuideOnMove | Determines if the time guide will appear when an appointment is being moved with the mouse in the day view.
Public Property TimeGuideOnSelect | Determines if the time guide will appear when multiple time cells are being selected in the day view.
Public Property TimeGuideOpacity | Returns/sets the maximum alpha (transparency) value assigned to the background and foreground colors of the time guide.
Public Property TimeGuideWidth | Returns/sets the width of the time guide.
Public Property TimeHeightOffset | Returns/sets the offset value used to calculate the height if the time lines in the day view.
Public Property TimeIncrement | Returns/sets the amount of time (minutes) separating each line in the day view.
Public Property TimePMText | Returns/sets the text used to describe time values between noon and midnight.
Public Property TimeSelectBackColor | Returns/sets the color used to paint the minute background of selected lines in the time area of the day view.
Public Property TimeSelectForeColor | Returns/sets the color used to paint the minute text of selected lines in the time area of the day view.
Public Property TimeSelectWidth | Returns/sets the width of the selected area in the time area of the day view.
Public Property TimeStart | Returns/sets the starting time for the day view.
Public Property TimeType | Returns/sets how the time values are displayed in the time area of the day view.
Public Property TimeWidth | Returns/sets the width of the time area in the day view.
Public Property TitleArea | Determines if a title area is displayed in a month or week view.
Public Property TitleFont | Returns/sets the font of the title area in a month or week view.
Public Property TitleForeColor | Returns/sets the text color of the title area in a month or week view.
Public Property TitleHeight | Returns/sets the height of the title area in a month or week view.
Public Property TitleText | Returns/sets the default text of the title area in a month or week view.
Public Property TitleTextAlign | Returns/sets the horizontal text alignment of the title area in a month or week view.
Public Property TodayBackColor | Returns/sets the primary color used to paint the header of a current date.
Public Property TodayBackColorTo | Returns/sets the secondary color used to paint the header of a current date.
Public Property TodayBorderColor | Returns/sets the border color of the current date.
Public Property TodayFillType | Returns/sets the fill type used to paint the header of a current date.
Public Property TodayForeColor | Returns/sets the color used to paint the text in a header of a current date.
Public Property TodayStyle | Returns/sets how a column in the day view or a date in the month and week view of the current date will be presented.
Public Property UserDrawnHeaderImage | Sets the index of the the image to be placed inside a date header in the weekly and monthly views.
Public Property VertScrollMax | Returns the maximum value or range of the vertical scroll bar.
Public Property VertScrollPos | Returns/sets the value or position of the vertical scroll bar of the control.
Public Property VertScrollVisible | Determines if the vertical scroll bar for the control will be visible.
Public Property ViewType | Returns/sets the current view type for the control.
Public Property WeekendBackColor | Returns/sets the background color used to paint weekend days in the weekly and monthly views.
Public Property Weekends | Returns/sets the days of the weeks that will be considered weekend days.
Public Property WeekSummary | Determines if a week summary will be visible in a month view.
Public Property WeekSummaryBackColor | Returns/sets the primary color of the background of each week summary in a month view.
Public Property WeekSummaryBackColorTo | Returns/sets the secondary color of the background of each week summary in a month view.
Public Property WeekSummaryBorderColor | Returns/sets the border color of each week summary in a month view.
Public Property WeekSummaryFillType | Returns/sets the background pattern of each week summary in a month view.
Public Property WeekSummaryFont | Returns/sets the font of each week summary in a month view.
Public Property WeekSummaryForeColor | Returns/sets the text color of each week summary in a month view.
Public Property WeekSummaryText | Sets the text to be painted inside a week summary in the monthly view.
Public Property WeekSummaryTextAngle | Returns/sets the text angle of each week summary in a month view.
Public Property WeekSummaryWidth | Returns/sets the width of the week summaries in a month view.
Public Property XMLRead | Returns/sets an XML file to read into ctxCalendar.
Public Property XMLWrite | Create an XML file based on the current settings of the control.
Public Property YearDisplay | Returns/sets how year values will be displayed in the month and week views.
Public Property ZoneOffset | Returns/sets the hour offset used in a secondary time zone.

Events

Public Event AfterAppointmentAdd | Occurs after an appointment has been added to the control.
Public Event AfterAppointmentChange | Fires after an appointment has been moved/resized within the control.
Public Event AfterAppointmentSelect | Fires after an appointment has been selected in the control.
Public Event AfterAppointmentUnSelect | Fires after an appointment is unselected in the control.
Public Event AfterDateSelected | Fires after a date is selected in the weekly or monthly views.
Public Event AfterReportPrint | Occurs after a printed report has been created.
Public Event AfterTimeSelect | Occurs after a new time cell is selected in the daily view.
Public Event AppIndicatorClick | Occurs when the user clicks an appointment indicator in the daily view.
Public Event AppointmentChanging | Occurs while the user moves or resizes an appointment in the control.
Public Event AppointmentClick | Fires when a user left-clicks an appointment in the control.
Public Event AppointmentDblClick | Fires when a user double clicks an appointment with the left mouse button.
Public Event AppointmentMouseOver | Fires when the user moves the cursor over an appointment.
Public Event AppointmentRightClick | Fires when a user right-clicks an appointment in the control.
Public Event ArrowClick | Occurs when an arrow is clicked
Public Event BeforeAppointmentAdd | Occurs before an appointment is added to the control.
Public Event BeforeAppointmentChange | Occurs before changes made to an appointment through user interactions have been fully committed to the control.
Public Event BeforeAppointmentSelect | Occurs before an appointment is selected in the control.
Public Event BeforeDateSelect | Occurs just before a date is selected in the Weekly and Monthly views.
Public Event BeforeReportPrint | Occurs just before a printed report is created.
Public Event BeforeTimeSelect | Occurs just before a new cell in the daily view is selected.
Public Event Click | Occurs when the user clicks the control with the mouse.
Public Event ControlError | Occurs when the control encounters an internal error.
Public Event DateClick | Occurs when a date is clicked in the Weekly and Monthly views.
Public Event DateDblClick | Occurs when a date is double clicked in the Weekly and Monthly views.
Public Event DateRightClick | Occurs when the user right-clicks a date in the weekly or monthly views.
Public Event DblClick | Occurs when the user double clicks the control with the mouse.
Public Event DisplayMenu | Occurs when the user right-clicks within the edit window of the selected appointment, and the CustomMenu Property is set to True.
Public Event DropItem | Occurs when an item is dropped into a time cell.
Public Event FirstDraw | Occurs immediately after the control has been painted for the first time. This can be important because some properties base their data on how the control draws itself (i.e. font information). This data will not be accurate until the control draws itself at least once.
Public Event HorzScroll | Occurs when the value of the horizontal scroll bar is changed.
Public Event KeyDown | Occurs when the user presses a key while an object has the focus.
Public Event KeyPress | Occurs when the user presses and releases an ANSI key.
Public Event KeyUp | Occurs when the user releases a key while an object has the focus.
Public Event MouseDown | Occurs when the user presses a mouse button.
Public Event MouseMove | Occurs when the user moves the mouse over an object
Public Event MouseUp | Occurs when the user releases the mouse button.
Public Event StartDragOut | Occurs when the left mouse button is clicked and then dragged from an appointments task bar.
Public Event TextChange | Occurs when the text in an appointment is changed.
Public Event TimeDblClick | Occurs when a time segment in the control is double clicked on.
Public Event UserDrawnCellText | Occurs after each time cell is drawn in the daily view.
Public Event UserDrawnColorCell | Occurs just before a time a cell is drawn in the control, allowing the developer to color a cell uniquely.
Public Event UserDrawnDateHeaderText | Occurs before the text is drawn in the headers of each date in the weekly/monthly view
Public Event UserDrawnHeaderImage | Occurs just before a header for a date column is drawn in the daily view.
Public Event UserDrawnPageNumber | Occurs just before a page number is written on a printed report.
Public Event UserDrawnShowTime | Occurs just before the Time text is displayed in an appointment.
Public Event UserDrawnWeekSummary | Occurs just before the text is displayed in a WeekSummary in the Monthly view of the control.
Public Event VertScroll | Occurs when the value of the vertical scroll bar is changed.
Public Event ViewPainted | Occurs just after the calendar has been painted.
Public Event ViewTypeChanged | Occurs when the ViewType Property is changed.

See Also

ctxCalendar Object


%%Phrase%%

ctxCalendar (4.0) Calendar and Day View Control Send comments on this topic.
Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z


Class not licensed

Error Message

"Class is not licensed for use. OLE object is being ignored."

PROBLEM

The activeX control in the form or project does not reside in the same folder as the license file.

CAUSE

When developing with activeX control, the registered control must reside in the same folder as the license file (ct*.lic)

RESOLUTION

Place the .lic file in the same folder as the registered .ocx file. If the problem persists it is possible that multiple copies of the control are located on a development machine. Perform a search of the hard drive to confirm that the .ocx and .lic file are in the same folder and re-register the .ocx file using RegSvr32.exe, found in the System32 folder.


Run Time Error 429

Error Message

“Runtime Error '429': You do not have an appropriate license to use this functionality”

PROBLEM

An error reporting "a license is required to use this functionality" occurs when an application containing an instance of a DBI component, created exclusively through code, is distributed to a client machine.

CAUSE

Runtime licensing of ActiveX components instantiated in an application through code at runtime (the component is not included in the project at design time). The licenses collection cannot locate the licensing information.

APPLIES TO

Commercially licensed ActiveX components and User control ActiveX components containing commercial licensed ActiveX components (please see special notes at the end).

DETAIL

Developers distributing applications that create an instance of a commercial licensed ActiveX component or an ActiveX component created in VB 6 containing a commercial licensed component receive the following error when the application is run on a client machine:

“Runtime Error '429': You do not have an appropriate license to use this functionality”

The error is the result of missing license information in the licenses collection of the application.

RESOLUTION

In order to create an instance of a commercial licensed component or an ActiveX component containing a commercial licensed ActiveX component, the license for the component must first be added to the licenses collection of the application.

Typically, the license for a component is added to the licenses collection for the application when the component is added to the toolbar of the project (Visual Basic). If however an application only creates instances of a component in code, not having added the component the toolbar prior to compiling the application, then the license must be manually added in code prior to creating the instance of the component. To accomplish this the developer must first store the license in a text file, which ultimately must be distributed with the application.

The following Visual Basic code illustrates how to capture the license string for a component called ctDBI, and store it in a text file:

Dim intFile As Integer

intFile = FreeFile

' Open a file to write the license key to.

Open "c:\Ctl_DBI.txt" For Output As #intFile

Dim strLicense As String

strLicense = Licenses.Add("ctDBI.ctDBICtrl.1")

' Note: ctDBI.ctDBICtrl.1is the Prog ID for the component as stored in the registry

' The Licenses.Add method returns the license key string for the component

' Write the license key to the file.

Write #intFile, strLicense

Close #intFile

The Ctl_DBI.txt file now contains the license key string for the ctDBI ActiveX component.

NOTE: This must be run on the machine licensed to develop with component and should be run independently of the application project in which the component is to be used.

Once the license text file has been generated the code to add the license to the application's license collection can be added.

NOTE: This code must be executed prior to creating the instance of the component.

intFile = FreeFile

Open "c:\ctl_DDB.txt" For Input As #intFile

Dim strKey As String

' On the client machine, read the license key from the file.

Input #intFile, strKey

'Add the license for the component to the licenses collection for the application

Licenses.Add "ctDBI.ctDBICtrl.1", strKey

Close #intFile

Once the license has been added to the licenses collection of the application, the component can be instantiated and used, as follows:

'Create the instance of the component

Set extObj = Controls.Add("ctDBI.ctDBICtrl.1", "ctl1")

'Note: ctDBI.ctDBICtrl.1 is the Prog ID of the component as stored in the registry

'Make the object visible

With Controls("ctl1")

.Visible = True

End With

SPECIAL NOTE For User-created Controls:

If the component being instantiated is a user control containing a commercial licensed ActiveX component, the user control must be generated with a license. In Visual Basic this will generate a .vbl file. Once the user control ocx has been generated and registered, the license for the user control can be added to the application in the same manner as described above.


Supporting Files

Using DBI controls

Supporting dll's

In order to use the OCX components the following support files are required:

  • MFC42.DLL (version 6.0 or later)-this is the Microsoft Foundation Class Library. It must be registered with your system registry.
  • MSVCRT.DLL-this is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL, -required to display the stock property pages of the components in development mode.

Additionally, MSHTML.DLL and MLANG.DLL are Microsoft dll's required for the operation of the ctHTML View component.

These files must be distributed (and registered where necessary) with your applications (with the exception of MSSTKPRP.DLL). You may require additional OCX or OLE support files if your application requires them-check with the host language manual to determine what those files (if any) might be.


Working with Properties and special DataTypes

Fonts

There are 2 ways to assign values to Font based properties of the ActiveX controls at runtime.

1. Assign the value from a Font property on another OleControl.

[Visual Basic and Access]

Me.ctxControl.Font = Ole_object.Font

[Visual FoxPro]

thisform.ctxControl.Font = Ole_Object.Font

2. Modify the individual properties on the Font object itself.

[Visual Basic and Access]

Me.ctxControl.Font.Name = "Verdana"

Me.ctxControl.Font.Bold = True

[Visual FoxPro]

thisform.ctxControl.Font.Name = "Verdana"

thisform.ctxControl.Font.Bold = .T.

Images

Assigning images to a control at runtime, requires the image be an olePicture object (not just a standard image).

Some IDE's such as Visual Basic, Visual Foxpro and Access have a LoadPicture method which can be used to load a picture file and will convert it to the correct format.

[Visual Basic and Access]

Me.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

[Visual Foxpro]

thisform.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

Alternatively, if the image has already been assigned to a property on an oleControl, then the value of that property can be assigned directly.

[Visual Basic and Access]

Me.ctxControl.BackImage = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxControl.BackImage = Ole_Control.Picture