Welcome to ctxSchedule

ctxSchedule (3.0) 32/64 bit Scheduling Control

Welcome to ctxSchedule

The ctxSchedule object is a full-featured 32 bit and 64 bit, Unicode compliant scheduling system control.

ctxSchedule allows you to quickly add employee or resource scheduling to your applications. ctxSchedule gives you the ability to print schedules, assign time lines or bars to a resource, change the viewing granularity (zoom in and zoom out), and create a wide variety of time bar styles.

The ctxSchedule control contains the following sections:

  • The Schedule Area - where time bars are created and interacted with and through which developers define the type of Gantt style end-user interaction.

  • The integrated multi column Resource List area - where developers set data and presentations for interacting with categorized lists of Resources.

  • The Ruler Area - offers direct time line customization for creating plans and schedules based on time types and time lines of Seconds to Years.

  • List Items - which originate in the List View and carry through the Scheduling Area for contiguous representation of Resources and the tasks and roles assigned to them.

  • Time Bars - which reside in the Schedule Area that complete DBI's unique Gantt Style, intuitively interactive, Drag and Drop planning and scheduling surface.

See what's new in the latest version

Easy to develop with - complete with over 200 properties, events and methods.

Elegant, simple and intuitive to use, your end-users will love the easy-to-use drag and drop creation of time bars.


Getting Started

DBI Technologies

Getting Started

System Requirements

All of the DBI "CTX" pre-fixed activeX controls can be used in any development environment that supports 32/64 bit OCX/ActiveX™ OLE components.

Supporting Files

In order to use the OCX components the following support files are required:

  • MFC110U.DLL (version 11.0)-this is the Microsoft Foundation Class Library. It must be registered with your system registry.
  • MSVCR110.DLL - (version 11.0)-this is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL, -required to display the stock property pages of the components in development mode (or at runtime if desired, with the "PropertyPages" property on each control). NOTE: The MSSTKPRP.dll is currently only available in 32-bit environments and applications

NOTE: The XML functionality requires MSXML4.dll be installed on the host system.

These files must be distributed (and registered where necessary) with your applications (with the exception of MSSTKPRP.DLL). You may require additional OCX or OLE support files if your application requires them-check with the host language manual to determine what those files (if any) might be.

Versioning

All components that receive new properties, new events, or new methods, that change the structure of the ODL file, will receive an increment in its whole version number (i.e. from version 1.0 to version 2.0). These components will be compiled with a new GUID—the GUID is the unique identifier used to identify the control within the system registry. All components that receive bug fixes or enhancements that do not change the structure of the ODL file will receive an increment in the decimal version number (e.g. from version 1.0 to 1.1). These components will not be compiled with a new GUID. All components will contain a description string (that reflects the component name), version number (to identify the version of source code that was used to compile the component), and product identifier (to indicate whether the component is generic to a component package or a custom compile for a specific customer).

Note: Globally unique identifiers (GUIDs) are 128-bit integer values that are used to assign world-wide unique identifiers for COM interfaces and CoClasses

BACKWARD COMPATIBILITY

To address the problem of maintaining compatibility with previous versions, DBI Technologies has elected to generate new GUIDs as described above. In essence, new versions that are compiled with new GUIDs become new components. These may be registered and referenced on a system with an older version of the same component without conflict. This co-existence will allow developers to release new applications utilizing new component versions without effecting the performance or functionality of existing applications using older component versions.


%%PageItemTitle%% $$Members$$

ctxSchedule (3.0) Scheduling Control
ctxSchedule Object Members
See Also Overview Send comments on this topic.

Public Methods

Public Method AbortPrint | Cancels a printed report before being sent to the printer.
Public Method AddBarStyle | Adds a new time bar style to the control.
Public Method AddColorBar | Adds a new color block to the schedule area.
Public Method AddColumn | Adds a new column to the list area.
Public Method AddGuideLine | Add a guideline to the Schedule.
Public Method AddImage | Adds a new image to the internal image list.
Public Method AddItem | Adds a new item to the list area.
Public Method AddKeyTimeBar | Adds a new timebar with a key ID to the schedule.
Public Method AddLink | Creates a new link between 2 time bars.
Public Method AddNote | Adds a new note to the schedule.
Public Method AddTimeBar | Adds a new time bar to the schedule.
Public Method BarEnd | Moves the end position of the time bar.
Public Method BarIsMilestone | Determines if the time bar is defined as a milestone.
Public Method BarMove | Moves the position of a time bar.
Public Method BarMoveToLine | Moves a time bar from one item to another (vertically).
Public Method BarStart | Moves the start position of an existing time bar.
Public Method BringToFront | Moves a specified timebar in front of any conflicting time bars.
Public Method CancelChange | Prevents a change to a time bar from occuring.
Public Method CancelDelete | Prevents a time bar from being deleted.
Public Method CancelDrop | Prevents a time bar from being added or moved in the schedule.
Public Method CancelLink | Used to cancel a link between 2 time bars.
Public Method CancelSelect | Prevents a time bar from being selected.
Public Method CancelUnlink | Used to cancel an unlink operation between 2 time bars.
Public Method ClearBarStyles | Removes all the bar styles stored in the control.
Public Method ClearColorBars | Removes all the color bars stored in the control.
Public Method ClearColumns | Clears all the columns stored in the control.
Public Method ClearGuideLines | Clears all the GuideLines in the Schedule.
Public Method ClearHistory | Clears all history items stored in the control.
Public Method ClearLinks | Clears all of the links stored in the control.
Public Method ClearNotes | Clears all the notes from a line item.
Public Method ClearSchedule | Clears all of the items and time bars stored in the control.
Public Method ClearTimeBars | Clears all the time bars in a list item.
Public Method ColorBarsAt | Returns the count of the colorbars at the specified coordinates
Public Method ColumnCount | Gets the total number of columns assigned to the control.
Public Method CreateImage | Creates an image file based on the current content of the control.
Public Method ctDragDrop | Passes the DragDrop information from the DragDrop event into the control
Public Method ctDragOver | Passes the DragOver information to the DragOver event.
Public Method DateAt | Gets the date at a specific x coordinate.
Public Method DeleteColorBar | Deletes a color bar from the control.
Public Method DeleteGuideLine | Delete a specific GuideLine in the Schedule.
Public Method DeleteItem | Deletes a list item from the control
Public Method DeleteLink | Deletes a link from the control.
Public Method DeleteNote | Deletes a single note from a line item.
Public Method DeleteTimeBar | Deletes a time bar from the control.
Public Method DragDrop | Passes the DragDrop information from the DragDrop event into the control
Public Method DragOver | Passes the DragOver information to the DragOver event.
Public Method FindBarCargo | Gets the index of the first time bar on a specific item with the desired cargo value
Public Method FindBarCargoItem | Gets the index of the first list item in the control that contains a time bar with the desired cargo value.
Public Method FindBarCargoItemNext | Gets the index of the next list item in the control that contains a time bar with the desired cargo value.
Public Method FindBarCargoNext | Gets the index of the next time bar on a specific item with the desired cargo value
Public Method FindBarData | Gets the index of the first time bar on a specific item with the desired data value
Public Method FindBarDataItem | Gets the index of the first list item in the control that contains a time bar with the desired data value.
Public Method FindBarDataItemNext | Gets the index of the next list item in the control that contains a time bar with the desired data value.
Public Method FindBarDataNext | Gets the index of the next time bar on a specific item with the desired data value
Public Method FindConflictBar | Gets the first conflicting time bar within a given area.
Public Method FindFirstBar | Gets the first time bar which conflicts with a given time bar in a single list item.
Public Method FindFirstColorBar | Returns the index of the first colorbar at the specified coordinates.
Public Method FindFirstItem | Gets the first list item which contains a time bar that conflicts with a given time bar.
Public Method FindFirstTimeBar | Returns the index of the first timebar at the specified coordinates.
Public Method FindItemCargo | Gets the index of the first item in the control that contains the specified string value in their ItemCargo property.
Public Method FindItemCargoNext | Gets the index of the next item in the control that contains the specified string value in their ItemCargo property.
Public Method FindItemData | Gets the index of the first item in the control that contains the specified long value in their ItemData property.
Public Method FindItemDataNext | Gets the index of the next item in the control that contains the specified long value in their ItemData property.
Public Method FindNextBar | Gets the next time bar which conflicts with a given time bar on a single list item.
Public Method FindNextColorBar | Returns the index of the next colorbar at the specified coordinates.
Public Method FindNextItem | Gets the next list item which contains a time bar that conflicts with a given time bar.
Public Method FindNextTimeBar | Returns the index of the next timebar at the specified coordinates.
Public Method FirstLine | Sets the first visible list item in the schedule.
Public Method InDeadZone | Determines if a specific area in the schedule is a dead zone.
Public Method InsertColumn | Inserts a new column into the list area.
Public Method InsertItem | Inserts a new list item into the list area.
Public Method KeyIDBar | Gets the time bar assigned with a specific key ID value.
Public Method KeyIDItem | Gets the list item that contains a time bar with a specific KeyID value.
Public Method LineAt | Returns the index of the list item at the specified coordinate.
Public Method MakeBarVisible | This method will attempt to scroll a specific time bar in to the visible area of the control.
Public Method NoteAt | Returns the index of the Note at the specified coordinate.
Public Method PrintSchedule | Sends the contents of the current ctxSchedule to a printer.
Public Method PrintScheduleImage | Sends the contents of the current ctxSchedule to a printer.
Public Method ReadFile | Reads an xml document to populate the control.
Public Method ReadXMLString | Reads the schedule data into a memory variable
Public Method Redo | Performs an redo action on the control.
Public Method RedoCount | Gets the number of items in the redo list.
Public Method ReDraw | Forces the control to be re-painted.
Public Method RemoveColumn | Removes a column from the list area.
Public Method RemoveImage | Removes an image from the internal image list.
Public Method ScheduleItemAt | Returns a value indicating the area of the schedule at the specified coordinates.
Public Method ScrollToColumn | Will attempt to scroll the list portion of the control to the specified column.
Public Method SendToBack | Moves a specified timebar behind of any conflicting time bars.
Public Method SetView | Sets the view in the control so that a given area is fully visible.
Public Method StopTimer | Stops the internal timer within the control.
Public Method TimeAt | Gets the time at a specific x coordinate.
Public Method TimeBarsAt | Returns the count of the timebars at the specified coordinates
Public Method TimeScroll | Moves the horizontal scroll bar to given date and time.
Public Method Today | Returns the current date.
Public Method Undo | Performs an undo action on the control.
Public Method UndoCount | Gets the number of items in the undo list.
Public Method WriteFile | Writes the data in ctxSchedule to an xml file.

Public Properties

Public Property AdjustOnMove | Determines if a partially exposed time line will be scrolled up when a time bar is moved within it.
Public Property AlignmentLines | Determines if alignment lines will be displayed, inside the schedule area, when moving/sizing/creating time bars.
Public Property AlignmentLinesColor | Determines the color used to paint AlignmentLines in the schedule area of the control
Public Property AllowHorzMoves | Determines if users can move time bars horizontally in the schedule area.
Public Property AllowNewBars | Determines if users can create time bars in the schedule area.
Public Property AllowResizeBars | Determines if users can resize time bars in the schedule area.
Public Property AllowVertMoves | Determines if users can move time bars vertically between items in the schedule area.
Public Property AltListColorEven | Returns/sets the background color of the even numbered list items.
Public Property AltListColorOdd | Returns/sets the background color of the odd numbered list items.
Public Property AltListColors | Determines if the list items will drawn with alternate colors.
Public Property AltListItems | Determines how ofter to alternate the list item between the even and odd background colors.
Public Property AltSchedColorEven | Returns/sets the background color of the even numbered list items in the schedule area of the control.
Public Property AltSchedColorOdd | Returns/sets the background color of the odd numbered list items in the schedule area of the control.
Public Property AltSchedColors | Determines if background color of list items in the schedule area will drawn with alternate colors.
Public Property AltSchedItems | Determines how ofter to alternate the list item in the schedule area between the even and odd background colors.
Public Property BackColor | Returns/sets the background color of the schedule area in the control.
Public Property BackImage | Returns/sets the background image of the schedule area.
Public Property Bar | Returns/sets the selected time bar in the control
Public Property BarBackColor | Returns/sets the background color of a time bar.
Public Property BarBackColorTo | Returns/sets the secondary background color (fill color) of a time bar.
Public Property BarBorderColor | Returns/sets the border color of a time bar.
Public Property BarBorderWidth | Returns/sets the width of the border of a timebar.
Public Property BarCargo | Returns/sets a non-visible text value to the time bar.
Public Property BarCount | Returns the number of time bar assigned to a specific list item.
Public Property BarData | Returns/sets a non-visible integer value of a time bar.
Public Property BarDateEnd | Returns/sets the end date of the time bar.
Public Property BarDateForeColor | Determines the color used to paint the date text in an individual time bar
Public Property BarDateStart | Returns/sets the start date of the time bar.
Public Property BarDateText | The text to assign to be displayed in the UserDrawnBarDateText event.
Public Property BarDateTextColor | Returns/sets the text color of the dates in the time bars.
Public Property BarDefBackColor | Returns/sets the default background color of a time bar.
Public Property BarDefBackColorTo | Returns/sets the default secondary background color (fill color) of a time bar.
Public Property BarDefBorderColor | Returns/sets the default border color of a time bar.
Public Property BarDefFillType | Returns/sets the default timebar fill type.
Public Property BarDefFont | Returns/sets the default font for the text in the time bars.
Public Property BarDefForeColor | Returns/sets the default foreground color of a time bar.
Public Property BarEndImage | Returns/sets the end image of a time bar.
Public Property BarFillType | Returns/sets the fill pattern of a time bar.
Public Property BarFont | Returns/sets the font of a time bar.
Public Property BarForeColor | Returns/sets the foreground color of a time bar.
Public Property BarKeyID | Returns/sets the unique KeyId of a time bar.
Public Property BarMinSize | Returns/sets the minimum size of a time bar.
Public Property BarReadOnly | Determines if a time bar is read-only.
Public Property BarSelectBackColor | Returns/sets the background color of the selected time bar.
Public Property BarSelectBorderColor | Returns/sets the border color of the selected time bar.
Public Property BarSelectFocus | Determines if a focus border will appear around the selected time bar.
Public Property BarSelectForeColor | Returns/sets the forecolor color of the selected time bar.
Public Property BarStartImage | Returns/sets the start image of a time bar.
Public Property BarStyle | Returns/sets a pre-defined bar style to a time bar.
Public Property BarStylePriority | Determines if the properties on a BarStyle or individual TimeBar get the highest priority when displaying a TimeBar in the control.
Public Property BarSubText | Returns/sets the sub-text of a time bar.
Public Property BarText | Returns/sets the primary text of a time bar.
Public Property BarTextAlign | Returns/sets the horizontal alignment of the time bar text.
Public Property BarTextWrap | Determines if the text within a time bar will wrap (shown as multiple lines of text).
Public Property BarTimeEnd | Returns/sets the end time of the time bar.
Public Property BarTimeStart | Returns/sets the start time of the time bar.
Public Property BarTipExtension | Returns/sets the distance outside the time bar that the user to click to resize the bar.
Public Property BarTipSize | Returns/sets the distance inside the time bar that the user to click to resize the bar.
Public Property BarVisible | Returns/sets the visibility of a timebar when it is within the display area of the schedule area.
Public Property BorderColor | Returns/sets the border color below the title line and around the control.
Public Property BorderType | Returns/sets the type of border to place around the control.
Public Property BreakChar | Returns/sets the character used for seperating text between columns in the list.
Public Property CBarCount | Returns a count of the total number of color bars assigned to the control.
Public Property CBarDateEnd | Returns/sets the end date of the color bar.
Public Property CBarDateStart | Returns/sets the start date of the color bar.
Public Property CBarDeadZone | Determines if the color bar area will be considered a dead zone.
Public Property CBarFillType | Returns/sets the fill pattern of the color bar.
Public Property CBarIndex | Returns/sets the list item assigned to the color bar.
Public Property CBarLineWidth | Returns/sets the width of the color bar when the start and end times are the same.
Public Property CBarTimeColor | Returns/sets the background color of the color bar.
Public Property CBarTimeColorTo | Returns/sets the secondary color of the color bar.
Public Property CBarTimeEnd | Returns/sets the end time of the color bar.
Public Property CBarTimeStart | Returns/sets the start time of the color bar.
Public Property CBarVertOffset | Returns/sets the vertical offset used to draw the color bar
Public Property CellBackColor | Returns/sets the background color of an individual cell in the list area.
Public Property CellCheck | Returns/sets the check state of an individual cell in the list area.
Public Property CellFont | Returns/sets the font of an individual cell in the list area.
Public Property CellForeColor | Returns/sets the foreground color of an individual cell in the list area.
Public Property CellPicSelect | Returns/sets the image to display in a cell when the list item is selected.
Public Property CellPicture | Returns/sets the image to place in an individual cell in the list area.
Public Property CellText | Returns/sets the text of an individual cell in the list area.
Public Property CheckPicDisabled | Returns/sets the picutre used for a disabled check box.
Public Property CheckPicDown | Returns/sets the picutre used for a selected check box.
Public Property CheckPicUp | Returns/sets the picutre used for an un-selected check box.
Public Property CheckXOffset | Returns/sets the horizontal offset value used to calculate the position of the checkbox in a cell.
Public Property CheckYOffset | Returns/sets the vertical offset used to calculate the position of the checkbox in a cell.
Public Property ColumnBackColor | Returns/sets the background color for the cells in a column.
Public Property ColumnCheckAlign | Returns/sets the alignment of the checkboxes within the cells in the column.
Public Property ColumnCheckBox | Determines the type of checkbox to display in the cells of the column.
Public Property ColumnForeColor | Returns/sets the foreground color of the cells in the column.
Public Property ColumnHeaderAlign | Returns/sets the horizontal alignment of the column header.
Public Property ColumnLock | Determines if the column can be resized with the mouse.
Public Property ColumnPicture | Returns/sets the index of the image in a specific column header.
Public Property ColumnPictureAlign | Returns/sets the horizontal alignment of the image in a column header.
Public Property ColumnText | Returns/sets the column header text.
Public Property ColumnTextAlign | Returns/sets the horizontal alignment of the item cell text in the column.
Public Property ColumnWidth | Returns/sets the width of the column.
Public Property ConflictOffset | Returns/sets the number of minutes used to determine a time bar conflict.
Public Property DateEnd | Returns/sets the end date of the schedule
Public Property DateFormat | Returns/sets the date format in the ruler title.
Public Property DateOffset | Returns/sets the offset value used to synchronize the base date of the control to the base date of the development platform.
Public Property DatesInBars | Determines if the start and end dates of a time bar will be displayed as text within the time bar.
Public Property DateStart | Returns/sets the start date of the schedule.
Public Property DayMonthOffset | Determines the offset used to calculate the starting day of the week in a monthly ruler.
Public Property DayNames | Returns/sets the names of the week days.
Public Property DefaultStyle | Returns/sets the default style of the time bars.
Public Property DefBarHeight | Returns the default height of the time bars.
Public Property DefLineHeight | Returns the default height of the list items.
Public Property DisplayOnly | Determines if the control will react to user interaction.
Public Property DisplaySubText | Determines if the time bar sub-text will be displayed.
Public Property EditMode | Returns/sets the type of action to perform on a time bar.
Public Property FillList | Determines how the last column in the list area will be displayed.
Public Property FontIndex1 | Returns/sets an additional font which can be assigned to the list items and cells.
Public Property FontIndex2 | Returns/sets an additional font which can be assigned to the list items and cells.
Public Property FontIndex3 | Returns/sets an additional font which can be assigned to the list items and cells.
Public Property FontIndex4 | Returns/sets an additional font which can be assigned to the list items and cells.
Public Property GridFrequency | Returns/sets the distance where the time bars can be moved or sized.
Public Property GuideColor | Returns/sets the color of an individual GuideLine based on the index.
Public Property GuideDate | Returns/sets the long date value of the GuideLine.
Public Property GuideImage | Returns/sets the index value of the GuideLine image.
Public Property GuideImageIndex | Returns/sets the image index value of default GuideLines.
Public Property GuideImagePosition | Determines wether the GuideLine images will appear in front of or behind the ruler text.
Public Property GuideImageXOffset | Returns/sets the horizontal offset value used to calculate the position of the GuideLine image in the ruler.
Public Property GuideImageYOffset | Returns/sets the vertical offset used to calculate the position of the GuideLine image in the ruler.
Public Property GuideLineColor | Returns/sets the default GuideLine color.
Public Property GuideLineDistance | Determines how close the edge of a time bar must be to a GuideLine before the time bar is snapped to the GuideLine location (in pixels).
Public Property GuideLocked | Determines if a GuideLine can be moved/removed with the mouse.
Public Property GuideMoveColor | Returns/sets the color of a GuideLine while it is moving.
Public Property GuideTime | Returns/sets the time value (in minutes past midnight) of the GuideLine.
Public Property HeightOffset | Returns/sets the offset value used to calculate the height of the list items.
Public Property HistorySize | Returns/sets the number of items that can be undone/redone
Public Property HorzGridLineColor | Determines the color used to paint the HorzGridLines in the schedule area.
Public Property HorzGridLines | Determines if horizontal grid lines will be displayed in the schedule area.
Public Property HorzListLargeChange | Returns/sets the override for the large change of the horizontal scroll bar in the list area.
Public Property HorzListMax | Returns the max scroll value of the horizontal scroll bar in the list area.
Public Property HorzListSmallChange | Returns/sets the override for the small change of the horizontal scroll bar in the list area.
Public Property HorzScheduleLargeChange | Returns/sets the override for the large change of the horizontal scroll bar in the schedule area.
Public Property HorzScheduleMax | Returns the max scroll value of the horizontal scroll bar in the schedule area.
Public Property HorzScheduleSmallChange | Returns/sets the override for the small change of the horizontal scroll bar in the schedule area.
Public Property HorzScrollType | Determines how the list area is horizontally scrolled.
Public Property ImageListCount | Returns the number of images stored in the internal image list.
Public Property ImagePosition | Returns/sets the alignment/format of the background image in the schedule area.
Public Property IncludeAmPm | Determines if the AM and PM tags will be displayed in the ruler text.
Public Property IncludeMinutes | Determines if minutes will be included in the ruler text.
Public Property ItemBackColor | Returns/sets the background color of a list item
Public Property ItemCargo | Returns/sets the non-visible text value for the list item.
Public Property ItemData | Returns/sets a non-visible integer value of a list item.
Public Property ItemFont | Returns/sets the font of a list item.
Public Property ItemForeColor | Returns/sets the foreground color of a list item.
Public Property ItemHeader | Determines if the list item will appear as a group header item.
Public Property ItemHeaderBackColor | Returns/sets the primary background color for all group header items.
Public Property ItemHeaderBackColorTo | Returns/sets the secondary background color for all group header items.
Public Property ItemHeaderClick | Determines if the header items will respond to click events.
Public Property ItemHeaderFillType | Returns/sets the enumFillType for all group header items.
Public Property ItemHeaderFont | Returns/sets the default font for a list item group header.
Public Property ItemHeaderForeColor | Returns/sets the foreground(text) color for all group header items.
Public Property ItemLoaded | Determines if a list item is marked as loaded.
Public Property ItemNextBarIndex | Returns the index value for the first time bar past the end of the visible area of the schedule.
Public Property ItemPrevBarIndex | Returns the index value for the first time bar before the start of the visible area of the schedule.
Public Property ItemReadOnly | Determines if the list item will be readonly.
Public Property ItemText | Returns/sets the text of a list item.
Public Property LineArrowAfter | Returns/sets the image used for the line arrows indicating more time bars after the current view.
Public Property LineArrowBefore | Returns/sets the image used for the line arrows indicating more time bars before the current view.
Public Property LineArrowColor | Returns/sets the color used for the painting of the default line arrow appearance.
Public Property LineArrowPosition | Returns/sets where the line arrows will be drawn in the schedule.
Public Property LineMaxSize | Returns/sets the height of the line marking the major time unit within the ruler area.
Public Property LineMinSize | Returns/sets the height of the line marking the minor time units within the ruler area.
Public Property LinkColor | Returns/sets the color of a specific link item.
Public Property LinkCount | Returns the number of links stored in the control.
Public Property LinkFromBar | Returns the index value of the time bar initiating the link.
Public Property LinkFromItem | Returns/sets the index value of the schedule item containing time bar initiating the link.
Public Property LinkLineColor | Returns/sets the default link line color.
Public Property LinkToBar | Returns/sets the index value of the time bar receiving the link.
Public Property LinkToItem | Returns/sets the index value of the time bar receiving the link.
Public Property LinkType | Returns/sets the type of link to display between 2 time bars.
Public Property ListAlign | Determines the horizontal alignment of the text in the list area.
Public Property ListBackColor | Returns/sets the default background color of the list area in the control.
Public Property ListBarBorder | Determines the border type to use for the splitter bar
Public Property ListBarColor | Returns/sets the color of the splitter bar in the control.
Public Property ListBarWidth | Returns/sets the width of the splitter bar in the control.
Public Property ListBorder | Returns/sets the type of border to place around the cells and list items in the control.
Public Property ListCount | Returns the total number of the items in the list area.
Public Property ListFont | Returns/sets the default font for the list area in the control.
Public Property ListForeColor | Returns/sets the default foreground color of the list area in the control.
Public Property ListImage | Gets or sets an image within the internal image list.
Public Property ListIndent | Returns/sets the indent of the list item text.
Public Property ListIndex | Returns/sets the selected list item.
Public Property ListWidth | Returns/sets the width of the list area in ctxSchedule.
Public Property LockedLines | Returns/sets the number of lines (0-3) to lock at the top of the control's display.
Public Property LockListBar | Determines if the list area can be resized by moving the splitter bar.
Public Property MajorTimeLineRuler | Determines if the major time line will be drawn in the ruler.
Public Property MajorTimeLineRulerColor | Returns/sets the color to paint the major time lines in the ruler.
Public Property MajorTimeLineSchedule | Determines if a major time line will be drawn in the schedule.
Public Property MajorTimeLineScheduleColor | Returns/sets the color to paint major time line in the schedule.
Public Property MajorTimeLineScheduleWidth | Returns/sets the width of the major time line in the schedule.
Public Property MapHeight | Returns/sets the height of the map area.
Public Property MapLineColor | Returns/sets the color to place around the current view in the map area.
Public Property MapVisible | Determines if the map area is visible
Public Property MarkerBarColor | Returns/sets the color of the marker bars.
Public Property MarkerBars | Determines if marker bars will be visible.
Public Property MaskBitmap | Determines if a color in the images will appear transparent.
Public Property MaskColor | Returns/sets which color in the images will appear transparent.
Public Property MaxImageHeight | Returns/sets the maximum height of a file created with the CreateJPG method.
Public Property MaxImageWidth | Returns/sets the maximum width of a file created with the CreateJPG method.
Public Property MaxTimeBars | Returns/sets the maximum number of time bars assigned to a list item.
Public Property MilitaryTime | Determines if the ruler will display a 24 hour military time.
Public Property MonthlyType | Returns/sets the display of the month ruler.
Public Property MonthNames | Returns/sets the month names.
Public Property NoteCount | Returns the total count of notes on a line item
Public Property NoteDate | Returns/sets the date for the note.
Public Property NoteImageAlign | Returns/sets the the alignment for a note's image when it is locked in the schedule.
Public Property NoteImageIndex | Returns/sets the index value of the image to use for the note, from the internal image list.
Public Property NoteImageXOffset | Returns/sets the horizontal offset value used to calculate the position of the note image in the schedule.
Public Property NoteImageYOffset | Returns/sets the vertical offset value used to calculate the position of the note image in the schedule.
Public Property NoteLocked | Returns/sets if the note will be locked in the viewable area of the schedule.
Public Property NotesDistance | Determines the distance between locked notes in the schedule area.
Public Property NotesPosition | Determines where the notes will be drawn, relative to the Time Bars.
Public Property NoteText | Returns/sets the text assigned to a note.
Public Property NoteTime | Returns/sets the time for the note.
Public Property OverlapColor | Returns/sets the overlap line color.
Public Property OverlapLines | Determines if overlap lines will be displayed.
Public Property OverlapTime | Determines when an overlap between 2 time bars will occur.
Public Property OverlapWidth | Determines the width of the overlap lines.
Public Property Page | Sets the horizontal thumb in the list area to a fixed width.
Public Property PageXOffset | Returns/sets the offset value used to calculate the width of a printed report.
Public Property PageYOffset | Returns/sets the offset value used to calculate the height of a printed report.
Public Property PicAlign | Returns/sets the default horizontal alignment of an image within a cell in the list area.
Public Property PicMaxWidth | Returns/sets the maximum width of the images displayed in the list area.
Public Property PicXOffset | Returns/sets the horizontal offset value used to calculate the position of the images within the list area.
Public Property PicYOffset | Returns/sets the vertical offset value used to calculate the position of the images within the list area.
Public Property PreColumnBackColor | Returns/sets the background color of a non-selected pre-column cell.
Public Property PreColumnBorder | Returns/sets the border around a non-selected pre-column cell.
Public Property PreColumnFont | Returns/sets the pre-column font.
Public Property PreColumnForeColor | Returns/sets the foreground color of a non-selected pre-column cell.
Public Property PreColumnPicture | Returns/sets the picture of a selected pre-column cell.
Public Property PreColumnType | Returns/sets the type of column to display to the left of the defined columns.
Public Property PreColumnWidth | Returns/sets the pre-column width.
Public Property PreSelectBackColor | Returns/sets the background color of a selected pre-column cell.
Public Property PreSelectBorder | Returns/sets the border of a selected pre-column cell.
Public Property PreSelectForeColor | Returns/sets the foreground color of a selected pre-column cell.
Public Property PrintAltSchedColors | Determines if the alternating color in the schedule area will be included in a printed report.
Public Property PrintColorBars | Determines if color bars will be included in a printed report.
Public Property PrintColumns | Returns/sets the number of column in the list area to include in a printed report.
Public Property PrintDefaultPrinter | Determines if the print operations of the control will try to use the current users default printer instead of displaying the print dialog.
Public Property PrintFooter | Returns/sets the footer text in printed report.
Public Property PrintLandscape | Determines if the print operations of the control will try to pre-select the landscape orientation in the print dialog before displaying it.
Public Property PrintPageColumnFrom | Returns/sets the starting column of pages of a printed report.
Public Property PrintPageColumnMax | Returns the maximum amount of page columns a printed report will contain.
Public Property PrintPageColumnTo | Returns/sets the ending column of pages of a printed report.
Public Property PrintPageRowFrom | Returns/sets the starting row of pages of a printed report.
Public Property PrintPageRowMax | Returns the maximum amount of page rows a printed report will contain.
Public Property PrintPageRowTo | Returns/sets the ending row of pages of a printed report.
Public Property PrintPageText | Returns/sets the text used to describe the page in a printed report.
Public Property PrintSubTitle | Returns/sets the sub title of a printed report.
Public Property PrintTimeDistance | Returns/sets the distance between the major time units in a printed report.
Public Property PrintTitle | Returns/sets the title of a printed report.
Public Property PrintTitleAlign | Returns/sets the horizontal alignment of the title and sub-title in a printed report.
Public Property PrintTitleFont | Returns/sets the title font in a printed report.
Public Property PrintWeekendColor | Determines if the weekend colors will be included in a printed report.
Public Property PropertyPages | Allows for the display of the custom property pages in runtime.
Public Property RulerAlign | Returns/sets the horizontal alignment of the lower portion in the ruler area.
Public Property RulerBackColor | Returns/sets the background color of the ruler area of the control.
Public Property RulerBackColorTo | Returns/sets the secondary background color of the ruler of the control.
Public Property RulerBorder | Returns/sets the type of border to place around the ruler area.
Public Property RulerDays | Determines if the day names will be displayed in the ruler.
Public Property RulerDaySize | Returns/sets the number of characters used to display the day names.
Public Property RulerDivisions | Returns/sets the number of divisions between major time units in the ruler.
Public Property RulerFillType | Returns/sets the background fill pattern of the Ruler/list header area.
Public Property RulerFont | Returns/sets the default font of the Ruler/list header area.
Public Property RulerForeColor | Returns/sets the foreground color of the Ruler.
Public Property RulerLineColor | Returns/sets the line colors within the ruler area.
Public Property RulerSplit | Determines if the ruler will be split in half along the vertical axis of the ruler area.
Public Property RulerText | Returns/sets the text to appear in each time segment in the ruler.
Public Property RulerThreeD | Determines if the lines in the ruler area will be displayed with a lowered border.
Public Property RulerTitle | Returns/sets the title text of the ruler area.
Public Property RulerTitleBackColor | Determines the primary background color used to paint the ruler title area.
Public Property RulerTitleBackColorTo | Determines the secondary background color used to paint the ruler title area.
Public Property RulerTitleFillType | Determines the background fill pattern of the ruler title area.
Public Property RulerTitleForeColor | Determines the text color used in the ruler title area.
Public Property RulerXOffset | Returns/sets the horizontal offset value used to calculate the position of the text in the Ruler/list header area.
Public Property RulerYOffset | Returns/sets the vertical offset value used to calculate the position of the text in the Ruler/list header area.
Public Property SchedHeaderBackColor | Returns/sets the background color that will display on the schedule area for a header item.
Public Property SchedScroll | Returns/sets thevalue of the horizontal scroll bar in the schedule area of the control.
Public Property SchedSelectBackColor | Returns/sets the background color of the schedule area for the selected list item.
Public Property SelectBackColor | Returns/sets the background color of the selected list item.
Public Property Selected | Returns/sets the selected list item.
Public Property SelectForeColor | Returns/sets the foreground color of the selected list item.
Public Property SmallIcons | Determines the size of the icons in the list area.
Public Property SnapToGrid | Determines if the time bars will be aligned to the control using the GridFrequency property.
Public Property SnapToGuideLines | Enables the TimeBars to snap to the GuideLines.
Public Property StartWeekDay | Determine the first day of the week.
Public Property StyleBackColor | Returns/sets the background color of a time bar style.
Public Property StyleBackColorTo | Returns/sets the secondary background color (fill color) of a time bar style.
Public Property StyleBarHeight | Returns/sets the height of the time bar style.
Public Property StyleBorderColor | Returns/sets the border color of the time bar style.
Public Property StyleBrushType | Returns/sets the pattern brush for the time bar style.
Public Property StyleCount | Returns the number of time bar styles stored in the control.
Public Property StyleEndFront | Determines if the end image will be placed in front or behind the time bar.
Public Property StyleEndImage | Returns/sets the image to place at the end of the time bar.
Public Property StyleEndXOffset | Returns/sets the offset used to calulate the horizontal position of the end image of the time bar.
Public Property StyleEndYOffset | Returns/sets the offset used to calulate the vertical position of the end image of the time bar.
Public Property StyleFillType | Returns/sets the gradient fill for the time bar style.
Public Property StyleFont | Returns/sets the font of the time bar style.
Public Property StyleForeColor | Returns/sets the foreground color of a time bar.
Public Property StyleMilestone | Determines if the time bar style will display a milestone marker or a standard time bar.
Public Property StyleStartFront | Determines if the start image will be placed in front or behind the time bar.
Public Property StyleStartImage | Returns/sets the image to place at the start of the time bar.
Public Property StyleStartXOffset | Returns/sets the offset used to calulate the horizontal position of the start image of the time bar.
Public Property StyleStartYOffset | Returns/sets the offset used to calulate the vertical position of the start image of the time bar.
Public Property StyleTextXOffset | Returns/sets the offset used to calulate the horizontal position of the text in the time bar.
Public Property StyleTextYOffset | Returns/sets the offset used to calulate the vertical position of the text in the time bar.
Public Property StyleVOffset | Returns/sets the offset used to calulate the vertical position of the time bar.
Public Property TextIntoView | Determines if the time bar text will always be displayed within the time bar.
Public Property TimeBarHeight | Returns/sets the default height for time bars drawn in the control.
Public Property TimeBarImage | The TimeBar Picture to use in the UserDrawnBar Event .
Public Property TimeBarShadows | Determine if default timebars will be drawn with a shadow effect.
Public Property TimeBarVOffset | Returns/sets the default vertical offset for time bars drawn in the control.
Public Property TimeDistance | Returns/sets the distance between the major time units in the ruler area.
Public Property TimeEnd | Returns/sets the end time of the schedule.
Public Property TimeLineBreak | Returns/sets the frequency of the time lines.
Public Property TimeLineColor | Returns/sets the color of the time lines.
Public Property TimeLines | Determines if time lines will be displayed.
Public Property TimeLineStart | Returns/sets the first major time unit to display a time line.
Public Property TimeLineWidth | Returns/sets the style of the time lines.
Public Property TimeStart | Returns/sets the start time of the schedule.
Public Property TimeTagAM | Returns/sets the morning or AM tag used to format a time value within the lower portion of the ruler.
Public Property TimeTagPM | Returns/sets the evening or PM tag used to format a time value within the lower portion of the ruler.
Public Property TimeType | Returns/sets the type of units to display in the ruler of ctxSchedule.
Public Property TipsBackColor | Returns/sets the background color of the tool tips.
Public Property TipsDelay | Returns/sets the initial delay between the mouse moving over a time bar, and the tool tip becoming visible.
Public Property TipsDistance | Returns/sets the distance between the tool tip and vertical scroll bar.
Public Property TipsFont | Returns/sets the tool tips font.
Public Property TipsForeColor | Returns/sets the fore ground color of the tool tips.
Public Property TipsOnNotes | Returns/sets if tool tips will be displayed when the mouse hovers over a note.
Public Property TipsOnOverBar | Returns/sets if tool tips will be displayed when the mouse hovers over a time bar.
Public Property TipsOnVScroll | Returns/sets if tool tips will be displayed when the mouse drags the vertical scroll thumb.
Public Property TipsPosition | Returns/sets the position of the tool tips when the vertical scroll bar is moved.
Public Property TipsText | Sets the tool tip text.
Public Property TipsTextAlign | Returns/sets the horizontal alignment of a tool tip.
Public Property TitleAlign | Returns/sets the horizontal alignment of the title/list header area.
Public Property TitleBackColor | Returns/sets the background color of the title/list header area of the control.
Public Property TitleBackColorTo | Returns/sets the secondary background color of the title/list header area of the control.
Public Property TitleBorder | Returns/sets the type of border to place around the title/list header area.
Public Property TitleFillType | Returns/sets the background fill patter of the title/list header area.
Public Property TitleFont | Returns/sets the default font of the title/list header area.
Public Property TitleForeColor | Returns/sets the foreground color of the title.
Public Property TitleHeight | Returns/sets the height of the title/list header area.
Public Property TitleOverBackColor | Returns/sets the background color of the column header as the mouse moves over it.
Public Property TitleOverForeColor | Returns/sets the foreground color of the column header as the mouse moves over it.
Public Property TitlePosition | Returns/sets the vertical alignment of the title/list header text.
Public Property TitleStyle | Determines the style of the title/ header area.
Public Property TitleXOffset | Returns/sets the horizontal offset value used to calculate the position of the text in the title/list header area.
Public Property TitleYOffset | Returns/sets the vertical offset value used to calculate the position of the text in the title/list header area.
Public Property TodayLine | Determines if a vertical line will be displayed for the current date.
Public Property TodayLineColor | Returns/sets the color of the line representing the current date.
Public Property TodayLineSize | Returns/sets the width of the line representing the current date.
Public Property TodayLineWidth | Returns/sets the style of the line representing the current date.
Public Property TopRow | Returns/sets the top visible row in the control.
Public Property UndoType | Gets the type of undo/redo action performed on the control.
Public Property UsePreLoad | Determines how the data is loaded into the control.
Public Property UserDrawnBar | Determines if the timebar drawing will be handled by the developer.
Public Property VertScrollLargeChange | Returns/sets the override for the large change of the vertical scroll bar.
Public Property VertScrollMax | Returns the max scroll value of the vertical scroll bar.
Public Property VertScrollSmallChange | Returns/sets the override for the small change of the vertical scroll bar.
Public Property WeekendColor | Returns/sets the background color of the weekend columns in the schedule area.
Public Property WeekendDates | Determines if weekend dates will be displayed in the ruler.
Public Property Weekends | Returns/sets which days of the week will be considered weekend days.
Public Property XMLRead | Returns/sets an XML file to read into ctxSchedule.
Public Property XMLWrite | Returns/sets an XML file to write the data from ctxSchedule.
Public Property YearlyType | Returns/sets how a yearly ruler is displayed.

Events

Public Event BarAdded | Occurs when a new time bar is added to the control.
Public Event BarChanged | Occurs after a time bar has been moved or sized horizontally.
Public Event BarDblClick | Occurs when a time bar is double clicked with the left mouse.
Public Event BarDeleted | Occurs after a time bar has been deleted from the schedule.
Public Event BarLeftClick | Occurs when a time bar is left clicked.
Public Event BarLinked | Occurs when 2 time bars are linked together.
Public Event BarPreDrop | Occurs before a time bar is created or moved in the schedule.
Public Event BarPreSelect | Occurs before a time bar is selected.
Public Event BarRightClick | Occurs when a time bar is right clicked.
Public Event BarSelect | Occurs when a new time bar is selected via user interaction.
Public Event BarSizing | Occurs as the position or time bar is being changed.
Public Event BarUnlinked | Occurs when a link is removed between 2 time bars.
Public Event BarUnSelect | Occurs when a time bar is no longer selected.
Public Event BarVertMove | Occurs when a time bar is moved vertically.
Public Event BeforeBarChanged | Occurs before a change to the time bar has been committed to the schedule.
Public Event BeforeBarDeleted | Occurs before a time bar is deleted from the schedule.
Public Event BeforeBarLinked | Occurs before two bar bars are linked using the mouse.
Public Event BeforeBarUnlinked | Occurs before two bar bars are unlinked using the mouse.
Public Event BeforePrint | Occurs before a print operation begins, just after the control has calculated the total pages horizontally and vertically it will be printing.
Public Event CheckClick | Occurs when the state of check box changes.
Public Event Click | Occurs when the user clicks the control with the mouse.
Public Event CtrlError | Occurs when an error takes place in the control
Public Event DblClick | Occurs when the user double clicks the control with the mouse.
Public Event DropItem | Occurs when an item is dropped into the list or schedule area.
Public Event FirstDraw | Occurs after ctxSchedule has been drawn for the first time.
Public Event GuideLineAdd | Occurs when a GuideLine is added through the Edit Mode = GuideLines.
Public Event GuideLineClick | Occurs when a GuideLine is clicked.
Public Event GuideLineMove | Occurs as the GuideLine is moving.
Public Event GuideLineMoved | Occurs once the GuideLine has finished moving (on mouseup).
Public Event GuideLineRemove | Occurs just before a GuideLine is deleted.
Public Event HistoryChange | Occurs when the UndoCount or RedoCount values change.
Public Event HistoryRedo | Occurs when the Redo method of the control is called
Public Event HistoryUndo | Occurs when the Undo method of the control is called
Public Event ItemSelect | Occurs when the selected status of list item and/or a time bar changes.
Public Event KeyDown | Occurs when the user presses a key while an object has the focus.
Public Event KeyPress | Occurs when the user presses and releases an ANSI key.
Public Event KeyUp | Occurs when the user releases a key while an object has the focus.
Public Event LineArrowDblClick | Occurs when the mouse double clicks a line arrow in the schedule.
Public Event LineArrowLeftClick | Occurs when the mouse left clicks a line arrow in the schedule.
Public Event LineArrowRightClick | Occurs when the mouse right clicks a line arrow in the schedule.
Public Event ListClick | Occurs when an item in the list is clicked on.
Public Event ListDblClick | Occurs when an item in the list is double clicked on.
Public Event ListSize | Occurs after the width of the list section is resized.
Public Event MouseDown | Occurs when the user pressed a mouse button.
Public Event MouseMove | Occurs when the mouse moves over the control.
Public Event MouseUp | Occurs when the users releases a mouse button.
Public Event NoteDblClick | Occurs when the mouse double clicks a note in the schedule.
Public Event NoteLeftClick | Occurs when the mouse left clicks a note in the schedule.
Public Event NoteRightClick | Occurs when the mouse right clicks a note in the schedule.
Public Event PreLoad | Occurs each time a list item is about to be drawn.
Public Event PrePrint | Occurs before a printed report is produced.
Public Event ScheduleClick | Occurs when the schedule area of the control is clicked on.
Public Event ScheduleOver | Occurs when the mouse moves over a new item or time bar in the schedule area.
Public Event ScrollTrack | Occurs when the vertical or horizontal scroll bar is being moved in the schedule area of the control.
Public Event SetTips | Occurs before a tool tip is displayed.
Public Event UserDrawnBar | This event fires before a timebar is drawn allowing the developer to create their own by setting the TimeBarImage Property.
Public Event UserDrawnBarDateText | Occurs just before the text is rendered at either edge of a timebar when the DatesInBars property is set to True.
Public Event UserDrawnDays | Occurs just before each day text is written above each date in the ruler, when TimeType = Days and RulerDays is True.
Public Event ValuePoint | Occurs before each time value is drawn in the ruler area.

See Also

ctxSchedule Overview

© DBI Technologies Inc. All Rights Reserved.

© 2019 All Rights Reserved.


Migrating from previous versions

ctxSchedule (3.0) 32/64 bit Scheduling Control

Migrating from ctSchedule to ctxSchedule

Migrating from version 8.0 or earlier of ctSchedule

Due to changes that affected the colors and fill types used by TimeBars and BarStyles, the priority of the property values was changed in version 9.0. To allow developers to match the older behavior of the control (TimeBar properties having the highest priority) the BarStylePriority has been added. Assigning a value of False to that property, will allow the relative properties on TimeBars to override the properties of BarStyles.

With this change, some older properties were deprecated and replaced with newer ones.

Deprecated Property | Replacement Property
StyleGradColorFrom | StyleBackColor
StyleGradColorTo | StyleBackColorTo
The Hatch Style patterns were moved to a new property. | StyleBrushType

For additional details on working with the property priority and which properties are affected, please see the "Overriding Properties" section in An Overview of a Time Bar or the "Overriding Properties" and "Property Value Priority" section in Creating Time Bar Styles.

Migrating from version 10.0 or earlier of ctSchedule

Due to the addition of the new Schedule Notes in version 11.0 of ctSchedule, the ToolTip functionality of the control was changed. The old TipsType property was deprecated and replaced with individual Boolean properties.

The enumerated values of the TipsType property were replaced with the following new Boolean properties:

  1. TipsOnOverBar

  2. TipsOnVScroll

Migrating from version 7.0 or later of ctSchedule

The ctxSchedule control contains the CreateImage method, allowing developers to generate an image of the control in various formats, which replaces the CreateJPG method of the older ctSchedule. Additionally the MaxJPGWidth and MaxJPGHeight properties have been replaced with the MaxImageWidth and MaxImageHeight properties.

Old Property/Method | New Property/Method
CreateJPG | CreateImage
MaxJPGHeight | MaxImageHeight
MaxJPGWidth | MaxImageWidth


%%PageItemTitle%%

AbortPrint Method
See Also Send comments on this topic.

Description

Cancels a printed report before being sent to the printer.

Syntax

Visual Basic
Public Sub AbortPrint()

Remarks

This method can be used in the PrePrint event or the BeforePrint event.

Example

[Visual Basic and Access]

Me.ctxSchedule.AbortPrint

[Visual FoxPro]

thisform.ctxSchedule.AbortPrint

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

AddBarStyle Method
nHeight
The default height of the time bar assigned to this style.
nVOffset
The value used to vertically offset the center of the time bars assigned to this style.

Description

Adds a new time bar style to the control.

Syntax

Visual Basic
Public Function AddBarStyle( _
   ByVal nHeight As Integer, _
   ByVal nVOffset As Integer _
) As Integer

Parameters

nHeight
The default height of the time bar assigned to this style.
nVOffset
The value used to vertically offset the center of the time bars assigned to this style.

Return Type

The 1-based index value of the item. A value of 0 indicates that the add was not successful.

Example

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddBarStyle(30, 0)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddBarStyle(30, 0)

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

AddColorBar Method
lTimeStart
The start time of the color bar.
lTimeEnd
The end time of the color bar.
lDateStart
The start date of the color bar.
lDateEnd
The end date of the color bar.
clrTimeColor
The color to assign to the color bar.
nIndex
The 1-based index value of the schedule item to assign to the color bar. If a value of 0 is sent to this parameter, the color bar will be displayed from the first schedule item until the last. If a value of -1 is assigned to this parameter the color bar will appear below the time area in the ruler.

Description

Adds a new color block to the schedule area.

Syntax

Visual Basic
Public Function AddColorBar( _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long, _
   ByVal clrTimeColor As ULong, _
   ByVal nIndex As Integer _
) As Integer

Parameters

lTimeStart
The start time of the color bar.
lTimeEnd
The end time of the color bar.
lDateStart
The start date of the color bar.
lDateEnd
The end date of the color bar.
clrTimeColor
The color to assign to the color bar.
nIndex
The 1-based index value of the schedule item to assign to the color bar. If a value of 0 is sent to this parameter, the color bar will be displayed from the first schedule item until the last. If a value of -1 is assigned to this parameter the color bar will appear below the time area in the ruler.

Return Type

The 1-based index value of the color bar.

Remarks

The start and end times of a bar color are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a color bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddColorBar(0, 180, 38722, 38722, RGB(125,125,125), 0)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddColorBar(0, 180, 38722, 38722, RGB(125,125,125), 0)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

AddColumn Method
strCaption
A string value indicating the column header.
nWidth
An Integer value indicating the column width.

Description

Adds a new column to the list area.

Syntax

Visual Basic
Public Function AddColumn( _
   ByVal strCaption As String, _
   ByVal nWidth As Integer _
) As Integer

Parameters

strCaption
A string value indicating the column header.
nWidth
An Integer value indicating the column width.

Return Type

The 1-based index value of the column.

Example

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddColumn("Column 1", 75)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddColumn("Column 1",75)

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

AddGuideLine Method
See Also Example Send comments on this topic.
lTime
The time (in minutes from midnight) the guideline will appear at.
lDate
The date (as a long value) the guideline will appear at.

Description

Add a guideline to the Schedule.

Syntax

Visual Basic
Public Function AddGuideLine( _
   ByVal lTime As Long, _
   ByVal lDate As Long _
) As Integer

Parameters

lTime
The time (in minutes from midnight) the guideline will appear at.
lDate
The date (as a long value) the guideline will appear at.

Return Type

Integer

Example

Visual Basic Copy Code
Dim x As Integer
x = Me.ctxSchedule1.AddGuideLine(540, CLng(Now))

See Also

ctxSchedule Object


%%PageItemTitle%%

AddImage Method
picImage
The image to add to the internal image list. Valid images include icons (.ico), bitmaps (.bmp) and .JPG files.

Description

Adds a new image to the internal image list.

Syntax

Visual Basic
Public Function AddImage( _
   ByVal picImage As Picture _
) As Integer

Parameters

picImage
The image to add to the internal image list. Valid images include icons (.ico), bitmaps (.bmp) and .JPG files.

Return Type

The 1-based index value of the image in the internal image list.

Remarks

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control.

Example

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddImage (LoadPicture("C:\Path to Image\Image.bmp"))

or

intIndex = Me.ctxSchedule.AddImage (Ole_Control.Picture)

[Visual Foxpro]

intIndex = thisform.ctxSchedule.AddImage(LoadPicture("C:\Path to Image\Image.bmp"))

or

intIndex = thisform.ctxSchedule.AddImage(Ole_Control.Picture)

See Also

ctxSchedule Object


%%PageItemTitle%%

AddItem Method
strText
The text of the list item.

Description

Adds a new item to the list area.

Syntax

Visual Basic
Public Function AddItem( _
   ByVal strText As String _
) As Integer

Parameters

strText
The text of the list item.

Return Type

The 1-based index value of the item. A value of 0 indicates that the add is unsuccessful.

Remarks

If the list area consists of more than one column, a semi-colon can be placed between the column values.

Example

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddItem("Item 1")

intIndex = Me.ctxSchedule.AddItem("Item 1;Column 2")

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddItem("Item 1")

intIndex = thisform.ctxSchedule.AddItem("Item 1;Column 2")

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

AddKeyTimeBar Method
nIndex
The 1-based index value of the schedule item to assign the time bar.
lTimeStart
The start time of the time bar.
lTimeEnd
The end time of the time bar.
lDateStart
The start date of the time bar.
lDateEnd
The end date of the time bar.
cKeyID
The key ID to assign to the time bar.

Description

Adds a new timebar with a key ID to the schedule.

Syntax

Visual Basic
Public Function AddKeyTimeBar( _
   ByVal nIndex As Integer, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long, _
   ByVal cKeyID As String _
) As Integer

Parameters

nIndex
The 1-based index value of the schedule item to assign the time bar.
lTimeStart
The start time of the time bar.
lTimeEnd
The end time of the time bar.
lDateStart
The start date of the time bar.
lDateEnd
The end date of the time bar.
cKeyID
The key ID to assign to the time bar.

Return Type

The 1-based index value of the time bar.

Remarks

NOTE: The start and end times of a bar color are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

NOTE: The start and end dates of a color bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will create a time bar with an ID value of REC01 in the first list item. The time bar will begin at 12:00 am and end at 3:00 am.

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddKeyTimeBar(1, 0, 180, 38722, 38722, "REC01")

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddKeyTimeBar(1, 0, 180, 38722, 38722, "REC01")

See Also

ctxSchedule Object


%%PageItemTitle%%

AddLink Method
nItemFrom
The 1-based index value of the schedule item of the initiating time bar.
nBarFrom
The 1-based index value of the initiating time bar.
nItemTo
The 1-based index value of the schedule item of the receiving time bar.
nBarTo
The 1-based index value of the receiving time bar.

Description

Creates a new link between 2 time bars.

Syntax

Visual Basic
Public Function AddLink( _
   ByVal nItemFrom As Integer, _
   ByVal nBarFrom As Integer, _
   ByVal nItemTo As Integer, _
   ByVal nBarTo As Integer _
) As Integer

Parameters

nItemFrom
The 1-based index value of the schedule item of the initiating time bar.
nBarFrom
The 1-based index value of the initiating time bar.
nItemTo
The 1-based index value of the schedule item of the receiving time bar.
nBarTo
The 1-based index value of the receiving time bar.

Return Type

The 1-based index value of the link item. A value of 0 is returned if the method is unsuccessful.

Example

The following will create a link between the first time bar in the first item, to the first time bar in the second item.

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddLink(1,1,2,1)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddLink(1,1,2,1)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

AddNote Method
nIndex
The 1-based index value of the schedule item to assign the note.
lTime
The time of the note. (minutes since midnight)
lDate
The date of the note. (number of days since the base date)

Description

Adds a new note to the schedule.

Syntax

Visual Basic
Public Function AddNote( _
   ByVal nIndex As Integer, _
   ByVal lTime As Long, _
   ByVal lDate As Long _
) As Integer

Parameters

nIndex
The 1-based index value of the schedule item to assign the note.
lTime
The time of the note. (minutes since midnight)
lDate
The date of the note. (number of days since the base date)

See Also

ctxSchedule Object


%%PageItemTitle%%

AddTimeBar Method
nIndex
The 1-based index value of the schedule item to assign the time bar.
lTimeStart
The start time of the time bar.
lTimeEnd
The end time of the time bar.
lDateStart
The start date of the time bar.
lDateEnd
The end date of the time bar.

Description

Adds a new time bar to the schedule.

Syntax

Visual Basic
Public Function AddTimeBar( _
   ByVal nIndex As Integer, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long _
) As Integer

Parameters

nIndex
The 1-based index value of the schedule item to assign the time bar.
lTimeStart
The start time of the time bar.
lTimeEnd
The end time of the time bar.
lDateStart
The start date of the time bar.
lDateEnd
The end date of the time bar.

Return Type

The 1-based index value of the time bar.

Remarks

An key ID value will automatically be generated for a time bar created with this method.

NOTE: The start and end times of a bar color are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

NOTE: The start and end dates of a color bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will create a time bar in the first item. The time bar will begin at 12:00 am and end at 3:00 am.

[Visual Basic and Access]

intIndex = Me.ctxSchedule.AddTimeBar(1, 0, 180, 38722, 38722)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddTimeBar(1, 0, 180, 38722, 38722)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarEnd Method
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
lTime
The new end time to assign to the time bar.
lDate
The new end time to assign to the time bar.

Description

Moves the end position of the time bar.

Syntax

Visual Basic
Public Sub BarEnd( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal lTime As Long, _
   ByVal lDate As Long _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
lTime
The new end time to assign to the time bar.
lDate
The new end time to assign to the time bar.

Return Type

This method does not return a value.

Remarks

This method will adjust the length of the time. The start date and time position will remain the same.

NOTE: The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

NOTE: The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will change the end time of the first time bar in the first item to 60 minutes past the start time.

[Visual Basic and Access]

Me.ctxSchedule.BarEnd(1, 1 ,Me.ctxSchedule.BarTimeStart(1,1) + 60, Me.ctxSchedule.BarDateEnd(1,1))

[Visual FoxPro]

thisformctxSchedule.BarEnd(1, 1 ,thisform.ctxSchedule.BarTimeStart(1,1) + 60, thisform.ctxSchedule.BarDateEnd(1,1))

See Also

ctxSchedule Object


%%PageItemTitle%%

BarIsMilestone Method
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Determines if the time bar is defined as a milestone.

Syntax

Visual Basic
Public Function BarIsMilestone( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A Boolean value.

Example

[Visual Basic and Access]

booMilestone = Me.ctxSchedule.BarIsMilestone(1,1)

[Visual FoxPro]

booMilestone = thisform.ctxSchedule.BarIsMilestone(1,1)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarMove Method
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.
lTimeStart
The new start time of the time bar.
lTimeEnd
The new end time of the time bar.
lDateStart
The new start date of the time bar.
lDateEnd
The new end date of the time bar.

Description

Moves the position of a time bar.

Syntax

Visual Basic
Public Sub BarMove( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long _
)

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.
lTimeStart
The new start time of the time bar.
lTimeEnd
The new end time of the time bar.
lDateStart
The new start date of the time bar.
lDateEnd
The new end date of the time bar.

Return Type

This method does not return a value.

Remarks

This method will move a time bar horizontally across the schedule.

Example

The following will move the first time bar in the first time. The new start time will be 9:00 am and will end at 10:00 am on the first date in the schedule.

[Visual Basic and Access]

Me.ctxSchedule.BarMove 1,1, 540, 600, Me.ctxSchedule.DateStart, Me.ctxSchedule.DateStart

[Visual FoxPro]

thisform.ctxSchedule.BarMove(1,1, 540, 600, thisform.ctxSchedule.DateStart, thisform.ctxSchedule.DateStart)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarMoveToLine Method
nOldIndex
The 1-based index of the item to move the time bar from.
nBar
The 1-based index of the time bar to move
nNewIndex
The 1-based index of the item to move the time bar to

Description

Moves a time bar from one item to another (vertically).

Syntax

Visual Basic
Public Function BarMoveToLine( _
   ByVal nOldIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nNewIndex As Integer _
) As Integer

Parameters

nOldIndex
The 1-based index of the item to move the time bar from.
nBar
The 1-based index of the time bar to move
nNewIndex
The 1-based index of the item to move the time bar to

Return Type

The new 1-based index value of the time bar, on the new item. A value of 0 indicates that the move was unsuccessful.

Remarks

When a time bar is moved to a new line, the index value for the subsequent time bars on the original item change.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarStart Method
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
lTime
The new start time to assign to the time bar.
lDate
The new start date to assign to the time bar.

Description

Moves the start position of an existing time bar.

Syntax

Visual Basic
Public Sub BarStart( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal lTime As Long, _
   ByVal lDate As Long _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
lTime
The new start time to assign to the time bar.
lDate
The new start date to assign to the time bar.

Return Type

This method does not return a value.

Remarks

This method will adjust the length of the time. The end date and time position will remain the same.

NOTE: The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

NOTE: The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will change the start time of the first time bar in the first item to 60 minutes before the end time.

[Visual Basic and Access]

Me.ctxSchedule.BarStart(1, 1 ,Me.ctxSchedule.BarTimeEnd(1,1) - 60, Me.ctxSchedule.BarDateEnd(1,1))

[Visual FoxPro]

thisformctxSchedule.BarEnd(1, 1 ,thisform.ctxSchedule.BarTimeEnd(1,1) - 60, thisform.ctxSchedule.BarDateEnd(1,1))

See Also

ctxSchedule Object


%%PageItemTitle%%

BringToFront Method
nIndex
The 1-based index value of the schedule item containing the specified time bar.
nBar
The 1-based index value of the time bar to move to the front.

Description

Moves a specified timebar in front of any conflicting time bars.

Syntax

Visual Basic
Public Function BringToFront( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the schedule item containing the specified time bar.
nBar
The 1-based index value of the time bar to move to the front.

Return Type

A Boolean value indicating if the move was successful.

Example

[Visual Basic and Access]

Dim booFront as Boolean

booFront = Me.ctxSchedule.BringToFront(1,1)

[Visual FoxPro]

booFront = thisform.ctxSchedule.BringToFront(1,1)

See Also

ctxSchedule Object


%%PageItemTitle%%

CancelChange Method

Description

Prevents a change to a time bar from occuring.

Syntax

Visual Basic
Public Sub CancelChange()

Return Type

This method does not return a value.

Remarks

This method is only effective when used in the BeforeBarChanged event.

Example

[Visual Basic and Access]

Me.ctxSchedule.CancelChange

[Visual FoxPro]

thisform.ctxSchedule.CancelChange()

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

CancelDelete Method

Description

Prevents a time bar from being deleted.

Syntax

Visual Basic
Public Sub CancelDelete()

Return Type

This method does not return a value.

Remarks

This method is only effective when used in the BeforeBarDeleted event.

Example

[Visual Basic and Access]

Me.ctxSchedule.CancelDelete

[Visual FoxPro]

thisform.ctxSchedule.CancelDelete()

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

CancelDrop Method

Description

Prevents a time bar from being added or moved in the schedule.

Syntax

Visual Basic
Public Sub CancelDrop()

Remarks

This method is only applicable in the BarPreDrop event.

Example

[Visual Basic and Access]

Me.ctxSchedule.CancelDrop

[Visual FoxPro]

thisform.ctxSchedule.CancelDrop()

See Also

ctxSchedule Object | Moving Time Bars Vertically | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

CancelLink Method

Description

Used to cancel a link between 2 time bars.

Syntax

Visual Basic
Public Sub CancelLink()

Remarks

Can only be used inside the BeforeBarLinked Event .

See Also

ctxSchedule Object


%%PageItemTitle%%

CancelSelect Method

Description

Prevents a time bar from being selected.

Syntax

Visual Basic
Public Sub CancelSelect()

Remarks

This method is only applicable when used in the BarPreSelect event.

Example

[Visual Basic and Access]

Me.ctxSchedule.CancelSelect

[Visual FoxPro]

thisform.ctxSchedule.CancelSelect()

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

CancelUnlink Method

Description

Used to cancel an unlink operation between 2 time bars.

Syntax

Visual Basic
Public Sub CancelUnlink()

Remarks

Can only be used in the BeforeBarUnlinked Event.

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearBarStyles Method

Description

Removes all the bar styles stored in the control.

Syntax

Visual Basic
Public Sub ClearBarStyles()

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearBarStyles

[Visual FoxPro]

thisform.ctxSchedule.ClearBarStyles

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearColorBars Method

Description

Removes all the color bars stored in the control.

Syntax

Visual Basic
Public Sub ClearColorBars()

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearColorBars

[Visual FoxPro]

thisform.ctxSchedule.ClearColorBars

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearColumns Method

Description

Clears all the columns stored in the control.

Syntax

Visual Basic
Public Function ClearColumns() As Boolean

Return Type

This method does not return a value.

Remarks

The text assigned to the column will persist after the column have been removed. To clear the item text, use the ClearSchedule method.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearColumns

[Visual FoxPro]

thisform.ctxSchedule.ClearColumns

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearGuideLines Method

Description

Clears all the GuideLines in the Schedule.

Syntax

Visual Basic
Public Sub ClearGuideLines()

Example

me.ctxSchedule1.ClearGuideLines

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearHistory Method

Description

Clears all history items stored in the control.

Syntax

Visual Basic
Public Sub ClearHistory()

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearHistory

[Visual FoxPro]

thisform.ctxSchedule.ClearHistory

See Also

ctxSchedule Object | Schedule Edit Modes | Undo/Redo Features


%%PageItemTitle%%

ClearLinks Method

Description

Clears all of the links stored in the control.

Syntax

Visual Basic
Public Sub ClearLinks()

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearLinks

[Visual FoxPro]

thisform.ctxSchedule.ClearLinks

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearNotes Method
nIndex
The 1-based index of the line item to clear the note(s) from.

Description

Clears all the notes from a line item.

Syntax

Visual Basic
Public Function ClearNotes( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the line item to clear the note(s) from.

Remarks

If a value of 0 or less is supplied for the nIndex parameter, the method will clear all the notes from the control.

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearSchedule Method

Description

Clears all of the items and time bars stored in the control.

Syntax

Visual Basic
Public Sub ClearSchedule()

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearSchedule

[Visual FoxPro]

thisform.ctxSchedule.ClearSchedule

See Also

ctxSchedule Object


%%PageItemTitle%%

ClearTimeBars Method
nIndex
The 1-based index value of the list item.

Description

Clears all the time bars in a list item.

Syntax

Visual Basic
Public Function ClearTimeBars( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ClearTimeBars(1)

[Visual FoxPro]

thisform.ctxSchedule.ClearTimeBars(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

ColorBarsAt Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the count of the colorbars at the specified coordinates

Syntax

Visual Basic
Public Function ColorBarsAt( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

ColumnCount Method

Description

Gets the total number of columns assigned to the control.

Syntax

Visual Basic
Public Function ColumnCount() As Integer

Return Type

An Integer value indicating the total number of columns.

Example

[Visual Basic and Access]

Dim intCount as Integer

intCount = Me.ctxSchedule.ColumnCount

[Visual FoxPro]

intCount = thisform.ctxSchedule.ColumnCount

See Also

ctxSchedule Object


%%PageItemTitle%%

CreateImage Method
strFileName
The name of the JPG image to create.
nWidth
The width of the image.
nHeight
The height of the image.
nType

The type of image to generate

BMP = 0
JPG = 1
GIF = 2
TIF = 3
PNG = 4

Description

Creates an image file based on the current content of the control.

Syntax

Visual Basic
Public Function CreateImage( _
   ByVal strFileName As String, _
   ByVal nWidth As Integer, _
   ByVal nHeight As Integer, _
   ByVal nType As Integer _
) As Boolean

Parameters

strFileName
The name of the JPG image to create.
nWidth
The width of the image.
nHeight
The height of the image.
nType

The type of image to generate

BMP = 0
JPG = 1
GIF = 2
TIF = 3
PNG = 4

Return Type

A Boolean value indicating if the method was successful.

Remarks

The file name should include the full path where the image should be saved to. The file extension on the name is optional, and if not included the control will append an extension based on the nType value.

The Width and Height parameters can accept a value of 0 or -1 to change the behavior of how the image is created. If a value of 0 is sent to either of these parameters, the width and/or height of the JPG will be the same as what is visible on screen. If a value of -1 is sent to either of these parameters, the width and/or height of the image will be the entire width and/or height of the control (i.e. all time values or all schedule items). When the height and/or width parameter is equal to -1, the MaxImageHeight and MaxImageWidth properties are used to set the maximum height and width of the image.

Example

[Visual Basic and Access]

Dim booImage as Boolean

booImage = Me.ctxSchedule.CreateJPG("MyControl",0,0,1)

booImage = Me.ctxSchedule.CreateJPG("C:\Image.jpg",-1,-1,1)

booImage = Me.ctxSchedule.CreateJPG("C:\ctxScheduleImage.jpg",200,500,1)

[Visual FoxPro]

booImage = thisform.ctxSchedule.CreateJPG("MyControl",0,0,1)

booImage = thisform.ctxSchedule.CreateJPG("C:\Image.jpg",-1,-1,1)

booImage = thisform.ctxSchedule.CreateJPG("C:\ctxScheduleImage.jpg",200,500,1)

See Also

ctxSchedule Object | Creating an Image of ctxSchedule


%%PageItemTitle%%

ctDragDrop Method
nxPosn
The x coordinate of the mouse during the drag drop.
nyPosn
The y coordinate of the mouse during the drag drop.

Description

Passes the DragDrop information from the DragDrop event into the control

Syntax

Visual Basic
Public Function ctDragDrop( _
   ByVal nxPosn As Integer, _
   ByVal nyPosn As Integer _
) As Integer

Parameters

nxPosn
The x coordinate of the mouse during the drag drop.
nyPosn
The y coordinate of the mouse during the drag drop.

Return Type

An Integer value indicating which list item received the drop.

Remarks

This functionality is only supported by those platform which support drag and drop within an ole container. Some platform, such as Access does not support this functionality.

Example

[Visual Basic and Access]

Please see the DragDrop method

[Visual FoxPro]

DragDrop Method
*** ActiveX Control Method ***

Lparameters Source, nxpoint, nypoint

*!* The method does not provide the correct parameters. The Source parameter must be added manually

*!* NOTE: The dragdrop event does not pass the necessary information through the OLE container to the control. Therefore, the control's ctDragDrop method is used to notify the control internally of the event.

*!* NOTE: Because Visual FoxPro does not host the OLE container as a child of the form in which the control is instantiated, but rather treats the control as a unique window, the X and Y coordinates of the mouse at the point of the drop operation must first be offset by the left and top values of the OLE container in the host window. The ctDragDrop method requires the X and Y coordinates of the position on which the drop operation took place, accordingly they must first be offset by the left and top values of the control.

nItem = thisform.ctxSchedule.ctDragDrop(nxpoint - thisform.ctxSchedule.Left , nypoint - thisform.ctxSchedule.top)

See Also

ctxSchedule Object | Implementing Drag and Drop


%%PageItemTitle%%

ctDragOver Method
nxPosn
The x coordinate of the mouse during the drag.
nyPosn
The y coordinate of the mouse during a drag.
nState
The current status or state of the drag.

Description

Passes the DragOver information to the DragOver event.

Syntax

Visual Basic
Public Function ctDragOver( _
   ByVal nxPosn As Integer, _
   ByVal nyPosn As Integer, _
   ByVal nState As Integer _
) As Integer

Parameters

nxPosn
The x coordinate of the mouse during the drag.
nyPosn
The y coordinate of the mouse during a drag.
nState
The current status or state of the drag.

Return Type

An Integer value indicating which list item is being dragged over.

Remarks

This functionality is only supported by those platform which support drag and drop within an ole container. Some platform, such as Access does not support this functionality.

This method can be used when DragOver is a reserved word.

Example

[Visual Basic and Access]

Please see the DragOver method.

[Visual FoxPro]

DragOver Method

*** ActiveX Control Method ***

Lparameters Source, nxpoint, nypoint, nstate

*!* The method does not provide the correct parameters. The Source parameter must be added manually

*!* The ctxSchedule control requires the x and y coordinates of the object being dragged in order to respond to the event. The ctDragOver method of the control is used to pass the dragover information into the control.

*!* NOTE: The x coordinate is adjusted by the left coordinate of the control and the y coordinate is adjusted by the top coordinate of the control to account for VFP not treating the OLE container as a child object in the form.

nListItem = thisform.ctxSchedule.ctDragOver(nxpoint - thisform.ctxSchedule.Left, nypoint - thisform.ctxSchedule.top, nstate)

See Also

ctxSchedule Object | Implementing Drag and Drop


%%PageItemTitle%%

DateAt Method
nxPoint
The horizontal coordinate within the schedule.

Description

Gets the date at a specific x coordinate.

Syntax

Visual Basic
Public Function DateAt( _
   ByVal nxPoint As Integer _
) As Long

Parameters

nxPoint
The horizontal coordinate within the schedule.

Return Type

An Integer value.

Remarks

While this method can be used in any event, it is most effective in the ScheduleClick event.

To determine the time at a specific x coordinate, use the TimeAt method.

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

[Visual Basic and Access]

Dim intDate as Integer

intDate = Me.ctxSchedule.DateAt(nxCoor)

[Visual FoxPro]

intDate = thisform.ctxSchedule.DateAt(nxCoor)

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

DeleteColorBar Method
nIndex
The 1-based index value of the color bar.

Description

Deletes a color bar from the control.

Syntax

Visual Basic
Public Function DeleteColorBar( _
   ByVal nIndex As Long _
) As Boolean

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

A Boolean indicating if the method was successful.

Remarks

When a color bar is removed, the index value for the subsequent items change.

Example

[Visual Basic and Access]

Dim booColor as Boolean

booColor = Me.ctxSchedule.DeleteColorBar(1)

[Visual FoxPro]

booColor = thisform.ctxSchedule.DeleteColorBar(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

DeleteGuideLine Method
nIndex
The integer value of the GuideLine Index to delete.

Description

Delete a specific GuideLine in the Schedule.

Syntax

Visual Basic
Public Function DeleteGuideLine( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The integer value of the GuideLine Index to delete.

Return Type

Boolean

Example

me.ctxSchedule1.DeleteGuideLine 3

See Also

ctxSchedule Object


%%PageItemTitle%%

DeleteItem Method
nIndex
The 1-based index value of the list item.

Description

Deletes a list item from the control

Syntax

Visual Basic
Public Function DeleteItem( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A Boolean value indicating if the method was successful.

Remarks

When an item is removed, the index value for the subsequent items change. All time bars associated with the removed item will also be deleted.

Example

[Visual Basic and Access]

Dim booItem as Boolean

booItem = Me.ctxSchedule.DeleteItem(1)

[Visual FoxPro]

booItem = thisform.ctxSchedule.DeleteItem(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

DeleteLink Method
nIndex
The 1-based index value of the link.

Description

Deletes a link from the control.

Syntax

Visual Basic
Public Function DeleteLink( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the link.

Return Type

A Boolean value indicating if the method was successful.

Remarks

When a link is removed, the index value for the subsequent items change.

Example

[Visual Basic and Access]

Dim booLink as Boolean

booLink = Me.ctxSchedule.DeleteLink(1)

[Visual FoxPro]

booLink = thisform.ctxSchedule.DeleteLink(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

DeleteNote Method
nIndex
The 1-based index value of the line item that contains the note.
nNote
The 1-based index value of the note to delete.

Description

Deletes a single note from a line item.

Syntax

Visual Basic
Public Function DeleteNote( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the line item that contains the note.
nNote
The 1-based index value of the note to delete.

See Also

ctxSchedule Object


%%PageItemTitle%%

DeleteTimeBar Method
nIndex
The 1-based index value of the list item containing the time bar.
nBar
The 1-based index value of the time bar.

Description

Deletes a time bar from the control.

Syntax

Visual Basic
Public Function DeleteTimeBar( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item containing the time bar.
nBar
The 1-based index value of the time bar.

Return Type

A Boolean value indicating if the method was successful.

Remarks

When a time bar is deleted, the index value for the subsequent time bars on the same item change.

Example

[Visual Basic and Access]

Dim booTimeBar as Boolean

booTimeBar = Me.ctxSchedule.DeleteTimeBar(1,1)

[Visual FoxPro]

booTimeBar = thisform.ctxSchedule.DeleteTimeBar(1,1)

See Also

ctxSchedule Object


%%PageItemTitle%%

DragDrop Method
nxPosn
The x coordinate of the mouse during the drag drop.
nyPosn
The y coordinate of the mouse during the drag drop.

Description

Passes the DragDrop information from the DragDrop event into the control

Syntax

Visual Basic
Public Function DragDrop( _
   ByVal nxPosn As Integer, _
   ByVal nyPosn As Integer _
) As Integer

Parameters

nxPosn
The x coordinate of the mouse during the drag drop.
nyPosn
The y coordinate of the mouse during the drag drop.

Return Type

An Integer value indicating which list item received the drop.

Remarks

This functionality is only supported by those platform which support drag and drop within an ole container. Some platform, such as Access does not support this functionality.

In some development platforms DragDrop is a reserved word. In such cases, use the ctDragDrop Method.

Example

ctxSchedule uses pixels as it's scale mode. Some platforms may require a conversion to a different unit.

[Visual Basic and Access]

Private Sub ctxSchedule1_DragDrop(Source As Control, x As Single, y As Single)
Dim intListItem As Integer
intListItem = Me.ctxSchedule1.DragDrop(x / Screen.TwipsPerPixelX, y / Screen.TwipsPerPixelY)
End Sub

[Visual FoxPro]

Please see ctDragDrop Method.

See Also

ctxSchedule Object | Implementing Drag and Drop


%%PageItemTitle%%

DragOver Method
nxPosn
The x coordinate of the mouse during the drag.
nyPosn
The y coordinate of the mouse during a drag.
nState
The current status or state of the drag.

Description

Passes the DragOver information to the DragOver event.

Syntax

Visual Basic
Public Function DragOver( _
   ByVal nxPosn As Integer, _
   ByVal nyPosn As Integer, _
   ByVal nState As Integer _
) As Integer

Parameters

nxPosn
The x coordinate of the mouse during the drag.
nyPosn
The y coordinate of the mouse during a drag.
nState
The current status or state of the drag.

Return Type

An Integer value indicating which list item is being dragged over.

Remarks

This functionality is only supported by those platform which support drag and drop within an ole container. Some platform, such as Access does not support this functionality.

In some development platforms DragOver is a reserved word. In such cases, use the ctDragOver method.

Example

ctxSchedule uses pixel as it's scale mode. Some platforms may require a conversion to a different unit.

[Visual Basic and Access]

Private Sub ctxSchedule1_DragOver(Source As Control, x As Single, y As Single, State As Integer)
Dim intListItem As Integer
intListItem = Me.ctxSchedule1.DragOver(x / Screen.TwipsPerPixelX, y / Screen.TwipsPerPixelY, State)
End Sub

[Visual FoxPro]

Please see ctDragOver.

See Also

ctxSchedule Object | Implementing Drag and Drop


%%PageItemTitle%%

FindBarCargo Method
strValue
The string value to find. The search is case sensitive and requires an exact match.
nIndex
The 1-based index value of the item containing the time bars to search.

Description

Gets the index of the first time bar on a specific item with the desired cargo value

Syntax

Visual Basic
Public Function FindBarCargo( _
   ByVal strValue As String, _
   ByVal nIndex As Integer _
) As Integer

Parameters

strValue
The string value to find. The search is case sensitive and requires an exact match.
nIndex
The 1-based index value of the item containing the time bars to search.

Return Type

An integer value representing the index of the time bar containing the desired cargo value. A value of 0 indicates no time bars on that item contain the desired cargo value.

Remarks

This method must be called before calling the FindBarCargoNext method.

Example

The following will search the first list item for the first time bar that has the specified cargo value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarCargo("Cargo1", 1)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarCargo("Cargo1", 1)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarCargoItem Method
strValue
The string value to find. The search is case sensitive and requires an exact match.

Description

Gets the index of the first list item in the control that contains a time bar with the desired cargo value.

Syntax

Visual Basic
Public Function FindBarCargoItem( _
   ByVal strValue As String _
) As Integer

Parameters

strValue
The string value to find. The search is case sensitive and requires an exact match.

Return Type

An integer value representing the index of the list item containing a time bar with the desired cargo value. A value of 0 indicates there are no items with a time bar that contains the desired cargo value.

Remarks

This method must be called before calling the FindBarCargoItemNext method.

Example

The following will search the control for the first item that contains a time bar with the specified cargo value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarCargoItem("Cargo1")

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarCargoItem("Cargo1")

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarCargoItemNext Method
strValue
The string value to find. The search is case sensitive and requires an exact match.

Description

Gets the index of the next list item in the control that contains a time bar with the desired cargo value.

Syntax

Visual Basic
Public Function FindBarCargoItemNext( _
   ByVal strValue As String _
) As Integer

Parameters

strValue
The string value to find. The search is case sensitive and requires an exact match.

Return Type

An integer value representing the index of the list item containing a time bar with the desired cargo value. A value of 0 indicates there are no items with a time bar that contains the desired cargo value.

Remarks

This method must be called after calling the FindBarCargoItemNext method.

Example

The following will search the control for the next item that contains a time bar with the specified cargo value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarCargoItemNext("Cargo1")

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarCargoItemNext("Cargo1")

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarCargoNext Method
strValue
The string value to find. The search is case sensitive and requires an exact match.
nIndex
The 1-based index value of the item containing the time bars to search.

Description

Gets the index of the next time bar on a specific item with the desired cargo value

Syntax

Visual Basic
Public Function FindBarCargoNext( _
   ByVal strValue As String, _
   ByVal nIndex As Integer _
) As Integer

Parameters

strValue
The string value to find. The search is case sensitive and requires an exact match.
nIndex
The 1-based index value of the item containing the time bars to search.

Return Type

An integer value representing the index of the time bar containing the desired cargo value. A value of 0 indicates no time bars on that item contain the desired cargo value.

Remarks

This method must be called after calling the FindBarCargo method.

Example

The following will search the first list item for the next time bar that has the specified cargo value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarCargoNext("Cargo1", 1)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarCargoNext("Cargo1", 1)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarData Method
nValue
The data value to find.
nIndex
The 1-based index value of the item containing the time bars to search.

Description

Gets the index of the first time bar on a specific item with the desired data value

Syntax

Visual Basic
Public Function FindBarData( _
   ByVal nValue As Long, _
   ByVal nIndex As Integer _
) As Integer

Parameters

nValue
The data value to find.
nIndex
The 1-based index value of the item containing the time bars to search.

Return Type

An integer value representing the index of the time bar containing the desired cargo value. A value of 0 indicates no time bars on that item contain the desired data value.

Remarks

This method must be called before calling the FindBarDataNext method.

Example

The following will search the first list item for the first time bar that has the specified data value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarData(22, 1)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarData(22, 1)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarDataItem Method
nValue
The data value to find.

Description

Gets the index of the first list item in the control that contains a time bar with the desired data value.

Syntax

Visual Basic
Public Function FindBarDataItem( _
   ByVal nValue As Long _
) As Integer

Parameters

nValue
The data value to find.

Return Type

An integer value representing the index of the list item containing a time bar with the desired data value. A value of 0 indicates there are no items with a time bar that contains the desired data value.

Remarks

This method must be called before calling the FindBarDataItemNext method.

Example

The following will search the control for the first item that contains a time bar with the specified data value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarDataItem(22)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarDataItem(22)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarDataItemNext Method
nValue
The data value to find.

Description

Gets the index of the next list item in the control that contains a time bar with the desired data value.

Syntax

Visual Basic
Public Function FindBarDataItemNext( _
   ByVal nValue As Long _
) As Integer

Parameters

nValue
The data value to find.

Return Type

An integer value representing the index of the list item containing a time bar with the desired data value. A value of 0 indicates there are no items with a time bar that contains the desired data value.

Remarks

This method must be called after calling the FindBarDataItem method.

Example

The following will search the control for the next item that contains a time bar with the specified data value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarDataItemNext(22)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarDataItemNext(22)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindBarDataNext Method
nValue
The data value to find.
nIndex
The 1-based index value of the item containing the time bars to search.

Description

Gets the index of the next time bar on a specific item with the desired data value

Syntax

Visual Basic
Public Function FindBarDataNext( _
   ByVal nValue As Long, _
   ByVal nIndex As Integer _
) As Integer

Parameters

nValue
The data value to find.
nIndex
The 1-based index value of the item containing the time bars to search.

Return Type

An integer value representing the index of the time bar containing the desired cargo value. A value of 0 indicates no time bars on that item contain the desired data value.

Remarks

This method must be called after calling the FindBarData method.

Example

The following will search the first list item for the first time bar that has the specified data value.

[Visual Basic and Access]

Dim intTimeBar as Integer

intTimeBar = Me.ctxSchedule1.FindBarDataNext(22, 1)

[Visual FoxPro]

intTimeBar = thisform.ctxSchedule.FindBarDataNext(22, 1)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindConflictBar Method
nIndex
The 1-based index value of the schedule item containing nBar to not be considered a conflict.
nBar
The 1-based index value of the time bar to not be considered a conflict.
nItem
The schedule item to search for conflicts.
nTimeStart
The start time of the searched area.
nTimeEnd
The end time of the searched area.
nDateStart
The start date of the searched area.
nDateEnd
The end date of the searched area.

Description

Gets the first conflicting time bar within a given area.

Syntax

Visual Basic
Public Function FindConflictBar( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nItem As Integer, _
   ByVal nTimeStart As Long, _
   ByVal nTimeEnd As Long, _
   ByVal nDateStart As Long, _
   ByVal nDateEnd As Long _
) As Integer

Parameters

nIndex
The 1-based index value of the schedule item containing nBar to not be considered a conflict.
nBar
The 1-based index value of the time bar to not be considered a conflict.
nItem
The schedule item to search for conflicts.
nTimeStart
The start time of the searched area.
nTimeEnd
The end time of the searched area.
nDateStart
The start date of the searched area.
nDateEnd
The end date of the searched area.

Return Type

The 1-based index value of the conflicting time bar.

Remarks

The nIndex and nBar parameters specify which time bar is not to be considered in conflict. For example when testing for a conflict as a result of changes to a time bar in the BeforeBarChanged event the nIndex and nBar values would describe the time bar being changed. Therefore the FindConflictBar method will not consider the changed bar as a conflict to itself.

The nIndex, nTimeStart, nTimeEnd, nDateStart and nDateEnd parameters indicate the area in the schedule to search for conflicts.

Example

The following will search for any time bar on the second list item in the first day of the schedule.

[Visual Basic and Access]

Dim intTimeBarConflict as Integer

Dim intStartDate as Integer

intStartDate = Me.ctxSchedule.DateStart

intTimeBarConflict = Me.ctxSchedule.FindConflictBar(1, 1, 2, 0, 1440, intDateStart, intDateStart)

[Visual FoxPro]

intDateStart = thisform.ctxSchedule.DateStart

intTimeBarConflict = thisform.ctxSchedule.FindConflictBar(1, 1, 2, 0, 1440, intDateStart, intDateStart)

See Also

ctxSchedule Object


%%PageItemTitle%%

FindFirstBar Method
nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar to evaluate.
nItem
The 1-based index value of the list item to evaluate.

Description

Gets the first time bar which conflicts with a given time bar in a single list item.

Syntax

Visual Basic
Public Function FindFirstBar( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nItem As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar to evaluate.
nItem
The 1-based index value of the list item to evaluate.

Return Type

An Integer value indicating the index value of the conflicting time bar. A value of 0 is returned when there are no conflicts.

Remarks

This method must be used before the FindNextBar method. The ConflictOffset property defines when a conflict will occur.

Example

The following will search the second list item for the first conflict with the third time bar of the first list item.

[Visual Basic and Access]

Dim intTimeBarConflict as Integer

intTimeBarConflict = Me.ctxSchedule.FindFirstBar(1,3,2)

[Visual FoxPro]

intTimeBarConflict = thisform.ctxSchedule.FindFirstBar(1,3,2)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindFirstColorBar Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the first colorbar at the specified coordinates.

Syntax

Visual Basic
Public Function FindFirstColorBar( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

FindFirstItem Method
nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar.

Description

Gets the first list item which contains a time bar that conflicts with a given time bar.

Syntax

Visual Basic
Public Function FindFirstItem( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value. If a value of 0 indicates no conflicts occur.

Remarks

This method must be used before the FindNextItem method. The ConflictOffset property defines when a conflict will occur.

Example

The following will search the for the first conflict with the third time bar in the first item.

[Visual Basic and Access]

Dim intTimeBarConflict as Integer

intTimeBarConflict = Me.ctxSchedule.FindFirstItem(1,3)

[Visual FoxPro]

intTimeBarConflict = thisform.ctxSchedule.FindFirstItem(1,3)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindFirstTimeBar Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the first timebar at the specified coordinates.

Syntax

Visual Basic
Public Function FindFirstTimeBar( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

FindItemCargo Method
strValue
The string value to search for. The search is case sensitive and requires an exact match.

Description

Gets the index of the first item in the control that contains the specified string value in their ItemCargo property.

Syntax

Visual Basic
Public Function FindItemCargo( _
   ByVal strValue As String _
) As Integer

Parameters

strValue
The string value to search for. The search is case sensitive and requires an exact match.

Return Type

The 1-based index of the item containing the value. A return of 0 means no matches were found.

Remarks

This method must be used before the FindItemCargoNext method.

Example

The following will search the control for the first item with the specified cargo.

[Visual Basic and Access]

Dim intItem as Integer

intItem = Me.ctxSchedule.FindItemCargo("Cargo1")

[Visual FoxPro]

intItem = thisform.ctxSchedule.FindItemCargo("Cargo1)

See Also

ctxSchedule Object | Selecting and Searching for List Items


%%PageItemTitle%%

FindItemCargoNext Method
strValue
The string value to search for. The search is case sensitive and requires an exact match.

Description

Gets the index of the next item in the control that contains the specified string value in their ItemCargo property.

Syntax

Visual Basic
Public Function FindItemCargoNext( _
   ByVal strValue As String _
) As Integer

Parameters

strValue
The string value to search for. The search is case sensitive and requires an exact match.

Return Type

The 1-based index of the item containing the value. A return of 0 means no matches were found.

Remarks

This method must be used after the FindItemCargo method.

Example

The following will search the control for the next item with the specified cargo.

[Visual Basic and Access]

Dim intItem as Integer

intItem = Me.ctxSchedule.FindItemCargoNext("Cargo1")

[Visual FoxPro]

intItem = thisform.ctxSchedule.FindItemCargoNext("Cargo1)

See Also

ctxSchedule Object | Selecting and Searching for List Items


%%PageItemTitle%%

FindItemData Method
nValue
The long value to search for.

Description

Gets the index of the first item in the control that contains the specified long value in their ItemData property.

Syntax

Visual Basic
Public Function FindItemData( _
   ByVal nValue As Long _
) As Integer

Parameters

nValue
The long value to search for.

Return Type

The 1-based index of the item containing the value. A return of 0 means no matches were found.

Remarks

This method must be used before the FindItemDataNext method.

Example

The following will search the control for the first item with the specified data.

[Visual Basic and Access]

Dim intItem as Integer

intItem = Me.ctxSchedule.FindItemData(12)

[Visual FoxPro]

intItem = thisform.ctxSchedule.FindItemData(12)

See Also

ctxSchedule Object | Selecting and Searching for List Items


%%PageItemTitle%%

FindItemDataNext Method
nValue
The long value to search for.

Description

Gets the index of the next item in the control that contains the specified long value in their ItemData property.

Syntax

Visual Basic
Public Function FindItemDataNext( _
   ByVal nValue As Long _
) As Integer

Parameters

nValue
The long value to search for.

Return Type

The 1-based index of the item containing the value. A return of 0 means no matches were found.

Remarks

This method must be used after the FindItemData method.

Example

The following will search the control for the next item with the specified data.

[Visual Basic and Access]

Dim intItem as Integer

intItem = Me.ctxSchedule.FindItemDataNext(12)

[Visual FoxPro]

intItem = thisform.ctxSchedule.FindItemDataNext(12)

See Also

ctxSchedule Object | Selecting and Searching for List Items


%%PageItemTitle%%

FindNextBar Method
nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar to evaluate.
nItem
The 1-based index value of the list item to evaluate.

Description

Gets the next time bar which conflicts with a given time bar on a single list item.

Syntax

Visual Basic
Public Function FindNextBar( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nItem As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar to evaluate.
nItem
The 1-based index value of the list item to evaluate.

Return Type

An Integer value indicating the index value of the conflicting time bar. A value of 0 is returned when there are no conflicts.

Remarks

This method must be used after the FindFirstBar method. The ConflictOffset property defines when a conflict will occur.

Example

The following will search the second list item for the next conflict with the third time bar of the first list item.

[Visual Basic and Access]

Dim intTimeBarConflict as Integer

intTimeBarConflict = Me.ctxSchedule.FindFirstBar(1,3,2)

[Visual FoxPro]

intTimeBarConflict = thisform.ctxSchedule.FindFirstBar(1,3,2)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindNextColorBar Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the next colorbar at the specified coordinates.

Syntax

Visual Basic
Public Function FindNextColorBar( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

FindNextItem Method
nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar.

Description

Gets the next list item which contains a time bar that conflicts with a given time bar.

Syntax

Visual Basic
Public Function FindNextItem( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item containing the time bar to evaluate.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value. If a value of 0 indicates no conflicts occur.

Remarks

This method must be used after the FindFirstItem method. The ConflictOffset property defines when a conflict will occur.

Example

The following will search the for the next conflict with the third time bar in the first item.

[Visual Basic and Access]

Dim intTimeBarConflict as Integer

intTimeBarConflict = Me.ctxSchedule.FindNextItem(1,3)

[Visual FoxPro]

intTimeBarConflict = thisform.ctxSchedule.FindNextItem(1,3)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

FindNextTimeBar Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the next timebar at the specified coordinates.

Syntax

Visual Basic
Public Function FindNextTimeBar( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

FirstLine Method
nLine
The 1-based index value of the first list item.

Description

Sets the first visible list item in the schedule.

Syntax

Visual Basic
Public Function FirstLine( _
   ByVal nLine As Integer _
) As Boolean

Parameters

nLine
The 1-based index value of the first list item.

Return Type

A Boolean value indicating if the method was successful.

Example

The following will set the first line to be the third list item

[Visual Basic and Access]

Dim booFirstLine as Boolean

booFirstLine = Me.ctxSchedule.FirstLine(3)

[Visual FoxPro]

booFirstLine = thisform.ctxSchedule.FirstLine(3)

See Also

ctxSchedule Object


%%PageItemTitle%%

InDeadZone Method
nIndex
The 1-based index value of the schedule item to evaluate.
nTimeStart
The start time of the evaluated area.
nTimeEnd
The end time of the evaluated area.
nDateStart
The start date of the evaluated area.
nDateEnd
The end date of the evaluated area.

Description

Determines if a specific area in the schedule is a dead zone.

Syntax

Visual Basic
Public Function InDeadZone( _
   ByVal nIndex As Integer, _
   ByVal nTimeStart As Long, _
   ByVal nTimeEnd As Long, _
   ByVal nDateStart As Long, _
   ByVal nDateEnd As Long _
) As Boolean

Parameters

nIndex
The 1-based index value of the schedule item to evaluate.
nTimeStart
The start time of the evaluated area.
nTimeEnd
The end time of the evaluated area.
nDateStart
The start date of the evaluated area.
nDateEnd
The end date of the evaluated area.

Return Type

A Boolean value; true if the area is defined as a dead zone.

Example

The following will determine if a dead zone is defined on the first item of ctxSchedule between 12:00 pm and 1:00 pm on the first day.

[Visual Basic and Access]

Dim booDeadZone as Boolean

Dim intDate as Integer

intDate = Me.ctxSchedule.DateStart

booDeadZone = Me.ctxSchedule.InDeadZone(1, 720, 780, intDate, intDate)

[Visual FoxPro]

intDate = Me.ctxSchedule.DateStart

booDeadZone = Me.ctxSchedule.InDeadZone(1, 720, 780, intDate, intDate)

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars | About Dead Zones


%%PageItemTitle%%

InsertColumn Method
strCaption
A String value indicating the column header.
nWidth
An Integer value indicating the column width.
nIndex
An Integer value indicating the position of the new column.

Description

Inserts a new column into the list area.

Syntax

Visual Basic
Public Function InsertColumn( _
   ByVal strCaption As String, _
   ByVal nWidth As Integer, _
   ByVal nIndex As Integer _
) As Integer

Parameters

strCaption
A String value indicating the column header.
nWidth
An Integer value indicating the column width.
nIndex
An Integer value indicating the position of the new column.

Return Type

The 1-based index value of the new column.

Remarks

If the nIndex parameters is greater than number of defined columns, the new column will be placed at the end of the column list.

Example

The following will place a new column in the second position in the list.

[Visual Basic and Access]

intIndex = Me.ctxSchedule.InsertColumn("Insert", 75, 2)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.InsertColumn("Insert",75, 2)

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

InsertItem Method
strText
A String value indicating the item text.
nIndex
An Integer value indicating the position of the new list item.

Description

Inserts a new list item into the list area.

Syntax

Visual Basic
Public Function InsertItem( _
   ByVal strText As String, _
   ByVal nIndex As Integer _
) As Integer

Parameters

strText
A String value indicating the item text.
nIndex
An Integer value indicating the position of the new list item.

Return Type

The 1-based index value of the new list item.

Remarks

If the list area consists of more than one column, a semi-colon can be placed between the column values.

Example

The following will place a new item in the second row of the list.

[Visual Basic and Access]

intIndex = Me.ctxSchedule.InsertItem("New Item", 2)

[Visual Foxpro]

intIndex = thisform.ctxSchedule.InsertItem("New Item", 2)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

KeyIDBar Method
strText
The key ID to evaluate.
nIndex
The 1-based index value of the list item to evaluate.

Description

Gets the time bar assigned with a specific key ID value.

Syntax

Visual Basic
Public Function KeyIDBar( _
   ByVal strText As String, _
   ByVal nIndex As Integer _
) As Integer

Parameters

strText
The key ID to evaluate.
nIndex
The 1-based index value of the list item to evaluate.

Return Type

The 1-based index value of the time bar with the matching key ID. A value of 0 indicates that there are no matching time bars.

Remarks

The time bar key id value can be defined with the BarKeyID property, or by using the AddKeyTimeBar method when adding a new time bar. If more than 1 time bar has the given key id value, only the index value of the first time bar found is returned. The KeyIDItem method is used to find the index value of the list item containing a given time bar key id.

Example

The following will find the time bar in the first list item with a BarKeyID value of KEY1234.

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.KeyIDBar("KEY1234", 1)

[Visual Foxpro]

intIndex = thisform.ctxSchedule.KeyIDBar("KEY1234", 1)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

KeyIDItem Method
strText
The key ID to evaluate.

Description

Gets the list item that contains a time bar with a specific KeyID value.

Syntax

Visual Basic
Public Function KeyIDItem( _
   ByVal strText As String _
) As Integer

Parameters

strText
The key ID to evaluate.

Return Type

The 1-based index value of the list item containing a time bar with the matching key ID. A value of 0 indicates that there are no matching time bars.

Remarks

The time bar key id value can be defined with the BarKeyID property, or by using the AddKeyTimeBar method when adding a new time bar. If more than 1 time bar has the given key id value, only the index value of the first time bar found is returned. The KeyIDBar method is used to find the index value of the time bar containing a given time bar key id.

Example

The following will find the list item that contains a time bar with a BarKeyID value of KEY1234.

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.KeyIDItem("KEY1234")

[Visual Foxpro]

intIndex = thisform.ctxSchedule.KeyIDItem("KEY1234")

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

LineAt Method
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the list item at the specified coordinate.

Syntax

Visual Basic
Public Function LineAt( _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nyCoor
The y-Coordinate to test in pixels.

Return Type

1-based Integer value indicating the index of the Item at the supplied y coordinate in the control

Remarks

This method can be called from anywhere, but the y coordinate must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the "HitTest" demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

MakeBarVisible Method
nIndex
The 1-based index of the line item containing the time bar.
nBar
The 1-based index of the time bar to view.

Description

This method will attempt to scroll a specific time bar in to the visible area of the control.

Syntax

Visual Basic
Public Function MakeBarVisible( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the line item containing the time bar.
nBar
The 1-based index of the time bar to view.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteAt Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the index of the Note at the specified coordinate.

Syntax

Visual Basic
Public Function NoteAt( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Remarks

If there are multiple notes at the specified coordinates, only the index for the top most note will be returned.

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object


%%PageItemTitle%%

PrintSchedule Method

Description

Sends the contents of the current ctxSchedule to a printer.

Syntax

Visual Basic
Public Function PrintSchedule() As Boolean

Return Type

A Boolean value indicating if the method was successful.

Remarks

Note : The control is able to handle Legal, Letter, A3, A4, Executive, and Tabloid paper sizes. If an additional paper size is required, the programmer can use the PrePrint event to change the page dimensions using the PageXOffset and PageYOffset properties. If a paper type is not recognized, the internal dimensions for the page will default to Letter size paper ( 8.5" x 11" or 800 units x 1000 units). The PageXOffset and PageYOffset properties can be used to increase and/or decrease those units.

Example

[Visual Basic and Access]

Dim booPrint as Boolean

booPrint = Me.ctxSchedule.PrintSchedule

[Visual Foxpro]

booPrint = thisform.ctxSchedule.PrintSchedule

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintScheduleImage Method

Description

Sends the contents of the current ctxSchedule to a printer.

Syntax

Visual Basic
Public Function PrintScheduleImage() As Boolean

Return Type

A Boolean value indicating if the method was successful.

Remarks

This method combines the image creation routines of the CreateImage method, with the control's printing functionality.

Unlike the PrintSchedule method which can only attempt to fully duplicate the appearance of the control on the individual pages of the output, this method create snap shots of all the current content of the control and then places those images one per page in the printed document.

Note : The control is able to handle Legal, Letter, A3, A4, Executive, and Tabloid paper sizes. If an additional paper size is required, the programmer can use the PrePrint event to change the page dimensions using the PageXOffset and PageYOffset properties. If a paper type is not recognized, the internal dimensions for the page will default to Letter size paper ( 8.5" x 11" or 800 units x 1000 units). The PageXOffset and PageYOffset properties can be used to increase and/or decrease those units.

Example

[Visual Basic and Access]

Dim booPrint as Boolean

booPrint = Me.ctxSchedule.PrintScheduleImage

[Visual Foxpro]

booPrint = thisform.ctxSchedule.PrintScheduleImage

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

ReadFile Method
strFileName
The full name of the xml file to read.
nFileInfo

Determines how the file is read:

0 - the entire file is read

1 - the schedule items, their time bars, column information, style info, and color bar information will be read. The general property information will be ignored.

Description

Reads an xml document to populate the control.

Syntax

Visual Basic
Public Function ReadFile( _
   ByVal strFileName As String, _
   ByVal nFileInfo As Integer _
) As Boolean

Parameters

strFileName
The full name of the xml file to read.
nFileInfo

Determines how the file is read:

0 - the entire file is read

1 - the schedule items, their time bars, column information, style info, and color bar information will be read. The general property information will be ignored.

Return Type

A Boolean value indicating if the method was successful.

Remarks

The file can be read from a local drive, mapped drive or web site. The xml file must be valid and created in the ctxSchedule format. If it is invalid an error is generated.

Example

[Visual Basic and Access]

Dim booRead as Boolean

booRead = Me.ctxSchedule.ReadFile("C:\ctxSchedule.xml",0)

or

booRead = Me.ctxSchedule.ReadFile("http://www.dbi-tech.com/mysched.xml", 1)

[Visual Foxpro]

booRead = thisform.ctxSchedule.ReadFile("C:\ctxSchedule.xml",0)

or

booRead = thisform.ctxSchedule.ReadFile("http://www.dbi-tech.com/mysched.xml", 1)

See Also

ctxSchedule Object | Reading and Writing XML Data


%%PageItemTitle%%

ReadXMLString Method
nFileInfo

An Integer value indicating the type of data to read into the variable.

0 - Reads all the data the settings

1 - Reads schedule items and supporting data only. General settings are not read into the variable.

Description

Reads the schedule data into a memory variable

Syntax

Visual Basic
Public Function ReadXMLString( _
   ByVal nFileInfo As Integer _
) As String

Parameters

nFileInfo

An Integer value indicating the type of data to read into the variable.

0 - Reads all the data the settings

1 - Reads schedule items and supporting data only. General settings are not read into the variable.

Return Type

A String value.

Remarks

This method is similar to the WriteFile method, but writes the data to a memory variable instead of a file.

ReadXMLString is useful for string handling or passing streams of text via various text-based protocols (such as xmlHTTP)

Example

The following will set a variable to schedule data as as XML string.

[Visual Basic and Access]

Dim strData as String

strData = Me.ctxSchedule.ReadXMLString(0)

[Visual Foxpro]

strData = thisform.ctxSchedule.ReadXMLString(0)

[HTML]

strData = Me.ctxSchedule.ReadXMLString(0)

See Also

ctxSchedule Object | Reading and Writing XML Data


%%PageItemTitle%%

Redo Method

Description

Performs an redo action on the control.

Syntax

Visual Basic
Public Function Redo() As Boolean

Return Type

A Boolean value indicating if the operation was successful.

Remarks

The type of redo action is determined by the UndoType property. When a redo action is performed, the action is added to the undo list and the HistoryChange event fires.

Example

[Visual Basic and Access]

Dim intRedo as Integer

intRedo = Me.ctxSchedule.Redo

[Visual FoxPro]

intRedo = thisform.ctxSchedule.Redo

See Also

ctxSchedule Object | Undo/Redo Features


%%PageItemTitle%%

RedoCount Method

Description

Gets the number of items in the redo list.

Syntax

Visual Basic
Public Function RedoCount() As Integer

Return Type

An Integer value

Remarks

The maximum number of items which can be stored in the redo list is defined by the HistorySize property. The redo list is stored internally within the control and is readonly. Whenever the Undo method is invoked, the un-done action is added to the redo list.

Example

[Visual Basic and Access]

Dim intRedo as Integer

intRedo = Me.ctxSchedule.RedoCount

[Visual FoxPro]

intRedo = thisform.ctxSchedule.RedoCount

See Also

ctxSchedule Object | Undo/Redo Features


%%PageItemTitle%%

ReDraw Method
bScroll
A boolean indicating if the control will vertically scroll to display the selected item.

Description

Forces the control to be re-painted.

Syntax

Visual Basic
Public Sub ReDraw( _
   ByVal bScroll As Boolean _
)

Parameters

bScroll
A boolean indicating if the control will vertically scroll to display the selected item.

Return Type

This method does not return a value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ReDraw True

[Visual FoxPro]

thisform.ctxSchedule.ReDraw .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

RemoveColumn Method
nIndex
The 1-based index value of the column to removed.

Description

Removes a column from the list area.

Syntax

Visual Basic
Public Function RemoveColumn( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the column to removed.

Return Type

A Boolean value indicating if the removal was successful.

Remarks

The data assigned to the removed columns will persist after the column is removed. This information can be accessed through the ItemText property.

Example

The following will remove the first column in the list area.

[Visual Basic and Access]

Dim booRemove as Boolean

booRemove = Me.ctxSchedule.RemoveColumn(1)

[Visual FoxPro]

booRemove = thisform.ctxSchedule.RemoveColumn(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

RemoveImage Method
nIndex
The 1-based index value of the image to remove.

Description

Removes an image from the internal image list.

Syntax

Visual Basic
Public Function RemoveImage( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the image to remove.

Return Type

A Boolean value indicating if the remove was successful.

Remarks

When an image is removed, the index value for the subsequent items change.

Example

The following will remove the first image in the internal image list.

[Visual Basic and Access]

Dim booRemove as Boolean

booRemove = Me.ctxSchedule.RemoveImage(1)

[Visual FoxPro]

booRemove = thisform.ctxSchedule.RemoveImage(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

ScheduleItemAt Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns a value indicating the area of the schedule at the specified coordinates.

Syntax

Visual Basic
Public Function ScheduleItemAt( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

0 | Nothing (coordinates are outside the area of the ctxSchedule)
1 | The splitter bar
2 | The list area
3 | The schedule area
4 | The ruler area
5 | The map area

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

ScrollToColumn Method
nColumn
The 1-based index of the column to scroll to.

Description

Will attempt to scroll the list portion of the control to the specified column.

Syntax

Visual Basic
Public Function ScrollToColumn( _
   ByVal nColumn As Integer _
) As Boolean

Parameters

nColumn
The 1-based index of the column to scroll to.

Return Type

A Boolean value indicating if the method was successful or not

Remarks

Depending on how wide the columns and list area are, the exact location of the specified column in the display area may vary.

Example

The following will scroll the the list area to the third column in the control.

[Visual Basic and Access]

Dim booScrollColumn as Boolean

booScrollColumn = Me.ctxSchedule.ScrollToColumn(3)

[Visual Foxpro]

booScrollColumn = thisform.ctxSchedule.ScrollToColumn(3)

See Also

ctxSchedule Object


%%PageItemTitle%%

SendToBack Method
nIndex
The 1-based index value of the schedule item containing the specified time bar.
nBar
The 1-based index value of the time bar to move to the back.

Description

Moves a specified timebar behind of any conflicting time bars.

Syntax

Visual Basic
Public Function SendToBack( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the schedule item containing the specified time bar.
nBar
The 1-based index value of the time bar to move to the back.

Return Type

A Boolean value indicating if the move was successful.

Example

The following will move the first time bar of the first list item behind any overlapping time bars.

[Visual Basic and Access]

Dim booBack as Boolean

booBack = Me.ctxSchedule.SendToBack(1,1)

[Visual FoxPro]

booBack = thisform.ctxSchedule.SendToBack(1,1)

See Also

ctxSchedule Object


%%PageItemTitle%%

SetView Method
nTimeStart
The starting time to display.
nTimeEnd
The ending time to display
nDateStart
The starting date to display
nDateEnd
The ending date to display.
nMinSize
The amount of space to place between the major time units.

Description

Sets the view in the control so that a given area is fully visible.

Syntax

Visual Basic
Public Function SetView( _
   ByVal nTimeStart As Long, _
   ByVal nTimeEnd As Long, _
   ByVal nDateStart As Long, _
   ByVal nDateEnd As Long, _
   ByVal nMinSize As Integer _
) As Integer

Parameters

nTimeStart
The starting time to display.
nTimeEnd
The ending time to display
nDateStart
The starting date to display
nDateEnd
The ending date to display.
nMinSize
The amount of space to place between the major time units.

Return Type

An Integer value indicating the success of the method:

0 - Successful

1 - The nMinSize value is too small to only display the given area.

2 - The requested start date/time is before the starting date/time in the schedule.

3 - The requested end date/time is after the ending date/time in the schedule

Remarks

When the return value is equal to 1, the distance between the major time units is automatically adjusted to only display the given area.

This method is similar to the TimeScroll method, but in addition to adjusting the horizontal scroll value so that a given date/time is at the left most side of the schedule, it also adjusts the TimeDistance property so that it maximizes the space to fit the requested date/time into view.

The start and end times of a bar color are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a color bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will request that schedule display 9 am to 5 pm on the second day.

[Visual Basic and Access]

Dim intView as Integer

Dim intStart as Integer

intStart = Me.ctxSchedule.DateStart + 1

intView = Me.ctxSchedule.SetView(540, 1020, intStart, intStart, 45)

[Visual FoxPro]

intStart = thisform.ctxSchedule.DateStart + 1

intView = thisform.ctxSchedule.SetView(540, 1020, intStart, intStart, 45 )

See Also

ctxSchedule Object | Setting up Schedule Views


%%PageItemTitle%%

StopTimer Method

Description

Stops the internal timer within the control.

Syntax

Visual Basic
Public Sub StopTimer()

Return Type

This method does not return a value.

Remarks

This method is required when calling modal forms from within the control.

Example

[Visual Basic and Access]

Me.ctxSchedule.StopTimer

Msgbox("ctxSchedule")

[Visual FoxPro]

thisform.ctxSchedule.StopTimer()

MESSAGEBOX("ctxSchedule")

See Also

ctxSchedule Object


%%PageItemTitle%%

TimeAt Method
nxPoint
The horizontal coordinate within the schedule.

Description

Gets the time at a specific x coordinate.

Syntax

Visual Basic
Public Function TimeAt( _
   ByVal nxPoint As Integer _
) As Long

Parameters

nxPoint
The horizontal coordinate within the schedule.

Remarks

While this method can be used in any event, it is most effective in the ScheduleClick event.

The value of start and end times are the number of minutes since midnight.

To locate the date at a specific x coordinate, use the DateAt method.

Example

[Visual Basic and Access]

Dim intTime as Integer

intTime = Me.ctxSchedule.TimeAt(nxCoor)

[Visual FoxPro]

intTime = thisform.ctxSchedule.TimeAt(nxCoor)

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

TimeBarsAt Method
nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Description

Returns the count of the timebars at the specified coordinates

Syntax

Visual Basic
Public Function TimeBarsAt( _
   ByVal nxCoor As Integer, _
   ByVal nyCoor As Integer _
) As Integer

Parameters

nxCoor
The x-Coordinate to test in pixels.
nyCoor
The y-Coordinate to test in pixels.

Return Type

Integer

Remarks

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.

See Also

ctxSchedule Object

Developing With

Using the HitTest Methods


%%PageItemTitle%%

TimeScroll Method
lDate
The date to start the view.
lTime
The time to start the view.

Description

Moves the horizontal scroll bar to given date and time.

Syntax

Visual Basic
Public Sub TimeScroll( _
   ByVal lDate As Long, _
   ByVal lTime As Long _
)

Parameters

lDate
The date to start the view.
lTime
The time to start the view.

Return Type

This method does not return a value.

Example

The following will adjust the horizontal scroll bar so that 10 am on January 1, 2006 starts the view.

[Visual Basic and Access]

Me.ctxSchedule.TimeScroll 38718, 600

[Visual FoxPro]

thisform.ctxSchedule.TimeScroll(38718, 600)

See Also

ctxSchedule Object | Setting up Schedule Views


%%PageItemTitle%%

Today Method

Description

Returns the current date.

Syntax

Visual Basic
Public Function Today() As Long

Return Type

An Integer value representing today.

Example

[Visual Basic and Access]

Dim intDate as Integer

intDate = Me.ctxSchedule.Today

[Visual FoxPro]

intDate = thisform.ctxSchedule.Today

See Also

ctxSchedule Object


%%PageItemTitle%%

Undo Method

Description

Performs an undo action on the control.

Syntax

Visual Basic
Public Function Undo() As Boolean

Return Type

A Boolean value indicating if the operation was successful.

Remarks

The type of undo action is determined by the UndoType property. When an undo action is performed, the action is added to the redo list and the HistoryChange event fires.

Example

[Visual Basic and Access]

Dim intUndo as Integer

intUndo = Me.ctxSchedule.Undo

[Visual FoxPro]

intUndo = thisform.ctxSchedule.Undo

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars | Undo/Redo Features


%%PageItemTitle%%

UndoCount Method

Description

Gets the number of items in the undo list.

Syntax

Visual Basic
Public Function UndoCount() As Integer

Return Type

An Integer value.

Remarks

The maximum number of items which can be stored in the undo list is defined by the HistorySize property. The undo list is stored internally within the control and is readonly. Whenever an action is performed on a time bar it is added to the undo list.

Example

[Visual Basic and Access]

Dim intUndo as Integer

intUndo = Me.ctxSchedule.UndoCount

[Visual FoxPro]

intUndo = thisform.ctxSchedule.UndoCount

See Also

ctxSchedule Object | Undo/Redo Features


%%PageItemTitle%%

WriteFile Method
strFileName
The full path name of the xml file. The file name provided to this parameter will be the exact name used to create the file. The control will not automatically create the .xml extension.
nFileInfo
Determines how the file is written; 0, then almost all data in the control is written. The only items that are not written are the property values for tool tips, printed reports, and images. If it is sent a value of 1, then only schedule items, their time bars, column information, style info, and color bar information will be written. The general property information will be ignored.

Description

Writes the data in ctxSchedule to an xml file.

Syntax

Visual Basic
Public Function WriteFile( _
   ByVal strFileName As String, _
   ByVal nFileInfo As Integer _
) As Boolean

Parameters

strFileName
The full path name of the xml file. The file name provided to this parameter will be the exact name used to create the file. The control will not automatically create the .xml extension.
nFileInfo
Determines how the file is written; 0, then almost all data in the control is written. The only items that are not written are the property values for tool tips, printed reports, and images. If it is sent a value of 1, then only schedule items, their time bars, column information, style info, and color bar information will be written. The general property information will be ignored.

Return Type

A Boolean value indicating if the operation was successful.

Remarks

This method can only write a file to a local or mapped drive. It cannot write data to a web site. If that operation is required, it is advised to create the file on a local drive, and use some other control or operation to send it to the appropriate destination.

Example

[Visual Basic and Access]

Dim booWrite as Boolean

booWrite = Me.ctxSchedule.WriteFile("C:\ctxSchedule.xml", 0)

[Visual FoxPro]

booWrite = thisform.ctxSchedule.Write("C:\ctxSchedule.xml", 0)

See Also

ctxSchedule Object | Reading and Writing XML Data


%%PageItemTitle%%

AdjustOnMove Property

Description

Determines if a partially exposed time line will be scrolled up when a time bar is moved within it.

Property type

Read-write property

Syntax

Visual Basic
Public Property AdjustOnMove() As Boolean

Return Type

A Boolean value

Remarks

When set to the true, the time line will be fully exposed when a time bar is moved within it. A time line would only be partially exposed if it were at the bottom of the control.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AdjustOnMove = True

[Visual FoxPro]

thisform.ctxSchedule.AdjustOnMove = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

AlignmentLines Property

Description

Determines if alignment lines will be displayed, inside the schedule area, when moving/sizing/creating time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property AlignmentLines() As Boolean

Return Type

A boolean value

Remarks

The AlignmentLines can be colored and used independently from the MarkerBars in the ruler area.

See Also

ctxSchedule Object


%%PageItemTitle%%

AlignmentLinesColor Property

Description

Determines the color used to paint AlignmentLines in the schedule area of the control

Property type

Read-write property

Syntax

Visual Basic
Public Property AlignmentLinesColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

See Also

ctxSchedule Object


%%PageItemTitle%%

AllowHorzMoves Property

Description

Determines if users can move time bars horizontally in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowHorzMoves() As Boolean

Return Type

A boolean value

See Also

ctxSchedule Object


%%PageItemTitle%%

AllowNewBars Property

Description

Determines if users can create time bars in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowNewBars() As Boolean

Return Type

A boolean value

See Also

ctxSchedule Object


%%PageItemTitle%%

AllowResizeBars Property

Description

Determines if users can resize time bars in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowResizeBars() As Boolean

Return Type

A boolean value

See Also

ctxSchedule Object


%%PageItemTitle%%

AllowVertMoves Property

Description

Determines if users can move time bars vertically between items in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowVertMoves() As Boolean

Return Type

A boolean value

Remarks

This property replaces the older "VertReposition" property.

See Also

ctxSchedule Object


%%PageItemTitle%%

AltListColorEven Property

Description

Returns/sets the background color of the even numbered list items.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltListColorEven() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when AltListColors is equal to True. The background color of the odd numbered list items is defined by the AltListColorOdd property.

This property is only applied to the list area in the control.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltListColorEven = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.AltListColorEven = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

AltListColorOdd Property

Description

Returns/sets the background color of the odd numbered list items.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltListColorOdd() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when AltListColors is equal to True. The background color of the even numbered list items is defined by the AltListColorEven property.

This property is only applied to the list area in the control.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltListColorOdd = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.AltListColorOdd = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

AltListColors Property

Description

Determines if the list items will drawn with alternate colors.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltListColors() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the alternating list items will be painted with the AltListColorEven and AltListColorOdd properties.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltListColors = True

[Visual FoxPro]

thisform.ctxSchedule.AltListColors = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

AltListItems Property

Description

Determines how ofter to alternate the list item between the even and odd background colors.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltListItems() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when the AltListColors property is equal to True.

Example

The following will paint 2 list items with the AltListColorEven property before painting 2 list items with the AltListColorOdd property.

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltListItems = 2

[Visual FoxPro]

thisform.ctxSchedule.AltListItems = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

AltSchedColorEven Property

Description

Returns/sets the background color of the even numbered list items in the schedule area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltSchedColorEven() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when AltSchedColors is equal to True. The background color of the odd numbered list items is defined by the AltSchedColorOdd property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltSchedColorEven = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.AltSchedColorEven = RGB(50,50,50)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

AltSchedColorOdd Property

Description

Returns/sets the background color of the odd numbered list items in the schedule area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltSchedColorOdd() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when AltSchedColors is equal to True. The background color of the odd numbered list items is defined by the AltSchedColorEven property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltListSchedOdd = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.AltListSchedOdd = RGB(50,50,50)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

AltSchedColors Property

Description

Determines if background color of list items in the schedule area will drawn with alternate colors.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltSchedColors() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the background color of the alternating list item in the schedule area will be painted with the AltSchedColorEven and AltSchedColorOdd properties.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltSchedColors = True

[Visual FoxPro]

thisform.ctxSchedule.AltSchedColors = .T.

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

AltSchedItems Property

Description

Determines how ofter to alternate the list item in the schedule area between the even and odd background colors.

Property type

Read-write property

Syntax

Visual Basic
Public Property AltSchedItems() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when the AltSchedColors property is equal to True.

Example

The following will paint 2 list items with the AltSchedColorEven property before painting 2 list items with the AltSchedColorOdd property.

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.AltSchedItems = 2

[Visual FoxPro]

thisform.ctxSchedule.AltSchedItems = 2

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

BackColor Property

Description

Returns/sets the background color of the schedule area in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BackColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BackColor = RGB(50,50,50)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

BackImage Property

Description

Returns/sets the background image of the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property BackImage() As Picture

Return Type

A Picture Object.

Remarks

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

or

Me.ctxSchedule.BackImage = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxSchedule.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

or

thisform.ctxSchedule.BackImage = Ole_Control.Picture

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

Bar Property

Description

Returns/sets the selected time bar in the control

Property type

Read-write property

Syntax

Visual Basic
Public Property Bar() As Integer

Return Type

An Integer value.

Remarks

To select a time bar programmatically, the Selected property cannot be equal to 0.

Example

This property is only available at runtime.

[Visual Basic and Access]

Me.ctxSchedule.Bar = 1

[Visual Foxpro]

thisform.ctxSchedule.Bar = 1

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

BarBackColor Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the background color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarBackColor( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarBackColor(1,1) = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarBackColor(1,1) = RGB(50,50,50)

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarBackColorTo Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the secondary background color (fill color) of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarBackColorTo( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

This property is only applicable when the FillType used is not equal to Solid (0).

See Also

ctxSchedule Object


%%PageItemTitle%%

BarBorderColor Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the border color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarBorderColor( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarBorderColor(1,1) = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarBorderColor(1,1) = RGB(50,50,50)

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarBorderWidth Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the width of the border of a timebar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarBorderWidth( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarBorderWidth(1,1) = 2

[Visual FoxPro]

thisform.ctxSchedule.BarBorderWidth(1,1) = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

BarCargo Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets a non-visible text value to the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarCargo( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A String value.

Remarks

The BarData property is used to assign a non-visible integer value to the time bar. The purpose of the text string is to be determined by the developer.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarCargo(1,1) = "REC234"

[Visual FoxPro]

thisform.ctxSchedule.BarCargo(1,1) = "REC234"

See Also

ctxSchedule Object


%%PageItemTitle%%

BarCount Property
nIndex
The 1-based index value of the list item.

Description

Returns the number of time bar assigned to a specific list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarCount( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.

Return Type

An Integer value.

Example

The following will obtain the number of time bars assigned to the first list item.

[Visual Basic and Access]

Dim intCount as Integer

intCount = Me.ctxSchedule.BarCount(1)

[Visual FoxPro]

intCount = thisform.ctxSchedule.BarCount(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarData Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets a non-visible integer value of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarData( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

The BarCargo property is used to assign a non-visible string value to the time bar. The purpose of the integer value is to be determined by the developer.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarData(1,1) = 987

[Visual FoxPro]

thisform.ctxSchedule.BarData(1,1) = 987

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDateEnd Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the end date of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDateEnd( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the end date of the first time bar of the first item to January 1, 2006.

[Visual Basic and Access]

Me.ctxSchedule.BarDateEnd(1,1) = 38718

or

Me.ctxSchedule.BarDateEnd(1,1) = CLng(#1/1/2006#)

[Visual FoxPro]

thisform.ctxSchedule.BarDateEnd(1,1) = 38718

or

thisform.ctxSchedule.BarDateEnd(1,1) = CTOD("1/1/2006") - CTOD("1/1/1900")

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDateForeColor Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Determines the color used to paint the date text in an individual time bar

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDateForeColor( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will override the BarDateTextColor for an individual time bar.

Dates are displayed in the time bars when the DatesInBars is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDateStart Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the start date of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDateStart( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the start date of the first time bar of the first item to January 1, 2006.

[Visual Basic and Access]

Me.ctxSchedule.BarDateStart(1,1) = 38718

or

Me.ctxSchedule.BarDateStart(1,1) = CLng(#1/1/2006#)

[Visual FoxPro]

thisform.ctxSchedule.BarDateStart(1,1) = 38718

or

thisform.ctxSchedule.BarDateStart(1,1) = CTOD("1/1/2006") - CTOD("1/1/1900")

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDateText Property

Description

The text to assign to be displayed in the UserDrawnBarDateText event.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDateText() As String

Return Type

A String value

Remarks

This property will only have an effect if assigned a value within the UserDrawnBarDateText event.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDateTextColor Property

Description

Returns/sets the text color of the dates in the time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDateTextColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Dates are displayed in the time bars when the DatesInBars is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarDateTextColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarDateTextColor = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDefBackColor Property

Description

Returns/sets the default background color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarDefBackColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarDefBackColor = RGB(50,50,50)

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

BarDefBackColorTo Property

Description

Returns/sets the default secondary background color (fill color) of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefBackColorTo() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when the FillType used is not equal to Solid (0).

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDefBorderColor Property

Description

Returns/sets the default border color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefBorderColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDefFillType Property

Description

Returns/sets the default timebar fill type.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefFillType() As enumFillType

Return Type

enumFillType

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDefFont Property

Description

Returns/sets the default font for the text in the time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarDefFont = Ole_object.Font

or

Me.ctxSchedule.BarDefFont.Name = "Verdana"

Me.ctxSchedule.BarDefFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.BarDefFont = Ole_Object.Font

or

thisform.ctxSchedule.BarDefFont.Name = "Verdana"

thisform.ctxSchedule.BarDefFont.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars | An Overview of a Time Bar


%%PageItemTitle%%

BarDefForeColor Property

Description

Returns/sets the default foreground color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarDefForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarDefForeColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarDefForeColor = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarEndImage Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the end image of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarEndImage( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

A negative integer will use a stock image which is built into the control, a positive integer will use an image assigned to the internal image list. Images can be added to the internal image list through the AddImage method.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarEndImage(1,1) = -3

[Visual FoxPro]

thisform.ctxSchedule.BarEndImage(1,1) = -3

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarFillType Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the fill pattern of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarFillType( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value (enumerated) - enumFillType Enumeration

Remarks

This property now uses gradient fills instead of the hatch brushes, those can now be set in the StyleBrushType Property.

If a value of -1 is supplied to this property, it will be ignored.

If the following FillTypes are used on TimeBars, then the Border of the TimeBar will not be drawn:
FillDiagonal
FillRevDiagonal
FillDiamond
FillCircle
FillEllipse

Example

[Visual Basic and Access]

Me.ctxSchedule.BarFillType(1,1) = 3

[Visual FoxPro]

thisform.ctxSchedule.BarFillType(1,1) = 3

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarFont Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the font of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarFont( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value

Example

[Visual Basic and Access]

Me.ctxSchedule.BarFont(1,1) = -2

[Visual FoxPro]

thisform.ctxSchedule.BarFont(1,1) = -2

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars | An Overview of a Time Bar


%%PageItemTitle%%

BarForeColor Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the foreground color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarForeColor( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarForeColor(1,1) = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarForeColor(1,1) = RGB(50,50,50)

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarKeyID Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the unique KeyId of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarKeyID( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A String value.

Remarks

A default BarKeyID value is automatically generated through the BarAdded event if a time bar is created with the mouse, or if a time bar is added programmatically using the AddTimeBar method. The default values can be overridden using this property. The AddKeyTimeBar method allows the developer to define a KeyID value when a time bar is created programmatically.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarKeyID(1,1) = "REC123"

[Visual FoxPro]

thisform.ctxSchedule.BarKeyID(1,1) = "REC123"

See Also

ctxSchedule Object


%%PageItemTitle%%

BarMinSize Property

Description

Returns/sets the minimum size of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarMinSize() As Integer

Return Type

An Integer value.

Remarks

This property is applied to all the time bars and is measured in pixels. For example, if this property is equal to 60, the TimeType is equal to Hours and the TimeDistance is equal to 60 than the minimum time bar size will span 1 hour.

This property is for display purposes only. It can be used to prevent appointments from showing up as lines in the schedule when the scale is very large. However, those appointments will still respond to mouse actions based on their actual size, and not the drawn size

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarMinSize = 60

[Visual FoxPro]

thisform.ctxSchedule.BarMinSize = 60

See Also

ctxSchedule Object


%%PageItemTitle%%

BarReadOnly Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Determines if a time bar is read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarReadOnly( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A Boolean value.

Remarks

Time bars marked as read-only cannot be moved or changed via user interaction. They can only be modified programmatically.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarReadOnly(1,1) = False

[Visual FoxPro]

thisform.ctxSchedule.BarReadOnly(1,1) = .F.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarSelectBackColor Property

Description

Returns/sets the background color of the selected time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarSelectBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarSelectBackColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarSelectBackColor = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSelectBorderColor Property

Description

Returns/sets the border color of the selected time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarSelectBorderColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarSelectBorderColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarSelectBorderColor = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSelectFocus Property

Description

Determines if a focus border will appear around the selected time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarSelectFocus() As Boolean

Return Type

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarSelectFocus = True

[Visual FoxPro]

thisform.ctxSchedule.BarSelectFocus = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSelectForeColor Property

Description

Returns/sets the forecolor color of the selected time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarSelectForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarSelectForeColor = RGB(50,50,50)

[Visual FoxPro]

thisform.ctxSchedule.BarSelectForeColor = RGB(50,50,50)

See Also

ctxSchedule Object


%%PageItemTitle%%

BarStartImage Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the start image of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarStartImage( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

A negative integer will use a stock image which is built into the control, a positive integer will use an image assigned to the internal image list. Images can be added to the internal image list through the AddImage method.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarStartImage(1,1) = -3

[Visual FoxPro]

thisform.ctxSchedule.BarStartImage(1,1) = -3

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarStyle Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets a pre-defined bar style to a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarStyle( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

Bar styles are created with the AddBarStyle method.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarStyle(1,1) = 2

[Visual FoxPro]

thisform.ctxSchedule.BarStyle(1,1) = 2

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

BarStylePriority Property

Description

Determines if the properties on a BarStyle or individual TimeBar get the highest priority when displaying a TimeBar in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarStylePriority() As Boolean

Remarks

A Value of True indicates that the BarStyle properties (prefixed "Style") get highest priority and override any relative "Bar" or "BarDef" prefixed properties.

A value of False indicates that TimeBar properties (prefixed "Bar") get highest priority and override any relative "Style" or "BarDef" prefixed properties.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSubText Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the sub-text of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarSubText( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A String value.

Remarks

This text will appear below the primary text defined in the BarText property.

Example

[Visual Basic and Access]

Me.ctxSchedule.BarSubText(1,1) = "Sub Text"

[Visual FoxPro]

thisform.ctxSchedule.BarSubText(1,1) = "Sub-Text"

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarText Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the primary text of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarText( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

A String value

Example

[Visual Basic and Access]

Me.ctxSchedule.BarText(1,1) = "Bar Text"

[Visual FoxPro]

thisform.ctxSchedule.BarText(1,1) = "Bar Text"

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarTextAlign Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the horizontal alignment of the time bar text.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTextAlign( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarTextAlign = 2

[Visual FoxPro]

thisform.ctxSchedule.BarTextAlign = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

BarTextWrap Property

Description

Determines if the text within a time bar will wrap (shown as multiple lines of text).

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTextWrap() As Boolean

Return Type

A Boolean value.

Remarks

This property is not applied when BarTextAlign is equal to 3 (right of bar). When set to True, the vertical alignment of the time bar text is automatically aligned to the top of the time, else it is vertically centered.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarTextWrap = True

[Visual FoxPro]

thisform.ctxSchedule.BarTextWrap = .T.

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

BarTimeEnd Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the end time of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTimeEnd( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

The value of start and end times are the number of minutes since midnight.

Example

The following will set the end time of the first time bar in the first list item to 12:00 pm.

[Visual Basic and Access]

Me.ctxSchedule.BarTimeEnd(1, 1) = 720

[Visual FoxPro]

thisform.ctxSchedule.BarTimeEnd(1, 1) = 720

See Also

ctxSchedule Object


%%PageItemTitle%%

BarTimeStart Property
nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Description

Returns/sets the start time of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTimeStart( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.
nBar
The 1-based index value of the time bar.

Return Type

An Integer value.

Remarks

The value of start and end times are the number of minutes since midnight.

Example

The following will set the start time of the first time bar in the first list item to 12:00 pm.

[Visual Basic and Access]

Me.ctxSchedule.BarTimeStart(1, 1) = 720

[Visual FoxPro]

thisform.ctxSchedule.BarTimeStart(1, 1) = 720

See Also

ctxSchedule Object


%%PageItemTitle%%

BarTipExtension Property

Description

Returns/sets the distance outside the time bar that the user to click to resize the bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTipExtension() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarTipExtension = 15

[Visual FoxPro]

thisform.ctxSchedule.BarTipExtension = 15

See Also

ctxSchedule Object


%%PageItemTitle%%

BarTipSize Property

Description

Returns/sets the distance inside the time bar that the user to click to resize the bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarTipSize() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BarTipSize = 15

[Visual FoxPro]

thisform.ctxSchedule.BarTipSize = 15

See Also

ctxSchedule Object


%%PageItemTitle%%

BarVisible Property
nIndex
The 1-based index of the item containing the timebar.
nBar
The 1-based index of the timebar.

Description

Returns/sets the visibility of a timebar when it is within the display area of the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property BarVisible( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the item containing the timebar.
nBar
The 1-based index of the timebar.

Return Type

A Boolean value.

Remarks

When this property is set to false, any link lines or overlap/conflict lines associated with the timebar will also not be drawn. Setting this property back to True will cause those same link lines and overlap/conflicts to display as well.

See Also

ctxSchedule Object


%%PageItemTitle%%

BorderColor Property

Description

Returns/sets the border color below the title line and around the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BorderColor() As ULong

Return Type

A ULong value repesenting an OLE_COLOR.

Remarks

This property will only be applied to the border around the control when BorderType is equal to Regular (0).

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BorderColor = RGB(150,150,150)

[Visual FoxPro]

thisform.ctxSchedule.BorderColor = RGB(150,150,150)

See Also

ctxSchedule Object


%%PageItemTitle%%

BorderType Property

Description

Returns/sets the type of border to place around the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property BorderType() As enumBorder

Return Type

An Integer value representing an enumBorder member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.BorderType = 1

[Visual FoxPro]

thisform.ctxSchedule.BorderType = 1

See Also

ctxSchedule Object


%%PageItemTitle%%

BreakChar Property

Description

Returns/sets the character used for seperating text between columns in the list.

Property type

Read-write property

Syntax

Visual Basic
Public Property BreakChar() As String

Remarks

The BreakChar property is case sensitive.

If no value is assigned to this property, the control will use a default value of ";" for internal calculations.

Example

ctxSchedule1.BreakChar = ";"

See Also

ctxSchedule Object


%%PageItemTitle%%

CBarCount Property

Description

Returns a count of the total number of color bars assigned to the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarCount() As Integer

Return Type

An Integer value.

Example

[Visual Basic and Access]

Dim intColorCount as Integer

intColorCount = Me.ctxSchedule.CBarCount()

[Visual FoxPro]

intColorCount = thisform.ctxSchedule.CBarCount()

See Also

ctxSchedule Object


%%PageItemTitle%%

CBarDateEnd Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the end date of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarDateEnd( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the color bar end date to January 1, 2006.

[Visual Basic and Access]

Me.ctxSchedule.CBarDateEnd = 38718

[Visual FoxPro]

thisform.ctxSchedule.CBarDateEnd = 38718

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarDateStart Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the start date of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarDateStart( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the color bar start date to January 1, 2006.

[Visual Basic and Access]

Me.ctxSchedule.CBarDateStart = 38718

[Visual FoxPro]

thisform.ctxSchedule.CBarDateStart = 38718

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarDeadZone Property
nIndex
The 1-based index value of the color bar.

Description

Determines if the color bar area will be considered a dead zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarDeadZone( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

A Boolean value.

Remarks

The dead zone will automatically prevent time bar from being added or dropped.

Example

[Visual Basic and Access]

Me.ctxSchedule.CBarDeadZone = False

[Visual FoxPro]

thisform.ctxSchedule.CBarDeadZone = .F.

See Also

ctxSchedule Object | Coloring the Background of the Schedule | About Dead Zones


%%PageItemTitle%%

CBarFillType Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the fill pattern of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value representing an enumFillType member.

Remarks

The primary and secondary colors are defined by the CBarTimeColor and CBarTimeColorTo properties.

Example

The following will set the fill type to horizontal.

[Visual Basic and Access]

Me.ctxSchedule.CBarFillType(1) = 1

[Visual FoxPro]

thisform.ctxSchedule.CBarFillType(1) = 1

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarIndex Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the list item assigned to the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarIndex( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value.

Example

The following will assign the first color bar to the first item in the list area

[Visual Basic and Access]

Me.ctxSchedule.CBarIndex(1) = 1

[Visual FoxPro]

thisform.ctxSchedule.CBarIndex(1) = 1

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarLineWidth Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the width of the color bar when the start and end times are the same.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarLineWidth( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value representing an enumLineType value.

Example

The following will set the width the color bar line.

[Visual Basic and Access]

Me.ctxSchedule.CBarLineWidth(1) = 1

[Visual FoxPro]

thisform.ctxSchedule.CBarLineWidth(1) = 1

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarTimeColor Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the background color of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarTimeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the first color bar to white.

[Visual Basic and Access]

Me.ctxSchedule.CBarTimeColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.CBarTimeColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarTimeColorTo Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the secondary color of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarTimeColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applied when the CBarFillType property is not equal to 0 (Solid).

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the first color bar to black.

[Visual Basic and Access]

Me.ctxSchedule.CBarTimeColorTo(1) = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.CBarTimeColorTo(1) = RGB(0,0,0)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarTimeEnd Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the end time of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarTimeEnd( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value.

Remarks

The start and end times in ctxSchedule are based on the number of minutes since midnight.

Example

The following will set the first color bar's end time to 12:00 pm.

[Visual Basic and Access]

Me.ctxSchedule.CBarTimeEnd(1) = 720

[Visual FoxPro]

thisform.ctxSchedule.CBarTimeEnd(1) = 720

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarTimeStart Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the start time of the color bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarTimeStart( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An Integer value.

Remarks

The start and end times in ctxSchedule are based on the number of minutes since midnight.

Example

The following will set the first color bar's start time to 8:00 am.

[Visual Basic and Access]

Me.ctxSchedule.CBarTimeStart(1) = 480

[Visual FoxPro]

thisform.ctxSchedule.CBarTimeStart(1) = 480

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

CBarVertOffset Property
nIndex
The 1-based index value of the color bar.

Description

Returns/sets the vertical offset used to draw the color bar

Property type

Read-write property

Syntax

Visual Basic
Public Property CBarVertOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the color bar.

Return Type

An integer value

Remarks

Positive values will shift the top edge of the color bar towards the bottom, and negative values will shift the bottom edge towards the top.

Example

[Visual Basic and Access]

Me.ctxSchedule.CBarVertOffset(1) = 10

[Visual FoxPro]

thisform.ctxSchedule.CBarVertOffset(1) = 10

See Also

ctxSchedule Object


%%PageItemTitle%%

CellBackColor Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the background color of an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellBackColor( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

A ULong value representing an OLE_COLOR

Remarks

This property will take precedence over the ColumnBackColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the cell located in the first row, first column.

[Visual Basic and Access]

Me.ctxSchedule.CellBackColor(1,1) = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.CellBackColor(1,1) = RGB(0,0,0)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CellCheck Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the check state of an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellCheck( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

An Integer value.

Remarks

If the state of a checkbox is set to disabled, the user can still change it value via the mouse. When a check box is clicked on the CheckClick event fires.

Example

The following will set the check box in the first row, first column to selected/checked.

[Visual Basic and Access]

Me.ctxSchedule.CellCheck(1,1) = 1

[Visual FoxPro]

thisform.ctxSchedule.CellCheck(1,1) = 1

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CellFont Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the font of an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellFont( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

An Integer value indicating which font to assign to the cell.

Example

The following will assign FontIndex2 font to the cell.

[Visual Basic and Access]

Me.ctxSchedule.CellFont(1,1) = 2

[Visual FoxPro]

thisform.ctxSchedule.CellFont(1,1) = 2

See Also

ctxSchedule Object | Adding and Customizing List Items | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

CellForeColor Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the foreground color of an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellForeColor( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will take precedence over the ColumnForeColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the foreground color of the cell located in the first row, first column.

[Visual Basic and Access]

Me.ctxSchedule.CellForeColor(1,1) = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.CellForeColor(1,1) = RGB(0,0,0)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CellPicSelect Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the image to display in a cell when the list item is selected.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellPicSelect( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

The 1-based index value of the image in the internal image list.

Remarks

Images can be added to the internal image list with the AddImage method. If no image is assigned to this property, the CellPicture image is displayed.

Example

[Visual Basic and Access]

Me.ctxSchedule.CellPicSelect(1,1) = 2

[Visual FoxPro]

thisform.ctxSchedule.CellPicSelect(1,1) = 2

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CellPicture Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the image to place in an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellPicture( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

The 1-based index value of the image in the internal image list.

Remarks

Images can be added to the internal image list with the AddImage method.

Example

[Visual Basic and Access]

Me.ctxSchedule.CellPicture(1,1) = 2

[Visual FoxPro]

thisform.ctxSchedule.CellPicture(1,1) = 2

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CellText Property
nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Description

Returns/sets the text of an individual cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property CellText( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.
nColumn
The 1-based index of the column.

Return Type

A String value.

Remarks

The ItemText property is used to assign a text value to an entire list item.

Example

The following will set the text of the cell located in the first row, first column.

[Visual Basic and Access]

Me.ctxSchedule.CellText(1,1) = "Item Text"

[Visual FoxPro]

thisform.ctxSchedule.CellText(1,1) = "Item Text"

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

CheckPicDisabled Property

Description

Returns/sets the picutre used for a disabled check box.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckPicDisabled() As Picture

Return Type

A Picture object.

Remarks

This property is only applicable when the ColumnCheckBox is equal to 3 (User Defined) and the CellCheck property is equal to 2 (Disabled).

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.CheckPicDisabled = LoadPicture("C:\Path to Image\Image.bmp")

or

Me.ctxSchedule.CheckPicDisabled = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxSchedule.CheckPicDisabled = LoadPicture("C:\Path to Image\Image.bmp")

or

thisform.ctxSchedule.CheckPicDisabled = Ole_Control.Picture

See Also

ctxSchedule Object


%%PageItemTitle%%

CheckPicDown Property

Description

Returns/sets the picutre used for a selected check box.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckPicDown() As Picture

Return Type

A Picture object.

Remarks

This property is only applicable when the ColumnCheckBox is equal to 3 (User Defined) and the CellCheck property is equal to 1 (Down/selected).

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.CheckPicDown = LoadPicture("C:\Path to Image\Image.bmp")

or

Me.ctxSchedule.CheckPicDown = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxSchedule.CheckPicDown = LoadPicture("C:\Path to Image\Image.bmp")

or

thisform.ctxSchedule.CheckPicDown = Ole_Control.Picture

See Also

ctxSchedule Object


%%PageItemTitle%%

CheckPicUp Property

Description

Returns/sets the picutre used for an un-selected check box.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckPicUp() As Picture

Return Type

A Picture object.

Remarks

This property is only applicable when the ColumnCheckBox is equal to 3 (User Defined) and the CellCheck property is equal to 0 (Up/un-selected).

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.CheckPicUp = LoadPicture("C:\Path to Image\Image.bmp")

or

Me.ctxSchedule.CheckPicUp = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxSchedule.CheckPicUp = LoadPicture("C:\Path to Image\Image.bmp")

or

thisform.ctxSchedule.CheckPicUp = Ole_Control.Picture

See Also

ctxSchedule Object


%%PageItemTitle%%

CheckXOffset Property

Description

Returns/sets the horizontal offset value used to calculate the position of the checkbox in a cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckXOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.CheckXOffset = 0

[Visual FoxPro]

thisform.ctxSchedule.CheckXOffset = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

CheckYOffset Property

Description

Returns/sets the vertical offset used to calculate the position of the checkbox in a cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckYOffset() As Integer

Return Type

An Integer value.

Remarks

A value of 0 will vertically center the checkbox in the cell.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.CheckYOffset = -4

[Visual FoxPro]

thisform.ctxSchedule.CheckYOffset = -4

See Also

ctxSchedule Object


%%PageItemTitle%%

ColumnBackColor Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the background color for the cells in a column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the column.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnBackColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.ColumnBackColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

ColumnCheckAlign Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the alignment of the checkboxes within the cells in the column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnCheckAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value representing an enumAlign member.

Remarks

This property will override the ListAlign property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnCheckAlign(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ColumnCheckAlign(1) = 2

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnCheckBox Property
nIndex
The 1-based index value of the column.

Description

Determines the type of checkbox to display in the cells of the column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnCheckBox( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnCheckBox(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ColumnCheckBox(1) = 2

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnForeColor Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the foreground color of the cells in the column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the column.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnForeColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.ColumnForeColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnHeaderAlign Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the horizontal alignment of the column header.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnHeaderAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value representing an enumAlign member.

Remarks

This property will override the ListAlign property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnHeaderAlign(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ColumnHeaderAlign(1) = 2

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnLock Property
nIndex
The 1-based index value of the column.

Description

Determines if the column can be resized with the mouse.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnLock( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the column.

Return Type

A Boolean value.

Remarks

When this property is equal to true, the column width can be changed programmatically with the ColumnWidth property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnLock = False

[Visual FoxPro]

thisform.ctxSchedule.ColumnLock = .F.

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnPicture Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the index of the image in a specific column header.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnPicture( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

The 1-based index value of the image in the internal image list.

Remarks

Images can be added to the internal image list with the AddImage method.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnPicture(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ColumnPicture(1) = 2

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnPictureAlign Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the horizontal alignment of the image in a column header.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnPictureAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value representing an enumAlign member.

Remarks

This property will override the PicAlign property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnPictureAlign(1) = 0

[Visual FoxPro]

thisform.ctxSchedule.ColumnPictureAlign(1) = 0

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnText Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the column header text.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnText( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index value of the column.

Return Type

A String value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnText(1) = "Column 1"

[Visual FoxPro]

thisform.ctxSchedule.ColumnText(1) = "Column 1"

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnTextAlign Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the horizontal alignment of the item cell text in the column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnTextAlign( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value representing an enumAlign member.

Remarks

This property will override the ListAlign property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnTextAlign(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ColumnTextAlign(1) = 2

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ColumnWidth Property
nIndex
The 1-based index value of the column.

Description

Returns/sets the width of the column.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnWidth( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the column.

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ColumnWidth(1) = 50

[Visual FoxPro]

thisform.ctxSchedule.ColumnWidth(1) = 50

See Also

ctxSchedule Object | Adding Columns to the List Area


%%PageItemTitle%%

ConflictOffset Property

Description

Returns/sets the number of minutes used to determine a time bar conflict.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConflictOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

By setting this property to -5, time bars can overlap by 5 minutes before a conflict is reported.

[Visual Basic and Access]

Me.ctxSchedule.ConflictOffset = -5

[Visual FoxPro]

thisform.ctxSchedule.ConflictOffset = -5

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

DateEnd Property

Description

Returns/sets the end date of the schedule

Property type

Read-write property

Syntax

Visual Basic
Public Property DateEnd() As Long

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the end date to January 1, 2006.

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DateEnd = 38718

or

Me.ctxSchedule.DateEnd = CLng(#1/1/2006#)

[Visual FoxPro]

thisform.ctxSchedule.DateEnd = 38718

or

thisform.ctxSchedule.DateEnd = CTOD("1/1/2006") - CTOD("1/1/1900")

See Also

ctxSchedule Object


%%PageItemTitle%%

DateFormat Property

Description

Returns/sets the date format in the ruler title.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateFormat() As String

Return Type

A String value

Remarks

If TimeType is equal to Days (1) then the d,D,n,N characters will be ignored. The RulerTitle and Date string are displayed in the same area in the ruler. The RulerTitle will override this property.

Available characters for formatting:

D - Day of the week. The days are specified in the DayNames property. It makes no difference whether this character is in upper or lowercase.

M - Month of the year. If this character is in upper case, it will be replaced with a month name from the MonthNames property. If it is in lower case, it will be replaced with a two digit number.

N - Day of the month. If this character is in upper case, then the day will be formatted as a two digit number. If the value is less than ten, a zero will precede it (i.e. 07). If the character is in lower case, the day will be formatted as a regular number.

Y - The current year. If this character is in upper case, the year will be formatted as a four digit number. If it is in lower case, it will be formatted as a two digit number.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DateFormat = "D, M, Y"

[Visual FoxPro]

thisform.ctxSchedule.DateFormat = "D, M, Y"

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

DateOffset Property

Description

Returns/sets the offset value used to synchronize the base date of the control to the base date of the development platform.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateOffset() As Integer

Return Type

An Integer value.

Remarks

The base date for ctxSchedule is January 1, 1900. Some platforms such as Visual Basic and Access use a base date of December 30, 1899. Therefore if this property is equal to 2, the base date of the development platform and the control will be synchronized.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DateOffset = 2

[Visual FoxPro]

thisform.ctxSchedule.DateOffset = 2

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

DatesInBars Property

Description

Determines if the start and end dates of a time bar will be displayed as text within the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property DatesInBars() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the month date (1-31) will be displayed at the start and end of the time bar.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DatesInBars = True

[Visual FoxPro]

thisform.ctxSchedule.DatesInBars = .T.

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

DateStart Property

Description

Returns/sets the start date of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property DateStart() As Long

Return Type

An Integer value.

Remarks

The dates in ctxSchedule are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Example

The following will set the start date to January 1, 2006.

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DateStart = 38718

or

Me.ctxSchedule.DateStart = CLng(#1/1/2006#)

[Visual FoxPro]

thisform.ctxSchedule.DateStart = 38718

or

thisform.ctxSchedule.DateStart = CTOD("1/1/2006") - CTOD("1/1/1900")

See Also

ctxSchedule Object


%%PageItemTitle%%

DayMonthOffset Property

Description

Determines the offset used to calculate the starting day of the week in a monthly ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayMonthOffset() As Integer

Return Type

An Integer value

Remarks

Accepts values of 0-6 to determine the offset.

This property is only valid when the TimeType property is set to Months. By default, the first day of each week is determined by the day of the week of the DateStart. This property can be used to offset the first displayed week (shorten it) so that the next week (and all after) will start on a different day of the week.

Example

If the control is being started on a Tuesday, normally all weeks will start on Tuesday.

Setting this property to a value of 1 in this case, will shorten the week by a day, causing all other weeks to start on Monday.

See Also

ctxSchedule Object


%%PageItemTitle%%

DayNames Property

Description

Returns/sets the names of the week days.

Property type

Read-write property

Syntax

Visual Basic
Public Property DayNames() As String

Return Type

A String value

Remarks

The week names are seperated by the semi-colon. The first string represents sunday.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DayNames = "Sun;Mon;Tues;Wed;Thurs;Fri;Sat"

[Visual FoxPro]

thisform.ctxSchedule.DayNames = "Sun;Mon;Tues;Wed;Thurs;Fri;Sat"

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

DefaultStyle Property

Description

Returns/sets the default style of the time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultStyle() As Integer

Return Type

The 1-based index value of the bar style to assign as default.

Remarks

Additional styles must be created within the control before this property will have any effect. If no styles have been created, or if the value of this property is outside the range of valid image styles, the time bar will be drawn with the default style.

Example

[Visual Basic and Access]

Me.ctxSchedule.DefaultStyle = 1

[Visual FoxPro]

thisform.ctxSchedule.DefaultStyle = 1

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

DefBarHeight Property

Description

Returns the default height of the time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefBarHeight() As Integer

Example

x = ctxSchedule1.DefBarHeight

See Also

ctxSchedule Object


%%PageItemTitle%%

DefLineHeight Property

Description

Returns the default height of the list items.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefLineHeight() As Integer

Example

x = ctxSchedule1.DefLineHeight

See Also

ctxSchedule Object


%%PageItemTitle%%

DisplayOnly Property

Description

Determines if the control will react to user interaction.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayOnly() As Boolean

Return Type

A Boolean value.

Remarks

When this property is equal to True, the schedule and list area can still be scrolled with the mouse.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DisplayOnly = False

[Visual FoxPro]

thisform.ctxSchedule.DisplayOnly = .F.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

DisplaySubText Property

Description

Determines if the time bar sub-text will be displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplaySubText() As Boolean

Return Type

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.DisplaySubText = True

[Visual FoxPro]

thisform.ctxSchedule.DisplaySubText = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

EditMode Property

Description

Returns/sets the type of action to perform on a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditMode() As enumEditMode

Return Type

An Integer value representing an enumEditMode member.

Example

[Visual Basic and Access]

Me.ctxSchedule.EditMode = 0

[Visual FoxPro]

thisform.ctxSchedule.EditMode = 0

See Also

ctxSchedule Object | Time Bar Linking | Schedule Edit Modes


%%PageItemTitle%%

FillList Property

Description

Determines how the last column in the list area will be displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property FillList() As Boolean

Return Type

A Boolean value.

Remarks

If this property is equal to True, the last column will stretch up to the splitter bar and ignore the defined column width. When set to False, the assigned column width will persist.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.FillList = False

[Visual FoxPro]

thisform.ctxSchedule.FillList = .F.

See Also

ctxSchedule Object


%%PageItemTitle%%

FontIndex1 Property

Description

Returns/sets an additional font which can be assigned to the list items and cells.

Property type

Read-write property

Syntax

Visual Basic
Public Property FontIndex1() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.FontIndex1 = Ole_object.Font

or

Me.ctxSchedule.FontIndex1.Name = "Verdana"

Me.ctxSchedule.FontIndex1.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.FontIndex1 = Ole_Object.Font

or

thisform.ctxSchedule.FontIndex1.Name = "Verdana"

thisform.ctxSchedule.FontIndex1.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

FontIndex2 Property

Description

Returns/sets an additional font which can be assigned to the list items and cells.

Property type

Read-write property

Syntax

Visual Basic
Public Property FontIndex2() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.FontIndex2 = Ole_object.Font

or

Me.ctxSchedule.FontIndex2.Name = "Verdana"

Me.ctxSchedule.FontIndex2.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.FontIndex2 = Ole_Object.Font

or

thisform.ctxSchedule.FontIndex2.Name = "Verdana"

thisform.ctxSchedule.FontIndex2.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

FontIndex3 Property

Description

Returns/sets an additional font which can be assigned to the list items and cells.

Property type

Read-write property

Syntax

Visual Basic
Public Property FontIndex3() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.FontIndex3 = Ole_object.Font

or

Me.ctxSchedule.FontIndex3.Name = "Verdana"

Me.ctxSchedule.FontIndex3.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.FontIndex3 = Ole_Object.Font

or

thisform.ctxSchedule.FontIndex3.Name = "Verdana"

thisform.ctxSchedule.FontIndex3.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

FontIndex4 Property

Description

Returns/sets an additional font which can be assigned to the list items and cells.

Property type

Read-write property

Syntax

Visual Basic
Public Property FontIndex4() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.FontIndex4 = Ole_object.Font

or

Me.ctxSchedule.FontIndex4.Name = "Verdana"

Me.ctxSchedule.FontIndex4.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.FontIndex4 = Ole_Object.Font

or

thisform.ctxSchedule.FontIndex4.Name = "Verdana"

thisform.ctxSchedule.FontIndex4.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

GridFrequency Property

Description

Returns/sets the distance where the time bars can be moved or sized.

Property type

Read-write property

Syntax

Visual Basic
Public Property GridFrequency() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when SnapToGrid is equal to True.

When the SnapToGrip property is set to a value of True a time bar can only be moved to position within the major time unit as specified by this property. For example, if the major time unit is set to Hours, and the TimeDistance property is set to 60 (one pixel for each minute) then the user can place a time bar to start on any minute within an hour. To insure that time bars can only start on 15 minutes after the hour, 30 minutes after the hour, 45 minutes after the hour, or on the hour, the GridFrequency would be set to 15. In this case moving or creating a time bar in the schedule would automatically snap the start time to the nearest 15 minute increment.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.GridFrequency = 15

[Visual FoxPro]

thisform.ctxSchedule.GridFrequency = 15

See Also

ctxSchedule Object | Setting up Schedule Views


%%PageItemTitle%%

GuideColor Property
nIndex
Integer index value of the GuideLine

Description

Returns/sets the color of an individual GuideLine based on the index.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
Integer index value of the GuideLine

Return Type

A ULong value representing an OLE_COLOR.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideDate Property
See Also Example Send comments on this topic.
nIndex
Integer index value of the GuideLine

Description

Returns/sets the long date value of the GuideLine.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideDate( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
Integer index value of the GuideLine

Return Type

Long

Example

Visual Basic Copy Code
Me.ctxSchedule1.GuideDate(1) = CLng(Now)

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideImage Property
nIndex
Index of the image in the internal image list.

Description

Returns/sets the index value of the GuideLine image.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideImage( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
Index of the image in the internal image list.

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideImageIndex Property

Description

Returns/sets the image index value of default GuideLines.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideImageIndex() As Integer

Return Type

Integer

Remarks

This sets the default image for GuideLines added through the Edit mode = Guidelines or when programmatically adding GuideLines without setting the GuideImage property.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideImagePosition Property

Description

Determines wether the GuideLine images will appear in front of or behind the ruler text.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideImagePosition() As enumGuidePosition

Return Type

enumGuidePosition

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideImageXOffset Property
nIndex
The 1-based index value of the GuideLine to offset the image of.

Description

Returns/sets the horizontal offset value used to calculate the position of the GuideLine image in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideImageXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the GuideLine to offset the image of.

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideImageYOffset Property
nIndex
The 1-based index value of the GuideLine to offset the image of.

Description

Returns/sets the vertical offset used to calculate the position of the GuideLine image in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideImageYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the GuideLine to offset the image of.

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineColor Property

Description

Returns/sets the default GuideLine color.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This sets the default color for GuideLines added through the Edit mode = Guidelines or when programmatically adding GuideLines without setting the GuideColor property.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineDistance Property

Description

Determines how close the edge of a time bar must be to a GuideLine before the time bar is snapped to the GuideLine location (in pixels).

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideLineDistance() As Integer

Return Type

Integer

Remarks

SnapToGuideLines Property must be set to True to enable this feature.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLocked Property
nIndex
Integer value of the GuideLine to lock.

Description

Determines if a GuideLine can be moved/removed with the mouse.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideLocked( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
Integer value of the GuideLine to lock.

Return Type

Boolean

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideMoveColor Property

Description

Returns/sets the color of a GuideLine while it is moving.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideMoveColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideTime Property
nIndex
Integer index value of the GuideLine

Description

Returns/sets the time value (in minutes past midnight) of the GuideLine.

Property type

Read-write property

Syntax

Visual Basic
Public Property GuideTime( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
Integer index value of the GuideLine

Return Type

Integer

Example

me.ctxSchedule1.GuideTime(1) = 540

See Also

ctxSchedule Object


%%PageItemTitle%%

HeightOffset Property

Description

Returns/sets the offset value used to calculate the height of the list items.

Property type

Read-write property

Syntax

Visual Basic
Public Property HeightOffset() As Integer

Return Type

An Integer value.

Remarks

The height of a list item is based on the ListFont property and heights of the images placed in them. This property is used to increase or decrease the calculated height. This property is applied to all list items.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.HeightOffset = 10

[Visual FoxPro]

thisform.ctxSchedule.HeightOffset = 10

See Also

ctxSchedule Object


%%PageItemTitle%%

HistorySize Property

Description

Returns/sets the number of items that can be undone/redone

Property type

Read-write property

Syntax

Visual Basic
Public Property HistorySize() As Integer

Return Type

An Integer value

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.HistorySize = 5

[Visual FoxPro]

thisform.ctxSchedule.HistorySize = 5

See Also

ctxSchedule Object | Undo/Redo Features


%%PageItemTitle%%

HorzGridLineColor Property

Description

Determines the color used to paint the HorzGridLines in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzGridLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzGridLines Property

Description

Determines if horizontal grid lines will be displayed in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzGridLines() As Boolean

Return Type

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.HorzGridLines = True

[Visual FoxPro]

thisform.ctxSchedule.HorzGridLines = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzListLargeChange Property

Description

Returns/sets the override for the large change of the horizontal scroll bar in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzListLargeChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Large Changes occur when the user clicks in an empty part of the scroll bar, or presses the PageUp/PageDown keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzListMax Property

Description

Returns the max scroll value of the horizontal scroll bar in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzListMax() As Integer

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzListSmallChange Property

Description

Returns/sets the override for the small change of the horizontal scroll bar in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzListSmallChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Small Changes occur when the user clicks an arrow button of the scroll bar, or presses the Arrow keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzScheduleLargeChange Property

Description

Returns/sets the override for the large change of the horizontal scroll bar in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScheduleLargeChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Large Changes occur when the user clicks in an empty part of the scroll bar, or presses the PageUp/PageDown keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzScheduleMax Property

Description

Returns the max scroll value of the horizontal scroll bar in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScheduleMax() As Integer

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzScheduleSmallChange Property

Description

Returns/sets the override for the small change of the horizontal scroll bar in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScheduleSmallChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Small Changes occur when the user clicks an arrow button of the scroll bar, or presses the Arrow keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

HorzScrollType Property

Description

Determines how the list area is horizontally scrolled.

Property type

Read-write property

Syntax

Visual Basic
Public Property HorzScrollType() As enumHorzScroll

Return Type

An Integer value representing an enumHorzScroll member.

Remarks

If this property is set to a value of 0 (column width) the horizontal scroll bar will receive a value of the total width of all of the columns and the pre-column. If a value of 1 is assigned to this property the horizontal scroll bar will recieve a value based on the number of defined columns in the list area not including the pre-column.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.HorzScrollType = 0

[Visual FoxPro]

thisform.ctxSchedule.HorzScrollType = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

ImageListCount Property

Description

Returns the number of images stored in the internal image list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImageListCount() As Integer

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intImageCount

intImageCount = Me.ctxSchedule.ImageListCount

[Visual FoxPro]

intImageCount = thisform.ctxSchedule.ImageListCount

See Also

ctxSchedule Object


%%PageItemTitle%%

ImagePosition Property

Description

Returns/sets the alignment/format of the background image in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImagePosition() As enumImagePosn

Return Type

An Integer value representing an enumImagePosn member.

Remarks

The background image is defined in the BackImage property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ImagePosition = 2

[Visual FoxPro]

thisform.ctxSchedule.ImagePosition = 2

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

IncludeAmPm Property

Description

Determines if the AM and PM tags will be displayed in the ruler text.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeAmPm() As Boolean

Return Type

A Boolean value.

Remarks

This property is only applied when TimeType is equal to Hours (0). The text for the AM and PM tags are defined by the TimeTagAM and TimeTagPM properties.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.IncludeAmPm = True

[Visual FoxPro]

thisform.ctxSchedule.IncludeAmPm = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

IncludeMinutes Property

Description

Determines if minutes will be included in the ruler text.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeMinutes() As Boolean

Return Type

A Boolean value.

Remarks

This property is only applied when TimeType is equal to Hours (0).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.IncludeMinutes = True

[Visual FoxPro]

thisform.ctxSchedule.IncludeMinutes = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

ItemBackColor Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the background color of a list item

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A ULong representing an OLE_COLOR

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the item to white.

[Visual Basic and Access]

Me.ctxSchedule.ItemBackColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.ItemBackColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ItemCargo Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the non-visible text value for the list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemCargo( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A String value.

Remarks

This value is not visible to the user. The purpose of this string is to be determined by the developer. The ItemData property is used specify a non-visible Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ItemCargo(1) = "REC1234"

[Visual FoxPro]

thisform.ctxSchedule.ItemCargo(1) = "REC1234"

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ItemData Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets a non-visible integer value of a list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemData( _
   ByVal nIndex As Integer _
) As Long

Parameters

nIndex
The 1-based index value of the list item.

Return Type

An Integer value.

Remarks

This value is not visible to the user. The purpose of this integer is to be determined by the developer. The ItemCargo property is used specify a non-visible String value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ItemData(1) = 655

[Visual FoxPro]

thisform.ctxSchedule.ItemData(1) = 655

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ItemFont Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the font of a list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemFont( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.

Return Type

An Integer value

Remarks

If this property is not set, or assigned a value of 0, the item will be drawn with the ListFont property.

Example

The following will assign the FontIndex2 font to the first list item

[Visual Basic and Access]

Me.ctxSchedule.ItemFont(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.ItemFont(1) = 2

See Also

ctxSchedule Object | Adding and Customizing List Items | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

ItemForeColor Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the foreground color of a list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A ULong representing an OLE_COLOR

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the foreground color of the item to blue.

[Visual Basic and Access]

Me.ctxSchedule.ItemForeColor(1) = RGB(0,0,255)

[Visual FoxPro]

thisform.ctxSchedule.ItemForeColor(1) = RGB(0,0,255)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ItemHeader Property
nIndex
The 1-based index value of the list item.

Description

Determines if the list item will appear as a group header item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeader( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A Boolean value.

Remarks

Group headers are drawn into a single column and are not effected by the ListIndent property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ItemHeader(1) = True

[Visual FoxPro]

thisform.ctxSchedule.ItemHeader(1) = .T.

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ItemHeaderBackColor Property

Description

Returns/sets the primary background color for all group header items.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderBackColor() As ULong

Return Type

A ULong representing an OLE_COLOR

See Also

ctxSchedule Object

Developing With

Adding and Customizing List Items


%%PageItemTitle%%

ItemHeaderBackColorTo Property

Description

Returns/sets the secondary background color for all group header items.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderBackColorTo() As ULong

Return Type

A ULong representing an OLE_COLOR

See Also

ctxSchedule Object

Developing With

Adding and Customizing List Items


%%PageItemTitle%%

ItemHeaderClick Property

Description

Determines if the header items will respond to click events.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderClick() As Boolean

Return Type

Boolean

See Also

ctxSchedule Object


%%PageItemTitle%%

ItemHeaderFillType Property

Description

Returns/sets the enumFillType for all group header items.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderFillType() As enumFillType

Return Type

enumFillType

See Also

ctxSchedule Object

Developing With

Adding and Customizing List Items


%%PageItemTitle%%

ItemHeaderFont Property

Description

Returns/sets the default font for a list item group header.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

[Visual Basic and Access]

Me.ctxSchedule.ItemHeaderFont = Ole_object.Font

or

Me.ctxSchedule.ItemHeaderFont.Name = "Verdana"

Me.ctxSchedule.ItemHeaderFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.ItemHeaderFont = Ole_Object.Font

or

thisform.ctxSchedule.ItemHeaderFont.Name = "Verdana"

thisform.ctxSchedule.ItemHeaderFont.Bold = .T.

See Also

ctxSchedule Object | Adding and Customizing List Items | Assigning Fonts to List Items and Time Bars

Developing With

Adding and Customizing List Items


%%PageItemTitle%%

ItemHeaderForeColor Property

Description

Returns/sets the foreground(text) color for all group header items.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemHeaderForeColor() As ULong

Return Type

A ULong representing an OLE_COLOR

Remarks

This property replaces the ItemHeaderColor property.

See Also

ctxSchedule Object

Developing With

Adding and Customizing List Items


%%PageItemTitle%%

ItemLoaded Property
nIndex
The 1-based index value of the list item.

Description

Determines if a list item is marked as loaded.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemLoaded( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.ItemLoaded = True

[Visual FoxPro]

thisform.ctxSchedule.ItemLoaded = .T.

See Also

ctxSchedule Object | Adding and Customizing List Items | Using the Pre-Load Option to Save Memory


%%PageItemTitle%%

ItemNextBarIndex Property
nIndex
The 1-based index for the line item to check.

Description

Returns the index value for the first time bar past the end of the visible area of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemNextBarIndex( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index for the line item to check.

Remarks

Will return a value of 0, if no time bars exist on the item after the current visible area.

See Also

ctxSchedule Object


%%PageItemTitle%%

ItemPrevBarIndex Property
nIndex
The 1-based index for the line item to check.

Description

Returns the index value for the first time bar before the start of the visible area of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemPrevBarIndex( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index for the line item to check.

Remarks

Will return a value of 0, if no time bars exist on the item before the current visible area.

See Also

ctxSchedule Object


%%PageItemTitle%%

ItemReadOnly Property
nIndex
The 1-based index value of the list item.

Description

Determines if the list item will be readonly.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemReadOnly( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A Boolean value.

Remarks

A list item that has been marked as read-only can still have time bars added and edited within them through code. However, time bars cannot be added or moved with the mouse into a list item marked as read-only, and existing time bars cannot be edited.

Example

The first list item will be read only.

[Visual Basic and Access]

Me.ctxSchedule.ItemReadOnly(1) = False

[Visual FoxPro]

thisform.ctxSchedule.ItemReadOnly(1) = .F.

See Also

ctxSchedule Object | Adding and Customizing List Items | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

ItemText Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the text of a list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemText( _
   ByVal nIndex As Integer _
) As String

Parameters

nIndex
The 1-based index value of the list item.

Return Type

A String value.

Remarks

To separate the text for each column in the list, a semi-colon should be placed within the text at the desired breaks.

Example

The following will set the text for 3 columns.

[Visual Basic and Access]

Me.ctxSchedule.ItemText(1) = "Name;Start;End"

[Visual FoxPro]

thisform.ctxSchedule.ItemText(1) = "Name;Start;End"

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

LineArrowAfter Property

Description

Returns/sets the image used for the line arrows indicating more time bars after the current view.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineArrowAfter() As Picture

Return Type

A Picture Object.

Remarks

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowBefore Property

Description

Returns/sets the image used for the line arrows indicating more time bars before the current view.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineArrowBefore() As Picture

Return Type

A Picture Object.

Remarks

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowColor Property

Description

Returns/sets the color used for the painting of the default line arrow appearance.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineArrowColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is used to paint the line arrows on both sides of the items, when no picture has been assigned to LineArrowAfter or LineArrowBefore properties, respectively.

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowPosition Property

Description

Returns/sets where the line arrows will be drawn in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineArrowPosition() As enumItemPosition

Return Type

enumItemPosition

Remarks

This property must be set to a value of 1 (Back) or 2 (Front) for line arrows to be displayed in the schedule.

See Also

ctxSchedule Object


%%PageItemTitle%%

LineMaxSize Property

Description

Returns/sets the height of the line marking the major time unit within the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineMaxSize() As Integer

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.LineMaxSize = 10

[Visual FoxPro]

thisform.ctxSchedule.LineMaxSize = 10

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

LineMinSize Property

Description

Returns/sets the height of the line marking the minor time units within the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property LineMinSize() As Integer

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.LineMinSize = 5

[Visual FoxPro]

thisform.ctxSchedule.LineMinSize = 5

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

LinkColor Property
nIndex
The 1-based index value of the link.

Description

Returns/sets the color of a specific link item.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the link.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will override the LinkLineColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.LinkColor(1) = RGB(120,120,120)

[Visual FoxPro]

thisform.ctxSchedule.LinkColor(1) = RGB(120,120,120)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkCount Property

Description

Returns the number of links stored in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkCount() As Integer

Return Type

An Integer value

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intLinkCount as Integer

intLinkCount = Me.ctxSchedule.LinkCount

[Visual FoxPro]

intLinkCount = thisform.ctxSchedule.LinkCount

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkFromBar Property
nIndex
The 1-based index value of the link.

Description

Returns the index value of the time bar initiating the link.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkFromBar( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the link.

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.LinkFromBar(1)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.LinkFromBar(1)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkFromItem Property
nIndex
The 1-based index value of the link.

Description

Returns/sets the index value of the schedule item containing time bar initiating the link.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkFromItem( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the link.

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.LinkFromItem(1)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.LinkFromItem(1)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkLineColor Property

Description

Returns/sets the default link line color.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The LinkColor property is used assign a unique color to a link line, and will override this property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.LinkLineColor = RGB(120,120,120)

[Visual FoxPro]

thisform.ctxSchedule.LinkLineColor = RGB(120,120,120)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkToBar Property
nIndex
The 1-based index value of the link.

Description

Returns/sets the index value of the time bar receiving the link.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkToBar( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the link.

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.LinkToBar(1)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.LinkToBar(1)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkToItem Property
nIndex
The 1-based index value of the link.

Description

Returns/sets the index value of the time bar receiving the link.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkToItem( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the link.

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intIndex as Integer

intIndex = Me.ctxSchedule.LinkToItem(1)

[Visual FoxPro]

intIndex = thisform.ctxSchedule.LinkToItem(1)

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

LinkType Property
nIndex
The 1-based index value of the link.

Description

Returns/sets the type of link to display between 2 time bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the link.

Return Type

An Integer value.

Remarks

Available values are:
0 – Standard
1 – Reciprocal
2 – Direct

Example

[Visual Basic and Access]

Me.ctxSchedule.LinkType(1) = 1

[Visual FoxPro]

thisform.ctxSchedule.LinkType(1) = 1

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

ListAlign Property

Description

Determines the horizontal alignment of the text in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListAlign() As enumAlign

Return Type

An Integer value representing an enumAlign member.

Remarks

This property can be overridden with the ColumnTextAlign property.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListAlign = 0

[Visual FoxPro]

thisform.ctxSchedule.ListAlign = 0

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ListBackColor Property

Description

Returns/sets the default background color of the list area in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.ListBackColor = RGB(255,255,255)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ListBarBorder Property

Description

Determines the border type to use for the splitter bar

Property type

Read-write property

Syntax

Visual Basic
Public Property ListBarBorder() As enumBorder

Return Type

An Integer value representing an enumBorder member.

See Also

ctxSchedule Object


%%PageItemTitle%%

ListBarColor Property

Description

Returns/sets the color of the splitter bar in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListBarColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The splitter bar is located between the list area and schedule area of the control.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListBarColor = RGB(55,55,55)

[Visual FoxPro]

thisform.ctxSchedule.ListBarColor = RGB(55,55,55)

See Also

ctxSchedule Object


%%PageItemTitle%%

ListBarWidth Property

Description

Returns/sets the width of the splitter bar in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListBarWidth() As Integer

Return Type

An Integer value

Remarks

The splitter bar is located between the list area and schedule area of the control.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListBarWidth = 10

[Visual FoxPro]

thisform.ctxSchedule.ListBarWidth = 10

See Also

ctxSchedule Object


%%PageItemTitle%%

ListBorder Property

Description

Returns/sets the type of border to place around the cells and list items in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListBorder() As enumBorder

Return Type

An Integer value representing an enumBorder member.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListBorder = 1

[Visual FoxPro]

thisform.ctxSchedule.ListBorder = 1

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ListCount Property

Description

Returns the total number of the items in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListCount() As Integer

Return Type

An Integer value

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intItemCount as Integer

intItemCount = Me.ctxSchedule.ListCount

[Visual FoxPro]

intItemCount = thisform.ctxSchedule.ListCount

See Also

ctxSchedule Object


%%PageItemTitle%%

ListFont Property

Description

Returns/sets the default font for the list area in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListFont = Ole_object.Font

or

Me.ctxSchedule.ListFont.Name = "Verdana"

Me.ctxSchedule.ListFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.ListFont = Ole_Object.Font

or

thisform.ctxSchedule.ListFont.Name = "Verdana"

thisform.ctxSchedule.ListFont.Bold = .T.

See Also

ctxSchedule Object | Adding and Customizing List Items | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

ListForeColor Property

Description

Returns/sets the default foreground color of the list area in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListForeColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.ListForeColor = RGB(0,0,0)

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ListImage Property
nIndex
The 1-based index value of the image in the internal image list.

Description

Gets or sets an image within the internal image list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListImage( _
   ByVal nIndex As Integer _
) As Picture

Parameters

nIndex
The 1-based index value of the image in the internal image list.

Return Type

An OLE_PICTURE object.

Remarks

This property will not add additional images to the internal image list. For example, if 5 images have been added to the internal image list via the AddImage method, this property can only access those 5 images.

With this property, images can be loaded into other OLE objects, as well as read into ctxSchedule.

Example

The following will load the first image in the internal image list of ctxSchedule into the internal image list of ctTree and it will read the first image stored in ctImage into the first position of the ctxSchedule internal image list.

[Visual Basic and Access]

Dim intImage As Integer
intImage = Me.ctTree.AddImage(Me.ctxSchedule.ListImage(1))

Me.ctxSchedule.ListImage(1) = Me.ctImage.ListImage(1)

[Visual FoxPro]

intImage = thisform.ctTree.AddImage(thisform.ctxSchedule.ListImage(1))

thisform.ctxSchedule.ListImage(1) = thisform.ctImage.ListImage(1)

See Also

ctxSchedule Object


%%PageItemTitle%%

ListIndent Property

Description

Returns/sets the indent of the list item text.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListIndent() As Integer

Remarks

This property is not applied to items marked as group headers (ItemHeader = True) and it is only applied to text in the first column.

Example

[Visual Basic and Access]

Me.ctxSchedule.ListIndent = 5

[Visual FoxPro]

thisform.ctxSchedule.ListIndent = 5

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

ListIndex Property

Description

Returns/sets the selected list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListIndex() As Integer

Remarks

This property is identical to the Selected property. A value of 0 indicates that no item is selected.

Example

The following will select the first item in the list.

[Visual Basic and Access]

Me.ctxSchedule.ListIndex = 1

[Visual FoxPro]

thisform.ctxSchedule.ListIndex = 1

See Also

ctxSchedule Object | Adding and Customizing List Items | Selecting and Searching for Time Bars


%%PageItemTitle%%

ListWidth Property

Description

Returns/sets the width of the list area in ctxSchedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property ListWidth() As Integer

Return Type

An Integer value

Example

[Visual Basic and Access]

Me.ctxSchedule.ListWidth = 100

[Visual FoxPro]

thisform.ctxSchedule.ListWidth = 100

See Also

ctxSchedule Object


%%PageItemTitle%%

LockedLines Property

Description

Returns/sets the number of lines (0-3) to lock at the top of the control's display.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockedLines() As enumLockedLines

Return Type

An Integer value representing an enumLockedLines member.

Remarks

Locked lines are the top most items in the list, and will always be drawn no matter the value of the vertical scroll bar.

Time bars can be moved to and from locked lines and non-locked lines. However, no linked lines will be drawn to any time bars in a locked line.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.LockedLines = 1

[Visual FoxPro]

thisform.ctxSchedule.LockedLines = 1

See Also

ctxSchedule Object | Locking Line Items in the Control View


%%PageItemTitle%%

LockListBar Property

Description

Determines if the list area can be resized by moving the splitter bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property LockListBar() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the list area can still be resized programmatically through the ListWidth property.

Example

[Visual Basic and Access]

Me.ctxSchedule.LockListBar = True

[Visual FoxPro]

thisform.ctxSchedule.LockListBar = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

MajorTimeLineRuler Property

Description

Determines if the major time line will be drawn in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorTimeLineRuler() As Boolean

Return Type

A Boolean value

Remarks

Major time lines in the ruler are a vertical line that is drawn between major time segments in the ruler area.

Depending on the current value of the TimeType property, the major time line will be drawn at different intervals:
Hours: It will be drawn at each midnight segment.
Days: It will be drawn at the start of each month.
Weeks: It will be drawn at the start of each week.
Months: It will be drawn at the start of each month.
Years:It will be drawn at the start of each year.

When TimeType is either "Years" or "Months", then the major time line in the ruler is only visible in the top half of the ruler if RulerSplit is True.

Example

[Visual Basic and Access]

Me.ctxSchedule.MajorTimeLineRuler = True

[Visual FoxPro]

thisform.ctxSchedule.MajorTimeLineRuler = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

MajorTimeLineRulerColor Property

Description

Returns/sets the color to paint the major time lines in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorTimeLineRulerColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

Setting this property to a value of -1 (default) will cause the major time line in the ruler to be painted using the current value of the RulerLineColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.MajorTimeLineRulerColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.MajorTimeLineRulerColor = RGB(0,0,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

MajorTimeLineSchedule Property

Description

Determines if a major time line will be drawn in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorTimeLineSchedule() As Boolean

Return Type

A Boolean value

Remarks

Major time lines are a form of time line that is drawn between major time segments in a schedule.

Depending on the current value of the TimeType property, the major time line will be drawn at different intervals:
Hours: It will be drawn at each midnight segment.
Days: It will be drawn at the start of each month.
Weeks: It will be drawn at the start of each week.
Months: It will be drawn every 7 days from the start of the schedule.
Years:It will be drawn every week/month/quarter, based on the current YearlyType property.

Example

[Visual Basic and Access]

Me.ctxSchedule.MajorTimeLineSchedule = True

[Visual FoxPro]

thisform.ctxSchedule.MajorTimeLineSchedule = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

MajorTimeLineScheduleColor Property

Description

Returns/sets the color to paint major time line in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorTimeLineScheduleColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.MajorTimeLineScheduleColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.MajorTimeLineScheduleColor = RGB(0,0,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

MajorTimeLineScheduleWidth Property

Description

Returns/sets the width of the major time line in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorTimeLineScheduleWidth() As Integer

Return Type

An Integer value

Example

[Visual Basic and Access]

Me.ctxSchedule.MajorTimeLineScheduleWidth = 5

[Visual FoxPro]

thisform.ctxSchedule.MajorTimeLineScheduleWidth = 5

See Also

ctxSchedule Object


%%PageItemTitle%%

MapHeight Property

Description

Returns/sets the height of the map area.

Property type

Read-write property

Syntax

Visual Basic
Public Property MapHeight() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when MapVisible is equal to True.

Example

[Visual Basic and Access]

Me.ctxSchedule.MapHeight = 30

[Visual FoxPro]

thisform.ctxSchedule.MapHeight = 30

See Also

ctxSchedule Object | Map Area


%%PageItemTitle%%

MapLineColor Property

Description

Returns/sets the color to place around the current view in the map area.

Property type

Read-write property

Syntax

Visual Basic
Public Property MapLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when MapVisible is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.MapLineColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.MapLineColor = RGB(0,0,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

MapVisible Property

Description

Determines if the map area is visible

Property type

Read-write property

Syntax

Visual Basic
Public Property MapVisible() As Boolean

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.MapVisible = True

[Visual FoxPro]

thisform.ctxSchedule.MapVisible = .T.

See Also

ctxSchedule Object | Map Area


%%PageItemTitle%%

MarkerBarColor Property

Description

Returns/sets the color of the marker bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property MarkerBarColor() As ULong

Return Type

A ULong value representing an OLE_COLOR

Remarks

This property is only applicable when MarkerBars is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.MarkerBarColor = RGB(255,0,0)

[Visual FoxPro]

thisform.ctxSchedule.MarkerBarColor = RGB(255,0,0)

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

MarkerBars Property

Description

Determines if marker bars will be visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property MarkerBars() As Boolean

Return Type

A Boolean value.

Remarks

Marker bars are drawn within the ruler area of the control. They help to identify the start and end dates/times of a time bar and they move as the time bar is being moved and resized.

Example

[Visual Basic and Access]

Me.ctxSchedule.MarkerBars = True

[Visual FoxPro]

thisform.ctxSchedule.MarkerBars = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

MaskBitmap Property

Description

Determines if a color in the images will appear transparent.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaskBitmap() As Boolean

Return Type

A Boolean value.

Remarks

The color in the images to appear transparent is defined by the MaskColor property.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.MaskColor = True

[Visual FoxPro]

thisform.ctxSchedule.MaskColor = .T.

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

MaskColor Property

Description

Returns/sets which color in the images will appear transparent.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaskColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when MaskBitmap is equal to True. In order for the color in the image to appear transparent, it must be an exact match to this property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.MaskColor = RGB(125, 125, 125)

[Visual FoxPro]

thisform.ctxSchedule.MaskColor = RGB(125, 125, 125)

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

MaxImageHeight Property

Description

Returns/sets the maximum height of a file created with the CreateJPG method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageHeight() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when the third parameter in the CreateJPG method is equal to -1. If this property is assigned a value of 0 the maximum height of the image could be as large as the system will support.

Example

[Visual Basic and Access]

Me.ctxSchedule.MaxJPGHeight = 500

[Visual FoxPro]

thisform.ctxSchedule.MaxJPGHeight = 500

See Also

ctxSchedule Object | Creating an Image of ctxSchedule


%%PageItemTitle%%

MaxImageWidth Property

Description

Returns/sets the maximum width of a file created with the CreateJPG method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxImageWidth() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when the second parameter in the CreateJPG method is equal to -1. If this property is assigned a value of 0 the maximum width of the image could be as large as the system will support.

Example

[Visual Basic and Access]

Me.ctxSchedule.MaxJPGWidth = 500

[Visual FoxPro]

thisform.ctxSchedule.MaxJPGWidth = 500

See Also

ctxSchedule Object | Creating an Image of ctxSchedule


%%PageItemTitle%%

MaxTimeBars Property
nIndex
The 1-based index value of the list item.

Description

Returns/sets the maximum number of time bars assigned to a list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxTimeBars( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the list item.

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.MaxTimeBars(1) = 5

[Visual FoxPro]

thisform.ctxSchedule.MaxTimeBars(1) = 5

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

MilitaryTime Property

Description

Determines if the ruler will display a 24 hour military time.

Property type

Read-write property

Syntax

Visual Basic
Public Property MilitaryTime() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the TimeTagAM and TimeTagPM properties will not be applied.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.MilitaryTime = True

[Visual FoxPro]

thisform.ctxSchedule.MilitaryTime = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

MonthlyType Property

Description

Returns/sets the display of the month ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthlyType() As enumMonthlyType

Return Type

An Integer value representing an enumMonthlyType member.

Remarks

This property is only applicable when TimeType is equal to 3 (month)

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.MonthlyType = 1

[Visual FoxPro]

thisform.ctxSchedule.MonthlyType = 1

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

MonthNames Property

Description

Returns/sets the month names.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonthNames() As String

Return Type

A String value

Remarks

The month names are seperated by the semi-colon. The first string represents January.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.MonthNames = "Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec"

[Visual FoxPro]

thisform.ctxSchedule.MonthNames = "Jan;Feb;Mar;Apr;May;Jun;Jul;Aug;Sep;Oct;Nov;Dec"

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteCount Property
nIndex
The 1-based index of the line item to check.

Description

Returns the total count of notes on a line item

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteCount( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the line item to check.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteDate Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the date for the note.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteDate( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Long

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Remarks

The value represents the number of days since the base date.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteImageAlign Property
nIndex
The 1-based index value of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the the alignment for a note's image when it is locked in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteImageAlign( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the line item containing the note.
nNote
The 1-based index of the note.

Remarks

Notes can only be aligned if they are locked.

valid values include:

Left = 0
Right = 1
Center = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteImageIndex Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the index value of the image to use for the note, from the internal image list.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteImageIndex( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteImageXOffset Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the horizontal offset value used to calculate the position of the note image in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteImageXOffset( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteImageYOffset Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the vertical offset value used to calculate the position of the note image in the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteImageYOffset( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Integer

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteLocked Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets if the note will be locked in the viewable area of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteLocked( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Boolean

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Remarks

The note will not appear at its assigned date/time, but will appear inside the schedule area of the parent line item, aligned to either the left/middle/right, based on its NoteImageAlign property.

See Also

ctxSchedule Object


%%PageItemTitle%%

NotesDistance Property

Description

Determines the distance between locked notes in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property NotesDistance() As Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

NotesPosition Property

Description

Determines where the notes will be drawn, relative to the Time Bars.

Property type

Read-write property

Syntax

Visual Basic
Public Property NotesPosition() As enumItemPosition

Return Type

enumItemPosition

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteText Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the text assigned to a note.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteText( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As String

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Return Type

By default the text assigned to the note is displayed inside a tool tip, when TipsOnNotes is True.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteTime Property
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Returns/sets the time for the note.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoteTime( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
) As Long

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Remarks

The value represents the number of minutes since midnight.

See Also

ctxSchedule Object


%%PageItemTitle%%

OverlapColor Property

Description

Returns/sets the overlap line color.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverlapColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applied when OverlapLines is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.OverlapColor = RGB(115,115,115)

[Visual FoxPro]

thisform.ctxSchedule.OverlapColor = RGB(115,115,115)

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

OverlapLines Property

Description

Determines if overlap lines will be displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverlapLines() As Boolean

Return Type

A Boolean value.

Remarks

When set to true, the overlap lines will appear on the top and bottom of the overlapped area.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.OverlapLines = True

[Visual FoxPro]

thisform.ctxSchedule.OverlapLines = .T.

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

OverlapTime Property

Description

Determines when an overlap between 2 time bars will occur.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverlapTime() As Integer

Return Type

An Integer value.

Remarks

This property is only applied when OverlapLines is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

By setting this property equal to 5, the overlap lines will appear when 2 times bars are 5 minutes apart.

[Visual Basic and Access]

Me.ctxSchedule.OverlapTime = 5

[Visual FoxPro]

thisform.ctxSchedule.OverlapTime = 5

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

OverlapWidth Property

Description

Determines the width of the overlap lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverlapWidth() As Integer

Return Type

An Integer value.

Remarks

This property is only applied when OverlapLines is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.OverlapWidth = 2

[Visual FoxPro]

thisform.ctxSchedule.OverlapWidth = 2

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

Page Property
nPageNum
A 0 value.

Description

Sets the horizontal thumb in the list area to a fixed width.

Property type

Read-write property

Syntax

Visual Basic
Public Property Page( _
   ByVal nPageNum As Integer _
) As Integer

Parameters

nPageNum
A 0 value.

Return Type

A Integer value, this value should always be 0.

Remarks

This property was created to address an anomly within Visual Foxpro 8 under Windows XP. The anomoly occurs when the splitter bar is moved so that the thumb is maximized, the scroll bar becomes unresponsive and does not draw correctly.

Example

[Visual FoxPro]

thisform.ctxSchedule.Page(0) = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

PageXOffset Property

Description

Returns/sets the offset value used to calculate the width of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageXOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PageXOffset = 20

[Visual FoxPro]

thisform.ctxSchedule.PageXOffset = 20

See Also

ctxSchedule Object


%%PageItemTitle%%

PageYOffset Property

Description

Returns/sets the offset value used to calculate the height of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageYOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PageYOffset = 20

[Visual FoxPro]

thisform.ctxSchedule.PageYOffset = 20

See Also

ctxSchedule Object


%%PageItemTitle%%

PicAlign Property

Description

Returns/sets the default horizontal alignment of an image within a cell in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property PicAlign() As enumAlign

Return Type

An Integer value representing an enumAlign member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PicAlign = 0

[Visual FoxPro]

thisform.ctxSchedule.PicAlign = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

PicMaxWidth Property

Description

Returns/sets the maximum width of the images displayed in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property PicMaxWidth() As Integer

Return Type

An Integer value

Remarks

When set to -1, the maximum width is determined by the actual size of image.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PicMaxWidth = 20

[Visual FoxPro]

thisform.ctxSchedule.PicMaxWidth = 20

See Also

ctxSchedule Object


%%PageItemTitle%%

PicXOffset Property

Description

Returns/sets the horizontal offset value used to calculate the position of the images within the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property PicXOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PicXOffset = 2

[Visual FoxPro]

thisform.ctxSchedule.PicXOffset = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

PicYOffset Property

Description

Returns/sets the vertical offset value used to calculate the position of the images within the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property PicYOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PicYOffset = 2

[Visual FoxPro]

thisform.ctxSchedule.PicYOffset = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnBackColor Property

Description

Returns/sets the background color of a non-selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.PreColumnBackColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnBorder Property

Description

Returns/sets the border around a non-selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnBorder() As enumBorder

Return Type

An Integer value representing an enumBorder member.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnBorder = 1

[Visual FoxPro]

thisform.ctxSchedule.PreColumnBorder = 1

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnFont Property

Description

Returns/sets the pre-column font.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnFont() As Font

Return Type

A Font object.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnFont = Ole_object.Font

or

Me.ctxSchedule.PreColumnFont.Name = "Verdana"

Me.ctxSchedule.PreColumnFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.PreColumnFont = Ole_Object.Font

or

thisform.ctxSchedule.PreColumnFont.Name = "Verdana"

thisform.ctxSchedule.PreColumnFont.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

PreColumnForeColor Property

Description

Returns/sets the foreground color of a non-selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnForeColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.PreColumnForeColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnPicture Property

Description

Returns/sets the picture of a selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnPicture() As Picture

Return Type

A Picture object.

Remarks

This property is only applied when PreColumnType is equal to 4 (Picture).

Images can be defined by using the property page or at runtime. When defining the image at run-time, the image needs to be converted to a valid picture object. Within Visual Basic, Visual Foxpro and Access, the LoadPicture method can be used to convert the image to a valid type. This property can also be defined by assigning an ole picture from another control. The image can be a bitmap, jpeg, or icon.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnPicture = LoadPicture("C:\Path to Image\Image.bmp")

or

Me.ctxSchedule.PreColumnPicture = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxSchedule.PreColumnPicture = LoadPicture("C:\Path to Image\Image.bmp")

or

thisform.ctxSchedule.PreColumnPicture = Ole_Control.Picture

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnType Property

Description

Returns/sets the type of column to display to the left of the defined columns.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnType() As enumPreColumn

Return Type

An Integer value representing an enumPreColumn member.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnType = 2

[Visual FoxPro]

thisform.ctxSchedule.PreColumnType = 2

See Also

ctxSchedule Object


%%PageItemTitle%%

PreColumnWidth Property

Description

Returns/sets the pre-column width.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreColumnWidth() As Integer

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreColumnWidth = 15

[Visual FoxPro]

thisform.ctxSchedule.PreColumnWidth = 15

See Also

ctxSchedule Object


%%PageItemTitle%%

PreSelectBackColor Property

Description

Returns/sets the background color of a selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSelectBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreSelectBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.PreSelectBackColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

PreSelectBorder Property

Description

Returns/sets the border of a selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSelectBorder() As enumBorder

Return Type

An Integer value representing an enumBorder member.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreSelectBorder = 1

[Visual FoxPro]

thisform.ctxSchedule.PreSelectBorder = 1

See Also

ctxSchedule Object


%%PageItemTitle%%

PreSelectForeColor Property

Description

Returns/sets the foreground color of a selected pre-column cell.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreSelectForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.PreSelectForeColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.PreSelectForeColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

PrintAltSchedColors Property

Description

Determines if the alternating color in the schedule area will be included in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintAltSchedColors() As Boolean

Return Type

A Boolean value.

Remarks

This property is only applicable in AltSchedColors is equal to True.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintAltSchedColors = False

[Visual FoxPro]

thisform.ctxSchedule.PrintAltSchedColors = .F.

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintColorBars Property

Description

Determines if color bars will be included in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintColorBars() As Boolean

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintColorBars = False

[Visual FoxPro]

thisform.ctxSchedule.PrintColorBars = .F.

See Also

ctxSchedule Object | Creating a Printed Report | Coloring the Background of the Schedule


%%PageItemTitle%%

PrintColumns Property

Description

Returns/sets the number of column in the list area to include in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintColumns() As Integer

Return Type

An Integer value.

Remarks

The number of columns defined in the list determines the total amount of columns. If a value of -1, or a value that is greater than that defined in the list is placed within this property, all columns in the list will be included on the report.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintColumns = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintColumns = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintDefaultPrinter Property

Description

Determines if the print operations of the control will try to use the current users default printer instead of displaying the print dialog.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintDefaultPrinter() As Boolean

Return Type

a Boolean value

Remarks

If this property is set to true, the control's printing routines will attempt to run without having to display a print dialog to the user. However, if for any reason the control is unable to properly communicate with the default printer (or if there isn't one selected), then the print dialog will still display.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintDefaultPrinter = True

[Visual FoxPro]

thisform.ctxSchedule.PrintDefaultPrinter = .T.

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintFooter Property

Description

Returns/sets the footer text in printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintFooter() As String

Return Type

A String value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintFooter = "This report is confidential"

[Visual FoxPro]

thisform.ctxSchedule.PrintFooter = "This report is confidential"

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintLandscape Property

Description

Determines if the print operations of the control will try to pre-select the landscape orientation in the print dialog before displaying it.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintLandscape() As Boolean

Return Type

A Boolean value

Remarks

When this property is set to true, the control will attempt to adjust the default orientation of the print out to be landscape before displaying the print dialog. The user will still be able to manually adjust the orientation through the dialog afterwards.

To be able to adjust the orientation, the routines will try to communicate with the current default printer, through the print dialog, before displaying it. If there for whatever reason the control is unable to properly communicate with the default printer, then the print dialog will use the users current default orientation.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintLandscape = True

[Visual FoxPro]

thisform.ctxSchedule.PrintLandscape = .T.

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageColumnFrom Property

Description

Returns/sets the starting column of pages of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageColumnFrom() As Integer

Return Type

An Integer value

Remarks

If this property is set to 0, the printed report will start with the first column of pages.

The best place to set this property is within the BeforePrint event. In that event you can use the PrintPageColumnMax property to determine the maximum horizontal pages for the current printed report, and adjust the property within the available range.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintPageColumnFrom = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintPageColumnFrom = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageColumnMax Property

Description

Returns the maximum amount of page columns a printed report will contain.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageColumnMax() As Integer

Return Type

An Integer value.

Remarks

This property is read-only.

This property will only contain a valid value during the BeforePrint event of the control.

Example

The following code would be used in the BeforePrint event.

[Visual Basic and Access]

Dim MaxColumnPage as Integer

MaxColumnPage = Me.ctxSchedule.PrintPageColumnMax

[Visual FoxPro]

MaxColumnPage = thisform.ctxSchedule.PrintPageColumnMax

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageColumnTo Property

Description

Returns/sets the ending column of pages of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageColumnTo() As Integer

Return Type

An Integer value

Remarks

If this property is set to 0, the printed report will end with the last column of pages.

The best place to set this property is within the BeforePrint event. In that event you can use the PrintPageColumnMax property to determine the maximum horizontal pages for the current printed report, and adjust the property within the available range.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintPageColumnTo = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintPageColumnTo = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageRowFrom Property

Description

Returns/sets the starting row of pages of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageRowFrom() As Integer

Return Type

An Integer value

Remarks

If this property is set to 0, the printed report will start with the first row of pages.

The best place to set this property is within the BeforePrint event. In that event you can use the PrintPageRowMax property to determine the maximum vertical pages for the current printed report, and adjust the property within the available range.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintPageRowFrom = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintPageRowFrom = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageRowMax Property

Description

Returns the maximum amount of page rows a printed report will contain.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageRowMax() As Integer

Return Type

An Integer value.

Remarks

This property is read-only.

This property will only contain a valid value during the BeforePrint event of the control.

Example

The following code would be used in the BeforePrint event.

[Visual Basic and Access]

Dim MaxRowPage as Integer

MaxRowPage = Me.ctxSchedule.PrintPageRowMax

[Visual FoxPro]

MaxRowPage = thisform.ctxSchedule.PrintPageRowMax

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageRowTo Property

Description

Returns/sets the ending row of pages of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageRowTo() As Integer

Return Type

An Integer value

Remarks

If this property is set to 0, the printed report will end with the last row of pages.

The best place to set this property is within the BeforePrint event. In that event you can use the PrintPageRowMax property to determine the maximum vertical pages for the current printed report, and adjust the property within the available range.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.PrintPageRowTo = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintPageRowTo = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintPageText Property

Description

Returns/sets the text used to describe the page in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintPageText() As String

Return Type

A String value.

Remarks

This text is displayed before the page number.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintPageText = "Page: "

[Visual FoxPro]

thisform.ctxSchedule.PrintPageText = "Page: "

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintSubTitle Property

Description

Returns/sets the sub title of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintSubTitle() As String

Return Type

A String value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintSubTitle = "Report by DBI Technologies"

[Visual FoxPro]

thisform.ctxSchedule.PrintSubTitle = "Report by DBI Technologies"

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintTimeDistance Property

Description

Returns/sets the distance between the major time units in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTimeDistance() As Integer

Return Type

An Integer value.

Remarks

This property is very similar to the TimeDistance property except that it is only used on a printed report.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintTimeDistance = 30

[Visual FoxPro]

thisform.ctxSchedule.PrintTimeDistance = 30

See Also

ctxSchedule Object | Creating a Printed Report | Setting up Schedule Views


%%PageItemTitle%%

PrintTitle Property

Description

Returns/sets the title of a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitle() As String

Return Type

A String value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintTitle = "Solutions::Schedule Report"

[Visual FoxPro]

thisform.ctxSchedule.PrintTtitle = "Solutions::Schedule Report"

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintTitleAlign Property

Description

Returns/sets the horizontal alignment of the title and sub-title in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitleAlign() As enumAlign

Return Type

A Integer value representing an enumAlign member.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintTitleAlign = 2

[Visual FoxPro]

thisform.ctxSchedule.PrintTitleAlign = 2

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintTitleFont Property

Description

Returns/sets the title font in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintTitleFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

[Visual Basic and Access]

Me.ctxSchedule.TitleFont = Ole_object.Font

or

Me.ctxSchedule.TitleFont.Name = "Verdana"

Me.ctxSchedule.TitleFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.TitleFont = Ole_Object.Font

or

thisform.ctxSchedule.TitleFont.Name = "Verdana"

thisform.ctxSchedule.TitleFont.Bold = .T.

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

PrintWeekendColor Property

Description

Determines if the weekend colors will be included in a printed report.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrintWeekendColor() As Boolean

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.PrintWeekendColor = False

[Visual FoxPro]

thisform.ctxSchedule.PrintWeekendColor = .F.

See Also

ctxSchedule Object | Creating a Printed Report | Coloring the Background of the Schedule


%%PageItemTitle%%

PropertyPages Property

Description

Allows for the display of the custom property pages in runtime.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyPages() As enumProperties

Remarks

This property is not a true property in that it does not store a value. Instead, it acts more like a method because acts it causes the property pages to appear.

Example

Me.ctxSchedule1.PropertyPages = Display

See Also

ctxSchedule Object


%%PageItemTitle%%

RulerAlign Property

Description

Returns/sets the horizontal alignment of the lower portion in the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerAlign() As enumRulerAlign

Remarks

If RulerSplit is equal to True, this property is only applied to the lower portion of the ruler.

Example

The following will set the ruler text to be above the major time divisions.

[Visual Basic and Access]

Me.ctxSchedule.RulerAlign = 0

[Visual FoxPro]

thisform.ctxSchedule.RulerAlign = 0

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerBackColor Property

Description

Returns/sets the background color of the ruler area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerBackColor() As ULong

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the ruler to white.

[Visual Basic and Access]

Me.ctxSchedule.RulerBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.RulerBackColor = RGB(255,255,255)

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerBackColorTo Property

Description

Returns/sets the secondary background color of the ruler of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerBackColorTo() As ULong

Remarks

This property is only applicable when RulerFillType is not equal to Solid (0). The primary color is defined in the RulerBackColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following will set the background color of the ruler to black.

[Visual Basic and Access]

Me.ctxSchedule.RulerBackColorTo = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.RulerBackColorTo = RGB(0,0,0)

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerBorder Property

Description

Returns/sets the type of border to place around the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerBorder() As enumBorder

Example

The following will set the ruler border to regular.

[Visual Basic and Access]

Me.ctxSchedule.RulerBorder = 0

[Visual FoxPro]

thisform.ctxSchedule.RulerBorder = 0

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerDays Property

Description

Determines if the day names will be displayed in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerDays() As Boolean

Return Type

A Boolean value

Remarks

When set to True, the day names will appear above the dates. This property is only applicable when the TimeType is equal to Days (1). The day names are defined by the DayNames property and the length of the displayed values are defined by the RulerDaySize property.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerDays = True

[Visual FoxPro]

thisform.ctxSchedule.RulerDays = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerDaySize Property

Description

Returns/sets the number of characters used to display the day names.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerDaySize() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when TimeType is equal to Days (1) or Weeks (2) and RulerDays is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerDaySize = 3

[Visual FoxPro]

thisform.ctxSchedule.RulerDaySize = 3

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerDivisions Property

Description

Returns/sets the number of divisions between major time units in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerDivisions() As Integer

Return Type

An Integer value.

Remarks

The height of the minor time line are defined by the the LineMinSize property. This property is not applicable when TimeType is equal to Years (4) and YearlyType is equal to Months (1) or Quarters (2).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerDivisions = 4

[Visual FoxPro]

thisform.ctxSchedule.RulerDivisions = 4

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerFillType Property

Description

Returns/sets the background fill pattern of the Ruler/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerFillType() As enumFillType

Return Type

An Integer value representing an enumFillType member.

Remarks

The primary and secondary background colors are defined by the RulerBackColor and RulerBackColorTo properties.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the Ruler/list header fill pattern to horizontal.

[Visual Basic and Access]

Me.ctxSchedule.RulerFillType = 1

[Visual FoxPro]

thisform.ctxSchedule.RulerFillType = 1

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerFont Property

Description

Returns/sets the default font of the Ruler/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerFont = Ole_object.Font

or

Me.ctxSchedule.RulerFont.Name = "Verdana"

Me.ctxSchedule.RulerFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.RulerFont = Ole_Object.Font

or

thisform.ctxSchedule.RulerFont.Name = "Verdana"

thisform.ctxSchedule.RulerFont.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars | Setting up the Time Ruler


%%PageItemTitle%%

RulerForeColor Property

Description

Returns/sets the foreground color of the Ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the ruler text to black.

[Visual Basic and Access]

Me.ctxSchedule.RulerForeColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.RulerForeColor = RGB(0,0,0)

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerLineColor Property

Description

Returns/sets the line colors within the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the ruler lines to black.

[Visual Basic and Access]

Me.ctxSchedule.RulerLineColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.RulerLineColor = RGB(0,0,0)

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerSplit Property

Description

Determines if the ruler will be split in half along the vertical axis of the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerSplit() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the top area text is defined by the DateFormat or RulerTitle property.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerSplit = True

[Visual FoxPro]

thisform.ctxSchedule.RulerSplit = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerText Property

Description

Returns/sets the text to appear in each time segment in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerText() As String

Return Type

A String value

Remarks

This property is only applicable when it is defined in the ValuePoint event.

Example

This event is used to interecept values being written in the ruler so that we can format them in a different way.

[Visual Basic and Access]

Private Sub ctxSchedule1_ValuePoint(ByVal nValue1 As Long, ByVal nValue2 As Long)
If Me.ctxSchedule1.TimeType = 4 Then 'Years
Select Case Me.ctxSchedule1.YearlyType
Case 1 'Months
Me.ctxSchedule1.RulerText = Left(Me.ctxSchedule1.RulerText, 3) + "."
Case 2 'Quarters
 Me.ctxSchedule1.RulerText = LTrim(Str(nValue2)) + " Qtr"
End Select
End If
End Sub

[Visual Foxpro]

*** ActiveX Control Event ***
LPARAMETERS nvalue1, nvalue2

If This.TimeType = 4 THEN &&Years
 DO CASE
CASE this.yearlyType = 1 &&Months
This.RulerText = Left(This.RulerText, 3) + "."
CASE this.yearlyType = 2 &&Quarters
This.RulerText = LTrim(Str(nValue2)) + " Qtr"
ENDCASE
ENDIF

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerThreeD Property

Description

Determines if the lines in the ruler area will be displayed with a lowered border.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerThreeD() As Boolean

Return Type

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerThreeD = True

[Visual FoxPro]

thisform.ctxSchedule.RulerThreeD = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerTitle Property

Description

Returns/sets the title text of the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerTitle() As String

Return Type

A String value.

Remarks

This property will be displayed in the top portion of the ruler area and it is only applicable when RulerSplit is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerTitle = "ctxSchedule Title"

[Visual FoxPro]

thisform.ctxSchedule.RulerTitle = "ctxSchedule Title"

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerTitleBackColor Property

Description

Determines the primary background color used to paint the ruler title area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerTitleBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will only be used in the top portion of the ruler area and it is only applicable when RulerSplit is equal to True.

See Also

ctxSchedule Object


%%PageItemTitle%%

RulerTitleBackColorTo Property

Description

Determines the secondary background color used to paint the ruler title area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerTitleBackColorTo() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will only be used in the top portion of the ruler area and it is only applicable when RulerSplit is equal to True, when RulerTitleFillType is not equal to Solid (0) and RulerTitleBackColor is assigned a valid color. The primary color is defined in the RulerTitleBackColor property.

See Also

ctxSchedule Object


%%PageItemTitle%%

RulerTitleFillType Property

Description

Determines the background fill pattern of the ruler title area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerTitleFillType() As enumFillType

Return Type

An Integer value representing an enumFillType member.

Remarks

This property will only be used in the top portion of the ruler area and it is only applicable when RulerSplit is equal to True, and RulerTitleBackColor is assigned a valid color.

The primary and secondary background colors are defined by the RulerTitleBackColor and RulerTitleBackColorTo properties.

See Also

ctxSchedule Object


%%PageItemTitle%%

RulerTitleForeColor Property

Description

Determines the text color used in the ruler title area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerTitleForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property will only be used in the top portion of the ruler area and it is only applicable when RulerSplit is equal to True.

See Also

ctxSchedule Object


%%PageItemTitle%%

RulerXOffset Property

Description

Returns/sets the horizontal offset value used to calculate the position of the text in the Ruler/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerXOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerXOffset = 3

[Visual FoxPro]

thisform.ctxSchedule.RulerXOffset = 3

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

RulerYOffset Property

Description

Returns/sets the vertical offset value used to calculate the position of the text in the Ruler/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property RulerYOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.RulerYOffset = 3

[Visual FoxPro]

thisform.ctxSchedule.RulerYOffset = 3

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

SchedHeaderBackColor Property

Description

Returns/sets the background color that will display on the schedule area for a header item.

Property type

Read-write property

Syntax

Visual Basic
Public Property SchedHeaderBackColor() As ULong

Return Type

A ULong representing an OLE_COLOR

Remarks

Will be overridden by the WeekendColor Property.

See Also

ctxSchedule Object | Adding and Customizing List Items


%%PageItemTitle%%

SchedScroll Property

Description

Returns/sets thevalue of the horizontal scroll bar in the schedule area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property SchedScroll() As Integer

Return Type

An Integer value.

Remarks

This property is useful when you do not want to initially display the schedule at its starting time or date.

Example

[Visual Basic and Access]

Me.ctxSchedule.SchedScroll = 4

[Visual FoxPro]

thisform.ctxSchedule.SchedScroll = 4

See Also

ctxSchedule Object


%%PageItemTitle%%

SchedSelectBackColor Property

Description

Returns/sets the background color of the schedule area for the selected list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property SchedSelectBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Assigning a value of -1 to this property will tell the control to ignore it.

Example

[Visual Basic and Access]

Me.ctxSchedule.SchedSelectBackColor = RGB(0,255,0)

[Visual FoxPro]

thisform.ctxSchedule.SchedSelectBackColor = RGB(0,255,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

SelectBackColor Property

Description

Returns/sets the background color of the selected list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.SelectBackColor = RGB(0,255,0)

[Visual FoxPro]

thisform.ctxSchedule.SelectBackColor = RGB(0,255,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

Selected Property

Description

Returns/sets the selected list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected() As Integer

Return Type

An Integer value.

Remarks

This property is identical to the ListIndex property. A value of 0 indicates that no item is selected.

Example

The following will select the second item in the list area.

[Visual Basic and Access]

Me.ctxSchedule.Selected = 2

[Visual FoxPro]

thisform.ctxSchedule.Selected = 2

See Also

ctxSchedule Object | Selecting and Searching for Time Bars


%%PageItemTitle%%

SelectForeColor Property

Description

Returns/sets the foreground color of the selected list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.SelectForeColor = RGB(0,255,0)

[Visual FoxPro]

thisform.ctxSchedule.SelectForeColor = RGB(0,255,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

SmallIcons Property

Description

Determines the size of the icons in the list area.

Property type

Read-write property

Syntax

Visual Basic
Public Property SmallIcons() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, the icons will appear in a 16x16 format, else the icons will appear in a 32x32 format.

Example

[Visual Basic and Access]

Me.ctxSchedule.SmallIcons = True

[Visual FoxPro]

thisform.ctxSchedule.SmallIcons = .T.

See Also

ctxSchedule Object


%%PageItemTitle%%

SnapToGrid Property

Description

Determines if the time bars will be aligned to the control using the GridFrequency property.

Property type

Read-write property

Syntax

Visual Basic
Public Property SnapToGrid() As Boolean

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.SnapToGrid = True

[Visual FoxPro]

thisform.ctxSchedule.SnapToGrid = .T.

See Also

ctxSchedule Object | Setting up Schedule Views


%%PageItemTitle%%

SnapToGuideLines Property

Description

Enables the TimeBars to snap to the GuideLines.

Property type

Read-write property

Syntax

Visual Basic
Public Property SnapToGuideLines() As Boolean

Return Type

Boolean

Remarks

Occurs when moving or sizing a TimeBar. Please note that when adding a timebar, the initial starting point will not snap to the GuideLine, only the end point. Also be aware that using the SnapToGuideLine in conjunction with the SnapToGrid Property may cause undesired effects. We recommend disabling SnapToGrid when using SnapToGuideLines or take precautions in setting the GridFrequency Property.

See Also

ctxSchedule Object


%%PageItemTitle%%

StartWeekDay Property

Description

Determine the first day of the week.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartWeekDay() As enumDayStart

Return Type

An Integer value representing an enumDayStart member.

Remarks

This property is only applied when TimeType is equal to Weeks (2).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.StartWeekDay = 1

[Visual FoxPro]

thisform.ctxSchedule.StartWeekDay = 1

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

StyleBackColor Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the background color of a time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleBackColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the style.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleBackColor(1) = RGB(0,255,0)

[Visual FoxPro]

thisform.ctxSchedule.StyleBackColor(1) = RGB(0,255,0)

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleBackColorTo Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the secondary background color (fill color) of a time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleBackColorTo( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the style.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when the FillType used is not equal to Solid (0).

If a value of -1 is supplied to this property, it will be ignored.

See Also

ctxSchedule Object


%%PageItemTitle%%

StyleBarHeight Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the height of the time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleBarHeight( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleBarHeight(1) = 30

[Visual FoxPro]

thisform.ctxSchedule.StyleBarHeight(1) = 30

See Also

ctxSchedule Object


%%PageItemTitle%%

StyleBorderColor Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the border color of the time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleBorderColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the style.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleBorderColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.StyleBorderColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

StyleBrushType Property
nIndex
1-based index of the Style.

Description

Returns/sets the pattern brush for the time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleBrushType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
1-based index of the Style.

Return Type

Integer

Remarks

This information used to be stored in the StyleFillType Property.

See Also

ctxSchedule Object


%%PageItemTitle%%

StyleCount Property

Description

Returns the number of time bar styles stored in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleCount() As Integer

Return Type

An Integer value.

Example

This property is read-only and available at run-time.

[Visual Basic and Access]

Dim intCount as Integer

intCount = Me.ctxSchedule.StyleCount

[Visual FoxPro]

intCount = thisform.ctxSchedule.StyleCount

See Also

ctxSchedule Object


%%PageItemTitle%%

StyleEndFront Property
nIndex
The 1-based index value of the style.

Description

Determines if the end image will be placed in front or behind the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleEndFront( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the style.

Return Type

A Boolean value.

Remarks

When set to True, the image will be placed in front of the time bar. The end image is defined by the StyleEndImage property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleEndFront(1) = True

[Visual FoxPro]

thisform.ctxSchedule.StyleEndFront(1) = .T.

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleEndImage Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the image to place at the end of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleEndImage( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A negative integer will use a stock image which is built into the control, a positive integer will use an image assigned to the internal image list.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleEndImage(1) = -3

[Visual FoxPro]

thisform.ctxSchedule.StyleEndImage(1) = -3

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleEndXOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the horizontal position of the end image of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleEndXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar end image horizontally in the host item. The vertical offset value is determined by the StyleEndYOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleEndXOffset(1) = 3

[Visual FoxPro]

thisform.ctxSchedule.StyleEndXOffset(1) = 3

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleEndYOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the vertical position of the end image of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleEndYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar end image vertically in the host item. The horizontal offset value is determined by the StyleEndXOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleEndYOffset(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.StyleEndYOffset(1) = 2

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleFillType Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the gradient fill for the time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleFillType( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

The new gradient fills replace the brush styles in previous versions, those can still be used by setting the StyleBrushType Property.

If the following FillTypes are used on TimeBars, then the Border of the TimeBar will not be drawn:
FillDiagonal
FillRevDiagonal
FillDiamond
FillCircle
FillEllipse

Example

The following will set the fill pattern to gradient.

[Visual Basic and Access]

Me.ctxSchedule.StyleFillType(1) = 1

[Visual FoxPro]

thisform.ctxSchedule.StyleFillType(1) = 1

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleFont Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the font of the time bar style.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleFont( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleFont(1) = 0

[Visual FoxPro]

thisform.ctxSchedule.StyleFont(1) = 0

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

StyleForeColor Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the foreground color of a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleForeColor( _
   ByVal nIndex As Integer _
) As ULong

Parameters

nIndex
The 1-based index value of the style.

Return Type

A ULong value representing an OLE_COLOR.

Remarks

If a value of -1 is supplied to this property, it will be ignored.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleForeColor(1) = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.StyleForeColor(1) = RGB(255,255,255)

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleMilestone Property
nIndex
The 1-based index value of the style.

Description

Determines if the time bar style will display a milestone marker or a standard time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleMilestone( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the style.

Return Type

A Boolean value.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleMilestone(1) = True

[Visual FoxPro]

thisform.ctxSchedule.StyleMilestone(1) = .T.

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleStartFront Property
nIndex
The 1-based index value of the style.

Description

Determines if the start image will be placed in front or behind the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleStartFront( _
   ByVal nIndex As Integer _
) As Boolean

Parameters

nIndex
The 1-based index value of the style.

Return Type

A Boolean value.

Remarks

When set to True, the image will be placed in front of the time bar. The start image is defined by the StyleStartImage property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleStartFront(1) = True

[Visual FoxPro]

thisform.ctxSchedule.StyleStartFront(1) = .T.

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleStartImage Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the image to place at the start of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleStartImage( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A negative integer will use a stock image which is built into the control, a positive integer will use an image assigned to the internal image list.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleStartImage(1) = -3

[Visual FoxPro]

thisform.ctxSchedule.StyleStartImage(1) = -3

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleStartXOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the horizontal position of the start image of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleStartXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar start image horizontally in the host item. The vertical offset value is determined by the StyleStartYOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleStartXOffset(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.StyleStartXOffset(1) = 2

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleStartYOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the vertical position of the start image of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleStartYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar start image vertically in the host item. The horizontal offset value is determined by the StyleStartXOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleStartYOffset(1) = 2

[Visual FoxPro]

thisform.ctxSchedule.StyleStartYOffset(1) = 2

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleTextXOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the horizontal position of the text in the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleTextXOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar text horizontally in the host item. The vertical offset value is determined by the StyleTextYOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleTextXOffset(1) = 5

[Visual FoxPro]

thisform.ctxSchedule.StyleTextXOffset(1) = 5

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleTextYOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the vertical position of the text in the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleTextYOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value.

Remarks

A value of 0 will center the time bar text vertically in the host item. The horizontal offset value is determined by the StyleTextXOffset property.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleTextYOffset(1) = 5

[Visual FoxPro]

thisform.ctxSchedule.StyleTextYOffset(1) = 5

See Also

ctxSchedule Object | Creating Time Bar Styles


%%PageItemTitle%%

StyleVOffset Property
nIndex
The 1-based index value of the style.

Description

Returns/sets the offset used to calulate the vertical position of the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property StyleVOffset( _
   ByVal nIndex As Integer _
) As Integer

Parameters

nIndex
The 1-based index value of the style.

Return Type

An Integer value

Remarks

A value of 0 will center the time bar in the host item.

Example

[Visual Basic and Access]

Me.ctxSchedule.StyleVOffset(1) = -5

[Visual FoxPro]

thisform.ctxSchedule.StyleVOffset(1) = -5

See Also

ctxSchedule Object


%%PageItemTitle%%

TextIntoView Property

Description

Determines if the time bar text will always be displayed within the time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property TextIntoView() As Boolean

Return Type

A Boolean value.

Remarks

When set the True, the time bar text will always be displayed with the time bar. If only part of the time bar is displayed, the bar text will move to ensure that it is visible.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TextIntoView = True

[Visual FoxPro]

thisform.ctxSchedule.TextIntoView = .T.

See Also

ctxSchedule Object | An Overview of a Time Bar


%%PageItemTitle%%

TimeBarHeight Property

Description

Returns/sets the default height for time bars drawn in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBarHeight() As Integer

Remarks

This value represents the number of pixels the time bars should be.

See Also

ctxSchedule Object


%%PageItemTitle%%

TimeBarImage Property

Description

The TimeBar Picture to use in the UserDrawnBar Event .

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBarImage() As Picture

Return Type

OlePicture

Remarks

This property will only be used during runtime, setting it in the designer will have no effect.

In order to use the UserDrawnTimebar functionality, you must have UserDrawnBar Property = true.

For more information on UserDrawnTimebars see the developing with for UserDrawnTimebars.

See Also

ctxSchedule Object

Developing With

UserDrawn Timebars


%%PageItemTitle%%

TimeBarShadows Property

Description

Determine if default timebars will be drawn with a shadow effect.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBarShadows() As Boolean

Return Type

Boolean

Remarks

Will not be drawn with BarStyles applied or with userdrawn timebars enabled.

See Also

ctxSchedule Object

Developing With

An Overview of a Timebar


%%PageItemTitle%%

TimeBarVOffset Property

Description

Returns/sets the default vertical offset for time bars drawn in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeBarVOffset() As Integer

Remarks

The default value is, which centers the time bars in the items. A negative value moves them higher, a positive value lowers them.

See Also

ctxSchedule Object


%%PageItemTitle%%

TimeDistance Property

Description

Returns/sets the distance between the major time units in the ruler area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeDistance() As Integer

Return Type

An Integer value.

Remarks

When TimeType is equal to Hours, Days or Weeks, this property sets the distance between the major time units. When TimeType is set to Months or Years, this property sets the distance between days.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeDistance = 60

[Visual FoxPro]

thisform.ctxSchedule.TimeDistance = 60

See Also

ctxSchedule Object | Setting up the Time Ruler | Setting up Schedule Views


%%PageItemTitle%%

TimeEnd Property

Description

Returns/sets the end time of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeEnd() As Long

Return Type

An Integer value.

Remarks

This property is only applicable when TimeType is equal to Hours. If TimeType is not equal to hours, the display will always be 12:00 am.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the end time to 5:00 pm

[Visual Basic and Access]

Me.ctxSchedule.TimeEnd = 1020

[Visual FoxPro]

thisform.ctxSchedule.TimeEnd = 1020

See Also

ctxSchedule Object


%%PageItemTitle%%

TimeLineBreak Property

Description

Returns/sets the frequency of the time lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeLineBreak() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when TimeLines is equal to True. By default, the time lines are displayed for every major time unit.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will display a time line for every second major time unit.

[Visual Basic and Access]

Me.ctxSchedule.TimeLineBreak = 2

[Visual FoxPro]

thisform.ctxSchedule.TimeLineBreak = 2

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TimeLineColor Property

Description

Returns/sets the color of the time lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when TimeLines is equal to True.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeLineColor = RGB(255,0,0)

[Visual FoxPro]

thisform.ctxSchedule.TimeLineColor = RGB(255,0,0)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TimeLines Property

Description

Determines if time lines will be displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeLines() As Boolean

Return Type

A Boolean value.

Remarks

When set to True, a time line frequency is determined by TimeLineBreak.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeLines = True

[Visual FoxPro]

thisform.ctxSchedule.TimeLines = .T.

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TimeLineStart Property

Description

Returns/sets the first major time unit to display a time line.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeLineStart() As Long

Return Type

An Integer value.

Remarks

This property is only applicable when TimeLines is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will display the first time line on the second major unit

[Visual Basic and Access]

Me.ctxSchedule.TimeLineStart = 2

[Visual FoxPro]

thisform.ctxSchedule.TimeLineStart = 2

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TimeLineWidth Property

Description

Returns/sets the style of the time lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeLineWidth() As enumLineType

Return Type

An Integer value representing an enumLineType member.

Remarks

This property is only applicable when TimeLines is equal to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeLineWidth = 0

[Visual FoxPro]

thisform.ctxSchedule.TimeLineWidth = 0

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TimeStart Property

Description

Returns/sets the start time of the schedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeStart() As Long

Return Type

An Integer value.

Remarks

This property is only applicable when TimeType is equal to Hours. If TimeType is not equal to hours, the display will always be 12:00 am.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the start time to 8:00 am

[Visual Basic and Access]

Me.ctxSchedule.TimeStart = 480

[Visual FoxPro]

thisform.ctxSchedule.TimeStart = 480

See Also

ctxSchedule Object


%%PageItemTitle%%

TimeTagAM Property

Description

Returns/sets the morning or AM tag used to format a time value within the lower portion of the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeTagAM() As String

Return Type

A String value.

Remarks

This property is only applicable when TimeType is equal to 0 (Hours) and IncludeAMPM is set to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeTagAM = "am"

[Visual FoxPro]

thisform.ctxSchedule.TimeTagAM = "am"

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

TimeTagPM Property

Description

Returns/sets the evening or PM tag used to format a time value within the lower portion of the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeTagPM() As String

Return Type

A String value.

Remarks

This property is only applicable when TimeType is equal to 0 (Hours) and IncludeAMPM is set to True.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeTagPM = "pm"

[Visual FoxPro]

thisform.ctxSchedule.TimeTagPM = "pm"

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

TimeType Property

Description

Returns/sets the type of units to display in the ruler of ctxSchedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeType() As enumTimeType

Return Type

An Integer value representing an enumTimeType member.

Remarks

The MonthlyType and YearlyType properties indicate how the rulers are displayed when the TimeType is equal to Months and Years.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TimeType = 1

[Visual FoxPro]

thisform.ctxSchedule.TimeType = 1

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

TipsBackColor Property

Description

Returns/sets the background color of the tool tips.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the background color of the tips to white.

[Visual Basic and Access]

Me.ctxSchedule.TipsBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.TipsBackColor = RGB(255,255,255)

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsDelay Property

Description

Returns/sets the initial delay between the mouse moving over a time bar, and the tool tip becoming visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsDelay() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TipsDelay = 5

[Visual FoxPro]

thisform.ctxSchedule.TipsDelay = 5

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsDistance Property

Description

Returns/sets the distance between the tool tip and vertical scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsDistance() As Integer

Return Type

An Integer value.

Remarks

This property is only applied to the tool tips on the vertical scroll bar.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TipsDistance = 5

[Visual FoxPro]

thisform.ctxSchedule.TipsDistance = 5

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsFont Property

Description

Returns/sets the tool tips font.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TipsFont = Ole_object.Font

or

Me.ctxSchedule.TipsFont.Name = "Verdana"

Me.ctxSchedule.TipsFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.TipsFont = Ole_Object.Font

or

thisform.ctxSchedule.TipsFont.Name = "Verdana"

thisform.ctxSchedule.TipsFont.Bold = .T.

See Also

ctxSchedule Object | Displaying Tool Tips | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

TipsForeColor Property

Description

Returns/sets the fore ground color of the tool tips.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the background color of the tips to black.

[Visual Basic and Access]

Me.ctxSchedule.TipsForeColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.TipsForeColor = RGB(0,0,0)

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsOnNotes Property

Description

Returns/sets if tool tips will be displayed when the mouse hovers over a note.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsOnNotes() As Boolean

Remarks

The default tool tip text, is the NoteText property value.

See Also

ctxSchedule Object


%%PageItemTitle%%

TipsOnOverBar Property

Description

Returns/sets if tool tips will be displayed when the mouse hovers over a time bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsOnOverBar() As Boolean

Remarks

The default value of the tool tip is the BarText property value.

This property used to be part of the TipsType property. However, that property has been deprecated, and replaced with individual Tips properties.

See Also

ctxSchedule Object


%%PageItemTitle%%

TipsOnVScroll Property

Description

Returns/sets if tool tips will be displayed when the mouse drags the vertical scroll thumb.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsOnVScroll() As Boolean

Remarks

The default text is the index of the item being scrolled to.

This property used to be part of the TipsType property. However, that property has been deprecated, and replaced with individual Tips properties.

See Also

ctxSchedule Object


%%PageItemTitle%%

TipsPosition Property

Description

Returns/sets the position of the tool tips when the vertical scroll bar is moved.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsPosition() As enumTipsPosn

Return Type

An Integer value representing an enumTipsPosn member.

Remarks

This property is only applied to the tool tips on the vertical scroll bar.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the tips to be displayed on the left side of the vertical scroll bar.

[Visual Basic and Access]

Me.ctxSchedule.TipsPosition = 0

[Visual FoxPro]

thisform.ctxSchedule.TipsPosition = 0

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsText Property

Description

Sets the tool tip text.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsText() As String

Return Type

A String value.

Remarks

By default, the tool tip text is set to the veritcal scroll bar position or the text of the time bar. This property allows the developer to customize the text and it is only applicable when used in the SetTips event.

Example

[Visual Basic and Access]

Me.ctxSchedule.TipsText = "Time Bar Tip"

[Visual FoxPro]

thisform.ctxSchedule.TipsText = "Time Bar Tip"

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TipsTextAlign Property

Description

Returns/sets the horizontal alignment of a tool tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipsTextAlign() As enumAlign

Return Type

An Integer value representing an enumAlign member.

Remarks

This property is only applicable when tool tips span multiple lines.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the tips to be left justified.

[Visual Basic and Access]

Me.ctxSchedule.TipsTextAlign = 0

[Visual FoxPro]

thisform.ctxSchedule.TipsTextAlign = 0

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

TitleAlign Property

Description

Returns/sets the horizontal alignment of the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleAlign() As enumAlign

Return Type

An Integer value representing an enumAlign member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header text to be left justified.

[Visual Basic and Access]

Me.ctxSchedule.TitleAlign = 0

[Visual FoxPro]

thisform.ctxSchedule.TitleAlign = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleBackColor Property

Description

Returns/sets the background color of the title/list header area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the background color of the title/list header to white.

[Visual Basic and Access]

Me.ctxSchedule.TitleBackColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.TitleBackColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleBackColorTo Property

Description

Returns/sets the secondary background color of the title/list header area of the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBackColorTo() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

This property is only applicable when TitleFillType is not equal to Solid (0). The primary color is defined in the TitleBackColor property.

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the secondary background color of the title/list header to black.

[Visual Basic and Access]

Me.ctxSchedule.TitleBackColorTo = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.TitleBackColorTo = RGB(0,0,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleBorder Property

Description

Returns/sets the type of border to place around the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleBorder() As enumBorder

Return Type

An Integer value representing an enumBorder member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header to regular.

[Visual Basic and Access]

Me.ctxSchedule.TitleBorder = 0

[Visual FoxPro]

thisform.ctxSchedule.TitleBorder = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleFillType Property

Description

Returns/sets the background fill patter of the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleFillType() As enumFillType

Return Type

An Integer value representing an enumFillType member.

Remarks

The primary and secondary background colors are defined by the TitleBackColor and TitleBackColorTo properties.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header fill pattern to horizontal.

[Visual Basic and Access]

Me.ctxSchedule.TitleFillType = 1

[Visual FoxPro]

thisform.ctxSchedule.TitleFillType = 1

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleFont Property

Description

Returns/sets the default font of the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleFont() As Font

Return Type

A Font object.

Remarks

This property must be set using the font property page of the control, by using the property table of the host language (if available), or by assigning a font from another control with the same font type.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TitleFont = Ole_object.Font

or

Me.ctxSchedule.TitleFont.Name = "Verdana"

Me.ctxSchedule.TitleFont.Bold = True

[Visual FoxPro]

thisform.ctxSchedule.TitleFont = Ole_Object.Font

or

thisform.ctxSchedule.TitleFont.Name = "Verdana"

thisform.ctxSchedule.TitleFont.Bold = .T.

See Also

ctxSchedule Object | Assigning Fonts to List Items and Time Bars


%%PageItemTitle%%

TitleForeColor Property

Description

Returns/sets the foreground color of the title.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header text to black.

[Visual Basic and Access]

Me.ctxSchedule.TitleForeColor = RGB(0,0,0)

[Visual FoxPro]

thisform.ctxSchedule.TitleForeColor = RGB(0,0,0)

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleHeight Property

Description

Returns/sets the height of the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleHeight() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header height to 40 pixels.

[Visual Basic and Access]

Me.ctxSchedule.TitleHeight = 40

[Visual FoxPro]

thisform.ctxSchedule.TitleHeight = 40

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleOverBackColor Property

Description

Returns/sets the background color of the column header as the mouse moves over it.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleOverBackColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TitleOverBackColor = RGB(120,45,230)

[Visual FoxPro]

thisform.ctxSchedule.TitleOverBackColor = RGB(120,45,230)

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleOverForeColor Property

Description

Returns/sets the foreground color of the column header as the mouse moves over it.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleOverForeColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TitleOverForeColor = RGB(255,255,255)

[Visual FoxPro]

thisform.ctxSchedule.TitleOverForeColor = RGB(255,255,255)

See Also

ctxSchedule Object


%%PageItemTitle%%

TitlePosition Property

Description

Returns/sets the vertical alignment of the title/list header text.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitlePosition() As enumPosition

Return Type

An Integer value representing an enumPosition member.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set the title/list header text to be top justified

[Visual Basic and Access]

Me.ctxSchedule.TitlePosition = 0

[Visual FoxPro]

thisform.ctxSchedule.TitlePosition = 0

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleStyle Property

Description

Determines the style of the title/ header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleStyle() As enumTitleStyle

Return Type

An Integer value representing an enumTitleStyle member.

Remarks

When this property is equal to Standard (0), the TitleBorder property is applied, else the area will appear flat.

Example

[Visual Basic and Access]

Me.ctxSchedule.TitleStyle = 1

[Visual FoxPro]

thisform.ctxSchedule.TitleStyle = 1

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleXOffset Property

Description

Returns/sets the horizontal offset value used to calculate the position of the text in the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleXOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TitleXOffset = 3

[Visual FoxPro]

thisform.ctxSchedule.TitleXOffset = 3

See Also

ctxSchedule Object


%%PageItemTitle%%

TitleYOffset Property

Description

Returns/sets the vertical offset value used to calculate the position of the text in the title/list header area.

Property type

Read-write property

Syntax

Visual Basic
Public Property TitleYOffset() As Integer

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TitleYOffset = -2

[Visual FoxPro]

thisform.ctxSchedule.TitleYOffset = -2

See Also

ctxSchedule Object


%%PageItemTitle%%

TodayLine Property

Description

Determines if a vertical line will be displayed for the current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayLine() As Boolean

Return Type

A Boolean value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TodayLine = True

[Visual FoxPro]

thisform.ctxSchedule.TodayLine = .T.

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TodayLineColor Property

Description

Returns/sets the color of the line representing the current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayLineColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TodayLineColor = RGB(10,200,150)

[Visual FoxPro]

thisform.ctxSchedule.TodayLineColor = RGB(10,200,150)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TodayLineSize Property

Description

Returns/sets the width of the line representing the current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayLineSize() As Integer

Return Type

An Integer value.

Remarks

This property is only applicable when TodayLineWidth is equal to 0 (Solid).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TodayLineSize = 3

[Visual FoxPro]

thisform.ctxSchedule.TodayLineSize = 3

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TodayLineWidth Property

Description

Returns/sets the style of the line representing the current date.

Property type

Read-write property

Syntax

Visual Basic
Public Property TodayLineWidth() As enumLineType

Return Type

An Integer value.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.TodayLineWidth = 0

[Visual FoxPro]

thisform.ctxSchedule.TodayLineWidth = 0

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

TopRow Property

Description

Returns/sets the top visible row in the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property TopRow() As Integer

Return Type

An Integer value

Remarks

If the value assigned to this property is near the bottom of available items, the top row will be set so that the item is still visible, even if it is not possible to make the top row the same value as it is assigned. The maximum value for the top row is the total number of items minus the lines per list.

Example

[Visual Basic and Access]

Me.ctxSchedule.TopRow = 10

[Visual FoxPro]

thisform.ctxSchedule.TopRow = 10

See Also

ctxSchedule Object


%%PageItemTitle%%

UndoType Property

Description

Gets the type of undo/redo action performed on the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property UndoType() As Integer

Return Type

An Integer value.

Remarks

This property is read-only.

Example

[Visual Basic and Access]

Dim intUndoType as Integer

intUndoType = Me.ctxSchedule.UndoType

[Visual FoxPro]

intUndoType = thisform.ctxSchedule.UndoType

See Also

ctxSchedule Object | Undo/Redo Features


%%PageItemTitle%%

UsePreLoad Property

Description

Determines how the data is loaded into the control.

Property type

Read-write property

Syntax

Visual Basic
Public Property UsePreLoad() As Boolean

Return Type

A Boolean value.

Remarks

When set to False, all the list items will be added on the initial load. When set to True, the items are loaded as it comes into view.

Example

[Visual Basic and Access]

Me.ctxSchedule.UsePreLoad = False

[Visual FoxPro]

thisform.ctxSchedule.UsePreLoad = .F.

See Also

ctxSchedule Object


%%PageItemTitle%%

UserDrawnBar Property

Description

Determines if the timebar drawing will be handled by the developer.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDrawnBar() As Boolean

Return Type

Boolean

Remarks

For more information see the developing with topic UserDrawn Timebars.

This property is reset to its default value, and must be re-assigned a value, every time the UserDrawnBar event fires.

See Also

ctxSchedule Object

Developing With

UserDrawn Timebars


%%PageItemTitle%%

VertScrollLargeChange Property

Description

Returns/sets the override for the large change of the vertical scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollLargeChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Large Changes occur when the user clicks in an empty part of the scroll bar, or presses the PageUp/PageDown keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

VertScrollMax Property

Description

Returns the max scroll value of the vertical scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollMax() As Integer

Return Type

Integer

See Also

ctxSchedule Object


%%PageItemTitle%%

VertScrollSmallChange Property

Description

Returns/sets the override for the small change of the vertical scroll bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property VertScrollSmallChange() As Integer

Return Type

Integer

Remarks

A value of 0 indicates that the control will use its defaults.

Small Changes occur when the user clicks an arrow button of the scroll bar, or presses the Arrow keys when the scroll bar has focus.

See Also

ctxSchedule Object


%%PageItemTitle%%

WeekendColor Property

Description

Returns/sets the background color of the weekend columns in the schedule area.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekendColor() As ULong

Return Type

A ULong value representing an OLE_COLOR.

Remarks

The OLE_COLOR data type is internally represented as a 32-bit long integer. However, what makes OLE_COLOR data type unique is that when a property of this type is selected, Visual Basic displays the color palette in the Visual Basic property window and accepts a selection, the same way that the color palette is displayed for the BackColor property of a Form.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.WeekendColor = RGB(0,0,255)

[Visual FoxPro]

thisform.ctxSchedule.WeekendColor = RGB(0,0,255)

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

WeekendDates Property

Description

Determines if weekend dates will be displayed in the ruler.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeekendDates() As Boolean

Return Type

A Boolean value.

Remarks

This property is only applicable when TimeType is equal to Days (1) or Weeks (2).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.WeekendDates = True

[Visual FoxPro]

thisform.ctxSchedule.WeekendDates = .T.

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

Weekends Property

Description

Returns/sets which days of the week will be considered weekend days.

Property type

Read-write property

Syntax

Visual Basic
Public Property Weekends() As Integer

Return Type

An Integer value.

Remarks

The weekends are determined by the bits within an integer value. Each day of the week is assigned one of those bits. To mark a day as a weekend, add up the bit value and assign it to this property

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

The following will set Saturday and Sunday as weekend dates (64 + 1)

[Visual Basic and Access]

Me.ctxSchedule.Weekends = 65

[Visual FoxPro]

thisform.ctxSchedule.Weekends = 65

See Also

ctxSchedule Object | Coloring the Background of the Schedule


%%PageItemTitle%%

XMLRead Property

Description

Returns/sets an XML file to read into ctxSchedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property XMLRead() As String

Return Type

A String value indicating the xml file to read.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.XMLRead = "C:\ctxScheduleData.xml"

[Visual FoxPro]

thisform.ctxSchedule.XMLRead = "C:\ctxScheduleData.xml"

See Also

ctxSchedule Object


%%PageItemTitle%%

XMLWrite Property

Description

Returns/sets an XML file to write the data from ctxSchedule.

Property type

Read-write property

Syntax

Visual Basic
Public Property XMLWrite() As String

Return Type

A String value indicating the xml file to write to.

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.XMLWrite = "C:\ctxScheduleData.xml"

[Visual FoxPro]

thisform.ctxSchedule.XMLWrite = "C:\ctxScheduleData.xml"

See Also

ctxSchedule Object


%%PageItemTitle%%

YearlyType Property

Description

Returns/sets how a yearly ruler is displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property YearlyType() As enumYearlyType

Return Type

An Integer value representing an enumYearlyType member.

Remarks

This property is only applied when TimeType is equal to Year (4).

Example

The following illustrates how to set this property programmatically. This property can also be set at design time using the property inspector window.

NOTE: Setting property values of an object programmatically in code is recommended to improve code readability and make it easier to update the application with newer versions of an object.

[Visual Basic and Access]

Me.ctxSchedule.YearlyType = 1

[Visual FoxPro]

thisform.ctxSchedule.YearlyType = 1

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

BarAdded Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
bMouseBar
A Boolean; true if the time bar is created with the mouse, false if created programmatically.
bKeyedBar
A Boolean; true if the BarKeyID is defined programmatically, false if automatically generated.

Description

Occurs when a new time bar is added to the control.

Syntax

Visual Basic
Public Event BarAdded( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal bMouseBar As Boolean, _
   ByVal bKeyedBar As Boolean _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
bMouseBar
A Boolean; true if the time bar is created with the mouse, false if created programmatically.
bKeyedBar
A Boolean; true if the BarKeyID is defined programmatically, false if automatically generated.

Remarks

If bMouseBar is equal to true, the time bar was created using the mouse.

if bKeyedBar is equal to true, the time bar was added with the AddKeyTimeBar method.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarChanged Event
nIndex
The 1-based index value of the schedule item containg the time bar.
nBar
The 1-based index value of the time bar.
cKeyID
A String value indicating the KeyID of the time bar.
lTimeStart
An Integer value indicating the new start time of the time bar.
lTimeEnd
An Integer value indicating the new end time of the time bar.
lDateStart
An Integer value indicating the new start date of the time bar.
lDateEnd
An Integer value indicating the new end date of the time bar.

Description

Occurs after a time bar has been moved or sized horizontally.

Syntax

Visual Basic
Public Event BarChanged( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal cKeyID As String, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long _
)

Parameters

nIndex
The 1-based index value of the schedule item containg the time bar.
nBar
The 1-based index value of the time bar.
cKeyID
A String value indicating the KeyID of the time bar.
lTimeStart
An Integer value indicating the new start time of the time bar.
lTimeEnd
An Integer value indicating the new end time of the time bar.
lDateStart
An Integer value indicating the new start date of the time bar.
lDateEnd
An Integer value indicating the new end date of the time bar.

Remarks

This event will fire when the BarDateStart, BarDateEnd, BarTimeStart or BarTimeEnd property is changed. These property can be changed programmatically or via user interaction. If a time bar is moved vertically and horizontally the BarChanged event will fire, followed by the BarVertMove event.

The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

See Also

ctxSchedule Object | Moving Time Bars Vertically | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarDblClick Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when a time bar is double clicked with the left mouse.

Syntax

Visual Basic
Public Event BarDblClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

If a form is being called from this event, the StopTimer method must be invoked before the form is called.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarDeleted Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
cKeyID
The KeyID of the time bar which has been deleted.

Description

Occurs after a time bar has been deleted from the schedule.

Syntax

Visual Basic
Public Event BarDeleted( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal cKeyID As String _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
cKeyID
The KeyID of the time bar which has been deleted.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarLeftClick Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when a time bar is left clicked.

Syntax

Visual Basic
Public Event BarLeftClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarLinked Event
nIndex
The 1-based index value of the link.
nIndexFrom
The 1-based index value of schedule item containing the time bar initiating the link.
nBarFrom
The 1-based index value of the time bar initiating the link.
nIndexTo
The 1-based index value of schedule item containing the time bar receiving the link.
nBarTo
The 1-based index value of the time bar receiving the link.

Description

Occurs when 2 time bars are linked together.

Syntax

Visual Basic
Public Event BarLinked( _
   ByVal nIndex As Integer, _
   ByVal nIndexFrom As Integer, _
   ByVal nBarFrom As Integer, _
   ByVal nIndexTo As Integer, _
   ByVal nBarTo As Integer _
)

Parameters

nIndex
The 1-based index value of the link.
nIndexFrom
The 1-based index value of schedule item containing the time bar initiating the link.
nBarFrom
The 1-based index value of the time bar initiating the link.
nIndexTo
The 1-based index value of schedule item containing the time bar receiving the link.
nBarTo
The 1-based index value of the time bar receiving the link.

See Also

ctxSchedule Object | Time Bar Linking


%%PageItemTitle%%

BarPreDrop Event
nIndex
The 1-based index value of the schedule item containing the time bar before the move.
nBar
The 1-based index value of the time bar before it has been moved.
nStartDate
An Integer value indicating the new start date of the time bar.
nEndDate
An Integer value indicating the new end date of the time bar.
nStartTime
An Integer value indicating the new start time of the time bar.
nEndTime
An Integer value indicating the new end time of the time bar.
nRow
The 1-based index value of the schedule item the time bar is being moved to.
bNewApp
A Boolean value; true if a new time is created via user interaction, false if an existing time bar is being moved.

Description

Occurs before a time bar is created or moved in the schedule.

Syntax

Visual Basic
Public Event BarPreDrop( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nStartDate As Long, _
   ByVal nEndDate As Long, _
   ByVal nStartTime As Long, _
   ByVal nEndTime As Long, _
   ByVal nRow As Integer, _
   ByVal bNewApp As Boolean _
)

Parameters

nIndex
The 1-based index value of the schedule item containing the time bar before the move.
nBar
The 1-based index value of the time bar before it has been moved.
nStartDate
An Integer value indicating the new start date of the time bar.
nEndDate
An Integer value indicating the new end date of the time bar.
nStartTime
An Integer value indicating the new start time of the time bar.
nEndTime
An Integer value indicating the new end time of the time bar.
nRow
The 1-based index value of the schedule item the time bar is being moved to.
bNewApp
A Boolean value; true if a new time is created via user interaction, false if an existing time bar is being moved.

Remarks

The CancelDrop method can be used in this event to prevent a time bar from being created or moved.

The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

See Also

ctxSchedule Object | Moving Time Bars Vertically | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarPreSelect Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs before a time bar is selected.

Syntax

Visual Basic
Public Event BarPreSelect( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

This event will fire before a time bar is selected programmatically or via user interaction.

The CancelSelect method can be used within this event to cancel the selection of a time bar.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarRightClick Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when a time bar is right clicked.

Syntax

Visual Basic
Public Event BarRightClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

The time bar does not need to be selected for this event to fire.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSelect Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when a new time bar is selected via user interaction.

Syntax

Visual Basic
Public Event BarSelect( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

This event will not fire if a time bar is selected programmatically.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarSizing Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
nType
Determines how the bar is being moved or sized.
lTimeStart
An Integer value indicating the new start time of the time bar.
lTimeEnd
An Integer value indicating the new end time of the time bar.
lDateStart
An Integer value indicating the new start date of the time bar.
lDateEnd
An Integer value indicating the new end date of the time bar.

Description

Occurs as the position or time bar is being changed.

Syntax

Visual Basic
Public Event BarSizing( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nType As Integer, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.
nType
Determines how the bar is being moved or sized.
lTimeStart
An Integer value indicating the new start time of the time bar.
lTimeEnd
An Integer value indicating the new end time of the time bar.
lDateStart
An Integer value indicating the new start date of the time bar.
lDateEnd
An Integer value indicating the new end date of the time bar.

Remarks

This event will not report the final position of the time bar. The BarChanged event will report the final position.

The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

Possible values for nType are:

0 - Time Bar is being added
1 - Time Bar is being moved
2 - The Start of the Bar is being changed
3 - The End of the Bar is being changed

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BarUnlinked Event
nIndex
The 1-based index value of the removed link.

Description

Occurs when a link is removed between 2 time bars.

Syntax

Visual Basic
Public Event BarUnlinked( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The 1-based index value of the removed link.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarUnSelect Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when a time bar is no longer selected.

Syntax

Visual Basic
Public Event BarUnSelect( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

See Also

ctxSchedule Object


%%PageItemTitle%%

BarVertMove Event
nIndexOld
The 1-based index value of the schedule item containing the bar before the vertical move.
nBarOld
The 1-based index value of the time bar before the vertical move.
nIndexNew
The 1-based index value of the schedule item containing the bar after the vertical move.
nBarNew
The 1-based index value of the time bar after the vertical move.

Description

Occurs when a time bar is moved vertically.

Syntax

Visual Basic
Public Event BarVertMove( _
   ByVal nIndexOld As Integer, _
   ByVal nBarOld As Integer, _
   ByVal nIndexNew As Integer, _
   ByVal nBarNew As Integer _
)

Parameters

nIndexOld
The 1-based index value of the schedule item containing the bar before the vertical move.
nBarOld
The 1-based index value of the time bar before the vertical move.
nIndexNew
The 1-based index value of the schedule item containing the bar after the vertical move.
nBarNew
The 1-based index value of the time bar after the vertical move.

Remarks

Time bar be moved vertically when the AllowVertMoves property is equal to true. If a time bar is moved vertically and horizontally the BarChanged event will fire, followed by the BarVertMove event.

See Also

ctxSchedule Object | Moving Time Bars Vertically | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BeforeBarChanged Event
nIndex
The 1-based index value of the schedule item containing the time bar before the change is committed.
nBar
The 1-based index value of the time bar before the change is committed.
nItem
The 1-based index value of the schedule item containing the time bar if the change is to be committed.
cKeyID
The Key Id value of the time bar being changed.
lTimeStart
An Integer value indicating the start time of the time bar if the change is to occur.
lTimeEnd
An Integer value indicating the end time of the time bar if the change is to occur.
lDateStart
An Integer value indicating the start date of the time bar if the change is to occur.
lDateEnd
An Integer value indicating the end date of the time bar if the change is to occur.

Description

Occurs before a change to the time bar has been committed to the schedule.

Syntax

Visual Basic
Public Event BeforeBarChanged( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nItem As Integer, _
   ByVal cKeyID As String, _
   ByVal lTimeStart As Long, _
   ByVal lTimeEnd As Long, _
   ByVal lDateStart As Long, _
   ByVal lDateEnd As Long _
)

Parameters

nIndex
The 1-based index value of the schedule item containing the time bar before the change is committed.
nBar
The 1-based index value of the time bar before the change is committed.
nItem
The 1-based index value of the schedule item containing the time bar if the change is to be committed.
cKeyID
The Key Id value of the time bar being changed.
lTimeStart
An Integer value indicating the start time of the time bar if the change is to occur.
lTimeEnd
An Integer value indicating the end time of the time bar if the change is to occur.
lDateStart
An Integer value indicating the start date of the time bar if the change is to occur.
lDateEnd
An Integer value indicating the end date of the time bar if the change is to occur.

Remarks

The CancelChange method can be used within this event to prevent the change of the time bar to be committed to the control.

This event will fire when the BarDateStart, BarDateEnd, BarTimeStart or BarTimeEnd property is changed with the mouse. It will not fire if the property values are changed programmatically.

The nIndex and nItem parameters will be the same unless vertical move occurs, the nIndex represents the original schedule item containing the time bar and the nItem parameter indicates the schedule item where the time bar is being moved to.

The Undo method cannot be used within this event as the change has not been committed to the control.

The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BeforeBarDeleted Event
nIndex
The 1-based index value of the schedule item containing the time bar
nBar
The 1-based index value of the time bar about to be deleted.

Description

Occurs before a time bar is deleted from the schedule.

Syntax

Visual Basic
Public Event BeforeBarDeleted( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item containing the time bar
nBar
The 1-based index value of the time bar about to be deleted.

Remarks

The CancelDelete method can be used within this event to cancel the deletion of the time bar.

The Undo method cannot be used within this event as the change has not been committed to the control.

See Also

ctxSchedule Object | Placing Restrictions on the Schedule and Time Bars


%%PageItemTitle%%

BeforeBarLinked Event
nIndexFrom
The 1-based index of the line item containing the source time bar.
nBarFrom
The 1-based index of the source time bar
nIndexTo
The 1-based index of the line item containing the destination time bar.
nBarTo
The 1-based index of the destination time bar.

Description

Occurs before two bar bars are linked using the mouse.

Syntax

Visual Basic
Public Event BeforeBarLinked( _
   ByVal nIndexFrom As Integer, _
   ByVal nBarFrom As Integer, _
   ByVal nIndexTo As Integer, _
   ByVal nBarTo As Integer _
)

Parameters

nIndexFrom
The 1-based index of the line item containing the source time bar.
nBarFrom
The 1-based index of the source time bar
nIndexTo
The 1-based index of the line item containing the destination time bar.
nBarTo
The 1-based index of the destination time bar.

Remarks

The CancelLink method can be used in this event to cancel the linking of the time bars.

See Also

ctxSchedule Object


%%PageItemTitle%%

BeforeBarUnlinked Event
nIndexFrom
The 1-based index of the line item containing the source time bar.
nBarFrom
The 1-based index of the source time bar.
nIndexTo
The 1-based index of the line item containing the destination time bar.
nBarTo
The 1-based index of the destination time bar.

Description

Occurs before two bar bars are unlinked using the mouse.

Syntax

Visual Basic
Public Event BeforeBarUnlinked( _
   ByVal nIndexFrom As Integer, _
   ByVal nBarFrom As Integer, _
   ByVal nIndexTo As Integer, _
   ByVal nBarTo As Integer _
)

Parameters

nIndexFrom
The 1-based index of the line item containing the source time bar.
nBarFrom
The 1-based index of the source time bar.
nIndexTo
The 1-based index of the line item containing the destination time bar.
nBarTo
The 1-based index of the destination time bar.

Remarks

The CancelUnlink method can be used in this event to cancel the unlinking of the time bars.

See Also

ctxSchedule Object


%%PageItemTitle%%

BeforePrint Event

Description

Occurs before a print operation begins, just after the control has calculated the total pages horizontally and vertically it will be printing.

Syntax

Visual Basic
Public Event BeforePrint()

Remarks

This event fires after the PrePrint event, so changes to the PageXOffset and PageYOffset properties in the PrePrint event will already be included in the page count.

The PrintHorzPageMax and PrintVertPageMax methods can be used in this event to check the total pages being printed horizontally and vertically in the report. The PrintHorzPageFrom, PrintHorzPageTo, PrintVertPageFrom and PrintVertPageTo properties can then be adjusted in the event to modify the output to only a selected range of pages.

The AbortPrint method can still be called in this event to stop the printing operation

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

CheckClick Event
nIndex
The 1-based index value of the schedule item containing the modified check box.
nColumn
The 1-based index value of the column containing the modified check box.
nValue
The new state of the check box; 0 if unchecked, 1 if checked

Description

Occurs when the state of check box changes.

Syntax

Visual Basic
Public Event CheckClick( _
   ByVal nIndex As Integer, _
   ByVal nColumn As Integer, _
   ByVal nValue As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item containing the modified check box.
nColumn
The 1-based index value of the column containing the modified check box.
nValue
The new state of the check box; 0 if unchecked, 1 if checked

See Also

ctxSchedule Object


%%PageItemTitle%%

Click Event

Description

Occurs when the user clicks the control with the mouse.

Syntax

Visual Basic
Public Event Click()

See Also

ctxSchedule Object


%%PageItemTitle%%

CtrlError Event
nError
An Integer value indicating the error code.
nIndex
The 1-based index value of the item where the error occurs.

Description

Occurs when an error takes place in the control

Syntax

Visual Basic
Public Event CtrlError( _
   ByVal nError As Integer, _
   ByVal nIndex As Integer _
)

Parameters

nError
An Integer value indicating the error code.
nIndex
The 1-based index value of the item where the error occurs.

See Also

ctxSchedule Object | Error Messages


%%PageItemTitle%%

DblClick Event

Description

Occurs when the user double clicks the control with the mouse.

Syntax

Visual Basic
Public Event DblClick()

See Also

ctxSchedule Object


%%PageItemTitle%%

DropItem Event
nType

The area/type of drop which occurred. Values include:

0 - drop occurred in the list area
1 - drop occurred on a list item
2 - drop occurred in the schedule area

nIndex
The 1-based index value of the item receiving the drop; 0 if not dropped on an existing item
nObject
The 1-based index value of the object receiving the drop; 0 if not dropped on an existing item or time bar.
nTime
The time where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
nDate
The date where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.

Description

Occurs when an item is dropped into the list or schedule area.

Syntax

Visual Basic
Public Event DropItem( _
   ByVal nType As Integer, _
   ByVal nIndex As Integer, _
   ByVal nObject As Integer, _
   ByVal nTime As Long, _
   ByVal nDate As Long _
)

Parameters

nType

The area/type of drop which occurred. Values include:

0 - drop occurred in the list area
1 - drop occurred on a list item
2 - drop occurred in the schedule area

nIndex
The 1-based index value of the item receiving the drop; 0 if not dropped on an existing item
nObject
The 1-based index value of the object receiving the drop; 0 if not dropped on an existing item or time bar.
nTime
The time where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
nDate
The date where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.

Remarks

This event only fires when the DragDrop is invoked.

The start and end times of a time bar are based on the number of minutes since midnight. A value of 540 represents 9:00 am.

The start and end dates of a time bar are based on the number of days since January 1, 1900. A value of 0 represents January 1, 1900. Some platforms use a different base date. If this is the case the DateOffset property is used to synchronize the base date of the control and the base date of the platform.

See Also

ctxSchedule Object | Implementing Drag and Drop


%%PageItemTitle%%

FirstDraw Event

Description

Occurs after ctxSchedule has been drawn for the first time.

Syntax

Visual Basic
Public Event FirstDraw()

Remarks

The FirstDraw event only fires once therefore it provides an ideal event in which to load the control for the first time.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineAdd Event
nIndex
1-based index of the added GuideLine
nTime
Long value of the time of the GuideLine (in minutes past midnight)
nDate
Long value of the date of the GuideLine

Description

Occurs when a GuideLine is added through the Edit Mode = GuideLines.

Syntax

Visual Basic
Public Event GuideLineAdd( _
   ByVal nIndex As Integer, _
   ByVal nTime As Long, _
   ByVal nDate As Long _
)

Parameters

nIndex
1-based index of the added GuideLine
nTime
Long value of the time of the GuideLine (in minutes past midnight)
nDate
Long value of the date of the GuideLine

Remarks

This event will only fire when EditMode = GuideLine not when GuideLines are added programmatically.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineClick Event
nIndex
1-based index of the clicked GuideLine
nButton
The button used to click the GuideLine

Description

Occurs when a GuideLine is clicked.

Syntax

Visual Basic
Public Event GuideLineClick( _
   ByVal nIndex As Integer, _
   ByVal nButton As Integer _
)

Parameters

nIndex
1-based index of the clicked GuideLine
nButton
The button used to click the GuideLine

Remarks

This event will fire when the EditMode = GuideLines and a GuideLine is clicked anywhere along the line or on the image, or if EditMode <> GuideLines the event will only fire if the GuideLine image is clicked.

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineMove Event
nIndex
1-based index of the moving GuideLine
nTime
The current time value of the GuideLine (in minutes past midnight)
nDate
The current date value of the GuideLine
bNewLine
A boolean value indicating if the GuideLine was just created

Description

Occurs as the GuideLine is moving.

Syntax

Visual Basic
Public Event GuideLineMove( _
   ByVal nIndex As Integer, _
   ByVal nTime As Long, _
   ByVal nDate As Long, _
   ByVal bNewLine As Boolean _
)

Parameters

nIndex
1-based index of the moving GuideLine
nTime
The current time value of the GuideLine (in minutes past midnight)
nDate
The current date value of the GuideLine
bNewLine
A boolean value indicating if the GuideLine was just created

Remarks

This event fires continuously as the GuideLine is being dragged (either by the GuideLine itself in EditMode = GuideLines or by the image in EditMode <> GuideLines). The GuideLineMoved Event will fire once the drag is completed (on the mouseup).

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineMoved Event
nIndex
1-based index of the moved GuideLine
nTime
The new time value of moved GuideLine (in minutes past midnight)
nDate
The new date value of the dropped GuideLine

Description

Occurs once the GuideLine has finished moving (on mouseup).

Syntax

Visual Basic
Public Event GuideLineMoved( _
   ByVal nIndex As Integer, _
   ByVal nTime As Long, _
   ByVal nDate As Long _
)

Parameters

nIndex
1-based index of the moved GuideLine
nTime
The new time value of moved GuideLine (in minutes past midnight)
nDate
The new date value of the dropped GuideLine

See Also

ctxSchedule Object


%%PageItemTitle%%

GuideLineRemove Event
nIndex
1-based index of the deleted GuideLine

Description

Occurs just before a GuideLine is deleted.

Syntax

Visual Basic
Public Event GuideLineRemove( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
1-based index of the deleted GuideLine

Remarks

To delete a GuideLine, move the GuideLine off of the Schedule control.

See Also

ctxSchedule Object


%%PageItemTitle%%

HistoryChange Event

Description

Occurs when the UndoCount or RedoCount values change.

Syntax

Visual Basic
Public Event HistoryChange()

See Also

ctxSchedule Object


%%PageItemTitle%%

HistoryRedo Event
nIndex
The 1-based index value of the item that contains the bar affected by the Redo
nBar
The 1-based index value of the bar affected by the Redo
nAction
An integer value indicating the action that was re-done to the time bar.

Description

Occurs when the Redo method of the control is called

Syntax

Visual Basic
Public Event HistoryRedo( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nAction As Integer _
)

Parameters

nIndex
The 1-based index value of the item that contains the bar affected by the Redo
nBar
The 1-based index value of the bar affected by the Redo
nAction
An integer value indicating the action that was re-done to the time bar.

Remarks

Possible values for nAction:
1 = Creating a Time Bar
2 = Moving a Time Bar
3 = Sizing a Time Bar
4 = Erasing a Time Bar
5 = Linking a Time Bar
6 = Unlinking a Time Bar

See Also

ctxSchedule Object


%%PageItemTitle%%

HistoryUndo Event
nIndex
The 1-based index value of the item that contains the bar affected by the Undo
nBar
The 1-based index value of the bar affected by the Undo
nAction
An integer value indicating the action that was Undone to the time bar.

Description

Occurs when the Undo method of the control is called

Syntax

Visual Basic
Public Event HistoryUndo( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nAction As Integer _
)

Parameters

nIndex
The 1-based index value of the item that contains the bar affected by the Undo
nBar
The 1-based index value of the bar affected by the Undo
nAction
An integer value indicating the action that was Undone to the time bar.

Remarks

Possible values for nAction:
1 = Creation of a Time Bar
2 = Moving a Time Bar
3 = Sizing a Time Bar
4 = Erasing a Time Bar
5 = Linking a Time Bar
6 = Unlinking a Time Bar

See Also

ctxSchedule Object


%%PageItemTitle%%

ItemSelect Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when the selected status of list item and/or a time bar changes.

Syntax

Visual Basic
Public Event ItemSelect( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

If both the item and the time bar values change, this event will fire twice. The first represents the change of list item, and second will represent the change of time bar.

See Also

ctxSchedule Object


%%PageItemTitle%%

KeyDown Event
KeyCode
Contains a number which identifies the key pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys at the time of the event. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT are pressed, the value of shift is 6.

Description

Occurs when the user presses a key while an object has the focus.

Syntax

Visual Basic
Public Event KeyDown( _
   ByRef KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
Contains a number which identifies the key pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys at the time of the event. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT are pressed, the value of shift is 6.

See Also

ctxSchedule Object


%%PageItemTitle%%

KeyPress Event
KeyAscii
An integer that returns a standard numeric ANSI keycode. Keyascii is passed by reference; changing it sends a different character to the object. Changing keyascii to 0 cancels the keystroke so the object receives no character.

Description

Occurs when the user presses and releases an ANSI key.

Syntax

Visual Basic
Public Event KeyPress( _
   ByRef KeyAscii As Integer _
)

Parameters

KeyAscii
An integer that returns a standard numeric ANSI keycode. Keyascii is passed by reference; changing it sends a different character to the object. Changing keyascii to 0 cancels the keystroke so the object receives no character.

See Also

ctxSchedule Object


%%PageItemTitle%%

KeyUp Event
KeyCode
Contains a number which identifies the key pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys at the time of the event. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT are pressed, the value of shift is 6.

Description

Occurs when the user releases a key while an object has the focus.

Syntax

Visual Basic
Public Event KeyUp( _
   ByRef KeyCode As Integer, _
   ByVal Shift As Integer _
)

Parameters

KeyCode
Contains a number which identifies the key pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys at the time of the event. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT are pressed, the value of shift is 6.

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowDblClick Event
nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

Description

Occurs when the mouse double clicks a line arrow in the schedule.

Syntax

Visual Basic
Public Event LineArrowDblClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal bDirection As Boolean _
)

Parameters

nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowLeftClick Event
nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

Description

Occurs when the mouse left clicks a line arrow in the schedule.

Syntax

Visual Basic
Public Event LineArrowLeftClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal bDirection As Boolean _
)

Parameters

nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

See Also

ctxSchedule Object


%%PageItemTitle%%

LineArrowRightClick Event
nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

Description

Occurs when the mouse right clicks a line arrow in the schedule.

Syntax

Visual Basic
Public Event LineArrowRightClick( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal bDirection As Boolean _
)

Parameters

nIndex
The 1-based index of the line item containing the line arrow.
nBar
The 1-based index of the first time bar represented by the arrow.
bDirection
The direction of the arrow. True means pointing right (after the current view), false means pointing left (before the current view).

See Also

ctxSchedule Object


%%PageItemTitle%%

ListClick Event
nIndex
The 1-based index value of the schedule item.

Description

Occurs when an item in the list is clicked on.

Syntax

Visual Basic
Public Event ListClick( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.

Remarks

This event will fire when an item is clicked in the list area and the schedule area.

See Also

ctxSchedule Object


%%PageItemTitle%%

ListDblClick Event
nIndex
The 1-based index value of the schedule item.

Description

Occurs when an item in the list is double clicked on.

Syntax

Visual Basic
Public Event ListDblClick( _
   ByVal nIndex As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.

Remarks

This event will fire when an item is double-clicked in the list area and the schedule area.

See Also

ctxSchedule Object


%%PageItemTitle%%

ListSize Event
nListWidth
The new width of the list area.

Description

Occurs after the width of the list section is resized.

Syntax

Visual Basic
Public Event ListSize( _
   ByVal nListWidth As Integer _
)

Parameters

nListWidth
The new width of the list area.

See Also

ctxSchedule Object


%%PageItemTitle%%

MouseDown Event
Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

Description

Occurs when the user pressed a mouse button.

Syntax

Visual Basic
Public Event MouseDown( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also

ctxSchedule Object


%%PageItemTitle%%

MouseMove Event
Button
An integer that corresponds to the state of the mouse buttons in which a bit is set if the button is down. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. It indicates the complete state of the mouse buttons; some, all, or none of these three bits can be set, indicating that some, all, or none of the buttons are pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

Description

Occurs when the mouse moves over the control.

Syntax

Visual Basic
Public Event MouseMove( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
An integer that corresponds to the state of the mouse buttons in which a bit is set if the button is down. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. It indicates the complete state of the mouse buttons; some, all, or none of these three bits can be set, indicating that some, all, or none of the buttons are pressed.
Shift
An integer that corresponds to the state of the SHIFT, CTRL, and ALT keys. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also

ctxSchedule Object


%%PageItemTitle%%

MouseUp Event
Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

Description

Occurs when the users releases a mouse button.

Syntax

Visual Basic
Public Event MouseUp( _
   ByVal Button As Integer, _
   ByVal Shift As Integer, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

Button
Returns an integer that identifies the button that was pressed to cause the event. The button argument is a bit field with bits corresponding to the left button (bit 0), right button (bit 1), and middle button (bit 2). These bits correspond to the values 1, 2, and 4, respectively. Only one of the bits is set, indicating the button that caused the event.
Shift
Returns an integer that corresponds to the state of the SHIFT, CTRL, and ALT keys when the button specified in the button argument is pressed or released. A bit is set if the key is down. The shift argument is a bit field with the least-significant bits corresponding to the SHIFT key (bit 0), the CTRL key (bit 1), and the ALT key (bit 2 ). These bits correspond to the values 1, 2, and 4, respectively. The shift argument indicates the state of these keys. Some, all, or none of the bits can be set, indicating that some, all, or none of the keys are pressed. For example, if both CTRL and ALT were pressed, the value of shift would be 6.
x
Returns a number that specifies the current x location of the mouse pointer.
y
Returns a number that specifies the current y location of the mouse pointer.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteDblClick Event
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Occurs when the mouse double clicks a note in the schedule.

Syntax

Visual Basic
Public Event NoteDblClick( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
)

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteLeftClick Event
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Occurs when the mouse left clicks a note in the schedule.

Syntax

Visual Basic
Public Event NoteLeftClick( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
)

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

NoteRightClick Event
nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

Description

Occurs when the mouse right clicks a note in the schedule.

Syntax

Visual Basic
Public Event NoteRightClick( _
   ByVal nIndex As Integer, _
   ByVal nNote As Integer _
)

Parameters

nIndex
The 1-based index of the line item containing the note.
nNote
The 1-based index of the note.

See Also

ctxSchedule Object


%%PageItemTitle%%

PreLoad Event
nIndex

The index value of the item to be drawn

Description

Occurs each time a list item is about to be drawn.

Syntax

Visual Basic
Public Event PreLoad( _
   ByVal nIndex As Integer _
)

Parameters

nIndex

The index value of the item to be drawn

Remarks

This event only fires when the ItemLoaded event is equal to False.

See Also

ctxSchedule Object | Using the Pre-Load Option to Save Memory


%%PageItemTitle%%

PrePrint Event
nPaperSize
The paper size selected by the user.
nOrientation
The paper orientation selected by the user.

Description

Occurs before a printed report is produced.

Syntax

Visual Basic
Public Event PrePrint( _
   ByVal nPaperSize As Integer, _
   ByVal nOrientation As Integer _
)

Parameters

nPaperSize
The paper size selected by the user.
nOrientation
The paper orientation selected by the user.

Remarks

This event is designed to allow the developer to adjust the PageXOffset and PageYOffset properties so the report better fits the selected paper size and orientation. The paper size and orientation can not be modified in this event.

See Also

ctxSchedule Object | Creating a Printed Report


%%PageItemTitle%%

ScheduleClick Event
nxPoint
Returns a number that specifies the current x location of the mouse pointer.
nyPoint
Returns a number that specifies the current y location of the mouse pointer.
nButton
Returns an integer that identifies the button that was pressed to cause the event.
0 = Left Button Click
1 = Left Button Double Click
2 = Right Button Click

Description

Occurs when the schedule area of the control is clicked on.

Syntax

Visual Basic
Public Event ScheduleClick( _
   ByVal nxPoint As Integer, _
   ByVal nyPoint As Integer, _
   ByVal nButton As Integer _
)

Parameters

nxPoint
Returns a number that specifies the current x location of the mouse pointer.
nyPoint
Returns a number that specifies the current y location of the mouse pointer.
nButton
Returns an integer that identifies the button that was pressed to cause the event.
0 = Left Button Click
1 = Left Button Double Click
2 = Right Button Click

Remarks

The nxPoint and nyPoint coordinates can be used with other properties and methods such as DateAt and TimeAt to determine additional information.

See Also

ctxSchedule Object


%%PageItemTitle%%

ScheduleOver Event
nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Description

Occurs when the mouse moves over a new item or time bar in the schedule area.

Syntax

Visual Basic
Public Event ScheduleOver( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer _
)

Parameters

nIndex
The 1-based index value of the schedule item.
nBar
The 1-based index value of the time bar.

Remarks

A value of 0 is returned to the nIndex when the mouse is not over an item in the schedule area and a value of 0 is returned to the nBar parameters when the mouse is not over a time bar.

See Also

ctxSchedule Object | Moving Time Bars Vertically


%%PageItemTitle%%

ScrollTrack Event
nScrollBar

The scroll bar being tracked. Values include:

0 - The vertical scroll bar
1 - The horizontal scroll bar

nValue
The value of the scroll bar.
nScrollType

Indicates how the scroll bar is being moved. Values include:

0 - The left scroll button or top scroll button was clicked
1 - The right scroll button or bottom scroll button was clicked
2 - Page Up/Left Up / Left scroll bar was clicked
3 - Page Down/Right Down / Right scroll bar was clicked
4 - The thumb is in an up state and position of the thumb was moved.
5 - The thumb is in a down state and it is being moved

Description

Occurs when the vertical or horizontal scroll bar is being moved in the schedule area of the control.

Syntax

Visual Basic
Public Event ScrollTrack( _
   ByVal nScrollBar As Integer, _
   ByVal nValue As Integer, _
   ByVal nScrollType As Integer _
)

Parameters

nScrollBar

The scroll bar being tracked. Values include:

0 - The vertical scroll bar
1 - The horizontal scroll bar

nValue
The value of the scroll bar.
nScrollType

Indicates how the scroll bar is being moved. Values include:

0 - The left scroll button or top scroll button was clicked
1 - The right scroll button or bottom scroll button was clicked
2 - Page Up/Left Up / Left scroll bar was clicked
3 - Page Down/Right Down / Right scroll bar was clicked
4 - The thumb is in an up state and position of the thumb was moved.
5 - The thumb is in a down state and it is being moved

See Also

ctxSchedule Object


%%PageItemTitle%%

SetTips Event
nType
The type of tool tip being displayed; 0 when the tip is diplayed over the scroll bar, 1 when the tip is displayed over a time bar, 2 when the tip is for a note.
nIndex
The 1-based value of the vertical scroll bar or the 1-based index value of the time bar.
nItem
The 1-based index value of the time bar. If the tip is being displayed over the scroll bar this value will be 0.

Description

Occurs before a tool tip is displayed.

Syntax

Visual Basic
Public Event SetTips( _
   ByVal nType As Integer, _
   ByVal nIndex As Integer, _
   ByVal nItem As Integer _
)

Parameters

nType
The type of tool tip being displayed; 0 when the tip is diplayed over the scroll bar, 1 when the tip is displayed over a time bar, 2 when the tip is for a note.
nIndex
The 1-based value of the vertical scroll bar or the 1-based index value of the time bar.
nItem
The 1-based index value of the time bar. If the tip is being displayed over the scroll bar this value will be 0.

Remarks

This event will only fire if one of the Tips are enabled.

See Also

ctxSchedule Object | Displaying Tool Tips


%%PageItemTitle%%

UserDrawnBar Event
nIndex
The list item index for the specific timebar being drawn.
nBar
The timebar index for the timebar being drawn.
nHeight
The height of the timebar drawing in pixels.
nWidth
The width of the timebar drawing in pixels.

Description

This event fires before a timebar is drawn allowing the developer to create their own by setting the TimeBarImage Property.

Syntax

Visual Basic
Public Event UserDrawnBar( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal nHeight As Integer, _
   ByVal nWidth As Integer _
)

Parameters

nIndex
The list item index for the specific timebar being drawn.
nBar
The timebar index for the timebar being drawn.
nHeight
The height of the timebar drawing in pixels.
nWidth
The width of the timebar drawing in pixels.

Remarks

The UserDrawnBar Property must be set to true. For more information see the developing with topic UserDrawn Timebars.

See Also

ctxSchedule Object

Developing With

UserDrawn Timebars


%%PageItemTitle%%

UserDrawnBarDateText Event
nIndex
The 1-based index of the list item containing the timebar displaying the text.
nBar
The 1-based index of the timebar displaying the text.
bPosn
Determines which edge of the the timebar (start or end) is the text is being displayed at. A value of False indicates the Start (left edge), while a value of True indicates the End (right edge).
strText
The default text that will be displayed in the timebar.

Description

Occurs just before the text is rendered at either edge of a timebar when the DatesInBars property is set to True.

Syntax

Visual Basic
Public Event UserDrawnBarDateText( _
   ByVal nIndex As Integer, _
   ByVal nBar As Integer, _
   ByVal bPosn As Boolean, _
   ByVal strText As String _
)

Parameters

nIndex
The 1-based index of the list item containing the timebar displaying the text.
nBar
The 1-based index of the timebar displaying the text.
bPosn
Determines which edge of the the timebar (start or end) is the text is being displayed at. A value of False indicates the Start (left edge), while a value of True indicates the End (right edge).
strText
The default text that will be displayed in the timebar.

Remarks

The DateBarText property can be assigned a new value in this event to override the default text at either edge of the timebar independently.

See Also

ctxSchedule Object


%%PageItemTitle%%

UserDrawnDays Event
nDate
The date value corresponding to the day being rendered in the ruler.
nDay

The day of the week being rendered

1 = Sunday
2 = Monday
3 = Tuesday
4 = Wednesday
5 = Thursday
6 = Friday
7 = Saturday

nSegment

Indicates the current time unit being rendered.

1 = DateStart
2 = DateStart + 1 day
Etc...

Description

Occurs just before each day text is written above each date in the ruler, when TimeType = Days and RulerDays is True.

Syntax

Visual Basic
Public Event UserDrawnDays( _
   ByVal nDate As Long, _
   ByVal nDay As Long, _
   ByVal nSegment As Integer _
)

Parameters

nDate
The date value corresponding to the day being rendered in the ruler.
nDay

The day of the week being rendered

1 = Sunday
2 = Monday
3 = Tuesday
4 = Wednesday
5 = Thursday
6 = Friday
7 = Saturday

nSegment

Indicates the current time unit being rendered.

1 = DateStart
2 = DateStart + 1 day
Etc...

See Also

ctxSchedule Object


%%PageItemTitle%%

ValuePoint Event
nValue1
The date being drawn.
nValue2

The value of the major time unit.

This parameter is dependant on the TimeType property. When TimeType is equal to:

Hours: Value2 = Hour (0-24)

Days: Value2 = Day of Month (1-31)

Weeks: Value2 = Day of Week (0-6)

Month and MonthlyType = Weeks: Value2 = Week of Year (1-52)

Month and MonthlyType = Dates: Value2 = Day of Month (1-31)

Year and YearlyType = Weeks: Value2 = Week of Year (1-52)

Year and YearlyType = Months: Value2 = Month of Year (1-12)

Year and YearlyType = Quarters: Value2 = Quarter (1-4)

Description

Occurs before each time value is drawn in the ruler area.

Syntax

Visual Basic
Public Event ValuePoint( _
   ByVal nValue1 As Long, _
   ByVal nValue2 As Long _
)

Parameters

nValue1
The date being drawn.
nValue2

The value of the major time unit.

This parameter is dependant on the TimeType property. When TimeType is equal to:

Hours: Value2 = Hour (0-24)

Days: Value2 = Day of Month (1-31)

Weeks: Value2 = Day of Week (0-6)

Month and MonthlyType = Weeks: Value2 = Week of Year (1-52)

Month and MonthlyType = Dates: Value2 = Day of Month (1-31)

Year and YearlyType = Weeks: Value2 = Week of Year (1-52)

Year and YearlyType = Months: Value2 = Month of Year (1-12)

Year and YearlyType = Quarters: Value2 = Quarter (1-4)

Remarks

This event can then be used to change or format that text in the ruler to a more acceptable description

See Also

ctxSchedule Object | Setting up the Time Ruler


%%PageItemTitle%%

enumAlign Enumeration

Description

Specifies a horizontal alignment

Members

Member | Value | Description
AlignLeft | 0 | Left Justify
AlignRight | 1 | Right Justify
AlignCenter | 2 | Center


%%PageItemTitle%%

enumArrowType Enumeration

Description

Specifies the display type for arrows

Members

Member | Value | Description
LineArrows | 0 | Lines
ArrowSolid | 1 | Solid


%%PageItemTitle%%

enumBorder Enumeration

Description

Specifies border types

Members

Member | Value | Description
BorderRegular | 0 | Regular
BorderNone | 1 | None
BorderRaised | 2 | Raised
BorderLowered | 3 | Lowered


%%PageItemTitle%%

enumDayStart Enumeration

Description

Specifies available days of the week

Members

Member | Value | Description
DaySunday | 0 | Sunday
DayMonday | 1 | Monday
DayTuesday | 2 | Tuesday
DayWednesday | 3 | Wednesday
DayThursday | 4 | Thursday
DayFriday | 5 | Friday
DaySaturday | 6 | Saturday


%%PageItemTitle%%

enumEditMode Enumeration

Description

Specifies available edit modes for the control.

Members

Member | Value | Description
ModeEdit | 0 | Edit
ModeErase | 1 | Erase
ModeLink | 2 | Link
ModeUnlink | 3 | UnLink
ModeGuideLine | 4 | Guideline


%%PageItemTitle%%

enumFillType Enumeration

Description

Specifies the available background fill patterns

Members

Member | Value | Description
FillSolid | 0 | Solid
FillHorizontal | 1 | Horizontal
FillVertical | 2 | Vertical
FillDiagonal | 3 | Diagonal
FillRevDiag | 4 | Reverse Diagonal
FillHorzBump | 5 | Horizontal Bump
FillVertBump | 6 | Vertical Bump
FillDiamond | 7 | Diamond
FillPyramid | 8 | Pyramid
FillCircle | 9 | Circle
FillEllipse | 10 | Ellipse
FillHorzEdge | 11 | Horizontal Edge
FillVertEdge | 12 | Vertical Edge
FillVertEdge2 | 13 | Vertical Edge 2


%%PageItemTitle%%

enumGuidePosition Enumeration

Description

Determines whether GuideLine images will appear in front of or behind the ruler text.

Members

Member | Value | Description
GuideFront | 0 | In front of the ruler text.
GuideBack | 1 | Behind the ruler text.


%%PageItemTitle%%

enumHorzScroll Enumeration

Description

Specifies the horizontal scroll behavior

Members

Member | Value | Description
HScrollWidth | 0 | Column Width
HScrollColumns | 1 | Number of Columns


%%PageItemTitle%%

enumImagePosn Enumeration

Description

Specifies available image alignment options

Members

Member | Value | Description
ImageCenter | 0 | Center
ImageTopLeft | 1 | Top Left
ImageTopCenter | 2 | Top Center
ImageTopRight | 3 | Top Right
ImageMidLeft | 4 | Middle Left
ImageMidRight | 5 | Middle Right
ImageBotLeft | 6 | Bottom Left
ImageBotCenter | 7 | Bottom Center
ImageBotRight | 8 | Bottom Right
ImageStretch | 9 | Stretch to Fill
ImageTile | 10 | Tile
ImageHide | 11 | Hide


%%PageItemTitle%%

enumItemPosition Enumeration

Description

Determines the position an object will take, relative to other objects.

Members

Member | Value | Description
PositionNone | 0 | Does not appear
PositionBack | 1 | Appears behind other objects
PositionFront | 2 | Appears in front of other objects


%%PageItemTitle%%

enumLineType Enumeration

Description

Available line styles

Members

Member | Value | Description
LineSolid | 0 | Solid
LineThick | 1 | Dotted thick
LineThin | 2 | Dotted thin


%%PageItemTitle%%

enumLockedLines Enumeration

Description

Available number of line items to lock at the top of the schedule display.

Members

Member | Value | Description
Line0 | 0 | No lines are locked.
Line1 | 1 | The first item is locked in the view.
Line2 | 2 | The first two items are locked in the view.
Line3 | 3 | The first three items are locked in the view.


%%PageItemTitle%%

enumMonthlyType Enumeration

Description

Available displays for monthly views.

Members

Member | Value | Description
MonthlyWeeks | 0 | Weeks
MonthlyDates | 1 | Dates


%%PageItemTitle%%

enumPosition Enumeration

Description

Available vertical alignments

Members

Member | Value | Description
PosnTop | 0 | Top
PosnBottom | 1 | Bottom
PosnCenter | 2 | Center


%%PageItemTitle%%

enumPreColumn Enumeration

Description

Available pre-column displays

Members

Member | Value | Description
ColumnNone | 0 | None
ColumnArrow | 1 | Arrow
ColumnNum0 | 2 | 0 based row index
ColumnNum1 | 3 | 1 based row index
ColumnPicture | 4 | Picture


%%PageItemTitle%%

enumProperties Enumeration

Description

Available options for displaying the control's custom property pages.

Members

Member | Value | Description
None | 0 | None
Display | 1 | Display


%%PageItemTitle%%

enumRulerAlign Enumeration

Description

Available alignments for the ruler text

Members

Member | Value | Description
RulerLeft | 0 | Left Justify
RulerRight | 1 | Right Justify
RulerCenter | 2 | Center
RulerOver | 3 | Center Over Time


%%PageItemTitle%%

enumTimeType Enumeration

Description

Available time types for the control

Members

Member | Value | Description
TimeHours | 0 | Hours
TimeDays | 1 | Days
TimeWeeks | 2 | Weeks
TimeMonths | 3 | Months
TimeYears | 4 | Years


%%PageItemTitle%%

enumTipsPosn Enumeration

Description

Available alignment options for displaying tips on the vertical scroll bar.

Members

Member | Value | Description
TipsLeft | 0 | Left Justify
TipsRight | 1 | Right Justify


%%PageItemTitle%%

enumTitleStyle Enumeration

Description

Available display styles for the title area.

Members

Member | Value | Description
StyleStandard | 0 | Standard
StyleXP | 1 | XP


%%PageItemTitle%%

enumYearlyType Enumeration

Description

Available displays for yearly views

Members

Member | Value | Description
YearlyWeeks | 0 | Weeks
YearlyMonths | 1 | Months
YearlyQuarters | 2 | Quarters


Adding and Customizing List Items

ctxSchedule (3.0) 32/64 bit Scheduling Control

Adding and Customizing List Items

Before time bars can be assigned to a resource, the resource must be set up within the control. This is done using the AddItem or InsertItem methods. These methods returns a 1-based index value of the new list item. This index value can then be used to add other features to the list item. Each column, item and cell can be customized in the list area.

The properties in the list area are broken up into 3 majors section:

Properties which apply to the entire list area (prefixed with "List")
Property | Description
ListAlign | Determines the horizontal alignment of the text in the list area.
ListBackColor | Returns/sets the default background color of the list area in the control.
ListBorder | Returns/sets the type of border to place around the cells and list items in the control.
ListFont | Returns/sets the default font for the list area in the control.
ListForeColor | Returns/sets the default foreground color of the list area in the control.
ListIndent | Returns/sets the indent of the list item text.
ListIndex | Returns/sets the selected list item.
Properties which apply to A Specific list item
Property | Description
ItemBackColor | Returns/sets the background color of a list item
ItemCargo | Returns/sets the non-visible text value for the list item.
ItemData | Returns/sets a non-visible integer value of a list item.
ItemFont | Returns/sets the font of a list item.
ItemForeColor | Returns/sets the foreground color of a list item.
ItemHeader | Determines if the list item will appear as a group header item.
ItemHeaderBackColor | Returns/sets the primary background color for all group header items.
ItemHeaderBackColorTo | Returns/sets the secondary background color for all group header items.
ItemHeaderClick | Determines if the header items will respond to click events.
ItemHeaderColor | *Deprecated, please use ItemHeaderForeColor
ItemHeaderFillType | Returns/sets the enumFillType for all group header items.
ItemHeaderForeColor | Returns/sets the default text color for all group header items.
ItemHeaderFont | Returns/sets the default font for all group header items.
ItemLoaded | Determines if a list item is marked as loaded.
ItemReadOnly | Determines if the list item will be read-only.
ItemText | Returns/sets the text of a list item.
SchedHeaderBackColor | Returns/sets the background color that will display on the schedule area for a header item.
Properties which apply to A Specific cell in a list item (prefixed with "cell")
Property | Description
CellBackColor | Returns/sets the background color of an individual cell in the list area.
CellCheck | Returns/sets the check state of an individual cell in the list area.
CellFont | Returns/sets the font of an individual cell in the list area.
CellForeColor | Returns/sets the foreground color of an individual cell in the list area.
CellPicSelect | Returns/sets the image to display in a cell when the list item is selected.
CellPicture | Returns/sets the image to place in an individual cell in the list area.
CellText | Returns/sets the text of an individual cell in the list area.


Adding Columns to the List Area

ctxSchedule (3.0) 32/64 bit Scheduling Control

Adding Columns to the List Area

Columns can be added to the control using 2 different method. They can be added programmatically using AddColumn and InsertColumn method or through the property page. To maintain forward compatibility, DBI recommends programmatically adding the columns, or upon upgrading, the column data will need to be exported to an .xml file through the WriteFile method.

Column header data created with the Column property page is stored as a Blob object. If the host language you are using does not support persistent Blob objects, you will have to create the column headers with code.

NOTE: When a column is inserted or removed from the list area, ctxSchedule will not automatically move or remove the list data associated with that column. It is the responsibility of the programmer to update the list data.

The following properties can be used to customize the columns in the list area:

Property | Description
ColumnBackColor | Returns/sets the background color for the cells in a column.
ColumnCheckAlign | Returns/sets the alignment of the checkboxes within the cells in the column.
ColumnCheckBox | Determines the type of checkbox to display in the cells of the column.
ColumnForeColor | Returns/sets the foreground color of the cells in the column.
ColumnHeaderAlign | Returns/sets the horizontal alignment of the column header.
ColumnLock | Determines if the column can be resized with the mouse.
ColumnPicture | Returns/sets the index of the image in a specific column header.
ColumnPictureAlign | Returns/sets the horizontal alignment of the image in a column header.
ColumnText | Returns/sets the column header text.
ColumnTextAlign | Returns/sets the horizontal alignment of the item cell text in the column.
ColumnWidth | Returns/sets the width of the column.


Creating Groups within the List

ctxSchedule (3.0) 32/64 bit Scheduling Control

Creating Groups within the List

Headers are created by adding or inserting a list item and defining it's ItemHeader property equal to True. Item headers are useful when you are scheduling similar types of resources. Items marked as a group header will not be broken up into separate columns, the ListIndent property is not applied and they have their own font and color properties. Each item added after the item marked as a header will be part of that group. There is also the ability to set fill types on the header items. For more information see the property tables below.

The "Sales" list item has been defined as a header.

Time bars can still be added to list items that have been marked as list headers. There are 3 different methods which can be used to prevent a time bar to be added to list headers:

  1. The CancelSelect method can be invoked in the BarPreSelect event:

    If ctxSchedule.ItemHeader(nItemIndex) = True Then

    ctxSchedule.CancelSelect()

    End If

  2. The MaxTimeBars property can be set to 0 for each item header

  3. The item header can be set to read-only using the ItemReadOnly property

Properties which apply to GROUP HEADERS
Property | Description
ItemHeader | Determines if the list item will appear as a group header item.
ItemHeaderBackColor | Returns/sets the primary background color for all group header items.
ItemHeaderBackColorTo | Returns/sets the secondary background color for all group header items.
ItemHeaderClick | Determines if the header items will respond to click events.
ItemHeaderFillType | Returns/sets the enumFillType for all group header items.
ItemHeaderForeColor | Returns/sets the default text color for all group header items.
ItemHeaderFont | Returns/sets the default font for all group header items.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Selecting and Searching for List Items

ctxSchedule provides the developer with functionality to programmatically select a new time bar, and to search for time bars and time bar conflicts.

SELECTING AN ITEM

List items can be selected through user interaction or programmatically. To select a list item through user interaction, the user simply needs to click on the respective item in either the list or schedule area, or interact with one of it's time bars. To programmatically select a list item, the developer can use either the Selected or ListIndex property.

SEARCHING FOR LIST ITEMS WITH ITEMCARGO OR ITEMDATA

The control can search for any list items currently loaded in it that contain a specified ItemCargo or ItemData value.

The FindItemCargo and FindItemCargoNext methods can be used to search for all time bars that contain a desired BarCargo value. The search string is case sensitive and requires an exact match.

The following VB code is a custom routine that receives the desired cargo value as a parameter and searches all the items in the control to find all matches:

Private Sub ItemCargoSearch(ByVal CargoToFind As String)

Dim intItem As Integer 'Stores the index value of the list item containing the desired cargo value

intItem = Me.ctxSchedule1.FindItemCargo(CargoToFind) 'Gets the first item which contains the desired cargo value

Do While intItem > 0 'If intItem is greater than 0, then an item containing the desired cargo was found

'The desired cargo value was found at the list item with the index value of intItem
Me.List1.AddItem "Cargo Found"
Me.List1.AddItem "List Item: " & intItem

'Check for additional list items with the desired cargo value
 intItem = Me.ctxSchedule1.FindItemCargoNext(CargoToFind)
Loop
End Sub

The FindItemData and FindItemDataNext methods can be used to search for all time bars that contain a desired BarData value.

The following VB code is a custom routine that receives the desired data value as a parameter and searches all the items in the control to find all matches:

Private Sub ItemDataSearch(ByVal DataToFind As Long)

Dim intItem As Integer 'Stores the index value of the list item containing the desired data value

intItem = Me.ctxSchedule1.FindItemData(DataToFind) 'Gets the first item which contains the desired data value

Do While intItem > 0 'If intItem is greater than 0, then an item containing the desired data was found

'The desired data value was found at the list item with the index value of intItem
Me.List1.AddItem "Data Found"
Me.List1.AddItem "List Item: " & intItem

'Check for additional list items with the desired data value
 intItem = Me.ctxSchedule1.FindItemDataNext(DataToFind)
Loop
End Sub


Setting up the Time Ruler

ctxSchedule (3.0) 32/64 bit Scheduling Control

Setting up the Time Ruler

ctxSchedule is able to display different time lines in increments of minutes to months. This can be accomplished by setting the TimeType property to its appropriate setting. The control contains many other properties that allow you to customize the time view or ruler even further.

The ruler area is the top-right section of the control. By default, the ruler is divided along the horizontal axis. The top half of the ruler displays a date of the time segment being displayed. The text for the top portion is determined by the DateFormat and RulerTitle properties. By design, the RulerTitle property will override the DateFormat. However, the ruler does not have to be split. To display only the lower portion of the ruler, the RulerSplit property must be set to False.

The time values placed in the bottom portion of the ruler are determined by the TimeType property. Time values are based on the major time lines, there is no text for minor time lines. The frequency of the minor time lines are determined by the RulerDivisions property. For example, if the TimeType is equal to hours, minor time lines can be displayed in increments of 15 minutes by setting the RulerDivisions property to 4. The height of the major and minor time lines are determined by the LineMaxSize and LineMinSize properties respectively. The distance between each major time value is determined by the TimeDistance property (See Setting up Different Views for additional details).

CUSTOMIZING THE TIME VALUES

Just before each major time value is displayed, the ValuePoint event is fired. The ValuePoint contains 2 parameters, the first is the date being displayed, the second is the default text for that time segment. It is within this event that we can use the RulerText property to change the default text for that time segment. This allows the developer to customize the text for each major time unit.

For example, if the control is defined to display yearly quarters (TimeType = 4 and YearlyType = 2), each quarter is displayed by an integer value between 1 and 4. The ValuePoint event and RulerText property allows for a different description for each quarter, such as seasons:

Private Sub ctxSchedule1_ValuePoint(ByVal nValue1 As Long, ByVal nValue2 As Long)

If Me.ctxSchedule1.TimeType = 4 And Me.ctxSchedule1.YearlyType = 2 Then

Select Case nValue2

Case 1 'First Quarter

Me.ctxSchedule1.RulerText = "Winter"

Case 2 'Second Quarter

Me.ctxSchedule1.RulerText = "Spring"

Case 3 'Third Quarter

Me.ctxSchedule1.RulerText = "Summer"

Case 4 'Fourth Quarter

Me.ctxSchedule1.RulerText = "Autumn"

End Select

End If

End Sub

The following properties are used to customize the appearance of the ruler:

Property | Description
DateFormat | Returns/sets the date format in the ruler title.
DateOffset | Returns/sets the offset value used to synchronize the base date of the control to the base date of the development platform.
DayNames | Returns/sets the names of the week days.
IncludeAMPM | Determines if the AM and PM tags will be displayed in the ruler text.
IncludeMinutes | Determines if minutes will be included in the ruler text.
LineMaxSize | Returns/sets the height of the line marking the major time unit within the ruler area.
LineMinSize | Returns/sets the height of the line marking the minor time units within the ruler area.
MajorTimeLineRuler | Determines if the major time line will be drawn in the ruler.
MajorTimeLineRulerColor | Returns/sets the color to paint the major time lines in the ruler.
MarkerBarColor | Returns/sets the color of the marker bars.
MarkerBars | Determines if marker bars will be visible.
MilitaryTime | Determines if the ruler will display a 24 hour military time.
MonthNames | Returns/sets the month names.
RulerAlign | Returns/sets the horizontal alignment of the lower portion in the ruler area.
RulerBackColor | Returns/sets the background color of the ruler area of the control.
RulerBackColorTo | Returns/sets the secondary background color of the ruler of the control.
RulerBorder | Returns/sets the type of border to place around the ruler area.
RulerDays | Determines if the day names will be displayed in the ruler.
RulerDaySize | Returns/sets the number of characters used to display the day names.
RulerDivisions | Returns/sets the number of divisions between major time units in the ruler.
RulerFillType | Returns/sets the background fill patter of the Ruler/list header area.
RulerFont | Returns/sets the default font of the Ruler/list header area.
RulerForeColor | Returns/sets the foreground color of the Ruler.
RulerLineColor | Returns/sets the line colors within the ruler area.
RulerSplit | Determines if the ruler will be split in half along the vertical axis of the ruler area.
RulerText | Returns/sets the text to appear in each time segment in the ruler.
RulerThreeD | Determines if the lines in the ruler area will be displayed with a lowered border.
RulerTitle | Returns/sets the title text of the ruler area.
RulerXOffset | Returns/sets the horizontal offset value used to calculate the position of the text in the Ruler/list header area.
RulerYOffset | Returns/sets the vertical offset value used to calculate the position of the text in the Ruler/list header area.
StartWeekDay | Determine the first day of the week.
TimeDistance | Returns/sets the distance between the major time units in the ruler area.
TimeTagAM | Returns/sets the morning or AM tag used to format a time value within the lower portion of the ruler.
TimeTagPM | Returns/sets the evening or PM tag used to format a time value within the lower portion of the ruler.
TimeType | Returns/sets the type of units to display in the ruler of ctxSchedule.
WeekendDates | Determines if weekend dates will be displayed in the ruler.
YearlyType | Returns/sets how a yearly ruler is displayed.


Setting up Schedule Views

ctxSchedule (3.0) 32/64 bit Scheduling Control

Setting up Schedule Views

ZOOMING

By changing the value of the TimeDistance property in the ctxSchedule, the developer can effectively zoom in and out of the view in the schedule being displayed. This ability to zoom in or out of a schedule provides the developer with the option of presenting micro or macro views of the detail in the schedule. In the case where the items being scheduled require very precise time increments the TimeDistance value can be set to a higher value. NOTE: The higher the TimeDistance value the larger the distance between major time units (a major time unit will be wider). When the distance between major time units is larger, a user is able to position a time bar more precisely with the mouse. In the case where it is desirable to see more of the schedule simultaneously set the TimeDistance property to a smaller value.

DISPLAYING A GIVEN TIME

The TimeScroll method can be used to ensure that a specific time is displayed in the schedule area. This method will adjust the horizontal scroll bar so that the specific date/time is visible. The control will attempt to display the given date/time as the first visible value in the schedule.

DISPLAYING A GIVEN DATE/TIME RANGE

The SetView method attempts to display a specific date/time range within the visible schedule area. This method accepts a start and end dates and times, and attempts to adjust the TimeDistance property and horizontal scroll so that time period is fully visible within the control. This method can be used at any point when the schedule is visible.

GENERAL NOTES

  • The TimeDistance property of the control can be used to set up different views of a schedule. It specifies the distance (in pixels) between the major time units within the ctxSchedule control. If the TimeType property is set to “Hours”, the TimeDistance property specifies the distance between the hours of the day. If the TimeType property is set to “Days”, the TimeDistance property specifies the distance between the days of the month, and so on.

  • The TimeDistance property is the number of pixels between major time units. For maximum efficiency, the TimeDistance property should be set to a value that corresponds in equal increments to the major time unit segments. For example, if the TimeType property is set to “Hours”, the TimeDistance property should be set to a value that corresponds to the sixty minutes in that hour (i.e. 120, 60, 30, 15). If the property is set to a value that is not incrementally equal to the minutes in an hour, for example 37, a time bar could not be moved to exactly half past the hour. If the TimeDistance property was set to a value of 60, then each pixel on the screen would represent one minute.

  • The SnapToGrid property allows the developer to coerce a time bar start time to minimum value within the time line. If the SnapToGrip property is set to a value of True a time bar can only be moved to position within the major time unit as specified by the GridFrequency setting. For example, if the major time unit is set to Hours, the TimeDistance property is set to 60 (one pixel for each minute) then the user can place a time bar to start on any minute within an hour. To insure that time bars can only start on 15 minutes after the hour, 30 minutes after the hour, 45 minutes after the hour, or on the hour, the GridFrequency would be set to 15 and the SnapToGrid property would be set to true. In this case moving or creating a time bar in the schedule would automatically snap the start time to the nearest 15 minute increment.

  • NOTE: The PrintTimeDistance property is the equivalent of the TimeDistance property when printing the schedule control.


Placing Restrictions on the Schedule and Time Bars

ctxSchedule (3.0) 32/64 bit Scheduling Control

Placing Restrictions on the Schedule and Time Bars

There are a variety of different methods that may be used to restrict the user interaction with the schedule and time bars. The following are some common restrictions to place on the schedule and time bars.

  • Prevent the user for interacting with the entire schedule control

  • Prevent time bars from being added to a single list item

  • Prevent a time bar from being added with the mouse, but allow time bars to be added programmatically

  • Prevent all time bars from being moved

  • Prevent all time bars from being resized

  • Prevent a single time bar from being moved or resized

  • Prevent a single time bar from being resized

  • Prevent all time bars from being moved vertically

  • Prevent a single time bar from being moved vertically

  • Prevent a time bar from being deleted

  • Prevent a time bar from being changed

  • Prevent a time bar from being selected

  • Prevent a time bar from being visible

Restriction: Prevent the user from interacting with entire schedule control.

Method: Set the DisplayOnly property to True. By setting this property to True the user cannot select, add, modify or delete time bars with the mouse, select list items or resize the columns. All modification to the control need to set be through code. The vertical and horizontal scroll bars and splitter bar can still be moved with the mouse when this property is set true.

Restriction: Prevent time bars from being added to a single list item.

Method 1: Set the ItemReadOnly property True.

Method 2: Set the MaxTimeBars property to 0

Method 3: Issue a CancelDrop method in the BarPreDrop event. This event is fired before the time bar has been committed to the list item. The CancelDrop method will prevent the time bar from being dropped and is only applicable in this event.

Method 4: Issue a CancelSelect method in the BarPreSelect event. This event is fired before the BarPreDrop event.

Restriction: Prevent a time bar from being added with the mouse but allow time bars to be added programmatically.

Method 1: When a time bar is added (via user interaction or programmatically) the BarAdded event fires. Two of the parameters included in this event are: bMouseBar and bKeyedBar. These parameters indicate how the new time bar was added. If bMouseBar is equal to True, then the time bar was added via user interaction. When true, issue an Undo action

Private Sub ctxSchedule1_BarAdded(ByVal nIndex As Integer, ByVal nBar As Integer, ByVal bMouseBar As Boolean, ByVal bKeyedBar As Boolean)

If bMouseBar = True Then 'Time Bar added with the mouse

Me.ctxSchedule1.Undo

End If

End Sub

Method 2: Set the AllowNewBars property to false.

Restriction: Prevent all time bars from being moved.

Method: Set the AllowHorzMoves property to False.

Restriction: Prevent all time bars from being resized.

Method: Set the AllowResizeBars property to False.

Restriction: Prevent a single time bar from being moved or resized.

Method: Set the BarReadOnly property to True. If a time bar is defined as read-only it cannot be moved or resized, but it can be selected.

Restriction: Prevent a single time bar from being resized.

Method: To prevent a time bar from being resized, but still allowing it to be moved, requires 2 events. The first is the BarSizing event. This event will fire as the start and end dates/times are changing. BarSizing contains a parameter called nType which indicate the action on the time bar. If this parameter is equal to 2 or 3 (start and ending position is changing) then a resize action is taking place and flag can be set. This flag will also be used in the MouseUp event indicating if an Undo action is to be performed.

Dim booResize As Boolean 'Define a variable to store the resizing action

Private Sub ctxSchedule1_BarSizing(ByVal nIndex As Integer, ByVal nBar As Integer, ByVal nType As Integer, ByVal lTimeStart As Long, ByVal lTimeEnd As Long, ByVal lDateStart As Long, ByVal lDateEnd As Long)
If nType = 2 Or nType = 3 Then 'The start or end of the time bar is changing
booResize = True 'Set the flag to true, so that the action can be undone
End If
End Sub

Private Sub ctxSchedule1_MouseUp(Button As Integer, Shift As Integer, x As Single, y As Single)
If booResize = True Then 'If a resizing occurred
Me.ctxSchedule1.Undo 'Undo the action
End If

booResize = False 'Reset the resize flag
End Sub

Private Sub Form_Load()
booResize = False 'Initialize the Resize flag
End Sub

Restriction: Prevent all time bars from being moved vertically.

Method: Set the AllowVertMoves property to False. By setting this property to false, time bars can still be created programmatically or via user interaction, resized and moved horizontally.

Restriction: Prevent a single time bar from being moved vertically.

Method: When a time bar is moved to a different list item, the BarVertMove event fires (could be in addition to the BarChanged event). To prevent the time bar from being moved vertically, issue an Undo action from the BarVertMove event. If a time is moved horizontally as well as vertically in a single mouse action, the time bar will appear in it's original position.

Restriction: Prevent a time bar from being deleted.

Method: To prevent a time bar from being deleted, issue a CancelDelete method from within the BeforeBarDeleted event.

Restriction: Prevent a change to a time bar.

Method: To prevent a change in a time bar to be committed to the control, issue a CancelChange method from within the BeforeBarChanged event. This method is particularly useful when a time bar conflict is found. This method will cancel the change to the time bar.

Restriction: Prevent a time bar from being selected.

Method: Issue a CancelSelect from the BarPreSelect event.

Restriction: Prevent a time bar from being visible.

Method: Assign a value of False to the BarVisible property of a time bar. When a time bar is not visible, any link lines or overlap lines will also not be rendered in the display.


About Dead Zones

ctxSchedule (3.0) 32/64 bit Scheduling Control

About Dead Zones

A Dead zone is an area on the control where a time bar cannot be created, moved, sized, or dragged into. A dead zone is defined through a color bar item. We must add a color bar to the control, and then mark it as a dead zone. For instance…

nIndex = ctxSchedule1.AddColorBar(60, 120, Date, Date, RGB(0,255,0), 1)

ctxSchedule1.CBarDeadZone(nIndex) = True

NOTE : A dead zone only works when time bars are being moved with the mouse, not when they moved/created programmatically (i.e. AddKeyTimeBar method). The InDeadZone method allows the developer to determine if an area in the schedule has been defined as a dead zone.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Assigning Fonts to List Items and Time Bars

Each list item, list cell and time bar can display different fonts. However, the associated property does not accept a font object, but rather an integer value. Each Integer value represents a different font stored in the control.

The following is a list of Integer values with their corresponding font which can be assigned to the ItemFont, CellFont, BarFont and StyleFont properties:

Integer value | Associated Font
-7 | TipsFont
-6 | PreColumnFont
-5 | ItemHeaderFont
-4 | ListFont
-3 | BarDefFont
-2 | RulerFont
-1 | TitleFont
0 | Default
1 | FontIndex1
2 | FontIndex2
3 | FontIndex3
4 | FontIndex4


Coloring the Background of the Schedule

ctxSchedule (3.0) 32/64 bit Scheduling Control

Coloring the Background of the Schedule

The primary color used to paint the schedule portion of the control is defined by the BackColor property. However, there are many additional ways in which to add colors and images to schedule area of the control. ctxSchedule has the ability to display blocks of color, weekend colors, time lines, a background image and alternating color items.

COlor bars

A specific area in the schedule area can be assign a new color using the AddColorBar method. This method allows you to create columns or lines of colors within the schedule area of the control. These colors are primary, and will override any colors assigned to the schedule. If the starting time and date for a color bar are the same as the ending time and date, the color bar will become a color line. The width of a color line can be manipulated through the CBarLineWidth property. The 6th parameter of the AddColorBar method defines which list item will display the color bar. If a value of 0 is assigned to this parameter, the color bar will extend from the top of the schedule area to the bottom. If a number greater than 0 is assigned to this parameter, the color bar will only be drawn for that list item. The PrintColorBars property will determine if the colors bars are to be included in a printed report.

NOTE: By setting the 6th parameters to -1, the color bar will be added to a time segment in the ruler.

The following is a list of properties used to define a color bar.

Property | Description
CBarDateEnd | Returns/sets the end date of the color bar.
CBarDateStart | Returns/sets the start date of the color bar.
CBarDeadZone | Determines if the color bar area will be considered a dead zone.
CBarFillType | Returns/sets the fill pattern of the color bar.
CBarIndex | Returns/sets the list item assigned to the color bar.
CBarLineWidth | Returns/sets the width of the color bar when the start and end times are the same.
CBarTimeColor | Returns/sets the background color of the color bar.
CBarTimeColorTo | Returns/sets the secondary color of the color bar.
CBarTimeEnd | Returns/sets the end time of the color bar.
CBarTimeStart | Returns/sets the start time of the color bar.

Weekend colors

Weekend colors are solid color blocks assigned to the days defined as weekends (Weekends). The Weekend color is defined through the WeekendColor property. If a value of -1 is assigned to the property, the weekend color will not be applied. The PrintWeekendColor property will determine if the weekend color is to be included in a printed report.

Time lines

Time lines are lines that extend throughout the height of the schedule and are drawn along each major time segment of the schedule. The frequency, line width, and color can all be set through the proper properties. A special time line representing the current date can be displayed by setting the TodayLine property to True.

The following is a list a properties used to define the time lines and the today line.

Property | Description
TimeLineBreak | Returns/sets the frequency of the time lines.
TimeLineColor | Returns/sets the color of the time lines.
TimeLines | Determines if time lines will be displayed.
TimeLineStart | Retruns/sets the first major time unit to display a time line.
TimeLineWidth | Returns/sets the style of the time lines.
TodayLine | Determines if a vertical line will be displayed for the current date.
TodayLineColor | Returns/sets the color of the line representing the current date.
TodayLineSize | Returns/sets the width of the line representing the current date.
TodayLineWidth | Returns/sets the style of the line representing the current date.

Backimage

A background image can be assigned to the schedule area with the BackImage property. The ImagePosition property defines the format/alignment of the background image.

Alternating colors

Schedule lines can alternate in color by setting the AltSchedColors property equal to True. The alternating colors are defined by the AltSchedColorEven and AltSchedColorOdd properties and frequency of the alternating colors is defined by AltSchedItems.


Displaying Tool Tips

ctxSchedule (3.0) 32/64 bit Scheduling Control

Displaying Tool Tips

ctxSchedule is capable of displaying tool tips when the mouse is over a time bar and when the vertical scroll bar is being moved. The TipsOn prefixed properties are used to determine the type of tool tips to display within the control.

Scroll Tips

Scroll tips will be displayed when the vertical scroll bar is being moved. The text displayed will be that with the same index value of the scroll bar.

Time Bar Tips

A tool tip will appear when the mouse moves over a time bar containing text within the control. The tool tip will appear underneath the cursor.

Changing the Text Within a Tip

The TipsText property allows the developer to customize the tips text. This property is only applicable when defined in the SetTips event.

The following illustrates how to set the tips text to text in the fifth column in corresponding list item.

Private Sub ctxSchedule1_SetTips(ByVal nType As Integer, ByVal nIndex As Integer, ByVal nItem As Integer)

If nType = 1 'The mouse is over a time bar

ctxSchedule.TipsText = ctxSchedule1.CellText(nIndex, 5)

End If

End Sub

Multi line tool tips can also be displayed. To display a multi line tool tip and carriage return is required within the tips text:

ctxSchedule.TipsText = "To display different text when" + Chr(10) + "scrolling you need to" + Chr(10) + "use the TipsText Property."

The following properties are used to customize the appearance of the tool tips:

Properties | Description
TipsBackColor | Returns/sets the background color of the tool tips.
TipsDelay | Returns/sets the initial delay between the mouse moving over a time bar, and the tool tip becoming visible.
TipsDistance | Returns/sets the distance between the tool tip and vertical scroll bar.
TipsFont | Returns/sets the tool tips font.
TipsForeColor | Returns/sets the fore ground color of the tool tips.
TipsPosition | Returns/sets the position of the tool tips when the vertical scroll bar is moved.
TipsText | Sets the tool tip text.
TipsTextAlign | Returns/sets the horizontal alignment of a tool tip.
TipsOnNotes | Determines if tool tips will be displayed on notes.
TipsOnOverBar | Determines if tool tips will be displayed on time bars.
TipsOnVScroll | Determines if tool tips will be displayed on the vertical scroll thumb.


Map Area

ctxSchedule (3.0) 32/64 bit Scheduling Control

Map Area

The map area will display a compressed version of the entire schedule along the top area of the control.

In the image above, the entire schedule has been compressed so that it fits along the top of the control. A red rectangle also appears in the map area. This rectangle represents the approximate current viewing area in the main schedule.

If the user clicks on the map area, the view in the schedule area will change so that the clicked area is displayed.

NOTE: If there are a lot of line items, or if the schedule is very large, the compressed image could become very blurry. As well, the regular schedule area of the control is drawn in such a manner that it is very efficient. It only draws items in the visible area. But the map schedule has to draw everything. As such, the performance of the control might start to diminish of the map area is visible, and the schedules are very large.

The appearance of the map area is determined by the MapVisible property. The height of the map area is determined by the MapHeight property.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Using the Internal Image List

ctxSchedule is able to store up to 100 images (icons and bitmaps) internally. Many of the image properties in ctxSchedule reference the internal image list.

Images can be added to the internal image list through 2 different methods:

  1. Images can be added through the Image tab in the custom property pages

  2. Programmatically through the AddImage method.

By default, the control will display the images as 32x32 bits. To display a 16 x 16 bit image the SmallIcons property needs to be set to True. For forwards compatibility, DBI recommends programmatically adding the images to the internal image list.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Locking Line Items in the Control View

The control supports locking up to the first 3 items added to the control, through the LockedLines property. Locked items will remain in view at the top of the control while the control is scrolled vertically. The locked items allow all the same functionality for time bar interactions as the unlocked list items.

Image1: An instance of the control scrolled all the way to the bottom, displaying the last 5 items.

Image2: The LockedLine property is now set to 1, and the first item in the control is now locked to the top of the display.

Image3: The LockedLine property is now set to 2, and the first two items in the control are now locked to the top of the display.

Image3: Finally the LockedLine property is set to 3, and the first three items in the control are now locked to the top of the display.

While line items are locked in the display, they will be drawn the same as if they were unlocked. Developers can use any of the standard properties available to the items to customize their appearance to further emphasize their locked nature to the user, if required.

The following images demonstrate the three options for locking lines in the control as the above images, with the addition of also modifying the ItemBackColor, ItemText and BarBackColor properties to differentiate the locked items from the standard items.


An Overview of a Time Bar

ctxSchedule (3.0) 32/64 bit Scheduling Control

An Overview of a Time Bar

A time bar is the main object representing a period of time in the ctxSchedule control. The main purpose of a time bar is to hold a starting and ending time/date. This period of time can represent an appointment, the availability of a resource, or any other time-related event. While a time bar can be used to store a period of time, it can contain other features as well.

Text and Sub-Text

Each time bar can contain a primary text value and a sub-text value. The main text is provided by the BarText property. This text can be aligned within the bar, or it can placed to the right of the bar. The font can be changed through the BarFont property and can be set to wrap within the bar using the BarTextWrap property. The sub-text is provided by the BarSubText property. Unlike the main text, the only font that can be assigned to the text is through the BarDefFont property. As well, this text will always wrap, and it is always left aligned.

A Time bar displaying text and subtext

Bar Images

Images can be assigned to the front and back of a time bar through the BarEndImage and BarStartImage properties. Each of these properties takes an integer value. If a negative value is assigned to the BarEndImage or BarStartImage property, a stock is will be applied. A positive value would assign an image from the internal image list.

A time bar displaying an end image from the internal image list

A time bar displaying a start and end image from the stock images

stock images

Additional Features

In addition to the text and the images, time bars can be further customized. Some features include:

  • Different background pattern. Each background pattern of a time bar is defined by the BarFillType property, options include a solid fill pattern, a gradient fill or textured patterns.

  • Displaying the start and end dates within the time bar by setting the DatesInBars property to True.

  • Ensuring that the bar text is always visible. As the schedule scroll, the time bars may not be fully visible. By setting the TextIntoView equal to True, the text will shift within the time bar so that it is always visible.

A time bar displaying the start and end date with a gradient fill background

TIP: Creating a time bar style will allow the developer to assign a standard set of properties to a group of time bars. For additional information on creating time bar styles, please see: Creating Time Bar Styles

Timebar Shadows

The TimeBarShadows Property set to true will display default timebars with a shadow effect. This will be overwritten if using styles or userdrawn timebars.

USERDRAWN TIMEBARS

The timebar image can be overridden using the UserDrawn Timebars.

Overriding properties

Some of the time bar style properties can be overridden by individual time bar settings. To enable this, the BarStylePriority property must be assigned a value of False. These properties include:

Overriding Property | Description | Overridden Style Property
BarBackColor | Returns/sets the primary background color of a time bar. | StyleBackColor
BarBackColorTo | Returns/sets the secondary background color of a time bar. | StyleBackColorTo
BarBorderColor | Returns/sets the border color of a time bar. | StyleBorderColor
BarEndImage | Returns/sets the end image of a time bar. | StyleEndImage
BarFillType | Returns/sets the fill pattern of a time bar. | StyleFillType
BarFont | Returns/sets the font of a time bar. | StyleFont
BarForeColor | Returns/sets the foreground color of a time bar. | StyleForeColor
BarStartImage | Returns/sets the start image of a time bar. | StyleStartImage


Creating Time Bar Styles

ctxSchedule (3.0) 32/64 bit Scheduling Control

Creating Time Bar Styles

By default, the height of a time bar is 10 pixels less than the height of its host list item (5 pixels from the top and 5 from the bottom) and is vertically centered within the host item. The default background color of the time bars is determined by the BarDefBackColor property. The time bar initially contains no text and no images on either side of the bar. Bar styles can set time bars up with different heights, fonts, images and vertical alignment. ctxSchedule is able to store up to 32,000 different bar styles.

Adding a new style

A bar style is defined by the AddBarStyle method. This method accepts two parameters:

  1. The height of the time bar style

  2. The vertical offset (a positive value will move the time bar down, a negative will move it up)

The AddBarStyle method will return an integer value. This value represents the index value of the newly added bar style, and will be required to further enhance the bar style. If a value of 0 is returned, the bar style was not added.

Image

Images can be added to the start and end of a time bar. The StyleStartImage and StyleEndImage properties will assign a start and end image to the time bar style. By assigning a value between -1 to -15 to either of these properties, a stock image will be used. A positive value will reference an image from the internal image list (see Using the Internal Image List).

stock images

A custom images assigned to the StyleEndImage property

When using images, icons support a transparent area, while a bitmap does not. The MaskBitmap and MaskColor properties are designed to assign a single color in a bitmap to appear transparent. Depending on the system settings, the MaskColor property must reference the exact color which is to appear transparent.

The StyleEndXOffset, StyleEndYOffset, , StyleStartXOffset, and StyleStartYOffset properties help to set the exact vertical and horizontal position of the start and end images of a time bar. The StyleEndFront and StyleStartFront properties determine if the images will appear in front or behind the time bar.

Colors

The background of a time bar can be displayed by a solid color or by a fill pattern. The StyleBackColor property is displayed on a solid background (StyleFillType = 0). The StyleBackColor will override the BarDefBackColor. When the StyleFillType is assigned a value (>0), the StyleBackColor and StyleBackColorTo properties are applied. To display a background pattern you will need to use the StyleBrushType.

The foreground color of a bar style is defined by StyleForeColor property. This property will override the BarDefForeColor property.

TEXT

The actual time bar text cannot be assigned at the style level. It can only be added through the BarText property. However, the vertical and horizontal text offset value are defined at the style level through the StyleTextXOffset and StyleTextYOffset properties.

MILESTONES

A milestone is a special type of bar style. Milestones represent a certain place in time. Therefore, the starting and ending dates and times for a milestone are identical. A milestone bar style displays the time bar as a very thin line. It is too thin to place text or color into it. It is the responsibility of the developer to set the alignment of the bar text to appear to the right of the time bar (BarTextAlign). Time bars marked as milestones cannot be re-sized. They can only be moved. The StyleMilestone property is used to define a bar style as a milestone.

TIP: Assigning a start image to a milestone time bar will make the time bar easier to see and more visually appealing.

Assigning a Style to a Time Bar

Once the bar style has been defined, it then needs to be assigned to a time bar. The DefaultStyle property sets a defined style as the default style which is applied to each time bar. The time bar style can be changed through the BarStyle property.

EXAMPLE:

The following script will create the style below:

Dim intIndex As Integer 'Stores the index value of a bar style

intIndex = Me.ctxSchedule1.AddBarStyle(25, 0) 'Creates a new bar style

'Assigns the colors to the time bar style

Me.ctxSchedule1.StyleFillType(intIndex) = 1 'Assign the background pattern to a horizontal gradient fill

Me.ctxSchedule1.StyleBackColor(intIndex) = RGB(255, 255, 255) 'assigns the primary fill color to white

Me.ctxSchedule1.StyleBackColorTo(intIndex) = RGB(125, 125, 125) 'assigns the secondary fill color to grey

Me.ctxSchedule1.StyleForeColor(intIndex) = RGB(0, 0, 0) 'assigns the fore color to black

'Assigns the image properties

Me.ctxSchedule1.StyleEndImage(intIndex) = 1 'Assigns the end image to the first image in the internal image list

Me.ctxSchedule1.StyleEndXOffset(intIndex) = -3 'Shifts the end image into the time bar. This prevents the time bar border from appearing at the end of the time bar

Me.ctxSchedule1.StyleEndFront(intIndex) = True 'The end image will be displayed in front of the time bar

Me.ctxSchedule1.DefaultStyle = intIndex 'Assigns the style above as the default bar style

Overriding properties

Some of the time bar style properties can be overridden by individual time bar settings. To enable this, the BarStylePriority property must be assigned a value of False. These properties include:

Overriding Property | Description | Overridden Style Property
BarBackColor | Returns/sets the primary background color of a time bar. | StyleBackColor
BarBackColorTo | Returns/sets the secondary background color of a time bar. | StyleBackColorTo
BarBorderColor | Returns/sets the border color of a time bar. | StyleBorderColor
BarEndImage | Returns/sets the end image of a time bar. | StyleEndImage
BarFillType | Returns/sets the fill pattern of a time bar. | StyleFillType
BarFont | Returns/sets the font of a time bar. | StyleFont
BarForeColor | Returns/sets the foreground color of a time bar. | StyleForeColor
BarStartImage | Returns/sets the start image of a time bar. | StyleStartImage

Property Value priority

Depending on different situations, developers may need to adjust the priority that the control uses to determine the values used to display timebars. This priority can be toggled to give either BarStyle or individual TimeBar properties the highest priority. The BarStylePriority property can be toggled to adjust this priority. The control will attempt to retrieve a value by checking the highest priority first and moving down the list until one is found.

BarStylePriority Value | Highest Priority | Medium Priority | Lowest Priority
True (default) | BarStyle | TimeBar | Default
False | TimeBar | BarStyle | Default

The properties affected by the BarStylePriority property are:

TimeBar ("Bar" prefix) | Default ("BarDef" prefix) | BarStyle ("Style" prefix)
BarBackColor | BarDefBackColor | StyleBackColor
BarBackColorTo | BarDefBackColorTo | StyleBackColorTo
BarBorderColor | BarDefBorderColor | StyleBorderColor
BarEndImage |  | StyleEndImage
BarFillType | BarDefFillType | StyleFillType
BarFont | BarDefFont | StyleFont
BarForeColor | BarDefForeColor | StyleForeColor
BarStartImage |  | StyleStartImage


Moving Time Bars Vertically

ctxSchedule (3.0) 32/64 bit Scheduling Control

Moving Time Bars Vertically

By default, it is not possible to move a time bar from one item to another. However, it does become possible when the AllowVertMoves property is set to a value of True. When a time bar is moved vertically, 2 events will fire.

The first event which fires is the BarPreDrop event. This event fires before the time bar has been committed to a different list item. It allows the developer the opportunity to cancel the vertical move, by invoking the CancelDrop method. The BarPreDrop event passes 2 parameters, an index value of the list item the time bar originated from and the index value of the time bar. To determine which list item the time bar is being dropped on at the time of BarPreDrop event, the list item index value can be tracked through the ScheduleOver event.

The second event to fire is the BarVertMove event. This event occurs after the time bar has been committed to the new list item. NOTE: If the start date/time and the end date/time of the time bar changes, the BarChanged event will fire before the BarVertMove event.


Selecting and Searching for Time Bars

ctxSchedule (3.0) 32/64 bit Scheduling Control

Selecting and Searching for Time Bars

ctxSchedule provides the developer with functionality to programmatically select a new time bar, and to search for time bars and time bar conflicts.

SELECTING A NEW TIME BAR

Time bar can be selected through user interaction or programmatically. To select a time bar through user interaction, the user simply needs to click on a time bar and the appropriate selected properties are updated. To programmatically select a time bar, first the list item needs to be selected through the Selected or ListIndex property. Once the list item is selected, the time bar can be selected through the Bar property.

SEARCHING USING KEY ID

Time bars can be searched on based on their Key ID value. ctxSchedule provides 2 methods for obtaining the necessary index values to perform this type of search:

  1. KeyIDBar: Gets the 1-based index value of the time bar

  2. KeyIDItem: Gets the 1-based index value of the list item containing time bar.

The following sample code will perform a search on all the list items:

Dim strKeyID as String 'Stores the Key ID value to search for

Dim intListItem as Integer 'Stores the index value of the list item containing the time bar

Dim intTimeBar as Integer 'Stores the index value of the time bar

strKeyID = "RECORD1234" 'Sets the Key ID to search on

intListItem = ctxSchedule.KeyIDItem(strKeyID)

If intListItem > 0 Then 'If intListItem is greater than 0, a list item was found containing a matching time bar

intTimeBar = ctxSchedule.KeyIDBar(strKeyID, intListItem) 'Search for the matching time bar within the list item returned from the KeyIDItem method

If intTimeBar > 0 Then 'If intTimeBar is greater the 0, a matching time bar was found

......

End If

End If

SEARCHING FOR TIME BARS WITH BARCARGO OR BARDATA

The control can search for any time bars currently loaded in it that contain a specified BarCargo or BarData value.

The FindBarCargo, FindBarCargoNext, FindBarCargoItem and FindBarCargoItemNext methods can be used to search for all time bars that contain a desired BarCargo value. The search string is case sensitive and requires an exact match.

The following VB code is a custom routine that receives the desired cargo value as a parameter and searches all the items and time bars in the control to find all matches:

Private Sub BarCargoSearch(ByVal CargoToFind As String)

Dim intItem As Integer 'Stores the index value of the list item containing a timebar with the desired cargo value
Dim intTimeBar As Integer 'Stores the index value of the time bar which has the desired cargo value

intItem = Me.ctxSchedule1.FindBarCargoItem(CargoToFind) 'Gets the first item which contains a time bar with the desired cargo value

Do While intItem > 0 'If intItem is greater than 0, then a time bar containing the desired cargo was found
intTimeBar = Me.ctxSchedule1.FindBarCargo(CargoToFind, intItem) 'Gets the first time bar within the list item which has the cargo value

Do While intTimeBar > 0 'If intTimeBar is greater than 0, the desired cargo value was found on a time bar
'The desired cargo value was found at the list item with the index value of intItem
'at the time bar with the index value of intTimeBar
Me.List1.AddItem "Cargo Found"
Me.List1.AddItem "List Item: " & intItem
Me.List1.AddItem "Time Bar: " & intTimeBar
intTimeBar = Me.ctxSchedule1.FindBarCargoNext(CargoToFind, intItem) 'Gets the next time bar within the list item which has the desired cargo value
Loop

'Once all the time bars that contain the cargo value have been found within the list item, the next list item is checked
intItem = Me.ctxSchedule1.FindBarCargoItemNext(CargoToFind)
Loop
End Sub

The FindBarData, FindBarDataNext, FindBarDataItem and FindBarDataItemNext methods can be used to search for all time bars that contain a desired BarData value. The search requires an exact match.

The following VB code is a custom routine that receives the desired data value as a parameter and searches all the items and time bars in the control to find all matches:

Private Sub BarDataSearch(ByVal DataToFind As Long)

Dim intItem As Integer 'Stores the index value of the list item containing a timebar with the desired data value
Dim intTimeBar As Integer 'Stores the index value of the time bar which has the desired data value

intItem = Me.ctxSchedule1.FindBarDataItem(DataToFind) 'Gets the first item which contains a time bar with the desired data value

Do While intItem > 0 'If intItem is greater than 0, then a time bar containing the desired data was found
intTimeBar = Me.ctxSchedule1.FindBarData(DataToFind, intItem) 'Gets the first time bar within the list item which has the data value

Do While intTimeBar > 0 'If intTimeBar is greater than 0, the desired data value was found on a time bar
'The desired data value was found at the list item with the index value of intItem
'at the time bar with the index value of intTimeBar
Me.List1.AddItem "Data Found"
Me.List1.AddItem "List Item: " & intItem
Me.List1.AddItem "Time Bar: " & intTimeBar
intTimeBar = Me.ctxSchedule1.FindBarDataNext(DataToFind, intItem) 'Gets the next time bar within the list item which has the desired data value
Loop

'Once all the time bars that contain the data value have been found within the list item, the next list item is checked
intItem = Me.ctxSchedule1.FindBarDataItemNext(DataToFind)
Loop
End Sub

SEARCHING FOR CONFLICTING TIME BARS

There may be times when it is necessary to know when the time bars overlap. The ctxSchedule controls offers two different methods to determine time bar conflicts. The first method is through a visual representation using overlap lines. The overlap lines will appear above and below the conflicting area. To display over lapping lines the OverlapLines property must be set to true. The color and width of the over lap lines can defined through the OverlapColor and OverlapWidth properties. The OverlapTime and ConflictOffset properties determines when the overlap lines are displayed.

Above, the red overlap lines indicate the conflicting area

The second method to determine conflicts is done programmatically using the FindFirstBar, FindFirstItem, FindNextBar, FindNextItem methods and the ConflictOffset property. These methods determine time bar conflicts occur in the same list item, or any item within the schedule. The ConflictOffset property determines what is considered a conflict. For instance, if the property is set to 15 (minutes), it will report on other appointments that come within 15 minutes of the original appointment.

The following VB script occurs in the BarPreDrop event:

Private Sub ctxSchedule1_BarPreDrop(ByVal nIndex As Integer, ByVal nBar As Integer, ByVal nStartDate As Long, ByVal nEndDate As Long, ByVal nStartTime As Long, ByVal nEndTime As Long, ByVal nRow As Integer, ByVal bNewApp As Boolean)

Dim intItem As Integer 'Stores the index value of the list item containing a conflict
Dim intTimeBar As Integer 'Stores the index value of the time bar which is in conflict

intItem = Me.ctxSchedule1.FindFirstItem(nIndex, nBar) 'Gets the first item which contains a conflicting time bar

Do While intItem > 0 'If intItem is greater than 0, a conflicting item was found
intTimeBar = Me.ctxSchedule1.FindFirstBar(nIndex, nBar, intItem) 'Gets the first time bar within the list item which is a conflict

Do While intTimeBar > 0 'If intTimeBar is greater than 0, a conflicting time bar was found
'A time bar conflict was found at the list item with the index value of intItem
'at the time bar with the index value of intTimeBar
Me.List1.AddItem "Conflict"
Me.List1.AddItem "List Item: " & intItem
Me.List1.AddItem "Time Bar: " & intTimeBar
intTimeBar = Me.ctxSchedule1.FindNextBar(nIndex, nBar, intItem) 'Gets the next time bar within the list item which is a conflict
Loop

'Once all the conflicting time bars have been found within the list item, the next list item is checked
intItem = Me.ctxSchedule1.FindNextItem(nIndex, nBar)
Loop
End Sub


Time Bar Linking

ctxSchedule (3.0) 32/64 bit Scheduling Control

Time Bar Linking

Time bar links can be created in two different ways; programmatically through code, or through user interaction with EditMode property in the control is set to Link.

Example:

Programmatically create a link between the first time bar of the first item to the second time bar in the second item using the AddLink method.

[Visual Basic and Access]

Dim intIndex as Integer 'Stores the index value of the link

intIndex = Me.ctxSchedule.AddLink(1 , 1, 2, 2) 'Creates the link

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddLink(1 , 1, 2, 2) && Creates the link

To allow the user to create links between time bars in the schedule, set the control's EditMode to “Link”. The user can then click on one time bar, drag the mouse to another time bar and release the mouse. A link is visually displayed between the two time bars. NOTE: The control responds to user input when in link mode by firing the BeforeBarLinked event before the link is created and the BarLinked event after the link has been created. These events can be used to validate the input, optionally delete or allow link, code the necessary data binding logic to persist the link in the database, and modify the appearance of the link. The CancelLink method can be called inside the BeforeBarLinked event to prevent the link from being created.

Time bar links can be broken using the mouse by setting the EditMode property to “Unlink”. Clicking and dragging on the time bars connected by a link causes the link to be removed when the mouse button is released on the second time bar. If two time bars are loop linked (one time bar links to another, and then another link goes back to the first time bar), the primary link will be removed first. When in the "Unlink" edit mode, user interaction will trigger two events, the BeforeBarUnlinked and BarUnlinked events. These events can be used to validate the operation, as well as cancel/allow it and update the database as needed. The CancelUnlink method can be called from the BeforeBarUnlinked event to preserve the link.

There are three different types of time bar links:

1. Standard Link: A link with square lines and an arrow at the destination time bar.

2. Reciprocal Link: A link with square lines and arrows at the source and destination time bar.

3. Direct Link: A straight line between two time bars with no arrows.

The following properties can be used to customize the appearance of a link:

Property | Description
LinkColor | Returns/sets the color of a specific link item.
LinkCount | Returns the number of links stored in the control.
LinkFromBar | Returns the index value of the time bar initiating the link.
LinkFromItem | Returns/sets the index value of the schedule item containing time bar initiating the link.
LinkLineColor | Returns/sets the default link line color.
LinkToBar | Returns/sets the index value of the time bar receiving the link.
LinkToItem | Returns/sets the index value of the item containing the time bar receiving the link.
LinkType | Returns/sets the type of link to display between 2 time bars.


Schedule Edit Modes

ctxSchedule (3.0) 32/64 bit Scheduling Control

Schedule Edit Modes

EDIT

This mode allows the user to create, size and move time bars. To create a new time bar, simply left click on a time line in the schedule and drag the mouse to the left or right. When the mouse button is released, a new time bar should be created.

To size a time bar, the user must left click on either end of a time bar and drag. If a time bar is sized so that its end time is less than or equal to the start time, the time bar will be erased.

There are a variety of restrictions that can be placed on the schedule to prevent a time bar from being created, moved or sized:

  • A time bar may not have been created, moved or sized if those actions place it in a dead zone (See section on Coloring the Background of the Schedule for more details)

  • A time bar may not be created or moved into a line item where that time bar will exceed the limit of time bars placed on the line item. The limit on a line item is set by the MaxTimeBars property of a line item.

  • The line item has been set to a read only state through the ItemReadOnly property of the line item.

  • The BarReadOnly property of a time bar item is set to a value of True.

  • The actions can be cancelled through the BeforeBarChanged event.

  • The AlowVertMoves property of the control must be set to a value of True in order to move a time bar vertically.

ERASE

This mode allows the user to erase individual time bars by clicking on them.

NOTE: When a time bar is erased, it is not actually removed from the time bar collection for the line item. It is simply marked as being deleted. This is so it can be recalled with the Undo method. However, the time bar will be removed from the collection if the ClearHistory method is used.

LINK

This mode allows the user to click and drag on one time bar and release the mouse over another time bar. When this is done, a link between the two time bars will be created. (See section on Time Bar Linking for more details and restrictions.)

UNLINK

This mode allows the user to click and drag on one time bar and release the mouse over another time bar. If a link between the two time bars existed, it will be removed. (See section on Time Bar Linking for more details and restrictions.)


Undo Redo Features

ctxSchedule (3.0) 32/64 bit Scheduling Control

Undo/Redo Features

The ctxSchedule control contains an internal collection for recording mouse based actions with the control. The following actions are recorded by ctxSchedule when performed via user interaction:

  • Creating a Time Bar

  • Moving a Time Bar

  • Sizing a Time Bar

  • Erasing a Time Bar

  • Linking a Time Bar

  • Unlinking a Time Bar

The above action are not recorded when defined programmatically. For example, if a time bar is added programmatically through the AddKeyTimeBar method, the action is not stored in the internal undo collection.

The undo/redo collections only store actions the effect time bars. Adding, inserting or removing list items are not stored. The limit on the amount of actions recorded in the Undo collection is determined by the HistorySize property.

The undo and redo operations are initiated by the Undo and Redo methods respectively. The UndoCount and RedoCount indicating how many items are available in each collection. For example:

If Me.ctxSchedule.UndoCount > 0 then

Me.ctxSchedule.Undo

End If

The type of the next undo operation in the collection can be read through the UndoType property. The HistoryChange event will fire after the Undo or Redo method is called. It indicates that the internal collection has changed.

NOTE: When a time bar is deleted from the control with the mouse, it is not actually removed from the time bar collection. Instead, it is only marked as deleted, and no longer appears in the control. However, if we use the ClearHistory method, the deleted time bars will be removed from the control.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Line Arrows and More Time Bar Functionality

Line Arrows

Line Arrows can be displayed inside the Schedule area, to indicate to users that more Time Bars exist outside the currently visible time frame (before or after it). Line Arrows are turned on by setting the LineArrowPosition property to a value of 1 (back) or 2 (front). The LineArrowPosition property also determines how the Line Arrows will be displayed, relative to any Time Bars they may overlap with in the display.

The following properties are available for working with line arrows:

Property | Description
LineArrowAfter | Returns/sets the image used for the line arrows indicating more time bars after the current view.
LineArrowBefore | Returns/sets the image used for the line arrows indicating more time bars before the current view.
LineArrowColor | Returns/sets the color used for the painting of the default line arrow appearance.
LineArrowPosition | Returns/sets where the line arrows will be drawn in the schedule.

The following events are available for working with line arrows:

Event | Description
LineArrowDblClick | Occurs when the mouse double clicks a line arrow in the schedule.
LineArrowLeftClick | Occurs when the mouse left clicks a line arrow in the schedule.
LineArrowRightClick | Occurs when the mouse right clicks a line arrow in the schedule.

More Time Bar Functionality

There are also properties and methods for finding and displaying Time Bars currently outside visible time frame of the schedule. These properties and methods can be used in conjunction with the Line Arrows and their functionality, or used independently.

The following properties are available for finding the next and previous time bars from the view:

Property | Description
ItemNextBarIndex | Returns the index value for the first time bar past the end of the visible area of the schedule.
ItemPrevBarIndex | Returns the index value for the first time bar before the start of the visible area of the schedule.

NOTE: These properties require the index of a line item to test for time bars.

The following methods are available for displaying time bars:

Method | Description
MakeBarVisible | This method will attempt to scroll a specific time bar in to the visible area of the control.

For an example of working with Line Arrows and the More Time Bar Functionality, please see the sample application that ships with the product.


ctxSchedule (3.0) 32/64 bit Scheduling Control

UserDrawn Timebars

The user drawn timebar feature of ctxSchedule (3.0) 32/64 bit Scheduling Control is an advanced feature to allow the application developer to create their own custom OLEPicture timebar. To enable the UserDrawn Timebars set the UserDrawnBar Property = True. There is an event that is raised for each timebar that is drawn - the UserDrawnBar Event. In that event, the developer will set the TimeBarImage Property. Once this property has been set, the event will copy that image to replace the default timebar that is being drawn. If you do not set that property explicitly the default timebar will be drawn. As the TimeBarImage property is cleared when the UserDrawnBar event is fired, setting the property in the designer will have no effect.

**Please note that the TimeBarImage property will only accept an OLEPicture. There are several API's that will need to be used to create this image or a third-party control that returns an OLEPicture. Due to the complexities of the GDI and GDI+ drawing API calls, the only demo available is for VB6, and is provided as a sample drawing routine only. There is no consideration for memory cleanup nor is this to be considered a best practice example.

VB6 - Sample Source for UserDrawnBar event.

Private Sub ctxSchedule1_UserDrawnBar(ByVal nIndex As Integer, ByVal nBar As Integer, ByVal nHeight As Integer, ByVal nWidth As Integer)

If Me.ctxSchedule1.UserDrawnBar Then
Dim curImage As Picture

'The CalcTimeBar is a function that returns an OLEPicture
Set curImage = CalcTimeBar(nWidth, nHeight, Me.ctxSchedule1.BarData(nIndex, nBar))
'Apply the user created image to the TimeBar
Me.ctxSchedule1.TimeBarImage = curImage
Set curImage = Nothing
End If
End Sub

VFP9SP2 (Sedna) -

*** ActiveX Control Event ***
LPARAMETERS nindex, nbar, nheight, nwidth

&& The CalcTimeBar method needs to return an OLEPicture
thisform.ctxSchedule1.TimeBarImage = CalcTimeBar(nWidth, nHeight, thisform.ctxSchedule1.BarData(nIndex, nBar))


GuideLine Procedural

ctxSchedule (3.0) 32/64 bit Scheduling Control

Working with GuideLines

Working with Guide Lines

Guide Lines are vertical lines used to represent specific times in a schedule. Guide lines provide the user with discrete “snap-to” functionality making it easier to position time bars.

Guide lines enhance the process of creating and maintaining a schedule. Guide lines are not intended to be included in the static display functionality of the schedule and accordingly they have certain limitations. Guide lines are not rendered in a print or print preview report, and are not part of the Undo/Redo functionality.

Adding Guide Lines to the Schedules

Guide lines are assigned to a specific schedule object. Therefore, if the user wants to display a guide line in multiple schedules for a specific time the guide line must be created for each schedule object in which it is to appear. There are two ways to add a guide line to a schedule …

1.) User Interaction: Set the EditMode property of the control to GuideLine. Click a point on the schedule. On the OnMouseUp event, the new guide line will be created.

2.) Programmatically: Create a GuideLine through code. For example…

Dim curGuideLine as integer

curGuideLine = ctxSchedule1.AddGuideLine(540, me.ctxSchedule1.DateStart)

When a guide line is added with the mouse a GuideLineAdd event will be fired by the ctxSchedule control. This event can be used to validate the action and optionally delete the guide line from the control, or set the appearance of the guide line.

Changing the Position of a Guide Line

The position of a guide line in a schedule is based on the GuideDate and GuideTime values. Changing the position of a guide line can be achieved in one of three ways ...

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally in the schedule. On the mouseup, the guide line will be set at its new position and time. NOTE: To move the guideline inside the schedule area the EditMode must be set to GuideLine.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line the image appears in the ruler area. Click and drag the image horizontally in the ruler to change its time. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine.

3.) Programmatically: Change the value of the GuideTime and GuideDate properties of the ctxSchedule through code. For example …

me.ctxSchedule1.GuideTime(curGuideLine) = 240

me.ctxSchedule1.GuideDate(curGuideLine) = clng(Now)

When a guide line is moved with the mouse a GuideLineMoved event will be fired. NOTE: As a guide line is being moved with the mouse, the GuideLineMove event will be firing.

Removing Guide Lines from the Schedules

Guide lines can be removed from the ctxSchedule in one of three ways …

1.) User Interaction with the guideline in the schedule: Set the EditMode property of the control to GuideLine, Click and drag an existing guide line horizontally off of the schedule. On the mouseup, the guide line will be removed.

2.) User Interaction with the guideline in the ruler: If an image has been assigned to a guide line, click and drag the image horizontally off of the schedule. NOTE: The EditMode of the control DOES NOT have to be set to GuideLine

3.) Programmatically: Remove the guide line through code. For example ...

me.ctxSchedule1.DeleteGuideLine curGuideLine

When a guide line is being removed with the mouse a GuideLineRemove event will be fired.

Adding Images to a Guide Line

Each guide line can be assigned an image that is rendered in the ruler section of the control. By default the image will be vertically aligned to the bottom of the ruler and horizontally aligned so that the middle of the image is on top of the guide line. The position can be changed though the GuideImageXOffset and GuideImageYOffset. NOTE: It is possible to display an image for a guide line inside the actual schedule instead of the ruler area however this is NOT a recommended practice as the logic for the guide line images assumes they are within the ruler area of the schedule. Unpredictable results may occur by placing them elsewhere. To add an image to a guide line perform the following …

1.) Assign the Guide Line images to the image list of the ctxSchedule.

2.) To set the default image for all Guide Lines in the ctxSchedule control, assign the index value of an image in the image list to the GuideImageIndex property of the ctxSchedule control. After that, all guide lines will use that image unless the GuideImage property for a GuideLine index is set discretely to the index value of a different image in the ctxSchedule image list. Setting the GuideImage property of a Guide Line overrides any default image assigned to the guide lines.

Snapping a Time Bar to a Guide Line

To cause time bars to be snapped to a guide line, the SnapToGuideLines property of the ctxSchedule control must be set to True. As one end of a time bar approaches a guide line the edge of the time bar will become aligned with the guide line. The distance at which the time bar is “snapped” to the guide line is determined in pixels and is defined in the GuideLineDistance property of the ctxSchedule control.

When a time bar is “snapped” to a guide line, it is assigned the actual time of that guide line. For example, if a guide line is set to 1:13:15 (1 hour, 13 minutes, 15 seconds), when a time bar is snapped to the guide line, its beginning (or end depending on the proximity of the guide line) will be set to the 1:13:15 setting.

NOTE : Because the Snap to Guide Lines feature is based on pixels, a time bar will only snap to a guide line that is visible within the schedule object. If a guide line is not visible in the schedule object the time bar will not snap to its value.

NOTE : Working with GuideLines and SnapToGrid... please be aware that if you have snap-to-grid enabled with snap-to-guidelines, be sure to synchronize the guidelines to the gridfrequency. If the guidelines fall too close to the gridfrequency but not exactly then there may be issues related to the drawing of the timebars as they attempt to position themselves to accommodate both values.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Schedule Notes

Schedule Notes

Schedule Notes can be displayed at a single Date and Time, allowing custom indicators of important and unique events.

Notes can be added to the control, through the use of the AddNote method. This method receives the Date, Time and Item index where the note is to appear. The method will return the 1-based index of the newly added Note.

Example:

Programmatically create a Note at 8 am on the first day of the schedule, on the first item using the AddNote method.

[Visual Basic and Access]

Dim intIndex as Integer 'Stores the index value of the note

intIndex = Me.ctxSchedule.AddNote(1 , 480, Me.ctxSchedule.DateStart) 'Creates the note

[Visual FoxPro]

intIndex = thisform.ctxSchedule.AddNote(1 , 480, thisform.ctxSchedule.DateStart) && Creates the note

All notes have a default image for displaying inside the control: Default image of a note

By default a note will only appear when it's Date, Time and Item are visible in the current display of the Schedule Area. However, notes can be locked to force them to always be visible, by setting the NoteLocked property. Locked notes can be aligned to either the right, left or center of the visible portion of their item in the schedule, using the NoteImageAlign property.

The following properties are available for working with notes:

Property | Description
NoteCount | Returns the total count of notes on a line item.
NoteDate | Returns/sets the date for the note.
NoteImageAlign | Returns/sets the the alignment for a note's image when it is locked in the schedule.
NoteImageIndex | Returns/sets the index value of the image to use for the note, from the internal image list.
NoteImageXOffset | Returns/sets the horizontal offset value used to calculate the position of the note image in the schedule.
NoteImageYOffset | Returns/sets the vertical offset value used to calculate the position of the note image in the schedule.
NoteLocked | Returns/sets if the note will be locked in the viewable area of the schedule.
NotesDistance | Determines the distance between locked notes in the schedule area.
NotesPosition | Determines where the notes will be drawn, relative to the Time Bars.
NoteText | Returns/sets the text assigned to a note.
NoteTime | Returns/sets the time for the note.

The following methods are available for working with notes:

Method | Description
AddNote | Adds a new note to the schedule.
ClearNotes | Clears all the notes from a line item.
DeleteNote | Deletes a single note from a line item.
NoteAt | Returns the index of the Note at the specified coordinate.

The following events are available for working with notes:

Event | Description
NoteDblClick | Occurs when the mouse double clicks a note in the schedule.
NoteLeftClick | Occurs when the mouse left clicks a note in the schedule.
NoteRightClick | Occurs when the mouse right clicks a note in the schedule.

For an example of working with notes, please see the sample application that ships with the product.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Using the HitTest Methods

There are several "hittest" methods available for the ctxSchedule. These methods can be used for custom dialogs, tooltips and whiteboard type solutions. They can also be used for customizing drag/drop operations. Some are accessed using x and y coordinates, x-coordinates or y-coordinates.

The ScheduleItemAt Method will indicate the area of the ctxSchedule control for the supplied coordinates.

The LineAt Method will indicate the list item for the supplied y-coordinate.

The DateAt Method will indicate the date value for the supplied x-coordinate.

The TimeAt Method will indicate the time value for the supplied x-coordinate.

The NoteAt Method will indicate the index of the note at the specified coordinates.

The TimeBarsAt Method will return the count of the timebars at the specified coordinates.

The FindFirstTimeBar Method will return the index of the first timebar at the specified coordinates.

The FindNextTimeBar Method will return the index of the next timebar at the specified coordinates.

The ColorBarsAt Method will return the count of the colorbars at the specified coordinates.

The FindFirstColorBar Method will return the index of the first colorbar at the specified coordinates.

The FindNextColorBar Method will return the index of the next colorbar at the specified coordinates.

These methods can be called from anywhere, but the x and y coordinates must be in pixels relative to the control. As such vb6 may require the use of twips per pixel calculations. For more information see the demo applications found in both VFP9 and VB6.


ctxSchedule (3.0) 32/64 bit Scheduling Control

ctxSchedule Data Binding

Introduction

ctxSchedule points of integration for data

Loading the control from the Database

Responding to Time Bar changes (edits/moves) in the control

Responding to Add and Delete Time Bar events in the control

Summary

INTRODUCTION

The ctxSchedule.ocx component provides a presentation and interaction surface through which the scheduling of resources can be defined and maintained. The control encapsulates three basic objects: A Schedule (the time line over which the resources are being managed), Items (the resources being scheduled), and Time Bars (the periods of time for which the resources are being utilized).

A simple example of a scheduling application would be the management of meeting rooms. In this scenario the Schedules would represent the periods of time for which the meeting room schedules would be published, for example the months of the year. Each Schedule would represent one month. The Items in the Schedule would represent the rooms being scheduled for meetings (the resources), and the Scheduled Time (Time Bars) would represent the times at which the meeting rooms were scheduled to hold meetings. The database structure to store the data for the application would look something like ...

The ctxSchedule.ocx control maintains 2 arrays that reflect the data being stored in the database;

  1. Schedule Items - describe the resource that is being scheduled. These could be people, rooms, positions/tasks, equipment, in essence any item that requires scheduling for its fulfillment or utilization.

  2. Time Bars - Discreet periods of time that signify the resource's utilization.

NOTE: The records stored in the Schedules Table describe the settings (Schedule Start - Date and Time/Schedule End - Date and Time) for the timeline in the ctxSchedule control.

As you can see from this simple example, the timeline settings in the control mirrors the Schedules table in the database, the Items in the control reflect the MeetingRooms table in the database, and the Time Bars in the control reflect the ScheduledTime table in the database.

ctxSchedule.ocx points of integration for data

There are essentially three Points of Integration to consider when binding the ctxSchedule.ocx control to a database:

  1. Loading the control with data from the database (reading data from tables).

  2. Responding to changes (edits) in the data in the control (editing of records).

  3. Responding to Add and Delete events to the data in the control (New records or Deletion of records).

Loading the control from the Database

To programmatically load data from the database into the control when the application is first started, the developer should use the ctxSchedule.FirstDraw event to code the retrieval of the Schedule Timeline, Schedule Items, and TimeBars data from the database.

NOTE: Using the FirstDraw event insures the control is fully formed (colors, fonts, etc. are assigned correctly) before modifying its contents. The FirstDraw event only fires once therefore it provides an ideal event in which to load the control for the first time.

Once the Schedule record has been read from the database, the developer can set the Schedule properties describing the overall start and end date of the timeline to be considered along with any special formatting for the timeline. In our Meeting Rooms scenario, the Schedule record would describe a time line for a month (start date of first day of month, end date of last day of month). The time line could be set to hourly mode to allow the schedule time to be in hours or sub-increments of hours such as 15 minutes, etc., or the time line can be set to days, weeks, months, or years.

NOTE: When setting the schedule properties, the developer can programmatically restrict the minimum size of a time bar and minimum increment for the resizing of a time bar by setting the snap to grid property to true and setting the Grid Frequency to describe the smallest increment of time allowed when resizing a time bar.

Within the same FirstDraw event the next step is to programmatically add the Schedule Items to the control's list area, and for each Schedule Item add its associated time bars to be displayed in the schedule area to the right of the list within the appropriate schedule item.

In our Meeting Rooms example this would require reading a Meeting Room record from the MeetingRooms table and adding it to the ctxSchedule List area with the properties from the MeetingRooms table record.

IMPORTANT NOTE: When an item is added to the list area in the control, the developer should store the item's record id into the item's Data or Cargo property. This will allow the developer to identify the record in the database table that the item in the list represents. This value is used to link new time bar records when adding new time bars to the schedule.

Once the Item has been added to the collection, the Time Bars associated with the Item are read from the ScheduledTime table and each record related to the selected MeetingRoom record is added as time bar to the Item in the schedule list.

IMPORTANT NOTE: As noted above, the Schedule Item has two non-visual properties that can be used to store the record id to relate the item in the Schedule List to the record in the table from which the schedule list item was created. The Data and Cargo properties of the Schedule Item are designed to persist the link between the item in the schedule and its related database record. Similarly, a Time Bar has three properties that allow the developer to link back to records in a table; The KeyID property, The BarCargo property, and the BarData property. When reading information in from a table the developer should assign the record id value to the appropriate property in the appropriate object.

When complete, the ctxSchedule.ocx control will display a timeline as specified in the Schedule record, the Meeting Rooms as items in the list area of the Schedule control, and the Scheduled Times as time bars in the schedule area of the control in their respective meeting room items.

Responding to Time Bar changes (edits/moves) in the control

When a time bar is sized, either made larger or smaller, it represents a change in the period of time the item containing the time bar is committed within the schedule. Any change in the size of a time bar needs to be persisted in the database record that the time bar reflects.

When a time bar is moved within an item in the ctxSchedule control (left or right) it represents a simultaneous change in the start and end times of the time bar, i.e. the schedule commitment for the item to which the time bar is attached. When a time bar is moved between items in the ctxSchedule control it represents a change in the schedule commitment for two items, the item that originally contained the time bar and the item that contains the time bar after the move is finished. A vertical move may also represent a simultaneous change in the start and end times of the time bar being moved. Any move to a time bar (horizontal or vertical) needs to be persisted in the database record that the time bar reflects.

The ctxSchedule.ocx control has three events that provide the developer an opportunity to respond to a time bar resize and/or move ...

  1. BeforeBarChanged: Fires when the start and or end times of a time bar are changed or when a time bar moves between items (NOTE: The BeforeBarChanged event fires before the change to the time bar is written back to the control).

  2. BarChanged: Fires when the start or end times of a time bar are changed (NOTE: The BarChanged event fires after the changes to the time bar have been written back to the control).

  3. BarVertMove: Fires when a time bar is moved vertically between items. NOTE: The BarVertMove event fires after the change to the time bar has been written back to the control

IMPORTANT NOTE: The BarChanged event will not fire if a time bar is moved vertically between items without having its start or end times change.

The BeforeBarChanged event is fired before the move has been completed, i.e. written back to the control's time bars array. This event is provided for the developer to test if the move will be allowed, and optionally store the change in the data back to the record represented by the time bar being moved. If the change is not to be allowed, the developer can call the ctxSchedule control's CancelChange method to return the time bar to its previous state. The BarChanged and BarVertMove events can also be used to determine if a move is to be allowed, however they occur after the change has been written to the control. Using these events the developer must use the Undo method of the control if the change event is to be disallowed.

IMPORTANT NOTE: The BeforeBarChanged, BarChanged, and BarVertMove event arguments include the index of the item and the index value of the bar describing the time bar being moved. This allows the developer to query the time bar for its record id (KeyID property), thereby allowing the event to relate back to the record represented by the time bar being moved.

Responding to Add and Delete Time Bar events in the control

When a time bar is added to the control, programmatically or through the mouse interface (clicking and dragging) a BarAdded event fires. In the case where the Add event is generated as the result of user interaction (clicking and dragging), the developer can recognize the addition (using the bMouseBar parameter provided by the event) and programmatically add a record to the table representing the time bars. This event fires after the new bar has been written to the control therefore to cancel the add event the developer can call the Undo method in the control.

NOTE: The ctxSchedule control can also respond to drag and drop events in IDE's that support that functionality. Adding of time bars through the use of drag and drop can be handled in the DragDrop and DropItem events of the control.

IMPORTANT NOTE: The BarAdded event passes the index value of the item to which the new bar has been added, the index value of the new time bar within the item, and an indicator to determine if the time bar was added programmatically or through user interaction with the control. This allows the developer to query the newly added time bar and create a record in the time bar table that reflects the properties of the new object.

IMPORTANT NOTE: In the BarAdded event a test can be made to ascertain if the addition is to be allowed. If disallowed, the bar can be removed programmatically using the Undo method of the control without any impact on the database.

IMPORTANT NOTE: When a new time bar is added to the schedule and saved in the database, the record id of the newly added record should be retrieved from the database and stored in the time bar to identify the source record for any future changes or deletions of the time bar.

SUMMARY

Databinding the dbiSchedule control requires three distinct points of integration; loading the data from the database, responding to changes (moves/edits) to the time bars in the schedule plan, and responding to Adds (new) and Deletes to the time bars in the schedule plan. Each of the objects in the schedule plan (items and time bars) have a data and a cargo property that allow the developer to store the record id of the object in the database being reflected in the item or time bar. Each event that is fired in the schedule passes the index values (Item and Bar) of the time bar against which the event occurred (move, size, add, remove) to allow the programmer to read the necessary property values (start time, end time, etc.) and the record id of the object in the database to which the time bar is related.

NOTE: The discussion above is based on a simple example (meeting rooms) that does not involve multiple resources against the same time bar (for example equipment such as projectors, people, etc. in the meeting). These items could be added however as detail to the time bar record in the database and reflected in the schedule plan as detail to the time bar, either as text, sub-text, a tip, or a drill down form invoked by a mouse action on the time bar (i.e. a double-click). Also, this example does not take into account the linking of time bars. Links are a separate collection in the control and therefore represent a separate table in the database. In a fashion similar to the time bars, links have their own set of events (BarLinked and BarUnlinked) in which the programmer can code the binding of the objects to the database.

IMPORTANT NOTE: For more information and examples on databinding the ctxSchedule.ocx control please refer to the databinding demo provided with the install.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Implementing Drag and Drop

The ctxSchedule control will only support drag and drop operations if the host language supports drag and drop within an OLE control. Access does not support this functionality. Languages such as Visual Basic will automatically attach DragOver and DragDrop events to an OLE control. These are the events that are used to notify the control an object is being dragged over or dropped onto a control. ctxSchedule does not support dragging objects outside the control.

When dragging an object into ctxSchedule the drag and drop information must be supplied by the host language and then sent to the control’s DragOver and DragDrop methods.

DragOver : When an object is dragged over the control, the DragOver event is fired. Inside the DragOver event the developer intercepts the X and Y coordinates of the object being dragged, and the current state variable of the drag, and sends them to the control using the control's DragOver method. This causes the control's internal DragOver event to fire causing the control to draw the drag border around the item in the list over which the object is being dragged. NOTE: ctxSchedule uses pixels to determine how to draw itself. Depending on the development language the X and Y coordinates may need to be converted to pixels.

DragDrop : When an item is dropped into the control, the DragDrop event is fired. Inside the DragDrop event the developer intercepts the X and Y coordinates of the drop action using the control's DragDrop method to tell the control that an item was dropped into it at a certain coordinate. When notified of the DragDrop event, the control will fire its internal DropItem event.

The DropItem event contains the following parameters:

  • nType: Where the drop took place

  • nIndex: The 1-based index value of the item receiving the drop; 0 if not dropped on an existing item

  • nObject: The 1-based index value of the object receiving the drop; 0 if not dropped on an existing item or time bar.

  • nTime The time where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.

  • nDate The date where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.

The developer then codes the insertion of the object being dragged into ctxSchedule with the information reported in the DropItem event. NOTE: The ctDragDrop and ctDragOver methods can be used instead of DragDrop and DragOver, respectively, in cases or languages where the words "DragDrop" and "DragOver" are reserved words.

[VISUAL BASIC]

Private Sub ctxSchedule1_DragOver(Source As Control, X As Single, Y As Single, State As Integer)

Dim intIndex As Integer

'The ctxSchedule control requires the x and y coordinates of the object being dragged in order to respond to the event.

'The DragOver method of the control is used to pass the dragover information into the control.

intIndex = Me.ctxSchedule1.DragOver(X / Screen.TwipsPerPixelX, Y / Screen.TwipsPerPixelY, State)

'The DragOver event returns the index value of the item being dragged over.

End Sub

Private Sub ctxSchedule1_DragDrop(Source As Control, X As Single, Y As Single)

Dim intIndex As Integer

'The ctxSchedule control requires the x and y coordinates of the object being dragged in order to respond to the event.

'The DragDrop method of the control is used to pass the dragdrop information into the control.

intIndex = Me.ctxSchedule1.DragDrop(X / Screen.TwipsPerPixelX, Y / Screen.TwipsPerPixelY)

'The DragDrop method returns the index of item which has been dropped on.

End Sub

Private Sub ctxSchedule1_DropItem(ByVal nType As Integer, ByVal nIndex As Integer, ByVal nObject As Integer, ByVal nTime As Long, ByVal nDate As Long)

Dim intIndex As Integer

'The following will test which area the drop occurred and perform the required actions

Select Case nType

Case 0 'Dropped onto the list area, but not over an item

intIndex = Me.ctxSchedule1.AddItem("New Item")

Case 1 'Dropped on an item in the list area

intIndex = Me.ctxSchedule1.InsertItem("Inserted Item", nIndex)

Case 2 'Dropped in the schedule area

If nIndex > 0 Then

intIndex = Me.ctxSchedule1.AddTimeBar(nIndex, nTime, nTime + 60, nDate, nDate)

End If

End Select

End Sub

[VISUAL FOXPRO]

DragOver Event

Lparameters Source, nxpoint, nypoint, nstate

*!* The ctxSchedule control requires the x and y coordinates of the object being dragged in order to respond to the event.
*!* The ctDragOver method of the control is used to pass the dragover information into the control.
*!* NOTE: The x coordinate is adjusted by the left coordinate of the control and the y coordinate is adjusted by
*!* the top coordinate of the control to account for VFP not treating the OLE container as a child object in the form.

intIndex = thisform.ctxSchedule1.ctDragOver(nxpoint - this.Left, nypoint - this.top, nstate)

*!* The DragOver event returns the index value of the item being dragged over.

DragDrop Event

LPARAMETERS Source, nxposn, nyposn

*!* NOTE: The dragdrop event does not pass the necessary information through the OLE container to the control.
*!* Therefore, the control's ctDragDrop method is used to notify the control internally of the event.

*!* NOTE: Because Visual FoxPro does not host the OLE container as a child of the form in which the control is instantiated,
*!* but rather treats the control as a unique window, the X and Y coordinates of the mouse at the point of the drop operation
*!* must first be offset by the left and top values of the OLE container in the host window. The ctDragDrop method requires
*!* the X and Y coordinates of the position on which the drop operation took place, accordingly they must first be offset
*!* by the left and top values of the control.

intIndex = thisform.ctxSchedule1.ctDragDrop(nxposn - this.left, nyposn - this.Top)

*!*The ctDragDrop method returns the index of item which has been dropped on.

DropItem Event

LPARAMETERS ntype, nindex, nobject, ntime, ndate

*!*The following will test which area the drop occurred and perform the required actions
DO CASE
CASE (ntype = 0) &&Dropped onto the list area, but not over an item
intIndex = thisform.ctxSchedule1.AddItem("New Item")
CASE (ntype = 1) &&Dropped on an item in the list area
intIndex = thisform.ctxSchedule1.InsertItem("Inserted Item", nIndex)
CASE (ntype = 2) &&Dropped in the schedule area
If nIndex > 0 Then
intIndex = thisform.ctxSchedule1.AddTimeBar(nIndex, nTime, nTime + 60, nDate, nDate)
EndIf
ENDCASE


Error Messages

ctxSchedule (3.0) 32/64 bit Scheduling Control

Error Messages

There are a number of trappable errors that may be raised by the control during its operation. NOTE: All error messages are sent directly to the CtrlError event and are parameterized as an integer value. These errors include:

1000 - Not Able to Load XML File : The control was unable to load an XML file.

1001 - Not Schedule XML: The XML file was not a valid ctxSchedule XML file.

1002 - Not able to Retrieve XML : The control was unable to retrieve the XML from the file.

1003 - Not able to Initialize the XML Document : The control was unable to Initialize the XML Document.

1004 - Not able to Create File : The control was unable to create an XML or JPG file.

1005 - Unable to Create JPG File : The control was unable to create a JPG file.

32000 - No Memory : There is no longer any available memory to store new items.

32001 - Item Not Added : An attempt was made to add a new item, bar, or style to the control, but was unable to do so.

32002 - Too Many Items : An attempt was made to add a new item, or bar style past the 32000 item limit.

32003 - Too Many Bars : An attempt was made to add a new time bar past the 32000 item limit.

32004 - Bad Item Index : An attempt was made to access an item that is outside the range of the present items.

32005 - Bad Time Bar Index : An attempt was made to access a time bar that is outside the range of the present time bars.

32006 - Bad Style Index : An attempt was made to access a bar style that is outside the range of the present bar styles.

32007 - Bad Column Index : An attempt was made to access a column in the list that is outside the range of the available columns.

32008 - Bad Color Bar Index : An attempt was made to access a color bar that is outside the range of the available color bars.

32009 – Non Check Column : An attempt was made to determine the status of a check box in the list in a column that was not defined as having check boxes.

32010 – Bad Link Index : An attempt was made to access a time bar link that is outside the range of the present time bar links.

32011 – Bar In DeadZone : An attempt was made by the user to move/create/resize a timebar in to a ColorBar marked as a DeadZone.

32012 – Too Many Lines : An attempt was made to add a new GuideLine past the 32000 item limit.

32013 – Bad Line Index : An attempt was made to access a guide line that is outside the range of the present guide lines.

32014 – Bad Note Index : An attempt was made to access a schedule note that is outside the range of the present schedule notes.

32020 - Too Many Images : An attempt was made to add another image to the internal image list past its pre-defined limit.

32030 - No Default Printer : An attempt was made to communicate with the user's defaut printer, but it failed.


Creating a Printed Report

ctxSchedule (3.0) 32/64 bit Scheduling Control

Creating a Printed Report

The ctxSchedule control is able to produce a printed report of its current contents through the PrintSchedule and the PrintScheduleImage methods. Before the ctxSchedule printing information is sent to the printer the PrePrint event fires. The BeforePrint event fires after the printing information as been initially sent to the printer, but before the printing operation has begun. Both events provide the developer the opportunity to cancel the printed report through the AbortPrint method.

The following is a list of properties which can be used to customize the appearance of a printed report when calling the PrintSchedule method.

Property | Description
PageXOffset | Returns/sets the offset value used to calculate the width of a printed report.
PageYOffset | Returns/sets the offset value used to calculate the height of a printed report.
PrintAltSchedColors | Determines if the alternating color in the schedule area will be included in a printed report.
PrintColorBars | Determines if color bars will be included in a printed report.
PrintColumns | Returns/sets the number of columns in the list area to include in a printed report.
PrintFooter | Returns/sets the footer text in printed report.
PrintPageColumnFrom | Returns/sets the starting column of pages of a printed report.
PrintPageColumnMax | Returns the maximum amount of page columns a printed report will contain.
PrintPageColumnTo | Returns/sets the ending column of pages of a printed report.
PrintPageRowFrom | Returns/sets the starting row of pages of a printed report.
PrintPageRowMax | Returns the maximum amount of page rows a printed report will contain.
PrintPageRowTo | Returns/sets the ending row of pages of a printed report.
PrintPageText | Returns/sets the text used to describe the page in a printed report.
PrintSubTitle | Returns/sets the sub title of a printed report.
PrintTimeDistance | Returns/sets the distance between the major time units in a printed report.
PrintTitle | Returns/sets the title of a printed report.
PrintTitleAlign | Returns/sets the horizontal alignment of the title and sub-title in a printed report.
PrintTitleFont | Returns/sets the title font in a printed report.
PrintWeekendColor | Determines if the weekend colors will be included in a printed report.

Special Consideration for printed reports using the PrintSchedule method:

  • The control will attempt to produce the same colors as those on the screen. However, on a monochrome printer, this may cause some undesirable effects. A property such as PrintWeekendColor allows the weekend color on a printed report to be different from the weekend color on the screen. PrintAltSchedColors and PrintColorBars allow the programmer to prevent the extra colors from being placed on a printed report.

The following is a list of properties which can be used to customize the appearance of a printed report when calling the PrintScheduleImage method.

Property | Description
PageXOffset | Returns/sets the offset value used to calculate the width of a printed report.
PageYOffset | Returns/sets the offset value used to calculate the height of a printed report.
PrintColumns | Returns/sets the number of columns in the list area to include in a printed report.
PrintFooter | Returns/sets the footer text in printed report.
PrintPageColumnFrom | Returns/sets the starting column of pages of a printed report.
PrintPageColumnMax | Returns the maximum amount of page columns a printed report will contain.
PrintPageColumnTo | Returns/sets the ending column of pages of a printed report.
PrintPageRowFrom | Returns/sets the starting row of pages of a printed report.
PrintPageRowMax | Returns the maximum amount of page rows a printed report will contain.
PrintPageRowTo | Returns/sets the ending row of pages of a printed report.
PrintPageText | Returns/sets the text used to describe the page in a printed report.
PrintSubTitle | Returns/sets the sub title of a printed report.
PrintTimeDistance | Returns/sets the distance between the major time units in a printed report.
PrintTitle | Returns/sets the title of a printed report.
PrintTitleAlign | Returns/sets the horizontal alignment of the title and sub-title in a printed report.
PrintTitleFont | Returns/sets the title font in a printed report.

Special Consideration for printed reports using the PrintScheduleImage method:

  • The control will take snap shots of the current contents of the control, including all current color and fills being used. As such the PrintWeekendColor, PrintAltSchedColors and PrintColorBars properties are ignored when printing the control with this method.

Special Consideration for all printed reports:

  • The page orientation is defined by the printer properties, and while the PrintLandscape property can be used to try and preset the print dialog to that orientation, the user can still change it and the print operation will use their settings.

  • Both the PrintLandscape and PrintDefaultPrinter properties require the control to be able to find and communicate with a the current users default printer. If the control is unable to, then those properties will have no effect on the printing operations.


Creating an Image of ctxSchedule

ctxSchedule (3.0) 32/64 bit Scheduling Control

Creating an Image of ctxSchedule

The ctxSchedule control is capable of generating an image of itself into a file on a local or mapped drive. This can be very useful when posting a visual representation of the control on a web site or as an attachment to an email.

An image is created using the CreateImage method. This method accepts three parameters. The first is the name of the file to be created. The second and third parameters then determine the size of image.The fourth parameter is the type of image format to generate.

The image size can be set up in three different ways:

Fixed Size

If the second and third parameters are sent a value greater than 5, the height and width of the image will be that of the values sent to those parameters. The first line item in the image will be the current top visible time in the control.

Actual Size

If the second and third parameters are sent a value of 0, the height and width of the image will be set to the current size of the actual control. The first line item in the image will be the current top visible item in the control. The image will be what is on the screen at the time the image is created.

Full Size

The second and third parameters can be used to specify if the generated output is to contain all of the contents of the control or just the visible area of the control. If a value of -1 is sent to the second parameter, the control will generate an image containing the entire height (all items) in the control. If a value of 0 is sent to the second parameter the generated output will display only the visible items in the control. If a value of -1 is sent to the third parameter, the control will generate output containing the entire width of the control. If a value of 0 is sent to the third parameter the generated output will display only the visible width of the control.

NOTE: In either case, the first record in the image will be based on the first item in the control. The starting date and time will be the same as the DateStart and TimeStart properties.

NOTE: A full size image (0,0) may be too large to actually produce. To ensure that the image does not get too large, the developer can set height and width limits using the MaxImageHeight and MaxImageWidth properties respectively. These properties will only take effect if their value is greater than 0 and a value of -1 was sent to the respective CreateImage parameters.


Reading and Writing XML Data

ctxSchedule (3.0) 32/64 bit Scheduling Control

Reading and Writing XML Data

The ctxSchedule control is capable of reading and writing XML data. The data can be read and written as a string into or from memory, or to and from a file. The control is also capable of creating XML data for the entire control, or the objects only (list items, column information, time bars, styles and color bars).

Read and Write an XML File

The methods used to read and write the xml files are the ReadFile and WriteFile. A valid XML file can be read from a local drive, a mapped drive, or from a web site. However, you may only write a file to a local or mapped drive.

Both of these methods accept two parameters. The first is the name of the file. When reading or writing a file, the full path, file name, and extension must be included as part of the parameter. The second parameter is used to determine what type of data is read or written. If a value of 0 is sent to either method, then all relevant data is read from the file, or written to the file. If a value of 1 is sent, then only schedule items, their time bars, column information, style information, and color bar information will be read or written. The general property information will be ignored. The type of data not included in an XML file include the image information, properties concerning tool tips, and properties concerning printed reports.

Reading and XML string

The ctxSchedule control contains a ReadXMLString method, when read, this method will pass the data in an XML format into a memory variable. This property is similar to the WriteFile method, but instead of writing the data to a file, it is read into a memory variable.

READING AND WRITING XML FILES AT DESIGN TIME

One of the benefits of the XML functionality built into the ctxSchedule control is the ability to read and write XML files at design time. This can be very useful in instances where a control is being upgraded from one version to another (i.e. save the properties, upgrade, and then load in the new control), or to share control styles between developers.

The property window for the ctxSchedule includes an XMLRead property and an XMLWrite property. When a character string is entered into one of these fields, an Open (XMLRead) or Save File (XMLWrite) dialog will appear to allow the developer to specify the path to read or write an XML file. NOTE: The XMLWrite property will only write data for the entire control (i.e. not individual collection data such as time bars and links).

NOTE: The XML functionality requires MSXML4.dll be installed on the host system.


Using the Pre-Load Option to Save Memory

ctxSchedule (3.0) 32/64 bit Scheduling Control

Using the Pre-Load Option to Save Memory

There may be occasions where you are required to load a great deal of information into the control. When there is an excessive amount of information to load, the load time could be prohibitive, and performance could suffer. The ctxSchedule control provides an option that addresses this issue.

The Pre-Load option only load the list items as they need to be displayed. It is similar to a virtual mode except that once the data has been loaded, it will remain in the control. The Pre-Load option still requires that you add time bars for each item as they become visible. However, it simply requires this information so that it knows how to set up the vertical scroll bar. The data actually sent to the control can initially be blank. The following steps describe how to use the Pre-Load option:

  1. Set the UsePreLoad property to True.

  2. In the FirstDraw event, load the list items into the schedule. Any data can be used to initially load the list items. This step is required to properly set up the vertical scroll bar.

  3. By default, each list item's ItemLoaded property is set to False. As each list item is drawn (and the ItemLoaded is set to False), the PreLoad event will fire. It is within this event that the time bars are loaded into the control. After the time bars for the list item are loaded, the ItemLoaded property needs to be set to True. This will ensure that the PreLoad event will not fire each time the item is drawn

    Private Sub ctxSchedule1_PreLoad(ByVal nIndex As Integer)

    ' Search your database for the appropriate data

    ' based upon the nIndex value sent to this event

    Me.ctxSchedule1.ItemText(nIndex) = dbSource.Text

    For nCntr = 1 To dbSource.Time.Count

    ctxSchedule1.AddTimeBar nIndex, dbSource.Time.Start, ...

    Next

    Me.ctxSchedule1.ItemLoaded(nIndex) = True

    End Sub


Supporting Files

Using DBI controls

Supporting dll's

In order to use the OCX components the following support files are required:

  • MFC110U.DLL (version 11.0) - This is the Microsoft Foundation Class Library. It must be registered with your system registry. This is the Unicode version of the library.
  • MSVCR110.DLL - (version 11.0) This is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL, -required to display the stock property pages of the components in development mode.

NOTE: The XML functionality requires MSXML4.dll be installed on the host system.

These files must be distributed (and registered where necessary) with your applications (with the exception of MSSTKPRP.DLL). You may require additional OCX or OLE support files if your application requires them-check with the host language manual to determine what those files (if any) might be.


Additions by Version

Solutions Schedule for COM (SSCOM) and Solutions Schedule COM 64 (SSCOM64)

Additions by Version

SSCOM 15.0/SSCOM64 3.0

Properties
BarDateText | BarVisible | LockedLines
MajorTimeLineRuler | MajorTimeLineRulerColor | MajorTimeLineSchedule
MajorTimeLineScheduleColor | MajorTimeLineScheduleWidth | PrintDefaultPrinter
PrintLandscape | PrintPageColumnFrom | PrintPageColumnMax
PrintPageColumnTo | PrintPageRowFrom | PrintPageRowMax
PrintPageRowTo
Methods
FindBarCargo | FindBarCargoItem | FindBarCargoItemNext
FindBarCargoNext | FindBarData | FindBarDataItem
FindBarDataItemNext | FindBarDataNext | FindItemCargo
FindItemCargoNext | FindItemData | FindItemDataNext
PrintScheduleImage | ScrollToColumn
Events
BeforePrint | UserDrawnBarDateText
Enumerations
enumLockedLines

SSCOM 14.0/SSCOM64 2.0

Properties
BarBorderWidth | CBarVertOffset | HorzListLargeChange
HorzListMax | HorzListSmallChange | HorzScheduleLargeChange
HorzScheduleMax | HorzScheduleSmallChange | VertScrollLargeChange
VertScrollMax | VertScrollSmallChange
Methods
CreateImage
Events
UserDrawnDays

SSCOM 13.0/SSCOM64 1.0

Architecture
The ctSchedule control has been converted to the ctxSchedule control.
The ctxSchedule control has been compiled against version 11.0 of the MFC.
The ctxSchedule control has been compiled as both 32 and 64 bit OCX files.
The Solutions Schedule for COM product contains only the 32-bit version, while Solutions Schedule COM 64 contains both the 32 and 64-bit versions.

SSCOM 12.0

Architecture
The ctSchedule control is now compiled with support for Unicode character sets.
Properties
AlignmentLines | AlignmentLinesColor | AllowHorzMoves
AllowNewBars | AllowResizeBars | AllowVertMoves
BarDateForeColor | DayMonthOffset | HorzGridLineColor
ListBarBorder | RulerTitleBackColor | RulerTitleBackColorTo
RulerTitleFillType | RulerTitleForeColor
Methods
BarMoveToLine
Events
HistoryRedo | HistoryUndo

SSCOM 11.1

Properties
BarStylePriority

SSCOM 11.0

Properties
BreakChar | DefBarHeight | DefLineHeight
ItemNextBarIndex | ItemPrevBarIndex | LineArrowAfter
LineArrowBefore | LineArrowColor | LineArrowPosition
NoteCount | NoteDate | NoteImageAlign
NoteImageXOffset | NoteImageYOffset | NoteLocked
NotesDistance | NotesPosition | NoteText
NoteTime | TimeBarHeight | TimeBarVOffset
TipsOnNotes | TipsOnOverBar | TipsOnVScroll
Methods
AddNote | CancelLink | CancelUnLink
ClearNotes | DeleteNote | MakeBarVisible
NoteAt |  |
Events
BeforeBarLinked | BeforeBarUnLinked | LineArrowDblClick
LineArrowLeftClick | LineArrowRightClick | NoteDblClick
NoteLeftClick | NoteRightClick
Enumerations
enumItemPosition
Procedural
Line Arrows and More Time Bars Functionality |  | Schedule Notes

SSCOM 10.0

Properties
ItemHeaderBackColor | ItemHeaderBackColorTo | ItemHeaderClick
ItemHeaderFillType | ItemHeaderForeColor | SchedHeaderBackColor
TimeBarImage | TimeBarShadows | UserDrawnBar
Methods
ColorBarsAt | FindFirstColorBar | FindFirstTimeBar
FindNextColorBar | FindNextTimeBar | LineAt
ScheduleItemAt | TimeBarsAt
Events
UserDrawnBar
Enumerations
enumGuidePosition
Procedural
UserDrawn Timebars | Using the Hit Test Methods

SSCOM 9.0

Properties
BarBackColorTo | BarDefBackColorTo | BarDefBorderColor
BarDefFillType | GuideColor | GuideDate
GuideImage | GuideImageIndex | GuideImagePosition
GuideImageXOffset | GuideImageYOffset | GuideLineColor
GuideLineDistance | GuideLocked | GuideMoveColor
GuideTime | PropertyPages | SnapToGuideLines
StyleBackColorTo | StyleBrushType
Methods
AddGuideLine | ClearGuideLines | DeleteGuideLine
Events
GuideLineAdd | GuideLineClick | GuideLineMove
GuideLineMoved | GuideLineRemove
Enumerations
enumGuidePosition
Procedural
Working with GuideLines


Working with DataTypes

ActiveX Controls

Working with Properties and special DataTypes

Fonts

There are 2 ways to assign values to Font based properties of the ActiveX controls at runtime.

1. Assign the value from a Font property on another OleControl.

[Visual Basic and Access]

Me.ctxControl.Font = Ole_object.Font

[Visual FoxPro]

thisform.ctxControl.Font = Ole_Object.Font

2. Modify the individual properties on the Font object itself.

[Visual Basic and Access]

Me.ctxControl.Font.Name = "Verdana"

Me.ctxControl.Font.Bold = True

[Visual FoxPro]

thisform.ctxControl.Font.Name = "Verdana"

thisform.ctxControl.Font.Bold = .T.

Images

Assigning images to a control at runtime, requires the image be an olePicture object (not just a standard image).

Some IDE's such as Visual Basic, Visual Foxpro and Access have a LoadPicture method which can be used to load a picture file and will convert it to the correct format.

[Visual Basic and Access]

Me.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

[Visual Foxpro]

thisform.ctxControl.BackImage = LoadPicture("C:\Path to Image\Image.bmp")

Alternatively, if the image has already been assigned to a property on an oleControl, then the value of that property can be assigned directly.

[Visual Basic and Access]

Me.ctxControl.BackImage = Ole_Control.Picture

[Visual Foxpro]

thisform.ctxControl.BackImage = Ole_Control.Picture


Compile Error

Error Message

Compile Error: Can't Find Project or Library

PROBLEM

When attempting to run or compile a project, the following error message is generated:

Compile Error: Can't Find Project or Library

CAUSE

The project contains a reference to a file or an ActiveX control that has been changed or does not exist.

RESOLUTION

Open the References dialog and clear any references to any entries marked MISSING. If those references are required for the project, re-register the correct files.

MORE INFORMATION

This error message can appear under the following conditions:

  • The file referenced has been deleted or unregistered.
  • The GUID of the ActiveX control has been changed.
  • The file referenced was moved to a different location.


No Object in this Control

Error Message

"No Object in this control"

POSSIBLE CAUSE
  1. The most common reason for this is error is that the version of the component used to develop the application is different than the version of the component being shipped.
  2. The required component has not been registered on the user machine
  3. The component has been corrupt
RESOLUTION
  1. Ensure that the same version of the component is being used for both development and deployment.
  2. Confirm that the component has been registered on the user machine using RegSvr32.exe
  3. If the above 2 options fail, try to redistribute the component.


Error 339

Error Message

Run-time error 339: Component "ctxControl.ocx" or one of its dependencies not correctly registered: a file is missing or invalid.

This error occurs when the component itself or one of the component dependency files are not registered or installed. All of DBI components required the following dependency files:

  • MFC110U.DLL (version 11.0) - This is the Microsoft Foundation Class Library. It must be registered with your system registry. This is the Unicode version of the library.
  • MSVCR110.DLL - (version 11.0) This is the Microsoft C Runtime Library. It does not need to be registered, but must be present in your ..Windows\System directory.
  • MSSTKPRP.DLL - Required to display the stock property pages of the components in development mode. Required for deployment, only if you are surfacing the custom Property Pages in your application.


Distribution

Distribution Policy

DBI’s component products (COM and WinForm) are licensed per person/developer exposing the controls in a design surface.

The licensed person/developer is provided under the license agreement rights to distribute the “Run-Time” component(s) royalty-free. ”

For those situations where the intended end-user of the licensee’s software is provided the opportunity to further modify or expose DBI’s intellectual property in a design surface (ie. Source Code included, distribution of MDB’s, etc.), DBI does offer distribution licensing under its OEM product banner. For more information contact sales@dbi-tech.com

Your software-license agreement permits you to distribute the OCX files to an unlimited number of computers so long that:

  1. the OCX controls are not being made available as development controls within a development environment.

Consult the DBI Technologies " Software-License" agreement for additional information: http://www.dbi-tech.com/license_agreements.asp


Support Policy

Product Support

DBI Technologies Product Support

Please see the support website at http://www.dbi-tech.com/support_policies.asp for information on our support policies and plans, or visit our FAQ at http://www.dbi-tech.com/Support/FAQ/default.aspx


New Page 1

Frequently Asked Questions

Frequently Asked Questions

The DBI FAQ-Technical page is constantly being updated.

To view the frequently asked questions, please navigate to our FAQ page.


%%phrase%%

Project Overview
Send comments on this topic.

Description

ctxSchedule allows you to quickly add employee or resource scheduling to your applications. ctxSchedule gives you the ability to print schedules, assign time lines or bars to a resource, change the viewing granularity (zoom in and zoom out), and create a wide variety of time bar styles.

Classes

Class Module | Description
ctxSchedule | 32/64 bit Scheduling ActiveX control

Public Enumerations

Enumeration | Description
enumAlign | Specifies a horizontal alignment
enumArrowType | Specifies the display type for arrows
enumBorder | Specifies border types
enumDayStart | Specifies available days of the week
enumEditMode | Specifies available edit modes for the control.
enumFillType | Specifies the available background fill patterns
enumGuidePosition | Determines whether GuideLine images will appear in front of or behind the ruler text.
enumHorzScroll | Specifies the horizontal scroll behavior
enumImagePosn | Specifies available image alignment options
enumItemPosition | Determines the position an object will take, relative to other objects.
enumLineType | Available line styles
enumLockedLines | Available number of line items to lock at the top of the schedule display.
enumMonthlyType | Available displays for monthly views.
enumPosition | Available vertical alignments
enumPreColumn | Available pre-column displays
enumProperties | Available options for displaying the control's custom property pages.
enumRulerAlign | Available alignments for the ruler text
enumTimeType | Available time types for the control
enumTipsPosn | Available alignment options for displaying tips on the vertical scroll bar.
enumTitleStyle | Available display styles for the title area.
enumYearlyType | Available displays for yearly views


%%PageItemTitle%%

ctxSchedule Object
See Also Members Send comments on this topic.

Description

32/64 bit Scheduling ActiveX control

See Also

ctxSchedule Members


DropItem Event

See Also

ctxSchedule Object

nType

The area/type of drop which occurred. Values include:

0 - drop occurred in the list area
1 - drop occurred on a list item
2 - drop occurred in the schedule area

nIndex
The 1-based index value of the item receiving the drop; 0 if not dropped on an existing item
nObject
The 1-based index value of the object receiving the drop; 0 if not dropped on an existing item or time bar.
nTime
The time where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
nDate
The date where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
See Also ctxSchedule (8.0) Scheduling Control Send comments on this topic.

DragDrop Event

Description

Occurs when a drag-and-drop operation is completed as a result of dragging a control over an object and releasing the mouse button

Syntax

Private Sub object_DragDrop(Source, x, y)

Parameters

Source
References the control being dragged. You can refer to properties and methods of the control with this parameter.
x, y
Contains the horizontal (x) and vertical (y) position of the mouse pointer within the Form when data is dropped on a drop target. These coordinates are expressed in terms of the Form's coordinate system in the unit of measurement specified by the ScaleMode property of the Form.

Remarks

The DragDrop event involves two objects, a control being dragged and a target object. The DragDrop event is triggered for the target object, not the control being dragged. Use the DragMode property and Drag method to specify how dragging is to be initiated. Once dragging is initiated, you can handle events that precede a DragDrop event with a DragOver event. This event is only applicable when the host language supports drag and drop within an OLE container. Access does not support this functionality.

See Also

ctxSchedule Object | Implementing Drag and Drop

Â© 2006 DBI Technologies Inc. All Rights Reserved.


DropItem Event

See Also

ctxSchedule Object

nType

The area/type of drop which occurred. Values include:

0 - drop occurred in the list area
1 - drop occurred on a list item
2 - drop occurred in the schedule area

nIndex
The 1-based index value of the item receiving the drop; 0 if not dropped on an existing item
nObject
The 1-based index value of the object receiving the drop; 0 if not dropped on an existing item or time bar.
nTime
The time where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
nDate
The date where the drop occurred. This parameter will return a non-zero value if the item is dropped on an existing item in the schedule area.
See Also ctxSchedule (8.0) Scheduling Control Send comments on this topic.

DragDrop Event

Description

Occurs when a drag-and-drop operation is in progress. You can use this event to monitor the mouse pointer as it enters, leaves, or rests directly over a valid target. The mouse pointer position determines the target object that receives this event.

Syntax

Private Sub object_DragDrop(Source, x, y, State)

Parameters

Source
Contains a reference to the control being dragged. You can refer to properties and methods of the control with this parameter.
x, y
Contains the horizontal (x) and vertical (y) position of the mouse pointer within the Form when data is dragged over a drop target. These coordinates are expressed in terms of the Form's coordinate system in the unit of measurement specified by the ScaleMode property of the Form.
State
Contains a number that represents the transition state of the control being dragged in relation to the target object:
0 - Enter. The control is being dragged within the range of a target.
1 - Leave. The control is being dragged out of the range of a target.
2 - Over. The control has moved from one position in the target to another.

Remarks

The object under the drag icon is the target object and responds to the DragOver event. You can use this event to monitor when the mouse pointer enters, leaves, or is directly over a target object. This event is only applicable when the host language supports drag and drop within an OLE container. Access does not support this functionality.

See Also

ctxSchedule Object | Implementing Drag and Drop

Â© 2006 DBI Technologies Inc. All Rights Reserved.


%%PageItemTitle%%

Enumerations Object
See Also Members Send comments on this topic.

See Also

Enumerations Members


%%PageItemTitle%% $$Members$$

Enumerations Object Members
See Also Overview Send comments on this topic.

See Also

Enumerations Overview


Product Registration

Registration

Product Registration

To register or transfer your DBI product you may:

  • please complete our online form

  • print the completed online form and fax it to DBI Technologies at (204) 985-5771

  • mail the registration card that accompanied the product that was purchased through a 3rd party vendor

You do not need to register your product if you purchased directly from DBI.


ctxSchedule (3.0) 32/64 bit Scheduling Control

Title for Procedural Doc

A time bar is the main object representing a period of time in the ctxSchedule control. Its main purpose is to hold a starting and ending time/date. This period of time can represent an appointment, the availability of a resource, or any other time-related event. However, while a time bar can be used to store a period of time, it can contain other features as well.